Команды

Вызов команд может производиться следующими способами:

  • Нажатием кнопки мыши на имени команды в меню, на панели инструментов, на статусной панели или в контекстном меню.
  • Ввести имя или псевдоним команды в командную строку и нажать клавишу ENTER или ПРОБЕЛ.

В файле acad.pgp содержится список псевдоимен команд. Чтобы открыть файл acad.pgp, в меню "Сервис" выберите "Настройка" » "Изменение параметров программы" (acad.pgp).

В Справочнике команд рядом с началом описания каждой команды имеется раздел доступа к команде, в котором содержится информация о способах вызова команды.

Ваш комментарий об этой странице


3D Команды
  • 3D
  • 3DALIGN
  • 3DГРАНЬ
  • 3DДВФ
  • 3DЗЕРКАЛО
  • 3DМАССИВ
  • 3DОБЛЕТ
  • 3DОБХОД
  • 3DОРБИТА
  • 3DОРБЦЕНТР
  • 3DПАН
  • 3DПЕРЕНЕСТИ
  • 3DПЛИНИЯ
  • 3DПОВЕРНУТЬ
  • 3DПОКАЗАТЬ
  • 3DПОРБИТА
  • 3DРАССТ
  • 3DСЕКПЛ
  • 3DСЕТЬ
  • 3DСОРБИТА
  • 3DШАРНИР


3D Команда

3D Команды
3D Команды
3D Команда
Понятия Процедуры Команды

Создание трехмерных объектов в виде полигональных сетей распространенных геометрических форм, которые можно скрыть, раскрасить или тонировать

Ввод команды: 3D

Задать опцию

[Ящик/Конус/ЧАша/КУпол/Сеть/Пирамида/Сфера/Тор/Клин]:

Ящик

Построение трехмерной сети в форме параллелепипеда.

Угловая точка ящика:

Длина ящика: Задать расстояние

Ширина ящика или [Куб]: Задать расстояние или ввести к

Ширина

Задание ширины ящика. Здесь можно ввести расстояние или указать точку относительно угла ящика.

Высота ящика: Задать расстояние

Угол поворота ящика вокруг оси Z или [Опорный угол]: Задать угол или ввести б

Угол поворота

Задание угла поворота ящика относительно первой угловой точки. Если ввести 0, грани ящика ориентируются вдоль текущих направлений осей X и Y.

Базовая линия

Ящик ориентируется с заданным углом относительно других объектов чертежа. Угол отсчитывается относительно первой угловой точки ящика.

Задать опорный угол <0>: Указать точку, ввести значение угла или нажать клавишу ENTER

Опорный угол можно задать, указав две точки или ввести значение угла, отсчитываемое от оси X на плоскости XY. Таким образом, например, можно согласовать ориентацию ящика так, чтобы две его угловые точки и характерная точка какого-либо другого объекта лежали на одной прямой. После того, как опорный угол задан, необходимо указать точку, описывающую новый угол. При этом контурный образ создаваемого ящика поворачивается относительно первой угловой точки, иллюстрируя связь между опорным и новым углами.

Если ввести в качестве опорного угла значение 0, поворот ящика определяется только значением нового угла.

Новый угол: Указать точку или ввести значение

Для задания нового угла можно указать точку на чертеже. Угол отсчитывается относительно первой угловой точки ящика. Ящик поворачивается на угол, равный разности нового и опорного значений. Если требуется совместить ориентацию ящика с ориентацией другого объекта, следует задать новый угол указанием двух точек на этом объекте.

Если опорный угол равен 0, поворот ящика вокруг первой угловой точки определяется только значением нового угла.

Куб

Построение кубического ящика с использованием заданной длины ребра.

Угол поворота ящика вокруг оси Z или [Опорный угол]: Задать угол или ввести r

Угол поворота

Задание угла поворота кубического ящика относительно первой угловой точки. Если ввести 0, грани ящика ориентируются вдоль текущих направлений осей X и Y.

Базовая линия

Ящик ориентируется с заданным углом относительно других объектов чертежа. Угол отсчитывается относительно первой угловой точки ящика.

Задать опорный угол <0>: Указать точку, ввести значение угла или нажать клавишу ENTER

Опорный угол можно задать, указав две точки или ввести значение угла, отсчитываемое от оси X на плоскости XY. Таким образом, например, можно согласовать ориентацию ящика так, чтобы две его угловые точки и характерная точка какого-либо другого объекта лежали на одной прямой. После того как опорный угол задан, необходимо указать точку, описывающую новый угол. При этом контурный образ создаваемого ящика поворачивается относительно первой угловой точки, иллюстрируя связь между опорным и новым углами.

Если ввести в качестве опорного угла значение 0, поворот ящика определяется только значением нового угла.

Новый угол: Указать точку или ввести значение

Для задания нового угла можно указать точку на чертеже. Угол отсчитывается относительно первой угловой точки ящика. Ящик поворачивается на угол, равный разности нового и опорного значений угла. Если требуется совместить ориентацию ящика с ориентацией другого объекта, следует задать новый угол указанием двух точек на этом объекте.

Если опорный угол равен 0, поворот ящика вокруг первой угловой точки определяется только значением нового угла.

Конус

Построение трехмерной сети в форме конуса.

Центральная точка нижнего основания конуса: Указать точку (1)

Радиус нижнего основания конуса или [Диаметр]: Задать расстояние или ввести d

Радиус основания

Задание нижнего основания конуса по его радиусу.

Задать радиус верхнего основания конуса или [Диаметр] <0>: Задать расстояние, ввести d или нажать клавишу ENTER

Радиус верхнего основания

Задание радиуса верхнего основания конуса. При значении 0 строится полный конус. При значении, большем 0, строится усеченный конус.

Высота конуса: Задать расстояние

Ввести число сегментов поверхности конуса <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Диаметр верхнего основания

Задание диаметра верхнего основания конуса. При значении 0 строится полный конус. При значении, большем 0, строится усеченный конус.

Задать диаметр верхнего основания конуса <0>: Задать расстояние или нажать клавишу ENTER

Высота конуса: Задать расстояние

Ввести число сегментов поверхности конуса <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Диаметр основания

Задание нижнего основания конуса по его диаметру.

Диаметр нижнего основания конуса: Задать расстояние

Задать радиус верхнего основания конуса или [Диаметр] <0>: Задать расстояние, ввести d или нажать клавишу ENTER

Радиус верхнего основания

Задание радиуса верхнего основания конуса. При значении 0 строится полный конус. При значении, большем 0, строится усеченный конус.

Высота конуса: Задать расстояние

Ввести число сегментов поверхности конуса <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Диаметр верхнего основания

Задание диаметра верхнего основания конуса. При значении 0 строится полный конус. При значении, большем 0, строится усеченный конус.

Задать диаметр верхнего основания конуса <0>: Задать расстояние

Высота конуса: Задать расстояние

Ввести число сегментов поверхности конуса <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Чаша

Построение нижней половины сферической полигональной сети.

Центральная точка чаши: Указать точку (1)

Радиус чаши или [Диаметр]: Задать расстояние или ввести d

Радиус

Задание радиуса чаши.

Ввести число сегментов поверхности по долготе для чаши <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Ввести число сегментов поверхности по широте для чаши <8>: Ввести значение, большее 1, или нажать клавишу ENTER

Диаметр

Задание диаметра чаши.

Диаметр чаши: Задать расстояние

Ввести число сегментов поверхности по долготе для чаши <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Ввести число сегментов поверхности по широте для чаши <8>: Ввести значение, большее 1, или нажать клавишу ENTER

Купол

Построение верхней половины сферической полигональной сети.

Центральная точка купола: Указать точку (1)

Радиус купола или [Диаметр]: Задать расстояние или ввести d

Радиус

Задание радиуса купола.

Ввести число сегментов поверхности по долготе для купола: Ввести значение, большее 1, или нажать клавишу ENTER

Ввести число сегментов поверхности по широте для купола <8>:Ввести значение, большее 1, или нажать клавишу ENTER

Диаметр

Задание диаметра купола.

Задать диаметр купола: Задать расстояние

Ввести число сегментов поверхности по долготе для купола <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Ввести число сегментов поверхности по широте для купола <8>:Ввести значение, большее 1, или нажать клавишу ENTER

Сеть

Построение четырехугольной сети, в которой размеры M и N определяют число отрезков, которые должны быть нарисованы в каждом направлении сети. Направления M и N сети в пространстве играют такую же роль, что и оси X и Y на плоскости XY.

Первая угловая точка сети: Указать точку (1)

Вторая угловая точка сети: Указать точку (2)

Третья угловая точка сети: Указать точку (3)

Четвертая угловая точка сети: Указать точку (4)

Размер сети в направлении M: Ввести значение от 2 до 256

Размер сети в направлении N: Ввести значение от 2 до 256

Пирамида

Построение пирамиды или тетраэдра.

Первая угловая точка основания пирамиды: Указать точку (1)

Вторая угловая точка основания пирамиды: Указать точку (2)

Третья угловая точка основания пирамиды: Указать точку (3)

Четвертая угловая точка основания пирамиды или [Тетраэдр]: Указать точку (4) или ввести т

Четвертая угловая точка

Задание четвертой угловой точки основания пирамиды.

Задать точку вершины пирамиды или [Ребро/Верх]: Указать точку (5) или задать опцию

Координата Z заданной точки определяет высоту точки вершины пирамиды, верхней плоскости усеченной пирамиды или линии ребра.

Точка вершины

В заданной точке размещается вершина пирамиды.

Ребро

Запрашиваются две конечные точки линии ребра. Для того, чтобы не произошло их пересечения, точки следует вводить в том же направлении, что и точки основания.

Задать первую конечную точку ребра пирамиды: Указать точку (1)

Задать вторую конечную точку ребра пирамиды: Указать точку (2)

Сверху

Запрашиваются четыре точки, определяющие верхнюю плоскость усеченной пирамиды. Если линии, соединяющие точки верхней плоскости, пересекаются, создается самопересекающаяся полигональная сеть.

Задать первую угловую точку верха пирамиды: Указать точку

Задать вторую угловую точку верха пирамиды: Указать точку

Задать третью угловую точку верха пирамиды: Указать точку

Задать четвертую угловую точку верха пирамиды: Указать точку

Тетраэдр

Построение полигональной сети в форме тетраэдра.

Точка вершины тетраэдра или [Верх]: Указать точку или ввести т

Точка вершины

В заданной точке размещается вершина тетраэдра.

Сверху

Запрашиваются три точки, определяющие верхнюю плоскость усеченного тетраэдра. Если линии, соединяющие точки верхней плоскости, пересекаются, создается самопересекающаяся полигональная сеть.

Задать первую угловую точку верха тетраэдра: Указать точку (1)

Задать вторую угловую точку верха тетраэдра: Указать точку (2)

Задать третью угловую точку верха тетраэдра: Указать точку (3)

Сфера

Построение сферической полигональной сети.

Центральная точка сферы: Указать точку (1)

Радиус сферы или [Диаметр]: Задать расстояние или ввести d

Радиус

Задание радиуса сферы.

Ввести число сегментов поверхности по долготе для сферы <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Ввести число сегментов поверхности по широте для сферы <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Диаметр

Задание диаметра сферы.

Диаметр сферы: Задать расстояние

Ввести число сегментов поверхности по долготе для сферы <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Ввести число сегментов поверхности по широте для сферы <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Тор

Построение тороидальной полигональной сети, параллельной плоскости XY текущей ПСК.

Центр тора: Указать точку (1)

Радиус тора или [Диаметр]: Задать расстояние или ввести d

Радиус тора измеряется от его центра до внешнего края (а не до центра полости).

Радиус

Задание радиуса тора.

Радиус полости или [Диаметр]: Задать расстояние или ввести d

Радиус полости измеряется от ее центральной оси до внешнего края.

Радиус

Задание радиуса полости тора.

Ввести число сегментов по окружности полости <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Ввести число сегментов по окружности тора <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Диаметр

Задание диаметра полости тора.

Задать диаметр полости: Задать расстояние

Ввести число сегментов по окружности полости <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Ввести число сегментов по окружности тора <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Диаметр

Задание диаметра тора.

Диаметр тора: Задать расстояние

Радиус полости или [Диаметр]: Задать расстояние или ввести d

Радиус полости измеряется от ее центральной оси до внешнего края.

Радиус

Задание радиуса полости тора.

Ввести число сегментов по окружности полости <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Ввести число сегментов по окружности тора <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Диаметр

Задание диаметра полости тора.

Задать диаметр полости: Задать расстояние

Ввести число сегментов по окружности полости <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Ввести число сегментов по окружности тора <16>: Ввести значение, большее 1, или нажать клавишу ENTER

Клин

Построение полигональной сети в форме прямоугольного клина с наклонной гранью, спускающейся к оси X.

Угловая точка клина: Указать точку (1)

Длина клина: Задать расстояние

Ширина клина: Задать расстояние

Высота клина: Задать расстояние

Угол поворота клина вокруг оси Z:

Поворот происходит вокруг угловой точки клина. Если ввести 0, клин остается ортогональным текущей плоскости ПСК.


3DALIGN Команда

3D Команды
3D Команды
3DALIGN Команда
Понятия Процедуры Команды

Выравнивание объектов относительно других объектов в 2D и 3D

Панель "Моделирование"

Меню "Редактирование": "3D операции" » "3D Выравнивание"

Ввод команды: 3dalign

Выбрать объекты: выбрать объекты, подлежащие выравниванию, и нажать ENTER

Нужно указать исходную плоскость и ориентацию. . .

Для исходного объекта можно указать одну, две или три точки. Затем можно указать одну, две или три точки для места назначения. Выбранный объект перемещается и поворачивается так, что совпадают базовые точки и оси X и Y исходного объекта и места назначения выравниваются в 3D пространстве. Команда 3DALIGN работает с динамической ПСК (ДПСК), так что можно динамически перетаскивать выбранные объекты и выравнивать их с гранью твердотельного объекта.

Нужно указать базовую точку или выполнить операцию [Копировать]: указать точку или ввести c, чтобы создать копию

Базовая точка исходного объекта будет перемещена в базовую точку места назначения.

Следует указать вторую точку или выполнить операцию [Продолжить] <C>: указать точку на оси X объекта или нажать клавишу ENTER, чтобы перейти вперед к заданию точек мест назначения

Вторая точка задает новое направление оси X на плоскости, параллельной плоскости XY текущей ПСК. Если нажать клавишу ENTER вместо задания второй точки, то оси X и Y задаются параллельно осям X и Y текущей ПСК.

Следует указать третью точку или выполнить операцию [Продолжить] <C>: указать точку на положительной плоскости XY объекта или нажать клавишу ENTER, чтобы перейти вперед к заданию точек мест назначения

Третья точка полностью определяет ориентацию осей X и Y исходного объекта, который будет совмещен с плоскостью места назначения.

Нужно задать плоскость места назначения и ориентацию. . .

Следует указать первую точку места назначения: указать точку

Эта точка определяет место назначения базовой точки исходного объекта.

Следует указать вторую исходную точку или выполните операцию [Выход] <X>: указать точку для оси X места назначения или нажать клавишу ENTER

Вторая точка задает новое направление оси X для места назначения на плоскости, параллельной плоскости XY текущей ПСК. Если нажать клавишу ENTER вместо задания второй точки, то оси X и Y места назначения задаются параллельно осям X и Y текущей ПСК.

Следует указать третью исходную точку или выполните операцию [Выход] <X>:указать точку для положительной плоскости XY места назначения или нажать клавишу ENTER

Третья точка полностью определяет ориентацию осей X и Y плоскости места назначения.

Примечание Если место назначения представляет собой плоскость на существующем твердом объекте, пользователь может определить плоскость места назначения одной точкой на динамической ПСК.


3DГРАНЬ Команда

3D Команды
3D Команды
3DГРАНЬ Команда
Понятия Процедуры Команды

Создает трех- или четырехстороннюю поверхность в любом месте 3D пространства

Меню "Чертить": "Моделирование" » подменю "Сетки" » подменю "3D Грань"

Ввод команды: 3dгрань

Первая точка или [Скрытая]: Указать точку (1) или ввести i

Первая точка

Начальная точка 3D грани. Далее необходимо указать следующие точки, последовательно обходя грань по или против часовой стрелки. Если все четыре точки лежат в одной плоскости, создается плоская грань, подобная объекту области. Плоские грани участвуют в процессах раскрашивания и тонирования.

Скрытая

Управление видимостью каждой кромки 3D грани; это дает возможность адекватно моделировать объекты с отверстиями. Для того чтобы сделать кромку невидимой, перед указанием первой точки этой кромки необходимо ввести признак скрытая или просто с.

Режимы объектной привязки, координатные фильтры и сами координаты точки можно устанавливать только после ввода признака "Скрытая". Существует возможность создания 3D граней, у которых все кромки являются скрытыми. Такую грань можно назвать фантомной; она не видна в каркасных изображениях, но скрывает находящиеся за ней объекты в чертежах с подавленными скрытыми линиями. При раскрашивании и тонировке отображаются 3D грани.

Путем комбинирования 3D граней можно моделировать сложные 3D поверхности.

Вторая точка или [Невидимая]: Указать точку (2) или ввести i

Задать третью точку или [Невидимая] <выход>: Указать точку (3), ввести i или нажать клавишу ENTER

Задать четвертую точку или [Невидимая] <создать треугольную грань>: Указать точку (4), ввести i или нажать клавишу ENTER

Подсказки "Третья точка" и "Четвертая точка" будут отображаться до тех пор, пока не будет нажата клавиша ENTER. Присоединить следующие смежные грани можно путем задания точек (5), (6) и так далее. После завершения ввода точек следует нажать клавишу ENTER.


3DДВФ Команда

3D Команды
3D Команды
3DДВФ Команда
Понятия Процедуры Команды

Создает 3D DWF-файл пользовательской трехмерной модели и отображает ее в программе просмотра DWF

Панель "Стандартная"

Ввод команды: 3Dдвф

Выводится диалоговое окно "Экспорт 3D ДВФ" (диалоговое окно выбора стандартного файла). После ввода пользователем имени файла и выбора "Сохранить" запускается программа просмотра DWF компании Autodesk, и отображается пользовательский файл DWF.

Можно также изменить установки публикации из диалогового окна "Публикация 3D ДВФ".

Примечание Управление "Тип файла" в диалоговом окне "Экспорт 3D DWF" только указывает 3D DWF (*.dwf), когда используются команды 3DДВФ или ПУБЛ3DДВФ.

Темы:

  • Диалоговое окно "Публикация 3D ДВФ"


Диалоговое окно "Публикация 3D ДВФ"

3D Команды
3D Команды
Диалоговое окно "Публикация 3D ДВФ"
Понятия Процедуры Команды

Панель "Стандартная"

Контекстное меню: Ввести команду 3DДВФ и в диалоговом окне "Экспорт 3D ДВФ" выбрать "Сервис" » "Параметры".

Ввод команды: 3Dдвф

Позволяет пользователю публиковать трехмерную модель в формате файла Design Web Format™ (DWF™). В настоящее время публикация 3D ДВФ, функция технологического просмотра в AutoCAD® 2006, является стандартной функцией AutoCAD.

Объекты для публикации

Указывает, публикуются ли в файле DWF все объекты пространства модели или только выбранные объекты в пространстве модели.

Все объекты пространства модели

Все объекты в пространстве модели публикуются в файле 3D ДВФ.

Выбор объектов пространства модели

Позволяет пользователю создавать набор выбора объектов пространства модели, в том числе, внешние ссылки, которые публикуются в файле 3D ДВФ после нажатия кнопки ОК.

Выбор объектов

Активен только при включении опции "Выбор объектов пространства модели". Нажатие этой кнопки сворачивает до значков диалоговые окна и позволяет пользователю выбирать объекты на рабочем пространстве чертежа. После завершения выбора объекта и нажатия клавиши ENTER вновь появляется диалоговое окно "Публиковать 3D ДВФ", сообщающее количество выбранных для публикации объектов.

Организация 3D ДВФ

Указывает способ группирования объектов в файле DWF для просмотра в программе просмотра файлов Autodesk® DWF™.

Группировать по иерархии внешней ссылки

Упорядочивает объекты в отдельной программе просмотра по иерархии внешних ссылок. Если снять флажок этого параметра, файлы с внешними ссылками будут перечислены в программе просмотра наряду с другими объектами.

Настройки

Эти настройки позволяют указать, публикуются ли материалы в файле DWF.

Публиковать с материалами

Большинство материалов, назначенных пользователем для модели, будут публиковаться в файле 3D ДВФ. Если материал пользователя содержит наложение текстур, то публикуется только "Текстура рассеяния" вместе с собственным масштабом и данными ориентации. Входящие в состав модели материалы не сильно влияют на размер пользовательских файлов 3D ДВФ. По умолчанию = активно

Примечание В 3D ДВФ не поддерживаются такие материалы, как выпуклость, непрозрачность и наложение отражения, а также все формы обрабатываемых материалов, к которым относятся дерево и мрамор.


3DЗЕРКАЛО Команда

3D Команды
3D Команды
3DЗЕРКАЛО Команда
Понятия Процедуры Команды

Создание зеркальной копии объектов относительно заданной плоскости

Ввод команды: 3dзеркало

Рекомендуется использовать для манипулирования 3D объектами ручки, доступные по командам 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ. Подробнее об использовании ручек см. Использование инструментов ручек для редактирования объектов.

Выберите объекты: Выбрать объекты любым способом; по окончании выбора нажать ENTER

Первая точка плоскости отражения (3 точки) или [Объект/Последний/Zось/Вид/XY/YZ/ZX/3точки] <3точки>: Задать опцию, указать точку или нажать ENTER

Объект

В качестве плоскости отражения используется плоскость выбранного объекта.

Выбрать круг, дугу или сегмент 2D полилинии:

Удалить исходные объекты? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

При вводе д отраженный объект помещается в чертеж, а исходные объекты удаляются. При вводе н или нажатии ENTER отраженный объект помещается в чертеж, а исходные объекты сохраняются.

Последний

Зеркальное отображение выбранных объектов относительно последней заданной плоскости.

Удалить исходные объекты? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

При вводе д отраженный объект помещается в чертеж, а исходные объекты удаляются. При вводе н или нажатии ENTER отраженный объект помещается в чертеж, а исходные объекты сохраняются.

Zось

Плоскость отражения определяется на основании точки на плоскости и точки на перпендикуляре к ней.

Точка на плоскости отражения: Указать точку (1)

Точка на оси Z (нормали) плоскости отражения: Указать точку (2)

Удалить исходные объекты? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

При вводе д отраженный объект помещается в чертеж, а исходные объекты удаляются. При вводе н или нажатии ENTER отраженный объект помещается в чертеж, а исходные объекты сохраняются.

Вид

Плоскость отражения ориентируется согласно плоскости взгляда текущего видового экрана, проходящей через указанную точку.

Точка на плоскости вида <0,0,0>: Указать точку или нажать ENTER

Удалить исходные объекты? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

При вводе д отраженный объект помещается в чертеж, а исходные объекты удаляются. При вводе н или нажатии ENTER отраженный объект помещается в чертеж, а исходные объекты сохраняются.

XY/YZ/ZX

Плоскость отражения ориентируется вдоль одной из стандартных плоскостей (XY, YZили ZX), проходящей через указанную точку.

Точка на плоскости (XY, YZ, ZX) <0,0,0>: Указать точку (1) или нажать ENTER

Удалить исходные объекты? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

При вводе д отраженный объект помещается в чертеж, а исходные объекты удаляются. При вводе н или нажатии ENTER отраженный объект помещается в чертеж, а исходные объекты сохраняются.

3 точки

Задание плоскости отражения по трем точкам. При выборе этого параметра путем задания точки, запрос первой точки плоскости отражения не отображается.

Первая точка плоскости отражения: Указать точку (1)

Вторая точка плоскости отражения: Указать точку (2)

Третья точка плоскости отражения: Указать точку (3)

Удалить исходные объекты? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

При вводе д отраженный объект помещается в чертеж, а исходные объекты удаляются. При вводе н или нажатии ENTER отраженный объект помещается в чертеж, а исходные объекты сохраняются.


3DМАССИВ Команда

3D Команды
3D Команды
3DМАССИВ Команда
Понятия Процедуры Команды

Построение трехмерных массивов

Меню "Редактирование": "3D операции" » "3D массив"

Ввод команды: 3dмассив

Выберите объекты: Выбрать объекты любым способом

Весь набор объектов считается одним элементом массива.

Ввести тип массива [Прямоугольный/Круговой] <П>: Задать опцию или нажать клавишу ENTER

Прямоугольный массив

Копирование набора выбранных объектов необходимое число раз в направлениях рядов (ось X), столбцов (ось Y) и этажей (ось Z). Массив должен состоять как минимум из двух рядов, двух столбцов или двух этажей.

Ввести число рядов (—) <1>: Ввести положительное число или нажать клавишу ENTER

Ввести число столбцов ( | | | ) <1>: Ввести положительное значение или нажать клавишу ENTER

Число этажей ( . . . ) <1>: Ввести положительное значение или нажать клавишу ENTER

При задании одного ряда число столбцов должно быть не меньше двух, и наоборот. При числе этажей, равном 1, строится двумерный массив.

При задании более одного ряда отображается следующий запрос:

Задать расстояние между рядами (—): Задать расстояние

При задании более одного столбца отображается следующий запрос:

Расстояние между столбцами ( | | | ):Задать расстояние

При задании более одного уровня отображается следующий запрос:

Расстояние между этажами ( . . . ): Задать расстояние

При положительных значениях расстояний массив генерируется вдоль положительных направлений осей X, Y и Z. При отрицательных значениях расстояний массив генерируется вдоль отрицательных направлений осей X, Y и Z.

Круговой массив

Копирование выбранных объектов вокруг оси вращения.

Число элементов в массиве: Ввести положительное значение

Задать угол заполнения (+=прчс, -=почс) <360>: Задать угол или нажать клавишу ENTER

Заданный угол определяет число градусов между первым и последним элементами массива относительно оси поворота. Для поворота против часовой стрелки следует ввести положительное число. Для поворота по часовой стрелке следует ввести отрицательное число.

Поворачивать элементы массива? [Да/Нет] <Д>: Ввести д или н или нажать клавишу ENTER

Если ввести д или нажать клавишу ENTER, каждый элемент массива окажется повернутым.

Центральная точка массива: Указать точку (1)

Вторая точка оси поворота: Указать точку (2)


3DОБЛЕТ Команда

3D Команды
3D Команды
3DОБЛЕТ Команда
Понятия Процедуры Команды

Интерактивно изменяет пользовательский вид 3D чертежей так, что наблюдатель, как бы пролетает сквозь модель

Панель инструментов 3D навигации

Меню "Вид": "Облет и обход" » "Облет"

Контекстное меню: Запустить любую команду 3D навигации, нажать правую кнопку мыши в области чертежа и выбрать "Другие навигационные режимы" » "Облет" (7).

Ввод команды: 3dоблет

Пульт управления: Панель 3D навигации, Облет и обход

Команда 3DОБЛЕТ активизирует режим облета в текущем видовом экране. Пользователь может выйти из плоскости XY, как бы пролетая сквозь модель или облетая вокруг нее. Для задания направления облета можно использовать находящиеся на клавиатуре четыре клавиши со стрелками или клавиши W (вперед), A (влево), S (назад) и D (вправо), или мышь. Дополнительную информацию см. в разделе Диалоговое окно "Навигационные преобразования обхода и облета".

По умолчанию открывается окно Локатор положения, в котором отображается вид сверху на положение, заданное пользователем на чертеже.

Чтобы управлять установками параметров обхода и облета, следует использовать диалоговое окно Параметры обхода и облета. Установка параметров анимации 3D обхода или облета описывается в разделе Диалоговое окно "Параметры анимации".


3DОБХОД Команда

3D Команды
3D Команды
3DОБХОД Команда
Понятия Процедуры Команды

Интерактивно меняет вид 3D чертежа, при этом кажется, что наблюдатель обходит модель

Навигационная 3D панель:

Меню "Вид": "Обход и облет" » подменю "Обход"

Контекстное меню: Запустить любую команду 3D навигации, нажать правую кнопку мыши в области чертежа и выбрать "Другие навигационные режимы" &submenu "Обход" (6).

Ввод команды: 3dобход

Пульт управления: Панель 3D навигации, Облет и обход

Команда 3DОБХОД активизирует режим обхода в текущем видовом экране. Для задания направления обхода можно использовать находящиеся на клавиатуре четыре клавиши со стрелками или клавиши W (вперед), A (влево), S (назад) и D (вправо). Чтобы указать направление вида, пользователь должен перетащить мышь в требуемом направлении вида. Дополнительную информацию см. в разделе Диалоговое окно "Навигационные преобразования обхода и облета".

По умолчанию открывается окно Локатор положения, в котором отображается вид сверху на положение, заданное пользователем на чертеже.

Чтобы управлять установками параметров обхода и облета, следует использовать диалоговое окно Параметры обхода и облета. Установка параметров анимации 3D обхода или облета описана в разделе Диалоговое окно "Параметры анимации".

Вы можете использовать псевдоним команды 3DNAVIGATE, чтобы ввести команду 3DОБХОД.

Темы:

  • Диалоговое окно "Параметры анимации"
  • Окно "Локатор положения"
  • Диалоговое окно "Навигационные преобразования обхода и облета"


Диалоговое окно "Параметры анимации"

3D Команды
3D Команды
Диалоговое окно "Параметры анимации"
Понятия Процедуры Команды

Задает параметры записи анимации 3D навигации.

Режимы

Определяет установки в файле анимации.

Стиль отображения

Отображает список визуальных стилей и наборы параметров тонирования, которые можно применить к анимационному файлу.

Разрешение

Выводит список возможных разрешений. Значение по умолчанию 320 х 240.

Кадр/с

Задает частоту кадров (в секундах). Допустимы значения от 1 до 60. Значение по умолчанию 30.

Формат

Задает список форматов вывода анимации. Поддерживаемые форматы - AVI, MPG, WMV и MOV.


Окно "Локатор положения"

3D Команды
3D Команды
Окно "Локатор положения"
Понятия Процедуры Команды

Отображает вид сверху на положение 3D модели при навигации обхода или облета.

Увеличить

Увеличивает изображение в окне "Локатор положения".

Уменьшить

Уменьшает изображение в окне "Локатор положения".

Показать в границах

Зумирует изображение в рамках окна "Локатор положения"

Образец

Отображает текущее положение пользователя в модели. Пользователь может перетащить указатель положения, чтобы изменить свое местоположение. Пользователь может перетащить указатель цели, чтобы изменить направление вида.

Цвет указателя положения

Задает цвет точки, которая указывает текущее положение пользователя.

Размер указателя положения

Задает размер указателя. Пользователь может выбрать "Малый", "Средний" или "Большой" размер указателя.

Мерцание указателя положения

Включает или выключает эффект мерцания.

Указатель цели

Выводит на экран указатель, который показывает цель вида.

Цвет указателя цели

Задает цвет указателя цели.

Прозрачность образца для просмотра

Задает прозрачность в окне просмотра. Можно выбрать значение от 0 до 95.

Визуальный стиль образца для просмотра

Задает визуальный стиль образца для просмотра.


Диалоговое окно "Навигационные преобразования обхода и облета"

3D Команды
3D Команды
Диалоговое окно "Навигационные преобразования обхода и облета"
Понятия Процедуры Команды

Диалоговое окно "Навигационные преобразования обхода и облета" отображает клавиатуру и мышь, которые управляют режимами обхода и облета.

Чтобы включить или выключить отображение этого диалогового окна, следует нажать клавишу TAB. В диалоговом окне "Обход и облет" пользователь может указать, будут ли отображаться команды, и как часто.

Используются следующие средства управления:

  • Стрелка вверх/клавиша W. Перемещает камеру вперед, при этом кажется, что пользователь проходит (или пролетает) вперед.
  • Стрелка вниз/клавиша S. Перемещает камеру назад.
  • Стрелка влево/клавиша A. Перемещает камеру влево, при этом кажется, что пользователь перемещается влево.
  • Стрелка вправо/клавиша D. Перемещает камеру вправо.
  • Перетаскивание мышью. Задает цель для просмотра или поворота взгляда пользователя.
  • Клавиша F. Переключает режим облета (3DОБЛЕТ) на режим обхода (3DОБХОД) и наоборот.


3DОРБИТА Команда

3D Команды
3D Команды
3DОРБИТА Команда
Понятия Процедуры Команды

Интерактивный просмотр объектов в 3D пространстве

Панель инструментов 3D навигации

Меню "Вид": "Орбита" » "Зависимая орбита"

Устройство указания: Нажать клавишу SHIFT и прокрутить колесико мыши, чтобы временно включить режим "3D орбита".

Контекстное меню: Запустить любую команду 3D навигации, нажать правую кнопку мыши в области чертежа и выбрать "Другие навигационные режимы" » "Ограниченная орбита" (1).

Ввод команды: 3dорбита

Пульт управления: Панель 3D навигации, Облет ограниченной орбиты

Команда 3DОРБИТА активизирует на текущем видовом экране вид "3D орбита". Команда позволяет манипулировать всеми объектами чертежа или только выбранными.

Точка цели в команде 3DОРБИТА остается неподвижной, а положение камеры (т.е. наблюдателя) перемещается относительно нее. Однако с точки зрения пользователя она появляется, как если бы 3D модель поворачивалась по мере перетаскивания курсора мыши. Таким образом пользователь может задать любой вид модели.

Появляется значок курсора 3D орбиты. При перемещении курсора горизонтально камера перемещается параллельно плоскости XY в Мировой системе координат (МСК). При перемещении курсора вертикально камера перемещается вдоль оси Z.

Примечание Пока команда 3DОРБИТА активна, редактирование объектов невозможно.

В ходе выполнения команды 3DОРБИТА доступ к ее опциям возможен через контекстное меню (оно вызывается нажатием правой кнопки мыши в области рисования) или нажатием кнопок на навигационной панели инструментов 3D. См. Контекстное меню режима 3D орбиты.

Темы:

  • Контекстное меню режима 3D орбиты


Командная строка ГРАФНАСТР

Г Команды
Г Команды
Командная строка ГРАФНАСТР
Понятия Процедуры Команды

Если в ответ на подсказку в командной строке ввести -графнастр, в командной строке появится подсказка ГРАФНАСТР.

Ввести опцию: [Адаптивная деградация/Динамическая аппроксимация/Общие параметры/ускорение/Выход] <Адаптивная деградация>:

Подсказка отображается повторно до ввода пользователемx (Выход) или до нажатия клавиши ESC.

Виды при манипуляциях

Выключает или сводит к минимуму эффекты отображения, когда производительность становится ниже минимальной, заданной пользователем.

Ввести режим [ВКЛ/ОТКЛ] <ВКЛ>:

Если "Адаптивная деградация" включена, выводится указанная ниже подсказка.

Введите поддерживаемую частоту (1-60 кадр/с) <5>:

В командной строке отображается стандартное приглашение команды.

Динамическая аппроксимация

Задание параметров, определяющих гладкость объектов на чертеже. Объекты нарисованы с помощью множества коротких отрезков (или треугольников при рисовании сфер). Такие отрезки называются аппроксимирующими. Чем больше используется аппроксимирующих отрезков, тем точнее изображение графики на чертеже.

Ввести режим [ВКЛ/ОТКЛ] <ВКЛ>:

Если динамическая аппроксимация включена, выводится указанная ниже подсказка.

Ввести опцию [Аппроксимация поверхности/Аппроксимация кривой/Поместить аппроксимации в кэш/Выход] <Аппроксимация поверхности>:

Вновь выводится приглашение.

При визуализации поверхностей

Ввести допуск <92>: Ввести значение от 0 до 100

Степень детализации при отображении поверхностей на чертеже. Большая по величине установка обеспечивает меньшую детализацию, но использует больше линий аппроксимации и больше памяти.

Еще раз выводится подсказка динамической аппроксимации.

Визуализация кривых

Ввести допуск <87>: Ввести значение от 0 до 100

Степень детализации при отображении кривых на чертеже. Большая по величине установка обеспечивает меньшую детализацию, но использует больше линий аппроксимации и больше памяти.

Еще раз выводится подсказка динамической аппроксимации.

Число уровней аппроксимации

Ввести число аппроксимации в кэш <4>: Введите значение от 1 до 10

Позволяет настроить систему в соответствии с требованиями к объему памяти и производительности. В трехмерной кэш-памяти всегда хранится по крайней мере один уровень аппроксимации. Если значение этого параметра равно 1, аппроксимация на всех видовых экранах выполняется одинаково; это может привести к тому, что в процессе экранного увеличения или уменьшения некоторые объекты чертежа будут регенерироваться. При наличии нескольких видовых экранов с различными видами для этого параметра следует устанавливать значение 2 или более. Чем больше уровней задано, тем больше требуется памяти.

Еще раз выводится подсказка динамической аппроксимации.

Общие параметры

Задает опции, связанные с производительностью, которые не имеют аппаратной зависимости.

Конфигурировать: общие параметры

Ввести опцию [Не учитывать задние грани/ Качество прозрачности/Выход] <Не учитывать задние грани>:

Без задних граней

Ввести режим [ВКЛ/ОТКЛ] <ВКЛ>: Ввести вкл, чтобы не учитывать задние грани

Устанавливает режим рисования объектов, при котором их задние грани отбрасываются. Для некоторых объектов, например сфер, отключение отображения задних граней не заметно, так как их задняя сторона не видна, даже если она учитывается. Отмена учета задних граней особенно заметна для объектов, которые не имеют верхней грани. Установка этого режима отображения объектов приводит к повышению производительности.

Вновь выводится подсказка "Общие параметры".

Качество прозрачности

Корректирует качество прозрачности При установке "Низкая" эффект прозрачности достигается путем экранирования, и особого влияния на скорость это не оказывает. При установке "Средняя" (установка по умолчанию в программном режиме) смешивание улучшает качество изображения. При установке "Высокая" (установка по умолчанию в аппаратном режиме) формируется изображение, свободное от визуальных артефактов, создаваемое за счет снижения скорости построения. Для того, чтобы были видны текстуры, необходимо установить параметр "С материалами".

Вновь выводится подсказка "Общие параметры".

Ускорение

Задает использование программного или аппаратного ускорения в 3D графике.

Ввести опцию [Аппаратное/Программное/Выход] <Аппаратное>:

Выбрать режим [Вкл/Откл] <Вкл>: Включить или отключить сглаживание

При выборе аппаратного ускорения графики можно установить или отключить сглаживание и ускорение элементов геометрии.

Аппаратное ускорение

Введите опцию [Драйвер/Ускорение для геометрии/Включить сглаживание/Тени включены/Выход] <Драйвер>:

Задание аппаратного ускорения. Для повышения производительности графическая карта выполняет большинство задач рисования в режиме 3D аппаратно.

Введите имя драйвера <wopengl9.hdi>:

Имеются следующие драйверы wopengl9.hdi и direct3d9.hdi.

При выборе опции "Аппаратная" по умолчанию устанавливается драйвер wopengl9.hdi, который входит в состав программы.

При выборе опции "Драйвер" можно выбрать драйвер в списке драйверов, осуществляющих аппаратное ускорение, в папке Drv. Допускается использование драйвера другой фирмы, если он поддерживается графической системой Heidi® Graphics System.

Программное ускорение

Задание программного ускорения. Программная графическая система выполняет все задачи рисования в режиме 3D.

Ускорение для геометрии

Ввести режим [ВКЛ/ОТКЛ] <ВКЛ>:

Включение и отключение ускорения для объектов. Ускорение для объектов должно поддерживаться видеоадаптером. Подробную информацию о возможностях графической карты см. в документации производителя.

Задание ускорения для геометрии приводит к более эффективному использованию видеоадаптера. Объекты при этом рисуются с обычной точностью. Поэтому параметр используется только при рисовании объектов в пределах обычной точности.

Включить сглаживание

Ввести режим [ВКЛ/ОТКЛ] <ВКЛ>:

Включение сглаживания элементов чертежа. Линии отображаются более плавными, неровности сглаживаются.

Тени включены

Ввести режим [ВКЛ/ОТКЛ] <ВКЛ>:

Включает отображение теней.

Примечание При отключенном параметре "Ускорение для геометрии" полное отображение теней невозможно.

Выход

Завершение команды.


3DОРБЦЕНТР Команда

3D Команды
3D Команды
3DОРБЦЕНТР Команда
Понятия Процедуры Команды

Задает центр вращения на 3D орбитальных видах

Ввод команды: 3dорбцентр

Устанавливает 3D орбитальный вид и использует центр вращения, заданный с помощью указывающего устройства. Если указать точку вне текущего вида, то команда 3DОРБЦЕНТР игнорирует указанную точку и использует заданный по умолчанию центр вращения.

Команда 3DОРБЦЕНТР перезаписывает опцию "Орбита с автоприцелом" команды 3DОРБИТА.


3DПАН Команда

3D Команды
3D Команды
3DПАН Команда
Понятия Процедуры Команды

Если чертеж имеет вид "Перспектива", команда включает интерактивный 3D вид и позволяет пользователю перемещать вид горизонтально или вертикально

Навигационная 3D панель:

Меню "Вид": Панорамирование

Контекстное меню: Запустить любую команду 3D навигации, нажать правую кнопку мыши в области чертежа и выбрать "Другие навигационные режимы" » "Панорамирование" (9).

Ввод команды: 3dпан

Пульт управления: Панель 3D навигации, Панорамирование

Перемещается в направлении, указанном пользователем. Курсор можно перемещать по горизонтали, по вертикали и по диагонали. При выполнении команды 3DПАН курсор принимает вид кисти руки.

Перед вводом команды 3DПАН можно отобразить весь чертеж или выбрать объекты.


3DПЕРЕНЕСТИ Команда

3D Команды
3D Команды
3DПЕРЕНЕСТИ Команда
Понятия Процедуры Команды

Отображает инструмент ручки перемещения в 3D виде и перемещает объекты на указанное расстояние в заданном направлении

Панель "Моделирование"

Меню "Редактировать": "3D операции" » подменю "3D перемещение"

Ввод команды: 3dперенести

Пульт управления: Панель "3D Make", "3D перемещение"

Выбрать объекты: Выбрать объекты любым способом и нажать ENTER по завершении работы

Задать базовую точку или [Смещение ]<Смещение>: Указать базовую точку или ввести с

Задать вторую точку или <считать смещением первую точку>: Указать точку или нажать клавишу ENTER

Если пользователь работает в видовом экране с набором 2D Каркас в качества визуального стиля, 3DПЕРЕНЕСТИ временно переключает визуальный стиль в 3D Каркас на время выполнения команды.

Инструмент ручки перемещения отображается в заданной базовой точке. Более подробную информацию об использовании инструмента ручки перемещения см. в Использование инструмента ручки перемещения для редактирования объектов.

Нажмите ручку оси, чтобы ограничить движение перемещением по осям.

Две указанные точки задают направляющий вектор, который определяет, на какое расстояние и в каком направлении должны быть перемещены выбранные объекты.

Если при отображении подсказки "Указать вторую точку" нажать клавишу ENTER, первая точка интерпретируется как смещение относительно осей X, Y, Z. Например, если указать базовую точку 2,3 и при отображении следующей подсказки нажать клавишу ENTER, объект переместится на 2 единицы по оси X и на 3 единицы по оси Y относительно своей текущей позиции.

Повторное выравнивание ПСК

Пользователь может нажать клавиши CTRL+D, чтобы включить динамическую ПСК для повторного выравнивания ручки при перемещении указателя по граням, сегментам линии и сегментам полилинии. Ручка ориентирует рабочую плоскость в зависимости от того, какую кромку грани пересекает указатель. Пользователь может нажать кнопку мыши для размещения инструмента ручки (который будет ограничивать направление операции "Перемещение"). Координаты задаются относительно данной рабочей плоскости.

Еще одно нажатие клавиш CTRL+D для выключения динамической ПСК до размещения инструмента ручки изменяет ориентацию ручки на обратную для обеспечения соответствия статической ПСК.

Смещение

Указать смещение <последнее значение>: Ввести координаты для отображения вектора

Размещает ручку перемещения в начале координат (0,0,0). При вводе значений координат указывается относительное расстояние и направление.


3DПЛИНИЯ Команда

3D Команды
3D Команды
3DПЛИНИЯ Команда
Понятия Процедуры Команды

Построение полилиний из линейных сегментов в 3D пространстве

Меню "Чертить": "3D полилиния"

Ввод команды: 3dплиния

Начальная точка полилинии: Указать точку (1)

Конечная точка отрезка или [Отменить]: Указать точку или задать опцию

Конечная точка отрезка или [Отменить]: Указать точку или задать опцию

Конечная точка сегмента или [Замкнуть/Отменить]: Указать точку или задать опцию

Конечная точка сегмента

Построение прямолинейного сегмента от предыдущей точки к заданной новой точке. Запрос повторяется до тех пор, пока пользователь не нажмет клавишу ENTER для завершения команды.

Отменить

Удаление последнего сегмента полилинии. Позволяет продолжить построения от предыдущей точки.

Замкнуть

Построение замыкающего сегмента между последней и первой точками полилинии, после чего команда завершается. Эта опция требует наличия в 3D полилинии не менее двух сегментов.


3DПОВЕРНУТЬ Команда

3D Команды
3D Команды
3DПОВЕРНУТЬ Команда
Понятия Процедуры Команды

На 3D виде отображает ручку поворота и вращает объекты вокруг базовой точки

Панель "Моделирование"

Меню "Изменить": "3D операции" » подменю "3D повернуть"

Ввод команды: 3dповернуть

Пульт управления: Панель 3D Make, 3D повернуть

Выбрать объекты: Выбрать объекты любым способом и нажать ENTER по завершении работы

Указать базовую точку: Указать базовую точку

Если пользователь работает в видовом экране с набором 2D Каркас в качества визуального стиля, 3DПОВЕРНУТЬ временно переключает визуальный стиль в 3D Каркас на время выполнения команды.

Ручка поворота отображается в заданной базовой точке. Более подробную информацию об использовании ручки поворота см. в Использование захватного блока вращения для редактирования объекта.

Выбрать ось поворота: Нажать ручку оси, чтобы выбрать ось поворота

Ввести величину поворота или задать начальную и конечную точку угла.

Указать начальную точку угла: Указать точку

Указать конечную точку угла: Указать точку

Повторное выравнивание ПСК

Пользователь может нажать клавиши CTRL+D, чтобы включить динамическую ПСК для повторного выравнивания ручки перемещения при перемещении указателя по граням, сегментам линии и сегментам полилинии. Ручка ориентирует рабочую плоскость в зависимости от того, какую кромку грани пересекает указатель. Пользователь может нажать на кнопку мыши для размещения ручки (которая будет ограничивать направление операции "Перемещение"). Задает координаты относительно данной рабочей плоскости.

Еще одно нажатие клавиш CTRL+D для выключения динамической ПСК до размещения инструмента ручки изменяет ориентацию ручки на обратную для обеспечения соответствия статической ПСК.


3DПОКАЗАТЬ Команда

3D Команды
3D Команды
3DПОКАЗАТЬ Команда
Понятия Процедуры Команды

Увеличивает или уменьшает изображение, если чертеж имеет вид "Перспектива".

Навигационная 3D панель:

Меню "Вид": "Зумирование"

Устройство указания: Чтобы увеличить или уменьшить изображение, следует прокрутить колесико мыши.

Контекстное меню: Запустить любую команду 3D навигации, нажать правую кнопку мыши в области чертежа и выбрать "Другие навигационные режимы" &submenu "Зумирование" (8).

Ввод команды: 3dпоказать

Пульт управления: Панель 3D навигации, Зумирование

Если чертеж имеет вид "Параллельный", команда 3DПОКАЗАТЬ выведет следующую подсказку:

Нажать ESC или ENTER для выхода или правую кнопку мыши для отображения контекстного меню.

Зумирование в виде "Перспектива" имитирует приближение камеры к цели или удаление от нее. Объекты приближаются или удаляются, однако положение камеры не изменяется.

Ввести опцию [Все/Границы/Рамка/Предыдущий] <реальное время>:

Все

Зумирует изображение, чтобы отобразить весь чертеж.

Границы

Зумирует изображение в границах чертежа, в результате формирует максимально увеличенное изображение всех объектов.

Рамка

Зумирует изображение так, чтобы отобразить область чертежа, заданную двумя точками прямоугольной рамки.

Предыдущий

Показывает изображения в его предыдущем увеличении.

Реальное время

Интерактивно выполняет зумирование с помощью устройства указания.


3DПОРБИТА Команда

3D Команды
3D Команды
3DПОРБИТА Команда
Понятия Процедуры Команды

Запускает интерактивный 3D вид и задает непрерывное движение объектов

Навигационная 3D панель:

Меню "Вид": "Орбита" » "Непрерывная орбита"

Контекстное меню: Чтобы выполнить любую навигационную 3D команду, следует нажать правую кнопку мыши в области рисования и выбрать "Другие навигационные режимы" » подменю "Непрерывная орбита" (3).

Ввод команды: 3dпорбита

Пульт управления: Панель 3D навигации, Облет зависимой орбиты

Для того, чтобы начать перемещение объектов, следует нажать кнопку мыши в области рисования и, не отпуская ее, переместить мышь в нужную сторону. После отпускания кнопки объекты начинают вращаться в заданном направлении. Скорость вращения объектов определяется скоростью перемещения курсора.

Для смены направления вращения вида по орбите следует повторить запускающую операцию, перемещая мышь уже в другую сторону. Пользователь имеет возможность управлять визуализацией вида в процессе его вращения, используя для этого контекстное меню. Можно, например, выбрать "Средства визуализации" » подменю "Сетка", чтобы добавить сетку к виду, не выходя из подменю "Непрерывная орбита".


3DРАССТ Команда

3D Команды
3D Команды
3DРАССТ Команда
Понятия Процедуры Команды

Установка режима интерактивного 3D просмотра, приближение к объектам и удаление от них

Навигационная 3D панель:

Меню "Вид": "Камера", » "Регулировка расстояния"

Контекстное меню: Запустить любую команду 3D навигации, нажать правую кнопку мыши в области чертежа и выбрать "Другие навигационные режимы" » "Регулировка расстояния" (4).

Ввод команды: 3dрасст

Курсор в команде 3DРАССТ приобретает форму горизонтальной линии с двумя стрелками, одна из которых указывает вверх, а другая вниз. Нажать кнопку и перемещать курсор вертикально в верхнюю часть экрана, чтобы приблизить камеру к объектам и тем самым увеличить их видимые размеры. Нажать кнопку и перемещать курсор вертикально в нижнюю часть экрана, чтобы удалить камеру от объектов и тем самым уменьшить их видимые размеры.


3DСЕКПЛ Команда

3D Команды
3D Команды
3DСЕКПЛ Команда
Понятия Процедуры Команды

Запускает режим интерактивного 3D просмотра и открывает окно "Регулировка секущих плоскостей"

Ввод команды: 3dсекпл

Отображается окно "Регулировка секущих плоскостей".

Темы:

  • Окно "Регулировка секущих плоскостей"


Окно "Регулировка секущих плоскостей"

3D Команды
3D Команды
Окно "Регулировка секущих плоскостей"
Понятия Процедуры Команды

Ввод команды: 3dсекпл

Задает секущие плоскости для отображения на 3D орбитальных видах. Управлять плоскостями можно с помощью панели инструментов или выбрав соответствующую опцию из контекстного меню.

Для полноты эффекта секущих плоскостей можно нажать кнопку "Закрыть" в верхнем правом углу окна. Сами плоскости остаются неподвижными, и отсеченными оказываются все новые и новые объекты.

Для отключения секущих плоскостей следует нажать правую кнопку мыши в области рисования или окна "Регулировка секущих плоскостей" и установить или снять флажок "Передняя секущая вкл" или "Задняя секущая вкл".

Контекстное меню регулировки секущих плоскостей

Для доступа к перечисленным ниже опциям следует нажать правую кнопку мыши в пределах окна "Регулировка секущих плоскостей".

Регулировка передней секущей

Режим изменения положения передней секущей плоскости. Ей соответствует линия в нижней части окна. Если опция "Передняя секущая вкл" активна, результат перемещения плоскости становится сразу же заметен на 3D орбитальном виде.

Регулировка задней секущей

Режим изменения положения задней секущей плоскости. Ей соответствует линия в верхней части окна. Если опция "Задняя секущая вкл" активна, результат перемещения плоскости становится сразу же заметен на 3D орбитальном виде.

Создать срез

Выполняет совместное изменение положения задней и передней секущих плоскостей. На 3D орбитальном виде отображается так называемый “срез” — область пространства между двумя плоскостями. Для того, чтобы установить толщину среза, нужно предварительно отрегулировать плоскости по отдельности. После этого их можно регулировать совместно.

Панорамирование

Перемещение секущей плоскости по экрану с помощью курсора (в виде кисти руки). Курсор для этого следует перемещать в нужном направлении, удерживая нажатой кнопку мыши. Курсор остается активным до тех пор, пока не будет нажата другая кнопка мыши.

Зумирование

Увеличение или уменьшение изображения секущей плоскости на экране с помощью курсора (в виде увеличительного стекла). Для увеличения изображения следует нажать кнопку выбора и перемещать курсор в направлении верхней части окна "Регулировка секущих плоскостей". Для уменьшения изображения следует нажать кнопку и перемещать курсор в направлении нижней части окна.

Передняя секущая вкл

Включение и отключение передней секущей плоскости. Пометка около опции говорит о том, что передняя секущая плоскость включена, и можно наблюдать результаты перемещения регулировочной линии для нее. Чтобы отключить переднюю секущую плоскость, нужно убрать пометку, повторно выбрав данную опцию.

Задняя секущая вкл

Включение и отключение задней секущей плоскости. Пометка около имени опции в меню говорит о том, что задняя секущая плоскость включена, и можно наблюдать результаты перемещения регулировочной линии для нее. Чтобы отключить заднюю секущую плоскость, нужно убрать пометку, повторно выбрав данную опцию.

Сброс

Сброс установленных размеров и положения окна и секущей плоскости и возвращение к исходным размерам (на весь чертеж).


3DСЕТЬ Команда

3D Команды
3D Команды
3DСЕТЬ Команда
Понятия Процедуры Команды

Построение полигональных сетей произвольной формы

Меню "Чертить": "Моделирование" » подменю "Сети" » подменю "3D сеть"

Ввод команды: 3dсеть

Размер сети в направлении M: Ввести значение от 2 до 256

Размер сети в направлении N: Ввести значение от 2 до 256

Примечание Команду 3DСЕТЬ в первую очередь рекомендуется использовать при разработке приложений. Пользователи должны использовать команду 3D.

Полигональная сеть определяется матрицей, размер которой определяется числом M и N. Число вершин, необходимых для описания сети, равно произведению M и N.

Положение вершины (0, 0): Ввести 2D или 3D координаты

Положение каждой вершины сети определяется парой m и n, т.е. номером ряда и номером столбца. Задание вершин начинается с вершины (0,0). Первой меняется величина n:

Вершины могут находиться на произвольном расстоянии друг от друга. Вершины М и N могут находиться на произвольном расстоянии друг от друга.

Полигональные сети 3DСЕТЬ всегда открыты в направлениях M и N. Замкнуть сеть можно с помощью команды PEDIT.


3DСОРБИТА Команда

3D Команды
3D Команды
3DСОРБИТА Команда
Понятия Процедуры Команды

Управляет интерактивным просмотром объектов в 3D режиме, используя неограниченную орбиту

Панель инструментов 3D навигации

Меню "Вид": "Орбита" » "Свободная орбита"

Устройство указания: Нажать клавиши SHIFT+CTRL и прокрутить колесико мыши, чтобы временно включить режим "3DСОРБИТА".

Контекстное меню: Запустить любую команду 3D навигации, нажать правую кнопку мыши в области чертежа и выбрать "Другие навигационные режимы" » "Свободная орбита" (2).

Ввод команды: 3dсорбита

3DСОРБИТА активизирует вид "3D свободная орбита" в текущем видовом экране. Если видимость знака ПСК включена, на орбитальном виде появляется цветной 3D знак. Команда позволяет манипулировать всеми объектами чертежа или только выбранными.

Вид, на котором действует режим 3D Свободная орбита, помечается орбитальным кольцом. Геометрически оно представляет собой большой круг, разделенный на квадранты четырьмя малыми кругами. Если в контекстном меню опция "Включить автоприцел орбиты" отключена, цель вида остается неподвижной. Положение камеры, т.е. наблюдателя, перемещается вокруг цели. Точкой цели считается центр орбитального кольца; в общем случае он не совпадает с геометрическим центром совокупности рассматриваемых объектов. В отличие от команды 3DОРБИТА, команда 3DСОРБИТА не ограничивает вид вдоль оси XY или по направлению Z.

Примечание Пользователь не может редактировать объекты, если активна команда 3DСОРБИТА.

Установка курсора в различные положения относительно орбитального кольца влияет на форму курсора, которая, в свою очередь, иллюстрирует возможные направления вращения вида. Края граней, расположенных под большим углом, не сглаживаются. См. раздел Формы курсора "3D-свободная орбита".

В ходе выполнения команды 3DОРБИТА доступ к ее опциям возможен через контекстное меню (оно вызывается нажатием правой кнопки мыши в области рисования) или нажатием кнопок на 3D навигационной панели инструментов. См. Контекстное меню режима 3D орбиты.

Находясь в режиме "3D орбита" пользователь может временно включить режим "3D свободная орбита", нажав и удерживая клавишу SHIFT.

Темы:

  • Формы курсора "3D-свободная орбита"


Формы курсора "3D-свободная орбита"

3D Команды
3D Команды
Формы курсора "3D-свободная орбита"
Понятия Процедуры Команды

Направление вращение вида зависит от положения курсора относительно орбитального кольца. Каждому из положений соответствует определенная форма курсора.

Сфера с двумя внешними сферическими орбитами

Если курсор находится внутри орбитального кольца, он выглядит как маленькая сфера с двумя внешними окружностями-орбитами. Нажатие кнопки и перемещение курсора в этом случае вызывает свободное перемещение вида. Вид ведет себя так, как будто бы пользователь захватил курсором воображаемую сферу, окружающую объекты, и начал вращать ее вокруг точки цели. Курсор можно перемещать по горизонтали, по вертикали и по диагонали.

Сфера с внешней окружностью-стрелкой

Если курсор находится вне орбитального кольца, он выглядит как маленькая сфера с внешней окружностью-стрелкой. Нажатие кнопки и перемещение курсора вокруг орбитального кольца вызывает вращение вида относительно оси, проходящей через центр кольца перпендикулярно экрану. Если курсор перемещается внутрь орбитального кольца, он приобретает образ сферы с двумя орбитами и начинает свободно перемещать вид, как было описано выше.

Сфера с горизонтальным эллипсом-стрелкой

Если курсор находится на левом или правом малом круге орбитального кольца, он выглядит как маленькая сфера с горизонтальным эллипсом-стрелкой. Нажатие кнопки и перемещение курсора из этих точек вызывает вращение вида относительно вертикальной оси (оси Y), проходящей через центр кольца.

Сфера с вертикальным эллипсом-стрелкой

Если курсор находится на верхнем или нижнем малом круге орбитального кольца, он выглядит как маленькая сфера с вертикальным эллипсом-стрелкой. Нажатие кнопки и перемещение курсора из этих точек вызывает вращение вида относительно горизонтальной оси (оси X), проходящей через центр кольца.


3DШАРНИР Команда

3D Команды
3D Команды
3DШАРНИР Команда
Понятия Процедуры Команды

Изменяет цель вида в направлении перетаскивания мыши.

Навигационная 3D панель:

Меню "Вид": "Камера" » "Шарнир"

Устройство указания: Нажать клавишу CTRL и прокрутить колесико мыши, чтобы временно включить режим "3DШАРНИР".

Контекстное меню: Запустить любую команду 3D навигации, нажать правую кнопку мыши в области чертежа и выбрать "Другие навигационные режимы" » "Шарнир" (5).

Ввод команды: 3dшарнир

Пульт управления: Панель 3D навигации, Облет шарнира

Имитация панорамирования камерой в направлении перетаскивания. Направление обзора изменяется. Можно выполнять шарнирное перемещение камеры в плоскости XY или вдоль оси Z.


А Команды
  • АДАПТАЦИЯ
  • АНИМТРАЕКТ
  • АПЕРТУРА
  • АРХИВАЦИЯ
  • АТОПР
  • АТРЕД
  • АТРЕДАКТ
  • АТРИЗВЛЕЧЬ
  • АТРОБНОВИТЬ
  • АТЭКР
  • АТЭКСП


АДАПТАЦИЯ Команда

А Команды
А Команды
АДАПТАЦИЯ Команда
Понятия Процедуры Команды

Изменяет инструментальные палитры

Меню "Инструменты": подменю "Адаптация" » "Инструментальные палитры"

Контекстное меню: Нажать правую кнопку мыши на любой инструментальной палитре и выбрать "Настроить палитры".

Ввод команды: адаптация

Откроется диалоговое окно Адаптация.

Темы:

  • Диалоговое окно "Адаптация"


Диалоговое окно "Адаптация"

А Команды
А Команды
Диалоговое окно "Адаптация"
Понятия Процедуры Команды

Меню "Инструменты": подменю "Адаптация" » "Инструментальные палитры"

Контекстное меню: Нажать правую кнопку мыши на любой инструментальной палитре и выбрать "Настроить палитры".

Ввод команды: адаптация

Предоставляет интерфейс для настройки инструментальных палитр и палитр разработки блоков.

Создает, редактирует и структурирует палитры. Импортирует и экспортирует файлы палитр.

Палитры

Отображает список всех доступных палитр. Порядок следования палитр в списке можно изменять перетаскиванием с помощью мыши. Можно переименовать, удалить или экспортировать палитру, Нажав на ней правую кнопку мыши. (При экспорте палитра сохраняется в файле с расширением .xtp.) Можно импортировать палитру или создать новую (пустую), нажав правую кнопку мыши в области "Палитры".

Группы палитр

Отображает организацию инструментальных палитр в области структуры. Палитру можно перетащить с помощью мыши в другую группу. Нажать на группе палитр правую кнопку мыши, затем в контекстном меню выбрать "Установить", чтобы отобразить группу палитр.

С помощью контекстного меню можно также выполнить следующие операции:

  • Создать новую группу
  • Удалить существующую группу
  • Переименовать существующую группу
  • Удалить инструментальную палитру из группы
  • Экспорт группы (как файла XPG)
  • Импорт группы

Текущая группа палитр

Показывает имя группы палитр, отображаемой в настоящий момент. Выводит строку "Все палитры", если отображаются все доступные палитры.


АНИМТРАЕКТ Команда

А Команды
А Команды
АНИМТРАЕКТ Команда
Понятия Процедуры Команды

Сохраняет анимацию вдоль траектории в 3D модели

Меню "Вид": "Анимации траектории перемещения"

Ввод команды: анимтраект

Откроется диалоговое окно "Анимация траектории перемещения".

Темы:

  • Диалоговое окно "Анимации траектории перемещения"
  • Диалоговое окно "Предварительный просмотр анимации"


Диалоговое окно "Анимации траектории перемещения"

А Команды
А Команды
Диалоговое окно "Анимации траектории перемещения"
Понятия Процедуры Команды

Меню "Вид": "Анимации траектории перемещения"

Ввод команды: анимтраект

Задает параметры анимации траектории перемещения и создает анимационный файл.

Камера

Связать камеру с:

Связывает камеру со статической точкой или с траекторией движения на чертеже.

Точка

Связывает камеру со статической точкой на чертеже.

Траектория

Связывает камеру с траекторией движения на чертеже.

Указать точку/Указать траекторию

Выбрать точку местонахождения камеры или траекторию вдоль хода перемещения камеры в зависимости от того, выбрана точка или траектория.

Список точек/траекторий

Отображает список наименованных точек или траекторий, с которыми пользователь может связать камеру. Чтобы создать траекторию, пользователь может связать камеру с линией, дугой, эллиптической дугой, кругом, полилинией, 3D полилинией или сплайном.

Примечание При создании пользователем траектории движения камера создается автоматически. Если пользователь удаляет объект, созданный им в виде траектории движения, наименованная траектория движения также будет удалена.

Цель

Связать цель с

Связывает цель с точкой или траекторией.

Если камера связана с точкой, цель следует связать с траекторией. Если камера связана с траекторией, пользователь может связать цель с точкой или с траекторией.

Точка

Если камера связана с траекторией, эта команда связывает цель со статической точкой на чертеже.

Траектория

Связывает цель с траекторией перемещения на чертеже.

Указать точку/Указать траекторию

Выбирает точку или траекторию в качестве цели, в зависимости от выбора точки или траектории.

Список точек/траекторий

Отображает список наименованных точек или траекторий, с которыми пользователь может связать цель камеры. Чтобы создать траекторию, пользователь может связать цель с линией, дугой, эллиптической дугой, кругом, полилинией, 3D полилинией или сплайном.

Параметры анимации

Управляет выводом анимационного файла.

Кадр/с

Частота выполнения анимации, измеряемая в кадрах в секунду. Следует задать значение от 1 до 60. Значение по умолчанию 30.

Число кадров

Задает общее число кадров в анимации.

Вместе с частотой кадров это значение определяет длительность анимации. Когда пользователь изменяет это число, значение "Длительность" пересчитывается автоматически.

Длительность (в секундах)

Задает длительность анимации (в секундах).

Когда пользователь изменяет это число, значение "Число кадров" пересчитывается автоматически.

Визуальный стиль

Отображает список визуальных стилей и наборы параметров тонирования, которые можно применить к анимационному файлу. Более подробную информацию см. в описании команд ВИЗСТИЛИ и НАБПАРАМТОНИР.

Формат

Задает формат файла для анимации.

Пользователь может сохранять анимацию в файла форматов AVI, MOV, MPG или WMV для последующего воспроизведения. Формат MOV доступен только при установке программы Apple QuickTime Player. Формат WMV доступен и назначается по умолчанию, только если установлена программа Microsoft® Windows Media® Player версии 9 или выше. В противном случае по умолчанию устанавливается формат AVI.

Разрешение

Определяет ширину и высоту окончательной анимации в экранных единицах отображения. Значение по умолчанию 320 х 240.

Замедление в углу

Перемещает камеру медленнее при повороте угла.

Обратно

Меняет направление анимации на обратное.

При просмотре показать предварительный просмотр камеры

Включает отображение диалогового окна "Предварительный просмотр анимации", чтобы пользователь мог предварительно просмотреть анимацию до ее сохранения.

Образец

Отображает предварительный просмотр анимации в диалоговом окне "Предварительный просмотр анимации".


Диалоговое окно "Предварительный просмотр анимации"

А Команды
А Команды
Диалоговое окно "Предварительный просмотр анимации"
Понятия Процедуры Команды

Меню "Вид": "Анимации траектории перемещения"

Ввод команды: анимтраект

Просмотр анимации траектории перемещения, созданной пользователем с помощью траектории перемещения или 3D навигации.

Образец

Отображает образец анимации, заданной пользователем в диалоговом окне "Анимация траектории перемещения" или при облете или обходе анимации и записи ее с помощью пульта управления.

Воспроизведение

Воспроизведение образца анимации. Кнопка воспроизведения блокируется в процессе воспроизведения анимации.

Запись

Запись анимации, начиная с текущего кадра, отображенного в области "Образец". Все кадры, следующие за текущим, перезаписываются. Выводится предупреждение о подтверждении перезаписи, чтобы пользователь подтвердил свое намерение перезаписать существующие кадры. Кнопка "Запись" блокируется в процессе воспроизведения анимации.

Пауза

Временно останавливает анимацию на текущем кадре, отображенном в области "Образец". После временной остановки анимации кнопка "Пауза" блокируется.

Сохранить

Открывает диалоговое окно "Сохранить как". Пользователь может сохранять анимацию в файла форматов AVI, MOV, MPG или WMV для последующего воспроизведения. После сохранения анимации происходит возврат в чертеж. Кнопка "Сохранить" блокируется в процессе воспроизведения анимации.

Визуальный стиль

Задает визуальный стиль, отображаемый в области "Образец". Визуальный стиль сначала имеет значение "Текущий", что соответствует визуальному стилю, заданному в активном видовом экране. Выбрать из списка предварительно заданных и определенных пользователем визуальных стилей.

Движок

Производит покадровое перемещение в образце анимации. Движок можно переместить к определенному кадру в анимации. Указатель показывает текущий кадр и общее количество кадров в анимации.


АПЕРТУРА Команда

А Команды
А Команды
АПЕРТУРА Команда
Понятия Процедуры Команды

Изменение размера прицела объектной привязки

Ввод команды: апертура (или 'апертура для прозрачного вызова)

Размер высоты привязки целевого объекта (1-50 пикселов) <текущий>: Ввести значение (1-50 ) или нажать клавишу ENTER

Объектная привязка выполняется только в том случае, когда объекты находятся внутри прицела или пересекают его. Системная переменная APBOX управляет появлением прицела объектной привязки. Количество пикселов, введенных в команде АПЕРТУРА, задает размер прямоугольника привязки объекта. Чем выше число пикселов, тем больше прицел. Изменить эти установки можно также с помощью диалогового окна "Настройка" (на вкладке "Построения").

Команда АПЕРТУРА изменяет размер прицела объектной привязки, а не прицела выбора объектов. Размер последнего задается системной переменной PICKBOX.


АРХИВАЦИЯ Команда

А Команды
А Команды
АРХИВАЦИЯ Команда
Понятия Процедуры Команды

Упаковывает файлы текущей подшивки для архивирования

Ввод команды: архивация

Откроется диалоговое окно Архивация подшивки.

Если после приглашения к вводу команд ввести -архивация, то команда АРИВАЦИЯ отображает приглашения на командной строке.

Темы:

  • Диалоговое окно "Архивация подшивки"
  • Диалоговое окно "Редактирование параметров архива"
  • Диалоговое окно "Архив - Задание пароля"
  • АРХИВАЦИЯ - вариант для командной строки


Диалоговое окно "Архивация подшивки"

А Команды
А Команды
Диалоговое окно "Архивация подшивки"
Понятия Процедуры Команды

Ввод команды: архивация

Сборка комплекта файлов, относящихся к текущей подшивке, таким образом, чтобы он мог быть заархивирован.

На вкладке "Листы" представлены списки архивируемых листов в том порядке, в котором они были созданы, и в соответствии с организацией подшивки. На вкладке "Дерево файлов" представлен список архивируемых файлов в виде иерархического дерева. На вкладке "Таблица файлов" отображаются архивируемые файлы в виде таблицы.

Все файлы, включаемые в архив, помечаются галочкой около имени. Чтобы удалить файл из архивируемого набора, необходимо убрать с него пометку. Нажатие правой кнопкой мыши в области отображения файлов вызывает контекстное меню, с помощью которого можно либо пометить все файлы, либо снять пометку со всех них.

Примечание Необходимо убедиться в том, что файлы, которые будут архивироваться, в настоящий момент не открыты в каком либо приложении.

Вкладка "Листы"

Список листов, включаемых в архивируемый комплект, в порядке, в котором они были созданы, и в соответствии с организацией подшивки. Подшивка должна быть открыта в Диспетчере подшивок. Архивация может быть инициирована либо из контекстного меню, появляющегося при щелчке правой кнопкой мыши на элементе подшивки верхнего уровня, либо вводом команды архивация в командной строке.

Вкладка "Дерево файлов"

Список файлов, включаемых в архивируемый комплект, в виде иерархического дерева. По умолчанию сюда заносятся все файлы, на которые ссылается текущий чертеж (внешние ссылки, стили печати, шрифты и др.). Пользователь может добавить файлы в архивируемый комплект или удалить существующие файлы из него. В архив не включаются файлы, ссылки на которые установлены посредством URL.

Включены

Отображает количество файлов, включенных в архивируемый комплект, и размер комплекта.

Вкладка "Таблица файлов"

Список файлов, включаемых в архивируемый комплект, в виде таблицы. По умолчанию сюда заносятся все файлы, на которые ссылается текущий чертеж (внешние ссылки, стили печати, шрифты и др.). Пользователь может добавить файлы в архивируемый комплект или удалить существующие файлы из него. В архив не включаются файлы, ссылки на которые установлены посредством URL.

Включены

Отображает количество файлов, включенных в архивируемый комплект, и размер комплекта.

Добавить файл

Вызов стандартного диалогового окна выбора файлов, в котором пользователь может выбрать дополнительный файл для включения его в архивируемый комплект. Эта опция доступна как на вкладке "Дерево файлов", так и на вкладке "Таблица файлов".

Примечания к архиву

Область для ввода примечаний пользователя, добавляемых к архиву. Примечания также включаются в отчет о работе процедуры. Для того, чтобы ко всем архивам добавлялось стандартное примечание, нужно создать текстовый файл ASCII archive.txt и занести в него текст примечания. Файл необходимо сохранить в одной из папок пути доступа к вспомогательным файлам, заданного на вкладке Файлы диалогового окна "Настройка".

Просмотр отчета

Отображение отчетных сведений об архиве. Отчет, помимо прочего, включает все примечания, которые были введены пользователем. В отчет также включается текст пользовательских примечаний к комплекту.

Сохранить как

Вызов диалогового окна сохранения файлов. Необходимо помнить, что отчет автоматически включается в формируемый архивируемый комплект, а опция "Сохранить" предназначена для создания дополнительного экземпляра отчета (например для занесения в систему документооборота).

Параметры архива

Отображает диалоговое окно "Редактирование параметров архива", где пользователь может определить параметры архивируемого комплекта.


Диалоговое окно "Редактирование параметров архива"

А Команды
А Команды
Диалоговое окно "Редактирование параметров архива"
Понятия Процедуры Команды

Ввод команды: архивация

Тип архива

Определяет тип создаваемого архива.

Папка с файлами

Создание архива в виде неупакованного набора файлов в новой или существующей папке.

Самораспаковывающийся EXE-файл

Архивируемый комплект помещается в упакованный файл, способный распаковываться самостоятельно (то есть без использования архиваторов). Для распаковки этого файла и извлечения всех файлов из архива достаточно запустить его подобно обычному приложению (например, двойным щелчком мыши).

Zip-архив

Архивируемый комплект помещается в архивный ZIP-файл. Для распаковки файла необходима программа-архиватор; например PKZIP или WinZip.

Формат файлов

Определяет формат, в который будут преобразовываться все файлы чертежей, включаемые в архив. В раскрывающемся списке можно выбрать формат файла чертежа.

Папка для файла архива:

Определяет расположение, в котором будет создаваться архив. В списке хранятся последние девять мест, в которых были созданы архивы. Чтобы задать новую папку, следует нажать кнопку "Обзор" и разыскать папку в структуре диска.

Если это поле оставлено пустым, то файл архива будет создан в папке, содержащей файл данных подшивки (DST).

Обзор

Вызов стандартного диалогового окна выбора файлов. В нем следует перейти в папку, в которую должен быть помещен формируемый архив.

Имя файла архива

Определение метода задания имени для архива. Отображается имя файла архива, заданное по умолчанию. Эта опция недоступна, если в качестве типа архива установлен тип "Папка с файлами".

Запрос имени файла

Пользователь вводит имя архива в стандартном диалоговом окне выбора файлов.

Имя с возрастанием номера, если необходимо

Используется логическое имя файла, установленное по умолчанию. Если файл с таким именем уже существует, то к концу имени добавляется номер. Этот номер возрастает каждый раз при сохранении нового архива.

Заменять, если необходимо

Используется логическое имя файла, установленное по умолчанию. Если файл с таким именем уже существует, то он автоматически перезаписывается.

Опции для архива

Содержит параметры для архива.

Организованная структура папок

Дублирует структуру папок для файлов формируемого комплекта. Корневой папкой является папка верхнего уровня в иерархическом дереве папок.

При этом выполняются следующие условия:

  • Относительные пути не изменяются. Относительные пути, заданные вне исходной корневой папки, сохраняются вплоть до пути к папке первого уровня над ними и располагаются в корневой папке.
  • Абсолютные пути внутри дерева корневой папки преобразуются в относительные пути. Абсолютные пути сохраняются вплоть до пути к папке первого уровня над ними и располагаются в корневой папке.
  • Абсолютные пути вне дерева корневой папки преобразуются в пути к корневой папке или к папке внутри дерева корневой папки.
  • При необходимости создается папка Fonts.
  • При необходимости создается папка <f "italic">PlotCfgs</f>.
  • При необходимости создается папка SheetSets для хранения в ней всех вспомогательных файлов подшивок. Однако сам файл данных подшивки (DST) располагается в корневой папке.

Эта опция отсутствует, если пользователь сохраняет архивируемый комплект в Интернете.

Корневая папка

Определяет корневую папку для относительных путей зависимых от чертежей файлов, таких как внешние ссылки. Эта папка считается корневой при активной опции "Организованная структура папок".

В корневую папку при архивации подшивки также заносится файл данных подшивки (DST).

Обзор

Вызов стандартного диалогового окна выбора файлов, в котором пользователь может определить корневую папку.

Все файлы в одной папке

При создании архива все файлы собираются в одной папке.

Текущая структура файлов и папок

В архиве сохраняется структура папок всех файлов. Эта опция отсутствует, если пользователь сохраняет архивируемый комплект в Интернете.

Включить шрифты

Включает в архив все связанные файлы шрифтов (TXT и SHX).

Включает текстуры из материалов

Включает текстуры с материалами, которые прилагаются к объектам или граням.

Без плоттера по умолчанию

Отключение в архиве настройки на конкретный принтер/плоттер.

Запрос пароля

Открывает диалоговое окно "Архив — Задание пароля", где пользователь может указать пароль для архивируемого комплекта.

Включить данные и файлы подшивки

Включение в архив файла данных подшивки (DST), файлов чертежей блоков марок, файлов чертежей блоков-идентификаторов и файлов шаблонов чертежей (DWT).


Диалоговое окно "Архив - Задание пароля"

А Команды
А Команды
Диалоговое окно "Архив - Задание пароля"
Понятия Процедуры Команды

Ввод команды: архивация

Пароль на архив

Возможность (не обязательная) задания пароля для доступа к формируемому архиву. Для получения доступа к файлам архива необходимо ввести пароль при открытии данного архива. Защита паролем не применима к типу архива "Папка с файлами".

Повторный пароль для подтверждения

Здесь нужно повторно ввести пароль, заданный в поле "Пароль на комплект файлов". Если два пароля не совпадают, программа требует ввести их заново.


АРХИВАЦИЯ - вариант для командной строки

А Команды
А Команды
АРХИВАЦИЯ - вариант для командной строки
Понятия Процедуры Команды

Если в ответ на приглашение к вводу команд ввести -архивация, команда АРХИВАЦИЯ отображает приглашения в командной строке.

Имя подшивки или [?] <текущее>: Ввести известное имя подшивки, ввести ? для отображения списка подшивок или нажать клавишу ENTER

Имя подшивки определяет подшивку, используемую в архиве. Опция доступна, только если открыта какая-либо подшивка.

Задать опцию [Создать архивируемый комплект/Только отчет] <Создать>: Задать опцию или нажать клавишу ENTER

Пароль (для входа без пароля нажать клавишу ENTER): Ввести пароль или нажать клавишу ENTER

Если в настройке архива пользователь выбрал опцию "Запрос пароля", ему будет выдаваться только запрос пароля.


АТОПР Команда

А Команды
А Команды
АТОПР Команда
Понятия Процедуры Команды

Создание описаний атрибутов

Меню "Рисование": "Блок" » подменю "Задание атрибутов"

Ввод команды: атопр

Откроется диалоговое окно Описание атрибута.

Если в ответ на приглашение к вводу команд ввести -атопр, команда АТОПР отображает приглашения в командной строке.

Темы:

  • Диалоговое окно "Описание атрибута"
  • АТОПР вариант для командной строки


Диалоговое окно "Описание атрибута"

А Команды
А Команды
Диалоговое окно "Описание атрибута"
Понятия Процедуры Команды

Меню "Рисование": "Блок" » подменю "Задание атрибутов"

Ввод команды: атопр

Здесь задаются режим вставки и отображения атрибута, его имя, подсказка и начальное значение, а также точка вставки и параметры текста.

Режим

Параметры значений атрибутов блоков, которые вставляются в чертеж.

Значение по умолчанию запоминается в системной переменной AFLAGS. Изменение значения AFLAGS приводит к изменению режима по умолчанию для описаний новых атрибутов и не влияет на описания уже существующих.

Скрытый

Указывает, что значение атрибута вставленного блока не должно быть видно на экране или выводиться на печать. АТЭКР имеет приоритет перед режимом "Скрытый".

Постоянный

Задает фиксированное значение атрибута для всех вхождений блока.

Контролируемый

Позволяет проверить правильность значения атрибута во время процесса вставки блока.

Установленный

Присваивает атрибуту при вставке блока значение по умолчанию.

Атрибут

Задание данных для атрибута. Поля могут вмещать не более 256 символов. Для задания ведущих пробелов в подсказке или значении по умолчанию нужно начинать их с обратной косой черты (\). Если первый значащий символ данных строк должен быть обратной косой чертой, ее нужно повторить дважды.

Имя

Имя атрибута, по которому могут быть установлены все его вхождения в чертеж. Имя может состоять из любых символов, кроме пробелов. Все строчные буквы автоматически преобразуются в прописные.

Подсказка

Подсказка атрибута, выводимая на экран всякий раз при вставке блока, содержащего данный атрибут. Если оставить поле подсказки пустым, AutoCAD будет использовать в качестве подсказки имя атрибута. Если в группе "Режим" включена опция "Постоянный", поле "Подсказка" недоступно.

Значение

Значение, которое присваивается атрибуту по умолчанию.

Добавление поля

Открывает диалоговое окно "Поле". Пользователь может вставить поле в качестве всего значения атрибута или только его части.

Точка вставки

Указывает положение атрибута. Здесь можно ввести численные значения координат или, нажав кнопку "Указать на экране", определить точку вставки атрибута относительно тех объектов, с которыми связан этот атрибут.

Указать на экране

Отображает запрос для начальной точки, когда закрывается диалоговое окно. Используйте указывающее устройство, чтобы указать положение атрибута относительно объектов, с которыми он будет связан.

X

Указывает координату X для точки вставки атрибута.

Y

Указывает координату Y для точки вставки атрибута.

Z

Указывает координату Z для точки вставки атрибута.

Параметры текста

Здесь задаются выравнивание, текстовый стиль, высота и угол поворота текста атрибута.

Выравнивание

Задает выравнивание текста атрибута. Режимы выравнивания можно найти в описании команды ТЕКСТ.

Текстовый стиль

Заранее определенный текстовый стиль для текста атрибута. Отображается текстовый стиль, загруженный в настоящий момент. Для загрузки или создания нового текстового стиля используется команда СТИЛЬ.

Высота

Высота текста атрибута. Пользователь может ввести значение или указать его на экране, нажав эту кнопку. Высота текста равна расстоянию между двумя указанными точками. В случаях, если выбран стиль с ненулевым значением высоты, или если выбрана опция выравнивания "Вписать", поле ввода высоты текста недоступно.

Поворот

Угол поворота текста атрибута. Пользователь может ввести значение или указать его на экране, нажав эту кнопку. Угол поворота равен углу между горизонтальной осью и заданным двумя точками отрезком. Если выбрана опция выравнивания "Вписать" или "По ширине", поле ввода угла поворота недоступно.

Выровнять по предыдущему атрибуту

Размещение имени атрибута непосредственно под именем предыдущего. Если еще не было создано ни одного описания атрибута, опция недоступна.

Позиция фиксации в блоке

Фиксирует положение атрибута внутри вхождения блока.

Примечание В динамическом блоке положение атрибута должно быть зафиксировано для включения атрибута в набор операции.


АТОПР вариант для командной строки

А Команды
А Команды
АТОПР вариант для командной строки
Понятия Процедуры Команды

Если в ответ на приглашение к вводу команд ввести -атопр, команда АТОПР отображает приглашения в командной строке.

Текущие режимы атрибута: Скрытый=значение Постоянный=значение Контролируемый=значение Установленный=значение Позиция фиксации=значение

Задать опцию для изменения [[Невидимый/Постоянный/Контролируемый/Установленный/Позиция фиксации] <готово>:

Ввести имя атрибута: Ввести последовательность любых символов, кроме пробелов и восклицательных знаков

Ввести подсказку атрибута: Ввести текст подсказки или нажать ENTER (запрос не отображается, если включен режим "Постоянный")

Ввести значение атрибута по умолчанию: Ввести соответствующий текст или нажать ENTER (запрос не отображается, если включен режим "Постоянный")

Ввести значение атрибута: Ввести соответствующий текст или нажать ENTER (запрос отображается, только если включен режим "Постоянный")

Режимы атрибута

Строка с текущими значениями режимов атрибута свидетельствует о состоянии каждого из них (Д - включен, Н - отключен). Ввод с, п, к или у переключает соответствующий режим. Нажать клавишу ENTER после завершения настройки режима. Системная переменная AFLAGS хранит текущий режим атрибутов и может использоваться для установки режимов по умолчанию.

Скрытый

Указывает, что значение атрибута вставленного блока не должно быть видно на экране. АТЭКР имеет приоритет перед режимом "Скрытый".

Постоянный

Задает фиксированное значение атрибута для всех вхождений блока.

Контролируемый

Позволяет проверить правильность значения атрибута в процессе вставки блока.

Установленный

Присваивает атрибуту при вставке блока значение по умолчанию.

Положение фиксации

Фиксирует положение атрибута внутри вхождения блока.

Примечание В динамическом блоке положение атрибута должно быть зафиксировано для включения атрибута в набор операции.

Имя атрибута

Имя атрибута, по которому могут быть установлены все его вхождения в чертеж. Имя может состоять из любых символов, кроме пробелов и восклицательных знаков (!). Все строчные буквы автоматически преобразуются в прописные.

Подсказка атрибута

Подсказка атрибута, выводимая на экран всякий раз при вставке блока, содержащего данный атрибут. Если нажать клавишу ENTER, имя атрибута будет использоваться в качестве подсказки. При активном режиме "Постоянный" запрос задания подсказки не выводится.

Значение атрибута по умолчанию

Значение, которое присваивается атрибуту по умолчанию. Это значение появляется на экране в момент вставки блока в чертеж. Его ввод не обязателен. Если включить режим "Постоянный", то будет выведен запрос "Значение атрибута:".

Дальнейшие запросы команды АТОПР аналогичны запросам команды ТЕКСТ, вместо текстовой строки при этом используется имя атрибута.

Текущий текстовый стиль: "Стандарт" высота текста: 0,2000

Начальная точка текста или [Выравнивание/Стиль]: Задать опцию или нажать ENTER

Описание каждой опции см. в команде ТЕКСТ.

Значение атрибута

Значение постоянного атрибута. Этот запрос появляется, если включен режим "Постоянный".

Дальнейшие запросы команды АТОПР аналогичны запросам команды ТЕКСТ, вместо текстовой строки при этом используется имя атрибута.

Текущий текстовый стиль: "Стандарт" высота текста: 0,2000

Начальная точка текста или [Выравнивание/Стиль]: Задать опцию или нажать ENTER

Описание каждой опции см. в команде ТЕКСТ.


АТРЕД Команда

А Команды
А Команды
АТРЕД Команда
Понятия Процедуры Команды

Изменение данных в атрибутах

Меню "Изменить": "Объект" » подменю "Атрибут" » подменю "Один"

Ввод команды: атред

Выбрать вхождение блока: Выбрать блок с атрибутами

Отобразится диалоговое окно Редактирование атрибутов для изменения значений атрибутов выбранного блока.

Меню "Изменить": "Объект" » подменю "Атрибут" » подменю "Глобально"

Ввод команды: -атред

Если в ответ на подсказку "Команда:" ввести -атред, команда АТРЕД будет отображать в командной строке запросы для изменения значений и свойств атрибута, не зависимых от блока.

Темы:

  • Диалоговое окно "Редактирование атрибутов"
  • АТРЕД - вариант для командной строки


Диалоговое окно "Редактирование атрибутов"

А Команды
А Команды
Диалоговое окно "Редактирование атрибутов"
Понятия Процедуры Команды

Меню "Изменить": "Объект" » подменю "Атрибут" » подменю "Один"

Ввод команды: атред

Редактирует атрибуты в блоке.

Чтобы изменить такие свойства атрибутов, как расположение, высота и стиль, необходимо выполнить команду -АТРЕД.

Имя блока

Указывает название выбранного блока. В этом диалоговом окне отображаются значения всех атрибутов блока.

Список атрибутов

Отображает значения первых восьми атрибутов блока. Все их можно редактировать. Если блок содержит более восьми атрибутов, доступ к нужному атрибуту обеспечивают кнопки "Назад" и "Далее". Не допускается редактирование атрибутов, находящихся на блокированных слоях.

Для использования поля в качестве значения следует нажать правую кнопку мыши и выбрать из контекстного меню пункт "Вставить поле", чтобы отобразить диалоговое окно Поле.

Предыдущий

Отображает значения восьми предыдущих атрибутов. Кнопка "Назад" доступна, только если выбранный блок содержит более восьми атрибутов и для отображения дополнительных атрибутов использовалась кнопка "Далее".

Далее

Отображает значения восьми следующих атрибутов. Если блок не содержит дополнительных атрибутов, кнопка "Далее" недоступна.


АТРЕД - вариант для командной строки

А Команды
А Команды
АТРЕД - вариант для командной строки
Понятия Процедуры Команды

Если в ответ на приглашение к вводу команд ввести -атред, команда АТРЕД отображает приглашения в командной строке.

Редактировать атрибуты по одному? [Да/Нет] <Д>: Ввести д или нажать ENTER для редактирования атрибутов по одному, или ввести н для глобального редактирования

Да

Атрибуты редактируются по одному. Необходимо, чтобы все редактируемые атрибуты были видимы и параллельны текущей ПСК.

Ввести шаблон имени блока <*>: Нажать ENTER либо ввести имя блока или часть имени блока с символами-шаблонами (? или *) для выбора определенных блоков

Ввести шаблон имени атрибута <*>: Нажать ENTER либо ввести имя или часть имени с символами-шаблонами (? или *) для выбора определенных атрибутов

Ввести шаблон значения атрибута <*>: Нажать ENTER либо указать значение атрибута или шаблон значения с символами (? или *) для выбора определенных значений атрибута

Прописные и строчные буквы в значениях атрибутов различаются.

Выбрать атрибуты: Выбрать атрибуты (только параллельные текущей ПСК)

Первый атрибут в наборе помечается маркером X. Допускается изменение любого из свойств выбранного атрибута.

Задать опцию [Значение/Положение/Высота/Угол/Стиль/Слой/Цвет/Следующий] <Н>: Ввести свойство, которое необходимо изменить, или нажать ENTER для следующего атрибута

Если при описании атрибута был задан режим текста "По ширине" или "Вписать", опция "Угол" в запросе опускается. Для вписанного текста опускается опция "Высота". При выборе любого параметра, кроме "Следующий", команда АТРЕД запрашивает новое значение. Маркер остается на атрибуте, пока не выполнен переход к следующему атрибуту.

Значение

Изменение или замена значения атрибута.

Ввести способ модификации значения [Изменить/Заменить]: Ввести и или з, либо нажать клавишу ENTER

Изменить

Модификация нескольких символов значения атрибута.

Ввести строку, подлежащую изменению: Ввести строку, подлежащую изменению, или нажать клавишу ENTER

Ввести новую строку: Ввести заменяющую строку или нажать клавишу ENTER

Любая из строк может быть пустой. Cимволы ? и * интерпретируются буквально, а не как символы-шаблоны.

Заменить

Полная замена значения атрибута на новое.

Ввести новое значение атрибута: В ведите новое значение атрибута или нажать клавишу ENTER

Если нажать клавишу ENTER, атрибуту присваивается пустое значение.

Положение

Изменение точки вставки текста.

Указать новую точку вставки текста: Указать точку или нажать клавишу ENTER

Если выполнено выравнивание атрибута, команда АТРЕД запрашивает конечные точки базовой линии текста.

Высота

Изменение высоты текста.

Задать новую высоту <текущая>: Ввести значение, указать точку или нажать клавишу ENTER

Если указана точка, высотой считается расстояние от нее до начальной точки текста.

Угол

Изменение угла поворота текста.

Задать новый угол поворота <текущий>: Ввести значение, указать точку или нажать клавишу ENTER

Если указана точка, угол устанавливается равным углу от начальной точки текста до указанной точки.

Стиль

Изменение текстового стиля.

Ввести новый текстовый стиль: Ввести имя стиля или нажать клавишу ENTER

Слой

Изменение слоя.

Ввести имя нового слоя <текущий>: Ввести имя слоя или нажать клавишу ENTER

Цвет

Изменение цвета.

Пользователь может задать цвет по индексу цветов AutoCAD, цвет из палитры или альбома цветов.

Задать новый цвет [изПалитры/Альбом]<ПОСЛОЮ>: Задать цвет, ввести п, ввести а, или нажать клавишу ENTER

При вводе цвета можно использовать его стандартное имя, номер (от 1 до 255), а также значения послою и поблоку.

Из палитры

Выбор цвета для выбранного объекта из палитры всех цветов (true color).

Компоненты R,G,B: Ввести три разделенных запятыми значения от 0 до 255

Альбом

Выбор цвета для выбранного объекта из загруженного альбома цветов.

Ввести имя альбома цветов: Ввести имя установленного альбома цветов, например, PANTONE®

Если пользователь ввел имя альбома цветов, ему будет предложено ввести имя цвета из этого альбома.

Ввести имя цвета: Ввести имя цвета из выбранного альбома, например, PANTONE® 573

Далее

Переход к следующему атрибуту из набора. Если атрибутов больше нет, команда АТРЕД завершается.

Нет

Глобальное редактирование одновременное редактирование нескольких атрибутов. В глобальном редактировании могут участвовать как видимые, так и скрытые атрибуты.

При глобальном редактировании атрибутов пользователь может только менять вхождения текстовых строк в значениях атрибутов. При редактировании атрибутов по одному можно изменять любые свойства атрибутов.

Выполняется глобальное редактирование значений атрибутов.

Редактировать только видимые на экране атрибуты? [Да/Нет] <Д>: Ввести д или нажать ENTER для редактирования только видимых атрибутов, либо ввести н для редактирования всех атрибутов

Да

Редактирование только видимых атрибутов.

Ввести шаблон имени блока <*>: Нажать ENTER либо ввести имя блока или часть имени блока с символами-шаблонами (? или *) для выбора определенных блоков

Ввести шаблон имени атрибута <*>: Нажать ENTER либо ввести имя атрибута или шаблон имени с символами (? или *) для выбора определенных атрибутов

Ввести шаблон значения атрибута <*>: Нажать ENTER либо ввести значение атрибута или шаблон значения с символами (? или *) для выбора определенных значений атрибута

Прописные и строчные буквы в значениях атрибутов различаются. Так как пустые атрибуты невидимы и не могут быть выбраны на чертеже, для их выбора нужно ввести обратную косую черту (\).

Выбрать атрибуты: Выбрать атрибуты (только параллельные текущей ПСК)

Выбрать атрибуты, которые необходимо изменить.

Ввести строку, подлежащую изменению: Ввести строку, подлежащую изменению, или нажать клавишу ENTER

Ввести новую строку: Ввести заменяющую строку или нажать клавишу ENTER

Любая из строк может быть пустой. Cимволы ? и * интерпретируются буквально, а не как символы-шаблоны.

Нет

Редактирование всех атрибутов, независимо от их видимости. Внесенные в атрибуты изменения не отображаются на экране сразу. После завершения команды производится регенерация чертежа, кроме случая, когда команда РЕГЕНАВТО, выполняющая автоматическую регенерацию, отключена.

Шаблон имени блока <*>: Ввести полное имя блока или шаблон имени с символами ? или *) либо нажать ENTER для выбора атрибутов во всех блоках

Шаблон имени атрибута <*>: Ввести полное имя атрибута или шаблон имени с символами ? или *) либо нажать ENTER для выбора атрибутов в списке всех атрибутов

Шаблон значения атрибута <*>: Ввести полное значение атрибута или шаблон значения с символами ? или *) либо нажать ENTER для выбора всех атрибутов

Прописные и строчные буквы в значениях атрибутов различаются. Так как пустые атрибуты невидимы и не могут быть выбраны на чертеже, для их выбора нужно ввести обратную косую черту (\).

Будут выбраны атрибуты, у которых имена блоков, имена атрибутов и значения атрибутов совпадают с заданными.

Ввести старую строку: Ввести изменяемое значение атрибута или нажать ENTER для добавления нового значения к существующим

Новая строка: Ввести новое значение для замены значения или для добавления к выбранным значениям

Любая из строк может быть пустой. Cимволы ? и * интерпретируются буквально, а не как символы-шаблоны.


АТРЕДАКТ Команда

А Команды
А Команды
АТРЕДАКТ Команда
Понятия Процедуры Команды

Редактирование атрибутов во вхождениях блоков

Панель "Редактирование-2":

Меню "Редактировать": "Объект" » подменю "Атрибут" » подменю "Один"

Ввод команды: атредакт

Выбрать блок:

Появляется запрос для выбора блока в области рисования. После выбора блока с атрибутами открывается диалоговое окно Редактор атрибутов блоков.

Если выбранный блок не имеет атрибутов, или указанный объект не является блоком, появляется сообщение об ошибке, и снова выводится запрос для выбора блока.

Темы:

  • Редактор атрибутов блоков


Редактор атрибутов блоков

А Команды
А Команды
Редактор атрибутов блоков
Понятия Процедуры Команды

Панель "Редактирование-2":

Меню "Редактировать": "Объект" » подменю "Атрибут" » подменю "Один"

Ввод команды: атредакт

Появляется список атрибутов выбранного вхождения блока и свойства каждого атрибута. Свойства атрибутов и их значения можно редактировать.

Блок

Имя блока, атрибуты которого редактируются.

Имя

Имя, определяющее атрибут.

Выбрать блок

При выборе блока с помощью указывающего устройства временно закрывает диалоговое окно.

Если сразу после изменения атрибутов выбрать новый блок, на экране появится запрос о сохранении внесенных изменений.

Применить

Применение внесенных изменений без закрытия диалогового окна "Редактор атрибутов блоков".

Редактор атрибутов блоков содержит следующие вкладки:

  • Атрибут
  • Параметры текста
  • Свойства

Вкладка "Атрибут" (Редактор атрибутов блоков)

Отображение имени, подсказки и значения каждого атрибута. Изменять можно только значение атрибута.

Вывести в список

Выводит список атрибутов в выбранном вхождении блока и для каждого атрибута отображает имя, подсказку и значение.

Значение

Назначение выбранному атрибуту нового значения. Для использования поля в качестве значения следует нажать правую кнопку и выбрать пункт "Вставить поле" из контекстного меню. Открывается диалоговое окно "Поле".

Вкладка "Параметры текста" (редактор атрибутов блоков)

Здесь определяются свойства отображения текста атрибута на чертеже. Цвет текста атрибута изменяется на вкладке "Свойства".

Текстовый стиль

Стиль текста атрибута. Параметры выбранного на данной вкладке стиля определяют свойства текста атрибута.

Выравнивание

Определение режима выравнивания текста атрибута (выравнивание по левому краю, по центру или по правому краю).

Высота

Высота текста атрибута.

Поворот

Угол поворота текста атрибута.

Справа налево

Включение/отключение режима отображения текста атрибута справа налево.

Перевернутый

Включение/отключение режима отображения текста атрибута в перевернутом виде.

Степень растяжения

Степень сжатия/растяжения текста атрибута. Задание значения, меньшего 1,0, вызывает сжатие. Задание значения, большего 1,0, вызывает растяжение.

Угол наклона

Угол наклона текста атрибута. Измеряется от вертикальной оси.

Вкладка "Свойства" (редактор атрибутов блоков)

Здесь задается слой, на котором находится атрибут, вес и тип линий, а также цвет текста атрибута. Если чертеж использует именованные стили печати, с помощью данной вкладки можно связать атрибут со стилем печати.

Слой

Слой текста атрибута.

Тип линий

Тип линий атрибута.

Цвет

Цвет атрибута.

Стиль печати

Стиль печати атрибута.

Если текущий чертеж использует цветозависимые стили печати, список стилей печати недоступен.

Вес линий

Вес линий для атрибута.

Если системная переменная LWDISPLAY отключена, то изменения, внесенные с помощью этой опции, не будут отображаться на экране.


АТРИЗВЛЕЧЬ Команда

А Команды
А Команды
АТРИЗВЛЕЧЬ Команда
Понятия Процедуры Команды

Экспорт информации атрибута блока в таблицу или внешний файл

Панель "Редактирование-2":

Меню "Инструменты": "Извлечение атрибутов"

Ввод команды: атризвлечь

Откроется диалоговое окно мастера извлечения атрибутов.

Если в ответ на подсказку "Команда" ввести -атризвлечь, будет вызван вариант команды АТРИЗВЛЕЧЬ, при котором в командной строке выводятся подсказки

Темы:

  • Мастер извлечения атрибутов
  • Диалоговое окно "Извлечение атрибутов - Дополнительные настройки"
  • Диалоговое окно "Фильтр"
  • Командная строка АТРИЗВЛЕЧЬ


Мастер извлечения атрибутов

А Команды
А Команды
Мастер извлечения атрибутов
Понятия Процедуры Команды

Панель "Редактирование-2":

Меню "Инструменты": "Извлечение атрибутов"

Ввод команды: атризвлечь

Предоставляет пошаговые инструкции для извлечения информации из атрибутов блока в текущем чертеже или других чертежах. Информация используется для создания таблицы в текущем чертеже или сохраняется во внешний файл.

Мастер извлечения атрибутов содержит следующие страницы:

  • Начало
  • Выбрать чертежи
  • Выбор атрибутов
  • Завершение вывода
  • Стиль таблиц
  • Готово

Начало

Параметр для указания новых настроек для извлечения атрибутов или для использования ранее сохраненных настроек в файле шаблона извлечения атрибутов (BLK).

Создавать таблицу или внешний файл заново

Использует настройки, указанные при продолжении работы с мастером.

По шаблону

Использует настройки, ранее сохраненные в файле шаблона извлечения атрибутов (BLK). При перемещении по программе мастера каждая страница уже заполнена настройками, сделанными в файле шаблона. Эти настройки можно изменить. На странице "Конец" можно выбрать, сохранять ли новые настройки.

Имя шаблона

Указывает файл шаблона извлечения атрибутов (BLK). Нажать кнопку [...], чтобы выбрать файл в стандартном диалоговом окне для выбора файлов.

Выбрать чертежи

Указывает файлы чертежей и блоки для извлечения из них информации.

Выбор объектов

Делает доступной кнопку "Выбрать блоки" для выбора объектов в текущем чертеже.

Выбрать блоки

При выборе экземпляров блока в текущем чертеже временно закрывает мастера.

Текущий чертеж

Извлекает информацию атрибутов блоков из всех блоков в текущем чертеже.

Выбранные чертежи/Подшивки

Делает доступной кнопку [...] для выбора файлов чертежа или файла подшивки (DST). В выбранных чертежах информация атрибутов извлечена из всех блоков.

Кнопка [...]

Отображает диалоговое окно "Выбор файла" (стандартное диалоговое окно выбора файлов), в котором можно обнаружить и выбрать файлы чертежей или файл подшивки (DST).

Файлы чертежей

Перечисление выбранных файлов чертежей или листов в выбранной подшивке. Можно выбрать один или несколько файлов, затем с помощью правой кнопки мыши выбрать "Исключить", чтобы удалить их из списка.

  • Если выбран параметр "Текущий чертеж" или "Выбранные чертежи", то отобразятся пути и имена выбранных файлов.
  • Если выбран параметр "Список листов", то отобразятся пути и имена всех исходных файлов выбранной подшивки.

Дополнительные настройки

Отображает диалоговое окно "Извлечение атрибутов - Дополнительные настройки", в котором можно указать, требуется ли включать вложенные блоки и блоки во внешних ссылках, а также указать блоки для подсчета.

Выбор атрибутов

Здесь задаются блоки, атрибуты и свойства для извлечения.

Исключать блоки без атрибутов

Фильтрация списка блоков. При выборе этого параметра в список блока входят только экземпляры блоков, для которых назначены атрибуты. Динамические блоки включены в список, если для них назначены специальные свойства (например, операции и параметры). Отменить по умолчанию.

Исключать общие свойства блоков

Фильтрация свойств для списка проверенных блоков. При выборе этого параметра общие свойства блока (кроме имени) в список не включены. В списке отобразятся только атрибуты блоков и свойства динамических блоков. Данная опция используется по умолчанию.

Блоки

Список блоков в выбранных чертежах или листах. Если выбранный чертеж или лист содержит только определение блока, но не экземпляры, блок не будет включен в список. Чтобы изменить порядок сортировки на обратный, следует дважды нажать кнопку мыши на заголовке столбца.

Установить флажок рядом с каким-либо именем блока, чтобы отобразить атрибуты этого блока и его свойства в списке "Свойства отмеченных блоков".

В столбце "Отображаемое имя" имеется место для ввода дополнительного альтернативного имени блока, чтобы оно было отображено в извлеченной информации. Выбрать блок, нажать правую кнопку мыши на списке и выбрать "Изменение отображаемого имени".

Свойства для проверенных блоков

Отображает список свойств и атрибутов для блоков, проверенных в списке блоков. Для получения информации об атрибуте или свойстве нужно установить флажок рядом с его именем. Имя проверено по умолчанию.

Если свойство или атрибут отмеченного флажком блока уникальны, то при отмене выбора этого блока данное свойство или атрибут удаляется из списка. При повторном выборе этого блока имя свойства или атрибута будет восстановлено в списке; если свойство требуется извлечь из списка, следует установить для него флажок.

В столбце "Отображаемое имя" имеется место для ввода дополнительного альтернативного имени свойства, чтобы оно было отображено в извлеченной информации. Выбрать свойство, нажать правую кнопку мыши на списке и выбрать "Изменение отображаемого имени".

В столбце "Тип" отображается одна из трех категорий свойства. Общие - это обычные свойства блока, например цвет или слой. Атрибуты - это пользовательские атрибуты. Динамические - это пользовательские данные о свойстве динамического блока.

Образец

Просмотр, когда в списке блоков отмечен только один блок.

Завершение вывода

Предоставляет список извлеченных блоков и атрибутов, а также методы форматирования информации.

В каждой строке отображается имя блока и значения для каждого атрибута данного блока. Имена атрибутов отображаются в заголовках столбцов. Если блок не имеет значение для атрибута, ячейка остается пустой.

Изменить порядок расположения столбцов, перетащив столбец в другое место. Нажать правую кнопку мыши на заголовке столбца и с помощью параметров контекстного меню отредактировать заголовки столбцов, скрыть или отобразить столбцы или отсортировать таблицу по значениям любого столбца.

Можно контролировать отображение значений для любого атрибута. Нажать правую кнопку мыши на заголовке столбца и выбрать "Фильтр строк" для отображения диалогового окна "Фильтр".

Таблица AutoCAD

Извлекает информацию в таблицу и при нажатии кнопки "Далее" отображает страницу "Стиль таблицы".

Внешний файл

Указывает имя и расположение файла, в который планируется экспорт информации. Нажать кнопку [...], чтобы выбрать файл в стандартном диалоговом окне для выбора файлов. Форматы CSV (разделение запятыми) и TXT (разделение табуляцией) присутствуют в списке.

Полный просмотр

Полный просмотр конечного файла в текстовом окне. Предварительный вид предназначен только для просмотра. Внести какие-либо изменения на странице "Завершение вывода".

Можно также нажать правую кнопку мыши на списке и выбрать "Копирование в буфер обмена", а затем вставить окончательный вариант в файл.

Стиль таблиц

Управление внешним видом таблицы. Данная страница отображается, если на странице "Завершение вывода" выбрана таблица AutoCAD.

Ввести название таблицы

Указывает название таблицы. При обновлении таблицы данная строка перезаписана не будет. Если выбран стиль таблицы по умолчанию СТАНДАРТ, в таблицу будет включена строка заголовка. Если выбран стиль таблицы без строки заголовка, данный параметр недоступен.

Выбрать стиль таблицы

Имя стиля таблицы. Кнопка [...] открывает диалоговое окно "Стиль таблицы". Выбрать стиль таблицы в списке "Стили" и нажать "Сделать текущим". Стиль таблицы можно создавать и изменять.

Отображать уведомление лотка, только когда требуется обновление данных

Если в извлеченные данные внесены изменения, в стоке состояния отображается уведомление “Необходимо обновить таблицу извлечения атрибутов”. Для автоматического обновления таблицы с помощью тех же настроек извлечения атрибутов нажать "Обновить данные таблицы". Таблица будет вновь создана и заменит старую таблицу. Утеряны все изменения, выполненные для таблицы вручную. Во избежание потери изменений форматирования изменения следует изменять стиль таблицы, а не саму таблицу.

Образец

Просмотр листа таблицы. Если стиль таблицы не предусматривает строку заголовка, ничего не отобразится.

Готово

Завершает процесс извлечения атрибутов.

Сохранить шаблон

Отображает диалоговое окно "Сохранить как" (стандартное диалоговое окно выбора файлов), в котором можно сохранить параметры извлечения атрибутов в файле шаблона, имеющем расширение .blk.

Во время следующего использования "Мастера извлечения атрибутов" на странице "Начало" можно выбрать файл шаблона, чтобы предварительно заполнить каждую страницу мастера.


Диалоговое окно "Извлечение атрибутов - Дополнительные настройки"

А Команды
А Команды
Диалоговое окно "Извлечение атрибутов - Дополнительные настройки"
Понятия Процедуры Команды

Панель "Редактирование-2":

Меню "Инструменты": "Извлечение атрибутов"

Ввод команды: атризвлечь

Параметры вложенных блоков и блоков внешних ссылок, а также параметры, указывающие блоки для подсчета.

Параметры блока

Параметры, определяющие блоки, которые планируется включить в извлечение атрибутов и счетчик блоков.

Включать вложенные блоки

Включает блоки, вложенные в другие блоки.

Включать блоки во внешних ссылках

Включает блоки в файлы внешних ссылок.

Включать ссылки в счетчиках блоков

При подсчете блоков включает внешние ссылки.

Параметры счетчика

Параметры для подсчета блоков.

Включать только блоки в пространстве модели

Подсчет экземпляров блоков только в пространстве модели и исключение блоков на листах в пространстве листа. По умолчанию откл.

Включать все блоки со всего чертежа

Подсчет всех экземпляров блоков чертежа. Доступен только при выборе текущего чертежа или нескольких чертежей. По умолчанию вкл.


Диалоговое окно "Фильтр"

А Команды
А Команды
Диалоговое окно "Фильтр"
Понятия Процедуры Команды

Панель "Редактирование-2":

Меню "Инструменты": "Извлечение атрибутов"

Ввод команды: атризвлечь

Количество строк в таблице. Значения в столбце перечислены и отмечены флажком. Следует снять флажок с любой строкой, которую не требуется отображать в таблице или файле.


Командная строка АТРИЗВЛЕЧЬ

А Команды
А Команды
Командная строка АТРИЗВЛЕЧЬ
Понятия Процедуры Команды

Если в ответ на подсказку "Команда" ввести -атризвлечь, будет вызван вариант команды АТРИЗВЛЕЧЬ, при котором в командной строке выводятся подсказки.

Ввести тип извлечения атрибутов: [Объекты/Текущий чертеж/Выбрать чертеж/Шаблон]: Для принятия заданной по умолчанию установки или ввода опции нужно нажать клавишу ENTER

Текущий чертеж

Извлечение информации из текущего меню.

Извлечь данные из чертежа по внешней ссылке? [Да/Нет] <Да>: Ввести у или n

Извлечь данные из вложенных блоков? [Да/Нет] <Да>: Ввести y или n

Хотите использовать шаблон? [Да/Нет] <Да>: Ввести y , чтобы воспользоваться шаблоном, созданным в версиях, предшествующих AutoCAD 2006, или ввести n

При вводе "y" отображается следующая подсказка. Шаблоны извлечения атрибутов, созданные до выхода версии AutoCAD 2006, сохраняют только сведения о блоке и не могут быть использованы для вставки таблицы. Чтобы использовать шаблон для вставки таблицы, следует в командной строке задать "t" в качестве первой опции, указывающей на необходимость использования шаблона.

Ввод пути к файлу шаблона: Задать путь и имя для файла шаблона извлечения атрибутов (BLK), содержащего описание способа извлечения данных

На экран выводятся следующие подсказки:

Ввести тип файла на выходе [Csv/Txt/Xls/Mdb] <Csv>: Ввести c для использования запятой в качестве разделителя (CSV), t для использования табуляции в качестве разделителя (TXT), x для формата электронных таблиц Microsoft Excel (XLS) или m для формата СУБД Microsoft Access (MDB)

Ввести путь к файлу на выходе: Задать имена пути и файла, в который будут помещены извлеченные данные

Объекты

Извлечение информации из выбранных пользователем блоков со ссылками.

Выбрать блоки: В области чертежа выбрать блоки, содержащие информацию, которую необходимо извлечь

Последующие подсказки такие же, как для опции "Текущий чертеж".

Выбор чертежа

Извлечение информации из чертежей, заданных пользователем.

Задать файл чертежа или список файлов чертежей, разделенных запятой "," и нажать клавишу ENTER: Задать разделенные запятыми пути и имена файлов тех чертежей, из которых необходимо извлечь информацию

Последующие подсказки такие же, как для опции "Текущий чертеж".

Шаблон

Извлечение данных способом, определяемым существующим шаблоном извлечения атрибутов (BLK), созданным с помощью мастера извлечения атрибутов в программе AutoCAD 2006 или в более поздней версии этой программы.

Ввести путь к файлу шаблона: Задать путь и имя для файла шаблона извлечения атрибутов (BLK), содержащего описание способа извлечения данных

Последующие подсказки определяются данными, которые содержатся в файле шаблона. Если шаблон задает извлечение данных во внешний файл, то на экран выводятся следующие подсказки:

Ввести тип файла на выходе [Csv/Txt/Xls/Mdb] <Csv>: Ввести c для использования запятой в качестве разделителя (CSV), t для использования табуляции в качестве разделителя (TXT), x для формата электронных таблиц Microsoft Excel (XLS) или m для формата СУБД Microsoft Access (MDB)

Ввести путь к файлу на выходе: Задать имена пути и файла, в который будут помещены извлеченные данные

Если таблицу определяет шаблон, на экран выводятся следующие подсказки:

Точка вставки:


АТРОБНОВИТЬ Команда

А Команды
А Команды
АТРОБНОВИТЬ Команда
Понятия Процедуры Команды

Обновление всех экземпляров указанного блока с текущими атрибутами, заданными для блока

Панель Редактирование-2:

Ввод команды: атробновить

Задать опцию [?/Имя/Выбрать] <Выбрать>:

Программа запрашивает имена блоков, которые необходимо обновить с заданными для них текущими атрибутами.

Используйте эту команду для обновления всех экземпляров блоков, содержащих атрибуты, которые были переопределены с помощью команд БЛОК или БЛОКРЕД. Команда АТРОБНОВИТЬ не изменяет никаких значений, присвоенных атрибутам существующих блоков.

Примечание Следует использовать команду ПЕРЕАТР для переопределения и обновления блоков в одной команде.

Если ввести ?, на экране появляется список описаний всех блоков чертежа. Ввести с клавиатуры имя обновляемого блока.

Если нажать клавишу ENTER, блоки, атрибуты которых требуется обновить, могут быть выбраны на экране с помощью указательного устройства.

Если заданный блок не содержит атрибутов или не существует, на экране появляется сообщение об ошибке и приглашение выбрать другой блок.

Предупреждение Команда АТРОБНОВИТЬ удаляет любое, внесенное командами АТРЕД или АТРЕДАКТ изменение формата или свойства. Она также удаляет любые дополнительные данные, связанные с блоком, и может повлиять на динамические блоки или блоки, созданные в приложениях сторонних разработчиков.


АТЭКР Команда

А Команды
А Команды
АТЭКР Команда
Понятия Процедуры Команды

Выполняет общий контроль видимости атрибутов блока в чертеже

Меню "Вид": "Отображение" » подменю "Отображение атрибута"

Ввод команды: атэкр (или 'атэкр для прозрачного вызова)

Cостояние видимости атрибута [Нормальный/Вкл/Откл] <текущее>:

После изменения состояния видимости атрибутов чертеж регенерируется (кроме случая, когда команда РЕГЕНАВТО, выполняющая автоматическую регенерацию, отключена). Текущее состояние видимости атрибутов хранится в системной переменной ATTMODE.

Нормальный

Сохраняет текущее состояние видимости каждого из атрибутов. Видимые атрибуты отображаются; скрытые - нет.

Вкл

Делает все атрибуты видимыми.

Откл

Делает все атрибуты невидимыми.


АТЭКСП Команда

А Команды
А Команды
АТЭКСП Команда
Понятия Процедуры Команды

Извлекает данные атрибута, т.е. связанный с блоком информационный текст, в файл

Ввод команды: атэксп

Откроется диалоговое окно Извлечение атрибутов.

Если в ответ на приглашение к вводу команд ввести -атэксп, команда АТЭКСП отображает приглашения в командной строке.

Темы:

  • Диалоговое окно "Извлечение атрибутов"
  • АТЭКСП - вариант для командной строки


Диалоговое окно "Извлечение атрибутов"

А Команды
А Команды
Диалоговое окно "Извлечение атрибутов"
Понятия Процедуры Команды

Ввод команды: атэксп

Здесь задаются формат файла для вывода информации, участвующие в операции объекты, а также имена файла шаблона и выходного файла.

Формат файлов

Задание формата для извлечения данных из атрибутов.

Файл с разделением запятыми (CDF)

Генерируется файл, содержащий по одной записи для каждого вхождения блока в чертеж. По крайней мере один атрибут блока должен соответствовать имеющемуся в файле шаблона. Поля записей разделяются запятыми. Символьные поля заключаются в одиночные кавычки.

Файл с разделением пробелами (SDF)

Генерируется файл, содержащий по одной записи для каждого вхождения блока в чертеж. По крайней мере один атрибут блока должен соответствовать имеющемуся в файле шаблона. Поля каждой записи имеют фиксированную длину, поэтому не требуются ни разделители, ни ограничители символьных полей.

Файл формата DXF (DXX)

Генерирует подмножество формата файла графического обмена AutoCAD, содержащее только описания вхождений блоков, атрибутов и признаков конца последовательности. Шаблон для вывода в формате DXF™ не требуется. Расширение имени файла.dxx отличает выходной файл от обычных DXF-файлов.

Выбор объектов

Временно закрывает диалоговое окно и позволяет выбрать блоки, имеющие атрибуты, непосредственно на чертеже. После того, как диалоговое окно "Извлечение атрибутов" появляется вновь, справа от слова "Найдено" выводится количество выбранных объектов.

Обнаружено

Указывает количество объектов, выбранных по запросу "Выбрать объекты".

Файл шаблона

Задает файл шаблона для вывода в форматах CDF и SDF. Ввести имя файла в поле или выбрать "Файл шаблона", чтобы выполнить поиск уже существующих файлов шаблона в стандартном окне выбора файлов. По умолчанию файлы имеют расширение имени .txt. Если в группе "Формат файла" выбран формат DXF, кнопка и текстовое поле "Файл шаблона" недоступны.

Более подробную информацию о создании файлов шаблонов см. в разделе Атрибуты блоков Руководства пользователя.

Файл вывода

Указывает имя и положение файла, в который будут записаны извлеченные данные атрибутов. Ввести для извлеченных данных атрибута путь или имя файла либо выбрать "Файл вывода", чтобы выполнить поиск уже существующих файлов шаблонов в стандартном окне выбора файлов. Расширение имени файла .txt добавляется к файлам CDF или SDF, а расширение .dxx добавляется к файлам DXF.


АТЭКСП - вариант для командной строки

А Команды
А Команды
АТЭКСП - вариант для командной строки
Понятия Процедуры Команды

Если в ответ на приглашение к вводу команд ввести -атэксп, команда АТЭКСП отображает приглашения в командной строке.

Указать формат вывода или задать режим вывода с выбором объектов [Cdf/Sdf/Dxf/Объекты] <C>: Ввести опцию или нажать клавишу ENTER

CDF: Файл с разделением запятыми

Генерируется файл, содержащий по одной записи для каждого вхождения блока в чертеж. Поля записей разделяются запятыми. Символьные поля заключаются в одиночные кавычки.

Имя файла шаблона задается в диалоговом окне "Выбор файла шаблона".

В диалоговом окне "Создание файла вывода" нужно задать имя выходного файла. Выходной файл имеет расширениеtxt для файлов в форматах CDF или SDF.

SDF: файл с разделением пробелами

Генерируется файл, содержащий по одной записи для каждого вхождения блока в чертеж. Поля каждой записи имеют фиксированную длину, поэтому не требуются ни разделители, ни ограничители символьных полей.

Имя файла шаблона задается в диалоговом окне "Выбор файла шаблона".

В диалоговом окне "Создание файла вывода" нужно задать имя выходного файла. Выходной файл имеет расширениеtxt для файлов в форматах CDF или SDF.

DXF: Файл графического обмена

Генерирует подмножество формата файла графического обмена AutoCAD, содержащее только описания вхождений блоков, атрибутов и признаков конца последовательности. Шаблон для вывода в формате DXF не требуется. Расширение имени файла .dxx отличает выходной файл от обычных DXF-файлов.

В диалоговом окне "Создание файла вывода" задать имя выходного файла. Выходной файл имеет расширениеdxx для формата DXF.

Объекты

Выбор объектов, атрибуты которых требуется извлечь.

Выбрать объект: Выбрать объект любым способом

Указать формат вывода атрибутов [Cdf/Sdf/Dxf] <C>: Ввести опцию или нажать клавишу ENTER


Б Команды
  • БКЗАКРЫТЬ
  • БЛОКТАБЛВЫБ
  • БАЗА
  • БВЫБОР
  • БВЫНОСКА
  • БДСВЯЗЬ
  • БДСПИСОК
  • БЕЗОПНАСТР
  • БИБМАТ
  • БЛОБРАЗЕЦ
  • БЛОК
  • БЛОКНАБРУЧ
  • БЛОКПАЛВАР
  • БЛОКПАЛВАРЗАКР
  • БЛОКПАРАМ
  • БЛОКПОКАЗАТЬ
  • БЛОКПОРАТР
  • БЛОКРЕАКТ
  • БЛОКРЕАКТИНСТ
  • БЛОКРЕАКТНАБОР
  • БЛОКРЕАКТСВЯЗЬ
  • БЛОКРЕД
  • БЛОКРЕДЗАКР
  • БЛОКСКРЫТЬ
  • БЛОКСОСТВИД
  • БЛОКСОХР
  • БЛОКСОХРКАК
  • БПОРЦИКЛ
  • БРАЗМЕР
  • БРАУЗЕР
  • БСОЗДАТЬ
  • БСОХРАНИТЬ
  • БЫСТРКАЛЬК


БКЗАКРЫТЬ Команда

Б Команды
Б Команды
БКЗАКРЫТЬ Команда
Понятия Процедуры Команды

Закрытие калькулятора QuickCalc

Ввод команды: бкзакрыть

Закрытие калькулятора QuickCalc.


БЛОКТАБЛВЫБ Команда

Б Команды
Б Команды
БЛОКТАБЛВЫБ Команда
Понятия Процедуры Команды

Отображает или создает таблицу выбора для описания динамического блока

Ввод команды: блокред » подменю блокреакт

Отображает диалоговое окно "Таблица выбора свойств".

Текущее описание динамического блока должно содержать реактор выбора и, по крайней мере, один параметр выбора, чтобы отобразить диалоговое окно "Таблица выбора свойств". Если для реактора выбора уже определена таблица, она отобразится в диалоговом окне. Если таблица не определена, она создается и отображается в диалоговом окне "Таблица выбора свойств".

Темы:

  • Диалоговое окно "Таблица выбора свойств"
  • Диалоговое окно "Добавление свойств параметров"


Диалоговое окно "Таблица выбора свойств"

Б Команды
Б Команды
Диалоговое окно "Таблица выбора свойств"
Понятия Процедуры Команды

В диалоговом окне "Таблица выбора свойств" содержится таблица выбора для описания динамического блока. Таблица выбора используется для управления значениями, доступными для параметра выбора (свойство поиска). В таблице выбора можно также управлять значениями параметров выбора с помощью значений других параметров (свойства входа).

В таблице выбора указываются значения свойств для вхождения динамического блока в зависимости от манипулирования блоком в чертеже. Если для свойства поиска выбран обратный поиск, во вхождении блока отображается ручка выбора. При нажатии в чертеже ручки выбора отображается список свойств поиска. При выборе параметра из этого списка изображение вхождения динамического блока будет изменено.

Имя операции

Отображает имя реактора выбора, связанного с таблицей.

Добавить свойства

Отображает диалоговое окно "Добавление свойств параметров". Свойства параметров можно добавлять в таблицу выбора.

Проверить

Проверяет данные в таблице для обеспечения уникальности каждого ряда.

Свойства входа

Задает свойства входа для динамического блока. В группе "Свойства входа" каждый параметр в динамическом блоке (за исключением параметра поиска, выравнивания или базовой точки) можно отобразить в виде столбца. Если значение параметра совпадает со значением в соответствующем столбце свойства ввода в таблице выбора, соответствующее свойство поиска в правой части таблицы назначается вхождению блока.

Свойства поиска

Задает свойства поиска для динамического блока. В группе "Свойства поиска" каждый параметр в динамическом блоке можно отобразить в виде столбца. Если значение параметра совпадает со значением в соответствующем столбце свойства ввода в таблице выбора, соответствующее свойство поиска в правой части таблицы назначается вхождению блока. Управляющий раскрывающийся список в нижней части столбца поиска используется для того, чтобы сделать свойство поиска доступным только для чтения или разрешить обратный поиск. Если все столбцы в таблице являются уникальными, можно установить свойство поиска для разрешения обратного поиска. Функция "Разрешить обратный просмотр" позволяет установить свойство поиска для вхождения блока из раскрывающегося списка, который отображается при нажатии ручки выбора в чертеже. Выбор параметра из этого списка изменяет вхождение блока для совпадения с соответствующими значениями свойства входа в таблице.


Диалоговое окно "Добавление свойств параметров"

Б Команды
Б Команды
Диалоговое окно "Добавление свойств параметров"
Понятия Процедуры Команды

Добавляет свойства параметра в таблицу выбора.

Свойства параметров

Отображает список параметров, не добавленных в таблицу выбора. Выбрать параметр и нажать "ОК", чтобы добавить его в таблицу выбора.

Тип свойства

Указывает тип свойства, которое необходимо добавить в таблицу выбора.

Добавить свойства входа

При выборе этого параметра в списке "Свойства параметров" отображаются доступные параметры свойства входа, которые можно добавить в таблицу выбора.

Добавить свойства поиска

При выборе этого параметра в списке "Свойства параметров" отображаются доступные параметры свойства поиска, которые можно добавить в таблицу выбора.


БАЗА Команда

Б Команды
Б Команды
БАЗА Команда
Понятия Процедуры Команды

Задание базовой точки вставки для текущего чертежа

Меню "Рисование": "Блок" » подменю "База"

Ввод команды: база (или 'база для прозрачного вызова)

Ввести базовую точку <текущая>: Указать точку или нажать ENTER

Базовая точка выражается в координатах текущей ПСК. При вставке чертежа в качестве блока или внешней ссылки в другие чертежи, заданная базовая точка используется в качестве базовой точки вставки.


БВЫБОР Команда

Б Команды
Б Команды
БВЫБОР Команда
Понятия Процедуры Команды

Быстрое создание набора объектов на основе заданных критериев фильтрации

Меню "Сервис": "Быстрый выбор"

Контекстное меню: Завершите выполнение всех активных команд, нажмите правую кнопку мыши в области рисования и выберите "Быстрый выбор".

Ввод команды: бвыбор

Откроется диалоговое окно "Быстрый выбор".

Темы:

  • Диалоговое окно "Быстрый выбор"


Диалоговое окно "Быстрый выбор"

Б Команды
Б Команды
Диалоговое окно "Быстрый выбор"
Понятия Процедуры Команды

Меню "Сервис": "Быстрый выбор"

Контекстное меню: Завершите выполнение всех активных команд, нажмите правую кнопку мыши в области рисования и выберите "Быстрый выбор".

Ввод команды: бвыбор

Задание критериев фильтрации и способа создания набора объектов на основе этих критериев.

Применить

Позволяет применить заданные критерии ко всему чертежу или к текущему набору (если он существует). Для выбора группы объектов, к которой требуется применить критерии фильтрации, служит кнопка "Выбрать объекты". После выбора объектов для возврата в диалоговое окно следует нажать ENTER. Для параметра "Применить" установлено значение "Текущий выделенный фрагмент".

Если установлен флажок "Добавить в текущий набор", критерии фильтрации применяются ко всему чертежу.

Выбор объектов

Временное закрытие диалогового окна для выбора в текущем чертеже одного или нескольких объектов, к которым требуется применить критерии фильтрации. Для возврата в диалоговое окно "Быстрый выбор" следует нажать ENTER. Теперь параметр "Применить" имеет значение "К текущему набору". Кнопка "Выбрать объекты" доступна, только если флажок "Включить в новый набор" установлен, а флажок "Добавить в текущий набор" снят.

Тип объекта

Задание типов объектов для включения в критерии фильтрации. Если критерии фильтрации применяются ко всему чертежу, в списке "Тип объекта" перечисляются все типы объектов, включая объекты сторонних приложений. В противном случае в списке представлены только типы выбранных объектов.

Если в таком приложении как Autodesk Map для объекта была создана классификация, можно выбрать классификацию объекта.

Свойства

Задание свойств объектов для фильтра. Содержит список всех свойств объектов, по которым можно осуществить отбор, для выбранного типа объектов. Выбранное свойство определяет опции, доступные в списках "Оператор" и "Значение".

Если в таком приложении как Autodesk®Map™ для объекта была создана классификация, можно выбрать классификацию объекта.

Оператор

Управление диапазоном применения фильтра. В зависимости от выбранного свойства в списке могут содержаться операторы "Равно", "Не равно", "Больше", "Меньше" и "Поиск с использованием символов-шаблонов". Для некоторых свойств операторы "Больше" и "Меньше" не доступны. Поиск с использованием символов-шаблонов можно выполнять только для редактируемых текстовых полей.

Подробнее об использовании символов-шаблонов см. таблицу в разделе Фильтрация и сортировка слоев в списке документа Руководство пользователя.

Значение

Задание значения свойства для фильтра. Если программе известны значения выбранного свойства в чертеже (и они представляют собой конечное множество), поле "Значение» становится списком, из которого можно выбрать значение. В противном случае, значение свойства следует вводить в поле с клавиатуры.

Отобранные объекты

Указывает, что нужно делать с объектами, удовлетворяющими критериям фильтрации: включать в набор или исключать из набора. Для создания нового набора, состоящего только из объектов, удовлетворяющих критериям фильтрации, следует установить флажок "Включить в новый набор". Для создания нового набора, состоящего только из объектов, не удовлетворяющих критериям фильтрации, следует установить флажок "Исключить из нового набора".

Добавить в текущий набор

Выбор способа добавления набора объектов, созданного командой БВЫБОР, в текущий набор: добавление новых объектов в текущий набор или замена текущего набора новым.

Примечание Команда БВЫБОР поддерживает сторонние объекты (созданные в других приложениях) и их свойства. Для выбора свойств сторонних объектов, которые не используются в AutoCAD, с помощью команды БВЫБОР должно быть запущено исходное приложение сторонних объектов.


БВЫНОСКА Команда

Б Команды
Б Команды
БВЫНОСКА Команда
Понятия Процедуры Команды

Построение простой выноски и надписи для нее

Панель "Размеры":

Меню "Размеры": "Выноска"

Ввод команды: бвыноска

Команда БВЫНОСКА используется для быстрого нанесения выносок и надписей на выносках. В диалоговом окне "Параметры выноски" можно настроить команду на запрос количества запрашиваемых точек и требуемого типа надписей. С помощью команды БВЫНОСКА можно

  • Задать надпись на выноске и ее формат
  • Указать точки прикрепления выносок к надписям многострочного текста
  • Ограничить число точек выноски
  • Ограничить углы первого и второго сегмента выноски

Если включен режим "Ассоциативные размеры" (с помощью переменной DIMASSOC), начальная точка выноски может быть прикреплена к точке на объекте. В этом случае перемещение объекта не требует корректировки положения текста или рамки допуска (они остаются на месте), и стрелки продолжают соединять объект и линии выноски.

Первая точка выноски или [Параметры] <Параметры>: Указать первую точку выноски или нажать ENTER для задания параметров

Первая точка выноски

Следующая точка: Указать следующую точку выноски

Укажите следующую точку: Указать следующую точку выноски или нажать ENTER для перехода к вводу надписи выноски

Количество запрашиваемых программой точек, задается в группе "Количество точек" на вкладке "Выноска и стрелка" диалогового окна "Параметры выноски".

Содержание следующего запроса зависит от параметров, заданных на вкладке "Надпись" диалогового окна "Параметры выноски".

Если на вкладке "Надпись" выбраны параметры "МТекст" и "Запрос ширины", отображаются следующие запросы:

Ширина текста <0.0000><текущая>: Задать ширину текста, очертив границы текста или введя значение с клавиатуры

Если задать значение ширины текста 0,00, ширина многострочного текста не ограничивается.

Первая строка текста пояснения: Ввести первую строку текста

Нажмите ENTER для завершения строки и перехода к следующей, или дважды нажмите ENTER для завершения команды.

Если на вкладке "Надпись" выбран параметр "Копия объекта", отображается следующий запрос:

Выберите копируемый объект: Выбрать текст, вхождение блока или рамку допуска

Объект прикрепляется к выноске.

Если на вкладке "Надпись" выбран параметр "Допуск", откроется диалоговое окно "Допуски формы и расположения". В нем можно создать рамку допуска. После нажатия "ОК" рамка допуска прикрепляется к выноске.

Если на вкладке "Надпись" выбран параметр "Вхождение блока", отображается следующий запрос:

Имя блока или [?]: Ввести имя или ввести ? для отображения имен блоков, описанных в чертеже

Точка вставки или [Масштаб/X/Y/Z/ПОворот/ПМасштаб/ПX/ПY/ПZ/ППоворот]: Указать точку вставки блока или задать опцию

Описание опций вставки см. в ВСТАВИТЬ вариант для командной строки.

Если на вкладке "Надпись" выбран параметр "Ничего", запросы не выводятся.

Параметры

Вызов диалогового окна "Параметры выноски".

Темы:

  • Диалоговое окно "Параметры выноски"


Диалоговое окно "Параметры выноски"

Б Команды
Б Команды
Диалоговое окно "Параметры выноски"
Понятия Процедуры Команды

Панель "Размеры":

Меню "Размеры": "Выноска"

Ввод команды: бвыноска

Позволяет настроить команду БВЫНОСКА и определить свойства выносок и надписей.

Диалоговое окно "Параметры выноски" состоит из следующих вкладок: Надпись, Выноска и стрелка, Выравнивание

Вкладка "Надпись" (диалоговое окно "Параметры выноски")

Вкладка используется для выбора типа надписи, установки режимов многострочного текста и задания параметра повторного использования надписи для последующих выносок.

Тип надписи

Задание типа надписи выноски. Для каждого из типов команда БВЫНОСКА выдает отдельный запрос.

МТекст

Выбор многострочного текста в качестве надписи.

Копировать объект

Отображает запрос на копирование многострочного текста, однострочного текста, допуска, объекта вхождения блока и соединяет копию с концом линии выноски. Копия связывается с выносной линией, поэтому при перемещении скопированного объекта конец этой линии перемещается вместе с объектом. Наличие полки зависит от типа скопированного объекта.

Допуск

Вызов диалогового окна "Допуски формы и расположения" для создания рамки допуска с последующим прикреплением ее к выноске.

Блок

Отображение запроса на вставку вхождения блока. Вхождение блока вставляется со смещением от конца выносной линии и связывается с ней таким образом, что при перемещении блока конец линии выноски также перемещается. Полка не генерируется.

Нет

Создание выноски без надписи.

Режимы МТекста

Задание параметров многострочного текста. Параметры доступны только при использовании типа надписи "многострочный текст".

Запрос ширины

Отображение запроса ширины надписи многострочного текста.

Выравнивание влево

Выравнивание многострочного текста пояснения влево независимо от расположения выноски.

Текст в рамке

Текст надписи заключается в рамку.

Повторное использование

Задание режима повторного использования надписи.

Нет

Отключение повторного использования надписи.

Следующая надпись

Повторное использование следующей надписи для всех последующих выносок.

Текущая надпись

Повторное использование текущей надписи. Этот параметр выбирается автоматически при повторном использовании надписи после выбора параметра "Следующая надпись".

Вкладка "Выноска и стрелка" (диалоговое окно "Параметры выноски")

Задание формата выносной линии и стрелки.

Выносная линия

Задание формата выносной линии.

Прямая

Построение выносной линии, состоящей из прямолинейных сегментов, по указанным точкам.

Сплайн

Создание сплайнового объекта по точкам выноски, заданным как управляющие точки.

Стрелка

Выбор типа стрелки выноски. В списке "Стрелка" приведены все имеющиеся стрелки. Для выносок используются такие же стрелки, что и для размерных линий. См. РЗМСТИЛЬ. При выборе "Пользовательская" отображается список существующих в чертеже блоков. В списке можно выбрать нужный блок для использования в качестве стрелки выноски.

Количество точек

Задание количества точек, после указания которых команда БВЫНОСКА переходит к созданию надписи. Например, если задано 3 точки, команда БВЫНОСКА автоматически запрашивает текст надписи после указания двух точек выноски. Число точек должно на единицу превышать количество сегментов выноски, которое требуется создать.

Если установлен флажок "Не ограничено", команда БВЫНОСКА запрашивает точки, пока не будет нажата клавиша ENTER.

Ограничения углов

Задание ограничений для углов первого и второго сегмента выноски.

Первый сегмент

Задание угла для первого сегмента выноски.

Второй сегмент

Задание угла для второго сегмента выноски.

Вкладка "Выравнивание" (диалоговое окно "Параметры выноски")

Задание точки прикрепления для выносных линий и надписей многострочного текста. Параметры доступны, только если в качестве пояснения задан многострочный текст.

Верх первой строки

Выноска прикрепляется к верхней границе первой строки многострочного текста.

Середина первой строки

Выноска прикрепляется к середине первой строки многострочного текста.

Середина текста

Выноска прикрепляется к середине многострочного текста.

Середина последней строки

Выноска прикрепляется к середине последней строки многострочного текста.

Низ последней строки

Выноска прикрепляется к нижней границе последней строки многострочного текста.

Разместить текст над полкой

Размещение текста надписи над полкой выноски.


БДСВЯЗЬ Команда

Б Команды
Б Команды
БДСВЯЗЬ Команда
Понятия Процедуры Команды

Интерфейс между программой и таблицами внешних баз данных

Меню "Сервис": "Палитры" » "Базы данных"

Ввод команды: базы данных

Отображается Диспетчер подключения к БД и в строку меню добавляется меню "Базы данных".

В справочной системе вначале описываются четыре основных элемента интерфейса команды (диспетчер подключения к БД, окно просмотра данных, редактор запросов и диалоговое окно выбора по связи). Затем следует информация о дополнительных диалоговых окнах. Диалоговое окно "Значения столбца" описано в разделе "Редактор запросов", т.к. оно является подчиненным элементом этого редактора. В каждом из разделов, посвященных какому-либо диалоговому окну, содержатся сведения о том, как его вызывать.

  • Диспетчер подключения к БД
  • Окно просмотра данных
  • Редактор запросов
  • Диалоговое окно "Значения столбца"
  • Диалоговое окно "Выбор по связи"
  • Диалоговое окно "Настройка источника данных"
  • Диалоговое окно "Параметры окна просмотра данных и запросов"
  • Диалоговое окно "Экспорт связей"
  • Диалоговое окно "Экспорт набора запросов"
  • Диалоговое окно "Экспорт набора шаблонов"
  • Диалоговое окно "Поиск"
  • Диалоговое окно "Формат"
  • Диалоговое окно "Импорт набора запросов"
  • Диалоговое окно "Импорт набора шаблонов"
  • Диалоговое окно "Шаблон ярлыка"
  • Диалоговое окно "Свойства шаблона ярлыка"
  • Диалоговое окно "Преобразование связей"
  • Диспетчер связей
  • Диалоговое окно "Шаблон связи"
  • Диалоговое окно "Свойства шаблона связи"Диалоговое окно "Свойства шаблона связи"
  • Диалоговое окно "Новый шаблон ярлыка"
  • Диалоговое окно "Новый шаблон связи"
  • Диалоговое окно "Новый запрос"
  • Диалоговое окно "Замена"
  • Диалоговое окно "Выбор объекта базы данных"
  • Диалоговое окно "Выбор объекта данных"
  • Диалоговое окно "Сортировка"
  • Диалоговое окно "Синхронизация"

Темы:

  • Диспетчер подключения к БД
  • Окно просмотра данных
  • Редактор запросов
  • Вкладка "Простой запрос" (Редактор запросов)
  • Вкладка "Запрос по интервалу" (редактор запросов)
  • Вкладка "Формирователь" (редактор запросов)
  • Вкладка "SQL-запрос" (редактор запросов)
  • Диалоговое окно "Значения столбца"
  • Диалоговое окно "Настройка источника данных"
  • Диалоговое окно "Параметры окна просмотра данных и запросов"
  • Диалоговое окно "Экспорт связей"
  • Диалоговое окно "Экспорт набора запросов"
  • Диалоговое окно "Экспорт набора шаблонов"
  • Диалоговое окно "Поиск файлов"
  • Диалоговое окно "Формат"
  • Диалоговое окно "Импорт набора запросов"
  • Диалоговое окно "Импорт набора шаблонов"
  • Диалоговое окно "Шаблон ярлыка"
  • Диалоговое окно "Свойства шаблона ярлыка"
  • Диалоговое окно "Преобразование связей"
  • Диспетчер связей
  • Диалоговое окно "Выбор по связи"
  • Диалоговое окно "Шаблон связи"
  • Диалоговое окно "Свойства шаблона связи"
  • Диалоговое окно "Новый шаблон ярлыка"
  • Диалоговое окно "Новый шаблон связи"
  • Диалоговое окно "Новый запрос"
  • Диалоговое окно "Замена"
  • Диалоговое окно "Выбор объекта базы данных"
  • Диалоговое окно "Выбор объекта данных"
  • Диалоговое окно "Сортировка"
  • Диалоговое окно "Синхронизация"


Диспетчер подключения к БД

Б Команды
Б Команды
Диспетчер подключения к БД
Понятия Процедуры Команды

Обеспечивает базовый интерфейс при поддержании связи с базами данных. Можно просматривать и редактировать таблицы баз данных, выполнять запросы на языке структурированных запросов (SQL) и связывать записи таблиц с графическими объектами. По умолчанию диспетчер подключения к БД открывается как фиксированное окно в левой части области рисования.

При первом открытии диспетчера подключения к БД все базы данных и объекты данных помечаются с помощью красного крестика. Это означает, что объекты в настоящий момент не подключены. Для того чтобы подключиться к БД или к объекту данных, необходимо дважды нажать на соответствующем ярлыке в диспетчере.

Диспетчер подключения к БД состоит из следующих компонентов:

  • Кнопки "Диспетчера подключения к БД"
  • Зона структуры "Диспетчера подключения к БД"
  • Контекстное меню открытых чертежей
  • Контекстное меню объектов баз данных
  • Контекстное меню источников данных
  • Контекстное меню объектов данных

Кнопки "Диспетчера подключения к БД"

Просмотр объектов баз данных и выполнение операций с ними.

Просмотреть таблицу

Открытие таблицы внешней БД в режиме "только чтение". Кнопка не доступна, если в зоне структуры не выбрана таблица, шаблон связи или шаблон ярлыка.

Редактирование таблицы

Открытие таблицы внешней БД в режиме редактирования. Кнопка не доступна, если в зоне структуры не выбрана таблица, шаблон связи или шаблон ярлыка.

Выполнить запрос

Выполнение запроса. Кнопка недоступна, если в зоне структуры не выбран запрос.

Новый запрос

Отображает диалоговое окно "Новый запрос". Кнопка не доступна, если в зоне структуры не выбрана таблица, шаблон связи или запрос. Если выбран запрос, при нажатии этой кнопки открывается Редактор запросов, предназначенное для изменения запроса.

Новый шаблон связи

Отображает диалоговое окно "Новый шаблон связи". Кнопка не доступна, если в зоне структуры не выбрана таблица, шаблон связи или запрос. Если выбран шаблон связи, нажатие кнопки вызывает диалоговое окно "Шаблон связи", предназначенное для его изменения. Кнопка не доступна для шаблонов, по которым уже установлены связи для объектов чертежа.

Новый шаблон ярлыка

Отображает диалоговое окно "Новый шаблон ярлыка". Кнопка не доступна, если в зоне структуры не выбрана таблица, шаблон связи или шаблон ярлыка. Если выбран шаблон ярлыка, нажатие кнопки вызывает диалоговое окно "Шаблон ярлыка", предназначенное для изменения его параметров.

Зона структуры "Диспетчера подключения к БД"

Содержит узлы для каждого открытого в настоящий момент чертежа, а также узел "Источники данных", где перечислены все доступные источники данных, на которые настроена система.

Контекстное меню открытых чертежей

Содержит функции, доступные для открытых чертежей. Для вызова меню нужно нажать правую кнопку мыши на ярлыке открытого чертежа.

Экспорт набора шаблонов

Вызов диалогового окна "Экспорт набора шаблонов", предназначенного для сохранения во внешнем файле всех шаблонов связей и ярлыков, имеющихся в чертеже.

Импорт набора шаблонов

Вызов диалогового окна "Импорт набора шаблонов", предназначенного для импорта набора шаблонов связей и ярлыков из внешнего файла.

Экспорт набора запросов

Вызов диалогового окна "Экспорт набора запросов", предназначенного для сохранения во внешнем файле всех запросов, имеющихся в чертеже. Набор запросов сохраняется в файле с расширением .dbq.

Импорт набора запросов

Вызов диалогового окна "Импорт набора запросов", предназначенного для импорта набора запросов из внешнего файла с расширением .dbq.

Показать ярлыки

Включение видимости всех ярлыков, имеющихся в выбранном чертеже.

Скрыть ярлыки

Отключение видимости всех ярлыков, имеющихся в выбранном чертеже.

Обновить ярлыки

Обновление полей ярлыков, имеющихся в выбранном чертеже, для того чтобы в них отражалось текущее состояние таблицы базы данных.

Контекстное меню объектов баз данных

Содержит функции, доступные для объектов баз данных (шаблонов связей, шаблонов ярлыков и запросов), связанных с чертежами. Каждому классу объектов баз данных присущ свой набор функций. Так, содержание контекстного меню, вызванного щелчком правой кнопки на запросе, отличается от содержания меню для шаблона связи. Для различных объектов баз данных в контекстные меню могут входить следующие пункты:

Просмотреть таблицу

Открытие таблицы внешней БД в режиме "только чтение". Опция доступна только для шаблонов связей.

Редактирование таблицы

Открытие таблицы внешней БД в режиме редактирования. Опция доступна только для шаблонов связей.

Изменить

Вызов диалогового окна, предназначенного для изменения свойств выбранного объекта базы данных. Опция доступна для шаблонов связей, шаблонов ярлыков и запросов. Опция не доступна для шаблонов связей, по которым уже установлены связи для объектов чертежа.

Удалить

Удаление выбранного объекта базы данных. Опция доступна для шаблонов связей, шаблонов ярлыков и запросов.

Копировать

Создание копии выбранного объекта базы данных и вставка ее в текущий чертеж. Опция доступна для шаблонов связей, шаблонов ярлыков и запросов.

Переименовать

Вызов диалогового окна, предназначенного для переименования выбранного объекта базы данных. Опция доступна для шаблонов связей, шаблонов ярлыков и запросов. Опция не доступна для шаблонов связей, по которым уже установлены связи для объектов чертежа.

Новый запрос

Вызов диалогового окна "Новый запрос". Опция доступна только для шаблонов связей.

Выбор по связи

Вызов диалогового окна "Выбор по связи". Опция доступна только для шаблонов связей.

Новый шаблон ярлыка

Вызов диалогового окна "Новый шаблон ярлыка". Опция доступна только для шаблонов связей.

Показать ярлыки

Показ всех ярлыков, относящихся к выбранному объекту базы данных. Опция доступна для шаблонов связей и шаблонов ярлыков.

Скрыть ярлыки

Скрытие всех ярлыков, относящихся к выбранному объекту базы данных. Опция доступна для шаблонов связей и шаблонов ярлыков.

Удалить связи

Удаление из текущего чертежа всех связей, использующих выбранный шаблон связи. Опция доступна только для шаблонов связей.

Удалить ярлыки

Удаление из текущего чертежа всех ярлыков, использующих выбранный шаблон ярлыка. Опция доступна только для шаблонов ярлыков.

Синхронизация

Проверка в текущем чертеже корректности всех связей, использующих выбранный шаблон связи. Сообщения об обнаруженных несоответствиях выводятся в диалоговом окне "Синхронизация". Опция доступна только для шаблонов связей.

Обновить

Обновление полей ярлыков выбранного чертежа, связанных с выбранным шаблоном ярлыка, для того чтобы в них отражалось текущее состояние таблицы базы данных. Опция доступна только для шаблонов ярлыков.

Выполнить

Выполнение выбранного запроса. Опция доступна только для запросов.

Удалить связи

Удаление из текущего чертежа всех связей, использующих выбранный шаблон связи. Опция доступна только для шаблонов связей.

Контекстное меню источников данных

Содержит функции работы с источниками данных. Для вызова меню нужно нажать правую кнопку на разделе "Источники данных".

Настройка источника данных

Вызов диалогового окна "Настройка источника данных", предназначенного для настройки новых и редактирования имеющихся источников данных.

Контекстное меню объектов данных

Содержит функции работы с объектами данных. Для вызова меню нужно нажать правую кнопку на имени объекта данных (каталоге, таблице и т.п.) в разделе "Источники данных".

Подключить

Установка связи с выбранным объектом данных. Опция доступна для источников данных, каталогов и схем.

Отключить

Разрыв связи с выбранным объектом данных. Опция доступна для источников данных, каталогов и схем.

Синхронизация

Вызов диалогового окна "Синхронизация". Опция доступна только для подключенных источников данных.

Настройка

Вызов диалогового окна "Настройка источника данных", предназначенного для настройки новых и редактирования имеющихся источников данных. Опция доступна только для отключенных источников данных.

Просмотреть таблицу

Открытие выбранной таблицы БД в режиме "только чтение". Опция доступна только для таблиц.

Редактирование таблицы

Открытие выбранной таблицы БД в режиме правки. Опция доступна только для таблиц.

Новый шаблон связи

Вызов диалогового окна "Новый шаблон связи". Опция доступна только для таблиц баз данных.

Новый шаблон ярлыка

Вызов диалогового окна "Новый шаблон ярлыка". Опция доступна только для таблиц баз данных.

Новый запрос

Вызов диалогового окна "Новый запрос". Опция доступна только для таблиц баз данных.


Окно просмотра данных

Б Команды
Б Команды
Окно просмотра данных
Понятия Процедуры Команды

Базовый интерфейс для просмотра и редактирования таблиц внешних баз данных в программе. Вызвать диалоговое окно можно любым из следующих способов:

Используя кнопки диспетчера подключения к БД: в диспетчере подключения к БД выбрать шаблон связи, шаблон ярлыка или таблицу и нажать кнопку "Просмотреть таблицу" или "Редактировать таблицу".

Из меню "Базы данных": "Просмотр данных" » подменю "Просмотреть внешнюю таблицу", "Редактировать внешнюю таблицу", "Просмотреть связанную таблицу" или "Редактировать связанную таблицу". (Отображает диалоговое окно для выбора таблицы базы данных, которую необходимо открыть.)

Контекстное меню: Нажать правую кнопку мыши на шаблоне связи или таблице базы данныхДиспетчер подключения к БД и выбрать "Просмотреть таблицу" или "Редактировать таблицу".

Устройство указания: Нажать правую кнопку мыши на шаблоне связи или таблице базы данных в окне диспетчера подключения к БД. Двойное нажатие кнопки мыши на шаблоне связи, не имеющем связей, созданных на соответствующем этому шаблону чертеже, открывает диалоговое окно "Шаблон связи". Таблица базы данных открывается или в режиме редактирования, или в режиме "Только чтение", что определяется параметрами подключения к базе данных, заданными во вкладки "Система" диалогового окна "Настройка". См. НАСТРОЙКА.

В окне просмотра данных отображается содержимое записей выбранной таблицы БД. В окне просмотра данных содержится набор кнопок, окно таблицы для просмотра и редактирования записей и навигационная панель для перелистывания записей в окне. После открытия окна просмотра данных в строку меню добавляется меню "Просмотр данных". Нажав правую кнопку мыши на строке заголовка и выбрав в контекстном меню соответствующую опцию, пользователь может задать для окна просмотра данных возможность его закрепления или прикрепления якорем.

Внешний вид окна просмотра данных управляется системными настройками компьютера, для изменения которых используется Панель управления Windows. Текст в ячейках выводится цветом, заданным для текста в окне. Если таблица базы данных открыта только для чтения, фон ячеек имеет цвет, заданный для фона трехмерных объектов (по умолчанию — светло-серый). Если таблица открыта для редактирования, фон ячеек имеет цвет, заданный для фона окна (по умолчанию — белый). Текст и фон выделенных ячеек изображаются цветами, заданными в системе для выделенных элементов.

В окне просмотра данных находятся следующие кнопки:

  • Кнопки окна просмотра данных
  • Рабочая область окна просмотра данных
  • Контекстное меню столбцов
  • Контекстное меню ячеек
  • Контекстное меню записей
  • Контекстное меню заголовка таблицы
  • Навигационная панель
  • Предварительный просмотр перед печатью

Кнопки окна просмотра данных

Позволяют создавать связи, просматривать связанные записи и графические объекты.

Связь

Создание связи между выделенной строкой (строками) таблицы базы данных и одним или несколькими графическими объектами. В окне просмотра данных по выбранным шаблонам связи и ярлыка можно создать связь и, если необходимо, ярлык. Для того чтобы задать текущий режим создания связей, следует нажать кнопку "Параметры связей и ярлыков". Доступны три режима:

Связь

Создаются связи с одним или несколькими графическими объектами; ярлыки при этом не образуются. Если в текущем чертеже уже имеются выбранные объекты, создаются связи с каждым из них. Если выбранных объектов нет, программа предлагает указать, к каким объектам должны присоединяться связи.

Создавать свободные ярлыки

Создание свободного ярлыка, не относящегося к какому-либо графическому объекту. Точки вставки ярлыков указывает пользователь.

Создать прикрепленный ярлык

Создаются связи с одним или несколькими графическими объектами и соответствующие ярлыки. Если в текущем чертеже уже выбраны объекты, создаются связи с каждым из них. Если выбранных объектов нет, программа предлагает указать, к каким объектам должны присоединяться связи.

Просмотр связанных объектов в чертеже

Выбор графических объектов текущего чертежа, связанных с выделенной в окне просмотра данных строкой или строками.

Просмотр связанных записей в окне просмотра данных

Выделение в окне просмотра данных тех записей, которые связаны с выбранными графическими объектами чертежа.

Автопросмотр связанных объектов в чертеже

Автоматический выбор связанных графических объектов текущего чертежа при выделении какой-либо записи окна просмотра данных.

Автопросмотр связанных записей в окне просмотра данных

Автоматическое выделение связанных записей в окне просмотра данных при выборе графических объектов текущего чертежа.

Печать окна просмотра данных

Печать содержимого окна просмотра данных активным в настоящий момент системным принтером Microsoft® Windows®.

Параметры окна просмотра данных и запросов

Вызов диалогового окна "Параметры окна просмотра данных и запросов", параметры которого задают порядок взаимодействия и отображения связанных записей окна просмотра данных и графических объектов текущего чертежа.

Запрос, возврат к запросу, возврат к выбору по связи

Вызов одного из диалоговых окон "Новый запрос", Редактор запросов или "Выбор по связи" в зависимости от способа открытия окна просмотра данных. Если окно просмотра данных было открыто для просмотра или редактирования таблицы БД, кнопка носит название "Запрос" и вызывает диалоговое окно "Новый запрос". Если окно просмотра данных было открыто для просмотра результатов запроса, кнопка носит название "Возврат к запросу" и осуществляет возврат к Редактору запросов. Если окно просмотра данных было открыто для возврата к результатам выбора по связи, кнопка носит название "Возврат к выбору по связи" и вызывает диалоговое окно "Выбор по связи".

Выбор шаблона связи

Создание нового или выбор имеющегося шаблона связи. На его основе создаются новые связи в текущем чертеже. Для создания нового шаблона связи нужно выбрать из списка значение "Новый шаблон связи", а затем нажать кнопку "Связь!".

Выбор шаблона ярлыка

Создание нового или выбор имеющегося шаблона ярлыка. На его основе создаются новые ярлыки в текущем чертеже. Для создания нового шаблона ярлыка нужно выбрать из списка значение "Новый шаблон ярлыка", а затем установить в меню "Параметры связей и ярлыков" текущим один из следующих пунктов: "Создавать свободные ярлыки" или "Создавать прикрепленные ярлыки". Если для выбранной таблицы базы данных в текущем чертеже не определен шаблон связи, открывается диалоговое окно "Новый шаблон связи".

Рабочая область окна просмотра данных

Здесь отображается подмножество записей таблицы базы данных. Выбор ячеек, записей и столбцов осуществляется с помощью следующих элементов интерфейса:

  • Заголовок столбца: Выделение всех ячеек данного столбца. Двойное нажатие кнопки мыши на заголовке столбца вызывает сортировку записей по возрастанию значений в нем. Повторное двойное нажатие на заголовке столбца вызывает сортировку записей по убыванию значений в нем.
  • Заголовок записи: Выделение отдельной записи. Двойное нажатие кнопки мыши на заголовке записи приводит к выбору всех связанных с ней графических объектов на чертеже.
  • Ячейка таблицы: Выделение содержимого данного поля записи. Двойное нажатие кнопки мыши на ячейке дает возможность отредактировать значение в ней.
  • Заголовок таблицы: Выделение всех ячеек таблицы. Двойное нажатие кнопки мыши на заголовке таблицы приводит к принятию всех изменений и закрытию окна просмотра данных.

Контекстное меню столбцов

Нажатие правой кнопки на заголовке столбца (или нескольких выделенных столбцов) открывает контекстное меню, состоящее из следующих пунктов.

Сортировка

Вызов диалогового окна "Сортировка", в котором можно задать до пяти критериев сортировки записей в окне просмотра данных.

Скрыть

Скрытие всех выделенных столбцов в окне просмотра данных. Из таблицы столбцы при этом не удаляются.

Показать все

Показ всех ранее скрытых столбцов в окне просмотра данных. Опция доступна, только если в таблице имеются скрытые столбцы.

Заморозить

Фиксация всех выделенных столбцов так, чтобы они не перемещались при горизонтальной прокрутке. Опция доступна, только если выделены один или несколько смежных столбцов.

Освободить все

Отмена фиксации всех столбцов; после этого они начинают перемещаться при горизонтальной прокрутке. Опция доступна, только если в таблице имеются фиксированные столбцы.

Вписанный

Режим выравнивания данных в текущем столбце. Стандартный означает, что числовые данные выравниваются вправо, а все остальные влево. Названия других режимов (Влево, По центру и Вправо) в пояснениях не нуждаются.

Найти

Вызов диалогового окна "Поиск", с помощью которого можно найти требуемое значение в таблице. Поиск производится только в пределах выделенного столбца.

Заменить

Вызов диалогового окна "Замена", с помощью которого можно найти требуемое значение в таблице и заменить его на другое. Замена производится только в пределах выделенного столбца. Опция доступна только для таблиц баз данных, открытых в режиме редактирования.

Контекстное меню ячеек

Нажатие правой кнопки на выделенной ячейке открывает контекстное меню, состоящее из следующих пунктов.

Просмотреть связанные объекты

Просмотр графических объектов текущего чертежа, связанных с выделенной записью базы данных.

Связь

Установка связи текущей записи с графическим объектом. В окне просмотра данных по выбранным шаблонам связи и ярлыка можно создать связь и, если необходимо, ярлык. Пользователь может указать, что именно нужно создать (связь, свободный ярлык или прикрепленный ярлык), используя расположенное здесь же подменю "Параметры связей и ярлыков".

Параметры связей и ярлыков

Здесь выбирается режим создания связей. Пользователь указывает, что именно нужно создать (связь, свободный ярлык или прикрепленный ярлык) при выборе опции "Связь!" этого же контекстного меню.

Найти

Вызов диалогового окна "Поиск", с помощью которого можно найти требуемое значение в таблице. Область поиска при работе функции "Найти" ограничивается тем столбцом, в котором находится выделенная в текущий момент ячейка.

Заменить

Вызов диалогового окна "Замена", с помощью которого можно найти требуемое значение в таблице и заменить его другим. Область поиска при работе функции "Заменить" ограничивается тем столбцом, в котором находится выделенная в текущий момент ячейка. Опция доступна только для таблиц баз данных, открытых в режиме редактирования.

Изменить

Изменение значения в выбранной ячейке. Опция доступна только для таблиц баз данных, открытых в режиме редактирования.

Вырезать

Очистка текущей ячейки и перенос значения из нее в буфер обмена. Опция доступна только для таблиц баз данных, открытых в режиме редактирования.

Копировать

Копирование значения из текущей ячейки в буфер обмена.

Вставить

Вставка в выделенную ячейку значения, хранящегося в буфере обмена. Опция доступна только для таблиц баз данных, открытых в режиме редактирования.

Отменить

Очистка текущей ячейки. Опция доступна только для таблиц баз данных, открытых в режиме редактирования.

Контекстное меню записей

Нажатие правой кнопки на заголовке записи (или нескольких выделенных записей) открывает контекстное меню, состоящее из следующих пунктов.

Просмотреть связанные объекты

Просмотр графических объектов текущего чертежа, связанных с выделенными записями базы данных.

Связь

Создание связи между выделенной строкой (строками) таблицы и одним или несколькими графическими объектами. В окне просмотра данных по выбранным шаблонам связи и ярлыка можно создать связь и, если необходимо, ярлык. Пользователь может указать, что именно нужно создать (связь, свободный ярлык или прикрепленный ярлык), используя расположенное здесь же подменю "Параметры связей и ярлыков".

Параметры связей и ярлыков

Здесь выбирается режим создания связей. Пользователь указывает, что именно нужно создать (связь, свободный ярлык или прикрепленный ярлык) при выборе опции "Связь!" этого же контекстного меню.

Копировать

Копирование выделенных записей в буфер обмена.

Удалить запись

Удаление выделенных записей. Опция доступна только для таблиц баз данных, открытых в режиме редактирования.

Добавить запись

Добавление в конец таблицы новой записи с пустыми значениями полей. Опция доступна только для таблиц баз данных, открытых в режиме редактирования.

Снять все пометки

Снятие пометок с выделенных записей окна просмотра данных.

Контекстное меню заголовка таблицы

Нажатие правой кнопки мыши на заголовке таблицы (серой ячейке в ее левом верхнем углу) открывает контекстное меню, состоящее из следующих пунктов.

Принять

Сохранение всех сделанных изменений в таблице БД и закрытие окна просмотра данных. Опция доступна, только если таблица базы данных была открыта в режиме редактирования и пользователь изменил что-либо в ней.

Восстановить

Отмена всех изменений, сделанных в течение сеанса, и закрытие окна просмотра данных. Опция доступна, только если таблица базы данных была открыта в режиме редактирования и пользователь изменил что-либо в ней.

Показать все столбцы

Показ всех ранее скрытых столбцов в окне просмотра данных.

Освободить все столбцы

Отмена фиксации всех столбцов; после этого они начинают перемещаться при горизонтальной прокрутке.

Снять все пометки

Снятие пометок со всех записей окна просмотра данных.

Предварительный просмотр

Открытие окна предварительного просмотра подготовленного отчета.

Печать

Вывод содержимого окна просмотра данных на системный принтер Windows.

Формат

Вызов диалогового окна "Формат", с помощью которого можно управлять представлением информации в окне просмотра данных.

Навигационная панель

Служит для быстрого пролистывания записей в окне просмотра данных. Состоит из следующих кнопок:

Первая

Переход к первой записи.

Предыдущая

Переход к предыдущей записи.

Следующая

Переход к следующей записи.

Последняя

Переход к последней записи.

Предварительный просмотр перед печатью

Загрузка в окно просмотра данных изображения, показывающего, как текущая таблица будет выглядеть в печатном виде. В этом режиме становятся не доступными все кнопки инструментов в окне просмотра данных. Навигационная панель также исчезает. Вызвать диалоговое окно можно любым из следующих способов:

Меню "Просмотр данных": "Предварительный просмотр"

Контекстное меню: Нажать правую кнопку мыши на заголовке таблицы в окне просмотра данных и выбрать "Предварительный просмотр".

Печать

Вызов системного диалогового окна "Печать".

Следующая

Вывод изображения следующей страницы таблицы базы данных.

Предыдущая

Вывод изображения предыдущей страницы таблицы базы данных.

Две страницы

Переключение между режимами показа одной и двух страниц. В режиме показа двух страниц имя кнопки заменяется на "Одна страница".

Увеличить

Увеличение изображения страницы так, чтобы можно было рассмотреть более мелкие детали.

Уменьшить

Уменьшение изображения страницы так, чтобы можно было видеть большую часть таблицы базы данных.

Закрыть

Выход из режима предварительного просмотра и восстановление таблицы в окне просмотра данных.


Редактор запросов

Б Команды
Б Команды
Редактор запросов
Понятия Процедуры Команды

Окно редактора запросов состоит из четырех вкладок, предназначенных для формирования и выполнения запросов. Если создается новый запрос, вначале появляется диалоговое окно "Новый запрос". Открыть редактор запросов можно любым из следующих способов:

Используя кнопки диспетчера подключения к БД: выбрать таблицу базы данных или шаблон связи в диспетчере подключения к БД и нажать кнопку "Новый запрос".

Использую кнопки окна просмотра данных: нажать в окне просмотра данных кнопку "Запрос" или "Возврат к запросу".

Меню "Базы данных": "Запросы" » подменю "Новый запрос к внешней таблице", "Новый запрос по шаблону связи" или "Редактировать запрос". (Отображает диалоговое окно, в котором можно сделать запрос по объекту базы данных.)

Контекстное меню: Нажать правую кнопку мыши на таблице базы данных или шаблоне связи или таблице в Диспетчере подключения к БД и выбрать "Новый запрос", или нажать правую кнопку мыши на запросе и выбрать "Изменить".

Редактор запросов содержит следующие вкладки:

  • Простой запрос
  • Запрос по интервалу
  • Формирователь
  • SQL-запросы

Темы:

  • Вкладка "Простой запрос" (Редактор запросов)
  • Вкладка "Запрос по интервалу" (редактор запросов)
  • Вкладка "Формирователь" (редактор запросов)
  • Вкладка "SQL-запрос" (редактор запросов)


Вкладка "Простой запрос" (Редактор запросов)

Б Команды
Б Команды
Вкладка "Простой запрос" (Редактор запросов)
Понятия Процедуры Команды

Позволяет формировать простейшие запросы, осуществляющие отбор записей по одному столбцу, одному значению и с использованием одного оператора.

Поле

Список столбцов текущей таблицы базы данных. Из него выбирается столбец, участвующий в запросе.

Оператор

Список операторов, которые могут быть использованы в запросах. Сведения об операторах см. в Формирование простых запросов в Руководстве пользователя.

Значение

Значение в столбце, используемое для формирования запроса.

Просмотр значений

Нажатие кнопки мыши позволяет выбрать значение из списка всех имеющихся значений в указанном столбце таблицы. Список выводится в диалоговом окне "Значения столбца", предназначенном для выбора значения.

Пометить записи в окне просмотра

Выделение цветом записей, совпадающих с критерием поиска, в окне просмотра данных.

Пометить объекты на чертеже

Выделение цветом связанных объектов, совпадающих с критерием поиска, в текущем чертеже.

Выполнить

Выполнение сформированного запроса и закрытие диалогового окна.

Закрыть

Закрытие диалогового окна без выполнения запроса.

Сохранить

Сохранение запроса в текущем чертеже.

Опции

Вызов диалогового окна "Параметры окна просмотра данных и запросов".


Вкладка "Запрос по интервалу" (редактор запросов)

Б Команды
Б Команды
Вкладка "Запрос по интервалу" (редактор запросов)
Понятия Процедуры Команды

Формирование запроса на поиск всех записей или объектов, значения которых лежат в заданном интервале.

Поле

Список столбцов текущей таблицы базы данных. Из него выбирается столбец, участвующий в запросе.

Источник

Нижняя граница интервала значений. Запрос возвращает все записи или графические объекты, значение столбца для которых больше или равно заданной границе.

Просмотр значений (От, До)

Нажатие кнопки мыши позволяет выбрать значение из списка всех имеющихся значений в указанном столбце таблицы. Список выводится в диалоговом окне "Значения столбца", предназначенном для выбора значения.

Точка

Верхняя граница интервала значений. Запрос возвращает все записи или графические объекты, значение столбца для которых меньше или равно заданной границе.

Пометить записи в окне просмотра

Выделение цветом записей, совпадающих с критерием поиска, в окне просмотра данных.

Пометить объекты на чертеже

Выделение цветом связанных объектов, совпадающих с критерием поиска, в текущем чертеже.

Выполнить

Выполнение сформированного запроса и закрытие диалогового окна.

Закрыть

Закрытие диалогового окна без выполнения запроса.

Сохранить

Сохранение запроса в текущем чертеже.

Опции

Вызов диалогового окна "Параметры окна просмотра данных и запросов".


Вкладка "Формирователь" (редактор запросов)

Б Команды
Б Команды
Вкладка "Формирователь" (редактор запросов)
Понятия Процедуры Команды

Позволяет формировать запросы с несколькими критериями. Имеется возможность группирования критериев с помощью скобок, выбора полей, отображаемых в результате, и задания порядка сортировки записей.

Рабочая область формирователя

Здесь формируется запрос по нескольким критериям.

Группирующие скобки

Используются для группирования отдельных условий запроса. Выражение может содержать не более четырех уровней вложенности. Для вставки открывающей скобки нужно нажать на ячейке, расположенной слева от той ячейки "Поле", которая должна служить началом группы условий. Для вставки закрывающей скобки нужно нажать на ячейке, расположенной справа от той ячейки "Поле", которая должна служить окончанием группы условий.

Поле

Здесь задается поле (поля) для включения в запрос. Для того, чтобы раскрыть список всех имеющихся полей, следует дважды нажать кнопку мыши на ячейке, в которую требуется вставить имя поля. Для добавления новых строк следует задать оператор и значение для текущей строки, а затем выбрать на ней ячейку "Логический".

Оператор

Здесь задается оператор для текущей строки критерия запроса. Для того, чтобы раскрыть список всех имеющихся операторов, следует дважды нажать кнопку мыши на ячейке, в которую требуется вставить оператор.

Значение

Здесь задается значение для текущей строки критерия запроса. Значение можно либо ввести непосредственно, либо выбрать в диалоговом окне "Значения столбца".

Логический

Здесь можно выбрать логический оператор: And (И) или Or (Или). Первое нажатие кнопки мыши устанавливает текущим оператор And. Повторное нажатие изменяет его на Or.

Столбцы таблицы

Список столбцов текущей таблицы базы данных. Здесь можно выбрать столбцы, которые должны отображаться в окне просмотра данных, выводимом на экран для показа результатов выполнения запроса. Если ни один столбец не выбран, по этому запросу будут показаны все столбцы таблицы базы данных. Для того чтобы добавить столбец в список отображаемых в результате, нужно либо дважды нажать на нем в списке, либо выделить его и нажать кнопку "Добавить" над списком "Показать столбцы". Имена столбцов можно перетаскивать в списки "Показать столбцы" и "Сортировка".

Показать столбцы

Столбцы, которые должны отображаться в окне просмотра данных, выводимом на экран для показа результатов выполнения запроса. Чтобы удалить какой-либо столбец из списка, нужно перетащить его в любое другое место вкладки "Формирователь".

Добавить (Показать столбцы)

Добавление имени столбца в список столбцов, которые должны отображаться в окне просмотра данных при показе результатов выполнения запроса. Для того чтобы добавить столбец в список, нужно выделить его в списке "Столбцы таблицы" и нажать "Добавить".

Сортировать по

Порядок сортировки записей, выводимых по запросу. Первый столбец в списке "Сортировка" имеет максимальный приоритет. Для того, чтобы изменить приоритет столбца при сортировке, следует перетащить его в новую позицию внутри списка. По умолчанию сортировка производится по возрастанию значений. Чтобы задать сортировку по убыванию значений какого-либо столбца, нужно либо выделить его в списке и нажать кнопку "По возрастанию/убыванию", либо дважды нажать кнопку мыши на его имени в списке. Чтобы удалить какой-либо столбец из списка, следует перетащить его в любое другое место вкладки "Формирователь" или выделить его и нажать клавишу DELETE.

Добавить (Сортировка)

Добавление столбца в список сортировки. Для того, чтобы добавить столбец в список сортировки, нужно выделить его в списке "Столбцы таблицы" и нажать "Добавить". Повторить действия для задания дополнительных условий сортировки записей.

По возрастанию/убыванию

Смена порядка сортировки для выделенного в списке столбца. Допустимые значения порядка по возрастанию и по убыванию.

Пометить записи в окне просмотра

Выделение цветом записей, совпадающих с критерием поиска, в окне просмотра данных.

Пометить объекты на чертеже

Выделение цветом связанных объектов, совпадающих с критерием поиска, в текущем чертеже.

Выполнить

Выполнение сформированного запроса и закрытие диалогового окна.

Закрыть

Закрытие диалогового окна без выполнения запроса.

Сохранить

Сохранение запроса в текущем чертеже.

Опции

Вызов диалогового окна "Параметры окна просмотра данных и запросов".


Вкладка "SQL-запрос" (редактор запросов)

Б Команды
Б Команды
Вкладка "SQL-запрос" (редактор запросов)
Понятия Процедуры Команды

Формирование запроса в соответствии с протоколом SQL 92. Вкладка "SQL-запрос" содержит специальную область для ввода и редактирования произвольных запросов на языке SQL, а также вспомогательные средства, облегчающие формирование запросов. Поскольку не все системы управления базами данных полностью совместимы со стандартом SQL 92, необходимо обратиться к системной документации и выяснить, какие SQL-команды действительны для конкретной базы данных.

Область ввода SQL-условий

Здесь формируется сам запрос. Условия могут вводиться вручную или автоматически набираться с помощью служебных средств.

Таблица

Список всех таблиц баз данных, имеющихся в текущем источнике данных. Добавить таблицу базы данных в область ввода можно, дважды нажав на ней кнопку мыши, выбрав ее и нажав "Добавить", или же путем перетаскивания. Допускается также ввод имен вручную.

Добавить (Таблица)

Добавление выделенной таблицы базы данных в область ввода SQL-условий.

Поля

Список всех столбцов выбранной таблицы базы данных. Добавить столбец в область ввода можно, дважды нажав кнопку мыши на нем, выбрав его и нажав "Добавить", или же путем перетаскивания.

Добавить (Столбцы)

Добавление выделенного столбца в область ввода SQL-условий.

Оператор

Список операторов, которые могут быть использованы в запросах.

Добавить (оператор)

Добавление выделенного оператора в область ввода SQL-условий.

Значения

Значение для выделенного столбца.

Добавить (значения)

Добавление содержимого поля "Значения" в область ввода SQL-условий.

Кнопка "..."

Нажатие кнопки позволяет выбрать значение из списка всех имеющихся значений в указанном столбце выделенной таблицы. Список выводится в диалоговом окне "Значения столбца", предназначенном для выбора значения запроса.

Пометить записи в окне просмотра

Выделение цветом записей, совпадающих с критерием поиска, в окне просмотра данных.

Пометить объекты на чертеже

Выделение цветом связанных объектов, совпадающих с критерием поиска, в текущем чертеже.

Выполнить

Выполнение сформированного запроса и закрытие диалогового окна.

Закрыть

Закрытие диалогового окна без выполнения запроса.

Сохранить

Сохранение запроса в текущем чертеже.

Проверить

Позволяет проверить запрос на соответствие правилам языка SQL без выполнения запроса. Данная функция предназначена для выявления синтаксических ошибок.

Опции

Вызов диалогового окна "Параметры окна просмотра данных и запросов".


Диалоговое окно "Значения столбца"

Б Команды
Б Команды
Диалоговое окно "Значения столбца"
Понятия Процедуры Команды

Здесь перечисляются значения выбранного столбца базы данных. Выбранное значение вставляется в поле исходного диалогового окна.

Значения столбца

Список всех значений столбца. Для переноса значения в поле исходного диалогового окна следует выбрать требуемое значение и нажать "OK". При формировании запроса с помощью оператора In можно выбирать одновременно несколько значений, удерживая при этом нажатой клавишу CTRL или SHIFT.


Диалоговое окно "Настройка источника данных"

Б Команды
Б Команды
Диалоговое окно "Настройка источника данных"
Понятия Процедуры Команды

Настройка доступа к внешней базе данных из программы. Подробная информация о настройке систем баз данных содержится Настройка внешних баз данных в руководстве по драйверам и устройствам. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Источники данных" » подменю "Настройка"

Контекстное меню: Нажать правую кнопку мыши на элементе "Источники данных" и выбрать "Настройка источника данных".

Имя источника данных

Имя источника данных OLE DB, настройка которого производится.

Источники данных

Список всех обнаруженных в системе источников данных OLE для баз данных, настроенных на работу со значком.

"OK"

Открывает диалоговое окно "Data Links Properties" Microsoft, в котором задаются параметры источника данных.


Диалоговое окно "Параметры окна просмотра данных и запросов"

Б Команды
Б Команды
Диалоговое окно "Параметры окна просмотра данных и запросов"
Понятия Процедуры Команды

Диалоговое окно предназначено для управления параметрами, относящимися к отображению связанных записей таблиц и объектов чертежа, и обработкой SQL-запросов. Вызвать диалоговое окно можно любым из следующих способов:

С помощью кнопок окна просмотра данных:

Из меню "Просмотр данных": "Параметры". (Меню "Просмотр данных" доступно, только если на экране имеется окно просмотра данных, и в нем открыта таблица БД.)

Панорамирование и зумирование

Управление отображением связанных объектов в текущем чертеже при выделении соответствующих им записей в окне просмотра данных.

Автоматическое панорамирование

Автоматическое перемещение чертежа для отображения объектов, связанных с набором записей, который выделен в окне просмотра данных.

Автоматическое зумирование

Автоматическое изменение масштаба чертежа для отображения всех объектов, связанных с текущим набором записей.

Коэффициент

Коэффициент, определяющий, какую часть (в процентах) от области рисования должен занимать выбранный набор объектов. Возможный диапазон значений лежит в пределах от 20 до 90 процентов; по умолчанию используется значение 50 процентов. Если коэффициент равен 50 процентам, то экранное увеличение подбирается таким образом, чтобы высота или ширина набора объектов (большее из этих значений) составляла 50 процентов от области рисования.

Режимы пометки записей

Управление отображением связанных записей в окне просмотра данных при выделении соответствующих им объектов в текущем чертеже.

Только записи для выбранных объектов

Отображает в окне просмотра данных только записи, связанные с выбранными объектами чертежа. Никакие другие записи в окне не видны.

Все записи, с выделением выбранных

Отображаются все записи из текущей таблицы базы данных. В окне просмотра становятся выбранными те записи, которые связаны с выбранными графическими объектами чертежа.

Помечать связанные записи

Связанные записи помечаются цветом в окне просмотра данных. Это позволяет визуально отличать их от записей, не имеющих связей.

Цвет пометки

Цвет, которым помечаются связанные записи (по умолчанию — желтый).

Параметры запросов

Параметры обработки SQL-запросов.

В формате собственного SQL

Запросы к таблицам БД генерируются в собственном формате СУБД, а не в формате SQL 92. Опция может оказаться полезной для включения в запрос команд, поддерживаемых не всеми СУБД.

Автоматическое сохранение

Автоматическое сохранение выполняемых запросов в текущем чертеже.

Режимы накопления

Управление накоплением объектов и записей в наборе.

Накапливать объекты в наборе

Добавление объектов в набор при выделении новых записей в окне просмотра данных. Если флажок сброшен, при каждом выделении записей в чертеже создается новый набор объектов.

Накапливать записи в наборе

Добавление записей в набор при выборе новых графических объектов чертежа. Если флажок сброшен, при каждом выборе набора графических объектов в окне просмотра данных создается новый набор выделенных записей.


Диалоговое окно "Экспорт связей"

Б Команды
Б Команды
Диалоговое окно "Экспорт связей"
Понятия Процедуры Команды

Диалоговое окно используется для экспорта набора связей, относящихся к выбранным графическим объектам. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Связи" » подменю "Экспорт связей"

Если к выбранным графическим объектам внешние данные подключены с помощью нескольких шаблонов связи, открывается диалоговое окно "Выбор объекта базы данных". Выбрать в нем шаблон, связи которого будут экспортироваться.

Включая поля

Задание экспортируемых полей (столбцов) таблицы базы данных. Ключевые столбцы шаблона связи выбираются автоматически. Для каждой связи также экспортируется идентификатор того объекта, который использует данную связь.

Имя файла

Имя файла, в который экспортируются связи.

Тип файла

Формат файла, в который экспортируются связи. Файл можно сохранить либо в формате исходной базы данных, либо в текстовом файле с разделением полей записи запятыми или пробелами.

Имя шаблона связи

Отображение имени шаблона связи, связи которого участвуют в экспорте.


Диалоговое окно "Экспорт набора запросов"

Б Команды
Б Команды
Диалоговое окно "Экспорт набора запросов"
Понятия Процедуры Команды

Диалоговое окно используется для экспорта набора запросов, относящихся к текущему чертежу. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Запросы" » подменю "Экспорт набора запросов"

Контекстное меню: В окне Диспетчер подключения к БД нажать правую кнопку мыши на чертеже, который имеет один или несколько запросов, и выбрать "Экспорт набора запросов".

Имя файла

Имя файла набора запросов.

Тип файла

Формат файла набора запросов. Наборы запросов всегда сохраняются с расширением ..dbq.


Диалоговое окно "Экспорт набора шаблонов"

Б Команды
Б Команды
Диалоговое окно "Экспорт набора шаблонов"
Понятия Процедуры Команды

Диалоговое окно используется для экспорта набора шаблонов связей и ярлыков, относящихся к текущему чертежу. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Шаблоны" » подменю "Экспорт набора шаблонов"

Контекстное меню: В окне Диспетчер подключения к БД нажать правую кнопку на чертеже, который имеет один или несколько шаблонов, и выбрать "Экспорт набора шаблонов".

Имя файла

Имя файла набора шаблонов.

Тип файла

Формат файла набора шаблонов. Наборы шаблонов всегда сохраняются с расширением .dbt.


Диалоговое окно "Поиск файлов"

Б Команды
Б Команды
Диалоговое окно "Поиск файлов"
Понятия Процедуры Команды

С помощью диалогового окна "Замена" осуществляется поиск указанного текстового или числового значения в таблице, загруженной в окно просмотра данных. Поиск ограничен только одним столбцом таблицы. Глобальный поиск по всей таблице невозможен. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Просмотр данных": "Найти". (Меню "Просмотр данных" доступно, только если на экране имеется окно просмотра данных, и в нем открыта таблица БД.)

Контекстное меню: Нажать правую кнопку мыши на заголовке столбца или на отдельной ячейке в окне просмотра данных и выбрать "Найти".

Что искать

Значение для поиска.

С учетом регистра

Поиск значения, в точности как оно было введено в поле "Образец". Если флажок сброшен, программа выполняет поиск значения, набранного в любом регистре.

Найти далее

Поиск следующего вхождения значения, поиск которого осуществляет пользователь.

Направление

Переключение направления, в котором программа производит поиск заданного значения в окне просмотра данных.


Диалоговое окно "Формат"

Б Команды
Б Команды
Диалоговое окно "Формат"
Понятия Процедуры Команды

Управление параметрами отображения записей таблицы в окне просмотра данных. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Просмотр данных": "Формат". (Меню "Просмотр данных" доступно, только если на экране имеется окно просмотра данных, и в нем открыта таблица БД.)

Контекстное меню: Нажать правую кнопку мыши на заголовке таблицы в окне просмотра данных и выбрать "Формат".

Шрифт

Шрифт, которым отображаются записи в текущей таблице.

Начертание

Начертание для текущего шрифта. Возможные варианты "Обычный", "Курсив", "Полужирный", "Полужирный курсив", "Не полужирный" и "Не курсив".

Размер

Размер шрифта (в пунктах), которым отображаются записи в текущей таблице.

Эффекты

Дополнительные опции форматирования записей в окне просмотра данных. Опция "Зачеркнутый" добавляет в ячейки линию, делящую их пополам горизонтально. Опция "Подчеркнутый"вызывает подчеркивание всех данных в ячейках.

Цвет текста

Цвет, которым отображаются записи в текущей таблице.

Образец

Здесь показан примерный вид данных в таблице после применения текущего форматирования.


Диалоговое окно "Импорт набора запросов"

Б Команды
Б Команды
Диалоговое окно "Импорт набора запросов"
Понятия Процедуры Команды

Импорт набора запросов в текущий чертеж. Если имя импортируемого запроса совпадает с именем одного из уже имеющихся в текущем чертеже запросов, появляется окно предупреждения, в котором запросу можно присвоить другое имя. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Запросы" » подменю "Импорт набора запросов"

Контекстное меню: Нажать правую кнопку мыши на имени чертежа в окне Диспетчер подключения к БД и выбрать "Импорт набора запросов".

Папка

Папка, в которой находится набор запросов.

Имя файла

Имя импортируемого файла набора запросов.

Тип файла

Задает расширение файла для импортируемого набора запросов. Наборы запросов всегда имеют расширение .dbq.


Диалоговое окно "Импорт набора шаблонов"

Б Команды
Б Команды
Диалоговое окно "Импорт набора шаблонов"
Понятия Процедуры Команды

Диалоговое окно используется для импорта набора шаблонов связей и ярлыков в текущий чертеж. Если имя импортируемого шаблона связи или ярлыка совпадает с именем одного из уже имеющихся в текущем чертеже шаблонов, вызывается окно, в котором шаблону можно присвоить другое имя. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Шаблоны" » подменю "Импорт набора шаблонов"

Контекстное меню: Нажать правую кнопку мыши на имени чертежа в окне Диспетчер подключения к БД и выбрать "Импорт набора шаблонов".

Папка

Папка, в которой находится набор шаблонов.

Имя файла

Имя импортируемого файла набора шаблонов.

Тип файла

Задает расширение файла для импортируемого набора шаблонов. Наборы шаблонов всегда имеют расширение .dbt.


Диалоговое окно "Шаблон ярлыка"

Б Команды
Б Команды
Диалоговое окно "Шаблон ярлыка"
Понятия Процедуры Команды

Здесь задается форматирование для ярлыков.

Перед открытием окна "Шаблон ярлыка" появляется диалоговое окно "Новый шаблон ярлыка", в котором шаблону ярлыка можно присвоить имя. Вызвать диалоговое окно можно любым из следующих способов:

С помощью кнопок диспетчера подключения к БД: выбрать таблицу базы данных, шаблон связи или шаблон ярлыка и нажать кнопку "Новый шаблон ярлыка". Если был выбран шаблон ярлыка, программа открывает диалоговое окно "Шаблон ярлыка" без предварительного вызова окна "Новый шаблон ярлыка".

С помощью кнопок окна просмотра данных: выбрать из списка "Выбор шаблона ярлыка" значение "Новый шаблон ярлыка", а затем установить в меню "Параметры связей и ярлыков" текущим один из пунктов "Создавать свободные ярлыки" или "Создавать прикрепленные ярлыки". Если для выбранной таблицы базы данных в текущем чертеже не определен шаблон связи, открывается диалоговое окно "Новый шаблон связи"

Из меню "Базы данных": "Шаблоны" » подменю "Новый шаблон ярлыка". Выбрать шаблон связи в диалоговом окне "Выбор объекта базы данных", а затем нажать кнопку "Далее".

Контекстное меню: Нажать правую кнопку мыши на шаблоне связи или таблице базы данных в окне Диспетчера подключения к БД и выбрать "Новый шаблон ярлыка".

Устройство указания: Дважды нажать кнопку мыши на шаблоне ярлыка в "Диспетчере подключения к БД". В этом случае диалоговое окно "Шаблон ярлыка" открывается сразу же, без предварительного вызова окна "Новый шаблон ярлыка".

Вкладка "Символы"

Управление форматированием символов вводимого с клавиатуры или импортируемого текста.

Шрифт

Задание шрифта для нового текста или изменение шрифта выделенного фрагмента.

Высота

Задание высоты символов или ее изменение для выделенного фрагмента текста. Высота задается в единицах чертежа. Принятое по умолчанию значение основано на текущем стиле текста. Если высота символов не определена в выбранном текстовом стиле, ее значение хранится в системной переменной TEXTSIZE.

Полужирный

Включает и отключает полужирное начертание для нового или выделенного текста. Опция доступна только для символов, использующих шрифты TrueType.

Курсив

Включает и отключает курсивное начертание для нового или выделенного текста. Опция доступна только для символов, использующих шрифты TrueType.

Подчеркивание

Включает и отключает подчеркивание для нового или выделенного текста.

Отменить

Отмена действий, в том числе отмена изменений, внесенных в содержание или в формат текста. Можно также использовать комбинацию клавиш CTRL+Z.

Повтор

Повторное выполнение действий, в том числе изменений, внесенных в содержание или в формат текста. Можно также использовать комбинацию клавиш CTRL+Y.

Создать дробный текст, преобразовать дробный текст в обычный

Для создания дробного текста необходимо выделить фрагмент текста, содержащий специальные символы. Если был выделен дробный текст, нажатие кнопки превращает его в обычный. Специальными символами являются символы крышки (^), обычной косой черты (/) или решетки (#). При преобразовании обычного текста в дробный, все что, расположено слева от специальных символов, выводится над текстом, расположенном справа от них.

Тексты, содержащие символ крышки (^), преобразуются в выровненные по левому краю значения допусков. Тексты, содержащие символ обычной косой черты (/), преобразуются в выровненные по центру дроби с горизонтальным разделителем, длина которого определяется длиной наибольшей из выводимых друг над другом строк. Тексты, содержащие символ решетки (#), преобразуются в числовые дроби, с диагональным разделителем, длина которого зависит от высоты обеих разделяемых строк. Текст над диагональной чертой выравнивается вниз и вправо; под чертой — вверх и влево.

Цвет текста

Задание цвета для нового текста или изменение цвета выделенного фрагмента.

Пользователь может присваивать тексту цвет, заданный для слоя, на котором он расположен (ПОСЛОЮ), или присваивать тексту цвет блока, в который он входит (ПОБЛОКУ). Можно также выбрать один из цветов из списка цветов или нажать кнопку "Другой" и открыть диалоговое окно "Выбор цвета".

Символ

Вставка символа или неразрывного пробела в текущую позицию курсора. Символ можно также вставить вручную. Края граней, расположенных под большим углом, не сглаживаются. См. раздел Символы и специальные знаки.

Список обычно используемых символов содержится в подменю. Выбрать другой символ можно в окне "Таблица символов", которое открывается при выборе пункта "Другой" из этого подменю. В этом окне следует нажать кнопку мыши на символе, а затем нажать кнопку "Выбрать". Символ вставляется в поле "Для копирования". Выбрав для копирования все требуемые символы, нажать кнопку "Копировать" и закрыть диалоговое окно. В диалоговом окне "Шаблон ярлыка" нажать правую кнопку мыши и выбрать "Вставить".

Символ евро можно использовать со шрифтами SHX и их эквивалентами TrueType, поставляемыми вместе с AutoCAD 2000 и более поздними версиями. Если на клавиатуре нет символа евро, его можно ввести так: удерживая клавишу ALT, набрать на цифровой клавиатуре последовательность цифр 0128.

В вертикальном тексте символы не поддерживаются.

Примечание В данном диалоговом окне символ диаметра отображается в виде %%c, но в ярлыке этот символ отображается корректно. Неразрывный пробел не используется в двухбайтовых операционных системах.

Вкладка "Свойства"

Здесь осуществляется управление свойствами, которые относятся к шаблону ярлыка в целом.

Стиль

Применение в данном ярлыке какого-либо стиля текста. Текущий стиль сохраняется в системной переменной TEXTSTYLE. При применении нового стиля к существующему шаблону ярлыка исходный формат его символов (шрифт, высота и начертание) изменяется в соответствии с новым стилем. Дробность, подчеркивание и цвет сохраняются для тех символов, к которым применяется новый стиль. Применение стилей, обладающих эффектом начертания справа налево или эффектом перевернутого текста, не производится. Если стиль, для которого задано вертикальное начертание, применяется к шрифту SHX, то текст в диалоговом окне "Шаблон ярлыка" отображается горизонтально.

Выравнивание

Установка режима расположения и выравнивания для данного ярлыка. По умолчанию используется выравнивание "Вверх-влево". При выравнивании абзаца и разбиении его на строки учитываются все пробелы. В горизонтальном направлении текст может центрироваться, либо выравниваться влево или вправо. По вертикали текст может выравниваться по середине, вверх или вниз. См. описание всех девяти видов выравнивания в разделе Командная строка МТЕКСТ.

Ширина

Установка параметра ширины абзаца для нового или выбранного текста. Опция "Без перехода на новую строку" предназначена для создания одиночной строки. Эта опция не влияет на ширину отдельных символов.

Поворот

Определение для данного ярлыка угла поворота, выраженного в текущих единицах измерения углов (градусы, радианы или градиенты).

Вкладка "Найти/Заменить"

Поиск по шаблону ярлыка заданных строк символов и замена их новым текстом.

Найти

Задание строки символов для поиска в тексте.

Кнопка "Найти"

Запуск функции поиска строки символов в окне "Найти". Для продолжения поиска следует повторно нажать кнопку "Найти".

Чем заменить

В данном поле вводится строка для замены текста, заданного для поиска в поле "Что искать".

Кнопка "Заменить"

Заменяет выделенный текст на текст, введенный в поле "Чем заменить".

С учетом регистра

Поиск текста с учетом только полного совпадения регистра всех символов заданной в окне "Найти" строки и символов обнаруженного в тексте вхождения этой строки. Если флажок не установлен, выполняется поиск совпадения для указанных текстовых строк без учета регистра.

Слово целиком

Поиск заданной строки, представляющей собой самостоятельное слово, то есть отделенное от других слов пробелами или знаками препинания. Фрагменты, являющиеся частью более длинных слов, пропускаются. Если флажок не установлен, для текстовых строк выполняется поиск совпадения независимо от того, является оно отдельным словом или частью другого слова.

Вкладка "Столбцы для ярлыков"

Здесь указывают, значения каких столбцов таблицы базы данных должны включаться в ярлыки, создаваемые по данному шаблону.

Поле

Список столбцов текущей таблицы БД, доступных для включения в ярлык. Количество включаемых столбцов не ограничено.

Добавить

Добавление в ярлык столбца, текущего в списке "Столбцы".

Таблица

Имя текущей таблицы базы данных.

Вкладка "Смещение ярлыка"

Здесь задаются смещения координат X и Y точки вставки ярлыка и (если это прикрепленный ярлык) полки принадлежащей ему выноски.

Начало

Задает начальную точку объекта-выноски. Положение точки определяется относительно границ графического объекта, к которому прикрепляется ярлык. Опция "Начало" не оказывает влияния на свободные ярлыки, т.к. они не имеют выносок.

Смещение полки

Задает смещение полки и надписи ярлыка по координатам X и Y относительно начала выноски. По умолчанию смещение полки по X и Y устанавливается равным 1, что задает смещение надписи ярлыка относительно начала выноски (стрелки) на одну единицу чертежа по каждой из координат. Опция "Смещение полки" применяется только для прикрепленных ярлыков.

Смещение выноски

Смещение начала выноски (или текста) для прикрепленных и свободных ярлыков. Для прикрепленных ярлыков здесь задается смещение выноски по координатам X и Y относительно точки, определяемой опцией "Начало". Для свободных ярлыков здесь задается смещение ярлыка от заданной пользователем точки вставки.


Диалоговое окно "Свойства шаблона ярлыка"

Б Команды
Б Команды
Диалоговое окно "Свойства шаблона ярлыка"
Понятия Процедуры Команды

Здесь отображается полный путь к источнику данных для таблицы базы данных, к которой относится ярлык шаблона. Это диалоговое окно используется для обновления ярлыков при перемещении источников данных.

Перед открытием окна "Свойства шаблона ярлыка" появляется диалоговое окно "Выбор объекта базы данных", в котором можно выбрать новый шаблон ярлыка.

Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Шаблоны" » подменю "Свойства шаблона ярлыка"

Имя шаблона

Имя выбранного шаблона ярлыка.

Источник данных

Имя источника данных, к которому относится выбранный шаблон ярлыка. Пользователь может изменить источник данных, выбрав новое имя из списка.

Каталог

Имя каталога, к которому относится выбранный шаблон ярлыка. Пользователь может изменить каталог, выбрав новое имя из списка.

Схема

Имя схемы, к которой относится выбранный шаблон ярлыка. Пользователь может изменить схему, выбрав новое имя из списка.

Таблица

Имя таблицы базы данных, к которой относится выбранный шаблон ярлыка. Пользователь может сменить таблицу базы данных, выбрав новое имя из списка.

Поля

Имена столбцов, к которым относится выбранный шаблон ярлыка.


Диалоговое окно "Преобразование связей"

Б Команды
Б Команды
Диалоговое окно "Преобразование связей"
Понятия Процедуры Команды

Окно применяется для преобразования связей с БД из формата AutoCAD Release 12, Release 13 и Release 14 в формат AutoCAD 2000 (и более новых версий). Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Преобразование связей"

Формат связей прежних версий значительно отличается от принятого в AutoCAD 2000 и в более поздних версиях, поэтому для преобразования связей необходимо, чтобы сам пользователь задал соответствие прежних значений связей AutoCAD SQL Extension™ (ASE) новым значениям, используемым в системе AutoCAD 2000 и более поздних версиях. Так, например, необходимо указать среду, которая использовалась для связи в Release 14 и соответствующий источник данных, который применяется вместо этой среды в AutoCAD 2000 (и позднее). Аналогичные действия нужно произвести и для других составных элементов связей, которыми необходимо заменить прежние значения ASE.

Формат связи

Формат связей, подлежащих преобразованию. В зависимости от выбранного формата (R12 или R13/R14), в диалоговом окне предлагается различный набор полей.

R12

Задает параметры преобразования связей R12.

R13/R14

Задает параметры преобразования связей R13 и R14.

Прежний формат связи (R12)

Задает путь к таблице БД, которую использует связь, подлежащая преобразованию.

СУБД

Определяет систему управления базами данных, которая используется подлежащей преобразованию связью.

База данных

Определяет базу данных, которая используется подлежащей преобразованию связью.

Таблица

Определяет таблицу базы данных, которую использует подлежащая преобразованию связь.

Прежний формат связи (R13/R14)

Задает путь к таблице БД, которую использует связь, подлежащая преобразованию.

Среда

Определяет среду, которую использует подлежащая преобразованию связь.

Каталог

Определяет каталог, который используется подлежащей преобразованию связью.

Схема

Определяет схему, которую использует подлежащая преобразованию связь.

Таблица

Определяет таблицу базы данных, которую использует подлежащая преобразованию связь.

Имя маршрута связи

Определяет имя траектории связи, используемое подлежащей преобразованию связью.

Новый формат связи

Путь к таблице БД, который должен действовать после преобразования связей.

Источник данных

Список доступных источников данных для преобразованных связей.

Каталог

Список доступных каталогов для преобразованных связей.

Схема

Список доступных схем для преобразованных связей.

Таблица

Список доступных таблиц базы данных для преобразованных связей.

Шаблон связи

Список доступных шаблонов связей для преобразованных связей.

"OK"

Запись параметров преобразования в файл asi.ini и закрытие диалогового окна.

Применить

Запись параметров преобразования в файл asi.ini. Диалоговое окно остается открытым, и в нем можно перейти к заданию параметров для других связей.

Отмена

Закрытие диалогового окна без преобразования связей.


Диспетчер связей

Б Команды
Б Команды
Диспетчер связей
Понятия Процедуры Команды

Диспетчер позволяет редактировать значения в ключевых полях для выбранного связанного объекта. Открыть "Диспетчер связей" можно любым из следующих способов:

Из меню "Базы данных": "Связи" » подменю "Диспетчер связей". Выбрать графический объект, имеющий связь с записью из БД.

Контекстное меню: Выбрать связанный графический объект и нажать на нем правую кнопку мыши, затем выбрать "Связь" » подменю "Диспетчер связей".

Шаблоны связи

Список всех шаблонов, относящихся к выбранному графическому объекту. Из него следует выбрать шаблон, ключевое значение которого будет редактироваться.

Ключ

Ключевые столбцы выбранного шаблона связи.

Значение

Все значения ключевых столбцов для выбранной связи. Для того чтобы получить список всех возможных значений каждого столбца, следует нажать на ячейке и нажать кнопку [...].

Удалить

Удаление выбранной связи из графического объекта, с которым эта связь ассоциирована.


Диалоговое окно "Выбор по связи"

Б Команды
Б Команды
Диалоговое окно "Выбор по связи"
Понятия Процедуры Команды

Позволяет итеративно создавать наборы графических объектов и записей базы данных. Диалоговое окно "Выбор по связи" (в предыдущих версиях его функции выполняло окно "ASE Select") является модификацией редактора запросов. Операция выбора по связи начинается с создания исходного запроса или набора графических объектов (набора A), который затем подвергается воздействию дополнительного запроса или набора графических объектов (набора B). Результатом операции является текущий набор объектов (набор A); выполняя дополнительные запросы и вовлекая новые наборы, можно далее уточнять текущий набор.

Для того чтобы выполнить выбор по связи, необходимо открыть чертеж, имеющий связи с таблицей. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Связи" » подменю "Выбор по связи"

Контекстное меню: Нажать правую кнопку мыши на шаблоне связи в окне Диспетчер подключения к БД и выбрать "Выбор по связи".

Диалоговое окно "Выбор по связи" содержит вкладки "Простой запрос", "Запрос по интервалу" и "Формирователь", аналогичные имеющимся в диалоговом окне Редактор запросов, а также несколько дополнительных элементов.

Do

Оператор выбора по связи, применяемый к текущему запросу или набору. Доступны следующие операторы: "Выбрать", "Объединение", "Пересечение", "Вычесть A-B", "Вычесть B-A".

Выбрать

Создает исходный запрос или набор объектов. Полученный таким образом набор можно уточнять с помощью повторного выполнения операций выбора по связи.

Объединение

Добавляет в исходный набор объектов результат выполнения дополнительного запроса или повторного выбора объектов. Данная операция возвращает все записи или объекты, находящиеся в наборах А или В.

Пересечение

Возвращает пересечение исходного набора с результатом выполнения дополнительного запроса или повторного выбора объектов. Данная операция возвращает только те записи или объекты, которые имеются одновременно в наборах А и В.

Вычесть A-B

Вычитает из текущего набора результат выполнения дополнительного запроса или повторного выбора объектов.

Вычесть B-A

Вычитает из результата выполнения дополнительного запроса или повторного выбора объектов текущий набор.

Шаблон

Список шаблонов связи, которые можно использовать с текущим набором объектов.

По запросу

Позволяет сформировать запрос, результат выполнения которого затем передается в функцию выбора по связи.

Выбрать на чертеже

Режим ручного создания набора на чертеже. Диалоговое окно временно закрывается по нажатию кнопки "Выбрать" и появляется вновь после того, как выбор объектов будет завершен.

Выполнить/Выбрать

Выполнение текущего запроса "Выбор по связи" или временное закрытие диалогового окна "Выбор по связи" для выбора графических объектов чертежа. Если активна опция "По запросу", кнопка носит название "Выполнить". Если активна опция "Выбрать на чертеже", кнопка носит название "Выбрать". После того, как выполнен запрос или выбраны объекты, можно формировать новые запросы и выбирать новые объекты, уточняя содержимое текущего набора.

Диаграмма операции

Графическая иллюстрация логической операции, выбранной из списка "Операция".

Сброс

Очистка полей диалогового окна "Выбор по связи" и отмена всех ранее произведенных в нем действий. Позволяет начать операцию выбора по связи с самого начала.

Отмена

Закрытие диалогового окна и отмена всех произведенных в нем действий.

Готово

Завершение операции выбора по связи и закрытие диалогового окна. Возвращается либо набор графических объектов, либо подмножество записей окна просмотра данных, либо и то и другое (в зависимости от установленных параметров операции выбора по связи).

Зона состояния

Здесь отображается статусная информация о текущей операции выбора по связи. Выводятся имена текущего чертежа и таблицы, количество объектов и записей, удовлетворяющих заданным критериям.


Диалоговое окно "Шаблон связи"

Б Команды
Б Команды
Диалоговое окно "Шаблон связи"
Понятия Процедуры Команды

Здесь задаются ключевые столбцы, используемые шаблоном связи.

Перед открытием окна "Шаблон связи" появляется диалоговое окно "Новый шаблон связи", в котором шаблону связи можно присвоить имя. Вызвать диалоговое окно можно любым из следующих способов:

С помощью кнопок диспетчера подключения к БД: выбрать таблицу базы данных и нажать кнопку "Новый шаблон связи".

С помощью кнопок окна просмотра данных: выбрать из списка "Выбор шаблона связи" значение "Новый шаблон связи", а затем нажать кнопку "Связь!".

Из меню "Базы данных": "Шаблоны" » подменю "Новый шаблон связи". Выбрать таблицу базы данных в диалоговом окне "Выбор объекта базы данных", а затем нажать кнопку "Далее".

Контекстное меню: Нажать правую кнопку мыши на таблице базы данных в диспетчере подключения к БД и выбрать "Новый шаблон связи".

Устройство указания: Дважды нажать на шаблоне связи в диспетчере подключения к БД. В этом случае диалоговое окно "Шаблон связи" открывается сразу же, без предварительного вызова окна "Новый шаблон связи".

Имя шаблона

Имя шаблона связи.

Таблица

Текущая таблица базы данных. В первой строке записывается имя таблицы, во второй - полный путь к источнику данных в формате: среда.каталог.схема.таблица

Ключевые столбцы

В списке перечислены все столбцы текущей таблицы базы данных, их типы и (для строковых) длины. Для того чтобы сделать столбец шаблона связи ключевым, необходимо установить пометку в квадрате слева от его имени.


Диалоговое окно "Свойства шаблона связи"

Б Команды
Б Команды
Диалоговое окно "Свойства шаблона связи"
Понятия Процедуры Команды

Здесь отображается полный путь к источнику данных в таблице, к которой относится шаблон связи. Это диалоговое окно используется для обновления шаблонов связи при перемещении источников данных.

Перед открытием окна "Свойства шаблона связи" появляется диалоговое окно "Выбор объекта базы данных", в котором можно выбрать шаблон связи.

Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Шаблоны" » подменю "Свойства шаблона связи"

Имя шаблона

Имя выбранного шаблона связи.

Источник данных

Имя источника данных, к которому относится выбранный шаблон связи. Пользователь может изменить источник данных, выбрав новое имя из списка.

Каталог

Имя каталога, к которому относится выбранный шаблон связи. Пользователь может изменить каталог, выбрав новое имя из списка.

Схема

Имя схемы, к которой относится выбранный шаблон связи. Пользователь может изменить схему, выбрав новое имя из списка.

Таблица

Имя таблицы базы данных, к которой относится выбранный шаблон связи. Пользователь может изменить таблицу, выбрав новое имя из списка.

Ключи

Имена ключевых столбцов, к которым относится выбранный шаблон связи.


Диалоговое окно "Новый шаблон ярлыка"

Б Команды
Б Команды
Диалоговое окно "Новый шаблон ярлыка"
Понятия Процедуры Команды

Создание нового шаблона ярлыка. Вызвать диалоговое окно можно любым из следующих способов:

С помощью кнопок диспетчера подключения к БД: выбрать таблицу базы данных и нажать кнопку "Новый шаблон ярлыка".

С помощью кнопок окна просмотра данных: выбрать из списка "Выбор шаблона ярлыка" значение "Новый шаблон ярлыка", а затем установить в меню "Параметры связей и ярлыков" текущим один из пунктов "Создавать свободные ярлыки" или "Создавать прикрепленные ярлыки". Если для выбранной таблицы базы данных в текущем чертеже не определен шаблон связи, открывается диалоговое окно "Новый шаблон связи"

Из меню "Базы данных": "Шаблоны" » подменю "Новый шаблон ярлыка". Выбрать шаблон связи в диалоговом окне "Выбор объекта базы данных", а затем нажать кнопку "Далее".

Контекстное меню: Нажать правую кнопку мыши на таблице базы данных в диспетчере подключения к БД и выбрать "Новый шаблон ярлыка".

После того, как пользователь задал имя шаблона и нажал кнопку "Далее", открывается диалоговое окно "Шаблон ярлыка". В нем задаются поля ярлыка и их форматирование.

Имя нового шаблона ярлыка

Имя шаблона ярлыка.

На основе шаблона

Список шаблонов ярлыков, имеющихся в текущем чертеже. Выбранный из этого списка шаблон становится основой для создания нового шаблона.


Диалоговое окно "Новый шаблон связи"

Б Команды
Б Команды
Диалоговое окно "Новый шаблон связи"
Понятия Процедуры Команды

Диалоговое окно используется для создания нового шаблона связи. Вызвать диалоговое окно можно любым из следующих способов:

С помощью кнопок диспетчера подключения к БД: выбрать таблицу базы данных и нажать кнопку "Новый шаблон связи".

С помощью кнопок окна просмотра данных: выбрать из списка "Выбор шаблона связи" значение "Новый шаблон связи", а затем нажать кнопку "Связь!".

Из меню "Базы данных": "Шаблоны" » подменю "Новый шаблон связи". Выбрать таблицу базы данных в диалоговом окне "Выбор объекта данных" и нажать кнопку "Далее".

Контекстное меню: Нажать правую кнопку мыши на таблице в диспетчере подключения к БД и выбрать "Новый шаблон связи".

После того как пользователь задал имя шаблона и нажал кнопку "Далее", открывается диалоговое окно "Шаблон связи". В нем задаются ключевые столбцы для связи.

Имя нового шаблона связи

Имя шаблона связи.

На основе шаблона

Список шаблонов связи, имеющихся в текущем чертеже. Выбранный из этого списка шаблон становится основой для создания нового шаблона.


Диалоговое окно "Новый запрос"

Б Команды
Б Команды
Диалоговое окно "Новый запрос"
Понятия Процедуры Команды

Окно используется для создания нового запроса и вызова редактора запросов. Вызвать диалоговое окно можно любым из следующих способов:

С помощью кнопок диспетчера подключения к БД: выбрать шаблон связи, таблицу базы данных или существующий запрос и нажать кнопку "Новый запрос".

Из меню "Базы данных": "Запросы" » подменю "Новый запрос к внешней таблице" или "Новый запрос по шаблону связи". (Открывается диалоговое окно, в котором можно выбрать объект базы данных для выполнения запроса.)

Контекстное меню: Нажать правую кнопку мыши на шаблоне связи, таблице базы данных или существующем запросе в диспетчере подключения к БД и выбрать "Новый запрос".

После того как пользователь задал имя шаблона и нажал кнопку "Далее", открывается диалоговое окно Редактор запросов. В нем задаются параметры запроса.

Запрос записей в таблице

Предназначенное только для чтения поле, которое указывает на таблицу, являющуюся объектом запроса.

Имя нового запроса

Задается имя запроса.

Имеющиеся запросы

Список всех запросов, имеющихся в текущем чертеже.


Диалоговое окно "Замена"

Б Команды
Б Команды
Диалоговое окно "Замена"
Понятия Процедуры Команды

С помощью диалогового окна "Замена" осуществляется поиск указанного текстового или числового значения в таблице, загруженной в окно просмотра данных. Пользователь может задать значение, на которое будет заменено найденное. Поиск ограничен только одним столбцом таблицы базы данных. Глобальный поиск по всей таблице базы данных невозможен. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Просмотр данных": "Заменить". (Это меню доступно, только если на экране имеется окно просмотра данных, и в нем открыта таблица БД.)

Контекстное меню: Нажать правую кнопку на заголовке столбца или на отдельной ячейке в окне просмотра данных и выбрать "Заменить".

Что искать

Значение для поиска.

Чем заменить

Задает значение, на которое будет заменено найденное.

С учетом регистра

Поиск значения, в точности как оно было введено в поле "Образец". Если флажок сброшен, программа выполняет поиск значения, набранного в любом регистре.

Найти далее

Поиск следующего вхождения значения, поиск которого осуществляет пользователь.

Заменить

Замена следующего вхождения искомого значения на то, которое задано в поле "Заменить на".

Заменить все

Замена всех вхождений искомого значения на значение, заданное в поле "Заменить на".


Диалоговое окно "Выбор объекта базы данных"

Б Команды
Б Команды
Диалоговое окно "Выбор объекта базы данных"
Понятия Процедуры Команды

В окне выводится список объектов баз данных (шаблонов связей, шаблонов ярлыков и запросов), относящихся к текущему чертежу. Из списка необходимо выбрать объект, над которым выполняется операция. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Шаблоны" » подменю "Новый шаблон ярлыка", "Редактировать шаблон связи", "Редактировать шаблон ярлыка", "Удалить шаблон связи" или "Удалить шаблон ярлыка"; "Запросы" » подменю "Выполнить запрос", "Новый запрос по шаблону связи", "Редактировать запрос" или "Удалить запрос"; "Связи" » подменю "Удалить связи"; "Ярлыки" » подменю "Обновить ярлыки", "Показать ярлыки", "Скрыть ярлыки" или "Удалить ярлыки"; "Просмотр данных" » подменю "Просмотреть связанную таблицу", "Редактировать связанную таблицу"

Список объектов базы данных

Здесь представлены относящиеся к текущему чертежу объекты базы данных. Из списка необходимо выбрать объект, над которым выполняется операция.

OK/Далее

Либо завершение текущей операции, либо вызов следующего диалогового окна для ее продолжения.

Если, например, выполняется создание нового шаблона ярлыка, вызывается диалоговое окно "Новый шаблон ярлыка".


Диалоговое окно "Выбор объекта данных"

Б Команды
Б Команды
Диалоговое окно "Выбор объекта данных"
Понятия Процедуры Команды

Окно отображает ветвь "Источники данных" окна Диспетчер подключения к БД, в которой можно выбрать таблицу базы данных для обработки в текущей операции. Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Источники данных" » подменю "Установить связь"; "Шаблоны" » подменю "Новый шаблон связи"; "Запросы" » подменю "Новый запрос к внешней таблице"; "Просмотр данных" » подменю "Просмотреть внешнюю таблицу" или "Редактировать внешнюю таблицу"

Зона структуры

Здесь перечисляются все доступные источники данных. Из них следует выбрать таблицу базы данных для обработки в текущей операции.

OK/Далее

Либо завершение текущей операции, либо вызов следующего диалогового окна для ее продолжения.

Если, например, выполняется создание нового шаблона связи, вызывается диалоговое окно "Новый шаблон связи".


Диалоговое окно "Сортировка"

Б Команды
Б Команды
Диалоговое окно "Сортировка"
Понятия Процедуры Команды

Здесь задается порядок сортировки записей таблицы базы данных, открытой в окне просмотра данных. В качестве критериев сортировки можно задавать до пяти столбцов таблицы. Вызвать диалоговое окно можно любым из следующих способов:

Контекстное меню: Нажать правую кнопку мыши на заголовке столбца окна просмотра данных и выбрать "Сортировка".

Сортировать по

Главный столбец, по которому выполняется сортировка. При одинаковых значениях в этом столбце порядок сортировки определяется значениями в дополнительных столбцах (выбранных из списков "Затем по").

По возрастанию

Сортировка по возрастанию значений в выбранном столбце. Записи с наименьшими значениями располагаются в начале отсортированной таблицы; с наибольшими значениями — в конце.

По убыванию

Сортировка по убыванию значений в выбранном столбце. Записи с наибольшими значениями располагаются в начале отсортированной таблицы; с наименьшими значениями — в конце.

Затем по

Дополнительные столбцы, по которым выполняется сортировка.

Сброс

Очистка всех критериев сортировки (используется для перехода к созданию порядка сортировки с самого начала).


Диалоговое окно "Синхронизация"

Б Команды
Б Команды
Диалоговое окно "Синхронизация"
Понятия Процедуры Команды

В этом окне обновляются нарушенные связи, обнаруженные программой. Связи могут нарушиться из-за модификаций структуры исходных таблиц базы данных, а также при перемещении таблицы в другое положение на диске. В таких случаях структура шаблона связи, использованная при создании связей, оказывается недействительной. Шаблоны и все опирающиеся на них связи нуждаются в обновлении.

В диалоговом окне "Синхронизация" выводится список обнаруженных ошибок. Определенные типы ошибок (например изменение формата столбца в таблице базы данных) можно исправить непосредственно с помощью диалогового окна "Синхронизация". Некоторые типы ошибок (например подключение к несуществующей записи) следует исправлять в самой таблице базы данных.

Вызвать диалоговое окно можно любым из следующих способов:

Из меню "Базы данных": "Синхронизация"

Контекстное меню: Нажать правую кнопку мыши на шаблоне связи в окне Диспетчер подключения к БД и выбрать "Синхронизация".

Только ошибки

Список обнаруженных ошибок. Здесь пользователь может выбрать ошибку для исправления.

Описание

Краткое описание ошибки, выбранной в списке "Ошибки".

Исправить

Исправление выбранной ошибки.

Удалить

Удаление некорректного шаблона связи и всех созданных на его основе связей из текущего чертежа.

Закрыть

Закрытие диалогового окна.

Выделить объекты чертежа

Выбор на чертеже всех объектов, к которым относится некорректный шаблон связи.


БДСПИСОК Команда

Б Команды
Б Команды
БДСПИСОК Команда
Понятия Процедуры Команды

Вывод на экран информации из базы данных для всех объектов чертежа

Ввод команды: бдсписок

В текстовое окно выводится информация о каждом из объектов текущего чертежа. Полностью заполнив окно информацией, программа делает паузу. Для возобновления вывода нажать клавишу ENTER, для отмены - клавишу ESC.


БЕЗОПНАСТР Команда

Б Команды
Б Команды
БЕЗОПНАСТР Команда
Понятия Процедуры Команды

Задание параметров безопасности в диалоговом окне "Параметры безопасности"

Ввод команды: безопнастр

Открывается диалоговое окно "Параметры безопасности". В этом окне можно задать параметры безопасности, которые будут применяться при сохранении чертежа.

Темы:

  • Диалоговое окно "Параметры безопасности"
  • Диалоговое окно "Подтверждение пароля"
  • Диалоговое окно "Дополнительные параметры"


Диалоговое окно "Параметры безопасности"

Б Команды
Б Команды
Диалоговое окно "Параметры безопасности"
Понятия Процедуры Команды

Ввод команды: безопнастр

Задание параметров безопасности, которые будут применяться при сохранении чертежа.

Вкладка "Пароль" (диалоговое окно "Параметры безопасности")

Задание пароля для открытия чертежа. Пароль вступает в силу при сохранении чертежа.

Для открытия этого чертежа необходимо ввести пароль (слово или фразу)

Добавление, изменение или удаление пароля при следующем сохранении чертежа. При добавлении или изменении пароля открывается диалоговое окно "Подтверждение пароля". Восстановление утерянного пароля невозможно. Перед тем как защитить чертеж паролем, необходимо создать его резервную копию, не защищенную паролем.

Шифровать свойства чертежа

Шифрование свойств чертежа. Для просмотра свойств требуется ввод пароля. Свойства чертежа включают в себя сведения о заголовке, авторе, теме, ключевых словах и т.д., которые помогают распознать и отыскать чертеж среди остальных.

Выбранный метод шифрования

Задание метода шифрования по умолчанию, поддерживаемого операционной системой, если в диалоговом окне "Дополнительные параметры" (кнопка "Дополнительные параметры") не был выбран другой метод шифрования.

Дополнительные параметры

Вызов диалогового окна "Дополнительные параметры", в котором можно выбрать поставщика услуг шифрования и задать длину ключа.

Вкладка "Цифровая подпись" (диалоговое окно "Параметры безопасности")

Присоединение цифровой подписи к чертежу после его сохранения.

Присоединить цифровую подпись после сохранения чертежа

Присоединение цифровой подписи к чертежу после его сохранения.

Выберите сертификат

Вывод списка цифровых сертификатов, которые можно использовать для подписывания файлов. В список включена информация об организации или частном лице, получившем сертификат, организации, выдавшей сертификат, и о сроке действия сертификата.

Сведения о цифровой подписи

Предоставляет список служб времени, которые можно использовать для добавления отметок времени к цифровой подписи; содержит поля для отображения состояния связи с сервером времени и для комментариев (для информации, относящейся к цифровой подписи или к файлам, которые нужно подписать).

Источник для отметки времени

Список серверов времени, которые можно использовать для добавления отметок времени к цифровым подписям.

Состояние связи с сервером времени

Отображает состояние связи с сервером времени ("Связь с сервером времени успешно установлена" или "Невозможно установить связь с сервером времени").

Пояснение

Поле для ввода информации о цифровой подписи или подписываемых файлах.


Диалоговое окно "Подтверждение пароля"

Б Команды
Б Команды
Диалоговое окно "Подтверждение пароля"
Понятия Процедуры Команды

Ввод команды: безопнастр

Подтверждает пароль, введенный в диалоговом окне "Параметры безопасности", который будет добавлен или изменен при следующем сохранении чертежа.

Предупреждение Восстановление утерянного пароля невозможно. Перед тем как защитить чертеж паролем, необходимо создать его резервную копию, не защищенную паролем.


Диалоговое окно "Дополнительные параметры"

Б Команды
Б Команды
Диалоговое окно "Дополнительные параметры"
Понятия Процедуры Команды

Ввод команды: безопнастр

Выбор поставщика услуг шифрования и длины ключа для чертежей, защищаемых паролем.

Поставщик услуг шифрования

Задание уровня шифрования для чертежа. Выбор осуществляется из числа систем шифрования, поддерживаемых операционной системой.

Длина ключа

Задание длины ключа. Чем больше длина ключа, тем выше уровень безопасности для чертежа.


БИБМАТ Команда

Б Команды
Б Команды
БИБМАТ Команда
Понятия Процедуры Команды

Устар.

Ввод команды: бибмат

Открывается окно "Материалы".


БЛОБРАЗЕЦ Команда

Б Команды
Б Команды
БЛОБРАЗЕЦ Команда
Понятия Процедуры Команды

Формирует образцы для блоков, отображаемых в Центре управления

Меню "Файл": подменю "Утилиты чертежа" » "Обновить образцы блоков"

Ввод команды: блобразец

Имена блоков <*>: Указать имена блоков, или нажать ENTER для обновления всех блоков

Эта команда используется для обновления образцов блоков, созданных в более ранних версиях программы. В ответ на запрос можно ввести список имен блоков через запятую. Разрешается использование глобальных символов. Например, ввод b1,?2, означает генерацию образцов для блока "b1" и для всех блоков с именами из двух символов, заканчивающимися на цифру 2.

После ввода имен блоков появится сообщение о ходе работы. Нажать клавишу ESC, чтобы прервать выполнение команды в любое время.


БЛОК Команда

Б Команды
Б Команды
БЛОК Команда
Понятия Процедуры Команды

Создание описания блока из выбранных объектов

Панель "Рисование":

Меню "Рисование": "Блок" » подменю "Make"

Ввод команды: блок

Откроется диалоговое окно "Описание блока".

При вводе -блок в ответ на подсказку "Команда", команда БЛОК будет выводить подсказки в командной строке.

Темы:

  • Диалоговое окно "Описание блока"
  • БЛОК - вариант для командной строки


Диалоговое окно "Описание блока"

Б Команды
Б Команды
Диалоговое окно "Описание блока"
Понятия Процедуры Команды

Панель Рисование:

Меню "Рисование": "Блок" » подменю "Make"

Ввод команды: блок

Служит для создания описания блока и присвоения ему имени.

Имя

Имя, присваиваемое блоку. Имя может содержать до 255 символов и состоять из букв, цифр, пробелов и любых специальных символов, не используемых операционной системой или этой программой в других целях.

Описание блока сохраняется в текущем чертеже.

Примечание Следующие названия не могут быть использованы в качестве имен блоков: DIRECT, LIGHT, AVE_RENDER, RM_SDB, SH_SPOT и OVERHEAD.

Базовая точка

Задание базовой точки вставки блока. По умолчанию используется значение 0,0,0.

X

Значение координаты по оси X.

Y

Значение координаты по оси Y.

Z

Значение координаты по оси Z.

Указать базовую точку вставки

Временное закрытие диалогового окна для указания базовой точки вставки непосредственно на текущем чертеже.

Объекты

Задает объекты, включаемые в блок, а также поведение программы по отношению к ним после создания блока.

Выбор объектов

Временное закрытие диалогового окна, для того чтобы пользователь мог выбрать нужные объекты для блока на чертеже. По завершении выбора объектов и нажатии ENTER диалоговое окно "Описания блоков" вновь появляется на экране.

Быстрый выбор

Отображает диалоговое окно "Быстрый выбор", в котором можно выбирать объекты по их свойствам.

Оставить

Выбранные объекты остаются в чертеже без изменений.

Сделать блоком

Выбранные объекты преобразуются во вхождение только что созданного блока.

Удалить

Выбранные объекты удаляются из чертежа.

Выбрано объектов

Вывод информации о количестве выбранных объектов.

Режимы

Указывает параметры для блока.

Единицы блока

Указывает единицы вставки для вхождения блока.

Одинаковый масштаб

Указывает, защищено ли вхождение блока от применения разного масштаба.

Разрешить расчленение

Указывает, возможно ли расчленение вхождения блока

Описание

Указывает описание текста блока.

Гиперссылка

Вызов диалогового окна "Вставка гиперссылки", в котором можно связать гиперссылку с описанием создаваемого блока.

Открыть в редакторе блоков

Открывает текущее описание блока в Редактор блоков при нажатии "ОК".


БЛОК - вариант для командной строки

Б Команды
Б Команды
БЛОК - вариант для командной строки
Понятия Процедуры Команды

При вводе -блок в ответ на подсказку "Команда", команда БЛОК будет выводить подсказки в командной строке

Имя блока или [?]: Ввести имя или ?

Имя блока

Имя, присваиваемое блоку. Имя может содержать до 255 символов. В него могут входить буквы, цифры, пробелы и специальные символы, не используемые Microsoft Windows и программой в других целях (если для системной переменной EXTNAMES установлено значение 1).

При вводе имени существующего блока выдается следующий запрос.

Блок "ИМЯ" уже существует. Переопределить его? [Да/Нет] <Н>: Ввести д или н, или нажать ENTER

После переопределения блока все его вхождения автоматически обновляются. Атрибуты, связанные с имеющимися вхождениями блока, остаются без изменений. Однако при последующих вставках блока запросы о значениях атрибутов не появляются (если атрибуты не включены в новое описание блока). О том, как производится переопределение блоков с атрибутами, см. команду ATTREDEF.

Базовая точка вставки: Указать точку (1)

Точка, указанная в качестве базовой, используется для последующих вставок блока. Обычно в качестве базовой точки принимают центр блока или его левый нижний угол. Относительно базовой точки производится поворот блока при вставке. Блок с нулевым углом поворота ориентируется относительно ПСК, действовавшей в момент его создания. Если указана трехмерная точка вставки, блок располагается на соответствующем ей уровне. Если координата Z опущена, используется текущий уровень.

Выбрать объекты: Выбрать объекты любым способом

Программа создает блок, используя выбранные объекты, указанную базовую точку вставки и заданное имя. Выбранные объекты на чертеже стираются. Удаленные объекты можно восстановить, введя команду OOPS сразу после команды БЛОК.

Базовая точка вставки становится начальной точкой в системе координат блока, параллельной ПСК, действительной во время определения блока. При вставке блока в чертеж его система координат ориентируется параллельно текущей ПСК. Таким образом, определив ПСК соответствующим образом, можно вставить блок с любой ориентацией в пространстве.

?—Список ранее определенных блоков

Список имен блоков выводится в текстовом окне.

Ввести блок(и) в список <*>: Ввести список имен или нажать ENTER

Внешние ссылки отмечаются примечанием

Вн-ссылка: обработана

Внешне зависимые блоки (блоки внешних ссылок) отмечаются примечанием

"Вн-зав: Ссылка"

, где "Ссылка" имя внешней ссылки. В списке используются следующие обозначения:

  • Собственные блоки: блоки, созданные пользователем.
  • Внешние ссылки: внешние ссылки на другие чертежи.
  • Зависимые блоки: блоки, вставленные в чертежи внешних ссылок.
  • Блоки без имени: неименованные блоки.


БЛОКНАБРУЧ Команда

Б Команды
Б Команды
БЛОКНАБРУЧ Команда
Понятия Процедуры Команды

Создает, удаляет или выполняет сброс ручек, связанных с параметром

Контекстное меню: Выбрать параметр из описания блока. Нажать правую кнопку мыши в области черчения редактора блоков. Выбрать "Отображение ручки", а затем операцию.

Ввод команды: блокред » блокнабруч

Указывает количество ручек, отображаемых для параметра. Кроме того, следует восстановить положение ручек для параметра по умолчанию. Команду БЛОКНАБРУЧ можно использовать только в Редактор блоков.

Выбрать параметр: В текущем описании динамического блока выбрать параметр

Ввести число объектов ручки для параметра или выполните сброс положения [0/1/2/4/Перемещение]: Ввести число ручек, которое должно отображаться для параметра, (число доступных ручек будет изменяться в зависимости от типа выбранного параметра) или ввести перемещение для восстановления положения существующих ручек в описании блока по умолчанию


БЛОКПАЛВАР Команда

Б Команды
Б Команды
БЛОКПАЛВАР Команда
Понятия Процедуры Команды

Открытие окна "Палитры вариации блоков" в редакторе блоков.

Панель инструментов редактора блоков:

Ввод команды: блокред » подменю bauthorpalette

Отображает окно "Палитры вариации блоков" в Редактор блоков. Окно "Палитры вариации блоков" можно открыть только из редактора блоков. Если ввести в командную строку блокпалвар при закрытом редакторе блоков, будет выведено следующее сообщение: “Команда БЛОКПАЛВАР разрешена только в редакторе блоков.”

В окне "Палитры вариации блоков" имеются следующие вкладки:

  • вкладка "Параметры";
  • вкладка "Операции";
  • вкладка "Наборы параметров".


БЛОКПАЛВАРЗАКР Команда

Б Команды
Б Команды
БЛОКПАЛВАРЗАКР Команда
Понятия Процедуры Команды

Закрывает окно "Палитры вариации блоков" в редакторе блоков

Панель инструментов редактора блоков:

Ввод команды: Подменю блокред » блокпалварзакр

Окно "Палитры вариации блоков" можно закрыть только из Редактор блоков. Если ввести в командную строку блокпалварзакр при закрытом редакторе блоков, будет выведено следующее сообщение: “Команда БЛОКПАЛВАРЗАКР разрешена только в редакторе блоков.”


БЛОКПАРАМ Команда

Б Команды
Б Команды
БЛОКПАРАМ Команда
Понятия Процедуры Команды

Добавляет в описание динамического блока параметр с ручками

Панель инструментов редактора блоков:

Ввод команды: блокред » блокпарам

Команду БЛОКПАРАМ можно использовать только в Редактор блоков. Параметр определяет свойства настройки для вхождения блока. После добавления параметра его необходимо связать с операцией, чтобы сделать блок динамическим.

Ввести тип параметра [Выравнивание/Базовая точка/Точка/Линейный/Полярная/XY/Поворот/Отразить /Видимость/Поиск] <последний>: Ввести тип параметра

Выравнивание

Добавляет параметр выравнивания в текущее описание динамического блока. Поскольку параметр выравнивания влияет на весь блок, связывать с ним операцию не требуется.

Параметр выравнивания определяет координаты X и Y и угол. Параметр выравнивания всегда относится ко всему блоку и не требует наличия связанной с ним операции. Параметр выравнивания позволяет вхождению блока автоматически вращаться вокруг точки для выравнивания с другими объектами на чертеже. Параметр выравнивания влияет на свойство угла вхождения блока.

Указать базовую точку выравнивания или [Имя]: Указать точку или ввести имя

При задании базовой точки для параметра выравнивания в редакторе блоков отображается X. По завершении выполнения команды в эту базовую точку добавляется ручка выравнивания. Вхождение блока автоматически вращается вокруг этой точки для выравнивания с другим объектом на чертеже.

При выборе параметра в редакторе блоков его имя отображается в палитре свойств.

Тип выравнивания = нормаль

Указать направление выравнивания или тип выравнивания [Тип] <Тип>: Указать направление выравнивания или ввести тип

Направление выравнивания задает направление ручки и угла выравнивания для вхождения блока.

Ввести тип выравнивания [Нормаль/Касательная] <Нормаль>: Указать тип выравнивания

Нормаль

Задает перпендикулярное выравнивание вхождения динамического блока относительно объектов на чертеже.

Касательная

Задает выравнивание вхождения динамического блока по касательной относительно объектов на чертеже.

Базовая точка

Добавляет базовый точечный параметр в текущее описание динамического блока. Не следует связывать какие-либо операции с базовым точечным параметром. Базовый точечный параметр определяет базовую точку для вхождения динамического блока относительно геометрии в блоке. Это обеспечивает способ управления расположением базовой точки во вхождении блока при его редактировании на чертеже. Параметр базовой точки обычно входит в набор объектов операций описания блока.

Указать местоположение параметра: Указать местоположение

В описании динамического блока допустим только один базовый точечный параметр. При попытке добавить другой базовый точечный параметр появится следующее предупреждение.

Параметр базовой точки уже существует в описании блока

Точка

Добавляет точечный параметр в текущее описание динамического блока и определяет свойства настройки X и Y для вхождения блока. Операция перемещения и растягивания связывается с точечным параметром.

Указать местоположение параметра или [Имя/Метка/Цепочка/Описание/Палитра]: Указать местоположение или задать опцию

Указать положение метки: Указать местоположение ярлыка параметра

Ввести число ручек [0/1] <1>: Указать число ручек для параметра

Имя

Указывает имя параметра. При выборе параметра в редакторе блоков его имя отображается в палитре свойств.

Ввести имя параметра <по умолчанию>: Ввести имя параметра или нажать ENTER для использования имени по умолчанию

Подпись

Указывает ярлык параметра, который определяет имя свойства настройки, добавляемое в блок. Ярлык параметра отображается в палитре свойств как свойство настройки при выборе вхождения блока на чертеже. В редакторе блоков ярлык параметра отображается рядом с параметром.

Ввести метку свойства местоположения <по умолчанию>: Ввести метку для свойства местоположения или нажать ENTER для использования метки по умолчанию

Цепочка

Указывает свойство "Цепочка операций" для параметра. Точечный параметр может входить в набор операции, связанной с другим параметром. При редактировании этого параметра во вхождении блока операция, связанная с ним, может вызвать изменение значения других параметров, входящих в набор объектов операции.

Если для свойства "Цепочка операций" установлено значение "Да", это изменение запускает все операции, связанные с точечными параметрами. Это аналогично редактированию параметра во вхождении блока с помощью ручек или настраиваемых свойств.

Если для свойства "Цепочка операций" установлено значение "Нет", операции, связанные с параметром точки не переключаются при изменении других параметров.

Оценка связанных операций при изменении параметра в другой операции? [Да/Нет] <Нет>: Ввести д или нажать ENTER

Описание

Указывает описание имени свойства настройки (ярлык параметра). При выборе параметра в редакторе блоков это описание отображается в палитре свойств. При выборе имени свойства настройки (ярлык параметра) для вхождения блока в палитре свойств на чертеже описание отображается в нижней части палитры.

Ввести описание свойства: Ввести описание параметра

Палитра

Задает отображение ярлыка параметра в палитре свойств при выборе вхождения блока на чертеже.

Отображать свойство в палитре свойств? [Да/Нет] <Да>: Ввести н или нажать ENTER

Линейный

Добавляет линейный параметр в текущее описание динамического блока и определяет свойство настройки расстояния для вхождения блока. Реактор перемещения, масштабирования, растягивания или реактор массива связывается с линейным параметром.

Указать начальную точку или [Имя/Метка/Цепочка/Описание/База/Палитра/Набор значений]: Указать начальную точку параметра или задать опцию

Указать конечную точку: Указать конечную точку для параметра

Указать положение метки: Указать местоположение ярлыка параметра

Ввести число ручек [0/1/2] <2>: Указать число ручек для параметра

Если для параметра задана одна ручка, она добавляется к конечной точке параметра.

Имя

Указывает имя параметра. При выборе параметра в редакторе блоков его имя отображается в палитре свойств.

Ввести имя параметра <по умолчанию>: Ввести имя параметра или нажать ENTER для использования имени по умолчанию

Подпись

Указывает ярлык параметра, который определяет имя свойства настройки, добавляемое в блок. Ярлык параметра отображается в палитре свойств как свойство настройки при выборе вхождения блока на чертеже. В редакторе блоков ярлык параметра отображается рядом с параметром.

Ввести метку свойства расстояния <по умолчанию>: Ввести метку для свойства расстояния или нажать ENTER для использования метки по умолчанию

Цепочка

Указывает свойство "Цепочка операций" для параметра. Линейный параметр может входить в набор операции, связанной с другим параметром. При редактировании этого параметра во вхождении блока операция, связанная с ним, может вызвать изменение значения других параметров, входящих в набор объектов операции.

Если для свойства "Цепочка операций" установлено значение "Да", это изменение запускает все операции, связанные с линейным параметром. Это аналогично редактированию параметра во вхождении блока с помощью ручек или настраиваемых свойств.

Если для свойства "Цепочка операций" установлено значение "Нет", операции, связанные с линейным параметром, не переключаются при изменении других параметров.

Производить оценку связанных операций при изменении параметра в другой операции? [Да/Нет] <Нет>: Ввести д или нажать ENTER

Описание

Указывает описание имени свойства настройки (ярлык параметра). При выборе параметра в редакторе блоков это описание отображается в палитре свойств. При выборе имени свойства настройки (ярлык параметра) для вхождения блока в палитре свойств на чертеже описание отображается в нижней части палитры.

Ввести описание свойства: Ввести описание параметра

Базовая точка

Указывает свойство "Местоположение базы" для параметра.

Ввести местоположение базы [Начальная точка/Средняя точка]: Задать опцию

Начальная точка

Закрепление начальной точки параметра при редактировании его конечной точки во вхождении блока.

Середина

Указывает местоположение базы средней точки для параметра. Эта средняя точка обозначается X в описании блока. При редактировании линейного параметра во вхождении блока средняя точка параметра остается зафиксированной, а начальная и конечная точки перемещаются одновременно на одинаковое расстояние от средней. Например, при перемещении ручки на конечной точке на две единицы от средней точки начальная точка одновременно переместится на две единицы в противоположном направлении.

Палитра

Задает отображение ярлыка параметра в палитре свойств при выборе вхождения блока на чертеже.

Отображать свойство в палитре свойств? [Да/Нет] <Да>: Ввести н или нажать ENTER

Набор значений

Задает набор значений для параметра. Ограничивает доступные значения для параметра во вхождении блока до значений, указанных в наборе.

Ввести тип набора значений расстояния [Нет/Список/Приращение] <Нет>: Указать тип набора значений или нажать ENTER , чтобы указать отсутствие типа набора значений

Вывести в список

Указывает список доступных значений параметра во вхождении блока.

Ввести список значений расстояний (разделенных запятыми): Указать список значений, разделенных запятыми

Приращение

Указывает приращение значения, а также минимальные и максимальные значения параметра во вхождении блока.

Ввести приращение расстояния: Задать значение приращения для параметра

Ввести минимальное расстояние: Задать значение минимального расстояния для параметра

Ввести максимальное расстояние: Задать значение максимального расстояния для параметра

Полярная

Добавляет полярный параметр в текущее описание динамического блока. Определяет свойства настройки расстояния и угла для вхождения блока. Реактор перемещения, масштабирования, растягивания , полярного растягивания или реактор массива связывается с полярным параметром.

Указать базовую точку или [Имя/Метка/Цепочка/Описание/Палитра/Набор значений]: Указать начальную точку параметра или задать опцию

Указать конечную точку: Указать конечную точку для параметра

Указать положение метки: Указать местоположение ярлыка параметра

Ввести число ручек [0/1/2] <2>: Указать число ручек для параметра

Если для параметра задана одна ручка, она добавляется к конечной точке параметра.

Имя

Указывает имя параметра. При выборе параметра в редакторе блоков его имя отображается в палитре свойств.

Ввести имя параметра <по умолчанию>: Ввести имя параметра или нажать ENTER для использования имени по умолчанию

Подпись

Указывает ярлык параметра, который определяет имя свойства настройки, добавляемое в блок. Ярлык параметра отображается в палитре свойств как свойство настройки при выборе вхождения блока на чертеже. В редакторе блоков ярлык параметра отображается рядом с параметром.

Ввести метку свойства расстояния <по умолчанию>: Ввести метку для свойства расстояния или нажать ENTER для использования метки по умолчанию

Ввести метку свойства угла <по умолчанию>: Ввести метку для свойства угла или нажать ENTER для использования метки по умолчанию

Цепочка

Указывает свойство "Цепочка операций" для параметра. Полярный параметр может входить в набор операции, связанной с другим параметром. При редактировании этого параметра во вхождении блока операция, связанная с ним, может вызвать изменение значения других параметров, входящих в набор объектов операции.

Если для свойства "Цепочка операций" установлено значение "Да", это изменение запускает все операции, связанные с полярным параметром. Это аналогично редактированию параметра во вхождении блока с помощью ручек или настраиваемых свойств.

Если для свойства "Цепочка операций" установлено значение "Нет", операции, связанные с полярным параметром, не переключаются при изменении других параметров.

Оценка связанных операций при изменении параметра в другой операции? [Да/Нет] <Нет>: Ввести д иди ввести ENTER

Описание

Указывает описание имени свойства настройки (ярлык параметра). При выборе параметра в редакторе блоков это описание отображается в палитре свойств. При выборе имени свойства настройки (ярлык параметра) для вхождения блока в палитре свойств на чертеже описание отображается в нижней части палитры.

Ввести описание свойства: Ввести описание параметра

Палитра

Задает отображение ярлыка параметра в палитре свойств при выборе вхождения блока на чертеже.

Отображать свойство в палитре свойств? [Да/Нет] <Да>: Ввести н или нажать ENTER

Набор значений

Задает набор значений для параметра. Ограничивает доступные значения для параметра во вхождении блока до значений, указанных в наборе.

Ввести тип набора значений расстояния [Нет/Список/Приращение] <Нет>: Указать тип набора значений расстояния или нажать ENTER , чтобы указать отсутствие типа набора значений

Ввести тип набора значений угла [Нет/Список/Приращение] <Нет>: Указать тип набора значений угла или нажать ENTER , чтобы указать отсутствие типа набора значений

Вывести в список

Указывает список доступных значений параметра во вхождении блока.

Ввести список значений расстояний (разделенных запятыми): Указать список значений, разделенных запятыми

Ввести список значений углов (разделенных запятыми): Указать список значений, разделенных запятыми

Шаг

Указывает приращение значения, а также минимальные и максимальные значения для расстояния параметра во вхождении блока.

Ввести приращение расстояния: Задать значение приращения для расстояния параметра

Ввести минимальное расстояние: Задать минимальное значение для расстояния параметра

Ввести максимальное расстояние: Задать максимальное значение для расстояния параметра

Указывает приращение значения, а также минимальные и максимальные значения для угла параметра во вхождении блока.

Ввести приращение угла: Задать значение приращения для угла параметра

Ввести минимальный угол: Задать минимальное значение для угла параметра

Ввести максимальный угол: Задать максимальное значение для угла параметра

XY

Добавляет XY-параметр в текущее описание динамического блока и определяет свойства настройки расстояния по горизонтали и вертикали для вхождения блока. Реактор перемещения, масштабирования, растягивания или реактор массива связывается с XY-параметром.

Указать базовую точку или [Имя/Метка/Цепочка/Описание/Палитра/Набор значений]: Указать базовую точку параметра или задать опцию

Указать конечную точку: Указать конечную точку для параметра

Ввести число ручек [0/1/2/4] <1>: Указать число ручек для параметра

Если для параметра задана одна ручка, она добавляется к конечной точке параметра. Если задать две ручки для параметра, ручка добавляется к базовой и конечной точкам параметра. Если задать четыре ручки для параметра, ручка добавляется ко всем четырем углам параметра.

Имя

Указывает имя параметра. При выборе параметра в редакторе блоков его имя отображается в палитре свойств.

Ввести имя параметра <по умолчанию>: Ввести имя параметра или нажать ENTER для использования имени по умолчанию

Подпись

Указывает ярлык параметра, который определяет имя свойства настройки, добавляемое в блок. Ярлык параметра отображается в палитре свойств как свойство настройки при выборе вхождения блока на чертеже. В редакторе блоков ярлык параметра отображается рядом с параметром.

Ввести метку свойства расстояния по горизонтали <по умолчанию>: Ввести метку для свойства расстояния по горизонтали или нажать ENTER для использования метки по умолчанию

Ввести метку свойства расстояния по вертикали <по умолчанию>: Ввести метку для свойства расстояния по вертикали или нажать ENTER для использования метки по умолчанию

Цепочка

Указывает свойство "Цепочка операций" для параметра. XY-параметр может входить в набор операции, связанной с другим параметром. При редактировании этого параметра во вхождении блока операция, связанная с ним, может вызвать изменение значения других параметров, входящих в набор объектов операции.

Если для свойства "Цепочка операций" установлено значение "Да", это изменение запускает все операции, связанные с XY-параметром. Это аналогично редактированию параметра во вхождении блока с помощью ручек или настраиваемых свойств.

Если для свойства "Цепочка операций" установлено значение "Нет", операции, связанные с параметром XY, не переключаются при изменении других параметров.

Оценка связанных операций при изменении параметра в другой операции? [Да/Нет] <Нет>: Ввести д или нажать ENTER

Описание

Указывает описание имени свойства настройки (ярлык параметра). При выборе параметра в редакторе блоков это описание отображается в палитре свойств. При выборе имени свойства настройки (ярлык параметра) для вхождения блока в палитре свойств на чертеже описание отображается в нижней части палитры.

Ввести описание свойства расстояния по горизонтали: Ввести описание свойства расстояния по горизонтали параметра

Ввести описание свойства расстояния по вертикали: Ввести описание свойства расстояния по вертикали параметра

Палитра

Задает отображение ярлыка параметра в палитре свойств при выборе вхождения блока на чертеже.

Отображать свойство в палитре свойств? [Да/Нет] <Да>: Ввести н или нажать ENTER

Набор значений

Задает набор значений для параметра. Ограничивает доступные значения для параметра во вхождении блока до значений, указанных в наборе.

Ввести тип набора значений по горизонтали [Нет/Список/Приращение] <Нет>: Указать тип набора значений или нажать ENTER , чтобы указать отсутствие типа набора значений

Ввести тип набора значений по вертикали [Нет/Список/Приращение] <Нет>: Указать тип набора значений или нажать ENTER , чтобы указать отсутствие типа набора значений

Вывести в список

Указывает список доступных значений параметра во вхождении блока.

Ввести список значений расстояний (разделенных запятыми): Указать список значений, разделенных запятыми

Приращение

Указывает приращение значения, а также минимальные и максимальные значения параметра во вхождении блока.

Ввести приращение расстояния: Задать значение приращения для параметра

Ввести минимальное расстояние: Задать значение минимального расстояния для параметра

Ввести максимальное расстояние: Задать значение максимального расстояния для параметра

Поворот

Добавляет параметр поворота в текущее описание динамического блока и определяет свойство настройки угла для вхождения блока. С параметром поворота можно связать только реактор поворота.

Указать базовую точку или [Имя/Метка/Цепочка/Описание/Палитра/Набор значений]: Указать базовую точку параметра или задать опцию

Указать радиус параметра: Указать радиус для параметра

Указать угол поворота по умолчанию или [Базовый угол] <0>: Указать базовый угол для параметра

Указать положение метки: Указать местоположение ярлыка параметра

Ввести число ручек [0/1] <1>: Указать число ручек для параметра

Если для параметра задана одна ручка, она добавляется к ключевой точке на радиусе параметра.

Базовый угол

Задает базовый угол для параметра и помещает ручку для параметра под этим углом.

Указать базовый угол <0>: Указать базовый угол для параметра или нажать ENTER

Имя

Указывает имя параметра. При выборе параметра в редакторе блоков его имя отображается в палитре свойств.

Ввести имя параметра <по умолчанию>: Ввести имя параметра или нажать ENTER для использования имени по умолчанию

Подпись

Указывает ярлык параметра, который определяет имя свойства настройки, добавляемое в блок. Ярлык параметра отображается в палитре свойств как свойство настройки при выборе вхождения блока на чертеже. В редакторе блоков ярлык параметра отображается рядом с параметром.

Ввести метку свойства поворота <по умолчанию>: Ввести метку для свойства поворота или нажать ENTER для использования метки по умолчанию

Цепочка

Указывает свойство "Цепочка операций" для параметра. Параметр поворота может входить в набор операции, связанной с другим параметром. При редактировании этого параметра во вхождении блока операция, связанная с ним, может вызвать изменение значения других параметров, входящих в набор объектов операции.

Если для свойства "Цепочка операций" установлено значение "Да", это изменение запускает все операции, связанные с параметром поворота. Это аналогично редактированию параметра во вхождении блока с помощью ручек или настраиваемых свойств.

Если для свойства "Цепочка операций" установлено значение "Нет", операции, связанные с параметром поворота, не переключаются при изменении других параметров.

Оценка связанных операций при изменении параметра в другой операции? [Да/Нет] <Нет>: Ввести д или нажать ENTER

Описание

Указывает описание имени свойства настройки (ярлык параметра). При выборе параметра в редакторе блоков это описание отображается в палитре свойств. При выборе имени свойства настройки (ярлык параметра) для вхождения блока в палитре свойств на чертеже описание отображается в нижней части палитры.

Ввести описание свойства: Ввести описание параметра

Палитра

Задает отображение ярлыка параметра в палитре свойств при выборе вхождения блока на чертеже.

Отображать свойство в палитре свойств? [Да/Нет] <Да>: Ввести н или нажать ENTER

Набор значений

Задает набор значений для параметра. Ограничивает доступные значения для параметра во вхождении блока до значений, указанных в наборе.

Ввести тип набора значений угла [Нет/Список/Приращение] <Нет>: Указать тип набора значений угла или нажать ENTER , чтобы указать отсутствие типа набора значений

Вывести в список

Указывает список доступных значений параметра во вхождении блока.

Ввести список значений углов (разделенных запятыми): Указать список значений, разделенных запятыми

Приращение

Указывает приращение значения, а также минимальные и максимальные значения для угла параметра во вхождении блока.

Ввести приращение угла: Задать значение приращения для угла параметра

Ввести минимальный угол: Задать минимальное значение для угла параметра

Ввести максимальный угол: Задать максимальное значение для угла параметра

Отразить

Добавляет параметр отражения в текущее описание динамического блока. Определяет свойство настройки отражения для вхождения блока. Параметр отражения отражает объекты. В редакторе блоков параметр отражения отображается в виде линии отражения. Объекты могут отражаться относительно этой линии отражения. Параметр отражения отображает значение, которое показывает, отражено или еще нет вхождение блока. Операция отражения связывается с параметром отражения.

Указать базовую точку линии отражения или [Имя/Метка/Описание/Палитра]: Указать базовую точку линии отражения или задать опцию

Указать конечную точку линии отражения: Указать конечную точку линии отражения

Указать положение метки: Указать местоположение ярлыка параметра

Ввести число ручек [0/1] <1>: Указать число ручек для параметра

Имя

Указывает имя параметра. При выборе параметра в редакторе блоков его имя отображается в палитре свойств.

Ввести имя параметра <по умолчанию>: Ввести имя параметра или нажать ENTER для использования имени по умолчанию

Подпись

Указывает ярлык параметра, который определяет имя свойства настройки, добавляемое в блок. Ярлык параметра отображается в палитре свойств как свойство настройки при выборе вхождения блока на чертеже. В редакторе блоков ярлык параметра отображается рядом с параметром.

Ввести метку свойства отражения <по умолчанию>: Ввести метку для свойства отражения или нажать ENTER для использования метки по умолчанию

Указать значения для элементов в раскрывающемся списке свойства отражения:

Ввести значение свойства отражения для неотраженного состояния <Без отражения>: Ввести значение свойства для отображения, если параметр является неотраженным, или нажать ENTER для использования метки по умолчанию

Ввести значение свойства отражения для отраженного состояния <Отраженное>: Ввести значение свойства для отображения, если параметр является отраженным, или нажать ENTER для использования метки по умолчанию

Описание

Указывает описание имени свойства настройки (ярлык параметра). При выборе параметра в редакторе блоков это описание отображается в палитре свойств. При выборе имени свойства настройки (ярлык параметра) для вхождения блока в палитре свойств на чертеже описание отображается в нижней части палитры.

Ввести описание свойства: Ввести описание параметра

Палитра

Задает отображение ярлыка параметра в палитре свойств при выборе вхождения блока на чертеже.

Отображать свойство в палитре свойств? [Да/Нет] <Да>: Ввести н или нажать ENTER

Видимость

Добавляет параметр видимости в текущее описание динамического блока и определяет свойство настройки видимости для вхождения блока. Параметр видимости позволяет создавать состояния видимости и управлять видимостью объектов в блоке. Параметр видимости всегда относится ко всему блоку и не требует наличия связанной с ним операции.

Указать местоположение параметра или [Имя/Метка/Описание/Палитра]: Указать местоположение параметра или задать опцию

Ввести число ручек [0/1] <1>: Указать число ручек для параметра

Имя

Указывает имя параметра. При выборе параметра в редакторе блоков его имя отображается в палитре свойств.

Ввести имя параметра <по умолчанию>: Ввести имя параметра или нажать ENTER для использования имени по умолчанию

Подпись

Указывает ярлык параметра, который определяет имя свойства настройки, добавляемое в блок. Ярлык параметра отображается в палитре свойств как свойство настройки при выборе вхождения блока на чертеже. В редакторе блоков ярлык параметра отображается рядом с параметром.

Ввести метку свойства видимости <по умолчанию>: Ввести метку для свойства видимости или нажать ENTER для использования метки по умолчанию

Описание

Указывает описание имени свойства настройки (ярлык параметра). При выборе параметра в редакторе блоков это описание отображается в палитре свойств. При выборе имени свойства настройки (ярлык параметра) для вхождения блока в палитре свойств на чертеже описание отображается в нижней части палитры.

Ввести описание свойства: Ввести описание параметра

Палитра

Задает отображение ярлыка параметра в палитре свойств при выборе вхождения блока на чертеже.

Отображать свойство в палитре свойств? [Да/Нет] <Да>: Ввести н или нажать ENTER

Поиск

Добавляет параметр выбора в текущее описание динамического блока и определяет свойства настройки поиска для вхождения блока. Параметр выбора определяет свойство настройки, которое можно указать, или набор для вычисления значения из списка или таблицы, задаваемых пользователем. Реактор выбора связывается с параметром выбора. Каждый параметр выбора, добавляемый в описание блока, можно добавить в виде столбца в диалоговое окно "Таблица выбора свойств".

Указать местоположение параметра или [Имя/Метка/Описание/Палитра]: Указать местоположение параметра или задать опцию

Ввести число ручек [0/1] <1>: Указать число ручек для параметра

Имя

Указывает имя параметра. При выборе параметра в редакторе блоков его имя отображается в палитре свойств.

Ввести имя параметра <по умолчанию>: Ввести имя параметра или нажать ENTER для использования имени по умолчанию

Подпись

Указывает ярлык параметра, который определяет имя свойства настройки, добавляемое в блок. Ярлык параметра отображается в палитре свойств как свойство настройки при выборе вхождения блока на чертеже. В редакторе блоков ярлык параметра отображается рядом с параметром.

Ввести метку свойства поиска <по умолчанию>: Ввести метку для свойства поиска или нажать ENTER для использования метки по умолчанию

Описание

Указывает описание имени свойства настройки (ярлык параметра). При выборе параметра в редакторе блоков это описание отображается в палитре свойств. При выборе имени свойства настройки (ярлык параметра) для вхождения блока в палитре свойств на чертеже описание отображается в нижней части палитры.

Ввести описание свойства: Ввести описание параметра

Палитра

Задает отображение ярлыка параметра в палитре свойств при выборе вхождения блока на чертеже.

Отображать свойство в палитре свойств? [Да/Нет] <Да>: Ввести н или нажать ENTER


БЛОКПОКАЗАТЬ Команда

Б Команды
Б Команды
БЛОКПОКАЗАТЬ Команда
Понятия Процедуры Команды

Делает объекты видимыми в текущем или во всех состояниях видимости в описании динамического блока

Панель инструментов редактора блоков:

Контекстное меню: Выбрать объекты, которые необходимо сделать видимыми для состояний видимости. Нажать правую кнопку мыши в области черчения редактора блоков. Выбрать "Видимость объекта" » подменю "Показать для текущего состояния" или выбрать "Видимость объекта" » подменю "Показать для всех состояний"

Ввод команды: блокред » подменю блокпоказать

Позволяет делать объекты видимыми для состояний видимости. Команду БЛОКПОКАЗАТЬ можно использовать только в Редактор блоков.

Выбрать объекты, которые нужно сделать видимыми: Выбрать объекты, которые необходимо сделать видимыми для текущего состояния или всех состояний видимости

Сделать видимым для текущего состояния или всех состояний видимости [Текущее/Все] <Текущее>: Ввести текущее, чтобы сделать выбранные объекты видимыми для текущего состояния видимости, или ввести все, чтобы сделать выбранные объекты видимыми для всех состояний видимости в описании блока


БЛОКПОРАТР Команда

Б Команды
Б Команды
БЛОКПОРАТР Команда
Понятия Процедуры Команды

Задание порядка атрибутов для блока

Ввод команды: блокред » подменю battorder

Отображает диалоговое окно "Порядок атрибутов", управляющее порядком перечисления и запросов атрибутов при вставке или редактировании вхождения блока. Команду БЛОКПОРАТР можно использовать только в Редактор блоков.

Темы:

  • Диалоговое окно "Порядок атрибутов"


Диалоговое окно "Порядок атрибутов"

Б Команды
Б Команды
Диалоговое окно "Порядок атрибутов"
Понятия Процедуры Команды

Ввод команды: блокред » подменю battorder

Указывает порядок перечисления и запросов атрибутов при вставке или редактировании вхождения блока.

Описания атрибутов

Перечисляет описания атрибутов текущего блока.

Вверх

Перемещает выбранное описание атрибута вверх по списку.

Вниз

Перемещает выбранное описание атрибута вниз по списку.


БЛОКРЕАКТ Команда

Б Команды
Б Команды
БЛОКРЕАКТ Команда
Понятия Процедуры Команды

Добавляет операцию в описание динамических блоков

Панель инструментов редактора блоков:

Ввод команды: блокред » Подменю блокреакт

Команду БЛОКРЕАКТ можно использовать только в Редактор блоков. Операции определяют способ перемещения или изменения геометрии динамического вхождения блока при выполнении операций с настраиваемыми свойствами вхождения блока в чертеже. Операции связываются с параметрами.

Выбрать параметр: Выбрать параметр из описания блока, с которым необходимо связать операцию

Выбрать тип операции [Массив/Перенести/Масштаб/Растянуть/Полярное растяжение ]: Выбрать тип операции, которую необходимо связать с параметром (доступные типы операций соответствуют типу выбранного параметра)

При выборе параметра поворота в описание динамических блоков автоматически добавляется операция поворота, которая связывается с выбранным параметром.

При выборе параметра отражения в описание динамических блоков автоматически добавляется операция отражения, которая связывается с выбранным параметром.

При выборе параметра выбора в описание динамических блоков автоматически добавляется операция поиска, которая связывается с выбранным параметром.

Массив

Добавляет реактор массива в текущее описание динамических блоков. Реактор массива можно связать с линейным и полярным параметром или XY-параметром. Создает массив набора объектов при выполнении операции во вхождении динамического блока.

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

При выборе линейного или полярного параметра отобразятся следующие запросы.

Ввести расстояние между столбцами (|||): Ввести значение расстояния между столбцами объектов массива

Указать местоположение операции: Указать местоположение операции в описании блока

При выборе XY-параметра отобразятся следующие запросы.

Расстояние между рядами или размер ячейки (---): Ввести значение расстояния между рядами или значения, разделенные запятой, для каждой точки размера ячейки объектов массива

Ввести расстояние между столбцами (|||): Ввести значение расстояния между столбцами объектов массива

Указать местоположение операции: Указать местоположение операции в описании блока

Перенести

Добавляет реактор перемещения в текущее описание динамических блоков. Реактор перемещения можно связать с линейным и полярным параметром или параметром точки и XY. Перемещение набора объектов при выполнении операции во вхождении динамического блока.

При выборе точечного параметра отобразятся следующие запросы.

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [Множитель/Смеcтить]: Указать местоположение операции в описании блока

При выборе линейного или полярного параметра отобразятся следующие запросы.

Указать точку параметра, которую необходимо связать с операцией, или ввести [Начальная точка/Вторая точка] <Вторая>: Указать точку параметра, которую необходимо связать с операцией, или нажать ENTER, чтобы связать операцию со второй точкой

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [Множитель/Смеcтить]: Указать местоположение операции в описании блока

При выборе XY-параметра отобразятся следующие запросы.

Указать точку параметра, которую необходимо связать с операцией, или ввести [Начальная точка/Вторая точка] <Вторая>: Указать точку параметра, которую необходимо связать с операцией, или нажать ENTER, чтобы связать операцию со второй точкой

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [Множитель/Смеcтить/XY]: Указать местоположение операции в описании блока

Множитель

Изменяет значение связанного параметра на заданный коэффициент при выполнении операции.

Ввести коэффициент расстояния <1,0000>: Ввести значение или нажать ENTER для выбора 1,0000

Сместить

Увеличивает или уменьшает угол связанного параметра на заданный коэффициент при выполнении операции.

Ввести угловое смещение <0>: Ввести значение или нажать ENTER для выбора 0

XY

Указывает, является ли расстояние, примененное в операции, расстоянием Х параметра XY, расстоянием Y или расстоянием XY от базовой точки параметра.

Ввести тип расстояния XY [X/Y/XY] <XY>: Ввести тип расстояния или нажать ENTER для выбора XY

Масштаб

Добавляет реактор масштабирования в текущее описание динамических блоков. Реактор масштабирования можно связать с только линейным и полярным параметром или XY-параметром. Масштабирование набора объектов относительно базовой точки, определяемой реактором масштабирования, при выполнении операции во вхождении динамического блока.

При выборе линейного или полярного параметра отобразятся следующие запросы.

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [тип Базы]: Указать местоположение операции в описании блока или ввести тип базы для выбора типа базовой точки

При выборе XY-параметра отобразятся следующие запросы.

Выбрать параметр: Выбрать параметр из описания блока, который необходимо связать с операцией

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [тип Базы/Xy]: Указать местоположение операции в описании блока, ввести тип базы для выбора типа базовой точки или xy для задания типа расстояния

Тип базы

Указывает тип базовой точки, используемой для операции.

Ввести тип базовой точки [Зависимый/Независимый] <Зависимый>: Ввести тип базовой точки операции или нажать ENTER для использования зависимой базовой точки

Зависимый

Масштабирование вхождения динамического блока относительно базовой точки параметра, с которым связан реактор масштабирования. Для базовой точки можно задать смещение, которое поддерживается относительно параметра.

Указать местоположение базовой точки <0,0>: Ввести два значения, разделенные запятой, или нажать ENTER для выбора 0,0

Независимый

Масштабирование вхождения динамического блока относительно указанной независимой базовой точки. Независимая базовая точка показана в редакторе блоков как маркер X.

Задает положение базовой точки <положение XY связанной с параметром базовой точки>: Ввести два значения, разделенных запятой, или нажать ENTER , чтобы выбрать положение связанной с параметром базовой точки

XY

Указывает, является ли расстояние, примененное в операции, расстоянием Х параметра XY, расстоянием Y или расстоянием XY от базовой точки параметра.

Ввести тип расстояния XY [X/Y/XY] <XY>: Ввести тип расстояния или нажать ENTER для выбора XY

Растянуть

Добавляет операцию растягивания в текущее описание динамических блоков. Операцию растягивания можно связать с линейным и полярным параметром или параметром точки и XY. Перемещение или растяжение набора объектов при выполнении операции во вхождении динамического блока.

При выборе линейного или полярного параметра отобразятся следующие запросы.

Указать точку параметра, которую необходимо связать с операцией, или ввести [Начальная точка/Вторая точка] <Вторая>: Указать точку параметра, которую необходимо связать с операцией, или нажать ENTER, чтобы связать операцию со второй точкой

Указать первый угол рамки растяжения или [СМн-угол]: Указать первый угол рамки растяжения или ввести смн-угол для создания многоугольника любой формы как рамки растягивания

Противоположный угол: Задать противоположный угол рамки растягивания

Указать объекты для растяжения

Выбрать объекты: Выбрать объекты, подлежащие добавлению в набор объектов операции или удалению из него

Указать местоположение операции или [Множитель/Смеcтить]: Указать местоположение операции в описании блока

При выборе XY-параметра отобразятся следующие запросы.

Указать точку параметра, которую необходимо связать с операцией, или ввести [Начальная точка/Вторая точка/Xугол/Yугол] <Xугол>: Указать точку параметра, которую необходимо связать с операцией, или нажать ENTER, чтобы связать операцию с углом X

Указать первый угол рамки растяжения или [СМн-угол]: Указать первый угол рамки растяжения или ввести смн-угол для создания многоугольника любой формы как рамки растягивания

Противоположный угол: Задать противоположный угол рамки растягивания

Указать объекты для растяжения

Выбрать объекты: Выбрать объекты, подлежащие добавлению в набор объектов операции или удалению из него

Указать местоположение операции или [Множитель/Смеcтить/XY]: Указать местоположение операции в описании блока.

Множитель

Изменяет значение связанного параметра на заданный коэффициент при выполнении операции.

Ввести коэффициент расстояния <1,0000>: Ввести значение или нажать ENTER для выбора 1,0000

Сместить

Увеличивает или уменьшает угол связанного параметра на заданный коэффициент при выполнении операции.

Ввести угловое смещение <0>: Ввести значение или нажать ENTER для выбора 0

XY

Указывает, является ли расстояние, примененное в операции, расстоянием Х параметра XY, расстоянием Y или расстоянием XY от базовой точки параметра.

Ввести тип расстояния XY [X/Y/XY] <XY>: Ввести тип расстояния или нажать ENTER для выбора XY

Полярное растяжение

Добавляет операцию полярного растягивания в текущее описание динамических блоков. Операцию полярного растягивания можно связать только с полярным параметром. Перемещение или растяжение набора объектов при выполнении операции во вхождении динамического блока.

Указать точку параметра, которую необходимо связать с операцией, или ввести [Начальная точка/Вторая точка] <Вторая>: Указать точку параметра, которую необходимо связать с операцией, или нажать ENTER, чтобы связать операцию со второй точкой

Указать первый угол рамки растяжения или [СМн-угол]: Указать первый угол рамки растяжения или ввести смн-угол для создания многоугольника любой формы как рамки растягивания

Противоположный угол: Задать противоположный угол рамки растягивания

Указать объекты для растяжения

Выбрать объекты: Выбрать объекты, подлежащие добавлению в набор объектов операции или удалению из него

Указать объекты только для поворота

Выбрать объекты: Выбрать объекты:, которые будут только вращаться, а не растягиваться

Указать местоположение операции или [Множитель/Смеcтить]: Указать местоположение операции в описании блока

Множитель

Изменяет значение связанного параметра на заданный коэффициент при выполнении операции.

Ввести коэффициент расстояния <1,0000>: Ввести значение или нажать ENTER для выбора 1,0000

Сместить

Увеличивает или уменьшает угол связанного параметра на заданный коэффициент при выполнении операции.

Ввести угловое смещение <0>: Ввести значение или нажать ENTER для выбора 0

Повернуть

Добавляет реактор поворота в текущее описание динамических блоков. Реактор поворота можно связать только с параметром поворота. Поворот набора объектов при выполнении операции во вхождении динамического блока.

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [тип Базы]: Указать местоположение операции в описании блока или ввести тип базы для выбора типа базовой точки

Тип базы

Указывает тип базовой точки, используемой для операции.

Ввести тип базовой точки [Зависимый/Независимый] <Зависимый>: Ввести тип базовой точки операции или нажать ENTER для использования зависимой базовой точки

Зависимый

Указывает, что вхождение динамического блока поворачивается вокруг базовой точки связанного параметра.

Задает положение базовой точки <текущее>: Ввести два значения, разделенные запятой, или нажать ENTER , чтобы выбрать текущее положение базовой точки параметра

Независимый

Поворот вхождения динамического блока вокруг заданной базовой точки.

Задать положение базовой точки <положение XY базовой точки связанного параметра>: Ввести два значения, разделенных запятой, или нажать ENTER , чтобы выбрать положение базовой точки связанного параметра

Отразить

Добавляет операцию отражения в текущее описание динамических блоков. Операцию отражения можно связать только с параметром отражения. Отражение набора объектов вокруг линии отражения соответствующего параметра при выполнении операции во вхождении динамического блока.

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции: Указать местоположение операции в описании блока

Поиск

Добавляет реактор выбора в текущее описание динамических блоков. Реактор выбора можно связать только с параметром выбора. При добавлении реактора выбора в описание блока отобразится диалоговое окно "Таблица выбора свойств"

Указать местоположение операции: Указать местоположение операции в описании блока


БЛОКРЕАКТИНСТ Команда

Б Команды
Б Команды
БЛОКРЕАКТИНСТ Команда
Понятия Процедуры Команды

Добавляет операцию в описание динамических блоков

Ввод команды: блокред » подменю bactiontool

Команда БЛОКРЕАКТИНСТ используется в Редактор блоков инструментами операций на вкладке "Операции" диалогового окна "Палитры вариации блоков". Операции определяют способ перемещения или изменения геометрии динамического вхождения блока при выполнении операций с настраиваемыми свойствами вхождения блока в чертеже. Операции связываются с параметрами.

Выбрать тип операции [Массив/Поиск/Отразить /Переместить/Повернуть/Масштаб/Растянуть/полярное растяжение]:

Массив

Добавляет реактор массива в текущее описание динамических блоков. Реактор массива можно связать с линейным и полярным параметром или XY-параметром. Создает массив набора объектов при выполнении операции во вхождении динамического блока.

Выбрать параметр: Выбрать параметр из описания блока, который необходимо связать с операцией

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

При выборе линейного или полярного параметра отобразятся следующие запросы.

Ввести расстояние между столбцами (|||): Ввести значение расстояния между столбцами объектов массива

Указать местоположение операции: Указать местоположение операции в описании блока

При выборе XY-параметра отобразятся следующие запросы.

Расстояние между рядами или размер ячейки (---): Ввести значение расстояния между рядами или значения, разделенные запятой, для каждой точки размера ячейки объектов массива

Ввести расстояние между столбцами (|||): Ввести значение расстояния между столбцами объектов массива

Указать местоположение операции: Указать местоположение операции в описании блока

Поиск

Добавляет реактор выбора в текущее описание динамических блоков. Реактор выбора можно связать только с параметром выбора. При добавлении реактора выбора в описание блока отобразится диалоговое окно "Таблица выбора свойств"

Выбрать параметр: Выбрать параметр из описания блока, который необходимо связать с операцией

Указать местоположение операции: Указать местоположение операции в описании блока

Отразить

Добавляет операцию отражения в текущее описание динамических блоков. Операцию отражения можно связать только с параметром отражения. Отражает набор объектов при выполнении операции во вхождении динамического блока.

Выбрать параметр: Выбрать параметр из описания блока, который необходимо связать с операцией

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции: Указать местоположение операции в описании блока

Переместить

Добавляет реактор перемещения в текущее описание динамических блоков. Реактор перемещения можно связать с линейным и полярным параметром или параметром точки и XY. Перемещение набора объектов при выполнении операции во вхождении динамического блока.

Выбрать параметр: Выбрать параметр из описания блока, который необходимо связать с операцией

При выборе точечного параметра отобразятся следующие запросы.

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [Множитель/Смеcтить]: Указать местоположение операции в описании блока

При выборе линейного или полярного параметра отобразятся следующие запросы.

Указать точку параметра, которую необходимо связать с операцией, или ввести [Начальная точка/Вторая точка] <Вторая>: Указать точку параметра, которую необходимо связать с операцией, или нажать ENTER, чтобы связать операцию со второй точкой

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [Множитель/Смеcтить]: Указать местоположение операции в описании блока

При выборе XY-параметра отобразятся следующие запросы.

Указать точку параметра, которую необходимо связать с операцией, или ввести [Начальная точка/Вторая точка] <Вторая>: Указать точку параметра, которую необходимо связать с операцией, или нажать ENTER, чтобы связать операцию со второй точкой

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [Множитель/Смеcтить/XY]: Указать местоположение операции в описании блока

Множитель

Изменяет значение связанного параметра на заданный коэффициент при выполнении операции.

Ввести коэффициент расстояния <1,0000>: Ввести значение или нажать ENTER для выбора 1,0000

Сместить

Увеличивает или уменьшает угол связанного параметра на заданный коэффициент при выполнении операции.

Ввести угловое смещение <0>: Ввести значение или нажать ENTER для выбора 0

XY

Указывает, является ли расстояние, примененное в операции, расстоянием Х параметра XY, расстоянием Y или расстоянием XY от базовой точки параметра.

Ввести тип расстояния XY [X/Y/XY] <XY>: Ввести тип расстояния или нажать ENTER для выбора XY

Повернуть

Добавляет реактор поворота в текущее описание динамических блоков. Реактор поворота можно связать только с параметром поворота. Поворот набора объектов при выполнении операции во вхождении динамического блока.

Выбрать параметр: Выбрать параметр из описания блока, который необходимо связать с операцией

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [тип Базы]: Указать местоположение операции в описании блока или ввести тип базы для выбора типа базовой точки

Тип базы

Указывает тип базовой точки, используемой для операции.

Ввести тип базовой точки [Зависимый/Независимый] <Зависимый>: Ввести тип базовой точки операции или нажать ENTER для использования зависимой базовой точки

Зависимый

Указывает, что вхождение динамического блока поворачивается вокруг базовой точки связанного параметра.

Задает положение базовой точки <текущее>: Ввести два значения, разделенные запятой, или нажать ENTER , чтобы выбрать текущее положение базовой точки параметра

Независимый

Поворот вхождения динамического блока вокруг заданной базовой точки.

Задать положение базовой точки <положение XY базовой точки связанного параметра>: Ввести два значения, разделенных запятой, или нажать ENTER , чтобы выбрать положение базовой точки связанного параметра

Масштаб

Добавляет реактор масштабирования в текущее описание динамических блоков. Реактор масштабирования можно связать с только линейным и полярным параметром или XY-параметром. Масштабирование набора объектов при выполнении операции во вхождении динамического блока.

При выборе линейного или полярного параметра отобразятся следующие запросы.

Выбрать параметр: Выбрать параметр из описания блока, который необходимо связать с операцией

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [тип Базы]: Указать местоположение операции в описании блока или ввести тип базы для выбора типа базовой точки

При выборе XY-параметра отобразятся следующие запросы.

Выбрать параметр: Выбрать параметр из описания блока, который необходимо связать с операцией

Указать набор объектов для операции

Выбрать объекты: Выбрать объекты для набора объектов операции

Указать местоположение операции или [тип Базы/Xy]: Указать местоположение операции в описании блока, ввести тип базы для выбора типа базовой точки или xy для задания типа расстояния

Тип базы

Указывает тип базовой точки, используемой для операции.

Ввести тип базовой точки [Зависимый/Независимый] <Зависимый>: Ввести тип базовой точки операции или нажать ENTER для использования зависимой базовой точки

Зависимый

Масштабирование вхождения динамического блока относительно базовой точки параметра, с которым связан реактор масштабирования. Для базовой точки можно задать смещение, которое поддерживается относительно параметра.

Указать местоположение базовой точки <0,0>: Ввести два значения, разделенные запятой, или нажать ENTER для выбора 0,0

Независимый

Масштабирование вхождения динамического блока относительно указанной независимой базовой точки. Независимая базовая точка показана в редакторе блоков как маркер X.

Задать положение базовой точки <положение XY базовой точки связанного параметра>: Ввести два значения, разделенных запятой, или нажать ENTER , чтобы выбрать положение базовой точки связанного параметра

XY

Указывает, является ли расстояние, примененное в операции, расстоянием Х параметра XY, расстоянием Y или расстоянием XY от базовой точки параметра.

Ввести тип расстояния XY [X/Y/XY] <XY>: Ввести тип расстояния или нажать ENTER для выбора XY

Растянуть

Добавляет операцию растягивания в текущее описание динамических блоков. Операцию растягивания можно связать с линейным и полярным параметром или параметром точки и XY. Перемещение или растяжение набора объектов при выполнении операции во вхождении динамического блока.

Выбрать параметр: Выбрать параметр из описания блока, который необходимо связать с операцией

При выборе линейного или полярного параметра отобразятся следующие запросы.

Указать точку параметра, которую необходимо связать с операцией, или ввести [Начальная точка/Вторая точка] <Вторая>: Указать точку параметра, которую необходимо связать с операцией, или нажать ENTER, чтобы связать операцию со второй точкой

Указать первый угол рамки растяжения или [СМн-угол]: Указать первый угол рамки растяжения или ввести смн-угол для создания многоугольника любой формы как рамки растягивания

Противоположный угол: Задать противоположный угол рамки растягивания

Указать объекты для растяжения

Выбрать объекты: Выбрать объекты, подлежащие добавлению в набор объектов операции или удалению из него

Указать местоположение операции или [Множитель/Смеcтить]: Указать местоположение операции в описании блока

При выборе XY-параметра отобразятся следующие запросы.

Указать точку параметра, которую необходимо связать с операцией, или ввести [Начальная точка/Вторая точка/Xугол/Yугол] <Xугол>: Указать точку параметра, которую необходимо связать с операцией, или нажать ENTER, чтобы связать операцию с углом X

Указать первый угол рамки растяжения или [СМн-угол]: Указать первый угол рамки растяжения или ввести смн-угол для создания многоугольника любой формы как рамки растягивания

Противоположный угол: Задать противоположный угол рамки растягивания

Указать объекты для растяжения

Выбрать объекты: Выбрать объекты, подлежащие добавлению в набор объектов операции или удалению из него

Указать местоположение операции или [Множитель/Смеcтить/XY]: Указать местоположение операции в описании блока.

Множитель

Изменяет значение связанного параметра на заданный коэффициент при выполнении операции.

Ввести коэффициент расстояния <1,0000>: Ввести значение или нажать ENTER для выбора 1,0000

Сместить

Увеличивает или уменьшает угол связанного параметра на заданный коэффициент при выполнении операции.

Ввести угловое смещение <0>: Ввести значение или нажать ENTER для выбора 0

XY

Указывает, является ли расстояние, примененное в операции, расстоянием Х параметра XY, расстоянием Y или расстоянием XY от базовой точки параметра.

Ввести тип расстояния XY [X/Y/XY] <XY>: Ввести тип расстояния или нажать ENTER для выбора XY

Полярное растяжение

Добавляет операцию полярного растягивания в текущее описание динамических блоков. Операцию полярного растягивания можно связать только с полярным параметром. Перемещение или растяжение набора объектов при выполнении операции во вхождении динамического блока.

Выбрать параметр: Выбрать параметр из описания блока, который необходимо связать с операцией

Указать точку параметра, которую необходимо связать с операцией, или ввести [Начальная точка/Вторая точка] <Вторая>: Указать точку параметра, которую необходимо связать с операцией, или нажать ENTER, чтобы связать операцию со второй точкой

Указать первый угол рамки растяжения или [СМн-угол]: Указать первый угол рамки растяжения или ввести смн-угол для создания многоугольника любой формы как рамки растягивания

Противоположный угол: Задать противоположный угол рамки растягивания

Указать объекты для растяжения

Выбрать объекты: Выбрать объекты, подлежащие добавлению в набор объектов операции или удалению из него

Указать объекты только для поворота

Выбрать объекты: Выбрать объекты:, которые будут только вращаться, а не растягиваться

Указать местоположение операции или [Множитель/Смеcтить]: Указать местоположение операции в описании блока

Множитель

Изменяет значение связанного параметра на заданный коэффициент при выполнении операции.

Ввести коэффициент расстояния <1,0000>: Ввести значение или нажать ENTER для выбора 1,0000

Сместить

Увеличивает или уменьшает угол связанного параметра на заданный коэффициент при выполнении операции.

Ввести угловое смещение <0>: Ввести значение или нажать ENTER для выбора 0


БЛОКРЕАКТНАБОР Команда

Б Команды
Б Команды
БЛОКРЕАКТНАБОР Команда
Понятия Процедуры Команды

Указывает набор объектов, связанных с операцией в описании динамического блока

Контекстное меню: В описании блока выбрать операцию. Нажать правую кнопку мыши в области рисования редактора блоков. Выбрать "Набор объектов для операции", а затем выбрать операцию.

Ввод команды: блокред » подменю блокреактнабор

Повторное указание набора объектов, связанных с операцией путем создания нового набора или добавления объектов в существующий набор или исключения их оттуда. Команду БЛОКРЕАКТНАБОР можно использовать только в Редактор блоков.

Выбрать операцию: В текущем описании динамического блока выбрать операцию

Задать набор объектов для объекта операции [Создать/Изменить] <Новый>: Ввести Изменить для изменения существующего набора объектов или нажать ENTER для создания нового набора объектов

Создать

При выборе операции перемещения, масштабирования, поворота, отражения или реактора массива отобразится следующий запрос.

Выбрать объект операции\\\\

Выбрать объекты: Выбрать объекты: для нового набора, а затем нажать ENTER

При выборе операции растягивания отобразятся следующие запросы.

Указать первый угол рамки растяжения или [СМн-угол]: Указать первый угол рамки растяжения или ввести смн-угол для создания многоугольника любой формы как рамки растягивания

Противоположный угол: Задать противоположный угол рамки растягивания

Указать объекты для растяжения

Выбрать объекты: Выбрать объекты: для нового набора, а затем нажать ENTER

При выборе операции полярного растягивания отобразятся следующие запросы.

Указать первый угол рамки растяжения или [СМн-угол]: Указать первый угол рамки растяжения или ввести смн-угол для создания многоугольника любой формы как рамки растягивания

Противоположный угол: Задать противоположный угол рамки растягивания

Указать объекты для растяжения

Выбрать объекты: Выбрать объекты: для растяжения

Указать объекты только для поворота

Выбрать объекты: Выбрать объекты, которые будут только вращаться, но не растягиваться

Изменить

При выборе операции перемещения, масштабирования, поворота, отражения или реактора массива отобразится следующий запрос.

Выбрать объекты для добавления в набор операции или [Удалить]: Выбрать объекты для добавления в набор объектов операции или для удаления из набора, который будет только повернут, но не растянут

При выборе операции растягивания отобразятся следующие запросы.

Указать первый угол рамки растяжения или [СМн-угол]: Указать первый угол рамки растяжения или ввести смн-угол для создания многоугольника любой формы как рамки растягивания

Противоположный угол: Задать противоположный угол рамки растягивания

Указать объекты для растяжения

Выбрать объекты для добавления в набор операции или [Удалить]: Выбрать объекты для добавления в набор объектов операции или удаления из него

При выборе операции полярного растягивания отобразятся следующие запросы.

Указать первый угол рамки растяжения или [СМн-угол]: Указать первый угол рамки растяжения или ввести смн-угол для создания многоугольника любой формы как рамки растягивания

Противоположный угол: Задать противоположный угол рамки растягивания

Указать объекты для растяжения

Выбрать объекты для добавления в набор операции или [Удалить]: Выбрать объекты для добавления в набор объектов операции или удаления из него

Указать объекты только для поворота

Выбрать объекты для добавления в набор операции или [Удалить]: Выбрать объекты для добавления в набор объектов операции или для удаления из набора, который будет только повернут, но не растянут


БЛОКРЕАКТСВЯЗЬ Команда

Б Команды
Б Команды
БЛОКРЕАКТСВЯЗЬ Команда
Понятия Процедуры Команды

Связывает операцию с параметром в описании динамического блока

Ввод команды: блокред » подменю блокреактсвязь

Связывает операцию разорван с параметром. Команду БЛОКРЕАКТСВЯЗЬ можно использовать только в Редактор блоков. Операция становится разорванной, если параметр, с которым она связана, исключен из описания блока.

Выбрать объект операции: В текущем описании блока выбрать операцию, не связанную с параметром

Выбрать параметр для связи с операцией: Выбрать параметр, который необходимо связать с операцией (при выборе реактора выбора можно добавить один или несколько параметров выбора)

При выборе операции и сочетания параметров, для которого требуется связь с важным свойством параметра, отобразятся запросы для выбора точки параметра для связи с операцией.


БЛОКРЕД Команда

Б Команды
Б Команды
БЛОКРЕД Команда
Понятия Процедуры Команды

Открывает диалоговое окно "Редактирование описания блока", а затем редактор блоков

Панель "Стандартная"

Меню "Инструменты": "Редактор блоков"

Контекстное меню: Выбрать вхождение блока. Нажать правую кнопку мыши в области черчения. Выбрать "Редактор блоков".

Ввод команды: блокред

Откроется диалоговое окно "Редактирование описания блока". Выбрать описание блока, которое необходимо редактировать, или ввести имя нового описания блока, которое необходимо создать, а затем нажать "ОК", чтобы открыть Редактор блоков.

Если для системной переменной BLOCKEDITLOCK установлено значение 1, редактор блоков невозможно открыть.

Темы:

  • Диалоговое окно "Редактирование описания блока"
  • Редактор блоков
  • Командная строка БЛОКРЕД


Диалоговое окно "Редактирование описания блока"

Б Команды
Б Команды
Диалоговое окно "Редактирование описания блока"
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Инструменты": "Редактор блоков"

Ввод команды: блокред

В диалоговом окне "Редактирование описания блока" из списка можно выбрать описания блоков, сохраненных в чертеже, для редактирования их в редакторе блоков. Можно также ввести имя нового описания блока, который необходимо создать в редакторе блоков.

При нажатии "ОК" диалоговое окно "Редактирование описания блока" закрывается и отображается редактор блоков. При выборе описания блока из списка в диалоговом окне "Редактирование описания блока" оно отображается в редакторе блоков и доступно для редактирования. При вводе имени для нового описания блока отобразится редактор блоков, позволяя добавить объекты в описание блока.

Имя

Указывает имя блока для редактирования или создания в редакторе блоков. При выборе <Текущий чертеж> текущий чертеж отображается в редакторе блоков. После добавления в чертеж динамических элементов его можно сохранить и вставить в чертеж в качестве вхождения динамического блока.

Список имен

Отображает список описаний блоков, сохраненных в текущем чертеже. При выборе описания блока из списка имя отображается в поле "Имя". При нажатии "ОК" это описание блока открывается в редакторе блоков. При выборе <Текущий чертеж> текущий чертеж отображается в редакторе блоков.

Образец

Отображает образец выбранного описания блока. Значок вспышки молнии обозначает, что блок динамический.

Описание

Отображает описание блока, указанное в области "Блок" палитры свойств в редакторе блоков.

"OK"

Открывает выбранное или новое описание блока в редакторе блоков.


Редактор блоков

Б Команды
Б Команды
Редактор блоков
Понятия Процедуры Команды

Панель "Стандартная"

Контекстное меню: Выбрать вхождение блока. Нажать правую кнопку мыши в области черчения. Выбрать "Редактор блоков".

Меню "Инструменты": "Редактор блоков"

Ввод команды: блокред

Редактор блоков используется для определения функции динамического изменения описания блока. В редакторе блоков можно добавить параметры и операции, которые определяют настраиваемые свойства и функцию динамического изменения. В редакторе блоков имеется специальная область, в которой можно рисовать и изменять геометрию, как и в области рисования.

Для создания динамических блоков используются следующие команды, которые доступны только в редакторе блоков.

  • БЛОКРЕАКТ
  • БЛОКРЕАКТНАБОР
  • БЛОКРЕАКТИНСТ
  • БЛОКРЕАКТСВЯЗЬ
  • БЛОКПОРАТР
  • БЛОКПАЛВАР
  • БЛОКПАЛВАРЗАКР
  • БЛОКРЕДЗАКР
  • БПОРЦИКЛ
  • БЛОКНАБРУЧ
  • БЛОКТАБЛВЫБ
  • БЛОКПАРАМ
  • БЛОКСОХР
  • БЛОКСОХРКАК
  • БЛОКСКРЫТЬ
  • БЛОКПОКАЗАТЬ
  • БЛОКСОСТВИД

Если для системной переменной BLOCKEDITLOCK установлено значение 1, редактор блоков невозможно открыть.

В редакторе блоков также имеется панель инструментов и палитры вариации блоков, содержащие инструменты для создания динамических блоков. В окне "Палитры вариации блоков" имеются следующие вкладки:

  • вкладка "Параметры"
  • вкладка "Операции"
  • вкладка "Наборы параметров"

Панель инструментов редактора блоков

Содержит инструменты для работы в редакторе блоков, создания динамических блоков и работы с состояниями видимости.

Изменение или создания описания блока

Отображает диалоговое окно "Редактирование описания блока".

Сохранить описание блока

Сохраняет текущее описание блока.

Сохранить блок как

Отображает диалоговое окно "Сохранение блока как", в котором можно сохранить копию текущего описания блока под новым именем.

Имя

Отображает имя описания текущего блока.

Палитры вариации

Отображает или скрывает палитры вариации блоков, содержащей инструменты для добавления параметров и операций в описание динамического блока.

Параметр

Выполняет команду БЛОКПАРАМ, которая добавляет параметр к описанию динамического блока.

Операция

Выполняет команду БЛОКРЕАКТ, которая добавляет операцию к описанию динамического блока.

Описание атрибута

Отображает диалоговое окно "Описание атрибутов", в котором можно определить режим, имя, подсказку, значение, точку вставки и параметры текста для атрибута.

Обновление параметра и размер текста операции

Выполняет команду РЕГЕН, которая регенерирует изображение в редакторе блоков и обновляет размеры текста, стрелок, значков и ручек параметров и операций. При увеличении или уменьшении в редакторе блоков, размер текста, стрелки, значка и ручки изменяется пропорционально коэффициенту масштаба. При регенерации изображения в редакторе блоков текст, стрелки, значки и ручки отображаются в указанных значениях.

Подробнее о динамических блоках

Отображает демонстрации по созданию динамических блоков в окне "Семинар по новым возможностям".

Закрытие редактора блоков

Закрывает редактор блоков и выдает запрос на сохранение изменений в текущем описании блока или отказа от них.

Режим видимости

Устанавливает значение для системной переменной BVMODE, которая затемняет или скрывает объекты, которые становятся невидимыми для текущего состояния видимости.

Сделать видимым

Выполняет команду БЛОКПОКАЗАТЬ, позволяющую сделать объекты видимыми для текущего состояния или всех состояний видимости.

Сделать невидимым

Выполняет команду БЛОКСКРЫТЬ, позволяющую сделать объекты невидимыми для текущего состояния или всех состояний видимости.

Управление состоянием видимости

Отображает диалоговое окно "Состояния видимости", в котором можно создавать, удалять, переименовывать и делать текущими состояния видимости.

Состояние видимости

Указывает текущее состояние видимости, которое отображается в редакторе блоков.

Вкладка "Параметры" (окно "Палитры вариации блоков")

Содержит инструменты для добавления параметров в описание динамического блока в редакторе блоков. Параметры определяют положения, расстояния и углы для геометрии во вхождения блока. При добавлении параметра в описание динамического блока он определяет одно или несколько настраиваемых свойств для блока.

Точечный параметр

Выполняет команду БЛОКПАРАМ (опция точечного параметра), которая добавляет точечный параметр в описание динамического блока и определяет свойства настройки X и Y для вхождения блока. Точечный параметр определяет координаты X и Y на чертеже. В редакторе блоков точечный параметр выглядит похоже на ординатный размер.

Линейный параметр

Выполняет команду БЛОКПАРАМ (опция линейного параметра), которая добавляет линейный параметр в описание динамического блока и определяет свойство настройки расстояния для вхождения блока. Линейный параметр отображает расстояние между двумя точками привязки. Линейный параметр ограничивает перемещение с помощью ручки по заданному углу. В редакторе блоков линейный параметр выглядит похоже на выровненный размер.

Полярный параметр

Выполняет команду БЛОКПАРАМ (опция полярного параметра), которая добавляет полярный параметр в описание динамического блока и определяет свойства настройки расстояния и угла для вхождения блока. Полярный параметр отображает расстояние между двумя точками привязки и отображает значение угла. Для изменения значений расстояния и угла можно использовать как ручки, так и палитру свойств. В редакторе блоков полярный параметр выглядит похоже на выровненный размер.

XY-параметр

Выполняет команду БЛОКПАРАМ (опция XY-параметра), которая добавляет XY-параметр в описание динамического блока и определяет свойства настройки расстояния по горизонтали и вертикали для вхождения блока. XY-параметр показывает расстояния X и Y от базовой точки параметра. В редакторе блоков XY-параметр отображается в виде пары размеров (горизонтального и вертикального). Для этих размеров используется общая базовая точка.

Параметр поворота

Выполняет команду БЛОКПАРАМ (опция параметра поворота), которая добавляет параметр поворота в описание динамического блока и определяет свойство настройки угла для вхождения блока. Параметр поворота определяет угол. В редакторе блоков параметр поворота отображается в виде окружности.

Параметр выравнивания

Выполняет команду БЛОКПАРАМ (опция параметра выравнивания), которая добавляет параметр выравнивания в описание динамического блока. Параметр выравнивания определяет координаты X и Y и угол. Параметр выравнивания всегда относится ко всему блоку и не требует наличия связанной с ним операции. Параметр выравнивания позволяет вхождению блока автоматически вращаться вокруг точки для выравнивания с другими объектами на чертеже. Параметр выравнивания влияет на свойство угла вхождения блока. В редакторе блоков параметр выравнивания выглядит как линия выравнивания.

Параметр отражения

Выполняет команду БЛОКПАРАМ (опция параметра отражения), которая добавляет параметр отражения в описание динамического блока и определяет свойство настройки отражения для вхождения блока. Параметр отражения отражает объекты. В редакторе блоков параметр отражения отображается в виде линии отражения. Объекты могут отражаться относительно этой линии отражения. Параметр отражения отображает значение, которое показывает, отражено или еще нет вхождение блока.

Параметр видимости

Выполняет команду БЛОКПАРАМ (опция параметра видимости), которая добавляет параметр видимости в описание динамического блока и определяет свойство настройки видимости для вхождения блока. Параметр видимости позволяет создавать состояния видимости и управлять видимостью объектов в блоке. Параметр видимости всегда относится ко всему блоку и не требует наличия связанной с ним операции. На чертеже можно щелкнуть ручку, чтобы отобразить список имеющихся состояний видимости для вхождения блока. В редакторе блоков параметр видимости отображается в виде текста со связанной ручкой.

Параметр выбора

Выполняет команду БЛОКПАРАМ (опция параметра выбора), которая добавляет параметр выбора в описание динамического блока и определяет свойства настройки поиска для вхождения блока. Параметр выбора определяет свойство настройки, которое можно указать, или набор для вычисления значения из списка или таблицы, задаваемых пользователем. Его можно связать с одной ручкой выбора. Во вхождении блока можно нажать на ручку, чтобы отобразить список имеющихся значений. В редакторе блоков параметр выбора отображается в виде текста.

Базовый точечный параметр

Выполняет команду БЛОКПАРАМ (опция базового точечного параметра), которая добавляет базовый точечный параметр в описание динамического блока. Базовый точечный параметр определяет базовую точку для вхождения динамического блока относительно геометрии в блоке. Параметр базовой точки не может быть связан с какими-либо операциями, но может принадлежать набору объектов операции. В редакторе блоков базовый точечный параметр отображается в виде окружности с перекрестиями

Вкладка "Операции" (окно "Палитры вариации блоков")

Содержит инструменты для добавления операций в описание динамического блока в редакторе блоков. Операции определяют способ перемещения или изменения геометрии динамического вхождения блока при выполнении операций с настраиваемыми свойствами вхождения блока в чертеже. Операции связываются с параметрами.

Реактор перемещения

Выполняет команду БЛОКРЕАКТИНСТ (опция реактора перемещения), которая добавляет реактор перемещения в описание динамического блока при связи операции с параметром точки, XY, а также линейным и полярным параметром. Действие реактора перемещения подобно действию команды СДВИГ. Во вхождении динамического блока реактор перемещения приводит к перемещению объектов на заданные расстояние и угол.

Реактор масштабирования

Выполняет команду БЛОКРЕАКТИНСТ (опция реактора масштабирования), которая добавляет реактор масштабирования в описание динамического блока при связи реактора с XY-параметром или линейным и полярным параметром. Действие реактора масштабирования подобно действию команды МАСШТАБ. Во вхождении динамического блока реактор масштабирования приводит к масштабированию набора объектов блока при изменении параметра путем перемещения ручек или с использованием палитры свойств.

Операция растягивания

Выполняет команду БЛОКРЕАКТИНСТ (опция операции растягивания), которая добавляет операцию растягивания в описание динамического блока при связи операции с параметром точки, XY, а также линейным и полярным параметром. Операция растягивания приводит к перемещению и растягиванию объектов на заданное расстояние в указанном месте.

Операция полярного растягивания

Выполняет команду БЛОКРЕАКТИНСТ (опция операции полярного растягивания), которая добавляет операцию полярного растягивания в описание динамического блока при связи операции с полярным параметром. Операция полярного растягивания поворачивает, перемещает и растягивает объекты на указанный угол и расстояние, если ключевая точка в связанном полярном параметре изменяется с помощью ручки или палитры свойств.

Реактор поворота

Выполняет команду БЛОКРЕАКТИНСТ (опция реактора поворота), которая добавляет реактор поворота в описание динамического блока при связи реактора с параметром поворота. Действие реактора поворота подобно действию команды ПОВЕРНУТЬ. Во вхождении динамического блока реактор поворота приводит к повороту связанных объектов при редактировании связанного параметра с помощью ручки или палитры свойств.

Операция отражения

Выполняет команду БЛОКРЕАКТИНСТ (опция операции отражения), которая добавляет операцию отражения в описание динамического блока при связи операции с параметром отражения. С помощью операции отражения можно выполнять отражение вхождения динамического блока относительно указанной оси, которая называется линией отражения.

Реактор массива

Выполняет команду БЛОКРЕАКТИНСТ (реактор массива), которая добавляет реактор массива в описание динамического блока при связи операции с XY-параметром или линейным и полярным параметром. Реактор массива приводит к копированию и созданию массивов в прямоугольном массиве при редактировании связанного параметра с помощью ручки или палитры свойств.

Реактор выбора

Выполняет команду БЛОКРЕАКТИНСТ (опция реактор выбора), которая добавляет реактор выбора в описание динамического блока. При добавлении реактора выбора в описание динамического блока и связывании ее с параметром выбора создается таблица выбора. Можно использовать таблицу выбора для назначения свойств настройки и значений динамического блока.

Вкладка "Наборы параметров" (окно "Палитры вариации блоков")

Содержит инструменты для одновременного добавления параметра и, по крайней мере, одного действия в описание динамического блока в редакторе блоков. При добавлении набора параметров в динамический блок, автоматически добавляются операции, связанные с параметром. После добавления набора параметров в динамический блок дважды нажмите на желтый значок предупреждения (или используйте команду БЛОКРЕАКТНАБОР) и следуйте подсказкам в командной строке, чтобы связать операцию с набором объектов геометрии.

Перемещение точки

Выполняет команду БЛОКПАРАМ (опция точечного параметра с одной заданной ручкой), которая добавляет точечный параметр в описание динамического блока. Автоматически добавляет реактор перемещения, связанную с точечным параметром.

Линейное перемещение

Выполняет команду БЛОКПАРАМ (опция линейного параметра с одной заданной ручкой), которая добавляет линейный параметр в описание динамического блока. Автоматически добавляет реактор перемещения, связанную с конечной точкой линейного параметра.

Линейное растягивания

Выполняет команду БЛОКПАРАМ (опция линейного параметра с одной заданной ручкой), которая добавляет линейный параметр в описание динамического блока. Автоматически добавляет операцию растягивания, связанную с линейным параметром.

Линейный массив

Выполняет команду БЛОКПАРАМ (опция линейного параметра с одной заданной ручкой), которая добавляет линейный параметр в описание динамического блока. Автоматически добавляет реактор массива, связанный с линейным параметром.

Пара линейных перемещений

Выполняет команду БЛОКПАРАМ (опция линейного параметра с двумя заданными ручками), которая добавляет линейный параметр в описание динамического блока. Автоматически добавляет два реактора перемещения, один из которых связан с базовой точкой, а другой - с конечной точкой линейного параметра.

Пара линейных растяжений

Выполняет команду БЛОКПАРАМ (опция линейного параметра с двумя заданными ручками), которая добавляет линейный параметр в описание динамического блока. Автоматически добавляет две операции растягивания, одна из которых связана с базовой точкой, а другая - с конечной точкой линейного параметра.

Полярное перемещение

Выполняет команду БЛОКПАРАМ (опция полярного параметра с одной заданной ручкой), которая добавляет полярный параметр в описание динамического блока. Автоматически добавляет реактор перемещения, связанный с полярным параметром.

Полярное растягивания

Выполняет команду БЛОКПАРАМ (опция полярного параметра с одной заданной ручкой), которая добавляет полярный параметр в описание динамического блока. Автоматически добавляет операцию растягивания, связанную с полярным параметром.

Круговой массив

Выполняет команду БЛОКПАРАМ (опция полярного параметра с одной заданной ручкой), которая добавляет полярный параметр в описание динамического блока. Автоматически добавляет реактор массива, связанный с полярным параметром.

Пара полярных перемещений

Выполняет команду БЛОКПАРАМ (опция полярного параметра с двумя заданными ручками), которая добавляет полярный параметр в описание динамического блока. Автоматически добавляет два реактора перемещения, один из которых связан с базовой точкой, а другой - с конечной точкой полярного параметра.

Пара полярных растяжений

Выполняет команду БЛОКПАРАМ (опция полярного параметра с двумя заданными ручками), которая добавляет полярный параметр в описание динамического блока. Автоматически добавляет две операции растягивания, одна из которых связана с базовой точкой, а другая - с конечной точкой полярного параметра.

Перемещение XY

Выполняет команду БЛОКПАРАМ (опция XY-параметра с одной заданной ручкой), которая добавляет XY-параметр в описание динамического блока. Автоматически добавляет реактор перемещения, связанный с конечной точкой XY-параметра.

Пара перемещений XY

Выполняет команду БЛОКПАРАМ (опция XY-параметра с двумя заданными ручками), которая добавляет XY-параметр в описание динамического блока. Автоматически добавляет два реактора перемещения, один из которых связан с базовой точкой, а другой - с конечной точкой XY-параметра.

Набор рамок перемещения XY

Выполняет команду БЛОКПАРАМ (опция XY-параметра с четырьмя заданными ручками), которая добавляет XY-параметр в описание динамического блока. Автоматически добавляет четыре реактора перемещения, каждый из которых связан с ключевой точкой в XY-параметре.

Набор рамок растягивания XY

Выполняет команду БЛОКПАРАМ (опция XY-параметра с четырьмя заданными ручками), которая добавляет XY-параметр в описание динамического блока. Автоматически добавляет четыре операции растягивания, каждая из которых связана с ключевой точкой в XY-параметре.

Набор рамок массива XY

Выполняет команду БЛОКПАРАМ (опция XY-параметра с четырьмя заданными ручками), которая добавляет XY-параметр в описание динамического блока. Автоматически добавляет реактор массива, связанный с XY-параметром.

Управляющая группа поворота

Выполняет команду БЛОКПАРАМ (опция параметра поворота с одной заданной ручкой), которая добавляет параметр поворота в описание динамического блока. Автоматически добавляет операцию поворота, связанную с параметром поворота.

Набор отражения

Выполняет команду БЛОКПАРАМ (опция параметра отражения с одной заданной ручкой), которая добавляет параметр отражения в описание динамического блока. Автоматически добавляет операцию отражения, связанную с параметром отражения.

Набор видимости

Выполняет команду БЛОКПАРАМ (опция параметра видимости с одной заданной ручкой), которая добавляет параметр видимости в описание динамического блока и позволяет определить состояния видимости. Параметр видимости не требует никаких операций.

Управляющая группа выбора

Выполняет команду БЛОКПАРАМ (опция параметра выбора с одной заданной ручкой), которая добавляет параметр выбора в описание динамического блока. Автоматически добавляет реактор выбора, связанный с параметром выбора.


Командная строка БЛОКРЕД

Б Команды
Б Команды
Командная строка БЛОКРЕД
Понятия Процедуры Команды

Если выбрать на чертеже блок и ввести в командной строке -блокред, выбранный блок откроется в Редактор блоков. Если ничего не выбрано, отобразится следующий запрос.

Имя блока или [?]: Ввести имя или ?

Имя блока

Указывает имя сохраненного в текущем чертеже блока, который необходимо открыть в редакторе блоков, или имя нового блока, который необходимо создать.

?—Список ранее определенных блоков

Список имен блоков выводится в текстовом окне.

Ввести блок(и) в список <*>: Ввести список имен или нажать ENTER


БЛОКРЕДЗАКР Команда

Б Команды
Б Команды
БЛОКРЕДЗАКР Команда
Понятия Процедуры Команды

Закрывает редактор блоков

Контекстное меню: В редакторе блоков нажать правую кнопку мыши в области черчения. Выбрать "Закрыть редактор блоков"

Ввод команды: блокред » блокредзакр

Закрывает Редактор блоков. Если с момента последнего сохранения в описание блока были внесены изменения, программа предлагает сохранить изменения или отказаться от них.


БЛОКСКРЫТЬ Команда

Б Команды
Б Команды
БЛОКСКРЫТЬ Команда
Понятия Процедуры Команды

Делает объекты невидимыми в текущем или во всех состояниях видимости в описании динамического блока

Панель инструментов редактора блоков:

Контекстное меню: Выбрать объекты, которые необходимо скрыть для состояний видимости. Нажать правую кнопку мыши в области черчения редактора блоков. Выбрать "Видимость объекта" » подменю "Скрыть для текущего состояния" или выбрать "Видимость объекта" » подменю "Скрыть для всех состояний"

Ввод команды: блокред » подменю блокскрыть

Позволяет делать объекты невидимыми для текущего состояния видимости. Команду БЛОКСКРЫТЬ можно использовать только в Редактор блоков.

Выбрать объекты, которые нужно скрыть: Выбрать объекты, которые необходимо скрыть для текущего состояния или всех состояний видимости

Скрыть для текущего состояния или всех состояний видимости [Текущее/Все] <Текущее>: Ввести текущее, чтобы скрыть выбранные объекты для текущего состояния видимости, или ввести все, чтобы скрыть выбранные объекты для всех состояний видимости в описании блока


БЛОКСОСТВИД Команда

Б Команды
Б Команды
БЛОКСОСТВИД Команда
Понятия Процедуры Команды

Создает, устанавливает или удаляет состояние видимости в динамическом блоке

Ввод команды: блокред » подменю блоксоствид

Отображает диалоговое окно "Состояния видимости". Команду БЛОКСОСТВИД можно использовать только в Редактор блоков после добавления параметра видимости в описание блока.

Темы:

  • Диалоговое окно "Состояния видимости"
  • Диалоговое окно "Новое состояние видимости"
  • Командная строка БЛОКСОСТВИД


Диалоговое окно "Состояния видимости"

Б Команды
Б Команды
Диалоговое окно "Состояния видимости"
Понятия Процедуры Команды

Создает или изменяет состояния видимости. С помощью кнопок в диалоговом окне или параметров контекстного меню можно выполнять следующие действия.

  • Создавать новые состояния видимости
  • Устанавливать любое состояние видимости в качестве текущего
  • Переименовывать состояния видимости
  • Удалять состояния видимости
  • Изменять порядок следования состояний видимости в списке

Состояния видимости

Содержит список доступных состояний видимости для текущего описания динамического блока. Порядок этого списка отражается во вхождении динамического блока при нажатии ручки для отображения списка состояний видимости. По умолчанию вхождение блока размещается в верхней части списка.

Установить

Устанавливает выбранное состояние видимости текущим для отображения в редакторе блоков. Не изменяет состояние видимости по умолчанию, которое отображается при вставке блока в чертеж, а также не изменяет отображаемое состояние видимости для вхождений блоков, вставленных и измененных в чертеже.

Создать

Отображает диалоговое окно "Новое состояние видимости".

Переименовать

Переименовывает выбранное состояние видимости.

Удалить

Удаляет выбранное состояние видимости.

Вверх

Перемещает выбранное состояние видимости вверх по списку.

Вниз

Перемещает выбранное состояние видимости вниз по списку.


Диалоговое окно "Новое состояние видимости"

Б Команды
Б Команды
Диалоговое окно "Новое состояние видимости"
Понятия Процедуры Команды

Создает новое состояние видимости.

Имя состояния видимости

Задает имя для нового состояния видимости.

Параметры видимости для новых состояний

Отображает параметры для нового состояния видимости.

Скрыть все существующие объекты

Указывает, что все объекты в описании блока будут скрыты в новом состоянии видимости.

Показать все существующие объекты

Указывает, что все объекты в описании блока будут отображены в новом состоянии видимости.

Оставить видимость существующих объектов неизменной

Указывает, что видимость объектов в новом состоянии будет соответствовать текущему состоянию видимости, на котором основано новое состояние.

"OK"

Создает новое состояние видимости.


Командная строка БЛОКСОСТВИД

Б Команды
Б Команды
Командная строка БЛОКСОСТВИД
Понятия Процедуры Команды

При вводе в командную строку -блоксоствид отобразится следующий запрос.

Текущее состояние видимости: <Имя текущего состояния видимости>

Ввести опцию [Создать/Установить/Удалить] <Новый>: Ввести опцию или нажать ENTER

Создать

Создает новое состояние видимости.

Ввести имя нового состояния видимости: Ввести имя для нового состояния видимости

Указать видимость объектов для нового состояния [Скрыть все/Показать все/Текущая видимость] <Текущая видимость>: Указать видимость объектов для нового состояния

Скрыть все

Указывает, что все объекты в описании блока будут скрыты в новом состоянии видимости.

Показать все

Указывает, что все объекты в описании блока будут отображены в новом состоянии видимости.

Текущая видимость

Указывает, что видимость объектов в новом состоянии будет соответствовать текущему состоянию видимости, на котором основано новое состояние.

Установить

Указывает состояние видимости, которое необходимо установить в качестве текущего.

Ввести имя состояния видимости, которое необходимо сделать текущим, или [?]: Ввести имя состояния видимости, которое необходимо установить в качестве текущего

Удалить

Удаляет состояние видимости.

Ввести имена состояний видимости для удаления: Ввести имена состояний видимости, которые необходимо удалить


БЛОКСОХР Команда

Б Команды
Б Команды
БЛОКСОХР Команда
Понятия Процедуры Команды

Сохраняет текущее описание блока

Панель инструментов редактора блоков:

Ввод команды: блокред » Подменю блоксохр

Сохраняет изменения в текущем описании блока.

Команду БЛОКСОХР можно использовать только в Редактор блоков.


БЛОКСОХРКАК Команда

Б Команды
Б Команды
БЛОКСОХРКАК Команда
Понятия Процедуры Команды

Сохраняет копию текущего описания блока под новым именем

Панель инструментов редактора блоков:

Ввод команды: блокред » Подменю блоксохркак

Отображает диалоговое окно "Сохранение блока как".

Команду БЛОКСОХРКАК можно использовать только в Редактор блоков.

Темы:

  • Диалоговое окно "Сохранение блока как"


Диалоговое окно "Сохранение блока как"

Б Команды
Б Команды
Диалоговое окно "Сохранение блока как"
Понятия Процедуры Команды

Сохраняет копию текущего описания блока под новым именем.

Имя блока

Задает новое имя, под которым сохраняется копия текущего описания блока.

Список блоков

Отображает список описаний блоков, сохраненных в текущем чертеже.

Образец

Отображает образец выбранного описания блока.

Описание

Отображает описание блока, указанное в области "Блок" палитры свойств в редакторе блоков.


БПОРЦИКЛ Команда

Б Команды
Б Команды
БПОРЦИКЛ Команда
Понятия Процедуры Команды

Изменяет порядок циклического перебора ручек для вхождения динамического блока

Ввод команды: блокред » бпорцикл

Отображает диалоговое окно "Порядок перебора при вставке". Команду БПОРЦИКЛ можно использовать только в Редактор блоков.

Темы:

  • Диалоговое окно "Порядок перебора при вставке"


Диалоговое окно "Порядок перебора при вставке"

Б Команды
Б Команды
Диалоговое окно "Порядок перебора при вставке"
Понятия Процедуры Команды

Задает порядок циклического перебора ручки для точки вставки вхождения динамического блока. При вставке вхождения динамического блока в чертеж можно использовать клавишу CTRL для циклического перемещения по ручкам, для которых в описании блока включен циклический перебор. Выбранная ручка используется при циклической вставке как точка вставки для вхождения блока.

Список перебора ручек

Перечисляет ручки в описании динамического блока. Пометка в столбце "Циклический перебор" означает, что циклический перебор включен для этой ручки.

Вверх

Перемещает выбранную ручку вверх в порядке циклического перебора для вхождения динамического блока.

Вниз

Перемещает выбранную ручку вниз в порядке циклического перебора для вхождения динамического блока.

Циклический перебор

Включает или выключает циклический перебор для выбранной ручки. Пометка в столбце "Циклический перебор" означает, что циклический перебор включен для этой ручки.


БРАЗМЕР Команда

Б Команды
Б Команды
БРАЗМЕР Команда
Понятия Процедуры Команды

Быстрое нанесение размера

Панель "Размеры":

Меню "Размеры": "Быстрый размер"

Ввод команды: бразмер

Команда БРАЗМЕР используется для быстрого создания или редактирования набора размеров. Команда особенно полезна для нанесения набора размеров от общей базы или цепочкой, а также для проставления размеров для набора кругов и дуг.

Выберите объекты для нанесения размеров: Выбрать объекты для нанесения размеров или размеры для редактирования и нажать ENTER

Положение размерной линии или [Цепь/Ступенчатый/Базовый/Ординатный/Радиус/Диаметр/Точка/Изменить/Параметры] <текущий>: Задать опцию или нажать ENTER

Цепь

Нанесение набора размеров цепочкой.

Ступенчатый

Нанесение набора ступенчатых размеров.

Базовый

Нанесение набора размеров от общей базы.

Ординатный

Нанесение набора ординатных размеров.

Радиус

Нанесение набора радиусов.

Диаметр

Нанесение набора диаметров.

Точка

Задание новой базы (начала) для базовых и ординатных размеров.

Новая точка начала: Указать точку

Отображается предыдущий запрос.

Изменить

Изменение набора размеров. Отображается запрос на добавление или удаления точек существующих размеров.

Укажите размерную точку для исключения или [Добавить/выХод] <eXit>: Указать точку, ввести д или нажать ENTER для возвращения к предыдущему запросу

Режимы

Включение режима объектной привязки по умолчанию для задания начала выносной линии. В командной строке отображаются следующие запросы:

Приоритет в ассоциативных размерах [Конточка/Пересечение]

Отображается предыдущий запрос.


БРАУЗЕР Команда

Б Команды
Б Команды
БРАУЗЕР Команда
Понятия Процедуры Команды

Запускает обозреватель Интернета по умолчанию, указанный в системном реестре

Панель "Web":

Ввод команды: браузер

Ввести адрес унифицированного указателя информационного ресурса Интернет (URL) <текущий>: Нажать ENTERили ввести новый адрес ; не нужно вводить http:// перед указанием адреса

После нажатия ENTER на экран выводится Интернет-браузер, и происходит автоматическое соединение с сайтом по заданному адресу. Команда БРАУЗЕР не добавляет префикс “http://” к введенному адресу. Это позволяет задавать адреса ftp-серверов или файлов в качестве Интернет-адреса, используемого по умолчанию.


БСОЗДАТЬ Команда

Б Команды
Б Команды
БСОЗДАТЬ Команда
Понятия Процедуры Команды

Создает новый чертеж с помощью файла шаблона по умолчанию

Панель "Стандартная":

Ввод команды: БСОЗДАТЬ

Команда БСОЗДАТЬ служит для создания нового чертежа с использованием шаблона по умолчанию, заданного на вкладке "Файлы" диалогового окна "Настройка". В качестве шаблона по умолчанию можно задать любой файл шаблона чертежа. Шаблон можно не задавать, выбрав параметр Нет.

Если шаблон по умолчанию не задан или выбран параметр Нет, при вызове команды БСОЗДАТЬ откроется диалоговое окно "Выбор шаблона" (стандартное диалоговое окно выбора файлов).

Характер действий, выполняемых командой БСОЗДАТЬ, зависит от значения параметра "При запуске" на вкладке "Система" диалогового окна "Настройка".

  • Диалоговое окно начала работы: Отображает диалоговое окно "Создание нового чертежа".
  • Без начального окна: Отображает диалоговое окно "Выбор файла шаблона" (стандартного окна выбора файлов) или создает новый чертеж с использованием шаблона по умолчанию.

Если значение системной переменной FILEDIA равно 0, а не 1, выводятся подсказки для этой команды. Если значение системной переменной FILEDIA равно 0, подсказка в командной строке отображается независимо от параметра "При запуске".


БСОХРАНИТЬ Команда

Б Команды
Б Команды
БСОХРАНИТЬ Команда
Понятия Процедуры Команды

Быстрое сохранение текущего чертежа в формате, заданном в диалоговом окне "Настройка"

Панель "Стандартная:

Меню "Файл": "Сохранить"

Ввод команды: бсохранить

Использование команды БСОХРАНИТЬ эквивалентно выбору пункта "Сохранить" из меню "Файл".

Если чертежу присвоено имя, он сохраняется в формате, заданном на вкладке "Открытие/Сохранение" диалогового окна "Настройка" без запроса имени файла. Если чертеж не назван, откроется диалоговое окно "Сохранение файла" (см. СОХРАНИТЬКАК), после чего файл будет сохранен с заданным именем и в указанном формате.

Чертеж, открытый в режиме "только чтение", можно сохранить под другим именем с помощью команды СОХРАНИТЬКАК.


БЫСТРКАЛЬК Команда

Б Команды
Б Команды
БЫСТРКАЛЬК Команда
Понятия Процедуры Команды

Вызов калькулятора QuickCalc

Панель "Стандартная":

Выбрать в меню "Сервис": "Палитры" » "QuickCalc"

Контекстное меню: Нажмите правую кнопку мыши и выберите "QuickCalc".

Ввод команды: БЫСТРКАЛЬК

Вызов калькулятора QuickCalc.

Темы:

  • Калькулятор QuickCalc
  • Диалоговое окно "Описание переменной"
  • Диалоговое окно "Описание категории"


Калькулятор QuickCalc

Б Команды
Б Команды
Калькулятор QuickCalc
Понятия Процедуры Команды

Выполняет весь спектр математических, научных и геометрических вычислений, создает и использует переменные, а также преобразует единицы измерений.

Калькулятор QuickCalc состоит из следующих областей:

  • Панель
  • Область журнала
  • Поле ввода
  • Кнопка "Больше/Меньше"
  • Цифровая клавиатура
  • Область научных расчетов
  • Область преобразования единиц
  • Область переменных

Панель

Выполняет быстрые вычисления для стандартных функций.

Сброс

Сбрасывает значение в поле ввода.

Очистить журнал

Удаляет данные из области журнала.

Вставить значение в командную строку

Вставляет значение из поля ввода в командную строку. Если калькулятор QuickCalc используется в прозрачном режиме во время выполнения команды, эта кнопка заменяется кнопкой "Применить" в нижней части окна калькулятора.

Получить координаты

Вычисляет координаты точки, выбранной на чертеже с помощью мыши.

Расстояние между двумя точками

Вычисляет расстояние между двумя точками, выбранными на объекте с помощью мыши.

Угол линии, определенной двумя точками

Вычисляет угол между двумя точками, выбранными на объекте с помощью мыши.

Пересечение двух линий, определенных четырьмя точками

Вычисляет точку пересечения двух линий, заданных четырьмя точками, выбранными на объекте с помощью мыши.

Справка

Отображает справку для калькулятора QuickCalc.

Область журнала

Отображает бегущий список ранее вычисленных выражений. В контекстном меню "Область журнала" содержится несколько пунктов, включая пункт для копирования выбранного выражения в буфер обмена.

Поле ввода

Поле для ввода и извлечения выражений. При нажатии кнопки со знаком равенства = или клавиши ENTER калькулятор QuickCalc производит вычисление и отображает результаты.

Кнопка "Больше/Меньше"

Скрывает или отображает все области функций калькулятора QuickCalc. Можно также нажать правую кнопку мыши, чтобы скрыть или отобразить отдельные области функций.

Цифровая клавиатура

Стандартная клавиатура калькулятора, с помощью которой можно вводить цифры, символы для арифметических выражений. Нажатие знака равенства (=) позволяет вычислить введенное выражение. В следующей таблице приведены дополнительные функции управления, доступные на цифровой клавиатуре.

Управление | Описание
C (Очистить) | Удаляет значение в поле ввода и сбрасывает его в 0.
<-- (возврат) | Перемещает курсор на один символ влево в поле ввода. При этом один десятичный знак или символ удаляется с дисплея.
sqt (квадратный корень) | Вычисляет квадратный корень значения.
1/X (обратная функция) | Вычисляет значение или выражение, обратное находящемуся в поле ввода.
x^2 (X в степени 2) | Возводит значение в квадрат.
x^3 (X в степени 3) | Возводит число или выражение в поле ввода в степень 3.
x^y (X в степени Y) | Возводит число или выражение в поле ввода в указанную степень.
pi | Вводит число "пи" с 14 знаками после запятой в поле ввода.
( (открывающая скобка) ) (закрывающая скобка) | При объединении в пары используются для группирования части выражения. Элементы, заключенные в скобки, обрабатываются раньше, чем оставшаяся часть выражения.
= (знак равенства) | Вычисляет выражение в поле ввода.
MS (сохранение в памяти) | Сохраняет текущее значение в памяти QuickCalc.
M+ (добавление к значению в памяти) | Добавляет текущее значение к значению, сохраненному в памяти QuickCalc.
MR (восстановление значения из памяти) | Если в памяти QuickCalc хранится значение, оно будет восстановлено в окне ввода.
MC (очистка памяти) | Удаляет значение, хранящееся в памяти QuickCalc.

Область научных расчетов

Вычисляет значения тригонометрических, логарифмических, показательных и других выражений, обычно используемых в научных и инженерных приложениях. В приведенной ниже таблице описываются элементы управления в научной области.

Управление | Описание
sin (синус) | Указывает синус угла в поле ввода.
cos (косинус) | Указывает косинус угла в поле ввода.
tang (тангенс) | Указывает тангенс угла в поле ввода.
Log (логарифм по основанию 10) | Указывает логарифм значения в поле ввода.
10^x (степень по основанию 10) | Указывает степень по основанию 10 значения в поле ввода.
asin (арксинус) | Указывает арксинус числа в поле ввода. Число должно лежать в пределах от -1 до 1.
acos (арккосинус) | Указывает арккосинус числа в поле ввода. Число должно лежать в пределах от -1 до 1.
atan (арктангенс) | Указывает арктангенс числа в поле ввода.
In (натуральный логарифм) | Указывает натуральный логарифм числа в поле ввода.
e^x (натуральный показатель) | Указывает натуральный показатель числа в поле ввода.
r2d (преобразование радиан в градусы) | Преобразует радианы в градусы; например, r2d ("пи") преобразует значение "пи" в 180 градусов.
d2r (преобразование градусов в радианы) | Преобразует углы из градусов в радианы; например, d2r(180) преобразует угол 180 градусов в радианы и возвращает значение, равное константе "пи".
abs (абсолютное значение) | Возвращает абсолютное значение числа в поле ввода.
rnd (округление) | Округляет число в поле ввода до ближайшего целого числа.
trunc (усечение) | Отображает целую часть числа в поле ввода.

Область преобразования единиц

Преобразует единицы измерения одного типа в другой. В области преобразования единиц можно использовать только целые значения.

Тип единиц

Выбор длины, площади, объема и угловых значений из списка.

Преобразовать из

Отображает список исходных единиц измерения.

Преобразовать в

Отображает список конечных единиц измерения.

Преобразуемое значение

Отображает поле для ввода преобразуемого значения.

Преобразованное значение

Преобразует введенные единицы и отображает результат.

Значок калькулятора

Возвращает преобразованное значение в поле ввода.

Область переменных

Обеспечивает доступ к предопределенным константам и функциям. Область переменных можно использовать для определения и хранения дополнительных констант и функций.

Дерево переменных

Используется для хранения функций сокращенного вида и переменных, заданных пользователем.

Функции сокращенного вида - это часто используемые выражения, в которых функция связана с привязкой к объекту. В приведенной ниже таблице описываются стандартные функции сокращенного вида.

Функция сокращенного вида | Сокращенная форма | Описание
dee | dist(end,end) | Расстояние между двумя конечными точками
ille | ill(end,end,end,end) | Пересечение двух линий, проведенных через четыре конечные точки
mee | (end+end)/2 | Середина отрезка, соединяющего две конечные точки
nee | nor(end,end) | Единичный вектор в плоскости XY, нормальный к двум конечным точкам
rad | rad | Радиус выбранной окружности, дуги или дуги полилинии
vee | vec(end,end) | Вектор от одной конечной точки к другой
vee1 | vec1(end,end) | Единичный вектор в направлении от одной конечной точки к другой

Кнопа "Новая переменная"

Отображает диалоговое окно "Описание переменной".

Кнопка "Изменить переменную"

Отображает диалоговое окно "Описание переменной" для внесения изменений в выбранную переменную.

Кнопка "Удалить переменную"

Удаляет выбранную переменную.

Кнопка калькулятора

Возвращает выбранную переменную в поле ввода.


Диалоговое окно "Описание переменной"

Б Команды
Б Команды
Диалоговое окно "Описание переменной"
Понятия Процедуры Команды

Задает переменную, которую необходимо сохранить в дереве переменных.

Тип переменной

Указывает тип переменной.

Постоянный

Сохраняет новую переменную в качестве константы.

Назначение

Сохраняет новую переменную в качестве функции.

Свойства переменной

Задает свойства новой переменной.

Имя

Сохраняет имя переменной. В именах констант нельзя использовать пробелы.

Группа с

Сохраняет именованную переменную в выбранной категории. Если выбрано значение "Новая", отобразится диалоговое окно "Описание категории", в котором можно указать новую категорию для переменной.

Значение выражения

Сохраняет значение выражения для переменной.

Описание

Сохраняет описание для переменной.

OK

Закрывает диалоговое окно и применяет текущие настройки к переменной.

Отмена

Закрывает диалоговое окно без применения текущих настроек.

Справка

Отображает справку.


Диалоговое окно "Описание категории"

Б Команды
Б Команды
Диалоговое окно "Описание категории"
Понятия Процедуры Команды

Задает категорию для структурирования переменных в дереве переменных.

Свойства категории

Задает свойства новой категории.

Имя

Сохраняет имя категории.

Описание

Сохраняет описание для категории.

OK

Закрывает диалоговое окно и применяет текущие настройки к переменной.

Отмена

Закрывает диалоговое окно без применения текущих настроек.

Справка

Отображает справку.


В Команды
  • ВБУФЕР
  • ВЕСЛИН
  • ВЗАИМОД
  • ВИД
  • ВИЗСТИЛИ
  • ВИЗСТИЛИЗАКР
  • ВНЕДРИТЬ
  • ВНССЫЛКИ
  • ВНССЫЛКИЗАКРЫТЬ
  • ВОССТАН
  • ВОССТАНЧЕРТЕЖА
  • ВПАКЕТ
  • ВРАЩАТЬ
  • ВРЕМЯ
  • ВСЕОСВЕЖ
  • ВСЕРЕГЕН
  • ВСЛОЙ
  • ВСТАВИТЬ
  • ВСТБЛОК
  • ВСТБУФЕР
  • ВСТИСХОД
  • ВСТОБЪЕКТ
  • ВСТСПЕЦ
  • ВЫБРАТЬ
  • ВЫДАВИТЬ
  • ВЫНОСКА
  • ВЫРОВНЯТЬ
  • ВЫРТЕКСТ
  • ВЫДАВГРАНЬ
  • ВЫЧИТАНИЕ
  • ВЭКРАН
  • ВЭКРЕЗ
  • ВЭКРМАКС
  • ВЭКРМИН


ВБУФЕР Команда

В Команды
В Команды
ВБУФЕР Команда
Понятия Процедуры Команды

Занесение объектов в буфер обмена с удалением их из чертежа

Панель "Стандартная":

Меню "Правка": "Вырезать"

Контекстное меню: Завершить выполнение активных команд, щелкнуть правой кнопкой мыши в области рисования и выбрать "Вырезать".

Ввод команды: вбуфер

Выбрать объекты:

Команда ВБУФЕР перемещает выбранные объекты в буфер обмена, удаляя их из чертежа. Содержимое буфера обмена может быть вставлено в документ или чертеж как внедренный OLE-объект (см. команды PASTECLIP и PASTESPEC). Команда ВБУФЕР не создает OLE-связей.


ВЕСЛИН Команда

В Команды
В Команды
ВЕСЛИН Команда
Понятия Процедуры Команды

Задание текущего веса линий, параметров отображения линий в зависимости от их веса и единиц веса линий

Меню "Формат": "Веса линий"

Контекстное меню: Нажмите правую кнопку мыши на кнопке "ВЕС" в строке состояния и выберите "Настройка".

Ввод команды: веслин ( или 'веслин для прозрачного вызова)

Откроется диалоговое окно "Параметры весов линий".

Если в ответ на подсказку "Команда" ввести -веслин, будет вызван вариант команды ВЕСЛИН, использующий интерфейс командной строки.

Темы:

  • Диалоговое окно «Параметры весов линий»
  • ВЕСЛИН вариант для командной строки


Диалоговое окно «Параметры весов линий»

В Команды
В Команды
Диалоговое окно «Параметры весов линий»
Понятия Процедуры Команды

Меню "Формат": "Веса линий"

Контекстное меню: Нажмите правую кнопку мыши на кнопке "ВЕС" в строке состояния и выберите "Настройка".

Ввод команды: веслин ( или 'веслин для прозрачного вызова)

Задание текущего значения и единиц веса линий, управление отображением и масштабом веса линий на вкладке "Модель", а также выбор значения веса линий ОБЫЧНЫЙ для слоев. Таблицу допустимых значений веса линий см. в разделе Коротко о весах линий Руководства пользователя.

Веса линий

Вывод списка допустимых значений весов линий. Значения веса линий можно выбирать из стандартного ряда значений, среди которых есть специальные значения ПОСЛОЮ, ПОБЛОКУ и ОБЫЧНЫЙ. Значение ОБЫЧНЫЙ определяется системной переменной LWDEFAULT и по умолчанию принимается равным 0,25 мм (0,01 дюйма). Новым слоям по умолчанию назначается вес линий ОБЫЧНЫЙ. В пространстве модели нулевое значение веса линий соответствует линии толщиной в один пиксел, а при выводе на печать наименьшей величине, обеспечиваемой используемым печатающим устройством.

Текущий вес линий

Выводится текущий вес линий. Для задания текущего веса линий следует выбрать нужное значение из списка и нажать «OK».

Единицы списка

Установка единиц измерения весов линий дюймы или миллиметры. Единицы для весов линий можно задать также с помощью системной переменной LWUNITS.

Миллиметры (мм)

Задание весов линий в миллиметрах.

Дюймы (д)

Задание весов линий в дюймах.

Отображать линии в соответствии с весами

Отображение линий в чертеже в соответствии с весом линий. Если флажок установлен, линии отображаются в соответствии с их весом и в пространстве листа, и в пространстве модели. Задать отображение линий с учетом их веса можно также с помощью системной переменной LWDISPLAY. Следует отметить, что если используемые веса линий представляются более чем одним пикселом, то время регенерации чертежа возрастает. Флажок "Отображать линии в соответствии с весами" следует снять, если производительность при работе с включенными весами линий падает. Состояние этого флажка не оказывает влияния на вид объектов при печати.

По умолчанию

Задание значения веса линий ОБЫЧНЫЙ, который используется по умолчанию для слоев. Исходное значение - 0,25 мм (0,01 дюйма). (Системная переменная LWDEFAULT)

Масштаб экранного отображения

Настройка масштаба экранного отображения весов линий для пространства модели. На вкладке «Модель» веса линий отображаются в пикселах. Толщина отображения остальных весов линий (в пикселах) устанавливается пропорционально их точным значениям, с которыми они выводятся на печать. Мониторы с большим разрешением позволяют настроить отображение веса линий с большей точностью. Толщина образцов весов линий в списке «Веса линий» отражает текущее положение указателя скользящей шкалы.

Все линии на экране, имеющие более одного пиксела в ширину, увеличивают время регенерации чертежа. Если необходимо оптимизировать производительность при работе на вкладке "Модель", то рекомендуется уменьшить масштаб экранного отображения весов линий или вообще отключить отображение линий в соответствии с весами.


ВЕСЛИН вариант для командной строки

В Команды
В Команды
ВЕСЛИН вариант для командной строки
Понятия Процедуры Команды

Если в ответ на подсказку "Команда" ввести -веслин, будет вызван вариант команды ВЕСЛИН, использующий интерфейс командной строки.

Текущий вес линий: текущий

Вес линий по умолчанию для новых объектов или [?]: Ввести допустимое значение веса линий или ?

Появляется текущее значение веса линий. Если весу линий не присвоено значение ПОСЛОЮ, ПОБЛОКУ или ОБЫЧНЫЙ, то значение отображается в миллиметрах (или дюймах).

Вес линий по умолчанию

Задание текущего веса линий. Значения веса линий могут выбираться из фиксированного ряда значений, среди которых есть специальные значения ПОСЛОЮ, ПОБЛОКУ и ОБЫЧНЫЙ. Численные значения весов линий могут выражаться в миллиметрах или дюймах. По умолчанию используются миллиметры. Если введено допустимое значение веса линий, то оно становится текущим значением. Если введено недопустимое значение веса линий, то текущим значением становится ближайшее допустимое значение.

Для настройки вывода на печать объектов с нестандартным весом линий можно воспользоваться Редактором таблиц стилей печати. См. раздел Задание веса и типа линий в Руководстве пользователя. Значение веса линии ОБЫЧНЫЙ задается системной переменной LWDEFAULT. Исходное значение - 0,25 мм (0,01 дюйма). В пространстве модели нулевое значение веса линий соответствует линии толщиной в один пиксел, а при выводе на печать — наименьшей величине, обеспечиваемой используемым печатающим устройством.

?—Вывести значения веса линий

Вывод списка допустимых значений веса линий в текущих единицах.

Примечание Если сохранить чертеж в формате AutoCAD Release 14 или более ранней версии, информация о весе линий будет отображаться на образце чертежа, даже если на чертеже, сохраненном в формате предыдущих версий, она не отображается.


ВЗАИМОД Команда

В Команды
В Команды
ВЗАИМОД Команда
Понятия Процедуры Команды

Подсвечивает накладывающиеся друг на друга 3D тела

Меню "Редактирование": "3D операции" » "Проверка взаимодействия"

Ввод команды: взаимод

Пульт управления: Панель создания 3D объектов (нажмите левую кнопку мыши на значке, чтобы развернуть), "Проверка взаимодействий"

Выберите первый набор объектов или [Выбор вложенных объектов/Режимы]: Выберите объекты любым способом или задайте опцию

Команда ВЗАИМОД подсвечивает накладывающиеся друг на друга 3D тела, создавая временное составное 3D тело из общего объема, образованного взаимодействием двух или более тел. Если создан всего один набор, команда ВЗАИМОД определяет области пересечения тел из набора друг с другом. Если задано два набора, команда ВЗАИМОД определяет области пересечения тел из первого набора с телами из второго. Если одни и те же 3D тела включены в оба набора, команда ВЗАИМОД игнорирует второй набор и производит поиск взаимодействий тел первого набора.

Выберите второй набор объектов или [Выбор вложенных объектов/проверка первого набора] <проверка>: Выберите объекты любым способом, нажмите ENTER для проверки наложения или введите н

Нажатие клавиши ENTER запускает проверку наложения пар 3D тел и отображает диалоговое окно "Проверка взаимодействий".

Если в командной строке ввести -взаимод, будут выведены подсказки для команды ВЗАИМОД.

Выбор вложенных объектов

Выбор отдельных объектов-тел, вложенных в блоки и внешние ссылки.

Выберите вложенные объекты или [вЫход] <Ы>: Выберите вложенные объекты или нажмите ENTER для возврата в обычный режим выбора объектов

Режимы

Отобразится диалоговое окно "Параметры взаимодействий".

Проверить

Отобразится диалоговое окно "Проверка взаимодействий".

Темы:

  • Диалоговое окно "Проверка взаимодействий"
  • Диалоговое окно "Проверка взаимодействий"
  • ВЗАИМОД (вариант для командной строки)


Диалоговое окно "Проверка взаимодействий"

В Команды
В Команды
Диалоговое окно "Проверка взаимодействий"
Понятия Процедуры Команды

Меню "Изменить": "3D операции" » "Взаимодействие"

Ввод команды: взаимод

Управление отображением объектов взаимодействий.

Объекты взаимодействий

Задание визуального стиля и цвета для объектов взаимодействий.

Визуальный стиль

Задание визуального стиля для объектов взаимодействий. (системная переменная INTERFEREOBJVS)

Цвет

Задание цвета для объектов взаимодействий. (системная переменная INTERFERECOLOR)

Подсветить взаимодействующую пару

Подсветка взаимодействующей пары тел.

Подсветить взаимодействие

Подсвечивание объектов взаимодействия, созданных из взаимодействующей пары.

Отображение видового экрана

Задание отображения видового экрана при проверке взаимодействий.

Визуальный стиль

Задание визуального стиля видового экрана при проверке взаимодействий. (системная переменная INTERFEREVPVS)


Диалоговое окно "Проверка взаимодействий"

В Команды
В Команды
Диалоговое окно "Проверка взаимодействий"
Понятия Процедуры Команды

Меню "Изменить": "3D операции" » "Взаимодействие"

Ввод команды: взаимод

Позволяет последовательно переключаться между объектами взаимодействия и выполнять зумирование. Также можно определить, будут ли удаляться объекты взаимодействий при закрытии диалогового окна.

Объекты взаимодействий

Вывод числа взаимодействий между каждым набором объектов во время выполнения команды ВЗАИМОД.

Первый набор

Вывод числа объектов первого набора.

Второй набор

Вывод числа объектов второго набора.

Обнаруженные взаимодействующие пары

Вывод числа обнаруженных взаимодействий выбранных объектов.

Подсветить

Подсветка взаимодействующих объектов при использовании команд Предыдущий и Следующий для последовательного переключения между ними.

Предыдущий

Подсветка предыдущего объекта взаимодействия.

Следующий

Подсветка следующего объекта взаимодействия.

Зумировать к паре

Зумирование к объектам взаимодействий с помощью команд Предыдущий и Следующий.

Зумирование

Закрытие диалогового окна и запуск команды ПОКАЗАТЬ.

Панорамирование

Закрытие диалогового окна и запуск команды ПАН.

3D орбита

Закрытие диалогового окна и запуск команды 3DОРБИТА.

Удалить созданные объекты взаимодействий при закрытии

Удаление созданных объектов взаимодействий при закрытии диалогового окна.

Закрыть

Закрытие диалогового окна и удаление созданных объектов, если этот параметр выбран.


ВЗАИМОД (вариант для командной строки)

В Команды
В Команды
ВЗАИМОД (вариант для командной строки)
Понятия Процедуры Команды

Если в командной строке ввести -взаимод, будет выведена следующая подсказка:

Проверка наложений объектов одного набора на объекты другого набора или проверка наложений объектов в одном наборе...

Выберите первый набор объектов или [Выбор вложенных объектов/]: Выберите объекты любым способом или задайте опцию

Выберите второй набор объектов или [Выбор вложенных объектов/проверкА текущего] <проверкА>: Выберите объекты любым способом, введите н или нажмите ENTER для проверки взаимодействий

Команда ВЗАИМОД подсвечивает все взаимодействующие 3D тела и выводит число выбранных объектов, а также число взаимодействующих пар.

Если создан всего один набор, команда ВЗАИМОД определяет области пересечения тел из набора друг с другом. Если задано два набора, команда ВЗАИМОД определяет области пересечения тел из первого набора с телами из второго. Если одни и те же 3D тела включены в оба набора, команда ВЗАИМОД игнорирует второй набор и производит поиск взаимодействий тел первого набора.

Создать объекты взаимодействий? [Да/Нет] <Н>: Введите д или н или нажмите ENTER для выбора опции по умолчанию

Если ответить д, на текущем слое создаются новые тела, занимающие перекрывающиеся области выбранных тел.

Если перекрывается несколько пар тел, положение пересечений на чертеже может быть не совсем ясным.

Зумировать к парам объектов взаимодействий? [Да/Нет] <Н>: Введите д или н или нажмите ENTER для выбора опции по умолчанию

Если перекрывающихся пар несколько, отобразится следующая подсказка:

Задайте опцию [Следующая пара/выХод] <Следующая>: Введите х или с или нажмите ENTER

После каждого следующего нажатия с или ENTER подсвечивается следующая пара 3D тел. Ввод х завершает работу команды.

Выбор вложенных объектов

Выбор отдельных объектов-тел, вложенных в блоки и внешние ссылки.

Выберите вложенные объекты или [вЫход] <Ы>: Выберите вложенные объекты или нажмите ENTER для возврата в обычный режим выбора объектов


ВИД Команда

В Команды
В Команды
ВИД Команда
Понятия Процедуры Команды

Сохраняются и восстанавливаются именованные виды, виды камеры, виды листов и стандартные виды

Меню "Вид": "Именованные виды"

Ввод команды: вид

Открывается диалоговое окно «Диспетчер видов».

Если в ответ на подсказку "Команда" ввести -вид, будет вызван вариант команды ВИД, использующий интерфейс командной строки.

Примечание Команда ВИД не может использоваться в прозрачном режиме.

Темы:

  • Диспетчер видов
  • Диалоговое окно «Новый вид»
  • Диалоговое окно "Фон"
  • Диалоговое окно "Настройка фонового изображения"
  • Команда ВИД - использование интерфейса командной строки


Диспетчер видов

В Команды
В Команды
Диспетчер видов
Понятия Процедуры Команды

Меню "Вид": "Именованные виды"

Ввод команды: вид

Создаются, устанавливаются, переименовываются, изменяются и удаляются именованные виды, включая именованные виды моделей и виды камеры, виды на листах и стандартные виды. Нажмите левую кнопку мыши на виде для отображения свойств данного вида.

Виды

Выводится список имеющихся видов. Можно развернуть любой из узлов (кроме узла "Текущий") для отображения входящих в него видов.

  • Текущий Отображается текущий вид и указываются его свойства "Вид" и "Сечение".
  • Виды моделей Отображается список именованных видов и камер и перечисляются "Общие" свойства, свойства "Вид" и "Сечение" для выбранного вида.
  • Виды на листах Отображается список видовых экранов на листе, определяющем вид, и указываются "Общие" свойства и свойства "Вид" для выбранного вида.
  • Стандартные виды Выводится список ортогональных и изометрических проекций, и указываются "Общие" свойства для выбранного вида.
Общие

Указанные далее свойства доступны для видов в разделе "Общие" списка свойств.

Имя

Отображается имя выбранной камеры. вид модели или вид на листе Камерам, создаваемым в чертеже, назначаются имена по умолчанию (Камера 1, Камера 2 и т.д.). В данном поле можно изменять имя.

Категория

Для видов моделей и видов на листах отображается категория вида (например, Уровни илиСечение и детали), определенная на чертеже или в подшивке, с которой связан выбранный вид.

Связь видового экрана

Исключительно для видов на листах указывается, связан ли именованный вид с видовым экраном на листе в наборе листов.

ПСК

Для видов моделей и видов на листах отображается имя пользовательской системы координат (мировой, без имени), сохраненной с именованным видом.

Восстановить Орто ПСК

Если для видов предварительного просмотра ортографическая проекция является текущей, восстанавливается связанная с ним ПСК. Эта опция устанавливает значение системной переменной UCSORTHO.

Установить по отношению к

Выбор базовой системы координат, относительно которой должен ориентироваться ортогональный вид. Системная переменная UCSBASE также определяет ориентацию стандартных ортогональных ПСК относительно МСК или именованной ПСК. Изменение значения системной переменной UCSBASE на вкладке "Ортогональные и изометрические виды" также изменяет ориентацию стандартных ортогональных ПСК.

Снимок слоев

Для видов моделей и видов на листах указывается, запоминаются ли с выбранным видом параметры включения/отключения текущего слоя.

Визуальный стиль

Исключительно для видов моделей указывается, сохраняется ли с видом визуальный стиль. Если выбрано "Нет", то с видом не связывается ни один из визуальных стилей. Подробнее о визуальных стилях см. Использование стиля отображения для модели.

Фон

Для видов моделей, для которых значение визуального стиля иное, чем "2D каркас", указывается переопределение фона (заливка, градиент или изображение), применяемое к выбранному виду. Открывается диалоговое окно "Фон".

Псевдоразрез

Исключительно для видов моделей отображается псевдоразрез, применяемый при восстановлении вида. Подробнее о псевдоразрезах см. СЕКПЛОСКОСТЬ.

Вид

Указанные далее свойства виды доступны для видов в разделе "Вид" списка свойств.

Камера X

Исключительно для текущих видов и видов моделей отображается координата X видовой камеры.

Камера Y

Исключительно для текущих видов и видов моделей отображается координата Y видовой камеры.

Камера Z

Исключительно для текущих видов и видов моделей отображается координата Z видовой камеры.

Цель X

Исключительно для текущих видов и видов моделей отображается координата X целевого объекта вида.

Цель Y

Исключительно для текущих видов и видов моделей отображается координата Y видовой камеры.

Цель Z

Исключительно для текущих видов и видов моделей отображается координата Z видовой камеры.

Угол наклона

Указывается текущий угол наклона вида.

Высота

Указывается высота вида.

Ширина

Указывается ширина вида.

Перспектива

Для текущего вида и вида модели указывается включенное/отключенное состояние вида в перспективе.

Фокусное расстояние (мм)

Для всех видов, кроме вида на листе, указывается фокусное расстояние (в миллиметрах). При изменении данного значение соответствующим образом изменяется настройка в "Поле зрения".

Поле зрения

Для всех видов, кроме вида на листе, указывается поле зрения по горизонтали (в единицах текущего угла). При изменении данного значения соответствующим образом изменяется фокусное расстояние.

Секущие плоскости

Для всех видов, кроме вида на листе, отображаются указанные ниже свойства секущей плоскости в разделе "Секущие плоскости" списка свойств:

Передняя плоскость

Указывается значение смещения передней секущей плоскости, если она используется в виде.

Задняя плоскость

Указывается значение смещения задней секущей плоскости, если она используется в виде.

Секущие плоскости

Задаются опции секущей плоскости. Можно выбирать опции Откл, Передняя вкл, Задняя вкл или Передняя и задняя вкл.

Установить

Восстанавливается выбранный вид.

Новый

Отображает диалоговое окно "Новый вид".

Обновить слои

Обновляется информация о слоях, сохраненная вместе с выбранным видом, для согласования с настройками видимости слоя в текущем пространстве модели или видовом экране листа.

Границы

Отображается выбранный вид с выделением остальной части области рисования более светлым цветом для показа границ именованного вида.

Удалить

Удаляется выбранный вид.


Диалоговое окно «Новый вид»

В Команды
В Команды
Диалоговое окно «Новый вид»
Понятия Процедуры Команды

Меню "Вид": "Именованные виды"

Ввод команды: вид

Создается именованный вид.

Имя вида

Указывается имя вида.

Категория

Указывается категория для именованного вида. Необходимо выбрать категорию из выпадающего списка, ввести имя новой категории или оставить это поле пустым.

Текущий экран

Использование границ текущего экрана в качестве границ для создаваемого вида.

Задать рамкой

В качестве нового вида используется окно, определяемое в области рисования с помощью рамки по двум противоположным углам.

Кнопка "Задать окно вида"

На время закрываются диалоговые окна "Создать вид" и "Диспетчер видов" с тем, чтобы можно было использовать устройство указания для определения противоположных углов окна "Новый вид".

Режимы

Задание опций для сохранения с именованным видом.

Сохранить снимок слоя с видом

Сохранение настроек видимости текущего слоя вместе с создаваемым видом.

ПСК

Для вида модели и вида на листе указывается ПСК для сохранения с новым видом.

Псевдоразрез

Исключительно для видов моделей указывается псевдосечение, применяемое при восстановлении вида.

Визуальный стиль

Исключительно для видов моделей указывается визуальный стиль для сохранения с видом. Подробнее о визуальных стилях см. Использование стиля отображения для модели.

Переопределение фона по умолчанию

Для видов моделей, для которых значение визуального стиля иное, чем "2D каркас", указывается переопределение фона (заливка, градиент или изображение), применяемое к выбранному виду. Открывается диалоговое окно "Фон".

Текущее переопределение

Отображается тип переопределения текущего фона (если он задан).

Окно просмотра

Отображается текущий фон (если он определен).

Кнопка «...»

Если выбрана опция "Переопределение фона по умолчанию", открывается диалоговое окно "Фон", в котором можно изменить выбор текущего фона.


Диалоговое окно "Фон"

В Команды
В Команды
Диалоговое окно "Фон"
Понятия Процедуры Команды

Меню "Вид": "Именованные виды"

Ввод команды: вид

Определяются тип фона, его цвет, положение и добавляемые эффекты для использования в виде.

Тип

Выводится список переопределений фона (нет, заливка, градиент, изображение или редактирование), которые можно применить к виду.

Заливка

Выбирается одноцветный сплошной фон.

Градиент

Задается двух- или трехцветный переходный фон. (Трехцветный переходный фон определяется установкой флажка "Три цвета"). Цвет выбирается нажатием левой кнопки мыши на клетке цвета. Отображает диалоговое окно "Выбор цвета".

Изображение

Для определения фона используется файл изображения.

Параметры заливки

Цвет

Открывается диалоговое окно "Выбор цвета".

Образец

Отображается выбранный цвет.

Параметры градиента

Задаются параметры для нового градиентного фона.

Три цвета

Указывается трехцветный градиент. Если не выбран, можно задать двухцветный градиент.

Верхний цвет

Открывается диалоговое окно "Выбор цвета". Выбрать цвет в качестве верхнего цвета градиента.

Средний цвет

Открывается диалоговое окно "Выбор цвета". Выбрать цвет в качестве среднего цвета градиента. Данная опция отображается только при установленном флажке "Три цвета".

Нижний цвет

Открывается диалоговое окно "Выбор цвета". Выбрать цвет в качестве нижнего цвета градиента.

Поворот

Указывается угол, на который может быть повернут переходный фон. Для сплошного фона и фона-изображения данная опция недоступна. Для установки значения используются текстовое окно или стрелки.

Образец

Отображается переходный фон.

Параметры изображения

Имя файла

Отображаются путь и имя файла изображения.

Обзор

Открывается диалоговое окно "Выбор файла". Выбрать файл изображения и нажать на "Открыть".

Регулировка изображения

Открывается диалоговое окно "Настройка фонового изображения"

Образец

Выводится изображение.


Диалоговое окно "Настройка фонового изображения"

В Команды
В Команды
Диалоговое окно "Настройка фонового изображения"
Понятия Процедуры Команды

Панель Вид:

Меню "Вид": "Именованные виды"

Ввод команды: вид

Управление опциями для фонового изображения, применяемыми к именованному виду в пространстве модели.

Позиция изображения

Определяется часть изображения, входящая в именованный вид.

Выбрать одну из указанных ниже опций.

  • Центр Изображение центрируется без изменения его формата или масштаба.
  • Растяжение Изображение центрируется и растягивается (масштабируется) вдоль оси X и оси Y, пока не займет вид целиком. Если предполагается печатать фоновое изображение, следует задать позицию изображения как "Растяжение".
  • ФрагментИзображение располагается в верхнем левом углу экранного вида и копируется столько раз, сколько требуется для заполнения пространства в соответствующем видовом экране. Формат и масштаб изображения не изменяются.

Отступ

Задается управление смещением изображения (недоступно, если для расположения изображения выбрана опция "Растяжение").

Смещение может выражаться значениями от -2000 до +2000 по любой из осей X и Y. Значения корректируются перетаскиванием регуляторов.

Масштаб

Задается масштаб изображения (недоступен, если для расположения изображения выбрана опция "Растяжение").

Масштаб может выражаться значениями от 0,1 до 10 по любой из осей X и Y. Значения корректируются перетаскиванием регуляторов.

Регулятор позиции по вертикали

Если выбрана опция "Смещение", осуществляется смещение изображения по вертикали (смещение по оси Y). Если выбрана опция "Масштаб", корректируется масштаб изображения по оси Y.

Регулятор позиции по горизонтали

Если выбрана опция "Смещение", осуществляется смещение изображения по горизонтали (смещение по оси X). Если выбрана опция "Масштаб", корректируется масштаб изображения по оси X.

Сброс

Для параметров "Смещение" или "Масштаб" восстанавливаются их значения по умолчанию.

Сохранять пропорции при масштабировании

Устанавливается взаимная зависимость значений по осям X и Y. Оба регулятора перемещаются соответствующим образом.

Если выбирается "Мозаика" и пользователь изменяет смещение таким образом, что растровый прямоугольник оказывается за пределами проекционного прямоугольника, растр не центрируется внутри области рисования при отображении вида. (Смещение в этом случае расценивается как относительное, а не абсолютное.) Если растр отображается за пределами проекционного прямоугольника, он не отображается в виде.


Команда ВИД - использование интерфейса командной строки

В Команды
В Команды
Команда ВИД - использование интерфейса командной строки
Понятия Процедуры Команды

Если в ответ на запрос "Команда" ввести -вид, вызывается вариант команды ВИД, использующий интерфейс командной строки.

Задайте опцию [?/Delete/Ортогонально/Восстановить/Сохранить/Режимы/Рамка]:

?—Список видов

Вывод списка именованных видов и камер текущего чертежа.

Введите имена видов для вывода списка <*>: Ввести символ-шаблон или нажать ENTER

Список содержит информацию об именах видов и пространстве, в котором они были созданы. М обозначает пространство модели, Л пространство листа.

Удалить

Удаление одного или нескольких именованных видов.

Имена видов для удаления: Ввести имя или список имен через запятую.

Ортогонально

Восстановление на текущем видовом экране одного из стандартных ортогональных видов.

Опция [сВерху/сНизу/спЕреди/сЗади/сЛева/сПрава] <сВерху>: Ввести опцию или нажать ENTER

Выбранный ортогональный вид ориентируется относительно системы координат, имя которой хранится в системной переменной UCSBASE. При восстановлении одного из ортогональных видов программа автоматически зумирует его до границ текущего видового экрана.

Восстановить

Восстановление на текущем видовом экране указанного именованного вида. Если с видом сохранена ПСК, то она также восстанавливается.

Имя вида для восстановления: Ввести имя

Восстанавливается также центральная точка и экранное увеличение сохраненного вида. Если при работе в пространстве листа восстанавливается вид, сохраненный в пространстве модели, программа выдает запрос на выбор видового экрана, на котором нужно восстановить вид.

Выполняется регенерация модели.

Выберите видовой экран для вида: Выбрать видовой экран

Выбрать видовой экран, щелкнув его границу. Выбираемый видовой экран должен быть активным. Программа переключается в пространство модели и восстанавливает вид на выбранном видовом экране.

При восстановлении вида пространства листа во время работы на вкладке листа в пространстве модели программа в пространство листа и восстанавливает вид. При работе в пространстве модели (на вкладке "Модель") не обеспечивается восстановление вида пространства листа.

Сохранить

Сохранение текущего видового экрана в качестве именованного вида.

Имя вида для сохранения: Ввести имя

При сохранении вида пользователю выдается информация о текущем значении системной переменной UCSVIEW. Для изменения настройки и включения или отключения данной опции используется опция ПСК команды ВИД.

Режимы

Различные параметры для команды ВИД.

Ввести опцию [Задний план/Категория/сНимок слоев/пСк/Визуальный стиль]:

Фон

Фон для использования в виде. Открывается диалоговое окно "Фон". Фоны видимы только в 3D визуальном стиле.

Категория

Категория для именованного вида. На вкладке "Список видов" в Диспетчере подшивок именованные виды отображаются по категориям.

Снимок слоев

Сохранение настроек видимости текущего слоя вместе с создаваемым видом.

ПСК

Включение/отключение сохранения ПСК и значения уровня вместе с создаваемыми именованными видами. Задается системная переменная UCSVIEW

Визуальный стиль

Задание или обновление визуального стиля для использования в виде. Следует указать визуальный стиль, ввести * для указания на отсутствие визуального стиля или вести ? для вывода списка всех визуальных стилей чертежа

Рамка

Сохранение части текущего видового экрана в качестве именованного вида.

Имя вида для сохранения: Ввести имя

Первый угол:

Противоположный угол:

При восстановлении вида на экран может быть выведена большая область, чем была задана рамкой. Однако при выводе вида на плоттер на чертеже будут изображены только те объекты, которые находятся в пределах этой рамки.


ВИЗСТИЛИ Команда

В Команды
В Команды
ВИЗСТИЛИ Команда
Понятия Процедуры Команды

Создание и изменение визуальных стилей и применение визуального стиля к видовому экрану.

Меню "Сервис": "Палитры" » "Визуальные стили"

Ввод команды: визстили

Пульт управления: Панель "Стиль отображения", "Диспетчер стилей отображения"

Отображается Диспетчер визуальных стилей .

Если в ответ на запрос "Команда" ввести -визстили, вызывается вариант команды ВИЗСТИЛИ, использующий интерфейс командной строки.

Примечание В пакете команда ВИЗСТИЛИ не вызывает автоматическое подавление "Диспетчера визуальных стилей". Необходимо использовать -визстили для отображения запросов в командной строке.

Темы:

  • Диспетчер визуальных стилей
  • Диалоговые окна "Создать новый визуальный стиль" и "Редактировать имя и описание"
  • Команда ВИЗСТИЛИ - использование интерфейса командной строки


Диспетчер визуальных стилей

В Команды
В Команды
Диспетчер визуальных стилей
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Визуальные стили"

Ввод команды: визстили

Пульт управления: Панель "Стиль отображения", "Диспетчер стилей отображения"

Создаются и изменяются визуальные стили.

"Диспетчер визуальных стилей" содержит панель образцов изображений визуальных стилей, имеющихся в чертеже, и указанные ниже панели свойств.

  • Параметры грани
  • Параметры среды
  • Параметры ребер

Примечание Изменения, внесенные на панели "Визуальные стили" пульта управления, создают временный визуальный стиль *Текущий*, который применяется к текущему видовому экрану. Эти настройки не сохраняются как именованный визуальный стиль.

Имеющиеся в чертеже визуальные стили

Отображаются образцы изображений визуальных стилей, имеющихся в чертеже. В панели параметров отображаются параметры грани, среды и ребер для выбранного визуального стиля.

Выбранный визуальный стиль отображается с желтым окаймлением. Имя выбранного визуального стиля отображается в нижней части панели.

Значки на образце изображения указывают на состояние визуального стиля.

  • Значок рядом с кнопкой "Применить выбранный визуальный стиль к текущему видовому экрану" внизу по центру указывает на визуальный стиль, применяемый к текущему видовому экрану.
  • Значок чертежа снизу посередине указывает визуальный стиль, который используется в текущем чертеже, но не используется в текущем видовом экране.
  • Значок программы внизу справа указывает на визуальный стиль по умолчанию, установленный в поставляемой программе.
Кнопки на полосе инструментов

Обеспечивается доступ с помощью кнопок к часто используемым опциям.

Создать новый визуальный стиль

Открывается диалоговое окно "Создать новый визуальный стиль", в котором можно ввести имя и дополнительное описание. Новый образец изображения помещается в конец панели и выбирается.

Применить выбранный визуальный стиль к текущему видовому экрану

Выбранный визуальный стиль применяется к текущему видовому экрану.

Экспортировать выбранный визуальный стиль в инструментальную палитру

Создается инструмент для выбранного визуального стиля, помещаемый в активную инструментальную палитру. Если окно "Инструментальные палитры" закрыто, оно открывается, и инструмент помещается в верхнюю палитру.

Удалить выбранный визуальный стиль

Удаляется визуальный стиль из чертежа. Не допускается удаление визуального стиля по умолчанию и используемого визуального стиля.

Контекстное меню

Обеспечивается доступ через меню к опциям, устанавливаемым с помощью кнопок на планке инструментов, а также к указанным ниже дополнительным опциям, устанавливаемым с помощью контекстного меню. Необходимо нажать правую кнопку мыши на изображении образца в панели для получения доступа в контекстное меню.

Применить ко всем видовым экранам

Выбранный визуальный стиль применяется ко всем видовым экранам чертежа.

Редактировать описание

Открывается диалоговое окно "Редактировать описание", в котором можно добавить описание или изменить имеющееся описание. Описание отображается в подсказке при установке курсора на образец изображения.

Копировать

Образец изображения визуального стиля копируется в буфер обмена. Можно вставить его в окно "Инструментальные палитры" для создания инструмента визуального стиля либо в панель "Доступные визуальные стили" для создания копии.

Вставить

Инструмент визуального стиля вставляется в панель, а сам визуальный стиль добавляется в чертеж; либо копия визуального стиля добавляется в панель "Доступные визуальные стили".

Размер

Устанавливается размер образцов изображений. Опция "Полное" вызывает заполнение панели одним изображением.

Восстановить значения по умолчанию

Для одного из визуальных стилей по умолчанию восстанавливаются исходные параметры.

Параметры грани

Определяется внешний вид граней в видовом экране.

Кнопка "Интенсивность подсветки"

Изменяет значение "Интенсивность подсветки" с положительного на отрицательное и наоборот.

Кнопка "Непрозрачность"

Изменяет значение "Непрозрачность" с положительного на отрицательное и наоборот.

Стиль грани

Определяется раскрашивание на гранях. (Системная переменная VSFACESTYLE)

  • Опция "Реалистичная" (по умолчанию) с максимально возможным приближением отображает то, как грань выглядит на самом деле.
  • Опция "Гуч" определяет использование гаммы холодных и теплых цветов вместо темных и светлых для улучшения отображения граней, которые могли бы быть затенены и плохо видимы в реалистичном представлении.
  • "Нет" не применяется к стилю грани. Другие параметры грани заблокированы.

Качество освещения

Устанавливается освещение в зависимости от необходимости отображения граней на модели. По умолчанию задается сглаживание. (Системная переменная VSLIGHTINGQUALITY)

Интенсивность подсветки

Регулируется интенсивность подсветок на гранях без материалов. (Системная переменная VSFACEHIGHLIGHT)

Прозрачность

Управляет непрозрачностью и прозрачностью граней в видовом экране. (системная переменная VSFACEOPACITY)

Материалы и цвет

Определяет отображение материалов и цвета на гранях.

Материалы

Определяет, отображаются ли материалы и текстуры. (системная переменная VSMATERIALMODE)

Режим цвета грани

Определяет отображение цветов на гранях. (Системная переменная VSFACECOLORMODE)

  • Нормальный Не применяется к модификатору цвета грани.
  • Монохромное Модель отображается в оттенках заданного пользователем цвета.
  • Оттенок Изменяются оттенок и насыщенность цвета грани.
  • Уменьшение насыщенности Цвет смягчается путем сокращения компоненты его насыщенности на 30 процентов.

Монохромный цвет/Оттенок цвета

Открывается диалоговое окно "Выбор цвета", в котором можно выбрать монохромный цвет или оттенок цвета в зависимости от режима цвета грани. Данная настройка недоступна, если для цвета грани выбран режим "Нормальный" или "Уменьшение насыщенности". (Системная переменная VSMONOCOLOR)

Параметры среды

Регулируются тени и фон.

С тенями

Регулируется отображение теней: без теней, только тени на земле или полные тени. Для повышения качества изображения следует отключить тени. (Системная переменная VSSHADOWS)

Примечание Для полного отображения теней требуется аппаратное ускорение. Когда "Ускорение для геометрии" отключено, тени не могут быть отображены полностью. (Для перехода к этим настройкам в командной строке введите графнастр. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" установите флажок "Ручная настройка".)

Фон

Определяет, отображается ли фон в видовом экране. (Системная переменная VSBACKGROUNDS)

Параметры ребер

Определяет способ отображения ребер.

Режим ребер

Для отображения ребер устанавливается режим "Ребра граней", "Изолинии" или "Нет". (Системная переменная VSEDGES)

Цвет

Открывается диалоговое окно "Выбор цвета", в котором можно задавать цвет для ребер. (Системная переменная VSEDGECOLOR)

Ребра-модификаторы

Определяются параметры, применяемые ко всем режимам ребер, кроме режима "Нет".

Кнопка "Выступание" и настройка

Отрезки продлеваются за их пересечения для создания эффекта рисования от руки. Кнопка обеспечивает включение и отключение эффекта выступания. Во включенном состоянии можно изменять настройку. (Системная переменная VSEDGEOVERHANG)

Кнопка "Мерцание" и настройка

Линиям придается вид эскизов. Настройки принимают значения "Низкое", "Среднее" и "Высокое", и любую из них можно отключить. С помощью кнопок можно включать и отключать эффект мерцания. Во включенном состоянии можно изменять настройку. (Системная переменная VSEDGEJITTER)

Угол сгиба

Определяется угол, при котором кромки внутри грани становятся невидимыми, для получения эффекта сглаживания. Эта опция доступна, когда системная переменная VSEDGES установлена в состояние отображения ребер граней. (Системная переменная VSEDGESMOOTH)

Коэффициент недовода %

Указывается размер зазора, отображаемого в области покрытия одного объекта другим. Данная опция доступна, если выбраны визуальные стили "Концептуальный" или "3D скрытый" либо визуальный стиль на их основе. Если значение коэффициента недовода больше 0, ребра силуэта не отображаются. (Системная переменная VSHALOGAP)

Ребра быстрых силуэтов

Определяют параметры, применимые к ребрам силуэтов. Ребра силуэта не отображаются на каркасе или на прозрачных объектах. (Системная переменная VSSILHEDGES)

Видимые

Определяется отображение ребер силуэтов. (Системная переменная VSSILHEDGES)

Ширина

Указывается ширина, при которой отображаются ребра силуэтов. (Системная переменная VSSILHWIDTH)

Скрытые ребра

Определяются параметры, применяемые к скрытым ребрам, если режимом ребра является "Ребра граней".

Видимые

Определяет, отображаются ли скрытые ребра. (Системная переменная VSOBSCUREDEDGES)

Цвет

Отображается диалоговое окно "Выбор цвета", в котором можно задавать цвет для скрытых ребер. (Системная переменная VSOBSCUREDCOLOR)

Тип линий

Задается тип линии для скрытых ребер. (системная переменная VSOBSCUREDLTYPE)

Ребра пересечения

Определяются параметры, применяемые к ребрам пересечений, если установлен режим "Ребра граней".

Видимые

Определяет, отображаются ли ребра пересечений. (Системная переменная VSINTERSECTIONEDGES).

Примечание Для увеличения производительности отключите отображение ребер пересечений.

Цвет

Открывается диалоговое окно "Выбор цвета", в котором можно задавать цвет для ребер пересечения. Системная переменная VSINTERSECTIONCOLOR)

Тип линий

Задается тип линий для ребер пересечения. (системная переменная VSINTERSECTIONLTYPE)


Диалоговые окна "Создать новый визуальный стиль" и "Редактировать имя и описание"

В Команды
В Команды
Диалоговые окна "Создать новый визуальный стиль" и "Редактировать имя и описание"
Понятия Процедуры Команды

Назначается имя визуальному стилю, и обеспечивается пространство для описания.

Имя

Визуальному стилю присваивается имя.

Описание

Создается дополнительное описание для визуального стиля. Описание отображается в подсказке при установке курсора на образец изображения.


Команда ВИЗСТИЛИ - использование интерфейса командной строки

В Команды
В Команды
Команда ВИЗСТИЛИ - использование интерфейса командной строки
Понятия Процедуры Команды

Ввод команды: визстили

Если в ответ на запрос "Команда" ввести -визстили, вызывается вариант команды ВИЗСТИЛИ, использующий интерфейс командной строки.

Ввести опцию [Установить/Сохранить как/Переименовать/Удалить/?]:

Установить

Ввести опцию [2dкаркас/3dкаркас/3dскрытыq/Реалистичный/Концептуальныйl/Другой]<текущий>:

Эти опции совпадают с опциями в ТЕКВИЗСТИЛЬ.

Сохранить как

Сохранить текущий визуальный стиль как или [?]: Ввести имя или ввести ? для вывода списка всех визуальных стилей в чертеже

Имя

Сохраняется визуальный стиль под именем, заданным пользователем.

Примечание Сохранение визуального стиля возможно только в пространстве модели. Если вводится имя, уже используемое в качестве имени визуального стиля, следует либо заменить имеющийся визуальный стиль, либо ввести другое имя.

?-Список визуальных стилей

Выводится список визуальных стилей чертежа и заново отображается запрос "Сохранить как".

Переименовать

Укажите визуальный стиль для переименования [?] <последняя по времени запись>:

Имя

Переименовывается визуальный стиль.

?-Список визуальных стилей

Выводится список визуальных стилей чертежа и повторно отображается запрос на переименование.

Удалить

Имя удаляемого визуального стиля [?]:

Имя

Удаляется визуальный стиль

?-Список визуальных стилей

Выводится список визуальных стилей чертежа и повторно отображается запрос на удаление.

?-Список визуальных стилей

Выводится список визуальных стилей чертежа и повторно отображается основной запрос.


ВИЗСТИЛИЗАКР Команда

В Команды
В Команды
ВИЗСТИЛИЗАКР Команда
Понятия Процедуры Команды

Закрывается "Диспетчер визуальных стилей".

Ввод команды: визстилизакр

Закрывается Диспетчер визуальных стилей.


ВНЕДРИТЬ Команда

В Команды
В Команды
ВНЕДРИТЬ Команда
Понятия Процедуры Команды

Внедрение одного или нескольких описаний именованных объектов во внешней ссылке в текущий чертеж

Панель "Ссылки":

Меню "Редактирование": "Объект" » "Внешние ссылки" » "Внедрить"

Ввод команды: внедрить

Откроется диалоговое окно "Внедрение символов".

Если в ответ на подсказку "Команда:" ввести -внедрить, будет вызван вариант команды ВНЕДРИТЬ, использующий интерфейс командной строки.

Примечание Опция "Внедрить" команды ССЫЛКА позволяет внедрить файл внешней ссылки. Команда ВНЕДРИТЬ используется для одиночных зависимых описаний.

Темы:

  • Диалоговое окно "Внедрение"
  • ВНЕДРИТЬ (вариант для командной строки)


Диалоговое окно "Внедрение"

В Команды
В Команды
Диалоговое окно "Внедрение"
Понятия Процедуры Команды

Панель "Ссылки":

Меню "Редактирование": "Объект" » "Внешняя ссылка" » "Внедрить"

Ввод команды: внедрить

Добавление в чертеж зависимых от внешней ссылки именованных объектов (таких как блоки, размерные стили, слои, типы линий, текстовые стили).

Внешние ссылки

Вывод списка всех внешних ссылок, вставленных в текущий чертеж. Для просмотра описаний именованных объектов, содержащихся во внешней ссылке, следует выбрать внешнюю ссылку (двойным нажатием левой кнопки мыши).

Внедряемые описания

Вывод списка описаний, зависимых от внешней ссылки именованных объектов, которые подлежат внедрению в главный чертеж.

Добавить

Перенос выделенных в списке "Внешние ссылки" описаний именованных объектов в список "Внедряемые описания".

Исключить

Перенос зависимых от внешней ссылки описаний именованных объектов, выделенных в списке "Внедряемые описания", обратно в таблицу описаний.


ВНЕДРИТЬ (вариант для командной строки)

В Команды
В Команды
ВНЕДРИТЬ (вариант для командной строки)
Понятия Процедуры Команды

Если в ответ на подсказку "Команда:" ввести -внедрить, будет вызван вариант команды ВНЕДРИТЬ, использующий интерфейс командной строки.

Тип внедряемых символов [Блок/Размстиль/Слой/Типлиний/СТиль]: Задать опцию

На основе указанной опции выдается запрос зависимого от внешней ссылки именованного объекта (символа), например, блока, размерного стиля, слоя, типа линий или текстового стиля.

Имена зависимых символов типа Символ : Ввести список имен или * для переноса всех зависимых от внешних ссылок именованных объектов (символов) из этой таблицы описаний

Каждое имя зависимого символа должно быть полным и содержать имя файла внешней ссылки, отделенное символом вертикальной черты ( | ).

Указанные зависимые от внешней ссылки именованные объекты добавляются в чертеж. После этого их можно использовать, как любой другой именованный объект. Символ вертикальной черты (|) из каждого зависимого от внешней ссылки именованного объекта заменяется тремя новыми символами: число (обычно 0) между двумя знаками доллара ($).

При внедрении слоя, которому присвоен тип линий, отличный от CONTINUOUS, этот тип линий будет также внедрен командой ВНЕДРИТЬ. При использовании команды ВНЕДРИТЬ для блока все размерные стили, слои, типы линий или текстовые стили, на которые ссылаются объекты этого блока, также внедряются в чертеж. Если блок содержит внешнюю ссылку, команда ВНЕДРИТЬ внедряет эту ссылку и все зависимые именованные объекты.


ВНССЫЛКИ Команда

В Команды
В Команды
ВНССЫЛКИ Команда
Понятия Процедуры Команды

Открытие палитры "Внешние ссылки"

Панель "Ссылки":

Меню "Вставка": "Внешние ссылки"

Ввод команды: внссылки

Команда ВНССЫЛКИ открывает палитру "Внешние ссылки", если эта палитра была неактивна. Если палитра активна, но скрыта, то команда ВНССЫЛКИ выведет ее на экран. Если нажать кнопку мыши где-либо за пределами палитры "Внешние ссылки", палитра возвращается в скрытый режим отображения.

Примечание При вставке файлов из палитры "Внешние ссылки" системная переменная FILEDIA игнорируется.

Темы:

  • Палитра "Внешние ссылки"
  • Инструментальные кнопки палитры "Внешние ссылки"
  • Панель ссылок с отображением данных в режимах "Список / Дерево"
  • Панель ссылок на файлы - контекстные меню и функциональные клавиши
  • Панель "Подробности / Предварительный просмотр"


Палитра "Внешние ссылки"

В Команды
В Команды
Палитра "Внешние ссылки"
Понятия Процедуры Команды

Панель "Ссылки":

Меню "Вставка": "Внешние ссылки"

Ввод команды: внссылки

Палитра "Внешние ссылки" предназначена для собирания, вывода на экран и управления файлами ссылок, например, связанными ссылкой чертежами (Xrefs), вставленными подложками DWF и импортированными растровыми изображениями.

Палитра "Внешние ссылки" содержит набор инструментальных кнопок, две панели данных двойного режима отображения и поле сообщений. Верхняя панель данных, которая называется Панель ссылок на файлы, может быть настроена для вывода ссылок в режиме списка или в режиме дерева. Контекстные меню и функциональные клавиши обеспечивают опции работы с файлами. Нижняя панель данныхПанель "Подробности / Предварительный просмотр" выводит на экран свойства выбранных ссылок или отображает выбранную ссылку в уменьшенном окне предварительного просмотра. Расположенное в нижней части палитры поле сообщений выводит относящуюся к выбранным ссылкам информацию, которая может быть существенна в конкретных условиях.

Темы:

  • Инструментальные кнопки палитры "Внешние ссылки"
  • Панель ссылок с отображением данных в режимах "Список / Дерево"
  • Панель ссылок на файлы - контекстные меню и функциональные клавиши
  • Панель "Подробности / Предварительный просмотр"


Инструментальные кнопки палитры "Внешние ссылки"

В Команды
В Команды
Инструментальные кнопки палитры "Внешние ссылки"
Понятия Процедуры Команды

Расположенные в верхней части палитры инструментальные кнопки дают пользователю возможность управлять типами вставляемых в чертеж файлов и способность обновлять статус уже вставленных ссылок.

Вставить файл

Первая кнопка, расположенная в верхней части палитры "Внешние ссылки", позволяет вставлять в чертеж файлы DWG, DWF или растровые изображения. По умолчанию, исходным состоянием этой кнопки является состояние "Вставить файл DWG". Кнопка сохраняет тот тип вставки, который использовался последним. Таким образом, после вставки DWF-файла кнопка останется в состоянии "Вставить файл DWF" до тех пор, пока не будет выбран другой тип вставляемого файла.

Раскрывающееся меню "Вставить файл"

Раскрывающееся меню "Вставить файл" выводит на экран список возможных для вставки типов файлов. Меню содержит следующие позиции:

  • Вставка файла DWG - запускает команду ДВГВСТАВИТЬ.
  • Вставка изображения - запускает команду ИЗОБВСТАВИТЬ.
  • Вставка файла DWF - запускает команду ДВФВСТАВИТЬ.

  • Вставка из Vault - позволяет обратиться к данным, сохраняемым клиентом Vault.

Примечание Позиция "Вставка из Vault" отображается только в том случае, если клиент Vault установлен. Доступ к клиенту Vault возможен только для пользователя, имеющего подписку Autodesk.

Обновить

Повторно синхронизирует данные состояния файла ссылки с данными в памяти. Обновление взаимодействует в основном с Autodesk Vault.

Раскрывающееся меню "Обновить"

Раскрывающееся меню "Обновить" предоставляет две возможности выбора:

  • Обновить
  • Обновление всех ссылок


Панель ссылок с отображением данных в режимах "Список / Дерево"

В Команды
В Команды
Панель ссылок с отображением данных в режимах "Список / Дерево"
Понятия Процедуры Команды

Верхнюю панель ссылок на файлы можно настроить, чтобы она отображала список всех внешних ссылок, вставленных пользователем в чертеж. Пользователь имеет возможность настроить отображение вставленных ссылок в виде списка или в виде древовидной структуры. По умолчанию, для панели ссылок на файлы принят режим отображения в виде списка.

Список

Если панель ссылок на файлы настроена на отображение списка, пользователю предоставляется список всех внешних ссылок, связанных с данным чертежом. В списке можно выбрать сразу несколько ссылок. К содержащимся в списке данным относятся имя, статус, размер файла, тип файла, дата создания и сохраненный путь.

Значки ссылок

Каждой ссылке файла предшествует значок, соответствующий этому типу ссылки.

Указывает значок текущего чертежа. Она представляет основной чертеж, к которому прикрепляются все внешние ссылки.

Указывает прикрепление подложки DWF.

Указывает прикрепление DWG (внешней ссылки).

Указывает наложение DWG (внешней ссылки).

Указывает прикрепление растрового изображения.

Имя

В столбце имени первой записью всегда является имя текущего чертежа, за которым следуют имена дополнительных вставленных файлов, выстроенные в порядке их вставки.

Положение

Положение файла ссылки:

  • Загружен - файл ссылки в настоящий момент вставлен в чертеж.
  • Выгружен - файл ссылки помечен для выгрузки из чертежа.
  • Не найден - в рамках путей корректного поиска файл ссылки отсутствует.
  • Не обработан - невозможно осуществить чтение файла ссылки.
  • Разорван - данный файл ссылки вставлен в другой файл, статус которого "Не обработан".

Размер

Размер вставленной ссылки.

Тип

Тип вставленного файла ссылки. Файлы чертежа (Внешние ссылки) отображаются как прикрепления или наложения, растровые изображения показывают формат файла, а подложки DWF выводятся списком, в порядке соответствующих им типов файлов.

Дата

Дата создания или последнего по времени сохранения файла ссылки.

Сохр. путь

Отображает путь, сохраняемый вместе с чертежом при выполнении вставки файла ссылки.

Дерево

В режиме дерева панель ссылок на файлы отображает описания всех файлов ссылок и уровни их вложения во внешние ссылки.

На верхнем уровне дерева всегда показывается текущий чертеж. Файлы ссылок отображаются на следующем уровне. Имеется возможность открывать файлы ссылок, содержащие собственные вложенные ссылки на файлы, и показывать более глубокие уровни. При режиме отображения в виде дерева одновременно можно выбрать только одну ссылку на файл.


Панель ссылок на файлы - контекстные меню и функциональные клавиши

В Команды
В Команды
Панель ссылок на файлы - контекстные меню и функциональные клавиши
Понятия Процедуры Команды

При работе с панелью ссылок на файлы можно вывести на экран одно из нескольких возможных контекстных меню, нажав правую кнопку мыши на ссылках или на незаполненных областях панели. Приведенные ниже таблицы содержат элементы контекстного меню, выводимые на экран при определенных условиях.

Ничего не выбрано

Если ни одна ссылка не выбрана, то при нажатии правой кнопки мыши открывается контекстное меню, предлагающее следующие функции:

Элемент меню | Описание
Обновление всех ссылок | Обновление всех файлов ссылок. (При отсутствии вставленных ссылок на файлы эта функция недоступна.)
Выбрать все | Выбор всех ссылок на файлы, за исключением текущего чертежа. В режиме дерева этот элемент меню не отображается.
Вставить DWG | Запускает команду ДВГВСТАВИТЬ.
Вставка изображения | Запускает команду ИЗОБВСТАВИТЬ.
Вставить DWF | Запускает команду ДВФВСТАВИТЬ.
Вставка из Vault | Открывает диалоговое окно сервера Vault "Вставить файл", которое выводится на экран только если установлен клиент Vault.
Вход в систему | Позволяет пользователю войти в систему сервера Vault . Если пользователь уже вошел в систему, этот элемент меню недоступен. Элемент отображается только в том случае, если установлен клиент Vault.
Выход из системы | Позволяет пользователю выйти из системы сервера Vault. Если пользователь уже вышел из системы, этот элемент меню недоступен. Элемент отображается только в том случае, если установлен клиент Vault.
Закрыть | Закрывает палитру внешних ссылок.
Выбрана ссылка на DWG, на изображение, на DWF

Если выбрана какая-либо ссылка на файл, то нажатие на правую кнопку мыши выведет на экран контекстное меню, представляющее следующие функции:

Элемент меню

Описание

Статус ссылки

Открыть

Открывает выбранную ссылку в заданном операционной системой приложении.

Данная команда доступна только по отношению к ссылкам на файлы, имеющим статус "Загружен". Команда недоступна при статусе "Выгружен", "Не найден" или "Не обработан".

Вставить

Открывает диалоговое окно, соответствующее типу выбранной ссылки.

  • Выбор вхождения DWG открывает диалоговое окно "Внешняя ссылка".
  • Выбор вхождения растрового изображения открывает диалоговое окно "Изображение".
  • Выбор ссылки на DWF открывает диалоговое окно "Подключение подложки DWF".

Всегда доступна - на эту функцию положение файла не влияет.

Выгрузить

Выгружает выбранные ссылки на файлы.

Всегда доступна - на эту функцию положение файла не влияет.

Обновить

Обновляет выбранные ссылки на файлы.

Всегда доступна - на эту функцию положение файла не влияет.

Удалить

Удаляет вхождения выбранных ссылок на файлы.

Всегда доступна - на эту функцию положение файла не влияет.

Внедрить

Отображает диалоговое окно "Внедрение ссылок". Выбранное вхождение DWG связывается с текущим чертежом. Функция доступна только для связанных ссылками файлов DWG.

Данная команда доступна только по отношению к ссылкам на файлы, имеющие статус "Загружен". Команда недоступна при статусе "Выгружен", "Не найден" или "Не обработан".

Установить в

Возврат в Vault измененного файла, проверка которого осуществлялась вне Vault. Предыдущая версия сохраняется архиве. Команда отображается, только если установлен клиент Vault.

Определяется функциями Vault.

Установить вне

Извлечение предназначенной для чтения/записи копии файла, сохраняемого в Vault. Команда отображается, только если установлен клиент Vault.

Определяется функциями Vault.

Отменить команду "Установить вне"

Освобождение файла, установленного пользователем вне Vault. Команда отображается, только если установлен клиент Vault.

Определяется функциями Vault.
Доступ к командам посредством функциональных клавиш

К некоторым из функций панели ссылок на файлы можно обратиться с помощью функциональных клавиш.

  • Клавиша F2 - доступ к функции "Переименовать", если выбрана одна ссылка.
  • Клавиша F3 - переключатель для режима отображения в виде списка.
  • Клавиша F4 - переключатель для режима отображения в виде дерева.


Панель "Подробности / Предварительный просмотр"

В Команды
В Команды
Панель "Подробности / Предварительный просмотр"
Понятия Процедуры Команды

Нижнюю панель данных палитры "Внешние ссылки" можно настроить для вывода на экран свойств ссылок или для вывода образца изображения выбранной ссылки на файл.

Панель "Подробности"

В режиме "Подробности" выводятся свойства выбранной ссылки на файл. Каждая ссылка имеет основной набор свойств, а некоторые ссылки, такие как связанные ссылкой изображения, имеют свойства, специфичные данному типу файла. К основному набору подробностей относятся имя, статус, размер файла, тип файла, дата создания, сохраненный путь, обнаруживаемый вместе с версией пути и файла, если клиент Vault установлен. Некоторые из свойств можно редактировать.

Имя

Вывод на экран имени файла. Редактировать это свойство можно только в случае, если выбрана одна ссылка на файл. Если выбрано несколько ссылок, в поле "Имя" отображается *Разные*. Редактирование этого свойства возможно для всех ссылок на файлы.

Положение

Указывает на состояние "Загружен", "Выгружен" или "Не найден" для ссылки на файл. Редактирование этого свойства невозможно.

Размер

Указывает размер файла выбранной ссылки. Для ссылок на файлы, имеющих статус "выгружена" или "не найдена", размер не отображается. Редактирование этого свойства невозможно.

Тип

Указывает на то, является ссылка вставкой или наложением, а также указывает на тип файла изображения или подложки DWF. Редактирование этого свойства невозможно.

Дата

В данной графе выводится дата последней модификации ссылки на файл. Дата не выводится на экран, если ссылка на файл имеет статус "Выгружена" или "Не найдена". Редактирование этого свойства невозможно.

Сохр. путь

Показывает сохраненный путь выбранной ссылки на файл (это необязательно место, где находится файл). Редактирование этого свойства невозможно.

Обнаружено в

Отображение полного пути к выбранной в настоящий момент ссылке. Это место фактического нахождения связанного ссылкой файла. Оно необязательно совпадает с сохраненным путем. Нажатие на кнопку […] выводит на экран диалогового окна "Выбор файла изображения", в котором можно выбрать другой путь или имя файла. Данные также можно ввести с клавиатуры непосредственно в поле пути. Если новый путь введен корректно, то внесенные изменения сохраняются посредством функции "Сохраненный путь".

Версия файла

Свойство "Версия файла", определяемое клиентом Vault. Это свойство отображается только в случае, если пользователь вошел в систему Vault.

Специальные свойства изображения

При выборе связанного ссылкой изображения на экран выводятся дополнительные свойства. Ни одно из добавленных свойств изображения не может быть отредактировано.

Цветовая система

Вывод на экран цветовой системы.

Глубина цветности

Объем информации, заключенной в каждом пикселе растрового изображения. Чем выше значения насыщенности цвета, тем ровнее переходы между степенями тонирования.

Пиксельная ширина

Ширина растрового изображения, измеряемая в пикселах.

Пиксельная высота

Высота растрового изображения, измеряемая в пикселах.

Разрешение

Разрешение по ширине и по высоте в точках на дюйм (т/дюйм).

Обычный размер (в единицах AutoCAD)

Ширина и высота растрового изображения, измеряемые в единицах AutoCAD.

Панель предварительного просмотра

В режиме предварительного просмотра на экран выводится образец ссылки на файл, выбранной с помощью Панели ссылок на файлы.

Изображение в режиме предварительного просмотра выводится на экран только в случае, если в Панели ссылок на файлы выбрана только одна ссылка. Другие органы управления в этой панели данных отсутствуют. Если ни один файл ссылки не выбран, панель предварительного просмотра представляет собой сплошное серое поле. Если функция предварительного просмотра недоступна, в центре панели выводится сообщение "Предварительный просмотр недоступен".

Поле сообщений

Под панелью "Подробности / Предварительный просмотр" располагается поле сообщений, в котором выводится информация о конкретных ссылках, выбранных пользователем. Если пользователь выбирает одну или несколько вложенных ссылок, в этом поле выводится информация об этих ссылках. Сообщения появляются и в том случае, если пользователь решает изменить имя ссылки.


ВНССЫЛКИЗАКРЫТЬ Команда

В Команды
В Команды
ВНССЫЛКИЗАКРЫТЬ Команда
Понятия Процедуры Команды

Закрывает палитру внешних ссылок

Ввод команды: ВНССЫЛКИЗАКРЫТЬ

Команда ВНССЫЛКИЗАКРЫТЬ закрывает палитру "Внешние ссылки". Если в момент выполнения этой команды палитра "Внешние ссылки" выведена на экран, в скрытом или в открытом режиме отображения, она закрывается.


ВОССТАН Команда

В Команды
В Команды
ВОССТАН Команда
Понятия Процедуры Команды

Восстановление поврежденного чертежа

Меню "Файл": » "Утилиты"; "Восстановить"

Ввод команды: восстан

В диалоговом окне "Выбор файла" (стандартном окне выбора файлов) ввести или выбрать имя поврежденного файла чертежа. Результаты отобразятся в текстовом окне.

Если системная переменная FILEDIA равна 0, то команда ВОССТАН отображает следующий запрос в командной строке:

Имя файла чертежа для восстановления

По запросу следует ввести тильду ~ для игнорирования значения FILEDIA и отображения диалогового окна "Восстановление чертежа".

Примечание Команда ВОССТАН выполняет операции восстановления или проверки только для файлов DWG. Операция восстановления для файла DHF™ приводит только к открытию этого файла.


ВОССТАНЧЕРТЕЖА Команда

В Команды
В Команды
ВОССТАНЧЕРТЕЖА Команда
Понятия Процедуры Команды

Отображает список имен файлов чертежей, подлежащих восстановлению после сбоя системы

Меню "Файл": "Восстановление чертежа"

Ввод команды: восстанчертежа

Вызов диспетчера восстановления чертежей.

Темы:

  • Диспетчер восстановления чертежей


Диспетчер восстановления чертежей

В Команды
В Команды
Диспетчер восстановления чертежей
Понятия Процедуры Команды

Меню "Файл": "Утилиты" » подменю "Диспетчер восстановления чертежей"

Ввод команды: восстанчертежа

Диспетчер восстановления чертежей отображает список всех файлов чертежей, которые были открыты во время программного или системного сбоя. Можно предварительно просмотреть и открыть любой файл чертежа или резервную копию файла, чтобы выбрать именно тот, который необходимо сохранить в качестве исходного DWG-файла.

Резервное копирование

Отображает список имен файлов чертежей, которые, возможно, необходимо восстановить после программного или системного сбоя. Элемент чертежа верхнего уровня состоит из набора файлов, связанных с каждым чертежом. Для просмотра имен файлов чертежей и резервных копий файлов, подлежащих восстановлению, необходимо раскрыть элемент чертежа верхнего уровня. Если опция доступна, отобразятся до 4 файлов, приведенных ниже.

  • Восстановленный файл чертежа, сохраненный во время программного сбоя (DWG, DWS)
  • Файл автоматического сохранения, также называемый файлом “автосохранения” (SV$)
  • Файл резервной копии чертежа (BAK)
  • Исходный файл чертежа (DWG, DWS)

Как только открывается и сохраняется файл чертежа или резервная копия файла, соответствующий элемент чертежа верхнего уровня удаляется из раздела "Файлы архива".

Подробности

Сведения о выбранном элементе в разделе "Файлы архива".

  • При выборе элемента чертежа верхнего уровня выводится информация о каждом доступном файле чертежа или резервной копии файла, связанной с исходным файлом.
  • При выборе отдельного файла чертежа или резервной копии файла выводится дополнительная информация об этом файле.
Образец

Образец для предварительного просмотра выбранного чертежа или резервной копии файла чертежа.

Пункты контекстного меню

Нажать правую кнопку мыши на элементе чертежа, чертеже или резервной копии файла чертежа, или в области раздела "Файлы архива". Откроется контекстное меню с нужными параметрами.

"Открыть все"

Открытие всех файлов чертежей или резервных копий файлов, связанных с выбранным элементом чертежа верхнего уровня.

Удалить

Удаление выбранных элементов чертежа верхнего уровня.

Открыть

Открытие выбранного файла чертежа или резервной копии файла для восстановления чертежа. Используя сочетания клавиш SHIFT и CTRL, можно выбрать несколько файлов.

Свойства

Отображает диалоговое окно "Свойства файла" для выбранного файла чертежа или резервной копии файла в проводнике Windows.

"Развернуть все"

Развертывание всех элементов чертежей верхнего уровня. Доступ к этой опции можно получить, щелкнув правой кнопкой мыши в области раздела "Файлы архива".

"Свернуть все"

Свертывание всех элементов чертежей верхнего уровня. Доступ к этой опции можно получить, нажав правую кнопку мыши в области раздела "Файлы архива".


ВПАКЕТ Команда

В Команды
В Команды
ВПАКЕТ Команда
Понятия Процедуры Команды

Повторное выполнение пакетного файла

Команда ВПАКЕТ полезна для показа демонстрационных материалов, в которых повторяется сценарий.

Если команду ВПАКЕТ поставить последней строкой пакетного файла, файл будет выполняться до тех пор пока не будет нажата клавиша ESC.

Примечание Перед запуском сценария на длительное время работы следует отключить команду ОТМЕНИТЬ и любые файлы журналов; в противном случае эти файлы журналов могут увеличиться и занять значительную часть дискового пространства.


ВРАЩАТЬ Команда

В Команды
В Команды
ВРАЩАТЬ Команда
Понятия Процедуры Команды

Создается 3D тело или поверхность вращением 2D объектов вокруг оси.

Панель инструментов "Моделирование"

Меню "Рисование": "Моделирование" » "Вращать"

Ввод команды: вращать

Пульт управления: Панель "3D построения", "Вращать"

Текущая плотность каркаса: ИЗОЛИНИИ=4

Выберите объекты для вращения: Использовать метод выбора объекта

С помощью команды ВРАЩАТЬ можно создать новое тело или новую поверхность вращением разомкнутой или замкнутой плоской кривой вокруг оси. Можно вращать несколько объектов.

Системная переменная DELOBJ определяет, требуется ли автоматическое стирание повернутых объектов после создания тела или поверхности, а также вывод запроса на удаление объектов.

Пользователю разрешается выбирать объекты для вращения перед запуском команды.

Возможно вращение указанных ниже объектов.

  • Отрезки
  • Дуги
  • Эллиптические дуги
  • Двумерные полилинии
  • 2D сплайны
  • Круги
  • Эллипсы
  • Плоские 3D грани
  • Двумерные фигуры
  • Полосы
  • Области
  • Плоские грани на телах или поверхностях

Примечание Для выбора граней на телах необходимо нажать и удерживать нажатой клавишу CTRL и далее выбирать эти подобъекты.

Объекты внутри блоков вращать нельзя. То же относится и к самопересекающимся полилиниям. Команда ВРАЩАТЬ не учитывает ширину полилинии и вращает ее от центра пути полилинии.

Положительное направление вращения определяется по правилу правой руки. См. Задание пользовательской системы координат в 3D пространстве в Руководстве пользователя.

Начальная точка оси вращения или Объект[X/Y/Z] <Объект>: Указать точку, нажать клавишу ENTER , чтобы выбрать объект для оси или ввести опцию

Начальная точка оси

Требуется указать две точки, задающие ось вращения. Положительное направление оси вращения — от первой указанной точки ко второй.

Конечная точка оси: УКазать точку

Угол вращения или [Начальный угол] <360>: Указать угол или нажать ENTER.

При положительном значении угла вращение объектов происходит против часовой стрелки. При отрицательном значении угла вращение объектов происходит по часовой стрелке.

Объекты поворачиваются на указанный угол.

Начальный угол

Задает смещение для поворота от плоскости вращаемого объекта.

Начальный угол <0>: Задать угол или нажать клавишу ENTER

Угол вращения <360>: Задать угол или нажать клавишу ENTER

Объект

Пользователь может выбрать существующий объект, определяющий ось для вращения вокруг нее выбранного объекта. Положительным считается направление оси от ближайшей к самой дальней конечной точке данного объекта.

В качестве оси можно использовать указанные ниже объекты.

  • Отрезки
  • Линейные сегменты полилинии
  • Линейные кромки тел или поверхностей

Примечание Для выбора ребер на телах необходимо нажать и удерживать нажатой клавишу CTRL и далее выбирать эти ребра.

Выберите объект: Выбрать объект любым способом

Угол вращения или [Начальный угол] <360>: Указать угол или нажать клавишу ENTER.

Х (ось)

Использует в качестве оси вращения ось X текущей ПСК.

Угол вращения или [Начальный угол] <360>: Указать угол или нажать клавишу ENTER

Y (ось)

Использует в качестве оси вращения ось Y текущей ПСК.

Угол вращения или [Начальный угол] <360>: Указать угол или нажать клавишу ENTER

Z (ось)

Использует в качестве положительной оси вращения положительную ось Z текущей ПСК.

Угол вращения или [Начальный угол] <360>: Указать угол или нажать клавишу ENTER


ВРЕМЯ Команда

В Команды
В Команды
ВРЕМЯ Команда
Понятия Процедуры Команды

Получение сведений о дате и времени чертежа

Меню "Сервис": "Сведения" » "Время"

Ввод команды: время ( или 'время для вызова в прозрачном режиме)

Команда ВРЕМЯ выводит на экран следующую информацию:

Текущее время: Среда, 31 декабря, 2003 9:54:51:406 AM

Время доступа к данному чертежу:

Создания: Пятница, 12 декабря, 2003 1:21:36:203 AM

Последней обработки: Среда, 31 декабря, 2003 9:49:19:208 AM

Общее время редактирования: 0 дней 06:44:10520

Затраченное (вкл): 0 дней 00:07:05.312

Следующее автоматическое сохранение: 0 дней 01:59:15.570

Задайте опцию [Показать/Вкл/Откл/Сброс]: Задайте опцию или нажмите ENTER

Текущее время

Отображение текущей даты и времени в 24-часовом формате с точностью до миллисекунды.

Создания

Дата и время создания текущего чертежа.

Последней обработки

Отображение даты и времени последнего обновления текущего чертежа. Изначально время последнего обновления соответствует времени создания чертежа. Изменение времени последнего обновления производится при каждом сохранении файла чертежа.

Общее время редактирования

Отображение времени, затраченного на редактирование текущего чертежа. Счетчик времени постоянно обновляется программой; его нельзя сбросить или остановить. Время вывода чертежа на печать при подсчете времени редактирования не учитывается. При завершении сеанса редактирования без сохранения чертежа время, затраченное на редактирование, не учитывается.

Затраченное

Дополнительный счетчик, функционирующий в процессе работы программы. Его можно включать/отключать и сбрасывать, когда это необходимо.

Следующее автоматическое сохранение

Отображение времени, оставшегося до очередного автоматического сохранения. Интервал между автосохранениями задается командой НАСТРОЙКА или значением системной переменной SAVETIME.

Показать

Повторный вывод сведений о дате и времени чертежа (с обновлением).

Вкл

Запуск пользовательского счетчика затраченного времени, если он отключен.

Откл

Останов пользовательского счетчика затраченного времени, если он включен.

Сброс

Присвоение пользовательскому счетчику затраченного времени значения 0 дней 00:00:00.000.


ВСЕОСВЕЖ Команда

В Команды
В Команды
ВСЕОСВЕЖ Команда
Понятия Процедуры Команды

Перерисовка содержимого всех видовых экранов

Меню "Вид": "Освежить"

Ввод команды: всеосвеж (или 'всеосвеж для прозрачного вызова)

Если системная переменная BLIPMODE включена, следы маркеров, оставленные командами редактирования, удаляются из всех видовых экранов.


ВСЕРЕГЕН Команда

В Команды
В Команды
ВСЕРЕГЕН Команда
Понятия Процедуры Команды

Регенерация чертежа и перерисовка всех видовых экранов

Меню "Вид": "Регенерировать все"

Ввод команды: всереген

Команда ВСЕРЕГЕН регенерирует весь чертеж и заново вычисляет экранные координаты всех объектов на всех видовых экранах. Она также выполняет индексирование базы данных чертежа для оптимального отображения на экране и выбора объектов.


ВСЛОЙ Команда

В Команды
В Команды
ВСЛОЙ Команда
Понятия Процедуры Команды

Управление видимостью слоев для отдельных видовых экранов

Ввод команды: вслой

Задайте опцию ?/Заморозить/Разморозить/Сброс/Новые замороженные/Видимость по умолчанию]:

?—Список замороженных слоев

Вывод списка слоев, замороженных на текущем видовом экране.

Выберите видовой экран:

В командной строке выводится список слоев, замороженных на текущем видовом экране.

Заморозить

Замораживание одного или нескольких слоев на одном или нескольких видовых экранах. Объекты на замороженных слоях не выводятся на экран, не регенерируются и не вычерчиваются.

Имена слоев для замораживания: Ввести одно или несколько имен слоев

Задайте опцию [Все/вЫбрать/Текущий] <Текущий>: Задать опцию или нажать ENTER

Все

Изменение состояния видимости слоев на всех видовых экранах.

Выбрать

Изменение состояния видимости слоев только на выбранных видовых экранах.

Выберите объекты: Выбрать один или несколько видовых экранов и нажать ENTER

Текущий

Изменение состояния видимости слоев только на текущем видовом экране.

Разморозить

Размораживание одного или нескольких слоев на одном или нескольких видовых экранах.

Имена слоев для размораживания: Ввести одно или несколько имен слоев

Задайте опцию [Все/вЫбрать/Текущий] <Текущий>: Задать опцию или нажать ENTER

Все

Изменение состояния видимости слоев на всех видовых экранах.

Выбрать

Изменение состояния видимости слоев только на выбранных видовых экранах.

Выберите объекты: Выбрать один или несколько видовых экранов и нажать ENTER

Текущий

Изменение состояния видимости слоев только на текущем видовом экране.

Сброс

Установка видимости одного или нескольких слоев на выбранных видовых экранах согласно видимости слоев по умолчанию.

Имена слоев для сброса: Ввести одно или несколько имен слоев

Задайте опцию [Все/вЫбрать/Текущий] <Текущий>: Задать опцию или нажать ENTER

Все

Изменение состояния видимости слоев на всех видовых экранах.

Выбрать

Изменение состояния видимости слоев только на выбранных видовых экранах.

Выберите объекты: Выбрать один или несколько видовых экранов и нажать ENTER

Текущий

Изменение состояния видимости слоев только на текущем видовом экране.

Новые замороженные

Создание новых слоев, замороженных на всех видовых экранах.

Имена новых замороженных слоев на всех видовых экранах: Ввести одно или несколько имен слоев

Видимость по умолчанию

Замораживание или размораживание указанных слоев для всех новых видовых экранов.

Имена слоев для изменения видимости на новых видовых экранах: Ввести одно или несколько имен слоев

Введите опцию видимости на видовых экранах [Замороженный/Размороженный] <текущий>: Ввести з или р или нажать ENTER.


ВСТАВИТЬ Команда

В Команды
В Команды
ВСТАВИТЬ Команда
Понятия Процедуры Команды

Вставка именованного блока или другого чертежа в текущий чертеж

Панель Вставка:

Меню "Вставка": "Блок"

Ввод команды: вставить

Откроется диалоговое окно "Вставка блока".

Если в командной строке ввести -вставить, будут выведены подсказки для команды ВСТАВИТЬ.

Темы:

  • Диалоговое окно "Вставка блока"
  • ВСТАВИТЬ вариант для командной строки


Диалоговое окно "Вставка блока"

В Команды
В Команды
Диалоговое окно "Вставка блока"
Понятия Процедуры Команды

Панель Вставка:

Меню "Вставка": "Блок"

Ввод команды: вставить

Задание имени и расположения блока или чертежа для вставки.

Последний вставленный в сеансе редактирования блок становится блоком по умолчанию для последующих вызовов команды ВСТАВИТЬ. Место вставки блока зависит от ориентации ПСК.

Имя

Задание имени вставляемого блока или файла чертежа.

Обзор

Открывает диалоговое окно "Выбор файла чертежа" (стандартное окно выбора файлов), в котором можно выбрать блок или файл чертежа для вставки.

Путь

Задание пути к блоку.

Образец

Отображает образец указанного блока, который требуется вставить. Оранжевый значок вспышки молнии, отображаемый в правом нижнем углу образца блока, обозначает, что блок динамический.

Точка вставки

Задание точки вставки блока.

Указать на экране

Задание точки вставки с помощью устройства указания на экране.

X

Значение координаты X.

Y

Значение координаты Y.

Z

Значение координаты Z.

Масштаб

Задание масштаба для вставки блока. Если какой-либо из масштабных коэффициентов X, Y или Z отрицателен, блок зеркально отображается в этом направлении.

Указать на экране

Задание масштаба блока с помощью устройства указания на экране.

X

Задание масштабного коэффициента по оси X.

Y

Задание масштабного коэффициента по оси Y.

Z

Задание масштабного коэффициента по оси Z.

Равные масштабы

Указывает единый масштаб по всем трем направлениям (X, Yи Z). Значение, введенное для оси X, применяется и для осей Y и Z.

Угол поворота

Задание угла поворота для вставляемого блока в текущей пользовательской системе координат (ПСК).

Указать на экране

Задание угла поворота блока с помощью устройства указания на экране.

Угол

Задание угла поворота для вставляемого блока.

Единицы блока

Отображает информацию о единицах блока по умолчанию.

Ед. изм

Указывает значение параметра ЕДИНИЦЫ ВСТАВКИ для вставленного блока.

Коэфф

Отображает масштабный коэффициент, который вычисляется на основе значения параметра INSUNITS блока и единиц чертежа.

Расчленить

Расчленение блока и вставка в чертеж его отдельных частей. При выборе этой опции задается единый масштабный коэффициент по всем трем координатным осям.

Компоненты блока, нарисованные на слое 0, остаются на нем. Объекты, имеющие цвет ПОБЛОКУ, рисуются белым цветом. Объекты, имеющие тип линии ПОБЛОКУ, рисуются сплошными линиями (типа CONTINUOUS).


ВСТАВИТЬ вариант для командной строки

В Команды
В Команды
ВСТАВИТЬ вариант для командной строки
Понятия Процедуры Команды

Если в командной строке ввести -вставить, будут выведены подсказки для команды ВСТАВИТЬ.

Имя блока или [?] <последний>: Введите имя, введите ?, введите ~ или нажмите ENTER

Единицы: <значение параметра ЕДИНИЦЫ ВСТАВКИ, указанное для вставленного блока> Преобразование: <масштаб преобразования>

Укажите точку вставки или [Базовая точка/Масштаб/X/Y/Z/Поворот]: Укажите точку или задайте опцию

Имя блока

В запросе в качестве текущего используется имя блока, вставленного последним на протяжении текущего рабочего сеанса.

Сгруппированные объекты вставляются как неименованная группа. Просмотреть неименованные группы можно, установив флажок "Включая неименованные" в диалоговом окне "Группы объектов".

При вводе тильды (~) отобразится диалоговое окно "Выбор файла чертежа" (стандартное окно выбора файлов).

Поведением блоков при вставке можно управлять с помощью подсказок в командной строке.

  • Расчленение блоков при вставке: Если имени блока предшествует звездочка (*), блок расчленяется, и в чертеж вставляются отдельные объекты, из которых он состоял. Описание блока в чертеж не вставляется.
  • Изменение пути к блоку: При вводе имени блока без указания пути команда ВСТАВИТЬ выполняет поиск существующего описания блока с этим именем в данных текущего чертежа. Если в текущем чертеже описание блока не найдено, команда ВСТАВИТЬ выполняет поиск по библиотечному пути. При обнаружении файла имя файла используется в качестве имени блока после вставки описания блока. При последующих вставках блоков с тем же именем используется это же описание блока. Имеющееся описание блока можно заменить на внешний файл, если ввести в ответ на запрос "Имя блока:" следующее:

    • имя блока = имя файла

  • Обновление описания блока: Чтобы обновить блок после изменения содержимого исходного файла, не создавая нового вхождения блока, следует в ответ на запрос "Точка вставки" (идущий после подсказки "Имя блока") ввести следующее:

    • имя блока=

    Если после имени блока ввести знак равенства =, отобразится следующая подсказка:

    Блок "текущий" уже существует. Переопределить его? [Да/Нет] <Нет>: Введите д, ввести н или нажмите ENTER

    При переопределении блока существующее описание блока замещается новым. Чертеж регенерируется, и новое описание применяется ко всем имеющимся вхождениям блока. При отображении подсказки о точке вставки нажать ESC, если вставлять новый блок в чертеж не требуется.

?—Список имен блоков

Если ввести ?, выдается список блоков, описанных в чертеже.

Точка вставки

Задание положения блока или чертежа.

Введите масштабный коэффициент или [Угол/XYZ] <1>: Введите значение, задайте опцию или нажмите ENTER

Масштабный коэффициент

Задание масштабного коэффициента.

Угол поворота <0>:

Все размеры блоков или чертежей по осям X и Y пересчитываются в соответствии с заданными масштабами по осям X и Y. Блок или чертеж поворачивается на заданный угол, причем точка вставки берется за центр вращения.

Угол

Определяет масштабы по осям X и Y одновременно, используя точку вставки и другую точку как противоположные углы прямоугольной рамки. Размер прямоугольника по оси Х становится масштабом по Х, а размер по оси Y масштабом по Y. Точка вставки задает первый угол прямоугольника.

Противоположный угол: Указать точку

Угол поворота <0>:

XYZ

Задание масштабов по осям X, Y и Z

Укажите масштаб по оси X или [Угол] <1>: Задайте ненулевое значение, введите с или нажмите ENTER

  • Масштаб по оси X: Позволяет задать масштабные коэффициенты по осям X, Y и Z.

    • Масштаб по оси Y или <равен масштабу по X>: Задайте масштаб или нажмите ENTER

    Масштаб по оси Z или <равен масштабу по X>: Задайте масштаб или нажмите ENTER

    Угол поворота <0>: Задайте угол или нажмите ENTER

  • Угол: Определяет масштабы по осям X и Y одновременно, используя точку вставки и другую точку как противоположные углы прямоугольной рамки, а затем запрашивает масштаб по оси Z.

    • Противоположный угол: Указать точку

    Масштаб по оси Z или <равен масштабу по X>: Задайте масштаб или нажмите ENTER

    Угол поворота <0>: Задайте угол или нажмите ENTER

Базовая точка

Временно оставляет блок в текущем местоположении в чертеже и позволяет указать новую базовую точку для вхождения блока при его перемещении. Этот параметр не влияет на фактическую базовую точку, заданную для вхождения блока.

Базовая точка: Указать базовую точку для вхождения блока

Масштаб

Задание масштабных коэффициентов блока по осям X, Y и Z. По оси Z используется абсолютное значение введенной величины.

Масштаб по осям X, Y и Z: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

X

Задание масштабного коэффициента по оси X.

Масштаб по оси X: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

Y

Задание масштабного коэффициента по оси Y.

Масштаб по оси Y: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

Z

Задание масштабного коэффициента по оси Z.

Масштаб по оси Z: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

Поворот

Задание угла поворота для вставки блока.

Угол поворота <0>:

Точка вставки:

Введите масштаб по оси X, укажите второй угол или [Угол/XYZ] <1>: Введите значение, задайте опцию или нажмите ENTER

Описание опций "Масштаб по оси Х", "Угол" и "XYZ" в списке "Поворот" совпадает с описанием соответствующих опций в списке "Точка вставки".


ВСТБЛОК Команда

В Команды
В Команды
ВСТБЛОК Команда
Понятия Процедуры Команды

Вставка скопированных ранее объектов в виде блока

Меню "Правка": Вставить как блок

Контекстное меню: Завершить выполнение активных команд, Нажать правую кнопку мыши на области рисования и выбрать "Вставить как блок".

Ввод команды: встблок

Точка вставки: Указать точку

Объекты, копируемые в буфер обмена, вставляются в чертеж как блок в указанную точку.


ВСТБУФЕР Команда

В Команды
В Команды
ВСТБУФЕР Команда
Понятия Процедуры Команды

Вставка содержимого буфера обмена

Панель "Стандартная"

Меню "Правка": Вставить

Контекстное меню: Завершить выполнение активных команд, нажать правую кнопку мыши в области рисования и выбрать "Вставить".

Ввод команды: встбуфер

Точка вставки:

Если буфер обмена содержит текст ASCII, то текст вставляется как многострочный текст с параметрами команды МТЕКСТ по умолчанию. Электронные таблицы импортируются как объекты-таблицы.

Все остальные объекты (кроме объектов AutoCAD) становятся внедренными или связанными объектами (OLE-объектами). Редактирование OLE-объектов осуществляется в соответствующих приложениях, вызываемых двойным нажатием левой кнопки мыши на объектах.

Примечание Для вызова команды ВСТБУФЕР можно также использовать комбинацию клавиш CTRL+V. Если при вызове команды ВСТБУФЕР курсор находится в области рисования, то данная команда ведет себя так, как описано выше. Если же курсор находится в командной строке, то текст из буфера обмена вставляется в строку текущего запроса.


ВСТИСХОД Команда

В Команды
В Команды
ВСТИСХОД Команда
Понятия Процедуры Команды

Вставка скопированного блока в новый чертеж с координатами, которые он имел в исходном чертеже

Меню "Правка": Вставить с исходными координатами

Контекстное меню: Завершить выполнение активных команд, нажать правую кнопку мыши в области рисования и выбрать "Вставить с исходными координатами".

Ввод команды: встисход

Объект, копируемый в буфер обмена, вставляется в чертеж с теми же координатами, которые он имел в исходном чертеже.

Команда ВСТИСХОД действует только в случаях, когда в буфере обмена содержатся графические данные AutoCAD, скопированные из чертежей, отличных от текущего.


ВСТОБЪЕКТ Команда

В Команды
В Команды
ВСТОБЪЕКТ Команда
Понятия Процедуры Команды

Вставка связанного или внедренного объекта

Панель Вставка:

Меню "Вставка": "Объект"

Ввод команды: встобъект

Откроется диалоговое окно "Вставка объекта".

Темы:

  • Диалоговое окно "Вставка объекта"


Диалоговое окно "Вставка объекта"

В Команды
В Команды
Диалоговое окно "Вставка объекта"
Понятия Процедуры Команды

Панель Вставка:

Меню "Вставка": "Объект"

Ввод команды: встобъект

Вставка связанного или внедренного объекта. Параметры диалогового окна зависят от положения переключателя: "Создать новый" или "Создать из файла".

Создать новый

Запуск приложения, выделенного в списке "Тип объекта", для создания нового объекта для вставки.

Тип объекта

Список имеющихся приложений, которые поддерживают технологию OLE. Для создания внедренного объекта необходимо запустить соответствующее приложение двойным нажатием кнопки мыши.

В меню приложения "Файл" опция "Сохранить" заменяется на "Обновить". Выбор этого пункта вызывает вставку объекта в чертеж или его обновление.

В виде значка

Отображение значка приложения-источника в чертеже. Внедренная информация раскрывается после двойного нажатия левой кнопки мыши на значке.

Создать из файла

Выбор связываемого или внедряемого файла.

Файл

Задание имени (с учетом пути) внедряемого или связываемого файла.

Обзор

Вызов диалогового окна "Обзор" (стандартного окна выбора файлов), в котором следует выбрать внедряемый или связываемый файл.

Связь

Задание связывания (а не внедрения) заданного файла.

В виде значка

Отображение значка приложения-источника в чертеже. Внедренная (связанная) информация раскрывается после двойного нажатия левой кнопки мыши на значке.


ВСТСПЕЦ Команда

В Команды
В Команды
ВСТСПЕЦ Команда
Понятия Процедуры Команды

Вставка данных из буфера обмена Windows с возможностью управления их форматом

Меню "Правка": Специальная вставка

Ввод команды: встспец

Откроется диалоговое окно "Специальная вставка".

Темы:

  • Диалоговое окно "Специальная вставка"


Диалоговое окно "Специальная вставка"

В Команды
В Команды
Диалоговое окно "Специальная вставка"
Понятия Процедуры Команды

Меню "Правка": Специальная вставка

Ввод команды: встспец

Задание формата вставляемого файла и параметров связи с ним.

Источник данных

Имя документа, содержащего скопированную информацию. Здесь же может выводиться характерный фрагмент документа-источника данных.

Вставить

Содержимое буфера обмена помещается в текущую позицию курсора как внедренный объект.

Связать

Вставка содержимого буфера обмена в текущий чертеж. Если исходное приложение поддерживает OLE, устанавливается связь с исходным файлом.

Как

Отображение применимых форматов, в которых можно вставлять содержимое буфера обмена в текущий чертеж.

Если выбрать "Объекты AutoCAD", содержимое метафайла в буфере обмена преобразуется в объекты AutoCAD. В случае невозможности такого преобразования метафайл вставляется как OLE-объект.

В виде значка

Вместо данных в чертеж помещается значок соответствующего приложения. Для просмотра или редактирования данных следует дважды нажать левую кнопку мыши на значке.


ВЫБРАТЬ Команда

В Команды
В Команды
ВЫБРАТЬ Команда
Понятия Процедуры Команды

Занесение выбранных объектов в текущий набор

Ввод команды: выбрать

Выберите объекты: Выбрать объекты любым способом

В перекрестии курсора появляется маленький квадрат, который называется прицелом выбора объектов.

Для совершения операций над объектами необходимо их выбрать. В ходе выполнения большинства команд (включая и саму команду ВЫБРАТЬ) выдается запрос "Выберите объекты".

Объекты могут быть выбраны с помощью устройства указания по одному. Можно выбрать сразу группу объектов посредством заключения их в рамку выбора. Можно также выбрать объекты по их координатам или воспользоваться любым из описанных ниже способов выбора. Эти способы действуют одинаково для всех команд, требующих выбора объектов.

Кроме того, удерживая клавишу CTRL, можно выбрать исходные отдельные формы, являющиеся частью составных тел, или вершины, кромки и грани 3D тел. Можно выбрать один из этих подобъектов или создать набор объектов, состоящий из нескольких подобъектов. Набор объектов может состоять из подобъектов разных типов.

Для просмотра списка всех доступных опций в командной строке следует ввести ?.

Требуется точка или

Рамка/Последний/Секрамка/БОКС/Все/Линия/РМн-угол/СМн-угол/Группа/Добавить/Исключить /Несколько/Текущий/Отменить/Авто/Единственный/Подобъект/Объект

Выберите объекты: Указать точку или задать опцию

Рамка

Позволяет выбрать все объекты, полностью лежащие в прямоугольной области, заданной двумя точками. Если углы задаются слева направо, выполняется выбор рамкой. (Если углы задаются справа налево, выполняется выбор секущей рамкой.)

Первый угол: Указать точку (1)

Противоположный угол: Указать точку (2)

Последний

Выбор последнего созданного объекта, видимого на экране. Объект должен находиться в текущем пространстве, т. е. в пространстве модели или листа, а его слой не должен быть заморожен или выключен.

Секрамка

Позволяет выбрать объекты, находящиеся внутри и пересекающие область, заданную двумя точками. Границы секущей рамки изображаются пунктирными линиями или подсвечиваются для отличия от обычной рамки. Если углы задаются справа налево, выполняется выбор секущей рамкой. (Если углы задаются слева направо, выполняется выбор рамкой.)

Первый угол: Указать точку (1)

Противоположный угол: Указать точку (2)

Бокс

Позволяет выбрать все объекты, лежащие внутри прямоугольной области, заданной двумя точками, или пересекающие ее. Если точки прямоугольника указываются слева направо, опции "Бокс" и "Секрамка" эквивалентны. В противном случае опция "Бокс" работает как опция "Рамка".

Первый угол: Указать точку

Противоположный угол: Указать точку

Все

Выбор всех объектов, находящихся на размороженных слоях.

Линия

Позволяет выбрать объекты, пересекающие линию выбора. Метод "Линия" схож с методом "СМн-угол", отличием является то, что линия не замкнута и может пересекать саму себя. Системная переменная PICKADD не действует на метод выбора "Линия".

Укажите первую точку линии выбора: Указать точку

Укажите следующую точку линии выбора или [Отменить]: Указать точку или ввести о для отмены последней точки

РМн-угол

Позволяет выбрать все объекты, полностью заключенные внутри многоугольника. Многоугольник может иметь любую форму, но он не должен иметь самопересечений. Последний вычерчиваемый сегмент замыкает многоугольник. Системная переменная PICKADD не действует на метод выбора "РМн-угол".

Первая точка многоугольника: Указать точку

Конечная точка отрезка или [Отменить]: Указать точку или ввести о для отмены последней точки

СМн-угол

Позволяет выбрать все объекты, хотя бы частично заключенные внутри многоугольника. Многоугольник может иметь любую форму, но он не должен иметь самопересечений. Последний вычерчиваемый сегмент замыкает многоугольник. Системная переменная PICKADD не действует на метод выбора "СМн-угол".

Первая точка многоугольника: Указать точку

Конечная точка отрезка или [Отменить]: Указать точку или ввести о для отмены последней точки

Группа

Позволяет выбрать все объекты, входящие в указанную группу.

Введите имя группы: Ввести список имен

Добавить

Объекты добавляются в текущий набор с помощью любого способа выбора объектов. Способы "Авто" и "Добавить" используются по умолчанию.

Исключить

Объекты исключаются из текущего набора с помощью любого способа выбора объектов. Кроме того, исключение объектов из набора можно производить, выбирая их при нажатой клавише SHIFT в режиме добавления или в автоматическом режиме.

Несколько

Задание нескольких точек без подсвечивания объектов; это позволяет повысить скорость выбора сложных объектов. Если два объекта пересекаются, их можно выбрать, дважды указав точку их пересечения.

Текущий

Выбор последнего набора объектов. Этот набор очищается операциями, удаляющими объекты из чертежа.

Программа запоминает, в каком пространстве (листа или модели) был задан набор. При переключении пространства набор, выбранный в другом пространстве, игнорируется.

Отменить

Снятие выделения с объекта, добавленного в набор последним.

Авто

Объект выбирается при наведении на него указателя мыши. Если навести указатель мыши на пустую область внутри или снаружи объекта, задается первый угол рамки или секущей рамки, т.е. включается режим "Бокс". Способы "Авто" и "Добавить" используются по умолчанию.

Единственный

Выбор объекта (или нескольких объектов) автоматически заканчивается после единственного указания.

Подобъект

Позволяет выбрать исходные отдельные формы, являющиеся частью составных тел, или вершины, кромки и грани 3D тел. Можно выбрать один из этих подобъектов или создать набор объектов, состоящий из нескольких подобъектов. Набор объектов может состоять из подобъектов разных типов.

Выберите объекты: Выбрать исходные отдельные формы, являющиеся частью составных тел, или вершины, кромки и грани 3D тел

Нажатие и удерживание клавиши CTRL эквивалентно заданию для команды ВЫБРАТЬ опции "подобъект".

Объект

Выход из режима выбора подобъектов. Позволяет выбрать объекты любым способом.

Выберите объекты: Выбрать объекты любым способом


ВЫДАВИТЬ Команда

В Команды
В Команды
ВЫДАВИТЬ Команда
Понятия Процедуры Команды

Создание 3D тела или поверхности путем выдавливания объекта или плоской грани в заданном направлении и на заданное расстояние.

Панель "Моделирование":

Меню "Рисование": "Моделирование" » подменю "Выдавить"

Ввод команды: выдавить

Пульт управления: Панель "Создать 3D тело", "Выдавить"

Текущая плотность каркаса: ISOLINES=4

Выбрать объекты для операции выдавливания:

Задать глубину выдавливания или [Направление/Траектория/Угол конуса] <по умолчанию>: Задать расстояние или ввести p

Пользователь перед запуском команды имеет возможность выбрать объекты для операции выдавливания.

Системная переменная DELOBJ определяет, будут ли объекты и путь (если он выбран) при создании тела или поверхности удалены автоматически или об удалении объектов и пути будет выдан запрос.

Выбор объекта

Задание выдавливаемых объектов. Операцию выдавливания можно применить к следующим объектам и подобъектам:

  • Отрезки
  • Дуги
  • Эллиптические дуги
  • Двумерные полилинии
  • Двумерные сплайны
  • Круги
  • Эллипсы
  • Плоские трехмерные грани
  • Двумерные фигуры
  • Полосы
  • Области
  • Плоские поверхности
  • Плоские грани на телах

Примечание Чтобы выбрать грани на твердотельных объектах, следует нажать и удерживать клавишу CTRL, а затем выбирать эти подобъекты.

Нельзя выдавить объекты, входящие в блоки, а также полилинии с пересекающимися сегментами.

Если заданная полилиния имеет ширину, эта ширина игнорируется, и полилиния выдавливается из центра своего пути. Если выбранный объект имеет толщину, эта толщина игнорируется.

Примечание Для преобразования имеющих толщину полилиний и кругов в тела можно использовать команду ПРЕОБРВТЕЛО. Для преобразования в поверхности имеющих толщину линий и дуг, а также незамкнутых, имеющих толщину и нулевую ширину полилиний можно использовать команду ПРЕОБРВПВРХ.

Глубина выдавливания

Выдавливание объектов вдоль положительной оси Z на системе координат объекта, если введено положительное значение. При задании отрицательного значения объекты выдавливаются вдоль отрицательной оси Z. Объекты не обязательно должны быть параллельны одной и той же плоскости. Если все объекты располагаются на общей плоскости, объекты выдавливаются в направлении, перпендикулярном к этой плоскости.

По умолчанию, выдавливание плоских объектов выполняется в направлении, перпендикулярном плоскости объекта.

Вторая точка: Указать точку

Направление

С помощью двух заданных пользователем точек определяет длину и направление выдавливания.

Задать начальную точку вектора направления: Задать точку

Задать конечную точку вектора направления: Задать точку

Траектория

Задание траектории выдавливания. Траектория перемещается к центру тяжести профиля. Затем профиль выбранного объекта выдавливается вдоль выбранной траектории для создания тел или поверхностей.

Траектория выдавливания: Выбрать объекты любым способом

Траекториями могут быть следующие объекты:

  • Отрезки
  • Круги
  • Дуги
  • Эллипсы
  • Эллиптические дуги
  • Двумерные полилинии
  • Трехмерные полилинии
  • Двумерные сплайны
  • Трехмерные сплайны
  • Грани тел
  • Грани поверхностей
  • Спирали

Примечание Чтобы выбрать грани на твердотельных объектах, следует нажать и удерживать клавишу CTRL, а затем выбирать эти подобъекты.

Траектория не должна принадлежать той же плоскости, что и объект, и не должна иметь участков большой кривизны.

Выдавленное твердое тело начинается от плоскости объекта и сохраняет его ориентацию относительно траектории.

Если в траектории имеется излом, программа выполняет выдавливание объекта в направлении каждого сегмента, а затем выполняет в месте соединения скос в плоскости, делящей пополам угол между сегментами. Если траектория замкнута, объект должен лежать в плоскости скашивания. Только в этом случае начальное и конечное сечения тела будут совпадать. Если объект не лежит в плоскости скашивания, он будет поворачиваться до тех пор, пока не окажется в плоскости скашивания.

Объекты с несколькими замкнутыми контурами выдавливаются так, что в конечном сечении выдавленного тела все контуры оказываются лежащими в одной плоскости.

Угол конуса

Задать угол конуса выдавливания <0>: Задать угол от -90 до +90 градусов или нажать клавишу ENTER или указать точку

Если вместо ввода значения пользователь указывает для угла конуса точку, необходимо указать и вторую точку. В применении к выдавливанию углом конуса является расстояние между этими двумя заданными точками.

Вторая точка: Указать точку

Положительные величины угла сужают объект, отрицательные — расширяют его. По умолчанию угол задан равным 0, а 2D объекты выдавливаются перпендикулярно их 2D плоскости. Расширение и сужение всех выбранных объектов и замкнутых контуров выполняется в соответствии с одним и тем же значением угла конуса.

Задание слишком больших значений угла конусности или глубины выдавливания может привести к тому, что объект сузится до нуля, не достигнув заданной высоты.

Отдельные замкнутые контуры области всегда выдавливаются на одну глубину.

При конусном выдавливании дуги ее центральный угол остается постоянным, а радиус изменяется.


ВЫНОСКА Команда

В Команды
В Команды
ВЫНОСКА Команда
Понятия Процедуры Команды

Построение линий, соединяющих пояснительные надписи с поясняемыми элементами

Ввод команды: выноска

Начальная точка выноски:

Следующая точка:

Будет нарисован следующий сегмент выносной линии и отображен запрос для указания точек и задания параметров.

Следующая точка или [Надпись/Формат/Отменить] <Надпись>: Указать точку, ввести параметр или нажать клавишу ENTER

Указание точки

К заданной точке проводится сегмент выноски. Программа предлагает указать следующую точку или задать опцию.

Следующая точка или [Надпись/Формат/Отменить] <Надпись>: Указать точку, ввести параметр или нажать клавишу ENTER

Надпись

Вставка надписи в конец линии-выноски. Это может быть однострочный или многострочный текст, рамка допуска формы и расположения или блок.

Первая строка текста надписи или <опции>: Ввести текст или нажать клавишу ENTER

При вводе текста в ответ на запрос надписи, он помещается в конец линии выноски. Запрос на ввод дополнительных строк текста будет повторяться, пока пользователь не прервет действие команды двойным нажатием клавиши ENTER.

Если в ответ на запрос надписи не вводить текст, а нажать клавишу ENTER, то появится следующий запрос:

Задайте опцию для пояснительного текста [Допуск/Копировать/Блок/Ничего/Мтекст] <Мтекст>: Задать опцию или нажать клавишу ENTER

Допуск

Построение рамки допуска формы и расположения, используя соответствующие диалоговые окна (см. описание команды ДОПУСК).

Кроме того, там же можно нанести на чертеж обозначения баз и номинальные размеры. После задания геометрического допуска команда ВЫНОСКА завершается.

Копировать

Копирование текста, многострочного текстового объекта, рамки допуска формы и расположения или блока; скопированный объект связывается с концом линии выноски. Копия связывается с выносной линией, поэтому при перемещении скопированного объекта конец этой линии перемещается вместе с объектом. Наличие полки зависит от типа скопированного объекта.

Выберите копируемый объект:

Объект вставляется, и команда ВЫНОСКА завершается. Текущее значение зазора текста (см. описание команды РЗМСТИЛЬ или системной переменной DIMGAP) определяет место вставки текстового объекта или многострочного текста. Блоки и рамки допусков присоединяются непосредственно к конечной точке линии выноски.

Блок

Вставка блока в конец линии выноски. Используется тот же формат запросов, что и для команды ВСТАВИТЬ. Вхождение блока вставляется со смещением в конце линии выноски и связывается с ней таким образом, что при перемещении блока конец линии выноски также перемещается. Полка не генерируется.

Имя блока или [?]: Ввести имя блока или ? для вывода списка всех блоков чертежа

"Нет"

Завершение команды без добавления текста к выноске.

Мтекст

Создает текст с помощью Текстовый редактор, используемый в месте редактирования после указания точки вставки текста и второй точки его границы.

Ввести текст. Для префиксов и суффиксов форматирование задается в угловых скобках (< >). Форматирующие последовательности для альтернативных единиц вводятся в квадратных скобках ([ ]). Подробнее о добавлении префиксов и суффиксов см. раздел Форматирование размерных единиц Руководства пользователя.

Отображение размерного текста определяется установленными единицами и текущим текстовым стилем. Центрирование многострочного текста по вертикали и выравнивание по горизонтали выполняется в соответствии с координатами по оси X последних двух вершин линии выноски. Расстояние от полки выноски до текста задается в поле "Отступ от размерной линии" вкладки "Текст" диалогового окна работы с размерными стилями. Если задан отрицательный отступ, многострочный текст заключается в рамку как номинальный размер.

После ввода текста команда ВЫНОСКА завершается.

Формат

Определяет способ построения выноски и наличие на ней стрелки.

Задайте опцию для формата выноски [Сплайн/Отрезки/сТрелка/Ничего] <Выход>: Задать опцию или нажать ENTER для возврата к предыдущему запросу

После задания каждой опции происходит возврат к запросу «Следующая точка».

Сплайн

Построение выноски в виде сплайна. Управляющими точками в данном случае являются вершины линии выноски, все они обладают равным весом.

Ломаная

Построение выноски в виде набора прямолинейных сегментов.

Стрелка

Построение выноски со стрелкой в начале.

"Нет"

Построение выноски без стрелки.

Выход

Завершение операции форматирования.

Отменить

Отмена ввода последней вершины линии-выноски. Отобразится предыдущий запрос.


ВЫРОВНЯТЬ Команда

В Команды
В Команды
ВЫРОВНЯТЬ Команда
Понятия Процедуры Команды

Выравнивание объектов относительно других объектов в 2D и 3D

Меню "Редактирование": "3D операции" » "Выравнивание"

Ввод команды: выровнять

Выберите объекты: Выбрать объекты, подлежащие выравниванию, и нажать ENTER

Указать одну, две или три пары исходных и определяющих точек для выравнивания выбранных объектов.

Выравнивание по одной паре точек

Первая исходная точка: Указать точку (1)

Первая целевая точка: Указать точку (2)

Указать вторую исходную точку: Нажать ENTER

При указании только одной пары исходных и целевых точек выбранные объекты перемещаются на плоскости или в пространстве на расстояние, заданное точками (1) и (2).

Выравнивание по двум парам точек

Первая исходная точка: Указать точку (1)

Первая целевая точка: Указать точку (2)

Вторая исходная точка:

Вторая целевая точка: Указать точку (4)

Третья исходная точка: Нажать ENTER

Масштабировать объекты по точкам выравнивания [Да/Нет] <Нет>: Ввести д или нажать ENTER

При указании двух пар исходных и целевых точек выбранные объекты могут быть перемещены, повернуты и масштабированы на плоскости или в пространстве.

Первая пара точек задает базовую точку выравнивания (1, 2). Вторая пара точек описывает угол поворота (3, 4).

После ввода второй пары точек отображается запрос на масштабирование объекта. В качестве опорной длины для масштабирования берется расстояние между первой и второй целевыми точками (2, 4). Масштабирование доступно только при выравнивании с помощью двух пар точек.

Примечание Выравнивание объектов с помощью двух пар точек в неперпендикулярных друг другу рабочих плоскостях может привести к непредсказуемым результатам.

Выравнивание по трем парам точек

Первая исходная точка: Указать точку (1)

Первая целевая точка: Указать точку (2)

Вторая исходная точка:

Вторая целевая точка: Указать точку (4)

Третья исходная точка:

Третья целевая точка:

При указании трех пар исходных и целевых точек выбранные объекты могут быть перемещены и повернуты в пространстве.

Вначале объекты перемещаются вдоль вектора, проведенного из исходной точки (1) к целевой точке (2).

Затем исходный объект поворачивается (1, 3), выравниваясь с целевым объектом (2, 4).

Наконец, исходный объект поворачивается еще раз (3, 5), выравниваясь с целевым объектом (4, 6).


ВЫРТЕКСТ Команда

В Команды
В Команды
ВЫРТЕКСТ Команда
Понятия Процедуры Команды

Изменение точки выравнивания для выбранных текстовых объектов без изменения их положения

Панель Текст:

Меню "Изменить": Выравнивание текста

Меню "Изменить": "Объект" » "Текст" » "Выравнивание"

Ввод команды: выртекст

Выберите объекты: Выберите объекты любым способом и нажмите ENTER по завершении выбора

Можно выбрать однострочный текст, многострочный текст, текст на выноске или атрибут.

Задайте опцию выравнивания [вЛево/впИсанный/Поширине/Центр/сЕредина/впРаво/ВЛ/ВЦ/ВП/СЛ/СЦ/СП/НЛ/НЦ/НП]<Существующий>: Задайте местоположение новой точки выравнивания

Полное описание опций выравнивания см. в описании команды ТЕКСТ. Для однострочного текста режимы выравнивания "Вписанный", "Поширине" и "Влево" эквивалентны привязке многострочного текста к нижнему левому углу.


ВЫДАВГРАНЬ Команда

В Команды
В Команды
ВЫДАВГРАНЬ Команда
Понятия Процедуры Команды

Сжимаются или растягиваются ограниченные области

Панель "Моделирование"

Ввод команды: выдавгрань

Пульт управления: Панель "3D Создать", "выдавгрань"

Для сжатия или растягивания нажмите левую кнопку мыши в ограниченной области.

Можно сжимать или растягивать ограниченные области любого из указанных ниже типов:

  • Области, доступные для штриховки методом выбора точек (с нулевым допуском на зазор)
  • Области, замыкаемые пересечением компланарных линейных объектов, включая кромки и геометрические объекты в блоках
  • Замкнутые полилинии, области, 3D грани и 2D тела, состоящие из компланарных вершин
  • Области, создаваемые геометрией (включая ребра на гранях), вычерчиваемой компланарно любой грани 3D тела


ВЫЧИТАНИЕ Команда

В Команды
В Команды
ВЫЧИТАНИЕ Команда
Понятия Процедуры Команды

Объединение выбранных областей или тел посредством вычитания

Панель "Моделирование":

Меню "Редактирование": "Редактирование тела" » "Вычитание"

Ввод команды: вычитание

Пульт управления: Панель создания 3D объектов, Вычесть

Выберите тела и области, из которых будет выполняться вычитание...

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Выберите тела или области для вычитания...

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Объекты второго набора вычитаются из объектов первого набора. Создается новая (единственная) область или тело.

Вычитать области можно только из компланарных областей. Однако с помощью команды ВЫЧИТАНИЕ можно одновременно проводить вычитание для нескольких плоскостей. Программа создает отдельные вычитаемые области на каждой плоскости. Области, для которых не найдены другие компланарные области, не обрабатываются.


ВЭКРАН Команда

В Команды
В Команды
ВЭКРАН Команда
Понятия Процедуры Команды

Создает несколько видовых экранов в пространстве модели и в пространстве листа.

Панель Листы:

Меню "Вид": "Видовые экраны"

Ввод команды: вэкран

Откроется диалоговое окно "Видовые экраны".

Если в ответ на запрос "Команда" ввести -вэкран, вызывается вариант команды ВЭКРАН, использующий интерфейс командной строки.

Темы:

  • Диалоговое окно «Видовые экраны»
  • ВЭКРАН вариант для командной строки
  • ВЭКРАН командная строка - Видовые экраны в пространстве модели
  • ВЭКРАН командная строка - Видовые экраны листа


Диалоговое окно «Видовые экраны»

В Команды
В Команды
Диалоговое окно «Видовые экраны»
Понятия Процедуры Команды

Панель Листы:

Меню "Вид": "Видовые экраны"

Ввод команды: вэкран

Создание новых видовых экранов. Конфигурациям неперекрывающихся видовых экранов можно присваивать имена. Набор опций данного диалогового окна зависит от того, какие видовые экраны создаются: неперекрывающиеся (для пространства модели) или плавающие (для пространства листа).

Вкладки для видовых экранов в пространстве модели: Новые видовые экраны—Пространство модели, Именованные видовые экраны—Пространство модели

Вкладки для видовых экранов в пространстве листа: Новые видовые экраны—Листы, Именованные видовые экраны—Листы

Вкладка "Новые видовые экраны"—Пространство модели (Диалоговое окно "Видовые экраны")

Создание неперекрывающихся видовых экранов на основе стандартных конфигураций видовых экранов.

Новое имя

Задание имени для создаваемой конфигурации неперекрывающихся видовых экранов. Имя можно не указывать, однако в этом случае конфигурация видовых экранов не сохраняется, и при необходимости повторного использования данную конфигурацию придется создавать заново. Если конфигурация видовых экранов не сохранена, ее нельзя использовать в пространстве листа.

Стандартные конфигурации

Список стандартных конфигураций видовых экранов, включая конфигурацию "ТЕКУЩАЯ".

Образец

Предварительный просмотр выбранной конфигурации видовых экранов, включая информацию о виде, назначенному каждому из них.

Применить

Применение конфигурации видовых экранов ко всей области рисования или только к текущему видовому экрану.

  • Экран: Применяет конфигурацию видовых экранов ко всей области рисования вкладки "Модель". Данное значение используется по умолчанию.
  • Текущий ВЭкран: Применяет конфигурацию видовых экранов только к текущему видовому экрану.

Режим

Выбор 2D- или 3D-режима. Если выбран 2D-режим, на всех видовых экранах создаваемой конфигурации по умолчанию устанавливается такой же вид, как и у текущего активного видового экрана. Если выбран 3D-режим, на создаваемых видовых экранах сразу же будут установлены стандартные виды модели.

Сменить вид на

Список возможных видов для создаваемых видовых экранов. В списке выводятся имеющиеся в чертеже именованные виды, а если установлен 3D-режим, то еще и стандартные виды модели. Для смены вида на каком-либо видовом экране нужно выделить его в группе «Образец» и выбрать нужный вид из списка.

Визуальный стиль

Визуальный стиль, применяемый к видовому экрану.

Вкладка "Именованные видовые экраны"—Пространство модели (Диалоговое окно "Видовые экраны")

Список конфигураций видовых экранов, сохраненных в чертеже. При выделении именованной конфигурации соответствующее ей расположение видовых экранов отображается в группе «Образец».

Текущее имя

Имя текущей выделенной конфигурации видовых экранов.

Вкладка "Новые видовые экраны"—Листы (Диалоговое окно "Видовые экраны")

Создание неперекрывающихся видовых экранов на основе стандартных конфигураций видовых экранов.

Стандартные конфигурации

Создание неперекрывающихся видовых экранов на основе стандартных конфигураций видовых экранов.

Образец

Предварительный просмотр выбранной конфигурации видовых экранов, включая информацию о виде, назначенному каждому из них.

Расстояние

Расстояние между создаваемыми плавающими видовыми экранами.

Режим

Выбор 2D- или 3D-режима. Если выбран 2D-режим, на всех видовых экранах создаваемой конфигурации по умолчанию устанавливается такой же вид, как и у текущего активного видового экрана. Если выбран 3D-режим, на создаваемых видовых экранах сразу же будут установлены стандартные виды модели.

Сменить вид на

Список возможных видов для создаваемых видовых экранов. В списке выводятся имеющиеся в чертеже именованные виды, а если установлен 3D-режим, то еще и стандартные виды модели. Для смены вида на каком-либо видовом экране нужно выделить его в группе «Образец» и выбрать нужный вид из списка.

Вкладка "Именованные видовые экраны"—Листы (Диалоговое окно "Видовые экраны")

Список конфигураций неперекрывающихся видовых экранов, сохраненных в чертеже. Любую из именованных конфигураций можно использовать на текущем листе. Создавать и сохранять именованные конфигурации плавающих видовых экранов нельзя.


ВЭКРАН вариант для командной строки

В Команды
В Команды
ВЭКРАН вариант для командной строки
Понятия Процедуры Команды

Запросы в командной строке зависят от типа настраиваемых видовых экранов: видовые экраны модели (на вкладке "Модель") или видовые экраны листа (на вкладке "Лист").

Темы:

  • ВЭКРАН командная строка - Видовые экраны в пространстве модели
  • ВЭКРАН командная строка - Видовые экраны листа


ВЭКРАН командная строка - Видовые экраны в пространстве модели

В Команды
В Команды
ВЭКРАН командная строка - Видовые экраны в пространстве модели
Понятия Процедуры Команды

Если в ответ на запрос "Команда" на вкладке "Модель" ввести -вэкран, вызывается вариант команды ВЭКРАН, использующий интерфейс командной строки.

Задайте опцию [Сохранить/Восстановить/Удалить/соЕдинить/Один/?/2/3/4]<3>: Задайте опцию

Вместе взятые количество и компоновка активных видовых экранов, а также связанные с ними установки называются конфигурацией видовых экранов.

Сохранить

Сохранение текущей конфигурации видовых экранов под заданным именем.

Имя новой конфигурации видовых экранов или [?]: Ввести имя или нажать ? для вывода списка сохраненных конфигураций видовых экранов

Восстановить

Восстановление именованной конфигурации видовых экранов.

Имя конфигурации видовых экранов для восстановления или [?]: Ввести имя или нажать ? для вывода списка сохраненных конфигураций видовых экранов

Удалить

Удаление именованной конфигурации видовых экранов.

Имя конфигурации видовых экранов для удаления <нет>: Ввести имя или нажать ? для вывода списка сохраненных конфигураций видовых экранов

соЕдинить

Объединение двух смежных видовых экранов в один. Вновь образованный видовой экран наследует вид основного видового экрана.

Выберите основной видовой экран <текущий>: Нажать ENTER или выбрать видовой экран

Выберите видовой экран для соединения: Выбрать видовой экран

Один

Восстановление одноэкранной конфигурации, на которой устанавливается вид текущего видового экрана.

?—Список конфигураций видовых экранов

Вывод информации о номерах-идентификаторах и положении текущих видовых экранов.

Имена каких конфигураций видовых экранов вывести <*>: Ввести имя или нажать ENTER

Положение видового экрана определяют его левый нижний и правый верхний углы. Для этих углов в программе используются значения от 0.0,0.0 (левый нижний угол области рисования) до 1.0,1.0 (правый верхний угол области рисования). Текущий видовой экран выводится в списке первым.

2

Деление текущего видового экрана пополам.

Расположение в конфигурации [Горизонтально/Вертикально] <Вертикально>: Ввести г или нажать ENTER

3

Деление текущего видового экрана на три части.

Расположение в конфигурации [Горизонтально/Вертикально/вЫше/Ниже/Левее/Правее] <Правее>: Задать опцию или нажать ENTER

Опции «Горизонтально» и «Вертикально» делят графическую область на три равные части. Название остальных опций («Выше», «Ниже», «Левее», «Правее») указывает, где располагается больший видовой экран.

4

Деление текущего видового экрана на четыре равные части.


ВЭКРАН командная строка - Видовые экраны листа

В Команды
В Команды
ВЭКРАН командная строка - Видовые экраны листа
Понятия Процедуры Команды

Если в ответ на запрос "Команда" на вкладке "Лист" ввести -вэкран , вызывается вариант команды ВЭКРАН, использующий интерфейс командной строки.

Угловая точка видового экрана или Вкл/Откл/Поширине/Тонирование/Блокировать/Объект/Многоугольный/Восстановить/2/3/4 <Вписать>: Указать точку или задать опцию

Вместе взятые количество и компоновка активных видовых экранов, а также связанные с ними установки называются конфигурацией видовых экранов.

Вкл

Включение видового экрана и его активизация. Располагающиеся на видовом экране объекты становятся видимыми.

Откл

Отключение видового экрана. Когда видовой экран отключен, его нельзя сделать текущим. Объекты на отключенном видовом экране невидимы.

Поширине

Создание одного видового экрана, занимающего всю свободную область листа. Размер видового экрана зависит от параметров листа.

Тонирование

Параметры печати видовых экранов.

Режим печати для тонированного ВЭ? [Обычный/все визуальные стили /все наборы параметров тонирования ]<Обычный>: Ввести опцию визуализации при печати

  • Обычный: Печатает объекты в соответствии с режимом отображения на экране
  • Все визуальные стили: Распечатка с использованием указанного визуального стиля; все визуальные стили, входящие в чертеж, перечисляются в виде опций независимо от их фактического использования.
  • Все наборы параметров тонирования: Распечатка с использованием заданного набора параметров тонирования; все наборы параметров тонирования указываются в списке в качестве опций.

Блокировать

Блокирование видовых экранов. Действие данной опции аналогично блокированию слоев.

Объект

Преобразование замкнутой полилинии, круга, эллипса, сплайна или области в новый видовой экран. Выбираемая полилиния должна быть замкнутой и содержать по крайней мере три вершины. Она может иметь самопересечения; допускается наличие в ней и линейных, и дуговых сегментов.

Многоугольный

Создание видового экрана, имеющего границу в виде многоугольника. Описание этого параметра см. в пункте "Новый контур" раздела ССПОДРЕЗАТЬ.

Начальная точка:

Следующая точка или [Дуга/Замкнуть/длИна/Отменить]: Указать точку или задать опцию

Восстановить

Восстановление именованной конфигурации видовых экранов.

Имя конфигурации видовых экранов или [?]: Ввести имя или ? для вывода списка сохраненных конфигураций видовых экранов

2

Деление текущего видового экрана пополам.

Расположение видовых экранов [Горизонтально/Вертикально] <Вертикально>: Ввести г или нажать ENTER

3

Деление текущего видового экрана на три части.

Расположение видовых экранов [Горизонтально/Вертикально/вЫше/Ниже/Левее/Правее] <Правее>: Задать опцию или нажать ENTER

Опции "Горизонтально" и "Вертикально" делят область на три равные части. С помощью остальных опций можно создать один видовой экран большего размера и два — меньшего. Название опций ("Выше", "Ниже", "Левее", "Правее") указывает, где располагается больший видовой экран.

4

Деление текущего видового экрана на четыре равные части.


ВЭКРЕЗ Команда

В Команды
В Команды
ВЭКРЕЗ Команда
Понятия Процедуры Команды

Подрезает объекты на видовых экранах и границы видового экрана.

Контекстное меню: Выбрать видовой экран, щелкнуть правой кнопкой мыши в области рисования и выбрать пункт «Подрезать видовой экран».

Ввод команды: вэкрез

Выберите видовой экран для подрезки:

Выберите подрезающий объект или [Многоугольный/Удалить] <Многоугольник>:

Подрезающий объект

Выбор объекта для контура подрезки. В качестве контура подрезки можно использовать замкнутые полилинии, круги, эллипсы, замкнутые сплайны, а также области.

Многоугольный

Построение контура подрезки произвольной формы. Контур может состоять из линейных и дуговых сегментов. В командной строке выдаются следующие запросы:

Начальная точка:

Следующая точка или [Дуга/Замкнуть/длИна/Отменить]:

Описание параметров "Следующая точка", "Дуга", "Закрыть", "Длина" и "Отменить", выводимых в командной строке, совпадает с описанием соответствующих параметров команды "ПЛИНИЯ".

Удалить

Удаление контура подрезки выбранного видового экрана. Данная опция доступна только в том случае, если выбранный видовой экран уже подрезан. При повторной подрезке видового экрана старый контур подрезки удаляется.


ВЭКРМАКС Команда

В Команды
В Команды
ВЭКРМАКС Команда
Понятия Процедуры Команды

Развертывает текущий видовой экран листа для редактирования

Строка состояния:

Контекстное меню: Щелкнуть правой кнопкой на видовом экране и выбрать «Развернуть ВЭкран».

Ввод команды: вэкрмакс

Выберите видовой экран для разворачивания:

Видовой экран максимально разворачивается и переключается в пространство модели для редактирования.


ВЭКРМИН Команда

В Команды
В Команды
ВЭКРМИН Команда
Понятия Процедуры Команды

Восстанавливает текущий видовой экран листа

Строка состояния:

Контекстное меню: Щелкнуть правой кнопкой на развернутом видовом экране и выбрать «Свернуть ВЭкран».

Ввод команды: вэкрмин

Видовой экран сворачивается до прежнего состояния. При этом восстанавливаются прежние значения центральной точки и коэффициента экранного увеличения.


Г Команды
  • ГРАДИЕНТ
  • ГЕОПОЛОЖЕНИЕ
  • ГИПЕРСВОЙСТВА
  • ГИПЕРССЫЛКА
  • ГРАФНАСТР
  • ГРАФЭКР
  • ГРПРЕД
  • ГРУППА
  • ГСВСТАВИТЬ


ГРАДИЕНТ Команда

Г Команды
Г Команды
ГРАДИЕНТ Команда
Понятия Процедуры Команды

Заполняет замкнутую область или выбранные объекты градиентной заливкой

Панель Рисование:

Меню "Рисование": Градиент

Ввод команды: градиент

Открывает диалоговое окно "Штриховка и градиент" на вкладке "Градиент".


ГЕОПОЛОЖЕНИЕ Команда

Г Команды
Г Команды
ГЕОПОЛОЖЕНИЕ Команда
Понятия Процедуры Команды

Задание широты и долготы расположения

Меню "Вид": "Тонирование" " "Источники света" " "Географическое положение"

Ввод команды: геоположение

Откроется диалоговое окно "Географическое положение"

Темы:

  • Диалоговое окно "Географическое положение"


Диалоговое окно "Географическое положение"

Г Команды
Г Команды
Диалоговое окно "Географическое положение"
Понятия Процедуры Команды

Панель "Источники света":

Пульт управления: "Источники света" " "Географическое положение"

Меню "Вид": "Тонирование" " "Источники света" " "Географическое положение"

Ввод команды: геоположение

Установка широты, долготы и направления на север для расположения

Широта

Отображение или установка широты и направления в десятичных значениях.

Широта

Установка широты текущего расположения. Можно ввести значение с клавиатуры или выбрать расположение на карте. Допустимый диапазон значений — от 1 до 90. (системная переменная LATITUDE)

Направление

Установка направления широты от экватора.

Долгота

Отображение или установка долготы и направления в десятичных значениях. Положительные значения определяют западную долготу.

Долгота

Отображение долготы текущего расположения. Можно ввести значение с клавиатуры или выбрать расположение на карте. Допустимый диапазон значений — от 1 до 180. (системная переменная LONGITUDE)

Направление

Отображение направления широты от главного меридиана.

Направление на север

Установка направления на север. По умолчанию направление на север это положительное направление оси Y Мировой системы координат (МСК).

Угол

Задание угла от 0 для направления на север.

Предварительный просмотр направления на север

Отображение направления на север.

Карта

Задание расположения с помощью мыши. Значения широты и долготы обновляются при выборе расположения. При вводе значений широты и долготы с клавиатуры происходит обновление карты и показывается расположение.

Ближайший крупный город

Отображение значений широты и долготы для выбранного ближайшего крупного города.

Область

Задание области мира.

Ближайший город

Задание города в выбранной области.

Часовой пояс

Задание часового пояса. Часовые пояса рассчитываются относительно расположения. Предусмотрена возможность непосредственного задания часового пояса. (системная переменная TIMEZONE)


ГИПЕРСВОЙСТВА Команда

Г Команды
Г Команды
ГИПЕРСВОЙСТВА Команда
Понятия Процедуры Команды

Управляет отображением курсора, подсказок и контекстного меню для гиперссылок

Ввод команды: гиперсвойства

Показывать курсор, подсказки и контекстные меню для гиперссылок? [Да/Нет] <Да>:

Примечание Если выбрать "Нет", доступ к гиперссылкам становится невозможен.


ГИПЕРССЫЛКА Команда

Г Команды
Г Команды
ГИПЕРССЫЛКА Команда
Понятия Процедуры Команды

Создание гиперссылки для объекта или изменение существующей гиперссылки

Меню "Вставка": "Гиперссылка"

Контекстное меню: Для редактирования гиперссылки следует выбрать объект, к которому она подключена, нажать правую кнопку мыши в области рисования и выбрать "Гиперссылка" » "Редактирование гиперссылки".

Ввод команды: гиперссылка

Выберите объекты: Выберите объекты любым способом

Отобразится одно из следующих диалоговых окон:

  • "Вставка гиперссылки" (для графических объектов, пока не имеющих гиперссылок) или
  • "Редактирование гиперссылки" (для графических объектов, уже содержащих гиперссылки)

Если с объектом связана гиперссылка, то при наведении на него указателя появляется курсор гиперссылки. Чтобы открыть гиперссылку, следует нажать правую кнопку мыши на выбранном объекте и выбрать из меню опцию "Гиперссылка". Для возможности открытия файлов, связанных с гиперссылками, системная переменная PICKFIRST должна иметь значение 1.

Если в командной строке ввести -гиперссылка, будут выведены опции команды ГИПЕРССЫЛКА, включая опции, позволяющие определить связываемую с гиперссылкой область.

Темы:

  • Диалоговое окно "Вставка гиперссылки"
  • Диалоговое окно "Редактирование гиперссылки"
  • Диалоговое окно "Выбор позиции в документе"
  • ГИПЕРССЫЛКА вариант для командной строки


Диалоговое окно "Вставка гиперссылки"

Г Команды
Г Команды
Диалоговое окно "Вставка гиперссылки"
Понятия Процедуры Команды

Меню "Вставка": "Гиперссылка"

Контекстное меню: Для редактирования гиперссылки следует выбрать объект, к которому она подключена, нажать правую кнопку мыши в области рисования и выбрать "Гиперссылка" » "Редактирование гиперссылки".

Ввод команды: гиперссылка

Снабжение графических объектов гиперссылками.

Пояснение к гиперссылке

Задание пояснения к гиперссылке. Это полезно, если имя файла или адрес, на который делается ссылка, не информативно и не позволяет судить о содержимом файла.

В диалоговом окне "Вставка гиперссылки" (под заголовком "Ссылка на:") имеются следующие вкладки: Имеющийся файл или Web-страница, Вид из этого чертежа, Адрес электронной почты

Имеющийся файл или Web-страница (диалоговое окно "Вставка гиперссылки")

Создание гиперссылки на существующий файл или Web-страницу.

Введите имя файла или Web-страницы

Задание файла или Web-страницы, на которые создается ссылка. Файл может храниться на рабочей станции, на сетевом диске, в Интернете или в корпоративной сети организации.

Последние файлы

Вывод списка последних файлов, на которые были установлены гиперссылки.

Просмотренные страницы

Вывод списка недавно просмотренных Web-страниц.

Вставленные ссылки

Вывод списка последних назначенных в чертеже гиперссылок.

Файл

Открывает диалоговое окно "Обзор Web - Выбор гиперссылки" (стандартное диалоговое окно выбора файлов), в котором можно разыскать файл, на который создается ссылка.

Web-страница

Открывает обозреватель Интернета, где можно перейти к web-странице, которую требуется связать с гиперссылкой.

Цель

Вызов диалогового окна "Выбор позиции в документе", в котором можно указать именованную позицию в чертеже, на которую создается ссылка.

Путь

Вывод пути к файлу, на который указывает гиперссылка. Если выбрана опция "Использовать относительный путь", то выводится только имя файла. Если опция "Использовать относительный путь" не выбрана, выводится полный путь к файлу.

Использовать относительный путь

Выбор между использованием относительного и полного пути для гиперссылок. При выборе этого параметра в гиперссылке не сохраняется полный путь к связанному с ней файлу. Для относительного пути устанавливается значение, указанное в системной переменной HYPERLINKBASE или, если этой переменной не присвоено никакого значения, относительный путь определяется как путь к текущему чертежу. Если этот параметр не выбран, в гиперссылке сохраняется полный путь к связанному с ней файлу.

Преобразовать гиперссылки из DWG в DWF

Указывает, что гиперссылка DWG будет преобразована в ссылку на файл DWF при публикации или печати чертежа в формате DWF.

Вид из этого чертежа (диалоговое окно "Вставка гиперссылки")

Задание именованного вида в текущем чертеже, на который создается ссылка.

Выберите вид из этого чертежа

Вывод структуры именованных видов текущего чертежа.

Адрес электронной почты (диалоговое окно "Вставка гиперссылки")

Задание адреса электронной почты, на который создается ссылка. При выборе ссылки открывается зарегистрированный по умолчанию клиент электронной почты, и в нем создается новое сообщение.

Адрес электронной почты

Задание адреса электронной почты.

Тема

Задание темы сообщения.

Последние использованные адреса электронной почты

Список последних использованных адресов электронной почты.


Диалоговое окно "Редактирование гиперссылки"

Г Команды
Г Команды
Диалоговое окно "Редактирование гиперссылки"
Понятия Процедуры Команды

Меню "Вставка": "Гиперссылка"

Контекстное меню: Для редактирования гиперссылки следует выбрать объект, к которому она подключена, нажать правую кнопку мыши в области рисования и выбрать "Гиперссылка" » "Редактирование гиперссылки".

Ввод команды: гиперссылка

Редактирование гиперссылок. Диалоговое окно "Редактирование гиперссылки" представляет собой видоизмененное окно "Вставка гиперссылки", в которое добавлен один дополнительный параметр.

Удалить ссылку

Удаление гиперссылки из выбранных графических объектов.


Диалоговое окно "Выбор позиции в документе"

Г Команды
Г Команды
Диалоговое окно "Выбор позиции в документе"
Понятия Процедуры Команды

Меню "Вставка": "Гиперссылка"

Контекстное меню: Для редактирования гиперссылки следует выбрать объект, к которому она подключена, нажать правую кнопку мыши в области рисования и выбрать "Гиперссылка" » "Редактирование гиперссылки".

Ввод команды: гиперссылка

Перемещение по видам и листам в пределах чертежа. Выбранная здесь именованная позиция будет являться начальным видом после перехода по гиперссылке.

Выберите существующую позицию внутри документа

Вывод дерева именованных позиций в чертеже, связанном с гиперссылкой.


ГИПЕРССЫЛКА вариант для командной строки

Г Команды
Г Команды
ГИПЕРССЫЛКА вариант для командной строки
Понятия Процедуры Команды

Если в командной строке ввести -гиперссылка, будут выведены опции для команды ГИПЕРССЫЛКА. Команда ГИПЕРССЫЛКА, вводимая в командной строке, позволяет подключать гиперссылки к областям и выбранным объектам, а также удалять гиперссылки.

Задайте опцию [Удалить/Слияние] <Вставка>: задайте опцию или нажмите ENTER

Удалить

Удаление гиперссылок из выбранных графических объектов. Если ни один из объектов не был выбран, программа предлагает их выбрать.

Выберите объекты: Выберите графические объекты на чертеже

Если выбранные объекты содержат несколько гиперссылок, в командной строке выводится нумерованный список найденных гиперссылок.

Введите номер, гиперссылку или * (все): Ввести номер, имя гиперссылки, или задать * для удаления всех гиперссылок из выбранных объектов

В командной строке отображается количество удаленных гиперссылок.

Слияние

Подключение гиперссылки к зоне или объекту чертежа.

Задайте опцию вставки гиперссылки [Зона/Объект] <Объект>: Выберите способ вставки гиперссылки

Площадь

Создание на слое URLLAYER ограничивающего прямоугольника. При отсутствии слоя с таким именем в текущем чертеже, он будет создан.

Примечание Чтобы прямоугольные границы зон-гиперссылок не отображались в области рисования или при выводе чертежа на печать, нужно заморозить слой URLLAYER. См. раздел Применение слоев для организации чертежей в руководстве пользователя.

Второй угол: Задать противоположный угол прямоугольника

AutoCAD запрашивает путь к файлу, подключаемому по гиперссылке.

Введите путь к файлу, с которым необходимо связать гиперссылку.

Гиперссылка <текущий чертеж>: Ввести полный путь к файлу на компьютере или полный URL-адрес файла в Интернете или нажать ENTER , чтобы создать гиперссылку на именованный вид в текущем чертеже

Задайте именованную позицию для гиперссылки, например, вид в чертеже или закладку в текстовом документе.

Именованная позиция <нет>: Задать именованную позицию или нажать ENTER для создания гиперссылки без нее

Введите пояснение <нет>: Ввести пояснение или нажать ENTER для создания гиперссылки без него

Объект

Выбор графического объекта для создания гиперссылки.

Выберите объекты: Выберите графические объекты на чертеже

Введите путь к файлу, с которым необходимо связать гиперссылку.

Гиперссылка <текущий чертеж>: Ввести полный путь к файлу на компьютере или полный URL-адрес файла в Интернете или нажать ENTER , чтобы создать гиперссылку на именованный вид в текущем чертеже

Задайте именованную позицию для гиперссылки, например, вид в чертеже или закладку в текстовом документе.

Именованная позиция <нет>: Задать именованную позицию или нажать ENTER для создания гиперссылки без нее

Введите пояснение <нет>: Ввести пояснение для гиперссылки или нажать ENTER для создания гиперссылки без него


ГРАФНАСТР Команда

Г Команды
Г Команды
ГРАФНАСТР Команда
Понятия Процедуры Команды

Обеспечивает конфигурационные установки системы 3D-графики

Ввод команды: графнастр

Отображается диалоговое окно "Адаптивное ухудшение и оптимизация параметров".

Если в ответ на подсказку в командной строке ввести -графнастр, в командной строке появится подсказка ГРАФНАСТР.

Темы:

  • Диалоговое окно "Адаптивное ухудшение и оптимизация параметров"
  • Протокол мастера оптимизации параметров
  • Диалоговое окно "Ручная оптимизации параметров"
  • Командная строка ГРАФНАСТР


Диалоговое окно "Адаптивное ухудшение и оптимизация параметров"

Г Команды
Г Команды
Диалоговое окно "Адаптивное ухудшение и оптимизация параметров"
Понятия Процедуры Команды

Управляет производительностью 3D отображения. (Это диалоговое окно также можно открыть нажатием кнопки "Параметры производительности" на вкладке "Система" диалогового окна Настройка.)

Виды при манипуляциях

Включает и выключает адаптивную деградацию. Если при включенной адаптивной деградации производительность становится ниже заданного вами уровня, то эффекты выключаются или блокируются в определенном порядке до восстановления приемлемого уровня производительности.

Деградация включается, когда "Кадр/с ниже"

Задает уровень, при котором начинается адаптивная деградация, измеряемая в кадрах в секунду (Кадр/с). Частота по умолчанию 5 кадр/с. Значение можно ввести с клавиатуры или выбрать из списка.

Порядок цепочки деградации

Задает порядок деградации эффектов. Деградация начинается с верхних элементов. Деградация непроверенных элементов не осуществляется. Нажать кнопку "Сдвиг вверх" или "Сдвиг вниз", чтобы переместить выбранный элемент в цепочке вверх или вниз.

Сдвиг вверх

Перемещает выбранный элемент вверх в цепочке.

Сдвиг вниз

Перемещает выбранный элемент вниз в цепочке.

Оптимизация парам. оборуд. и ПО

Задает установки параметров оборудования и настройки производительности. Мастер оптимизации параметров осуществляет считывание данных пользовательской системы и принимает решение об использовании программной или аппаратной реализации функций, которые поддерживают как программы, так и аппаратуру. Производится настройка функций, которые работают с пользовательской системой, а функции, которые с этой системой не работают, выключаются. Результаты выводятся в файл протокола. Пользователь может внести изменения вручную.

Просмотр протокола оптимизации

Отображает Протокол мастера оптимизации параметров

Ручная настройка

Отображает диалоговое окно "Ручная оптимизация параметров".

Проверка обновлений

Отображает веб-страницу, в которой содержится описание программы сертификации графических карт и драйверов дисплеев. В любое время можно загрузить последний обновленный список сертифицированных карт и драйверов.


Протокол мастера оптимизации параметров

Г Команды
Г Команды
Протокол мастера оптимизации параметров
Понятия Процедуры Команды

Меню "Сервис": "Настройки" (вкладка "Система" диалогового окна "Настройки")

Ввод команды: настрой

Перечисляет блокированные функции, если они имеются. В составе информации выводится конфигурация машины, графическое 3D-устройство и драйвер. Если 3D-устройство сертифицировано, значит компания Autodesk проверила его с помощью мастера оптимизации параметров.

Сохранить протокол как...

Отображает стандартное диалоговое окно выбора файлов.


Диалоговое окно "Ручная оптимизации параметров"

Г Команды
Г Команды
Диалоговое окно "Ручная оптимизации параметров"
Понятия Процедуры Команды

Меню "Сервис": "Настройки" (вкладка "Система" диалогового окна "Настройки")

Ввод команды: настрой

Задает опции, которые сказываются на производительности 3D отображения. Эти опции задаются автоматически мастером оптимизации параметров. Можно задать их вручную в этом диалоговом окне.

Параметры оборудования

Задает драйвер для графической карты и опции для использования аппаратного ускорения.

Включить аппаратное ускорение

Использует аппаратное ускорение. Если этот флажок сброшен, аппаратное ускорение не применяется, и все элементы в этом диалоговом окне недоступны.

  • Зеленый флажок указывает, что графическая карта сертифицирована, и может выполнять все функции.
  • Желтое предупреждение указывает, что графическая карта сертифицирована, но не может выполнять все функции. Если графическая карта неизвестна, мастер оптимизации параметров выводит желтое предупреждение, и пользователь может использовать аппаратное ускорение на свой собственный риск.
  • Красное предупреждение указывает, что графическая карта не сертифицирована. Когда этот флажок снят, функция "Включить аппаратное ускорение" недоступна.

Драйвер

Задает драйвер для графической карты. OpenGL – это wopengl9.hdi. Direct 3D - это direct3d9.hdi. Если для графической карты никаких драйверов не сертифицировано, выводится сообщение "нет сертифицированных драйверов". Переключается на драйвер, который может повлиять на список аппаратных эффектов.

Список аппаратных эффектов

Перечисляет функции и указывает их состояние, а также включены они или выключены. Этот флажок указывает функцию, которая поддерживается и включена; пользователь может ее выключить. Желтое предупреждение указывает, что функция не рекомендуется; пользователь может включить ее или выключить. Красное предупреждение, указывает, что данная функция не поддерживается и не может быть включена.

Примечание Для полного отображения теней требуется аппаратное ускорение. При отключенном параметре "Ускорение для геометрии" полное отображение теней невозможно.

Общие параметры

Задает опции, связанные с производительностью, которые не имеют аппаратной зависимости.

Без задних граней

При установке этого флажка задние грани объектов не прорисовываются.

Качество прозрачности

Корректирует качество прозрачности При установке "Низкая" эффект прозрачности достигается путем экранирования, и особого влияния на скорость это не оказывает. При установке "Средняя" (установка по умолчанию в программном режиме) смешивание улучшает качество изображения. При установке "Высокая" (установка по умолчанию в аппаратном режиме) формируется изображение, свободное от визуальных артефактов, создаваемое за счет снижения скорости построения.

Установки построения

Задает значения производительности на уровне чертежа.

Динамическая аппроксимация

Задание параметров, определяющих гладкость объектов на чертеже. Объекты построены с помощью множества коротких отрезков (или треугольников при рисовании сфер). Такие отрезки называются аппроксимирующими. Чем больше используется аппроксимирующих отрезков, тем точнее изображение графики на чертеже.

При визуализации поверхностей

Степень детализации при отображении поверхностей на чертеже. Нижний конец движка обеспечивает меньше линий аппроксимации и использует меньше памяти.

Визуализация кривых

Степень детализации при отображении кривых на чертеже. Нижнее положение ползунка обеспечивает меньше линий аппроксимации и использует меньше памяти.

Число уровней аппроксимации

Позволяет настроить систему в соответствии с требованиями к объему памяти и производительности. В трехмерной кэш-памяти всегда хранится по крайней мере один уровень аппроксимации. Если значение этого параметра равно 1, аппроксимация на всех видовых экранах выполняется одинаково и может привести к тому, что в процессе экранного увеличения или уменьшения некоторые объекты чертежа будут регенерироваться. При наличии нескольких видовых экранов с различными видами для этого параметра следует устанавливать значение 2 или более. Чем больше уровней задано, тем больше требуется памяти.

Сброс к рекомендуемым значениям

Выполняет сброс к значениям по умолчанию на основе анализа графической карты мастером оптимизации параметров.


ГРАФЭКР Команда

Г Команды
Г Команды
ГРАФЭКР Команда
Понятия Процедуры Команды

Переключение из текстового окна в графическую область

Ввод команды: графэкр (или 'графэкр для прозрачного вызова)

Команда ГРАФЭКР закрывает текстовое окно. Включить и отключить текстовое окно можно также нажатием клавиши F2. AutoCAD игнорирует эту команду, если к компьютеру подключены два монитора.


ГРПРЕД Команда

Г Команды
Г Команды
ГРПРЕД Команда
Понятия Процедуры Команды

Удаляет журнал из 3D элементарных тел и составных тел

Ввод команды: грпред

Выбрать объекты: Выбрать объекты любым способом и нажать ENTER по завершении работы

Журнал выбранных тел удален. Журнал исходных частей, из которых было создано тело, больше не сохраняется, таким образом, его исходные части нельзя выбрать и изменить.

При использовании команды ГРПРЕД для элементарного тела элементарное тело больше не является истинным примитивом и не может быть использовано как таковое (с помощью ручек и палитры свойств).


ГРУППА Команда

Г Команды
Г Команды
ГРУППА Команда
Понятия Процедуры Команды

Создание именованных наборов объектов (групп) и управление ими

Ввод команды: группа

Откроется диалоговое окно "Группы объектов".

Если в командной строке ввести -группа, будут выведены подсказки для команды ГРУППА.

Темы:

  • Диалоговое окно "Группы объектов"
  • Диалоговое окно "Порядок объектов в группе"
  • ГРУППА (вариант для командной строки)


Диалоговое окно "Группы объектов"

Г Команды
Г Команды
Диалоговое окно "Группы объектов"
Понятия Процедуры Команды

Ввод команды: группа

Просмотр, идентификация, именование и изменение групп объектов.

Имя группы

Список имен имеющихся групп.

Выбираемая

Флажок указывает, является ли группа выбираемой. Если он установлен, выбор одного объекта группы приводит к выбору всех объектов группы. Объекты, расположенные на замороженных и блокированных слоях, при этом не выбираются. Если системная переменная PICKSTYLE равна 0, группы не являются выбираемыми. В этом случае при указании объекта группы выбирается только он один.

Идентификация группы

Вывод имени и описания (если оно задано) для группы, выбранной в списке "Имя группы".

Имя группы

Задание имени группы. Имя может иметь длину до 31 символа; оно может состоять из букв, цифр и специальных символов (знак доллара ($), дефис (-) и знак подчеркивания (_)). Имя группы не может содержать пробелов. Имя преобразуется в верхний регистр.

Описание

Вывод описания выбранной группы (если оно задано).

Найти имя

Вывод списка групп, в которые входит объект.

Укажите элемент группы: Выбрать один объект

Отображается диалоговое окно "Список групп для объекта", в котором перечислены все группы, в которые входит объект.

Подсветить

Отображает в области рисования членов выбранной группы.

Включая неименованные

Добавление неименованных групп в список диалогового окна "Диспетчер групп". Если флажок не установлен, в списке выводятся только именованные группы.

Создать группу

Задание свойств новых групп.

Новая

Создает из выбранных объектов новую группу с именем и описанием, заданными в полях "Имя группы" и "Описание".

Имя группы появляется в списке "Имя группы".

Выбираемая

Задание свойства выбираемости для вновь создаваемой группы.

Без имени

Создание неименованной группы. Неименованным группам присваивается имя по умолчанию *An. где n число, увеличивающееся с каждой новой группой.

Изменение группы

Изменение свойств существующих групп.

Исключить

Исключение объектов из выбранной группы. Для использования этого параметра необходимо снять флажок "Выбираемая".

Выберите объекты для исключения: Выбрать объекты любым способом

Выбранные объекты удаляются из группы. Откроется диалоговое окно "Группы объектов".

Даже если из группы исключаются все объекты, описание группы сохраняется. Описание группы удаляется с помощью опции "Расчленить".

Примечание Если в течение сеанса рисования объекты сначала исключаются из группы, а затем вновь добавляются в нее, они возвращаются на прежнее место в соответствии с порядковыми номерами группы.

Добавить

Добавление объектов в выбранную группу.

Выберите объекты: Выбрать объекты любым способом

Выбранные объекты включаются в группу. Откроется диалоговое окно "Группы объектов".

Примечание Имена групп перечисляются в алфавитном порядке.

Переименовать

Присвоение выбранной группе нового имени, введенного в поле "Имя группы" в группе опций "Идентификация группы".

Порядок

Отображает диалоговое окно "Порядок объектов в группе", в котором можно изменить порядок следования объектов в группе. Объекты нумерованы в порядке их выбора при включении в группу. Изменение порядковых номеров полезно при расчете траекторий движения инструмента при обработке материалов. Например, можно изменить порядок обрезки горизонтальных и вертикальных линий.

Можно либо изменить порядковые позиции отдельных элементов (как по одному, так и для нескольких), либо обратить порядок следования всех элементов. Нумерация элементов группы начинается с 0, а не с 1.

Описание

Обновление описания выбранной группы на введенное в поле "Описание". Для описания имени можно использовать до 64 символов.

Расчленить

Удаление описания выбранной группы. Объекты группы не удаляются из чертежа.

Выбираемая

Изменение свойства выбираемости группы.


Диалоговое окно "Порядок объектов в группе"

Г Команды
Г Команды
Диалоговое окно "Порядок объектов в группе"
Понятия Процедуры Команды

Ввод команды: группа

Изменение порядка следования объектов в группах.

Имя группы

Список имен групп.

Описание

Вывод описания для выбранной группы.

Удалить из позиции (0-n)

Задание текущей позиции (порядкового номера) изменяемого объекта.

Введите новую позицию объекта (0-n)

Задание нового порядкового номера объекта в группе.

Число объектов (1-n)

Задание количества объектов, порядок которых изменяется. Также допускается задание интервала порядковых номеров объектов.

Порядок

Изменение порядковых номеров объектов группы.

Подсветить

По одному, в соответствии с порядковым номером в группе, отображает в области рисования объекты выбранной группы.

Обратный порядок

Изменение порядка следования объектов на противоположный.


ГРУППА (вариант для командной строки)

Г Команды
Г Команды
ГРУППА (вариант для командной строки)
Понятия Процедуры Команды

Если в командной строке ввести -группа, будут выведены подсказки для команды ГРУППА.

Задайте опцию для группы

[?/Порядок/Добавить/Удалить/Расчленить/ПЕРЕименование/Выбираемая/Создать] <Создать>: Задайте опцию или нажмите ENTER

?—Список групп

Вывод списка имен и описаний существующих групп в чертеже.

Имена каких групп вывести <*>: Введите список имен или нажмите ENTER для вывода всех групп

Порядок

Изменение порядка следования объектов в группе. Изменение порядковых номеров полезно при расчете траекторий движения инструмента при обработке материалов. Например, можно изменить порядок обрезки горизонтальных и вертикальных линий.

Имя группы или [?]: Введите список имен или нажмите ? для вывода списка всех групп

Введите порядковый номер переупорядочиваемого объекта (0-n ) или [Обратный порядок]: Введите порядковый номер или r

Порядковый номер

Задание номера позиции объекта, порядок которого изменяется. Для изменения порядка следования нескольких объектов здесь нужно указать номер первого из них.

Новая позиция объекта <0-n )>: Введите номер позиции, на которую перемещается объект

Число переупорядочиваемых объектов <0-n>: Введите число переупорядочиваемых объектов

Обратный порядок

Изменение порядка элементов группы на обратный.

Добавить

Добавление объектов в группу.

Имя группы или [?]: Введите имя или нажмите ? для вывода списка всех групп

Выберите объекты для добавления в группу...

Выберите объекты:

Удалить

Исключение объектов из группы.

Имя группы или [?]: Введите имя или нажмите ? для вывода списка всех групп

Выберите объекты для исключения из группы...

Выберите объекты для исключения:

Даже если из группы исключаются все объекты, описание группы сохраняется. Описание группы удаляется с помощью опции "Расчленить".

Расчленить

Группа расчленяется на исходные объекты. Описание группы удаляется.

Имя группы или [?]: Введите имя или нажмите ? для вывода списка всех групп

Разгруппировать

Отмена объединения объектов в группу и удаление самой группы.

Переименовать

Присвоение нового имени существующей группе.

Имя переименовываемой группы или [?]: Введите имя имеющейся группы или нажмите ? для вывода списка всех групп

Новое имя группы или [?]: Введите новое имя или ? для вывода списка всех групп

Выбираемая

Флажок указывает, является ли группа выбираемой. Если он установлен, выбор одного объекта группы приводит к выбору всех объектов группы. Объекты, расположенные на замороженных и блокированных слоях, при этом не выбираются.

Имя группы или [?]: Введите имя группы или ? для вывода списка всех групп

Эта группа выбираемая, хотите изменить ее состояние [Да/Нет]? <Д>: Введите д или н или нажмите ENTER

Создать

Создание группы.

Имя группы или [?]: Введите имя или ?

Имя может иметь длину до 31 символа; оно может состоять из букв, цифр и специальных символов (знак доллара ($), дефис (-) и знак подчеркивания (_)). Имя группы не может содержать пробелов. Имя преобразуется в верхний регистр.

Описание группы: Введите до 64 символов или нажмите ENTER

Выберите объекты:


ГСВСТАВИТЬ Команда

Г Команды
Г Команды
ГСВСТАВИТЬ Команда
Понятия Процедуры Команды

Вставка данных из буфера обмена как гиперссылки

Меню "Правка": Вставить как гиперссылку

Ввод команды: гсвставить

Выберите объекты:

Выбранные объекты вставляются в чертеж как гиперссылки.


Д Команды
  • ДАКОМ
  • ДВИД
  • ДВФВСТАВИТЬ
  • ДВФРЕГУЛ
  • ДВФРЕЗ
  • ДЕРЕВО
  • ДИАЛРЕД
  • ДИАЛТЗР
  • ДИАЛТТОЧ
  • ДИСПАТБЛК
  • ДИСППЕЧ
  • ДИСПСК
  • ДИСПСТИЛЬ
  • ДОПУСК
  • ДОС
  • ДСЛАЙД
  • ДСОЗАКРЫТЬ
  • ДУГА


ДАКОМ Команда

Д Команды
Д Команды
ДАКОМ Команда
Понятия Процедуры Команды

Восстановление внутренних команд AutoCAD, подавленных командой НЕТКОМ

Ввод команды: даком

Имя команды: Ввести имя команды AutoCAD, подавленной командой НЕТКОМ

Подавленную стандартную команду все же можно выполнить, набрав перед именем команды точку.


ДВИД Команда

Д Команды
Д Команды
ДВИД Команда
Понятия Процедуры Команды

Установка параллельной проекции или вида в перспективе с помощью камеры и цели

Ввод команды: двид

Выбрать объекты или <использовать ДВИДБЛОК>.

Задать опцию

[Камера/Цель/Расстояние/Точки/Пан/Зумирование/Вращать/Сечение/Скрыть/Откл/Отменить]: Указать точку с помощью устройства указания или задать опцию

Примечание При выполнении команды ДВИД прозрачные командыПОКАЗАТЬ,ОБЩИЙВИД, ПАН и полосы прокрутки недоступны. Если текущим является вид в перспективе, команды ПОКАЗАТЬ, ПАН, прозрачные ПОКАЗАТЬ, ПАН и ОБЩИЙВИД, а также полосы прокрутки недоступны.

Выбор объекта

Если выбраны объекты, они участвуют в построении образцов видов при их смене. Слишком много объектов выбирать не рекомендуется, так как это замедляет работу.

ДВИДБЛОК

Если нажать клавишу ENTER при наличии подсказки "Выбрать объекты", то с помощью блока ДВИДБЛОК будет выведено изображение в режиме предварительного просмотра. Пользователь может создать собственный блок ДВИДБЛОК в пределах области размером 1х1х1 единиц и с точкой вставки в левом нижнем углу. Ниже на рисунке показан пример использования стандартного блока ДВИДБЛОК при настройке вида (настройка вида выполняется при перемещении курсора).

Указание точки

Поворот вида под камерой. Точка, указанная мышью, принимается за начальную. Направление взгляда на цель изменяется по мере перемещения курсора.

Ввести углы направления и размера: Ввести углы от 0 до 360 градусов или указать точку устройством указания

Значения углов разделяются запятой. Они должны быть положительными. Угол направления определяет переднюю часть вида, а угол размера — его поворот.

Камера

Поворачивает камеру вокруг цели. Поворот задается двумя углами.

Указать положение камеры, или ввести угол от плоскости XY <от оси X>,

или [Переключение (угол текущий )] <текущий>: Указать точку с координатами XYZ, ввести t, ввести значение угла или нажать клавишу ENTER

Положение камеры

Определение положения камеры на основе заданной точки.

Ввод угла с плоскостью XY

Определение положения камеры, расположенной под углом к плоскости XY над плоскостью или под ней. Угол в 90 градусов направлен сверху вниз, угол –90 градусов - снизу вверх. Если угол равен 0, камера параллельна плоскости XY пользовательской системы координат ПСК.

После переключения угла или ввода значения угла в плоскости XY отобразится предыдущий запрос.

Переключение (угол в)

Переключает два режима ввода углов. Если угол введен из командной строки, курсор блокируется, и взгляд становится возможен только из заданного положения. После переключения курсор освобождается и может использоваться для поворота камеры.

Ввод угла в плоскости XY с осью X

Определение положения камеры, расположенной в плоскости XY под углом по отношению к оси X текущей ПСК. Допустимые значения угла находятся в диапазоне от –180 до 180 градусов. Если угол равен 0, взгляд направлен против оси X к началу координат.

На чертеже показан поворот камеры влево при неизменном угле с плоскостью XY.

Переключение (угол от)

Переключает два режима ввода углов. Если угол введен из командной строки, курсор блокируется, и взгляд становится возможен только из заданного положения. После переключения курсор освобождается и может использоваться для поворота камеры.

Цель

Поворачивает цель вокруг камеры. Действие данной опции аналогично тому, как если бы зритель, оставаясь на одном месте, поворачивал голову, чтобы лучше рассмотреть различные части чертежа. Поворот задается двумя углами.

Указать положение камеры, или ввести угол от плоскости XY <от оси X>,

или [Переключение (угол текущий )] <текущий>: Указать точку с координатами XYZ, ввести t, ввести значение угла или нажать клавишу ENTER

Ввод угла с плоскостью XY

Устанавливает положение цели относительно плоскости XY. Угол в 90 градусов направлен сверху вниз, угол –90 градусов - снизу вверх. Если угол равен 0, цель параллельна плоскости XY ПСК.

После переключения угла или ввода значения угла в плоскости XY отобразится предыдущий запрос.

Переключение (угол в)

Переключает два режима ввода углов. Если угол введен из командной строки, курсор блокируется, и взгляд становится возможен только из заданного положения. После переключения курсор освобождается и может использоваться для поворота цели.

Ввод угла в плоскости XY с осью X

Устанавливает положение цели в плоскости XY под углом относительно оси X текущей ПСК. Допустимые значения угла находятся в диапазоне от –180 до 180 градусов. Если угол равен 0, взгляд направлен против оси X к началу координат.

На чертеже показан поворот цели слева направо при неизменном угле с плоскостью XY.

Переключение (угол от)

Переключает два режима ввода углов. Если угол введен из командной строки, курсор блокируется, и взгляд становится возможен только из заданного положения. После переключения курсор освобождается и может использоваться для поворота цели.

Расстояние

Перемещает камеру вдоль направления взгляда с включением вида в перспективе. Объекты, расположенные дальше от камеры, кажутся более мелкими. Знак системы координат заменяется пиктограммой перспективы. Появляется запрос на указание нового расстояния от камеры до цели.

Задать новое расстояние камера-цель <текущее>: Ввести значение расстояния или нажать клавишу ENTER

Шкала в верхней части области чертежа имеет деления от 0x до 16x, где 1x - текущий коэффициент. Шкала имеет деления от 0x до 16x, где 1x текущее расстояние. При перемещении указателя вправо расстояние от камеры до цели увеличивается, при перемещении влево — уменьшается. Для отключения вида в перспективе нажать опцию "Откл" в ответ на запрос команды ДВИД.

При близко расположенных друг к другу камере и цели, или при большом фокусном расстоянии после задания нового расстояния на экране может оказаться видна лишь небольшая часть чертежа. В таком случае можно попробовать поставить максимальное значение увеличения (16x) или увеличить расстояние. Для увеличения вида чертежа без включения перспективы служит опция "Зумирование" команды ДВИД.

На чертеже показан результат перемещения камеры относительно цели вдоль линии взгляда; угол зрения остается постоянным.

Точки

Размещает камеру и цель в точках, заданных координатами (X,Y,Z). Можно воспользоваться точечными фильтрами XYZ.

Задать точку цели <текущая>: Указать точку или нажать клавишу ENTER

Для удобства определения направления взгляда от камеры к перекрестью курсора проводится резиновая линия. Появляется запрос на указание нового положения камеры.

Задать точку камеры <текущая>: Указать точку, ввести значения направления и углов или нажать клавишу ENTER

Для удобства размещения камеры от цели к перекрестью курсора проводится резиновая линия. На чертеже показано, как изменяется вид, когда точки камеры и цели меняются местами. Расстояние и углы одинаковы в обоих случаях.

Подробные сведения о вводе данных о направлении и величинах углов см. в разделе "Определение точки".

Панорамирование

Перемещает вид, не изменяя его увеличение.

Базовая точка перемещения: Указать точку

Вторая точка: Указать точку

Зумирование

При отключенной перспективе опция зумирования динамически увеличивает или уменьшает видимые размеры объектов на текущем видовом экране.

Задать коэффициент зумирования с заданием масштаба <текущий>: Задать масштаб или нажать клавишу ENTER

Коэффициент можно устанавливать на скользящей шкале, расположенной в верхней части области рисования. Шкала имеет деления от 0x до 16x, где 1x — текущий коэффициент. При перемещении указателя вправо коэффициент увеличивается, при перемещении влево — уменьшается.

При включенной перспективе опция зумирования настраивает фокусное расстояние, определяющее размер поля зрения. По умолчанию принято фокусное расстояние, равное 50 мм, имитирующее вид, обеспечиваемый 35-мм камерой с 50-мм объективом. Увеличение фокусного расстояния моделирует переключение на телеобъектив. Чем меньше фокусное расстояние, тем шире поле зрения.

Задать фокусное расстояние <50,000мм>: Задать значение или нажать ENTER

Фокусное расстояние можно устанавливать на скользящей шкале, расположенной в верхней части области рисования. Шкала имеет деления от 0x до 16x, где 1x — текущее расстояние. При перемещении указателя вправо фокусное расстояние увеличивается, при перемещении влево — уменьшается.

Вращать

Вращает и наклоняет вид относительно направления взгляда. Угол скручивания измеряется против часовой стрелки, значение 0 градусов справа.

Задать угол закручивания вида <текущий>: Задать угол или нажать клавишу ENTER

Сечение

Устанавливает на виде секущие плоскости. Элементы чертежа, расположенные дальше задней или ближе передней секущей плоскости, не видны. Плоскости подобны невидимым стенам, установленным между камерой и целью перпендикулярно направлению взгляда.

Задать секущую плоскость [Задняя/Передняя/Откл] <Откл>: Задать опцию или нажать клавишу ENTER

Назад

Скрывает объекты, расположенные дальше задней секущей плоскости.

Задать расстояние от цели или [ВКЛ/ОТКЛ] <текущее>: Указать расстояние, задать опцию или нажать клавишу ENTER

Расстояние от цели

Включает заднюю секущую плоскость и задает ее положение. Если расстояние положительно, плоскость находится между камерой и целью, иначе — за целью. Для установки секущей плоскости можно использовать скользящую шкалу.

Вкл

Включает заднюю секущую плоскость на текущем расстоянии от цели.

Откл

Отключает заднюю секущую плоскость.

Передний план

Скрывает объекты, расположенные между камерой и передней секущей плоскостью.

Задать расстояние от цели или [Глаз (камера)/ВКЛ/ОТКЛ] <текущее>: Указать расстояние, ввести e или нажать ENTER

Расстояние от цели

Включает переднюю секущую плоскость и задает ее положение. Если расстояние положительно, плоскость находится между камерой и целью, иначе — за целью. Для установки секущей плоскости можно использовать скользящую шкалу.

Глаз

Совмещает переднюю секущую плоскость с камерой.

Вкл

Включает переднюю секущую плоскость. Опция доступна только при отключенной перспективе.

Откл

Отключает переднюю секущую плоскость. Опция доступна только при отключенной перспективе.

Откл

Отключает секущие плоскости. При включенной перспективе передняя секущая плоскость совмещается с камерой.

Скрыть

Подавляет скрытые линии для выбранных объектов. Круги, фигуры, полосы, области, широкие полилинии, трехмерные грани, полигональные сети и выдавленные с ненулевой глубиной объекты рассматриваются как непрозрачные поверхности, способные загораживать другие объекты. Операция выполняется быстрее, чем команда СКРЫТЬ, но получившийся вид не может быть выведен на печать.

Откл

Отключает перспективу. Для ее нового включения следует задать опцию "Расстояние".

Отменить

Обращает результаты последнего выполнения команды ДВИД. Можно последовательно отменить результаты нескольких операций команды ДВИД.


ДВФВСТАВИТЬ Команда

Д Команды
Д Команды
ДВФВСТАВИТЬ Команда
Понятия Процедуры Команды

Вставка подложки DWF в текущий чертеж

Панель "Вставка":

Меню "Вставка": "Подложка DWF"

Ввод команды: двфвставить

На экран выводится диалоговое окно "Выбор DWF-файла" (стандартное диалоговое окно выбора файлов). После выбора DWF-файла на экран выводится диалоговое окно "Подключение подложки DWF".

Примечание Если планируется доступ к DWF-файлам с сервера клиента Vault, следует иметь в виду, что диалоговое окно открытия файлов Vault имеет приоритет перед диалоговым окном "Выбор DWF-файла". Доступ к серверу клиента Vault открыт только для пользователей, обладающих подпиской Autodesk.

Темы:

  • Диалоговое окно "Подключение подложки DWF"
  • Диалоговое окно "Замена имени DWF"
  • Командная строка ДВФВСТАВИТЬ


Диалоговое окно "Подключение подложки DWF"

Д Команды
Д Команды
Диалоговое окно "Подключение подложки DWF"
Понятия Процедуры Команды

Панель "Вставка":

Меню "Вставка": "Подложка DWF"

Ввод команды: двфвставить

Присваивает имя, выполняет размещение и определяет точку вставки, масштаб и угол поворота подключаемых подложек DWF.

Имя

Определяет DWF-файл, выбранный пользователем для вставки, либо через диалоговое окно "Выбор DWF-файла" (DWF-файл, вставка которого не производилась ранее), либо из списка ранее вставлявшихся подложек DWF. Чтобы добавить еще одно вхождение уже вставленной подложки DWF, выбрать соответствующее имя DWF из списка.

Примечание Во время процедуры вставки DWF-файла, который хранится на сервере клиента Vault, поле "Имя" отключено. Эти данные сервер Vault вводит автоматически. Доступ к серверу клиента Vault открыт только для пользователей, обладающих подпиской Autodesk.

Обзор

Открывает диалоговое окно "Выбор DWF-файла" (стандартное диалоговое окно выбора файлов). Если выбрать "Виды" » подменю "Просмотр", на экран будет выведено окно предварительного просмотра выбранного файла.

Примечание Во время процедуры вставки DWF-файла, который хранится на сервере клиента Vault, кнопка "Обзор" скрыта.

Найдено в

Отображает путь к месту расположения DWF-файла.

Сохраненный путь

Отображает путь, сохраняемый вместе с чертежом при выполнении вставки DWF-файла. Этот путь определяется настройкой "Тип пути".

Выбрать лист

Выводит на экран все листы, найденные в DWF-файле. Если DWF-файл содержит только один лист, этот лист заносится в список.

Если DWF-файл содержит несколько листов, то выбрать для вставки можно только один из них. По умолчанию выбирается лист, стоящий в списке первым.

Примечание 3D листы в список не включаются, и, если DWF-файл не содержит пригодного к использованию 2D листа, на экран выводится предупреждение.

Задание пути

Определяет один из трех типов путей к папке, сохраняемых вместе со вставленной подложкой DWF: абсолютный путь, относительный путь и незаданный путь. Полное описание каждого типа см. в Задание путей к внешним чертежам в Руководстве пользователя.

Примечание Во время процедуры вставки DWF-файла, который хранится на сервере клиента Vault, группа параметров "Тип пути" заблокирована. Эти данные сервер Vault вводит автоматически.

Полный

Определяет абсолютный путь к DWF-файлу.

Относительный

Определяет относительный путь к DWF-файлу.

Без пути

Задает только имя DWF-файла. DWF-файл должен быть сохранен в одной папке с файлом текущего чертежа.

Точка вставки

Задает точку вставки для выбранного DWF-файла. По умолчанию установлен флажок "Указать на экране". Точкой вставки по умолчанию считается 0,0,0.

Указать на экране

Задание параметра в командной строке или устройством указания на экране. Если же флажок "Указать на экране" снят, координаты X, Y и Z точки вставки задаются в диалоговом окне.

X

Значение координаты X.

Y

Значение координаты Y.

Z

Значение координаты Z.

Масштаб

Задает масштабный коэффициент для выбранной подложки DWF.

Если установлен флажок "Указать на экране", задание параметра будет произведено в командной строке или устройством указания. Если флажок сброшен, масштабный коэффициент задается в диалоговом окне. Масштаб по умолчанию равен 1.

Если для INSUNITS установлено значение “без единиц” или если отсутствует информация о разрешении подложки, то ширину подложки в единицах AutoCAD представляет масштабный коэффициент. Если для INSUNITS задано значение в таких единицах, как миллиметры, сантиметры, дюймы или футы, а подложка содержит данные о разрешающей способности, то масштабный коэффициент применяется после того, как определена истинная ширина подложки в единицах AutoCAD.

Поворот

Задает угол поворота для выбранной подложки DWF.

Если установлен флажок "Указать на экране", угол поворота задается после выхода из диалогового окна с помощью устройства указания или вводом значения в командной строке. Если же флажок "Указать на экране" сброшен, угол поворота изображения задается в диалоговом окне. Угол по умолчанию равен 0.


Диалоговое окно "Замена имени DWF"

Д Команды
Д Команды
Диалоговое окно "Замена имени DWF"
Понятия Процедуры Команды

Панель "Вставка":

Меню "Вставка": "Подложка DWF"

Ввод команды: двфвставить

Имена вставляемых ссылок DWF должны быть уникальны. Попытка вставить две ссылки DWF с одним и тем же именем приведет к выводу на экран диалогового окна "Замена имени DWF".

Новое имя DWF

Ввести уникальное имя для вставляемой подложки DWF.

После присвоения нового имени можно продолжить процесс вставки.

Примечание Это приведет только к изменению имени ссылки DWF при вставке этой ссылки. Ввод нового имени для подложки не изменит имени DWF-файла.


Командная строка ДВФВСТАВИТЬ

Д Команды
Д Команды
Командная строка ДВФВСТАВИТЬ
Понятия Процедуры Команды

Если в ответ на подсказку "Команда" ввести -двфвставить, будет вызван вариант команды ДВФВСТАВИТЬ, при котором в командной строке выводятся подсказки:

Путь к вставляемому DWF-файлу: Ввести путь и имя DWF-файла, подлежащего вставке

Ввести имя листа или [?]<Первое действительное имя листа в чертеже>: Задать имя листа или нажать ENTER, чтобы подтвердить имя листа из списка

Задать точку вставки: Указать точку вставки

Задать масштабный коэффициент или [Единица измерения] <1.0000>: Задать масштабный коэффициент

Задать угол поворота <0>: Задать угол поворота

?—Список листов

Выводит список действительных листов текущего чертежа.

Ввести листы, которые следует внести в список <*>: Ввести имя, часть имени с групповыми символами или нажать клавишу ENTER для включения в список всех листов

После вывода списка листов выдается предыдущая подсказка.


ДВФРЕГУЛ Команда

Д Команды
Д Команды
ДВФРЕГУЛ Команда
Понятия Процедуры Команды

Позволяет выполнять настройку подложки DWF из командной строки

Ввод команды: двфрегул

Выбрать подложку DWF: Выбрать одну или несколько подложек DWF

Задать опцию для подложки DWF [Слияние с фоном/Контрастность/ Монохромный ] <Слияние с фоном>:

Если выбрана одиночная подложка DWF, то значениями по умолчанию для параметров "Слияние с фоном", "Контрастность" и "Монохромность" принимаются текущие свойства выбранной подложки. Если выбрано несколько подложек, то значениями по умолчанию для параметров "Слияние с фоном", "Контрастность" и "Монохромность" останутся значения, установленные при последнем применении данной команды.

Для настройки цветов в подложке DWF следует открыть "Палитру свойств" для подложки DWF. Для получения дополнительных сведений см. раздел Регулировка контрастности, степени слияния с фоном, параметра "Монохромный" и цветов фона подложки DWF .

Слияние с фоном

Управляет эффектом слияния подложки с фоном. Значения могут изменяться в диапазоне от 0 до 80. Чем больше значение, чем тоньше отображается линия на подложке. Косвенно влияет на эффект контраста; при более высоком значении контраста цвет подложки переходит в цвет фона, если параметру эффекта слияния с фоном установлено более высокое значение. Значение по умолчанию=25.

Ввести значение для эффекта слияния с фоном (0-80): Ввести значение

Контрастность

Управляет контрастностью изображения и косвенно степенью его слияния с фоном подложки. Значение может изменяться в диапазоне от 0 до 100. Чем оно больше, тем ближе цвет пикселов к одному из двух основных цветов. Значение по умолчанию=75.

Ввести значение для эффекта контрастности (0-100): Ввести значение

Монохромный

Переключатель "Да/Нет" управляет эффектом насыщенности цветом линий при поддержании их яркости. Если данная опция включена, отображаемые линии имеют различные оттенки серого цвета, начиная с черного, если для яркости цвета фона установлено значение 50% или выше. Если значение яркости цвета фона менее 50%, то выполняется инвертирование цвета, при котором самые темные линии отображаются белым цветом, а самые тонкие линии - черным цветом.

Монохромный? [Да/Нет]: Выбрать да или нет и нажать ENTER


ДВФРЕЗ Команда

Д Команды
Д Команды
ДВФРЕЗ Команда
Понятия Процедуры Команды

Определение подобласти подложки DWF с помощью секущих контуров.

Контекстное меню: Выбрать подлежащую подрезке подложку DWF, нажать правую кнопку мыши на области чертежа и выбрать позицию "Подрезка DWF".

Ввод команды: двфрез

Выбрать DWF для подрезки: Выбрать кромку подложки DWF

Задать опцию подрезки DWF [ВКЛ/ОТКЛ/Удалить/Новый контур] <Новый контур>: Ввести опцию или нажать клавишу ENTER

Контур подрезки задается в плоскости, параллельной подложке DWF.

Вкл

Включение функции подрезки и вывод на экран части подложки DWF, обрезанной по предварительно заданному контуру.

Откл

Отключение функции подрезки и вывод на экран подложки DWF полностью в ее исходных границах.

Если повторная подрезка подложки DWF выполняется при выключенной функции подрезки, то при повторном вызове этой команды подрезка автоматически восстанавливается. Отобразится подсказка удалить старый контур, даже если подрезка отключена и он невидим.

Удалить

Удаление ранее заданного контура подрезки и вывод на экран подложки DGN целиком, в ее первоначальном виде.

Новый контур

Новый контур Задание нового контура подрезки. Для определения контура подрезки следует внутри границ подложки DWF задать вершины. Допускаются самопересекающиеся вершины. Контуры могут быть самопересекающимися. Если в ответ на подсказу "Тип контура подрезки" для указания точки используется указывающее устройство, точка рассматривается как первый угол прямоугольного контура.

Тип контура подрезки [Многоугольный/Прямоугольный] <Прямоугольный>: Ввести p или нажать клавишу ENTER

Многоугольный

Построение многоугольного контура путем последовательного указания точек.

Первая точка: Указать точку

Следующая точка или [Отменить]: Указать точку или ввести u

Следующая точка или [Отменить]: Указать точку или ввести u

Задать следующую точку или [Закрыть/Отменить]: Задать точку или ввести c или u

Для формирования многоугольного контура необходимо указать по крайней мере три точки.

Если для данной подложки DWF уже определен контур подрезки, отобразится следующая подсказка:

Удалить прежние контуры? [Нет/Да] <Да>:Ввести n или нажать клавишу ENTER

При выборе "Да" вся подложка DWF перерисовывается и выполнение команды продолжается; если выбран ответ "Нет", выполнение команды завершается.

Прямоугольный

Построение прямоугольного контура путем указания его противоположных угловых точек. Прямоугольник всегда строится параллельно граням подложки DWF.

Задать первый угол: Задать точку

Задать противоположный угол: Задать точку


ДЕРЕВО Команда

Д Команды
Д Команды
ДЕРЕВО Команда
Понятия Процедуры Команды

Отображение информации о пространственных индексах в чертеже

Ввод команды: дерево (или 'дерево для вызова в прозрачном режиме)

Программа индексирует объекты в области посредством записи их расположения в пространстве. Построенный индекс называется пространственным. Пространственный индекс имеет древовидную структуру и состоит из ветвей, к узлам которых прикреплены объекты. Основных ветвей в индексе две. Ветвь пространства листа называется деревом квадрантов и рассматривает объекты как двумерные. Ветвь пространства модели называется деревом октантов и рассматривает объекты как двух- или трехмерные. При работе с двумерными чертежами в пространстве модели его ветвь может также быть преобразована в дерево квадрантов.

Команда ДЕРЕВО отображает информацию о каждой ветви. Наиболее важными являются первые две строчки отчета — количество узлов, количество объектов, максимальная глубина ветвей и среднее количество объектов, приходящихся на узел.

Если команда ОСВЕЖИТЬ и выбор объектов работают медленно, можно повысить их производительность. Например, если доступно 50 Мбайт памяти, а в текущем чертеже существует 50000 объектов, для которых задано только 1000 узлов в дереве индексов, для повышения производительности следует увеличить значение системной переменной TREEDEPTH.

Каждый узел занимает около 80 байт памяти. Чем меньше приходится объектов на узел дерева октантов, тем выше производительность.


ДИАЛРЕД Команда

Д Команды
Д Команды
ДИАЛРЕД Команда
Понятия Процедуры Команды

Редактирование текстов (в том числе размерных), описаний атрибутов и допусков формы и расположения

Панель "Текст":

Меню "Изменить": "Объект" » подменю "Текст" » подменю "Правка"

Устройство указания: Дважды нажать на текстовом объекте.

Контекстное меню: Выбрать текстовый объект, нажать правую кнопку мыши в области рисования и выбрать "Редактирование".

Ввод команды: диалред

Выбрать объект-пояснение или [Отменить]:

Выбор объекта

Отображает способ редактирования, соответствующий типу выбранного текста:

  • Если для системной переменной DTEXTED установлено значение 0 или 2, то текст, созданный посредством команды ТЕКСТ или ДТЕКСТ, отображает Текстовый редактор, используемый в месте редактирования без панели "Формат текста" и без линейки. Нажать правую кнопку мыши для отображения параметров.
  • Если текст создан с помощью команды МТЕКСТ, на экран выводится диалоговое окно Текстовый редактор, используемый в месте редактирования.
  • Если выбрано описание атрибута (не входящего в блок), открывается диалоговое окно "Редактирование описания атрибута".
  • Если выбран допуск формы и расположения, на экран выводится диалоговое окно "Допуски формы и расположения".

Команда ДИАЛРЕД повторяет свою подсказку до тех пор, пока не будет нажата клавиша ENTER.

Отменить

Возвращает текст или описание атрибута в состояние, которое они имели до редактирования. Данная опция должна вызываться непосредственно после редактирования.

Темы:

  • Диалоговое окно "Редактирование текста"
  • Диалоговое окно "Редактирование описания атрибута"


Диалоговое окно "Редактирование текста"

Д Команды
Д Команды
Диалоговое окно "Редактирование текста"
Понятия Процедуры Команды

Панель "Текст":

Контекстное меню: Выбрать текстовый объект, нажать правую кнопку мыши в области рисования и выбрать "Редактирование".

Ввод команды: диалред

Если значение системной переменной DTEXTED равно 1, изменяется текст, созданный с помощью команд ТЕКСТ или ДТЕКСТ. Ввести текст и нажать "ОК".

Для добавления тексту поля, следует нажать правую кнопку мыши на том месте, куда это поле необходимо вставить, и выбрать из контекстного меню пункт "Вставить поле". При этом открывается диалоговое окно "Поле".


Диалоговое окно "Редактирование описания атрибута"

Д Команды
Д Команды
Диалоговое окно "Редактирование описания атрибута"
Понятия Процедуры Команды

Панель "Текст":

Контекстное меню: Выбрать текстовый объект, нажать правую кнопку мыши в области черчения и выбрать "Редактирование".

Ввод команды: диалред

Редактирование имени атрибута, его подсказки и значения по умолчанию.

Имя

Имя атрибута, по которому он идентифицируется в чертеже. Имя может состоять из любых символов, кроме пробелов и восклицательных знаков (!). Все строчные буквы автоматически преобразуются в прописные.

Подсказка

Подсказка атрибута, выводимая на экран всякий раз при вставке блока, содержащего данный атрибут. Для задания ведущих пробелов в подсказке нужно начать ее с обратной косой черты (\). Если первый значащий символ должен быть обратной косой чертой, ее следует повторить дважды.

По умолчанию

Значение, которое присваивается атрибуту по умолчанию. Для задания ведущих пробелов в значении по умолчанию нужно начинать его с обратной косой черты (\). Если первый значащий символ должен быть обратной косой чертой, ее следует повторить дважды.

Для использования поля в качестве значения следует нажать правую кнопку и выбрать пункт "Вставить поле" из контекстного меню. Открывается диалоговое окно "Поле".


ДИАЛТЗР Команда

Д Команды
Д Команды
ДИАЛТЗР Команда
Понятия Процедуры Команды

Задание направления взгляда в трехмерном пространстве

Меню "Вид": "3D виды" » подменю "Стандартные точки зрения"

Ввод команды: диалтзр

Открывается диалоговое окно "Задание точки зрения".

Темы:

  • Диалоговое окно "Задание точки зрения"


Диалоговое окно "Задание точки зрения"

Д Команды
Д Команды
Диалоговое окно "Задание точки зрения"
Понятия Процедуры Команды

Меню "Вид": "3D виды" » подменю "Стандартные точки зрения"

Ввод команды: диалтзр

Здесь описываются параметры 3D точки зрения.

Задание углов зрения

Задает направление взгляда относительно либо МСК, либо ПСК.

Абсолютно в МСК

Задает направление взгляда относительно МСК.

Относительно ПСК

Задает направление взгляда относительно текущей ПСК.

Источник

Задает углы зрения.

Ось X

Задает угол с осью X.

С плоскостью XY

Задает угол с плоскостью XY.

Для установки углов зрения можно использовать слайд-образец. Черный штрих указывает новый угол, серый текущий угол. Угол задается указанием точки внутри круга или полукруга. Если же указана точка во внешних разделенных на секторы областях, значение угла округляется до соответствующей величины. Если указать внутреннюю дугу или область внутри нее, то угол не округляется и результат может представлять собой дробное число.

Вид в плане

Устанавливает вид в плане выбранной системы координат.


ДИАЛТТОЧ Команда

Д Команды
Д Команды
ДИАЛТТОЧ Команда
Понятия Процедуры Команды

Задание стиля отображения и величины точечных объектов

Меню "Формат": "Отображение точек"

Ввод команды: диалтточ(или 'диалтточ для прозрачного вызова)

Открывается диалоговое окно "Отображение точек".

Темы:

  • Диалоговое окно "Отображение точек"


Диалоговое окно "Отображение точек"

Д Команды
Д Команды
Диалоговое окно "Отображение точек"
Понятия Процедуры Команды

Меню "Формат": "Отображение точек"

Ввод команды: диалтточ(или 'диалтточ для прозрачного вызова)

В диалоговом окне "Отображение точек" показаны текущий вид объектов-точек и их величина. Режим изображения точек можно изменить путем выбора необходимой пиктограммы.

Варианты изображений

Здесь задается изображение, которое используется для показа объектов-точек. Стиль изображения точек запоминается в системной переменной PDMODE.

Размер в пунктах

Устанавливает размер символа точки. Введенное значение может задавать размер относительно размера экрана или в абсолютных единицах. Размер символа точки хранится в системной переменной PDSIZE. Вновь наносимые объекты-точки будут иметь величину, соответствующую заданному размеру.

Установка размера относительно экрана

Устанавливает размер символа точки в процентах от размера экрана. В этом случае при зумировании размер точек не меняется.

Установка размера в абсолютных единицах

Устанавливает размер символа точки равным числу, заданному в поле "Размер точки", в текущих абсолютных единицах. Размер точки увеличивается или уменьшается при увеличении или уменьшении масштаба.


ДИСПАТБЛК Команда

Д Команды
Д Команды
ДИСПАТБЛК Команда
Понятия Процедуры Команды

Редактирование свойств атрибутов в описаниях блоков

Панель "Редактирование-2":

Меню "Редактирование": объект » подменю "Атрибут" » подменю "Диспетчер атрибутов блоков"

Ввод команды: диспатблк

Открывается диалоговое окно "Диспетчер атрибутов блоков".

Если текущий чертеж не содержит блоков с атрибутами, на экране появляется сообщение об этом.

Темы:

  • Диспетчер атрибутов блоков
  • Диалоговое окно "Редактирование атрибута"
  • Диалоговое окно "Параметры"


Диспетчер атрибутов блоков

Д Команды
Д Команды
Диспетчер атрибутов блоков
Понятия Процедуры Команды

Панель "Редактирование-2":

Меню "Редактирование": объект » подменю "Атрибут" » подменю "Диспетчер атрибутов блоков"

Ввод команды: диспатблк

Управление описаниями атрибутов в блоках текущего чертежа. Можно редактировать описания атрибутов в блоках, удалять атрибуты из блоков и изменять порядок, согласно которому запрашиваются значения атрибутов при вставке блока.

Атрибуты выбранного блока отображаются в списке атрибутов. По умолчанию в список включены имя атрибута, подсказка, значение по умолчанию, а также режимы вставки и отображения атрибута. С помощью опции "Параметры" можно задать свойства атрибута, которые должны быть показаны в списке.

Для каждого выбранного блока под списком атрибутов даны сведения о количестве вхождений блока в текущем чертеже и на текущей вкладке.

Выбрать блок

Позволяет выбрать блок с помощью устройства указания непосредственно на чертеже. После выбора опции "Выбрать блок" диалоговое окно закрывается, пока не будет выбран блок в чертеже или отменена команда нажатием ESC.

Если сразу после изменения атрибутов выбрать новый блок, на экране появится запрос о сохранении внесенных изменений.

Блок

Список всех описаний блоков, имеющих атрибуты, в текущем чертеже. Из списка выбирается блок, атрибуты которого требуется модифицировать.

Список атрибутов

Отображает свойства каждого атрибута в выбранном блоке.

Блоки, обнаруженные в чертеже

Число вхождений выбранного блока в текущем чертеже.

Блоки, обнаруженные в текущем пространстве

Число вхождений выбранного блока в текущем пространстве модели или листа.

Обновить

Обновление всех выбранных блоков с учетом измененных свойств атрибутов. Эта опция не изменяет значения, присвоенные атрибутам блоков.

Вверх

Перемещение выбранного атрибута вверх по порядку следования. Эта опция недоступна, если выбран постоянный атрибут.

Вниз

Перемещение выбранного атрибута вниз по порядку следования. Эта опция недоступна, если выбран постоянный атрибут.

Изменить

Вызов диалогового окна "Редактирование атрибута", где редактируются свойства атрибута.

Удалить

Исключение выбранного атрибута из описания блока. Если перед выбором этой опции в диалоговом окне "Параметры" активизировать опцию "Применять к имеющимся вхождениям", атрибуты будут исключены из всех блоков текущего чертежа. Опция недоступна для блоков с одним атрибутом.

Режимы

Вызов диалогового окна "Параметры". В нем устанавливается, какая информация об атрибуте должна отображаться в списке Диспетчера атрибутов блоков.

Применить

Применяет внесенные изменения без закрытия диалогового окна.


Диалоговое окно "Редактирование атрибута"

Д Команды
Д Команды
Диалоговое окно "Редактирование атрибута"
Понятия Процедуры Команды

Панель "Редактирование-2":

Меню "Редактирование": объект » подменю "Атрибут" » подменю "Диспетчер атрибутов блоков"

Ввод команды: диспатблк

Редактирование атрибутов в описаниях блоков.

Имя блока

Отображает имя блока, атрибуты которого необходимо отредактировать.

Автопросмотр изменений

Управление режимом немедленного обновления чертежа после изменения видимых атрибутов. При выборе этой опции изменения атрибутов сразу отображаются на экране. Если опция не выбрана, этого не происходит.

Отключение опции "Автопросмотр изменений" немного повышает быстродействие программы. Режим автопросмотра изменений недоступен, если не выбрана опция "Применять к имеющимся вхождениям".

Диалоговое окно "Редактирование атрибута" содержит следующие вкладки:

  • Атрибут
  • Параметры текста
  • Свойства

Вкладка "Атрибут" (диалоговое окно "Редактирование атрибута")

Здесь определяется способ присвоения значения атрибуту, режим отображения значения на экране, а также задается текст подсказки, приглашающей пользователя ввести значение. На вкладке также показывается имя атрибута.

Режим

Режим определяет, где и как появляется текст атрибута.

Скрытый

Показывает или скрывает атрибут на экране. Если опция выбрана, значение атрибута не видно на экране; в противном случае значение атрибута отображается на экране.

Постоянный

Задает, имеет ли атрибут значение по умолчанию. Это свойство нельзя изменить. Если опция активна, атрибуту присваивается его значение по умолчанию. Если опция не активна, атрибуту можно задавать разные значения.

Контролируемый

Позволяет проверить правильность значения атрибута во время процесса вставки блока. Если опция активна, проверка возможна, если не активна — нет.

Установленный

Управляет присваиванием значения по умолчанию. Если опция активна, атрибуту при вставке блока присваивается значение по умолчанию. Если опция не активна, программа игнорирует значение атрибута по умолчанию и выдает подсказку для ввода значения при вставке блока.

Данные

Данные атрибута, которые появляются на экране.

Имя

Идентификатор, связанный с атрибутом.

Подсказка

Текст подсказки атрибута, выводимый на экран при вставке блока.

По умолчанию

Значение по умолчанию, присваиваемое атрибуту при вставке блока.

Вкладка "Параметры текста" (диалоговое окно "Редактирование атрибута")

Задает свойства, определяющие способ отображения на чертеже текста атрибута. Цвет текста атрибута изменяется на вкладке "Свойства".

Текстовый стиль

Текстовый стиль для текста атрибута. Параметры выбранного на данной вкладке стиля определяют свойства текста атрибута.

Выравнивание

Выравнивание текста атрибута.

Высота

Высота текста атрибута.

Поворот

Угол поворота текста атрибута.

Справа налево

Написание текста справа налево.

Перевернутый

Написание текста в перевернутом виде.

Степень растяжения

Расстояние между символами в тексте. Задание значения, меньшего 1.0, вызывает сжатие. Задание значения, большего 1.0, вызывает растяжение.

Угол наклона

Угол, на который отклоняется текст атрибута относительно его вертикальной оси.

Вкладка "Свойства" (диалоговое окно "Редактирование атрибута")

Задает слой, в котором атрибут будет включен, а также цвет, вес линии и тип линии атрибута. Если чертеж использует именованные стили печати, с помощью данной вкладки можно связать атрибут со стилем печати.

Слой

Слой текста атрибута.

Тип линий

Тип линии текста атрибута.

Цвет

Определяет цвет текста атрибута.

Стиль печати

Стиль печати атрибута.

Если текущий чертеж использует цветозависимые стили печати, список стилей печати недоступен.

Вес линий

Вес линии текста атрибута.

Если системная переменная LWDISPLAY отключена, то изменения, внесенные в эту опцию, не будут отображаться на экране.


Диалоговое окно "Параметры"

Д Команды
Д Команды
Диалоговое окно "Параметры"
Понятия Процедуры Команды

Панель "Редактирование-2":

Меню "Редактирование": объект » подменю "Атрибут" » подменю "Диспетчер атрибутов блоков"

Ввод команды: диспатблк

Задание параметров отображения списка атрибутов в окне Диспетчера атрибутов блоков.

Сведения в таблице

Свойства, которые должны отображаться в списке атрибутов. В списке отображаются только выбранные свойства. Имя атрибута всегда отображается в списке.

Выбрать все

Выбор всех свойств.

Очистить все

Отмена выбора всех свойств.

Выделять повторные имена

Включение и отключение выделения повторяющихся имен. Если опция активна, повторяющиеся имена атрибутов выделяются красным цветом шрифта в списке. Если опция не активна, повторяющиеся имена не выделяются в списке.

Применять к имеющимся вхождениям

Режим обновления всех существующих блоков, атрибуты которых были изменены. Если опция активна, обновляются все блоки с новыми описаниями атрибутов. Если опция не активна, обновляются только новые блоки, созданные после изменения описаний атрибутов.

Нажатие кнопки "Обновить" в Диспетчере атрибутов блоков изменяет существующие блоки сразу после модификации атрибутов. Это происходит даже при отключенной опции "Применять к имеющимся вхождениям".


ДИСППЕЧ Команда

Д Команды
Д Команды
ДИСППЕЧ Команда
Понятия Процедуры Команды

Вызов Диспетчера плоттеров, в котором можно добавить или изменить конфигурацию плоттера

Меню "Файл": Диспетчер плоттеров

Ввод команды: дисппеч

Отображается диспетчер плоттеров, где можно выполнить следующие операции:

  • Дважды нажать левую кнопку мыши на Мастере установки плоттеров, который добавляет и конфигурирует новые плоттеры и принтеры.
  • Двойным нажатием левой кнопки мыши на ярлыке имеющегося PC3-файла параметров вызвать окно Редактор параметров плоттера.

Темы:

  • Мастер установки плоттеров
  • Редактор параметров плоттера
  • Вкладка "Общие" (Редактор параметров плоттера)
  • Вкладка "Порты" (Редактор параметров плоттера)
  • Вкладка "Устройство и документ" (Редактор параметров плоттера)
  • Диалоговое окно "Параметры порта LPT"
  • Диалоговое окно "Параметры порта COM"
  • Диалоговое окно "Дополнительные опции порта COM"


Мастер установки плоттеров

Д Команды
Д Команды
Мастер установки плоттеров
Понятия Процедуры Команды

Меню "Файл": Диспетчер плоттеров

Ввод команды: дисппеч

Добавление новых плоттеров и принтеров. Мастер создает PC3-файл, который впоследствии можно редактировать в окне "Редактор параметров плоттера". Пользовательские конфигурации сохраняются в папке "Плоттеры".


Редактор параметров плоттера

Д Команды
Д Команды
Редактор параметров плоттера
Понятия Процедуры Команды

Меню "Файл": Диспетчер плоттеров

Ввод команды: дисппеч

Изменение содержащихся в PC3-файле схем соединений портов и параметров вывода, включая носители, графику, параметры физических перьев, дополнительные свойства, строки инициализации, калибровку плоттера и пользовательские форматы листа. Эти параметры настройки можно перетаскивать из одного PC3-файла в другой.

"Редактор параметров плоттера" может быть вызван любым из указанных ниже способов.

  • Дважды нажать левую кнопку мыши на PC3-файле в Проводнике Microsoft® Windows® или нажать правую кнопку мыши на PC3-файле и выбрать "Открыть". По умолчанию файлы параметров хранятся в папке "Плоттеры". Для того чтобы найти расположение файлов параметров плоттеров, следует из меню "Сервис" выбрать "Настройка". На вкладке "Файлы" диалогового окна "Настройка" выбрать знак "+" слева от надписи "Путь к вспомогательным файлам печати". Выбрать знак "+" слева от надписи "Путь поиска конфигураций печати". В окне "Путь поиска конфигураций печати" выбрать имя пути для просмотра мест расположения файлов плоттера.
  • Выбрать "Изменить конфигурацию плоттера" в Мастере установки плоттеров.
  • Нажать кнопку "Свойства" в диалоговом окне "Параметры листа".
  • Нажать кнопку "Свойства" в диалоговом окне "Печать".

Дополнительные опции, появляющиеся на вкладке "Устройство и документ", зависят от типа сконфигурированного плоттера. Например, при настройке параметров для несистемного плоттера можно изменить характеристики перьев.

Редактор параметров плоттера содержит следующие вкладки:

  • Общие
  • Порты
  • Устройство и документ

Темы:

  • Вкладка "Общие" (Редактор параметров плоттера)
  • Вкладка "Порты" (Редактор параметров плоттера)
  • Вкладка "Устройство и документ" (Редактор параметров плоттера)


Вкладка "Общие" (Редактор параметров плоттера)

Д Команды
Д Команды
Вкладка "Общие" (Редактор параметров плоттера)
Понятия Процедуры Команды

Содержит основные сведения о файле конфигурации плоттера (PC3). В поле "Пояснение" можно добавлять или изменять информацию. Остальные сведения на вкладке приведены только для справки.

Имя файла параметров плоттера

Имя файла, заданное в Мастере установки плоттеров.

Описание

Информация о плоттере, которую пользователь считает нужным запомнить.

Информация о драйвере

Здесь выводится следующая информация:

  • Тип драйвера (системный или несистемный), модель плоттера, путь к файлу драйвера
  • Номер версии HDI-драйвера (драйверы, специализированные для AutoCAD)
  • UNC-имя сервера сети (если плоттер подключен к нему)
  • Порт ввода/вывода (если плоттер подключен локально)
  • Имя системного принтера (если система сконфигурирована на его использование)
  • Имя файла PMP (параметров модели печати) и адрес (если файл PMP подключен к файлу PC3)


Вкладка "Порты" (Редактор параметров плоттера)

Д Команды
Д Команды
Вкладка "Порты" (Редактор параметров плоттера)
Понятия Процедуры Команды

Изменение настроек взаимодействия между сконфигурированным плоттером и пользовательским компьютером или сетевой системой. Здесь указывается вывод на печать через порт, вывод в файл или использование буферизации (AutoSpool). См. раздел Печать в фоновом режиме в Руководстве по драйверам и периферийным устройствам.

При печати через параллельный порт можно задать значение тайм-аута. При печати через последовательный порт можно изменить скорость обмена, протокол, выбрать способ управления потоком, и задать значения тайм-аутов для ввода и вывода.

Вывод в порт

Вывод чертежа на плоттер через выбранный порт.

Вывод в файл

Вывод чертежа в файл, заданный в диалоговом окне "Печать".

Буферизация

Печать чертежа с использованием утилиты фоновой печати. Имя и путь поиска этой утилиты задается на вкладке "Файлы" диалогового окна "Настройка".

Список портов

Список имеющихся портов (как локальных, так и сетевых). Если порт является сетевым, здесь приводится также имя сетевого принтера.

Показать все порты

Показ всех доступных портов на компьютере, вне зависимости от того, доступны ли они для плоттера.

Сетевые устройства

Отображение опций работы в сети, с помощью которых можно подключаться к другим несистемным плоттерам.

Настройка порта

Отображает диалоговое окно Параметры порта LPT или Параметры порта COM.


Вкладка "Устройство и документ" (Редактор параметров плоттера)

Д Команды
Д Команды
Вкладка "Устройство и документ" (Редактор параметров плоттера)
Понятия Процедуры Команды

Управляет многими параметрами PC3-файла. Для просмотра и изменения конкретных характеристик выбрать мышью соответствующий узел дерева. При изменении параметра изменения отображаются в угловых скобках (< >) рядом с именем параметра. На значке элемента с измененным значением появляется галочка.

Примечание В дереве появляются только те параметры, которые имеют смысл для сконфигурированного устройства. Кроме того, некоторые параметры могут оказаться недоступными для редактирования, если они не поддерживаются используемым устройством или если их настройка осуществляется через дополнительные свойства драйвера.

Носитель

Задание подачи, формата, типа и ориентации бумаги. Возможные настройки зависят от характеристик, поддерживаемых сконфигурированным плоттером. Для системных принтеров Windows параметры носителя задаются в узле "Дополнительные свойства".

Подача и размеры

Задание способа подачи и формата бумажного носителя.

  • Подача: Задает способ подачи: например, рулон или лист. Если задается лоток, то можно указать его тип.
  • Ширина: Ширина рулона бумаги (при рулонном способе подачи).
  • Автоматически: Принтер автоматически выбирает подходящий размер бумаги.
  • Формат: Список имеющихся форматов бумаги (как стандартных, так и нестандартных).
  • Область печати: Отображает размеры области печати.

Тип носителя

Список типов носителей, поддерживаемых конфигурацией плоттера.

Двусторонняя печать

Выбор режима одновременной печати двух страниц и типа переплета. Переплет можно выбирать только для плоттеров, поддерживающих печать на развороте.

  • Нет: Печать на развороте не производится.
  • Переплет вдоль короткого края: Поля для переплета оставляются вдоль короткого края бумаги.
  • Переплет вдоль длинного края: Поля для переплета оставляются вдоль длинного края бумаги.

Механическая обработка

Список возможных операций механической обработки носителя для сконфигурированного плоттера, включая раскладку, резку и брошюрование. Можно выбирать только для плоттеров, поддерживающих эти операции.

Конфигурация физических перьев (только для перьевых плоттеров)

Управление перьями перьевого плоттера. В нижней части вкладки "Устройство и документ" приводится таблица соответствия цвета, ширины и скорости для каждого пера плоттера.

Примечание Информацию о физических перьях нельзя определить автоматически. Эту информацию для перьев плоттера необходимо указывать в группе "Параметры физических перьев".

Конфигурация перьев

Задание параметров для перьевых плоттеров.

  • Запрос смены перьев: Возможность использовать несколько перьев при печати на одноперьевом плоттере. В группе "Параметры физических перьев" можно задать параметры для любого числа перьев. Когда необходимо менять перья, выдается подсказка.
  • Учет толщины пера: С помощью программы компенсируется ширина перьев при печати закрашенных областей и широких полилиний. Каждый многоугольник уменьшается на половину толщины пера, используемого для его вычерчивания. Опция позволяет предотвратить увеличение размеров закрашенных областей и обеспечивает точность построений при использовании широких перьев. Эту опцию можно использовать, если требуемая точность заметно выше половины ширины пера, например в чертежах печатных плат.
  • Уровень оптимизации: Оптимизация перемещения перьев позволяет сократить время вывода на печать и повысить эффективность работы перьев. Например, можно исключить вычерчивание линий поверх уже имеющихся. Если в чертеже используется множество цветов или линий различной толщины, время на замену перьев можно сократить, выбрав "Сортировка перьев". Все объекты, использующие данное перо, будут вычерчены, прежде чем переключиться на другое перо. Каждый способ включает в себя и все методы оптимизации, предшествующие ему в списке (за исключением способа "Без оптимизации").

Параметры физических перьев

Для того чтобы правильно вывести чертеж на перьевом плоттере, необходимо указать информацию об используемых в устройстве перьях. Для каждого пера плоттера необходимо задать цвет и ширину. Чтобы оптимизировать производительность перьев, необходимо указать скорость их перемещения.

Примечание Эта информация необходима. Информацию о физических перьях нельзя определить автоматически.

  • Цвет: Задает цвета для перьев плоттера. Выбирается цвет пера, который наиболее близко подходит к цвету объекта. Пользователь назначает перьям цвета, которые соответствуют цветам каждого из объектов. В списке цветов можно выбрать один из следующих параметров: "Нет пера", "Красный", "Желтый", "Зеленый", "Голубой", "Синий", "Фиолетовый", "Черный" или "Другие". При выборе пункта "Другие" открывается диалоговое окно "Выбор цвета", содержащее полную цветовую палитру. Выбор "Нет пера" означает, что в конкретном положении нет пера.
  • Скорость: Задает скорость для каждого пера в отдельности. Это полезно, например, чтобы замедлить перемещение, если перо оставляет за собой пробелы. Каждый производитель перьев рекомендует определенные скорости перьев для различных типов носителей. Рекомендуется использовать именно эти значения. Скорость перьев можно задавать в миллиметрах или дюймах в секунду.
  • Толщина: Задает толщины перьев, чтобы программа могла определить, сколько приемов необходимо для вычерчивания широких линий. Толщина пера задается в дюймах или миллиметрах. Следует проследить, чтобы выбранная толщина пера соответствовала действительности. В списке приводится набор стандартных толщин перьев.

Задание характеристик перьев не заменяет таблиц присвоений перьев, которые пользователь может импортировать из файлов PCP, PC2 или CFG систем AutoCAD версии 14, AutoCAD LT® 98 или предыдущих версий. Подробнее об импорте этих параметров см. раздел Редактирование стилей печати в Руководстве пользователя.

Графика

Задание параметров для печати векторной графики, растровой графики и текстов TrueType. В зависимости от возможностей плоттера можно изменять глубину цветности, разрешение и размывание. Можно выбрать цветную или монохромную печать векторного чертежа. При печати растровых изображений на плоттере с ограниченным объемом памяти можно увеличить производительность, понизив качество вывода. При использовании несистемного плоттера, который поддерживает различные количества установленной оперативной памяти, можно для увеличения производительности задать этот параметр.

Установленная память

Обеспечивает программу информацией об общем объеме памяти (ОЗУ), установленной в несистемном плоттере. Опция доступна только для несистемных устройств печати, поддерживающих расширение памяти. Если плоттер имеет дополнительную память, то здесь следует указать общее количество памяти.

  • Полный объем памяти: Указывает общее количество установленной памяти в мегабайтах. Драйвер плоттера использует информацию о памяти для определения необходимости снижения качества печати растровых изображений с целью предотвратить нехватку памяти.

Векторная графика

Параметры глубины цветности, разрешения и размывания при выводе векторной графики. Некоторые параметры векторной графики тесно взаимосвязаны: изменение одного приводит к изменению других.

  • Глубина цветности: Отображает раскрывающийся список для выбора глубины цветности сконфигурированного плоттера. Параметры глубины цветности изменяются при изменении разрешения и размывания. Передача большей глубины цветов требует больше памяти и занимает больше времени. Печать может быть цветной или монохромной.
  • Разрешение: Настраивает разрешение (в точках на дюйм) для сконфигурированного плоттера. Изменение разрешения влияет на опции, доступные в списке "Размывание". Чем больше разрешение, тем больше расходуется памяти и дольше протекает печать.
  • Размывание: Задает размывание для неперьевых плоттеров. Некоторые варианты размывания могут замедлить процесс печати.

Растровая графика (только для неперьевых плоттеров)

Скользящая шкала позволяет найти компромиссное соотношение качества и скорости вывода. Снижение качества изображения позволяет сократить время вывода на печать. При ограниченных системных ресурсах снижение качества изображений может уменьшить вероятность нехватки памяти для процесса печати. Параметры доступны только для растровых устройств (не для перьевых).

  • Для растровых и раскрашенных/тонированных: Указывает скользящую шкалу, которая позволяет найти компромиссное соотношение качества и скорости вывода на печать растровых изображений. Если указатель установить на "Нет", растровое изображение не печатается. Уменьшение качества изображения позволяет сократить время вывода на печать Для получения изображения наилучшего качества за счет расходования памяти и уменьшения скорости печати указатель следует установить на "Качество".
  • OLE: Указывает скользящую шкалу, которая позволяет найти компромиссное соотношение качества и скорости вывода на печать OLE-объектов. Если указатель установить на "Нет", OLE-объект не печатается. Уменьшение качества изображения позволяет сократить время вывода на печать Для получения изображения наилучшего качества за счет расходования памяти и уменьшения скорости печати указатель следует установить на "Качество".
  • Баланс: Если не обеспечивается вывод с максимально высоким качеством, здесь указывается путь к компромиссному снижению качества. Переместить указатель, задавая им степень уменьшения разрешения и цветности.

Текст TrueType

Задание для системных принтеров Windows способа печати текстов TrueType: как графики или как текстов. Графическая печать гарантирует, что текст будет выведен на печать точно в том виде, как он выглядит на экране. Это достигается за счет снижения скорости печати и использования большего объема памяти. Печать шрифтами TrueType быстрее и использует меньше памяти, но плоттер может при печати подменить шрифт другим.

  • Выводить TrueType как текст: Выводит текст TrueType как текст.
  • Выводить TrueType как графику: Выводит текст TrueType как графику.

Наложения

Управление внешним видом пересекающихся линий для растровых плоттеров. Функцию нецелесообразно использовать, если плоттер настроен на черно-белую печать или при использовании языка PostScript.

  • Только последняя линия: Использует последнюю выведенную линию для перекрытия всех предыдущих. В месте пересечения видна только она.
  • Все линии: Смешивает цвета на пересечении линий.

Примечание Опция может появляться для системных принтеров, которые в действительности ее не поддерживают. Возможности принтера по управлению наложением линий следует проверить в документации на принтер.

Дополнительные свойства

Изменение параметров, характерных для данного плоттера. Параметры различаются в зависимости от модели плоттера. Если драйвер устройства не имеет диалогового окна пользовательских свойств, то опция "Дополнительные свойства" недоступна. Для некоторых драйверов, например для ePlot, это единственный видимый элемент дерева. Для системных принтеров Windows большинство параметров, характерных для устройства, задается в этом диалоговом окне. Подробнее о параметрах окна дополнительных свойств можно узнать, нажав в нем кнопку "Справка".

Строки инициализации (только для несистемных плоттеров)

Задание текстовых ASCII-строк прединициализации, постинициализации и заключительных строк плоттера, обеспечивающих посылку команд плоттеру до и после инициализации устройства программой и по окончании печати (соответственно).

При выводе на неподдерживаемый плоттер в режиме эмуляции можно задать строки инициализации в формате ASCII, которые подготавливают плоттер к печати, задают специальные параметры для устройства и возвращают плоттер в исходное состояние. Строки инициализации можно использовать также для включения или выключения характеристик плоттера, не поддерживаемых программой.

Текстовая строка воспринимается буквально, за исключением символа обратной косой черты. Обратная косая черта со следующим за ней трехзначным числом, взятым из таблицы ASCII (например, \027) используется для обозначения двоичных (непечатаемых) символов, например, символа перехода (ESC). \027 интерпретируется и посылается в виде одиночного символа со значением 27. Код 27 соответствует клавише ESC. Например, строка \27%-12345X@PJL ENTER LANGUAGE = PostScript\10 посылает команду HP PJL на двухязыковой лазерный принтер перед его инициализацией и переключает его в режим PostScript. Сочетание \027 посылает символ ESC, а \010 — символ перевода строки. Остальная часть текстовой строки воспринимается буквально. Рекомендуется использовать в качестве двоичных символов три десятичные цифры с добавлением ведущих нулей по мере необходимости.

Строки инициализации рекомендуется использовать только опытным пользователям.

Прединициализация

Переключение плоттера в режим эмуляции другого плоттера путем посылки текстовой ASCII-строки прединициализации плоттеру перед его инициализацией. Обратная косая черта со следующим за ней трехзначным числом, взятым из таблицы ASCII (например, \027) используется для обозначения двоичных (непечатаемых) символов, например, символа перехода (ESC).

Постинициализация

Задает для устройства специальные параметры, которые не поддерживаются в программе. Задание текстовой ASCII-строки постинициализации, посылаемой плоттеру после его инициализации. Обратная косая черта со следующим за ней трехзначным числом, взятым из таблицы ASCII (например, \027) используется для обозначения двоичных (непечатаемых) символов, например, символа перехода (ESC).

Завершение

Возвращение принтера в исходное состояние по завершении печати. Задание заключительной текстовой ASCII-строки, посылаемой плоттеру по окончании печати. Обратная косая черта со следующим за ней трехзначным числом, взятым из таблицы ASCII (например, \027) используется для обозначения двоичных (непечатаемых) символов, например, символа перехода (ESC).

Нестандартные форматы и калибровка

Подключение PMP-файла к PC3-файлу, калибровка плоттера, а также добавление, удаление, изменение и фильтрация пользовательских форматов. Здесь можно также изменить стандартные форматы листа. Отсюда вызываются Мастера калибровки плоттера и пользовательских форматов листа. Если используемый плоттер был откалиброван, информация о калибровочных поправках записывается в файл PMP (параметров модели плоттера). Если PMP-файл ранее не подключен к редактируемому PC3-файлу, необходимо установить эту связь, без которой использование PMP-файла невозможно.. Если плоттер был откалиброван в Мастере установки плоттеров при создании текущего PC3-файла, PMP-файл подключается автоматически. Для подключения и отключения PMP-файла от редактируемого PC3-файла используется элемент "Имя PMP-файла" в категории "Пользовательские форматы и калибровка".

Нестандартные форматы листа (только для несистемных принтеров)

Создание пользовательского формата листа и изменение области печати стандартных и нестандартных форматов. С помощью Мастера нестандартных форматов листа можно создать новый формат или выбрать из списка имеющийся формат (из PMP-файла), если плоттер не является системным устройством печати Windows. Если плоттер является системным устройством печати Windows, следует воспользоваться дополнительными свойствами. Форматы можно добавлять, удалять и редактировать.

Каждый плоттер имеет максимальную область печати, определяемую тем, где он захватывает бумагу, и амплитудой перемещения головки. При создании формата, размеры которого больше, чем предлагаемые в Редакторе параметров плоттера, следует убедиться, что плоттер физически может печатать на листе таких размеров.

  • Добавить: Запускает Мастера нестандартных форматов листа. Новый формат листа можно либо создать заново, либо на основе формата, выбранного из списка доступных для данного плоттера. Созданный таким образом формат считается нестандартным.
  • Удалить: Удаляет выбранный пользовательский формат из списка.
  • Изменить: Запускает Мастера нестандартных форматов листа, в котором можно изменить имеющийся формат. Можно изменять любые параметры пользовательских форматов.

Примечание Для системных принтеров Windows изменять параметры формата листа и создавать пользовательские форматы можно только в диалоговом окне дополнительных свойств.

Изменение стандартных форматов листа

Настройка области печати для стандартных форматов листа с учетом возможностей принтера. (Нельзя создавать пользовательские форматы для системных принтеров Windows с помощью Редактора параметров плоттера.)

  • Список стандартных форматов листа: Отображает список имеющихся стандартных форматов листа.
  • Изменить: Запускает Мастера нестандартных форматов листа. Можно изменить область печати и имя файла. Созданный таким образом формат считается нестандартным.

Ограничение списка форматов

Фильтрация форматов листа, выводимых для выбранного печатающего устройства в диалоговых окнах "Печать" и "Параметры листа". Список форматов выводится на вкладке "Параметры печати" диалогового окна "Печать" и на вкладке "Компоновка" диалогового окна "Параметры листа". Необходимо выбрать форматы, выводимые для данного устройства.

  • Отметить все: Скрывает все форматы листа для устройства.
  • Очистить все: Отображает все форматы листа для устройства.

Калибровка плоттера

Запуск Мастера калибровки плоттера. Если необходимо скорректировать расхождения масштабов, можно откалибровать плоттер с помощью Мастера калибровки плоттеров. См. раздел Калибровка плоттеров и работа с пользовательскими форматами в Руководстве по драйверам и периферийным устройствам.

Примечание При необходимости получения достаточно точных чертежей и в случае наличия искажений масштаба у плоттера следует выполнить процедуру калибровки плоттера. Калибровка плоттера приводит к тому, что программа слегка изменяет масштаб всех чертежей, посылаемых на плоттер. Если плоттер имеет свою утилиту калибровки, рекомендуется использовать именно ее, а не утилиту программы.

PMP-файл

Подключение или отключение PMP-файла от редактируемого PC3-файла. Для разрыва связи между файлами PMP и PC3 следует воспользоваться кнопкой "Отключить".

  • Подключить: Подключает PMP-файл к PC3-файлу. Таким образом, можно использовать данные о калибровке и пользовательских форматах, сохраненные в файле PMP.
  • Сохранить PMP: Сохраняет PMP-файл в новом файле в папке AutoCAD 2007\drv .
  • Отключить: Отключает связанный PMP-файл от редактируемого PC3-файла.
Импорт

Импортирует информацию из предыдущих версий программы. При наличии файла PCP или PC2 из предыдущей версии можно импортировать часть информации из этих файлов в файл PC3. В файлах PC3 хранится имя плоттера, информация о портах, уровень оптимизации перьев, формат листа и разрешение.

Сохранить как

Сохранение файла PC3 под новым именем.

Стандартные

Восстановление стандартных настроек на вкладке "Устройство и документ".


Диалоговое окно "Параметры порта LPT"

Д Команды
Д Команды
Диалоговое окно "Параметры порта LPT"
Понятия Процедуры Команды

Меню "Файл": Диспетчер плоттеров

Ввод команды: дисппеч

Указывает время, в течение которого программа ожидает, чтобы освободился буфер плоттера, перед тем как послать следующую порцию данных. Необходимо указать подходящее значение тайм-аута, по истечении которого будет предложено отменить вывод чертежа на печать. Если чертежи сложные или скорость пера очень низкая, значение тайм-аута следует установить больше, чем принимается по умолчанию (30 секунд). Если сообщения об истечении тайм-аута выдаются слишком часто, возможно, этому параметру присвоено слишком малое значение.

Тайм-аут

Указывает время ожидания перед повторением передачи.

Повтор передачи

Задание значения тайм-аута в миллисекундах.


Диалоговое окно "Параметры порта COM"

Д Команды
Д Команды
Диалоговое окно "Параметры порта COM"
Понятия Процедуры Команды

Меню "Файл": Диспетчер плоттеров

Ввод команды: дисппеч

Задание скорости (в бодах), протокола, управления потоком, а также параметров аппаратного квитирования для последовательных портов плоттеров, поддерживающих эти настройки.

Примечание Параметры плоттера должны соответствовать параметрам программы, иначе печать невозможна.

Скорость (в бодах)

Задание скорости в бодах. Следует задавать самую большую скорость из возможных.

Протокол

Задание параметров протокола для плоттера. Следует использовать протокол, рекомендуемый производителем устройства. Подробнее об этом см. документацию к устройству.

Управление потоком

Задание способа управления потоком для плоттера. По умолчанию параметром управления потоком является XON/XOFF (программное квитирование), используемый для совместимости с предыдущими версиями. При выборе аппаратного квитирования можно задать дополнительные параметры в диалоговом окне "Дополнительные параметры порта COM", опции которого соответствуют различным контактным выводам разъема RS232.


Диалоговое окно "Дополнительные опции порта COM"

Д Команды
Д Команды
Диалоговое окно "Дополнительные опции порта COM"
Понятия Процедуры Команды

Меню "Файл": Диспетчер плоттеров

Ввод команды: дисппеч

Задание дополнительных параметров аппаратного квитирования для последовательных портов.

CTS

Включение квитирования CTS (Clear To Send; сброс передатчика). Данная опция управляет опросом 5-го контакта у 25-контактного разъема последовательного порта или 8-го контакта у 9-контактного разъема. Вход CTS используется для обнаружения передачи данных от принтера или плоттера.

DSR

Включение квитирования DSR (Data Set Ready; сигнал готовности к передаче данных). Данная опция управляет опросом 6-го контакта у 25-контактного разъема последовательного порта или 6-го контакта у 9-контактного разъема. Вход DSR используется для обнаружения сигналов от принтера или плоттера.

RLSD

Включение квитирования RLSD (Received Line Signal Detector; детектор приема сигнала из линии). Иногда его еще называют DCD (Data Carrier Detect; детектирование носителя информации). Бит RLSD является входным для компьютера; его устанавливает плоттер или принтер. На 25-штырьковом разъеме этому сигналу соответствует вывод 8; на 9-штырьковом — вывод 1.

RTS

Управление выходным битом RTS (Request To Send; запрос на передачу). Данная опция управляет передачей сигналов принтеру или плоттеру по 4-му контакту 25-контактного разъема последовательного порта или по 7-му контакту 9-контактного разъема.

Сигнал неактивен

Отключение сигнала RTS, если устройство открыто.

Сигнал активен

Включение сигнала RTS, если устройство открыто.

Оптимальное

Включение оптимального режима квитирования по RTS. Драйвер устанавливает линию RTS, когда входной буфер заполнен менее чем наполовину, и сбрасывает ее, если буфер заполнен более чем на три четверти.

Упрощенное

Драйвер устанавливает линию RTS, если имеются данные для передачи. После того, как все байты переданы, линия RTS сбрасывается.

DTR

Управление выходным битом DTR (Data Terminal Ready; терминал данных готов). При этом на принтер или плоттер передается сигнал на контакт 20 25-контактного последовательного порта или контакт 4 9-контактного последовательного порта.

Сигнал неактивен

Отключение сигнала DTR, если устройство открыто.

Сигнал активен

Включение сигнала DTR, если устройство открыто.

Оптимальное

Включение квитирования по DTR.


ДИСПСК Команда

Д Команды
Д Команды
ДИСПСК Команда
Понятия Процедуры Команды

Управление заданными пользовательскими системами координат

Панель "ПСК":

Меню "Сервис": "Именованные ПСК"

Ввод команды: диспск

Откроется диалоговое окно "ПСК".

Темы:

  • Диалоговое окно "ПСК"
  • Диалоговое окно "Глубина ортогональной ПСК"
  • Диалоговое окно "Подробности о ПСК"


Диалоговое окно "ПСК"

Д Команды
Д Команды
Диалоговое окно "ПСК"
Понятия Процедуры Команды

Панель "ПСК":

Меню "Сервис": "Именованные ПСК"

Ввод команды: диспск

Восстановление и изменение заданных и неименованных ПСК, восстановление именованных и ортогональных ПСК, а также задание режимов знаков ПСК и ПСК для видовых экранов.

Диалоговое окно "ПСК" имеет следующие вкладки:

  • Именованные ПСК
  • Ортогональные ПСК
  • Режимы

Вкладка "Именованные ПСК" (диалоговое окно "ПСК")

Вывод списка ПСК и установка текущей ПСК.

Текущая ПСК

Отображение имени текущей ПСК. Если ПСК не сохранена и не названа, она отображается в списке под именем БЕЗ ИМЕНИ.

Список имен ПСК

Вывод списка систем координат, заданных в текущем чертеже. Если существует несколько видовых экранов, для каждого из которых задано несколько режимов неименованных ПСК, в списке отображается только одна неименованная ПСК, соответствующая текущему видовому экрану. Неименованные ПСК, привязанные к другим видовым экранам (для которых значение системной переменной UCSVP равно 1), в список для текущего видового экрана не включаются. ПСК, установленная в качестве текущей, помечается в списке указателем.

Если текущая ПСК не имеет имени, она всегда выводится в списке первой. Мировая система координат всегда присутствует в списке — ее нельзя удалить или переименовать. Если в сеансе редактирования чертежа для активного видового экрана были заданы другие системы координат, в списке рядом с их именами появляется кнопка "Предыдущая". Для последовательного восстановления этих ПСК служат кнопки "Предыдущая" и "Установить".

Для добавления в список имени ПСК используется опция "Сохранить" команды ПСК. Чтобы переименовать или удалить ПСК, следует нажать правую кнопку мыши на ее имени и выбрать требуемый пункт контекстного меню.

Установить

Восстановление выбранной системы координат. Кроме того, восстановление отдельной системы координат осуществляется следующими способами: дважды нажать левую кнопку мыши на имени ПСК; нажать правую кнопку мыши на имени ПСК и выбрать в контекстном меню пункт "Установить". При восстановлении текст текущей ПСК обновляется.

Подробности

Вызов диалогового окна "Подробности о ПСК", в котором содержится информация о координатах ПСК. Кроме того, для просмотра подробностей об отдельной ПСК можно нажать правую кнопку мыши на ее имени и выбрать в контекстном меню пункт "Подробности".

Переименовать (только в контекстном меню)

Переименование ПСК. Мировую систему координат переименовать нельзя. Кроме того, для переименования ПСК можно дважды нажать левую кнопку мыши на ее имени в списке.

Удалить (только в контекстном меню)

Удаление ПСК. Мировую систему координат удалить нельзя.

Вкладка "Ортогональные ПСК" (диалоговое окно "ПСК")

Замена ПСК одной из ортогональных ПСК.

Текущая ПСК

Отображение имени текущей ПСК. Если ПСК не сохранена и не названа, она отображается в списке под именем БЕЗ ИМЕНИ.

Список ортогональных ПСК

Вывод шести ортогональных систем координат, заданных в текущем чертеже. Ортогональные системы координат задаются относительно ПСК, указанной в списке "Относительно". В столбце "Глубина" перечислены значения расстояний между плоскостью XY ортогональной системы координат и параллельной ей плоскостью, проходящей через начало базовой системы координат (ее имя хранится в системной переменной UCSBASE).

Имя

Задание имени ортогональной системы координат.

Глубина

Задание расстояния между плоскостью XY ортогональной ПСК и параллельной ей плоскостью, проходящей через начало базовой системы координат, имя которой хранится в системной переменной UCSBASE. Параллельная плоскость может совпадать с плоскостью XY, YZ или XZ базовой системы координат.

Примечание Для выбранной ортогональной ПСК можно задать значение глубины или новое начало координат. См. опцию "Глубина".

Установить

Восстановление выбранной системы координат. Кроме того, восстановление отдельной системы координат осуществляется следующими способами: дважды нажать левую кнопку мыши на имени ПСК; нажать правую кнопку мыши на имени ПСК и выбрать в контекстном меню пункт "Установить".

Подробности

Вызов диалогового окна "Подробности о ПСК", в котором содержится информация о координатах ПСК. Кроме того, для просмотра подробностей об отдельной ПСК можно нажать правую кнопку мыши на ее имени и выбрать в контекстном меню пункт "Подробности".

Относительно

Выбор базовой системы координат, относительно которой будет задана ортогональная ПСК. По умолчанию в качестве базовой системы координат используется МСК. В списке отображаются все именованные ПСК, существующие в текущем чертеже.

При каждом изменении параметра "Относительно" восстанавливается положение по умолчанию для начала выбранной ортогональной ПСК.

Если ортогональная система координат сохранена в чертеже как часть конфигурации видовых экранов или, а также если параметр "Относительно" имеет значение, отличное от "Мировая", имя этой системы координат заменяется на БЕЗ ИМЕНИ, чтобы ее можно было отличить от стандартных ортогональных систем координат.

Сброс (только в контекстном меню)

Восстановление начала выбранной ортогональной системы координат. Начало ортогональной системы координат может быть перенесено из точки 0,0,0 в другую точку с помощью опции "Перенести" команды ПСК. Для сброса начала выбранной ортогональной ПСК следует нажать правую кнопку мыши на ее имени и выбрать в контекстном меню пункт "Сброс". Начало совмещается с точкой (0,0,0) указанной базовой системы координат.

Глубина (в контекстном меню или при двойном нажатии)

Задание расстояния между плоскостью XY ортогональной ПСК и параллельной ей плоскостью, проходящей через начало базовой системы координат. В диалоговом окне "Глубина ортогональной ПСК" необходимо ввести значение глубины или нажать кнопку "Задание нового начала" и указать новую глубину или новое положение начала координат непосредственно на чертеже.

Вкладка "Режимы" (диалоговое окно "ПСК")

Отображение и изменение сохраненных с видовым экраном режимов знака ПСК и ПСК.

Режимы знака ПСК

Задание режима отображения знака ПСК для текущего видового экрана.

Вкл

Отображение знака ПСК на текущем видовом экране.

В начале ПСК

Отображение знака ПСК на текущем видовом экране в точке начала координат. Если убрать этот флажок (или если начало ПСК находится за пределами видового экрана), знак ПСК располагается в левом нижнем углу видового экрана.

Для всех активных ВЭкранов

Применение режимов знака ПСК ко всем активным видовым экранам текущего чертежа.

Режимы ПСК

Задание поведения ПСК при обновлении ее режима.

Сохранять ПСК с ВЭкраном

Сохранение режима ПСК с видовым экраном. Установка этого флажка позволяет задать значение системной переменной UCSVP. Если убрать этот флажок, для заданного видового экрана используется ПСК текущего видового экрана.

Вид в плане при смене ПСК

Восстановление вида в плане при смене системы координат на видовом экране (системная переменная UCSFOLLOW).


Диалоговое окно "Глубина ортогональной ПСК"

Д Команды
Д Команды
Диалоговое окно "Глубина ортогональной ПСК"
Понятия Процедуры Команды

Контекстное меню: Нажмите правую кнопку мыши в списке "Ортогональные ПСК". Выберите "Глубина".

Задание глубины для ортогональной ПСК.

Глубина спереди

Задание расстояния между плоскостью XY ортогональной ПСК и параллельной ей плоскостью, проходящей через начало базовой системы координат. Введите значение или нажмите кнопку "Задание нового начала", чтобы указать новую глубину или новое положение начала координат непосредственно на чертеже.

Задание нового начала

Временное закрытие диалогового окна для указания нового положения глубины на чертеже с помощью мыши. Чтобы восстановить положение по умолчанию (0,0,0) точки начала координат для выбранной ортогональной ПСК, следует нажать правую кнопку мыши и выбрать "Сброс".


Диалоговое окно "Подробности о ПСК"

Д Команды
Д Команды
Диалоговое окно "Подробности о ПСК"
Понятия Процедуры Команды

Панель "ПСК":

Меню "Сервис": "Именованные ПСК"

Ввод команды: диспск

Отображение информации о положении начала и направлении осей выбранной ПСК.

По умолчанию начало и оси X, Y, Z рассчитываются относительно мировой системы координат.

Имя

Отображение имени текущей именованной ПСК. По умолчанию установлена мировая система координат.

Начало

Отображение положения начала ПСК относительно ПСК, выбранной в списке "Относительно".

Ось X

Отображение координат единичного вектора оси X ПСК относительно ПСК, выбранной в списке "Относительно".

Oсь Y

Отображение координат единичного вектора оси Y ПСК относительно ПСК, выбранной в списке "Относительно".

Ось Z

Отображение координат единичного вектора оси Z ПСК относительно ПСК, выбранной в списке "Относительно".

Относительно

Задание базовой системы координат, относительно которой рассчитываются координаты начала выбранной ПСК, а также направления ее осей. В результате использования данной опции происходит сброс значения системной переменной UCSBASE.


ДИСПСТИЛЬ Команда

Д Команды
Д Команды
ДИСПСТИЛЬ Команда
Понятия Процедуры Команды

Вызов диспетчера стилей печати

Меню "Файл": "Диспетчер стилей печати"

Ввод команды: диспстиль

Откроется окно диспетчера стилей печати.

Для создания новой таблицы стилей печати необходимо дважды нажать ярлык "Мастер стилей печати". Для редактирования имеющейся таблицы стилей печати служит Редактор таблиц стилей печати, который вызывается двойным нажатием на ярлыке таблицы.

Темы:

  • Мастер стилей печати
  • Редактор таблиц стилей печати
  • Вкладка "Общие" (Редактор таблиц стилей печати)
  • Вкладки "Таблица" и "Карточка" (Редактор таблиц стилей печати)
  • Диалоговое окно "Редактирование весов линий"


Мастер стилей печати

Д Команды
Д Команды
Мастер стилей печати
Понятия Процедуры Команды

Меню "Файл": "Диспетчер стилей печати"

Ввод команды: диспстиль

Мастер стилей печати предназначен для создания новых таблиц стилей печати. В этих таблицах хранятся описания имеющихся стилей, которые могут быть назначены объектам. Результатом работы мастера является STB- или CTB-файл (в зависимости от типа создаваемой таблицы). Для редактирования таких файлов используется Редактор таблиц стилей печати. Для использования новой таблицы стилей печати на вкладке "Печать/Публикация" диалогового окна "Настройка" необходимо выбрать соответствующий тип стилей печати (именованные или цветозависимые).

Таблицу стилей печати можно создать либо "с нуля", либо на основе уже существующей таблицы, либо путем импорта параметров печати из CFG-файла AutoCAD Release 14, PCP- или PC2-файла.

Таблицу стилей печати можно создать либо "с нуля", либо на основе уже существующей таблицы, либо путем импорта параметров печати из PCP-, PC2- или CFG-файла.

Стили в таблице могут быть именованными или цветозависимыми. Количество стилей в таблице именованных стилей печати любое; файл имеет расширение .stb. В таблице цветозависимых стилей печати всегда содержатся 255 стилей печати, которым соответствуют 255 цветов чертежа; файл имеет расширение .ctb. В настройках программы можно задать, какой тип стилей печати должен использоваться для вновь создаваемых чертежей или чертежей, созданных в предыдущих версиях программы pre-AutoCAD 2000 и сохраненных в формате более поздней версии.


Редактор таблиц стилей печати

Д Команды
Д Команды
Редактор таблиц стилей печати
Понятия Процедуры Команды

Меню "Файл": "Диспетчер стилей печати"

Ввод команды: диспстиль

Служит для изменения стилей печати в таблицах. Если таблица стилей печати назначена какому-либо листу чертежа или вкладке "Модель", любые изменения в стилях отражаются на использующих их объектах чертежа. Таблицы цветозависимых стилей печати хранятся в файлах с расширением CTB. Таблицы именованных стилей печати хранятся в файлах с расширением STB. Информацию о таблицах стилей печати см. в разделе Использование стилей печати документа Руководство пользователя.

Вызвать Редактор таблиц стилей печати можно одним из следующих способов:

  • Дважды нажать на ярлыке CTB- или STB-файла в диспетчере стилей печати.
  • Нажать правую кнопку мыши на ярлыке CTB- или STB-файла в Диспетчере стилей печати, затем выбрать "Открыть" из контекстного меню.
  • Нажать кнопку "Редактор таблиц стилей печати" на странице "Конец" Мастера стилей печати.
  • В диалоговом окне "Параметры листа" в группе "Таблица стилей печати" выбрать таблицу стилей и нажать кнопку "Изменить".
  • Нажать кнопку "Редактор" в одном из диалоговых окон "Текущий стиль печати" или "Выбор стиля печати".

Окно редактора таблиц стилей печати состоит из следующих вкладок:

  • Общие
  • Таблица и Карточка

Темы:

  • Вкладка "Общие" (Редактор таблиц стилей печати)
  • Вкладки "Таблица" и "Карточка" (Редактор таблиц стилей печати)


Вкладка "Общие" (Редактор таблиц стилей печати)

Д Команды
Д Команды
Вкладка "Общие" (Редактор таблиц стилей печати)
Понятия Процедуры Команды

Вкладка "Общие" содержит сведения об имени таблицы стилей печати, ее текстовом описании, номере версии и положении на диске. Здесь можно внести изменения в описание таблицы, а также задать режим масштабирования типов линий и образцов заполнения, не относящихся к стандарту ISO.

Файл таблицы стилей печати

Имя файла редактируемой таблицы стилей печати.

Описание

Текстовое пояснение к таблице стилей печати.

Информация о файле

Вывод информации о редактируемой таблице стилей печати: количество стилей в таблице, путь к ней, номер версии редактора таблиц стилей печати.

Применить глобальный масштаб к типам линий, не относящимся к ISO

Масштабирование всех не относящихся к ISO типов линий и образцов заполнения в стилях печати данной таблицы.

Масштаб

Масштабный коэффициент для не относящихся к ISO типов линий и образцов заполнения.

Удалить цветовую таблицу R14

Удаляет таблицы соответствия цветов, используемые при открытии чертежей, созданных в предыдущих версиях программы AutoCAD 2000. Таблицы именованных стилей печати, созданные на основе файлов acadr14.cfg, PCP или PC2, содержат стили печати, полученные из заданных в AutoCAD Release 14 присвоений перьев. Для таких таблиц, помимо этого, имеются таблицы соответствия цветов. Таблицы соответствия цветов используются для связывания стилей печати с цветами (а через них - с объектами чертежа) при открытии чертежей, созданных в предыдущих версиях программы AutoCAD 2000. Пока существует таблица соответствия цветов, добавление, удаление и переименование стилей печати в таблице невозможно.

После удаления таблицы соответствия цветов невозможно автоматически назначить стили печати для объектов при первом открытии чертежей, созданных в более ранних версиях программы.

Таблицы стилей печати, из которых удалена информация о соответствии цветов, не годятся для назначения стилей печати объектам старых чертежей. Тем не менее, остается возможность их использования во вновь создаваемых чертежах.


Вкладки "Таблица" и "Карточка" (Редактор таблиц стилей печати)

Д Команды
Д Команды
Вкладки "Таблица" и "Карточка" (Редактор таблиц стилей печати)
Понятия Процедуры Команды

И на той, и на другой вкладке перечисляются все существующие в таблице стили и их параметры. Стили печати отображаются каждый в отдельном столбце, слева направо. Модификация стилей может выполняться как на вкладке "Таблица", так и на вкладке "Карточка". Как правило, если количество стилей печати невелико, удобнее пользоваться вкладкой "Таблица". При большом количестве стилей предпочтительнее работать на вкладке "Карточка". На ней все имеющиеся стили перечислены в списке в левой части, а правая часть занята описанием свойств одного выбранного стиля. Для просмотра стиля и его свойств горизонтальная прокрутка не требуется. Стиль NORMAL расположен в начале таблицы именованных стилей печати и является свойством по умолчанию для объектов (стиль печати не назначен). Стиль NORMAL нельзя изменить или удалить.

Имя

Имена стилей в таблицах именованных стилей печати. Пользователю разрешено изменять их. Имена цветозависимых стилей печати тесно связаны с цветами объектов и не подлежат изменению. Программа поддерживает имена стилей, содержащие до 255 символов. В одной таблице не допускается наличие двух стилей с одинаковыми именами.

Пояснение

Текстовое пояснение к стилю печати.

Свойства

Задает параметры нового стиля печати, добавляемого в текущую таблицу стилей печати.

Цвет

Цвет, которым печатается объект. По умолчанию в стиле печати установлено значение цвета "Взять из объекта". Если задать цвет явно, при печати объекты будут перекрашены в этот цвет.

Чтобы выбрать один из 255 цветов палитры индекса цветов AutoCAD (ИЦА), всей палитры или альбома цветов, из списка необходимо выбрать значение "Выбор цвета", в результате чего отобразится диалоговое окно "Выбор цвета". Выбранный цвет отображается в стиле печати с пометкой "Пользовательский цвет". Если устройство печати не поддерживает выбранный цвет, то объекты вычерчиваются ближайшим доступным цветом, а на монохромных устройствах — черным.

Разрешить размывание

Разрешение размывания. Размывание используется в плоттерах для имитации составных цветов путем пространственного комбинирования точек, имеющих стандартные цвета AutoCAD (т.е. цвета чернил картриджей). Если плоттер не поддерживает размывание, параметр игнорируется.

Отключение опции может потребоваться для того, чтобы избежать появления псевдоштриховых линий из-за размывания тонких векторов. Кроме того, отключение размывания делает более четкими матовые цвета. Если размывание отключено, программа использует ближайшие по значению стандартные цвета; это ограничивает цветовую гамму чертежа при печати. Размывание при печати возможно независимо от того, как задан цвет в стиле печати (цвет объекта или явное присвоение).

Печатать оттенками серого

Преобразование цветов объектов в оттенки серого (при условии, что плоттер поддерживает печать оттенками серого). Если параметр "Печатать оттенками серого" отключен, для печати цветов объекта используются значения модели RGB. Размывание при печати возможно независимо от того, как задан цвет в стиле печати (цвет объекта или явное присвоение).

Номер назначенного пера (только для перьевых плоттеров)

Номер пера, которым вычерчиваются объекты, использующие данный стиль печати. Допустимые значения находятся в интервале от 1 до 32. Изменение номера пера невозможно в случае, если цвет в стиле печати имеет значение "Взять из объекта", а также для цветозависимых стилей печати. В этих случаях в поле номера всегда стоит значение "Авто".

Если занести в поле значение 0, программа изменяет его на "Авто". Программа назначает номер пера, выбирая ближайшее по цвету перо из описанных в редакторе параметров плоттера в группе "Параметры физических перьев".

Номер виртуального пера

Номер виртуального пера (в диапазоне от 1 до 255). Многие неперьевые плоттеры могут эмулировать работу перьевых с помощью виртуальных перьев. В большинстве случаев программирование толщины перьев, образцов заполнения, стилей концов линий и соединений, цветов и интенсивности выполняется с передней панели устройства.

Чтобы программа назначала виртуальные перья, основываясь на номерах цветов, приведенных в палитре индекса цветов, необходимо ввести значение 0 или "Авто".

Параметр "Номер виртуального пера" в стиле печати имеет смысл только для неперьевых плоттеров и работает, только если плоттер сконфигурирован на режим эмуляции перьевого. Все другие параметры стиля в этом случае игнорируются. Если же режим эмуляции перьевого плоттера не установлен, то все, что связано с физическими и виртуальными перьями, игнорируется, и печать производится на основании других параметров стилей печати.

Режим эмуляции можно установить в Редакторе параметров плоттера. В нем необходимо перейти на вкладку "Устройство и документы" и выбрать параметр "Векторная графика". В группе "Глубина цветности" выбрать "255 виртуальных перьев".

Интенсивность

Определяет значение интенсивности, прямо пропорциональное количеству красящего вещества, наносимого на бумагу при выводе на печать. Допустимый диапазон значений — от 0 до 100. Значение 0 соответствует выводу белым цветом, а значение 100 — полной интенсивности. Управление интенсивностью вывода возможно только при активной опции "Разрешить размывание".

Тип линий

Список с описаниями и образцами всех доступных типов линий. По умолчанию в стиле печати установлено значение типа линии "Взять из объекта". Заданный тип линий для стиля печати переопределяет исходный тип линий объекта во время печати.

Подстройка масштаба

Параметр регулирует масштаб типа линий так, чтобы в каждом объекте укладывалось целое число элементарных образцов. Если он отключен, элементарные образцы могут обрываться в линиях на середине. Параметр необходимо отключать, если приоритет имеет соблюдение точного масштаба. Включение параметра означает, что масштабы типов линий будут разными, но за счет этого будет достигнута корректность отображения объектов, выполненных штриховыми и пунктирными линиями.

Вес линий

Список образцов и численных значений доступных весов линий. Значения в списке выражены в миллиметрах. По умолчанию в стиле печати установлено значение веса линии "Взять из объекта". Заданный вес линий для стиля печати переопределяет исходный вес линий объекта во время печати.

Стиль окончания линий

Стиль окончания линий может быть одним из следующих: "Срез", "Квадрат", "Полукруг" и "Треугольник". По умолчанию в стиле печати установлено значение стиля окончания линий "Взять из объекта". Заданный стиль окончания линий переопределяет исходный стиль окончания линий объекта во время печати.

Стиль соединения линий

Стиль соединения линий может быть одним из следующих: "Угол", "Скос", "Дуга" и "Треугольник". По умолчанию в стиле печати установлено значение стиля соединения линий "Взять из объекта". Заданный стиль соединений линий переопределяет исходный стиль соединений линий объекта во время печати.

Стиль заполнения

Стиль заполнения может быть одним из следующих: "Сплошное", "Решетка", "Штриховка", "Шахматы", "Горизонтальные полосы", "Наклонные влево", "Наклонные вправо", "Квадраты" и "Вертикальные полосы". По умолчанию в стиле печати установлено значение стиля заполнения "Взять из объекта". Заданный стиль заполнения переопределяет исходный стиль заполнения для объекта во время печати.

Добавить стиль

Добавление стиля в таблицу именованных стилей печати.

Только что добавленный стиль использует параметры стиля «Обычный», т.е. свойства объектов по умолчанию не модифицируются. Пользователь затем сам указывает, какие свойства должны изменяться при печати. Добавление новых стилей в таблицы цветозависимых стилей печати невозможно, так как такие таблицы всегда содержат 255 стилей печати, которым соответствуют 255 цветов чертежа. Не разрешается также добавлять стили в таблицы именованных стилей печати, с которыми связаны таблицы соответствия цветов.

Удалить стиль

Удаление выбранного стиля из таблицы стилей печати.

Объекты, которым он был назначен, сохраняют ссылку на этот стиль, но печатаются стилем "Normal", т.к. их стиль удален из таблицы. Удаление стилей печати также разрешено только из таблиц именованных (но не цветозависимых) стилей. Не разрешается также удалять стили из таблиц именованных стилей печати, с которыми связаны таблицы соответствия цветов.

Редактировать веса

Вызов диалогового окна "Редактирование весов линий". Для назначения стилям печати, заносимым в таблицы, доступны 28 весов линий. Если нужного веса линии нет в предлагаемом списке, его можно получить только модификацией одного из существующих. Добавление новых весов линий в список, хранящийся в таблице стилей печати, и удаление их из списка не разрешены.

Сохранить как

Вызов диалогового окна "Сохранение файла", с помощью которого можно сохранить таблицу стилей печати под другим именем.


Диалоговое окно "Редактирование весов линий"

Д Команды
Д Команды
Диалоговое окно "Редактирование весов линий"
Понятия Процедуры Команды

Меню "Файл": "Диспетчер стилей печати"

Ввод команды: диспстиль

Изменение набора доступных значений весов линий.

Веса линий

Список весов линий, входящих в таблицу стилей печати. Полное количество весов линий (вместе со значением "Взять из объекта") равно 28. Пользователь может изменять имеющиеся веса линий, но не может добавлять и удалять веса. Изменение значения веса линий в списке воздействует на все стили печати, где он используется.

Введенное значение веса линий автоматически округляется до четырех десятичных знаков. Веса линий не могут быть отрицательными. Линии нулевого веса вычерчиваются плоттером с минимально возможной шириной. Максимально допустимое значение веса линии равно 100 миллиметрам.

Единицы списка

Единицы, в которых выражаются веса линий в списке. Возможные значения — дюймы или миллиметры.

Редактировать вес

Переход к редактированию веса, выбранного в списке.

Сортировка весов

Сортировка списка весов линий. Это может потребоваться, например, после редактирования значений некоторых весов.


ДОПУСК Команда

Д Команды
Д Команды
ДОПУСК Команда
Понятия Процедуры Команды

Нанесение допусков формы и расположения

Панель "Размеры":

Меню "Размеры": "Допуск"

Ввод команды: допуск

Откроется диалоговое окно "Допуски формы и расположения".

Темы:

  • Диалоговое окно "Допуски формы и расположения"
  • Диалоговое окно "Символ"
  • Диалоговое окно "Зависимый допуск"


Диалоговое окно "Допуски формы и расположения"

Д Команды
Д Команды
Диалоговое окно "Допуски формы и расположения"
Понятия Процедуры Команды

Панель "Размеры":

Меню "Размеры": "Допуск"

Ввод команды: допуск

Выбор символов и значений для управляющего контура элемента.

После выбора символов геометрических характеристик диалоговое окно "Допуски формы и расположения" закрывается, и отображается следующий запрос:

Положение рамки допуска: Указать расположение

В указанном расположении устанавливается управляющий контур элемента.

Симв

Отображение символа геометрических характеристик, выбранного в диалоговом окне "Символ". Диалоговое окно открывается при выборе любого поля "Симв".

Допуск 1

Формирование значения первого допуска в управляющем контуре элемента. Значение допуска соответствует максимально разрешенному отклонению геометрической характеристики от идеальной формы. Там, где это необходимо, перед значением допуска ставится символ диаметра, а после значения — символ зависимого допуска.

Первое поле

Вставка символа диаметра перед значением допуска. Для вставки символа диаметра следует выбрать поле.

Второе поле

Формирование значения допуска. Значение вводится в поле.

Третье поле

Вызов диалогового окна "Зависимый допуск", которое используется для выбора символов-модификаторов. Эти символы позволяют изменять геометрические характеристики и значение допуска для элементов переменного размера.

Выберите требуемый символ. Произойдет закрытие диалогового окна. Символ вставляется в поле "ЗД" для первого значения допуска в диалоговом окне "Допуски формы и расположения".

Допуск 2

Формирование значения второго допуска в управляющем контуре элемента. Значение второго допуска формируется так же, как и значение первого.

База 1

Формирование обозначения первой базы комплекта баз. Обозначение может включать значение и символ-модификатор. Базой называется элемент детали, определяющий одну из плоскостей или осей системы координат, по отношению к которой задается допуск.

Первое поле

Поле для ввода обозначения базы. Значение вводится в поле.

Второе поле

Вызов диалогового окна "Зависимый допуск", которое используется для выбора символов-модификаторов. Эти символы позволяют изменять базу.

Выберите требуемый символ. Произойдет закрытие диалогового окна. Символ вставляется в поле "ЗД" для первой базы комплекта баз в диалоговом окне "Допуски формы и расположения".

База 2

Формирование обозначения второй базы комплекта баз (аналогично первой базе).

База 3

Формирование обозначения третьей базы комплекта баз (аналогично первой базе).

Высота

Формирование значения выступающего поля допуска расположения. Выступающее поле определяет допуск на участке, расположенном вне детали. Значение вводится в поле.

Выступающее поле допуска

Вставка символа выступающего поля допуска после значения выступающего поля допуска.

Идентификатор базы

Поле для ввода буквенного обозначения базы. Базой называется элемент детали, определяющий одну из плоскостей или осей системы координат, по отношению к которой задается допуск. В качестве базы можно использовать точку, отрезок, плоскость, цилиндр или другой геометрический объект. Нужно ввести букву в текстовое поле.


Диалоговое окно "Символ"

Д Команды
Д Команды
Диалоговое окно "Символ"
Понятия Процедуры Команды

Панель "Размеры":

Меню "Размеры": "Допуск"

Ввод команды: допуск

Вывод символов геометрических характеристик для расположения, ориентации, формы, профиля и биения.

Выберите требуемый символ. Произойдет закрытие диалогового окна. Символ вставляется в текстовое поле "Симв" диалогового окна "Допуски формы и расположения". Приведенная ниже таблица содержит описание символов.

Символы геометрических характеристик
Символ | Вид допуска | Тип
 | Позиционный | Расположения
 | Соосности | Расположения
 | Симметричности | Расположения
 | Параллельности | Ориентации
 | Перпендикулярности | Ориентации
 | Наклона | Ориентации
 | Цилиндричности | Формы
 | Плоскостности | Формы
 | Круглости | Формы
 | Прямолинейности | Формы
 | Формы поверхности | Профиля
 | Типа линии | Профиля
 | Радиального биения | Биения
 | Полного биения | Биения


Диалоговое окно "Зависимый допуск"

Д Команды
Д Команды
Диалоговое окно "Зависимый допуск"
Понятия Процедуры Команды

Панель "Размеры":

Меню "Размеры": "Допуск"

Ввод команды: допуск

Задание символа-модификатора. Эти символы позволяют изменять геометрические характеристики и значение допуска для элементов переменного размера.

Выберите требуемый символ. Произойдет закрытие диалогового окна. Символ вставляется в поле "ЗД" для первого или второго значения допуска в диалоговом окне "Допуски формы и расположения".


ДОС Команда

Д Команды
Д Команды
ДОС Команда
Понятия Процедуры Команды

Доступ к командам операционной системы

Ввод команды: дос

Команда ОС: Ввести команду операционной системы или нажать ENTER

Команда ДОС позволяет выполнять команды операционной системы, не выходя из программы. В ответ на ее запрос можно вводить большинство команд ОС. После выполнения команды ОС отображается приглашение на ввод команды приложения.

Если в ответ на запрос "Команда ОС" нажать клавишу ENTER, появится системный запрос с дополнительной закрывающей угловой скобкой (>). После этого можно вводить любые команды операционной системы. Для возврата к приглашению на ввод команды в командной строке введите выход.

Предупреждение Не следует пользоваться командой ДОС с целью удаления файлов блокировки (файлы с расширением .??k) или временных файлов (файлы с расширением .ac$ или .$a). Нельзя пользоваться командой ДОС для запуска утилиты chkdsk, сброса портов ввода/вывода или запуска внешней программы, требующей обмена с дисковым буфером во время редактирования чертежа, хранимого на дискете. Резидентные программы следует загружать в память до запуска программы.


ДСЛАЙД Команда

Д Команды
Д Команды
ДСЛАЙД Команда
Понятия Процедуры Команды

Создание файла слайда из текущего видового экрана пространства модели или текущего листа

Ввод команды: дслайд

Откроется диалоговое окно "Создание файла слайда" (стандартное диалоговое окно выбора файлов). Необходимо ввести имя файла слайда (SLD), или выбрать нужное имя из списка. Файл слайда содержит растровое изображение видового экрана.

В пространстве модели команда ДСЛАЙД создает файл слайда только для вида на текущем видовом экране. В пространстве листа команда ДСЛАЙД создает файл слайда изображения в пространстве листа, включая все видовые экраны и их содержимое.

Не видимые на экране части чертежа, а также отключенные и замороженные слои в слайд не включаются.

Для просмотра слайдов можно воспользоваться командой СЛАЙД. Утилита SLIDELIB служит для создания библиотеки слайдов.

Если слайд, который получен из изображения, раскрашенного с помощью команды РАСКРАСИТЬ, просматривается в большем окне или с более высоким разрешением, чем то, которое использовалось при его создании, возможно появление черных линий на раскрашенных областях изображения. Чтобы этого избежать, при создании слайда следует использовать весь экран и максимальное разрешение.


ДСОЗАКРЫТЬ Команда

Д Команды
Д Команды
ДСОЗАКРЫТЬ Команда
Понятия Процедуры Команды

Закрытие Диспетчера подключения к БД

Меню "Инструменты": выбрать меню "Базы данных" при открытом диспетчере подключения к БД.

Ввод команды: дсозакрыть

Команда ДСОЗАКРЫТЬ закрывает окно Диспетчера подключения к БД и удаляет меню "Базы данных" из строки меню.


ДУГА Команда

Д Команды
Д Команды
ДУГА Команда
Понятия Процедуры Команды

Построение дуг

Панель "Рисование":

Меню "Рисование": "Дуга"

Ввод команды: дуга

Указать начальную точку дуги или [Центр]:Указать точку, ввести c или нажать ENTER для построения касательной к последнему проведенному отрезку, дуге или полилинии

Начальная точка

Положение начальной точки дуги.

Примечание Если пользователь нажал ENTER, не указав точку, то в качестве начальной точки используется конечная точка последнего построенного отрезка или дуги, и сразу же появляется запрос для указания конечной точки новой дуги. Дуга строится по касательной к последнему отрезку, дуге или полилинии.

Вторая точка дуги или [Центр/Конец]:

Вторая точка

Выполняет построение дуги по трем точкам, заданным на окружности дуги. Первая точка является начальной точкой (1). Третья точка — это конечная точка (3). Вторая точка (2) располагается на дуге между первой и третьей точками.

Конечная точка дуги: Указать точку (3)

По трем точкам можно строить дуги в любом направлении (по часовой стрелке и против нее).

Центр

Положение центра окружности, частью которой является дуга.

Центр дуги:

Конечная точка дуги или [Угол/Длина хорды]:

Конечная точка

Дуга строится с опорой на центральную точку, против часовой стрелки от начальной точки (1) к конечной точке (3). Конечная точка находится на пересечении дуги и воображаемого луча, проведенного от центра (2) через вторую из указанных точек.

На иллюстрации видно, что дуга не обязательно должна проходить через саму конечную точку.

Угол

Дуга строится против часовой стрелки от начальной точки (1); используются заданный центр (2) и заданный внутренний угол. Если угол имеет отрицательное значение, дуга строится по часовой стрелке.

Задать центральный угол:Задать угол

Длина хорды

Построение либо меньшей, либо большей дуги по заданной длине хорды.

Если значение длины хорды положительное, меньшая дуга строится от начальной точки против часовой стрелки. Если значение длины хорды отрицательное, большая дуга строится против часовой стрелки.

Задать длину хорды:Задать длину

Конец

Задание конечной точки дуги.

Конечная точка дуги:

Центр дуги или [Угол/Направление/Радиус]:

Центральная точка

Дуга строится с опорой на центральную точку, против часовой стрелки от начальной точки (1) к конечной точке (2). Конечная точка находится на пересечении дуги и воображаемого луча, проведенного от центра (3) через вторую из указанных точек.

Угол

Дуга строится против часовой стрелки от начальной точки (1) к конечной точке (2); используется заданный центральный угол. Если угол имеет отрицательное значение, дуга строится по часовой стрелке.

Задать внутренний угол: Ввести величину угла в градусах или задать угол, переместив указательное устройство против часовой стрелки

Направление

Дуга строится по касательной к заданному направлению. Здесь можно строить большие или меньшие дуги; по часовой стрелке или против нее. Дуга берет начало в точке (1) и заканчивается в точке (2). Направление определяется от начальной точки.

Направление касательной от начальной точки дуги:

Радиус

Строится меньшая дуга против часовой стрелки от начальной точки (1) к конечной точке (2). Если значение радиуса отрицательное, строится большая дуга.

Радиус дуги:

Центр

Положение центра окружности, частью которой является дуга.

Центр дуги:

Начальная точка дуги:

Конечная точка дуги или [Угол/Длина хорды]:

Конечная точка

Дуга строится против часовой стрелки от начальной точки (2) к конечной точке, которая находится на пересечении дуги и воображаемого луча, проведенного от центра (1) через указанную точку (3).

Угол

Дуга строится против часовой стрелки от начальной точки (2); используются заданный центр (1) и центральный угол. Если угол имеет отрицательное значение, дуга строится по часовой стрелке.

Центральный угол:

Длина хорды

Построение либо меньшей, либо большей дуги по заданной длине хорды.

Если значение длины хорды положительное, меньшая дуга строится от начальной точки против часовой стрелки. Если значение длины хорды отрицательное, большая дуга строится против часовой стрелки.

Длина хорды

Касательная к последнему проведенному отрезку, дуге или полилинии

Выполняет построение дуги, касательной к последнему проведенному отрезку, дуге или полилинии. Для этого нужно нажать ENTER после первого запроса.

Указать конечную точку дуги: Указать точку (1)


Е Команды
  • ЕДИНИЦЫ
  • ЕДПРОСТ


ЕДИНИЦЫ Команда

Е Команды
Е Команды
ЕДИНИЦЫ Команда
Понятия Процедуры Команды

Задание форматов и точности представления линейных и угловых единиц

Меню "Формат": "Единицы измерения"

Ввод команды: единицы (или 'единицы для вызова в прозрачном режиме)

Откроется диалоговое окно "Единицы чертежа".

Если в командной строке ввести -единицы, будут выведены подсказки для этой команды.

Темы:

  • Диалоговое окно "Единицы чертежа"
  • Диалоговое окно "Выбор направления"
  • ЕДИНИЦЫ (вариант для командной строки)


Диалоговое окно "Единицы чертежа"

Е Команды
Е Команды
Диалоговое окно "Единицы чертежа"
Понятия Процедуры Команды

Меню "Формат": "Единицы измерения"

Ввод команды: единицы (или 'единицы для вызова в прозрачном режиме)

Задание формата линейных и угловых величин.

Линейные

Задание текущих линейных единиц и точности измерения величин, выраженных в этих единицах.

Формат

Задание текущего формата единиц измерения. Возможно использование следующих форматов: "Архитектурные", "Десятичные", "Инженерные", "Дробные" и "Научные". Для форматов "Инженерные" и "Архитектурные" линейные величины выражаются в футах и дюймах; при этом единица чертежа соответствует одному дюйму. Остальные форматы могут представлять любые существующие единицы.

Точность

Задание числа десятичных знаков для линейных величин.

Угловые

Задание текущего формата и точности представления угловых величин.

Формат

Задание текущего формата угловых единиц.

Точность

Задание точности представления угловых единиц.

Для угловых единиц измерения приняты следующие соглашения: десятичные градусы обозначаются десятичными числами, грады - с правым нижним индексом g, радианы с правым нижним индексом r. В формате градусы/минуты/секунды d обозначает градусы, ' - минуты, " - секунды, например:

123d45'56.7"

В топографическом формате углы заменяются румбами; символы N или S обозначают базовое направление отсчета румба (север или юг), отклонение угла на восток/запад от направления на север/юг задается в градусах/минутах/секундах, символы E или W (восток или запад) обозначают квадрант, в котором находится румб, например:

N 45d0'0" E

Углы всегда меньше 90 градусов; они выводятся в формате градусы/минуты/секунды. Если угол совпадает с одним из географических направлений (север, юг, восток или запад), он представляется только соответствующей буквой.

По часовой стрелке

Если опция активна, за положительное направление отсчета углов принимается направление по часовой стрелке. По умолчанию положительным считается направление против часовой стрелки.

При запросе угла можно ввести требуемое направление или угол независимо от заданной опции "По часовой стрелке".

Масштаб вставки

Задание единиц измерения для блоков и чертежей, вставляемых в текущий чертеж. Если блок или чертеж создан с использованием единиц, не совпадающих с единицами, заданными этой опцией, при вставке он масштабируется. Масштаб вставки представляет собой отношение единиц исходного блока/чертежа и целевого чертежа. Для вставки блока без масштабирования следует задать опцию "Безразмерный".

Примечание Если в исходном блоке или в конечном чертеже для опции "Масштаб вставки" установлено значение "Безразмерный", используются параметры "Единицы исходного чертежа" и "Единицы целевого чертежа", расположенные на вкладке "Пользовательские" диалогового окна "Параметры".

Пример

Отображение примера представления линейных и угловых величин с использованием текущих единиц.

Направление

Вызов диалогового окна "Выбор направления".


Диалоговое окно "Выбор направления"

Е Команды
Е Команды
Диалоговое окно "Выбор направления"
Понятия Процедуры Команды

Меню "Формат": "Единицы измерения"

Ввод команды: единицы (или 'единицы для вызова в прозрачном режиме)

Задание нулевого угла и направления отсчета углов. При запросе угла можно указать точку в требуемом направлении или задать угол.

Базовый угол

Задание направления базового (нулевого) угла. Следующие опции позволяют контролировать ввод углов, формат отображения углов, а также ввод полярных, цилиндрических и сферических координат.

Восток

Задание направления нулевого угла на восток (по умолчанию).

Север

Задание направления нулевого угла на север.

Запад

Задание направления нулевого угла на запад.

Юг

Задание направления нулевого угла на юг.

Другое

Задание произвольного базового направления.

Угол

Задание направления нулевого угла при выборе опции "Другое". Угол задается посредством ввода значения.

Кнопка "Указать угол"

Позволяет задать угол посредством непосредственного указания двух точек на чертеже. Кнопка доступна, только если выбрана опция "Другое".


ЕДИНИЦЫ (вариант для командной строки)

Е Команды
Е Команды
ЕДИНИЦЫ (вариант для командной строки)
Понятия Процедуры Команды

Если в ответ на подсказку «Команда:» ввести -единицы, будет вызван вариант команды ЕДИНИЦЫ, использующий интерфейс командной строки.

В текстовом окне отображается следующий запрос:

Форматы единиц: (Примеры)

1. Научные 1,55E+01

2. Десятичные 15,50

3. Инженерные 1'-3,50"

4. Архитектурные 1'-3 1/2"

5. Дробные 15 1/2

Ваш выбор, от 1 до 5 <текущий>: Ввести значение ( 1 - 5 ) или нажать ENTER

Если выбран формат "Научные", "Десятичные" или "Инженерные", отображается запрос десятичной точности величин:

Число десятичных знаков после запятой (от 0 до 8) <текущее>: Ввести значение ( 0 -8 ) или нажать ENTER

Если выбран формат "Архитектурные" или "Дробные", отображается запрос знаменателя для наименьшей дроби:

Знаменатель для наименьшей дроби:

(1, 2, 4, 8, 16, 32, 64, 128, или 256) <текущий>: Ввести значение ( 1, 2, 4, 8, 16, 32, 64, 128 или 256 ) или нажать ENTER

Далее отображается запрос формата и точности углов:

Угловые единицы: (Примеры)

1. Десятичные градусы 45,0000

2. Градусы/минуты/секунды 45d0'0"

3. Грады 50,0000g

4. Радианы 0,7854r

5. Топографические единицы N 45d0'0" E

Ваш выбор, от 1 до 5 <текущий>: Ввести значение ( 1 -5 ) или нажать ENTER

Длина дробной части в представлении углов (от 0 до 8) <текущая>: Ввести значение ( 0 -8 ) или нажать ENTER

После этого отображается запрос направления нулевого угла:

Направление угла 0:

Восток (3 часа) = 0

Север (12 часов) = 90

Запад (9 часов) = 180

Юг (6 часов) = 270

Направление базового угла 0 <текущее>: Ввести значение или нажать ENTER

По умолчанию направление нулевого угла составляет 0 градусов с положительной полуосью Х текущей ПСК (соответствует 3 часам на циферблате). По умолчанию положительным считается направление отсчета углов против часовой стрелки.

Отсчет углов по часовой стрелке? [Да/Нет] <текущее>: Ввести д или н или нажать ENTER


ЕДПРОСТ Команда

Е Команды
Е Команды
ЕДПРОСТ Команда
Понятия Процедуры Команды

Преобразование расстояний между единицами пространства модели и пространства листа

Панель "Текст":

Ввод команды: едпрост

При работе на видовом экране пространства модели (не на вкладке "Модель", а на листе!) выдается следующий запрос:

Расстояние в пространстве листа <1.000>: Ввести расстояние в пространстве листа, которое требуется преобразовать в эквивалентное расстояние пространства модели

При работе в пространстве листа выдается следующий запрос:

Выберите видовой экран: Выбрать требуемый видовой экран

Расстояние в пространстве модели <1.000>: Ввести расстояние в пространстве модели, которое требуется преобразовать в эквивалентное расстояние пространства листа

Команда ЕДПРОСТ выполняет эквивалентные преобразования расстояний (как правило, высоту текста), заданных в единицах пространства модели или листа в расстояния в единицах другого пространства. Подразумевается использование этой команды в прозрачном режиме в ответ на запрос о высоте текста или какого-либо другого расстояния. Команда ЕДПРОСТ вычисляет расстояние, эквивалентное заданному в единицах другого пространства, и отображает его в окне команд.


Ж Команды
  • ЖУРНАЛВКЛ
  • ЖУРНАЛОТКЛ


ЖУРНАЛВКЛ Команда

Ж Команды
Ж Команды
ЖУРНАЛВКЛ Команда
Понятия Процедуры Команды

Включение записи содержимого текстового окна в файл

Ввод команды: журналвкл

Содержимое текстового окна будет записываться в файл журнала до момента выхода из программы или вызова команды ЖУРНАЛОТКЛ.

Кроме того, файлом журнала можно управлять с помощью команды НАСТРОЙКА. Для включения и отключения журнала следует установить флажок "Вести файл журнала" на вкладке "Открытие/Сохранение" диалогового окна "Настройка". Имя и расположение файла журнала задается на вкладке "Файлы".

Файл журнала (с расширением .log) ведется для каждого чертежа. Так как количество и размеры файлов журнала постоянно увеличиваются, их необходимо время от времени удалять.


ЖУРНАЛОТКЛ Команда

Ж Команды
Ж Команды
ЖУРНАЛОТКЛ Команда
Понятия Процедуры Команды

Закрывает текстовое окно файла журнала, открытое командой ЖУРНАЛВКЛ.

Ввод команды: журналоткл

Программа перестает записывать в файл журнала содержимое текстового окна и закрывает файл. Кроме того, файлом журнала можно управлять с помощью команды НАСТРОЙКА. Для включения и отключения журнала следует установить флажок "Вести файл журнала" на вкладке "Открытие/Сохранение" диалогового окна "Настройка". Имя и расположение файла журнала задается на вкладке "Файлы".

Файл журнала (с расширением .log) ведется для каждого чертежа. Так как количество и размеры файлов журнала постоянно увеличиваются, их необходимо время от времени удалять.


З Команды
  • ЗАГПРИЛ
  • ЗАГРУЗИТЬ
  • ЗАГРЧАСТЬ
  • ЗАДЕРЖКА
  • ЗАКРАСИТЬ
  • ЗАКРЫТЬ
  • ЗАКРЫТЬВСЕ
  • ЗНАКПСК


ЗАГПРИЛ Команда

З Команды
З Команды
ЗАГПРИЛ Команда
Понятия Процедуры Команды

Загрузка и выгрузка приложений; задание набора приложений для автозагрузки

Меню "Сервис": "Приложения"

Ввод команды: загприл

Отобразится диалоговое окно Загрузка/выгрузка приложений.

Темы:

  • Диалоговое окно "Загрузка/выгрузка приложений"
  • Диалоговое окно "Автозагрузка"


Диалоговое окно "Загрузка/выгрузка приложений"

З Команды
З Команды
Диалоговое окно "Загрузка/выгрузка приложений"
Понятия Процедуры Команды

Меню "Сервис": "Приложения"

Ввод команды: загприл

Окно служит для загрузки и выгрузки приложений, а также для задания набора приложений для автозагрузки.

Параметры в верхней части этого диалогового окна извлекаются из стандартного диалогового окна выбора файлов. Ниже описываются дополнительные элементы, присущие только окну "Загрузка/выгрузка приложений".

Загрузить

Загрузка или обновление приложений, выделенных в списке файлов на вкладках "Загруженные приложения" или "Журнал". Кнопка недоступна до тех пор, пока не будет выбрано хотя бы одно приложение. Приложения ObjectARX, VBA и DBX загружаются немедленно; приложения LSP, VLX и FAS ставятся в очередь и загружаются после закрытия диалогового окна "Загрузка/выгрузка приложений".

Если выбранный файл уже загружен, нажатие кнопки ведет к его обновлению в памяти. Для приложений ObjectARX, однако, такое обновление не разрешено. Их нужно выгружать из памяти, и затем загружать заново. Опция "Загрузить" имеется также в контекстном меню, которое вызывается щелчком правой кнопки мыши на вкладке "Журнал".

Загруженные приложения

Вкладка содержит список загруженных приложений. Список упорядочен по алфавиту (по именам файлов). LISP-программы присутствуют в списке, только если они были загружены с помощью диалогового окна "Загрузка/выгрузка приложений". Пользователь может перетаскивать файлы в этот список из списка файлов или из какого-либо приложения, где можно применить перетаскивание, например, Microsoft® Windows® Explorer.

Если приложение было загружено с помощью Web-браузера AutoCAD, оно вначале попадает в папку для временных файлов на локальном диске. AutoCAD запускает приложение именно из этой папки, и именно эта папка будет указана в списке загрузки.

Некоторые приложения из списка на данной вкладке могут быть выгружены пользователем. Подробнее см. описание кнопки "Выгрузить". Имена файлов, которые не могут быть выгружены, отображаются тусклым шрифтом и не могут быть выделены.

Список журнала

Данная вкладка содержит список приложений, которые загружались при установленном флажке "Добавить в журнал". Разрешается перетаскивать в список файлы из верхней части окна, а также из любых программ, поддерживающих такую технологию (например, из Проводника Windows). Если в момент перетаскивания флажок "Добавить в журнал" опущен, файлы загружаются в память, но в журнале не появляются.

Приложения могут добавляться в список журнала и исключаться из него, но их выгрузка осуществляется только на вкладке "Загруженные приложения". Подробнее см. описание пунктов "Загрузить", "Выгрузить" и "Исключить".

Добавить в журнал

Если флажок установлен, записи обо всех загружаемых приложениях добавляются в журнал.

Пользователь может предпочесть очистить эту опцию при загрузке приложений с помощью Web-браузера AutoCAD, так как эти приложения становятся недоступны после очистки кэша временного местоположения приложения.

Выгрузить/Исключить

Выгружает выбранные приложения или исключает их из списка журнала. Кнопка "Выгрузить" становится доступной, только если на вкладке "Загруженные приложения" выделен какой-либо файл. Кнопка "Исключить" становится доступной, только если на вкладке "Журнал" выделен какой-либо файл.

Не могут быть выгружены LISP-приложения, а также не зарегистрированные специальным образом приложения ObjectARX.

Следует помнить, что при нажатии кнопки "Исключить" выбранное приложение не выгружается из памяти. Опция "Исключить" имеется также в контекстном меню вкладки "Журнал".

Автозагрузка

Набор приложений, загружаемых каждый раз при запуске AutoCAD. В группу "Автозагрузка" разрешается перетаскивать файлы из верхней части окна, а также из любых программ, поддерживающих такую технологию (например, из Проводника Windows).

В список автозагрузки не могут быть добавлены приложения, загружаемые с помощью Web-браузера AutoCAD.

Содержимое

Отображает диалоговое окно "Автозагрузка". Можно также добавить файл в список автозагрузки, нажав на значок автозагрузки, или нажав правой кнопкой мыши имя приложения на вкладке "Журнал" и выбрав в контекстном меню "Добавить в список автозагрузки".

Строка состояния

Здесь отображаются сообщения о результатах загрузки и выгрузки приложений.


Диалоговое окно "Автозагрузка"

З Команды
З Команды
Диалоговое окно "Автозагрузка"
Понятия Процедуры Команды

Меню "Сервис": "Приложения"

Ввод команды: загприл

Окно служит для добавления и исключения приложений в списке автозагрузки. Приложения, включенные в список, загружаются каждый раз при запуске AutoCAD.

Список приложений

Список приложений, загружаемых при запуске AutoCAD. Список упорядочен по именам файлов.

Добавить

Вызов диалогового окна "Добавление файла в список автозагрузки". Это обычное окно выбора файлов.

Удалить

Исключение выделенных файлов из списка автозагрузки.


ЗАГРУЗИТЬ Команда

З Команды
З Команды
ЗАГРУЗИТЬ Команда
Понятия Процедуры Команды

Подготовка форм к использованию командой ФОРМА

Ввод команды: загрузить

Отобразится диалоговое окно "Выбор файла формы" (стандартное окно выбора файлов). Необходимо ввести имя файла формы, или выбрать нужное из списка.

Нужно загрузить файл формы (SHP) перед первым его использованием; впоследствии он загружается автоматически. Файл форм должен быть доступен всегда, когда редактируется чертеж.


ЗАГРЧАСТЬ Команда

З Команды
З Команды
ЗАГРЧАСТЬ Команда
Понятия Процедуры Команды

Дополнительная загрузка геометрии в частично открытый чертеж

Меню "Файл": Частичная загрузка

Ввод команды: загрчасть

Открывается диалоговое окно "Частичная загрузка". Команда ЗАГРЧАСТЬ работает только в частично открытых чертежах. Для частичного открытия чертежа нужно вызвать команду ОТКРЫТЬ и воспользоваться параметром "Открыть частично" в диалоговом окне "Выбор файла" (стандартном окне выбора файлов). Выгрузить геометрию, уже загруженную в чертеж с помощью команды ЗАГРЧАСТЬ, нельзя, даже вызовом команды ОТМЕНИТЬ.

Если по запросу "Команда" ввести -загрчасть, команда ЗАГРЧАСТЬ отображает запросы в командной строке.

Темы:

  • Диалоговое окно "Частичная загрузка"
  • Командная строка ЗАГРЧАСТЬ


Диалоговое окно "Частичная загрузка"

З Команды
З Команды
Диалоговое окно "Частичная загрузка"
Понятия Процедуры Команды

Меню "Файл": Частичная загрузка

Ввод команды: загрчасть

В окне отображаются списки видов и слоев, доступных для подгрузки в частично открытый чертеж. Пользователь может выбирать и загружать объекты из вида или из выбранной области и из слоев. Выгрузить геометрию, уже загруженную в чертеж, нельзя. Если чертеж содержит прикрепленные внешние ссылки, которые не были загружены в момент частичного открытия чертежа, их можно повторно загрузить в чертеж, используя палитру "Внешние ссылки". См. ССЫЛКА.

Загрузка объектов по видам

Имя выбранного вида и список доступных видов чертежа. Загружены могут быть только виды, созданные в пространстве модели. Загрузка объектов пространства листа может быть осуществлена только путем загрузки слоя, на котором построен объект пространства листа.

Имя вида

Имя выбранного вида. В чертеж загружаются объекты, одновременно находящиеся на выбранном виде и принадлежащие выбранным слоям.

Список видов

Все виды пространства модели, доступные в выбранном файле чертежа. Если выбран какой-либо вид, загружается только геометрия, которая находится в его пределах. По умолчанию предлагается вид "Границы". В списке можно одновременно выбрать не более одного вида. В чертеж загружаются объекты, одновременно находящиеся на выбранном виде и принадлежащие выбранным слоям. Выгрузить информацию, уже загруженную в файл, нельзя.

Указать рамкой

Подсказка об использовании указательного устройства для обозначения области путем выбора рамки. Эта область становится равноценной виду чертежа; она добавляется в список, получая имя "Новый вид".

Загрузка объектов по слоям

Здесь перечислены все слои, доступные в файле чертежа. В чертеж загружаются объекты, находящиеся на выбранных слоях (включая объекты как пространства модели, так и пространства листа). По умолчанию не выбран ни один слой. В списке можно одновременно выбрать несколько слоев. В чертеж загружаются объекты, одновременно находящиеся на выбранном виде и принадлежащие выбранным слоям. Выгрузить информацию, уже загруженную в файл, нельзя.

Имя слоя

Все слои, доступные в выбранном чертеже.

Загрузка объектов

Определяет, загружается ли объект из слоя в чертеж. Если выбрана "Загрузка объекта", то объект из слоя загружается в чертеж. Выгрузить информацию, уже загруженную в файл, нельзя.

Выбрать все

Выбор загрузки объектов для всех слоев. Для загрузки объектов из всех слоев можно также нажать на списке правую кнопку мыши и выбрать пункт "Выбрать все" из контекстного меню.

Очистить все

Отмена загрузки в чертеж любых объектов (отмена опции "Загрузка объектов" для всех слоев). Рекомендуется загружать в чертеж объекты хотя бы из одного слоя. Если не выбрано ни одного слоя, не загружаются никакие объекты, включая объекты из выбранного вида. Если не выбраны слои для загрузки в чертеж, выводится предупреждение. Отменить выбор можно также, нажав правую кнопку мыши на списке и выбрав "Очистить все" из контекстного меню.

Индексы

Индикатор наличия пространственных и/или слоевых индексов в выбранном файле чертежа. Системная переменная INDEXCTL управляет сохранением слоевых и пространственных индексов в файле чертежа. Пространственный индекс организует объекты по их положению в трехмерном пространстве. Слоевой индекс представляет собой список слоев с перечнем объектов, расположенных на каждом из них.


Командная строка ЗАГРЧАСТЬ

З Команды
З Команды
Командная строка ЗАГРЧАСТЬ
Понятия Процедуры Команды

Если чертеж открыт частично и по запросу "Команда" вводится -загрчасть, команда ЗАГРЧАСТЬ отображает запросы в командной строке.

Первый угол или [Вид]: Указать точку или ввести в

Первый угол

Задание первого угла определяемого пользователем вида.

Противоположный угол: Указать точку

Объекты, находящиеся в пределах заданного вида, подгружаются в чертеж.

Имена загружаемых слоев или [?] <нет>: Ввести имя слоя, затем ? или нажать ENTER

Имена загружаемых слоев

В чертеж загружаются объекты, находящиеся на выбранных слоях (независимо от пространства модели или листа). Для того чтобы одновременно задать несколько слоев, нужно ввести их имена, разделяя запятыми. Если не заданы слои, геометрия не в чертеж загружается даже в том случае, если указан вид для загрузки.

Выгрузить все внешние ссылки при открытии [Да/Нет] <Да>: Ввести д или н или нажать ENTER

Да

Информация о внешних ссылках не загружается в чертеж.

Нет

Информация о всех внешних ссылках загружается в чертеж.

?—Список слоев

Отображение списка имен слоев, имеющихся в текущем чертеже. Необходимо ввести имя слоя или список имен слоев. Если не заданы слои, геометрия не в чертеж загружается даже в том случае, если указан вид для загрузки.

Выгрузить все внешние ссылки при открытии [Да/Нет] <Да>: Ввести д или н или нажать ENTER

Да

Информация о внешних ссылках не загружается в чертеж.

Нет

Информация о всех внешних ссылках загружается в чертеж.

Вид

Загрузка в текущий чертеж геометрии с выбранного вида.

Имя вида для загрузки или [?] <*Границы*>: Ввести имя вида, затем ? или нажать ENTER для загрузки чертежа в его границах

Имя вида для загрузки

Загрузка в текущий частично открытый чертеж геометрии с выбранного вида.

Имена загружаемых слоев или [?] <нет>: Ввести имя слоя, затем ? или нажать ENTER

Имена загружаемых слоев

Загрузка в текущий чертеж геометрии с выбранного слоя (слоев). Для того чтобы одновременно задать несколько слоев, нужно ввести их имена, разделяя запятыми. Если не заданы слои, геометрия в чертеж не загружается даже в том случае, если указан вид для загрузки.

Выгрузить все внешние ссылки при открытии [Да/Нет] <Да>: Ввести д или н или нажать ENTER

Если ввести да, в чертеж не будут загружены внешние ссылки. Если ввести нет, в чертеж будут загружены все внешние ссылки.

?—Список слоев

Отображение списка имен слоев, имеющихся в текущем чертеже.. Необходимо ввести имя слоя или список имен слоев. Если не заданы слои, геометрия не загружается в чертеж даже в том случае, если указан вид для загрузки.

Выгрузить все внешние ссылки при открытии [Да/Нет] <Да>: Ввести д или н или нажать ENTER

Если ввести да, в чертеж не будут загружены внешние ссылки. Если ввести нет, в чертеж будут загружены все внешние ссылки.

?—Список видов

Отображение списка видов пространства модели, доступных в файле чертежа. Необходимо ввести имя вида.

Имена загружаемых слоев или [?] <нет>: Ввести имя слоя, затем ? или нажать ENTER

Имена загружаемых слоев

Загрузка в текущий чертеж геометрии с выбранного слоя (слоев). Для того чтобы одновременно задать несколько слоев, нужно ввести их имена, разделяя запятыми. Если не заданы слои, геометрия не загружается в чертеж даже в том случае, если указан вид для загрузки.

Выгрузить все внешние ссылки при открытии [Да/Нет] <Да>: Ввести д или н или нажать ENTER

Если ввести да, в чертеж не будут загружены внешние ссылки. Если ввести нет, в чертеж будут загружены все внешние ссылки.

?—Список слоев

Отображается список имен слоев, доступных в текущем чертеже. Необходимо ввести имя слоя или список имен слоев. Если не заданы слои, геометрия не загружается в чертеж даже в том случае, если указан вид для загрузки.

Выгрузить все внешние ссылки при открытии [Да/Нет] <Да>: Ввести д или н или нажать ENTER

Если ввести да, в чертеж не будут загружены внешние ссылки. Если ввести нет, в чертеж будут загружены все внешние ссылки.


ЗАДЕРЖКА Команда

З Команды
З Команды
ЗАДЕРЖКА Команда
Понятия Процедуры Команды

Задание паузы при выполнении пакета команд

Ввод команды: задержка (или 'задержка для прозрачного вызова)

Задержка (в миллисекундах): Ввести значение от 0 до 32767 миллисекунд

Числовой параметр описывает длительность паузы. Ввод задержка 1000 в пакете команд задерживает начало выполнения следующей команды на 1 секунду. Максимально допустимый параметр команды 32767 (это чуть меньше 33 секунд).


ЗАКРАСИТЬ Команда

З Команды
З Команды
ЗАКРАСИТЬ Команда
Понятия Процедуры Команды

Управление закрашиванием таких объектов, как штриховки, фигуры и широкие полилинии

Ввод команды: закрасить (или 'закрасить для прозрачного вызова)

Выберите режим [Вкл/Откл] <текущий>: Выбрать Вкл или Откл или нажать ENTER

Вкл

Включение режима закрашивания. При закрашивании трехмерных объектов направление выдавливания должно быть параллельно текущему направлению взгляда; удалять скрытые линии не следует.

Откл

Отключение режима закрашивания. На экран и на плоттер выводятся только контуры объектов. Изменение режима закрашивания проявляется после регенерации чертежа. Переключение режима закрашивания не влияет на объекты, изображенные с учетом веса линий.


ЗАКРЫТЬ Команда

З Команды
З Команды
ЗАКРЫТЬ Команда
Понятия Процедуры Команды

Закрытие текущего чертежа

Меню "Файл": "Закрыть"

Ввод команды: закрыть

Закрывает текущий чертеж. Если с момента последнего сохранения в чертеж были внесены изменения, программа предлагает сохранить изменения или отказаться от них.

Файлы, открытые только для чтения, закрываются данной командой, только если не было сделано никаких изменений или пользователь решил отказаться от них. Для сохранения изменений в чертеже, открытом только для чтения, следует воспользоваться командой SAVEAS.


ЗАКРЫТЬВСЕ Команда

З Команды
З Команды
ЗАКРЫТЬВСЕ Команда
Понятия Процедуры Команды

Закрытие всех открытых в данный момент чертежей

Меню "Окно": "Закрыть все"

Ввод команды: закрытьвсе

Закрывает все открытые чертежи. Для каждого чертежа, в котором имеются не сохраненные изменения, выводится окно запроса об их сохранении.


ЗНАКПСК Команда

З Команды
З Команды
ЗНАКПСК Команда
Понятия Процедуры Команды

Управление видимостью и расположением знака ПСК

Меню "Вид": "Отображение" » "Знак ПСК"

Ввод команды: знакпск

Знак ПСК показывает ориентацию осей ПСК и положение начала текущей ПСК. Он также показывает текущее направление взгляда относительно плоскости XY.

ПСК сохраняется с видовым экраном, если значение системной переменной UCSVP для этого видового экрана равно 1.

В пространстве листа и пространстве модели отображаются разные знаки систем координат. В обоих случаях при размещении знака в начале текущей ПСК в его основании появляется символ "плюс" (+). Символ М, расположенный на оси Y знака, свидетельствует о том, что ПСК совпадает с мировой системой координат.

На 3D знаке ПСК совпадение пользовательской системы координат с МСК обозначается с помощью квадратика, находящегося в начале координат в плоскости XY.

Рамка в основании знака ПСК свидетельствует о том, что направление взгляда совпадает с положительным направлением оси Z(взгляд сверху). Отсутствие рамки означает, что направление взгляда совпадает с отрицательным направлением оси Z (взгляд снизу).

На 3D знаке ПСК ось Z изображается сплошной линией/пунктиром, если точка взгляда находится выше/ниже плоскости XY.

Если ПСК повернута так, что ось Z лежит в плоскости, параллельной плоскости взгляда, т. е. плоскость XY расположена перпендикулярно плоскости взгляда, 2D знак ПСК заменяется изображением сломанного карандаша.

3D знак ПСК не заменяется изображением сломанного карандаша.

Задайте опцию [Вкл/Откл/Все/Без начала/Начало/Свойства]<текущая>: Задать опцию или нажать ENTER

Вкл

Включение видимости знака ПСК.

Откл

Отключение видимости знака ПСК.

Все

Применение изменений знака ПСК ко всем активным видовым экранам. В противном случае, действие команды ЗНАКПСК распространяется только на текущий видовой экран.

Задайте опцию [Вкл/Откл/Без начала/Начало] <текущая>: Задать опцию для применения ко всем активным видовым экранам или нажать ENTER

Без начала

Знак ПСК отображается в левом нижнем углу видового экрана независимо от положения начала ПСК.

Начало

Знак ПСК отображается в точке начала текущей ПСК (0,0,0). Если начало ПСК находится за пределами видимой части чертежа, а также если знак ПСК невозможно разместить в начале координат без обрезания на границах видового экрана, знак ПСК отображается в левом нижнем углу видового экрана.

Свойства

Вызов диалогового окна "Знак ПСК", в котором можно задать стиль, видимость и расположение знака ПСК.

Темы:

  • Диалоговое окно "Знак ПСК"


Диалоговое окно "Знак ПСК"

З Команды
З Команды
Диалоговое окно "Знак ПСК"
Понятия Процедуры Команды

Меню "Вид": "Отображение" » "Знак ПСК"

Ввод команды: знакпск

Управление свойствами отображения знака ПСК на экране.

Стиль знака ПСК

Задание стиля (2D или 3D) и внешнего вида знака ПСК.

2D

Отображение 2D знака ПСК без оси Z.

3D

Отображение 3D знака ПСК.

Конус

Отображение трехмерных конических стрелок на осях X и Y для 3D знака ПСК. Если убрать флажок "Конус", отображаются двухмерные стрелки.

Толщина линий

Задание толщины линий для 3D знака ПСК. Возможные варианты: 1, 2 или 3 пиксела.

Образец

Отображение образца знака ПСК для пространства модели.

Размер знака ПСК

Задание размера знака ПСК в процентах от размеров видового экрана. По умолчанию принято значение 12; допустимый диапазон — от 5 до 95. Следует учитывать, что размер знака определяется размером того видового экрана, на котором он отображается.

Цвет знака ПСК

Задание цветов знака ПСК, отображаемого на видовых экранах в пространстве модели и на вкладках "Лист".

Цвет знака в пространстве модели

Задание цвета знака ПСК на видовых экранах в пространстве модели. Для вызова диалогового окна "Выбор цвета" следует нажать "Выбор цвета".

В диалоговом окне "Выбор цвета" можно выбрать цвет для элементов окна из числа 255 цветов, входящих в Индекс цветов AutoCAD (ИЦА), а также из всей палитры или из альбома цветов.

Цвет знака на листах

Задание цвета знака ПСК на вкладках «Лист». Для вызова диалогового окна "Выбор цвета" следует нажать "Выбор цвета".

В диалоговом окне "Выбор цвета" можно выбрать цвет для элементов окна из числа 255 цветов, входящих в Индекс цветов AutoCAD (ИЦА), а также из всей палитры или из альбома цветов.


И Команды
  • ИЗВЛРЕБРА
  • ИЗЛОМРАЗРЕЗ
  • ИЗМЕНЕНИЯ
  • ИЗОБ
  • ИЗОБВСТАВИТЬ
  • ИЗОБКАЧЕСТВО
  • ИЗОБКОНТУР
  • ИЗОБРЕГУЛ
  • ИЗОБРЕЗ
  • ИЗОМЕТР
  • ИМПДГО
  • ИМПОРТ
  • ИМПОРТ3ДС
  • ИМПОРТМТФ
  • ИМПОРТПЛ
  • ИМПОРТТЕЛ
  • ИНСТРПАЛВКЛ
  • ИНСТРПАЛОТКЛ
  • ИНФО


ИЗВЛРЕБРА Команда

И Команды
И Команды
ИЗВЛРЕБРА Команда
Понятия Процедуры Команды

Создание геометрии каркаса посредством извлечения ребер из 3D тела или поверхности

Меню "Редактирование": "3D операции" » "Извлечь ребра"

Ввод команды: извлребра

Команда ИЗВЛРЕБРА позволяет создать геометрию каркаса посредством извлечения всех ребер из следующих объектов:

  • Тела
  • Области
  • Поверхности

Кроме того, можно выбрать отдельные ребра и грани для извлечения. Выбор ребер и граней производится с нажатой клавишей CTRL.

Выберите объекты: Выбрать объекты, из которых требуется извлечь геометрию каркаса, и нажать ENTER


ИЗЛОМРАЗРЕЗ Команда

И Команды
И Команды
ИЗЛОМРАЗРЕЗ Команда
Понятия Процедуры Команды

Добавление сегмента с изломом к объекту-сечению

Ввод команды: изломразрез

Выберите объект-сечение: Выберите объект-сечение

Укажите точку на линии сечения для добавления излома: Выберите точку на линии сечения

На линии сечения будет создан излом. Сегмент с изломом создается под углом 90 градусов к линии сечения.


ИЗМЕНЕНИЯ Команда

И Команды
И Команды
ИЗМЕНЕНИЯ Команда
Понятия Процедуры Команды

Управление свойствами объектов

Ввод команды: изменения

Выбрать объекты:

Выбранные объекты должны быть параллельны текущей пользовательской системе координат (ПСК). Это условие не касается отрезков нулевой высоты.

Если в одном наборе объектов имеются как отрезки, так и объекты других типов, выполнение команды будет зависеть от последовательности выбора. Простейшим способом использования команды ИЗМЕНЕНИЯ является выбор в наборе объектов только линий или только объектов, отличных от линий.

Задать точку изменения или [Свойства]: Указать новую точку или нажать ENTER , чтобы ввести новые значения

Точка изменения или значения

Изменение выбранных объектов. Результат определяется типом объекта.

Отрезки

Перемещение конечных точек отрезков. Указание точки изменения для отрезка или набора отрезков вызывает перемещение ближайших к ней концов выбранных отрезков в эту точку (если режим "Орто" отключен). Если режим "Орто" включен, выбранные отрезки изменяются так, что они располагаются параллельно либо оси X, либо оси Y; перемещения их концов в указанную точку не происходит.

Круги

Изменение радиусов кругов. Если выбрано несколько кругов, запрос повторяется для каждого последующего круга.

Новый радиус круга <не изменять>:

Текст

Изменение положения и других свойств текста.

Новая точка вставки текста <не изменять>:

Текст перемещается в соответствии с указанным новым положением. При нажатии клавиши ENTER текст останется в исходном положении.

Новый текстовый стиль <текущий>:

Если для текста установлена фиксированная высота, подсказка для ввода высоты не отображается.

Новая высота <текущая>:

Новый угол поворота <текущий>:

Новый текст <текущий>:

Будет выделен следующий объект, и отобразятся подсказки.

Описания атрибутов

Изменение текста и его характеристик для атрибутов, не являющихся частью блока.

Новая точка вставки текста <не изменять>:

Текст перемещается в соответствии с указанным новым положением. При нажатии клавиши ENTER текст останется в исходном положении.

Новый текстовый стиль <текущий>:

Если для текста установлена фиксированная высота, подсказка для ввода высоты не отображается.

Новая высота <текущая>:

Новый угол поворота <текущий>:

Новое имя <текущее>:

Новая подсказка <текущая>:

Новое значение по умолчанию <текущее>:

Блоки

Изменение положения или угла поворота блока.

Указать точку вставки нового блока: Указать точку (1) или нажать ENTER

Блок перемещается в соответствии с указанным новым положением. При нажатии клавиши ENTER блок останется в исходном положении.

Новый угол поворота <текущий>:

Блок вращается относительно точки вставки в соответствии со вновь заданным значением угла.

Свойства

Редактирования свойств имеющихся объектов.

Ввести свойство, подлежащее изменению[Цвет/Уровень/Слой/Тип линии/Лмасштаб/Вес линии/Высота/Материал/Стиль печати]:

Примечание Опция "Стиль печати" доступна только при использовании именованных стилей печати.

Если выбраны несколько объектов, имеющие различные значения изменяемого свойства, в качестве текущего значения отображается значение разные.

Одной командой можно изменить несколько свойств. После завершения каждой опции вновь появляется подсказка "Указать изменяемое свойство".

Цвет

Изменение цвета выбранных объектов.

Ввести новый цвет [изПалитры/Альбом]<текущий>: Ввести имя цвета или число от 1 до 255, ввести t, ввести co, ввести ПоСлою или ПоБлоку или нажать ENTER

Например, чтобы изменить цвет на красный, нужно ввести красный или 1. Чтобы установить цвет объекта равным цвету его слоя, следует ввести послою. Чтобы объект унаследовал цвет блока, в который он входит, следует ввести поблоку.

Из палитры

Выбор цвета для выбранного объекта из палитры всех цветов (true color).

Компоненты R,G,B: Ввести три разделенных запятыми значения от 0 до 255

Альбом

Выбор цвета для выбранного объекта из загруженного альбома цветов.

Имя альбома цветов: Ввести имя установленного альбома цветов, например PANTONE

При вводе имени альбома цветов отображается следующая подсказка.

Имя цвета: Ввести имя цвета из этого альбома, например Pantone 573

Уровень

Изменение уровня двумерного объекта по оси Z.

Новый уровень <текущий>:

Уровень объекта можно изменить только в том случае, если все его точки имеют одну и ту же координату Z.

Слой

Изменение слоя выбранных объектов.

Имя нового слоя <текущее>:

Тип линий

Изменение типа линии выбранных объектов.

Имя нового типа линии <текущее>:

Если указанный тип линии не загружен, программа пытается загрузить его из стандартного библиотечного файла типов линий acad.lin. Если попытка завершилась неудачно, следует загрузить этот тип линии вручную с помощью команды ТИПЛИН.

Лмасштаб

Изменение масштаба типа линии выбранных объектов.

Масштаб типа линии <текущий>:

Вес линий

Изменение веса линии выбранных объектов. Вес линий должен иметь значение из стандартного ряда. При вводе значения, отсутствующего в этом ряду, оно приводится к ближайшему стандартному.

Новый вес линии <текущий>:

Высота

Изменение высоты двумерного объекта по оси Z.

Новая высота <текущая>:

Попытка изменить высоту трехмерной полилинии, размера или видового экрана листа не дает никаких результатов.

Материал

Изменяет материал выбранных объектов, если он применяется.

Ввести имя нового материала < ПоСлою>:

Стиль печати

Изменение стиля печати выбранных объектов. Стиль печати — это набор свойств объектов, назначаемых им при печати и сохраняемых в таблицах стилей.

Стиль печати или [?] <текущий>: Ввести имя или ?

Стиль печати

Назначение стиля печати выбранным объектам. При выводе на печать объекты получают свойства, присущие назначенному стилю печати. Вновь назначенный объекту стиль печати заменяет имевшийся ранее.

?—Список стилей печати

Вывод списка стилей печати, имеющихся в чертеже.


ИЗОБ Команда

И Команды
И Команды
ИЗОБ Команда
Понятия Процедуры Команды

Открытие палитры "Внешние ссылки"

Панель "Ссылки":

Меню "Вставка": "Внешние ссылки"

Контекстное меню: Выберите изображение, нажмите правую кнопку мыши в области рисования и выберите "Изображение" » "Внешние ссылки".

Ввод команды: изоб

Отобразится Палитра "Внешние ссылки".

Если в командной строке ввести -изоб, будут выведены подсказки для команды ИЗОБ.

Темы:

  • ИЗОБ вариант для командной строки


ИЗОБ вариант для командной строки

И Команды
И Команды
ИЗОБ вариант для командной строки
Понятия Процедуры Команды

Если в командной строке ввести -изоб, будут выведены подсказки для команды ИЗОБ.

Задайте опцию [?/Удалить/Путь/Обновить/Выгрузить/Вставить] <Вставить>: Задайте опцию или нажмите ENTER

?—Список изображений

Вывод списка изображений с указанием пути и количества вхождений. Изображения перечислены в алфавитном порядке, независимо от значения системной переменной MAXSORT.

Какие имена изображений вывести <*>: Ввести * для вывода списка всех изображений или задать имя изображения

Удалить

Удаление указанного изображения (описания и всех вхождений) из чертежа.

Какие изображения удалить: Задать имя изображения или ввести * для удаления всех изображений

Путь

Обновление пути и имени файла для выбранного изображения. Данная опция полезна, если файл изображения был перемещен или переименован, а также если требуется заменить вставленное в чертеж изображение на новое (например, файл image01.pcx после изменения может быть сохранен как image02.pcx).

Для каких изображений изменить путь: Задать имя изображения или ввести * для вывода списка всех изображений

При вводе звездочки (*) отображается следующая подсказка:

Старый путь: Выводится текущий путь для каждого изображения

Новый путь: Ввести новый путь к выбранному изображению

Обновить

Обновляет выбранные изображения, делая возможным отображение чертежа на экране и вывод на печать.

Какие изображения обновить: Задать имя изображения или ввести * для обновления всех изображений

Идет обновление...

Обновляется изображение <имя>: <сохраненный путь>

<Имя> обновлено.

Выгрузить

Содержимое изображения выгружается из памяти; оно перестает выводиться на экран, что приводит к повышению производительности. Тем не менее, ссылка на изображение продолжает храниться в чертеже. Рамка каждого вставленного изображения остается видимой.

Какие изображения выгрузить: Задать имя загруженного изображения или ввести * для выгрузки всех изображений

Вставить

Вставляет в чертеж новое изображение или новое вхождение имеющегося изображения. Отобразится диалоговое окно "Выбор файла изображения" (стандартное окно выбора файлов).

Имя изображения назначается путем присвоения изображению имени файла без расширения. Имя изображения может содержать до 255 символов и состоять из букв, цифр, пробелов и специальных символов, не используемых системой Microsoft Windows или этой программой. Если выбранное имя файла содержит символы, не разрешенные в именах неграфических объектов, появляется диалоговое окно "Замена имени изображения". Корректное имя изображения генерируется из имени файла. При этом к имени добавляется номер и символ подчеркивания. Номер изменяется для избежания повторного использования одинаковых имен для изображений.

Изображение имя_файла_1 взято из файла имя_файла.bmp

Если описание с таким именем и путем уже существует в чертеже, изображение вставляется как копия и отображаются следующие подсказки.

Изображение имя_файла_1 уже загружено

Для его обновления вызовите ИЗОБ Обновить.

Точка вставки <0,0>: Указать точку вставки

Базовый размер изображения: Ширина: текущая ширина, Высота: текущая высота, текущая единица

Задайте масштабный коэффициент: Введите значение или нажмите ENTER

Задайте угол поворота <0>: Введите значение или нажмите ENTER

Если системной переменной FILEDIA присвоено значение 0, вместо диалогового окна отображается следующая подсказка:

Имя файла изображения для вставки <последнее>: Ввести имя файла

По умолчанию предлагается имя последнего вставленного в чертеж (в течение текущего рабочего сеанса) изображения. Во избежание ошибок рекомендуется при вставке изображений задавать как имя изображения, так и имя файла:

имяизображения=путь\длинноеимяфайла.bmp

или

имяизображения="путь\длинноеимяфайла.bmp"

Если введено правильное имя файла без расширения, программа выполняет поиск файла в следующем порядке: существующее описание изображения в чертеже, а затем файл изображения в папках с учетом порядка путей поиска. Программа выполняет поиск файла изображения с указанным именем без учета расширения и использует первое найденное имя. Если ни имя изображения, ни файл изображения не найдены, отображается сообщение "Изображение не найдено", и запрос повторяется.

Если длинное имя файла не удовлетворяет правилам именования файлов в программе, имя изображения необходимо задавать следующим образом:

"имя_изображения=имя_файла "

Для поиска файлов изображений можно использовать диалоговое окно. Однако при этом все равно необходимо задать в командной строке имя_изображения=имя_файла. Ввести тильду (~) в ответ на запрос "Имя файла изображения для вставки". Если после открытия диалогового окна нажать ESC, отобразится подсказка "Изображение для вставки".


ИЗОБВСТАВИТЬ Команда

И Команды
И Команды
ИЗОБВСТАВИТЬ Команда
Понятия Процедуры Команды

Вставка нового изображения в текущий чертеж

Панель Ссылки:

Меню "Вставка": "Растровое изображение"

Ввод команды: изобвставить

Отобразится диалоговое окно "Выбор файла изображения" (стандартное окно выбора файлов). После выбора файла изображения отобразится диалоговое окно Изображение.

Темы:

  • Диалоговое окно "Растровое изображение"


Диалоговое окно "Растровое изображение"

И Команды
И Команды
Диалоговое окно "Растровое изображение"
Понятия Процедуры Команды

Панель Ссылки:

Меню "Вставка": "Растровое изображение"

Ввод команды: изобвставить

Размещение, вставка, присвоение имени и задание параметров для вставляемых изображений.

Имя

Задание имени предназначенного для вставки изображения (выбирается либо в окне "Выбор файла изображения", либо из списка имеющихся картинок). Для добавления нового вхождения уже вставленного в чертеж изображения необходимо выбрать имя изображения из списка и нажать кнопку "OK".

Обзор

Открывает диалоговое окно "Выбор файла изображения" (стандартное окно выбора файлов). Если выбран параметр "Показать образец", отобразится образец картинки для просмотра.

Найдено в

Путь к искомому файлу растрового изображения.

Сохр. путь

Путь, заданный файлу растрового изображения при его вставке в текущий чертеж.

Задание пути

Указывает один из трех типов путей к папке, сохраняемых вместе со вставленным изображением: абсолютный путь, относительный путь и не заданный путь. Дополнительную информацию о каждой опции см. Задание путей к внешним чертежамв руководстве пользователя.

Полный

Полный путь к файлу растрового изображения.

Относительный

Относительный путь к файлу растрового изображения.

Без пути

Задается только имя файла изображения. Файл растрового изображения должен быть сохранен в одной папке с файлом текущего чертежа.

Точка вставки

Задание точки вставки для выбранного изображения. По умолчанию установлен флажок "Указать на экране". Точкой вставки по умолчанию считается 0,0.

Указать на экране

Задание параметра в командной строке или устройством указания на экране. Если же флажок "Указать на экране" снят, координаты X, Y и Z точки вставки задаются в диалоговом окне.

X

Значение координаты X.

Y

Значение координаты Y.

Z

Значение координаты Z.

Масштаб

Задание масштаба для выбранного изображения. Если установлен флажок "Указать на экране", задание параметра будет произведено в командной строке или устройством указания. Если флажок сброшен, масштабный коэффициент задается в диалоговом окне. Масштаб по умолчанию равен 1.

Если системной переменной INSUNITS присвоено значение “unitless” или если информация о разрешении изображения отсутствует, размеры изображения автоматически преобразуются в единицы AutoCAD. Если в переменной INSUNITS заданы единицы (миллиметры, сантиметры, дюймы или футы), а разрешение изображения известно, масштаб применяется только после того, как определена реальная ширина изображения в единицах AutoCAD.

Угол поворота

Задание угла поворота выбранного изображения. Если установлен флажок "Указать на экране", угол поворота задается после выхода из диалогового окна с помощью устройства указания или вводом значения в командной строке. Если же флажок "Указать на экране" сброшен, угол поворота изображения задается в диалоговом окне. Угол по умолчанию равен 0.

Подробности

Вывод информации о выбранном изображении.

Разрешение

Отображает информацию о вертикальном и горизонтальном разрешении выбранного изображения.

Текущие единицы AutoCAD

Отображает информацию о единицах по умолчанию, используемых в выбранном изображении. Изображение отображается с длиной и шириной в пикселах по умолчанию.

"Размеры изображения в пикселах"

Отображает информацию о ширине и высоте выбранного изображения в пикселах.

"Размеры изображения в единицах"

Отображает информацию о размере в единицах по умолчанию для выбранного изображения. По умолчанию для всех изображений единицы не устанавливаются (без единиц). Размеры изображения, автоматически преобразованные в единицы AutoCAD, предлагаются при вставке по умолчанию.


ИЗОБКАЧЕСТВО Команда

И Команды
И Команды
ИЗОБКАЧЕСТВО Команда
Понятия Процедуры Команды

Управление качеством вывода изображений на экран

Панель Ссылки:

Меню "Изменить": "Объект" » "Изображение" » "Качество"

Ввод команды: изобкачество

Качество изображения [Высокое/Черновое] <текущее>: Задайте опцию или нажмите ENTER

Установленное качество определяет быстродействие системы, так как вывод на экран изображений высокого качества происходит дольше. Изменение качества сразу же отражается на экране и не требует регенерации чертежа.

Примечание Изображения всегда печатаются с высоким качеством.

Высокое

Вывод изображения с высоким качеством.

Черновое

Вывод изображения с черновым качеством.


ИЗОБКОНТУР Команда

И Команды
И Команды
ИЗОБКОНТУР Команда
Понятия Процедуры Команды

Управляет видимостью рамок изображения и выводом их на печать

Панель "Ссылки":

Меню "Изменить": "Объект" » "Изображение" » "Рамка"

Ввод команды: изобконтур

Задайте опцию для рамки изображения [0, 1, 2] <текущий>: Задайте опцию или нажмите ENTER

Примечание Как правило, если рамки изображения не отображаются, выбрать изображение невозможно. Однако, команда ИЗОБРЕЗ временно отображает рамки изображения.

Значение 0

Рамки изображения не отображаются и не печатаются.

Значение 1

Рамки изображения отображаются и печатаются. Эта установка действует по умолчанию.

Значение 2

Рамки изображения отображаются, но не печатаются.


ИЗОБРЕГУЛ Команда

И Команды
И Команды
ИЗОБРЕГУЛ Команда
Понятия Процедуры Команды

Регулировка яркости, контрастности и степени слияния с фоном изображений

Панель Ссылки:

Меню "Изменить": "Объект" » "Изображение" » "Регулировка"

Контекстное меню: Выберите изображение для регулировки, нажмите правую кнопку мыши в области рисования и выберите "Изображение" » "Регулировка".

Ввод команды: изобрегул

Выберите изображения: Выбрать одно или несколько изображений

Отобразится диалоговое окно Регулировка изображения.

Если в командной строке ввести -изобрегул, будут выведены подсказки для команды ИЗОБРЕГУЛ.

Темы:

  • Диалоговое окно "Регулировка изображения"
  • ИЗОБРЕГУЛ вариант для командной строки


Диалоговое окно "Регулировка изображения"

И Команды
И Команды
Диалоговое окно "Регулировка изображения"
Понятия Процедуры Команды

Панель Ссылки:

Меню "Изменить": "Объект" » "Изображение" » "Регулировка"

Контекстное меню: Выберите изображение для регулировки, нажмите правую кнопку мыши в области рисования и выберите "Изображение" » "Регулировка".

Ввод команды: изобрегул

Регулирует настройки яркости, контрастности и степени слияния с фоном выбранного изображения. Настройка этих величин изменяет внешний вид изображения в чертеже, но не вносит изменений в файл изображения.

Яркость

Управление яркостью и (косвенно) контрастностью изображения. Значение может изменяться в диапазоне от 0 до 100. Чем оно больше, тем ярче изображение, и тем большее число пикселов окрашиваются в белый цвет при повышении контрастности. Перемещение указателя влево уменьшает значение, вправо — увеличивает.

Контрастность

Управление контрастностью изображения и (косвенно) степенью его слияния с фоном. Значение может изменяться в диапазоне от 0 до 100. Чем оно больше, тем ближе цвет пикселов к одному из двух основных цветов. Перемещение указателя влево уменьшает значение, вправо — увеличивает.

Слияние с фоном

Управление степенью слияния изображения с фоном. Значение может изменяться в диапазоне от 0 до 100. Чем оно больше, тем больше пикселов принимают текущий цвет фона. При значении, равном 100, картинка полностью сливается с фоном. Изменение цвета фона экрана приводит к перекрашиванию частично слитых с фоном изображений. При печати автоматически устанавливается белый цвет фона. Перемещение указателя влево уменьшает значение, вправо — увеличивает.

Образец

Вывод образца для предварительного просмотра изображения. При изменении параметров контрастности, яркости и слияния с фоном изображение обновляется динамически.

Сброс

Восстановление значений яркости, контрастности и слияния с фоном по умолчанию (соответственно 50, 50 и 0).


ИЗОБРЕГУЛ вариант для командной строки

И Команды
И Команды
ИЗОБРЕГУЛ вариант для командной строки
Понятия Процедуры Команды

Если в командной строке ввести -изобрегул, будут выведены подсказки для команды ИЗОБРЕГУЛ. Этот вариант команды ИЗОБРЕГУЛ позволяет выбирать для регулировки несколько изображений одновременно.

Выберите изображения: Выбрать одно или несколько изображений

Задайте опцию [Контрастность/Слияние с фоном/Яркость] <Яркость>: Введите к или с или нажмите ENTER для регулировки яркости

Если выбрано одиночное изображение, в качестве значений по умолчанию для параметров принимаются текущие значения яркости, контрастности и степени слияния с фоном. При выборе нескольких изображений значения яркости, контрастности и слияния с фоном по умолчанию принимают стандартные значения 50, 50 и 0.

Контрастность

Управление контрастностью изображения и (косвенно) степенью его слияния с фоном. Значение может изменяться в диапазоне от 0 до 100. Чем оно больше, тем ближе цвет пикселов к одному из двух основных цветов.

Величина контрастности (0-100) <50>: Ввести значение

Слияние с фоном

Управление степенью слияния изображения с фоном. Значение может изменяться в диапазоне от 0 до 100. Чем оно больше, тем больше пикселов принимают текущий цвет фона. При значении, равном 100, картинка полностью сливается с фоном. Изменение цвета фона экрана приводит к перекрашиванию частично слитых с фоном изображений. При печати автоматически устанавливается белый цвет фона.

Величина слияния с фоном (0-100) <0>: Ввести значение

Яркость

Управление яркостью и (косвенно) контрастностью изображения. Значение может изменяться в диапазоне от 0 до 100. Чем оно больше, тем ярче изображение, и тем большее число пикселов окрашиваются в белый цвет при повышении контрастности.

Величина яркости (0-100) <50>: Ввести значение


ИЗОБРЕЗ Команда

И Команды
И Команды
ИЗОБРЕЗ Команда
Понятия Процедуры Команды

Использует контуры подрезки для определения подобласти объекта изображения.

Панель Ссылки:

Меню "Изменить": "Подрезка" » "Изображение"

Контекстное меню: Выберите изображение для подрезки, нажмите правую кнопку мыши в области рисования и выберите "Изображение" » "Подрезка"

Ввод команды: изобрез

Выберите изображение для подрезки: Выберите границу изображения

Задайте опцию подрезки [Вкл/Откл/Удалить/Новый контур] <Новый>: Задайте опцию или нажмите ENTER

Контур подрезки задается в плоскости, параллельной растровой картинке.

Вкл

Включение подрезки. На экран выводится только часть изображения, расположенная внутри заданного ранее контура.

Откл

Отключение подрезки. На экран выводится полное изображение с рамкой.

Если подрезка выполняется при отключенном параметре, при повторном вызове команды подрезка автоматически восстанавливается. Отобразится подсказка удалить старый контур, даже если подрезка отключена, и он невидим.

Удалить

Удаление имеющегося контура подрезки.

Новый контур

Задает новый контур подрезки Контур может быть прямоугольным или многоугольным; но должен состоять только из линейных сегментов. При определении контура подрезки следует указать вершины контура изображения. Задание контура производится путем последовательного указания вершин. По умолчанию используются прямоугольные контуры. Если в ответ на подсказу "Тип контура подрезки" для указания точки используется указывающее устройство, точка рассматривается как первый угол прямоугольного контура.

Задайте тип контура подрезки [Многоугольный/Прямоугольный] <Прямоугольный>: Введите м или нажмите ENTER

Многоугольный

Построение многоугольного контура путем последовательного указания точек.

Укажите первую точку: Укажите точку

Укажите следующую точку или выберите [Отменить]: Укажите точку или введите о

Укажите следующую точку или выберите [Отменить]: Укажите точку или введите о

Укажите следующую точку или выберите [Замкнуть/Отменить]: Укажите точку или введите з или о

Для формирования многоугольного контура необходимо указать по крайней мере три точки.

Если для данного изображения уже определен контур подрезки, отобразится следующая подсказка.

Удалить прежние контуры? [Нет/Да] <Да>: Введите н или нажмите ENTER

При выборе "Да" изображение перерисовывается, и команда продолжается; если получен ответ "Нет", команда завершается.

Прямоугольный

Построение прямоугольного контура путем указания его противоположных углов. Прямоугольник всегда строится параллельно границам изображения.

Укажите точку первого угла: Укажите точку

Укажите точку противоположного угла: Укажите точку


ИЗОМЕТР Команда

И Команды
И Команды
ИЗОМЕТР Команда
Понятия Процедуры Команды

Выбор текущей изометрической плоскости

Ввод команды: изометр (или 'изометр для прозрачного вызова)

Выберите плоскость изометрии [Левая /Верхняя /Правая ] <Верхняя>: Задайте опцию или нажмите ENTER

Изометрические плоскости имеют силу только при изометрическом стиле шаговой привязки, причем режим "Шаг" должен быть включен. В режиме "Орто" изометрические оси работают даже при отключенной шаговой привязке. Текущая плоскость изометрии также определяет вид изометрических окружностей, которые строятся командой ЭЛЛИПС. Перемещаться между плоскостями изометрии можно также нажатием CTRL + E или F5.

Левая

Устанавливается левая плоскость, определенная парой осей, направленных под углами 150 и 90 градусов.

Верхняя

Устанавливается верхняя плоскость, определенная парой осей, направленных под углами 30 и 150 градусов.

Правая

Устанавливается правая плоскость, определенная парой осей, направленных под углами 90 и 30 градусов.


ИМПДГО Команда

И Команды
И Команды
ИМПДГО Команда
Понятия Процедуры Команды

Импорт двоичных файлов в специальной кодировке

Меню "Вставка": "Двоичные файлы графического обмена"

Ввод команды: импдго

Отображает диалоговое окно "Выбор DXB-файла" (стандартное окно выбора файлов). В нем нужно ввести имя импортируемого файла.


ИМПОРТ Команда

И Команды
И Команды
ИМПОРТ Команда
Понятия Процедуры Команды

Импортирует файлы в различных форматах

Панель Вставка:

Ввод команды: импорт

Откроется диалоговое окно "Импорт файла" (стандартное окно выбора файлов).

Формат файла для импорта выбирается в списке "Тип файла". Имя файла необходимо задать в поле "Имя файла". Файл импортируется в чертеж. Поддерживаются следующие форматы файлов для импорта:

  • WMF—метафайл Windows (см. ИМП WMF)
  • SAT—файл ACIS-тел (см. ИМП ACIS)
  • 3DS—файл 3D Studio (см. ИМПОРТ3ДС)

Для WMF-файлов при выборе пункта "Настройка" из меню "Сервис" этого окна открывается диалоговое окно "Параметры импорта из WMF". Вызвать это диалоговое окно можно и другим способом непосредственно, командой ОПЦИИМТФ.

Если системной переменной FILEDIA присвоено значение 0, отображается следующая подсказка:

Имя импортируемого файла: Ввести путь и имя файла


ИМПОРТ3ДС Команда

И Команды
И Команды
ИМПОРТ3ДС Команда
Понятия Процедуры Команды

Импорт файлов 3D Studio (3DS)

Меню "Вставить": "3D Studio"

Ввод команды: импорт3дс

Откроется диалоговое окно "Импорт файла 3D Studio " (стандартное диалоговое окно выбора файлов). После того, как пользователь выбрал файл для импорта, открывается диалоговое окно "Параметры импорта файла 3D Studio".

Темы:

  • Диалоговое окно "Параметры импорта файла 3D Studio"


Диалоговое окно "Параметры импорта файла 3D Studio"

И Команды
И Команды
Диалоговое окно "Параметры импорта файла 3D Studio"
Понятия Процедуры Команды

Меню "Вставить": "3D Studio"

Ввод команды: импорт3дс

Позволяет просмотреть имеющиеся и выбранные 3D объекты, распределить объекты по слоям и задать способ обработки объектов, которым присвоено более одного материала.

Имеющиеся объекты

Отображает имена всех объектов в файле 3D Studio® (3DS). Можно выбрать до 70 объектов.

Имя объекта и Тип

Тип и имя каждого объекта.

Добавить все

Добавляет все объекты из списка "Имеющиеся объекты" в список "Выбранные объекты".

Добавить

Добавляет объект, выбранный в списке "Имеющиеся объекты", в список "Выбранные объекты".

Выбранные объекты

Отображает выбранные для импорта объекты 3D Studio.

Имя объекта и тип

Тип и имя каждого объекта.

Удалить

Удаляет выделенные объекты из списка "Выбранные объекты" и возвращает их в список "Имеющиеся объекты".

Исключить все

Удаляет все объекты из списка "Выбранные объекты" и возвращает их в список "Имеющиеся объекты".

Размещать на слоях

Управляет способом распределения объектов 3D Studio по слоям чертежа.

По объектам

Создает слой для каждого объекта файла 3D Studio и размещает каждый импортированный объект на этом слое. Имя слоя совпадает с именем объекта.

По материалам

Создает слой для каждого материала файла 3D Studio и размещает объекты, которым присвоен определенный материал, на соответствующем слое. Имя слоя совпадает с именем материала.

По цветам объектов

AutoCAD создает слой для каждого цвета объектов файла 3D Studio. Каждый объект 3D Studio размещен на слое, соответствующем цвету этого объекта. Имя слоя COLORnn, где nn - индекс цвета 3D Studio. Если в файле 3D Studio имеются объекты, которым не присвоен никакой цвет, они помещаются на слой COLORNONE.

На единственном слое

Создает единственный слой с именем AVLAYER и помещает все объекты на этот слой.

Объекты с несколькими материалами

В 3D Studio можно присваивать материалы граням, элементам и объектам. В AutoCAD можно присваивать материалы только объектам. Когда AutoCAD обрабатывает объект 3D Studio, которому присвоено несколько материалов, данное ограничение приходится обходить разными способами.

С подсказкой

Выдает диалоговое окно "Способ присвоения материалов" для каждого из обнаруженных объектов с несколькими материалами. Имя объекта отображается в этом окне. Выбранные пользователем опции определяют способ присвоения рукояток ИМПОРТ3ДС. Назначение параметров:

Разделить объект по материалам

Разделяет объект на несколько объектов, по одному на каждый материал. Это позволяет сохранить присвоения материалов, имеющиеся в файле 3D Studio. Однако этот способ усложняет геометрию чертежа.

Присвоить первый материал

Присваивает целому объекту первый материал из нескольких присвоенных данному объекту в 3D Studio. Описание того, какой материал считается присвоенным первым, можно найти в документации по 3D Studio.

Выберите материал

Присваивает целому объекту один из нескольких присвоенных данному объекту в 3D Studio материалов. Выбрать материал из списка под этой опцией или выбрать НИЧЕГО, чтобы возвратить материал AutoCAD по умолчанию.

Разделять по материалам

Разделяет объект на несколько объектов, по одному на каждый материал. Это позволяет сохранить присвоения материалов, имеющиеся в файле 3D Studio. Однако этот способ усложняет геометрию чертежа.

Присвоить первый материал

Присваивает целому объекту первый материал из нескольких присвоенных данному объекту в 3D Studio. Описание того, какой материал считается присвоенным первым, можно найти в документации по 3D Studio.

Не назначать материал

Удаляет информацию о материалах. Геометрия 3D Studio сохраняется. Объектам присваивается материал AutoCAD по умолчанию.


ИМПОРТМТФ Команда

И Команды
И Команды
ИМПОРТМТФ Команда
Понятия Процедуры Команды

Импорт метафайла Windows

Меню "Вставка": "WMF"

Ввод команды: импортмтф

Откроется диалоговое окно "Импорт WMF" (стандартное диалоговое окно выбора файлов). Введите имя файла. Расширение файла .wmf добавляется автоматически.

Если в диалоговом окне "Импорт WMF" выбрать "Сервис" » "Параметры", откроется диалоговое окно "Параметры импорта из WMF". Кроме того, вызвать это диалоговое окно можно непосредственно командой ОПЦИИМТФ. После открытия выбранного файла WMF отобразится следующий запрос:

Точка вставки или [Масштаб/X/Y/Z/Поворот/ПМасштаб/ПX/ПY/ПZ/ППоворот]: Указать точку или задать опцию

Точка вставки

Размещение копии метафайла в заданной точке вставки.

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, задать опцию или нажать ENTER

Масштаб по X

Задание масштабных коэффициентов по осям X и Y.

Введите масштаб по оси Y <использовать масштаб по оси X>: Ввести значение или нажать ENTER для использования того же масштабного коэффициента

Угол поворота <0>:

Размеры метафайла по осям X и Y умножаются на соответствующие масштабные коэффициенты по X и Y. Изображение метафайла поворачивается на заданный угол; при этом точка вставки является центром поворота.

Угол

Задание масштабов по осям X и Y одновременно с помощью прямоугольника, очерчиваемого от точки вставки до другой точки. Размер прямоугольника по оси Х становится масштабом по Х, по оси Y — масштабом по Y. Точка вставки задает первый угол прямоугольника.

Противоположный угол: Указать точку

Угол поворота <0>:

Угол поворота определяет наклон изображения WMF-файла.

XYZ

Масштабирование метафайла во всех трех измерениях.

Масштаб по оси X или [Угол] <1>: Задать ненулевое значение, ввести у или нажать ENTER

Для указания угловой точки следует ввести у. Указанная точка и точка вставки определяют масштаб изображения WMF-файла по осям X и Y.

Масштаб по оси Y <использовать масштаб по оси X>: Ввести значение или нажать ENTER для использования того же масштабного коэффициента

Масштаб по оси Z <использовать масштаб по оси X>: Ввести значение или нажать ENTER для использования того же масштабного коэффициента

Угол поворота <0>:

Угол поворота определяет наклон изображения WMF-файла.

Масштаб

Задание масштабных коэффициентов по осям X, Y и Z. В качестве масштаба по Z используется абсолютное значение заданного масштабного коэффициента.

Масштаб по осям X, Y и Z: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

Угол поворота определяет наклон изображения WMF-файла.

X

Задание масштаба по оси X.

Масштаб по оси X: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

Угол поворота определяет наклон изображения WMF-файла.

Y

Задание масштаба по оси Y.

Масштаб по оси Y: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

Угол поворота определяет наклон изображения WMF-файла.

Z

Задание масштаба по оси Z.

Масштаб по оси Z: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

Угол поворота определяет наклон изображения WMF-файла.

Поворот

Задание угла поворота для вставляемого файла.

Угол поворота <0>:

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, указать точку, задать опцию или нажать ENTER

Масштаб по X

Задание масштабных коэффициентов по осям X и Y.

Введите масштаб по оси Y <использовать масштаб по оси X>: Ввести значение или нажать ENTER для использования того же масштабного коэффициента

Угол

Задание масштабов по осям X и Y одновременно с помощью прямоугольника, очерчиваемого от точки вставки до другой точки. Размер прямоугольника по оси Х становится масштабом по Х, по оси Y — масштабом по Y. Точка вставки задает первый угол прямоугольника.

Противоположный угол: Указать точку

XYZ

Масштабирование метафайла во всех трех измерениях.

Масштаб по оси X или [Угол] <1>: Задать ненулевое значение, ввести у или нажать ENTER

Для указания угловой точки следует ввести у. Указанная точка и точка вставки определяют масштаб блока по осям X и Y.

Масштаб по оси Y <использовать масштаб по оси X>: Ввести значение или нажать ENTER для использования того же масштабного коэффициента

Масштаб по оси Z <использовать масштаб по оси X>: Ввести значение или нажать ENTER для использования того же масштабного коэффициента

ПМасштаб

Задание временных масштабных коэффициентов по осям X, Y и Z для управления изображением WMF-файла при его перемещении в требуемое положение.

Предварительный масштаб по осям X, Y и Z: Ввести ненулевое значение

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, указать точку, задать опцию или нажать ENTER

Описание опций "Масштаб по Х", "Угол" и "XYZ" совпадает с описанием соответствующих опций команды "Повернуть".

ПX

Задание временного масштабного коэффициента по оси X для управления изображением WMF-файла при его перемещении в требуемое положение.

Предварительный масштаб по оси X: Ввести ненулевое значение

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, указать точку, задать опцию или нажать ENTER

Описание опций "Масштаб по Х", "Угол" и "XYZ" совпадает с описанием соответствующих опций команды "Повернуть".

ПY

Задание временного масштабного коэффициента по оси Y для управления изображением WMF-файла при его перемещении в требуемое положение.

Предварительный масштаб по оси Y: Ввести ненулевое значение

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, указать точку, задать опцию или нажать ENTER

Описание опций "Масштаб по Х", "Угол" и "XYZ" совпадает с описанием соответствующих опций команды "Повернуть".

ПZ

Задание временного масштабного коэффициента по оси Z для управления изображением WMF-файла при его перемещении в требуемое положение.

Предварительный масштаб по оси Z: Ввести ненулевое значение

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, указать точку, задать опцию или нажать ENTER

Описание опций "Масштаб по Х", "Угол" и "XYZ" совпадает с описанием соответствующих опций команды "Повернуть".

ППоворот

Задание угла поворота изображения WMF-файла при его перемещении в требуемое положение.

Предварительный угол поворота:

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, указать точку, задать опцию или нажать ENTER

Описание опций "Масштаб по Х", "Угол" и "XYZ" совпадает с описанием соответствующих опций команды "Повернуть".


ИМПОРТПЛ Команда

И Команды
И Команды
ИМПОРТПЛ Команда
Понятия Процедуры Команды

Импорт набора параметров листа из другого файла чертежа во вновь создаваемый лист

Ввод команды: импортпл

Отобразится диалоговое окно "Выбор набора параметров листа из файла" (стандартное окно выбора файлов), в котором можно выбрать чертеж (.dwg), шаблон (.dwt) или файл графического обмена (.dxf), параметры страниц которого необходимо импортировать.

Если системная переменная FILEDIA равна 0 (нулю) и по запросу "Команда:" вводится -импортпл, команда ИМПОРТПЛ отображает запросы в командной строке.

После того, как чертеж выбран, появляется диалоговое окно "Импорт параметров листа".

Темы:

  • Командная строка ИМПОРТПЛ


Командная строка ИМПОРТПЛ

И Команды
И Команды
Командная строка ИМПОРТПЛ
Понятия Процедуры Команды

Если по запросу "Команда:" ввести -импортпл, команда ИМПОРТПЛ отображает запросы в командной строке.

Введите имя файла:

Имя пользовательского набора параметров листа для импорта или [?]:


ИМПОРТТЕЛ Команда

И Команды
И Команды
ИМПОРТТЕЛ Команда
Понятия Процедуры Команды

Импортирует файлы формата ACIS и создает в чертеже соответствующие объекты: тела ACIS, 3D тела и области.

Меню "Вставить": файл ACIS

Ввод команды: импорттел

Отобразится диалоговое окно "Выбор файла ACIS" В списке "Имя файла" следует выбрать файл для импорта. Файл СБ ACIS (ASCII) импортируется в чертеж.


ИНСТРПАЛВКЛ Команда

И Команды
И Команды
ИНСТРПАЛВКЛ Команда
Понятия Процедуры Команды

Открытие окна инструментальных палитр

Панель "Стандартная":

Меню "Инструменты": "Палитры" » "Инструментальные палитры"

Ввод команды: инстрпалвкл

Инструментальные палитры позволяют объединять блоки, образцы штриховок и пользовательские инструменты в легко доступных окнах. Параметры настройки инструментальных палитр могут быть изменены с помощью контекстных меню. Следует отметить, что вид контекстных меню зависит от того, в какой области инструментальной палитры нажать правую кнопку мыши. Функции этих контекстных меню приведены ниже

Примечание Инструментальные палитры можно использовать только в той версии программы, в которой они были созданы. Например, инструментальную палитру, созданную в AutoCAD 2007 нельзя использовать в AutoCAD 2005.

Добавить текст

Вставка рамки для ввода текста в точке расположения курсора; для упрощения организации содержимого палитры к тексту можно добавить метку.

Добавить разделитель

Добавление разделительной линии инструментальных палитр в точке расположения курсора.

Все палитры

Отображение всех вкладок инструментальных палитр в окне палитр.

Разрешить закрепление

Переключение режимов закрепления/привязки окон палитр. Если эта функция выбрана, перетаскивая окно в зону закрепления, можно закрепить его на границе чертежа. Закрепленное окно примыкает к границе окна приложения и приводит к изменению размера области рисования. После выбора этой функции также можно выполнять привязку справа и слева. Для отмены закрепления следует снять этот флажок.

Привязка слева / Привязка справа

Прикрепление палитры к основанию вкладки на левой или правой границе области рисования. Привязанная палитра развертывается/свертывается при наведении/снятии с нее курсора. Когда привязанная палитра развернута, ее содержимое перекрывает область рисования. Привязанную палитру нельзя настроить таким образом, чтобы она постоянно находилась в развернутом состоянии.

Автоматически убирать с экрана

Параметр, задающий режим развертывания/свертывания плавающего окна при наведении/снятии с него курсора. Если убрать этот флажок, инструментальная палитра со всем ее содержимым будет развернута постоянно.

Закрыть

Закрытие окна инструментальных палитр.

Копировать

Копирование выбранного инструмента в буфер обмена.

Настроить команды

Вызов диалогового окна "Настройка интерфейса пользователя".

Настроить палитры

Вызов диалогового окна "Настройка".

Вырезать

Удаление выбранного инструмента из инструментальной палитры и помещение его в буфер обмена.

Удалить

Удаление выбранного инструмента из инструментальной палитры.

Удалить палитру

Удаление текущей палитры.

Динамические блоки

Отображение вкладок палитры, содержащих динамические блоки.

Переместить

Курсор принимает форму четырех указывающих в разные направления стрелок.

Вверх

Перемещение выбранной инструментальной палитры на одну позицию вверх.

Вниз

Перемещение выбранной инструментальной палитры на одну позицию вниз.

Создать палитру

Создание новой палитры. Следует ввести имя или нажать ENTER, чтобы использовать имя по умолчанию.

Вставить

Вставка инструмента из буфера обмена на текущую вкладку.

Свойства

Вызов диалогового окна "Свойства инструмента", в котором можно изменить свойства выбранного инструмента.

Переименовать

Переименование выбранного инструмента.

Переименовать палитру

Переименование текущей палитры.

Образцы

Отображение образцов инструментальных палитр.

Сортировать по

Задание способа сортировки содержимого палитры - по имени или по типу.

Размер

Курсор принимает форму четырех указывающих в разные направления стрелок. Для изменения размера инструментальной палитры следует захватить ее правый или нижний край, а затем растянуть.

Прозрачность

Вызов диалогового окна "Прозрачность".

Параметры отображения

Вызов диалогового окна "Параметры отображения", в котором можно задать параметры отображения инструментов.

Темы:

  • Диалоговое окно "Параметры отображения"
  • Диалоговое окно "Свойства инструмента"
  • Диалоговое окно "Добавление операций"


Диалоговое окно "Параметры отображения"

И Команды
И Команды
Диалоговое окно "Параметры отображения"
Понятия Процедуры Команды

Контекстное меню: Нажмите правой кнопкой мыши в пустой области или на вкладке инструментальной палитры и выберите "Параметры отображения".

Управление отображением инструментов на текущей или на всех инструментальных палитрах.

Размер изображения

Управление размером значков инструментов выбранной инструментальной палитры.

Вид

Управление отображением текста для значков инструментов.

Только значки

Отображение только значков инструментов.

Значки и текст

Отображение значков с именами инструментов под ними.

Список

Отображение значков с именами инструментов справа.

Применить для

Применение параметров отображения для текущей инструментальной палитры или для всех инструментальных палитр окна.


Диалоговое окно "Свойства инструмента"

И Команды
И Команды
Диалоговое окно "Свойства инструмента"
Понятия Процедуры Команды

Контекстное меню: Нажмите правую кнопку мыши на инструменте палитры и выберите "Свойства объекта".

Управление свойствами выбранного инструмента. Типы отображаемых свойств зависят от типа выбранного инструмента.

Свойства инструмента материала отображаются в редакторе свойств инструмента материала. Эти же свойства отображаются на панели "Редактор материалов" диалогового окна "Материалы".

Значок

Отображение значка выбранного инструмента.

Название

Отображение имени выбранного инструмента.

Пояснение

Вывод описания выбранного инструмента.


Диалоговое окно "Добавление операций"

И Команды
И Команды
Диалоговое окно "Добавление операций"
Понятия Процедуры Команды

Добавление операций к параметру или набору параметров в окне "Палитры вариации блоков" на вкладке Редактор блоков.

Добавляемый объект операции

Задание операции для добавления к параметру или набору параметров.

Список объектов операций

Вывод списка операций, связанных с выбранным параметром или набором параметров.

Добавить

Добавление к параметру или набору параметров операции, указанной в окне "Добавляемый объект операции".

Удалить

Удаление выбранной операции из параметра или набора параметров.


ИНСТРПАЛОТКЛ Команда

И Команды
И Команды
ИНСТРПАЛОТКЛ Команда
Понятия Процедуры Команды

Закрытие окна инструментальных палитр

Меню "Сервис": "Инструментальные палитры"

Ввод команды: инстрпалоткл

Закрытие окна инструментальных палитр.


ИНФО Команда

И Команды
И Команды
ИНФО Команда
Понятия Процедуры Команды

Отображает информацию об AutoCAD

Меню "Справка": о программе

Ввод команды: инфо (или 'инфо для прозрачного вызова)

Отображаются сведения об авторских правах и информация о продукте. Информация включает в себя номер версии программы и пакета обновления, серийный номер, тип лицензии и срок ее действия. Пользователь также может вывести на экран текст лицензионного соглашения. Информацию о программе можно сохранить в текстовом файле.


К Команды
  • КОМСТРСКРЫТЬ
  • КАЛЬК
  • КАМЕРА
  • КБУФЕР
  • КЕМОТКРЫТ
  • КЛЕЙМО
  • КЛИН
  • КОЛЬЦО
  • КОМПИЛ
  • КОМСТР
  • КОНТУР
  • КОНУС
  • КООРД
  • КОПИРБАЗ
  • КОПИРВИД
  • КОПИРОВАТЬ
  • КОПИРОВАТЬСВ
  • КОПИРОВАТЬЯЧСВ
  • КОПИЯВСЛОЙ
  • КПРОТОКОЛ
  • КРОМКА
  • КРУГ
  • КТЕКСТ
  • КШТРИХ


КОМСТРСКРЫТЬ Команда

К Команды
К Команды
КОМСТРСКРЫТЬ Команда
Понятия Процедуры Команды

Скрывает командную строку

Меню "Инструменты": "Командная строка"

Ввод команды: комстрскрыть

Скрывает командную строку. Если окно командной строки скрыто, команды можно вводить, если динамические подсказки включены.


КАЛЬК Команда

К Команды
К Команды
КАЛЬК Команда
Понятия Процедуры Команды

Вычисление математических и геометрических выражений

Ввод команды: кальк (или 'кальк для прозрачного вызова)

Команда КАЛЬК является интерактивным геометрическим калькулятором, который вычисляет значения выражений точки (вектора), вещественных и целочисленных выражений. Аргументами выражений могут быть имеющиеся геометрические объекты; доступ к ним производится с помощью функций объектной привязки, таких как ЦЕН, КОН или ТВС.

В арифметическое выражение можно вставить переменные программы AutoLISP® и, наоборот, назначить значение выражения переменной программы AutoLISP.

Арифметические и векторные выражения можно использовать в любой команде, ожидающей ввода точки, вектора или числа.

Темы для команды КАЛЬК:

  • Сведения о синтаксисе выражений
  • Формат футов и дюймов
  • Формат углов
  • Использование точек и векторов
  • использование переменных AutoLISP
  • Использование системных переменных в вычислениях
  • Преобразование единиц измерения
  • Использование стандартных числовых функций
  • Вычисление вектора между двумя точками
  • Вычисление длины вектора
  • Получение координат указанной точки
  • Получение координат последней указанной точки
  • Использование режимов привязки в арифметических выражениях
  • Преобразование точек из ПСК в МСК и обратно
  • Вычисление точки на линии
  • Поворот точки вокруг оси
  • Определение точки пересечения
  • Вычисление расстояния
  • Вычисление радиуса
  • Вычисление угла
  • Вычисление вектора нормали
  • Использование функций в сокращенном виде

Темы:

  • Сведения о синтаксисе выражений
  • Формат футов и дюймов
  • Формат углов
  • Использование точек и векторов
  • использование переменных AutoLISP
  • Использование системных переменных в вычислениях
  • Преобразование единиц измерения
  • Использование стандартных числовых функций
  • Вычисление вектора между двумя точками
  • Вычисление длины вектора
  • Получение координат указанной точки
  • Получение координат последней указанной точки
  • Использование режимов привязки в арифметических выражениях
  • Преобразование точек из ПСК в МСК и обратно
  • Вычисление точки на линии
  • Поворот точки вокруг оси
  • Определение точки пересечения
  • Вычисление расстояния
  • Вычисление радиуса
  • Вычисление угла
  • Вычисление вектора нормали
  • Использование функций в сокращенном виде


Сведения о синтаксисе выражений

К Команды
К Команды
Сведения о синтаксисе выражений
Понятия Процедуры Команды

При вычислении выражений с помощью команды КАЛЬК используются стандартные правила приоритета выполнения арифметических операций:

  • Вычисляются выражения в скобках, начиная со скобок максимальной вложенности
  • Выполняются операции в стандартной последовательности: вначале возведение в степень, затем умножение и деление, затем сложение и вычитание
  • Операции с равными приоритетами выполняются слева направо
Числовые выражения

Числовые выражения строятся из целых и вещественных чисел и функций, соединенных следующими операторами:

Операторы для числовых выражений
Оператор | Операция
( ) | группирование выражений
^ | Возведение в степень
* , / | Умножение и деление
+, - | Сложение и вычитание

Вот примеры числовых выражений:

3

3 + 0.6

(5.8^2) + PI

Векторные выражения

Векторные выражения строятся из точек, векторов, чисел и функций, соединенных следующими операторами:

Операторы для векторных выражений
Оператор | Операция
( ) | группирование выражений
& | Векторное произведение векторов (вектор) [a,b,c]&[x,y,z] = [ (b*z) - (c*y) , (c*x) - (a*z) , (a*y) - (b*x) ]
* | Скалярное произведение векторов (вещественное число) [a,b,c]*[x,y,z] = ax + by + cz
*, / | Умножение и деление вектора на вещественное число a*[x,y,z] = [a*x,a*y,a*z]
+ , - | Сложение и вычитание векторов (точек) [a,b,c] + [x,y,z] = [a+x,b+y,c+z]

Вот примеры векторных выражений:

A+[1,2,3] представляет собой точку, расположенную в [1,2,3] единицах относительно точки A.

В выражении:

[2<45<45] + [2<45<0] - [1.02, 3.5, 2]

производится сложение двух точек и вычитание третьей. Первые две точки заданы сферическими координатами.


Формат футов и дюймов

К Команды
К Команды
Формат футов и дюймов
Понятия Процедуры Команды

Величины футов и дюймов вводятся в следующем формате:

футы'-дюймы" или футы' дюймы" или футы'дюймы"

Футы, дюймы и дробные значения дюймов можно отделять с помощью тире, пробела, либо можно вообще ничего не использовать. Для ввода допустимых значений в формате футов/дюймов можно пользоваться любыми из указанных вариантов синтаксиса:

  • 5' или 60”
  • 5'-9” или 5' 9” или 5'9”
  • 5'-1/2” или 5' 1/2” или 5'1/2”
  • 5'-9-1/2” или 5' 9-1/2” или 5'9-1/2”
  • 5'-9 1/2” или 5' 9 1/2” или 5'9 1/2”

для обозначения дюймов для линейных вычислений вводить двойные кавычки (“) не обязательно. Например, вместо того, чтобы вводить 5'9-1/2” можно ввести 5'9-1/2.

Предупреждение При использовании британских единиц КАЛЬК интерпретирует минус или тире (-) не как операцию вычитания, а как разделитель единиц. Для обозначения вычитания вставляйте хотя бы один пробел до или после знака минуса. Например, чтобы вычесть 9” из 5', ввести 5' -9”, а не 5'-9”.


Формат углов

К Команды
К Команды
Формат углов
Понятия Процедуры Команды

По умолчанию единицей измерения углов являются десятичные градусы. При вводе углов используется следующий формат:

<градусы>d<минуты>'<секунды>”

Если вводимый угол меньше 1 градуса (отличны от нуля только минуты и секунды), необходимо начинать значение угла с 0d. Нулевые значения минут и секунд можно опускать.

Если вводимый угол выражен в радианах, за его значением должен следовать символ r. Если вводимый угол выражен в градах, за его значением должен следовать символ g.

В следующих примерах проиллюстрированы способы ввода значений углов:

5d10'20"

0d10'20"

124.6r

14g

Углы, введенные в любом формате, преобразуются в десятичные градусы.

Pi радиан равно 180 градусам; 100 градов равно 90 градусам.


Использование точек и векторов

К Команды
К Команды
Использование точек и векторов
Понятия Процедуры Команды

Как точки, так и векторы представляют собой пары или тройки вещественных чисел. Точка определяет положение в пространстве, а вектор определяет направление в пространстве (или перенос).

Некоторые функции команды КАЛЬК, такие как pld и plt, возвращают точку. Имеются также функции (nor, vec и др.), возвращающие вектор.

Форматы точек и векторов

Точки и векторы представляют собой наборы из трех вещественных выражений, заключенных в скобки ([ ]): [r1,r2,r3]

Обозначения p1, p2 и т.д. относятся к точкам; обозначения v1, v2 и т.д. к векторам. На чертежах точки изображаются в виде объектов-точек, а векторы — в виде отрезков со стрелками на концах.

Команда КАЛЬК поддерживает представление точек во всех форматах.

Форматы точек
Система координат | Формат точек
Полярная | [расстояние<угол]
Цилиндрическая | [расстояние<угол,z]
Сферическая | [расстояние<угол1<угол2]
Относительная | Использует префикс @ [@x,y,z]
МСК (подменяющая ПСК) | Использует префикс * [*x,y,z]

Можно опускать следующие компоненты точки или вектора: нулевые координаты и запятые, следующие непосредственно перед закрывающей скобкой (]).

Вот примеры корректного задания точек:

[1,2] соответствует [1,2,0]

[,,3] соответствует [0,0,3]

[ ] соответствует [0,0,0]

В следующем примере точка задается в относительной сферической системе координат в МСК. Длина радиус-вектора равна 1+2=3; углы равны 10+20=30 градусов и 45 градусов 20 минут.

[@*1+2<10+20<45d20"]

В следующем примере задается корректная точка, компонентами которой служат арифметические выражения:

[2*(1.0+3.3),0.4-1.1,2*1.4]

В следующем примере для вычисления точки с заданным смещением от конца выбранного объекта используется функция объектной привязки кон (конечная точка) и вектор [2,0,3]:

конечная + [2,,3]

Вычисленная точка лежит на расстоянии в 2 единицы по оси X и в 3 единицы по оси Z от конечной точки выбранного объекта.


использование переменных AutoLISP

К Команды
К Команды
использование переменных AutoLISP
Понятия Процедуры Команды

В арифметических выражениях можно использовать переменные AutoLISP. Переменные должны принадлежать к одному из следующих типов: вещественные, целые, двумерные и трехмерные точки (векторы).

В следующем примере определяется точка, отстоящая на 5 единиц по оси X и на 1 единицу по оси Y от точки, хранящейся в переменной A AutoLISP.

A+[5,1]

При вводе переменной программы AutoLISP, имя которой содержит символ, имеющий специальное значение в команде КАЛЬК (например, +, -, * или /), следует заключить имя переменной в апострофы ('), например:

'количество-отверстий'

Присвоение значений переменным AutoLISP

Для присвоения значения переменной AutoLISP перед арифметическим выражением нужно поставить имя переменной и знак равенства (=). Это значение можно использовать в последующих вычислениях.

В следующем примере показано сохранение значений выражений в переменных AutoLISP P1 и R1.

Команда: кальк

>> Выражение: P1=цен+[1,0]

>> Выбрать объект для привязки ЦЕН: Выбрать дугу или круг

Команда: кальк

>> Выражение: R1=расстоян(кон,кон)/3

>> Выбрать объект для привязки END: Выбрать объект, имеющий конечную точку

В следующем примере используются значения, присвоенные переменным P1 и R1:

Команда: круг

Центр круга или [3Т/2Т/Ккр (кас кас радиус)]: 'кальк

>> Выражение: P1+[0,1]

Радиус круга или [Диаметр] <последний>: 'кальк

>> Выражение: R1+0.5


Использование системных переменных в вычислениях

К Команды
К Команды
Использование системных переменных в вычислениях
Понятия Процедуры Команды

Для чтения значений системных переменных можно воспользоваться функцией getvar.

Синтаксис:

getvar (имя_переменной)

В следующем примере функция getvar используется для получения точки, являющейся центром вида в текущей ПСК.

getvar(viewctr)

С помощью этого метода можно также получить доступ к системным переменным пользователя USERI1-5 и USERR1-5. Например, для извлечения значения, содержащегося в переменной USERR2, ввести следующее:

getvar(userr2)


Преобразование единиц измерения

К Команды
К Команды
Преобразование единиц измерения
Понятия Процедуры Команды

Преобразование чисел и точек из одних единиц измерения в другие осуществляется функцией cvunit. Список единиц, доступных для преобразования, приведен в файле acad.unt. Синтаксис:

cvunit(значение,единицы_из, единицы_в)

В следующем примере производится преобразование числа 1 из дюймов в сантиметры:

cvunit(1,дюйм,см)


Использование стандартных числовых функций

К Команды
К Команды
Использование стандартных числовых функций
Понятия Процедуры Команды

Команда КАЛЬК поддерживает стандартные числовые функции, перечень которых приведен в следующей таблице.

Числовые функции
Назначение | Описание
sin(угол) | Синус угла
cos(угол) | Косинус угла
tang(угол) | Тангенс угла
asin(веществ) | Арксинус числа; значение аргумента должно быть в пределах от -1 до 1
acos(веществ) | Арккосинус числа; значение аргумента должно быть в пределах от -1 до 1
atan(веществ) | Арктангенс числа
ln(веществ) | Натуральный логарифм числа
log(веществ) | Десятичный логарифм числа
exp(веществ) | Натуральная экспонента числа
exp10(веществ) | Десятичная экспонента числа
sqr(веществ) | Квадрат числа
sqrt(веществ) | Квадратный корень числа (неотрицательного)
abs(веществ) | Абсолютная величина числа
round(веществ) | Число, округленное до ближайшего целого
trunc(веществ) | Целая часть числа
r2d(угол) | Преобразование угла из радиан в градусы. Например, r2d(pi) преобразует pi радиан в 180 градусов
d2r(угол) | Преобразование угла из градусов в радианы. Например, d2r(180) преобразует угол 180 градусов в радианы и возвращает значение, равное константе pi
pi | Константа "пи"


Вычисление вектора между двумя точками

К Команды
К Команды
Вычисление вектора между двумя точками
Понятия Процедуры Команды

Вычисление вектора между двумя точками производят функции vec и vec1.

vec(p1,p2)

Возвращает вектор от точки p1 к точке p2

vec1(p1,p2)

Возвращает единичный вектор в направлении от точки p1 к точке p2

В следующем примере показано использование команды КАЛЬК для перемещения выбранных объектов на 3 единицы от центра одного из выбранных кругов к центру другого:

Команда: перенести

Выберите объекты

Базовая точка или перемещение: 'кальк

>> Выражение: 3*vec1(цен,цен)

Выбрать объект для привязки ЦЕН: Выбрать дугу или окружность

Указать вторую точку смещения или <использовать первую точку в качестве смещения>: Указать точку или нажать ENTER

Следующие примеры иллюстрируют смысл вычислений векторов и точек:

Примеры вычисления векторов и точек
Выражение | Расшифровка
vec(a,b) | Определяет вектор перемещения от точки a к точке b.
vec1(a,b) | Определяет единичный вектор перемещения от точки a к точке b.
L*vec1(a,b) | Определяет вектор длиной L, направленный от точки a к точке b.
a+v | Определяет точку b, являющуюся результатом перемещения из точки a на вектор v.
a+[5<20] | Определяет точку b, расположенную на расстоянии 5 единиц от точки a под углом 20 градусов. Заметим, что запись [5<20] описывает вектор в полярных координатах.


Вычисление длины вектора

К Команды
К Команды
Вычисление длины вектора
Понятия Процедуры Команды

Вычисление длины вектора производится функцией abs.

abs(v)

Вычисляет длину вектора v в виде неотрицательного вещественного числа.

В сферических координатах (расстоян<угол<угол) длина вектора это расстоян.

В следующем примере вычисляется длина вектора [1,2,3]:

abs([1,2,3])


Получение координат указанной точки

К Команды
К Команды
Получение координат указанной точки
Понятия Процедуры Команды

Ввод точки с помощью устройства указания осуществляется функцией cur. Программа предлагает указать точку, координаты которой требуется использовать в выражении. Значения координат отсчитываются в текущей ПСК. Функция cur изменяет значение системной переменной LASTPOINT.

В следующем примере показано добавление вектора [3.6,2.4,0]—результата умножения 1.2*[3,2]— к выбранной пользователем точке. Это выражение вычисляет значение точки, смещенной относительно выбранной.

cur+1.2*[3,2]


Получение координат последней указанной точки

К Команды
К Команды
Получение координат последней указанной точки
Понятия Процедуры Команды

С помощью символа @ в выражении можно получить координаты последней введенной точки. Рассмотрим следующий пример:

Команда: отрезок

Первая точка: 'кальк

>> Выражение: цен+[0,1]

>> Выбрать объект для привязки ЦЕН: Выбрать дугу или окружность

Следующая точка или [Замкнуть/Отменить]: 'кальк

>> Выражение: @+3*vec1(цен,цен)

Первая точка отрезка смещена на 1 единицу вдоль оси Y от центра первого из выбранных кругов. Вторая точка отрезка отстоит от первой на 3 единицы. Направление от первой точки ко второй совпадает с направлением от центра первого из выбранных кругов к центру второго.


Использование режимов привязки в арифметических выражениях

К Команды
К Команды
Использование режимов привязки в арифметических выражениях
Понятия Процедуры Команды

Элементами арифметических выражений могут быть режимы привязки. Программа предлагает выбрать объект и возвращает координаты соответствующей точки привязки. Применение режимов привязки в арифметических выражениях заметно упрощает ввод координат, связанных с имеющимися объектами.

При работе с режимами привязки вводятся только три первых буквы названия режима. Например, для указании функции привязки к центру нужно ввести cen. Режимы привязки команды КАЛЬК устанавливают значение системной переменной LASTPOINT

Режимы привязки для КАЛЬК
Сокращение | Привязка (режим)
КОН | КОНТОЧКА
ТВС | ВСТАВИТЬ
ПЕР | ПЕРЕСЕЧЕНИЕ
СЕР | СЕРЕДИНА
ЦЕН | ЦЕНТР
БЛИ | БЛИЖАЙШАЯ
УЗЕ | УЗЕЛ
КВА | КВАДРАНТ
НОР | НОРМАЛЬ
КАС | КАСАТЕЛЬНАЯ

В следующем примере показано использование режимов привязки по центру и по конечной точке в выражении команды КАЛЬК:

(цен+кон)/2

Команда КАЛЬК выдает подсказку, указать окружность или дугу и объект. После этого вычисляется середина отрезка между центром окружности (дуги) и концом второго выбранного объекта.

В следующем примере показано, как в режиме привязки по средней точке (Середина) команда КАЛЬК выдает подсказку указать объект и возвращает точку, смещенную на 1 единицу вдоль оси Y от середины выбранного объекта:

сер+[,1]

В следующем примере для вычисления центра треугольника по трем конечным точкам его сторон использован режим привязки "Конточка":

(кон+кон+кон)/3


Преобразование точек из ПСК в МСК и обратно

К Команды
К Команды
Преобразование точек из ПСК в МСК и обратно
Понятия Процедуры Команды

Обычно подразумевается, что все координаты в программе выражены в текущей ПСК. Следующие функции производят пересчет координат между ПСК и МСК.

w2u(p1)

Преобразование координат точки p1 из МСК в текущую ПСК.

u2w(p1)

Преобразование координат точки p1 из текущей ПСК в МСК.

Функцию w2u, например, можно использовать для нахождения координат точки начала МСК в текущей ПСК:

w2u([0,0,0])

Фильтрация координат X, Y, Z точки или вектора

Следующие функции выполняют фильтрацию координат X, Y и Z точки или вектора:

Функции фильтрации координат
Назначение | Описание
xyof(p1) | X и Y координаты точки. Координате Z присваивается 0.0
xzof(p1) | X и Z координаты точки. Координате Y присваивается 0.0
yzof(p1) | Y и Z координаты точки. Координате X присваивается 0.0
xof(p1) | X координата точки. Координатам Y и Z присваивается 0.0
yof(p1) | Y координата точки. Координатам X и Z присваивается 0.0
zof(p1) | Z координата точки. Координатам X и Y присваивается 0.0
rxof(p1) | X координата точки.
ryof(p1) | Y координата точки.
rzof(p1) | Z координата точки.

В следующем примере определяется координата Z точки, выраженной в сферических координатах:

zof([2<45<45])

В следующем примере новая точка получает координаты X и Y точки a и координату Z точки b:

xyof(a)+zof(b)


Вычисление точки на линии

К Команды
К Команды
Вычисление точки на линии
Понятия Процедуры Команды

Для определения координат точки на заданном отрезке служат функции plt и pld. Положение точки на отрезке может быть задано либо расстоянием от первой точки, либо параметрически с использованием параметра t.

pld(p1,p2,расстояние)

Определяет координаты точки на отрезке, соединяющем точки p1 и p2. Параметр расстояние задает расстояние от искомой точки до точки p1.

plt(p1,p2,t)

Определяет координаты точки на отрезке, соединяющем точки p1 и p2. Параметр t задает относительное положение точки на отрезке.

Вот несколько примеров значений параметра t:

Если t=0, точка совпадает с p1

Если t=0,5, точка лежит посредине отрезка, соединяющего p1 и p2

Если t=1, точка совпадает с p2


Поворот точки вокруг оси

К Команды
К Команды
Поворот точки вокруг оси
Понятия Процедуры Команды

Координаты точки, полученной в результате поворота исходной точки вокруг оси, определяются функцией rot.

rot(p,центр,угол)

Поворот точки p на угол угол вокруг оси, параллельной оси Z и проходящей через точку центр:

rot(p,т_оси1,т_оси2,угол)

Поворот точки p на угол угол вокруг оси, проходящей через точки т_оси1 и т_оси2. Направление оси — от первой точки ко второй.


Определение точки пересечения

К Команды
К Команды
Определение точки пересечения
Понятия Процедуры Команды

Для определения точек пересечения служат функции ill и ilp.

ill(p1,p2,p3,p4)

Определение координат точки пересечения двух линий: (p1,p2) и (p3,p4). Все точки считаются трехмерными.

ilp(p1,p2,p3,p4,p5)

Определение координат точки пересечения линии (p1,p2) и плоскости, проходящей через три точки (p3,p4,p5).


Вычисление расстояния

К Команды
К Команды
Вычисление расстояния
Понятия Процедуры Команды

расстоян(p1,p2)

Определение расстояния между точками p1 и p2. Это аналогично векторному выражению abs(p1-p2).

dpl(p,p1,p2)

Определение кратчайшего расстояния от точки p до линии, проходящей через точки p1 и p2.

dpp(p,p1,p2,p3)

Определение расстояния от точки p до плоскости, проходящей через три точки (p1,p2,p3).

расстоян(p1,p2)

Определение расстояния между точками p1 и p2. Это аналогично векторному выражению abs(p1-p2).

В следующем примере определяется половина расстояния между центрами двух выбранных объектов:

расстоян(цен,цен)/2

В следующем примере определяется расстояние от точки (3,2,4) до плоскости, проходящей через три выбранные конечные точки:

dpp([3,2,4],конечная, конечная, конечная)


Вычисление радиуса

К Команды
К Команды
Вычисление радиуса
Понятия Процедуры Команды

Определение радиуса выбранного объекта выполняет функция rad.

rad

Определение радиуса выбранного объекта. Объект может быть кругом, дугой или дуговым сегментом двумерной полилинии.

В следующем примере функция rad используется в команде КРУГ. Радиус нового круга составляет две трети радиуса выбранного дугового сегмента полилинии:

Команда: круг

Центр круга или [3Т/2Т/ККР (кас кас радиус)]: цен

Выбрать круг

Радиус круга или [Диаметр] <последн>: 'cal

>> Выражение: 2/3*rad

>> Выбрать круг, дугу или сегмент полилинии для функции RAD: Выбрать круг


Вычисление угла

К Команды
К Команды
Вычисление угла
Понятия Процедуры Команды

Угол между двумя линиями можно получить с помощью функции ang. Углы измеряются против часовой стрелки относительно оси X (для двумерных объектов) или оси, заданной пользователем (для трехмерных объектов).

ang(v)

Определение угла между осью X и вектором v. Вектор v считается двумерным, спроецированным на плоскость XY текущей ПСК.

ang(p1,p2)

Определение угла между осью X и отрезком (p1,p2), ориентированным от p1 к p2. Точки считаются двумерными, спроецированными на плоскость XY текущей ПСК.

ang(вершина,p1,p2)

Определение угла между отрезками (вершина,p1) и (вершина,p2). Точки считаются двумерными, спроецированными на плоскость XY текущей ПСК.

ang(вершина,p1,p2,p)

Определение угла между отрезками (вершина,p1) и (вершина,p2). В отличие от предыдущего варианта, отрезки считаются трехмерными. Последний параметр, точка p, используется для задания ориентации угла. Угол измеряется против часовой стрелки относительно оси, направленной из точки вершина в точку p.

На следующих чертежах проиллюстрированы примеры измерения углов:

С помощью функции ang можно найти угол между двумя сторонами треугольника, как показано в следующем примере:

Команда: кальк

>> Выражение: ang(кон,кон,кон)

Сначала нужно выбрать вершину искомого угла, а затем — противоположные ей вершины треугольника.


Вычисление вектора нормали

К Команды
К Команды
Вычисление вектора нормали
Понятия Процедуры Команды

Для определения единичного вектора нормали (т.е. вектора, перпендикулярного отрезку или плоскости) служит функция nor. Результат функции nor единичный вектор, а не точка. Этот вектор задает направление нормали, а не ее положение в пространстве. Для получения координат конца вектора нормали, исходящего из какой-либо точки, нужно сложить эти точку и вектор.

nor

Определение трехмерного единичного вектора нормали к выбранному кругу, дуге или дуговому сегменту полилинии. Направление вектора нормали совпадает с осью Z объектной системы координат (ОСК) данного объекта.

nor(v)

Определение двумерного единичного вектора нормали к вектору v. Оба вектора считаются двумерными, спроецированными на плоскость XY текущей ПСК. Ориентация вектора нормали такова, что он указывает влево от исходного вектора v.

nor(p1,p2)

Определение двумерного единичного вектора нормали к отрезку (p1,p2). Отрезок считается направленным от p1 к p2. Ориентация вектора нормали такова, что он указывает влево от исходного отрезка (p1,p2).

nor(p1,p2,p3)

Определение трехмерного единичного вектора нормали к плоскости, проходящей через три точки p1, p2 и p3. Ориентация вектора нормали такова, что при взгляде в направлении вектора три точки расположены против часовой стрелки.

На следующих чертежах проиллюстрированы примеры определения векторов нормалей:

В следующем примере производится установка направления взгляда перпендикулярно выбранному объекту. В программе объект отображается в плане и не искажен параллельной проекцией.

Команда: тзрения

Текущее направление взгляда: VIEWDIR=текущее

Задать точку зрения или [Повернуть] <компас и тройка осей>: 'кальк

>> Выражение: nor

>> Выбрать круг, дугу или полилинию для функции NOR:


Использование функций в сокращенном виде

К Команды
К Команды
Использование функций в сокращенном виде
Понятия Процедуры Команды

Приведенные в следующей таблице функции являются сокращениями для часто используемых выражений. Они представляют собой комбинации некоторых из уже рассмотренных функций и режима привязки "Конточка".

Функции в сокращенном виде
Назначение | Полная форма | Описание
dee | расстоян(кон,кон) | Расстояние между двумя конечными точками
ille | ill(кон,кон,кон,кон) | Пересечение двух линий, проведенных через четыре конечные точки
mee | (кон+кон)/2 | Середина отрезка, соединяющего две конечные точки
nee | nor(кон,кон) | Единичный вектор в плоскости XY, нормальный к двум конечным точкам
pldee (d) | pld(d,кон,кон) | Указывает на отрезок на прямой, ограниченный двумя конечными точками (см. pld)
pltee (t) | plt(t,кон,кон) | Указывает на параметрический отрезок на прямой, ограниченный двумя конечными точками (см. plt)
vee | vec(кон,кон) | Вектор от одной конечной точки к другой
vee1 | vec1(кон,кон) | Единичный вектор в направлении от одной конечной точки к другой


КАМЕРА Команда

К Команды
К Команды
КАМЕРА Команда
Понятия Процедуры Команды

Устанавливает камеру и положение цели для создания и сохранения 3D вида объектов в перспективе

Панель "Вид":

Ввод команды: камера

Текущие установки камеры: высота=<текущая> фокусное расстояние=< текущее>

Указать положение камеры <текущее>: Ввести значение или указать точку

Устанавливает точку, из которой пользователь видит объекты в модели.

Указать положение цели: Ввести значение или указать точку

Устанавливает положение цели объектива камеры.

Задать опцию [?/Имя/Положение/Высота/Цель/Объектив/Секущие плоскости/Вид/<Выход>]:

?—Вывести список камер

Выводит на экран список определенных в настоящее время камер.

Ввести имя(имена) камеры в список <*>: Ввести список имен или нажать Enter, чтобы вывести список всех камер.

Имя

Присваивает камере имя.

Ввести имя новой камеры <Camera1>:

Местоположение

Указывает положение камеры.

Задать положение камеры <текущее>:

Высота

Изменяет высоту камеры.

Задать высоту камеры <текущую>:

Цель

Указывает целевой объект камеры.

Задать целевой объект камеры <текущий>:

Объектив

Изменяет фокусное расстояние камеры.

Задать фокусное расстояние в мм <текущее>:

Секущие плоскости

Определяет переднюю и заднюю секущие плоскости и устанавливает их значения.

Включить переднюю секущую плоскость? [Да/Нет] <Нет>: Указать "Да", чтобы включить переднюю секущую плоскость

Задать смещение передней секущей плоскости от целевой плоскости <текущее>: Ввести величину смещения

Включить заднюю секущую плоскость? <Да/Нет] <Нет>: Указать "Да", чтобы включить заднюю секущую плоскость

Задать смещение задней секущей плоскости от целевой плоскости <текущее>: Ввести величину смещения

Вид

Устанавливает текущий вид в соответствии с установками камеры

Переключить вид камеры? [Да/Нет] <Нет >:

Выход

Прерывание команды.

Темы:

  • Диалоговое окно "Предварительный просмотр камеры"


Диалоговое окно "Предварительный просмотр камеры"

К Команды
К Команды
Диалоговое окно "Предварительный просмотр камеры"
Понятия Процедуры Команды

Выводит на экран предварительный образец вида камеры.

Образец

Позволяет предварительно просмотреть образец вида камеры, заданный командой КАМЕРА.

Стиль отображения

Задает стиль отображения, применяемый к предварительному образцу вида камеры.

Открыть данное диалоговое окно при редактировании установок камеры

Указывает, что при редактировании установок камеры выводится диалоговое окно "Предварительный просмотр камеры".


КБУФЕР Команда

К Команды
К Команды
КБУФЕР Команда
Понятия Процедуры Команды

Копирует объекты или текст из командной строки в буфер обмена

Панель "Стандартная":

Меню "Правка": "Копировать"

Контекстное меню: Завершить выполнение активных команд, щелкнуть правой кнопкой мыши в области рисования и выбрать "Копировать".

Ввод команды: кбуфер

Выбрать объекты:

Команда КБУФЕР копирует все выбранные объекты в буфер обмена. Содержимое буфера обмена может быть вставлено в документ или чертеж как OLE-объект.

Примечание Вызов команды КБУФЕР может быть осуществлен комбинацией клавиш CTRL+C. Если курсор находится в области рисования, выбранные объекты копируются в буфер обмена. Если курсор находится в командной строке или в текстовом окне, выбранный текст копируется в буфер обмена.


КЕМОТКРЫТ Команда

К Команды
К Команды
КЕМОТКРЫТ Команда
Понятия Процедуры Команды

Вывод информации о том, кем открыт тот или иной файл чертежа

Ввод команды: кемоткрыт

Команда КЕМОТКРЫТ позволяет отслеживать пользователей, работающих в данный момент с тем или иным файлом чертежа.

Команда КЕМОТКРЫТ вызывает диалоговое окно "Выбор запрашиваемого чертежа" (стандартное диалоговое окно выбора файлов). После выбора файла в командной строке отображается информация о текущем владельце чертежа. Эта информация включает в себя имя компьютера пользователя, открывшего данный чертеж, имя, под которым пользователь вошел в систему, полный путь к компьютеру в сети (если возможно), а также дату и время открытия файла.

Примечание Аналогичная информация автоматически отображается при попытке открытия файла, уже загруженного другим пользователем.

Информация, выводимая командой КЕМОТКРЫТ, хранится во временном файле блокировки чертежа (DWL). DWL-файл создается автоматически при открытии файла чертежа и удаляется при его закрытии.


КЛЕЙМО Команда

К Команды
К Команды
КЛЕЙМО Команда
Понятия Процедуры Команды

Клеймение грани 3D тела

Меню "Редактирование": "Редактирование тела" » "Клеймить ребра"

Ввод команды: клеймить

Пульт управления: Панель создания 3D объектов, Клеймить

Клеймение выбранного тела другим объектом. Для того, чтобы операция была успешной, необходимо наличие пересечения клеймящего объекта и грани (граней) выбранного тела. Клеймение может быть применено к следующим объектам: дуги, круги, отрезки, 2D и 3D полилинии, эллипсы, сплайны, области, тела и 3D тела.

Выберите 3D тело: Выбрать объект (1)

Выберите клеймящий объект: Выбрать объект (2)

Удаление исходного объекта <Н>: Введите д или нажмите ENTER

Выберите клеймящий объект: Выберите объект или нажмите ENTER


КЛИН Команда

К Команды
К Команды
КЛИН Команда
Понятия Процедуры Команды

Построение трехмерного пятигранного тела с наклонной гранью, приближающейся к оси X.

Панель "Моделирование":

Меню "Рисование": "Моделирование" » "Клин"

Ввод команды: клин

Пульт управления: Панель создания 3D объектов, Клин

Первый угол или {Центр]: Указать точку или ввести ц для задания центра

Другой угол или [Куб/Длина]: Указать второй угол клина или задать опцию

Если для второго угла клина задано значение Z, отличающееся от значения для первого угла, запрос на указание высоты не выводится.

Высота или [2Точки] <по умолчанию>: Указать высоту или задать опцию 2Т для двух точек

При вводе положительного значения высота отсчитывается в положительном направлении оси Z текущей ПСК. При вводе отрицательного значения высота отсчитывается в отрицательном направлении оси Z текущей ПСК.

Центр

Построение клина по указанной центральной точке.

Центр: Указать точку (1)

Угол или [Куб/Длина]: Указать точку или задать опцию

Высота или [2Точки] <по умолчанию>: Указать высоту или задать опцию 2Т для двух точек

Куб

Построение равностороннего клина.

Длина: Ввести значение или выбрать точку для задания длины и поворота клина в плоскости XY

Длина

Построение клина с заданными значениями длины, ширины и высоты. Длина соответствует оси X, ширина оси Y, а высота оси Z. Выбор точки для указания длины задает также вращение в плоскости XY, в которой выполняется поворот.

Длина: Ввести значение или выбрать точку для задания длины и поворота клина в плоскости XY

Ширина: Задать значение

Высота: Задать значение

Куб

Построение равностороннего клина.

Длина: Ввести значение или выбрать точку для задания длины и поворота клина в плоскости XY

Длина

Построение клина с заданными значениями длины, ширины и высоты. Длина соответствует оси X, ширина оси Y, а высота оси Z.

Длина: Ввести значение или выбрать точку для задания длины и поворота клина в плоскости XY

Ширина: Задать значение

Высота: Задать значение

2Точки

Указывает, что высотой клина является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку


КОЛЬЦО Команда

К Команды
К Команды
КОЛЬЦО Команда
Понятия Процедуры Команды

Построение закрашенных кругов и колец

Меню "Рисование": "Кольцо"

Ввод команды: кольцо

Задать внутренний диаметр кольца <текущий>: Задать расстояние или нажать клавишу ENTER

Если внутренний диаметр равен нулю, рисуется закрашенный круг.

Задать внешний диаметр кольца <текущий>: Задать расстояние или нажать клавишу ENTER

Центр кольца или <выход>: Указать точку (1) или нажать ENTER для завершения команды

Положение кольца определяется центральной точкой. После задания диаметров выводится запрос на определение места построения кольца. В каждой последующей указанной точке строится такое же кольцо (2). Закрашивание пространства внутри кольца определяется режимом, установленным командой ЗАКРАСКА.


КОМПИЛ Команда

К Команды
К Команды
КОМПИЛ Команда
Понятия Процедуры Команды

Компилирует файлы форм и файлы шрифтов PostScript в файлы SHX

Ввод команды: компил

Отобразится диалоговое окно "Выбор файла формы или шрифта" (стандартное окно выбора файлов). В нем необходимо выбрать SHP- или PFB-файл. Скомпилированному файлу будет присвоено это имя с расширением .shx.


КОМСТР Команда

К Команды
К Команды
КОМСТР Команда
Понятия Процедуры Команды

Отображает командную строку

Меню "Инструменты": "Командная строка"

Ввод команды: комстр

Отображает скрытую командную строку.


КОНТУР Команда

К Команды
К Команды
КОНТУР Команда
Понятия Процедуры Команды

Создание области или полилинии из замкнутого контура

Меню "Рисование": "Контур"

Ввод команды: контур

Откроется диалоговое окно "Создание контура".

Если в ответ на подсказку "Команда:" ввести -контур, то по команде КОНТУР будут выводиться подсказки в командной строке.

Темы:

  • Диалоговое окно "Создание контура"
  • КОНТУР вариант для командной строки


Диалоговое окно "Создание контура"

К Команды
К Команды
Диалоговое окно "Создание контура"
Понятия Процедуры Команды

Меню "Рисование": "Контур"

Ввод команды: контур

Определяет тип объекта, набор контуров и способ обнаружения островков для создания области или полилинии с помощью заданной точки в области, замкнутой объектами.

Указание точек

Создает контур из существующих объектов, образующих замкнутую область вокруг указанной точки.

Островки

Управляет обнаружением внутренних замкнутых контуров, называемых островками, командой КОНТУР.

Тип объекта

Определяет тип объекта для нового контура. Команда КОНТУР создает контур как объект области или полилинии.

Контур

Определяет набор объектов, анализируемых командой КОНТУР при определении контура из указанной точки.

Текущий видовой экран

Создает набор контуров из всех объектов, находящихся в границах текущего видового экрана. При выборе этого параметра отменяется текущий набор контуров.

Создать

Переход к выбору объектов, которые должны учитываться при создании набора контуров. В КОНТУР входят только те объекты, которые можно использовать для создания области или замкнутой полилинии при формировании нового набора контуров.

Для получения дополнительной информации о параметрах этого диалогового окна см. ШТРИХ.


КОНТУР вариант для командной строки

К Команды
К Команды
КОНТУР вариант для командной строки
Понятия Процедуры Команды

При вводе -контур в ответ на подсказку "Команда", команда КОНТУР будет выводить подсказки в командной строке.

Указать внутреннюю точку или [Дополнительные опции]: Указать точку или ввести у

Внутренняя точка

Создает область или полилинию из существующих объектов, образующих замкнутую область. Указать точку внутри этой области.

Дополнительные опции

Устанавливает способ, используемый командой "КОНТУР" для создания контура.

Задать опцию [Контур/Островки/объект]: Задать опцию или нажать ENTER для возврата к предыдущему запросу

Контур

Определяет набор объектов, анализируемых командой КОНТУР при определении контура из указанной точки. Для получения сведений об определении набора контуров см. опцию командной строки ШТРИХ.

Островки

Указывает, использует ли команда КОНТУР объекты, лежащие в пределах внешнего контура, в качестве контуров. Для получения сведений о задании метода обнаружения островков см. опцию командной строки ШТРИХ.

Тип объекта

Указывает тип объекта, создаваемый командой КОНТУР.

Ввести тип объекта контура [Область/Полилиния] <текущий>: Ввести опцию или нажать ENTER


КОНУС Команда

К Команды
К Команды
КОНУС Команда
Понятия Процедуры Команды

Создает 3D тело с основанием в форме окружности или эллипса, симметрично суживающихся к точке, или к плоской грани в форме окружности или эллипса

Панель "Моделирование":

Меню "Рисование": Подменю "Моделирование" » Конус

Ввод команды: конус

Пульт управления: Панель "3D Make", "Конус"

Задать точку центра основания или [3Т/2Т/Ккр/Эллиптический]: Задать точку (1) или ввести опцию

Задать радиус основания или [Диаметр] <значение по умолчанию>: Задать радиус основания, ввести d, чтобы задать диаметр, или нажать ENTER, чтобы задать значение радиуса основания по умолчанию

Задать высоту или [2Точки/Конечную точку оси/Радиус при вершине] <значение по умолчанию>: Задать высоту, ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Использовать опцию "Радиус при вершине" для создания усеченного конуса.

Первоначально значение радиуса по умолчанию не установлено. В ходе сеанса построения значением радиуса основания по умолчанию всегда является предварительно введенное значение радиуса основания для любого элементарного тела.

3Т (Три точки)

Определяет длину окружности основания и базовую плоскость конуса с помощью задания трех точек.

Задать первую точку: Указать точку

Задать вторую точку: Указать точку

Задать третью точку: Указать точку

Задать высоту или [2Точки/Конечная точка оси/ Радиус при вершине] <значение по умолчанию>: Задать высоту, ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение высоты по умолчанию не установлено. В ходе сеанса построения значением высоты по умолчанию всегда является предварительно введенное значение высоты для любого элементарного тела.

2Точки

Указывает, что высотой конуса является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси конуса. Конечной точкой оси является верхняя точка конуса или центральная точка верхней грани усеченного конуса (опция "Радиус при вершине"). Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию конуса.

Задать конечную точку оси: Указать точку

Радиус при вершине

Определяет радиус при вершине усеченного конуса.

Указать радиус при вершине <по умолчанию>: Задать значение или нажать ENTER, чтобы задать значение по умолчанию

Первоначально значение радиуса при вершине по умолчанию не установлено. В ходе сеанса построения значением радиуса при вершине по умолчанию всегда является предварительно введенное значение радиуса при вершине для любого элементарного тела.

2Т (Две точки)

Определяет диаметр основания конуса путем указания двух точек.

Указать первую конечную точку диаметра: Указать точку

Указать вторую конечную точку диаметра: Указать точку

Задать высоту или [2Точки/Конечная точка оси/ Радиус при вершине] <значение по умолчанию>: Задать высоту, ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение высоты по умолчанию не установлено. В ходе сеанса построения значением высоты по умолчанию всегда является предварительно введенное значение высоты для любого элементарного тела.

2Точки

Указывает, что высотой конуса является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси конуса. Конечной точкой оси является верхняя точка конуса или центральная точка верхней грани усеченного конуса (опция "Радиус при вершине"). Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию конуса.

Задать конечную точку оси: Указать точку

Радиус при вершине

Определяет радиус при вершине усеченного конуса.

Указать радиус при вершине <по умолчанию>: Задать значение или нажать ENTER, чтобы задать значение по умолчанию

Первоначально значение радиуса при вершине по умолчанию не установлено. В ходе сеанса построения значением радиуса при вершине по умолчанию всегда является предварительно введенное значение радиуса при вершине для любого элементарного тела.

ККР (Касательная, Касательная, Радиус)

Определяет основание конуса по задаваемым касательным к двум объектам.

Указать точку на объекте для первой касательной: Выбрать точку на объекте

Указать точку на объекте для второй касательной: Выбрать точку на объекте

Указать радиус окружности <по умолчанию>: Задать значение радиуса основания или нажать ENTER, чтобы задать значение по умолчанию

В некоторых случаях по критериям, заданным в команде, можно построить несколько окружностей. Программа вычерчивает основание заданного радиуса, точки касания которого расположены ближе всего к выбранным точкам.

Задать высоту или [2Точки/Конечная точка оси/ Радиус при вершине] <значение по умолчанию>: Задать высоту, ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение высоты по умолчанию не установлено. В ходе сеанса построения значением высоты по умолчанию всегда является предварительно введенное значение высоты для любого элементарного тела.

2Точки

Указывает, что высотой конуса является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси конуса. Конечной точкой оси является верхняя точка конуса или центральная точка верхней грани усеченного конуса (опция "Радиус при вершине"). Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию конуса.

Задать конечную точку оси: Указать точку

Радиус при вершине

Определяет радиус при вершине усеченного конуса.

Указать радиус при вершине <по умолчанию>: Задать значение или нажать ENTER, чтобы задать значение по умолчанию

Первоначально значение радиуса при вершине по умолчанию не установлено. В ходе сеанса построения значением радиуса при вершине по умолчанию всегда является предварительно введенное значение радиуса при вершине для любого элементарного тела.

Эллиптический

Задает эллиптическое основание конуса.

Задать конечную точку первой оси или [Центр]: Задать точку

Задать вторую конечную точку первой оси: Задать точку

Задать конечную точку второй оси: Задать точку

Задать высоту или [2Point/Конечная точка оси/ Радиус при вершине] <значение по умолчанию>: Задать высоту, ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение высоты по умолчанию не установлено. В ходе сеанса построения значением высоты по умолчанию всегда является предварительно введенное значение высоты для любого элементарного тела.

Центр

Создает основание конуса по заданной точке центра.

Задать точку центра: Задать точку

Задать расстояние до первой оси <значение по умолчанию>: Задать расстояние или нажать ENTER, чтобы задать значение расстояния по умолчанию

Задать конечную точку второй оси: Задать точку

Задать высоту или [2Point/Конечная точка оси/ Радиус при вершине] <значение по умолчанию>: Задать высоту, ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение высоты по умолчанию не установлено. В ходе сеанса построения значением высоты по умолчанию всегда является предварительно введенное значение высоты для любого элементарного тела.

2Точки

Указывает, что высотой конуса является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси конуса. Конечной точкой оси является верхняя точка конуса или центральная точка верхней грани усеченного конуса (опция "Радиус при вершине"). Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию конуса.

Задать конечную точку оси: Задать точку

Радиус при вершине

Определяет радиус при вершине усеченного конуса.

Указать радиус при вершине <по умолчанию>: Задать значение или нажать ENTER, чтобы задать значение по умолчанию

Первоначально значение радиуса при вершине по умолчанию не установлено. В ходе сеанса построения значением радиуса при вершине по умолчанию всегда является предварительно введенное значение радиуса при вершине для любого элементарного тела.

Диаметр

Определяет диаметр основания конуса.

Задать диаметр <значение по умолчанию>: Задать диаметр или нажать ENTER, чтобы задать значение по умолчанию

Первоначально значение диаметра по умолчанию не установлено. В ходе сеанса построения значением диаметра по умолчанию всегда является предварительно введенное значение диаметра для любого элементарного тела.

2Точки

Указывает, что высотой конуса является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси конуса. Конечной точкой оси является верхняя точка конуса или центральная точка верхней грани усеченного конуса (опция "Радиус при вершине"). Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию конуса.

Задать конечную точку оси: Задать точку

Радиус при вершине

Определяет радиус при вершине усеченного конуса.

Указать радиус при вершине <по умолчанию>: Задать значение или нажать ENTER, чтобы задать значение по умолчанию

Первоначально значение радиуса при вершине по умолчанию не установлено. В ходе сеанса построения значением радиуса при вершине по умолчанию всегда является предварительно введенное значение радиуса при вершине для любого элементарного тела.

2Точки

Указывает, что высотой конуса является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси конуса. Конечной точкой оси является верхняя точка конуса или центральная точка верхней грани усеченного конуса (опция "Радиус при вершине"). Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию конуса.

Задать конечную точку оси: Задать точку

Радиус при вершине

Определяет радиус при вершине усеченного конуса.

Указать радиус при вершине <по умолчанию>: Задать значение или нажать ENTER, чтобы задать значение по умолчанию

Первоначально значение радиуса при вершине по умолчанию не установлено. В ходе сеанса построения значением радиуса при вершине по умолчанию всегда является предварительно введенное значение радиуса при вершине для любого элементарного тела.


КООРД Команда

К Команды
К Команды
КООРД Команда
Понятия Процедуры Команды

Определение координат точек

Меню "Сервис": "Сведения" » " Координаты"

Ввод команды: коорд (или 'коорд для прозрачного вызова)

Точка: Указать точку

В командной строке выводятся координаты точки в текущей пользовательской системе координат (ПСК).

Команда КООРД выводит X, Y и Z-координаты выбранной точки и запоминает ее как последнюю введенную. При следующем указании точки можно сослаться на нее, введя @.

Если же выполнена привязка к объекту в трехмерном пространстве, AutoCAD отображает реальное значение координаты Z.


КОПИРБАЗ Команда

К Команды
К Команды
КОПИРБАЗ Команда
Понятия Процедуры Команды

Копирование объектов в буфер обмена с указанием базовой точки

Меню "Правка": "Копировать с базовой точкой"

Контекстное меню: Завершить выполнение активных команд, щелкнуть правой кнопкой мыши в области рисования и выбрать "Копировать с базовой точкой".

Ввод команды: копирбаз

Базовая точка:

Выбрать объекты:

Выбранные объекты копируются в буфер обмена Windows. Для вставки скопированных объектов из буфера обмена в документ служит команда PASTECLIP. При вставке объекта, скопированного с помощью команды КОПИРБАЗ, объект размещается относительно заданной базовой точки.


КОПИРВИД Команда

К Команды
К Команды
КОПИРВИД Команда
Понятия Процедуры Команды

Копирование текущего вида в буфер обмена для связывания с другими OLE-приложениями

Меню "Правка": "Копировать вид"

Ввод команды: копирвид

Команда КОПИРВИД копирует текущий вид в буфер обмена. Содержимое буфера обмена может быть вставлено в документ или чертеж как OLE-объект.


КОПИРОВАТЬ Команда

К Команды
К Команды
КОПИРОВАТЬ Команда
Понятия Процедуры Команды

Копирует объекты на заданное расстояние в указанном направлении

Панель Редактирование:

Меню "Редактирование": "Копировать"

Контекстное меню: Выбрать объекты для копирования и щелкнуть правой кнопкой мыши в области рисования. Выбрать "Копировать выбранные".

Ввод команды: копировать

Выбрать объекты: Выбрать объекты любым способом и нажать ENTER по завершении работы

Базовая точка или [Перемещение]<Перемещение:>: Указать базовую точку и ввести р

Две указанные точки задают направляющий вектор, который определяет, на какое расстояние и в каком направлении должны быть перемещены копируемые объекты.

Если при выдаче подсказки "Задать вторую точку" нажать клавишу ENTER, первая точка будет интерпретироваться как смещение относительно осей X, Y, Z. Например, если задать координаты 2,3 для базовой точки и при выдаче следующей подсказки нажать клавишу ENTER, объекты будут скопированы на 2 единицы по оси X и на 3 единицы по оси Y относительно своей текущей позиции.

Для удобства можно повторять команду КОПИРОВАТЬ. Для завершения команды нажать ENTER.

Смещение

Указать смещение <последнее значение>: Ввести координаты для отображения вектора

При вводе значений координат указывается относительное расстояние и направление.


КОПИРОВАТЬСВ Команда

К Команды
К Команды
КОПИРОВАТЬСВ Команда
Понятия Процедуры Команды

Копирование свойств выбранного объекта в другие объекты

Панель "Стандартная":

Меню "Редактирование": Копировать свойства

Ввод команды: копироватьсв или кисть (или 'копироватьсв для прозрачного вызова)

Выберите исходный объект: Выбрать объект, свойства которого необходимо скопировать

Текущие активные настройки: Список копируемых характеристик

Выберите целевые объекты или [Настройки]: Ввести н или выбрать один или несколько объектов, в которые необходимо скопировать свойства

Целевой объект(ы)

Выбор объектов, для которых необходимо скопировать свойства исходного объекта. Можно либо продолжить выбор целевых объектов, либо нажать ENTER для применения свойств и завершения команды.

Установки

Отображает диалоговое окно "Настройки свойств", в котором можно установить набор свойств, копируемых в целевые объекты. По умолчанию в диалоговом окне "Настройки свойств" все свойства объектов выбираются для копирования.

Темы:

  • Диалоговое окно "Настройки свойств"


Диалоговое окно "Настройки свойств"

К Команды
К Команды
Диалоговое окно "Настройки свойств"
Понятия Процедуры Команды

Панель "Стандартная":

Меню "Редактирование": Копировать свойства

Ввод команды: копироватьсв или кисть (или 'копироватьсв для прозрачного вызова)

Указывает основные и специальные свойства, которые необходимо копировать из исходного объекта в целевые.

Цвет

Изменяет цвет целевого объекта на цвет исходного. Опция доступна для всех объектов.

Слой

Изменяет слой целевого объекта на слой исходного. Опция доступна для всех объектов.

Тип линий

Изменение типа линий целевого объекта на тип линий исходного. Опция доступна для всех объектов, за исключением атрибутов, штриховок, многострочного текста, точек и видовых экранов.

Масштаб типа линий

Изменяет масштаб типа линии целевого объекта на масштаб типа линии исходного. Опция доступна для всех объектов, за исключением атрибутов, штриховок, многострочного текста, точек и видовых экранов.

Вес линий

Изменяет вес линии целевого объекта на вес линии исходного. Опция доступна для всех объектов.

Высота

Заменяет значение высоты целевого объекта значением высоты исходного. Опция доступна только для дуг, атрибутов, кругов, отрезков, точек, 2D полилиний, областей, текстов и полос.

Стиль печати

Изменение стиля печати целевого объекта на стиль печати исходного. При использовании цветозависимых стилей печати (системной переменной PSTYLEPOLICY присвоено значение 1) эта опция не доступна. Доступна для всех объектов, кроме объектов с примененным модификатором "Мерцание ребра".

Размеры

Изменение размерного стиля целевого объекта на размерный стиль исходного в дополнение к изменению основных свойств объекта. Опция доступна только для размеров, выносок и полей допусков.

Полилиния

В дополнение к изменению основных свойств объекта, изменение ширины и типа полилинии объекта на ширину и тип исходной полилинии. Параметры сглаживания и высота полилинии исходного объекта не копируются в полилинии целевого объекта. Если исходная полилиния имеет переменную ширину, ее ширина не копируется в целевой полилинии.

Материал

Помимо основных свойств объекта изменяет материал, применяемый к объекту. Если материал назначен целевому объекту, но не назначен исходному объекту, материал удаляется из целевого объекта.

Текст

В дополнение к изменению основных свойств объекта, изменение текстового стиля целевого объекта на текстовый стиль исходного. Опция доступна только для текстовых объектов (одно- и многострочных).

Видовой экран

Помимо основных свойств объектов изменяет следующие свойства целевого видового экрана пространства листа в соответствии со свойствами исходного видового экрана: вкл/откл, блокировка экрана, стандартный и пользовательский масштаб, визуализация при печати, привязка, сетка, видимость и расположение значка ПСК.

Настройки подрезки изображений, ПСК для видового экрана, а также состояния (заморожен или нет) в целевой объект не переносятся.

Отображение теней

Наряду с основными свойствами объекта изменяется и отображение теней. Объект может отбрасывать тень, на него может падать тень, возможны также обе такие ситуации, или же тени могут игнорироваться.

Штриховка

Помимо основных свойств объектов изменяет свойства штриховки целевого объекта на свойства исходного объекта. Для приведения в соответствие исходной штриховке используется опция "Копирование свойств" в команде ШТРИХ или РЕДШТРИХ. Опция доступна только для объектов штриховки.

Таблица

Помимо основных свойств объекта изменяет стиль таблиц целевого объекта на стиль таблиц исходного объекта. Опция доступна только для объектов-таблиц.


КОПИРОВАТЬЯЧСВ Команда

К Команды
К Команды
КОПИРОВАТЬЯЧСВ Команда
Понятия Процедуры Команды

Копирует свойства выбранной ячейки таблицы в другие ячейки

Контекстное меню: Выбрав таблицу и ячейку, нажать правую кнопку мыши и выбрать "Формат по образцу".

Ввод команды: копироватьячсв

Выберите исходную ячейку: Нажать левую кнопку мыши на ячейке таблицы, свойства которой требуется скопировать

Выберите целевую ячейку: Нажать левую кнопку мыши на ячейках таблицы, для которых требуется скопировать свойства исходной ячейки, и нажать правую кнопку или нажать ENTER либо ESC для выхода

В целевую ячейку будут скопированы все свойства исходной ячейки за исключением типа ячейки: текстовая или блоковая.


КОПИЯВСЛОЙ Команда

К Команды
К Команды
КОПИЯВСЛОЙ Команда
Понятия Процедуры Команды

Копирует один или более объектов в другой слой

Панель "Слои II":

Меню "Формат": Подменю "Инструменты слоев" » "Копировать объекты в новый слой"

Ввод команды: копиявслой

Выбрать объекты для копирования:

Выбрать объект на слое назначения или [Имя] <Имя>: Выбрать объект или ввести n

При вводе команды -копиявслой по подсказке "Команда" команда КОПИЯВСЛОЙ будет выводить подсказки в командную строку.

Выбрать объект на слое назначения

Задает слой, в который будут помещены выбранные объекты.

Задать базовую точку или [Смещение/Выход] <выход>: Задать точку, ввести с или ввести x

Базовая точка:

Задает базовую точку для скопированных объектов.

Указать вторую точку смещения или <используйте первую точку в качестве смещения:

Смещение

Вводит значения координат, определяющие относительное расстояние и направление.

Указать смещение <0,0000, 0,0000, 0,0000>:

Выход

Прерывание команды.

Имя

Выводит на экран диалоговое окно Копировать в слой

Задать базовую точку или [Смещение/Выход] <выход>: Задать точку, ввести с или ввести x

Базовая точка:

Задает базовую точку для скопированных объектов.

Указать вторую точку смещения или <используйте первую точку в качестве смещения:

"Перемещение"

Водит значения координат, определяющие относительное расстояние и направление.

Указать смещение <0,0000, 0,0000, 0,0000>:

Выход

Прерывание команды.

Темы:

  • Диалоговое окно "Копировать в слой"
  • Командная строка КОПИЯВСЛОЙ


Диалоговое окно "Копировать в слой"

К Команды
К Команды
Диалоговое окно "Копировать в слой"
Понятия Процедуры Команды

Задает слой, в который будут помещены выбранные объекты.

Слой назначения

Отображает список слоев, которые можно выбрать в качестве слоя назначения. Пользователь может также ввести имя для создания нового слоя. Новый слой приобретает свойства (вкл/откл, заморожен/разморожен, заблокирован/ разблокирован и т.д.) текущего слоя.


Командная строка КОПИЯВСЛОЙ

К Команды
К Команды
Командная строка КОПИЯВСЛОЙ
Понятия Процедуры Команды

При вводе по подсказке "Команда" команды-копиявслой команда КОПИЯВСЛОЙ будет выводить подсказки в командную строку.

Выбрать объекты для копирования:

Задать имя слоя назначения или [?/= (выбрать объект)] <0>: Выбрать объект в слое назначения, ввести ? или ввести =

Задать имя слоя назначения

Отображает список слоев, которые можно выбрать в качестве слоя назначения. Пользователь может также ввести имя для создания нового слоя. Новый слой приобретает свойства (вкл/откл, заморажен/разморожен, заблокирован/ разблокирован и т.д.) текущего слоя

Число объектов, скопированных и помещенных в слой "<имя слоя>".

?—Список слоев

Ввести имя(имена) слоя в список <*>: *

=—Слой по Объекту

Выбирает слой назначения в соответствии с выбором объекта на этом слое.

Выбрать объект на слое с требуемым именемВыбрать объект на слое назначения


КПРОТОКОЛ Команда

К Команды
К Команды
КПРОТОКОЛ Команда
Понятия Процедуры Команды

Копирование текста из окна протокола командной строки в буфер обмена

Ввод команды: кпротокол

Текст копируется в буфер обмена.


КРОМКА Команда

К Команды
К Команды
КРОМКА Команда
Понятия Процедуры Команды

Изменение видимости кромок трехмерных граней

Меню "Рисование": "Моделирование" » подменю "Сети" » подменю "Грань"

Ввод команды: кромка

Выбрать кромку 3D грани для переключения ее видимости или [Показать]: Выбрать кромку или ввести к

Кромка

Управление видимостью выбранных кромок.

Выбрать кромку объекта 3D грань для переключения ее видимости или [Включить скрытые]:

Запрос повторяется до тех пор, пока пользователь не нажмет клавишу ENTER.

Если кромки одной или нескольких 3D граней накладываются друг на друга, программа изменяет видимость каждой из совпадающих кромок.

Показать

Подсветка скрытых кромок трехмерных граней.

Задать способ выбора для отображения скрытых кромок [Указать/Все] <Все>: Задать опцию или нажать клавишу ENTER

Все

Выбор всех скрытых кромок и регенерация всех трехмерных граней.

Для повторного включения видимости 3D граней используется опция "Кромка". Для включения видимости необходимо выбрать каждую кромку с помощью устройства указания. На объекте автоматически возникают маркеры и подсказки функции автопривязки AutoSnap™, предоставляя возможность выбора характерных позиций привязки на невидимых кромках.

Подсказка отображается до тех пор, пока не нажата клавиша ENTER.

Выбрать

Выбор скрытых кромок и регенерация выбранных трехмерных граней.

Выбрать объекты:

Для повторного включения видимости 3D граней используется опция "Кромка". Для включения видимости необходимо выбрать каждую кромку с помощью устройства указания. На объекте автоматически возникают маркеры и подсказки автопривязки, предоставляя возможность выбора характерных позиций на невидимых кромках.

Подсказка отображается до тех пор, пока не нажата клавиша ENTER.


КРУГ Команда

К Команды
К Команды
КРУГ Команда
Понятия Процедуры Команды

Построение окружностей

Панель "Рисование":

Меню "Рисование": "Круг"

Ввод команды: круг

Центр круга или [3Т (Три точки)/2Т (Две точки)/Ккр (кас кас радиус)]: Указать точку или задать опцию

Центральная точка

Построение окружности по заданным центру и диаметру (радиусу).

Задать радиус круга или [диаметр]: Указать точку, ввести значение, ввести d или нажать ENTER

Радиус

Определяет радиус круга. Следует ввести значение или указать точку (2). Если указана точка, радиусом считается расстояние от нее до центра.

Диаметр

Построение окружности по центральной точке и заданному диаметру.

Задать диаметр круга <текущий>: Указать точку (2), ввести значение или нажать ENTER

3Т (Три точки)

Построение окружности по трем принадлежащим ей точкам.

Первая точка круга: Указать точку (1)

Вторая точка круга: Указать точку (2)

Третья точка круга: Указать точку (3)

2Т (Две точки)

Построение окружности по двум конечным точкам ее диаметра.

Задать первую конечную точку диаметра круга: Указать точку (1)

Задать вторую конечную точку диаметра круга: Указать точку (2)

ККР (Касательная, Касательная, Радиус)

Построение окружности заданного радиуса, касательной к двум объектам.

Указать точку на объекте, задающую первую касательную: Выбрать окружность, дугу или отрезок

Указать точку на объекте, задающую вторую касательную: Выбрать окружность, дугу или отрезок

Радиус круга <текущий>:

Иногда по условиям, заданным в команде, можно построить несколько окружностей. Программа рисует круг указанного радиуса, точки касания которой расположены ближе всего к точкам выбора.


КТЕКСТ Команда

К Команды
К Команды
КТЕКСТ Команда
Понятия Процедуры Команды

Управление отображением и выводом на плоттер текста и атрибутов

Ввод команды: ктекст (или 'ктекст для вызова в прозрачном режиме)

Выберите режим [Вкл/Откл] <текущий>: Ввести вкл или откл или нажать ENTER

Когда включена команда КТЕКСТ (контурный текст), каждый текстовый объект или атрибут отображается в виде ограничивающего этот объект прямоугольника. Если режим КТЕКСТ включен, программе требуется меньше времени для перерисовки и регенерации чертежей, содержащих текстовые объекты.


КШТРИХ Команда

К Команды
К Команды
КШТРИХ Команда
Понятия Процедуры Команды

Создает градиентную заливку или штриховку для замкнутой области или выбранных объектов

Ввод команды: кштрих

Команда КШТРИХ была переименована в ШТРИХ. При вводе кштрих откроется диалоговое окно "Штриховка и градиент". При вводе -кштрих в командной строке отобразятся подсказки.


Л Команды
  • ЛАНДБИБ
  • ЛАНДНОВЫЙ
  • ЛАНДРЕД
  • ЛИМИТЫ
  • ЛИСТ
  • ЛМАСШТАБ
  • ЛУЧ


ЛАНДБИБ Команда

Л Команды
Л Команды
ЛАНДБИБ Команда
Понятия Процедуры Команды

Не выполняет других функций, кроме поддержания целостности сценариев.

Ввод команды: ландбиб

Устаревшая команда.


ЛАНДНОВЫЙ Команда

Л Команды
Л Команды
ЛАНДНОВЫЙ Команда
Понятия Процедуры Команды

Не выполняет других функций, кроме поддержания целостности сценариев.

Ввод команды: ландновый

Устаревшая команда.


ЛАНДРЕД Команда

Л Команды
Л Команды
ЛАНДРЕД Команда
Понятия Процедуры Команды

Не выполняет других функций, кроме поддержания целостности сценариев.

Ввод команды: ландред

Устаревшая команда.


ЛИМИТЫ Команда

Л Команды
Л Команды
ЛИМИТЫ Команда
Понятия Процедуры Команды

Установка и регулирование границ отображения сетки на текущей вкладке разметки листа или "Модель"

Меню "Формат": "Лимиты"

Ввод команды: лимиты (или ’лимиты для прозрачного вызова)

Левый нижний угол или [Вкл/Откл] <текущий>: Задать точечный источник света, ввести вкл или откл или нажать клавишу ENTER

Левый нижний угол.

Задание левого нижнего лимита сетки.

Правый верхний угол <текущий>: Задать точку или нажать клавишу ENTER

Вкл

Включение контроля лимитов. Если контроль лимитов включен, то пользователь не может вводить точки, координаты которых выходят за лимиты сетки. Поскольку контроль относится только к указываемым точкам, фрагменты объектов (например, кругов), могут оказаться за пределами лимитов сетки.

Откл

Отключение режима контроля лимитов. Текущие значения лимитов сохраняются и могут быть использованы при последующем включении режима контроля лимитов.


ЛИСТ Команда

Л Команды
Л Команды
ЛИСТ Команда
Понятия Процедуры Команды

Переключение видовых экранов из пространства модели в пространство листа

Ввод команды: лист

Программа переключается из пространства модели в пространство листа при работе на вкладке листа.

Пространство листа используется для окончательной компоновки и подготовки чертежа к выводу на печать. Частью процесса конструирования является создание видовых экранов пространства листа, представляющих собой окна с различными видами модели. Переключаясь из пространства листа в пространство модели (см. МОДЕЛЬ), можно производить различные операции с объектами на текущем видовом экране.

Для того, чтобы какой-либо из видовых экранов стал текущим, нужно дважды нажать в нем левую кнопку мыши. Еще один способ переключения в пространство листа - двойное нажатие левой кнопки мыши в точке листа, не принадлежащей ни одному видовому экрану.

Переключаться между пространствами модели и листа можно также с помощью кнопок МОДЕЛЬ и ЛИСТ в строке состояния.


ЛМАСШТАБ Команда

Л Команды
Л Команды
ЛМАСШТАБ Команда
Понятия Процедуры Команды

Глобальный масштаб типов линий

Ввод команды: лмасштаб (или 'лмасштаб для прозрачного вызова)

Новый масштаб типа линий <текущий>: Ввести положительное вещественное значение или нажать клавишу ENTER

Команда ЛМАСШТАБ используется для изменения масштаба типов линий для всех объектов чертежа. После изменения масштаба чертеж регенерируется.


ЛУЧ Команда

Л Команды
Л Команды
ЛУЧ Команда
Понятия Процедуры Команды

Построение линий, бесконечных в одном направлении

Меню "Рисование": "Луч"

Ввод команды: луч

Начальная точка: Указать точку (1)

Через точку: Указать точку, через которую должен проходить луч (2)

Направление каждого луча определяется двумя точками, одна из которых, начальная, является общей для всех лучей. Запрос "Через точку" будет выдан повторно для создания нескольких лучей. Нажать ENTER для завершения команды.


М Команды
  • МАРКЕР
  • МАСКИРОВКА
  • МАСС-ХАР
  • МАССИВ
  • МАСТЕРЛИСТ
  • МАСТЕРПЕЧ
  • МАСШТАБ
  • МАСШТЕКСТ
  • МАТЕРИАЛ
  • МАТЕРИАЛПРИСВ
  • МАТЕРИАЛСООТВ
  • МАТЕРИАЛЫ
  • МАТЕРИАЛЫЗАКР
  • МВСТАВИТЬ
  • МЕНЮ
  • МЕНЮВЫГР
  • МЕНЮЗАГР
  • МЛИНИЯ
  • МЛРЕД
  • МЛСТИЛЬ
  • МН-УГОЛ
  • МНОГОРАЗ
  • МОДЕЛЬ
  • МОДЕЛЬ
  • МПОВТОРИТЬ
  • МТЕКСТ
  • МТРЕД


МАРКЕР Команда

М Команды
М Команды
МАРКЕР Команда
Понятия Процедуры Команды

Управление простановкой маркеров при рисовании

Ввод команды: маркер (или 'маркер для прозрачного вызова)

Ввести режим [ВКЛ/ ОТКЛ] <текущий>: Ввести вкл или выкл, или нажать ENTER

Если режим "Маркер" включен, при указании точки на экране остается маркер (крестик). По умолчанию режим МАРКЕР отключен.

Маркеры удаляются с экрана при помощи команд ОСВЕЖИТЬ, РЕГЕН, ПОКАЗАТЬ, ПАН и любых других, выполняющих перерисовку или регенерацию.


МАСКИРОВКА Команда

М Команды
М Команды
МАСКИРОВКА Команда
Понятия Процедуры Команды

Скрытие существующих объектов чертежа посредством наложения на них объектов цвета фона

Меню "Рисование": "Маскировка"

Ввод команды: маскировка

Создание многоугольных объектов цвета фона, которыми можно закрывать объекты чертежа. Эти многоугольные объекты ограничиваются маскирующим контуром. Видимость маскирующего контура можно включать при редактировании и отключать при печати.

Первая точка или [Контуры/Полилиния]<Полилиния>: Указать точку или задать опцию

Первая точка

Определение многоугольного контура маскирующего объекта посредством задания набора точек.

Следующая точка: Указать следующую точку или нажать ENTER для завершения команды

Контуры

Отображение или скрытие контуров всех маскирующих объектов.

Выберите режим [Вкл/Откл]:<разные> Ввести в или о

Ввести в для отображения контуров всех маскирующих объектов. Ввести о для скрытия контуров всех маскирующих объектов.

Полилиния

Преобразование существующей полилинии в многоугольный контур маскирующего объекта.

Выберите замкнутую полилинию: Выбрать замкнутую полилинию любым способом

Стереть полилинию? [Да/Нет]<Н>: Ввести д или н

Чтобы стереть полилинию, которая использовалась для создания маскирующего объекта, введите д. Чтобы сохранить полилинию на чертеже, введите н.


МАСС-ХАР Команда

М Команды
М Команды
МАСС-ХАР Команда
Понятия Процедуры Команды

Вычисление массовых характеристик областей и тел

Панель "Сведения":

Меню "Сервис": "Сведения"» "Геометрия и масса"

Ввод команды: масс-хар

Выберите объекты: Использовать доступный способ выбора объекта

При выборе нескольких областей принимаются только области, компланарные первой из выбранных.

МАСС-ХАР отображает массовые характеристики в текстовом окне и далее запрашивает, требуется ли их запись в текстовый файл.

Записать результаты анализа в файл? <Н>: Ввести д или н или нажать ENTER

Если ввести д, команда МАСС-ХАР запрашивает ввод имени файла.

Характеристики, отображаемые командой МАСС-ХАР, зависят от того, являются ли выбранные объекты областями (и компланарны ли выбранные области плоскости XY текущей ПСК) или телами. Список параметров, управляющих единицами МАСС-ХАР, см. в разделе Вычисления в текущей ПСК.

Области

В следующей таблице приведены массовые характеристики, отображаемые для всех областей.

Массовые характеристики для всех областей

Массовая характеристика

Описание

Площадь

Площадь поверхности тел или внутренняя площадь областей.

Периметр

Общая длина внешних и внутренних петель области. Периметр тела не вычислен.

Ограничивающая рамка

Определяется двумя координатами. Для областей, компланарных плоскости XY текущей пользовательской системы координат, координатами ограничивающей рамки являются координаты противоположных углов прямоугольника, ограничивающего область. Для областей, не являющихся компланарными плоскости XY текущей ПСК, координатами ограничивающей рамки являются координаты противоположных углов параллелепипеда, ограничивающего область.

Центр масс

2D или 3D точка геометрического центра областей. Для областей, компланарных плоскости XY текущей ПСК, это двумерная точка. Для областей, не являющихся компланарными плоскости XY текущей ПСК, это трехмерная точка.

Если области компланарны плоскости XY текущей ПСК, отображаются дополнительные свойства, приведенные в следующей таблице.

Дополнительные массовые характеристики для компланарных областей

Массовая характеристика

Описание

Моменты инерции

Величины используются при расчете распределенных нагрузок, например, давления жидкости на плиту, или при вычислении сил при изгибе или кручении балок. Моменты инерции вычисляются по формуле:

момент_инерции = площадь * радиус2

Размерность моментов инерции — единицы длины в четвертой степени.

Центробежные моменты инерции

Величина, используемая для определения сил, вызывающих перемещение объекта. Вычисляется относительно двух ортогональных плоскостей. Центробежные моменты инерции для плоскостей YZ и XZ вычисляются по формуле:

центробеж_момент_инерции YZ,XZ = масса * расстоянот_центра_масс_до_YZ * расстоянот_центра_масс_до_XZ

Размерность центробежных моментов инерции — единицы массы, умноженные на единицы расстояния в квадрате.

Радиусы инерции

Эта характеристика — еще один способ выражения моментов инерции тела. Радиусы инерции вычисляются по формуле:

радиус_инерции = (момент_инерции/масса_тела)1/2

Размерность радиусов инерции — единицы длины.

Главные моменты и направления X,Y,Z относительно центра масс

Вычисляются на основании центробежных моментов инерции и имеют те же размерности. Относительно одной из осей, проходящих через центр масс объекта, момент инерции является наибольшим. Ось, относительно которой момент инерции является наименьшим, располагается перпендикулярно первой оси и также проходит через центр масс. Третье значение, представленное в результатах, является промежуточным.

Тела

В следующей таблице представлены массовые характеристики, выводимые для тел.

Массовые характеристики тел

Массовая характеристика

Описание

Масса

Мера инерции тела. Поскольку используется единичная плотность, значения массы и объема равны.

Объем

Величина ограничиваемой телом области 3D пространства.

Ограничивающая рамка

Координаты противоположных углов параллелепипеда, ограничивающего тело.

Центр масс

Трехмерная координата центра масс для тел. Предполагается, что плотность тела распределена равномерно.

Моменты инерции

Момент инерции тела используется при определении сил, требуемых для вращения объекта вокруг оси (например, вращении колеса вокруг оси). Момент инерции тела вычисляется по формуле:

момент_инерции_тела = масса_тела * радиусотносительно_оси2

Размерность момента инерции тела — единицы массы, умноженные на единицы длины в квадрате.

Центробежные моменты инерции

Величина, используемая для определения сил, вызывающих перемещение объекта. Вычисляется относительно двух ортогональных плоскостей. Центробежные моменты инерции для плоскостей YZ и XZ вычисляются по формуле:

центробеж_момент_инерции YZ,XZ = масса * расстоянот_центра_масс_до_YZ * расстоянот_центра_масс_до_XZ

Размерность центробежных моментов инерции — единицы массы, умноженные на единицы расстояния в квадрате.

Радиусы инерции

Эта характеристика — еще один способ выражения моментов инерции тела. Радиусы инерции вычисляются по формуле:

радиус_инерции = (момент_инерции/масса_тела)1/2

Размерность радиусов инерции — единицы длины.

Главные моменты и направления X,Y,Z относительно центра масс

Вычисляются на основании центробежных моментов инерции и имеют те же размерности. Относительно одной из осей, проходящих через центр масс объекта, момент инерции является наибольшим. Ось, относительно которой момент инерции является наименьшим, располагается перпендикулярно первой оси и также проходит через центр масс. Третье значение, представленное в результатах, является промежуточным.

Вычисления в текущей ПСК

В следующей таблице приведены параметры, управляющие единицами измерения массовых характеристик.

Параметры, управляющие размерными единицами массовых характеристик

Параметр

Используется для вычисления

ПЛОТНОСТЬ

Масса тел

ДЛИНА

Объем тел

ДЛИНА*ДЛИНА

Площадь области и площадь поверхности тела

ДЛИНА*ДЛИНА*ДЛИНА

Ограничивающая рамка, радиусы инерции, центр масс и периметр

ПЛОТНОСТЬ*ДЛИНА*ДЛИНА

Моменты инерции, центробежные моменты инерции и главные моменты


МАССИВ Команда

М Команды
М Команды
МАССИВ Команда
Понятия Процедуры Команды

Создание массивов объектов

Панель "Редактирование":

Меню "Изменить": "Массив"

Ввод команды: массив

Отобразится диалоговое окно "Массив". Окно содержит переключатель между прямоугольным или круговым массивом. Каждый объект массива может обрабатываться независимо от других. При выборе нескольких объектов они воспринимаются как один элемент для копирования и включения в массив.

Если в ответ на приглашение в командной строке ввести -массив, команда МАССИВ отображает приглашения в командной строке.

Темы:

  • Диалоговое окно "Массив"
  • МАССИВ вариант для командной строки


Диалоговое окно "Массив"

М Команды
М Команды
Диалоговое окно "Массив"
Понятия Процедуры Команды

Панель "Редактирование":

Меню "Изменить": "Массив"

Ввод команды: массив

Создание массивов объектов С помощью параметра Прямоугольный массив создается прямоугольный массив путем размножения выбранных элементов с заданным количеством рядов и столбцов, образующих прямоугольную матрицу. С помощью параметра Круговой массив создается массив путем указания центральной точки, вокруг которой строятся копии выбранных объектов.

Другие параметры: Выбор объектов, Область просмотра, Образец.

Прямоугольный массив

Создание прямоугольного массива путем размножения выбранных элементов с заданным количеством рядов и столбцов, образующих прямоугольную матрицу.

Ряды

Число рядов в массиве.

Если в массиве только один ряд, необходимо задать более одного столбца. Если задать большое количество строк и столбцов, построение массива может занять некоторое время. По умолчанию максимальное число элементов массива, построенного одной командой, равно 100000. Предел, заданный установкой MAXARRAY в системном реестре. Например, чтобы установить текущее значение равным 200000, необходимо ввести в командной строке выражение (setenv "MaxArray" "200000").

Кол. столбцов

Задание числа столбцов в массиве.

Если в массиве только один столбец, необходимо задать более одного ряда. Если задать большое количество строк и столбцов, построение массива может занять некоторое время. По умолчанию максимальное число элементов массива, построенного одной командой, равно 100000. Предел, заданный установкой MAXARRAY в системном реестре. Например, чтобы установить текущее значение равным 200000, необходимо ввести в командной строке выражение (setenv "MaxArray" "200000").

Расстояние и направление смещения

Обеспечивает пространство для задания пользователем расстояния и направления смещения массива.

Между рядами

Расстояние между рядами (в единицах чертежа). Для добавления рядов вниз необходимо задать отрицательное расстояние. Для задания расстояния между рядами с помощью устройства указания следует воспользоваться кнопкой "Указать оба расстояния" или кнопкой "Указать расстояние между рядами".

Между столбцами

Задание расстояния между столбцами (в единицах чертежа). Для добавления столбцов влево необходимо задать отрицательное значение. Для задания расстояния между столбцами с помощью устройства указания следует воспользоваться кнопкой "Указать оба расстояния" или кнопкой "Указать расстояние между столбцами".

Угол поворота

Задание угла поворота массива. Этот угол обычно равен нулю, так что строки и столбцы взаимно перпендикулярны и располагаются вдоль осей чертежа X и Y в текущей ПСК. С помощью команды ЕДИНИЦЫ можно изменить параметры измерения углов. Системные переменные ANGBASE и ANGDIR задают базовый угол и направление отсчета угла поворота массивов.

Указать оба расстояния

Временное закрытие диалогового окна для задания расстояний между рядами и столбцами непосредственно на экране (указанием двух противоположных углов элементарной ячейки массива).

Указать расстояние между рядами

Временное закрытие диалогового окна для задания расстояния между рядами непосредственно на экране. С помощью команды МАССИВ программа запрашивает две точки, которые определяют расстояние между рядами и их направление.

Указать расстояние между столбцами

Временное закрытие диалогового окна для задания расстояния между рядами непосредственно на экране. С помощью команды МАССИВ программа запрашивает две точки, которые определяют расстояние между столбцами и их направление.

Указать угол поворота массива

Временное закрытие диалогового окна "Массив" для задания угла поворота массива на экране. С помощью команды ЕДИНИЦЫ можно изменить параметры измерения углов. Системные переменные ANGBASE и ANGDIR задают базовый угол и направление отсчета угла поворота массивов.

Круговой массив

Создает массив путем указания центральной точки, вокруг которой строятся копии выбранных объектов.

Центральная точка

Центр кругового массива. Здесь можно ввести численные значения координат или, нажав "Указать центр массива", указать точку на экране.

Указать центр массива

Закрывает на время диалоговое окно "Массив" для указания центральной точки непосредственно в области рисования.

Способ и значения

Здесь задаются способ и значения для размещения объектов в круговом массиве.

Метод

Выбор способа размножения объектов в круговом массиве. Способ определяет, какие из полей группы "Способ и значения" будут доступны для ввода. Например, если выбран способ "Число элементов и угол заполнения", ввод значений разрешен только в соответствующие поля.

Число элементов

Число элементов в полученном массиве. По умолчанию используется значение 4.

Угол заполнения

Задание значения центрального угла между базовой точкой начального и конечного элементов массива. Положительное значение задает отсчет против часовой стрелки. Отрицательное значение задает отсчет по часовой стрелке. По умолчанию используется значение 360. Значение 0 не допускается и заменяется на значение по умолчанию.

Угол между элементами

Задание центрального угла между базовыми точками соседних элементов и центром массива. Величина угла должна быть положительной. По умолчанию устанавливается значение 90.

Примечание Угол заполнения и угол между элементами также можно задать непосредственно в области рисования с помощью кнопки "Указать".

Указать угол заполнения

Временное закрытие диалогового окна "Массив" для задания значения центрального угла между базовыми точками начального и конечного элементов массива на экране. С помощью команды МАССИВ программа предлагает выбрать точку относительно другой точки в области рисования.

Указать угол между элементами

Временное закрытие диалогового окна "Массив" для задания значения центрального угла между базовыми точками соседних элементов массива на экране. С помощью команды "МАССИВ" программа предлагает выбрать точку относительно другой точки в области рисования.

Поворачивать элементы массива

Поворот элементов в массиве, как показано на образце внутри диалогового окна.

Больше/Меньше

Показ и скрытие дополнительных опций в диалоговом окне "Массив". При нажатии кнопки "Больше" появляется ряд дополнительных опций, а имя кнопки меняется на "Меньше".

Базовая точка объекта

Задание новой базовой точки, которая остается на постоянном расстоянии от центральной точки при построении массива. Чтобы создать полярный массив, в команде МАССИВ определяется расстояние от центральной точки массива до опорной (базовой) точки на последнем выбранном объекте. Конкретный выбор точки в качестве базовой зависит от типа объекта, как показано в следующей таблице.

Базовые точки, установленные для объектов по умолчанию

Тип объекта

Базовые точки по умолчанию

Дуга, круг, эллипс

Центральная точка

Многоугольник, прямоугольник

Первая угловая точка

Кольцо, отрезок, полилиния, 3D полилиния, луч, сплайн

Начальная точка

Блок, многострочный текст, однострочный текст

Точка вставки

Вспомогательные линии

Середина

Область

Ручка

Как установлено в объекте

Использование стандартной базовой точки для расположения элемента кругового массива. Следует снять этот флажок для задания точки вручную.

Базовая точка

Задание новых координат X и Y базовой точки. При нажатии кнопки "Указать базовую точку" диалоговое окно временно закрывается, и пользователь получает возможность указания точки непосредственно на экране. После указания точки диалоговое окно "Массив" вновь появляется на экране.

Примечание Во избежание непредсказуемых результатов при построении кругового массива без поворота объектов базовую точку желательно устанавливать вручную.

Выбор объектов

Задание объектов, из которых строится массив. Выбрать объекты можно как до, так и после вызова диалогового окна "Массив". Для того чтобы выполнить выбор, когда окно уже вызвано, следует нажать кнопку "Выбор объектов". Диалоговое окно временно закрывается. После окончания выбора объектов нажать клавишу ENTER. Диалоговое окно "Массив" появляется вновь. После сообщения "Выбрано объектов:" выводится количество объектов, которые выбрал пользователь.

Примечание Если выбрано несколько объектов, для построения массива используется базовая точка последнего из них.

Область просмотра

Предварительный просмотр изображения массива, соответствующего текущим установкам диалогового окна. Образец динамически обновляется при изменении какого-либо параметра. Однако для этого необходимо перейти к другому полю.

Образец

Закрытие диалогового окна "Массив" и построение массива в текущем чертеже. Для возврата в диалоговое окно и внесения изменений нажать кнопку "Изменить".


МАССИВ вариант для командной строки

М Команды
М Команды
МАССИВ вариант для командной строки
Понятия Процедуры Команды

Если в ответ на приглашение к вводу команд ввести -массив, команда МАССИВ отображает приглашения в командной строке.

Выбрать объекты: Выбрать объекты любым способом

Ввести тип массива [Прямоугольный/Полярные] <текущий>: Задать опцию или нажать клавишу ENTER

Прямоугольный

Создание прямоугольного массива путем размножения выбранных элементов с заданным количеством рядов и столбцов, образующих прямоугольную матрицу.

Ввести число рядов (---) <1>: Ввести ненулевое целое число или нажать клавишу ENTER

Ввести число столбцов (|||) <1>: Ввести ненулевое целое число или нажать клавишу ENTER

Если задан один ряд, необходимо задать более одного столбца, и наоборот.

Выбранный объект или базовый элемент помещается в нижний левый угол, а остальные элементы массива создаются в направлении вверх и вправо от него.

В значениях расстояний между рядами и столбцами должны быть учтены размеры самих элементов массива.

Расстояние между рядами или размер ячейки (---):

Для добавления рядов вниз необходимо задать отрицательное расстояние между рядами. Команда МАССИВ не отображает следующий запрос, если указаны две точки для противоположных углов прямоугольной ячейки.

Расстояние между столбцами (|||):

Для добавления столбцов влево необходимо задать отрицательное расстояние между столбцами. Прямоугольные массивы строятся вдоль базовой линии, определяемой текущим углом поворота шаговой привязки. Этот угол обычно равен нулю, так что строки и столбцы взаимно перпендикулярны и располагаются вдоль осей X и Y . Опция "Поворот" команды ШАГ изменяет этот угол и приводит к построению повернутого массива. Угол поворота хранится в системной переменной SNAPANG.

Если задать большое количество строк и столбцов, построение массива может занять некоторое время. По умолчанию максимальное число элементов массива, построенного одной командой, равно 100000. Предел, заданный установкой MAXARRAY в системном реестре. Например, чтобы установить текущее значение равным 200000, необходимо ввести в командной строке выражение (setenv "MaxArray" "200000").

Полярные

Создает массив путем указания центральной точки, вокруг которой строятся копии выбранных объектов.

Указать центральную точку массива или [Базовая]: Указать точку или ввести б, чтобы задать новую базовую точку

Центральная точка

Массив строится вокруг указанной точки.

Базовая точка

Задание новой базовой точки, которая остается на постоянном расстоянии от центральной точки при построении массива.

Базовая точка объектов: указать точку

Ввести число элементов в массиве: Ввести положительное целое число или нажать клавишу ENTER

Если в ответ на запрос числа элементов введено какое-либо значение, должен быть задан либо угол заполнения, либо угол между элементами. Если нажать клавишу ENTER не указывая число элементов, требуется указать оба параметра.

Задать угол заполнения (+=ccw, -=cw) <360>: Ввести положительное целое число для копирования элементов против часовой стрелки или отрицательное целое число для копирования по часовой стрелке

Для угла заполнения можно ввести значение, равное 0, только если задано количество элементов.

Если задать значение величины угла заполнения, не указывая количество элементов, или задать угол заполнения, равный 0, указав при этом количество элементов, или нажать клавишу ENTER , появится следующее приглашение:

Угол между элементами: Задать угол

Если задано количество элементов массива, введен 0 в качестве угла заполнения или нажата клавиша ENTER, команд МАССИВ выдает приглашение ввести положительное или отрицательное значение для определения направления построения массива:

Угол между элементами (+=против чс, -=по чс): Ввести положительное целое число для копирования элементов против часовой стрелки или отрицательное целое число для копирования по часовой стрелке

С помощью команды МАССИВ определяется расстояние от центральной точки массива до опорной точки на последнем выбранном объекте. Базовой точкой может быть центр круга или дуги, точка вставки блока или формы, начальная точка текста, одна из конечных точек отрезка или полосы.

Поворачивать элементы массива? <Д>: Ввести д или н или нажать клавишу ENTER

При построении кругового массива базовая точка последнего объекта в наборе используется для всех объектов. Если выбор объектов был сделан с помощью рамки или секущей рамки, то последний объект в наборе устанавливается произвольно. Удаление объектов из набора и добавление объектов к нему также оказывает влияние на то, какой объект будет считаться последним. Набор можно также объединить в блок, размножая затем именно его.


МАСТЕРЛИСТ Команда

М Команды
М Команды
МАСТЕРЛИСТ Команда
Понятия Процедуры Команды

Создание нового листа, задание параметров листа и печати

Меню "Вставка": "Расположение" » "Мастер компоновки листа"

Меню "Сервис": "Мастера" » "Создание разметки листа"

Ввод команды: мастерлист

Отобразится диалоговое окно Мастера компоновки листа.

Темы:

  • Мастер компоновки листа


Мастер компоновки листа

М Команды
М Команды
Мастер компоновки листа
Понятия Процедуры Команды

Ввод команды: мастерлист

Мастер компоновки листа проводит пользователя по всем этапам создания новой разметки листа. Лист можно создать либо с самого начала, либо по выбранному шаблону.

Размер листа выбирается в зависимости от установленного устройства печати. Основную надпись для создаваемого листа можно выбрать из списка. Выбранная основная надпись отображается на образце.

После того как лист создан, любой из его параметров можно изменить с помощью команды ПАРАМЛИСТ.


МАСТЕРПЕЧ Команда

М Команды
М Команды
МАСТЕРПЕЧ Команда
Понятия Процедуры Команды

Вызов Мастера для импорта параметров печати из PCP- и PC2-файлов настройки для вкладки "Модель" или текущего листа

Меню "Сервис": "Мастера" » "Импорт параметров печати"

Ввод команды: мастерпеч

При вызове команды МАСТЕРПЕЧ открывается мастер импорта параметров печати из PCP или PC2. Из этих файлов можно импортировать значения таких параметров, как область печати, угол поворота и смещение при печати, оптимизация печати, печать в файл, формат листа, масштаб печати и присвоения перьев.

По подсказке мастера пользователь должен указать имя PCP- или PC2-файла конфигурации для импорта. Перед импортом параметров печати можно просматривать и изменять их. Параметры печати применяются к вкладке "Модель" или к текущему листу.


МАСШТАБ Команда

М Команды
М Команды
МАСШТАБ Команда
Понятия Процедуры Команды

Пропорциональное увеличение/уменьшение размеров выбранных объектов в направлениях X, Y и Z

Панель "Редактирование":

Меню "Редактирование": "Масштаб"

Контекстное меню: Выберите объекты для масштабирования и нажмите правую кнопку мыши в области рисования. Выберите "Масштаб".

Ввод команды: масштаб

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Базовая точка: Указать точку

Масштабирование выбранных объектов производится относительно базовой точки; это означает, что ее положение не изменяется.

Масштаб или [Копия/Опорный отрезок]: Укажите масштаб, введите к или введите о

Масштаб

Увеличение размеров выбранных объектов в указанное число раз. Для увеличения объектов следует задать значение, большее 1. Для уменьшения объектов следует задать значение в диапазоне 0 - 1. Кроме того, увеличивать или уменьшать объекты можно посредством перемещения курсора, удерживания нажатой левую кнопку мыши.

Копия

Создание копии выбранных объектов для масштабирования.

Опорный отрезок

Масштабирование выбранных объектов относительно существующей и новой длины опорного отрезка.

Длина опорного отрезка <1>: Ввести начальное значение длины, начиная с которого изменяется масштаб выбранных объектов

Новая длина или [Точки]: Ввести конечное значение длины, до которого изменяется масштаб выбранных объектов, или ввести т, чтобы определить длину двумя точками.


МАСШТЕКСТ Команда

М Команды
М Команды
МАСШТЕКСТ Команда
Понятия Процедуры Команды

Увеличение/уменьшение размеров текстовых объектов без изменения их расположения

Панель "Текст":

Меню "Редактирование": "Объект" » "Текст" » "Масштаб"

Ввод команды: масштекст

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Задайте опцию для базовой точки масштабирования [Имеющаяся/вЛево/Центр/сЕредина/впРаво/ВЛ/ВЦ/ВП/СЛ/СЦ/СП/НЛ/НЦ/НП]<Имеющаяся>: Выбрать опцию для базовой точки масштабирования

После отображения запроса на ввод базовой точки необходимо выбрать одно или несколько расположений базовых точек масштабирования для каждого из выбранных текстовых объектов. Опции масштабирования на основе базовой точки такие же, что и для выравнивания текста. Однако выбор базовой точки при масштабировании текстовых объектов не влияет на заданное для этих объектов выравнивание.

Приведенные выше опции поясняются в описании в команды ТЕКСТ. Опции масштабирования однострочного и многострочного текста на основе базовой точки похожи.

Высота текста или [По объекту/Масштабный коэффициент]<0.5000>: Задать высоту текста или задать опцию

По объекту

Масштабирование выбранных текстовых объектов по высоте заданного текстового объекта.

Выберите текстовый объект нужной высоты: Выбрать текстовый объект требуемой высоты

Масштаб

Масштабирование выбранных текстовых объектов относительно существующей и новой длины опорного отрезка.

Масштаб или [Опорный отрезок]: Задать масштабный коэффициент или ввести о

Масштаб

Масштабирование выбранных текстовых объектов на основе заданного масштабного коэффициента.

Опорный отрезок

Масштабирование выбранных текстовых объектов относительно существующей и новой длины опорного отрезка.

Длина опорного отрезка <1>: Задать длину опорного отрезка

Новая длина: Для задания масштаба относительно опорного отрезка задать новую длину

Масштаб выбранных текстовых объектов изменяется в соответствии с отношением существующей и новой длины опорного отрезка. Если новая длина меньше существующей длины опорного отрезка, выбранные текстовые объекты уменьшаются в размерах.


МАТЕРИАЛ Команда

М Команды
М Команды
МАТЕРИАЛ Команда
Понятия Процедуры Команды

Устар.

Ввод команды: материал

Открывается окно "Материалы". (команда МАТЕРИАЛЫ)


МАТЕРИАЛПРИСВ Команда

М Команды
М Команды
МАТЕРИАЛПРИСВ Команда
Понятия Процедуры Команды

Назначает материалы объектам по слоям

Ввод команды: материалприсв

Пульт управления: Панель материалов, применение через слой

Открывает диалоговое окно "Параметры назначения материалов".

Темы:

  • Диалоговое окно "Параметры назначения материалов"


Диалоговое окно "Параметры назначения материалов"

М Команды
М Команды
Диалоговое окно "Параметры назначения материалов"
Понятия Процедуры Команды

Ввод команды: материалприсв

Выполняет связывание материалов со слоями. Все объекты на слое, для которых свойство "Материал" задано ПОСЛОЮ, имеют прикрепленный заданный материал.

Список материалов

Указываются все материалы, имеющиеся в чертеже, независимо от их фактического использования. Для назначения материала определенному слою следует перетащить мышью материал в слой, указанный в списке слоев.

Список слоев

Указываются все слои, имеющиеся в чертеже, и в любой из внешних ссылок, присоединенных к чертежу. Материал, назначенный слою, отображается рядом со слоем. Для открепления материала от слоя используется кнопка "Снять".

Примечание Если изменяется связь между материалом и слоем во внешней ссылке, изменение не сохраняется в исходном чертеже внешней ссылки.


МАТЕРИАЛСООТВ Команда

М Команды
М Команды
МАТЕРИАЛСООТВ Команда
Понятия Процедуры Команды

Отображается ручка блока наложения материалов для корректировки наложений на грань или на объект

Инструментальная панель "Нал тек":

Панель "Тонирование":

Ввод команды: материалсоотв

Пульт управления: Панель "Материалы", всплывающее меню "Наложение текстуры" (соответствие прямоугольников, плоское наложение, сферическое наложение, цилиндрическое наложение)

Выбрать опцию [Прямоугольник/Плоскость/Сферическая/Цилиндрическая/копировать наложение в/восстановить наложение] <текущее>:

Прямоугольник

Выбрать грани или объекты:

В набор объектов необходимо включить объект по меньшей мере одного из следующих типов: 3D тело, 3D поверхность, грань или 2D объект с высотой.

Подтвердить наложение или [Перенести/Поворот/Сброс/Переключить режим наложения]:

Перенести

Отображается ручка "Перемещение" для перемещения текстуры.

Поворот

Отображается ручка "Поворот" для поворота текстуры.

Сброс

Для UV-координат восстанавливаются значения по умолчанию для текстуры.

Переключить режим наложения

Заново отображается основная подсказка.

Плоскость

Подтвердить наложение или [Перенести/Поворот/Сброс/Переключить режим наложения]:

Перенести

Отображается ручка "Перемещение" для перемещения текстуры.

Поворот

Отображается ручка "Поворот" для поворота текстуры.

Сброс

Для UV-координат восстанавливаются значения по умолчанию для текстуры.

Переключить режим наложения

Заново отображается основная подсказка.

Сферическая

Подтвердить наложение или [Перенести/Поворот/Сброс/Переключить режим наложения]:

Перенести

Отображается ручка "Перемещение" для перемещения текстуры.

Поворот

Отображается ручка "Поворот" для поворота текстуры.

Сброс

Для UV-координат восстанавливаются значения по умолчанию для текстуры.

Переключить режим наложения

Заново отображается основная подсказка.

Цилиндрическая

Подтвердить наложение или [Перенести/Поворот/Сброс/Переключить режим наложения]:

Перенести

Отображается ручка "Перемещение" для перемещения текстуры.

Поворот

Отображается ручка "Поворот" для поворота текстуры.

Сброс

Для UV-координат восстанавливаются значения по умолчанию для текстуры.

Переключить режим наложения

Заново отображается основная подсказка.

Копировать наложение в

Выбор объектов для копирования наложения:

Наложение применяется к исходному объекту либо грань прилагается к выбранным объектам.

Восстановить наложение

Для UV-координат восстанавливаются значения по умолчанию для текстуры.


МАТЕРИАЛЫ Команда

М Команды
М Команды
МАТЕРИАЛЫ Команда
Понятия Процедуры Команды

Администрирование, применение и редактирование материалов

Панель "Тонирование":

Меню "Вид": "Тонирование" » "Материалы"

Ввод команды: материалы

Пульт управления: Панель "Материалы", опция "Материалы"

Открывается окно "Материалы".

Темы:

  • Окно "Материалы"
  • Диалоговое окно "Настроить растровое изображение"
  • Редактор свойств инструмента материала
  • Диалоговые окна "Создание нового материала" и "Редактировать имя и описание"


Окно "Материалы"

М Команды
М Команды
Окно "Материалы"
Понятия Процедуры Команды

Панель "Тонирование":

Меню "Вид": "Тонирование" » "Материалы"

Ввод команды: материалы

Пульт управления: Панель "Материалы", опция "Материалы"

Применяются и редактируются материалы. В окне "Материалы" отображаются образцы материалов, имеющихся в чертеже и Редактор материалов.

Материалы, имеющиеся на панели "Рисование"

Отображаются образцы материалов, имеющихся на чертеже. Имя материала по умолчанию "Global" Чтобы выбрать материал нажмите левую кнопку мыши его образце. Настройки для данного материала отображаются в панели "Редактор материалов", и выбираемый образец выделяется желтым цветом. Одна кнопка над образцами и две кнопки под образцами обеспечивают указанные ниже опции. Кроме того, имеются опции, доступные только из контекстного меню.

Переключить экранное отображение

Переключение режима с отображения одиночных образцов на отображение рядов образцов. Данная кнопка находится над образцами.

Геометрия образцов

Управление типом геометрии, отображаемом для выбранного образца: прямоугольник, цилиндр или шар. В других образцах геометрия изменяется по мере их выбора.

Клетчатая подложка Откл/Вкл

Отображается многоцветная клетчатая подложка, обеспечивающая визуализацию степени непрозрачности материала.

Создание нового материала

Открывается диалоговое окно "Создание нового материала". После ввода имени создается новый образец справа от текущего образца и выбирается новый образец.

Удалить из чертежа

Выбранный материал удаляется из чертежа. Материал "Global", а также любой используемый материал, не может быть удален.

Указать используемые материалы

Обновляется изображение используемого значка. Для материалов, используемых в текущем чертеже, в нижнем правом углу образца отображается значок чертежа.

Применить материал к объектам

Текущий материал применяется к выбранным объектам и граням.

Удалить материалы из выбранных объектов

Отменяется применение материалов к выбранным объектам и граням.

Выбирать объекты с материалом (только в контекстном меню)

Выбираются все объекты в чертеже, в которых применяется выбранный материал. Грани с явно присвоенными материалами не выбираются.

Редактировать имя и описание (только в контекстном меню)

Открывается диалоговое окно "Редактировать имя и описание".

Экспортировать в активную инструментальную палитру (только в контекстном меню)

Создается инструмент материала в активной на текущий момент инструментальной палитре. Если окно инструментальных палитр закрыто, оно открывается.

Копировать (только в контекстном меню)

Выбранный материал копируется в буфер обмена. Можно вставить материал в окно инструментальных палитр либо перенести его в виде копии обратно в панель "Доступные материалы".

Вставить (только в контекстном меню)

Выполняется вставка из буфера обмена либо образца из панели "Доступные материалы", либо инструмента материалов из окна инструментальной палитры.

Размер (только в контекстном меню)

Определяется размер образцов, отображаемых в виде рядов.

Редактор материалов

Редактируются материалы, выбранные в меню "Доступные материалы" в панели "Чертеж". Имя выбранного материала отображается вслед за "Редактором материалов". Конфигурация редактора материалов изменяется в зависимости от выбранного шаблона.

Шаблон

Указывает тип материала Шаблоны "Реалистичный" и "Реалистичное тонирование металла" предназначены для материала, основанного на физических свойствах. Шаблоны "Дополнительный" и "Улучшенное тонирование металла" предназначены для материалов с дополнительными опциями, в том числе со свойствами, которые можно использовать для создания специальных эффектов; например, имитированных отражений.

Диффузный (шаблоны "Реалистичный" и "Реалистичное тонирование металла")

Открывается диалоговое окно "Выбор цвета", в котором можно указывать цвет материала.

По объекту (шаблоны "Реалистичный" и "Реалистичное тонирование металла")

Определяется цвет материала на основе цвета объекта, которому он назначается.

Рассеиваемый (шаблоны "Дополнительные" и "Улучшенное тонирование металла")

Открывается диалоговое окно "Выбор цвета", в котором можно указывать цвет, появляющийся на тех гранях, которые освещаются только рассеянным светом.

Значок "Первая блокировка" (шаблоны "Дополнительные" и "Улучшенное тонирование металла")

В заблокированном состоянии значок блокировки между опциями "Рассеиваемый" и "Диффузный" устанавливает в качестве цвета рассеянного освещения материала диффузный цвет. Опция "По объекту" недоступна.

Диффузный (шаблоны "Дополнительные" и "Улучшенное тонирование металла"):

Открывается диалоговое окно "Выбор цвета", в котором можно указывать диффузный цвет материала. Диффузный цвет является основным цветом объекта.

Значок "Вторая блокировка" (только шаблон "Дополнительные")

В заблокированном состоянии значок блокировки между опциями "Рассеиваемый" и "Цвет блика" устанавливает в качестве цвета блика материала диффузный цвет. Опция "По объекту" недоступна.

Цвет блика (только шаблон "Дополнительные")

Открывается диалоговое окно "Выбор цвета", в котором можно указывать цвет блика на блестящем материале. Размер блика зависит от степени блеска материала.

По объекту (только шаблон "Дополнительные")

Определяется цвет материала на основе цвета объекта, которому он назначен.

Блеск

Устанавливается степень блеска материала. Блик на грани тела с очень высокой степенью блеска имеет уменьшенные размеры и повышенную яркость. На менее блестящей грани происходит отражение света во многих направлениях, в результате чего создается блик большего размера с пониженной яркостью.

Коэффициент преломления

Задается коэффициент преломления материала. Определяется способ преломления света при прохождении через объект, которому назначен частично прозрачный материал. Например, при коэффициенте преломления 1 (для воздуха) объект позади прозрачного объекта не искажается. При коэффициенте, равном 1,5, происходит сильное искажение объекта, как при взгляде сквозь стеклянный шарик. Не применимо к шаблонам металлов.

Степень прозрачности

Задается степень прозрачности материала. Не применима к типу материала "Реалистичное тонирование металла". Полупрозрачный объект пропускает свет, но свет рассеивается также внутри объекта. Степень прозрачности выражается в процентах: при значении 0 материал не является просвечивающим; при 100 материал является просвечивающим в максимально возможной степени. Не применимо к шаблонам металлов.

Самосвечение

При положительном ненулевом значении объект представляется испускающим свет независимо от источников света в чертеже.

Текстура рассеяния

Если установлен данный флажок, текстура рассеяния активизируется в материале и становится доступной для тонирования.

Тип текстуры

Указывается тип текстуры. Можно использовать изображение из файла (например, плиточный образец) либо выбрать в качестве обрабатываемого материала дерево или мрамор.

Выбор изображения

Открывается диалоговое окно "Выбор файла изображения", стандартное диалоговое окно выбора файла. После выбора файла отображается имя файла.

В качестве текстур могут быть использованы следующие форматы:

  • TGA (.tga)
  • BMP (.bmp, .rle, .dib)
  • PNG (.png)
  • JFIF (.jpg, .jpeg)
  • TIFF (.tif)
  • GIF (.gif)
  • PCX (.pcx)

Кнопка "Настроить растровое изображение"

Открывается диалоговое окно "Настроить растровое изображение", в котором можно корректировать масштаб, мозаичное размещение окон, смещение и угол поворота файла изображения.

Кнопка "Удалить информацию о текстуре"

Удаляет выбранную информацию о текстуре материала.

Кнопка "Дополнительная правка текстуры" (дерево)

Открывается окно с панелью для корректировки внешнего вида текстуры.

  • Цвет 1. Открывается диалоговое окно "Выбор цвета".
  • Цвет 2. Открывается диалоговое окно "Выбор цвета".
  • Радиальные помехи: Устанавливается относительная неупорядоченность штриховки в плоскости, перпендикулярной зерну. Область значений равна 0-100, значение по умолчанию равно 1,00.
  • Осевые помехи: Устанавливается относительная неупорядоченность штриховки в плоскости, параллельной зерну. Область значений равна 0-100, значение по умолчанию равно 1,00.
  • Толщина зерна:Задается относительная толщина цветовых полос, образующих зерно. Область значений равна 0-100, значение по умолчанию равно 0,50.

Кнопка "Дополнительная правка текстуры" (мрамор)

Открывается окно с панелью для корректировки внешнего вида текстуры.

  • Цвет камня. Открывается диалоговое окно "Выбор цвета".
  • Цвет прожилок. Открывается диалоговое окно "Выбор цвета".
  • Шаг прожилок.Задается шаг между прожилками. Область значений равна 0-100, значение по умолчанию равно 1,00.
  • Ширина прожилок.Задается ширина прожилок. Область значений равна 0-100, значение по умолчанию равно 1,00.
Отражение (шаблоны "Дополнительные" и "Улучшенное тонирование металла")

Определяется, насколько отражающим является материал. Текстуры отражения (именуемые также текстурами среды) имитируют отражение на поверхности блестящего объекта. Чем выше значение, тем более отражающим является материал. Область значений равна 0-100, значение по умолчанию равно 0.

Выбор изображения

Открывается диалоговое окно "Выбор файла изображения", стандартное диалоговое окно выбора файла. После выбора файла отображается имя файла.

Кнопка "Настроить растровое изображение"

Открывается диалоговое окно "Настроить растровое изображение", в котором можно корректировать масштаб, мозаичное размещение окон, смещение и угол поворота файла изображения.

Кнопка "Удалить информацию о текстуре"

Удаляет выбранную информацию о текстуре материала.

Прозрачность

Определяется, какие участки материала должны быть прозрачными и какие непрозрачными. Участки, к которым применяется текстура прозрачности, представляются прозрачными; другие участки выглядят непрозрачными. Участки материала, являющиеся здесь прозрачными, имеют специфическую подсветку (такую, какая возникает на стеклянных участках). Область значений равна 0-100, значение по умолчанию равно 1.

Выбор изображения

Открывается диалоговое окно "Выбор файла изображения", стандартное диалоговое окно выбора файла. После выбора файла отображается имя файла.

Кнопка "Настроить растровое изображение"

Открывается диалоговое окно "Настроить растровое изображение", в котором можно корректировать масштаб, мозаичное размещение окон, смещение и угол поворота файла изображения.

Кнопка "Удалить информацию о текстуре"

Удаляет выбранную информацию о текстуре материала.

Текстура выдавливания

Добавляются характеристики поверхности к грани без изменения ее геометрии.

Регулятор текстуры выдавливания

Управляет свойством выпуклости текстуры. Область значений равна -1000 ... +1000, значение по умолчанию равно 30,0. Регулятор перемещается указательным устройством с приращением по 30 единиц или с помощью клавиш со стрелками на клавиатуре - с приращением по 5 единиц.

Выбор изображения

Открывается диалоговое окно "Выбор файла изображения", стандартное диалоговое окно выбора файла. После выбора файла отображается имя файла.

Кнопка "Настроить растровое изображение"

Открывается диалоговое окно "Настроить растровое изображение", в котором можно корректировать масштаб, мозаичное размещение окон, смещение и угол поворота файла изображения.

Кнопка "Удалить информацию о текстуре"

Удаляет выбранную информацию о текстуре материала.


Диалоговое окно "Настроить растровое изображение"

М Команды
М Команды
Диалоговое окно "Настроить растровое изображение"
Понятия Процедуры Команды

Ввод команды: материалы

Редактируются характеристики масштаба, мозаичного размещения и смещения текстур на материалах.

Масштаб изображения

Задается тип масштабирования для растрового изображения.

Масштаб

Задается масштаб растрового изображения для грани или объекта с использованием фиксированного масштаба или реального масштаба.

Вписать в объект

Вписывается растровое изображение в грань или объект.

Мозаика

Если данный флажок установлен, растровое изображение отображается в объекте столько раз, сколько она вписывается. Если флажок отсутствует, растровое изображение отображается в объекте однократно.

Единицы

Указываются единицы, используемые в масштабировании. "Нет" означает использование фиксированного масштаба. Выбор типа единиц для масштаба в единицах натурального масштаба. Данная опция недоступна, если выбрана опция "Вписать в объект".

Не изменять пропорции

Фиксируются очертания растрового изображения. Исходные значения мозаики для U и мозаики для V определяются на основе пропорций растрового изображения. Наибольшее из двух значений приравнивается единице, а другое значение устанавливается с целью сохранения неизменных пропорций. Если изменяется значение длины или ширины, другое значение изменяется в той степени, которая требуется для сохранения очертаний.

Мозаика для U

Корректируется мозаичное размещение растрового изображения вдоль оси U. Просмотровый образец обновляется по мере изменения значения. Данное значение может быть задано в интерактивном режиме путем перемещения ползунка рядом с образцом.

UVW-координаты схожи с XYZ-координатами, но относятся к растровому изображению и перемещаются вместе с ним при его перемещении или повороте.

Мозаика для V

Корректируется мозаичное размещение растрового изображения вдоль оси V. Просмотровый образец обновляется по мере изменения значения. Данное значение может быть задано в интерактивном режиме путем перемещения ползунка рядом с образцом.

Ширина

Задается ширина растрового изображения в единицах, указанных в поле "Единицы", на грани или на объекте

Высота

Задается высота растрового изображения в единицах, указанных в поле "Единицы", на грани или на объекте.

Интерактивная настройка

Корректируются масштаб, смещение и угол поворота растрового изображения в интерактивном режиме. Изменение смещения по осям U и V обеспечивается нажатием левой кнопки мыши и перетаскиванием. Новые значения отображаются в полях "Смещение для U" и "Смещение для V". Поворот изображения обеспечивается нажатием правой кнопки мыши и перетаскиванием в площади за пределами центрального прямоугольника. Новые значения отображаются в поле "Поворот".

Размер образца для просмотра

Увеличивается и уменьшается размер просмотрового образца. Используются кнопка "минус" и кнопка "плюс".

Просмотр

Отображается просмотровый образец растрового изображения на грани или на объекте, обновляемый по мере изменения настроек пользователем. Смещение по осям U и V корректируется нажатием левой кнопки мыши и перетаскиванием внутри квадрата. Поворот изображения обеспечивается нажатием левой кнопки за пределами квадрата.

Если выбрана опция "Масштаб", квадрат отображает единичную мозаичную ячейку. Если для единиц установлено значение "Нет", то единица устанавливается равной единицам, используемым в чертеже. Если выбрана опция "Вписать в объект", квадрат отображает мозаичную ячейку, растягиваемую для вписывания грани в объект.

Ползунок мозаики для U

Корректируется мозаичное размещение растрового изображения вдоль оси U. Просмотровый образец обновляется по мере изменения значения.

Ползунок мозаики для V

Корректируется мозаичное размещение растрового изображения вдоль оси V. Просмотровый образец обновляется по мере изменения значения.

Блокировать

Фиксируются очертания растрового изображения. Если изменяется значение длины или ширины, другое значение изменяется в той степени, которая требуется для сохранения очертаний.

Смещение для U

Начальная точка растрового изображения перемещается вдоль оси U. Данное значение может быть задано в интерактивном режиме путем перемещения квадрата внутри образца.

Смещение для V

Начальная точка растрового изображения перемещается вдоль оси V. Данное значение может быть задано в интерактивном режиме путем перемещения квадрата внутри образца.

Поворот

Растровое изображение поворачивается вокруг оси W системы UVW-координат. Поворот не обеспечивается для сферического и цилиндрического наложения. МАТЕРИАЛСООТВ используется для отображения ручек, обеспечивающих поворот для сферических и цилиндрических текстур.

Восстановить исходные значения

Восстанавливаются значения, существовавшие на момент открытия диалогового окна.


Редактор свойств инструмента материала

М Команды
М Команды
Редактор свойств инструмента материала
Понятия Процедуры Команды

Ввод команды: материалы

Определяются свойства выбранного инструмента материала. Отображаемые здесь свойства описываются в разделе "Редактор материалов" окна "Материалы". Некоторые свойства, например, "геометрия образца" и "клетчатая подложка", отсутствуют в Редакторе свойств инструмента материала.

При редактировании инструмента материала изменяется только сам инструмент. Если материал используется на чертеже, и пользователю требуется применить изменения, следует использовать инструмент материала и вновь применить измененный материала к объектам.

Чтобы сделать измененный материал доступным на чертеже, следует применить его к объектам на чертеже или скопировать его в окно "Материалы".

В отличие от палитры "Свойства" Редактор свойств инструмента материала следует закрыть, и только после этого можно продолжать работу с чертежом.


Диалоговые окна "Создание нового материала" и "Редактировать имя и описание"

М Команды
М Команды
Диалоговые окна "Создание нового материала" и "Редактировать имя и описание"
Понятия Процедуры Команды

Ввод команды: материалы

Назначаются имена материалам и обеспечивается пространство для описания.

Имя

Назначается имя материалу.

Описание

Приводится дополнительное описание для материала.


МАТЕРИАЛЫЗАКР Команда

М Команды
М Команды
МАТЕРИАЛЫЗАКР Команда
Понятия Процедуры Команды

Закрывается окно "Материалы".

Ввод команды: материалызакр

Закрывается окно "Материалы".


МВСТАВИТЬ Команда

М Команды
М Команды
МВСТАВИТЬ Команда
Понятия Процедуры Команды

Вставка множества экземпляров блока в прямоугольный массив

Ввод команды: мвставить

Имя блока или [?]: Введите имя или ? для вывода списка блоков, определенных в настоящий момент в чертеже, или введите ~ для отображения диалогового окна "Выбор файла чертежа"

Примечание Для данной команды в отличие от команды ВСТАВИТЬ не допускается расчленение блока при вставке путем ввода звездочки (*) перед именем блока.

Точка вставки или [Масштаб/X/Y/Z/Поворот/ПМасштаб/PX/PY/PZ/ППоворот]: Указать точку или задать опцию

Опции команды при выборе точки вставки служат для указания масштаба и угла поворота заранее, до ввода точки вставки. Это бывает полезно при перетаскивании блока, масштаб которого должен быть отличен от 1 (или угол поворота — от 0). При вводе одного из параметров необходимо задать расстояние для параметров масштаба или угла поворота в соответствии с запросами.

Блоки, вставляемые по команде МВСТАВИТЬ, нельзя расчленить.

Точка вставки

Задание местоположения блоков.

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, задать опцию или нажать ENTER

Масштабный коэффициент по оси X

Задание масштабных коэффициентов по осям X и Y.

Масштаб по оси Y <равен масштабу по X>: Ввести значение или нажать ENTER для применения того же масштабного коэффициента

Угол поворота <0>:

Введенный угол поворота определяет поворот как массива в целом, так и отдельных блоков в нем.

Число строк (---) <1>: Ввести положительное значение

Число столбцов ( | | | ) <1>: Ввести положительное значение

При задании более одной строки отображается следующий запрос:

Расстояние между рядами или размер ячейки (---): Ввести значение или указать две точки для определения поля, ширина и высота которого обозначают расстояние между рядами и столбцами

Если число столбцов больше одного, а размер ячейки не указан, отображается следующий запрос:

Расстояние между столбцами ( | | | ): Ввести значение или указать расстояние

Угол

Задание масштабного коэффициента по точке вставки блока и противоположному углу.

Противоположный угол: Указать точку

Угол поворота <0>:

Введенный угол поворота определяет поворот как массива в целом, так и отдельных блоков в нем.

Число строк (---) <1>: Ввести положительное значение

Число столбцов ( | | | ) <1>: Ввести положительное значение

При задании более одной строки отображается следующий запрос:

Расстояние между рядами или размер ячейки (---): Ввести значение или указать две точки для определения поля, ширина и высота которого обозначают расстояние между рядами и столбцами

Если число столбцов больше одного, а размер ячейки не указан, отображается следующий запрос:

Расстояние между столбцами ( | | | ): Ввести значение или указать расстояние

XYZ

Задание масштабных коэффициентов по осям X, Y и Z.

Масштаб по оси X или [Угол] <1>: Ввести значение или нажать ENTER для задания такого же масштабного коэффициента

Если введено у, необходимо указать противоположную угловую точку. Масштабные коэффициенты по X и Y определяются по указанной точке и точке вставки блока.

Масштаб по оси Y или <равен масштабу по X>: Ввести значение или нажать ENTER для задания такого же масштабного коэффициента

Масштаб по оси Z <равен масштабу по X>: Ввести значение или нажать ENTER для применения того же масштабного коэффициента

Угол поворота <0>:

Введенный угол поворота определяет поворот как массива в целом, так и отдельных блоков в нем.

Число строк (---) <1>: Ввести положительное значение

Число столбцов ( | | | ) <1>: Ввести положительное значение

При задании более одной строки отображается следующий запрос:

Расстояние между рядами или размер ячейки (---): Ввести значение или указать две точки для определения поля, ширина и высота которого обозначают расстояние между рядами и столбцами

Если число столбцов больше одного, а размер ячейки не указан, отображается следующий запрос:

Расстояние между столбцами ( | | | ): Ввести значение или указать расстояние

Масштаб

Задание масштабных коэффициентов блока по осям X, Y и Z. По оси Z используется абсолютное значение введенной величины.

Масштаб по осям X, Y и Z: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

Введенный угол поворота определяет поворот как массива в целом, так и отдельных блоков в нем.

Число строк (---) <1>: Ввести положительное значение

Число столбцов ( | | | ) <1>: Ввести положительное значение

При задании более одной строки отображается следующий запрос:

Расстояние между рядами или размер ячейки (---): Ввести значение или указать две точки для определения поля, ширина и высота которого обозначают расстояние между рядами и столбцами

При задании более одной строки отображается следующий запрос:

Расстояние между столбцами ( | | | ): Ввести значение или указать расстояние

X

Задание масштабного коэффициента по оси X.

Масштаб по оси X: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

Введенный угол поворота определяет поворот как массива в целом, так и отдельных блоков в нем.

Число строк (---) <1>: Ввести положительное значение

Число столбцов ( | | | ) <1>: Ввести положительное значение

При задании более одной строки отображается следующий запрос:

Расстояние между рядами или размер ячейки (---): Ввести значение или указать две точки для определения поля, ширина и высота которого обозначают расстояние между рядами и столбцами

Если число столбцов больше одного, а размер ячейки не указан, отображается следующий запрос:

Расстояние между столбцами ( | | | ): Ввести значение или указать расстояние

Y

Задание масштабного коэффициента по оси Y.

Масштаб по оси Y: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

Введенный угол поворота определяет поворот как массива в целом, так и отдельных блоков в нем.

Число строк (---) <1>: Ввести положительное значение

Число столбцов ( | | | ) <1>: Ввести положительное значение

При задании более одной строки отображается следующий запрос:

Расстояние между рядами или размер ячейки (---): Ввести значение или указать две точки для определения поля, ширина и высота которого обозначают расстояние между рядами и столбцами

Если число столбцов больше одного, а размер ячейки не указан, отображается следующий запрос:

Расстояние между столбцами ( | | | ): Ввести значение или указать расстояние

Z

Задание масштабного коэффициента по оси Z.

Масштаб по оси Z: Ввести ненулевое значение

Точка вставки:

Угол поворота <0>:

Введенный угол поворота определяет поворот как массива в целом, так и отдельных блоков в нем.

Число строк (---) <1>: Ввести положительное значение

Число столбцов ( | | | ) <1>: Ввести положительное значение

При задании более одной строки отображается следующий запрос:

Расстояние между рядами или размер ячейки (---): Ввести значение или указать две точки для определения поля, ширина и высота которого обозначают расстояние между рядами и столбцами

Если число столбцов больше одного, а размер ячейки не указан, отображается следующий запрос:

Расстояние между столбцами ( | | | ): Ввести значение или указать расстояние

Поворот

Задание угла вставки для массива в целом, и для входящих в него отдельных блоков.

Угол поворота <0>:

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, задать опцию или нажать ENTER

Масштабный коэффициент по оси X

Задание масштабного коэффициента по оси X.

Масштаб по оси Y <равен масштабу по X>: Ввести значение или нажать ENTER для применения того же масштабного коэффициента

Число строк (---) <1>: Ввести положительное значение

Число столбцов ( | | | ) <1>: Ввести положительное значение

При задании более одной строки отображается следующий запрос:

Расстояние между рядами или размер ячейки (---): Ввести значение или указать расстояние

Если число столбцов больше одного, а размер ячейки не указан, отображается следующий запрос:

Расстояние между столбцами ( | | | ): Ввести значение или указать расстояние

Угол

Задание масштаба по указанной точке и точке вставки блока.

Противоположный угол: Указать точку

Число строк (---) <1>: Ввести положительное значение

Число столбцов ( | | | ) <1>: Ввести положительное значение

При задании более одной строки отображается следующий запрос:

Расстояние между рядами или размер ячейки (---): Ввести значение или указать расстояние

Если число столбцов больше одного, а размер ячейки не указан, отображается следующий запрос:

Расстояние между столбцами ( | | | ): Ввести значение или указать расстояние

XYZ

Масштаб по оси X или [Угол] <1>: Задать ненулевое значение, ввести у или нажать ENTER

Масштабные коэффициенты по осям X и Y можно задать численным значением или указанием угловой точки. Во втором случае масштабы в направлениях X и Y определяются по заданной угловой точке и точке вставки.

Масштаб по оси Z <равен масштабу по X>: Ввести значение или нажать ENTER для задания такого же значения масштаба

Число строк (---) <1>: Ввести положительное значение

Число столбцов ( | | | ) <1>: Ввести положительное значение

При задании более одной строки отображается следующий запрос:

Расстояние между рядами или размер ячейки (---): Ввести значение или указать расстояние

Если число столбцов больше одного, а размер ячейки не указан, отображается следующий запрос:

Расстояние между столбцами ( | | | ): Ввести значение или указать расстояние

ПМасштаб

Задание масштабных коэффициентов блока по осям X, Y и Z для управления отображением блока в процессе его перетаскивания на позицию вставки.

Предварительный масштаб по осям X, Y и Z: Ввести ненулевое значение

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, задать опцию или нажать ENTER

Описание параметров "Масштаб по Х", "Угол" и "XYZ" совпадает с описанием соответствующих параметров в списке "Поворот".

PX

Задание масштабного коэффициента по оси X для управления отображением блока в процессе его перетаскивания на позицию вставки.

Предварительный масштаб по оси X: Ввести ненулевое значение

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, задать опцию или нажать ENTER

Описание параметров "Масштаб по Х", "Угол" и "XYZ" совпадает с описанием соответствующих параметров в списке "Поворот".

PY

Задание масштабного коэффициента блока по оси Y для управления отображением блока в процессе его перетаскивания на позицию вставки.

Предварительный масштаб по оси Y: Ввести ненулевое значение

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, задать опцию или нажать ENTER

Описание параметров "Масштаб по Х", "Угол" и "XYZ" совпадает с описанием соответствующих параметров в списке "Поворот".

PZ

Задание масштабного коэффициента блока по оси Z для управления отображением блока в процессе его перетаскивания на позицию вставки.

Предварительный масштаб по оси Z: Ввести ненулевое значение

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, задать опцию или нажать ENTER

Описание параметров "Масштаб по Х", "Угол" и "XYZ" совпадает с описанием соответствующих параметров в списке "Поворот".

ППоворот

Задание угла поворота блока для слежения при вставке.

Предварительный угол поворота:

Точка вставки:

Введите масштаб по оси X, укажите противоположный угол или [Угол/XYZ] <1>: Ввести значение, задать опцию или нажать ENTER

Описание параметров "Масштаб по Х", "Угол" и "XYZ" совпадает с описанием соответствующих параметров в списке "Поворот".


МЕНЮ Команда

М Команды
М Команды
МЕНЮ Команда
Понятия Процедуры Команды

Загружает файл адаптации

Ввод команды: меню

Открывается диалоговое окно "Выбор файла адаптации" (стандартное диалоговое окно выбора файлов). Ввести или выбрать имя файла адаптации. При нажатии ENTER или выборе опции "Открыть" загружается файл с заданным именем.

Файл адаптации - это файл на основе XML, содержащий меню, панели инструментов, рабочие пространства, палитры инструментов и прочие элементы интерфейса, которые можно настроить.

Пользователь может создать адаптированный файл меню и загрузить его с помощью МЕНЮ или НПИ.

Примечание Файл наследуемого меню (MNS) и шаблон наследуемого меню (MNU), использованные в предыдущих версиях, заменены файлом одного типа - файлом НПИ на основе XML.


МЕНЮВЫГР Команда

М Команды
М Команды
МЕНЮВЫГР Команда
Понятия Процедуры Команды

Устар.

Ввод команды: менювыгр

Открывается диалоговое окно "Загрузка/выгрузка адаптаций". (НПИВЫГРкоманда)

Примечание Файл наследуемого меню (MNS) и шаблон наследуемого меню (MNU), использованные в предыдущих версиях, заменены файлом одного типа - файлом НПИ на основе XML.


МЕНЮЗАГР Команда

М Команды
М Команды
МЕНЮЗАГР Команда
Понятия Процедуры Команды

Устар.

Ввод команды: менюзагр

Открывается диалоговое окно "Загрузка/выгрузка адаптаций". (НПИЗАГРкоманда)

Примечание Файл наследуемого меню (MNS) и шаблон наследуемого меню (MNU), использованные в предыдущих версиях, заменены файлом одного типа - файлом НПИ на основе XML.


МЛИНИЯ Команда

М Команды
М Команды
МЛИНИЯ Команда
Понятия Процедуры Команды

Создание нескольких параллельных отрезков

Меню "Рисование": Мультилинии

Ввод команды: млиния

Текущие настройки: Выравнивание = текущее, масштаб = текущий, стиль = текущий

Начальная точка или [Выравнивание/Масштаб/Стиль]: Указать точку или задать опцию

Начальная точка

Задание следующей вершины мультилинии.

Следующая точка:

Следующая точка или [Отменить]: Указать точку или ввести о

При создании мультилинии из двух или нескольких сегментов в запрос будет добавлен параметр "Замкнуть".

Следующая точка или [Замкнуть/Отменить]: Указать точку или задать опцию

Следующая точка

Сегмент мультилинии строится до указанной точки с использованием текущего стиля; далее выдаются запросы указания следующих точек.

Отменить

Отмена ввода последней вершины мультилинии. Отобразится предыдущий запрос.

Замкнуть

Последний сегмент мультилинии соединяется с первым, и мультилиния замыкается.

Выравнивание

Определение положения указываемых точек относительно всей мультилинии.

Тип выравнивания [Верх/Центр/Низ] <текущий>: Задать опцию или нажать ENTER

Сверху

Мультилиния рисуется ниже курсора; через указанные точки проходит линия с наибольшим положительным смещением.

Центр

Мультилиния центрируется относительно курсора; указываемые точки соответствуют смещению 0,0 (смещение элементов задается в диалоговом окне "Свойства элементов" команды МЛСТИЛЬ).

Снизу

Мультилиния рисуется выше курсора; через указанные точки проходит линия с наибольшим отрицательным смещением.

Масштаб

Управление шириной мультилинии. Данный масштаб не влияет на масштаб типа линий.

Масштаб мультилинии <текущий>: Ввести масштаб или нажать ENTER

Масштабный коэффициент определяется на основе ширины, заданной в определении стиля мультилинии. При масштабе, равном 2, мультилиния вдвое шире, чем указано в описании. Если масштаб отрицателен, то порядок следования линий в зависимости от смещения изменяется на обратный—линия с наименьшим смещением находится сверху при построении мультилинии слева направо. Отрицательное значение масштаба приводит также к замене единиц выражения масштаба на абсолютные значения. Если масштаб равен 0, мультилиния сжимается в одну линию. Подробнее о стилях мультилиний см. описание команды МЛСТИЛЬ.

Стиль

Задает стиль для мультилинии. См. Построение объектов мультилиний в Руководстве пользователя и описание команды МЛСТИЛЬ.

Имя стиля мультилиний или [?]: Введите имя или ?

Имя стиля

Указывается имя стиля, который уже загружен либо описан в библиотечном MLN-файле, созданном пользователем.

?—Список стилей

Вывод списка загруженных стилей мультилиний.


МЛРЕД Команда

М Команды
М Команды
МЛРЕД Команда
Понятия Процедуры Команды

Редактирует пересечения мультилиний, разрывы и вершины

Меню "Редактирование": "Объект" » "Мультилинии"

Ввод команды: млред

Откроется диалоговое окно "Редактирование мультилинии".

Если при запросе "Команда" ввести -млред, команда МЛРЕД, отображает запросы в командной строке.

Темы:

  • Диалоговое окно "Редактирование мультилинии"
  • командная строка МЛРЕД


Диалоговое окно "Редактирование мультилинии"

М Команды
М Команды
Диалоговое окно "Редактирование мультилинии"
Понятия Процедуры Команды

Меню "Редактирование": "Объект" » "Мультилинии"

Ввод команды: млред

Изменяет объекты мультилиний. В диалоговом окне инструменты с образцами изображений отображаются в четырех столбцах. Первый столбец управляет пересекающимися мультилиниями, второй - мультилиниями, образующими пересечение в форме Т, третий - угловыми соединениями и вершинами, а четвертый - разрывами мультилиний.

Закрытый крест

Создание пересечения мультилиний в форме закрытого креста.

Выберите первую мультилинию: Выбрать мультилинию для переднего плана

Выберите вторую мультилинию: Выбрать пересекающуюся мультилинию

Строится пересечение в форме закрытого креста, после чего выводится следующий запрос:

Выберите первую мультилинию или [Отменить]: Выбрать следующую мультилинию или ввести о

Первая мультилиния

Редактирование следующей мультилинии. После этого программа предлагает выбрать вторую мультилинию.

Отменить

Отмена создания закрытого крестообразного пересечения. После этого программа предлагает выбрать первую мультилинию.

Открытый крест

Создание пересечения мультилиний в форме открытого креста. Разрываются все элементы первой мультилинии и наружные элементы второй.

Выберите первую мультилинию: Выбрать мультилинию

Выберите вторую мультилинию: Выбрать пересекающуюся мультилинию

Строится пересечение в форме открытого креста, после чего выводится следующий запрос:

Выберите первую мультилинию или [Отменить]: Выбрать следующую мультилинию или ввести о

Первая мультилиния

Редактирование следующей мультилинии. После этого программа предлагает выбрать вторую мультилинию.

Отменить

Отмена создания открытого крестообразного пересечения. После этого программа предлагает выбрать первую мультилинию.

Сплошной крест

Создание пересечения мультилиний в форме сплошного креста. Порядок выбора мультилиний значения не имеет.

Выберите первую мультилинию: Выбрать мультилинию

Выберите вторую мультилинию: Выбрать пересекающуюся мультилинию

Строится пересечение в форме сплошного креста, после чего выводится следующий запрос:

Выберите первую мультилинию или [Отменить]: Выбрать следующую мультилинию или ввести о

Первая мультилиния

Редактирование следующей мультилинии. После этого программа предлагает выбрать вторую мультилинию.

Отменить

Отмена создания сплошного крестообразного пересечения. После этого программа предлагает выбрать первую мультилинию.

Закрытое Т

Создание пересечения мультилиний в форме закрытого Т. Программа обрезает или удлиняет первую мультилинию до пересечения со второй.

Выберите первую мультилинию: Выбрать мультилинию, которая будет обрезана или удлинена

Выберите вторую мультилинию: Выбрать пересекающуюся мультилинию

Строится пересечение в форме закрытого T, после чего выводится следующий запрос:

Выберите первую мультилинию (или "Отменить"): Выбрать следующую мультилинию или ввести о

Первая мультилиния

Редактирование следующей мультилинии. После этого программа предлагает выбрать вторую мультилинию.

Отменить

Отмена создания закрытого Т-образного пересечения. После этого программа предлагает выбрать первую мультилинию.

Открытое Т

Создание пересечения мультилиний в форме открытого Т. Программа обрезает или удлиняет первую мультилинию до пересечения со второй.

Выберите первую мультилинию: Выбрать мультилинию, которая будет обрезана или удлинена

Выберите вторую мультилинию: Выбрать пересекающуюся мультилинию

Строится пересечение в форме открытого T, после чего выводится следующий запрос:

Выберите первую мультилинию (или "Отменить"): Выбрать следующую мультилинию или ввести о

Первая мультилиния

Редактирование следующей мультилинии. После этого программа предлагает выбрать вторую мультилинию.

Отменить

Отмена создания открытого Т-образного пересечения. После этого программа предлагает выбрать первую мультилинию.

Сплошное Т

Создание пересечения мультилиний в форме сплошного Т. Программа обрезает или удлиняет мультилинию до пересечения с другой мультилинией.

Выберите первую мультилинию: Выбрать мультилинию, которая будет обрезана или удлинена

Выберите вторую мультилинию: Выбрать пересекающуюся мультилинию

Строится пересечение в форме сплошного T, после чего выводится следующий запрос:

Выберите первую мультилинию (или "Отменить"): Выбрать следующую мультилинию или ввести о

Первая мультилиния

Редактирование следующей мультилинии. После этого программа предлагает выбрать вторую мультилинию.

Отменить

Отмена создания сплошного Т-образного пересечения. После этого программа предлагает выбрать первую мультилинию.

Угловой стык

Создание углового стыка в месте пересечения мультилиний. Программа обрезает или удлиняет мультилинии до их пересечения.

Выберите первую мультилинию: Выбрать мультилинию, которая будет обрезана или удлинена

Выберите вторую мультилинию: Выбрать вторую мультилинию для углового стыка

Строится угловой стык, после чего выводится следующий запрос:

Выберите первую мультилинию (или "Отменить"): Выбрать следующую мультилинию или ввести о

Первая мультилиния

Редактирование следующей мультилинии. После этого программа предлагает выбрать вторую мультилинию.

Отменить

Отмена создания углового стыка. После этого программа предлагает выбрать первую мультилинию.

Добавить вершину

Добавление вершины для мультилинии.

Выберите мультилинию: Выбрать мультилинию

Программа добавляет в выбранной точке вершину и выдает следующий запрос:

Выберите мультилинию или [Отменить]: Выбрать следующую мультилинию или ввести о

Мультилиния

Редактирование следующей мультилинии. После этого программа снова предлагает выбрать мультилинию.

Отменить

Удаление добавленной вершины. После этого программа предлагает выбрать мультилинию.

Удалить вершину

Удаление вершины мультилинии.

Выберите мультилинию: Выбрать мультилинию

Программа удаляет ближайшую к выбранной точке вершину и выдает следующий запрос:

Выберите мультилинию или [Отменить]: Выбрать следующую мультилинию или ввести о

Мультилиния

Редактирование следующей мультилинии. После этого программа снова предлагает выбрать мультилинию.

Отменить

Восстановление удаленной вершины. После этого программа предлагает выбрать мультилинию.

Обрезать один

Создает визуальный разрыв в выбранном элементе мультилинии.

Выберите мультилинию: Выбрать мультилинию

Программа принимает выбранную точку в качестве первой точки для обрезки и выводит запрос:

Укажите вторую точку: Указать вторую точку обрезки на мультилинии

Элемент обрезается, после чего выводится следующий запрос:

Выберите мультилинию или [Отменить]: Выбрать следующую мультилинию или ввести о

Мультилиния

Редактирование следующей мультилинии. После этого программа снова предлагает выбрать мультилинию.

Отменить

Отмена обрезки. После этого программа предлагает выбрать мультилинию.

Обрезать все

Создает визуальный разрыв через всю мультилинию.

Выберите мультилинию: Выбрать мультилинию

Программа принимает выбранную точку в качестве первой точки для обрезки и выводит запрос:

Укажите вторую точку: Указать вторую точку обрезки на мультилинии

Все элементы мультилинии обрезаются, после чего выдается следующий запрос:

Выберите мультилинию или [Отменить]: Выбрать следующую мультилинию или ввести о

Мультилиния

Редактирование следующей мультилинии. После этого программа снова предлагает выбрать мультилинию.

Отменить

Отмена обрезки. После этого программа предлагает выбрать мультилинию.

Соединить все

Соединение разделенных сегментов мультилинии.

Выберите мультилинию: Выбрать мультилинию

Программа принимает выбранную точку в качестве начальной точки для соединения и выводит запрос:

Укажите вторую точку: Указать на мультилинии вторую точку соединения

Все элементы мультилинии соединяются, после чего выдается следующий запрос:

Выберите мультилинию или [Отменить]: Выбрать следующую мультилинию или ввести о

Мультилиния

Редактирование следующей мультилинии. После этого программа снова предлагает выбрать мультилинию.

Отменить

Отмена соединения. После этого программа снова предлагает выбрать мультилинию.


командная строка МЛРЕД

М Команды
М Команды
командная строка МЛРЕД
Понятия Процедуры Команды

Если при запросе "Команда" ввести -млред, команда МЛРЕД отображает запросы в командной строке.

Для получения дополнительных сведений об этих параметрах командной строки см. диалоговое окно "Редактирование мультилинии".

CC

Создание пересечения мультилиний в форме закрытого креста.

OC

Создание пересечения мультилиний в форме открытого креста. Разрываются все элементы первой мультилинии и только наружные элементы второй.

MC

Создание пересечения мультилиний в форме сплошного креста. Порядок выбора мультилиний значения не имеет.

CT

Создание пересечения мультилиний в форме закрытого Т. Программа обрезает или удлиняет первую мультилинию до пересечения со второй.

OT

Создание пересечения мультилиний в форме открытого Т. Программа обрезает или удлиняет первую мультилинию до пересечения со второй.

MT

Создание пересечения мультилиний в форме сплошного Т. Программа обрезает или удлиняет мультилинию до пересечения с другой мультилинией.

CJ

Создание углового стыка в месте пересечения мультилиний. Программа обрезает или удлиняет мультилинии до их пересечения.

AV

Добавление вершины для мультилинии.

DV

Удаление вершины мультилинии.

CS

Создание визуального разрыва в выбранном элементе мультилинии.

CA

Создание визуального разрыва через всю мультилинию.

WA

Соединение разделенных сегментов мультилинии.


МЛСТИЛЬ Команда

М Команды
М Команды
МЛСТИЛЬ Команда
Понятия Процедуры Команды

Создает, изменяет и управляет стилями мультилиний

Меню "Формат": Стили мультилиний

Ввод команды: млстиль

Отображает диалоговое окно "Стиль мультилинии".

Темы:

  • Диалоговое окно "Стиль мультилинии"
  • Диалоговое окно "Создание стиля мультилинии"
  • Диалоговые окна создания, изменения стиля мультилиний
  • Диалоговое окно "Загрузка стилей мультилиний"


Диалоговое окно "Стиль мультилинии"

М Команды
М Команды
Диалоговое окно "Стиль мультилинии"
Понятия Процедуры Команды

Меню "Формат": Стили мультилиний

Ввод команды: млстиль

Создает, изменяет, сохраняет и загружает стили мультилиний. Стиль мультилинии определяет количество элементов в ней и характеристики каждого элемента. Кроме того, команда МЛСТИЛЬ задает цвет фона и вид торцевых ограничителей каждой мультилинии.

Текущий стиль мультилинии

Отображает имя текущего стиля мультилинии, используемого для впоследствии созданных мультилиний.

Стили

Отображает список стилей мультилиний, загруженных в чертеж.

В список стилей мультилиний могут входить стили из связанных ссылок, т. е. стили мультилиний внешнего чертежа (внешняя ссылка). Для имен стилей мультилиний из внешних ссылок используется тот же синтаксис, что и для других внешне зависимых неграфических объектов. См. Коротко о внешних ссылках в Руководстве пользователя.

Описание

Отображает описание выбранного стиля мультилинии.

Просмотр

Отображает имя и изображение выбранного стиля мультилинии.

Установить

Устанавливает текущий стиль мультилинии для впоследствии созданных мультилиний. Выберите имя в списке "Стили" и нажмите "Установить".

Примечание Стиль мультилинии из внешней ссылки нельзя сделать текущим.

Новый

Отображает диалоговое окно "Создание стиля мультилинии", в котором можно создать новый стиль мультилинии.

Изменить

Отображает диалоговое окно "Редактирование стиля мультилинии", в котором можно изменить выбранный стиль мультилинии. Нельзя изменять стиль мультилинии по умолчанию (STANDARD).

Примечание Нельзя редактировать свойства элементов и мультилиний для стиля мультилинии СТАНДАРТ и стилей мультилинии, используемых объектами чертежа. Редактировать существующий стиль мультилинии необходимо перед тем, как создавать мультилинии, использующие этот стиль.

Переименовать

Переименовывает выбранный стиль мультилинии. Нельзя переименовывать стиль мультилинии по умолчанию (СТАНДАРТ).

Удалить

Удаляет выбранный стиль мультилинии из списка "Стили". При этом стиль не удаляется из файла MLN.

Нельзя удалять стиль мультилинии СТАНДАРТ, текущий стиль мультилинии и стиль мультилинии, используемый объектами чертежа.

Загрузить

Отображает диалоговое окно "Загрузка стилей мультилиний", предназначенного для загрузки стилей из указанного файла MLN.

Сохранить

Сохраняет или копирует стиль мультилинии в файл библиотеки (MLN). Если указанный MLN-файл уже существует, описание нового стиля добавляется в него; имеющиеся в файле описания остаются без изменения. По умолчанию имя файла acad.mln.


Диалоговое окно "Создание стиля мультилинии"

М Команды
М Команды
Диалоговое окно "Создание стиля мультилинии"
Понятия Процедуры Команды

Меню "Формат": Стили мультилиний

Ввод команды: млстиль

Присваивает имя новому стилю мультилинии и указывает стиль, используемый для начала рисования.

Имя нового стиля

Присваивает имя новому стилю мультилинии. Свойства элементов и мультилиний не доступны для редактирования до тех пор, пока не введено новое имя и нажата кнопка "Продолжить".

Начальный

Определяет стиль мультилинии, используемый для начала рисования. Чтобы сэкономить время, выберите стиль мультилинии, похожий на тот, который необходимо создать.

Далее

Отображает диалоговое окно "Новый стиль мультилинии".


Диалоговые окна создания, изменения стиля мультилиний

М Команды
М Команды
Диалоговые окна создания, изменения стиля мультилиний
Понятия Процедуры Команды

Меню "Формат": Стили мультилиний

Ввод команды: млстиль

Устанавливает свойства и элементы для нового стиля мультилинии или изменяет их для существующего стиля.

Описание

Задание описания для стиля мультилинии. Можно ввести до 255 символов, включая пробелы.

Торцы

Управление простановкой торцевых ограничителей в начале и конце мультилинии.

Линия

Отображает прямолинейный сегмент на каждом конце мультилинии.

Внешняя дуга

Отображает дугу между крайними элементами мультилинии.

Внутренние дуги

Отображает дугу между парами внутренних элементов. Если число элементов нечетно, центральный элемент не включается в соединение. Например, если мультилиния состоит из шести элементов, внутренние дуги соединяют 2-й элемент с 5-м, а 3-й элемент — с 4-м. Если мультилиния состоит из семи элементов, внутренние дуги соединяют 2-й элемент с 6-м, а 3-й элемент — с 5-м. Элемент 4 остается несоединенным.

Угол

Задание угла поворота торцевых ограничителей.

Заливка

Управление закраской фона мультилинии.

Цвет фона

Устанавливает цвет заливки фона мультилинии. При нажатии кнопки "Выбор цвета" открывается диалоговое окно "Выбор цвета".

Показать стыки

Управление отображением стыков в вершинах сегментов мультилинии. Стыки мультилиний иногда называются сгибами.

Элементы

Устанавливает свойства, например смещение, цвет и тип линии, для новых и существующих элементов мультилиний.

Смещение Цвет Тип линий

Отображает все элементы текущего стиля мультилинии. Для каждого элемента стиля определяется смещение от центра мультилинии, цвет и тип линии. Элементы отображаются в убывающем порядке значений смещений.

Добавить

Добавляет новый элемент в стиль мультилинии. Опция не доступна, пока не выбраны цвет или тип линии для стиля мультилинии, отличного от СТАНДАРТ.

Удалить

Удаляет элемент из стиля мультилинии.

Отступ

Задает смещение для каждого элемента стиля мультилинии.

Цвет

Отображает и устанавливает цвет элементов стиля мультилинии. При нажатии кнопки "Выбор цвета" открывается диалоговое окно "Выбор цвета".

Тип линий

Отображает и устанавливает тип линии для элементов стиля мультилинии. При нажатии кнопки "Тип линий" открывается диалоговое окно "Выбор типа линий", в котором перечислены загруженные типы линий. Чтобы загрузить новый тип линий, нажмите кнопку "Загрузить". Отобразится диалоговое окно "Загрузка/перезагрузка типов линий".


Диалоговое окно "Загрузка стилей мультилиний"

М Команды
М Команды
Диалоговое окно "Загрузка стилей мультилиний"
Понятия Процедуры Команды

Меню "Формат": Стили мультилиний

Ввод команды: млстиль

Загрузка стиля мультилиний из библиотечного MLN-файла. По умолчанию имя файла acad.mln. Если файл acad.mln не существует или не может быть найден, нажмите кнопку "Файл", чтобы выбрать другой файл или папку.

Файл

Отображает стандартное диалоговое окно выбора файлов, в котором можно выбрать другой файл библиотеки мультилинии.

Список

Перечисляет стили мультилиний, доступные в текущем файле библиотеки мультилиний. Чтобы загрузить другой стиль мультилинии, выберите его из списка и нажмите "OK".


МН-УГОЛ Команда

М Команды
М Команды
МН-УГОЛ Команда
Понятия Процедуры Команды

Построение равносторонних многоугольников в виде замкнутых полилиний

Панель "Рисование":

Меню "Рисование": Мн-угол

Ввод команды: мн-угол

Число сторон <текущее>: Ввести значение от 3 до 1024 или нажать ENTER

Укажите центр многоугольника или [Кромка]: Указать точку (1) или нажать e

Центр многоугольника

Положение центра многоугольника.

Задайте опцию размещения [Вписанный в окружность/Описанный вокруг окружности] <текущий>: Ввести в или о или нажать ENTER

Вписанный в окружность

Задание радиуса окружности, на которой лежат вершины многоугольника.

Радиус окружности: Указать точку (2) или задать значение

При указании радиуса при помощи устройства указания одновременно задаются и радиус, и угол поворота многоугольника. При вводе радиуса с клавиатуры нижняя сторона многоугольника строится в соответствии с текущим углом поворота шаговой привязки.

Описанный вокруг окружности

Задание расстояния от центра многоугольника до середин его сторон.

Радиус окружности: Задать расстояние

При указании радиуса при помощи устройства указания одновременно задаются и радиус, и угол поворота многоугольника. При вводе радиуса с клавиатуры нижняя сторона многоугольника строится в соответствии с текущим углом поворота шаговой привязки.

Кромка

Определение многоугольника заданием конечных точек одной из его сторон.

Первая конечная точка стороны: Указать точку (1)

Вторая конечная точка стороны: Указать точку (2)


МНОГОРАЗ Команда

М Команды
М Команды
МНОГОРАЗ Команда
Понятия Процедуры Команды

Многократное (до отмены) повторение последующей команды

Ввод команды: многораз

Имя команды для повторения:

Заданная пользователем команда повторяется до тех пор, пока пользователь не нажмет ESC. Поскольку команда МНОГОРАЗ повторяет только имя команды, все параметры повторяемой команды нужно указывать при каждом ее вызове.

Команда МНОГОРАЗ не работает с командами, использующими диалоговые окна.

Примечание Нельзя также использовать команду МНОГОРАЗ в качестве аргумента для команды на языке AutoLISP®.


МОДЕЛЬ Команда

М Команды
М Команды
МОДЕЛЬ Команда
Понятия Процедуры Команды

Переключение со вкладки "Лист" на вкладку "Модель"

Ввод команды: модель

Вкладка "Модель" соответствует пространству модели; на ней создаются объекты чертежа. При переходе на вкладку "Модель" системной переменной TILEMODE автоматически присваивается значение 1, что позволяет создавать неперекрывающиеся видовые экраны и размещать в них различные виды модели. После создания чертежа можно перейти на вкладку листа, чтобы начать компоновку листа для вывода на печать.

Для ускорения процесса переключения между вкладками листа и модели, или с одного листа на другой, можно менять значение системной переменной LAYOUTREGENCTL, управляющей обновлением списка отображения.


МОДЕЛЬ Команда

М Команды
М Команды
МОДЕЛЬ Команда
Понятия Процедуры Команды

Переключение из пространства листа на видовой экран пространства модели

Ввод команды: модель

Команды выполняются в пространстве модели и в пространстве листа. В пространстве модели (на вкладке "Модель") выполняется разработка и рисование двумерных чертежей и трехмерных моделей. Пространство листа (вкладки "Лист") используется для окончательной компоновки и подготовки чертежа к выводу на печать.

При работе на листе можно ввести в командную строку команду модель для установки последнего видового экрана на листе текущим и далее работать в пространстве модели на данном видовом экране внутри листа. Переключиться в пространство модели можно двойным нажатием левой кнопки мыши на видовом экране; для переключения обратно в пространство листа достаточно дважды нажать левую кнопку на области пространства листа.


МПОВТОРИТЬ Команда

М Команды
М Команды
МПОВТОРИТЬ Команда
Понятия Процедуры Команды

Отмена действия нескольких команд ОТМЕНИТЬ или О

Панель "Стандартная":

Ввод команды: мповторить

Количество операцийКоличество операций или [Все/Последний]: Задать опцию, ввести положительное число или нажать ENTER

Количество операций

Повтор заданного количества отмененных действий.

Все

Повтор всех предыдущих отмененных действий.

Последний

Повтор последнего отмененного действия.


МТЕКСТ Команда

М Команды
М Команды
МТЕКСТ Команда
Понятия Процедуры Команды

Создает абзацы текста как единый объект многострочного текста

Панель "Рисование":

Меню "Рисование": "Текст" » "Многострочный текст"

Устройство указания: Двойным нажатием левой кнопки мыши выбрать объект многострочного текста.

Ввод команды: мтекст

Текущий текстовый стиль: текущий Высота текста: текущая

Первый угол:

Противоположный угол или [Высота/вЫравнивание/Межстрочный интервал/Поворот/Стиль/Ширина]:

После того, как указана точка для противоположного угла, откроется текстовый редактор, используемый в месте редактирования.

Если указать другую опцию или в запросе "Команда" ввести -мтекст, то МТЕКСТ обходит текстовый редактор, применяемый в месте редактирования, и отображает дополнительные запросы в командной строке.

Темы:

  • Текстовый редактор, используемый в месте редактирования
  • Диалоговое окно "Отступы и табуляция"
  • Диалоговое окно "Маска заднего плана"
  • Диалоговое окно "Замена"
  • Диалоговое окно "Свойства дробного текста"
  • Диалоговое окно "Автоформат дробного текста"
  • Командная строка МТЕКСТ
  • Символы и специальные знаки


Текстовый редактор, используемый в месте редактирования

М Команды
М Команды
Текстовый редактор, используемый в месте редактирования
Понятия Процедуры Команды

Панель "Рисование":

Меню "Рисование": "Текст" » "Многострочный текст"

Ввод команды: мтекст

Создает или изменяет объекты многострочных текстов. Импортирует или вставляет текст из других файлов для использования в многострочном тексте.

В текстовом редакторе, используемом в месте редактирования, имеется панель "Форматирование текста" и меню параметров. Буквы столбца и номера строк отображаются в текстовом редакторе, используемом в месте редактирования, при выборе ячейки для редактирования.

Если введенный текст выходит за пределы указанной рамки текста, заданная ширина и высота обозначаются штриховой линией.

Примечание Текст, который в иных условиях мог бы быть трудночитаемым (слишком миниатюрным, слишком крупным или повернутым), отображается в разборчивом формате и с расположением по горизонтали, благодаря чему его можно легко читать и редактировать.

Панель "Форматирование текста"

Позволяет задать стиль многострочного текста и форматирование его отдельных символов в выделенном фрагменте.

Стиль

Список текстовых стилей, которые можно применить для многострочного текста. Текущий стиль сохраняется в системной переменной TEXTSTYLE.

При применении нового текстового стиля для многострочного текста исходный формат его символов (шрифт, высота и атрибуты полужирного шрифта или курсива) изменяется в соответствии с новым стилем. Атрибуты преобразования в дробь, подчеркивания и цвета сохраняются в символах, к которым применяется новый стиль.

Стили, в которых задано обратное или перевернутое начертание символов текста, не применяются. Если стиль, определенный с помощью вертикального начертания, применяется к шрифту SHX, в редакторе текста, используемом в месте редактирования, текст отображается по горизонтали.

Шрифт

Задание шрифта для нового текста или изменение шрифта выделенного фрагмента. Шрифты TrueType отображаются в списке по имени семейства шрифтов. AutoCAD выводит список шрифтов SHX, упорядоченный по именам соответствующих им файлов. Шрифты, созданные пользователем или сторонними производителями, заменяются в редакторе на специальные шрифты-заместители, поставляемые с программой Autodesk.

Образец чертежа (TrueType.dwg) с таблицей символов для каждого из шрифтов находится в папке "Образец".

Высота текста

Задание высоты символов или ее изменение для выделенного фрагмента текста. Высота задается в единицах чертежа. Если высота символов не определена в выбранном текстовом стиле, ее значение хранится в системной переменной TEXTSIZE. Высота отдельных символов многострочного текста может различаться.

Полужирный

Включает и отключает полужирное начертание для нового или выделенного текста. Опция доступна только для символов, использующих шрифты TrueType.

Курсив

Включает и отключает курсивное начертание для нового или выделенного текста. Опция доступна только для символов, использующих шрифты TrueType.

Подчеркнутый

Включает и отключает подчеркивание для нового или выделенного текста.

Отменить

Отменяет операции в текстовом редакторе, используемом в месте редактирования, включая изменения содержимого текста или его форматирования. Можно также использовать комбинацию клавиш CTRL+Z.

Повторить

Повторяет операции в текстовом редакторе, используемом в месте редактирования, включая изменения содержимого текста или его форматирования. Можно также использовать комбинацию клавиш CTRL+Y.

Дробный текст

Для создания дробного текста необходимо выделить фрагмент текста, содержащий специальные символы. Если был выделен дробный текст, нажатие кнопки превращает его в обычный. Если используются специальные символы (символы крышки (^), обычной косой черты (/) или решетки (#)), то текст, расположенный слева от специальных символов, выводится над текстом, расположенном справа от них.

Тексты, содержащие символ крышки (^), преобразуются в выровненные по левому краю значения допусков. Тексты, содержащие символ обычной косой черты (/), преобразуются в выровненные по центру дроби с горизонтальным разделителем, длина которого определяется длиной наибольшей из выводимых друг над другом строк. Тексты, содержащие символ решетки (#), преобразуются в числовые дроби с косой разделительной чертой, длина которого зависит от высоты обеих разделяемых строк. Символы, расположенные над косой разделительной чертой, выравнивается вниз и вправо; под чертой — вверх и влево.

Цвет текста

Задание цвета для нового текста или изменение цвета выделенного фрагмента.

Можно назначить тексту цвет, заданный для слоя, на котором он расположен (ПОСЛОЮ), или цвет блока, в который он входит (ПОБЛОКУ). Можно также задать любой цвет, из перечисленных в списке, или выбрать "Другой" для вызова диалогового окна "Выбор цвета".

Линейка

Отображает линейку в верхней части редактора. Наведите курсор на конец линейки, чтобы изменить ширину объекта многострочного текста.

OK

Закрывает редактор и сохраняет все внесенные изменения. Дополнительные варианты: нажать левую кнопку мыши в области рисования за пределами редактора или нажать CTRL + ENTER. Для выхода из текстового редактора, используемого в месте редактирования, без сохранения изменений следует нажать клавишу ESC.

Настройка

Отображает меню параметров.

Влево, Центр, Вправо

Задает выравнивание для левого и правого контуров текста. По умолчанию используется выравнивание "Вверх-влево". Пробелы, вводимые в конец строки, учитываются в составе текста и влияют на выравнивание абзаца. См. описание всех девяти видов выравнивания в разделе Командная строка МТЕКСТ.

Сверху, Посередине, Снизу

Задает выравнивание для верхнего и нижнего контуров текста. По умолчанию используется выравнивание "Вверх-влево". См. описание всех девяти видов выравнивания в разделе Командная строка МТЕКСТ.

Нумерация

Создает список с помощью цифр с точками.

Маркеры

Создает список с помощью маркеров.

Прописные буквы

Создает список с помощью прописных букв с точками. Если в списке больше элементов, чем букв в алфавите, для продолжения последовательности используются сдвоенные буквы.

Примечание Чтобы создать список с помощью букв нижнего регистра, следует нажать правую кнопку мыши в редакторе. Выбрать "Маркеры и списки" » "Буквенный" » "Нижний регистр".

Вставка поля

Отображает диалоговое окно "Поле", в котором можно выбрать поле для вставки в текст. После закрытия диалогового окна в тексте отображается текущее значение поля.

Верхний регистр

Изменяет регистр выделенного текста на верхний.

Нижний регистр

Изменяет регистр выделенного текста на нижний.

Надчеркнутый

Помещает линию над выделенным текстом.

Символ

Вставка символа или неразрывного пробела в текущую позицию курсора. Символ можно также вставить вручную. См. раздел Символы и специальные знаки.

В открывающемся подменю перечисляются наиболее часто используемые символы вместе с управляющими кодами и строками Юникод. Выбрать другой символ можно в окне "Таблица символов", которое открывается при выборе пункта "Другой" из этого подменю. В этом окне следует выбрать символ и нажать кнопку "Выбрать". Символ вставляется в поле "Для копирования". Выбрав для копирования все требуемые символы, следует нажать кнопку "Копировать". Таблица символов закрывается. Нажать правую кнопку мыши в редакторе и выбрать "Вставить".

Символ евро можно использовать со шрифтами SHX и их эквивалентами TrueType, поставляемыми вместе с AutoCAD 2000 и более поздними версиями. Если на клавиатуре нет символа евро, можно ввести его набором комбинации цифр 0128 при нажатой клавише ALT.

В вертикальном тексте символы не поддерживаются.

Примечание В редакторе символ диаметра отображается в виде %%c, неразрывный пробел в виде пустого прямоугольника. После вставки в чертеж эти символы отображаются корректно. Неразрывный пробел не используется в двухбайтовых операционных системах.

Угол наклона

Определяет наклон текста вправо или влево. Значение угла наклона отсчитывается относительно перпендикуляра, проведенного к основанию строки. Значение угла наклона может лежать в диапазоне от -85 до 85 градусов. Положительное значение угла соответствует наклону символов вправо. Отрицательное значение угла соответствует наклону символов влево.

Слежение

Уменьшает или увеличивает интервал между выделенными символами. Значение интервала в 1,0 является нормальным. Для увеличения интервала установите значение больше 1,0, для уменьшения интервала - меньше 1,0.

Коэффициент сжатия

Растягивает или сужает выделенные символы. Значение 1,0 является нормальным для ширины буквы этого шрифта. Ширину можно увеличить (например, использовать для коэффициента сжатия значение 2, чтобы увеличить ширину в два раза) или уменьшить (например, использовать для коэффициента сжатия значение 0,5, чтобы уменьшить ширину наполовину).

Меню "Параметры"

Управляет отображением панели "Форматирование текста" и предоставляет дополнительные параметры редактирования. Следующие параметры доступны только в меню "Параметры" и недоступны на панели "Форматирование текста".

Показать панель

Управляет отображением панели "Форматирование текста". Чтобы восстановить отображение панели инструментов, следует нажать правую кнопку мыши в редакторе и выбрать "Показать панель".

Показать параметры

Развертывает панель "Форматирование текста" для отображения большего числа параметров.

Непрозрачный фон

Если выбран этот параметр, фон редактора становится непрозрачным. По умолчанию фон редактора прозрачный. (Недоступно для ячеек таблицы.)

Импорт текста

Отображает диалоговое окно "Выбор файла" (стандартное диалоговое окно выбора файлов). Для импорта следует выбрать файл в формате ASCII или RTF. Импортированный текст сохраняет исходное форматирование символов и стиль, но его можно редактировать и форматировать с помощью редактора. Импортируемым текстом можно заменить выделенный фрагмент или весь исходный текст. Импорт позволяет также добавить текст к имеющемуся в пределах ограничивающей рамки. Размер файла с импортируемым текстом не должен превышать 32 Кб.

Редактором автоматически устанавливается цвет текста ПОСЛОЮ. При вставке символов черного цвета на черный фон редактор автоматически меняет цвет на белый или текущий.

Примечание При импорте электронной таблицы Microsoft Excel в чертеж будут вставлены только первые 72 ряда. Этого не произойдет, если таблица была создана с помощью Microsoft Office 2002 с установленным пакетом обновления 2. То же самое произойдет при открытии чертежа, содержащего OLE-объекты, если на компьютере установлена более ранняя версия Microsoft Office; электронная таблица усекается.

Отступы и табуляция

Отображает диалоговое окно "Отступы и табуляция". (Недоступно для ячеек таблицы.)

Маркеры и списки

Отображает параметры создания списков. (Недоступно для ячеек таблицы.) Отступ в списке создается для выравнивания с первым выделенным абзацем.

  • Откл: Если выбран этот параметр, из выделенного текста, к которому применено форматирование списка, удаляются буквы, цифры и маркеры. Отступ не изменяется.
  • Буквенный: Применяет форматирование списка, в котором для элементов используются буквы с точками. Если в списке больше элементов, чем букв в алфавите, для продолжения последовательности используются сдвоенные буквы.
  • Нумерованный: Применяет форматирование списка, в котором для элементов используются цифры с точками.
  • Маркированный: Применяет форматирование списка, в котором для элементов используются маркеры.
  • Начать заново: Начинает новую последовательность из букв или цифр в форматировании списка. Если выбранные элементы находятся в середине списка, то невыбранные элементы, расположенные ниже, также станут частью списка.
  • Продолжить: Добавляет выбранные абзацы в последний список и продолжает последовательность. При выборе элементов списка, а не абзацев невыбранные элементы, расположенные ниже выбранных, продолжат последовательность.
  • Разрешить автоматический список: Применяет форматирование списка при вводе текста. Указанные ниже символы можно использовать в качестве знаков препинания после букв и цифр, но не в качестве маркеров; точка (.), запятая (,), закрывающая круглпя скобка ()), закрывающая угловая скобка (>), закрывающая квадратная скобка (]) и закрывающая фигурная скобка (}).
  • Использовать только разделитель Tab: Ограничивает параметр "Разрешить автоматический список" и "Разрешить маркеры и списки". Форматирование списка применяется к тексту только, если пробел после буквы, цифры или маркера был создан нажатием клавиши TAB, а не ПРОБЕЛ. По умолчанию этот параметр включен.

    • Этот параметр может предотвратить получение неожиданных результатов. Например, если данный параметр отключен и введена команда Прод. в начале строки, следует нажать ПРОБЕЛ, ввести текст и нажать ENTER. При следующем открытии объекта многострочного текста в редакторе команда “Прод. ” воспринимается как часть схемы нумерации, и следующая строка начинается с “Прод. ”

  • Разрешить маркеры и списки: Если этот параметр включен, форматирование списка применяется ко всему обычному тексту в объекте многострочного текста, который похож на список. Списком считается текст, отвечающий следующим критериям. Строка начинается (1) с одной или нескольких букв, цифр или символов, после которых стоит (2) знак препинания, (3) есть пробел, созданный нажатием клавиши TAB, (4) строка заканчивается нажатием клавиши ENTER или сочетанием клавиш SHIFT+ENTER.

    • Если флажок не установлен, любое форматирование списка в объекте многострочного текста удаляется, а элементы преобразуются в обычный текст. Отключается параметр "Разрешить автоматический список", а все параметры "Маркеры и списки" становятся недоступными за исключением "Разрешить маркеры и списки".

Маска заднего плана

Отображает диалоговое окно "Маска заднего плана". (Недоступно для ячеек таблицы.)

Выравнивание

Задание выравнивания для многострочного текста. По умолчанию используется выравнивание "Вверх-влево". Пробелы, вводимые в конец строки, учитываются в составе текста и влияют на выравнивание абзаца. В горизонтальном направлении текст может центрироваться, либо выравниваться влево или вправо. Относительно верхней и нижней границ текст может выравниваться по середине, вверх или вниз. См. описание всех девяти видов выравнивания в разделе Командная строка МТЕКСТ.

Поиск и замена

Отображает диалоговое окно "Замена".

Выбрать все

Выделяет весь текст в окне редактора.

Изменить регистр

Изменение регистра выбранного текста. Раскрывает подменю, содержащее два пункта: "Верхний" и "Нижний".

Регистр

Переключает регистр всего нового и импортированного текста на верхний. Функция регистра не влияет на уже имеющийся в редакторе текст. Чтобы изменить регистр существующего текста, выберите текст и нажмите правую кнопку мыши. Выберите "Изменить регистр".

Убрать форматирование

Изменяет значения атрибутов символов выделенного текста на значения текущего стиля, а также цвет текста на цвет объекта многострочного текста.

Объединить абзацы

Объединение выбранных абзацев в один. Каждый знак абзаца заменяется на пробел.

Набор символов

Открывается подменю кодовых страниц. В нем следует выбрать требуемую кодировку для текста.


Диалоговое окно "Отступы и табуляция"

М Команды
М Команды
Диалоговое окно "Отступы и табуляция"
Понятия Процедуры Команды

Панель "Рисование":

Меню "Рисование": "Текст" » "Многострочный текст"

Ввод команды: мтекст

Установка отступа для первой строки и всего абзаца, а также позиций табуляции. Отступы можно установить, перемещая указатели на линейке. Позиции табуляции устанавливаются щелчком мыши на линейке.

Отступ

Установка отступа для параграфа, в котором находится курсор. Отступ можно установить для нескольких выделенных абзацев.

Первой строки

Установка отступа для первой строки абзаца. Отступ можно установить для нескольких выделенных абзацев.

Абзац

Установка отступа абзаца. Отступ можно установить для нескольких выделенных абзацев.

Позиции табуляции

Установка позиций табуляции. Позиции можно установить для нескольких выделенных абзацев. Список, расположенный ниже текстового поля, содержит установленные позиции табуляции.

Установить

Копирование значения табуляции из текстового поля в список.

Отменить

Удаление выделенного элемента списка позиций табуляции.


Диалоговое окно "Маска заднего плана"

М Команды
М Команды
Диалоговое окно "Маска заднего плана"
Понятия Процедуры Команды

Панель "Рисование":

Меню "Рисование": "Текст" » "Многострочный текст"

Ввод команды: мтекст

Управляет использованием непрозрачного фона за текстом.

Использовать маску заднего плана

Текст располагается на непрозрачном фоне.

Коэффициент перекрытия

Задание полей для непрозрачного фона текста. Значение привязывается к высоте текста. Коэффициент, равный единице, означает, что размер непрозрачного фона точно соответствует размеру объекта многострочного текста. Если коэффициент равен 1,5, то фон выступает за пределы текста на половину его высоты.

Цвет фона

Задает цвет фона.

Использовать цвет фона чертежа

Фону присваивается тот же цвет, что и фону чертежа.

Цвет

Задание цвета для непрозрачного фона. Можно задать любой цвет, из перечисленных в списке, или выбрать элемент "Выбор цвета" для вызова диалогового окна "Выбор цвета".


Диалоговое окно "Замена"

М Команды
М Команды
Диалоговое окно "Замена"
Понятия Процедуры Команды

Панель "Рисование":

Меню "Рисование": "Текст" » "Многострочный текст"

Ввод команды: мтекст

Поиск фрагментов текста и замена их новым текстом.

Что

Поле для ввода пользователем текста для ведения поиска.

Чем

Поле для ввода пользователем текста, заменяющего текст, введенный в поле "Что".

Найти далее

Поиск следующего экземпляра текста, введенного в поле "Что".

Заменить

Поиск следующего вхождения строки, заданной в поле "Что", и замена ее фрагментом, заданным в поле "Чем".

Заменить все

Поиск всех вхождений строки, заданной в поле "Что", и замена их фрагментом, заданным в поле "Чем".

Только слово целиком

Поиск только слов целиком, указанных в поле "Что".

Фрагменты, являющиеся частью более длинных слов, пропускаются. Если флажок не установлен, для текстовых строк выполняется поиск совпадения независимо от того, является оно отдельным словом или частью другого слова.

С учетом регистра

Поиск текста с символами нижнего и верхнего регистра точно в том виде, как они заданы в поле "Что".

Все символы текстовой строки должны быть представлены в таком же регистре, как в тексте в поле "Что". Если флажок не установлен, выполняется поиск совпадения для указанных текстовых строк без учета регистра.


Диалоговое окно "Свойства дробного текста"

М Команды
М Команды
Диалоговое окно "Свойства дробного текста"
Понятия Процедуры Команды

Панель "Рисование":

Меню "Рисование": "Текст" » "Многострочный текст"

Ввод команды: мтекст

Редактирование дробного текста: содержимого, стиля, выравнивания и высоты символов. Для вызова диалогового окна "Свойства дробного текста" следует выделить текст, нажать правую кнопку мыши и выбрать из контекстного меню пункт "Свойства".

Верхний и нижний текст можно отредактировать отдельно. В группе "Формат" можно задать стиль, выравнивание и высоту для дробного текста.

Текст

Изменение значений числителя и знаменателя дроби.

Сверху

Изменение содержимого верхней или первой половины дробного текста.

Снизу

Изменение содержимого нижней или второй половины дробного текста.

Формат

Редактирование стиля, положения и высоты текста дроби (дробного текста).

Стиль

Задает стиль дробного текста: допуск, дробь с горизонтальной или косой чертой.

Допуск

Выделенный текст преобразуется к дробному формату с первым числом поверх второго числа. Между верхним и нижним числами черта не ставится.

Дробь (гориз. черта)

Выделенный текст преобразуется к дробному формату, в котором первое число располагается над вторым и отделяется от него горизонтальной чертой.

Дробь (косая черта)

Выделенный текст преобразуется к дробному формату, в котором первое число располагается над вторым и отделяется от него косой чертой.

Примечание В предыдущих версиях программы AutoCAD (до AutoCAD 2000) не поддерживаются дроби с косой чертой. При сохранении чертежа в формате версий, предшествующих AutoCAD 2000, такие дроби преобразуются в дроби с горизонтальной чертой. При открытии чертежа в AutoCAD 2000 или его более поздних версиях дроби с косой чертой восстанавливаются. Если отдельный объект многострочного текста содержит дроби с горизонтальной и косой чертой, все дроби преобразуются в дроби с косой чертой при повторном открытии чертежа в программе AutoCAD 2000 или более поздней версии.

Положение

Задание способа выравнивания дробей. По умолчанию текст выравнивается по центру. Весь дробный текст внутри одного объекта выравнивается одинаково.

Сверху

Задает совмещение верхней границы дробного текста с верхней границей строки.

Центр

Центрирование дроби по вертикали относительно середины строки.

Снизу

Задает совмещение нижней границы дробного текста с базовой линией строки.

Размер

Задание высоты символов дробного текста в процентах от высоты текущего текстового стиля (от 25 до 125 процентов). По умолчанию это значение равно 70 процентам.

Стандартные

Сохранение текущих значений параметров в качестве стандартных или восстановление предыдущих стандартных параметров.

Кнопка "Автоформат"

Отображает диалоговое окно "Автоформат дробного текста". Автоформат применяется только для цифр, расположенных непосредственно до и после символов крышки (^), обычной косой черты (/) и решетки (#). Для преобразования произвольного фрагмента текста в дробный формат, его (фрагмент) следует выделить, после чего нажать кнопку "Дробный текст".


Диалоговое окно "Автоформат дробного текста"

М Команды
М Команды
Диалоговое окно "Автоформат дробного текста"
Понятия Процедуры Команды

Панель "Рисование":

Меню "Рисование": "Текст" » "Многострочный текст"

Ввод команды: мтекст

Устанавливает значения по умолчанию для символов, автоматически преобразуемых в дробь.

Преобразовывать в дробный текст

Числа, разделенные символами косой черты, решетки или крышки, автоматически преобразуются в дробный текст. Например, если после выражения 1#3 ввести какой-либо нецифровой символ или пробел, средство автоформатирования дробного текста разместит эти цифры в виде дроби с косой чертой.

Удалять ведущие пробелы

Удаление пробелов между целой и дробной частями числа. Опция доступна только при включении режима преобразования в дробный текст.

Дробь с косой чертой

Преобразование символа косой черты в диагональный разделитель дроби при включенной функции "Автоформат".

Дробь с горизонтальной чертой

Преобразование символа косой черты в горизонтальный разделитель дроби при включенной функции "Автоформат".

Примечание Символ решетки всегда преобразуется в диагональную дробь, а символ крышки всегда преобразуется в допуск, как бы ни был установлен режим автоформатирования.

"Запомнить установки и больше не выводить это окно"

Подавление дальнейшего вывода диалогового окна "Автоформат дробного текста". Текущие параметры используются для всех дробных текстов. Если флажок не установлен, диалоговое окно "Автоформат дробного текста" автоматически появляется после ввода двух чисел, разделенных косой чертой, крышкой или решеткой, за которыми следует пробел или нечисловой символ.

Примечание Для вызова диалогового окна "Автоформат дробного текста" при отмененном автоматическом отображении следует выделить дробный текст, нажать правую кнопку мыши и выбрать из контекстного меню пункт "Свойства". В диалоговом окне "Свойства дробного текста" нажать кнопку "Автоформат".


Командная строка МТЕКСТ

М Команды
М Команды
Командная строка МТЕКСТ
Понятия Процедуры Команды

Если при запросе "Команда" ввести -мтекст, команда МТЕКСТ обходит текстовый редактор, применяемый в месте редактирования, и отображает дополнительные запросы в командной строке.

Текущий текстовый стиль: текущий Высота текста: текущая

Первый угол:

Противоположный угол или [Высота/Выравнивание/Межстрочный интервал/Поворот/Стиль/Ширина]:

Противоположный угол

Размер и расположение многострочного текста обрисовываются рамкой, следующей за указательным устройством при наведении на противоположный угол. Стрелки внутри рамки указывают направление распространения текста абзаца.

Высота

Задание высоты шрифта, используемого для многострочного текста.

Высота <текущая>:

По умолчанию принимается высота текущего стиля (если она не равна нулю); иначе значение системной переменной TEXTSIZE. Высота текста выражается в единицах чертежа. Измененное значение высоты заносится в переменную TEXTSIZE.

Выравнивание

Задает выравнивание и распространение нового или выделенного текста относительно его границы. К вновь создаваемым текстам применяется выравнивание по умолчанию "Вверх влево". Текст выравнивается в пределах заданной рамки согласно настройке выравнивания и на основе одной из девяти точек выравнивания на рамке. Эти точки зависят от первой точки, которая была указана при создании рамки. В горизонтальном направлении текст может центрироваться, либо выравниваться влево или вправо. Пробелы, вводимые в конец строки, учитываются в составе текста и влияют на выравнивание абзаца. Текст может распространяться от середины, верхней или нижней границы абзаца с учетом верхней и нижней границ текста.

Выравнивание [ВЛ/ВЦ/ВП/СЛ/СЦ/СП/НЛ/НЦ/НП] <ВЛ>:

Параметры выравнивания

Опция

Расшифровка

TL

Вверху слева

TC

Вверх по центру

TR

Вверху справа

ML

По середине влево

MC

По середине по центру

MR

По середине вправо

BL

Вниз влево

BC

Вниз по центру

BR

Внизу справа

На следующем рисунке приведены примеры каждого из режимов выравнивания.

Межстрочный интервал

Задание значения межстрочного интервала для текста. Межстрочный интервал определяет расстояние по вертикали между основанием (или базовой линией) строки текста и основанием следующей строки текста.

Примечание Если команда МТЕКСТ используется для создания таблиц, рекомендуется задавать точное значение межстрочного интервала. Чтобы строки текста не накладывались друг на друга, его высота не должна превышать заданный межстрочный интервал.

Укажите способ задания межстрочного интервала [Минимум/Точно] <текущий>:

Минимум

Автоматический подбор интервала, исходя из размера самого высокого символа строки. Опция "Минимум" обеспечивает увеличение межстрочного интервала в случае строк с символами увеличенной высоты.

Задайте множитель или значение межстрочного интервала <текущий>:

  • Множитель: Устанавливает межстрочный интервал, кратный одинарному интервалу.

    • Одинарный межстрочный интервал равен 1,66 высоты символов. Кроме того, значение межстрочного интервала можно ввести, как число, за которым следует x (для обозначения коэффициента, на который умножается одинарный интервал). Например, для задания одинарного интервала необходимо ввести 1x, для задания двойного 2x.

  • Расстояние: Устанавливает межстрочный интервал по абсолютному значению в единицах чертежа. Абсолютные значения можно задавать в интервале от 0,0833 (0.25x) до 1,3333 (4x).

Точно

Использование одинакового интервала между всеми строками многострочного текста. Интервал зависит от высоты текста или текстового стиля.

Задайте множитель или значение межстрочного интервала <текущий>:

  • Множитель: Устанавливает межстрочный интервал, кратный одинарному интервалу.

    • Одинарный межстрочный интервал равен 1,66 высоты символов. Кроме того, значение множителя для межстрочного интервала можно ввести, как число, за которым следует x (для обозначения коэффициента, на который умножается одинарный интервал). Например, для задания одинарного интервала необходимо ввести 1x, для задания двойного 2x.

  • Расстояние: Устанавливает межстрочный интервал по абсолютному значению в единицах чертежа. Абсолютные значения можно задавать в интервале от 0,0833 (0.25x) до 1,3333 (4x).

Поворот

Угол поворота рамки текста.

Угол поворота <текущий>: Указать точку или задать значение

Если для обозначения точки используется указательное устройство, то углом поворота считается угол между осью X и отрезком, соединяющим предыдущую точку (по умолчанию 0,0,0) и указанную точку.

Повторяющееся отображение предыдущего запроса продолжается до тех пор, пока не будет задан противоположный угол контура текста.

Стиль

Текстовый стиль для многострочного текста.

Имя стиля или [?] <текущий>:

Имя стиля

Задание имени текстового стиля. Для задания и сохранения текстового стиля можно воспользоваться командой СТИЛЬ.

?—Список стилей

Вывод списка имен текстовых стилей и их характеристик.

Повторяющееся отображение предыдущего запроса продолжается до тех пор, пока не будет задан противоположный угол контура текста.

Ширина

Задание ширины рамки текста.

Ширина: Указать точку или задать значение

Если для обозначения точки используется указательное устройство, то шириной считается расстояние между начальной точкой и указанной точкой. Соответствие каждой строки многострочного текста заданной ширине обеспечивается переносом слов. Если задана нулевая ширина, перенос слов отключается, и весь многострочный текст записывается в одну строку максимально возможной длины. Для редактирования строки текста в указанной точке можно ввести текст и нажать ENTER. Для завершения команды нажать ENTER в ответ на запрос МТЕКСТ.


Символы и специальные знаки

М Команды
М Команды
Символы и специальные знаки
Понятия Процедуры Команды

Следующие специальные знаки и символы можно ввести с помощью управляющего кода или строки Юникод. Можно также нажать кнопку "Символ" на развернутой панели текстового редактора, используемого в месте редактирования.

Примечание В вертикальном тексте символы не поддерживаются.

Строки Юникод и управляющие коды
Управляющие коды | Строки Юникод | Результат
%%d | \U+00B0 | Символ градуса (°)
%%p | \U+00B1 | Символ допуска (±)
%%c | \U+2205 | Символ диаметра ( [image] )

Чтобы вставить следующие текстовые символы, нажмите кнопку "Символ" на развернутой панели "Форматирование текста" или введите соответствующую строку Юникод:

Текстовые символы и строки Юникод
Имя | Символ | Юникод
Приблизительно равно |  | \U+2248
Угол |  | \U+2220
Линия раздела |  | \U+E100
Осевая линия |  | \U+2104
Дельта |  | \U+0394
Фаза |  | \U+0278
Линия связи |  | \U+E101
Тождество |  | \U+2261
Исходная длина |  | \U+E200
Опорная линия |  | \U+E102
Не равно |  | \U+2260
Ом |  | \U+2126
Омега |  | \U+03A9
Граница участка |  | \U+214A
Нижний индекс 2 |  | \U+2082
Квадратный |  | \U+00B2
Кубический |  | \U+00B3

Эти текстовые символы доступны в следующих шрифтах True Type (TTF) и SHX:

  • Simplex
  • RomanS
  • Isocp
  • Isocp2
  • Isocp3
  • Isoct
  • Isoct2
  • Isoct3
  • Isocpeur (только TTF)
  • Isocpeur italic (только TTF)
  • Isocteur (только TTF)
  • Isocteur italic (только TTF)


МТРЕД Команда

М Команды
М Команды
МТРЕД Команда
Понятия Процедуры Команды

Редактирует многострочный текст

Ввод команды: мтред

Выбрать объект МТЕКСТ:

Открывается диалоговое окно "Текстовый редактор, используемый в месте редактирования".


Н Команды
  • НАБПАРАМТОНИР
  • НАЙТИ
  • НАЛТЕК
  • НАСТРВИД
  • НАСТРОЙКА
  • НЕТКОМ
  • НЛНАСТР
  • НОВОЕИМЯ
  • НОРМОКОНТРОЛЬ
  • НПИ
  • НПИВЫГР
  • НПИЗАГР
  • НПИИМПОРТ
  • НПИЭКСПОРТ
  • НПОТКРЫТЬ


НАБПАРАМТОНИР Команда

Н Команды
Н Команды
НАБПАРАМТОНИР Команда
Понятия Процедуры Команды

Задает предварительные настройки и повторно используемые параметры тонирования изображения

Панель "Тонирование":

Меню "Вид": "Тонирование"; » "Дополнительные параметры тонирования"; » "Выбрать набор параметров тонирования" » "Управление наборами параметров тонирования"

Ввод команды: набпарамтонир

Пульт управления: Панель "Тонирование", "Выбрать набор стандартных параметров тонирования" » "Управление наборами параметров тонирования"

Отображается Диспетчер наборов стандартных параметров тонирования.

Темы:

  • Диспетчер наборов стандартных параметров тонирования
  • Диалоговое окно "Копировать набор параметров тонирования"


Диспетчер наборов стандартных параметров тонирования

Н Команды
Н Команды
Диспетчер наборов стандартных параметров тонирования
Понятия Процедуры Команды

Панель "Тонирование":

Меню "Вид": "Тонирование"; » "Дополнительные параметры тонирования"; » "Выбрать набор параметров тонирования" » "Управление наборами параметров тонирования"

Ввод команды: набпарамтонир

Пульт управления: Панель "Тонирование", "Выбрать набор параметров тонирования" » "Управление наборами параметров тонирования"

Параметры тонирования для повторного использования запоминаются в качестве набора параметров тонирования. Возможен выбор из комплекта установленных наборов параметров тонирования. Также разрешается создавать пользовательские наборы параметров тонирования. Стандартные наборы параметров тонирования обычно задают для относительного быстрого, предварительного тонирования. Для более медленного тонирования с повышенным качеством можно создать другие наборы.

Диспетчер наборов стандартных параметров тонирования разделен на четыре сегмента: список наборов, панель свойств, кнопки и окно просмотра образцов.

Список наборов параметров тонирования

Отображается иерархический перечень всех наборов параметров, записанных с текущим чертежом. Различают наборы параметров двух типов: стандартный и пользовательский.

Иерархические структуры стандартных и пользовательских наборов параметров тонирования можно изменять, перетаскивая наборы мышью. Таким же образом можно изменять организацию множества пользовательских наборов параметров. Изменение организации стандартных наборов параметров в списке "Стандартные наборы параметров тонирования" не допускается.

Панель "Свойства"

Обеспечивает настройки, аналогичные свойствам палитры "Дополнительные параметры тонирования".

Информация о предварительных настройках

Общая информация о выбранных наборах параметров.

Имя

Указывается имя выбранного набора параметров. Разрешается также переименовывать пользовательский набор параметров. Переименование стандартных наборов параметров не допускается.

Описание

Отображается описание выбранного набора параметров.

Образец изображения

Указывается имя неподвижного изображения, связанного с выбранным набором параметров. При этом визуально отображается, как параметры тонирования влияют на тонированное изображение.

Нажать кнопку [...], чтобы открыть диалоговое окно "Указать изображение" (стандартное диалоговое окно выбора файла), где можно просмотреть и выбрать образец изображения для создаваемых наборов параметров.

Материалы

Содержит настройки, влияющие на способ обработки материалов системой тонирования.

С материалами

Применяет к поверхности материалы, которые определены пользователем и применяются к объектам. Если опция "С материалами" не выбрана, для всех объектов в чертеже предполагаются значения цвета, рассеяния, диффузии, отражения, шероховатости, прозрачности, преломления и текстуры выдавливания, определенные для ГЛОБАЛЬНОГО материала. Подробнее см. МАТЕРИАЛЫ.

Фильтр текстур

Указывает, используется ли фильтрация текстур.

Вынужденное 2-стороннее

Определяет, тонируются ли обе стороны грани.

Взятие образца

Определяет, как система тонирования выполняет взятие образца.

Мин. образцов

Задается минимальная частота взятия образцов. Значение отображает количество проб на пиксел. Значение, равное или большее единицы, указывает на вычисление одного и более образцов на пиксел. Дробная величина означает, что один образец вычисляется на каждые N пикселов (например, 1/4 указывает на вычисление не менее одного образца на каждые четыре пиксела). Значение по умолчанию = 1/4.

Макс. образцов

Задается максимальная частота взятия образцов. Если для соседних образцов обнаруживается разница контрастности, превышающая предел контрастности, то область с этой контрастностью подразделяется до заданной глубины. Значение по умолчанию=1.

Значения "Мин. образцов" и "Макс. образцов" связаны друг с другом так, что значение "Мин. образцов" не может превысить значения "Макс. образцов". Если значение "Мин. образцов" превышает значение "Макс. образцов", отображается диалоговое окно сообщения об ошибке.

Тип фильтра

Описывается способ комбинирования множества выборок в единое значение пиксела. Типы фильтров следующие:

  • Прямоугольник. Суммируются все образцы в области фильтрации, имеющие одинаковый вес. Это самый быстрый метод взятия образцов.
  • По Гауссу. Образцы взвешиваются с использованием гауссовой (колоколообразной) кривой, центрированной по пикселу.
  • Треугольник. Образцы взвешиваются с использованием пирамиды, центрированной по пикселу.
  • По Митчелу. Образцы взвешиваются с использованием кривой (большей крутизны по сравнению с гауссовой), центрированной по пикселу.
  • По Ланчосу. Образцы взвешиваются с использованием кривой (большей крутизны по сравнению с гауссовой), центрированной по пикселу, с уменьшением влияния образцов на границе области фильтрации.

Ширина и высота фильтра

Указывается размер области фильтрации. Увеличение значений ширины фильтра и высоты фильтра может понизить контрастность изображения, но при этом увеличивается длительность тонирования.

Контрастность цвета

Нажатие кнопки [...] открывает диалоговое окно "Выбор цвета", в котором пользователь может интерактивно указать пороговые значения красного, зеленого и синего цветов.

Контрастность красного, зеленого и синего цветов

Задает пороговые значения для красной, зеленой и синей составляющей образцов. Эти значения нормализованы и находятся в области от 0,0 до 1,0, где 0,0 указывает на то, что цветовая составляющая совершенно не насыщена (черный цвет или 0 в восьмиразрядной кодировке) а 1,0 указывает на полную насыщенность цветовой составляющей (белый цвет или 255 в восьмиразрядной кодировке).

Коэффициент контрастности (Альфа)

Указывается пороговое значение составляющей альфа-канала для образцов. Данное значение нормализовано и находится в области от 0,0 (полностью прозрачный или 0 в восьмиразрядной кодировке) до 1,0 (совершенно непрозрачный или 255 в восьмиразрядной кодировке).

С тенями

Содержит настройки, влияющие на метод представления теней в тонированном изображении.

Включить

Указывает на то, вычисляются ли тени во время тонирования.

Режим

Возможными режимами теней являются "простой", "с сортировкой" или "сегменты".

  • Простой Располагает модули построения теней в случайном порядке.
  • Отсортировано. Последовательно формирует модули построения теней от объекта до источника освещения.
  • Сегмент. Последовательно формирует модули построения теней в порядке их расположения вдоль светового луча от модулей тонирования по объему к сегментам светового луча между объектом и источником света.

Карта теней

Определяет, будет ли использовано наложение теней при их тонировании. Во включенном состоянии система тонирования выполняет раскрашивание с наложением теней. В отключенном состоянии все тени отслеживаются по лучам.

Отслеживание лучей

Содержит настройки, влияющие на метод представления теней в тонированном изображении.

Включить

Определяет, следует ли выполнять при раскрашивании отслеживание лучей.

Макс. глубина

Ограничивается комбинация отражений и преломлений. Трассировка луча прекращается при достижении суммой чисел отражения и преломления значения максимальной глубины. Например, если максимальная глубина равняется 3 и каждое из двух значений глубины отслеживания по умолчанию равно 2, возможно двукратное отражение и однократное преломление луча и наоборот, но четырехкратное отражение и преломление луча невозможно.

Максимум отражений

Задается число возможных отражений луча. При значении, равном 0, отражения отсутствуют. При значении, равном 1, допускается однократное отражение луча. При значении, равном 2, допускается двукратное отражение луча и т.д.

Максимум преломлений

Задается число возможных преломлений луча. При значении, равном 0, преломления отсутствуют. При значении, равном 1, допускается однократное преломление луча. При значении, равном 2, допускается двукратное преломление луча и т.д.

Общее освещение

Влияет на способ освещения сцены.

Включить

Определяет, будет ли использован расчет общего освещения для сцены.

Фотоны/образцы

Определяется количество фотонов, используемое для вычисления интенсивности общего освещения. При увеличении данного значения общее освещение становится менее ярким, но при этом более размытым. При уменьшении данного значения общее освещение становится более ярким, но при этом менее однородным. Чем выше значение "Образцы", тем больше длительность тонирования.

Использовать радиус

Определяет размер фотонов. Во включенном состоянии размер фотонов определяется значением наборного счетчика. В отключенном состоянии каждый фотон считается равным 1/10 радиуса полной сцены.

Радиус

Обозначается область, внутри которой используются фотоны при вычислении освещенности.

Макс. глубина

Ограничивается комбинация отражений и преломлений. Отражения и преломления фотона прекращаются, когда суммарное число отражений и преломлений достигает значения максимальной глубины. Например, если максимальная глубина равняется 3, и каждое из двух значений глубины отслеживания по умолчанию равно 2, возможно двукратное отражение и однократное преломление фотона и наоборот, но четырехкратное отражение и преломление фотона невозможно.

Максимум отражений

Задается число возможных отражений фотона. При значении, равном 0, отражения отсутствуют. При значение, равном 1, возможно только однократное отражение фотона. При значение, равном 2, возможно двукратное отражение фотона и т.д.

Максимум преломлений

Задается число возможных преломлений фотона. При значении, равном 0, преломления отсутствуют. При значении, равном 1, возможно только однократное преломление фотона. При значении, равном 2, возможно двукратное преломление фотона и т.д.

Чистовые пробы

Продолжает расчет общего освещения.

Включить

Определяет, требуются ли чистовые пробы для расчета окончательного раскрашивания.

Лучи

Определяется количество лучей, используемое для вычисления отраженного освещения в чистовой пробе. При увеличении данного значения общее освещение становится менее ярким, но одновременно возрастает длительность тонирования.

Режим радиуса

Определяет режим радиуса для обработки чистовых проб Параметры: "Вкл", "Откл" или "Вид"

  • Вкл. Указывает на то, что для обработки чистовых проб используется значение максимального радиуса. Радиус указывается в единицах мировой системы и по умолчанию равняется 10 процентам максимальной длины окружности модели.
  • Откл. Максимальный радиус по умолчанию равняется 10 процентам максимального радиуса модели в единицах мировой системы.
  • Вид. Для обработки чистовых проб используется значение максимального радиуса в пикселах, а не в единицах мировой системы.

Максимальный радиус

Задается максимальный радиус, в пределах которого используются чистовые пробы. Уменьшая данное значение, можно повысить качество ценой увеличения длительности тонирования.

Использовать минимум

Определяет, будет ли использован при обработке чистовых проб параметр "Минимальный радиус". "Вкл" - Значение минимального радиуса используется для обработки чистовых проб. "Откл" - Значение минимального радиуса не используется для обработки окончательной сборки.

Минимальный радиус

Задается минимальный радиус, в пределах которого используются чистовые пробы. Увеличивая данное значение, можно повысить качество, но с увеличением длительности тонирования.

Свойства источника света

Влияют на режим расчета отраженного освещения. По умолчанию настройки энергии и фотонов применяются ко всем источникам света в сцене.

Фотоны/Источник света

Задается количество фотонов, испускаемых каждым источником света для использования в общем освещении. При увеличении данного значения повышается точность действия общего освещения, но одновременно увеличивается используемый объем памяти и возрастает длительность тонирования. Уменьшение данного значения приводит к сокращению объема используемой памяти и понижению длительности тонирования и может быть полезным при просмотре эффектов от общего освещения.

Энергетический множитель

Умножается на общее освещение, отраженное освещение и яркость тонированного изображения.

Визуальный

Помогает пользователю понять причину конкретного поведения системы тонирования.

Сетка

Тонируется изображение, представленное в координатном пространстве объектов, в координатах мировой системы или координатах камеры.

  • Объект. Отображение в локальных координатах (UVW). Каждый объект имеет свой собственное координатное пространство.
  • МСК. Отображение в координатах мировой системы (XYZ). Ко всем объектам применяется одна и та же система координат.
  • Камера. Отображение в координатах камеры, представляемых в виде прямоугольной сетки, накладываемой на вид.

Размер сетки

Указывается размер сетки.

Фотон

Тонирование эффекта фотонов. Для этого требуется наличие фотонной схемы. Если фотонная схема отсутствует, то тонирование фотонов напоминает недиагностическое тонирование сцены: система тонирования вначале тонирует раскрашенную сцену, а затем заменяет ее псевдоцветным изображением.

  • Плотность. Тонирует фотонную схему так, как она проецируется на сцену. Высокая плотность отображается красным цветом, при понижении значений тонирование выполняется более холодными цветами.
  • Освещенность. Тонируется аналогично тонированию плотности, однако фотоны раскрашиваются согласно их освещенности. Максимальная освещенность тонируется красным цветом, при понижении значений тонирование выполняется более холодными цветами

БРП

Тонируется визуальное представление параметров, используемых иерархической структурой в методе ускорения отслеживания лучей с БРП. Если в сообщении от системы тонирования указаны слишком большие значения глубины или размера либо если скорость тонирования представляется недостаточной, это может помочь обнаружить проблему.

  • Глубина. Отображается глубина дерева с представлением верхних граней ярко-красным цветом и использованием все более холодных цветов по мере увеличения глубины расположения граней.
  • Формат. Отображается размер листьев дерева с обозначением листьев разного размера различающимися цветами.
Обработка

Размер фрагментов мозаики

Определяет размер фрагментов мозаики для тонирования. Для тонирования сцены изображение разделяют на мозаичные плитки. Чем меньше фрагмент, тем чаще обновляется изображение во время тонирования. При уменьшении размера мозаичной плитки увеличивается количество обновлений изображения, т.е. тонирование занимает больше времени. Если размер мозаичной плитки увеличивается, число обновлений изображения сокращается, и тонирование занимает меньше времени.

Порядок мозаики

Указывает используемый метод (порядок тонирования) обработки мозаичных плиток при тонировании изображения. Можно также выбрать метод в соответствии с тем, как должно выглядеть изображение при его тонировании в окне тонирования.

  • По Гильберту. Следующая тонируемая мозаичная плитка выбирается на основе стоимости переключения к следующей.
  • Спираль. Тонирование мозаичных плиток начинается в центре изображения и развивается по спирали наружу.
  • Слева направо. Мозаичные плитки тонируются столбцами снизу вверх, слева направо.
  • Справа налево. Мозаичные плитки тонируются столбцами снизу вверх, справа налево.
  • Сверху вниз. Мозаичные плитки тонируются рядами справа налево, сверху вниз.
  • Снизу вверх. Мозаичные плитки тонируются рядами справа налево, снизу вверх.

Ограничение по памяти

Определяет предел памяти для тонирования. Система тонирования ведет учет объема памяти, использованного во время тонирования. Если достигнут предел памяти, геометрия некоторых объектов не отображается, чтобы освободить память для других объектов.

Установить

Выбранный набор параметров тонирования устанавливается в качестве набора, используемого системой тонирования.

Создать копию

Копируются предварительные настройки. Открывается диалоговое окно "Копировать набор параметров тонирования".

Удалить

Удаляется выбранный пользовательский набор параметров тонирования. Удаление стандартных наборов параметров не допускается.

Окно просмотра образцов

Выводится образец изображения, соответствующий выбранному набору параметров тонирования. Если образец изображения не выводится, можно выбрать его среди параметров "Образец изображения" во вкладке "Информация о наборе параметров".


Диалоговое окно "Копировать набор параметров тонирования"

Н Команды
Н Команды
Диалоговое окно "Копировать набор параметров тонирования"
Понятия Процедуры Команды

Панель "Тонирование":

Меню "Вид": "Тонирование"; » "Дополнительные параметры тонирования"; » "Выбрать набор параметров тонирования"; » "Управление набором параметров тонирования" » "Создать копию"

Ввод команды: набпарамтонир

Пульт управления: Панель "Тонирование", "Выбрать набор параметров тонирования" » "Управление набором параметров тонирования" » "Создать копию"

Пользователь может определить свои собственные наборы параметров путем создания копии на основе существующих наборов параметров тонирования. Пользователь может задать имя и описание копируемых наборов параметров. Новые наборы параметров отображаются в виде одного из пользовательских наборов параметров тонирования в списке "Набор параметров тонирования" в "Диспетчере наборов стандартных параметров тонирования".

Имя

Назначает имя скопированному набору параметров. Имя набора параметров должно быть уникальным.

Описание

Следует добавить описание пользовательского набора параметров.

Также нужно описать эффект от тонирования, получаемый при использовании пользовательского набора параметров. Данное описание может быть более подробным, чем имя набора параметров.

Примечание В имена наборов параметров нельзя включать специальные символы. Если в имени набора параметров обнаруживается специальный символ, выводится диалоговое окно с предупреждением.

После определения нового набора параметров тонирования его можно выбрать в списке "Наборы параметров тонирования" и при необходимости изменить и сохранить параметры тонирования этого набора.


НАЙТИ Команда

Н Команды
Н Команды
НАЙТИ Команда
Понятия Процедуры Команды

Поиск, замена , выбор и показ текста на чертеже

Меню "Правка": Найти

Контекстное меню: Завершить выполнение активных команд, нажать правую кнопку мыши в области рисования и выбрать "Найти".

Ввод команды: найти

Откроется диалоговое окно "Поиск и замена".

Темы:

  • Диалоговое окно "Поиск и замена"
  • Диалоговое окно "Параметры поиска и замены"


Диалоговое окно "Поиск и замена"

Н Команды
Н Команды
Диалоговое окно "Поиск и замена"
Понятия Процедуры Команды

Найти Найти

Контекстное меню: Завершить выполнение активных команд, нажать правую кнопку мыши в области рисования и выбрать "Найти".

Ввод команды: найти

Задание фрагмента текста для поиска, замены или выбора, а также управление охватом и результатами поиска.

Строка для поиска

Задание текстовой строки, которую необходимо найти. Введите текстовую строку, включая символы-шаблоны, или выберите строку из списка шести последних искомых строк.

Заменить на

Фрагмент текста, которым следует заменить искомый фрагмент. Ввести строку или выбрать ее из списка шести последних строк, использованных для замены.

Область поиска

Задание области поиска: во всем чертеже или в текущем наборе объектов. Если хотя бы один объект был предварительно выбран, поиск по умолчанию осуществляется в текущем наборе объектов. Если ничего не выбрано, поиск по умолчанию осуществляется во всем чертеже. Для того чтобы временно выйти из диалогового окна "Поиск и замена" и создать или изменить набор объектов, можно воспользоваться кнопкой "Выбрать объекты".

Выбрать объекты

Временный выход из диалогового окна для выбора объектов на чертеже. Нажатие клавиши ENTER вновь открывает диалоговое окно. Когда объекты выбраны, областью поиска становится текущий набор объектов.

Параметры

Отображает диалоговое окно "Параметры поиска и замены", в котором можно задать тип объектов и параметры поиска строк.

Найти/Найти далее

Поиск указанного фрагмента текста. Если искомый фрагмент не задан, эта опция недоступна. Найденный текст отобразится в области "Контекст". После того как найден первый искомый элемент, вместо кнопки "Найти" отображается кнопка "Найти далее", которая используется для поиска следующего текстового элемента.

Заменить

Замена найденного фрагмента текста на строку, указанную в поле "Заменить на".

Заменить все

Поиск всех вхождений строки, заданной в поле "Строка для поиска", и замена их фрагментом, заданным в поле "Заменить на". Параметр "Область поиска" управляет поиском и перемещением текста во всем чертеже или в текущем выборе. Количество сделанных замен отображается в нижней части диалогового окна.

Выбрать все

Поиск и выделение всех загруженных объектов текста, содержащих указанный в поле "Строка для поиска" фрагмент. Параметр доступен только в том случае, если в списке "Область поиска" выбрано значение "Текущий набор". При нажатии кнопки "Выбрать все" диалоговое окно закрывается и в сообщении в командной строке отображается количество найденных и выбранных объектов. Следует обратить внимание, что опция "Выбрать все" не осуществляет замены текста; игнорируется весь текст, указанный в поле "Заменить на".

Зумировать

Показ на экране области чертежа, в которой располагается заданная строка. Несмотря на то, что выполняется поиск заданной текстовой строки как в пространстве модели, так и на всех листах, показать можно только те строки, которые находятся на текущей вкладке (модели или листа). Иногда найденная строка, если она входит в многострочный текст, при зумировании может не войти в видимую часть чертежа.

Тип объекта

Указывает тип объекта, в котором был обнаружен текст.

Контекст

Показ найденной текстовой строки вместе с контекстом. При выборе параметра "Найти далее" обновляется содержимое области "Контекст", и в ней размещается следующая текстовая строка в контексте.

Статус

Вывод сообщений о найденных и замененных строках.


Диалоговое окно "Параметры поиска и замены"

Н Команды
Н Команды
Диалоговое окно "Параметры поиска и замены"
Понятия Процедуры Команды

Найти Найти

Контекстное меню: Завершить выполнение активных команд, нажать правую кнопку мыши в области рисования и выбрать "Найти".

Ввод команды: найти

Задание типа объектов и параметров поиска.

Охватываемые элементы

Задание типов объектов, включаемых в область поиска. По умолчанию все флажки установлены.

Учитывать регистр

Поиск текстовой строки с учетом регистра.

Слово целиком

Поиск только целых слов, а не фрагментов слов, состоящих из заданной в поле "Строка для поиска" строки. Например, если при поиске строки “Пол“ установлен флажок "Слово целиком", команда НАЙТИ не включает в результат слово “Половик“”


НАЛТЕК Команда

Н Команды
Н Команды
НАЛТЕК Команда
Понятия Процедуры Команды

Устар.

Ввод команды: налтек

Запускает команду МАТЕРИАЛСООТВ.


НАСТРВИД Команда

Н Команды
Н Команды
НАСТРВИД Команда
Понятия Процедуры Команды

Задание точности аппроксимации объектов на текущем видовом экране

Ввод команды: настрвид

Нужно быстрое зумирование? [Да/Нет] <Д>: Нажать ENTER (быстрое зумирование более не является действующим параметром этой команды и используется только для совместимости со сценариями).

Точность аппроксимации (1-20000) <текущая>: Ввести целое число от 1 до 20000 или нажать ENTER

Модель регенерируется.

Команда НАСТРВИД позволяет задавать точность представления кругов, дуг, эллипсов и сплайнов. Любая кривая на экране аппроксимируется набором коротких прямых сегментов. Чем больше задано сегментов, тем более гладкими являются объекты. Например, если построить маленький круг, а затем зумировать чертеж с увеличением, круг может оказаться похожим на многоугольник. Для восстановления гладкости следует увеличить процент зумирования с помощью команды НАСТРВИД и регенерировать чертеж. Уменьшение точности аппроксимации ведет к обратному эффекту.

Примечание Увеличение процента зумирования в команде НАСТРВИД может привести к замедлению процесса регенерации чертежа.

Когда пространство листа активизируется впервые и в нем создается первый видовой экран, значение точности аппроксимации кривых нем устанавливается равным аналогичному значению для видового экрана пространства модели.

Текущее значение параметра НАСТРВИД хранится в чертеже. Чтобы для нового чертежа изменить принимаемые по умолчанию значения опций команды параметра НАСТРВИД, нужно внести изменения в соответствующий файл шаблона.


НАСТРОЙКА Команда

Н Команды
Н Команды
НАСТРОЙКА Команда
Понятия Процедуры Команды

Параметры данной вкладки служат для пользовательской настройки программы

Меню "Сервис": "Настройка"

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Отображается диалоговое окно "Настройка".

Темы:

  • Диалоговое окно "Настройка"
  • Вкладка "Файлы" (диалоговое окно "Настройка")
  • Вкладка "Экран" (диалоговое окно "Настройка")
  • Вкладка "Открытие/Сохранение" (диалоговое окно "Настройка")
  • Вкладка "Печать/Публикация" (диалоговое окно "Настройка")
  • Вкладка "Система" (диалоговое окно "Настройка")
  • Вкладка "Пользовательские" (диалоговое окно "Настройка")
  • Вкладка "Построения" (диалоговое окно "Настройка")
  • Вкладка "3D моделирование" (диалоговое окно "Настройка")
  • Вкладка "Выбор" (диалоговое окно "Настройка")
  • Вкладка "Профили" (диалоговое окно "Настройка")
  • Диалоговое окно "Альтернативный шрифт"
  • Диалоговое окно "Цвета окон чертежа"
  • Диалоговое окно "Шрифт командной строки"
  • Диалоговое окно "Вид обозначений источников света"
  • Диалоговое окно "Вид обозначения камеры"
  • Диалоговое окно "Образец для просмотра"
  • Диалоговое окно "Таблицы стилей печати"
  • Диалоговое окно "Настройка правой кнопки мыши "
  • Диалоговое окно "Настройка обновления полей"
  • Диалоговое окно "Параметры визуальных эффектов"
  • Диалоговое окно "Дополнительные опции просмотра"
  • Диалоговое окно "Добавление профиля"
  • Диалоговое окно "Переименование профиля"
  • Диалоговое окно "Прозрачность"


Диалоговое окно "Настройка"

Н Команды
Н Команды
Диалоговое окно "Настройка"
Понятия Процедуры Команды

Меню "Сервис": "Настройка"

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Настройка многих параметров программы.

Текущий профиль

Имя текущего профиля выводится над вкладками. Задать текущий профиль, создать новый или отредактировать имеющийся можно на вкладке "Профили". (системная переменная CPROFILE)

Значок чертежа

Указывает, что параметр сохраняется с текущим чертежом. Изменение таких параметров действует только для текущего чертежа. Параметр, сохраняемый в реестре (не помеченный значком файла чертежа), влияет на все чертежи сеанса работы. Параметры, сохраняемые в реестре, записываются в текущем профиле.

Текущий чертеж

Имя текущего чертежа выводится над вкладками. (системная переменная DWGNAME)

Диалоговое окно "Настройка" состоит из следующих вкладок:

  • Файлы
  • Отображение
  • Открытие/Сохранение
  • Печать/Публикация
  • Системный
  • Пользовательские
  • Построения
  • Выбор
  • Профили

Темы:

  • Вкладка "Файлы" (диалоговое окно "Настройка")
  • Вкладка "Экран" (диалоговое окно "Настройка")
  • Вкладка "Открытие/Сохранение" (диалоговое окно "Настройка")
  • Вкладка "Печать/Публикация" (диалоговое окно "Настройка")
  • Вкладка "Система" (диалоговое окно "Настройка")
  • Вкладка "Пользовательские" (диалоговое окно "Настройка")
  • Вкладка "Построения" (диалоговое окно "Настройка")
  • Вкладка "3D моделирование" (диалоговое окно "Настройка")
  • Вкладка "Выбор" (диалоговое окно "Настройка")
  • Вкладка "Профили" (диалоговое окно "Настройка")


Вкладка "Файлы" (диалоговое окно "Настройка")

Н Команды
Н Команды
Вкладка "Файлы" (диалоговое окно "Настройка")
Понятия Процедуры Команды

Отображает список папок, в которых программа осуществляет поиск файлов поддержки, меню, драйверов и других файлов. Кроме того, здесь можно задать ряд пользовательских установок, например, выбрать словарь для проверки правописания.

Обзор

Отображает диалоговое окно "Обзор папок" или "Выбор файла" (стандартное диалоговое окно выбора файлов), в котором можно указать новое местоположение папки или файла, выбранных в списке.

Путь доступа к вспомогательным файлам

Указывает папки, в которых программа должна выполнять поиск шрифтов для текста, файлов адаптации, подключаемых модулей, чертежей для вставки, типов линий и образцов штриховки, которые отсутствуют в текущей папке.

Путь поиска рабочих файлов поддержки

Отображает папки, в которых программа ищет файлы поддержки, характерные для системы пользователя. Список предназначен только для чтения и отображает все пути к вспомогательным файлам через текущую папку и сетевые подключения.

Путь доступа к драйверам устройств

Указывает путь поиска драйверов видеомониторов, устройств указания, принтеров и плоттеров.

Путь доступа к файлам проектов

Позволяет указать для чертежа имя проекта. Имя проекта связано с путем доступа к файлам внешних ссылок. Пользователь может создавать любое количество проектов с различными путями доступа, но для каждого чертежа можно использовать только один проект. (системная переменная PROJECTNAME)

Файлы адаптации

Задает имена и расположения ряда дополнительных файлов.

Основной файл адаптации

Указывает местоположение по умолчанию основного файла адаптации (acad.cui).

Корпоративный файл настройки

Указывает местоположение корпоративного файла настройки.

Папка для пользовательских значков

Задание расположения папки для пользовательских значков, используемых в файлах адаптации.

Имена файлов справки и других файлов

Задает имена и расположения ряда дополнительных файлов.

Файл справки

Указывает местоположение файла справки.

Начальный узел Интернета

Задание имени начальной страницы, которая загружается в браузер при вызове команды BROWSER или нажатии кнопки "Навигация в Интернете" на панели "Web".

Файл параметров

Содержит путь доступа к файлу настройки, используемому для хранения значений параметров драйверов устройств. Данный путь доступа имеет статус "только чтение" и может быть изменен только с помощью переключателя /c в командной строке. См. раздел Настройка запуска в документе "Руководство пользователя".

Имена файлов текстового редактора, словаря и шрифтов

Позволяет задать ряд необязательных установок.

Текстовый редактор

Позволяет выбрать приложение, которое будет использоваться для редактирования объектов многострочного текста. (системная переменная MTEXTED)

Основной словарь

Позволяет выбрать словарь для проверки орфографии в текстах. (системная переменная DCTMAIN)

Вспомогательный словарь

Позволяет выбрать для проверки орфографии вспомогательный словарь, если такой имеется. (системная переменная DCTCUST)

Файл альтернативного шрифта

Задает путь доступа к файлу шрифта, который следует использовать, если невозможно обнаружить исходный шрифт, а альтернативный шрифт не определен в файле соответствий шрифтов. При нажатии кнопки "Обзор" отобразится диалоговое окно "Альтернативный шрифт", в котором можно выбрать имеющийся шрифт. (системная переменная FONTALT)

Файл соответствия шрифтов

Указывает расположение файла, в котором определен порядок замены отсутствующих в системе шрифтов на альтернативные. (системная переменная FONTMAP)

Имена файла печати, программы фоновой печати и раздела пролога

Позволяет задать установки для вывода на печать.

Имя файла чертежа для командных файлов

Стандартные имена для файлов чертежей при выполнении командных файлов печати, созданных в AutoCAD Release 14 или более ранних версиях. Файлу чертежа по умолчанию присваивается имя чертежа и расширение .plt. Для чертежей AutoCAD 2000 и более поздних версий по умолчанию файлы именуются следующим образом: имя чертежа-имя листа и расширение .plt. Однако драйверы некоторых печатающих устройств используют другие расширения. Опция действует только на стандартные имена файлов чертежей для пакетов печати, созданных в предыдущих версиях AutoCAD.

Программа фоновой печати

Позволяет выбрать приложение для реализации фоновой печати. Имя исполняемого файла можно ввести вместе с аргументами командной строки. Например, для фоновой печати файлов из myspool.bat и автоматической генерации имени файла чертежа можно ввести myspool.bat %s. См. раздел Печать в фоновом режиме в "Руководстве по драйверам и периферийным устройствам".

Путь к вспомогательным файлам печати

Пути к файлам, обеспечивающим поддержку печати.

Папка для фоновой печати

Задает имя папки для размещения временных файлов печати.

Путь поиска конфигураций печати

Задание пути к файлам параметров плоттеров (PC3).

Путь поиска файлов описания принтеров

Задание пути к файлам с расширением .pmp, в которых хранятся описания принтеров.

Путь поиска таблиц стилей печати

Задание пути к файлам с расширениями stb или .ctb, т.е. файлам таблиц стилей печати (как именованных, так и цветозависимых).

Папка для файла автосохранения

Задание пути к временному файлу автосохранения, который создается при включении опции "Автосохранение" на вкладке "Открытие/Сохранение". (системная переменная SAVEFILEPATH)

Папки для альбомов цветов

Задание пути к файлам альбомов цветов, которые могут использоваться для выбора цвета в диалоговом окне "Выбор цвета". Для альбомов цветов можно задать несколько папок. Значение опции сохраняется в пользовательском профиле.

Положение источников данных

Задание пути к файлам баз данных. Изменения этого параметра вступают в силу только после перезапуска программы.

Параметры шаблонов

Задание параметров шаблонов чертежей.

Папка для шаблона чертежа

Задает путь к шаблонам чертежей, которые используются Мастером подготовки и в диалоговом окне "Создание нового чертежа".

Папка для файла шаблона подшивки

Задание пути поиска шаблонов подшивок, используемых Мастером создания подшивок.

Шаблон по умолчанию для команды БСОЗДАТЬ

Задание файла шаблона чертежа, используемого командой БСОЗДАТЬ.

Шаблон по умолчанию для создания листов и переопределения наборов параметров

Задание файла шаблона, используемого по умолчанию для создания новых листов и сохранения переопределения наборов параметров создания листов при публикации с помощью Диспетчера подшивок.

Папки с файлами инструментальных палитр

Задание пути к файлам описаний инструментальных палитр.

Папки файлов палитры вариации

Задает путь к файлам поддержки палитр вариации блоков. Палитры вариации блоков используются в редакторе блоков и содержат инструменты для создания динамических блоков.

Расположение файла журнала

Задание пути к файлу журнала, который создается при включении опции "Вести файл журнала" на вкладке "Открытие/Сохранение". (системная переменная LOGFILEPATH)

Папка для файла журнала печати/публикации

Задает путь для файла журнала, который автоматически создается при выборе параметров "Вести журнал автоматически" и "Публикация журнала" на вкладке "Печать/Публикация".

Папка для временных файлов

Указывает папку для хранения временных файлов. Эта программа создает временные файлы, которые удаляются при выходе из нее. При запуске программы из папки, защищенной от записи (например, при работе в сети или открытии файлов с компакт-диска), необходимо назначить для временных файлов другую папку. Указанная папка должна быть доступной для записи.

Текущая папка для временных файлов хранится также в системной переменной TEMPPREFIX (только чтение).

Папка для временных файлов внешних ссылок

Задает папку для расположения копий файлов внешних ссылок. Эта папка используется при выборе опции "Разрешена с копированием" для списка "Подгрузка файлов внешних ссылок" на вкладке "Открытие/Сохранение" диалогового окна "Настройка". (системная переменная DIMLWE)

Папка для поиска текстур

Указывает папки для поиска файлов текстур, используемых при тонировании.

Папка для связанных файлов точек загрузки

Задание пути, по которому размещаются файлы данных, связанные с содержимым точек загрузки. Если путь не задан, файлы записываются в папку текущего чертежа.

Обзор

Выводит одно из диалоговых окон "Обзор папок" или "Выбор файла", в зависимости от текущего элемента в списке.

Добавить

Добавляет путь поиска в выбранную группу.

Удалить

Удаляет выбранный путь доступа или файл.

Вверх

Перемещает выбранный путь в очереди использования для поиска на один шаг вперед.

Вниз

Перемещает выбранный путь в очереди использования для поиска на один шаг назад.

Установить

Установка выбранного проекта или орфографического словаря текущим.


Вкладка "Экран" (диалоговое окно "Настройка")

Н Команды
Н Команды
Вкладка "Экран" (диалоговое окно "Настройка")
Понятия Процедуры Команды

Параметры данной вкладки служат для настройки параметров рабочего экрана.

Элементы окна

Определяет параметры экрана, характерные для среды рисования.

Полосы прокрутки

Включает/отключает вывод полос прокрутки в нижней и правой части окна чертежа.

Экранное меню

Вывод экранного меню в правой части окна чертежа. Шрифт экранного меню задается системными настройками шрифтов Windows. При использовании экранного меню системные настройки шрифтов Windows должны соответствовать размерам экранного меню.

Крупные кнопки для панелей задач

Отображение на панелях инструментов кнопок крупного формата (32 х 30 пикселов). По умолчанию кнопки имеют размеры 16 х 15 пикселов.

Всплывающие подсказки

Отображение всплывающих подсказок при наведении курсора на кнопки панелей инструментов.

Комбинации клавиш в подсказках

Отображение комбинаций клавиш во всплывающих подсказках к кнопкам.

Цвета

Отображает диалоговое окно "Установка цветов". В этом диалоговом окне задаются цвета элементов главного окна приложения.

Шрифты

Отображает диалоговое окно "Шрифт командной строки". В этом диалоговом окне задается шрифт текста окна команд.

Листы

Задание настроек имеющихся и новых листов. Листом называется среда в пространстве листа, в которой производится компоновка чертежей для вывода на печать.

Вкладки "Модель" и "Лист"

Вывод ярлыков вкладок "Лист" и "Модель" в нижней части окна чертежа. Если этот флажок снят, вкладки заменяются кнопками в строке состояния.

Границы печатаемой области

Отображение границ печатаемой области на листе чертежа. Границы печатаемой области очерчиваются штриховой линией и зависят от выбранного устройства вывода. Объекты, выходящие за границы печатаемой области, при выводе на печать обрезаются или пропускаются.

Подложить заданный формат

Задание режима разметки заданного формата на вкладке листа. Размер подложенного формата определяется выбранными размерами листа и масштабом печати.

Тень вокруг границ: Отображает тени вокруг подложенного листа в режиме разметки заданного формата на вкладке листа. Данная настройка недоступна, если не включена опция "Подложить заданный формат".

Диспетчер параметров для новых листов

Отображает Диспетчер наборов параметров листов при открытии вкладки "Лист" в первый раз. Диалоговое окно используется для задания параметров листа и печати.

Создавать видовые экраны на новых листах

Автоматическое создание видового экрана на каждом новом листе.

Размер перекрестья

Управляет размером перекрестья курсора. Размер перекрестья задается в процентах от размера экрана (в пределах от 1 до 100). При значении 100% концы перекрестья никогда не видны. Если задано значение 99% или менее, то размер перекрестья принимает конечное значение и его концы становятся видны при перемещении курсора по экрану. По умолчанию выбирается значение 5%. (системная переменная CURSORSIZE)

Экранное разрешение

Управляет качеством отображения объектов на экране. При задании значений, резко улучшающих качество отображения, может существенно снизиться производительность системы.

Плавность дуг и кругов

Управление плавностью визуализации кругов, дуг и эллипсов. Большее значение увеличивает плавность передачи объектов, но при этом требуется больше времени для регенерации, панорамирования и масштабирования объектов. Можно повысить производительность системы путем снижения плавности визуального представления объектов на чертеже (например до 100) и соответствующего увеличения плавности при тонировании. Допустимый диапазон значений — от 1 до 20 000. По умолчанию устанавливается 1000. Настройка хранится в чертеже. Чтобы сменить значение для использования по умолчанию в новых чертежах, нужно настроить опцию в шаблоне, на котором они базируются. (команда НАСТРВИД)

Число сегментов в дугах полилиний

Число прямых сегментов, которые должны быть сгенерированы для каждого криволинейного участка полилинии. Чем больше значение в данном поле, тем значительнее влияние, оказываемое на эффективность системы. В целях оптимизации производительности устанавливается низкое значение (например, 4). Допустимый диапазон значений в пределах от -32767 до 32767. По умолчанию устанавливается 8. Настройка хранится в чертеже. (системная переменная SPLINESEGS).

Плавность тонированных объектов

Управление плавностью отображения искривленных тел при их раскрашивании и тонировании. Значение, введенное в поле "Плавность тонированных объектов", умножается на значение, введенное в поле "Плавность дуг и кругов", для определения режима визуализации трехмерных объектов. Для повышения эффективности системы при редактировании чертежа следует установить значение 1 в поле "Плавность тонированных объектов". При увеличении значения происходит снижение производительности, и увеличивается время тонирования. Допустимый диапазон значений от 0.01 до 10. По умолчанию значение равно 0.5. Настройка хранится в чертеже. (системная переменная FACETRES)

Число образующих в поверхностях

Задает число линий контура для изображения поверхностей объектов. При увеличении значения происходит снижение производительности, и увеличивается время тонирования. Допустимый диапазон значений от 0 до 2047. По умолчанию устанавливается 4. Настройка хранится в чертеже. (системная переменная ISOLINES).

Производительность отображения

Управляет параметрами отображения, от которых зависит производительность.

Пан/Зум с растр. изображениями и OLE

Управление отображением растровых изображений и OLE-объектов при использовании режимов панорамирования и зумирования в реальном времени (команды ПАН и ПОКАЗАТЬ). В целях оптимизации производительности флажок не устанавливается. Если данная опция включена, то в процессе панорамирования или зумирования чертежа в реальном времени содержимое растровых изображений и OLE-объектов перемещается по экрану вместе с курсором вместе с оригиналом.. Опция управляет отображением контуров перетаскиваемых объектов. Отображением объектов при перетаскивании управляет системная переменная DRAGMODE. (системная переменная RTDISPLAY)

Подсвечивать только границы растра

Управление показом растровых изображений в ходе выбора. Если флажок установлен, при выборе изображения подсвечивается только его граница. В целях оптимизации производительности рекомендуется установить флажок. (системная переменная IMAGEHLT)

Показывать заливку

Отображение сплошных заливок. Для того чтобы данная настройка вступила в силу, следует регенерировать чертеж. Настройка хранится в чертеже. В целях оптимизации производительности флажок не устанавливается. (системная переменная FILLMODE)

Действие команды ЗАКРАСИТЬ распространяется на штриховки (включая сплошные), 2М тела, широкие полилинии, мультилинии и полосы.

Только границы текстов

Включает/отключает режим вывода граничных рамок вместо соответствующих текстовых объектов. После включения или отключения данного режима необходимо выполнить регенерацию изображения с помощью команды РЕГЕН. Настройка хранится в чертеже. В целях оптимизации производительности рекомендуется установить флажок. (системная переменная QTEXTMODE)

Кромки силуэта

Управляет отображением кромок силуэтов, образующих каркасы трехмерных тел. Настройка также управляет видимостью сети при скрытии линий твердотельных объектов. Настройка хранится в чертеже. В целях оптимизации производительности флажок не устанавливается. (системная переменная DISPSILH)

Затенение при редактировании ссылок

Задание интенсивности затенения объектов при редактировании вхождений. В контексте текущего чертежа можно редактировать вхождения блоков и внешних ссылок. При редактировании вхождений объекты, не выбранные для редактирования, отображаются с затенением. Допустимый диапазон значений — от 0 до 90 процентов. По умолчанию устанавливается 50 процентов. (системная переменная XFADECTL)


Вкладка "Открытие/Сохранение" (диалоговое окно "Настройка")

Н Команды
Н Команды
Вкладка "Открытие/Сохранение" (диалоговое окно "Настройка")
Понятия Процедуры Команды

Управляет параметрами сохранения и открытия файлов.

Сохранение файлов

Управляет параметрами сохранения файлов.

Сохранить как

Список допустимых форматов файлов, используемых для сохранения файла с помощью команд СОХРАНИТЬ, СОХРАНИТЬКАК и БСОХРАНИТЬ и ПБЛОК. Формат, выбранный для данного параметра, используется по умолчанию для сохранения всех чертежей с помощью команд СОХРАНИТЬ, СОХРАНИТЬКАК, БСОХРАНИТЬ и ПБЛОК.

Примечание AutoCAD 2004 - это формат файлов чертежей, используемый в версиях AutoCAD 2004, AutoCAD 2005 и AutoCAD 2006.

Образец для просмотра

Отображает диалоговое окно "Параметры образца для просмотра", с помощью которого можно управлять обновлением образца для просмотра при сохранении чертежа.

Процент для быстрых сохранений

Максимально допустимый объем устаревшей информации, хранимой в файле чертежа, при быстрых (пошаговых) сохранениях его изменений. При этом часть устаревшей информации удаляется из файла чертежа. При последовательном сохранении скорость процесса выше, но при этом увеличивается размер чертежа. При установке в данном поле значения 0 каждое пошаговое сохранение будет выполняться в объеме полного сохранения. Для оптимизации производительности следует установить значение 50. При недостатке места на диске значение следует снизить до 25. Установка значения 20 или ниже значительно снижает производительность при выполнении команд СОХРАНИТЬ и СОХРАНИТЬКАК. (системная переменная ISAVEPERCENT)

Меры предосторожности при сохранении

Опции данной группы помогают предотвратить потерю данных и обнаружить ошибки.

Автосохранение

Задает периодическое автоматическое сохранение чертежа в файл на диске с заданным временным интервалом. Расположение файлов для автосохранения можно задать с помощью системной переменной SAVEFILEPATH. Системная переменная SAVEFILE (только чтение) хранит имя файла автосохранения.

Примечание Автосохранение отключается, если открыто Редактор блоков.

Интервал, мин: При включенной функции автосохранения задает частоту сохранения чертежа. (системная переменная DIMLWE)

Создавать резервные копии

Включение/отключение создания резервных копий чертежа при его сохранении. Резервная копия находится в той же папке, что и сам чертеж. (системная переменная ISAVEBAK)

Подробнее о резервном копировании см. раздел Создание файлов архива и восстановление документа Руководство пользователя.

Постоянно проверять контрольную сумму

Включает/отключает проверку контрольной суммы (CRC) при загрузке объектов из файла чертежа. CRC — это механизм проверки целостности данных. Если какой-либо чертеж был испорчен, а возможной причиной является аппаратная ошибка или ошибка программы, следует включить этот параметр.

Вести файл журнала

Запись содержимого текстового окна в файл журнала. Для выбора папки расположения и задания имени файла журнала следует использовать вкладку "Файлы" диалогового окна "Настройка". Папка расположения файла журнала контролируется также системной переменной LOGFILEMODE. Системная переменная LOGFILENAME хранит имя файла журнала (только чтение).

Расширение для временных файлов

Указывает уникальное расширение при сохранении временных файлов. По умолчанию файлы имеют расширение .ac$.

Параметры безопасности

Параметры цифровой подписи и пароля, добавляемых при сохранении файла.

Отображать информацию о цифровой подписи

Вывод информации о цифровой подписи при открытии файла с действительной подписью. (системная переменная SIGWARN)

Открытие файлов

Настройка параметров, относящимся к недавно использованным файлам и файлам, открытым в графическом редакторе.

Количество последних файлов в меню

Задает число последних файлов, отображаемых в меню "Файл" для быстрого доступа к ним. Допустимый диапазон значений от 0 до 9.

Полные пути в заголовках

Отображение полного пути активного чертежа в строке заголовка чертежа или в строке заголовка окна приложения, если окно чертежа полностью развернуто.

Внешние ссылки

Управление параметрами редактирования и загрузки внешних ссылок.

Подгрузка внешних ссылок

Управление подгрузкой внешних ссылок. Подгрузка увеличивает производительность системы путем добавления в чертеж только тех частей из внешней ссылки, которые необходимы для регенерации текущего чертежа. (системная переменная XLOADCTL)

  • Запрещена: Отключение подгрузки.
  • Разрешена: Включает режим подгрузки и увеличивает производительность. Параметр следует устанавливать для улучшения процесса подгрузки при работе с подрезанными внешними ссылками, содержащими пространственный или слоевой индекс. Если флажок установлен, другие пользователи не могут редактировать такой файл, пока открыт использующий его чертеж.
  • Разрешена с копированием: Включает режим подгрузки, но при этом используется копия исходного файла внешней ссылки. Другие пользователи не теряют возможности редактировать исходный файл.

Сохранять изменения слоев ссылок

Сохранение изменений свойств и состояния зависимых от ссылок слоев. Это значит, что при следующей загрузке чертежа в нем будут учтены все изменения таких слоев. Настройка хранится в чертеже. (системная переменная VISRETAIN)

Разрешить редактирование чертежа как ссылки

Определяет, может ли текущий чертеж участвовать в операции редактирования вхождений, будучи вставленным в другой чертеж или чертежи как внешняя ссылка. Настройка хранится в чертеже. (системная переменная XEDIT)

Приложения ObjectARX

Управление параметрами приложений AutoCAD Runtime Extension и заместителей.

Подгрузка ObjectARX-приложений

При обнаружении в чертеже объектов, созданных в стороннем приложении, определяет необходимость и момент загрузки этого приложения. (системная переменная DEMANDLOAD)

  • Отключение загрузки по запросу: Отключение подгрузки.
  • Обнаружение сторонних объектов: Загружает стороннее приложение при открытии чертежа, который содержит объекты, созданные в этом приложении. Эта установка не вызывает загрузку приложения по запросу при вызове одной из команд этого приложения.
  • Вызов команды: Загружает исходное приложение при вызове одной из определенных в нем команд. Это значение не вызывает подгрузку приложения при открытии чертежа, в котором содержатся принадлежащие приложению объекты.
  • Обнаружение объекта и вызов команды: Загружает стороннее приложение при открытии чертежа, который содержит объекты, созданные в этом приложении, или при вызове одной из определенных в нем команд.

Заместители для сторонних объектов

Управление отображением сторонних объектов в чертеже. (системная переменная PROXYSHOW)

  • Не показывать элементы: Сторонние объекты не выводятся в чертеже.
  • Показывать элементы: Сторонние объекты выводятся в чертеже.
  • Показывать только рамку: Включает отображение рамки вместо сторонних объектов в чертеже.

Выводить окно сведений о заместителях

Включает или отключает вывод предупреждения при открытии чертежа, содержащего объекты сторонних приложений. (системная переменная PROXYNOTICE)


Вкладка "Печать/Публикация" (диалоговое окно "Настройка")

Н Команды
Н Команды
Вкладка "Печать/Публикация" (диалоговое окно "Настройка")
Понятия Процедуры Команды

Вкладка позволяет задать параметры вывода на печать и публикации чертежей.

Параметры печати для новых чертежей по умолчанию

Задание устройства вывода по умолчанию для новых чертежей, а также чертежей, которые были созданы в AutoCAD Release 14 или более ранних версиях и еще не сохранены в формате AutoCAD 2000 или более поздней версии.

Устройство вывода по умолчанию

Задание устройства вывода по умолчанию для новых чертежей, а также чертежей, которые были созданы в AutoCAD Release 14 или более ранних версиях и еще не сохранены в формате AutoCAD 2000 или более поздней версии. В списке перечислены все файлы параметров печати (PC3), найденные по заданным путям поиска файлов, и все настроенные в системе системные принтеры.

Последнее успешно использованное устройство

Установка параметров печати в соответствии с настройками последнего успешно использованного устройства.

Добавление и настройка плоттеров

Отображает "Диспетчер плоттеров" (системное окно Windows). С помощью "Диспетчера плоттеров" можно добавить или настроить плоттер.

Печать в файл

Задание используемого по умолчанию расположения файла печати. Расположение можно ввести с клавиатуры или выбрать, нажав кнопку [...].

Параметры фоновой обработки

Задание параметров для вывода на печать или публикации в фоновом режиме. Чтобы не прерывать работу над чертежом можно выполнять печать/публикацию в фоновом режиме.

Подробности печати и публикации доступны в контекстном меню значка печати и публикации в строке состояния.

Печать и публикацию можно выполнять в фоновом режиме, даже если программа не запущена, введя в командной строке Windows acad/pl <имя файла DSD>.

Поддержка фонового вывода

Управление режимом фонового вывода в операциях печати/публикации.

Печать: Задает фоновый режим для вывода на печать. Эта настройка также управляется системной переменной BACKGROUNDPLOT.

Публикация: Задает фоновый режим для публикации. Эта настройка также управляется системной переменной BACKGROUNDPLOT.

Примечание При использовании в пакетных файлах (SCR) команд -ПЕЧАТЬ, ПЕЧАТЬ, -ПУБЛ и ПУБЛ значение системной переменной BACKGROUNDPLOT игнорируется. Все эти команды работают в стандартном (не фоновом) режиме.

Файл журнала печати и публикации

Управление параметрами ведения файла журнала для печати и публикации. Файл журнала имеет формат с разделиителем-запятой (CSV) и для его просмотра можно воспользоваться программой работы с электронными таблицами.

В файле журнала содержится информация об операциях печати и публикации, а именно:

  • Код задания
  • Имя задания
  • Имя подшивки
  • Имя категории
  • Дата и время начала и окончания
  • Имя листа
  • Полный путь к файлу
  • Имя выделенного листа
  • Набор параметров листа
  • Путь к набору параметров листа
  • Имя устройства
  • Имя формата листа
  • Окончательный статус

Вести журнал автоматически

Управление автоматическим сохранением в файле журнала сведений обо всех заданиях вывода на печать и публикации.

Общий файл для всех операций

Сведения обо всех заданиях вывода на печать и публикации автоматически сохраняются в одном файле журнала.

Отдельный файл для каждой операции

Для каждой отдельной операции вывода на печать или публикации создается свой файл журнала.

Общие параметры печати

Управляет параметрами общей среды печати, в том числе сохранением размеров листа, предупреждающими сообщениями системного принтера и выводом на печать объектов OLE чертежа.

Сохранять (если возможно) размеры листа

Размеры листа, заданные в диалоговом окне "Параметры листа", сохраняются, пока это позволяет выбранное устройство вывода на печать. Если выбранное устройство печати не поддерживает эти размеры листа, программа выдает предупреждающее сообщение и использует размеры листа, указанные либо в файле параметров плоттера (PC3), либо в системных настройках по умолчанию, если в качестве устройства вывода используется системный принтер. Включить опцию можно также, присвоив системной переменной PAPERUPDATE значение 0.

Использовать размеры листа из устройства

Использует размеры листа, указанные либо в файле параметров печати (PC3), либо в системных настройках системного принтера в зависимости от того, какое устройство используется. Кроме того, этот параметр можно включить, присвоив системной переменной PAPERUPDATE значение 1.

Предупреждать о буферизации

Выбор способа регистрации ошибок системного принтера, возникших в результате конфликта входного или выходного портов.

  • Всегда (регистрировать все ошибки): При буферизации печати через системный принтер всегда выдаются предупреждения об ошибках и производится их регистрация в журнале.
  • В первый раз (регистрировать все ошибки): При буферизации печати через системный принтер предупреждение об ошибке выдается только первый раз, регистрация ошибок в журнале производится всегда.
  • Никогда (регистрировать первую ошибку): При буферизации печати через системный принтер предупреждения об ошибках не выдаются, в журнале регистрируется только первая ошибка.
  • Никогда (не регистрировать ошибки): При буферизации печати через системный принтер предупреждения об ошибках не выдаются и их регистрация не производится.

Качество печати OLE

Задание качества вывода OLE-объекта на печать. Возможны следующие варианты: "Монохромное", "Простая графика", "Сложная графика" и "Автоматический выбор". Опция "Автоматический выбор" означает, что качество печати подбирается в зависимости от типа OLE-объекта. (системная переменная OLEQUALITY)

Печатать OLE-объекты в OLE-приложениях

При печати чертежа, содержащего OLE-объекты, запускается приложение, в котором они были созданы. Эта опция используется для оптимизации качества вывода на печать OLE-объектов. Настройка хранится в чертеже. (системная переменная OLESTARTUP)

Не показывать системные принтеры

Управление показом системных принтеров Windows в списках диалоговых окон "Печать" и "Параметры листа". Опция действует только на принтеры, настроенные через операционную систему. Используя этот параметр, нельзя скрыть системный принтер Windows, настроенный с помощью Мастера установки плоттеров.

Ограничивать списки устройств печати в диалоговых окнах "Печать" и "Параметры листа" можно и вручную, временно перемещая PC3-файлы неиспользуемых устройств из папки плоттеров и всех вложенных в нее папок.

Отсчет смещения чертежа

Задание отсчета смещения области чертежа от нижнего левого угла области печати или от края листа (системная переменная PLOTOFFSET).

От области печати

Задание отсчета смещения чертежа относительно печатаемой области.

От края листа

Задание отсчета смещения чертежа относительно кромок листа бумаги.

Параметры штемпеля

Открывает диалоговое окно "Штемпель чертежа".

Таблицы стилей печати

Открывает диалоговое окно "Таблицы стилей печати".


Вкладка "Система" (диалоговое окно "Настройка")

Н Команды
Н Команды
Вкладка "Система" (диалоговое окно "Настройка")
Понятия Процедуры Команды

Управляет настройкой системы.

Производительность 3D графики

Управление конфигурацией системы 3D графики.

Параметры производительности 3D графики

Вызов диалогового окна "Адаптивное ухудшение и оптимизация параметров".

Текущее устройство указания

Управление параметрами устройства указания.

Текущее устройство указания

Отображает список доступных драйверов устройств указания.

  • Текущее системное устройство указания: Устанавливает системное устройство указания текущим.
  • Wintab Compatible Digitizer: Установка текущим дигитайзера, совместимого с Wintab.

Источник входных данных

Определяет, откуда программа принимает входные данные: от мыши и дигитайзера или только от дигитайзера.

Регенерация вкладок

Режим обновления списка отображения на вкладке "Модель" и вкладках "Лист". При переходе с одной вкладки на другую это обновление может осуществляться либо путем регенерации чертежа, либо путем сохранения списка отображения в памяти и последующей регенерации только измененных объектов. Изменяя этот режим, можно управлять производительностью работы с чертежами. (системная переменная LAYOUTREGENCTL)

Примечание Эффективность установленного режима регенерации вкладок зависит от различных факторов. Для получения дополнительной информации см. описание системной переменной LAYOUTREGENCTL.

Регенерация при переключении

Чертеж регенерируется каждый раз при переходе на другую вкладку.

Кэширование модели и последнего листа

Для вкладки "Модель" и последнего активного листа список отображения сохраняется в памяти. При переключении между этими двумя вкладками регенерации не происходит. При переходе на какой-либо другой лист его содержимое регенерируется.

Кэширование модели и всех листов

Чертеж регенерируется только при первом заходе на каждую из вкладок. Поскольку списки отображения сохраняются в памяти на протяжении всего рабочего сеанса, последующих регенераций при переходе между вкладками уже не требуется.

Параметры подключения к БД

Управление параметрами подключения к базам данных.

Хранить индекс связей в чертеже

Сохраняет индекс баз данных внутри файла чертежа. Флажок устанавливается в целях оптимизации производительности в процессе операций выбора по связи. Для уменьшения размера чертежа и ускорения процесса открытия чертежей, содержащих информацию из баз данных, флажок следует сбросить.

Открывать таблицы только для чтения

Указывает, требуется ли открывать таблицы баз данных в файле только для чтения.

Общие параметры

Управление параметрами системы.

Однодокументный режим

Позволяет открывать чертежи только по одному. Если снять этот флажок, можно открывать несколько чертежей одновременно. Если обрабатывается несколько чертежей одновременно, то флажок не может быть снят до закрытия всех чертежей, кроме одного. (системная переменная SDI)

Отобразить диалоговое окно размера текста OLE

Отображает диалоговое окно размера текста OLE при вставке объектов OLE в чертежи.

Показывать все предупреждения

Вызов всех диалоговых окон, содержащих флажок "Больше не выводить это предупреждение". Все диалоговые окна с предупреждениями выводятся, независимо от предыдущей настройки параметра для каждого отдельного диалогового окна.

Звуковой сигнал при ошибках

Включает звуковой сигнал при обнаружении ошибочного ввода данных.

Загружать acad.lsp с каждым чертежом

Указывает, требуется ли загружать файл acad.lsp в каждый чертеж. Если флажок не установлен, в чертежи загружается только файл acaddoc.lsp. Чтобы не вызывать LISP-вычислений в определенных чертежах, следует сбросить флажок. (системная переменная ACADLSPASDOC)

Разрешить длинные имена

Разрешение использования длинных имен для именованных объектов в символьных таблицах чертежей. Имя объекта может содержать до 255 символов. В него могут входить буквы, цифры, пробелы и специальные символы, которые не используются Windows и данной программой в других целях. Длинные имена могут быть заданы для слоев, размерных стилей, блоков, типов линий, текстовых стилей, листов, ПСК, видов и видовых экранов. Параметр хранится в чертеже. (системная переменная EXTNAMES)

При запуске

Включает/отключает вывод диалогового окна начала работы при запуске программы или создании нового чертежа.

Адаптеры объектов

Устанавливает в программе режим поиска адаптеров объектов. С помощью адаптеров объектов можно отображать сторонние объекты и работать с ними, даже если приложение ObjectARX, в котором они были созданы, недоступно.

Искать адаптеры в Интернете

Выполняет поиск адаптеров объектов на веб-узле Autodesk.

Макс. число отрицательных проверок

Устанавливает количество попыток для поиска адаптеров объектов.

Подробнее об адаптерах объектов см. раздел Работа со сторонними объектами и заместителями документа "Руководство пользователя".


Вкладка "Пользовательские" (диалоговое окно "Настройка")

Н Команды
Н Команды
Вкладка "Пользовательские" (диалоговое окно "Настройка")
Понятия Процедуры Команды

Задание пользовательских предпочтений для работы с программой.

Соответствие стандартам Windows

Управление событиями, происходящими при нажатии клавиш и щелчке правой кнопкой мыши.

Редактирование двойным нажатием

Определение действия по редактированию, выполняемого при двойном нажатии левой кнопки мыши в области рисования. (системная переменная DBLCLKEDIT)

Контекстные меню в области рисования

Задает режим открытия контекстного меню при щелчке правой кнопкой мыши в области рисования. Если флажок снят, нажатие правой кнопки мыши воспринимается как нажатие клавиши ENTER.

Настройка правой кнопки мыши

Отображает диалоговое окно "Настройка правой кнопки мыши ". В этом диалоговом окне можно задать дополнительные параметры поведения программы по щелчку правой кнопкой мыши. (системная переменная SHORTCUTMENU)

Масштаб вставки

Управляет масштабом по умолчанию при вставке блоков и чертежей.

Единицы исходного чертежа

Устанавливает единицы, используемые при вставке объекта в текущий чертеж, если они не заданы в системной переменной INSUNITS. Если выбрано "Не заданы", масштабирование объекта при вставке не выполняется. (системная переменная INSUNITSDEFSOURCE)

Единицы целевого чертежа

Устанавливает единицы, используемые при вставке объекта в текущий чертеж, если они не заданы в системной переменной INSUNITS. (системная переменная INSUNITSDEFTARGET)

Поля

Задание параметров для полей.

Показывать задний план

Поля отображаются на светло сером фоне, не видимом при выводе на печать. Если флажок не установлен, поля отображаются на том же фоне, как и любой другой текст. (системная переменная FIELDDISPLAY)

Обновление полей

Отображает диалоговое окно "Настройка обновления полей". (системная переменная FIELDEVAL)

Ввод координат

Управляет реакцией программы на ввод координат. (системная переменная OSNAPCOORD)

Согласно привязке

Корректировка введенных с клавиатуры значений координат с учетом текущих режимов объектной привязки. Кроме того, этот параметр можно включить, присвоив системной переменной OSNAPCOORD значение 0.

С клавиатуры

Использование координат, введенных с клавиатуры (без применения к ним объектной привязки). Кроме того, этот параметр можно включить, присвоив системной переменной OSNAPCOORD значение 1.

С клавиатуры (кроме пакетов)

Использование координат, введенных с клавиатуры (без применения к ним объектной привязки) во всех случаях, кроме выполнения пакетных файлов. Кроме того, этот параметр можно включить, присвоив системной переменной OSNAPCOORD значение 2.

Ассоциативные размеры

Определяет, какие размерные объекты создаются ассоциативные или неассоциативные (как в прежних версиях).

Делать новые размеры ассоциативными

При выборе этого параметра, создаются ассоциативные размеры, которые автоматически изменяют свое положение, ориентацию и значения величин при редактировании связанных с ними геометрических объектов. (системная переменная DIMASSOC)

Гиперссылка

Управление свойствами отображения гиперссылок.

Курсор, подсказки и контекстное меню

Отображение курсора и подсказки при наведении курсора устройства указания на объект, содержащий гиперссылоку. Контекстное меню обеспечивает дополнительные функции, вызываемые щелчком правой кнопки мыши в области рисования после того, как выбран объект с гиперссылкой. Если флажок не установлен, то гиперссылки в чертеже игнорируются. (ГИПЕРСВОЙСТВАкоманда)

Отменить/Повторить

Управляет отменой и повтором операции при масштабировании и панорамировании.

Объединить команды масштабирования и панорамирования

Если установлен этот флажок, последовательные команды масштабирования и панорамирования объединяются в одну операцию при отмене или повторе.

Веса линий

Отображает диалоговое окно "Параметры весов линий". Диалоговое окно используется для задания параметров весов линий (свойства, значение по умолчанию, текущий вес линий).

Изменение списка масштабов

Отображает диалоговое окно "Изменение списка масштабов". С помощью этого диалогового окна можно работать со списком масштабов, который отображается в нескольких диалоговых окнах, связанных с видовыми экранами листов и печатью.


Вкладка "Построения" (диалоговое окно "Настройка")

Н Команды
Н Команды
Вкладка "Построения" (диалоговое окно "Настройка")
Понятия Процедуры Команды

Установка режимов для нескольких функций редактирования, включая автопривязку и автоотслеживание.

Параметры автопривязки

Настройка параметров средств визуализации, называемых в совокупности автопривязкой. Параметры автопривязки (AutoSnap™) хранятся в реестре. При наведении курсора или прицела на объект можно последовательно переключаться между всеми доступными точками привязки данного объекта с помощью клавиши TAB.

Маркер

Отображение маркеров автопривязки на экране. Маркер представляет собой геометрический значок, который появляется при перемещении курсора по точкам привязки объекта. (системная переменная AUTOSNAP)

Магнит

Включение и отключение магнита автопривязки. Магнит обеспечивает автоматическое перемещение курсора в ближайшую точку привязки. (системная переменная AUTOSNAP)

Всплывающие подсказки автопривязки

Управление выводом подсказок для автопривязки. Всплывающая подсказка сообщает о том, к какой части объекта осуществляется привязка. (системная переменная AUTOSNAP)

Прицел автопривязки

Управление прицелом автопривязки. Прицел выводится в центре перекрестья при привязке к точке объекта. (системная переменная APBOX)

Цвета

Вызов диалогового окна "Цвета окон чертежа".

Размер маркера автопривязки

Задание размера маркера автопривязки.

Параметры объектной привязки

Задание параметров для объектной привязки. (Команда ПРИВЯЗКА)

Игнорировать штриховку

Задание игнорирования объектной привязкой линий штриховки. (системная переменная OSOPTIONS)

Заменить значение Z на значение текущего уровня

Указывает, что при объектной привязке игнорируется значение Z положения привязки, а используется значение Z уровня в текущей ПСК.

Игнорировать объектные привязки к отрицательной полуоси Z для динамической ПСК

Если выбрана эта опция, геометрия с отрицательными значениями оси Z игнорируется объектными привязками во время использования динамической ПСК. (системная переменная OSOPTIONS)

Параметры автоотслеживания

Управление параметрами автоотслеживания (AutoTrack™). Автоотслеживание активизируется при включении полярного или объектного отслеживания (см. описание команды РЕЖИМЧРТ).

Бесконечные линии полярного отслеживания

При включении полярного отслеживания отображает вектор отслеживания под определенным углом. Полярное отслеживание позволяет рисовать наклонные линии. Полярные углы являются делителями прямого угла, т.е. могут быть равны 45, 30 или 15 градусам.

На 3D виде также отображается параллельный оси Z ПСК вектор полярного отслеживания; подсказка отображает +Z или -Z для угла, в зависимости от направления по оси Z

Для отключения бесконечных линий полярного отслеживания можно присвоить системной переменной TRACKPATH значение 2.

Показывать бесконечный вектор отслеживания

Управление отображением векторов отслеживания. Векторами отслеживания называются вспомогательные линии для построения объектов, повернутых под определенными углами или определенным образом расположенных относительно других объектов. Если установлен этот флажок, линии объектного отслеживания отображаются в виде бесконечных прямых.

Для отключения отображения векторов объектного отслеживания в виде бесконечных линий можно присвоить системной переменной TRACKPATH значение 1.

Всплывающие подсказки автоотслеживания

Управление отображением всплывающих подсказок для режимов "Автоотслеживание" и "Орто". Всплывающие подсказки - это метки, отображающие координаты отслеживания. (системная переменная AUTOSNAP)

Захват точек отслеживания

Управление способом отображения векторов отслеживания на чертеже.

Автоматическое

Векторы отслеживания выводятся автоматически при прохождении прицела через точку привязки.

Нажатием SHIFT

Векторы отслеживания выводятся при нажатии клавиши SHIFT и наведении прицела на точку привязки.

Размер прицела

Задание размера прицела. Прицел автопривязки появляется в перекрестье курсора при выполнении команд построения объектов, если активна опция "Прицел автопривязки" (или если переменная APBOX равна 1). От размера прицела зависит, насколько близко надо подвести курсор к характерной точке объекта, чтобы сработала привязка к ней. Диапазон допустимых значений в пределах от 1 до 50 пикселов. (системная переменная APERTURE)

Внешний вид подсказок на чертеже

Управляет цветом, размером и прозрачностью подсказок на чертеже.

Режимы

Отображает диалоговое окно "Внешний вид подсказок".

Параметры обозначений источников света

Вызов диалогового окна "Вид обозначений источников света".

Параметры обозначений камер

Вызов диалогового окна "Вид обозначения камеры".


Вкладка "3D моделирование" (диалоговое окно "Настройка")

Н Команды
Н Команды
Вкладка "3D моделирование" (диалоговое окно "Настройка")
Понятия Процедуры Команды

Установка режимов для работы с телами и поверхностями в трехмерном пространстве.

3D перекрестье

Управляет настройками стиля отображения указателя-перекрестья в 3D операциях.

Показывать ось Z в перекрестье

Управление отображением оси Z в перекрестье.

Отображать метки осей в стандартном перекрестье

Управление отображением меток осей в перекрестье.

Показывать метки для динамических ПСК

Отображение меток осей на перекрестье для динамических ПСК, даже если метки осей выключены на вкладке "Метки осей" окна "Стандартные перекрестья".

Метки на перекрестье

Позволяет выбрать метки для отображения на перекрестье.

X, Y, Z

Оси обозначаются X, Y и Z соответственно.

N, E, z

Оси обозначаются N (север), E (восток), Z (уровень) соответственно.

Пользовательские

Обозначение осей заданными символами.

Показывать знак ПСК

Управление отображением знака ПСК на экране.

Показывать в 2D пространстве модели

Отображение знака ПСК в пространстве модели, если текущим установлен визуальный стиль "2D каркас".

Показывать в 3D параллельной проекции

Отображение знака ПСК в пространстве модели, если текущим установлен визуальный стиль "3D скрытие", "3D каркас", "Концептуальный" или "Реалистичный", а для стиля проецирования установлен параметр "Параллельно".

Показывать в 3D перспективной проекции

Отображение знака ПСК в пространстве модели, если текущим установлен визуальный стиль "3D скрытие", "3D каркас", "Концептуальный" или "Реалистичный", а для стиля проецирования установлен параметр "Перспектива".

Динамический ввод

Управление отображением полей динамического ввода при задании координат.

Показывать поле координаты Z при динамическом вводе

Отображение поля координаты Z при динамическом вводе.

3D объекты

Управление параметрами отображения 3D тел и поверхностей.

Использовать визуальный стиль при создании 3D объектов

Позволяет задать визуальный стиль при создании элементарного 3D тела. (системная переменная DRAGVS)

Контроль операции удаления при создании 3D объектов

Задание способа удаления определяющей геометрии, которая использовалась в создании тел и поверхностей: автоматически по завершении создания 3D объекта или по запросу. (системная переменная DELOBJ)

Изолинии U на поверхностях и сетях

Установка изолиний U на поверхностях и сетях. (системная переменная SURFU)

Изолинии V на поверхностях и сетях

Установка изолиний V на поверхностях и сетях. (системная переменная SURFV)

3D навигация

Установка режимов обхода, облета и анимации для отображения 3D моделей.

Обратить зумирование колесиком мыши

Обращение направления зумирования колесиком мыши. (системная переменная ZOOMWHEEL)

Параметры обхода и облета

Вызов диалогового окна "Параметры обхода и облета".

Параметры анимации

Вызов диалогового окна "Параметры анимации".


Вкладка "Выбор" (диалоговое окно "Настройка")

Н Команды
Н Команды
Вкладка "Выбор" (диалоговое окно "Настройка")
Понятия Процедуры Команды

На вкладке задаются настройки выбора объектов.

Размер прицела

Управляет размером прицела. Прицел выбора появляется в перекрестье курсора при выполнении команд редактирования объектов. (системная переменная PICKBOX)

Просмотр выбранных объектов

Выделяет объекты при наведении на них прицела. Системная переменная PREVIEWEFFECT определяет внешний вид выделенных объектов.

Когда активна команда

Позволяет предварительный просмотр выбранных объектов, только если команда активна и отображается запрос "Выбрать объекты". (системная переменная SELECTIONPREVIEW)

Если нет активных команд

Отображает выбранные элементы для предварительного просмотра, если ни одна команда не активна. (системная переменная SELECTIONPREVIEW)

Параметры визуальных эффектов

Отображает диалоговое окно "Параметры визуальных эффектов".

Режимы выбора

Управление режимами выбора объектов.

Предварительный выбор

Позволяет выбирать объекты перед вызовом команды. Команда в таком случае работает с объектами текущего набора. (системная переменная PICKFIRST)

В режиме предварительного выбора могут работать следующие команды:

3DALIGN | ДВИД | ОКНОСВ
МАССИВ | УДАЛИТЬ | ПОВЕРНУТЬ
БЛОК | РАСЧЛЕНИТЬ | МАСШТАБ
ИЗМЕНИТЬ | СПИСОК | РАСТЯНУТЬ
CHPROP | ЗЕРКАЛО | ПБЛОК
КОПИРОВАТЬ | ПЕРЕНЕСТИ |

Использование клавиши SHIFT для добавления в набор

Добавление объекта в набор или удаление его из набора посредством выбора объекта с нажатой клавишей SHIFT. Для быстрой очистки набора нужно очертить рамку выбора в не занятой объектами зоне чертежа. (системная переменная PICKADD)

Динамическая рамка

Создает рамку для выбора объектов при выборе точки и перетаскивании устройства указания до второй точки. Если флажок не установлен, для формирования рамки выбора достаточно просто указать две разные точки с помощью устройства указания. (системная переменная PICKDRAG)

Выбор с помощью рамки

Включение режима выбора с помощью рамки при указании точки, не принадлежащей ни одному объекту.

При выделении рамкой слева направо в набор попадают объекты, полностью лежащие в пределах указанной области. При выделении рамкой слева направо в набор попадают как полностью лежащие в пределах указанной области, так и пересекающие эту область объекты. (системная переменная PICKAUTO)

Группа объектов

Выбор всей группы после указания одного объекта, принадлежащего этой группе. Для создания и именования набора объектов используется команда GROUP. Включить опцию можно также, присвоив системной переменной PICKSTYLE значение 1.

Ассоциативная штриховка

Определяет, какие объекты должны выбираться при указании ассоциативной штриховки. Если флажок установлен, при выборе ассоциативной штриховки выбирается также и ее контур. Можно также активизировать этот параметр, присвоив системной переменной PICKSTYLE значение 2.

Размер ручек

Управляет размером ручек. (системная переменная GRIPSIZE)

Ручки

Управление параметрами ручек. Ручками называются маленькие квадратики, появляющиеся на выбранных объектах.

Цвет невыбранных ручек

Задание цвета для невыбранных ручек. При выборе значения "Выбор цвета" в списке цветов отобразится диалоговое окно "Выбор цвета". Невыбранная ручка отображается в виде маленького закрашенного квадратика. (системная переменная GRIPCOLOR)

Цвет выбранных ручек

Задание цвета для выбранных ручек. При выборе значения "Выбор цвета" в списке цветов отобразится диалоговое окно "Выбор цвета". Выбранная ручка отображается в виде маленького закрашенного квадратика. (системная переменная GRIPHOT)

Цвет ручки под курсором

Задание цвета для ручек при перемещении курсора над ними. При выборе значения "Выбор цвета" в списке цветов отобразится диалоговое окно "Выбор цвета". (системная переменная GRIPHOVER)

Включить ручки

Отображение ручек на выбранных объектах. Для редактирования выбранного объекта с помощью ручек можно использовать специальное контекстное меню. Отображение ручек существенно влияет на производительность. В целях оптимизации производительности флажок не устанавливается. (системная переменная GRIPS)

Ручки внутри блоков

Управление способом показа ручек на выбранных объектах. Если этот флажок установлен, отобразятся все ручки для всех объектов, входящих в блок. Если флажок не установлен, отображается только одна ручка в точке вставки блока. Для редактирования выбранного объекта с помощью ручек можно использовать специальное контекстное меню. (системная переменная GRIPBLOCK)

Подсказки к ручкам

Вывод подсказки при наведении курсора на ручку пользовательского объекта, поддерживающего подсказки к ручкам. Этот параметр не работает для стандартных объектов. (системная переменная GRIPTIPS)

Предельное количество выбранных объектов для показа ручек

Подавление ручек в случае, если исходный набор содержит больше объектов, чем задано. Допустимый диапазон значений от 1 до 32767. По умолчанию устанавливается 100. (системная переменная GRIPOBJLIMIT)


Вкладка "Профили" (диалоговое окно "Настройка")

Н Команды
Н Команды
Вкладка "Профили" (диалоговое окно "Настройка")
Понятия Процедуры Команды

Управление использованием профилей. Профиль — это набор пользовательских настроек.

Имеющиеся профили

Список доступных профилей. Для установки профиля текущим следует выбрать его в списке и нажать кнопку "Установить".

Установить

Устанавливает выбранный в списке профиль текущим.

Добавить

Отображает диалоговое окно "Добавление профиля" для сохранения выбранного профиля под другим именем.

Переименовать

Отображает диалоговое окно "Переименование профиля", где можно изменить имя и описание имеющегося профиля. Данную функцию следует использовать при необходимости изменить имя и описание профиля, оставив без изменения текущие установки.

Удалить

Удаление выбранного профиля (если он не является текущим).

Экспорт

Экспорт профиля с расширением .arg для совместного использования с другими пользователями. Импортировать полученный файл можно на любом компьютере.

Импорт

Импорт профиля (файла с расширением .arg), созданного функцией экспорта.

Сброс

Изменяет установки выбранного в списке профиля на стандартные.


Диалоговое окно "Альтернативный шрифт"

Н Команды
Н Команды
Диалоговое окно "Альтернативный шрифт"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Файлы" диалогового окна "Настройка")

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Задает путь доступа к файлу шрифта, который следует использовать, если невозможно обнаружить исходный шрифт, а альтернативный шрифт не определен в файле соответствий шрифтов. Расположение файла альтернативного шрифта можно также задать с помощью системной переменной FONTALT.

Если альтернативный шрифт не задан в диалоговом окне "Настройка" или с помощью системной переменной FONTALT, при открытии чертежей, содержащих шрифты, местонахождение которых установить не удалось, открывается диалоговое окно, в котором можно задать замену для всех отсутствующих шрифтов.

Имя шрифта

Выводит список имен всех зарегистрированных шрифтов TrueType и шрифтов SHX папки Fonts. При выборе имени из списка программа читает файл соответствующего шрифта.

Начертание

Начертание символов шрифта (курсив, полужирный или обычный). Если отсутствует большой шрифт, список получает название "Большой шрифт", и выводит имена всех имеющихся файлов больших шрифтов для азиатских языков.


Диалоговое окно "Цвета окон чертежа"

Н Команды
Н Команды
Диалоговое окно "Цвета окон чертежа"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Экран" диалогового окна "Настройка")

Контекстное меню: Нажмите правую кнопку мыши в окне команд или (если нет выполняющихся команд и выбранных объектов) нажмите правую кнопку мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Установка цветов отображения элементов интерфейса для каждого контекста в приложении. Под контекстом здесь подразумевается рабочая среда, например, пространство модели. Под элементами интерфейса подразумеваются элементы, такие как перекрестье или цвет фона, видимые в отдельном контексте.

Контекст

Вывод списка всех контекстов в программе. Под контекстом здесь подразумевается рабочая среда, например, пространство модели. Элементам интерфейса могут назначаться разные цвета в зависимости от контекста. Например, цвет фона может быть разным в пространстве модели и пространстве листа. Выберите контекст в списке "Контексты" и элемент интерфейса в списке "Элементы интерфейса", а затем выберите цвет в списке "Цвет". Цвет заголовка окна и строки меню задаются системными настройками Windows.

Элемент интерфейса

Вывод списка всех элементов интерфейса в выбранном контексте. Под элементами интерфейса подразумеваются элементы, видимые в отдельном контексте (например, цвет фона). Выберите контекст в списке "Контексты" и элемент интерфейса в списке "Элементы интерфейса", а затем выберите цвет в списке "Цвет". Цвет заголовка окна и строки меню задаются системными настройками Windows.

Цвет

Вывод списка доступных параметров цветов для применения к выбранному элементу интерфейса. Можно задать любой из цветов, перечисленных в списке, или выбрать элемент "Выбор цвета" для вызова диалогового окна "Выбор цвета".

В диалоговом окне "Выбор цвета" можно выбрать цвет для элементов интерфейса из числа 255 цветов, входящих в Индекс цветов AutoCAD (ИЦА), а также из полной палитры или из альбома цветов.

Если для элемента интерфейса выбран новый цвет, новая настройка отображается в области предварительного просмотра.

Оттенок для X, Y и Z

Позволяет применить цветовые оттенки по осям X, Y и Z для следующих элементов интерфейса: перекрестья, векторы автоотслеживания, линии сетки нулевой плоскости и всплывающие подсказки. Для получения цветовых оттенков применяется чистый красный, синий и зеленый цвета с использованием яркости цвета, заданного пользователем, при увеличении насыщенности цвета на 50%.

Восстановить текущий элемент

Восстановление цвета по умолчанию для выбранного элемента интерфейса.

Восстановить текущий контекст

Восстановление цветов по умолчанию для всех элементов интерфейса выбранного контекста.

Восстановить все контексты

Восстановление цветов по умолчанию для всех элементов интерфейса.


Диалоговое окно "Шрифт командной строки"

Н Команды
Н Команды
Диалоговое окно "Шрифт командной строки"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Экран" диалогового окна "Настройка")

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Задание шрифта, используемого для сообщений командной строки. Шрифт экранного меню задается системными настройками шрифтов Windows. При использовании экранного меню системные настройки шрифтов Windows должны соответствовать размерам экранного меню.

Шрифт

Список имеющихся системных шрифтов.

Начертание

Список имеющихся начертаний для текущего шрифта.

Размер

Список имеющихся размеров для текущего шрифта.


Диалоговое окно "Вид обозначений источников света"

Н Команды
Н Команды
Диалоговое окно "Вид обозначений источников света"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Рисование" диалогового окна "Настройка")

Задание внешнего вида обозначений источников света.

Образец обозначения

Отображение текущего внешнего вида обозначения; вид обновляется по мере внесения изменений.

Точка

Отображение образца обозначения точечного источника света.

Прожектор

Отображение образца обозначения прожектора

Изменить цвета обозначения

Вызов диалогового окна "Цвета окон чертежа".

Размер обозначения

Настройка размера обозначения.


Диалоговое окно "Вид обозначения камеры"

Н Команды
Н Команды
Диалоговое окно "Вид обозначения камеры"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Рисование" диалогового окна "Настройка")

Задание внешнего вида обозначений камер.

Образец обозначения

Отображение текущего внешнего вида обозначения; вид обновляется по мере внесения изменений.

Изменить цвета обозначения

Вызов диалогового окна "Цвета окон чертежа".

Размер обозначения

Изменение размера обозначения в области рисования.


Диалоговое окно "Образец для просмотра"

Н Команды
Н Команды
Диалоговое окно "Образец для просмотра"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Открытие/Сохранение" диалогового окна "Настройка")

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Управление обновлением образца для просмотра при сохранении чертежа.

Создавать образец для просмотра

Включение/отключение сохранения в чертеже изображения для предварительного просмотра. С помощью данного изображения можно ознакомиться с содержимым чертежа в диалоговом окне "Выбор файла" еще до загрузки чертежа. (системная переменная RASTERPREVIEW)

Создавать образцы листов и видов листа/модели

Обновление образцов для просмотра в "Диспетчере подшивок". В операции участвуют образцы на вкладке "Список листов", образцы видов на листах на вкладке "Список видов", а также образцы видов пространства модели на вкладке "Чертежи с ресурсами". (системная переменная UPDATETHUMBNAIL)

Производительность-Точность (скользящая шкала)

Задание значения системной переменной UPDATETHUMBNAIL, которая определяет, когда и какие образцы для просмотра обновляются. Положение указателя на шкале в момент открытия диалогового окна указывает на текущее значение переменной UPDATETHUMBNAIL.

Окно информации

Вывод пояснений для текущего положения указателя на скользящей шкале.


Диалоговое окно "Таблицы стилей печати"

Н Команды
Н Команды
Диалоговое окно "Таблицы стилей печати"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Печать/Публикация" диалогового окна "Настройка")

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Задание настроек для таблиц стилей печати.

Стили печати по умолчанию для новых чертежей

Управление параметрами стилей печати. Стиль печати — это набор свойств объектов, назначаемых им при печати и сохраняемых в таблицах стилей. Изменение стиля печати, используемого по умолчанию, в окне "Настройка" не влияет на текущий чертеж. Он применяется только к новым чертежам или чертежам, созданным в предыдущих версиях AutoCAD, которые не сохранялись в формате AutoCAD 2000 или более поздней версии.

По умолчанию переключатель стилей печати установлен в положение "Цветозависимые стили печати". Таким образом, настройка стилей печати на панели "Свойства" по умолчанию недоступна. Активизировать настройку можно, установив переключатель в положение "Именованные стили печати" и открыв новый чертеж. (системная переменная PSTYLEPOLICY)

Цветозависимые стили печати

Применяет цветозависимые стили печати как в новых чертежах, так и в чертежах, созданных в AutoCAD Release 14 или более ранних версиях. При использовании цветозависимых стилей печати для создания таблицы стилей печати с файловым расширением .ctb применяются индексы цветов AutoCAD. Задание цвета производится по имени или с помощью числа в диапазоне от 1 до 255. Каждому из цветов можно поставить в соответствие свое перо на перьевом плоттере. Использование различных цветов облегчает идентификацию объектов на чертеже. Опция создает свой стиль печати для каждого цвета. Также для выбора этого параметра можно присвоить системной переменной PSTYLEPOLICY значение 1.

Настройка хранится в чертеже. Чертежи, сохраненные с цветозависимыми стилями печати, можно перестроить на использование именованных стилей печати командами ПРЕОБРТСП и ПРЕОБРСПЕЧ.

Именованные стили печати

Использует именованные стили печати как в новых чертежах, так и в чертежах, созданных в более ранних версиях AutoCAD. Чертеж выводится на печать в соответствии с установленным для него стилем печати. Стиль печати задается в таблице, назначенной листу. Таблицы именованных стилей печати хранятся в файлах с расширением .stb. Также для выбора этого параметра можно присвоить системной переменной PSTYLEPOLICY значение 0.

Настройка хранится в чертеже. Чертежи, сохраненные с именованными стилями печати по умолчанию, можно перестроить на использование цветозависимых стилей печати командами ПРЕОБРТСП и ПРЕОБРСПЕЧ. При этом следует помнить, что после преобразования именованных стилей печати в цветозависимые командой ПРЕОБРСПЕЧ обратное преобразование невозможно.

Настройка текущей таблицы стилей печати

Задание параметров текущей таблицы стилей печати для применения в новых чертежах.

Таблица стилей печати по умолчанию

Задание таблицы стилей печати по умолчанию для присвоения новым чертежам. Таблица стилей печати представляет собой файл с расширением .ctb или .stb, описывающий стили печати. При использовании цветозависимых стилей печати в списке перечисляются все найденные по заданному пути таблицы цветозависимых стилей печати, включая "Нет". При использовании именованных стилей печати в списке выводятся имена всех таблиц именованных стилей печати.

Стиль печати по умолчанию для слоя 0

Задает стиль печати по умолчанию для слоя 0 новых чертежей, а также чертежей, которые были созданы в прежних версиях AutoCAD, но не сохранялись в формате AutoCAD 2000 или более поздней версии. В списке, помимо стиля "Обычный", перечислены в алфавитном порядке все стили печати, описанные в текущей загруженной таблице стилей печати. (системная переменная DEFLPLSTYLE)

Стиль печати по умолчанию для объектов

Задание стиля печати по умолчанию, назначаемого при создании новых объектов. В списке, кроме стилей ПОСЛОЮ, ПОБЛОКУ и "Обычный", перечислены все стили печати, описанные в загруженной на данный момент таблице стилей печати. (системная переменная DEFPLSTYLE)

Таблицы стилей печати

Отображает Диспетчера стилей печати (окно проводника Windows), который позволяет создавать и редактировать таблицы стилей печати.


Диалоговое окно "Настройка правой кнопки мыши "

Н Команды
Н Команды
Диалоговое окно "Настройка правой кнопки мыши "
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Пользовательские" диалогового окна "Настройка")

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Управление событиями, происходящими при нажатии правой кнопки мыши: вызов контекстного меню или имитация нажатия ENTER. Это диалоговое окно можно использовать для задания имитации нажатия клавиши ENTER при нажатии правой кнопки мыши (при этом контекстные меню для удобства может потребоваться отключить). Для управления вызовом контекстных меню используется также системная переменная SHORTCUTMENU.

Учитывать длительность нажатия

Управление событиями, происходящими при щелчке правой кнопкой мыши. Кратковременное нажатие правой кнопкой мыши эквивалентно нажатию клавиши ENTER. Более продолжительное нажатие кнопки вызывает контекстное меню. Имеется возможность задания продолжительности долгого нажатия в миллисекундах.

Обычный режим

Здесь можно задать событие, происходящее по щелчку правой кнопки мыши в области рисования в обычном режиме, когда нет выбранных объектов и выполняющихся команд.

Повтор последней команды

Отключение стандартного контекстного меню. Таким образом, нажатие правой кнопки мыши в области рисования при отсутствии выбранных объектов и выполняющихся команд имитирует нажатие клавиши ENTER, т. е. служит для повторного выполнения последней команды.

Контекстное меню

Включение стандартного контекстного меню.

Режим редактирования

Здесь можно задать событие, происходящее по щелчку правой кнопки мыши в области рисования в режиме редактирования, т.е. если выбраны один или несколько объектов, но нет выполняющихся команд.

Повтор последней команды

Отключение контекстного меню редактирования. Таким образом, нажатие правой кнопки мыши в области рисования, если выбран один или несколько объектов, при отсутствии выполняющихся команд имитирует нажатие клавиши ENTER, т. е. служит для повторного выполнения последней команды.

Контекстное меню

Включение контекстного меню редактирования.

Командный режим

Здесь можно задать событие, происходящее по щелчку правой кнопки мыши в области рисования в командном режиме, т.е. в ходе выполнения какой-либо команды.

ENTER

Отключение контекстного меню команд. Таким образом, нажатие правой кнопки мыши в области рисования в ходе выполнения команды имитирует нажатие клавиши ENTER.

Контекстное меню: Всегда доступно

Включение контекстного меню команд.

Контекстное меню: Доступно, если команда имеет опции

Позволяет вызывать контекстное меню команд только в том случае, если в текущий момент в командной строке доступны какие-либо опции. В командной строке опции команд заключаются в квадратные скобки. Если в командной строке отсутствуют опции, нажатие правой кнопки мыши соответствует нажатию клавиши ENTER.


Диалоговое окно "Настройка обновления полей"

Н Команды
Н Команды
Диалоговое окно "Настройка обновления полей"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Пользовательские" диалогового окна "Настройка")

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Управляет методом обновления полей. (системная переменная FIELDEVAL)

Открыть

Автоматическое обновление полей при открытии файла.

Сохранить

Автоматическое обновление полей при сохранении файла.

Печать

Автоматическое обновление полей при печати файла.

Сформировать комплект

Автоматическое обновление полей при пересылке файла с помощью команды ФОРМКОМПЛЕКТ.

Реген

Автоматическое обновление полей при регенерации файла.


Диалоговое окно "Параметры визуальных эффектов"

Н Команды
Н Команды
Диалоговое окно "Параметры визуальных эффектов"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Выбор" диалогового окна "Настройка")

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Определяет внешний вид изображения для предварительного выбора.

Выбор эффекта просмотра

Определяет внешний вид объектов при предварительном выборе. (системная переменная PREVIEWEFFECT)

Область просмотра

Отображает результат применения текущих параметров.

Пунктиром

Отображает пунктирные линии при наведении прицела на объект. В этом случае предварительный выбор означает, что объект был бы выбран при щелчке на нем. По умолчанию выбранные объекты отображаются пунктирными линиями. (системная переменная PREVIEWEFFECT)

Придать толщину

Отображает утолщенные линии при наведении курсора на объект. Такое предварительное утолщение означает, что объект может быть выбран при щелчке на нем. (системная переменная PREVIEWEFFECT)

Оба

Отображает утолщенные пунктирные линии при наведении прицела на объект. Такое предварительное утолщение означает, что объект может быть выбран при щелчке на нем. (системная переменная PREVIEWEFFECT)

Дополнительные опции

Отображаетдиалоговое окно "Дополнительные опции просмотра".

Эффект выбранной области

Определяет внешний вид областей при предварительном выборе.

Область просмотра

Отображает результат применения текущих параметров.

Указать область

При выборе рамкой или зачеркивании отмечает область выбора другим фоновым цветом. (системная переменная SELECTIONAREA)

Цвет рамки выбора

Определяет фон для областей, выбранных с помощью рамки. (системная переменная WINDOWAREACOLOR)

Цвет секущей рамки выбора

Определяет фон областей, выбранных с помощью зачеркивания. (системная переменная CROSSINGAREACOLOR)

Затенение области выбора

Управление прозрачностью фона для выбранных с помощью рамки областей. (системная переменная SELECTIONAREAOPACITY)


Диалоговое окно "Дополнительные опции просмотра"

Н Команды
Н Команды
Диалоговое окно "Дополнительные опции просмотра"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Выбор" диалогового окна "Настройка")

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Исключает объекты из области предварительного выбора. (системная переменная PREVIEWFILTER)

Исключить объекты на заблокированных слоях

Не отображает обозначения предварительного выбора для объектов на заблокированных слоях. Данная опция используется по умолчанию. (системная переменная PREVIEWFILTER)

Исключить

Отключает предварительный выбор для определенных типов объектов. (системная переменная PREVIEWFILTER)

Внешние ссылки

Исключает объекты внешних ссылок из области предварительного выбора. Данная опция используется по умолчанию. (системная переменная PREVIEWFILTER)

Таблицы

Исключает таблицы из области предварительного выбора. Данная опция используется по умолчанию. (системная переменная PREVIEWFILTER)

Группы

Исключает объекты в группах из области предварительного выбора. По умолчанию этот параметр отключен. (системная переменная PREVIEWFILTER)

Многострочные тексты

Исключает объекты многострочного текста из области предварительного выбора. По умолчанию этот параметр отключен. (системная переменная PREVIEWFILTER)

Штриховки

Исключает заштрихованные объекты из области предварительного выбора. По умолчанию этот параметр отключен. (системная переменная PREVIEWFILTER)


Диалоговое окно "Добавление профиля"

Н Команды
Н Команды
Диалоговое окно "Добавление профиля"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Профили" диалогового окна "Настройка")

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Создание нового профиля на основе имеющегося. Новый профиль появляется в списке "Имеющиеся профили" на вкладке "Профили" диалогового окна "Настройка".

Имя профиля

Назначает для выбранного профиля новое имя.

Описание

Присваивает выбранному профилю новое или обновленное описание.


Диалоговое окно "Переименование профиля"

Н Команды
Н Команды
Диалоговое окно "Переименование профиля"
Понятия Процедуры Команды

Меню "Сервис": "Настройка" (вкладка "Профили" диалогового окна "Настройка")

Контекстное меню: Нажмите правой кнопкой мыши в окне команд или (убедитесь, что нет выполняющихся команд и выбранных объектов) нажмите правой кнопкой мыши в области чертежа и выберите "Настройка".

Ввод команды: настройка

Переименование имеющегося профиля. Новое имя профиля появляется в списке "Имеющиеся профили" на вкладке "Профили" диалогового окна "Настройка".

Имя профиля

Назначает для выбранного профиля новое имя.

Описание

Присваивает выбранному профилю новое или обновленное описание.


Диалоговое окно "Прозрачность"

Н Команды
Н Команды
Диалоговое окно "Прозрачность"
Понятия Процедуры Команды

Контекстное меню: Нажмите правой кнопкой мыши на строке заголовка закрепляемого окна и выберите "Прозрачность".

Управляет прозрачностью закрепляемых окон.

Меньше/Больше

Степень прозрачности окна. Если ползунок установлен в положение "Меньше", окно полностью непрозрачно. Если же ползунок установлен в положение "Больше", окно имеет максимальную прозрачность.

Отключить прозрачность для окна

При выборе этой опции все прозрачные окна становятся непрозрачными. Настройка прозрачности для каждого окна остается неизменной. (системная переменная PALETTEOPAQUE).


НЕТКОМ Команда

Н Команды
Н Команды
НЕТКОМ Команда
Понятия Процедуры Команды

Замена внутренней команды другой командой, определенной в приложении

Ввод команды: нетком

Имя команды:

Ввод имени команды для ее подавления. После этого можно определить новую команду, которая будет иметь имя подавленной команды, но выполнять другую функцию.

Подавлять можно только встроенные команды AutoCAD. Нельзя подавлять команды, созданные в приложении AutoLISP®. То же справедливо для команд приложения ObjectARX™, зарегистрированных с помощью acedDefun(). Кроме того, не допускается подавление внешних команд и псевдоимен, заданных в файле acad.pgp.

Если имя команды, созданной в приложении AutoLISP или ObjectARX, совпадает с именем одной из внутренних команд AutoCAD, активной является команда приложения.

Имя подавленной команды может быть восстановлено с помощью команды ДАКОМ.

Подавленную команду всегда можно выполнить, набрав перед ее именем точку (.).

Для выполнения команд приложения ObjectARX, зарегистрированных с помощью acedRegCmd, перед их именами нужно вводить точку (.), имя группы команды, а затем еще одну точку (.) . Например, обращение к команде МТЕКСТ выглядит так: .acad_mtext.mtext.

Чтобы определить имена команд и групп, созданных в приложении ObjectARX, следует вызвать команду ARX и выбрать опцию "Команды". Появится список всех загруженных в настоящий момент команд ObjectARX вместе с именами групп.


НЛНАСТР Команда

Н Команды
Н Команды
НЛНАСТР Команда
Понятия Процедуры Команды

Изменение отображения свойств линий в 2D каркасах

Ввод команды: нлнастр

Диспетчер визуальных стилей отображается для параметров 2D каркаса.


НОВОЕИМЯ Команда

Н Команды
Н Команды
НОВОЕИМЯ Команда
Понятия Процедуры Команды

Изменяет имена именованных объектов

Меню "Формат": "Переименовать"

Ввод команды: новоеимя

Откроется диалоговое окно "Задание нового имени".

Если в ответ на запрос "Команда:" ввести -новоеимя, вызывается вариант команды НОВОЕИМЯ, использующий интерфейс командной строки.

Темы:

  • Диалоговое окно «Задание нового имени»
  • НОВОЕИМЯ вариант для командной строки


Диалоговое окно «Задание нового имени»

Н Команды
Н Команды
Диалоговое окно «Задание нового имени»
Понятия Процедуры Команды

Меню "Формат": "Переименовать"

Ввод команды: новоеимя

Переименование именованных объектов.

Типы объектов

Выводится список именованных объектов чертежа по категориям Следует выбрать категорию объектов, подлежащих переименованию.

Имена

Список именованных объектов, соответствующих выбранной в списке «Типы объектов» категории объектов. Следует выбрать имя, которое требуется изменить.

Старое имя

Текущее имя выбранного объекта. Имя можно выбрать из списка или ввести с клавиатуры. Для переименования групп объектов можно использовать глобальные символы * и ?. Не разрешается переименовывать некоторые из стандартных объектов (например, слой 0 и тип линий CONTINUOUS).

Новое имя

Новое имя, присваиваемое объекту. Имя нужно ввести в текстовое поле и нажать кнопку «Новое имя».


НОВОЕИМЯ вариант для командной строки

Н Команды
Н Команды
НОВОЕИМЯ вариант для командной строки
Понятия Процедуры Команды

Если в ответ на запрос "Команда:" ввести -новоеимя, вызывается вариант команды НОВОЕИМЯ, использующий интерфейс командной строки.

Тип объекта для переименования [Блок/Рзмстиль/СЛой/типЛиний/ПСТиль/СТиль/Тблстиль/ПСК/ВИд/ВЭкран]: Задать тип именованного объекта для переименования

Старое имя элемента: Ввести текущее имя

Новое имя элемента: Ввести новое имя


НОРМОКОНТРОЛЬ Команда

Н Команды
Н Команды
НОРМОКОНТРОЛЬ Команда
Понятия Процедуры Команды

Проверка текущего чертежа на соответствие установленным стандартам оформления

Панель "Стандарты оформления":

Меню "Инструменты": "Стандарты оформления" » подменю "Установить"

Ввод команды: нормоконтроль

Отобразится диалоговое окно "Нормоконтроль".

Темы:

  • Диалоговое окно "Нормоконтроль"


Диалоговое окно "Нормоконтроль"

Н Команды
Н Команды
Диалоговое окно "Нормоконтроль"
Понятия Процедуры Команды

Панель "Стандарты оформления":

Меню "Инструменты": "Стандарты оформления" » подменю "Установить"

Ввод команды: нормоконтроль

Анализ текущего чертежа на нарушения стандартов.

Нарушение

Запись о не соответствующих стандартам объектах в текущем чертеже. Для устранения проблемы выбрать замену в списке "Заменить на" и затем нажать "Исправить".

Чем заменить

Список возможных исправлений для текущего несоответствия стандартам. Наиболее предпочтительная замена (если она существует) помечается особым образом. Если предпочтительных замен нет, то в списке "Заменить на" ничего не выделяется.

Просмотр изменений

Указывает свойства нестандартного объекта, которые будут изменяться при выборе текущего замещения из списка "Заменить на".

Исправить

Исправляет нестандартный объект с использованием элемента из списка "Заменить на". Выбор перемещается на другой нестандартный объект в текущем чертеже. Кнопка недоступна, если нет рекомендуемой замены или выделенных пунктов в списке "Заменить на".

Далее

Перемещение к следующему нестандартному объекту в текущем чертеже без исправления предыдущего.

Игнорировать нарушение в дальнейшем

Пометка текущей проблемы как игнорируемой. Если опция "Показывать проигнорированные нарушения" диалогового окна "Параметры нормоконтроля" не установлена, при следующей проверке чертежа ошибки, помеченные как игнорируемые, не отображаются.

Режимы

Отображает диалоговое окно "Параметры нормоконтроля", в котором задаются дополнительные параметры для диалоговых окон "Нормоконтроль" и "Настройка стандартов".

Закрыть

Закрытие диалогового окна "Нормоконтроль" без исправления несоответствий, показанных в поле "Нарушение".


НПИ Команда

Н Команды
Н Команды
НПИ Команда
Понятия Процедуры Команды

Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.

Меню "Инструменты": подменю "Адаптация" » "Интерфейс"

Ввод команды: нпи

Открывается диалоговое окно "Диалоговое окно "Настройка интерфейса пользователя"".

Примечание Файл НПИ (CUI) на основе XML заменяет традиционные файлы меню (MNS) шаблонов меню (MNU), использованные в предыдущих версиях.

Информацию о настройке различных элементов интерфейса пользователя, представленных в диалоговом окне "Настройка интерфейса пользователя", см. раздел Настройка интерфейса пользователя Руководства по настройке.

Темы:

  • Диалоговое окно "Настройка интерфейса пользователя"
  • Вкладка "Передача" (диалоговое окно "Настройка интерфейса пользователя")
  • Вкладка "Адаптация" (диалоговое окно "Настройка интерфейса пользователя")
  • Диалоговое окно "Редактор кнопок"
  • Диалоговое окно "Фильтры отображения"
  • Диалоговое окно "Поиск и замена"
  • Вкладка "Найти" (диалоговое окно "Поиск и замена")
  • Вкладка "Заменить" (диалоговое окно "Поиск и замена")


Диалоговое окно "Настройка интерфейса пользователя"

Н Команды
Н Команды
Диалоговое окно "Настройка интерфейса пользователя"
Понятия Процедуры Команды

Меню "Инструменты": подменю "Адаптация" » "Интерфейс"

Ввод команды: нпи

Управляет настраиваемыми элементами интерфейса пользователя, такими как рабочее пространство, панель инструментов, меню, контекстное меню и сочетание клавиш.

Отобразится диалоговое окно "Настройка интерфейса пользователя":

  • Вкладка "Передача" (диалоговое окно "Настройка интерфейса пользователя")
  • Вкладка "Адаптация" (диалоговое окно "Настройка интерфейса пользователя")

Информацию о настройке различных элементов интерфейса пользователя, представленных в диалоговом окне "Настройка интерфейса пользователя", см. раздел Настройка интерфейса пользователя Руководства по настройке.

Темы:

  • Вкладка "Передача" (диалоговое окно "Настройка интерфейса пользователя")
  • Вкладка "Адаптация" (диалоговое окно "Настройка интерфейса пользователя")


Вкладка "Передача" (диалоговое окно "Настройка интерфейса пользователя")

Н Команды
Н Команды
Вкладка "Передача" (диалоговое окно "Настройка интерфейса пользователя")
Понятия Процедуры Команды

Передает элементы интерфейса пользователя в основной или файл частичной адаптации (НПИ), в котором хранятся данные элементов интерфейса пользователя, и наоборот. Для импорта или экспорта данных интерфейса пользователя необходимо открыть файл НПИ, MNS или MNU. При открытии файла MNU или MNS они автоматически преобразуются в формат НПИ. Исходные файлы MNU или MNS не изменяются.

Адаптации в панелях

При вводе в командной строке нпиимпорт на правой панели отображается основной файл CUI (по умолчанию acad.cui). Для передачи данных необходимо открыть файл НПИ или MNU в левой панели. При вводе в командной строке нпиэкспорт в левой панели отображается основной файл НПИ. Для передачи данных необходимо открыть еще одни файл НПИ или MNU на правой панели.


Вкладка "Адаптация" (диалоговое окно "Настройка интерфейса пользователя")

Н Команды
Н Команды
Вкладка "Адаптация" (диалоговое окно "Настройка интерфейса пользователя")
Понятия Процедуры Команды

Отображает интерфейс для настройки рабочих пространств, панелей инструментов, меню, контекстных меню и других элементов интерфейса.

Примечание При выводе на экран диалогового окна "Настройка интерфейса пользователя" с помощью опции "Команды настройки" в Окне инструментальных палитр окно "Адаптации в панели" сворачивается, и раскрывается окно "Список команд"

Адаптации в панели

Отображает дерево настраиваемых элементов интерфейса пользователя, таких как рабочие пространства, панели инструментов, меню, частичные файлы НПИ и т.д.

Окно "Список"

Отображает список загруженных файлов НПИ и параметр "Открыть".

Панель инструментов "Существующие адаптации"

Содержит кнопки "Открыть", "Сохранить" и "Фильтры отображения".

Открыть

Загружает файл CUI, который можно добавить к файлу acad.cui.

Сохранить

Сохраняет изменения во всех отображаемых файлах НПИ.

Фильтры отображения

Открывает диалоговое окно "Фильтры отображения", в котором можно указать, будут отображаться элементы интерфейса пользователя в области структуры или нет.

Область структуры

Выводит список файлов НПИ, выбранных в поле "Список", и отображает элементы интерфейса, выбранные в диалоговом окне "Фильтры отображения".

Панель "Динамическое отображение"

Отображает содержимое, относящееся к элементу интерфейса пользователя, выбранного в области структуры в левой панели. Далее приведены типы содержимого, отображаемого на правой панели, и соответствующая информация, отображаемая в области структуры на левой панели.

Информация

Описывает выбранные элементы интерфейса пользователя, у которых нет свойств (например, узел "Панели", узел "Меню" и узел "Контекстные меню").

Свойства

Отображает свойства элементов интерфейса пользователя или элементы, выбранные в области структуры. Элементы с отображаемыми свойствами включают в себя отдельные меню, команды меню, панели инструментов и кнопки панелей инструментов.

Изображение кнопки

Отображает кнопки всех загруженных в программе панелей инструментов. Можно изменить кнопку панели инструментов и ее свойства, а также создать новую кнопку.

Ярлыки

Отображает список имен сочетаний клавиш и клавиш временной замены, соответствующие им сочетания клавиш, тип сочетания клавиш (сочетание клавиш или клавиши временной замены), а также имя исходного файла НПИ.

Панель "Список команд"

Отображает список загруженных в программе команд.

Категории

Отображает фильтры для списка команд, включая "Все команды", "Команды ACAD", "Пользовательская" или "Команды управления". Можно также применить к списку фильтры для отображения команд в пределах отдельного меню.

Новый

Создает новую команду. Можно добавить и изменить свойства, а также создать или изменить кнопку.

Панель "Свойства"

Отображает свойства пользовательского интерфейса, которые можно просматривать, изменять и удалять.

Общие

Отображает имя и описание элемента интерфейса пользователя. Вводимое имя - это название, отображающееся в программе. Вводимое описание отображается в строке состояния. Для рабочих пространств определяет параметры отображения вкладок листа и модели ("Вкл" или "Откл"), экранного меню ("Вкл" или "Откл") и строки прокрутки ("Вкл" или "Откл"). Для меню мозаики изображений определяет наличие или отсутствие пустой строки ("Да" или "Нет"), а также задает имя библиотеки слайдов и слайда.

Формат

Для панелей инструментов определяет параметры отображения по умолчанию ("Скрыть" или "Показать"), ориентацию панели инструментов ("Плавающая", "Сверху", "Снизу", "Слева", "Справа"), а также количество рядов в панели инструментов. Определяет начальную строку экранных меню.

Макрос

Отображает макрос, назначенный для команд панели инструментов, команд меню, кнопок мыши и меню мозаики изображений. Можно создать новый макрос или изменить существующий.

Дополнительные

Отображает строки DIESEL, псевдонимы, совместимость версий и идентификаторы элементов, которые можно задать для каждого элемента интерфейса пользователя.

Изображения

Для команд панели инструментов, команд меню, кнопок мыши и меню мозаики изображений отображает малое изображение и большое окно, в котором можно определить образ ресурса изображения ("Да" или "Нет") и имя (при поиске пользовательских изображений).


Диалоговое окно "Редактор кнопок"

Н Команды
Н Команды
Диалоговое окно "Редактор кнопок"
Понятия Процедуры Команды

Меню "Инструменты": подменю "Адаптация" » "Интерфейс"

"Контекстное меню": нажать правую кнопку мыши на любой панели и выбрать "Адаптация".

Ввод команды: нпи

Служит для создания и модификации кнопок.

Изображение кнопки

Показывает кнопку в реальном масштабе.

Средства редактирования

Инструменты, предназначенные для редактирования пиктограммы кнопки.

Карандаш

Окрашивает пикселы в установленный цвет.

"Линия"

Рисование линий текущим цветом. Нажатие кнопки мыши фиксирует начальную точку линии, отпускание — конечную.

Круг

Рисование окружностей текущим цветом. Нажатие кнопки мыши фиксирует центр окружности, отпускание — ее радиус.

Стереть

Окрашивает пикселы в белый цвет. Это происходит во время перемещения курсора над пикселами при нажатой кнопке мыши.

Палитра цветов

Задает текущую палитру для инструментов редактирования.

Другие опции

Открывает вкладку "Вся палитра" диалогового окна "Выбор цвета". Выбранный из палитры цвет показывается на образце.

Область редактирования

Здесь пиктограмма кнопки представлена в увеличенном виде.

Сетка

Изображение сетки в области редактирования. Каждая ячейка сетки эквивалентна одному пикселу.

Отменить

Очистка всей области редактирования.

Открыть

Открытие пиктограммы существующей кнопки для редактирования. Изображения кнопок хранятся в BMP-файлах.

Отменить

Отмена последнего действия.

Сохранить

Сохранение отредактированной пиктограммы в BMP-файле.

Сохранить как

Сохраняет отредактированную пиктограмму кнопки под другим именем или в другой папке.

Примечание При сохранении изображения новой кнопки диалоговое окно "Создание файла" по умолчанию будет использовать папку, определенную в папке для пользовательских значков вкладки "Файлы" диалогового окна "Настройка". Изображения кнопок, помещенные в папку, можно переносить в следующие версии программы с помощью диалогового окна "Перенос пользовательских настроек".


Диалоговое окно "Фильтры отображения"

Н Команды
Н Команды
Диалоговое окно "Фильтры отображения"
Понятия Процедуры Команды

Меню "Инструменты": подменю "Адаптация" » "Интерфейс"

Ввод команды: нпи

Отображает или скрывает элементы интерфейса пользователя, которые можно настроить в области структуры "Существующие адаптации". Следует установить флажок рядом с элементом для отображения элемента в области структуры или снимите флажок, если отображать элемент не требуется.

Показывать в древовидной структуре

Отображает или скрывает панели инструментов, меню, контекстные меню, сочетания клавиш, файлы LISP, кнопки мыши и элементы интерфейса старой версии (планшетные меню, кнопки планшета, меню мозаики изображений), которые являются частью выбранного файла НПИ.


Диалоговое окно "Поиск и замена"

Н Команды
Н Команды
Диалоговое окно "Поиск и замена"
Понятия Процедуры Команды

Меню "Инструменты": подменю "Адаптация" » "Интерфейс"

Ввод команды: нпи

Обнаруживает и заменяет команды или свойства команд (имена команд, описания или макросы).

В диалоговом окне "Поиск и замена" содержатся следующие вкладки:

  • вкладка "Найти" (диалоговое окно "Поиск и замена")
  • вкладка "Заменить" (диалоговое окно "Поиск и замена")

Темы:

  • Вкладка "Найти" (диалоговое окно "Поиск и замена")
  • Вкладка "Заменить" (диалоговое окно "Поиск и замена")


Вкладка "Найти" (диалоговое окно "Поиск и замена")

Н Команды
Н Команды
Вкладка "Найти" (диалоговое окно "Поиск и замена")
Понятия Процедуры Команды

Выполняет поиск команд или свойств команд на панели "Список команд" или "Существующие адаптации" <имя файла>.

Что найти

Отображает строку поиска, которую требуется обнаружить. Эта строка отображается в окне при выборе команды на панели "Список команд". Можно также ввести строку. Ранее введенные строки хранятся в раскрывающемся списке.

Без учета регистра

Выполняет поиск всех команд или свойств команд независимо от регистра (например, программа будет производить поиск по слову ОТРЕЗОК и по слову отрезок).

Ограничить поиск до:

Ограничивает параметры поиска файлом НПИ, указанном в раскрывающемся списке. По умолчанию выполняется поиск основного файла CUI (acad.cui ).

Найти выбранную команду

Если команда выбрана на панели "Список команд", она используется для поиска в области структуры следующего элемента, относящегося к команде интерфейса.

Найти далее

Выполняет поиск следующего вхождения строки поиска в полях "Имя", "Описание" или "Макросы" на панели "Свойства". При поиске на панели "Список команд" будут найдены только команды из списка. При поиске в области структуры панели "Существующие адаптации" поиск начинается в области структуры и продолжается среди команд на панели "Список команд".


Вкладка "Заменить" (диалоговое окно "Поиск и замена")

Н Команды
Н Команды
Вкладка "Заменить" (диалоговое окно "Поиск и замена")
Понятия Процедуры Команды

Заменяет строку поиска другой строкой поиска.

Что найти

Отображает строку поиска, которую требуется обнаружить. Эта строка отображается в окне при выборе команды на панели "Список команд". Можно также ввести строку. Ранее введенные строки хранятся в раскрывающемся списке.

Чем заменить

Отображает строку, которая заменит строку поиска.

Без учета регистра

Выполняет поиск всех команд или свойств команд независимо от регистра (например, программа будет производить поиск по слову ОТРЕЗОК и по слову отрезок).

Ограничить поиск до:

Ограничивает параметры поиска файлом НПИ, указанном в раскрывающемся списке. По умолчанию выполняется поиск основного файла НПИ (acad.cui ).

Заменить

Заменяет одно вхождение строки поиска. В диалоговом окне "Настройка интерфейса пользователя" место расположение строки поиска отображается на панели "Список команд", в области структуры и на панели "Свойства".

Заменить все

Заменяет все найденные вхождения строки поиска. Эту операцию отменить нельзя.

Найти далее

Выполняет поиск следующего вхождения строки поиска в полях "Имя", "Описание" или "Макросы" на панели "Свойства". При поиске на панели "Список команд" будут найдены только команды из списка. При поиске в области структуры панели "Существующие адаптации" поиск начинается в области структуры и продолжается среди команд на панели "Список команд".


НПИВЫГР Команда

Н Команды
Н Команды
НПИВЫГР Команда
Понятия Процедуры Команды

Выгружает файл НПИ

Ввод команды: нпивыгр

Открывает диалоговое окно Загрузка/выгрузка адаптаций, которое имеет те же опции, что и команда НПИВЫГР. Единственное различие между этими командами — содержание запросов командной строки.

Если переменной FILEDIA установлено значение 0 (откл), команда НПИВЫГР выведет следующую подсказку в командную строку.

Ввести имя адаптируемой группы для выгрузки: Ввести имя


НПИЗАГР Команда

Н Команды
Н Команды
НПИЗАГР Команда
Понятия Процедуры Команды

Загружает файл НПИ

Ввод команды: нпизагр

Открывает диалоговое окно "Загрузка/выгрузка адаптаций", в котором пользователь можно найти и загрузить файл НПИ для адаптации и переноса установок интерфейса пользователя.

Если переменной FILEDIA установлено значение 0 (откл), команда НПИЗАГР выведет следующую подсказку в командную строку.

Ввести имя файла адаптации, который необходимо загрузить: Ввести имя файла

Примечание Традиционные файлы меню (MNS) шаблонов меню (MNU), использованные в предыдущих версиях программы, заменены одним типом файла, а именно файл НПИ (CUI) на основе XML.

Темы:

  • Диалоговое окно "Загрузка/выгрузка адаптаций"


Диалоговое окно "Загрузка/выгрузка адаптаций"

Н Команды
Н Команды
Диалоговое окно "Загрузка/выгрузка адаптаций"
Понятия Процедуры Команды

Ввод команды: нпизагр

Управляет отображением адаптируемых групп и элементов интерфейса.

Загруженные адаптируемые группы

Перечисляет загруженные в настоящий момент файлы адаптаций.

Имя файла

Задает имя загружаемого файла. Можно ввести имя файла или нажать кнопку "Обзор" для отображения диалогового окна "Выбор файла адаптации" (стандартное диалоговое окно выбора файлов).

Выгрузить

Выгружает адаптируемую группу, выбранную в списке "Адаптируемые группы".

Загрузить

Загружает файл, выбранный в текстовом поле "Имя файла".

Обзор

Отображает диалоговое окно "Выбор файла меню" (стандартное диалоговое окно выбора файлов), в котором можно выбрать файл меню для загрузки.


НПИИМПОРТ Команда

Н Команды
Н Команды
НПИИМПОРТ Команда
Понятия Процедуры Команды

Импортирует пользовательские настройки из файла НПИ предприятия или частичного файла CUI в файл acad.cui.

Меню "Инструменты": подменю "Адаптация" » "Импорт адаптаций..."

Ввод команды: нпиимпорт

Открывается с помощью Вкладка "Передача" (диалоговое окно "Настройка интерфейса пользователя"), который является открытым по умолчанию. Элементы можно перетаскивать из одного файла НПИ в другой. Выбрать "Применить" для сохранения изменений и просмотра обновленного файла НПИ.


НПИЭКСПОРТ Команда

Н Команды
Н Команды
НПИЭКСПОРТ Команда
Понятия Процедуры Команды

Экспортирует пользовательские настройки из файла acad.cui а файл частичной адаптации или в файл CUI предприятия.

Меню "Инструменты": подменю "Адаптация" » "Экспорт адаптаций..."

Ввод команды: нпиэкспорт

Открывается с помощью Вкладка "Передача" (диалоговое окно "Настройка интерфейса пользователя"), который является открытым по умолчанию. Основной файл CUI (acad.cui) откроется на левой панели. Элементы можно перетаскивать из одного файла НПИ в другой. Выбрать "Применить" для сохранения изменений и просмотра обновленного файла НПИ.


НПОТКРЫТЬ Команда

Н Команды
Н Команды
НПОТКРЫТЬ Команда
Понятия Процедуры Команды

Открывает файл DWF, который содержит пометки

Меню "Файл": "Загрузить набор пометок"

Ввод команды: нпоткрыть

Команда вызывает диалоговое окно "Открытие DWF-файла пометок" (стандартное диалоговое окно выбора файлов), в котором можно выбрать файл формата DWF™ (Design Web Format™), содержащий пометки, для загрузки в Диспетчер наборов пометок. После выбора DWF-файла и нажатия кнопки "Открыть" вызывается "Диспетчер наборов пометок". Набор пометок из выбранного DWF-файла загружаются в "Диспетчер наборов пометок".


О Команды
  • О
  • ОБЛАКО
  • ОБЛАСТЬ
  • ОБНОБРАЗЦЫ
  • ОБНПОЛЕ
  • ОБРЕЗАТЬ
  • ОБХОДОБЛЕТНАСТР
  • ОБХСЛОЯ
  • ОБЩИЙВИД
  • ОБЪЕДИНЕНИЕ
  • ОЙ
  • ОКНО
  • ОКНОСВ
  • ОКНОСВЗАКР
  • ОЛЕСВОЙСТВА
  • ОПУБЛИКОВАТЬ
  • ОПЦИИМТФ
  • ОРТО
  • ОРФО
  • ОСВЕЖИТЬ
  • ОТКРЧАСТЬ
  • ОТКРЫТЬ
  • ОТМЕНИТЬ
  • ОТРЕЗОК
  • ОЧИСТИТЬ


О Команда

О Команды
О Команды
О Команда
Понятия Процедуры Команды

Отмена самой последней операции

Панель "Стандартная":

Контекстное меню: Убедитесь в отсутствии выбранных объектов и выполняющихся команд, нажмите правую кнопку мыши в области рисования и выберите "Отменить".

Ввод команды: о

Вводить команду о можно сколько угодно раз подряд до тех пор, пока чертеж не вернется в состояние, в котором он находился в начале сеанса редактирования.

Если операцию отменить нельзя, отображается имя команды, но не производится никаких действий. Операции, внешние по отношению к текущему чертежу, — такие как вывод на плоттер или запись в файл — не могут быть отменены.

Если в процессе выполнения команды изменялись режимы или использовался прозрачный режим для вызова других команд, их действия отменяются вместе с действием этой команды.

Команду отмены можно также вызвать нажатием клавиш CTRL + Z.

Команда О эквивалентна команде отменить 1.


ОБЛАКО Команда

О Команды
О Команды
ОБЛАКО Команда
Понятия Процедуры Команды

Создание полилиний с дуговыми сегментами, используемых в качестве облаков для пометок

Панель Рисование:

Меню "Рисование": "Облако"

Ввод команды: облако

Минимальная длина дуги: 0,5000 Максимальная длина дуги: 0,5000

Начальная точка или [Длина дуги/Объект/Стиль] <Объект>: Перетащить для создания облака, задать опцию или нажать ENTER.

Проведите курсор по контуру облака...

После возврата курсора в начальную точку в командной строке отображается следующее сообщение:

Облако построено.

Построенный объект является полилинией.

Примечание Команда ОБЛАКО записывает использованное последним значение длины дуги в системный реестр. Это значение умножается на значение системной переменной DIMSCALE, что обеспечивает согласованность при использовании в программе чертежей с различными масштабными коэффициентами.

Длина дуги

Задание минимальной и максимальной длины дуги для построения облака.

Минимальная длина дуги <0.5000>: Задать минимальную длину дуги

Максимальная длина дуги <0.5000>: Задать максимальную длину дуги

Проведите курсор по контуру облака...

Облако построено.

Значение максимальной длины дуги не может быть больше чем в 3 раза значения минимальной длины дуги.

Объект

Выбор замкнутого объекта для преобразования в облако.

Выберите объект: Выбрать замкнутый объект для преобразования в облако

Изменить направление на противоположное [Да/Нет]: Ввести д для изменения направления дуг облака на противоположное или нажать ENTER, чтобы оставить дуги без изменений

Облако построено.

Стиль

Задание стиля дуг для облака.

Стиль дуг [Обычный/Каллиграфия] <по умолчанию/последний>: Выбрать стиль для облака.


ОБЛАСТЬ Команда

О Команды
О Команды
ОБЛАСТЬ Команда
Понятия Процедуры Команды

Преобразование объектов, ограничивающих некоторую площадь, в области

Панель Рисование:

Меню "Рисование": "Область"

Ввод команды: область

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении

Области это плоские замкнутые объекты, которые образуются из нескольких двумерных объектов. Допускается выбирать полилинии, отрезки и криволинейные объекты. Под криволинейными объектами понимаются круги, дуги, эллиптические дуги, эллипсы и сплайны.

Входящие в набор замкнутые 2М и расчлененные плоские 3D полилинии преобразуются в отдельные области, а затем оставшиеся полилинии, отрезки и криволинейные объекты преобразуются в замкнутые плоские контуры (внешние границы и островки областей). Если более двух кривых имеют общую конечную точку, то вид полученной в результате области невозможно предугадать.

Граница области составляется из попарно соединенных криволинейных объектов, имеющих общие конечные точки. Все пересечения или самопересечения криволинейных объектов не обрабатываются.

Если выбранная полилиния была сглажена с помощью параметров "Сплайн" или "Вписать" команды ПОЛРЕД, то получаемая в результате область будет содержать линии или дуги сглаженной полилинии. Полилинии не преобразуются в сплайны.

Команда ОБЛАСТЬ удаляет использованные для создания области исходные объекты, если системная переменная DELOBJ имеет значение 1. Если исходные объекты были заштрихованы, ассоциативность штриховки теряется. Для восстановления ассоциативности необходимо заново выполнить штриховку области.


ОБНОБРАЗЦЫ Команда

О Команды
О Команды
ОБНОБРАЗЦЫ Команда
Понятия Процедуры Команды

Позволяет обновлять образцы листов, видов листов и видов пространства модели в диспетчере подшивок вручную

Ввод команды: обнобразцы

При этом выполняется обновление образцов в диспетчере подшивок. Образцы листов отображаются на вкладке "Список листов", образцы видов на листах - на вкладке "Список видов", а образцы видов пространства модели - на вкладке "Чертежи с ресурсами".


ОБНПОЛЕ Команда

О Команды
О Команды
ОБНПОЛЕ Команда
Понятия Процедуры Команды

Позволяет обновлять поля в выбранных объектах чертежа вручную

Меню "Сервис": "Обновить поля"

Контекстное меню: Вызвав команду работы с текстом и выделив поле, нажмите правую кнопку мыши и выберите "Обновить поле".

Ввод команды: обнполе

Выберите объекты: Выбрать объекты любым способом или ввести все, чтобы выбрать все поля в чертеже

При этом выполняется обновление полей в выбранных объектах.

Примечание Для обновления поля "Дата" служит команда ОБНПОЛЕ; возможность автоматического обновления определяется значением системной переменной FIELDEVAL.


ОБРЕЗАТЬ Команда

О Команды
О Команды
ОБРЕЗАТЬ Команда
Понятия Процедуры Команды

Обрезка объекта по режущей кромке, заданной другими объектами

Панель "Редактирование":

Меню "Редактирование": "Обрезать"

Ввод команды: обрезать

Текущие установки: Проекция = текущее значение Кромки = текущее значение

Выберите режущие кромки...

Выберите объекты или <выбрать все>: Выбрать один или несколько объектов и нажать ENTER или нажать ENTER для выбора всех отображенных объектов

Выбрать объекты, задающие режущие кромки, по которым следует обрезать объект, или нажать ENTER для выбора всех объектов в качестве потенциальных режущих кромок. Команда ОБРЕЗАТЬ проецирует режущие кромки и подлежащие обрезке объекты на плоскость XY текущей ПСК.

Примечание Для выбора режущих кромок, в которые входят блоки, можно использовать только одиночный выбор и параметры: "Перечеркивание", "Линия" и "Выбрать все".

Выберите обрезаемый или +Shift -- удлиняемый или [Линия/Перечеркивание/Проекция/Кромка/уДалить/Отменить]: Выбрать объект для обрезки, удерживать клавишу SHIFT и выбрать объект для удлинения, или задать опцию

Укажите способ выбора подлежащих обрезке объектов. Если при обрезке возможно образование нескольких результирующих объектов, требуемый результирующий объект определяется положением первой точки выбора.

Обрезаемый объект

Задание обрезаемого объекта. Запрос выбора обрезаемого объекта повторяется, что позволяет выполнять обрезку нескольких объектов. Для завершения команды следует нажать ENTER.

Выбор с помощью клавиши Shift для удлинения

Удлинение выбранных объектов вместо их обрезки. Эта опция предоставляет удобный способ переключения между обрезкой и удлинением объектов.

Линия

Выбор всех объектов, пересекающих линию выбора. Линия выбора - это последовательность временных линейных сегментов, заданная с помощью двух или более точек. Линия выбора не образует замкнутый контур.

Укажите первую точку линии выбора: Указать начальную точку линии выбора

Укажите следующую точку линии выбора или [Отменить]: Указать следующую точку линии выбора или ввести о

Укажите следующую точку линии выбора или [Отменить]: Указать следующую точку линии выбора, ввести о или нажать ENTER

Перечеркивание

Позволяет выбрать объекты, находящихся внутри прямоугольной области, определенной двумя точками, и пересекающих ее.

Первый угол: Указать точку

Противоположный угол: Указать точку на диагонали, которая выходит из первой точки

Примечание В ряде случаев пересечение прямоугольной области обрезаемым объектом может быть неоднозначным. Команда ОБРЕЗАТЬ разрешает выбор вдоль прямоугольной секущей рамки по часовой стрелке от первой точки до первого обнаруженного объекта.

Проекция

Задание режима проецирования, используемого при обрезке объектов.

Задайте опцию проецирования [Нет/Пск/Вид] <текущий>: Задать опцию или нажать ENTER

Нет

Обрезка без проецирования. Команда обрезает объекты, пересекающие режущую кромку в 3D пространстве.

ПСК

Проецирование на плоскость XY текущей ПСК. Команда обрезает объекты, не пересекающие режущую кромку в 3D пространстве.

Вид

Проецирование вдоль текущего направления взгляда. Команда обрезает объекты, пересекающие кромку под текущим углом зрения.

Кромка

Определение способа обрезки объекта: по продолженной кромке другого объекта или только до объекта, который пересекает подлежащий обрезке объект в трёхмерном пространстве.

Режим продолжения кромки до воображаемого пересечения [С продолжением/Без продолжения] <текущий>: Задать опцию или нажать ENTER

С продолжением

Удлинение режущей кромки до пересечения с 3D объектом.

Без продолжения

Объект обрезается только до режущей кромки, пересекающей его в 3D пространстве.

Примечание При обрезке штрихованных объектов не следует присваивать опции "Кромка" значение "С продолжением". В противном случае не будет происходить соединения режущих кромок, даже если значение допуска замкнутости лежит в пределах нормы.

Удалить

Удаление выбранных объектов. С помощью этого параметра удобно стирать ненужные объекты, не выходя из режима команды ОБРЕЗАТЬ.

Выберите объекты для удаления <выход>: Выбрать объекты любым способом и нажать ENTER для возврата к предыдущему запросу

Отменить

Отмена последнего действия команды ОБРЕЗАТЬ.


ОБХОДОБЛЕТНАСТР Команда

О Команды
О Команды
ОБХОДОБЛЕТНАСТР Команда
Понятия Процедуры Команды

Задает параметры обхода и облета

Панель инструментов 3D навигации

Нажмите "Вид": "Обход и облет" » "Параметры обхода и облета"

Ввод команды: обходоблетнастр

Пульт управления: Панель 3D навигации, Обход и облет

Отобразится диалоговое окно "Параметры обхода и облета".

Темы:

  • Диалоговое окно "Параметры обхода и облета"


Диалоговое окно "Параметры обхода и облета"

О Команды
О Команды
Диалоговое окно "Параметры обхода и облета"
Понятия Процедуры Команды

Задает параметры обхода и облета.

Параметры

Задает параметры, относящиеся к окну команд и к окну "Локатор положения.

При переходе к режиму обхода и облета

Каждый раз при включении режимов "Обход" или "Облет" выводится диалоговое окно "Управление навигацией обхода и облета".

Раз за сеанс

В каждом сеансе AutoCAD при первом входе пользователя в режим обхода или облета на экран выводится диалоговое окно "Управление навигацией обхода и облета".

Не показывать

Запрещает вывод диалогового окна "Управление навигацией обхода и облета".

Показывать диалоговое окно локатора положения

Указывает, будет ли открываться окно "Локатор положения" при включении пользователем режима обхода.

Параметры текущего чертежа

Указывает конкретные параметры обхода и облета для текущего чертежа.

Величина шага обхода/облета

Задает величину каждого шага в единицах чертежа (системная переменная STEPSIZE).

Количество шагов в секунду

Указывает количество шагов в секунду (системная переменная STEPSPERSEC).


ОБХСЛОЯ Команда

О Команды
О Команды
ОБХСЛОЯ Команда
Понятия Процедуры Команды

Динамически отображает слои в чертеже

Панель "Слои II":

Выберите в меню "Формат": "Инструменты слоя" » "Обход слоя"

Ввод команды: обхслоя

Откроется диалоговое окно "Обход слоя".

Темы:

  • Диалоговое окно "Обход слоя"


Диалоговое окно "Обход слоя"

О Команды
О Команды
Диалоговое окно "Обход слоя"
Понятия Процедуры Команды

Панель "Слои II":

Выберите в меню "Формат": "Инструменты слоя" » "Обход слоя"

Ввод команды: обхслоя

Динамически отображает объекты на слоях, выбранных пользователем из списка "Слои". Число слоев в чертеже отображается в заголовке диалогового окна. Можно изменить состояние текущего слоя при выходе, при сохранении состояний слоя или при очистке слоев, на которые нет ссылок.

Диалоговое окно "Обход слоя" можно использовать в видовом экране в пространстве листа для выбора включаемых и размораживаемых слоев в таблице слоев и в текущем видовом экране. Любой слой, который не был выбран в списке "Слои", замораживается в текущем видовом экране. Можно изменить отображение в одном видовом экране, не меняя отображение в другом видовом экране.

Фильтр

Включает и выключает активный фильтр. Если установлен этот флажок, в списке появляются только слои, соответствующие активному фильтру. При снятии этого флажка отображается полный список слоев. (Этот параметр доступен, только если имеется активный фильтр.) Чтобы включить активный фильтр, в списке фильтров введите символ-заместитель и нажмите клавишу ENTER, или выберите сохраненный фильтр.

Список слоев

Если активен некоторый фильтр, отображается список слоев, заданных в этом фильтре. Если никакой фильтр не активен, отображается список слоев чертежа. Дважды нажмите кнопку мыши на слое, чтобы установить его в режим "Показывать всегда" (слева от слоя отображается звездочка). Нажмите правую кнопку мыши в списке слоев, чтобы отобразить дополнительные опции.

В списке слоев можно:

  • Нажать кнопку мыши на имени слоя, чтобы отобразить содержимое слоя.
  • Дважды нажать на имени слоя, чтобы включить или выключить режим "Показывать всегда".
  • При нажатой клавише CTRL выбрать мышью несколько слоев.
  • При нажатой клавише SHIFT последовательно выбрать мышью слои.
  • При нажатой клавише CTRL или SHIFT дважды нажать кнопку мыши в списке слоев, чтобы включить или выключить режим "Показывать всегда".
  • Нажать кнопку мыши и перетащить курсор, выделив в списке несколько слоев.

    • Для вывода дополнительных опций работы со списком слоев нажмите правую кнопку мыши, чтобы отобразить контекстное меню "Список слоев".

Опции контекстного меню "Список слоев"

Отображается список опций для слоев, выбранных в списке слоев.

Сохранить выделение

Включается режим "Показывать всегда" для выбранных слоев. Слева от каждого зафиксированного слоя отображается звездочка (*).

Снять выделение

Выключает режим "Показывать всегда" для выбранных слоев.

Освободить все

Выключает режим "Показывать всегда" для всех слоев.

Выбрать все

Выбирает и отображает все слои.

Очистить все

Сбрасывается выбор всех слоев.

Инвертировать выбор

Сбрасывается текущий выбор слоев, выбираются и отображаются все прочие слои.

Выбрать неиспользуемые

Выбираются все слои без ссылок. Чтобы удалить неиспользуемые слои, нажмите кнопку "Удалить".

Сохранить состояние слоя

Выбранные слои сохраняются как конфигурация слоев, которая может использоваться Диспетчером конфигураций слоев.

Проверка

Отображается число слоев в чертеже, число выбранных слоев и число объектов на выбранных слоях.

Копировать как фильтр

Отображается имя выбранного слоя в текстовом поле "Фильтр" Можно использовать для создания символов-заместителей.

Сохранить текущий фильтр

Сохраняется текущий фильтр, и он становится доступным в списке "Фильтры" для повторного использования.

Удалить текущий фильтр

Удаляется текущий фильтр из списка.

Выбрать объекты

Выбор объекты и их слоев.

Список фильтров

Фильтры для списка слоев. Введите символ-заместитель и нажмите клавишу ENTER, чтобы отобразить и выделить только те слои, имена которых соответствуют символу-заместителю. Нажмите правую кнопку мыши, чтобы сохранить и удалить фильтры. В списке фильтров отображаются только сохраненные фильтры.

Подробнее об использовании символов-заместителей см. раздел "Символы-заместители" в Фильтрация и сортировка слоев в списке.

Удалить

Если выбранные слои не содержат ссылок, удалите их с чертежа. Чтобы вывести список слоев, которые можно очистить, нажмите правую кнопку мыши в любом месте в списке "Слои" и выберите пункт "Выбрать неиспользуемые". В списке "Слои" будут выделены слои без ссылок. Эти слои можно удалить.

Восстановить при выходе

Восстанавливает предыдущее состояние слоев при выходе из диалогового окна. Если этот флажок снят, любые внесенные пользователем изменения сохраняются


ОБЩИЙВИД Команда

О Команды
О Команды
ОБЩИЙВИД Команда
Понятия Процедуры Команды

Вызов окна "Общий вид"

Меню "Вид": "Общий вид"

Ввод команды: общийвид

Вывод диалогового окна "Общий вид".

Темы:

  • Окно "Общий вид"


Окно "Общий вид"

О Команды
О Команды
Окно "Общий вид"
Понятия Процедуры Команды

Меню "Вид": "Общий вид"

Ввод команды: общийвид

Отображает чертеж целиком; границы текущего вида выделяются утолщенной рамкой.

Меню "Вид" (окно "Общий вид")

Изменение экранного увеличения путем зумирования или показа общего вида чертежа в окне "Общий вид".

Если в окне "Общий вид" виден чертеж полностью, пункт меню "Уменьшить" и соответствующая кнопка панели становятся недоступны. Если текущий вид примерно совпадает с показанной в окне частью чертежа, недоступными становятся пункт и кнопка "Увеличить". Возможны ситуации, когда одновременно выполняются оба перечисленных условия, что ведет к недоступности обоих инструментов изменения вида; это, например, может произойти после вызова команды ПОКАЗАТЬ с опцией "Границы". Все пункты данного меню доступны и в контекстном меню, которое вызывается щелчком правой кнопки мыши в окне "Общий вид".

Крупнее

Увеличивает вдвое изображение в окне "Общий вид", не изменяя положение центра вида.

Уменьшить

Уменьшает вдвое изображение в окне "Общий вид", не изменяя положение центра вида.

Полный

Выводит в окне "Общий вид" чертеж целиком.

Меню "Параметры" (окно "Общий вид")

Позволяет переключать автоматический показ видовых экранов и динамическое обновление чертежа. Все пункты данного меню доступны и в контекстном меню, которое вызывается щелчком правой кнопки мыши в окне "Общий вид".

Автоматический видовой экран

Автоматическое поддержание в окне вида пространства модели на активном видовом экране, когда открыто несколько видовых окон. При отключенной опции "Авто ВЭкран" содержимое окна "Общий вид" не обновляется, когда меняется активный видовой экран.

Динамическое обновление

Управляет автоматическим обновлением вида при редактировании чертежа. При отключенной опции "Динамическое обновление" содержимое окна "Общий вид" не обновляется до тех пор, пока не нажать мышью в его пределах.

Зумирование в реальном времени

Управляет обновлением окна AutoCAD в реальном времени при зумировании в окне "Общий вид".


ОБЪЕДИНЕНИЕ Команда

О Команды
О Команды
ОБЪЕДИНЕНИЕ Команда
Понятия Процедуры Команды

Объединение выбранных областей или тел посредством сложения

Панель "Моделирование":

Меню "Редактирование": "Редактирование тела" » "Объединение"

Ввод команды: объединение

Пульт управления: Панель создания 3D объектов, Объединение

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

В набор объектов могут входить области и тела, расположенные в любых плоскостях. Наборы объектов делятся на поднаборы, объединение которых выполняется отдельно. В первый поднабор группируются тела. Во второй поднабор группируются первая выбранная область и все компланарные ей области. В третий поднабор группируются следующая область, некомпланарная первой области, и все дальнейшие компланарные области и т. д.

Результирующее составное тело представляет собой объем, включающий все выбранные тела. Каждая результирующая составная область представляет собой совокупность всех областей поднабора.


ОЙ Команда

О Команды
О Команды
ОЙ Команда
Понятия Процедуры Команды

Восстановление стертых объектов

Ввод команды: ой

Команда ОЙ восстанавливает объекты, удаленные последней командой СТЕРЕТЬ.

Кроме того, команду ОЙ можно использовать для восстановления объектов, стертых в процессе выполнения команд БЛОК и ПБЛОК. Однако команду ОЙ нельзя использовать для восстановления параметров, операций или ручек в Редактор блоков.

Команда ОЙ не позволяет восстановить объекты на слое, удаленном с помощью команды ОЧИСТИТЬ.


ОКНО Команда

О Команды
О Команды
ОКНО Команда
Понятия Процедуры Команды

Упорядочивает окна и значки при совместном использовании окна приложения с внешними приложениями

Ввод команды: окно

Задайте опцию [Каскад/сверху Вниз/слева Направо/Упорядочить]: Задать опцию

Каскад

Накладывает окна друг на друга, оставляя видимыми строки заголовков.

Слева направо

Упорядочивает окна, располагая их как неперекрывающиеся плитки одно рядом с другим.

Сверху вниз

Упорядочивает окна, располагая их как неперекрывающиеся плитки одно под другим.

Упорядочить

Упорядочивает значки окон.


ОКНОСВ Команда

С Команды
С Команды
ОКНОСВ Команда
Понятия Процедуры Команды

Управление свойствами объектов

Панель "Стандартная"

Выбрать в меню "Сервис": "Палитры" » "Свойства"

Контекстное меню: Выбрать объекты для просмотра/редактирования свойств, нажать правую кнопку мыши в области чертежа и выбрать "Свойства".

Указывающее устройство: Двойным нажатием кнопки выбирается большинство объектов

Ввод команды: ОКНОСВ

Откроется палитра свойств. Палитра свойств содержит перечень свойств выбранного объекта или набора объектов.

Можно также просматривать или изменять свойства объектов сторонних приложений, написанных в соответствии с требованиями стандартного интерфейса прикладного программирования (Application Programming Interface, API) AutoCAD.

Существует восемь общих свойств, которые имеются у всех объектов. Остальные свойства объектов определяются их типами.

Темы:

  • Палитра свойств
  • Общие свойства объектов
  • Диалоговое окно "Свойства границ ячеек"
  • Диалоговое окно "Добавление значения расстояния или угла"


Палитра свойств

С Команды
С Команды
Палитра свойств
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Сервис": Свойства

Контекстное меню: Выбрать объекты для просмотра/редактирования свойств, нажать правую кнопку мыши в области рисования и выбрать "Свойства".

Указывающее устройство: Двойным нажатием кнопки выбирается большинство объектов

Ввод команды: свойства

Палитра свойств отображает свойства выбранного объекта или набора объектов.

  • В случае, когда выбраны несколько объектов, палитра "Свойства" отображает только свойства, характерные для всех выбранных объектов.
  • В случае, когда не выбран ни один из объектов, палитра "Свойства" отображает только общие свойства текущего слоя и листа, название стиля печати, назначенного слою, свойства вида и данные о ПСК.

Любое свойство объекта может быть изменено путем задания нового значения. Выберите значение и используйте один из следующих методов:

  • Ввести новое значение.
  • Нажать на "стрелку вниз" справа от свойства для раскрытия списка и выбрать необходимое значение.
  • Нажать кнопку "Указать" и с помощью курсора изменить значения координат.
  • Нажать кнопку калькулятора QuickCalc, чтобы вычислить новое значение.
  • Чтобы увеличить или уменьшить значение, нажимать "стрелку влево" или "стрелку вправо".
  • Нажать кнопку {...} и изменить значение свойства в диалоговом окне.

Тип объекта

Информация о типе выбранного объекта.

Переключение значения системной переменной PICKADD

Включение (1) и отключение (0) системной переменной PICKADD. Если переменная PICKADD включена, то все выбранные по отдельности или с помощью рамки объекты добавляются в текущий набор. Если переменная PICKADD отключена, выбранные объекты заменяют текущий набор объектов.

Выбор объектов

Выбор объектов любым подходящим способом. В палитре свойств выводятся свойства, общие для всех выбранных объектов. Затем можно изменить свойства выбранных объектов в палитре свойств или изменить сами объекты с помощью команд редактирования.

Быстрый выбор

Отображает диалоговое окно "Быстрый выбор". Быстрое создание наборов объектов на основе определенного критерия выбора.

При нажатии правой кнопкой мыши на заголовке палитры появляется контекстное меню, содержащее описанные ниже опции.

Перенести

Отображается курсор с четырьмя стрелками, который используется для перемещения палитры. Зафиксировать палитру нельзя.

Размер

Отображается курсор с четырьмя стрелками, который используется для перетаскивания стороны или угла палитры для изменения ее размера.

Замкнуть

Закрытие палитры свойств.

Разрешить фиксацию

Переключается возможность фиксации (закрепления) окон палитры. Если выбрана данная опция, возможна фиксация окна при его перетаскивании в области фиксации сбоку чертежа. Зафиксированное окно сцепляется с боковой стороной окна приложения и вызывает изменение размера области рисования. При выборе данной опции становятся доступными опции "Крепление справа" и "Крепление слева".

Крепление справа/Крепление слева

Палитра "Свойства" присоединяется к основанию инструмента закрепления с правой или с левой стороны области рисования. Палитра развертывается и свертывается по мере перемещения курсора по ее ширине. Если закрепленная палитра открыта, ее содержимое накладывается на область рисования. Закрепленную палитру нельзя оставлять открытой.

Автоматически убирать с экрана

По мере перемещения курсора вдоль палитры происходит ее развертывание и свертывание. Если данная опция не включена, палитра остается открытой.

Описание

Управляет отображением области пояснений в нижней части палитры свойств. Если эта опция включена, отображаются описания опций, содержащихся в палитре "Свойства". Если эта опция не включена, никакие описания не отображаются.


Общие свойства объектов

С Команды
С Команды
Общие свойства объектов
Понятия Процедуры Команды

Перечисленные ниже свойства являются общими для большинства объектов и сторонних объектов (созданных в приложениях, которые разработаны согласно требованиям интерфейса AutoCAD API).

Цвет

Цвет объекта. При выборе из списка значения "Выбор цвета" открывается диалоговое окно "Выбор цвета" (см. ЦВЕТ).

В диалоговом окне "Выбор цвета" можно выбрать цвет для будущих объектов из числа 255 цветов, входящих в Индекс цветов AutoCAD (ИЦА), а также из всей палитры или из альбома цветов.

Слой

Текущий слой объекта. В списке представлены все слои текущего чертежа (см. СЛОЙ).

Тип линий

Текущий тип линий объекта. В списке представлены все типы линий текущего чертежа (см. ТИПЛИН).

Масштаб типа линий

Масштаб типа линий объекта (см. ЛМАСШТАБ).

Стиль печати

Список, содержащий значения ОБЫЧНЫЙ, ПОСЛОЮ, ПОБЛОКУ, а также стили печати, взятые из текущей таблицы (см. ПСТИЛЬ).

Вес линий

Вес линий объекта. В списке представлены все веса линий текущего чертежа (см. ВЕСЛИН).

Гиперссылка

Подключает гиперссылку к графическому объекту. Если с гиперссылкой связано текстовое пояснение, в окне отображается его текст. Если текстового пояснения нет, отображается URL-адрес (см. ГИПЕРССЫЛКА).

Высота

Значение текущей трехмерной высоты. Это свойство применимо не ко всем объектам (см. СВОЙСТВА).


Диалоговое окно "Свойства границ ячеек"

С Команды
С Команды
Диалоговое окно "Свойства границ ячеек"
Понятия Процедуры Команды

Указывающее устройство: При выделенной ячейке таблицы и открытой палитре "Свойства" выберите поле "Вес линий границ" или "Цвет границы" и нажмите кнопку [...].

В окне устанавливаются свойства границ ячеек таблицы.

Свойства границ

Определяет свойства выделенных ячеек таблицы.

Вес линий

Значение веса линий для отображаемых границ ячеек. При использовании широких линий следует соответствующим образом увеличить размер ячейки.

Цвет

Цвет для отображаемых границ ячеек. Если выбрать из списка значение "Выбор цвета", открывается диалоговое окно "Выбор цвета".

Применить

Вид границ выбранных ячеек таблицы, для которых применяются параметры "Свойства границы".

Все

Параметры границ применяются ко всем границам выбранных ячеек таблицы.

Внешние границы

Параметры границ применяются к наружным границам выбранных ячеек таблицы.

Внутренние границы

Параметры границ применяются для внутренних границ выбранных ячеек таблицы.

Нет

Параметры границ не применяются ни к одной из границ выбранных ячеек таблицы.

Просмотр

Иллюстрирует результат выполненных установок. Нажатием левой кнопки мыши на линии сетки координат в просмотровом образце можно назначить ей заданные свойства.


Диалоговое окно "Добавление значения расстояния или угла"

С Команды
С Команды
Диалоговое окно "Добавление значения расстояния или угла"
Понятия Процедуры Команды

Добавляет значение расстояния или угла к набору значений параметра в динамическом определении блока.

Расстояния или угол для добавления

Указывает значения (разделенные запятыми) для добавления к набору значений.

Список расстояний или углов (без маркировки)

Перечисляет расстояния или углы, определенные для набора значений.

Добавить

Добавляет значения, указанные в диалоговом окне "Расстояния или угол для добавления".

Удалить

Удаляет выбранное значение.


ОКНОСВЗАКР Команда

О Команды
О Команды
ОКНОСВЗАКР Команда
Понятия Процедуры Команды

Закрытие палитры свойств

Ввод команды: окносвзакр

Палитра свойств закрывается.


ОЛЕСВОЙСТВА Команда

О Команды
О Команды
ОЛЕСВОЙСТВА Команда
Понятия Процедуры Команды

Настройка размера, масштаба и других свойств выбранного OLE-объекта

Контекстное меню: Выберите OLE-объект, нажмите правую кнопку мыши и выберите из контекстного меню "Размер текста".

Ввод команды: олесвойства

Откроется диалоговое окно "Размер текста OLE".

Примечание Перед вызовом команды ОЛЕСВОЙСТВА необходимо выбрать OLE-объект.

Темы:

  • Диалоговое окно "Размер текста OLE"


Диалоговое окно "Размер текста OLE"

О Команды
О Команды
Диалоговое окно "Размер текста OLE"
Понятия Процедуры Команды

Контекстное меню: Выберите OLE-объект, нажмите правую кнопку мыши и выберите из контекстного меню "Размер текста".

Ввод команды: олесвойства

Окно позволяет ставить в соответствие высоту в пунктах шрифта в OLE-объекте высоте текста в чертеже. OLE-объект масштабируется автоматически в соответствии с высотой текста.

Шрифт OLE

В списке перечисляются все шрифты, используемые OLE-объектом.

Размер в пунктах

Список размеров (в пунктах), разрешенных для выбранного шрифта.

Высота текста

Задание высоты текста в чертеже для шрифта, имеющего заданный размер в пунктах.

Сброс

Восстановление первоначальных размеров OLE-объекта, с которыми он был вставлен в чертеж.


ОПУБЛИКОВАТЬ Команда

О Команды
О Команды
ОПУБЛИКОВАТЬ Команда
Понятия Процедуры Команды

Создание HTML-страниц с изображениями выбранных чертежей

Меню "Файл": Публикация в Интернете

Ввод команды: опубликовать

Откроется диалоговое окно "Публикация в Интернете".

Темы:

  • Мастер публикации в Интернете


Мастер публикации в Интернете

О Команды
О Команды
Мастер публикации в Интернете
Понятия Процедуры Команды

Меню "Файл": Публикация в Интернете

Ввод команды: опубликовать

Создание сформатированной HTML-страницы. Имеется несколько вариантов форматирования, определяющих компоновку готовых HTML-страниц. Созданную HTML-страницу можно с помощью Мастера опубликовать в Интернете или корпоративной сети (intranet).

Можно также пользоваться мастером для изменения имеющихся HTML-страниц, созданных командой ОПУБЛИКОВАТЬ.

Web-страницу можно создать на основе выбранного шаблона. Подробнее о настройке шаблонов см. раздел Настройка шаблонов Интернет-публикаций документа Руководство по адаптации.


ОПЦИИМТФ Команда

О Команды
О Команды
ОПЦИИМТФ Команда
Понятия Процедуры Команды

Задание опций для команды ИМПОРТМТФ

Ввод команды: опциимтф

Откроется диалоговое окно "Параметры импорта из WMF".

Темы:

  • Диалоговое окно "Параметры импорта из WMF"


Диалоговое окно "Параметры импорта из WMF"

О Команды
О Команды
Диалоговое окно "Параметры импорта из WMF"
Понятия Процедуры Команды

Ввод команды: опциимтф

Определяет, сохраняется ли относительная ширина линий при импорте метафайлов, а также, импортируются ли метафайлы в виде каркасов или тел.

В каркасном виде (без закрашивания)

Импорт объектов в виде каркасов. Если сбросить этот флажок, объекты импортируются с закрашиванием.

С широкими линиями

Сохранение относительной ширины линий и рамок при импорте. Если сбросить этот флажок, линии импортируются с нулевой шириной.


ОРТО Команда

О Команды
О Команды
ОРТО Команда
Понятия Процедуры Команды

Ограничивает перемещение курсора в вертикальном или горизонтальном направлении

Строка состояния: Орто

Ввод команды: орто (или 'орто для прозрачного вызова)

Выберите режим [Вкл/Откл] <текущий>: Ввести вкл или откл или нажать ENTER

На чертеже показано построение отрезка в режиме "Орто". Точка 1 является первой заданной точкой, точка 2 — это положение курсора в момент задания второй точки.

Режим "Орто" применяется только при задании угла или расстояния путем указания двух точек с помощью устройства указания. В режиме "Орто" курсор перемещается только в горизонтальном и вертикальном направлениях относительно ПСК.

Горизонтальным считается направление, параллельное оси X текущей ПСК, а вертикальным - направление, параллельное оси Y.

На 3D виде команда ОРТО также позволяет расположить объект параллельно оси Z ПСК; подсказка отображает +Z или -Z для угла, в зависимости от направления по оси Z.


ОРФО Команда

О Команды
О Команды
ОРФО Команда
Понятия Процедуры Команды

Орфографическая проверка надписей в чертеже

Меню "Сервис": "Орфография"

Ввод команды: орфо (или 'орфо для прозрачного вызова)

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Если в ответ на запрос выбора объектов ввести все, проверка будет выполнена для всех объектов вкладки "Модель" и всех листов.

При обнаружении неизвестного слова в выбранном тексте отобразится диалоговое окно "Проверка орфографии".

Темы:

  • Диалоговое окно "Проверка орфографии"
  • Диалоговое окно "Смена словарей"


Диалоговое окно "Проверка орфографии"

О Команды
О Команды
Диалоговое окно "Проверка орфографии"
Понятия Процедуры Команды

Меню "Сервис": "Орфография"

Ввод команды: орфо (или 'орфо для прозрачного вызова)

Исправление ошибок правописания в объектах, созданных командами ТЕКСТ, МТЕКСТ, ВЫНОСКА и АТОПР. Диалоговое окно "Проверка орфографии" отображается только при обнаружении неизвестного слова в выбранном тексте.

В атрибутах проверяются только их значения. Проверка орфографии выполняется как для текстовых объектов вхождений блоков, так и для текстовых объектов вложенных блоков. При выборе для проверки вхождения блока проверяется его описание.

Текущий словарь

Отображение имени текущего словаря.

Текущее слово

Отображает проверяемое слово.

Варианты

Список альтернатив из текущего словаря. Выбрать слово для замены из списка или ввести слово в поле.

Пропустить

Пропуск текущего слова.

Пропустить все

Пропуск всех сходных с текущим слов в еще не проверенном тексте.

Исправить

Замена текущего слова выделенным словом из списка "Варианты".

Исправить все

Замена текущего слова во всех выбранных текстовых объектах.

Запомнить

Добавление текущего слова в текущий вспомогательный словарь. Максимальная длина слова равняется 63 символам.

Поискать

Получение списка слов, которые близки к слову, выбранному в списке "Варианты".

Сменить словари

Вызов диалогового окна "Смена словарей".

Контекст

Отображает фразу, в которой было обнаружено текущее слово.


Диалоговое окно "Смена словарей"

О Команды
О Команды
Диалоговое окно "Смена словарей"
Понятия Процедуры Команды

Меню "Сервис": "Орфография"

Ввод команды: орфо (или 'орфо для прозрачного вызова)

Предназначено для перехода к использованию другого словаря. В ходе орфографической проверки команда ОРФО производит сравнение слов в чертеже со словами, хранящимися в текущем основном словаре. Все исключительные случаи, определяемые при помощи опции "Запомнить", записываются во вспомогательный словарь, являющийся текущим на момент проверки.

Если необходимо провести проверку на другом языке, следует поменять основной словарь. Кроме этого, можно вести одновременно несколько вспомогательных словарей, переключаясь с одного на другой по мере надобности.

Основной словарь

Список имеющихся основных словарей для различных языков. Основной словарь используется совместно со вспомогательным словарем.

Вспомогательный словарь

Отображение имени текущего вспомогательного словаря. Для создания нового вспомогательного словаря следует ввести имя нового словаря и нажать кнопку "Принять".

Обзор

Вызов диалогового окна "Выбор вспомогательного словаря" (стандартного окна выбора файлов), в котором можно выбрать другой файл словаря. Выбранный файл словаря используется до тех пор, пока не будет выбран новый файл.

Ведение вспомогательного словаря

Список слов, из которых состоит текущий вспомогательный словарь. Имеется возможность добавлять новые и удалять имеющиеся слова.

Добавить

Добавление в словарь слова, введенного в текстовом поле. Максимальная длина слова равняется 63 символам.

Удалить

Удаление из словаря слова, введенного в текстовом поле или выбранного из списка.


ОСВЕЖИТЬ Команда

О Команды
О Команды
ОСВЕЖИТЬ Команда
Понятия Процедуры Команды

Перерисовка содержимого текущего видового экрана

Ввод команды: освежить (или 'освежить для прозрачного вызова)

Если системная переменная BLIPMODE включена, следы маркеров, оставленные командами редактирования, удаляются из текущего видового экрана.


ОТКРЧАСТЬ Команда

О Команды
О Команды
ОТКРЧАСТЬ Команда
Понятия Процедуры Команды

Загрузка геометрии и именованных объектов в чертеж из выбранного вида или слоя.

Ввод команды: открчасть

Примечание Рекомендуется частично открыть чертеж с помощью команды ОТКРЫТЬ с последующим выбором параметра "Открыть частично" в диалоговом окне "Выбор файла" для отображения диалогового окна "Частичное открытие".

При вызове команды ОТКРЧАСТЬ из пакетного файла переменная FILEDIA может равняться как 0, так и 1. Если при значении системной переменной FILEDIA, равном 0, ввести открчасть или -открчасть по запросу "Команда", то команда ОТКРЧАСТЬ выводит запросы в командную строку.

Имя открываемого чертежа: Ввести имя чертежа и нажать ENTER

При ответе на запрос вводом символа тильда (~) игнорируется значение переменной FILEDIA и выводится диалоговое окно "Выбор файла. В нем нужно выбрать файл и указать опцию "Открыть частично", открывая диалоговое окно "Частичное открытие". Если ввести имя файла в ответ на запрос, в командной строке будут отображаться подсказки.

Имя вида для загрузки или [?] <*Границы*>: Ввести имя вида, затем ? или нажать ENTER для загрузки чертежа в его границах

Имя вида для загрузки

Открытие чертежа с загрузкой геометрии, принадлежащей выбранному виду.

Имена загружаемых слоев или [?] <нет>: Ввести имя слоя, затем ? или нажать ENTER

Имена загружаемых слоев

Загрузка в текущий чертеж геометрии с выбранного слоя (слоев). Для того чтобы одновременно задать несколько слоев, нужно ввести их имена, разделяя запятыми. Если не заданы слои, геометрия не загружается в чертеж даже в том случае, если указан вид для загрузки.

Выгрузить все внешние ссылки при открытии [Да/Нет] <Да>: Ввести д или н или нажать ENTER

Да

Информация о внешних ссылках не загружается в чертеж.

Нет

Информация о всех внешних ссылках загружается в чертеж.

?—Список слоев

Отображение списка слоев, доступных в выбранном чертеже чертежа. Необходимо ввести имя слоя или список имен слоев. Слои в списке должны разделяться запятыми.

Выгрузить все внешние ссылки при открытии [Да/Нет] <Да>: Ввести д или н или нажать ENTER

Да

Информация о внешних ссылках не загружается в чертеж.

Нет

Информация о всех внешних ссылках загружается в чертеж.

?—Список видов

Отображение списка видов пространства модели, доступных в выбранном чертеже. Необходимо ввести имя вида.

Имена загружаемых слоев или [?] <нет>: Ввести имя слоя, затем ? или нажать ENTER

Имена загружаемых слоев

Загрузка в текущий чертеж геометрии с выбранного слоя (слоев). Для того чтобы одновременно задать несколько слоев, нужно ввести их имена, разделяя запятыми. Если не заданы слои, геометрия не загружается в чертеж даже в том случае, если указан вид для загрузки.

Выгрузить все внешние ссылки при открытии [Да/Нет] <Да>: Ввести д или н или нажать ENTER

Да

Информация о внешних ссылках не загружается в чертеж.

Нет

Информация о всех внешних ссылках загружается в чертеж.

?—Список слоев

Получение списка слоев, доступных в файле чертежа. Необходимо ввести имя слоя или список имен слоев. Слои в списке должны разделяться запятыми.

Выгрузить все внешние ссылки при открытии [Да/Нет] <Да>: Ввести д или н или нажать ENTER

Да

Информация о внешних ссылках не загружается в чертеж.

Нет

Информация о всех внешних ссылках загружается в чертеж.


ОТКРЫТЬ Команда

О Команды
О Команды
ОТКРЫТЬ Команда
Понятия Процедуры Команды

Открытие существующего файла чертежа

Панель "Стандартная:

Меню "Файл": "Открыть"

Ввод команды: открыть

Откроется диалоговое окно "Выбор файла" (стандартное диалоговое окно выбора файлов).

Пользователь имеет возможность открыть и загрузить только отдельные объекты чертежа, расположенные на заданных слоях или видах. Для этого в диалоговом окне "Выбор файла" нужно нажать стрелку рядом с кнопкой "Открыть" и выбрать "Открыть частично" или "Открыть для чтения частично". Отобразится диалоговое окно "Частичное открытие".

Если значение системной переменной FILEDIA равно 0, отображается запрос команды ОТКРЫТЬ.

Примечание Если выбранный чертеж содержит макросы, отобразитсядиалоговое окно защиты от макровирусов AutoCAD.

Темы:

  • Стандартные диалоговые окна выбора файлов
  • Диалоговое окно "Ярлыки папки Buzzsaw"
  • Диалоговое окно "Вход на веб-узел Buzzsaw"
  • Диалоговое окно "Создание ярлыка папки Buzzsaw"
  • Диалоговое окно "Изменение ярлыка папки Buzzsaw"
  • Диалоговое окно "Выбор папки Buzzsaw"
  • Диалоговое окно "Поиск файлов"
  • Диалоговое окно "Добавление/изменение FTP-адресов"
  • Диалоговое окно "Частичное открытие"
  • ОТКРЫТЬ (вариант для командной строки)


Стандартные диалоговые окна выбора файлов

О Команды
О Команды
Стандартные диалоговые окна выбора файлов
Понятия Процедуры Команды

В некоторых командах используются стандартные диалоговые окна выбора файлов, с помощью которых можно выполнять навигацию по локальным и сетевым дискам, а также по серверам FTP и папкам в Интернете для выбора файлов. Диалоговые окна могут несколько отличаться от приведенного описания, но, как правило, содержат следующие опции:

Хранилища информации

Обеспечивает быстрый доступ к предварительно указанным папкам. Порядок значков в списке хранилищ информации можно менять путем перетаскивания. Чтобы добавить новый значок в список хранилищ информации, перетащите папку из списка. Нажмите правой кнопкой мыши в области хранилищ информации, чтобы отобразить контекстное меню, содержащее параметры для добавления, удаления и изменения значков или восстановления значков по умолчанию, которые были удалены. Значок Autodesk® Buzzsaw® удалить нельзя. Изменения, внесенные в список хранилищ информации, учитываются во всех стандартных диалоговых окнах выбора файла.

Журнал

Список ссылок на файлы, которые последними обрабатывались посредством данного диалогового окна. Рекомендуется периодически удалять из журнала неиспользуемые ссылки. Для этого следует открыть журнал, выделить неиспользуемые ссылки и нажать кнопку "Удалить". Чтобы упорядочить ярлыки по дате, следует выбрать "Виды" » "Подробности", а затем выбрать столбец "Изменен" в списке "Файлы".

Личная/Мои документы

Отображение содержимого папки "Личная" (или "Мои документы") для профиля текущего пользователя. Конкретное имя этой папки (“Личная” или “Мои документы”) зависит от версии операционной системы.

Избранное

Переход в папку "Избранное" для профиля текущего пользователя. В этой папке хранятся ярлыки файлов и папок, которые были добавлены в "Избранное" с помощью пункта меню "Сервис" » "Добавить в Избранное" данного диалогового окна.

FTP

Переход на FTP-узлы, доступные для посещения. Их содержимое отображается непосредственно в файловой области окна. Чтобы добавить в список новый FTP-адрес, или изменить параметры уже существующего FTP-адреса, в диалоговом окне следует выбрать "Сервис" » Добавление/изменение FTP-адресов.

Рабочий стол

Переход в папки, расположенные на системном рабочем столе.

Buzzsaw

Доступ к проектам, хранящимся на Web-сайте Buzzsaw. Buzzsaw является защищенной сетевой службой для сотрудничества и управления проектами. Эта служба позволяет различным группам разработчиков обмениваться проектной информацией. Для использования программного обеспечения Buzzsaw необходимо иметь учетную запись для управления проектами или получить доступ подписчика к веб-узлу Buzzsaw. Если пользователь еще не зарегистрирован на Buzzsaw, при выборе хранилища "Buzzsaw" отображается диалоговое окно "Выбор шаблона", где можно добавить ярлык папки Buzzsaw. Если дважды нажать "Добавить ярлык папки Buzzsaw", откроется диалоговое окно "Вход на веб-узел Buzzsaw", где можно подписаться на пробное бесплатное использование службы в течение 30 дней. При первом посещении Buzzsaw открывается веб-браузер, в который загружается главная страница управления проектами. Если пользователь уже имеет учетную запись для управления проектами, выбрав "Buzzsaw" можно просмотреть все веб-узлы проектов в списке.

Папка

Имя текущей папки или диска. Чтобы просмотреть иерархический путь к текущей папке и получить возможность перехода вверх/вниз по структуре папок, а также на другие диски (в том числе сетевые), FTP-серверы и веб-папки (Веб-папки или Мое сетевое окружение, в зависимости от установленной операционной системы), следует нажать расположенную рядом стрелку-треугольник. Веб-папки можно создавать в проводнике Windows. Дополнительную информацию о веб-папках можно получить у администратора или в справке по "Проводнику Windows". Для задания режима запоминания последних использованных путей в диалоговых окнах выбора файлов между сеансами работы служит системная переменная REMEMBERFOLDERS.

Назад

Возврат в предыдущую папку.

Переход на один уровень вверх

Переход по структуре папок выше на один уровень вложенности.

Поиск в Web

Отображает диалоговое окно "Навигация в Интернете", с помощью которого осуществляется доступ к файлам и хранение файлов в Интернете.

Удалить

Удаление выбранного файла или папки.

Создать папку

Создание в текущей папке новой вложенной папки. Имя создаваемой папки задается пользователем.

Виды

Определяет внешний вид списка файлов и папок, а для списка файлов указывает, требуется ли отображать образец для просмотра при выборе файла.

Список

Отображает список в виде нескольких столбцов.

Подробности

Отображает список в виде одного столбца (каждый файл на отдельной строке).

Образец

Режим отображения образца для быстрого просмотра содержимого чертежа, выбранного в списке. Если ни один файл в перечне не выделен, область просмотра пуста. Для того чтобы чертежи сохранялись вместе с образцами для просмотра, необходимо поднять флажок "Создавать образец для просмотра" на вкладке "Открытие/Сохранение" диалогового окна "Настройка".

Сервис

Предоставляет инструменты для выбора файлов и других операций, доступных в диалоговых окнах выбора файлов.

Найти

Отображает диалоговое окно "Поиск файлов", которое предназначено для поиска файлов по имени, размещению, а также по дате создания или изменения.

Обнаружить

Поиск файла по стандартному пути AutoCAD. Стандартный путь поиска задается на вкладке "Файлы" диалогового окна "Настройка".

Добавить/изменить FTP-адреса

Отображает диалоговое окно "Добавление/изменение FTP-адресов", в котором можно задать доступные для навигации серверы FTP. Для последующей работы с этими серверами необходимо выбрать FTP из списка хранилищ.

Добавить текущую папку как хранилище

Добавление ярлыка выбранной папки в список хранилищ информации, что обеспечивает быстрый доступ к этой папке из всех стандартных диалоговых окон выбора файлов. Для того чтобы удалить ярлык, следует нажать на нем правой кнопкой мыши и выбрать "Удалить" в контекстном меню.

Добавить в "Избранное"

Добавление ярлыка текущей или выбранной папки в папку "Избранное". Ярлык размещается в папке "Избранное" профиля текущего пользователя. В дальнейшем для доступа к сохраненному таким образом файлу или папке нужно будет выбрать "Избранное" из списка "Хранилища информации".

Поиск в "Избранном"

Задание пути к системной папке "Избранное".

Опции

Дополнительные возможности для некоторых стандартных диалоговых окон выбора файлов.

Параметры безопасности

Параметры цифровой подписи и пароля, добавляемых при сохранении файла.

Перечень файлов

Здесь отображаются файлы и папки, найденные по текущему пути и соответствующие заданному типу файлов по расширениям. С помощью меню "Вид" можно задать, как представлять содержимое текущей папки — в виде списка или в виде таблицы.

Образец

Отображение растрового изображения чертежа при выборе "Виды" » "Предварительный просмотр" в диалоговом окне. Если ни один файл в перечне не выделен, область просмотра пуста. Для того чтобы чертежи сохранялись вместе с образцами для просмотра, необходимо поднять флажок "Создавать образец для просмотра" на вкладке "Открытие/Сохранение" диалогового окна "Настройка".

Имя файла

Здесь отображается имя файла, выделенного в перечне. Если выделено несколько файлов, в поле заносятся все имена, причем каждое заключается в кавычки. Если ввести имя файла непосредственно в поле "Имя файла", отменяется любое выделение. При вводе нескольких имен файлов их следует заключать в кавычки. Для фильтрации файлов, отображаемых в списке, разрешается использовать символы шаблоны.

Тип файла

Фильтрация списка файлов по их типу. При сохранении файла задается формат, в котором файл будет сохранен.

С выбором начального вида

Отображение заданного вида пространства модели при открытии чертежа, если этот чертеж содержит более одного именованного вида.

С обновлением образцов для листов и видов

Здесь отображается текущее значение системной переменной UPDATETHUMBNAIL. Данный параметр временно переопределяет значение переменной. Для того, чтобы сохранить файл без обновления образцов, этот флажок следует сбросить. Для обновления всех образцов, этот флажок следует установить. Этот параметр не меняет текущего значения системной переменной UPDATETHUMBNAIL.

Открыть/Сохранить

В зависимости от предназначения определенного диалогового окна выбора файлов, открывает или сохраняет выбранный файл или задает путь к выбранной папке в предыдущем диалоговом окне. В некоторых диалоговых окнах выбора файлов могут присутствовать дополнительные параметры, доступ к которым можно получить, нажав стрелку рядом с кнопкой "Открыть".

Открыть для чтения

Открытие файла только для чтения. Изменения в файле невозможно сохранить, если не присвоить файлу новое имя.

Открыть частично

Отображает диалоговое окно "Частичное открытие". Пользователь имеет возможность открыть и загрузить только отдельные объекты чертежа, расположенные на заданных слоях или видах. Команду ОТКРЧАСТЬ можно применять только к чертежам в формате последней версии программы.

Открыть для чтения частично

Открытие отдельных фрагментов чертежа только для чтения.


Диалоговое окно "Ярлыки папки Buzzsaw"

О Команды
О Команды
Диалоговое окно "Ярлыки папки Buzzsaw"
Понятия Процедуры Команды

Создает, присваивает новое имя, изменяет и удаляет ярлыки папок Buzzsaw.

Ярлыки папки Buzzsaw

Отображает список папок существующих ярлыков Buzzsaw.

Новый

Открывает диалоговое окно "Вход на веб-узел Buzzsaw".

Переименовать

Присваивает новое имя выбранному ярлыку.

Изменить

Открывает диалоговое окно "Вход на веб-узел Buzzsaw", где можно изменить параметры выбранного ярлыка.

Удалить

Удаляет выбранный ярлык.

Замкнуть

Закрывает папку выбранного ярлыка.


Диалоговое окно "Вход на веб-узел Buzzsaw"

О Команды
О Команды
Диалоговое окно "Вход на веб-узел Buzzsaw"
Понятия Процедуры Команды

Выполняет вход на веб-узел Buzzsaw для перехода к определенной папке.

Сайт Buzzsaw

Указывает положение последнего использованного узла Buzzsaw. Ввести существующий адрес или имя веб-узла.

Имя пользователя Buzzsaw

Указывает имя пользователя для веб-узла Buzzsaw, к которому требуется получить доступ.

Пароль

Указывает пароль пользователя для входа на веб-узел Buzzsaw.

Сохранить имя пользователя и пароль

Сохранение имени пользователя для устранения необходимости повторного ввода при следующем посещении веб-узла.

Нажмите, чтоб зарегистрироваться и получить бесплатную пробную версию

Регистрирует пользователя для получения доступа к бесплатной пробной версии веб-узла Buzzsaw.


Диалоговое окно "Создание ярлыка папки Buzzsaw"

О Команды
О Команды
Диалоговое окно "Создание ярлыка папки Buzzsaw"
Понятия Процедуры Команды

Определяет ярлык папки Buzzsaw.

Это окно обеспечивает доступ к новому заданному пользователем адресу на Autodesk Buzzsaw, где можно сохранять и откуда можно открывать чертежи. Если открыта подшивка, то ей назначается указанный адрес Autodesk Buzzsaw. Отображаются только те папки Buzzsaw, которые имеют отношение к текущей подшивке.

Сайт Buzzsaw

Отображает имя текущего веб-узла Buzzsaw.

Выбор проекта или папки на веб-узле Buzzsaw

Отображает список наиболее часто открываемых на веб-узле проектов и папок.

Обзор

Отображает диалоговое окно "Выбор проекта или папки Buzzsaw", где можно найти и выбрать проект или папку.

Введите имя для этого ярлыка папки Buzzsaw

Указывает имя ярлыка.


Диалоговое окно "Изменение ярлыка папки Buzzsaw"

О Команды
О Команды
Диалоговое окно "Изменение ярлыка папки Buzzsaw"
Понятия Процедуры Команды

Изменяет ярлык папки Buzzsaw.

Это окно обеспечивает доступ к новому заданному пользователем адресу на Autodesk Buzzsaw. Если открыта подшивка, то ей назначается указанный адрес Autodesk Buzzsaw. Отображаются только те папки Buzzsaw, которые имеют отношение к текущей подшивке.

Сайт Buzzsaw

Отображает имя текущего веб-узла Buzzsaw.

Выбор проекта или папки на веб-узле Buzzsaw

Отображает список наиболее часто открываемых на веб-узле проектов и папок.

Обзор

Отображает диалоговое окно "Выбор проекта или папки Buzzsaw", где можно найти и выбрать проект или папку.

Введите имя для этого ярлыка папки Buzzsaw

Указывает имя ярлыка.


Диалоговое окно "Выбор папки Buzzsaw"

О Команды
О Команды
Диалоговое окно "Выбор папки Buzzsaw"
Понятия Процедуры Команды

Указывает проект или папку Buzzsaw, которую требуется сохранить, используя ярлык папки Buzzsaw.

Список проектов и папок Buzzsaw

Указывает проекты и папки Buzzsaw, которым может быть присвоен ярлык.


Диалоговое окно "Поиск файлов"

О Команды
О Команды
Диалоговое окно "Поиск файлов"
Понятия Процедуры Команды

Поиск файлов по имени, размещению, а также по дате создания или изменения. Чтобы вызвать диалоговое окно "Найти" в стандартном диалоговом окне выбора файлов, следует выбрать меню "Сервис" » "Найти".

Диалоговое окно "Поиск файлов" состоит из следующих вкладок: Имя и размещение, Дата изменения

Дополнительные опции: Найти, Остановить, Новый поиск, OK, Результаты поиска

Вкладка "Имя и размещение"

На вкладке "Имя и размещение" задаются критерии поиска файлов по имени, типу и размещению.

Имя

Полные имена файлов для поиска или их известные фрагменты. Если нужно указать несколько файлов, следует ввести имена одно за другим, заключая каждое из них в кавычки. При выполнении поиска могут применяться следующие глобальные символы-шаблоны:

  • * (Звездочка): Соответствует любой последовательности символов. Может использоваться в любой позиции строки.
  • ? (Знак вопроса): Соответствует любому одиночному символу; например, ?BC соответствует ABC, 3BC и т.п.

Тип искомых файлов задается в списке "Тип". Следовательно, задавать расширение файлов в поле "Имя" нет необходимости. Например, для того чтобы найти файл house102.dwg, следует ввести house* в поле "Имя" и из списка "Тип" выбрать "Чертежи" (файлы с расширением .dwg).

Тип

Типы файлов, учитываемые при поиске. Список ограничен только теми типами, которые поддерживаются текущим стандартным окном выбора файлов.

Папка

Папка, в которой выполняется поиск. Имя папки можно ввести с клавиатуры, выбрать из списка или, воспользовавшись кнопкой "Обзор", разыскать в структуре диска. Если указывается несколько папок, каждую из них нужно заключить в кавычки.

Обзор

Вызов диалогового окна "Обзор папок". В нем можно выбрать папку, в которой должен производиться поиск.

Включая вложенные папки

Поиск файлов не только в папке, выбранной в "Где искать", но и во всех папках, вложенных в нее.

Вкладка "Дата"

Фильтрация найденных файлов по дате создания или изменения.

Все файлы

Поиск без фильтра даты.

Все файлы, созданные или измененные

Вовлечение в процесс поиска только тех файлов, которые созданы или изменены за указанный промежуток времени.

  • Между: Поиск файлов, созданных или измененных в промежутке между указанными датами. Даты можно ввести с клавиатуры, или нажать на стрелке и выбрать их из календаря. Внутри календаря перемещение осуществляется с помощью кнопок-стрелок (влево и вправо); можно также выбирать месяц и год, нажимая на них в заголовке календаря.
  • За последние N месяцев: Поиск файлов, созданных или измененных за последние несколько месяцев (количество месяцев задается пользователем).
  • За последние N дней: Поиск файлов, созданных или измененных за последние несколько дней (количество дней задается пользователем).

Найти

Поиск файлов по критериям, заданным на обеих вкладках.

Остановить

Прерывание поиска.

Новый поиск

Очистка списков результатов поиска и возврат значений по умолчанию всем критериям поиска.

OK

Закрытие диалогового окна "Поиск файлов" и передача имен, выделенных в списке результатов поиска, в стандартное диалоговое окно выбора файлов.

Результаты поиска

Все файлы, найденные в ходе поиска. Для сортировки списка по значению какого-либо параметра нужно нажать на заголовке соответствующего столбца. Чтобы передать имя найденного файла в стандартное окно выбора файлов, нужно выделить его в списке и нажать "OK". Если в окне выбора файлов разрешается одновременный выбор нескольких файлов, имена всех их можно передать таким образом за один раз.


Диалоговое окно "Добавление/изменение FTP-адресов"

О Команды
О Команды
Диалоговое окно "Добавление/изменение FTP-адресов"
Понятия Процедуры Команды

В этом диалоговом окне задаются FTP-серверы, по которым можно перемещаться в стандартных диалоговых окнах выбора файлов. Для такого перемещения нужно предварительно нажать кнопку "FTP" в левой части окна выбора файлов.

Чтобы вызвать диалоговое окно "Добавление/изменение FTP-адресов" в стандартном диалоговом окне выбора файлов, следует выбрать "Сервис" » "Добавление/изменение FTP-адресов".

Адрес FTP-сервера

Сетевой адрес FTP-сервера (например, ftp.autodesk.com).

Способ входа

Способ входа пользователя на FTP-сервер: анонимно или под заданным именем.

Анонимно

Вход на FTP-сервер в качестве анонимного пользователя. Если FTP-сервер не допускает такого способа входа, необходимо перевести переключатель в положение "С именем" и ввести имя.

Пользовательский

Вход на FTP-сервер с указанием имени пользователя.

Пароль

Пароль для входа на FTP-сервер.

Добавить

Добавление нового FTP-узла в список FTP-серверов, доступных в стандартных диалоговых окнах выбора файлов.

Изменить

Изменение параметров для выбранного FTP-сервера (названия сервера, имени для входа и пароля).

Удалить

Исключение выбранного FTP-узла из списка FTP-серверов, доступных в стандартных диалоговых окнах выбора файлов.

FTP-серверы

Список FTP-серверов, доступных для просмотра в стандартных диалоговых окнах выбора файлов.

URL

Адрес URL выбранного FTP-сервера.


Диалоговое окно "Частичное открытие"

О Команды
О Команды
Диалоговое окно "Частичное открытие"
Понятия Процедуры Команды

Панель "Стандартная:

Меню "Файл": "Открыть"

Ввод команды: открыть

В окне отображаются списки видов и слоев, доступных для загрузки в выбранный чертеж. При работе с большими файлами можно задать минимальный набор геометрических объектов для загрузки в чертеж.

При частичном открытии в чертеж загружаются все имеющиеся именованные объекты и заданная геометрия. Именованными объектами являются блоки, размерные стили, слои, листы, типы линий, текстовые стили, ПСК, виды и конфигурации видовых экранов.

Загрузка объектов по видам

Имя выбранного вида и список доступных видов чертежа. Для загрузки доступны только виды пространства модели. Загрузка объектов пространства листа может быть осуществлена только через слои.

Имя вида

Имя выбранного вида. В чертеж загружаются объекты, одновременно находящиеся на выбранном виде и принадлежащие выбранным слоям.

Список видов

Все виды пространства модели, доступные в файле чертежа. Если выбран какой-либо вид, программа загружает только объекты, которые находятся в его пределах. По умолчанию предлагается вид "Границы". В чертеж загружаются объекты, одновременно находящиеся на выбранном виде и принадлежащие выбранным слоям. В списке можно одновременно выбрать не более одного вида.

Для загрузки дополнительной геометрии в частично открытый чертеж служит команда PARTIALOAD.

Примечание В частично открытый чертеж вместе с заданными геометрическими объектами загружаются все именованные объекты из выбранных видов. В частично открытые чертежи загружаются все виды, но объекты присутствуют только для тех видов, которые были выбраны для загрузки.

Загрузка объектов по слоям

Здесь перечислены все слои, доступные в файле чертежа. В чертеж загружаются объекты, находящиеся на выбранных слоях (как из пространства модели, так и из пространства листа). По умолчанию для загрузки не выбран ни один слой чертежа, нужные слои пользователь должен указать самостоятельно. Если слои для загрузки в чертеж не указаны, то геометрические объекты из выбранных видов в чертеж не загружаются. Слои, зависимые от внешних ссылок, отображаются в списке "Загрузка объектов по слоям", только если при сохранении выбранного чертежа системной переменной VISRETAIN было присвоено значение 1. Слои, созданные во внешнем файле после загрузки ссылки в чертеж, в списке "Загрузка объектов по слоям" не отображаются.

Для загрузки дополнительной геометрии в частично открытый чертеж служит команда PARTIALOAD.

Примечание В частично открытый чертеж вместе с заданными геометрическими объектами загружаются все именованные объекты с выбранных слоев. В частично открытые чертежи загружаются все слои, но объекты присутствуют только для тех слоев, которые были выбраны для загрузки.

Имя слоя

Все слои, доступные в файле чертежа.

Загрузка объектов

Загрузка в открываемый чертеж геометрии с выбранного слоя.

Выбрать все

Загрузка в открываемый чертеж геометрии со всех слоев. Загрузить всю геометрию в чертеж можно также с помощью контекстного меню, вызываемого щелчком правой кнопки мыши.

Очистить все

Отмена загрузки в открываемый чертеж любых слоев. Ни один объект, в том числе указанный для загрузки из вида, не загружается. Для отмены загрузки геометрии в чертеж можно воспользоваться контекстным меню.

Индексы

Индикатор наличия пространственных и/или слоевых индексов в файле чертежа. Системная переменная INDEXCTL управляет сохранением слоевых и пространственных индексов в чертеже.

По пространственному индексу

Управление использованием пространственного индекса в частично открытом чертеже. Пространственный индекс используется при определении загружаемой области чертежа. Это сокращает время, необходимое для открытия чертежа. Если чертеж не имеет пространственного и слоевого индексов, эта опция недоступна.

Пространственный индекс

Показывает наличие или отсутствие в выбранном файле чертежа индекса, который организует объекты в соответствии с их положением в пространстве.

Слоевой индекс

Показывает, есть ли в выбранном файле чертежа список объектов каждого слоя. Слоевой индекс используется при определении загружаемой области чертежа; это сокращает время, необходимое для открытия чертежа.

Выгрузить внешние ссылки при открытии

Выгружает все внешние ссылки при открытии чертежа. При установке флажка сокращается время, требующееся на открытие чертежа. Если частично открывается чертеж, содержащий внешнюю ссылку, то загружается только та ее часть, которая находится в пределах выбранного вида.

Открыть

Открытие чертежа с загрузкой геометрии, принадлежащей выбранному виду и расположенной на заданных слоях.


ОТКРЫТЬ (вариант для командной строки)

О Команды
О Команды
ОТКРЫТЬ (вариант для командной строки)
Понятия Процедуры Команды

Если значение системной переменной FILEDIA равно 0, отображается следующий запрос команды ОТКРЫТЬ.

Имя открываемого чертежа:

При вводе символа тильда (~) в ответ на запрос имени чертежа значение переменной FILEDIA игнорируется, и выводится диалоговое окно "Выбор файла" (стандартное диалоговое окно выбора файлов).


ОТМЕНИТЬ Команда

О Команды
О Команды
ОТМЕНИТЬ Команда
Понятия Процедуры Команды

Отмена действия команд

Панель "Стандартная":

Ввод команды: отменить

Количество отменяемых операций или [Авто/Управление/Начало/Конец/Метка/Обратно]: Ввести положительное число, задать опцию или нажать ENTER для отмены одной операции

При выполнении команды ОТМЕНИТЬ в командной строке выводится имя команды и системной переменной, действие которой отменяется.

Примечание Команда ОТМЕНИТЬ не действует на некоторые команды и системные переменные, в том числе, на команды и системные переменные, которые осуществляют открытие, закрытие и сохранение окон или чертежей, а также выводят информацию на экран, меняют режим отображения графики, регенерируют чертежи или сохраняют их в других форматах.

Количество

Отмена заданного количества предыдущих операций. Действие данной опции эквивалентно многократному вызову команды о.

Авто

Группирование действий одной команды, позволяющее отменять их однократным вызовом команды О. Если опция "Авто" включена, группируются все действия команды от запуска до завершения. Отмена группы действий выполняется так же, как отмена одного действия.

Опция "Авто" команды ОТМЕНИТЬ недоступна при отключении или ограничении возможностей этой команды с помощью опции "Управление".

Задайте состояние режима автоотмены [Вкл/Откл] <текущее>: Ввести вкл или откл или нажать ENTER

Управление

Отключение или ограничение возможностей команды ОТМЕНИТЬ.

Задайте опцию управления отменой [Все/ Ничего/Одну/Объединить] <Все>: Задать опцию или нажать ENTER

Все

Включение всех возможностей команды ОТМЕНИТЬ.

Ничего

Отключение команд О и ОТМЕНИТЬ; при этом теряется вся информация, сохраненная этими командами в сеансе редактирования. Кнопка "Отменить" панели "Стандартная" недоступна.

Опции "Авто", "Начало" и "Метка" недоступны, если задействована опция "Ничего" или "Одну". При попытке вызова отключенной команды ОТМЕНИТЬ выдается следующий запрос:

Задайте опцию управления отменой [Все/Ничего/Одну] <Все>:

Одну

Действие команды ОТМЕНИТЬ ограничивается одной операцией.

Опции "Авто", "Начало" и "Метка" недоступны, если задействована опция "Ничего" или "Одну". Если для команды ОТМЕНИТЬ задана опция "Одну", формат основного запроса этой команды позволяет обратиться к опции "Управление" либо выполнить одну отмену.

Управление/<1>:

Если ввести у, отобразится предыдущий запрос:

Задайте опцию управления отменой [Все/Ничего/Одну] <Все>:

Объединить

Объединение нескольких последовательных команд зумирования и панорамирования в одну операцию для отмены или повтора.

Объединить операции зумирования и панорамирования? [Да/Нет] <Д>: Ввести д или н или нажать ENTER

Начало, Конец

Группирование последовательности действий. При вводе опции "Начало" все последующие действия — вплоть до ввода опции "Конец" — объединяются в группу. При повторном вводе команды отменить началосоздание текущей группы завершается и начинается формирование новой группы. Команды ОТМЕНИТЬ и О воспринимают каждую группу действий как одно действие.

Если ввести команду отменить начало и не вводить отменить конец, опция "Количество" вызывает отмену заданного количества команд, но не далее первой команды группы. Чтобы отменить команды, выполненные до первой команды группы, необходимо использовать опцию "Конец", даже если группа пуста. То же относится и к команде О. Метки отмены, установленные в группе отмены с помощью опции "Метка", удаляются.

Метка, Обратно

Опция "Метка" используется для установки меток отмены. Опция "Обратно" позволяет отменить все команды до первой обнаруженной метки. При пошаговой отмене операций программа сообщает о достижении метки.

Число устанавливаемых меток не ограничено. За один раз опция "Обратно" отменяет все команды до первой обнаруженной метки; после этого метка удаляется. Если метка не обнаружена, выдается следующий запрос:

Данная операция отменит все. OK? <Д>: Ввести д или н или нажать ENTER

Введите д для отмены всех команд текущего сеанса. Введите н, чтобы игнорировать опцию "Обратно".

При использовании числового параметра для отмены нескольких операций, выполнение команды ОТМЕНИТЬ прервется, как только будет достигнута помеченная команда.


ОТРЕЗОК Команда

О Команды
О Команды
ОТРЕЗОК Команда
Понятия Процедуры Команды

Построение отрезков

Панель Рисование:

Меню "Рисование": "Линия"

Ввод команды: отрезок

Первая точка: Указать точку или нажать ENTER для продолжения от последней нарисованной линии или дуги

Следующая точка или [Замкнуть/Отменить]:

Далее

Построение отрезка от конечной точки последнего отрезка.

Если последней нарисованной линией была дуга, то отрезок строится от конечной точки дуги касательно к ней.

Замкнуть

Построение последнего замыкающего отрезка, после чего последовательность отрезков приобретает вид замкнутого многоугольника. Опцию можно использовать после построения последовательности из двух или более отрезков.

Отменить

Удаление последнего сегмента последовательности отрезков.

Каждый последующий ввод о отменяет отрезки в порядке, обратном очередности их построения.


ОЧИСТИТЬ Команда

О Команды
О Команды
ОЧИСТИТЬ Команда
Понятия Процедуры Команды

Очистка чертежа от неиспользуемых именованных элементов (описаний блоков, слоев и т.п.)

Меню "Файл": "Утилиты чертежей" » "Очистка чертежа"

Ввод команды: очистить

Откроется диалоговое окно "Очистка чертежа".

Если по запросу "Команда:" ввести -очистить, команда ОЧИСТИТЬ отображает запросы в командной строке.

Темы:

  • Диалоговое окно "Очистка чертежа"
  • Командная строка ОЧИСТИТЬ


Диалоговое окно "Очистка чертежа"

О Команды
О Команды
Диалоговое окно "Очистка чертежа"
Понятия Процедуры Команды

Меню "Файл": "Утилиты чертежей" » "Очистка чертежа"

Ввод команды: очистить

Список элементов, от которых можно очистить чертеж.

Просмотреть элементы, которые можно удалить

Переключение на дерево с отображением именованных объектов, от которых можно очистить текущий чертеж.

Элементы, не используемые в чертеже

Вывод списка элементов, которые не используются в текущем чертеже и могут быть удалены из него. Для того чтобы увидеть перечень доступных для удаления элементов какого-либо типа, нужно развернуть ветвь списка нажатием левой кнопки мыши на знаке "+" или двойным нажатием на имени типа. Для удаления элемента следует выбрать элемент.

Удаление вложенных элементов происходит, только если выбрать один из следующих параметров:

  • выбрать пункт "Все элементы" или "Блоки"
  • нажать кнопку "Удалить все"

Удаление элементов с подтверждением

Вызов диалогового окна для подтверждения удаления элементов.

Удаление вложенных элементов

Удаление из чертежа всех неиспользуемых именованных объектов, содержащихся внутри других неиспользуемых именованных объектов. Подтвердить или отменить намерение удалить элементы можно в диалоговом окне "Подтвердить очистку".

Просмотреть элементы, которые нельзя удалить

Переключение на дерево с отображением всех именованных объектов, от которых нельзя очищать текущий чертеж.

Элементы, используемые в чертеже

Вывод списка именованных объектов, которые не могут быть удалены при очистке чертежа. Чаще всего такие объекты либо используются в чертеже, либо являются стандартными элементами, удаление которых запрещено. Когда выбираются отдельные именованные объекты, под деревом выводится информация, почему нельзя удалить выбранный элемент.

Пояснение

Отображает подробную информацию о том, почему нельзя удалить выбранный элемент.

Очистить

Удаляет выбранные элементы.

Удалить все

Удаляет все выбранные элементы.


Командная строка ОЧИСТИТЬ

О Команды
О Команды
Командная строка ОЧИСТИТЬ
Понятия Процедуры Команды

Если по запросу "Команда:" ввести -очистить, команда -ОЧИСТИТЬ отображает запросы в командной строке.

Тип неиспользуемых объектов для удаления [Блоки/Рзмстили/Слои/типыЛин/Материалы/Пстили/Формы/Тстили/Млстили/тблстИли/визстили/Зарегприл/Все]: Введите тип объекта, затем з для удаления неиспользуемых приложений или введите в для удаления всех типов именованных объектов, но не приложений

Имена удаляемых элементов <*>: Ввести одно или несколько имен или нажать ENTER для удаления всех элементов

Запрашивать подтверждение на удаление каждого элемента? [Да / Нет]: Ввести д для подтверждения удаления каждого объекта или н для удаления без подтверждения

Команда -ОЧИСТИТЬ удаляет только один уровень вложенности. Следует повторять команду -ОЧИСТИТЬ, пока не останется именованных объектов без ссылок. Команду ОЧИСТИТЬ или -ОЧИСТИТЬ можно использовать в любой момент сеанса работы над чертежом.


П Команды
  • ПАРАМЕТРЫПВ
  • П-ВРАЩ
  • П-КРОМКА
  • П-СДВИГ
  • П-СОЕД
  • ПАКЕТ
  • ПАН
  • ПАНЕЛЬ
  • ПАНЗАДАЧ
  • ПАРАМЕТРЫРП
  • ПАРАМЛИСТ
  • ПБЛОК
  • ПГРАНЬ
  • ПДПРОВЕРИТЬ
  • ПЕРЕАТР
  • ПЕРЕИН
  • ПЕРЕНЕСТИ
  • ПЕРЕСЕЧЕНИЕ
  • ПЕЧАТЬ
  • ПИРАМИДА
  • ПЛАН
  • ПЛАНШЕТ
  • ПЛИНИЯ
  • ПЛОСКПОВ
  • ПЛОСКСНИМОК
  • ПЛОЩАДЬ
  • ПМТЗАКРЫТЬ
  • ПМТНАБОР
  • ПОВЕРНУТЬ
  • ПОВЕРНУТЬ3D
  • ПОВТОРИТЬ
  • ПОДЕЛИТЬ
  • ПОДРОБНОСТИПП
  • ПОДШИВКА
  • ПОДШИВКАОТКЛ
  • ПОКАЗАТЬ
  • ПОКИНУТЬ
  • ПОКМАТ
  • ПОЛЕ
  • ПОЛИТЕЛО
  • ПОЛОСА
  • ПОЛРЕД
  • ПОМОЩНИК
  • ПОМОЩНИКЗАКР
  • ПОРЯДОК
  • ПОСЕЧЕНИЯМ
  • ПРЕДВАР
  • ПРЕОБРАЗОВАТЬ
  • ПРЕОБРВПВРХ
  • ПРЕОБРВТЕЛО
  • ПРЕОБРСПЕЧ
  • ПРЕОБРТСП
  • ПРЕОБРУСТАРМАТЕРИАЛ
  • ПРЕОБРУСТАРСВЕТ
  • ПРИВЯЗКА
  • ПРОВЕРИТЬ
  • ПРОДОЛЖИТЬ
  • ПРОЖЕКТОР
  • ПРОЗРАЧНОСТЬ
  • ПРОСМОТР
  • ПРЯМАЯ
  • ПРЯМОУГ
  • ПСЕВДОРАЗРЕЗ
  • ПСК
  • ПСТИЛЬ
  • ПУБЛ
  • ПУБЛ3DДВФ
  • ПУЛЬТУПР
  • ПУЛЬТУПРЗАКР
  • ПШОТКРЫТЬ
  • ПШСОЗДАТЬ


ПАРАМЕТРЫПВ Команда

П Команды
П Команды
ПАРАМЕТРЫПВ Команда
Понятия Процедуры Команды

Отображает изменение в виде плавного перехода

Ввод команды: параметрыпв

Отобразится диалоговое окно "Просмотр переходов".

Темы:

  • Диалоговое окно "Просмотр переходов"


Диалоговое окно "Просмотр переходов"

П Команды
П Команды
Диалоговое окно "Просмотр переходов"
Понятия Процедуры Команды

Ввод команды: параметрыпв

Задает параметры для плавной смены вида.

"Включить анимацию для перемещения и увеличения"

Включает плавный переход из одного вида в другой при панорамировании и увеличении. (системная переменная VTENABLE)

"Включить анимацию при повороте вида"

Включает плавный переход при изменении угла обзора. (системная переменная VTENABLE)

"Включить анимацию во время сценариев"

Включает плавную смену вида во время выполнения сценариев. (системная переменная VTENABLE)

"Скорость перехода"

Задает скорость плавного перехода видов в миллисекундах.

"Производительность"

Задает минимальную скорость плавного перехода видов в кадрах в секунду. Если отображение плавных переходов не поддерживает эту скорость, для обеспечения производительности используется мгновенный переход.


П-ВРАЩ Команда

П Команды
П Команды
П-ВРАЩ Команда
Понятия Процедуры Команды

Создается сеть вращения вокруг выбранной оси.

Меню "Черчение": » "Моделирование"; » "Сети"; "Сеть вращения"

Ввод команды: п-вращ

Текущая плотность каркаса: SURFTAB1=текущая : SURFTAB2=текущая

Выберите объект для вращения: Выбрать отрезок, дугу, круг, 2М или 3D полилинию

Выберите объект, определяющий ось вращения: Выбрать отрезок или незамкнутую 2М или 3D полилинию

Сеть образуется вращением определяющей кривой вокруг выбранной оси. Определяющая кривая задает N-направление сети. Если выбран круг или замкнутая полилиния, то полученная сеть будет замкнута в направлении N.

Ось вращения определяется вектором от первой вершины полилинии к последней вершине. Все промежуточные вершины игнорируются. Ось вращения задает направление M сети.

Начальный угол <0>: Ввести значение или нажать ENTER

Центральный угол (+=против часовой стрелки, -=по часовой стрелке) <360>: Ввести значение или нажать ENTER

Начальный угол

Ненулевое значение определяет смещение начала сети вращения от определяющей кривой.

Центральный угол

Задается расстояние поворота сети вокруг оси вращения.

Начальный угол определяет смещение начала сети вращения от определяющей кривой. Центральный угол задает угол вращения кривой вокруг оси.

Если центральный угол меньше 360 градусов, то поверхность будет разомкнутой.

Точка указания оси вращения определяет направление вращения. Каждая из сетей в приведенных ниже примерах создана с заданием начального угла 0 градусов и центрального угла 90 градусов.

Плотность генерируемой сети управляется системными переменными SURFTAB1 и SURFTAB2. SURFTAB1 определяет количество линий табуляции, вычерчиваемых в направлении вращения. Если определяющей кривой является отрезок, дуга, круг или сглаженная сплайном полилиния, то SURFTAB2 определяет количество линий табуляции, вычерчиваемых для разделения кривой на одинаковые интервалы Если кривая является полилинией, не сглаженной сплайном, то линии табуляции вычерчиваются по концам прямолинейных сегментов, и каждый дуговой сегмент делится на число интервалов, определяемое значением.


П-КРОМКА Команда

П Команды
П Команды
П-КРОМКА Команда
Понятия Процедуры Команды

Построение трехмерных полигональных сетей

Меню "Рисование": "Моделирование" » подменю "Сети" » подменю "Сеть по кромкам"

Ввод команды: п-кромка

Текущая плотность каркаса: SURFTAB1=текущая SURFTAB2=текущая

Выбрать объект -- 1-ю кромку поверхности:

Выбрать объект -- 2-ю кромку поверхности:

Выбрать объект -- 3-ю кромку поверхности:

Выбрать объект -- 4-ю кромку поверхности:

Необходимо выбрать четыре смыкающиеся кромки, определяющие участок сети. Ограничивающие кривые могут представлять собой отрезки, дуги, сплайны, а также разомкнутые двумерные и трехмерные полилинии. Кромки должны смыкаться в конечных точках и образовывать топологически прямоугольный контур.

Кромки могут быть выбраны в любом порядке. Первая кромка (SURFTAB1) определяет направление M генерируемой сети (от конечной точки, ближайшей к точке указания, к другому концу). Две кромки, смежных с первой (SURFTAB2), задают направление N сети.


П-СДВИГ Команда

П Команды
П Команды
П-СДВИГ Команда
Понятия Процедуры Команды

Создание сети сдвига на основе определяющей кривой и вектора направления

Меню "Рисование": "Моделирование" » "Сети" » "Сеть сдвига"

Ввод команды: п-сдвиг

Выберите объект - определяющую кривую:

Определяющая кривая задает аппроксимированную поверхность многоугольной сети. Определяющей кривой может быть отрезок, дуга, круг, эллипс, а также 2D или 3D полилиния. Построение сети начинается в точке определяющей кривой, ближайшей к точке выбора.

Выберите объект - вектор направления: Выбрать отрезок или незамкнутую полилинию

Учитываются только первая и последняя точки полилинии; все промежуточные вершины игнорируются. Вектор направления задает направление и длину выдавливаемой формы. Направление выдавливания определяется конечной точкой полилинии или отрезка. Исходная определяющая кривая вычерчивается широкими линиями, которые дают наглядное представление о построении сети сдвига на основе вектора направления.

С помощью команды П-СДВИГ строится 2n полигональная сеть, где n определяется системной переменной SURFTAB1. Направление по M совпадает с вектором направления и всегда имеет размерность 2. Направление по N лежит вдоль определяющей кривой. Если определяющая кривая представляет собой отрезок, дугу, круг, эллипс или сглаженную сплайнами полилинию, линии сдвига строятся через равные интервалы, длина которых определяется системной переменной SURFTAB1. Если определяющая кривая является полилинией, не сглаженной сплайнами, линии сдвига строятся через конечные точки прямых сегментов, а каждый дуговой сегмент делится на интервалы, длина которых определяется системной переменной SURFTAB1.


П-СОЕД Команда

П Команды
П Команды
П-СОЕД Команда
Понятия Процедуры Команды

Создается сеть соединений между двумя кривыми

Меню "Черчение": » "Моделирование"; » "Сети"; "Сеть соединения"

Ввод команды: п-соед

Текущая плотность каркаса: SURFTAB1=текущая

Выберите первую определяющую кривую:

Выберите вторую определяющую кривую:

Два указанных объекта определяют кромки сети соединения. Ими могут быть точки, отрезки, сплайны, дуги, круги или полилинии. Если одна граница замкнута, то и другая граница также должна быть замкнутой. Одной из границ может быть точка, а другой разомкнутая или замкнутая кривая, однако точкой может быть только один из определяющих объектов. Отсчет вершин начинается с конечных точек кривых, ближайших к точкам их указания.

Для замкнутых кривых точки указания не играют роли. Если кривая является окружностью, то сеть соединения начинается в точке квадранта "0 градусов", определяемой текущей осью X, с приращением на текущее значение системной переменной SNAPANG. Если кривая является замкнутой полилинией, то сеть соединения начинается в последней вершине и проходит по сегментам полилинии в обратном направлении. Эти различия могут привести к ошибке при создании сети соединения между окружностью и замкнутой полилинией. Поэтому вместо окружностей предпочтительнее использовать замкнутые полилинии.

Сеть соединения строится в виде многоугольной сети 2 x N. Команда П-СОЕД размещает половину вершин сети с равными интервалами вдоль одной определяющей кривой, а остальные вершины - с равными интервалами вдоль другой кривой. Число интервалов определяется системной переменной SURFTAB1. Оно одинаково для обеих кривых, поэтому, если длины определяющих кривых различны, расстояние между вершинами на них будет разным.

Направление N сети проходит вдоль граничных кривых. Если обе граничные кривые замкнуты (либо одна замкнута, а другая является точкой), то полученная многоугольная сеть будет замкнута в направлении N, и N будет равно SURFTAB1. Если обе границы не замкнуты, то N равняется SURFTAB1 + 1, так как для деления кривой на n частей требуются n + 1 табуляций.

Полигональная сеть создается путем выбора объектов в одинаковых концах.

Самопересекающаяся полигональная сеть создается путем выбора объектов в разных концах.


ПАКЕТ Команда

П Команды
П Команды
ПАКЕТ Команда
Понятия Процедуры Команды

Выполнение последовательности команд из пакетного файла

Меню "Сервис": "Пакет"

Ввод команды: пакет (или 'пакет для вызова в прозрачном режиме)

Откроется диалоговое окно "Выбор файла пакета" (стандартное диалоговое окно выбора файлов). В нем задается имя пакетного файла, используемое при запуске.

Если значение системной переменной FILEDIA равно 0, при запуске команды ПАКЕТ в командной строке отображается следующий запрос.

Имя пакетного файла <текущее>:


ПАН Команда

П Команды
П Команды
ПАН Команда
Понятия Процедуры Команды

Перемещение изображения на текущем видовом экране

Панель "Стандартная"

Меню "Вид": "Панорамирование" » "В реальном времени"

Контекстное меню: При отсутствии выбранных объектов нажать правую кнопку мыши в области рисования и выбрать "Панорамирование".

Ввод команды: пан (или 'пан для прозрачного вызова)

Отображается следующий запрос; можно выполнить панорамирование чертежа в реальном времени.

Нажать ESC или ENTER для выхода или правую кнопку мыши для вывода контекстного меню.

Если по запросу "Команда" ввести -пан, команда ПАН отображает альтернативные запросы в командной строке, и можно задавать смещение для панорамирования изображения на чертеже.

Темы:

  • Панорамирование в реальном времени
  • Командная строка ПАН
  • Контекстное меню режима панорамирования


Панорамирование в реальном времени

П Команды
П Команды
Панорамирование в реальном времени
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Вид": "Панорамирование" » "В реальном времени"

Контекстное меню: При отсутствии выбранных объектов нажать правую кнопку мыши в области рисования и выбрать "Панорамирование".

Ввод команды: пан (или 'пан для прозрачного вызова)

Курсор принимает форму кисти руки. Удерживая в нажатом состоянии кнопку выбора устройства указания, можно зафиксировать курсор в его текущей позиции относительно системы координат видового экрана. При перемещении курсора по видовому экрану в том же направлении будет перемещаться и изображение.

При достижении логической границы (края области чертежа), к изображению курсора добавляется изображение ограничителя в виде полоски. В зависимости от нахождения логической границы вверху, внизу или сбоку чертежа полоска является либо горизонтальной (вверху или внизу), либо вертикальной (слева или справа).

При отпускании кнопки выбора устройства указания панорамирование прекращается. Пользователь может отпустить кнопку выбора, переместить курсор в другую позицию на чертеже, а затем нажать кнопку выбора и продолжить панорамирование изображения с новой позиции.

Для останова панорамирования в любое время следует нажать ENTER или ESC.


Командная строка ПАН

П Команды
П Команды
Командная строка ПАН
Понятия Процедуры Команды

Если по запросу "Команда" ввести -пан, команда ПАН выводит альтернативные запросы в командную строку.

ПАН данной версии действует двумя способами. Перемещение можно задать единственной точкой, обозначающей перемещение чертежа относительно текущего положения, или (более распространенный вариант) двумя точками с вычислением перемещения от первой точки к второй точке.

Нельзя использовать команду ПАН прозрачно во время работы команд ТЗРЕНИЯ или ДВИД, а также в процессе выполнения другой команды ПОКАЗАТЬ, ПАН или ВИД.

Базовая точка или перемещение: Указать точку (1)

Указываемая пользователем точка задает либо величину перемещения чертежа, либо позицию на чертеже, от которой это перемещение должно отсчитываться (это зависит от того, какой ответ дан на последующий запрос).

Вторая точка: Нажать ENTER или указать точку (2)

При нажатии ENTER чертеж перемещается на величину, заданную в ответ на запрос "Базовая точка или перемещение". Например, если ввести координаты 2,2 в ответ на первый запрос и нажать ENTER в ответ на второй запрос, чертеж переместится на 2 единицы в направлении X и на 2 единицы в направлении Y. Если точка указана в ответ на запрос "Вторая точка", первая точка переместится на место второй точки.


Контекстное меню режима панорамирования

П Команды
П Команды
Контекстное меню режима панорамирования
Понятия Процедуры Команды

Для вызова контекстного меню режима панорамирования нужно в ходе выполнения команды ПАН нажать правую кнопку мыши в области рисования.

Выход

Завершение работы команды ПАН или ПОКАЗАТЬ.

Пан

Переключение на команду ПАН.

Показать

Переключение на команду ПОКАЗАТЬ с опцией "В реальном времени".

3D орбита

Переключение на команду 3DОРБИТА.

Показать рамкой

Показ области чертежа, заключенной в заданной пользователем прямоугольной рамке.

Предыдущий вид

Восстановление исходного вида.

Показать в границах

Показ изображения в границах чертежа.


ПАНЕЛЬ Команда

П Команды
П Команды
ПАНЕЛЬ Команда
Понятия Процедуры Команды

Отображение, скрытие и настройка панелей

Меню "Вид": "Панели"

Контекстное меню: Нажмите правой кнопкой мыши на любой панели и выберите "Настройка".

Ввод команды: панель

Откроетсядиалоговое окно "Настройка интерфейса пользователя" (см. НПИ).

Если в ответ на подсказку "Команда:" ввести -панель, будет вызван вариант команды ПАНЕЛЬ, использующий интерфейс командной строки.

Темы:

  • ПАНЕЛЬ (вариант для командной строки)


ПАНЕЛЬ (вариант для командной строки)

П Команды
П Команды
ПАНЕЛЬ (вариант для командной строки)
Понятия Процедуры Команды

Если в ответ на подсказку «Команда:» ввести -панель, будет вызван вариант команды ПАНЕЛЬ, использующий интерфейс командной строки.

Имя панели или [ВСЕ]: Ввести имя или ввести все

Имя панели

Выбор панели для отображения, скрытия или размещения.

Введите правильное имя панели. Если загружено меню по умолчанию, доступны следующие имена:

3d_орбита | листы | раскрас | ucs_ii
стандарты_оформления | редактирование | тела | вид
размеры | modify_ii | редактирование_тела | видовые_экраны
рисование | object_snap | стандартная | web
порядок_прорисовки | свойства | стили | рабочие_пространства
сведения | РедСсыл | поверхности | зумирование
вставка | ссылка | текст |
слои | тонирование | пск |

Задать опцию [пОказать/Скрыть/сЛева/сПрава/сВерху/сНизу/плАвающая] <Показать>: Задать опцию или нажать ENTER

Показать

Отображение указанной панели.

Скрыть

Скрытие указанной панели.

Слева

Закрепление указанной панели в левой части экрана.

Новое положение (гориз, вертик) <0,0>: Указать положение или нажать ENTER

Запрос "Новое положение" предназначен для горизонтального и вертикального позиционирования панели в области закрепления панелей. Первое значение указывает положение по горизонтали. Второе значение указывает положение по вертикали.

Вправо

Закрепление заданной панели в правой части экрана.

Новое положение (гориз, вертик) <0,0>: Указать положение или нажать ENTER

Запрос "Новое положение" предназначен для горизонтального и вертикального позиционирования панели в области закрепления панелей. Первое значение указывает положение по горизонтали. Второе значение указывает положение по вертикали.

Сверху

Закрепление заданной панели в верхней части экрана.

Новое положение (гориз, вертик) <0,0>: Указать положение или нажать ENTER

Запрос "Новое положение" предназначен для горизонтального и вертикального позиционирования панели в области закрепления панелей. Первое значение указывает положение по горизонтали. Второе значение указывает положение по вертикали.

Снизу

Закрепление заданной панели в нижней части экрана.

Новое положение (гориз, вертик) <0,0>: Указать положение или нажать ENTER

Запрос "Новое положение" предназначен для горизонтального и вертикального позиционирования панели в области закрепления панелей. Первое значение указывает положение по горизонтали. Второе значение указывает положение по вертикали.

Плавающая

Преобразование панели из закрепленной в плавающую.

Новое положение (экранные координаты) <0,0>: Указать положение или нажать ENTER

Количество рядов в панели <1>: Ввести значение

В ответ на запрос "Новое положение" указывается положение плавающей панели (в экранных координатах). Запрос "Количество рядов в панели" определяет количество рядов кнопок в плавающей панели.

Все

Отображение или скрытие всех панелей.

Задайте опцию [Показать/Скрыть]: Ввести п или с

Показать

Отображение всех панелей.

Скрыть

Скрытие всех панелей.


ПАНЗАДАЧ Команда

П Команды
П Команды
ПАНЗАДАЧ Команда
Понятия Процедуры Команды

Управление отображением чертежей на панели задач Windows

Ввод команды: панзадач

Новое значение Панель задач<0>: Ввести 1, чтобы несколько открытых чертежей отображались на панели задач Windows как отдельные элементы

Если установлено значение по умолчанию (0), на панели задач Windows отображается только имя текущего чертежа.


ПАРАМЕТРЫРП Команда

П Команды
П Команды
ПАРАМЕТРЫРП Команда
Понятия Процедуры Команды

Задание параметров рабочих пространств

Ввод команды: параметрырп

Откроется диалоговое окно "Параметры рабочего пространства".

Темы:

  • Диалоговое окно "Параметры рабочего пространства"


Диалоговое окно "Параметры рабочего пространства"

П Команды
П Команды
Диалоговое окно "Параметры рабочего пространства"
Понятия Процедуры Команды

Ввод команды: параметрырп

Задание параметров отображения, сохранения и порядка следования меню рабочего пространства.

Мое рабочее пространство =

Вывод списка рабочих пространств, из которого можно выбрать рабочее пространство, чтобы назначить его кнопке панели "Мое рабочее пространство".

Отображение и порядок следования меню

Определение имени рабочего пространства, которое будет отображаться на панели и в меню "Рабочие пространства", порядка следования имен рабочих пространств, а также будет ли добавляться разделительная линия между каждым именем рабочего пространства. Рабочие пространства, отображаемые в этом окне, а также на панели и в меню "Рабочие пространства", включают текущее рабочее пространство (отмеченное флажком на панели и в меню) и рабочее пространство, определенное пользователем с помощью опции "Мое рабочее пространство=", независимо от настроек отображения.

Вверх

Перемещение имен рабочих пространств вверх в порядке отображения.

Вниз

Перемещение имен рабочих пространств вниз в порядке отображения.

Разделитель

Добавление разделителя между именами рабочих пространств.

Не сохранять изменения в рабочем пространстве

Позволяет не сохранять внесенные в рабочее пространство изменения при переключении на другое рабочее пространство

Автоматически сохранять изменения

Сохранение внесенных в рабочее пространство изменений при переключении на другое рабочее пространство


ПАРАМЛИСТ Команда

П Команды
П Команды
ПАРАМЛИСТ Команда
Понятия Процедуры Команды

Управление параметрами компоновки, устройством печати, форматом бумаги и другими настройками для каждого нового листа

Меню "Файл": Диспетчер наборов параметров листов

Контекстное меню: Нажать правую кнопку мыши на ярлыке вкладки "Модель" или "Лист" и выбрать "Диспетчер параметров листа".

Ввод команды: парамлист

Откроется диалоговое окно "Диспетчер наборов параметров листов".

Темы:

  • Диспетчер наборов параметров листов
  • Диалоговое окно "Создание набора параметров листа"
  • Диалоговое окно "Параметры листа"
  • Диалоговое окно "Изменения в файле параметров принтера" (Параметры листа)
  • Диалоговое окно "Импорт набора параметров листов"


Диспетчер наборов параметров листов

П Команды
П Команды
Диспетчер наборов параметров листов
Понятия Процедуры Команды

Панель "Листы":

Меню "Файл": Диспетчер наборов параметров листов

Контекстное меню: Нажать правую кнопку мыши на ярлыке вкладки "Модель" или "Лист" и выбрать "Диспетчер параметров листа".

Ввод команды: парамлист

Задание параметров компоновки для текущего листа чертежа или листа подшивки. Существует возможность создавать именованные наборы параметров листа, модифицировать ранее созданные наборы и импортировать свойства листов из других чертежей.

Текущий лист / Текущая подшивка

Указывается текущий лист, к которому будут применены определяемые параметры. Если диалоговое окно "Диспетчер наборов параметров листов" открыто из Диспетчера подшивок, отображается имя текущей подшивки. Если диалоговое окно "Диспетчер наборов параметров листов" открыто из листа чертежа, отображается имя текущего листа.

Значок листа

Отображается, когда диалоговое окно "Диспетчер наборов параметров листов" открывается из листа чертежа.

Значок подшивки

Отображается, когда диалоговое окно "Диспетчер наборов параметров листов" открывается из Диспетчера подшивок.

Наборы параметров листа

Отображает текущий набор параметров листа; позволяет изменить текущий набор, создать новый набор, изменить параметры существующих наборов и импортировать параметры листа из других чертежей.

Текущий набор

Имя набора параметров, применяемого к текущему листу. Выводится сообщение "Неприменимо" в случаях, когда Диспетчер наборов параметров листов открыт из Диспетчера подшивок, поскольку нельзя применить параметры листа к уже созданной подшивке.

Список наборов параметров листов

Наборы параметров листов, применимых к текущему листу или при публикации подшивки.

Если Диспетчер наборов параметров листов открыт для текущего листа, текущий набор параметров выделен. Список включает в себя все именованные наборы параметров и листы, доступные в текущем чертеже. Листы, к которым уже применены именованные наборы параметров, отмечены звездочками; например, *Лист 1 (Масштабирование со вписыванием)*. Двойным нажатием левой кнопки мыши на элементе списка данный набор параметров назначается текущему листу.

Если Диспетчер наборов параметров листов открыт из Диспетчера подшивок, список наборов содержит только именованные наборы параметров, для которых в файле переопределений параметров (шаблоне чертежа [.dwt]) область печати имеет значение "Лист" или "Границы". Первая позиция в списке отведена набору параметров по умолчанию. Любой из этих наборов параметров листа может быть временно применен в команде ПУБЛ.

Контекстное меню содержит опции для удаления и переименования наборов параметров листов.

Установить

Установка выбранного набора параметров как текущего для листа. Кнопка недоступна, если в списке выбран сам текущий лист. Опция "Установить" недоступна для подшивок.

Новый

Отображает диалоговое окно "Создание набора параметров листа", в котором можно ввести имя нового именованного набора параметров и указать набор, принимаемый за основу.

Изменить

Отображает диалоговое окно "Параметры листа", в котором можно редактировать параметры для выбранной страницы.

Импорт

Отображает диалоговое окно "Загрузка набора параметров листа из файла" (стандартное диалоговое окно выбора файлов), в котором можно выбрать файл чертежа (DWG), файл DWT или файл формата графического обмена (DXF)™, из которого импортируются один или несколько параметров листа. При выборе формата файла DWT в диалоговом окне "Загрузка набора параметров листа из файла" автоматически открывается папка "Шаблон". После нажатия "ОК" открывается диалоговое окно "Импорт наборов параметров листов".

Сведения о выделенном наборе параметров

Вывод информации о выбранном наборе параметров.

Имя устройства

Имя устройства печати, указанное в выбранном на текущий момент наборе параметров листа.

Плоттер

Тип устройства печати, указанный в выбранном на текущий момент наборе параметров листа.

Формат печати

Размер и ориентация носителя для текущего набора параметров листа.

Подключение

Отображается физическое расположение устройства вывода, указанного в выбранном на текущий момент наборе параметров листа.

Описание

Текстовое пояснение к устройству вывода, указанному в выбранном на текущий момент наборе параметров листа.

Показывать при создании нового листа

Определяет, показывать ли диалоговое окно "Параметры листа" при переходе на другую вкладку или при создании нового листа.

Для сброса данной функции можно выбрать опцию "Показывать диалоговое окно параметров листа для новых листов" во вкладке "Экран" диалогового окна "Настройка".


Диалоговое окно "Создание набора параметров листа"

П Команды
П Команды
Диалоговое окно "Создание набора параметров листа"
Понятия Процедуры Команды

Панель "Листы":

Меню "Файл": Диспетчер наборов параметров листов

Контекстное меню: Нажать правую кнопку мыши на ярлыке вкладки "Модель" или "Лист" и выбрать "Диспетчер параметров листа".

Ввод команды: парамлист

Определяет имя для нового набора параметров, а также набор параметров, служащий основой.

Имя набора параметров листа

Имя нового набора параметров листа.

На основе

Определяет набор, параметры которого по умолчанию применяются к новому набору параметров листа. После нажатия "ОК" открывается диалоговое окно "Параметры страницы", где определены параметры набора. Если необходимо, параметры могут изменяться.

Если окно "Создание набора параметров листа" открыто из окна Диспетчер подшивок, список параметров содержит только именованные наборы параметров из файла переопределений.

<Нет>

Указывает, что ни один набор параметров не берется за основу. Параметры по умолчанию, отображаемые в диалоговом окне "Параметры страницы", могут быть изменены.

<Стандартное устройство вывода>

Указывает, что в качестве устройства вывода берется устройство, заданное на вкладке "Печать/Публикация" диалогового окна "Настройка".

<Предыдущая печать>

Определяет для нового набора параметров устройство вывода, использовавшееся в последнем задании на печать.


Диалоговое окно "Параметры листа"

П Команды
П Команды
Диалоговое окно "Параметры листа"
Понятия Процедуры Команды

Панель "Листы":

Меню "Файл": Диспетчер наборов параметров листов

Контекстное меню: Нажать правую кнопку мыши на ярлыке вкладки "Модель" или "Лист" и выбрать "Диспетчер параметров листа".

Ввод команды: парамлист

Задание параметров компоновки листов и их печати. Диалоговое окно "Параметры листа" появляется в следующих случаях.

  • При создании нового набора параметров листа через Диспетчер наборов параметров листов
  • При изменении существующих настроек через Диспетчер наборов параметров листов

Задаваемые настройки параметров листа записываются вместе с листом и могут применяться к другим листам или импортироваться в другие чертежи.

В названии диалогового окна "Параметры листа" указывается имя текущего листа или подшивки.

Наборы параметров листа

Имя текущего набора параметров.

Имя

Имя текущего набора параметров.

Значок

Отображает значок DWG, если диалоговое окно "Параметры страницы" открыто из листа, и значок подшивки, если диалоговое окно "Параметры страницы" открыто из Диспетчер подшивок.

Принтер/плоттер

Сконфигурированное устройство печати для использования при распечатке (публикации) листов чертежа или подшивки.

Имя

Список доступных PC3-файлов или системных устройств печати, выбираемых для вывода на печать (публикации) текущего листа чертежа или подшивки. Значок спереди имени устройства обозначает его в качестве PC3-файла или системного принтера.

  • Значок PC3-файла: Определяет PC3-файлы.
  • Значок системного принтера: Определяет системные принтеры.

Свойства

ОтображаетРедактор параметров плоттера (редактор PC3), в котором можно просмотреть или изменить текущую конфигурацию плоттера, задать параметры портов, устройства и носителя.

После внесения изменений в PC3-файл с помощью редактора параметров плоттера открывается диалоговое окно "Изменения в файле параметров плоттера".

Плоттер

Отображение устройства печати, указанного в выбранном на текущий момент наборе параметров листа.

Подключение

Физическое размещение выбранного устройства печати для текущего набора параметров листа.

Описание

Текстовое пояснение к устройству вывода, указанному в выбранном на текущий момент наборе параметров листа. Для редактирования пояснения применяется Редактор параметров плоттера.

Частичный образец

Точное отображение действительной области печати, соотносимое с форматом бумаги и печатаемой областью. На образце подписаны размеры формата листа и обозначена область печати.

Формат листа

Список стандартных форматов, разрешенных для применения в выбранном устройстве печати. Если плоттер еще не выбран, в списке перечислены все поддерживаемые форматы листов.

Если выбранный плоттер не поддерживает формат текущего листа, выдается сообщение, и возможен выбор формата листа по умолчанию для плоттера либо пользовательский формат листа.

Сразу после создания PC3-файла параметров плоттера (в Мастере установки плоттеров) устройство настраивается на свой формат по умолчанию. Подробнее о Мастере установки плоттеров см. раздел Настройка плоттеров и принтеров документа Руководство по драйверам и устройствам. Заданный в диалоговом окне "Параметры листа" формат сохраняется вместе с листом и имеет приоритет перед указанным в PC3-файле.

Область печати, определенная в соответствии с типом печатающего устройства и форматом листа, выделяется в листе штриховой линией.

При выводе в растровый формат (например, в BMP- или TIFF-файл) размеры чертежа отображаются не в дюймах/миллиметрах, а в пикселах.

Область печати

Задание выводимой на печать части чертежа. Опция "Что печатать" определяет, какая часть чертежа будет напечатана.

Лист/Пределы

При распечатке листа печатаются все объекты в пределах области печати в листе указанного формата. Началом чертежа служит точка листа с координатами 0,0.

При распечатке из вкладки "Модель" печатается вся область чертежа, определяемая границами сетки. Если вид на текущем видовом экране отличен от вида в плане, опция работает аналогично опции "Границы".

Границы

Вывод на плоттер той части чертежа, которая в данный момент содержит объекты. Печатаются все объекты текущего пространства. Чертеж может быть регенерирован для пересчета границ перед печатью.

Показать

Печать вида в текущем видовом экране (для вкладки "Модель") или вида в текущем пространстве листа во складке листа (для вкладки листа).

Вид

Печать вида, предварительно описанного и сохраненного командой ВИД. Возможен выбор именованного вида из списка. Если в чертеже нет именованных видов, опция недоступна.

Рамка

Печать фрагмента чертежа, ограниченного прямоугольной рамкой. После того как указаны два противоположных угла печатаемой области, становится доступной кнопка "Рамка".

Нажав кнопку "Рамка", пользователь либо указывает два противоположных угла на экране, либо вводит их координаты.

Команда: Первый угол: Указать точку

Противоположный угол: Указать точку

Смещение от начала

Определяет смещение области печати относительно левого нижнего угла печатаемой страницы или края бумаги, в зависимости от установки параметра "Отсчет смещения чертежа" (диалоговое окно "Настройка", вкладка "Печать/Публикация"). Значение опции (в скобках) добавляется к заголовку группы "Смещение от начала" окна "Параметры листа".

Область печати листа чертежа определяется выбранным устройством вывода и отображается в листе штриховой линией. При выборе другого устройства вывода область печати может измениться.

Возможно смещение геометрии на листе путем ввода положительного или отрицательного значения в окна смещения по осям X и Y. Для плоттера задаются значения на бумаге в дюймах или миллиметрах.

Центрировать

Автоматическое определение смещений по X и Y так, чтобы чертеж оказался в центре чертежа на буиаге. Данная опция не доступна, если в качестве области печати выбран "Лист".

X

Указывается начальная точка чертежа в направлении X по отношению к точке, определяемой текущим значением опции "Отсчет смещения чертежа".

Y

Указывается начальная точка чертежа в направлении Y по отношению к точке, определяемой текущим значением опции "Отсчет смещения чертежа".

Масштаб печати

Управление масштабом выводимых на печать единиц чертежа. По умолчанию для листа устанавливается масштаб 1:1. Для вкладки "Модель" по умолчанию устанавливается значение масштаба "Вписать".

Примечание Если в группе "Область печати" установлен параметр "Лист", печать листа произойдет при значении 1:1, игнорируя значение параметра "Масштаб".

Вписать

Масштаб чертежа изменяется с целью его вписывания в выбранный размер бумаги и отображается пользовательский масштабный коэффициент в окнах "Масштаб", "Дюйм =" и "Единицы".

Масштаб

Точное значение масштаба печати. Пользовательский является нестандартным масштабом. Он задается путем ввода количества дюймов (или миллиметров), приравниваемого числу единиц чертежа.

Примечание Можно изменить список масштабов с помощью команды СПИСМАСШТРЕД.

Дюйм =/мм =/пиксел =

Определяет количество дюймов, миллиметров или пикселов, приравниваемое указанному числу единиц чертежа.

Дюйм/мм/пиксел

Задание дюймов или мм для отображения единиц в диалоговом окне "Печать". Значение по умолчанию зависит от формата листа и изменяется при каждом выборе нового формата. Значение в пикселах доступно только при выборе растрового вывода.

Единицы

Определяет соответствие единиц чертежа установленному числу единиц чертежа в дюймах, миллиметрах или пикселах.

Масштабировать веса линий

Масштабирование весов линий пропорционально масштабу печати. Веса линий, как правило, обозначают ширину линий объектов чертежа, и печать для них выполняется с шириной линий, не зависимой от масштаба печати.

Таблица стилей печати (Назначение перьев)

Установка текущей таблицы стилей печати, редактирование имеющихся и создание новых таблиц стилей печати.

Имя (без маркировки)

Таблица стилей печати, назначенная текущей вкладке "Модель" или вкладке листа, и список доступных на текущий момент таблиц стилей печати.

Если выбрать "Создать", вызывается Мастер стилей печати, в котором можно создать новую таблицу стилей печати. Вид Мастера определяется типом стилей печати, используемых в текущем чертеже (цветозависимые или именованные).

Изменить

Вызов диалогового окна Редактор таблиц стилей печати, где производится просмотр и редактирование стилей, входящих в назначенную таблицу стилей печати.

Показать стили печати

Определяет, отображаются ли на экране свойства стилей печати, назначенных объектам.

ВЭкраны с раскрашиванием

Задается способ вывода на печать раскрашенных и тонированных видовых экранов и определяются их уровни разрешения и количество точек на дюйм (т/дюйм).

Визуализация при печати

Способ вывода видов на печать. Для того чтобы задать этот параметр для видового экрана во вкладке листа, нужно выбрать видовой экран, а затем из меню "Сервис" выбрать "Свойства".

Для видового экрана на вкладке "Модель" существует возможность выбора одного из следующих параметров:

  • Обычный: Объекты выводятся на печать так же, как они выглядят на экране.
  • Каркас: На печать выводятся только контуры объектов независимо от того, как они выглядят на экране.
  • Скрытие: Скрытые линии на печать не выводятся, независимо от того, видны ли они на экране.
  • 3D скрытие: Объекты печатаются с применением визуального стиля "3D скрытие" независимо от способа отображения объектов на экране.
  • 3D каркас Объекты печатаются с применением визуального стиля "3D каркас" независимо от способа отображения объектов на экране.
  • Концептуальный Объекты печатаются с применением визуального стиля "Концептуальный" независимо от способа отображения объектов на экране.
  • Реалистичный Объекты печатаются с применением визуального стиля "Реалистичный" независимо от способа отображения объектов на экране.
  • Тонирование: Выполняется печать объектов с тонированием независимо от того, как они выглядят на экране.

Качество

Задание разрешения для печати раскрашенных и тонированных видовых экранов.

Для видового экрана существует возможность выбора одного из следующих параметров:

  • Черновое: Тонированные и раскрашенные виды пространства модели печатаются в каркасном режиме.
  • Просмотр: Тонированные и раскрашенные виды пространства модели печатаются с разрешением 1/4 от текущего разрешения устройства печати, максимум 150 т/дюйм.
  • Нормальное: Тонированные и раскрашенные виды пространства модели печатаются с разрешением 1/2 от текущего разрешения устройства печати, максимум 300 т/дюйм.
  • Презентационное: Тонированные и раскрашенные виды пространства модели печатаются с текущим разрешением устройства печати, максимум 600 т/дюйм.
  • Максимум: Тонированные и раскрашенные виды пространства модели печатаются с текущим разрешением устройства печати без установки максимального ограничения.
  • Пользовательское: Тонированные и раскрашенные виды пространства модели печатаются с разрешением, которое задается в поле "Т/дюйм". Задаваемое пользователем разрешение не может быть больше текущего разрешения устройства печати.

Т/дюйм

Задание разрешения (т/дюйм) для печати раскрашенных и тонированных видов. Задаваемое пользователем разрешение не может быть больше текущего разрешения устройства печати. Данное поле доступно для редактирования, только если в списке "Качество" выбрано "Пользовательское".

Опции печати

Параметры, относящиеся к весам линий, стилям печати, раскрашенным видовым экранам и порядку вывода объектов на печать.

Учитывать веса линий

Определяет, учитываются ли при печати веса линий, назначенные объектам и слоям. Данная опция недоступна, если выбрана опция "Учитывать стили печати".

Учитывать стили печати

Определяет, учитываются ли при печати стили печати, применяемые к объектам и слоям. При выборе данной опции автоматически активизируется также опция "Учитывать веса линий".

Объекты листа последними

Печать объектов пространства модели в первую очередь. Геометрия пространства листа обычно печатается перед геометрией пространства модели.

Скрывать объекты листа

Определяет, применяется ли операция СКРЫТЬ к объектам на видовых экранах листа. Доступно только для вкладок-листов. Эффект от данной настройки проявляется в образце для предварительного просмотра, но не в листе.

Ориентация чертежа

Задание ориентации чертежа на листе для плоттеров, поддерживающих ее книжный и альбомный варианты.

Книжная

Чертеж ориентируется таким образом, что при печати верх страницы соответствует короткой стороне листа.

Альбомная

Чертеж ориентируется таким образом, что при печати верх страницы соответствует длинной стороне листа..

Перевернуть

Поворот чертежа на 180 градусов.

Значок

Указывает ориентацию выбранной бумаги, и задает ориентацию чертежа на странице в виде, совпадающем с расположением букв на бумаге.

Примечание Ориентацию чертежа при печати можно задать также в системной переменной PLOTROTMODE.

Просмотр

Вызов команды ПРЕДВАР для предварительного просмотра чертежа на экране в таком виде, в каком он появится на бумаге. Для выхода из режима предварительного просмотра и возврата в диалоговое окно "Параметры страницы" нажать ESC или ENTER либо нажать правую кнопку мыши и выбрать из контекстного меню пункт "Выход".


Диалоговое окно "Изменения в файле параметров принтера" (Параметры листа)

П Команды
П Команды
Диалоговое окно "Изменения в файле параметров принтера" (Параметры листа)
Понятия Процедуры Команды

Панель "Листы":

Меню "Файл": Диспетчер наборов параметров листов

Контекстное меню: Нажать правую кнопку мыши на ярлыке вкладки "Модель" или "Лист" и выбрать "Диспетчер параметров листа".

Ввод команды: парамлист

Уведомление о том, что в PC3-файл параметров плоттера внесены изменения. Пользователь может отказаться от изменений, переписать имеющийся PC3- файл (нажав "OK") или задать другое имя PC3-файла для измененного PC3-файла.

Сохранить изменения в следующем файле

Имя измененного PC3-файла и путь к нему. Если нужно сохранить неизменным исходный PC3-файл, здесь следует ввести новое имя.


Диалоговое окно "Импорт набора параметров листов"

П Команды
П Команды
Диалоговое окно "Импорт набора параметров листов"
Понятия Процедуры Команды

Панель "Листы":

Меню "Файл": Диспетчер наборов параметров листов

Контекстное меню: Нажать правую кнопку мыши на ярлыке вкладки "Модель" или "Лист" и выбрать "Диспетчер параметров листа".

Ввод команды: парамлист

Отображает наборы параметров листов, доступных для импорта из выбранного чертежа.

Исходный чертеж

Исходный файл, который содержит доступные для импорта наборы параметров..

Наборы параметров листа

Список наборов параметров, доступных для импорта, с указанием их расположения в исходном чертеже. При нажатии кнопки "ОК" выбранные наборы параметров импортируются в текущий чертеж.

При импорте параметров в файл переопределений для подшивки импортируются только те наборы, для области печати которых установлены значения "Лист" или "Границы".

Имя

Имя набора параметров, доступного для импорта.

Расположения

Местоположение (модель или лист) набора параметров листа в чертеже, из которого импортируется набор параметров.

Подробности

Вывод информации о выбранном наборе параметров.

Устройство

Имя устройства печати, указанное в выбранном на текущий момент наборе параметров листа.

Плоттер

Тип устройства печати, указанный в выбранном на текущий момент наборе параметров листа.

Формат печати

Размер и ориентация носителя для текущего набора параметров листа.

Подключение

Физическое размещение выбранного устройства печати для текущего набора параметров листа.

Описание

Текстовое пояснение к устройству печати для текущего набора параметров листа.


ПБЛОК Команда

П Команды
П Команды
ПБЛОК Команда
Понятия Процедуры Команды

Запись объектов или блока в новый файл чертежа

Ввод команды: пблок

Отобразится диалоговое окно "Запись блока на диск".

Если в ответ на подсказку "Команда:" ввести -пблок , отобразится стандартное диалоговое окно выбора файлов, в котором нужно указать имя вновь создаваемого файла чертежа, а затем отвечать на запросы в командной строке. Если значение переменной FILEDIA равно 0, стандартное диалоговое окно выбора файлов не отображается.

Темы:

  • Диалоговое окно "Запись блока на диск"
  • ПБЛОК (вариант для командной строки)


Диалоговое окно "Запись блока на диск"

П Команды
П Команды
Диалоговое окно "Запись блока на диск"
Понятия Процедуры Команды

Ввод команды: пблок

Запись графических объектов или блоков в отдельный файл.

В диалоговом окне "Запись блока на диск" отображаются различные параметры по умолчанию в зависимости от выбранных элементов чертежа (ничего не выбрано, выбран одиночный блок, выбраны объекты, но не блоки).

Источник данных

Выбор блоков и объектов, запись их в файл и задание точек вставки.

Блок

Выбор блока для записи в файл. Имя нужного блока выбирается из списка.

Весь чертеж

Выбор текущего чертежа в качестве блока.

Объекты

Задание базовой точки для блока. По умолчанию используется значение 0,0,0.

Базовая точка

Задание базовой точки для блока. По умолчанию используется значение 0,0,0.

Указать точку

Временное закрытие диалогового окна для указания базовой точки вставки на текущем чертеже.

X

Значение координаты X базовой точки.

Y

Значение координаты Y базовой точки.

Z

Значение координаты Z базовой точки.

Объекты

Выбор способа обработки выбранных объектов текущего чертежа после записи блока в файл.

Оставить

Сохранение выбранных объектов текущего чертежа без изменений после записи их в файл.

Преобразовать в блок

Преобразование выбранных объектов текущего чертежа в блок после записи их в файл. Блоку присваивается имя, заданное в поле "Имя файла".

Удалить из чертежа

Удаление выбранных объектов из текущего чертежа после записи их в файл.

Кнопка выбора объектов

Позволяет временно закрыть диалоговое окно для выбора одного или нескольких объектов, которые требуется записать в файл.

Кнопка быстрого выбора

Служит для вызова диалогового окна "Быстрый выбор", в котором можно отфильтровать набор объектов.

Выбрано объектов

Вывод информации о количестве выбранных объектов.

Назначение

Задание нового имени и расположения файла, а также указание единиц измерения, используемых при вставке блока.

Имя файла и путь

Имя и путь к файлу, в который требуется сохранить блок или объекты.

[...]

Вызов стандартного диалогового окна выбора файлов.

Единицы измерения

Задание единиц измерения, которые будут использоваться для автоматического масштабирования при перетаскивании нового файла из Центра управления (DesignCenter™) или вставке его в качестве блока в чертеж с другими единицами. Если выбрано значение "Безразмерный", блок вставляется в чертеж без масштабирования. См. описание системной переменной INSUNITS.


ПБЛОК (вариант для командной строки)

П Команды
П Команды
ПБЛОК (вариант для командной строки)
Понятия Процедуры Команды

Если значение переменной FILEDIA равно 1, после ввода -пблок в командной строке будет вызвано стандартное диалоговое окно выбора файлов, в котором указывается имя нового файла чертежа. Если системная переменная FILEDIA равна 0, ввод -пблок вызывает вариант команды ПБЛОК, использующий интерфейс командной строки. Новый чертеж сохраняется в формате файла, который задан в пункте "Сохранять в формате" на вкладке "Открытие/Сохранение" в диалоговом окне "Параметры".

Введите имя выходного файла:

После указания имени файла — с помощью средств диалогового окна или командной строки — выводится следующий запрос.

Введите имя существующего блока или

[= (блок=выходной файл)/* (весь чертеж)] <задать новый чертеж>: Ввести имя существующего блока, ввести =, ввести * или нажать ENTER

Если введено имя существующего блока, этот блок записывается в файл. Нельзя вводить имя внешней ссылки, а также имена зависимых от нее блоков.

Ввод знака равенства (=) означает, что имена существующего блока и выходного файла совпадают. Если блок с заданным именем отсутствует в чертеже, запрос повторяется.

Ввод звездочки (*) означает, что весь чертеж, за исключением неиспользуемых символов, будет записан в новый выходной файл. Объекты пространства модели записываются в пространство модели, а объекты пространства листа — в пространство листа.

После нажатия ENTER следует указать базовую точку вставки для файла блока, а затем выбрать объекты, которые требуется записать в этот файл.

Базовая точка вставки: Указать точку (1)

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

После создания файла выбранные объекты удаляются из чертежа. Для восстановления объектов служит команда ОЙ.

В новом чертеже мировая система координат (МСК) устанавливается параллельно пользовательской системе координат (ПСК).


ПГРАНЬ Команда

П Команды
П Команды
ПГРАНЬ Команда
Понятия Процедуры Команды

Создание трехмерной многогранной сети по вершинам.

Ввод команды: пгрань

Положение вершины 1: Укажите точку

Положение вершины 2 или <задать грани>: Указать точку или нажать ENTER

Положение вершины n или <задать грани>: Указать точку или нажать ENTER

Положение вершины

Задание всех вершин, используемых в сети. В запросах отображаются номера вершин, используемые в ссылках на каждую из вершин. Запрос повторяется до тех пор, пока пользователь не нажмет ENTER. Если нажать ENTER на пустой строке, появится запрос о принадлежности вершин граням.

Задать грани

Укажите номер вершины или [Цвет/Слой]: Ввести номер вершины или задать опцию

Номер вершины

Грани описываются путем ввода номеров для всех вершин, образующих заданную грань. После ввода последней вершины надо нажать ENTER. Тогда программа запрашивает номера вершин следующей грани. После задания последней грани и нажатия ENTER (по запросу) на экране появляется сеть.

Чтобы сделать край грани произвольной сети невидимым, перед числом, обозначающим начальную вершину края, ставится знак минус. Системная переменная SPLFRAME управляет показом невидимых граней в многоугольной сети. При задании ненулевого значения для переменной SPLFRAME на экран выводятся все невидимые грани и кромки многогранных сетей, которые можно редактировать таким же способом, как полностью видимые многогранные сети.

Можно вводить многоугольники с любым числом сторон. Команда ПГРАНЬ автоматически разбивает их на несколько граней с соответствующими невидимыми ребрами. Грани с одной и двумя вершинами превращаются соответственно в точки и отрезки, отличающиеся тем, что грани-точки не могут по-разному воспроизводиться на экране, а грани-отрезки характеризуются только одним типом линий. Их можно использовать для вставки в сеть каркасных изображений. Для привязки к грани, образованной из одной или двух вершин, можно использовать режим объектной привязки "Конточка". Все режимы объектной привязки, доступные для линейных объектов, применимы для видимых кромок многогранных сетей. Для редактирования многогранных сетей не может быть использована команда ПОЛРЕД.

Цвет

К граням, создаваемым с помощью команды ПГРАНЬ, применяются текущие слой и цвет. Однако, в отличие от вершин полилиний, отдельным граням произвольных сетей можно явно назначать слои и цвета, отличные от слоя и цвета их исходного объекта.

Новый цвет [изПалитры/Альбом] <ПОСЛОЮ>: Ввести стандартное имя цвета или номер от 1 до 255, ввести п, а, либо нажать ENTER

Пользователь может задать цвет по индексу цветов AutoCAD (имя или номер цвета), цвет из палитры или альбома цветов.

Будет выдан предыдущий запрос.

Слой

К граням, создаваемым с помощью команды ПГРАНЬ, применяются текущие слой и цвет. Однако, в отличие от вершин полилиний, отдельным граням произвольных сетей можно явно назначать слои и цвета, отличные от слоя и цвета их исходного объекта. При этом видимость слоя влияет на отображение расположенных на нем граней многогранной сети. Однако при построении многогранной сети на замороженном слое программа не создает ее грани, включая и расположенные на незамороженных слоях.

Имя слоя <0>: Ввести имя или нажать ENTER

Будет выдан предыдущий запрос.


ПДПРОВЕРИТЬ Команда

П Команды
П Команды
ПДПРОВЕРИТЬ Команда
Понятия Процедуры Команды

Вывод информации о цифровой подписи файла

Ввод команды: пдпроверить

Откроется диалоговое окно "Проверка цифровых подписей". После ознакомления с информацией, содержащейся в данном окне, следует нажать кнопку "Закрыть" для просмотра подписанного файла.

Темы:

  • Диалоговое окно "Проверка цифровых подписей"
  • Диалоговое окно "Свойства цифровой подписи"


Диалоговое окно "Проверка цифровых подписей"

П Команды
П Команды
Диалоговое окно "Проверка цифровых подписей"
Понятия Процедуры Команды

Ввод команды: пдпроверить

Вывод информации о цифровой подписи, с помощью которой можно определить, действительна ли подпись и изменялся ли файл со времени подписания.

Имя

Имя и путь к файлу, информация о подписи которого просматривается.

Статус цифровой подписи

Отображает значок действительной цифровой подписи, если цифровая подпись действительна. Для недействительной цифровой подписи отображается значок недействительной цифровой подписи.

Статус файла

Информация о статусе подписанного файла.

Основная подпись

Вызов диалогового окна "Свойства цифровой подписи". Эта опция доступна, только если цифровая подпись действительна и файл не изменялся со времени подписания.

Чертежи внешних ссылок

Содержит подробные сведения о внешних ссылках в подписанных файлах.

Просмотр чертежей внешних ссылок

Вывод списка чертежей внешних ссылок, содержащихся в файле исходного чертежа.

Список внешних ссылок

Содержит список чертежей внешних ссылок в подписанном файле. Отображаются имя, папка и статус внешней ссылки. Список доступен только в случае, если текущий файл содержит внешние ссылки и отмечена опция "Просмотр чертежей внешних ссылок".

Подписи в ссылках

Вызов диалогового окна "Свойства цифровой подписи" для выбранной внешней ссылки. Кнопка доступна только для действительных подписей внешних ссылок.


Диалоговое окно "Свойства цифровой подписи"

П Команды
П Команды
Диалоговое окно "Свойства цифровой подписи"
Понятия Процедуры Команды

Ввод команды: пдпроверить

Вывод информации о цифровой подписи, с помощью которой можно определить, действительна ли подпись и изменялся ли файл со времени подписания.

Имя

Имя и путь к файлу, информация о подписи которого просматривается.

Статус цифровой подписи

Информация о статусе цифровой подписи.

Статус файла

Информация о статусе подписанного файла.

Подписал

Имя лица или название организации, добавившей цифровую подпись к данному файлу.

Другие поля

Отображаются тема, поставщик, начальная дата срока действия, конечная дата срока действия или серийный номер в окне "Значения".

Тема

Сведения об организации или частном лице, обладающем цифровым удостоверением и добавившем цифровую подпись к данному файлу.

Поставщик

Имя владельца сертификата, предоставившего цифровое удостоверение.

Действительна с

День, месяц, год и точное время, начиная с которого цифровое удостоверение может использоваться и считается действительным.

Действительна по

Отображает день, месяц, год и точное время, после которого цифровое удостоверение становится недействительным.

Серийный номер

Серийный номер цифрового удостоверения.

Значения

Сведения о подписи, отображаемые в зависимости от того, какой элемент выбран в списке "Другие поля".

Пояснение

Примечания, введенные пользователем для цифровой подписи данного файла.

Дата и время подписи

Дата и время добавления цифровой подписи к файлу чертежа. Дата и время основываются на показаниях службы определения времени, которая использовалась на момент добавления подписи.

Использованный сервер времени

Служба определения времени, которая использовалась при датировании файла.

Игнорировать предупреждения при работе с внешними ссылками

Определяет, будет ли вызываться диалоговое окно "Свойства цифровой подписи" для внешних ссылок. Этот флажок появляется только при открытии подписанного чертежа.


ПЕРЕАТР Команда

П Команды
П Команды
ПЕРЕАТР Команда
Понятия Процедуры Команды

Переопределение блока и обновление связанных с ним атрибутов

Ввод команды: переатр

Имя переопределяемого блока:

Выбрать объекты для нового блока:

Выбрать объекты:

Базовая точка вставки нового блока: Указать точку

Новым атрибутам существующих в чертеже блоков присваиваются значения по умолчанию. Ранее определенные атрибуты сохраняют свои старые значения. Атрибуты, определенные ранее, но отсутствующие в новом описании блока, удаляются.

Предупреждение Команда ПЕРЕАТР удаляет любое, внесенное командами АТРЕД или АТРЕДАКТ изменение формата или свойства. Она также удаляет любые дополнительные данные, связанные с блоком, и может повлиять на динамические блоки или блоки, созданные в приложениях сторонних разработчиков.


ПЕРЕИН Команда

П Команды
П Команды
ПЕРЕИН Команда
Понятия Процедуры Команды

Повторная инициализация портов ввода-вывода, дигитайзера, монитора и файла параметров программ

Ввод команды: переин

Откроется диалоговое окно "Переинициализация".

Темы:

  • Диалоговое окно «Переинициализация»


Диалоговое окно «Переинициализация»

П Команды
П Команды
Диалоговое окно «Переинициализация»
Понятия Процедуры Команды

Ввод команды: переин

Задает порты ввода/вывода и устройства, которые нужно инициализировать повторно.

Инициализация портов ввода-вывода

Задает инициализацию портов ввода-вывода для дигитайзера.

Инициализация файлов и устройств

Выполняет повторную инициализацию дигитайзера и файла acad.pgp.


ПЕРЕНЕСТИ Команда

П Команды
П Команды
ПЕРЕНЕСТИ Команда
Понятия Процедуры Команды

Перемещает объекты на заданное расстояние в указанном направлении

Панель "Редактирование":

Меню "Редактирование": Перенести

Контекстное меню: Выбрать объекты, которые необходимо переместить, и нажать правую кнопку мыши в области рисования. Выберите "Перенести".

Ввод команды: перенести

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении работы

Базовая точка или [Перемещение]<Перемещение>: Указать базовую точку или ввести п

Вторая точка или <считать перемещением первую точку>: Указать точку или нажать ENTER

Две указанные точки задают направляющий вектор, который определяет, на какое расстояние и в каком направлении должны быть перемещены выбранные объекты.

Если при запросе на ввод второй точки нажать клавишу ENTER, первая точка интерпретируется как смещение относительно осей X, Y, Z. Например, если указать базовую точку 2,3 и при следующей подсказке нажать ENTER, объект переместится на 2 единицы по оси X и на 3 единицы по оси Y относительно своей текущей позиции.

Перемещение

Укажите перемещение <последнее значение>: Ввести координаты для отображения вектора

При вводе значений координат указывается относительное расстояние и направление.


ПЕРЕСЕЧЕНИЕ Команда

П Команды
П Команды
ПЕРЕСЕЧЕНИЕ Команда
Понятия Процедуры Команды

Создает составные тела или области путем пересечения двух или более тел или областей и удаляет области снаружи пересечения.

Панель "Моделирование":

Меню "Редактирование": "Редактирование тела" » "Пересечение"

Ввод команды: пересечение

Пульт управления: Панель создания 3D объектов, Пересечение

Выберите объекты: Выберите объекты любым способом

Для работы с командой ПЕРЕСЕЧЕНИЕ можно выбрать только области и тела.

Команда ПЕРЕСЕЧЕНИЕ вычисляет площадь перекрывающейся части у областей или общий объем у двух или нескольких тел.

В наборе объектов могут находиться как области, так и тела, расположенные в любых плоскостях. Команда ПЕРЕСЕЧЕНИЕ делит набор объектов на несколько отдельных поднаборов, объекты внутри каждого из которых проверяются на пересечение. В первый поднабор заносятся тела. Во второй попадают первая из выбранных областей и все компланарные ей. В третий группируются первая область, некомпланарная областям из второго поднабора и все компланарные ей, и т.д.


ПЕЧАТЬ Команда

П Команды
П Команды
ПЕЧАТЬ Команда
Понятия Процедуры Команды

Вывод чертежа на плоттер, принтер или в файл

Панель "Стандартная"

Меню "Файл": Печать

Контекстное меню: Нажать правую кнопку мыши на ярлыке вкладки "Модель" или "Лист" и выбрать "Печать".

Ввод команды: печать

Откроется диалоговое окно "Печать". Если сразу нажать "ОК", печать пойдет с текущими значениями параметров.

Если по запросу "Команда:" ввести -печать, то команда ПЕЧАТЬ отображает запросы в командной строке.

Темы:

  • Диалоговое окно "Печать"
  • Диалоговое окно "Добавление набора параметров листа"
  • Диалоговое окно "Изменения в файле параметров принтера" (Печать)
  • Диалоговое окно "Печать Ход выполнения"
  • Диалоговое окно "Замена принтера в PC3-файле"
  • Командная строка ПЕЧАТЬ


Диалоговое окно "Печать"

П Команды
П Команды
Диалоговое окно "Печать"
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Файл": "Печать"

Контекстное меню: Нажать правую кнопку мыши на ярлыке вкладки "Модель" или "Лист" и выбрать "Печать".

Ввод команды: печать

Задание параметров для устройства печати и носителя (бумаги), и печатается чертеж. В названии диалогового окна "Печать" указывается имя текущего листа.

При выборе кнопки "Развернуть окно" в диалоговом окне "Печать" отображаются дополнительные параметры печати.

Наборы параметров листа

Список ранее сохраненных именованных наборов параметров листов чертежей. Можно создать текущие параметры листа на основе именованного набора параметров листа, сохраненного в чертеже, либо создать новый именованный набор параметров листа на основе текущих настроек в окне "Печать", нажав с этой целью на кнопку "Добавить".

Имя

Имя текущего набора параметров.

Добавить

Отображает диалоговое окно "Добавление набора параметров листа", позволяющего сохранить выбранные параметры текущего листа в диалоговом окне "Печать" для именованного набора параметров. Параметры страницы можно изменить через "Диспетчер наборов параметров листов".

Принтер/плоттер

Сведения о сконфигурированном устройстве печати для листов.

Если выбранный плоттер не поддерживает выбранный формат текущего листа, выдается сообщение, после чего можно выбрать формат листа плоттера по умолчанию либо пользовательский формат листа.

Имя

Список доступных PC3 файлов или системных принтеров, выбираемых для вывода на печать текущего листа. Устройство идентифицируется в качестве PC3-файла или системного принтера по значку, стоящему перед его именем.

  • Значок PC3-файла: Определяет PC3 файлы.
  • Значок системного принтера: Определяет системные принтеры.

Свойства

ОтображаетРедактор параметров плоттера (редактор PC3), в котором можно просмотреть или изменить текущую конфигурацию плоттера, задать параметры портов, устройства и носителя.

После внесения изменений в PC3-файл с помощью редактора параметров плоттера открывается диалоговое окно "Изменения в файле параметров плоттера".

Плоттер

Устройство печати для текущего набора параметров листа.

Подключение

Физическое размещение выбранного устройства печати для текущего набора параметров листа.

Описание

Текстовое пояснение к устройству печати для текущего набора параметров листа. Для редактирования пояснения применяется Редактор параметров плоттера.

Печать в файл

Вывод в файл (а не на плоттер или принтер). Путь для размещения файлов чертежей по умолчанию задается в диалоговом окне "Настройка" (вкладка "Печать/Публикация"), в поле "Расположение файлов чертежей по умолчанию".

Если выбрана опция "Печать в файл", то при нажатии на OK в диалоговом окне "Печать" открывается диалоговое окно "Поиск файла чертежа" (стандартное диалоговое окно поиска файлов).

Частичный образец

Точное отображение действительной области печати, соотносимое с форматом бумаги и печатаемой областью. На образце указан формат листа и обозначена печатаемая область.

Формат листа

Список стандартных форматов, разрешенных для применения на выбранном устройстве. Если плоттер еще не выбран, в списке перечислены все поддерживаемые форматы.

Если выбранный плоттер не поддерживает формат текущего листа, выдается сообщение, после чего можно выбрать формат листа по умолчанию для плоттера либо пользовательский формат листа.

Сразу после создания PC3-файла параметров плоттера (в Мастере установки плоттеров) устройство настраивается на свой формат по умолчанию. Подробнее о Мастере установки плоттеров см. раздел Настройка плоттеров и принтеров документа Руководство по драйверам и устройствам. Заданный в диалоговом окне "Параметры листа" формат сохраняется вместе с листом и имеет приоритет перед указанным в PC3-файле.

Фактическая область печати листа, определенная в соответствии с типом печатающего устройства и форматом листа, выделяется на листе штриховой линией.

При выводе в растровый формат (например, в BMP- или TIFF-файл) размеры чертежа отображаются не в дюймах/миллиметрах, а в пикселах.

Количество экземпляров

Определяет количество выводимых на печать экземпляров. Опция не доступна при печати в файл.

Область печати

Задание выводимой на печать части чертежа. Опция "Что печатать" определяет, какая часть чертежа будет напечатана.

Лист/Пределы

При распечатке листа печатаются все объекты в пределах печатаемой области для указанного формата листа, начиная с точки, вычисленной относительно координат 0,0 в листе.

При распечатке из вкладки "Модель" печатается вся графическая область, определяемая границами сетки. Если вид на текущем видовом экране отличен от вида в плане, опция работает аналогично опции "Границы".

Границы

Вывод на плоттер той части чертежа, которая в данный момент содержит объекты. Печатаются все объекты текущего пространства. Чертеж может быть регенерирован для пересчета границ перед печатью.

Показать

Печать текущего видового экрана (для выбранной вкладки "Модель") или текущего вида пространства листа.

Вид

Печать вида, предварительно описанного и сохраненного с помощью команды ВИД. Возможен выбор именованного вида из списка. Если в чертеже нет именованных видов, опция недоступна.

При выборе опции "Вид" рядом появляется список всех именованных видов, сохраненных в текущем чертеже. Возможен выбор вида для печати из списка.

Рамка

Вывод фрагмента чертежа, указанного пользователем. После выбора рамки кнопка "Рамка" становится доступной. Нажав кнопку "Рамка", пользователь либо указывает два противоположных угла на экране, либо вводит их координаты.

Первый угол: Указать точку

Противоположный угол: Указать точку

Смещение от начала

Определяет смещение области печати относительно левого нижнего угла печатаемой страницы или края бумаги, в зависимости от установки параметра "Отсчет смещения чертежа" (диалоговое окно "Настройка", вкладка "Печать/Публикация"). Выбранный вариант смещения приводится в круглых скобках после названия группы опций "Смещение от начала" в диалоговом окне "Печать".

Печатаемая область листа чертежа определяется выбором устройства вывода и выделяется на листе штриховой линией. При выборе другого печатающего устройства область печати может измениться.

Возможно смещение геометрии на листе путем ввода положительного или отрицательного значения в окна смещения по осям X и Y. Единицами смещения для плоттера являются дюймы или миллиметры на листе.

Центрировать

Автоматическое определение смещений по X и Y так, чтобы чертеж оказался в центре листа. Данная опция недоступна, если в качестве области печати указан "Лист".

X

Указывается начальная точка чертежа в направлении X по отношению к точке, определяемой текущим значением опции "Отсчет смещения чертежа".

Y

Указывается начальная точка чертежа в направлении Y по отношению к точке, определяемой текущим значением опции "Отсчет смещения чертежа".

Масштаб печати

Управление относительным размером единиц чертежа для печатаемых единиц. По умолчанию для листа устанавливается масштаб 1:1. Для вкладки "Модель" по умолчанию устанавливается значение масштаба "Вписать".

Вписать

Печатаемая область масштабируется для вписывания в указанный формат листа; пользовательский масштабный коэффициент отображается в полях "Масштаб", "дюйм =" и "единицы".

Масштаб

Точное значение масштаба печати. Пользовательский является нестандартным масштабом. Он задается путем указания соответствия между дюймами (миллиметрами) на чертеже и единицами чертежа.

Примечание Можно изменить список масштабов с помощью команды СПИСМАСШТРЕД.

Дюйм =/мм =/пиксел =

Определяет соответствие установленного числа единиц чертежа в дюймах, миллиметрах или пикселах единицам чертежа.

Дюйм/мм/пиксел

Задание дюймов или мм для отображения единиц в диалоговом окне "Печать". Значение по умолчанию зависит от формата листа и изменяется при каждом выборе нового формата. Значение в пикселах доступно только при выборе растрового вывода.

Единицы

Определяет соответствие единиц чертежа указанному количеству дюймов, миллиметров или пикселов.

Масштабировать веса линий

Масштабирование весов линий пропорционально масштабу печати. Веса линий, как правило, обозначают ширину линий на готовом чертеже, используемую при печати независимо от масштаба печати.

Просмотр

При выполнении команды ПРЕДВАР чертеж отображается в таком виде, как при распечатке на бумаге. Для выхода из режима предварительного просмотра и возврата в диалоговое окно "Печать" нажать ESC или ENTER, либо нажать правую кнопку и выбрать из контекстного меню пункт "Выход".

Применить к листу

Сохранение настроек печати для текущего листа.

Дополнительно

Управляет отображением дополнительных параметров в диалоговом окне "Печать".

  • Таблица стилей печати (назначение перьев)
  • ВЭкраны с раскрашиванием
  • Опции печати
  • Ориентация чертежа
Таблица стилей печати

Установка текущей таблицы стилей печати, редактирование имеющихся и создание новых таблиц.

Имя (без маркировки)

Список таблиц стилей печати, назначенных текущей вкладке "Модель" или вкладке листа, и список доступных на данный момент таблиц стилей печати.

Если выбрать "Создать", вызывается мастер добавления таблиц стилей печати, в котором можно создать новую таблицу. Вид мастера определяется типом стилей печати, используемых в текущем чертеже (цветозависимые или именованные).

Изменить

Вызов диалогового окна Редактор таблиц стилей печати, где производится просмотр и редактирование стилей, входящих в назначенную таблицу стилей печати.

ВЭкраны с раскрашиванием

Задается способ вывода на печать раскрашенных и тонированных видовых экранов и определяются их уровни разрешения и количество точек на дюйм (т/дюйм).

Способ вывода

Способ вывода видов на печать. Для того чтобы задать этот параметр для видового экрана на листе, нужно выбрать видовой экран, а затем из меню "Сервис" выбрать "Свойства".

Для видового экрана на вкладке "Модель" существует возможность выбора одного из следующих параметров:

  • Обычный: Объекты выводятся на печать так же, как они выглядят на экране.
  • Каркас: На печать выводятся только контуры объектов независимо от того, как они выглядят на экране.
  • Скрытие: Скрытые линии на печать не выводятся, независимо от того, видны ли они на экране.
  • 3D скрытие Объекты печатаются с применением визуального стиля "3D скрытие" независимо от способа отображения объектов на экране.
  • 3D каркас Объекты печатаются с применением визуального стиля "3D каркас" независимо от способа отображения объектов на экране.
  • Концептуальный Объекты печатаются с применением визуального стиля "Концептуальный" независимо от способа отображения объектов на экране.
  • Реалистичный Объекты печатаются с применением визуального стиля "Реалистичный" независимо от способа отображения объектов на экране.
  • Тонирование: Выполняется печать объектов с тонированием независимо от того, как они выглядят на экране.

Качество

Задание разрешения для печати раскрашенных и тонированных видовых экранов.

Возможен выбор одного из следующих параметров:

  • Черновое: Тонированные и раскрашенные виды пространства модели печатаются в каркасном режиме.
  • Просмотр: Тонированные и раскрашенные виды пространства модели печатаются с разрешением 1/4 от текущего разрешения устройства печати, максимум 150 т/дюйм.
  • Нормальное: Тонированные и раскрашенные виды пространства модели печатаются с разрешением 1/2 от текущего разрешения устройства печати, максимум 300 т/дюйм.
  • Презентационное: Тонированные и раскрашенные виды пространства модели печатаются с текущим разрешением устройства печати, максимум 600 т/дюйм.
  • Максимум: Тонированные и раскрашенные виды пространства модели печатаются с текущим разрешением устройства печати без установки максимального ограничения.
  • Пользовательское: Тонированные и раскрашенные виды пространства модели печатаются с разрешением, которое задается в поле "Т/дюйм". Задаваемое пользователем разрешение не может быть больше текущего разрешения устройства печати.

Т/дюйм

Задание разрешения (т/дюйм) для печати раскрашенных и тонированных видов. Задаваемое пользователем разрешение не может быть больше текущего разрешения устройства печати. Данное поле доступно для редактирования, только если в списке "Качество" выбрано "Пользовательское".

Опции печати

Параметры, относящиеся к весам линий, стилям печати, раскрашенным видовым экранам, в порядке вывода объектов на печать.

Фоновая печать

Указывает, что печать идет в фоновом режиме (системная переменная BACKGROUNDPLOT).

Учитывать веса линий

Печать с учетом весов линий, назначенных объектам и слоям. Данная опция недоступна при выбранном параметре "Учитывать стили печати".

Учитывать стили печати

Определяет, учитываются ли во время печати стили печати, применяемые к объектам и слоям. При выборе данной опции автоматически активизируется также опция "Учитывать веса линий".

Объекты листа последними

Печать объектов пространства модели в первую очередь. При положительном ответе первыми выводятся объекты пространства листа.

Скрывать объекты листа

Применение команды СКРЫТЬ к объектам на видовых экранах листа. Доступно только для вкладок-листов. Эффект от данной опции проявляется в просмотровом образце печати, но не на листе.

Штемпель вкл

Включение режима нанесения штемпелей. Наносит штемпель в определенном углу каждого чертежа и/или записывает соответствующую информацию в файл журнала.

Подробнее о параметрах штемпелей см. описание диалогового окна "Штемпель чертежа", в котором можно задать информацию, проставляемую на штемпеле например, имя чертежа, дату и время, масштаб печати и т.д. Для открытия диалогового окна "Штемпель чертежа" следует поднять флажок "Штемпель вкл" и нажать кнопку "Параметры штемпеля".

Диалоговое окно "Штемпель чертежа" можно также получить, нажав кнопку "Штемпели чертежей" на вкладке "Печать/Публикация" диалогового окна "Настройка".

Кнопка "Параметры штемпеля"

Отображает диалоговое окно "Штемпель чертежа", если в диалоговом окне "Печать" выбрана опция "Штемпель вкл".

Сохранить изменения в листе

Сохранение всех изменений параметров, внесенных в диалоговое окно "Печать", на листе.

Ориентация чертежа

Задание ориентации чертежа для плоттеров, поддерживающих ее книжный и альбомный варианты. Текущая ориентация выбранного листа иллюстрируется значком. Буква на значке указывает на расположение чертежа на листе.

Книжная

Чертеж ориентируется таким образом, что при печати верх страницы соответствует короткой стороне листа.

Альбомная

Чертеж ориентируется таким образом, что при печати верх страницы соответствует длинной стороне листа.

Перевернуть

Поворот чертежа на 180 градусов.

Значок

Указывает ориентацию, выбранной бумаги и задает ориентацию чертежа на странице, совпадающую с расположением букв на бумаге.

Примечание Ориентацию чертежа можно задать также в системной переменной PLOTROTMODE.

Свернуть окно

Скрываются указанные ниже опции диалогового окна "Печать".

  • Таблица стилей печати (назначение перьев)
  • ВЭкраны с раскрашиванием
  • Опции печати
  • Ориентация чертежа


Диалоговое окно "Добавление набора параметров листа"

П Команды
П Команды
Диалоговое окно "Добавление набора параметров листа"
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Файл": Печать

Контекстное меню: Нажать правую кнопку мыши на ярлыке вкладки "Модель" или "Лист" и выбрать "Печать".

Ввод команды: печать

Сохранение текущих настроек печати из диалогового окна "Печать" в именованном наборе параметров листа. Параметры страницы можно изменить через "Диспетчер наборов параметров листов".

Имя нового набора параметров листа

Имя нового набора параметров листа. Дальнейшее изменение набора параметра листа производится в Диспетчере параметров листов.


Диалоговое окно "Изменения в файле параметров принтера" (Печать)

П Команды
П Команды
Диалоговое окно "Изменения в файле параметров принтера" (Печать)
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Файл": Печать

Контекстное меню: Нажать правую кнопку мыши на ярлыке вкладки "Модель" или "Лист" и выбрать "Печать".

Ввод команды: печать

Уведомление о том, что в имеющийся PC3-файл настройки плоттера внесены изменения. Пользователь может отказаться от изменений, переписать имеющийся PC3-файл (нажав "OK") или задать новое имя для измененного PC3-файла.

Применить изменения только к текущему чертежу

Изменения параметров в PC3-файле действуют только для выполняемого чертежа и не сохраняются в PC3-файле.

Сохранить изменения в следующем файле

Путь к измененному PC3-файлу. Если нужно сохранить неизменным исходный PC3-файл, здесь следует ввести новое имя.


Диалоговое окно "Печать Ход выполнения"

П Команды
П Команды
Диалоговое окно "Печать Ход выполнения"
Понятия Процедуры Команды

Меню "Файл": Печать

Контекстное меню: Нажать правую кнопку мыши на ярлыке вкладки "Модель" или "Лист" и выбрать "Печать".

Ввод команды: печать

Диалоговое окно "Печать Ход выполнения" содержит информацию о статусе и ходе выполнения текущего задания на печать.

Прервать вывод листа

Отмена печати листа, выводимого в данный момент.

Отмена задания

Отмена задания на печать.


Диалоговое окно "Замена принтера в PC3-файле"

П Команды
П Команды
Диалоговое окно "Замена принтера в PC3-файле"
Понятия Процедуры Команды

Отображает имя драйвера устройства, которое хранится в PC3-файле. В качестве устройства печати может использоваться принтер или плоттер. С помощью данного диалогового окна можно выбрать из списка плоттер и заменить им не найденное или неправильно указанное устройство в существующем PC3-файле, либо сохранить внесенные изменения в новом PC3-файле.

Диалоговое окно выводится во время выполнения команды ПЕЧАТЬ или ПАРАМЛИСТ для листа, если в PC3-файле, на который настроен этот лист, не найдено или неправильно указано имя устройства печати.

Имя устройства

Имя настроенного на текущий лист устройства, указанное в PC3-файле.

Имя принтера

Список доступных плоттеров, принтеров и PC3-файлов. Здесь необходимо выбрать плоттер, принтер или PC3-файл, который будет использоваться для замены не найденного в PC3-файле принтера. Если замена не требуется, следует выбрать "Нет".

При выборе "Нет" другие настройки текущего листа не изменяются. При выборе плоттера или принтера, использующего драйвер, отличающийся от указанного в исходном PC3-файле, следующие параметры настройки могут оказаться изменены при сохранении PC3-файла:

  • Качество печати
  • Глубина цветности
  • Разрешение
  • Подача носителя
  • Механическая обработка носителя
  • Завершающие операции обработки носителя (фальцевание и переплет)
  • Пользовательские настройки предыдущего устройства или драйвера

Если выбранный плоттер или принтер не поддерживает заданный формат листа, используется формат листа по умолчанию. При этом выводится окно предупреждения, с помощью которого можно отменить операцию и вернуться в диалоговое окно "Печать" или "Параметры листа", при выбранном устройстве "Нет".

Устройство

В этом столбце отображается имя драйвера устройства, соответствующее выбранному в столбце "Имя принтера" элементу:

  • Если выбран плоттер или принтер, отображается имя драйвера устройства, указанное в PC3-файле этого плоттера или принтера.
  • Если выбран PC3-файл, отображается имя драйвера устройства, указанное в этом файле.
  • Если выбрано "Нет", данный столбец ничего не отображает. В этом случае недостающее устройство, указанное в PC3-файле, не заменяется.

Комментарии

Информация о выбранном плоттере, принтере или PC3-файле.

Обновить и сохранить PC3-файл

Отображение имени PC3-файла, в который внесены изменения для текущего листа. Если нажать кнопку "ОК", не изменив перед этим имя PC3-файла, замена принтера производится в существующем PC3-файле. Если же перед нажатием "ОК" изменить имя PC3-файла, сохраняется его копия с внесенными изменениями.


Командная строка ПЕЧАТЬ

П Команды
П Команды
Командная строка ПЕЧАТЬ
Понятия Процедуры Команды

Если по запросу "Команда:" ввести -печать, в командной строке появляется следующий запрос:

Выполнить детальное задание конфигурации? [Да/Нет] <Нет>: Ввести д или н или нажать ENTER

Нет

Указывает на отсутствие необходимости детального конфигурирования для данной печати.

Имя листа или [?] <текущий>:

Имя набора параметров листа < >:

Имя устройства вывода или [?] текущее>:

Запись чертежа в файл [Да/Нет] <текущее>:

Введите имя файла: <чертеж-имя_листа. plt>:

Сохранить изменения вкладки [Да/Нет] <Нет>:

Перейти к печати [Да/Нет] <Д>:

Подробнее об этих подсказках в командной строке см. описание опции "Да".

Да

Детальное задание параметров печати для выводимой на плоттер вкладки "Модель" или вкладки листа.

Имя листа или [?] <текущее>: Указать имя вкладки листа, которую требуется напечатать

Имя устройства вывода или [?] < текущее > : Указать имя устройства вывода, на которое выводится выбранная вкладка "Модель" или вкладка листа

Если задано новое имя устройства без расширения, программа проверяет, существует ли в устройстве PC3- файл (файл параметров плоттера HDI для Autodesk®). Если PC3-файл не обнаружен, программа выполняет поиск системного принтера Windows с этим именем.

Формат бумаги или [?] < текущий > : Указать формат бумаги для печати или ввести ? для просмотра исходного списка форматов бумаги, которые поддерживаются драйвером плоттера

Имя формата нужно вводить точно так, как оно описано в драйвере.

Единицы измерения размеров листа [Дюймы/Миллиметры] < текущие > :

Подсказка не появляется при выводе растрового изображения (например, BMP- или TIFF-файла), т.к. в этом случае подразумевается, что размеры чертежа выражены в пикселах.

Ориентация чертежа [Книжная/Альбомная] < текущая > :

Книжная

Чертеж ориентируется таким образом, что при печати верх страницы соответствует короткой стороне листа.

Альбомная

Чертеж ориентируется таким образом, что при печати верх страницы соответствует длинной стороне листа.

Перевернуть чертеж [Да/Нет] <Нет>:

Поворот чертежа на 180 градусов.

Область печати [Экран/Границы/Пределы/Лист/Вид/Рамка] <текущая>:

Показать

Распечатка вида в текущем видовом экране (для вкладки "Модель") или текущего вида на листе в зависимости от выбора вкладки для печати.

Границы

Печать всех объектов текущего видового экрана (кроме тех, которые находятся на замороженных слоях). Если на плоттер выводится лист, печатается вся геометрия пространства листа. Чертеж может быть регенерирован для пересчета границ перед печатью.

Если границы чертежа печатаются при включенном виде в перспективе и точка положения камеры находится внутри границ чертежа, данная опция действует так же, как опция "Экран".

Пределы

Печатается область чертежа, определяемая границами сетки. Опция доступна только при выбранной вкладке "Модель".

Лист

Печатаются все объекты в пределах печатаемой области листа заданного формата. Началом чертежа служит точка листа с координатами 0,0. Опция доступна, только если печатается лист чертежа.

Вид

Вывод вида, предварительно описанного и сохраненного командой ВИД. Имя вида выбирается из списка. Если в чертеже нет именованных видов, данная опция недоступна.

Рамка

Вывод выделенного фрагмента чертежа. Опция запрашивает обозначение углов рамки.

Левый нижний угол рамки: Указать точку

Правый верхний угол рамки: Указать точку

Масштаб печати (Миллиметры чертежа = Единицы чертежа) или [Вписать] <текущий>: Указать масштаб печати

Миллиметры чертежа = Единицы чертежа

Масштаб вычисляется на основании заданного соответствия между дюймами или миллиметрами чертежа и пользовательскими единицами чертежа. Здесь можно вводить как вещественные числа, так и дроби (например, допустимыми вариантами являются 1=2 или 0,5).

По ширине

Чертеж масштабируется так, чтобы он полностью заполнил лист бумаги текущего формата.

По умолчанию при выводе листа на печать устанавливается масштаб 1:1 (если он не был ранее изменен и сохранен). Для вкладки "Модель" по умолчанию устанавливается значение масштаба "По ширине".

Смещение от начала (x, y) или [Центрировать] <текущее>: Указать величину смещения в направлении X или Y или ввести ц, чтобы чертеж оказался в центре листа

Учитывать стили печати? [Да/Нет] <текущее>: Указать, используются ли при печати стили печати, примененные к объектам и определенные в таблице стилей печати

Если указать "Да" для печати с помощью стилей печати, отобразится следующий запрос:

Имя таблицы стилей печати или [?] (. если нет) <текущее>: Ввести имя таблицы стилей печати, ? для просмотра таблицы стилей печати или . (точку), если таблица не нужна

Все описания стилей с различными характеристиками свойств хранятся в текущей таблице стилей печати, и их можно назначать объектам чертежа. Эта настройка заменяет присвоения перьев, которые использовались в прежних версиях программы.

Учитывать веса линий? [Да/Нет] <текущее>:

Масштабировать веса линий? [Да/Нет] <текущее>:

Примечание Запрос "Масштабировать веса линий?" выводится только при печати из вкладки листа. Параметры для типа печати с раскрашиванием доступны только при выполнении печати из вкладки "Модель". Для настройки параметров раскрашивания видовых экранов на вкладке "Лист" следует использовать опцию "Печать оттенков" команды -вэкран при создании видового экрана.

Задайте параметры визуализации при печати [Обычный/Каркас/Скрытие/Тонирование] <Обычный>: Задать опцию визуализации при печати

Способ вывода видов пространства модели на печать.

Обычный

Вид пространства модели выводится на печать так же, как он выглядит на экране.

Каркас

На печать выводятся только контуры объектов вида пространства модели независимо от того, как они выглядят на экране.

Скрытие

Скрытые линии на печать не выводятся, независимо от того, видны ли они на экране.

3D скрытие

Указывается, что вид из пространства модели печатается с применением визуального стиля "3D скрытие" независимо от способа отображения объектов на экране.

3D каркас

Указывается, что вид из пространства модели печатается с применением визуального стиля "3D каркас" независимо от способа отображения объектов на экране.

Концептуальный

Указывается, что вид из пространства модели печатается с применением визуального стиля "Концептуальный" независимо от способа отображения объектов на экране.

Реалистичный

Указывается, что вид из пространства модели печатается с применением визуального стиля "Реалистичный" независимо от способа отображения объектов на экране.

Тонирование

Объекты на видах пространства модели выводятся на печать с тонированием независимо от того, как они выглядят на экране.

Запись чертежа в файл [Да/Нет] <текущее>: Ввести д, если необходима запись чертежа в файл, или нажать ENTER для вывода на устройство печати

Если указать "Да", отобразится следующий запрос:

Введите имя файла: <имя_чертежа-имя_листа. plt>: Ввести имя файла

Сохранить изменения в параметрах листа или задать качество визуализации при печати? [Да/Нет/Качество] <Нет>:

При вводе д сохраняются текущие параметры, заданные в диалоговом окне "Параметры листа". При вводе к программа предлагает задать качество печати с тонированием и пользователю предоставляется возможность задать разрешение в точках на дюйм. Затем пользователю предлагается сохранить параметры листа с добавленными настройками качества.

Задайте качество вывода [Черновое/Просмотр/Нормальное/пРезентационное/Максимум/Пользовательское] <Нормальное>: Ввести о, если необходимо задать пользовательское разрешение (т/дюйм), или задать другую опцию, чтобы использовать одно из стандартных значений "т/дюйм"

Пользовательское значение "т/дюйм" <150>:

Сохранить изменения в параметрах листа? [Да/Нет] <Нет>:

Печатать объекты листа первыми? [Да/Нет] <текущее>:

При положительном ответе первыми выводятся объекты пространства листа. При отрицательном ответе (ввод н) вначале печатаются объекты пространства модели. Опция доступна только при печати из вкладки листа.

Скрыть объекты пространства листа? [Да/Нет] <Нет>:

Определяет, применяется ли операция скрытия к объектам на видовых экранах листа. Доступно только для вкладок-листов.

Перейти к печати [Да/Нет] <Д>:


ПИРАМИДА Команда

П Команды
П Команды
ПИРАМИДА Команда
Понятия Процедуры Команды

Создается 3D тело пирамиды

Панель инструментов "Моделирование":

Меню "Рисование": "Моделирование" » "Пирамида"

Ввод команды: пирамида

Пульт управления: Панель "3D Создать", "Пирамида"

4 стороны (по умолчанию)

Описанная (по умолчанию)

Центральная точка основания или [Кромка/Стороны]: Указать точку или задать опцию

Выводится один из указанных ниже запросов:

Радиус в основании или [Вписанная] <по умолчанию>: Указать радиус в основании, ввести i для замены пирамиды на вписанную или нажать клавишу ENTER для выбора радиуса в основании по умолчанию

Радиус в основании или [Описанная] <по умолчанию>: Указать радиус в основании, ввести c для замены пирамиды на вписанную или нажать клавишу ENTER для выбора радиуса в основании по умолчанию

Первоначально значение радиуса в основании по умолчанию не задано. В сеансе черчения значение радиуса в основании по умолчанию всегда равняется предыдущему заданному значению радиуса в основании любого элементарного тела.

После задания радиуса в основании и указания на то, является ли пирамида вписанной или описанной, выводится следующий запрос:

Высота или [2Точки/Конечная точка оси/Радиус верхнего основания] <значение по умолчанию>: Задать высоту, ввести опцию или нажать клавишу ENTER, чтобы задать значение высоты по умолчанию

Опция "Радиус верхнего основания" используется для создания усеченной пирамиды.

Кромка

Указывается длина одной кромки основания пирамиды; пользователь задает две точки.

Первая конечная точка кромки: Указать точку

Вторая конечная точка кромки: Указать точку

Стороны

Указывается число сторон для пирамиды. Возможен ввод значения от 3 до 32.

Количество сторон <по умолчанию>: указать диаметр или нажать ENTER для выбора значения по умолчанию

Первоначально число сторон пирамиды устанавливается равным 4. В сеансе черчения значение число сторон по умолчанию всегда равняется предыдущему введенному значению количества сторон.

Вписанная

Указывается, что основание пирамиды вписывается в пределах (строится внутри) радиуса основания пирамиды.

Описанная

Указывается, что основание пирамиды описывается вокруг (строится по периметру) радиуса основания пирамиды.

2Точка

Указывается, что высота пирамиды равняется расстоянию между двумя указанными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Указывается местоположение конечной точки для оси пирамиды. Данная конечная является вершиной пирамиды. Возможно расположение конечной точки оси в любом месте 3D пространства. Конечная точка оси определяет длину пирамиды и ее положение в пространстве.

Конечная точка оси: Указать точку

Радиус верхнего основания

Указывается верхний радиус пирамиды при создании усеченной пирамиды.

Радиус верхнего основания : Ввести значение

Первоначально значение верхнего радиуса по умолчанию не задано. В сеансе черчения значение верхнего радиуса по умолчанию всегда равняется предыдущему заданному значению верхнего радиуса любого элементарного тела.

Высота или [2Точка (Две точки)/Конечная точка оси]] <по умолчанию>: Указать высоту, задать опцию или нажать ENTER для выбора значения высоты по умолчанию

2Точка

Указывается, что высота пирамиды равняется расстоянию между двумя указанными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Указывается местоположение конечной точки для оси пирамиды. Данная конечная является вершиной пирамиды. Возможно расположение конечной точки оси в любом месте 3D пространства. Конечная точка оси определяет длину пирамиды и ее положение в пространстве.

Конечная точка оси: Указать точку


ПЛАН Команда

П Команды
П Команды
ПЛАН Команда
Понятия Процедуры Команды

Отображение вида в плане указанной ПСК

Меню "Вид": "3D виды" » "Вид в плане"

Ввод команды: план

Задайте опцию[Текущая пск/Пск/МСК]<Текущая>:Ввести опцию или нажать ENTER

Текущая ПСК

Регенерация вида изображения в плане для вписывания границ чертежа в текущий видовой экран текущей ПСК.

ПСК

Переключение в план предварительно сохраненной ПСК и регенерация изображения.

Имя ПСК или [?]: Ввести имя или ? для вывода всех имен ПСК чертежа

Если на запрос ввести ?, отобразится следующий запрос:

Имена ПСК для вывода <*>: Ввести имя или * для вывода имен ПСК чертежа

МСК

Регенерация вида изображения в плане для вписывания границ чертежа в текущий видовой экран текущей мировой системы координат.


ПЛАНШЕТ Команда

П Команды
П Команды
ПЛАНШЕТ Команда
Понятия Процедуры Команды

Настройка, калибровка, включение и отключение графического планшета

Меню "Сервис": "Планшет"

Ввод команды: планшет

Задайте опцию [Вкл/Откл/Клб/Нас]:

Вкл

Включение режима "Планшет". Режим "Планшет" также можно включить, присвоив системной переменной TABMODE значение 1. В некоторых системах для включения/отключения режима "Планшет" служит комбинация клавиш CTRL + T.

Откл

Отключение режима "Планшет". Режим "Планшет" также можно отключить, присвоив системной переменной TABMODE значение 0. В некоторых системах для включения/отключения режима "Планшет" служит комбинация клавиш CTRL + T.

Клб

Калибровка дигитайзера по чертежу на бумаге или фотографии; установка соответствия координат точек чертежа на бумажном носителе и координат точек электронного чертежа. Калибровка заключается в преобразовании чертежа на бумажном носителе в электронный чертеж и установке соответствия полученных и истинных координат точек.

Калибровку можно выполнять как в пространстве модели, так и в пространстве листа. Выбор опции "Клб" включает режим "Планшет" в том пространстве, где выполняется калибровка планшета. При изменении пространства выбор опции "Клб" отключает режим "Планшет".

Бумага должна быть ровной (без вздутий и морщин) и тщательно закреплена на графическом планшете. Бумагу можно закрепить на планшете под любым углом.

Укажите точку номер 1: Указать точку чертежа на бумаге

Введите координаты для точки номер 1: Ввести координаты X и Y указанной точки

Укажите точку номер 2: Указать точку чертежа на бумаге

Введите координаты для точки номер 2: Ввести координаты X и Y указанной точки

Укажите точку номер 3 (или нажмите ENTER для завершения): Указать точку на планшете или нажать ENTER

Введите координаты для точки номер 3: Ввести координаты X и Y указанной точки

Вводимые координаты не должны совпадать. Не обязательно выбирать точки, расположенные в начале осей. Вводить можно любое число точек. Чем больше точек указано, тем точнее калибровка.

Если введены только две точки, вычисляется ортогональное преобразование. В случае успеха команда завершается.

Если введено три или более точек, вычисляется преобразование всех трех типов (ортогональное, аффинное, проекционное) и определяется, какое из них наилучшим образом соответствует указанным калибровочным точкам. Если введено более четырех точек, вычисление наиболее подходящего проекционного преобразования может занять много времени. Чтобы прервать вычисление преобразования, следует нажать ESC.

После завершения вычислений на экран выводится таблица результатов калибровки. В ней содержатся точки калибровки и типы преобразований.

Если проекционное преобразование выполнено успешно, предлагается выбрать тип преобразования:

Выберите тип преобразования [Ортогональное/Аффинное/Проекционное/Таблица] <Таблица>: Задать опцию или нажать ENTER

В запрос включаются только типы преобразований, показатель соответствия которых имеет значение "Успешное", "Точное" или "Прервано". Можно задать проекционное преобразование, даже если оно было прервано. Программа использует величины, которые были вычислены к моменту прерывания.

Ортогональное

Задает преобразование по двум калибровочным точкам, которое включает перенос, пропорциональное масштабирование и поворот.

Ортогональное преобразование используется при оцифровке чертежей, выполненных на бумаге в правильном масштабе, а также для оцифровки длинных узких фрагментов чертежей, состоящих главным образом из отдельных линий.

Примечание Сначала следует задать левую нижнюю точку чертежа, затем — правую верхнюю.

Аффинное

Задает произвольное линейное преобразование, включая: масштабирование, осуществляемое независимо по осям X и Y, поворот и наклон. Определяется тремя точками.

Аффинное преобразование используется, если горизонтальные размеры чертежа на бумаге растянуты относительно вертикальных, а параллельные линии чертежа на бумаге являются параллельными в электронном чертеже.

Характеристикой точности преобразования является значение средней квадратической ошибки (СК-ошибки), которое выводится на экран по завершении калибровки. Аффинное преобразование рекомендуется применять при небольших значениях СК-ошибки.

Проекционное

Задает преобразование по четырем калибровочным точкам, которое эквивалентно перспективной проекции одной плоскости пространства на другую плоскость. При проекционном преобразовании используется частный случай метода, который картографы называют листовая резина. Прямые линии отображаются в прямые линии. Параллельные линии не обязательно остаются параллельными.

При нарушении параллельности прямых проекционное преобразование обеспечивает их корректировку.

Повтор таблицы

Повторный вывод таблицы с результатами калибровки.

Таблица преобразований

Вывод числа калибровочных точек, а также информации о каждом типе преобразования.

Соответствие

Вывод показателя соответствия для каждого типа преобразования. Если показатели соответствия для всех типов преобразований имеют значения, отличные от "Успешное" или "Точное", программа выводит сообщение о неудачном выполнении калибровки и завершает выполнение команды. Остальные ячейки в каждом столбце заполняются только в том случае, если показатель соответствия имеет значение "Успешное".

Точное

Означает, что количество указанных точек однозначно задает преобразование данного типа.

Успешное

Означает, что указанное количество точек достаточно для того, чтобы задать преобразование данного типа. Преобразование выполнено успешно.

Отсутствует

Означает, что для данного типа преобразования задано недостаточное количество точек.

Сбой

Означает, что количество точек достаточно для преобразования, но программа не может выполнить преобразование (обычно из-за того, что некоторые точки совпадают или лежат на одной прямой).

Прервано

Означает, что процесс преобразования не завершен. Этот значение показателя соответствия возможно только при проекционном преобразовании.

СК-ошибка

Вывод на экран значения средней квадратической ошибки, характеризующего точность преобразования. При калибровке планшета следует добиваться получения как можно меньшей среднеквадратичной ошибки.

Среднее отклонение

Вывод значения среднего отклонения. Если это значение близко к нулю, отклонение по каждой калибровочной точке также близко к нулю.

Наибольшая невязка/В точке

Вывод точки, имеющей наибольшую невязку. Невязка — это расстояние между фактической и идеальной проекцией точки. Расстояние выражается в текущих линейных единицах.

Вторая наибольшая невязка/В точке

Вывод точки, имеющей вторую по величине невязку. Невязка — это расстояние между фактической и идеальной проекцией точки. Расстояние выражается в текущих линейных единицах.

Нас

Данная опция позволяет задать или перегруппировать области меню планшета или определить небольшой участок планшета как область указания точек.

Введите требуемое количество меню планшета (0-4) <текущее>: Ввести значение или нажать ENTER

Если меню планшета включены и указано число, равное их количеству, выводится следующий запрос:

Перегруппировать меню планшета? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

Укажите левый верхний угол области меню номер n : Указать точку (1)

Укажите левый нижний угол области меню номер n : Указать точку (2)

Укажите правый нижний угол области меню номер n : Указать точку (3)

В запросе n - это номер меню (1-4).

Необходимо закрепить распечатанную форму меню на поверхности планшета и по запросу указать точки для оцифровки. Три указанные точки должны образовывать угол в 90 градусов. Области меню планшета могут быть наклонены под любым углом.

Число столбцов в области меню номер n : Ввести положительное значение

Число строк в области меню номер n : Ввести положительное значение

После завершения диалога, связанного с меню планшета, отображается следующий запрос:

Переопределить фиксированную область указания точек? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

Если ввести д, отображаются следующие запросы:

Укажите левый нижний угол области указания точек: Указать точку

Укажите правый верхний угол области указания точек: Указать точку

Под фиксированную область указания точек отводится небольшой фрагмент поверхности планшета. В командной строке отображается следующий запрос:

Задать плавающую область указания точек? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

Если в ответ на предыдущий запрос ввести д, отображается следующий запрос:

Нужно, чтобы плавающая область указания точек была того же размера, что и фиксированная область указания точек? [Да/Нет] <Д>: Ввести д или н или нажать ENTER

Если в ответ на предыдущий запрос ввести н, отображаются следующие запросы:

Укажите левый нижний угол плавающей области указания точек: Указать точку

Укажите правый верхний угол плавающей области указания точек: Указать точку

Далее следует запрос:

Задать кнопку переключения плавающей области указания точек? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

Если в ответ на предыдущий запрос ввести д, отображается следующий запрос:

Нажмите любую кнопку, не используемую для указания точек, чтобы назначить ей функцию переключения на плавающую область указания точек


ПЛИНИЯ Команда

П Команды
П Команды
ПЛИНИЯ Команда
Понятия Процедуры Команды

Построение двумерных полилиний

Панель Рисование:

Меню "Рисование": Полилиния

Ввод команды: плиния

Начальная точка: Указать точку (1)

Текущая ширина полилинии равна <текущая>

Следующая точка или [Дуга/Замкнуть/Полуширина/Длина/Отменить/Ширина]: Указать точку (2) или задать опцию

Системная переменная PLINEGEN управляет отображением образца типа линии по периметру вершин двумерной полилинии и их сглаживанием. Если PLINEGEN равна 1, новые полилинии создаются в виде непрерывного образца по периметру вершин готовой полилинии. Если PLINEGEN равна 0, каждый сегмент полилинии обязательно начинается и заканчивается штрихом на каждой вершине. PLINEGEN не применяется к полилиниям с расширяющимися или сужающимися сегментами.

Следующая точка

Построение линейного сегмента. Предыдущий запрос будет выведен повторно.

Дуга

Добавление дуговых сегментов в полилинию.

Конечная точка дуги или

[Угол/ЦЕнтр/ЗАмкнуть/Направление/Полуширина/Линейный/Радиус/Вторая/Отменить/Ширина]: Указать точку (2) или задать опцию

Примечание Чтобы задать опцию "Центр" команды ПЛИНИЯ, необходимо ввести ц; чтобы задать режим объектной привязки "Центр", ввести цен или центр.

Конечная точка дуги

Построение дугового сегмента. Дуговой сегмент расположен по касастельной к предыдущему сегменту полилинии. Предыдущий запрос будет выведен повторно.

Угол

Задание центрального угла дугового сегмента от начальной точки.

Центральный угол:

Положительные значения угла соответствуют построению дугового сегмента против часовой стрелки. Отрицательные значения угла соответствуют построению дугового сегмента по часовой стрелке.

Конечная точка дуги или [Центр/Радиус]: Указать точку или задать опцию

Конечная точка дуги

Построение дугового сегмента до указанной конечной точки.

Центр

Задание центра дугового сегмента.

Задать центр дуги:

Радиус

Задание радиуса дугового сегмента.

Радиус дуги: Задать расстояние

Направление хорды для дуги <текущее>: Указать точку или нажать ENTER

Центр

Задание центра дугового сегмента.

Центр дуги: Указать точку (2)

Конечная точка дуги или [Угол/Длина]: Указать точку (3) или задать опцию

Конечная точка дуги

Построение дугового сегмента до указанной конечной точки.

Угол

Задание центрального угла дугового сегмента от начальной точки.

Центральный угол:

Длина

Задание длины хорды дугового сегмента. Если предыдущим сегментом был дуговой сегмент, то новый дуговой сегмент строится касательно к предыдущему.

Длина хорды

Замкнуть

Строит дуговой сегмент от последней точки, заданной как начальная, и создает замкнутую полилинию. Для применения этой опции следует указать как минимум две точки.

Направление

Задание начального направления дугового сегмента.

Направление касательной для начальной точки дуги: Указать точку (2)

Конечная точка дуги: Указать точку (3)

Полуширина

Задание расстояния от осевой линии широкого сегмента полилинии до одного из его краев.

Начальная полуширина <текущая>: Ввести значение или нажать ENTER

Конечная полуширина <начальная ширина>: Ввести значение или нажать ENTER

Заданная начальная полуширина становится значением по умолчанию для конечной. Значение конечной полуширины становится стандартным для всех последующих сегментов до следующего изменения полуширины. Начальная и конечная точки широких линейных сегментов находятся на центральной оси сегмента.

Обычно места пересечений смежных широких сегментов полилинии подрезаются. Этого не происходит для некасательных дуговых сегментов, очень острых углов пересечения или при использовании прерывистого типа линий.

Линия

Выход из опции "Дуга" и возврат к начальным запросам команды ПЛИНИЯ.

Радиус

Задание радиуса дугового сегмента.

Радиус дуги: Задать расстояние

Указать конечную точку дуги или [Угол]: Указать точку или ввести у

Конечная точка дуги

Обозначение конечной точки и построение дугового сегмента.

Угол

Задание центрального угла дугового сегмента.

Центральный угол:

Направление хорды для дуги <текущее>: Задать угол или нажать ENTER

Вторая тчк

Обозначение второй точки и конечной точки трехточечной дуги.

Вторая точка дуги: Указать точку (2)

Конечная точка дуги: Указать точку (3)

Отменить

Удаление последнего дугового сегмента, добавленного к полилинии.

Ширина

Задание ширины следующего дугового сегмента.

Начальная ширина <текущая>: Ввести значение или нажать ENTER

Конечная ширина <начальная ширина>: Ввести значение или нажать ENTER

Начальная ширина становится конечной шириной по умолчанию. Значение конечной ширины становится стандартным для всех последующих сегментов до нового изменения ширины. Начальная и конечная точки широких линейных сегментов находятся на центральной оси сегмента.

Обычно места пересечений смежных широких сегментов полилинии подрезаются. Этого не происходит для некасательных дуговых сегментов, очень острых углов пересечения или при использовании прерывистого типа линий.

Замкнуть

Строит линейный сегмент от последней точки, заданной как начальная, и создает замкнутую полилинию. Для применения этой опции следует указать как минимум две точки.

Полуширина

Задание расстояния от осевой линии широкого сегмента полилинии до одного из его краев.

Начальная полуширина <текущая>: Ввести значение или нажать ENTER

Конечная полуширина <текущая>: Ввести значение или нажать ENTER

Заданная начальная полуширина становится значением по умолчанию для конечной. Значение конечной полуширины становится стандартным для всех последующих сегментов до нового изменения полуширины. Начальная и конечная точки широких линейных сегментов находятся на центральной оси сегмента.

Обычно места пересечений смежных широких сегментов полилинии подрезаются. Этого не происходит для некасательных дуговых сегментов, очень острых углов пересечения или при использовании прерывистого типа линий.

Длина

Построение линейного сегмента по заданной длине под тем же углом, что и предыдущий сегмент. Если предыдущим сегментом был дуговой сегмент, то новый линейный сегмент строится касательно к предыдущему.

Длина линейного сегмента: Задать расстояние

Отменить

Удаление последнего линейного сегмента, добавленного к полилинии.

Ширина

Задание ширины следующего линейного сегмента.

Начальная ширина <текущая>: Ввести значение или нажать ENTER

Конечная ширина <начальная ширина>: Ввести значение или нажать ENTER

Введенное значение начальной ширины автоматически становится предлагаемым по умолчанию значением конечной ширины. Значение конечной ширины становится стандартным для всех последующих сегментов до нового изменения ширины. Начальная и конечная точки широких линейных сегментов находятся на центральной оси сегмента.

Обычно места пересечений смежных широких сегментов полилинии подрезаются. Этого не происходит для некасательных дуговых сегментов, очень острых углов пересечения или при использовании прерывистого типа линий.


ПЛОСКПОВ Команда

П Команды
П Команды
ПЛОСКПОВ Команда
Понятия Процедуры Команды

Создается плоская поверхность

Панель инструментов "Моделирование:

Меню "Рисование": "Моделирование" » "Плоская поверхность"

Ввод команды: плоскпов

Пульт управления: Панель "3D Создать", "Плоская поверхность"

С помощью команды ПЛОСКПОВ можно создать плоскую поверхность с помощью любого из указанных ниже методов:

  • Выбрать один или несколько объектов, образующих один или несколько замкнутых областей.
  • Указать противолежащие углы прямоугольника с помощью команды.

Когда задаются углы поверхности с помощью команды, создаваемая поверхность параллельна плоскости построений.

Количество линий, отображаемых на поверхности, определяется системными переменными SURFU и SURFV.

Укажите первый угол или [Объект]: Указать первую точку для плоской поверхности

Укажите другой угол: Указать вторую точку (другой угол) для плоской поверхности

Объект

Создается плоская или усеченная поверхность по выбору объекта. Можно выбрать один замкнутый объект или множество объектов, образующих замкнутую область.

Аналогично команде ОБЛАСТЬ, действительными объектами являются следующие: линия, окружность, дуга, эллипс, эллиптическая дуга, 2D полилиния, плоская 3D полилиния и плоский сплайн.

Системная переменная DELOBJ определяет, удаляются ли выбранные пользователем объекты автоматически после создания поверхности либо пользователю выводится запрос на удаление объектов.

Выберите объекты: Выбрать один или несколько объектов, определяющих область для плоской поверхности


ПЛОСКСНИМОК Команда

П Команды
П Команды
ПЛОСКСНИМОК Команда
Понятия Процедуры Команды

Создание 2D представления всех 3D объектов в текущем виде

Ввод команды: плоский снимок

Пульт управления: Панель создания 3D объектов, Плоский снимок

Откроется диалоговое окно "Плоский снимок".

Темы:

  • Диалоговое окно "Плоский снимок"


Диалоговое окно "Плоский снимок"

П Команды
П Команды
Диалоговое окно "Плоский снимок"
Понятия Процедуры Команды

Ввод команды: плоский снимок

Пульт управления: Панель создания 3D объектов, Плоский снимок

Создание 2D или "плоского" представления всех 3D объектов в текущем виде.

Размещение

Определяет место для создания плоского представления.

Вставить в виде нового блока

Вставка плоского представления в текущий чертеж в качестве блока.

Заменить существующий блок

Замена существующего в чертеже блока на вновь созданный блок.

Выбор блока

Временное закрытие диалогового окна при выборе блока чертежа для замены. После выбора блока нажмите ENTER для повторного открытия диалогового окна "Плоский снимок".

Блок выбран

Показывает, выбран ли блок.

Экспортировать в файл

Сохранение блока во внешний файл.

Линии переднего плана

Содержит средства установки цвета и типа линий переднего плана в плоском виде.

Цвет

Установка цвета линий переднего плана в плоском виде.

Тип линий

Установка типа линий переднего плана в виде.

Линии заднего плана

Определяет, будут ли отображаться присутствующие на чертеже линии заднего плана в плоском виде и позволяет установить цвет и тип этих линий.

Показать

Управляет плоским представлением линий заднего плана. В случае выбора 2D плоского представления линии, скрытые другими объектами, отображаются.

Цвет

Установка цвета линий, расположенных под объектами геометрии в плоском виде.

Тип линий

Установка типа линий, расположенных под объектами геометрии в плоском виде.

Создать

Создание плоского вида


ПЛОЩАДЬ Команда

П Команды
П Команды
ПЛОЩАДЬ Команда
Понятия Процедуры Команды

Вычисление площадей и периметров объектов или заданных областей

Панель "Сведения":

Меню "Инструменты": "Сведения" » подменю "Площадь"

Ввод команды: площадь

Указать первую угловую точку или [Объект/Добавить/Вычесть]: Указать точку (1) или задать опцию

Первая угловая точка

Вычисление площади и периметра воображаемых фигур, заданных указанием точек. Все точки должны лежать в плоскости, параллельной плоскости XY текущей системы координат пользователя ПСК.

Указать следующую угловую точку или нажать клавишу ENTER \\для вычисления общей суммы: Указать точку (2)

Продолжать указание точек, чтобы определить многоугольник, затем нажать клавишу ENTER для завершения определения периметра.

Если многоугольник незамкнутый, значение площади вычисляется так, как если бы последняя и первая точка были соединены прямым отрезком. При вычислении периметра учитывается длина этого отрезка.

Объект

Вычисление площади и периметра выбранного объекта. Таким образом можно находить площади кругов, эллипсов, сплайнов, полилиний, многоугольников, областей и тел.

Примечание Для 2D тел (построенных с помощью команды ТЕЛО) не указывается значение площади.

Выбрать объекты:

При выборе незамкнутой полилинии, значение площади вычисляется так, как если бы последняя и первая точка были соединены прямым отрезком. При вычислении периметра длина этого отрезка не учитывается.

Для полилиний с ненулевой шириной площадь и длина (периметр) вычисляются по их продольной оси.

Добавить

Включение режима добавления последовательно вычисляемых площадей к итоговому значению. Пользователю выдаются сведения как о площади и периметре отдельных областей и объектов, так и об общей площади. Для вычитания площадей из суммарного значения служит опция "Вычесть".

Первая угловая точка или [Объект/Вычесть]: Указать точку (1) или задать опцию

Первая угловая точка

Вычисление площади и периметра фигур, заданных указанием угловых точек. Все точки должны лежать в плоскости, параллельной плоскости XY текущей ПСК.

Указать следующую угловую точку или нажать клавишу ENTER для вычисления общего значения (режим добавления): Указать точку (2)

Указать точки, описывающие границу измеряемой многоугольной области (3). Нажать ENTER. С помощью команды ПЛОЩАДЬ вычисляется площадь и периметр и возвращается суммарная измеренная площадь объектов и заданных точками областей с момента включения режима добавления.

Если многоугольник незамкнутый, значение площади вычисляется так, как если бы последняя и первая точка были соединены прямым отрезком. При вычислении периметра учитывается длина этого отрезка.

Объект

Вычисление площади и периметра выбранного объекта.

(Режим добавления) Выбрать объекты:

С помощью команды ПЛОЩАДЬ вычисляется площадь и периметр и возвращается суммарная измеренная площадь объектов и заданных точками областей с момента включения режима добавления.

При выборе незамкнутой полилинии, значение площади вычисляется так, как если бы последняя и первая точка были соединены прямым отрезком. При вычислении периметра длина этого отрезка не учитывается.

Для полилиний с ненулевой шириной площадь и длина (периметр) вычисляются по их продольной оси.

Вычесть

Включение режима вычитания последовательно вычисляемых площадей из накапливаемого суммарного значения.

Вычесть

Включение режима вычитания последовательно вычисляемых площадей из накапливаемого суммарного значения. Все его опции подобны опциям режима добавления.


ПМТЗАКРЫТЬ Команда

П Команды
П Команды
ПМТЗАКРЫТЬ Команда
Понятия Процедуры Команды

Закрывает Диспетчер наборов пометок

Панель "Стандартная":

Меню "Сервис": Диспетчер наборов пометок

Ввод команды: пмтзакрыть

Окно Диспетчер наборов пометок закрывается.


ПМТНАБОР Команда

П Команды
П Команды
ПМТНАБОР Команда
Понятия Процедуры Команды

Отображает сведения о пометках с возможностью изменения их статуса

Панель "Стандартная":

Меню "Сервис": "Палитры" » "Диспетчер наборов пометок"

Ввод команды: пмтнабор

Команда вызывает Диспетчер наборов пометок.

Темы:

  • Диспетчер наборов пометок


Диспетчер наборов пометок

П Команды
П Команды
Диспетчер наборов пометок
Понятия Процедуры Команды

Панель "Стандартная":

Меню "Сервис": Диспетчер наборов пометок

Ввод команды: пмтнабор

В диалоговом окне приводится информация о загруженных наборах пометок и их статусе. Пометки и исходные файлы чертежей можно отобразить или скрыть в области рисования. Можно изменить статус отдельных пометок, а также снабдить их примечаниями и комментариями.

Список наборов пометок

В списке наборов пометок отображается имя набора пометок. Если не открыто ни одного набора пометок, в этом списке присутствует лишь опция "Открыть". В списке наборов пометок имеются также следующие опции.

Имена открытых наборов пометок

Список всех открытых наборов пометок (если имеются). Текущий набор пометок помечается галочкой. Текущим является открытый набор пометок, имя которого отображается в окне Диспетчера наборов пометок.

Недавние

Список недавно открывавшихся наборов пометок.

Открыть

Открывается диалоговое окно "Открытие DWF-файла пометок" (стандартное диалоговое окно выбора файлов), в котором можно выбрать файл Design Web Format™ (DWF™), содержащий пометки. При нажатии кнопки "Открыть" пометки из выбранного DWF-файла загружаются в Диспетчер наборов пометок.

Повторить публикацию DWF-файла

Здесь предлагаются варианты перепубликации DWF-файла с пометками. Любые листы, добавляемые в файл DWF с помощью Autodesk® Design Review, не включаются в повторно публикуемый файл DWF.

Повторить публикацию всех листов

Повторная публикация всех листов в DWF-файле с пометками. Открывается диалоговое окно "Выбор DWF-файла" (стандартное диалоговое окно выбора файлов), в котором можно выбрать ранее опубликованный DWF-файл для перезаписи или задать имя для нового DWF-файла. При нажатии кнопки "Выбрать" происходит перезапись ранее опубликованного DWF-файла или создается новый DWF-файл. При этом сохраняются все выполненные изменения геометрии чертежа или статуса пометок.

Повторить публикацию листов с пометками

Повторная публикация выполняется только для тех листов DWF-файла, для которых имеются соответствующие пометки. Открывается диалоговое окно "Выбор DWF-файла" (стандартное диалоговое окно выбора файлов), в котором можно выбрать ранее опубликованный DWF-файл для перезаписи или задать имя для нового DWF-файла. При нажатии кнопки "Выбрать" происходит перезапись ранее опубликованного DWF-файла или создается новый DWF-файл. При этом сохраняются все выполненные изменения геометрии чертежа или статуса пометок.

Просмотр геометрии пометок

Отображает или скрывает геометрию пометок в области рисования. Если кнопка находится в нажатом состоянии, геометрия пометок отображается в области рисования.

Просмотр геометрии DWG

Отображает или скрывает исходный файл чертежа в области рисования. Если кнопка находится в нажатом состоянии, файл чертежа отображается в области рисования.

Просмотр геометрии DWF

Отображает или скрывает геометрию файла DWF в области рисования. Если кнопка находится в нажатом состоянии, геометрия файла DWF отображается в области рисования.

Пометки

Здесь отображаются загруженные наборы пометок. Текущий загруженный набор пометок отображается на самом верхнем уровне древовидной структуры. Кроме того, свой узел соответствует и каждому листу, для которого имеются пометки. Все листы, добавленные в DWF-файл с помощью Autodesk Design Review, помечаются курсивным шрифтом. Каждая пометка отображается в виде отдельного узла, вложенного в структуру соответствующего листа. Статус пометки отображается с помощью специального значка. Чтобы просмотреть связанный лист чертежа в области рисования, можно дважды нажать левую кнопку мыши на пометке в области структуры. При двойном нажатии на листе, добавленном с помощью Autodesk Design Review, или на пометке, нанесенной для такого листа, открывается Autodesk DWF Viewer (или Autodesk Design Review, если эта программа установлена в системе).

Узел набора пометок

Обозначает текущий загруженный набор пометок.

Узел листа

Обозначает лист, для которого имеется хотя бы одна пометка. В древовидной структуре области пометок отображаются только те листы, для которых были сделаны пометки. Двойным нажатием левой кнопки мыши на узле листа можно открыть для него соответствующий исходный файл чертежа.

<Нет>

Обозначает отдельную пометку, для которой не задан статус. Пометки имеют такой статус по умолчанию при создании.

Вопрос

Обозначает отдельную пометку, которой присвоен статус "Вопрос". При открытии и просмотре пометки можно установить для нее статус "Вопрос", если для нее необходима дополнительная информация.

Рассмотрение

Обозначает отдельную пометку, которой присвоен статус "Рассмотрение". При работе с пометкой можно установить для нее статус "Рассмотрение" для указания на то, что пометка была учтена в чертеже, а автор пометки должен рассмотреть выполненные на листе изменения.

Выполнено

Обозначает отдельную пометку, которой присвоен статус "Выполнено". Статус "Выполнено" присваивается пометкам, которые были применены и утверждены в чертеже.

Опции контекстного меню пометок (для узла набора пометок)

При нажатии правой кнопки мыши на узле набора пометок открывается контекстное меню, в котором содержатся следующие опции.

Открыть DWF-файл пометок

Вызов диалогового окна "Открытие DWF-файла пометок" (стандартного окна выбора файлов), в котором можно выбрать файл формата DWF, содержащий пометки. При нажатии кнопки "Открыть" пометки из выбранного DWF-файла загружаются в Диспетчер наборов пометок.

Закрыть DWF-файл пометок

Выбранный DWF-файл пометок закрывается и удаляется из Диспетчера наборов пометок.

Сохранить журнал пометок

Сохранение изменений в статусе пометок и добавленных для DWF-файла примечаний.

Опции контекстного меню пометок (для узла листа)

При нажатии правой кнопки мыши на узле листа открывается контекстное меню, в котором содержатся следующие опции.

Открыть лист

Открывает исходный файл чертежа для этого листа и устанавливает его текущим в области рисования.

Повторить публикацию DWF-файла

Открывается диалоговое окно "Выбор DWF-файла" (стандартное диалоговое окно выбора файлов), в котором можно выбрать ранее опубликованный DWF-файл для перезаписи или задать имя для нового DWF-файла. При нажатии кнопки "Выбрать" создается новый DWF-файл, в котором сохраняются все выполненные изменения геометрии чертежа или статуса пометок.

Опции контекстного меню пометок (для узла пометок)

При нажатии правой кнопки мыши на узле пометки открывается контекстное меню, в котором содержатся следующие опции.

Открыть пометку

Открывает исходный файл чертежа для листа, связанного с выбранной пометкой, и устанавливает этот лист текущим в области рисования. Связанный файл пометки DWF также открывается в виде нередактируемой ссылки в области рисования.

Статус пометки

Отображает контекстное меню, содержащее список возможных вариантов статуса пометки. Текущий статус выбранной пометки помечается галочкой.

  • <Нет>: Обозначает, что для пометки не задан статус. Пометки имеют такой статус по умолчанию при создании.
  • Вопрос: После открытия и просмотра пометки можно изменить ее статус на "Вопрос", если необходимо получить о ней дополнительные сведения.
  • Рассмотрение: После ввода в действие пометки можно изменить ее статус на "Рассмотрение" для обозначения того, что пометка была учтена в чертеже, а автор пометки должен рассмотреть выполненные на листе изменения.
  • Выполнено: Статус "Выполнено" присваивается пометкам, которые были применены и утверждены в чертеже.

Вернуть исходное состояние пометки

Восстановление исходного вида выбранной пометки после операций зумирования, панорамирования или вращения вида в пространстве модели.

Повторить публикацию DWF-файла

Открывается диалоговое окно "Выбор DWF-файла" (стандартное диалоговое окно выбора файлов), в котором можно выбрать ранее опубликованный DWF-файл для перезаписи или задать имя для нового DWF-файла. При нажатии кнопки "Выбрать" происходит перезапись ранее опубликованного DWF-файла или создается новый DWF-файл. При этом сохраняются все выполненные изменения геометрии чертежа или статуса пометок.

Показать все листы/Скрыть листы без пометок

Отображение всех листов из DWF-файла пометок в древовидной структуре Диспетчера наборов пометок или скрытие листов, которым не назначены пометки.

Подробности

Сведения о выбранном в области "Пометки" узле (для набора пометок, листа или отдельной пометки).

Если в области "Пометки" выбрана отдельная пометка, то в области "Подробности" отображается статус этой пометки. Здесь статус пометки можно изменить.

В области "Журнал пометок" (в нижней части области "Подробности") приводятся в обратном хронологическом порядке нередактируемые сведения об истории выбранной пометки. В области "Примечания", расположенной под журналом для пометки, можно записать любые примечания и комментарии, которые автоматически сохраняются вместе с пометкой.

Просмотр

Замена области "Подробности" на область "Образец", в которой отображается образец выбранного листа или пометки. Для того чтобы снова перейти к просмотру подробностей, следует нажать на кнопку "Подробности".

Подробности

Замена области "Образец" на область "Подробности", в которой приводятся сведения о выбранном в области "Пометки" узле. Для того чтобы снова перейти к просмотру образца, следует нажать на кнопку "Образец".

Предварительный просмотр

Образец для предварительного просмотра выбранного листа или пометки.

Подробности

Замена области "Образец" на область "Подробности", в которой приводятся сведения о выбранном в области "Пометки" узле. Для того чтобы снова перейти к просмотру образца, следует нажать на кнопку "Образец".

Просмотр

Замена области "Подробности" на область "Образец", в которой отображается образец выбранного листа или пометки. Для того чтобы снова перейти к просмотру подробностей, следует нажать на кнопку "Подробности".


ПОВЕРНУТЬ Команда

П Команды
П Команды
ПОВЕРНУТЬ Команда
Понятия Процедуры Команды

Поворачивает объект вокруг базовой точки.

Панель Редактирование:

Меню "Редактирование": "Повернуть"

Контекстное меню: Выбрать объекты для поворота и щелкнуть правой кнопкой мыши в области рисования. Щелкнуть "Повернуть".

Ввод команды: повернуть

Текущие установки отсчета углов в ПСК: ANGDIR=текущая ANGBASE=текущая

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении

Базовая точка: Укажите точку

Угол поворота или [Копия/Опорный угол]: Введите угол, укажите точку, введите к или введите о

Угол поворота

Определяет, на какой угол объект поворачивается вокруг базовой точки.

Ось, вокруг которой поворачиваются объекты, проходит через указанную базовую точку и параллельна оси Z текущей ПСК.

Копия

Создает копии выбранных объектов для поворота.

Опорный угол

Поворачивает объекты с указанного угла на новый, абсолютный угол.

Опорный угол <последний опорный угол>: Задать угол либо вводом значения или указанием двух точек

Новый угол или [Точки] <последний новый угол>: Задать новый абсолютный угол вводом значения или указанием двух точек

При повороте объекта типа «видовой экран» границы видового экрана остаются параллельными границам области рисования.


ПОВЕРНУТЬ3D Команда

П Команды
П Команды
ПОВЕРНУТЬ3D Команда
Понятия Процедуры Команды

Поворот объектов вокруг оси в 3D пространстве

Ввод команды: повернуть3d

Рекомендуется использовать для манипулирования 3D объектами ручки, управление которыми выполняется вызовом команд 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ. Подробнее об использовании ручек см. Использование инструментов ручек для редактирования объектов.

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении

Укажите первую точку на оси или определите ось с помощью [Объект/Последний/Вид/Xось/Yось/Zось/2точки]: Указать точку, задать опцию или нажать ENTER

Объект

Совмещение оси вращения с существующим объектом.

Выберите отрезок, круг, дугу или сегмент 2-мерной полилинии:

Линия

Совмещает ось поворота с выбранным отрезком.

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол <0>: Задать начальный угол

Новый угол: Конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.

Круг

Совмещение оси поворота с 3D осью круга (линией, перпендикулярной к плоскости круга и проходящей через центр круга).

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол <0>: Задать начальный угол

Новый угол: Конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.

Дуга

Совмещение оси поворота с 3D осью дуги (линией, перпендикулярной к плоскости дуги и проходящей через центр дуги).

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол <0>: Задать начальный угол

Новый угол: Конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.

Сегмент 2М полилинии

Совмещение оси поворота с сегментом полилинии. Прямолинейные сегменты рассматриваются как отрезки. Дуговые сегменты рассматриваются как дуги.

Угол поворота или [Опорный угол]: Задать угол или ввести r

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол <0>: Задать начальный угол

Новый угол: Конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.

Последний

Использует последнюю заданную ось поворота.

Угол поворота или [Опорный угол]: Задать угол или ввести r

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол <0>: Задать начальный угол

Новый угол: Конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.

Вид

Совмещение оси поворота с направлением взгляда на текущем видовом экране, проходящем через выбранную точку.

Точка на оси направления взгляда <0,0,0>:

Угол поворота или [Опорный угол]: Задать угол или ввести r

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол <0>: Задать начальный угол

Новый угол: Конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.

Xось, Yось, Zось

Совмещает ось поворота с одной из стандартных осей (X, Y или Z), проходящей через выбранную точку.

Точка на оси (X, Y или Z) <0,0,0>: Указать точку (1)

Угол поворота или [Опорный угол]: Задать угол или ввести r

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол <0>: Задать начальный угол

Новый угол: Конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.

"2 точки"

Задание оси поворота путем указания двух точек. Нажатие ENTER в ответ на главную подсказку команды ПОВЕРНУТЬ3D вызывает вывод указанных ниже запросов. Если в ответ на главную подсказку команды указать точку, первый запрос из приведенной ниже последовательности опускается.

Первая точка оси: Указать точку (1)

Вторая точка оси: Указать точку (2)

Угол поворота или [Опорный угол]: Задать угол или ввести r

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол <0>: Задать начальный угол

Новый угол: Конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.


ПОВТОРИТЬ Команда

П Команды
П Команды
ПОВТОРИТЬ Команда
Понятия Процедуры Команды

Отменяет действие последней команды ОТМЕНИТЬ или О

Панель Стандартная

Меню "Правка": "Повторить"

Контекстное меню: Убедиться, что нет выполняющихся команд и выбранных объектов, щелкнуть правой кнопкой мыши в области рисования и выбрать «Повторить» из контекстного меню.

Ввод команды: повторить

ПОВТОРИТЬ отменяет действие только одной команды ОТМЕНИТЬ или команды О. Команда ПОВТОРИТЬ должна следовать сразу после команды О или ОТМЕНИТЬ.


ПОДЕЛИТЬ Команда

П Команды
П Команды
ПОДЕЛИТЬ Команда
Понятия Процедуры Команды

Размещение по длине или периметру объекта на равном расстоянии точек или блоков

Меню "Рисование": "Точка" » подменю "Поделить"

Ввод команды: поделить

Выбрать объект для деления: Выбрать объекты любым способом

Число сегментов или [Блок]: Ввести значение от 2 до 32,767 или ввести b

Число сегментов

Расставляет вдоль выбранного объекта объекты-точки с заданными интервалами.

На чертеже показана полилиния, разделенная на пять частей. Режим отображения точек (PDMODE) был установлен таким образом, чтобы точки были заметны.

Блок

Расставляет вдоль выбранного объекта блоки с заданными интервалами.

Имя блока для вставки: Ввести имя существующего в чертеже блока

Согласовать ориентацию блока с ориентацией объекта? [Да/Нет] <Д>: Ввести y или n или нажать клавишу ENTER

Да

Оси X вставляемых блоков будут параллельны делимому объекту в точках деления или совпадать с направлениями касательных в этих точках.

Нет

Блоки вставляются с исходной ориентацией.

Число сегментов: Ввести значение от 2 до 32767

На чертеже показано деление дуги на пять равных частей блоками в виде вертикально ориентированных эллипсов.


ПОДРОБНОСТИПП Команда

П Команды
П Команды
ПОДРОБНОСТИПП Команда
Понятия Процедуры Команды

Отображает информацию о выполненных заданиях печати и публикации

Меню "Файл": "Подробности о печати/публикации"

Ввод команды: подробностипп

Откроется диалоговое окно "Подробности о печати/публикации".

Темы:

  • Диалоговое окно «Подробности о печати/публикации»
  • Контекстное меню значка печати и публикации в строке состояния


Диалоговое окно «Подробности о печати/публикации»

П Команды
П Команды
Диалоговое окно «Подробности о печати/публикации»
Понятия Процедуры Команды

Меню "Файл": "Подробности о печати/публикации"

Ввод команды: подробностипп

Отображение информации о задачах печати и публикации, выполненных в текущем сеансе. Можно просматривать информацию обо всех выполненных задачах печати и публикации или только о возникших ошибках. Сведения, отображаемые в данном диалоговом окне, также можно копировать в буфер обмена.

Подробности о печати/публикации также доступны через контекстное меню значка печати и публикации в строке состояния.

Вид

Тип отображаемой информации. Можно также щелкнуть правой кнопкой мыши в области сведений в диалоговом окне и выбрать «Просмотреть ошибки» или «Просмотреть все» из контекстного меню.

Все

Отображение информации обо всех выполненных задачах печати/публикации и напечатанных листах.

Только ошибки

Список ошибок, возникших при выполнении печати/публикации.

Копировать в буфер

Копирование выделенного текста в диалоговом окне «Подробности о печати/публикации» в буфер обмена. Затем этот текст можно будет вставить в текстовый файл или в другую программу.

Область сведений

Информация о выполненных задачах печати/публикации. Здесь для каждого задания и листа отображаются следующие сведения:

  • Имя задания и листа
  • Путь к файлу чертежа (если производилась печать в файл)
  • Состояние завершения задания и наличие ошибок и предупреждений
  • Дата и время начала и окончания
  • Количество листов в задании и количество напечатанных листов
  • Количество ошибок и предупреждений
  • Подробные сведения о возникших ошибках и предупреждениях


Контекстное меню значка печати и публикации в строке состояния

П Команды
П Команды
Контекстное меню значка печати и публикации в строке состояния
Понятия Процедуры Команды

При включенной фоновой печати предоставляет параметры для отмены вывода на печать текущего листа, отмены печати или публикации всего задания, вызова диалогового окна "Подробности о печати/публикации" и просмотра последнего созданного файла DWF (DWF™). Необходимо щелкнуть правой кнопкой мыши на любом значке печати и публикации в лотке в правой части строки состояния. Эти значки описаны в таблице, представленной ниже.

Изменяющийся значок показывает, что в настоящее время в фоновом режиме выполняется печать или публикация.

Доступен отчет о подробностях печати. Нет ошибок или предупреждений.

Доступен отчет о подробностях печати. Есть ошибки и предупреждения.

Прервать вывод листа

Отмена печати текущего листа.

Прервать все задание

Отмена печати или публикации всего задания.

Подробности о печати/публикации

Отображает диалоговое окно "Подробности о печати/публикации".

Просмотр DWF-файла

Открытие последнего созданного DWF-файла.

Разрешить уведомления

Включение показа всплывающих уведомлений, отображающих состояние выполняющихся заданий печати и публикации.


ПОДШИВКА Команда

П Команды
П Команды
ПОДШИВКА Команда
Понятия Процедуры Команды

Вызов диспетчера подшивок

Панель "Стандартная":

Меню "Сервис": "Палитры" » "Диспетчер подшивок"

Ввод команды: подшивка

Отображение Диспетчер подшивок.

Темы:

  • Диспетчер подшивок
  • Вкладка "Список листов"
  • Вкладка "Виды на листе"
  • Вкладка "Виды моделей"
  • Диалоговое окно "Свойства группы листов"
  • Диалоговое окно "Выбор шаблона для листа подшивки"
  • Диалоговое окно "Новый лист"
  • Диалоговое окно "Смена названия и номера листа"
  • Диалоговое окно "Смена названия и номера вида"
  • Диалоговое окно "Импорт листов в подшивку"
  • Диалоговое окно "Вставка ведомости листов"
  • Диалоговое окно "Изменение параметров таблицы списков листов"
  • Диалоговое окно "Свойства подшивки"
  • Диалоговое окно "Дополнительные свойства"
  • Диалоговое окно "Новое дополнительное свойство"
  • Диалоговое окно "Расположение чертежей с ресурсами"
  • Диалоговое окно "Свойства листа"
  • Диалоговое окно "Новый набор листов"
  • Диалоговое окно "Наборы листов"
  • Диалоговое окно "Категория видов"
  • Диалоговое окно "Список блоков"
  • Диалоговое окно "Выбор блока"


Диспетчер подшивок

П Команды
П Команды
Диспетчер подшивок
Понятия Процедуры Команды

Меню "Сервис": "Диспетчер подшивок"

Ввод команды: подшивка

Диспетчер подшивок позволяет управлять подшивками - именованными коллекциями листов чертежей. Каждый лист в подшивке соответствует листу в файле чертежа (DWG).

В верхней части окна диспетчера подшивок расположено списковое окно Меню команд и несколько кнопок. Набор кнопок изменяется в зависимости от выбранной вкладки.

В окне диспетчера подшивок отображаются следующие вкладки:

  • Список листов
  • Виды на листе
  • Виды моделей
Меню команд

Отображение имени текущей подшивки, а если подшивки не заданы — запроса команды "Открыть". В меню команд для всех вкладок имеются следующие элементы:

Имена открытых подшивок

Вывод списка всех открытых подшивок. Имя текущей подшивки помечается галочкой. Текущей является подшивка, имя и содержимое которой отображается в окне диспетчера подшивок.

Недавние

Список подшивок, которые открывались в последнее время.

Создать подшивку

Запуск мастера создания подшивок.

Открыть

Вызов диалогового окна "Открытие подшивки" (стандартное окно выбора файлов).

Темы:

  • Вкладка "Список листов"
  • Вкладка "Виды на листе"
  • Вкладка "Виды моделей"


Вкладка "Список листов"

П Команды
П Команды
Вкладка "Список листов"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

На вкладке "Список листов" отображается упорядоченный перечень листов подшивки. Листы можно компоновать в группы.

На данной вкладке находятся кнопки:

Публикация в DWF

Публикация выбранных листов или всей подшивки в файле DWF. При этом автоматически применяются параметры, установленные в команде ПУБЛ.

Опубликовать

Доступ к параметрам публикации. Описание каждого параметра приведено в разделе "Пункты контекстного меню".

Наборы листов

Меню, с помощью которого можно сохранять именованные наборы листов и управлять ими. Эти параметры облегчают операции публикации, формирования комплектов и архивации групп листов. Описание каждого параметра приведено в разделе "Пункты контекстного меню".

Подробности (в нижней части окна)

Основная информация о текущем листе или подшивке.

Просмотр (в нижней части окна)

Образец для предварительного просмотра содержимого выбранного листа.

Пункты контекстного меню

На вкладке "Список листов" в контекстном меню отображаются перечисленные ниже пункты. Для упрощения доступа список выводится в алфавитном порядке. То, какие пункты будут отображаться в каждом контекстном меню, зависит от ситуации: например, пункты контекстного меню, вызванного нажатием правой кнопки мыши на имени подшивки, будут отличаться от пунктов контекстного меню, вызванного нажатием правой кнопки мыши на имени листа.

Архивация

Вызов диалогового окна "Архивация подшивки".

Закрыть подшивку

Закрытие текущей подшивки. При этом из окна Диспетчера удаляется вся информация, касающаяся данной подшивки.

Создать лист

Вызов диалогового окна "Новый лист".

Сменить название и номер

Вызов диалогового окна "Смена названия и номера листа".

Сформировать комплект

Вызов диалогового окна "Формирование комплекта файлов".

Импортировать лист

Вызов диалогового окна "Импорт листов в подшивку".

Добавить штемпель

Добавление штемпеля чертежа для подшивки или листа.

Параметры штемпеля

Вызов диалогового окна "Штемпель чертежа", в котором можно задать информацию, указываемую на штемпеле, например, имя чертежа, дату и время, масштаб печати и т.д.

Вставить ведомость листов

Вызов диалогового окна "Вставка ведомости листов". Вызов диалогового окна "Вставка ведомости листов" возможен только из контекстного меню имени подшивки.

Наборы параметров листа

Вызов диалогового окна "Диспетчер наборов параметров листов".

Создать группу

Вызов диалогового окна "Свойства группы листов", в котором можно создать новую группу листов для логической организации содержимого подшивки.

Открыть

Открытие файла чертежа выбранного листа и установка соответствующей вкладки активной.

Открыть для чтения

Открытие файла чертежа выбранного листа в режиме только для чтения и установка соответствующей вкладки активной. Изменения в файле невозможно сохранить, если не присвоить файлу новое имя.

Свойства (для всей подшивки)

Если выбран узел имени подшивки, открытие диалогового окна "Свойства подшивки".

Свойства (для группы листов)

Вызов диалогового окна "Свойства группы листов" (если выбран узел группы). См. также "Создать группу".

Свойства (для отдельного листа)

Если выбран узел имени подшивки, открытие диалогового окна "Свойства листа".

Опубликовать

Вызов диалогового окна "Публикация".

Опубликовать без учета параметров листа

Автоматическая публикация листов с переопределением параметров, заданных в отдельных чертежах. Переопределения параметров листа хранятся в файле шаблона листа (DWT).

Если данная опция не может быть вызвана, это значит, что параметры листа не установлены или DWT файл либо поврежден, либо отсутствует. Для выявления точной причины можно воспользоваться Диспетчером наборов параметров листов.

Параметры штемпеля

Вызов диалогового окна "Штемпель чертежа".

Публикация в DWF

Публикация выбранных листов или всей подшивки в файле DWF. При этом автоматически применяются параметры, установленные в команде ПУБЛ.

Опубликовать на плоттер

Автоматическая публикация выбранных листов на плоттер или принтер, принятые по умолчанию.

Сохранить все листы

Обновление информации, касающейся свойств листов в подшивке. При этом каждый файл в текущей подшивке открывается, и выполняется его повторное сохранение. Внесенные изменения сохраняются в файле данных подшивки (DST).

Файлы чертежей, сохраненные в предыдущем формате файлов DWF, пересохраняются без изменения формата.

Данная операция выполняется в фоновом режиме и не отображается на экране.

Примечание Перед выполнением данной операции следует убедиться, что файлы чертежей текущей подшивки не открыты на других компьютерах в сети.

Удалить группу

Удаление выбранной группы из подшивки.

Удалить лист

Удаление выбранного листа из подшивки.

Сохранить набор листов

Вызов диалогового окна "Новый набор листов".

Параметры публикации подшивки

Вызов диалогового окна "Параметры публикации подшивки". Данное диалоговое окно похоже на окно "Параметры публикации", но предназначено для подшивок.

Параметры комплекта

Вызов диалогового окна "Наборы параметров комплектов".


Вкладка "Виды на листе"

П Команды
П Команды
Вкладка "Виды на листе"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Виды на листе")

Ввод команды: подшивка

На вкладке "Виды на листе" отображается упорядоченный список видов, используемых в текущей подшивке. Виды можно организовывать в категории. Виды можно отображать по категориям или по листам, на которых они расположены.

Примечание На вкладке "Виды на листе" представлены только виды, созданные в AutoCAD 2005 или более поздних версиях продукта.

На данной вкладке находятся кнопки:

Новая категория видов

Вызов диалогового окна "Категория видов". Эта кнопка доступна только тогда, когда включена кнопка "Просмотр по категориям" и виды отображаются по категориям.

Просмотр по категориям

Отображает упорядоченный по категориям перечень видов в текущей подшивке.

Просмотр по листам

Отображает перечень видов текущей подшивки, упорядоченный по листам, на которых виды расположены.

Пункты контекстного меню

В контекстном меню вкладки "Виды на листе" содержатся следующие пункты. Для упрощения доступа список выводится в алфавитном порядке. То, какие пункты будут отображаться в каждом контекстном меню, зависит от ситуации: например, пункты контекстного меню, вызванного нажатием правой кнопки мыши на имени подшивки, будут отличаться от пунктов контекстного меню, вызванного нажатием правой кнопки мыши на категории видов или виде.

Показать

Отображение листа и выбранного вида на нем. При этом открывается файл чертежа, содержащий этот лист.

Создать категорию видов

Вызов диалогового окна "Категория видов", в котором можно создать новую категорию видов.

Вставить блок-идентификатор

Размещение блока-идентификатора на листе.

Вставить марку вида

Размещение блока марки вида на листе.

Свойства (для всей подшивки)

Вызов диалогового окна "Свойства подшивки".

Свойства (для категории видов)

Вызов диалогового окна "Категория видов".

Переименовать

Переименование выделенной в списке категории видов.

Сменить название и номер

Вызов диалогового окна "Смена названия и номера вида", в котором можно поменять имя и номер выбранного вида листа.

Установить категорию

Перемещает выбранный вид подшивки в категорию, заданную пользователем.


Вкладка "Виды моделей"

П Команды
П Команды
Вкладка "Виды моделей"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Виды моделей")

Ввод команды: подшивка

На вкладке "Виды модели" отображается список папок, файлов чертежей и видов пространства модели, доступных для текущей подшивки. Для управления тем, какие файлы чертежей связаны с текущей подшивкой, папки из этого списка можно удалять и добавлять новые.

Примечание Для добавления созданного именованного вида пространства модели на вкладку "Виды модели" чертеж необходимо сохранить.

На данной вкладке находятся кнопки:

Обновить

Обновление списка файлов чертежей в области структуры. При нажатии кнопки "Обновить" осуществляется обновление информации, хранящейся в файле данных подшивки (DST), проверка папок на наличие новых или удаленных файлов чертежей и проверка файлов чертежей на наличие новых или удаленных видов пространства модели. Альтернативный способ вызова функции обновления — нажатие клавиши F5 (при активной вкладке "Виды модели").

Добавление расположения

Вызов стандартного диалогового окна выбора файлов, в котором можно добавить в подшивку новую папку.

Пункты контекстного меню

В контекстном меню вкладки "Виды моделей" содержатся следующие пункты. Для упрощения доступа список выводится в алфавитном порядке. То, какие пункты будут отображаться в каждом контекстном меню, зависит от ситуации: например, пункты контекстного меню, вызванного нажатием правой кнопки мыши на папке, будут отличаться от пунктов контекстного меню, вызванного нажатием правой кнопки мыши на файле чертежа в папке.

Добавить расположение

Вызов стандартного диалогового окна выбора файлов, в котором можно добавить в подшивку новую папку.

Сформировать комплект

Вызов диалогового окна "Формирование комплекта файлов".

Открыть

Открытие выбранного файла чертежа (DWG).

Вставить на лист

Автоматическое размещение выбранного вида пространства модели на текущий лист текущего чертежа. Данную операцию можно подразделить на следующие этапы:

  • Выдается запрос о размещении вида на листе. Нажатие правой кнопки мыши дает возможность для изменения масштаба вида.
  • Выбранная модель вставляется в текущий чертеж как внешняя ссылка
  • На текущем листе создается видовой экран пространства листа
  • В подшивку добавляется вид, соответствующий новому видовому экрану на листе

Исключить расположение

Исключение выбранной папки из подшивки.

Виды пространства модели

Вызов списка видов пространства модели.


Диалоговое окно "Свойства группы листов"

П Команды
П Команды
Диалоговое окно "Свойства группы листов"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Создание новой группы листов в подшивке. Перенос листов из группы в группу можно осуществлять их перетаскиванием при помощи мыши.

Имя группы листов

Задание имени группы. Задание имени папки хранения листов для этой группы листов, если установлен флажок "Создавать папки относительно родительской папки хранилища поднабора".

Создавать папки относительно родительской папки хранилища поднабора

Если флажок установлен, при создании новой группы в родительской папке создается новая папка. Это удобный способ создания иерархической структуры папок параллельно с иерархической структурой групп.

Размещать новые DWG файлы в

Папка для сохранения в ней новых файлов чертежей (DWG), содержащих листы, относящиеся к данной группе. Кнопка "Обзор" вызывает стандартное диалоговое окно выбора файлов.

Шаблон листов для группы

Задание файла шаблона чертежей (DWT) и имени листа в нем, на основе которого создаются новые файлы чертежей для данной группы. Кнопка "Обзор" служит для вызова диалогового окна "Выбор шаблона для листа подшивки".

Для параметра используется следующий синтаксис:

имя_листа [путь_к_папке]имя_файла.dwt

С запросом шаблона

Если данная опция включена, AutoCAD запрашивает имя файла шаблона при создании в подшивке новых листов.


Диалоговое окно "Выбор шаблона для листа подшивки"

П Команды
П Команды
Диалоговое окно "Выбор шаблона для листа подшивки"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Задание пути к папке, файла шаблона чертежа(DWT) и имени вкладки для создания в подшивке новых листов.

Имя файла шаблона

Задание пути к файлу шаблона чертежа и имени файла для создания новых листов. Кнопка "Обзор" служит для вызова диалогового окна "Выбор чертежа" (стандартное диалоговое окно выбора файлов).

Лист чертежа для создания новых листов подшивок

Задание имени вкладки-листа в шаблоне чертежа для создания в подшивке новых листов.


Диалоговое окно "Новый лист"

П Команды
П Команды
Диалоговое окно "Новый лист"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Создание нового листа в текущей подшивке. При этом создается новый файл чертежа (DWG), включающий в себя вкладку-лист с тем же именем, что и сам чертеж.

Номер

Задание номера листа. При создании листа в первый раз не рекомендуется вводить номер листа. По умолчанию имя файла чертежа и имя листа представляют собой номер листа и его название. При создании нового листа из имени файла можно удалить номер листа, но он все еще будет присутствовать в имени листа.

Название листа

Задание имени листа, соответствующее вкладке-листу в новом чертеже с таким же именем.

Имя файла

Задание имени для нового файла чертежа. По умолчанию имя файла чертежа представляет собой номер листа, объединенный с названием листа. Предложенное имя файла можно изменить.

Путь к папке

Папка, в которую по умолчанию помещается новый файл чертежа.

Папка для группы, принятая по умолчанию, задается в диалоговом окне "Свойства группы листов", а папка для всей подшивки - в диалоговом окне "Свойства подшивки".

Шаблон листа

Имя файла шаблона листа для нового файла чертежа, принятое по умолчанию.

Стандартный файл шаблона для создания новых чертежей в группе задается в диалоговом окне "Свойства группы листов"; стандартный файл шаблона для создания новых чертежей в подшивке задается в диалоговом окне "Свойства подшивки".


Диалоговое окно "Смена названия и номера листа"

П Команды
П Команды
Диалоговое окно "Смена названия и номера листа"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Задание номера листа, названия листа и других параметров листа в подшивке.

Номер

Задание номера выбранного листа.

Название листа

Задание названия выбранного листа.

Имя файла

Отображает имя файла чертежа, соответствующего выбранному листу.

Путь к папке

Путь к папке, содержащей файл чертежа.

Переименовать связанный файл чертежа по названию листа

Если флажок установлен, файлу присваивается имя, соответствующее названию листа.

Добавлять номер листа в начало имя файла

Если флажок установлен, файлу чертежа присваивается новое имя, полученное при добавлении номера листа к началу названия листа.

Далее

Загрузка данных о следующем листе в диалоговое окно. Данная кнопка облегчает операцию задания нового названия и номера сразу нескольким листам.

Предыдущий

Загружает данные о предыдущем листе в диалоговое окно.


Диалоговое окно "Смена названия и номера вида"

П Команды
П Команды
Диалоговое окно "Смена названия и номера вида"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Виды на листе")

Ввод команды: подшивка

Задание номера листа и названия для вида в подшивке.

Номер

Задание номера выбранного вида.

Название вида

Задание названия выбранного вида.

Назад

Загружает данные о предыдущем виде в диалоговое окно. Данная кнопка облегчает операцию задания нового имени и номера сразу нескольким видам.

Далее

Загрузка данных о следующем виде в данное диалоговое окно. Данная кнопка облегчает операцию задания нового имени и номера сразу нескольким видам.


Диалоговое окно "Импорт листов в подшивку"

П Команды
П Команды
Диалоговое окно "Импорт листов в подшивку"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Позволяет осуществлять быстрый импорт листов чертежей в подшивку.

Примечание Каждый лист чертежа может принадлежать только одной подшивке. Для импорта листа, уже входящего в какую-либо подшивку, необходимо предварительно создать копию чертежа, содержащего этот лист.

Поиск чертежей

Вызов стандартного диалогового окна выбора файлов "Выбор чертежа".

Список листов в выбранном чертеже

Список листов, содержащихся в выбранном файле чертежа. Установить флажок для выбора листа.

Добавлять имена файлов к названиям листов

Если данная опция выбрана, то к началу названия листа прибавляется имя файла чертежа.

Импорт

Импортирует лист из списка, только если флажок установлен.


Диалоговое окно "Вставка ведомости листов"

П Команды
П Команды
Диалоговое окно "Вставка ведомости листов"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Создание таблицы, содержащей имена листов в подшивке. Данная таблица может быть вставлена на любой лист в подшивке, но чаще всего она размещается на титульном листе.

Примечание Опция "Вставить ведомость листов" недоступна в контекстном меню, если активна вкладка "Модель" или если текущий лист на экране на входит в текущую подшивку.

Настройка стиля таблицы

Отображает параметры стилей таблицы.

Имя стиля

Задание имени стиля таблиц для ведомости. Кнопка "Обзор" служит для вызова диалогового окна "Стиль таблиц".

Область с образцом стиля

Отображение внешнего вида выбранного стиля таблиц для ведомости.

С подзаголовками

Если выбрана данная опция, ведомость листов разделяется на секции в соответствии с существующими группами листов.

Данные для ведомости

Отображает параметры данных таблицы.

Текст заголовка

Задание наименования для ведомости листов.

Параметры граф

Список свойств граф ведомости листов. Каждая строка в списке соответствует одной графе. В ведомости графы следуют в том же порядке (слева направо), что и записи о них в данном диалоговом окне.

Столбец "Тип данных"

Список отображается после выбора описаний столбцов и нажатия на ячейку в столбце "Тип данных". В этом списке можно изменить тип информации, отображаемой в столбцах таблицы списков листов.

Столбец "Заголовок"

Позволяет изменять заголовки столбцов в таблице списков листов.

Добавить

Добавление графы номеров листов в ведомость.

Удалить

Исключение выбранной графы из ведомости листов. Если столбец удален случайно, можно добавить новый столбец "Номер листа", а затем изменить его тип данных в списке типов данных.

Вверх

Перемещение выбранной графы вверх по списку (т.е. влево в ведомости листов).

Вниз

Перемещение выбранной графы вниз по списку (т.е. вправо в ведомости листов).


Диалоговое окно "Изменение параметров таблицы списков листов"

П Команды
П Команды
Диалоговое окно "Изменение параметров таблицы списков листов"
Понятия Процедуры Команды

Контекстное меню: Выберите любую ячейку в таблице списков листов, нажмите правую кнопку мыши для открытия контекстного меню и выберите "Изменение параметров таблицы списков листов"

Позволяет редактировать существующую в текущем чертеже таблицу списков листов. Диалоговое окно "Изменение параметров таблицы списков листов" предоставляет доступ ко всем параметрам диалогового окна "Вставка таблицы списков листов".

Настройка стиля таблицы

Отображает параметры стилей таблицы.

Имя стиля

Задание имени стиля таблиц для ведомости. Кнопка "Обзор" служит для вызова диалогового окна "Стиль таблиц".

Область с образцом стиля

Отображение внешнего вида выбранного стиля таблиц для ведомости.

С подзаголовками

Если выбрана данная опция, ведомость листов разделяется на секции в соответствии с существующими группами листов.

Данные для ведомости

Отображает параметры данных таблицы.

Текст заголовка

Задание наименования для ведомости листов.

Параметры граф

Список свойств граф ведомости листов. Каждая строка в списке соответствует одной графе. В ведомости графы следуют в том же порядке (слева направо), что и записи о них в данном диалоговом окне.

Столбец "Тип данных"

Список отображается после выбора описаний столбцов и нажатия на ячейку в столбце "Тип данных". В этом списке можно изменить тип информации, отображаемой в столбцах таблицы списка листов.

Столбец "Заголовок"

Позволяет изменять заголовки столбцов в таблице списков листов.

Добавить

Добавление графы номеров листов в ведомость.

Удалить

Исключение выбранной графы из ведомости листов. Если столбец удален случайно, можно добавить новый столбец "Номер листа", а затем изменить его тип данных в списке типов данных.

Вверх

Перемещение выбранной графы вверх по списку (т.е. влево в ведомости листов).

Вниз

Перемещение выбранной графы вниз по списку (т.е. вправо в ведомости листов).


Диалоговое окно "Свойства подшивки"

П Команды
П Команды
Диалоговое окно "Свойства подшивки"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Отображение информации, касающейся выбранной подшивки. Можно нажать кнопку мыши на каждом поле, чтобы отобразить описание поля в нижней части диалогового окна.

К такой информации относятся путь и имя файла данных подшивки (DST), пути к папкам, содержащим файлы чертежей, относящихся к подшивке, и другие пользовательские свойства подшивки

Имя

Отображает имя подшивки.

Файл данных подшивки

Отображает путь и имя файла данных подшивки (DST).

Пояснение

Отображает описание подшивки.

Вид модели

Отображает пути и имена папок, содержащих чертежи, используемые в подшивке.

Блок марки для видов

Отображает путь и имя файла DWT или DWG, содержащего блоки марки для подшивки.

Блоки-идентификаторы

Отображает путь и имя файла DWT или DWG, содержащего блоки-идентификаторы для подшивки.

Файл переопределения параметров листов

Отображает путь и имя файла шаблона (DWT), содержащего переопределения параметров листа для подшивки.

Управление проектом

Отображает несколько полей, широко используемых в проектах, в том числе, "Номер проекта", "Имя проекта", "Фаза проекта" и "Этап проекта".

Дополнительные свойства листа

Отображает заданные пользователем свойства, связанные с каждым листом в подшивке.

Место хранения листа

Отображает путь и имя папки, в которой создаются новые листы.

Шаблон создания листа

Отображает путь и имя файла DWT или DWG, используемого при создании новых листов для подшивки.

С запросом шаблона

Определяет, будет ли выдаваться запрос шаблона для создания листа каждый раз при создании нового листа в подшивке.

Дополнительные свойства подшивки

Отображает заданные пользователем свойства, связанные с подшивкой.

Изменить свойства

Вызов диалогового окна "Дополнительные свойства".


Диалоговое окно "Дополнительные свойства"

П Команды
П Команды
Диалоговое окно "Дополнительные свойства"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Выводит список определяемых пользователем свойств текущей подшивки.

Добавить

Вызов диалогового окна "Новое дополнительное свойство".

Удалить

Удаление выбранного дополнительного свойства из подшивки.


Диалоговое окно "Новое дополнительное свойство"

П Команды
П Команды
Диалоговое окно "Новое дополнительное свойство"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Создание определяемого пользователем свойства для текущей подшивки или всех подшивок. В качестве дополнительных могут выступать такие свойства, как номер контракта, имя разработчика и дата выполнения.

Имя

Задание имени нового дополнительного свойства.

Значение по умолчанию

Задание значения дополнительного свойства.

Владелец

Присвоение дополнительного свойства подшивке или листу.


Диалоговое окно "Расположение чертежей с ресурсами"

П Команды
П Команды
Диалоговое окно "Расположение чертежей с ресурсами"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок"

Ввод команды: подшивка

Отображение папок, доступных для текущей подшивки. Для управления тем, какие файлы чертежей связаны с текущей подшивкой, папки из этого списка можно удалять и добавлять новые.

Добавить

Вызов стандартного диалогового окна выбора файлов, в котором можно добавить новую папку.

Удалить

Удаление выделенной папки из списка.


Диалоговое окно "Свойства листа"

П Команды
П Команды
Диалоговое окно "Свойства листа"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Отображает информацию, касающуюся выбранного листа, например, название листа, номер листа и данные о том, подлежит ли лист публикации. Здесь также отображаются дополнительные свойства. Значение любого свойства можно изменять.

Лист / Дополнительные свойства листа

Свойства выбранного листа. Здесь также отображаются дополнительные свойства. Значение любого свойства можно изменять. В поле "Ожидаемый лист чертежа" отображается путь к файлу и имя файла, где был сохранен лист. В поле "Реальный лист чертежа" отображается путь к файлу и имя файла, где был найден лист. Если пути не совпадают, то путь можно изменить в поле "Ожидаемый лист чертежа". Данная операция восстанавливает нарушенную связь листа с подшивкой.


Диалоговое окно "Новый набор листов"

П Команды
П Команды
Диалоговое окно "Новый набор листов"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Сохранение набора выбранных листов для дальнейших операций. После выбора и сохранения нескольких листов дальнейшее обращение к ним можно осуществлять по имени. Данная возможность облегчает операции публикации, передачи и архивации набора листов.

Имя набора листов

Задание имени для дальнейшего обращения к выбранным листам.


Диалоговое окно "Наборы листов"

П Команды
П Команды
Диалоговое окно "Наборы листов"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Список листов")

Ввод команды: подшивка

Переименование или удаление набора листов.

Наборы листов

Определение набора листов, который нужно переименовать или удалить.

Переименовать

Переименование выбранного набора листов.

Удалить

Удаление выбранного набора листов. При этом происходит только удаление набора из списка определенных. Сами листы остаются нетронутыми.


Диалоговое окно "Категория видов"

П Команды
П Команды
Диалоговое окно "Категория видов"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Виды на листе")

Ввод команды: подшивка

Создание новых категорий видов в подшивке. Виды можно компоновать логически, перетаскивая их мышью в нужную категорию.

Имя категории

Задание имени для новой категории видов.

Блоки-идентификаторы для использования в категории

Блоки-идентификаторы для использования в категории

Добавить блоки

Отображает диалоговое окно "Список блоков".


Диалоговое окно "Список блоков"

П Команды
П Команды
Диалоговое окно "Список блоков"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Виды на листе")

Ввод команды: подшивка

Добавление, удаление и получение списка блоков-идентификаторов для использования в текущей подшивке. Вызов этого диалогового окна осуществляется нажатием кнопки "Добавить блоки" в диалоговом окне "Категория видов" или кнопки "[...]", расположенной за пунктом "Блоки-идентификаторы" в диалоговом окне "Свойства подшивки".

С подшивкой связаны следующие блоки

Список блоков, доступных для работы в текущей подшивке.

Добавить

Вызов диалогового окна "Выбор блока".

Удалить

Удаление выбранного блока из списка блоков-идентификаторов.

Область просмотра

Выводит образец для предварительного просмотра при выборе одного блока.


Диалоговое окно "Выбор блока"

П Команды
П Команды
Диалоговое окно "Выбор блока"
Понятия Процедуры Команды

Меню "Сервис": "Палитры" » "Диспетчер подшивок" (вкладка "Виды на листе")

Ввод команды: подшивка

Добавление блока-идентификатора или блока марки вида для текущей подшивки.

Имя файла чертежа

Задание имени и пути к файлу чертежа (DWG) или имени и пути к файлу шаблона чертежа (DWT), используемых в качестве источника описания блока. Кнопка "Обзор" служит для вызова диалогового окна "Выбор чертежа" (стандартное окно выбора файлов).

Весь чертеж как блок

Использование всего выбранного файла чертежа или файла шаблона чертежа в качестве описания блока.

Блоки из выбранного файла

Использование выбранных описаний блоков из заданного файла чертежа или файла шаблона чертежа. Если задаются блоки-идентификаторы, можно, используя клавиши SHIFT или CTRL, выбрать несколько блоков одновременно.

Образец

Выводит образец для предварительного просмотра при выборе одного блока.


ПОДШИВКАОТКЛ Команда

П Команды
П Команды
ПОДШИВКАОТКЛ Команда
Понятия Процедуры Команды

Закрытие диспетчера подшивок

Меню "Сервис": "Палитры" » "Диспетчер подшивок"

Ввод команды: подшивкаоткл

Закрытие окна Диспетчера подшивок.


ПОКАЗАТЬ Команда

П Команды
П Команды
ПОКАЗАТЬ Команда
Понятия Процедуры Команды

Увеличение или уменьшение видимого размера объектов на текущем видовом экране

Панель "Стандартная":

Меню "Вид": "Зумирование"

Контекстное меню: Убедитесь в отсутствии выделенных объектов, нажмите правую кнопку мыши в области рисования и выберите "Зумирование" для зумирования в реальном времени.

Ввод команды: показать (или 'показать для вызова в прозрачном режиме)

В перспективном виде команда ПОКАЗАТЬ отображает приглашения команды 3DПОКАЗАТЬ.

Примечание Прозрачный режим команды ПОКАЗАТЬ недоступен во время выполнения команд ТЗРЕНИЯ, ДВИД, ПАН и ВИД или в процессе работы самой команды ПОКАЗАТЬ.

Укажите угол рамки, введите масштаб (nX или nXЛ), или

[Все/Центр /Динамика/Границы/Предыдущий/Масштаб /Рамка/Объект] <реальное время>:

Все

Зумирование чертежа для отображения всех его объектов на текущем видовом экране. На виде в плане с помощью опции "Все" выполняется зумирование до лимитов сетки или текущих границ (в зависимости от того, что больше). Для 3D видов команда "ПОКАЗАТЬ Все" эквивалентна команде "ПОКАЗАТЬ Границы". На экране отображаются все объекты, даже если чертеж выходит за лимиты сетки.

На примере видно, что лимиты, установленные командой ЛИМИТЫ, больше границ чертежа.

При использовании опции "Все" команды ПОКАЗАТЬ в прозрачном режиме следует помнить о том, что эта опция всегда производит регенерацию чертежа.

Центр

Зумирование с помощью рамки, определяемой центральной точкой и коэффициентом увеличения или высотой. Задание небольшого значения высоты приводит к увеличению изображения. Задание большего значения приводит к уменьшению изображения.

Центральная точка: Указать точку (1)

Увеличение или высота <текущее>: Ввести значение или нажать ENTER

Динамика

Зумирование для отображения сгенерированной части чертежа в рамке вида. Рамка вида представляет собой видовой экран, который можно уменьшать и увеличивать, а также перемещать по чертежу. При этом выполняется панорамирование и зумирование для вставки в видовой экран фрагмента чертежа, находящегося внутри рамки вида.

Сначала выводится рамка вида для панорамирования. Переместите ее в нужное место на чертеже и нажмите левую кнопку мыши. Появится рамка вида для зумирования. После изменения ее размеров до нужной величины можно нажать ENTER для зумирования изображения или нажать левую кнопку мыши для повторного переключения в режим панорамирования.

При нажатии ENTER текущий видовой экран заполняется изображением, находящимся внутри рамки вида.

Границы

Зумирование до границ чертежа; в результате обеспечивается максимально крупное отображение всех объектов.

Предыдущий

Отображение предыдущего вида зумирования. Можно восстановить до 10 предыдущих видов.

Примечание При изменении визуального стиля меняется и вид. С помощью опции "Предыдущий" команды ПОКАЗАТЬ можно восстанавливать любой предыдущий вид, в том числе виды, использующие различные режимы тонирования.

Масштаб

Зумирование изображения в соответствии с заданным масштабным коэффициентом.

Масштабный коэффициент (nX или nXЛ): Задать значение

Если ввести значение с символом x (латинское) на конце, коэффициент будет исчисляться относительно текущего изображения. Например, в результате ввода 0,5x каждый объект будет выведен на экран с размером вдвое меньшим, чем его текущий размер.

Если после ввода значения набрать символы xл (x латинское, л русское), коэффициент масштаба будет исчисляться относительно единиц пространства листа. Например, результате ввода 0,5xл пространство модели уменьшится вдвое относительно пространства листа. Можно создать лист с видовыми экранами, каждый из которых будет отображать объекты с разным масштабом.

При вводе только цифрового значения масштабный коэффициент вычисляется относительно лимитов чертежа. (Данная опция используется редко.) Например, в результате ввода числа 2 объекты чертежа будут увеличены вдвое по отношению к тому, как они выглядели бы в лимитах чертежа.

Рамка

Зумирование области чертежа, заключенной между заданными пользователем противоположными углами прямоугольной рамки.

Первый угол: Указать точку (1)

Противоположный угол: Указать точку (2)

Объект

Максимальное увеличение одного или нескольких выбранных объектов по центру области рисования. Объекты можно выбирать до или после вызова команды ПОКАЗАТЬ.

Реальное время

Интерактивное зумирование посредством указания границ мышью.

Нажмите ESC или ENTER для выхода или правую кнопку мыши для отображения контекстного меню

Курсор принимает форму увеличительного стекла со знаками плюс (+) и минус (-). Подробнее об опциях, доступных при зумировании в реальном времени, см. Контекстное меню зумирования.

Текущая область чертежа предназначена для задания коэффициента зумирования. Команда ПОКАЗАТЬ использует половину высоты рамки для изменения коэффициента увеличения на 100%. Удерживая нажатой левую кнопку мыши в середине рамки и перемещая курсор вертикально вверх, можно увеличить изображение до 100%. И наоборот, удерживая нажатой левую кнопку мыши в середине рамки и перемещая курсор вертикально вниз, можно уменьшить изображение до 100%.

Примечание Если после нажатия левой кнопки мыши перемещать курсор от нижней до верхней границы рамки, увеличение составит 200%.

При достижении предела увеличения изображения на текущем виде символ "плюс" на курсоре зумирования исчезает, что означает невозможность дальнейшего увеличения. При достижении предела уменьшения изображения на текущем виде символ "минус" на курсоре зумирования исчезает, что также означает невозможность дальнейшего уменьшения.

При отпускании левой кнопки мыши зумирование прекращается. Можно отпустить левую кнопку мыши, переместить курсор в другое место на чертеже, а затем вновь нажать левую кнопку мыши и продолжить зумирование изображения в новом расположении.

Для завершения зумирования следует нажать ENTER или ESC.

Темы:

  • Контекстное меню зумирования


Контекстное меню зумирования

П Команды
П Команды
Контекстное меню зумирования
Понятия Процедуры Команды

Когда команда ПОКАЗАТЬ активна, с помощью параметров контекстного меню этой команды ее можно завершить или переключиться в режим команды ПАН или 3DОРБИТА. Доступ к контекстному меню зумирования осуществляется нажатием правой кнопки мыши в области рисования при запущенной команде ПОКАЗАТЬ.

Выход

Завершение работы команды ПОКАЗАТЬ или ПАН.

Пан

Переключение на команду ПАН.

Показать

Переключение на команду ПОКАЗАТЬ с параметром "Реальное время".

3D орбита

Переключение на команду 3DОРБИТА.

Показать рамкой

Зумирование области чертежа, обведенной прямоугольной рамкой.

Показать объект

Максимальное увеличение одного или нескольких выбранных объектов по центру области рисования.

Исходный вид

Восстановление исходного вида.

Показать в границах

Зумирование изображения до границ чертежа.


ПОКИНУТЬ Команда

П Команды
П Команды
ПОКИНУТЬ Команда
Понятия Процедуры Команды

Завершение работы программы

Меню "Файл": "Выход"

Ввод команды: покинуть

Завершает работу программы в том случае, если с момента последнего сохранения в чертеж не были внесены изменения. Если чертеж был изменен, отображается диалоговое окно, в котором можно сохранить чертеж или отказаться от его сохранения.

Файлы, открытые только для чтения, можно закрыть, если в них не было внесены изменения или если эти изменения не требуют сохранения. Для сохранения изменений в чертеже, открытом только для чтения служит команда СОХРАНИТЬКАК. При этом чертеж будет сохранен под другим именем.


ПОКМАТ Команда

П Команды
П Команды
ПОКМАТ Команда
Понятия Процедуры Команды

Устар.

Ввод команды: покмат

Запускает команду СПИСОК.


ПОЛЕ Команда

П Команды
П Команды
ПОЛЕ Команда
Понятия Процедуры Команды

Создание объекта многострочного текста с полем, автоматически обновляемым при изменениях связанного с ним значения

Меню "Вставка": Поле

Контекстное меню: Нажать правую кнопку мыши во время выполнения любой из команд работы с текстом и выбрать "Вставить поле".

Ввод команды: поле

Откроется диалоговое окно "Поле".

Темы:

  • Диалоговое окно "Поле"


Диалоговое окно "Поле"

П Команды
П Команды
Диалоговое окно "Поле"
Понятия Процедуры Команды

Меню "Вставка": Поле

Контекстное меню: Нажать правую кнопку мыши во время выполнения любой из команд работы с текстом и выбрать "Вставить поле".

Ввод команды: поле

Вставка поля в чертеж.

Набор параметров, доступных в диалоговом окне "Поле", зависит от категории и имени поля.

Категории полей

Установка, согласно которой вслед за именами полей приводятся их типы (например, "Дата и время", "Документ" и "Объекты"). Категория "Прочее" включает DieselExpression, LispVariable и SystemVariable.

Имена полей

Перечень полей, имеющихся в данной категории. Выбрав в списке поле, можно посмотреть доступные для него параметры.

Значение поля

Текущее значение поля. Если поле имеет недопустимое значение, то здесь отображается пустая строка (----).

Настоящее название этой опции зависит от того, какое поле выбрано. Например, если в списке "Имена полей" выбрано "ИмяФайла", названием становится "ИмяФайла", а значением — имя текущего чертежа. Для полей объектов в качестве названия используется "Свойство". Исключение: при выборе поля даты отображается заданный формат даты; например, д/м/гггг.

Список форматов

Перечень вариантов отображения значения поля. Например, поля даты могут отображать или не отображать день, текстовые строки могут быть записаны прописными или строчными буквами, или только начинаться с заглавной буквы и т.п.. В диалоговом окне "Поле" значение поля будет отображать заданный для него формат.

Формула для поля

Выражение, которое описывает поле. Отредактировать это выражение нельзя. Однако оно дает представление о структуре полей.

Параметры для полей "Подшивка" и "ВидНаЛисте"

При выборе полей, имеющих отношение к подшивкам, доступны следующие дополнительные параметры:

Подшивка

Имя подшивки.

Структура листов

Древовидная структура, представляющая листы и виды на листах из Диспетчера подшивок. Здесь можно выбрать элемент для использования в поле.

Свойство

Свойства, доступные в виде полей для пунктов, выбранных в дереве.

С гиперссылками

Добавление гиперссылки к полю при его создании. Можно использовать CTRL + нажатие левой кнопки мыши для перехода к листу или виду. Этот параметр не доступен для поля "МасштабВЭкрана".

Параметры для полей "МестозаполнительБлока"

Вставка в поля "МестозаполнительБлока" возможна в диалоговом окне "Определение атрибута" после открытия Редактор блоков.

При выборе поля "МестозаполнительБлока" доступны следующие дополнительные параметры:

Имя блока

Отображает имя описания текущего блока.

Временное значение

Значение поля заменителя в заданном формате.

Свойства вхождения блока

Отображает список свойств вхождения блока для описания текущего блока.

Параметры для полей "ПодшЗаменитель"

При выборе поля "ПодшЗаменитель" доступны следующие дополнительные параметры:

Тип заменителя

Перечень имеющихся полей-заменителей.

Временное значение

Значение поля заменителя в заданном формате.

Например, пусть в списке "Имена полей" выбрано поле "ПодшЗаменитель", в списке "Тип заменителя" выбран тип "НазваниеЛиста", а в списке "Формат" указано "Верхний регистр". Тогда в текстовом поле "Временное значение" отображается НАЗВАНИЕЛИСТА. При включении чертежа в подшивку в этом поле отображается название листа.

Параметры для полей в категориях объектов

При выборе полей объектов доступны следующие дополнительные параметры:

Тип именованного объекта/Тип объекта

Если в списке "Имена полей" выбрано поле "ИменованныйОбъект", здесь перечисляются типы именованных объектов в чертеже. Если выбрано поле "Объект", здесь отображается тип выбранного объекта. Временно закрыть диалоговое окно для выбора объекта на чертеже можно с помощью кнопки "Выбор объекта".

Свойство/Имя

Если в списке "Имена полей" выбрано поле "ИменованныйОбъект", здесь перечисляются имена всех имеющихся в чертеже объектов указанного типа. Если в списке "Имена полей" выбрано поле "Объект", здесь перечисляются свойства выбранных объектов, которые доступны в качестве полей. Если выбран блок с атрибутами, то в списке свойств приводятся имена атрибутов.

Формула

При выборе "Формула" в списке "Имена полей" появляется поле для создания формулы, чтобы вставить в текст или ячейку таблицы.

Среднее/Сумма/Кол-во

При выборе "Формула" в списке "Имена полей" временно закрывается диалоговое окно "Поле", когда выбираются ячейки таблицы. Результат добавляется в формулу.

Ячейка

При выборе "Формула" в списке "Имена полей" временно закрывается диалоговое окно "Поле", когда выбирается ячейка таблицы. Адрес ячейки добавится в формулу.

Точность

Указывает точность представления полей на основе выбранного формата. Выберите "Текущая точность" для использования текущей настройки системной переменной LUPREC.

Дополнительный формат

Открывает диалоговое окно Дополнительный формат

Вычислить

Обновляет значение в окне "Просмотр" при изменении текста в формуле вручную.

Отображать значение для вхождения блока

Указывает, что поля свойств объектов во вхождении блока оценивают свойства вложенных объектов относительно размера и ориентации вхождения блока в чертеже, а не в описании блока.


ПОЛИТЕЛО Команда

П Команды
П Команды
ПОЛИТЕЛО Команда
Понятия Процедуры Команды

Создается 3D политело

Панель инструментов "Моделирование:

Меню "Рисование": "Моделирование"» "Политело"

Ввод команды: политело

Пульт управления: Панель "3D Создать", "Политело"

С помощью команды ПОЛИТЕЛО можно преобразовать имеющуюся линию, 2D полилинию, дугу или окружность в тело с прямоугольным профилем. Политело может содержать криволинейные сегменты, но профиль всегда является прямоугольным по умолчанию.

Тело можно строить с помощью команды ПОЛИТЕЛО точно так же, как полилинию. Системная переменная PSOLWIDTH определяет для тела ширину по умолчанию. Системная переменная PSOLHEIGHT определяет для тела высоту по умолчанию.

Начальная точка или [Объект/Высота/Ширина/Выравнивание] <Объект>: Указать начальную точку для профиля тела, нажать ENTER для определения объекта, преобразуемого в тело, или задать опцию

Укажите следующую точку или [Дуга/Отменить]: Указать следующую точку для профиля тела или задать опцию

Объект

Указывается объект для преобразования в тело. Возможные объекты:

  • Линия
  • Дуга
  • 2D полилиния
  • Окружность

Выберите объект: Выбрать объект, преобразуемый в тело

Высота

Указывается высота тела. Высота по умолчанию устанавливается равной текущему значению переменной PSOLHEIGHT.

Укажите высоту <по умолчанию>: Указать значение высоты или нажать ENTER для принятия значения по умолчанию

Указанное значение высоты заменяется установленное значение PSOLHEIGHT.

Ширина

Указывается высота тела. Ширина по умолчанию устанавливается равной текущему значению переменнойPSOLWIDTH.

Укажите ширину <текущая>: Указать значение ширины путем ввода значения или обозначения двух точек либо нажать ENTER для принятия текущего значения ширины

Указанное значение ширины заменяет установленное значение PSOLWIDTH.

Выравнивание

Задаются значения ширины и высоты, обеспечивающие выравнивание тела по левому, правому краю или по центру, при определении профиля с помощью команды. Выравнивание привязывается к начальному направлению первого сегмента профиля.

Задайте выравнивание [Слева/По центру/Справа] <По центру>: Задать вариант выравнивания или нажать ENTER для принятия выравнивания по центру

Следующая точка

Укажите следующую точку или [Дуга/Замкнуть/Отменить]: Указать следующую точку для профиля тела, задать опцию или нажать ENTER для завершения команды

Дуга

К телу добавляется дуговой сегмент. Начальным направлением дуги по умолчанию является касательная к последнему построенному сегменту. Можно определить другое начальное направление с помощью опции "Направление".

Укажите вторую точку дуги или [Замкнуть/Направление/Линия/Вторая точка/Отменить]: Указать конечную точку или задать опцию

Замкнуть

Тело замыкается путем построения линейного или дугового сегмента от заданной последней вершины до начальной точки тела. Для применения этой опции следует указать как минимум две точки.

Направление

Задание начального направления дугового сегмента.

Направление касательной для начальной точки дуги: Указать точку

Конечная точка дуги: Указать точку

Линия

Выход из режима построения дуговых сегментов и возврат к начальным запросам команды ПОЛИТЕЛО.

Вторая точка

Указываются вторая точка и конечная точка трехточечного дугового сегмента.

Вторая точка дуги: Указать точку

Конечная точка дуги: Указать точку

Отменить

Удаление последнего дугового сегмента, добавленного к телу.

Замкнуть

Тело замыкается путем построения линейного или дугового сегмента от заданной последней вершины до начальной точки тела. Для применения этой опции следует указать как минимум три точки.

Отменить

Удаление последнего дугового сегмента, добавленного к телу.

Дуга

К телу добавляется дуговой сегмент. Начальным направлением дуги по умолчанию является касательная к последнему построенному сегменту. Можно определить другое начальное направление с помощью опции "Направление".

Укажите конечную точку дуги или [Замкнуть/Направление/Линия/Вторая точка/Отменить]: Указать конечную точку либо задать опцию

Замкнуть

Тело замыкается путем построения линейного или дугового отрезка от последней вершины к началу тела.

Направление

Задание начального направления дугового сегмента.

Направление касательной для начальной точки дуги: Указать точку

Конечная точка дуги: Указать точку

Линия

Выход из режима построения дуговых сегментов и возврат к начальным запросам команды ПОЛИТЕЛО.

Вторая точка

Указываются вторая точка и конечная точка трехточечного дугового сегмента.

Вторая точка дуги: Указать точку

Конечная точка дуги: Указать точку

Отменить

Удаление последнего дугового сегмента, добавленного к телу.

Отменить

Удаление последнего сегмента, добавленного к телу.


ПОЛОСА Команда

П Команды
П Команды
ПОЛОСА Команда
Понятия Процедуры Команды

Построение линейных сегментов, обладающих шириной

Ввод команды: полоса

Ширина полосы <текущая>: Задать расстояние или нажать ENTER

Начальная точка: Указать точку (1)

Следующая точка: Указать точку (2)

Следующая точка: Указать точку (3) или нажать ENTER для завершения команды

Конечные точки полосы лежат на ее осевой линии. Команда ПОЛОСА автоматически подрезает концы смежных сегментов. Каждый сегмент строится после того, как будет задан следующий сегмент или нажата клавиша ENTER. Из-за сложности обработки соединений сегментов команда ПОЛОСА не имеет опции отмены.

В режиме закрашивания строятся сплошные полосы. Если этот режим отключен, отображается только контур полосы.


ПОЛРЕД Команда

П Команды
П Команды
ПОЛРЕД Команда
Понятия Процедуры Команды

Редактирование полилиний и трехмерных полигональных сетей

Панель Редактирование-2:

Меню "Изменить": "Объект" » "Полилиния"

Контекстное меню: Выбрать полилинию для редактирования, нажать правую кнопку мыши в области рисования и выбрать "Редактирование полилинии".

Ввод команды: полред

Выберите полилинию или [Несколько]: Выбрать объекты любым способом или ввести н

Дальнейшие запросы в командной строке зависят от того, какой объект выбран: 2D полилиния, 3D полилиния или 3D полигональная сеть.

Если выбранный объект является линией или дугой, отобразится следующий запрос.

Выбранный объект - не полилиния.

Сделать его полилинией? <Y>: Ввести д или н или нажать клавишу ENTER

При ответе д такой объект преобразуется в двумерную полилинию, состоящую из одного сегмента. Полученную полилинию можно отредактировать. Этой операцией можно пользоваться для объединения отрезков и дуг в полилинию. Если значение системной переменной PEDITACCEPT равно 1, то такой запрос не выдается, и выбранный объект автоматически преобразуется в полилинию.

Несколько

Возможность выбора нескольких объектов.

Выбор 2D полилинии

Если выбрать 2D полилинию, отобразится следующий запрос:

Задайте опцию [Замкнуть/Добавить/Ширина/Вершина/Сгладить/Сплайн/Убрать сглаживание/Типлин/Отменить]: Задать опцию или нажать ENTER для завершения команды

Если полилиния в текущий момент замкнута, опция "Замкнуть" заменяется опцией "Разомкнуть". 2D полилинии можно редактировать только в том случае, если направление нормали параллельно оси Z текущей ПСК.

Замкнуть

Создание замыкающего сегмента полилинии, соединяющего его последний сегмент с первым. Полилиния считается открытой, пока ее не замкнуть с помощью параметра "Замкнуть".

Открыть

Удаление замыкающего сегмента полилинии. Полилиния считается замкнутой до ее размыкания с помощью параметра "Открыть".

Добавить

Добавление отрезка, дуги или другой полилинии, какой-либо конец которой совпадает с концом данной полилинии, а также отмена сглаживания для полилиний, сглаженных дугой. Конец добавляемого объекта должен точно совпадать с одной из конечных точек полилинии, за исключением случаев, когда в ответ на первый запрос команды ПОЛРЕД была выбрана опция "Несколько". Эта опция позволяет объединять несоприкасающиеся полилинии, если их конечные точки лежат на расстоянии, не превышающем заданное.

Выберите объекты: Выбрать объекты любым способом

Если ранее было выбрано несколько объектов с помощью параметра "Несколько", отобразится следующий запрос:

Значение допуска или [Способ]<0,0000>: Ввести расстояние или с

Способ

Задание способа объединения выбранных полилиний.

Задайте опцию редактирования вершины

Cпособ добавления элементов [Удлинить/Добавить/Оба}<Удлинить>: Ввести у, д или о

С продолжением

Объединение выбранных полилиний удлинением или обрезкой сегментов до ближайших конечных точек.

Добавить

Объединение выбранных полилиний добавлением прямолинейного сегмента между ближайшими конечными точками.

Оба

Объединение выбранных полилиний удлинением или обрезкой (если возможно). Если это невозможно сделать с помощью этих операций, то объединение выбранных полилиний производится добавлением прямолинейного сегмента между ближайшими конечными точками.

Ширина

Задание новой единой ширины для всей полилинии.

Новая ширина для всех сегментов:

Для изменения начальной и конечной ширины отдельных сегментов можно воспользоваться также параметром "Ширина" опции "Редактировать вершину".

Редактировать вершину

Первая вершина полилинии помечается на экране крестиком (X). Если для этой вершины задана касательная, то ее направление указывается стрелкой. В командной строке выдаются следующие запросы:

[След/Пред/Разорвать/Вставить/Перенести/РеГен/Выпрямить/Касательная/Ширина/выХод] <текущая>: Задать опцию или нажать ENTER

При нажатии ENTER выполняется одна из опций по умолчанию ("След" или "Пред").

След

Перемещение маркера X к следующей вершине. При этом маркер не будет циклически переходить от конца к началу полилинии даже в том случае, когда последняя замкнута.

Пред

Перемещение маркера X к предыдущей вершине. При этом маркер не будет циклически переходить от начала к концу полилинии даже в том случае, когда последняя замкнута.

Разорвать

Запоминание места вершины, отмеченной маркером X, при перемещении маркера к другим вершинам.

Задайте опцию [След/Пред/Выполн/выХод] <текущая>: Задать опцию или нажать ENTER

Если какая-либо из заданных вершин попадает на конец полилинии, то результатом будет одна усеченная полилиния. Если обе заданные вершины попадают на концы полилинии (или если задана одна вершина и она попадает на конечную точку), то опцию "Разорвать" использовать нельзя.

След

Перемещение маркера X к следующей вершине. При этом маркер не будет циклически переходить от конца к началу полилинии даже в том случае, когда последняя замкнута.

Пред

Перемещение маркера X к предыдущей вершине. При этом маркер не будет циклически переходить от начала к концу полилинии даже в том случае, когда последняя замкнута.

Выполнить

Удаление всех сегментов и вершин между двумя заданными вершинами и возвращение в режим редактирования вершин.

Выход

Завершение работы в режиме "Разорвать" и возвращение в режим редактирования вершин.

Вставить

Добавление к полилинии новой вершины после той вершины, которая в текущий момент помечена маркером Х.

Положение новой вершины: Указать точку (1)

Перенести

Перенос помеченной в данный момент вершины в другое место.

Новое положение помеченной вершины: Указать точку (1)

Регенерировать

Регенерация полилинии.

Выпрямить

Запоминание места вершины, отмеченной маркером X, при перемещении маркера к другим вершинам.

Если требуется удалить дуговой сегмент, связывающий два прямых сегмента полилинии, а затем продлить эти прямые сегменты до пересечения, то следует воспользоваться командой СОПРЯЖЕНИЕ с нулевым радиусом скругления.

Задайте опцию [След/Пред/Выполн/выХод] <текущая>: Задать опцию или нажать ENTER

След

Перемещение маркера X к следующей вершине.

Пред

Перемещение маркера X к предыдущей вершине.

Выполнить

Удаление всех сегментов и вершин между двумя заданными вершинами, замена их одним прямолинейным сегментом и возвращение в режим редактирования вершин. Если задается только одна вершина (вводом слова выполнить без перемещения маркера Х), то будет спрямлен следующий за вершиной сегмент (если он является дугой).

Выход

Завершение работы в режиме "Выпрямить" и возвращение в режим редактирования вершин.

Касательная

Задание направления касательной в вершине, помеченной маркером Х, для последующего использования при сглаживании кривой. В командной строке выдаются следующие запросы:

Направление касательной в вершине: Указать точку или ввести угол

Ширина

Изменение значения начальной и конечной ширины сегмента, следующего за помеченной вершиной.

Начальная ширина следующего сегмента <текущая>: Указать точку, ввести значение либо нажать ENTER

Конечная ширина следующего сегмента <текущая>: Указать точку, ввести значение либо нажать ENTER

Для того чтобы увидеть сегмент c новой шириной, следует воспользоваться опцией "Регенерировать".

Выход

Выход из режима редактирования вершин.

По ширине

Вычисление гладкой кривой, сглаживающей все вершины полилинии, с использованием заданных направлений касательных. Кривая проходит через все вершины полилинии, удовлетворяя при этом значениям касательных, заданных для этих вершин.

Сплайн

Вершины выбранной полилинии используются как контрольные точки, или каркас, кривой, которая будет открытой или замкнутой в зависимости от исходной полилинии. Эта кривая носит название полилинии, сглаженной сплайном. Она проходит через первую и последнюю контрольную точки, если исходная полилиния не была замкнута. Кривая как бы подтянута к другим точкам, но не обязательно проходит через них. С увеличением числа точек на определенном участке сплайна кривая все больше приближается к ним. Можно создавать квадратичные и кубические сглаженные сплайнами полилинии.

Полилинии, сглаженные сплайнами, существенно отличаются от кривых, построенных с помощью опции "Вписать". При вписывании создаются пары дуг, проходящих через каждую контрольную точку. Форма этих кривых отличается от формы настоящих В-сплайнов, построенных командой СПЛАЙН.

Если исходная полилиния содержит дуговые сегменты, то при формировании каркаса сплайна они спрямляются. Если каркас имеет ширину, результирующий сплайн будет сужаться от ширины первой вершины к ширине последней. Информация о ширине в промежуточных точках игнорируется. При использовании сглаживания сплайном каркас, выводимый на экран, отображается с нулевой шириной и типом линий "НЕПРЕРЫВНАЯ". Направления касательных в контрольных точках не влияют на сглаживание сплайнами.

Если сглаживаемая сплайном кривая вписывается в полилинию, каркас сглаженной кривой запоминается и может быть затем заново вызван при последующей отмене сглаживания. Сглаженная сплайнами кривая может быть преобразована обратно в каркасную полилинию с помощью опции "Убрать сглаживание" команды ПОЛРЕД. Для сглаженных кривых данная опция действует так же, как для сплайнов.

Каркасы сплайнов обычно не высвечиваются на экране. Для вывода каркаса следует установить значение 1 для системной переменной SPLFRAME. При последующей регенерации чертежа строится как каркас, так и кривая сплайна.

Большинство команд редактирования действует как на сглаженные сплайном полилинии так и на сглаженные кривые.

  • Команды ПЕРЕНЕСТИ, СТЕРЕТЬ, КОПИРОВАТЬ, СИММЕТРИЯ, ПОВЕРНУТЬ и МАСШТАБ действуют как на видимый сплайн, так и на его каркас (независимо от видимости).
  • Команда УДЛИНИТЬ изменяет каркас путем добавления новой вершины в точке, где начальный или конечный сегмент полилинии пересекает граничную кромку.
  • Команды РАЗОРВАТЬ и ОБРЕЗАТЬ создают полилинию, сглаживаемую только сплайном и совместимую со сглаженными кривыми, где сглаживание кривой постоянно.
  • Команда РАСЧЛЕНИТЬ удаляет каркас и генерирует линии и дуги для соответствия сглаженной сплайном полилинии.
  • Команда ПОДОБИЕ создает полилинию, сглаживаемую только сплайном и совместимую по поведению со сглаженными кривыми.
  • Команды ПОДЕЛИТЬ, РАЗМЕТИТЬ и параметр "Объект" команд ПЛОЩАДЬ и ШТРИХ действуют только на сплайн; каркас для них недоступен.
  • Команда РАСТЯНУТЬ ведет себя особым образом по отношению к сплайнам: растягиваемый сплайн вписывается в растянутый каркас.

Опция "Добавить" команды ПОЛРЕД приводит к отмене сглаживания сплайном и к удалению информации о сплайне как для исходной полилинии, так и для любой полилинии, добавленной к ней. Выполнив команду "Добавить", можно вписать новый сплайн в получаемую полилинию.

Опции редактирования вершин команды ПОЛРЕД действуют следующим образом:

  • Опции "След" и "Пред" перемещают маркер X только к точкам каркаса (независимо от того, виден он или нет).
  • После использования опции "Разорвать" сплайн уничтожается.
  • При использовании опций "Вставить", "Перенести", "Выпрямить" и "Ширина" сплайн автоматически строится заново.
  • Опция "Касательная" на сплайн не действует.

Объектная привязка возможна только к кривой со сглаживанием сплайном, но не к каркасу. Если необходима привязка к управляющим точкам каркаса, то сначала следует использовать команду ПОЛРЕД для нового вызова каркаса полилинии.

Тип аппроксимированной кривой сплайна определяется системной переменной SPLINETYPE. Переменная SPLINETYPE, равная 5, аппроксимирует квадратичный B-сплайн. Переменная SPLINETYPE, равная 6, аппроксимирует кубический B-сплайн.

Качество сплайновой аппроксимации определяется и изменяется системной переменной SPLINESEGS. Можно также использовать средства AutoLISP®. По умолчанию используется значение 8. Большее значение переменной соответствует большему числу сегментов, которые будут нарисованы, а значит, и более близкому приближению к идеальному сплайну. Однако для этого требуется больше места в файле чертежа и времени для генерации сплайна.

Если задать для SPLINESEGS отрицательное значение, программа создаст количество сегментов, равное абсолютной величине этой переменной, а затем применяет к этим сегментам дуговое сглаживание. При таком способе дуги используются в качестве аппроксимирующих сегментов. Это позволяет производить более плавное сглаживание при малом числе заданных сегментов, но за большее время.

Для изменения числа сегментов, использованных в созданном сплайне, следует изменить SPLINESEGS и повторить генерацию сплайна. При этом нет необходимости предварительно отменять ранее сделанное сглаживание.

Убрать сглаживание

Удаление всех дополнительных вершин, вставленных при выполнении операций "Сгладить" и "Сплайн", и выпрямление всех сегментов полилинии. Любая информация о касательных, заданная для вершин полилинии, оставляется для последующего использования при выдаче запросов "Сгладить". После обработки сглаженной сплайном полилинии с помощью таких команд, как РАЗОРВАТЬ или ОБРЕЗАТЬ, параметр "Убрать сглаживание" нельзя будет использовать.

Типлин

Задание способа генерации типа линий в вершинах полилинии. При выборе значения "Откл" генерация заданного типа линий начинается со штриха и оканчивается штрихом в каждой вершине. Опция "Типлин" не действует для полилиний с сегментами переменной ширины.

Генерация типа линий по всей полилинии [Вкл/Откл] <текущая>: Ввести вкл или откл или нажать ENTER

Отменить

Отменяется действие операций редактирования до наступления состояния, существовавшего в начале сеанса ПОЛРЕД.

Выбор 3D полилинии

Если выбрать 3D полилинию, отобразится следующий запрос:

Задайте опцию [Замкнуть/Вершина/СПлайн/Убрать сглаживание/Отменить]: Задать опцию или нажать ENTER

Если полилиния в текущий момент замкнута, опция "Замкнуть" заменяется опцией "Разомкнуть".

Замкнуть

Создание замыкающего сегмента полилинии, соединяющего его последний сегмент с первым. Полилиния считается открытой, пока ее не замкнуть с помощью параметра "Замкнуть".

Открыть

Удаление замыкающего сегмента полилинии. Полилиния считается замкнутой до ее размыкания с помощью параметра "Открыть".

Редактировать вершину

Выполнение различных функций редактирования над вершиной полилинии и примыкающими к ней сегментами.

Задайте опцию редактирования вершины

[След/Пред/Разорвать/Вставить/Перенести/Реген/Выпрямить/выХод <текущая>: Задать опцию или нажать ENTER

При нажатии ENTER выполняется одна из опций по умолчанию ("След" или "Пред").

След

Перемещение маркера X к следующей вершине. При этом маркер не будет циклически переходить от конца к началу полилинии даже в том случае, когда последняя замкнута.

Пред

Перемещение маркера X к предыдущей вершине. При этом маркер не будет циклически переходить от начала к концу полилинии даже в том случае, когда последняя замкнута.

Разорвать

Запоминание места вершины, отмеченной маркером X, при перемещении маркера к другим вершинам.

Задайте опцию [След/Пред/Выполн/выХод] <текущая>: Задать опцию или нажать ENTER

След

Перемещение маркера X к следующей вершине. При этом маркер не будет циклически переходить от конца к началу полилинии даже в том случае, когда последняя замкнута.

Пред

Перемещение маркера X к предыдущей вершине. При этом маркер не будет циклически переходить от начала к концу полилинии даже в том случае, когда последняя замкнута.

Выполнить

Удаление всех сегментов и вершин между двумя заданными вершинами и возвращение в режим редактирования вершин.

Выход

Завершение работы в режиме "Разорвать" и возврат в режим редактирования вершины.

Если какая-либо из заданных вершин попадает на конец полилинии, то полилиния усекается . Если обе заданные вершины попадают на концы полилинии (или если задана одна вершина и она попадает на конечную точку), то опцию "Разорвать" использовать нельзя.

Слияние

Добавление к полилинии новой вершины после той вершины, которая в текущий момент помечена маркером.

Положение новой вершины: Указать точку

Перенести

Перемещение помеченной вершины.

Новое положение помеченной вершины: Указать точку

Регенерировать

Регенерация полилинии.

Выпрямить

Запоминание места вершины, отмеченной маркером X, при перемещении маркера к любой другой вершине.

Задайте опцию [След/Пред/Выполн/выХод] <текущая>: Задать опцию или нажать ENTER

След

Перемещение маркера X к следующей вершине.

Пред

Перемещение маркера X к предыдущей вершине.

Выполнить

Удаление всех сегментов и вершин между двумя заданными вершинами, замена их одним прямолинейным сегментом и возвращение в режим редактирования вершин. Если задается только одна вершина (вводом слова выполнить без перемещения маркера Х), то будет спрямлен следующий за вершиной сегмент (если он является дугой).

Выход

Завершение работы в режиме "Выпрямить" и возврат в режим редактирования вершин.

Если требуется удалить дуговой сегмент, связывающий два прямых сегмента полилинии, а затем продлить эти прямые сегменты до пересечения, то следует воспользоваться командой СОПРЯЖЕНИЕ с нулевым радиусом скругления.

Выход

Выход из режима редактирования вершин.

Сплайновая кривая

Сглаживание 3D кривой B-сплайна по ее управляющим точкам. Системная переменная SPLFRAME позволяет управлять точностью и отображением на экране управляющих точек для 3D B-сплайна, кривые которого могут быть аппроксимированы только сегментами линии. Отрицательные значения для сегментов сплайна игнорируются.

Убрать сглаживание

Удаление всех дополнительных вершин, вставленных при выполнении операций "Сгладить" и "Сплайн", и выпрямление всех сегментов полилинии. Любая информация о касательных, заданная для вершин полилинии, оставляется для последующего использования при выдаче запросов "Сгладить". После обработки сглаженной сплайном полилинии с помощью таких команд, как РАЗОРВАТЬ или ОБРЕЗАТЬ, параметр "Убрать сглаживание" нельзя будет использовать.

Отменить

Отменяется действие операций редактирования до наступления состояния, существовавшего в начале сеанса ПОЛРЕД.

Выбор 3D полигональных сетей

Если выбрать полигональную сеть, отобразится следующий запрос:

Задайте опцию [Вершина/Сгладить/Убрать сглаживание/Mзамкнуть/Nзамкнуть/Отменить]: Задать опцию или нажать ENTER для завершения команды

Если полигональная сеть в данный момент замкнута в направлениях M или N, то опции "Mзамкнуть" и "Nзамкнуть" заменяются соответственно на "Mразомкнуть" и "Nразомкнуть".

Редактировать вершину

Служит для редактирования отдельных вершин полигональной сети, которую можно рассматривать как прямоугольный массив M и N, где M и N размеры, определенные в команде 3DСЕТЬ. Системные переменные SURFTAB1 и SURFTAB2 хранят значения M и N для использования командами П-СОЕД, П-СДВИГ, П-ВРАЩ и П-КРОМКА.

Задайте опцию [След/Пред/Левая/прАвая/Верхняя/Нижняя/Перенести/Реген/выХод <текущая>: Задать опцию или нажать ENTER

При нажатии ENTER выполняется одна из опций по умолчанию ("След" или "Пред").

След

Перемещение маркера X к следующей вершине. При этом маркер не будет циклически переходить от конца к началу 3D сети даже в том случае, когда сеть замкнута.

Пред

Перемещение маркера X к предыдущей вершине. При этом маркер не будет циклически переходить от начала к концу 3D сети даже в том случае, когда сеть замкнута.

Левая

Маркер X перемещается к предыдущей вершине в направлении N. При этом маркер не будет циклически переходить от начала к концу 3D сети даже в том случае, когда сеть замкнута.

Правая

Маркер X перемещается к следующей вершине в направлении N. При этом маркер не будет циклически переходить от конца к началу 3D сети даже в том случае, когда сеть замкнута.

Верхняя

Маркер X перемещается к следующей вершине в направлении M. При этом маркер не будет циклически переходить от конца к началу 3D сети даже в том случае, когда сеть замкнута.

Нижняя

Маркер X перемещается к предыдущей вершине в направлении M. При этом маркер не будет циклически переходить от начала к концу 3D сети даже в том случае, когда сеть замкнута.

Перенести

Перенос помеченной в данный момент вершины в другое место.

Новое положение помеченной вершины: Указать точку

Регенерировать

Регенерация полигональной сети.

Выход

Выход из режима редактирования вершин.

Сгладить поверхностью

Сглаживание сети поверхностью. Выбором типа сглаживающей поверхности можно управлять с помощью системной переменной SURFTYPE. Типами поверхностей являются квадратичный B-сплайн, кубический B-сплайн и поверхность Безье.

Убрать сглаживание

Восстановление исходной полигональной сети управляющих точек.

Mзамкнуть

Сеть замыкается в направлении M, если она разомкнута в этом направлении.

Mразомкнуть

Сеть размыкается в направлении M, если она замкнута в этом направлении.

Nзамкнуть

Сеть замыкается в направлении N, если она разомкнута в этом направлении.

Nразомкнуть

Сеть размыкается в направлении N, если она замкнута в этом направлении.

Отменить

Отменяется действие операций редактирования до наступления состояния, существовавшего в начале сеанса ПОЛРЕД..


ПОМОЩНИК Команда

П Команды
П Команды
ПОМОЩНИК Команда
Понятия Процедуры Команды

Открывает в информационной палитре "Быструю справку", которая отображает контекстную информацию

Меню "Справка": "Информационная палитра"

Ввод команды: помощник (или 'помощник для прозрачного вызова)

Информационная палитра постоянно следит за выполняемыми командами и отображает информацию, напрямую связанную с активной командой или диалоговым окном. Пользователь может в любое время зафиксировать отображаемую информацию, и тогда она не будет динамически изменяться. Например, может понадобиться зафиксировать информацию о какой-либо процедуре в ходе выполнения ее пунктов.

Доступ к некоторым параметрам возможен через контекстное меню информационной палитры.

Темы:

  • Контекстное меню информационной палитры


Контекстное меню информационной палитры

П Команды
П Команды
Контекстное меню информационной палитры
Понятия Процедуры Команды

Обеспечивает доступ к опциям информационной палитры и контролю отображаемой в ней информации. Нажать правую кнопку мыши на информационной палитре.

Вернуть

Отображение информации, описывающей использование информационной палитры.

Назад

Возврат к предыдущей теме.

Вперед

Переход к следующей теме.

Печать

Печать текущей темы.

Блокировать

Фиксирование текущей справочной страницы в информационной палитре.


ПОМОЩНИКЗАКР Команда

П Команды
П Команды
ПОМОЩНИКЗАКР Команда
Понятия Процедуры Команды

Закрывает "Быструю справку" в информационной палитре

Ввод команды: помощникзакр (или'помощникзакр прозрачного вызова)

Закрывает краткую справку и информационную палитру.


ПОРЯДОК Команда

П Команды
П Команды
ПОРЯДОК Команда
Понятия Процедуры Команды

Изменение порядка прорисовки растровых изображений и других объектов на экран

Панель "Порядок прорисовки":

Меню "Инструменты": "Порядок прорисовки"

Контекстное меню: Выбрать объект, нажать на нем правую кнопку мыши и затем выбрать "Порядок прорисовки".

Ввод команды: порядок

Выбрать объекты: Выбрать объекты любым способом

Задать опцию порядка следования [Над объектами/Под объектами/Передний план/Задний план] <Сзади>: Задать опцию или нажать клавишу ENTER

Перед объектами

Выбранный объект помещается перед объектами, указанными в качестве опорных.

Выбрать опорные объекты: Выбрать объекты любым способом

За объектами

Выбранный объект помещается за объектами, указанными в качестве опорных.

Выбрать опорные объекты: Выбрать объекты любым способом

Передний план

Выбранные объекты помещаются перед всеми остальными.

Задний план

Выбранные объекты помещаются позади всех остальных.

При изменении порядка прорисовки (на экране или при выводе не печать) для нескольких объектов порядок отображения выбранных объектов друг относительно друга остается неизменным.

По умолчанию, новым объектам, созданным на основе уже имеющихся (например с помощью команд СОПРЯЖЕНИЕ или ПОЛРЕД), присваивается порядок прорисовки того исходного объекта, который был выбран первым. По умолчанию, в процессе редактирования (например с помощью команды ПЕРЕНЕСТИ или РАСТЯНУТЬ) объект располагается поверх всех остальных объектов в чертеже. После редактирования чертеж частично регенерируется так, чтобы объекты отображались в правильном порядке. Это может привести к увеличению времени выполнения некоторых операций редактирования. Для изменения настроек по умолчанию для порядка прорисовки объектов чертежа можно воспользоваться системной переменной DRAWORDERCTL. ТЕКСТПЕРПЛАН изменяет порядок прорисовки всех текстовых и размерных надписей на чертеже.


ПОСЕЧЕНИЯМ Команда

П Команды
П Команды
ПОСЕЧЕНИЯМ Команда
Понятия Процедуры Команды

Создает 3D тела или поверхности путем сечений двумя или более кривыми.

Панель "Моделирование":

Меню "Рисование": "Моделирование" » "По сечениям"

Ввод команды: посечениям

Пульт управления: Панель создания 3D объектов, "По сечениям"

С помощью команды ПОСЕЧЕНИЯМ можно создавать новые тела или поверхности, задавая ряд поперечных сечений. Поперечные сечения определяют профиль (форму) результирующего тела или поверхности. Поперечные сечения (в общем случае, кривые и линии) могут быть разомкнутыми (например, дуга) или замкнутыми (например, окружность). Команда ПОСЕЧЕНИЯМ изображает тела или поверхности в пространстве между поперечными сечениями. При использовании команды ПОСЕЧЕНИЯМ следует указать как минимум два поперечных сечения.

При создании тела или поверхности по сечениям можно использовать следующие объекты:

Объекты, которые можно использовать для поперечного сечения | Объекты, которые можно использовать в качестве траектории сечения | Объекты, которые можно использовать как направляющие
Отрезки | "Линия" | "Линия"
Дуги | Дуга | Дуга
Эллиптическая дуга | Эллиптическая дуга | Эллиптическая дуга
2D полилиния | Сплайн | 2D сплайн
2D сплайн | Спираль | 3D сплайн
Круг | Круг | 2D полилиния
Эллипс | Эллипс | 3D полилиния
Точки (только первое и последнее поперечные сечения) | Двумерные полилинии |
 | 3D полилиния |

С помощью параметра "Траектория" можно выбрать одну криволинейную траекторию , чтобы определить форму тела или поверхности. С помощью параметра "Направляющие" можно выбрать несколько кривых, чтобы определить контуры тела или поверхности.

Системная переменная DELOBJ определяет, требуется ли автоматическое удаление поперечных сечений, направляющих и траектории после создания тела или поверхности, а также, будет ли выдан запрос на удаление этих объектов.

Пользователь перед запуском команды имеет возможность выбрать поперечные сечения.

Выберите поперечные сечения в восходящем порядке: Выбрать разомкнутые или замкнутые кривые по порядку рассечения поверхности или тела

Задайте опцию [Направляющие/Траектория/Только поперечные сечения] <Только поперечные сечения>: Нажать клавишу ENTER, чтобы использовать выбранные поперечные сечения, отображающие диалоговое окно "Настройки сечений", или ввести опцию

Направляющие

Задает направляющие кривые, которые управляют формой создаваемого по сечениям тела или поверхности. Направляющие кривые - это линии или кривые, которые дополнительно определяют форму тела или поверхности путем добавления информации каркаса к объекту. Пользователь может использовать направляющие кривые для управления тем, как точки согласуются с соответствующими поперечными сечениями для предотвращения формирования нежелательных результатов, например, складок в окончательно полученном теле или поверхности.

Для получения корректного результата каждая направляющая кривая должна удовлетворять следующим критериям:

  • Пересекать каждое поперечное сечение
  • Начинаться на первом поперечном сечении
  • Завершаться на последнем поперечном сечении

Пользователь может выбрать любое число направляющих кривых для создаваемой по сечениям поверхности или тела.

Выберите направляющие: Выбрать направляющие кривые для создаваемой по сечениям поверхности или тела, а затем нажать клавишу ENTER

Траектория

Задает одиночную траекторию для создаваемого по сечениям тела или поверхности.

Криволинейная траектория должна пересекать все плоскости поперечных сечений.

Выберите траекторию: Задать одиночную траекторию для создаваемого по сечениям тела или поверхности

Только поперечные сечения

Отображается диалоговое окно "Настройки сечений".

Темы:

  • Диалоговое окно "Настройки сечений"


Диалоговое окно "Настройки сечений"

П Команды
П Команды
Диалоговое окно "Настройки сечений"
Понятия Процедуры Команды

Панель "Моделирование":

Меню "Рисование": "Моделирование" » "По сечениям"

Ввод команды: посечениям

Управляет контуром создаваемой по сечениям поверхности на ее поперечных сечениях. Кроме того, позволяет пользователю замыкать поверхность или тело.

Линейчатый

Указывает что тело или поверхность является линейчатым (прямым) между поперечными сечениями и имеет острые кромки на поперечных сечениях. (Системная переменная LOFTNORMALS)

Сглаживание

Указывает, что между поперечными сечениями расположено гладкое тело или поверхность, имеющее острые кромки на начальном и конечном поперечных сечениях. (Системная переменная LOFTNORMALS)

Нормаль к

Управляет нормалью к телу или поверхности, в местах где она проходит через поперечные сечения. (Системная переменная LOFTNORMALS)

Начальное поперечное сечение

Указывает, что нормаль к поверхности является нормалью к начальному поперечному сечению.

Конечное поперечное сечение

Указывает, что нормаль к поверхности является нормалью к конечному поперечному сечению.

Начальное и конечное поперечные сечения

Указывает, что нормаль к поверхности является нормалью и к начальному и конечному поперечным сечениям.

Все поперечные сечения

Указывает, что нормаль к поверхности является нормалью ко всем поперечным сечениям.

Конусные ограничения

Управляет углом и величиной конусных ограничений первого и последнего поперечных сечений тела или поверхности, построенных по сечениям. "Конусные ограничения" указывают начальное направление поверхности. 0 находится снаружи от плоскости кривой. (Системная переменная LOFTNORMALS)

Начальный угол

Указывает "конусное ограничение" для начального поперечного сечения. (Системная переменная LOFTANG1)

Начальная величина

Управляет относительным расстоянием поверхности от начального поперечного сечения в направлении "конусного ограничения" до начала изгиба поверхности к следующему поперечному сечению. (Системная переменная LOFTMAG1)

Конечный угол

Указывает "конусное ограничение" для конечного поперечного сечения. (Системная переменная LOFTANG2)

Конечная величина

Управляет относительным расстоянием поверхности от конечного поперечного сечения в направлении "конусное ограничение" до начала изгиба поверхности к предыдущему поперечному сечению. (Системная переменная LOFTMAG2)

Замкнуть поверхность или тело

Замыкает или размыкает поверхность или тело. При использовании этой опции поперечные сечения должны образовать тор, чтобы получаемая по сечениям поверхность или тело образовали замкнутую трубу. (Системная переменная LOFTPARAM)

Предварительный просмотр изменений

Применяет текущие настройки к получаемой по сечениям поверхности или телу и отображает предварительный вид изменений в области чертежа.


ПРЕДВАР Команда

П Команды
П Команды
ПРЕДВАР Команда
Понятия Процедуры Команды

Предварительный просмотр на экране выводимого на печать листа

Панель "Стандартная"

Меню "Файл": Просмотр чертежа

Ввод команды: предвар

Команда ПРОСМОТР выводит полностраничный просмотровый образец текущего чертежа. Этот образец базируется на текущих параметрах печати, которые задаются в диалоговых окнах Параметры листа и Печать.

Курсор принимает форму увеличительного стекла со знаками плюс (+) и минус (-). Перетаскивание курсора вверх экрана при удержании нажатой кнопки указательного устройства приводит к увеличению просмотрового образца. При перетаскивании курсора вниз экрана просмотровый образец уменьшается.

Дополнительные возможности обеспечиваются панелью инструментов "Просмотровое окно".

Панель инструментов "Просмотровое окно"

В просмотровом окне содержатся указанные ниже опции.

Печать

Печать чертежа так, как он отображается на макете, с последующим выходом из режима предварительного просмотра.

Пан

Перемещение изображения по экрану с помощью курсора (в виде кисти руки). Курсор для этого следует перемещать в нужном направлении, удерживая кнопку выбора мыши в нажатом состоянии. Курсор остается активным до тех пор, пока не будет выбрана другая кнопка.

Зумирование

Увеличение или уменьшение изображения на экране с помощью курсора (в виде увеличительного стекла). Для увеличения изображения следует нажать кнопку выбора и перемещать курсор в направлении верхней части экрана. Для уменьшения изображения следует нажать кнопку выбора и перемещать курсор в направлении нижней части экрана.

Показать рамкой

Зумирование изображения в пределах заданной прямоугольной области. Данная опция может использоваться как при зумировании, так и при панорамировании.

Предыдущий вид

Восстановление исходного изображения полного чертежа. Данная опция может использоваться как при зумировании, так и при панорамировании.

Выход

Закрытие окна предварительного просмотра.


ПРЕОБРАЗОВАТЬ Команда

П Команды
П Команды
ПРЕОБРАЗОВАТЬ Команда
Понятия Процедуры Команды

Преобразование 2D полилиний и ассоциативных штриховок, созданных в AutoCAD Release 13 или ранее

Ввод команды: преобразовать

Тип объектов для преобразования [Штриховка/Полилиния/Все] <все>: Ввести ш преобразования штриховки, п для преобразования полилиний или с для обоих типов объектов

Штриховка

Преобразование всех штриховок, имеющихся в чертеже.

Какие объекты преобразовать [Выбрать/все] <все>: Ввести в для выбора отдельных объектов или п для преобразования всех объектов чертежа

Полилиния

Преобразование всех полилиний, имеющихся в чертеже.

Какие объекты преобразовать [Выбрать/все] <все>: Ввести в для выбора отдельных объектов или п для преобразования всех объектов чертежа

Все

Преобразование всех полилиний и штриховок, имеющихся в чертеже.

Какие объекты преобразовать [Выбрать/все] <все>: Ввести в для выбора отдельных объектов или п для преобразования всех объектов чертежа

Отображается одно или оба следующих сообщений:

число преобразованных штриховок

число преобразованных 2D полилиний

При открытии в Release 14 (или более поздней версии) чертежей из прежних версий программы штриховка автоматически не обновляется. Если после создания штриховки выполнена смена ПСК, данные о повороте обновленной штриховки могут оказаться неверными. При обновлении штриховки с помощью команды ПРЕОБРАЗОВАТЬ рекомендуется использовать опцию "Выбрать", чтобы иметь возможность проверить результаты.

В большинстве случаев не требуется использовать команду ПРЕОБРАЗОВАТЬ для обновления полилиний. Режим их автоматического преобразования при открытии чертежа задается системной переменной PLINETYPE. Полилинии в старом формате могут быть получены из чертежей, созданных в других приложениях, а также из старых чертежей, вставленных как блоки и затем расчлененных.

Примечание Полилинии, сглаженные дугами и сплайнами, всегда сохраняют старый формат; аналогично ведут себя полилинии, в вершинах которых хранятся расширенные данные объектов. Поведение команд редактирования не зависит от формата объекта.


ПРЕОБРВПВРХ Команда

П Команды
П Команды
ПРЕОБРВПВРХ Команда
Понятия Процедуры Команды

Преобразует объекты в поверхности

Меню "Редактирование": подменю "3D операции" » "Преобразовать в поверхность"

Ввод команды: преобрвпврх

Пульт управления: Панель "3D Make" (нажать значок, чтобы расширить панель), "Преобразовать в Поверхность"

С помощью команды ПРЕОБРВПВРХ можно преобразовать следующие объекты в поверхности:

  • Двумерные фигуры
  • Области
  • Разомкнутые полилинии с нулевой шириной, имеющие высоту
  • Отрезки, имеющие высоту
  • Дуги, имеющие высоту
  • Плоские 3D грани

Перед выдачей команды можно выбрать объекты, подлежащие преобразованию.

Примечание С помощью команды РАСЧЛЕНИТЬ можно создать поверхности из 3D твердотельных объектов с искривленными гранями, например, из цилиндра.

Выбрать объекты: Выбрать один или более объектов, подлежащих преобразованию в поверхности

Если один или более объектов в наборе объектов выбран неверно для команды, будет выдана подсказка для повторного выбора объектов.

Системная переменная DELOBJ определяет, будут ли выбранные пользователем объекты удалены после создания поверхности, или будет выдана подсказка на удаление объектов.


ПРЕОБРВТЕЛО Команда

П Команды
П Команды
ПРЕОБРВТЕЛО Команда
Понятия Процедуры Команды

Преобразует полилинии и окружности, для которых задана высота, в 3D тела.

Меню "Редактирование": подменю "3D операции" » "Преобразовать в тело"

Ввод команды: преобрвтело

Пульт управления: Панель "3D Make" (нажать на значке, чтобы расширить панель), "Преобразовать в тело"

С помощью команды ПРЕОБРВТЕЛО можно преобразовать следующие объекты в выдавленные 3D тела:

  • Полилинии с равномерной шириной, имеющие высоту
  • Замкнутые полилинии с нулевой шириной, имеющие высоту
  • Круги, имеющие высоту

Примечание Нельзя использовать команду ПРЕОБРВТЕЛО для полилиний, содержащих вертикальные линии с нулевой шириной, или содержащих сегменты разной ширины.

Перед выдачей команды можно выбрать объекты, подлежащие преобразованию.

Выбрать объекты: Выбрать один или более объектов, имеющих высоту, для преобразования в выдавленные 3D тела

Если один или более объектов в наборе объектов выбран неверно для команды, будет выдана подсказка для повторного выбора объектов.

Системная переменная DELOBJ определяет, будут ли выбранные пользователем объекты удалены после создания тела, или будет выдана подсказка на удаление объектов.


ПРЕОБРСПЕЧ Команда

П Команды
П Команды
ПРЕОБРСПЕЧ Команда
Понятия Процедуры Команды

Настройка чертежа на использование именованных или цветозависимых стилей печати

Ввод команды: преобрспеч

В чертеже могут использоваться либо именованные, либо цветозависимые стили печати, но не оба вида стилей одновременно.

Команда ПРЕОБРСПЕЧ перестраивает текущий открытый чертеж с использования цветозависимых на использование именованных стилей печати, или наоборот, в зависимости от того, какой стиль печати применяется в чертеже на момент вызова команды.

  • Перенастройка чертежей на именованные стили печати
  • Перенастройка чертежей на цветозависимые стили печати

При преобразовании чертежа команда ПРЕОБРСПЕЧ присваивает системной переменнойPSTYLEMODE соответствующее значение (1 = именованные стили, 0 = цветозависимые стили).

Например, в чертеже с цветозависимыми стилями печати свойства печати назначаются объектам и слоям по цвету. Это означает, что все объекты с одинаковым цветом имеют одинаковые свойства печати. Команда ПРЕОБРСПЕЧ преобразует чертеж для использования именованных стилей печати, которые можно применять к объектам или слоям независимо от назначенного им цвета. В этом случае объекты одинакового цвета могут иметь разные свойства печати.

Перенастройка чертежей на именованные стили печати

После вызова команды появляется окно, которое советует пользователю перед преобразованием чертежа преобразовать таблицу стилей печати. Преобразовать таблицы цветозависимых стилей печати в таблицы именованных стилей печати можно с помощью команды ПРЕОБРТСП.

Отобразится диалоговое окно "Выбор файла" (стандартное диалоговое окно выбора файла), в котором следует выбрать файл таблицы именованных стилей печати для преобразованного чертежа.

Команда ПРЕОБРСПЕЧ требует выбрать таблицу именованных стилей печати, которая была преобразована командой ПРЕОБРТСП, или создана из файлов PC2 или PCP. Обычно выбирается таблица именованных стилей печати, преобразованная из таблицы цветозависимых стилей печати того же чертежа.

Команда ПРЕОБРСПЕЧ подключает выбранную таблицу именованных стилей печати к пространству модели и ко всем листам. Каждый слой чертежа связывается с именованным стилем печати (из преобразованной таблицы стилей печати), который имеет те же свойства печати, какие имел цветозависимый стиль. Объектам, имевшим такой же цветозависимый стиль печати, как и их слои, назначается именованный стиль печати ПОСЛОЮ. Объектам, имевшим цветозависимый стиль печати, который отличался от стиля печати их слоев, назначается именованный стиль печати со свойствами печати, которые были у цветозависимого стиля.

После преобразования чертежа назначенную таблицу именованных стилей печати можно изменить или задать другие таблицы для модели или слоев. Также можно задать для объектов чертежа индивидуальные стили печати.

Перенастройка чертежей на цветозависимые стили печати

После вызова команды появляется окно, предупреждающее пользователя, что связи объектов с именованными стилями печати и связи пространства модели и слоев с таблицами именованных стилей печати будут удалены.

После преобразования чертежа можно установить для него таблицу цветозависимых стилей печати. Стили печати будут назначены на основе цветов объектов.


ПРЕОБРТСП Команда

П Команды
П Команды
ПРЕОБРТСП Команда
Понятия Процедуры Команды

Преобразование таблиц цветозависимых стилей печати (СТВ) в таблицы именованных стилей печати (STB)

Ввод команды: преобртсп

Откроется диалоговое окно "Выбор файла" (стандартное диалоговое окно выбора файла), в котором следует выбрать файл цветозависимого стиля печати. Затем выводится диалоговое окно "Создание файла". При необходимости пользователь может задать новое расположение и имя преобразованного файла.

Команда ПРЕОБРТСП сохраняет копию таблицы цветозависимых стилей печати как таблицу именованных стилей печати, которую затем можно применить к чертежам, использующим именованные стили печати. Команда ПРЕОБРТСП не влияет на исходную таблицу цветозависимых стилей печати. По умолчанию новый файл таблицы именованных стилей печати размещается в папке Стили печати. Имя по умолчанию для нового файла таблицы именованных стилей печати — такое же, как имя таблицы цветозависимых стилей печати.

Команда ПРЕОБРТСП создает: один именованный стиль печати для каждого цвета, имеющего уникальные свойства печати; один именованный стиль печати для каждой группы цветов, которым назначены одинаковые свойства печати, и стиль печати по умолчанию с именем ОБЫЧНЫЙ.

Например, если все цвета в таблице цветозависимых стилей печати имеют одинаковые свойства печати, команда ПРЕОБРТСП создает только два именованных стиля печати в таблице именованных стилей печати: ОБЫЧНЫЙ (стиль печати по умолчанию) и СТИЛЬ 1, который приобретает свойства печати, назначенные всем цветам в таблице цветозависимых стилей печати. Теперь предположим, что все цвета в таблице цветозависимых стилей печати имеют одинаковые свойства печати, за исключением двух цветов (СИНЕГО и ЗЕЛЕНОГО). Если каждый из упомянутых цветов имеет уникальные свойства печати, команда ПРЕОБРТСП создает четыре именованных стиля печати в таблице именованных стилей печати: ОБЫЧНЫЙ (стиль печати по умолчанию); СТИЛЬ 1, который приобретает свойства печати для цвета ЗЕЛЕНЫЙ; СТИЛЬ 2, который приобретает свойства печати для цвета СИНИЙ; СТИЛЬ 3, который приобретает свойства печати, назначенные всем остальным цветам.

Команда ПРЕОБРТСП присваивает стилям печати в новой таблице именованных стилей печати групповые имена СТИЛЬ 1, СТИЛЬ 2 и т.п. Групповые имена стилей печати можно изменить с помощью Редакторам таблиц стилей печати. Нажать кнопку "Изменить" на вкладке "Устройство печати" диалогового окна "Параметры листа". Переименование стилей печати необходимо выполнять перед тем, как применить их в чертежах.


ПРЕОБРУСТАРМАТЕРИАЛ Команда

П Команды
П Команды
ПРЕОБРУСТАРМАТЕРИАЛ Команда
Понятия Процедуры Команды

Преобразует формат отображения материалов, созданный в предыдущих версиях, в формат программы AutoCAD 2007

Ввод команды: преобрустарматериал

Формат отображения материалов на чертеже преобразуется в формат программы AutoCAD 2007.

Предупреждение В некоторых случаях преобразование может быть некорректным. Например, может потребоваться регулировка отображения материалов.


ПРЕОБРУСТАРСВЕТ Команда

П Команды
П Команды
ПРЕОБРУСТАРСВЕТ Команда
Понятия Процедуры Команды

Преобразует формат отображения источников света, созданных в предыдущих версиях, в формат программы AutoCAD 2007

Ввод команды: преобрустарсвет

Формат отображения источников света на чертеже преобразуется в формат программы AutoCAD 2007.

Предупреждение В некоторых случаях преобразование может быть некорректным. Например, может потребоваться регулировка интенсивности.


ПРИВЯЗКА Команда

П Команды
П Команды
ПРИВЯЗКА Команда
Понятия Процедуры Команды

Установка текущих режимов объектной привязки

Панель "Объектная привязка":

Меню "Сервис": "Режимы рисования"

Контекстное меню: Удерживая в нажатом состоянии клавишу SHIFT, нажмите правую кнопку мыши в области рисования и выберите "Режимы привязки".

Строка состояния: Привязка

Ввод команды: привязка (или 'привязка для прозрачного вызова)

Отобразится вкладка "Объектная привязка" диалогового окна "Режимы рисования".

Если в командной строке ввести -привязка, будут выведены список опций команды ПРИВЯЗКА.

Текущие режимы привязки: текущий

Список режимов объектной привязки: Задать имена режимов объектной привязки через запятую, либо ввести нет или откл

Режимы объектной привязки

Здесь можно указать один или более режимов привязки, вводя только первые три символа из имени каждого режима. Если вводится несколько названий, их следует разделять запятыми.

КОНточка | ЦЕНтр | КАСательная
СЕРедина | УЗЕл | БЛИжайшая
ПЕРесечение | КВАдрант | ПАРаллельно
ПРОдолжение | ТВСтавки |
КАЖущееся пересечение | НОРмаль |

Описания каждого из режимов объектной привязки см. на вкладке "Объектная привязка" диалогового окна "Режимы рисования".

Команда -ПРИВЯЗКА также имеет следующие дополнительные опции:

БЫСтрая

Привязывает к первой найденной возможной точке привязки. Этот режим может использоваться совместно с другими режимами объектной привязки.

НИЧего

Отключает объектную привязку.


ПРОВЕРИТЬ Команда

П Команды
П Команды
ПРОВЕРИТЬ Команда
Понятия Процедуры Команды

Проверяет целостность чертежа и исправляет некоторые ошибки

Меню "Файл": "Утилиты" » подменю " Проверить"

Ввод команды: проверить

Исправить все обнаруженные ошибки? [Да/Нет] <Н>: Ввести д или н или нажать клавишу ENTER

Команда ПРОВЕРИТЬ помещает все объекты, для которых выводятся сообщения об ошибках, в текущий набор; это облегчает доступ к ним. Однако команды редактирования работают только с объектами, принадлежащими текущему пространству (листа или модели).

Если системная переменная AUDITCTL задана равной 1, команда ПРОВЕРИТЬ создает ASCII-файл с записями о найденных ошибках и предпринятых действиях. Файл отчета располагается в каталоге текущего чертежа, его расширение .adt.

Если чертеж содержит ошибки, которые невозможно определить с помощью команды ПРОВЕРИТЬ, то, чтобы найти чертеж и исправить его ошибки, следует применить команду ВОССТАН.


ПРОДОЛЖИТЬ Команда

П Команды
П Команды
ПРОДОЛЖИТЬ Команда
Понятия Процедуры Команды

Возобновление выполнения прерванного пакетного файла

Ввод команды: продолжить (или 'продолжить для прозрачного вызова)

Выполнение пакета можно прервать нажатием клавиши ESC или BACKSPACE. К приостановке выполнения пакета ведет также любая ошибка, встреченная в файле пакета. Если во время работы программы выполнение пакета приостановлено, можно использовать команду ПРОДОЛЖИТЬ для продолжения выполнения пакета.


ПРОЖЕКТОР Команда

П Команды
П Команды
ПРОЖЕКТОР Команда
Понятия Процедуры Команды

Создание прожектора

Панель "Источники света"

Меню "Вид": "Тонирование" » "Свет" » "Новый прожектор"

Ввод команды: прожектор

Пульт управления: Панель "Свет" (нажмите, чтобы развернуть), Создать прожектор

Задайте положение источника света <0,0,0>: Задать координаты вручную или использовать мышь

Задайте положение цели <1,1,1>: Задать координаты вручную или использовать мышь

Задайте опцию для изменения [Имя/Интенсивность/Состояние/Пятно/Спад освещенности /Тень/Затухание/Цвет/выХод] <выХод>:

Имя

Имя источника света. При задании имени допускается использование букв верхнего и нижнего регистра, цифр, пробелов, знаков переноса (-) и символов подчеркивания (_). Имя может содержать до 256 символов.

Введите имя источника света:

Интенсивность

Установка интенсивности (или яркости) источника света. Область значений: от 0 до максимального значения, которое поддерживается в пользовательской системе.

Введите интенсивность (0,00 - макс. плавающее):

Пятно

Угол, определяющий конус наиболее яркого света (максимальной освещенности). Допустимый диапазон - от 0 до 60 градусов или эквивалентные значения на основе AUNITS и AUNITS.

Введите значение яркого пятна (0,00-160,00):

Спад освещенности

Угол, определяющий полный конус света, называемый также угловым полем. Параметр может принимать значения от 0 до 160 градусов. Значение по умолчанию равно 45 градусам или эквивалентному значению на основе AUNITS и AUNITS. Угол спада освещенности должен быть больше или равен углу яркого пятна.

Введите значение полного светового конуса (0,00-160,00):

Состояние

Включение/отключение источника света. Если в чертеже не включено освещение, эта опция не работает.

Введите состояние (Вкл/ Откл):

Тень

Включение отбрасывания теней от источника света.

Введите параметры теней [Откл/Резкие/Мягкие]:

Откл

Включение и отключение отображения и расчета теней для источника света. Отключение теней повышает производительность.

Резкие

Отображение теней с жесткими кромками. Эта опция используется для повышения производительности.

Мягкие

Отображение реалистичных теней с мягкими кромками.

Затухание

Задайте опцию, чтобы изменить [Тип затухания/Использовать пределы/Начальный предел затухания/Конечный предел затухания/выХод] <выХод>:

Тип затухания

Зависимость затухания света от расстояния. Чем дальше от источника света располагается объект, тем темнее он выглядит. Затухание также называется ослаблением.

Тип затухания [Нет/Линейная инверсия/Квадратичная инверсия] <Линейная инверсия>:

  • Нет. Затухание отсутствует. И далекие, и близкие к источнику света объекты освещаются одинаково.
  • Линейная инверсия. Установка затухания обратно пропорционально расстоянию от источника света до объекта. Например, на расстоянии 2 единицы от источника освещенность равна 1/2 освещенности на источнике, на расстоянии 4 единицы — 1/4. По умолчанию интенсивность при линейной инверсии равна половине максимальной интенсивности.
  • Квадратичная инверсия. Установка затухания обратно пропорционально квадрату расстояния от источника света до объекта. Например, на расстоянии 2 единицы от источника освещенность равна 1/4 от освещенности на источнике, на расстоянии 4 единицы — 1/16.

Начальный предел затухания

Задание точки начала затухания как смещения от центра источника света. Значение по умолчанию равно 0.

Задайте смещение начального предела или [Откл]:

Примечание Начальные и конечные ограничения затухания не поддерживаются драйвером OpenGLwopengl8.hdi. Для идентификации драйвера надо ввести командуграфнастр, затем нажать на "Просмотр протокола оптимизации". Информацию об установленном драйвере см. в строке "Драйвер" протокола мастера оптимизации параметров.

Конечный предел затухания

Задание точки конца затухания как смещения от центра источника света. Свет не распространяется за пределы указанной точки. Установка конечного предела затухания позволяет повысить производительность за счет определения границ освещенности; таким образом, обработка вычислений занимает минимальное время.

Задайте смещение конечного предела или [Откл]:

Цвет

Управление цветом источника света.

Задайте цвет (R,G,B) или опцию [Номер цвета/Hsl/Альбом цветов]:

Цвет (R, G, B)

Задание истинного цвета. Введите цвет в формате R,G,B (красный, зеленый, синий).

Номер цвета

Задание цвета по индексу цветов AutoCAD.

Имя цвета или его номер (1-255):

HSL

Задание цвета в формате ОНЯ (оттенок, насыщение, яркость).

Введите цвет в системе HSL (О, Н, Я):

Альбом цветов

Задание цвета из альбома цветов.

Введите имя альбома цветов:

Выход

Завершение команды.


ПРОЗРАЧНОСТЬ Команда

П Команды
П Команды
ПРОЗРАЧНОСТЬ Команда
Понятия Процедуры Команды

Управление прозрачностью фоновых пикселов растровых изображений

Панель "Ссылки":

Меню "Редактирование": "Объект" » "Изображение" » "Прозрачность"

Контекстное меню: Выберите изображение, нажмите правую кнопку мыши в области рисования и выберите "Изображение" » "Прозрачность".

Ввод команды: прозрачность

Выберите изображения:

Состояние прозрачности [Вкл/Откл] <текущее>: Задать опцию или нажать ENTER

Вкл

Включение прозрачности. Объекты, закрытые изображением, становятся видимыми.

Откл

Отключение прозрачности. Объекты, закрытые изображением, становятся невидимыми.

Примечание Системная переменная PALETTEOPAQUE управляет свойством прозрачности закрепляемых окон.


ПРОСМОТР Команда

П Команды
П Команды
ПРОСМОТР Команда
Понятия Процедуры Команды

Устар.

Ввод команды: просмотр

Данная команда устарела.


ПРЯМАЯ Команда

П Команды
П Команды
ПРЯМАЯ Команда
Понятия Процедуры Команды

Построение бесконечных прямых

Панель "Рисование":

Меню "Рисование": "Прямая"

Ввод команды: прямая

Укажите точку или [Гор/Вер/Угол/Биссектр/Смещение]: Указать точку или задать опцию

Точка

Задание расположения бесконечной прямой по двум точкам, через которые проходит эта прямая.

Через точку: Указать точку (2), через которую должна проходить прямая, или нажать ENTER для завершения команды

Прямая строится через указанную точку.

Гор

Построение горизонтальной бесконечной прямой, проходящей через указанную точку.

Через точку: Указать точку (1), через которую должна проходить прямая, или нажать ENTER для завершения команды

Прямая строится параллельно оси X.

Вер

Построение вертикальной бесконечной прямой, проходящей через указанную точку.

Через точку: Указать точку (1), через которую должна проходить прямая, или нажать ENTER для завершения команды

Прямая строится параллельно оси Y.

Угол

Построение бесконечной линии, проходящей под заданным углом.

Угол прямой (0) или [Базовая линия]: Задать угол или ввести б

Угол прямой

Задание угла, под которым нужно построить бесконечную прямую.

Через точку: Указать точку, через которую должна проходить бесконечная прямая

Прямая строится через указанную точку под заданным углом.

Базовая линия

Задание угла относительно выбранного линейного объекта. Значения углов отсчитываются против часовой стрелки от выбранного линейного объекта.

Выберите линейный объект: Выбрать отрезок, полилинию, луч или бесконечную прямую

Угол прямой <0>:

Через точку: Указать точку (2), через которую должна проходить прямая, или нажать ENTER для завершения команды

Прямая строится через указанную точку под заданным углом.

Биссектр

Построение бесконечной прямой, проходящей через указанную вершину угла и делящей его пополам.

Укажите вершину угла: Указать точку (1)

Точка на первом луче угла: Указать точку (2)

Точка на втором луче угла: Указать точку (3) или нажать ENTER для завершения команды

Прямая располагается в плоскости, определяемой тремя точками.

Смещение

Построение бесконечной прямой параллельно выбранному линейному объекту.

Величина смещения или [Точка] <текущая>: Задать величину смещения, ввести т или нажать ENTER

Величина смещения

Задание расстояния, на котором должна располагаться бесконечная прямая относительно выбранного объекта.

Выберите линейный объект: Выбрать отрезок, полилинию, луч или бесконечную прямую либо нажать ENTER для завершения команды

Укажите сторону смещения? Указать точку и нажать ENTER для завершения команды

Точка

Построение бесконечной прямой, проходящей через заданную точку параллельно выбранному линейному объекту.

Выберите линейный объект: Выбрать отрезок, полилинию, луч или бесконечную прямую либо нажать ENTER для завершения команды

Через точку: Указать точку (2), через которую должна проходить прямая, или нажать ENTER для завершения команды


ПРЯМОУГ Команда

П Команды
П Команды
ПРЯМОУГ Команда
Понятия Процедуры Команды

Построение полилинии в виде прямоугольника

Панель Рисование:

Меню "Рисование": "Прямоугольник"

Ввод команды: прямоуг или прямоугольник

Текущие настройки: Поворот = 0

Первый угол или [Фаска/Уровень/Сопряжение/Высота/Ширина]: Указать точку или задать опцию

Первый угол

Угловая точка прямоугольника.

Второй угол или [Площадь/Размеры/поВорот]: Указать точку или задать опцию

Другой угол

Построение прямоугольника по двум противоположным углам.

Площадь

Создает прямоугольник с использованием значений площади, а также значений длины или ширины. Если параметр "Фаска" или "Сопряжение" включен, эффекты фаски или сопряжения на углах прямоугольника включаются в площадь.

Введите площадь прямоугольника в текущих единицах <100>: Ввести положительное значение

Вычислять размеры прямоугольника на основе параметра [Длина/Ширина] <Длина>: Ввести д или ш

Введите длину прямоугольника <10>: Ввести ненулевое значение

или

Введите ширину прямоугольника <10>: Ввести ненулевое значение

Второй угол или [Площадь/Размеры/поВорот]: Перемещайте курсор для отображения одной из четырех возможных точек прямоугольника, затем щелкните нужную точку

Размеры

Построение прямоугольника по заданным значениям длины и ширины.

Длина прямоугольника <0,0000> Ввести ненулевое значение

Ширина прямоугольника <0,0000> Ввести ненулевое значение

Второй угол или [Площадь/Размеры/поВорот]: Перемещайте курсор для отображения одной из четырех возможных точек прямоугольника, затем щелкните нужную точку

поВорот

Создает прямоугольник под заданным углом поворота.

Угол поворота или [Точки] <0> Задать угол вводом значения, указанием точки или вводом т и указанием двух точек

Второй угол или [Площадь/Размеры/поВорот]: Перемещайте курсор для отображения одной из четырех возможных точек прямоугольника, затем щелкните нужную точку

Фаска

Задает размеры фаски для прямоугольника.

Длина первой фаски прямоугольников <текущая>: Задать расстояние или нажать ENTER

Длина второй фаски прямоугольников <текущая>: Задать расстояние или нажать ENTER

Заданные значения становятся текущими размерами фаски, которые используются при последующих вызовах команды ПРЯМОУГ.

Уровень

Задает уровень для прямоугольника.

Уровень прямоугольников <текущий>: Задать расстояние или нажать ENTER

Введенное значение становится текущим уровнем, которое используется при последующих вызовах команды ПРЯМОУГ.

Сопряжение

Задает радиус сопряжения для прямоугольника.

Радиус сопряжения прямоугольников <текущий>: Задать расстояние или нажать ENTER

Введенное значение становится текущим радиусом сопряжения, которое используется при последующих вызовах команды ПРЯМОУГ.

Высота

Задает трехмерную высоту для прямоугольника.

Высота прямоугольников <текущая>: Задать расстояние или нажать ENTER

Введенное значение становится текущей высотой, которая используется при последующих вызовах команды ПРЯМОУГ.

Ширина

Задает ширину полилинии для прямоугольника.

Ширина линии прямоугольников <текущая>: Задать расстояние или нажать ENTER

Введенное значение становится текущей шириной полилинии, которая используется при последующих вызовах команды ПРЯМОУГ.


ПСЕВДОРАЗРЕЗ Команда

П Команды
П Команды
ПСЕВДОРАЗРЕЗ Команда
Понятия Процедуры Команды

Включение режима псевдоразреза для выбранного объекта-сечения.

Ввод команды: псевдоразрез

Выберите объект-сечение: Выберите объект-сечение

Включение режима псевдоразреза для выбранного объекта-сечения. При включении этого режима отображаются внутренние части 3D объектов, рассеченные объектом-сечением.


ПСК Команда

П Команды
П Команды
ПСК Команда
Понятия Процедуры Команды

Управление пользовательскими системами координат

Панель "ПСК":

Меню "Сервис": "Новая ПСК"

Ввод команды: пск

Задать начало ПСК или [Грань/Именованная/Объект/Предыдущая/Вид/Мир/X/Y/Z/Zось] <МСК>:

Задать начало ПСК

Задание новой ПСК по одной, двум или трем точкам. Если задана одна точка, начало текущей ПСК сдвигается с сохранением ориентации осей X, Y и Z.

Точка на оси X или <Принять>: Указать вторую точку или нажать ENTER для задания ПСК по одной точке

Если указана вторая точка, выполняется поворот ПСК вокруг ранее заданного начала координат; при этом положительная полуось X ПСК проходит через эту точку.

Точка на плоскости XY или <Принять>: Указать вторую точку или нажать ENTER для задания ПСК по двум точкам

Если указана третья точка, выполняется поворот ПСК вокруг оси X; при этом данная точка располагается на положительной полуоси Y плоскости XY ПСК.

Примечание Если задать только координаты точки X и Y, но не Z, используется текущее значение координаты Z.

Грань

Совмещение ПСК с выбранной гранью 3D тела. Для выбора грани необходимо нажать левую кнопку мыши внутри ее контура или на одной из кромок. Выбранная грань подсвечивается, а ось X ПСК совмещается с ближайшей кромкой первой обнаруженной грани.

Выберите грань тела:

Задайте опцию [Следующая/обратитьX/обратитьY] <принять>:

Следующая

Совмещение ПСК со смежной или с задней гранью выбранной кромки.

обратитьX

Поворот ПСК на 180 градусов вокруг оси X.

обратитьY

Поворот ПСК на 180 градусов вокруг оси Y.

Принять

Принятие текущего положения ПСК (для этого достаточно нажать ENTER). Запрос повторяется до тех пор, пока не будет принято какое-либо положение.

Именованные

Сохранение и восстановление наиболее часто используемых ориентаций ПСК по имени.

Задайте опцию [Восстановить/Сохранить/Удалить]: Задать опцию

Восстановить

Восстановление сохраненной ранее ПСК и использование ее в качестве текущей.

Имя ПСК для восстановления или [?]: Ввести имя или ?

Имя

Имя восстанавливаемой ПСК.

?—Список ПСК

Вывод списка именованных ПСК.

Имена ПСК для вывода <*>: Ввести список имен или нажать ENTER для вывода списка всех именованных ПСК

Сохранить

Сохранение текущей ПСК под заданным именем. Имя может содержать до 255 символов. В него могут входить буквы, цифры, пробелы и специальные символы, не используемые ОС Microsoft® Windows® и данной программой в других целях.

Имя для сохранения текущей ПСК или [?]: Ввести имя или ?

Имя

Сохранение текущей ПСК под заданным именем.

?—Список ПСК

Вывод списка именованных ПСК.

Имена ПСК для вывода <*>: Ввести список имен или нажать ENTER для вывода списка всех именованных ПСК

Удалить

Удаление ПСК из списка именованных ПСК.

Имена ПСК для удаления <нет>: Ввести список имен или нажать ENTER

При удалении текущей именованной ПСК, ей присваивается имя БЕЗ ИМЕНИ.

?—Список ПСК

Вывод списка пользовательских систем координат с указанием точек начала координат и направлений осей X, Y и Z относительно текущей ПСК. Если текущая ПСК не является именованной, она отображается в списке под именем МИРОВАЯ или БЕЗ ИМЕНИ (в зависимости от того, совпадает ли она с МСК или нет).

Имена ПСК для вывода <*>: Ввести список имен

Объект

Задание новой ПСК на основе выбранного 3D объекта. Направление выдавливания выбранного объекта определяет положительное направление оси Z новой ПСК.

Выберите объект для задания ПСК: Выбрать объект

С данной опцией нельзя использовать следующие объекты: 3D полилинии, 3D сети и бесконечные прямые.

Для большинства объектов начало новой ПСК располагается в ближайшей к точке выбора объекта вершине, а ось X совмещается с кромкой объекта или касается ее. В случае плоских объектов плоскость XY ПСК совмещается с плоскостью объекта. В случае составных объектов происходит изменение положения начала координат, а текущая ориентация осей сохраняется.

Новая ПСК задается по правилам, приведенным в следующей таблице.

Задание ПСК посредством выбора объекта

Объект

Метод задания ПСК

Дуга

Начало новой ПСК совмещается с центром дуги. Ось X проходит через тот конец дуги, который расположен ближе к точке выбора.

Круг

Начало новой ПСК совмещается с центром круга. Ось X проходит через точку выбора.

Размер

Начало новой ПСК совмещается с серединой размерного текста. Новая ось X строится параллельно оси X ПСК, использованной при нанесении размера.

Отрезок

Начало новой ПСК совмещается с тем концом отрезка, который расположен ближе к точке выбора. Новая ось X располагается таким образом, что отрезок лежит в плоскости XZ новой ПСК. В новой ПСК координата Y второго конца отрезка равна нулю.

Точка

Выбранная точка становится началом новой ПСК.

2D полилиния

Начало новой ПСК совмещается с начальной точкой полилинии. Ось X проходит через начальную точку и ближайшую к ней вершину полилинии.

Тело

Начало новой ПСК совмещается с первой точкой тела. Новая ось X проходит вдоль линии, образованной первыми двумя точками.

Полоса

Исходная точка полосы совмещается с началом ПСК; ось X проходит вдоль ее осевой линии.

3D грань

Начало новой ПСК определяется первой точкой, ось X - первой и второй точками, а положительная полуось Y - первой и четвертой точками. Направление оси Z определяется по правилу правой руки.

Форма, текст, вхождение блока, описание атрибута

Начало новой ПСК совмещается с точкой вставки объекта, а направление новой оси X определяется углом поворота объекта вокруг направления выдавливания. Объект, с помощью которого задается новая ПСК, имеет в этой ПСК нулевой угол поворота.

Предыдущая

Восстановление предыдущей ПСК. Программа запоминает до 10 последних систем координат, созданных в пространстве листа и пространстве модели. Повторное использование этой опции позволяет вернуться к той или иной системе координат. То, какая система координат будет восстановлена, зависит от текущего пространства.

При переключении между отдельными видовыми экранами, в которых сохранены режимы разных ПСК, информация об этих ПСК не сохраняется в списке "Предыдущая СК". Тем не менее, при изменении параметров ПСК в видовом экране информация о последнем изменении сохраняется в списке "Предыдущая СК". Например, при переходе от Мировой системы координат к ПСК1 название "Мировая" остается в верхней строке списка. Далее, после перехода на видовой экран, для которого установлена ПСК "Передняя", и замены этой системы координат на ПСК "Правая", в верхней строке списка остается ПСК "Передняя". Если теперь дважды вызвать команду ПСК с опцией "Предыдущая", на текущем видовом экране установится сначала "Передняя", а затем "Мировая" система координат. См. описание системной переменной UCSVP.

Вид

Задание новой системы координат таким образом, что плоскость XY располагается перпендикулярно направлению взгляда, т.е. параллельно плоскости видового экрана. Положение начала координат не изменяется.

Мир

Совмещение текущей ПСК с мировой системой координат (МСК). МСК является базовой системой координат, относительно которой задаются все ПСК и не может быть переопределена.

X, Y, Z

Поворот текущей ПСК вокруг указанной оси.

Угол поворота вокруг оси n <0>: Задать угол

В запросе параметр n соответствует оси X, Y или Z. Для поворота ПСК следует ввести положительное или отрицательное значение угла.

Посредством указания точки начала координат и одного или нескольких углов поворота вокруг осей X, Y и Z можно задать любую ПСК.

Ось Z

Задание ПСК по положительной полуоси Z.

Новое начало координат или [Объект] <0,0,0>: Указать точку или ввести о

Точка на положительной полуоси Z <текущая>: Указать точку

Необходимо задать новое начало координат и точку, лежащую на новой положительной полуоси Z. Опция "Zось" используется для наклона плоскости XY.

Объект

Выравнивание оси Z в направлении конечной точки, ближайшей к точке выбора объекта. Положительная полуось Z направлена от объекта.

Выберите объект: Выбрать разомкнутый объект

Применить

Применение параметров текущей ПСК к указанному видовому экрану или ко всем активным видовым экранам, для которых установлена эта ПСК. Системная переменная UCSVP определяет, сохраняется ли ПСК с видовым экраном.

Укажите видовой экран для применения к нему текущей ПСК или [Все] <текущий>: Нажать левую кнопку мыши внутри области видового экрана, ввести в или нажать ENTER

Видовой экран

Применение текущей ПСК к указанному видовому экрану и завершение команды ПСК.

Все

Применение текущей ПСК ко всем активным видовым экранам.


ПСТИЛЬ Команда

П Команды
П Команды
ПСТИЛЬ Команда
Понятия Процедуры Команды

Задание текущего стиля печати для новых объектов или назначение стиля печати выбранным объектам

Ввод команды: пстиль

Командой ПСТИЛЬ можно пользоваться только в чертежах, специально настроенных для работы с именованными стилями печати.

  • Если чертеж создан в цветозависимом режиме, для использования именованных стилей печати следует преобразовать его командой ПРЕОБРСПЕЧ.
  • При настройке нового чертежа для использования именованных стилей печати, установить для переменной PSTYLEPOLICY значение 0 перед созданием нового чертежа.

Если не выбран ни один набор объектов, отобразится диалоговое окно "Текущий стиль печати". Если набор объектов выбран, отобразится диалоговое окно "Выбор стиля печати"

Если по запросу "Команда:" ввести -пстиль, то команда ПСТИЛЬ отображает запрос в командной строке.

Темы:

  • Диалоговое окно "Текущий стиль печати"
  • Диалоговое окно "Выбор стиля печати"
  • Командная строка ПСТИЛЬ


Диалоговое окно "Текущий стиль печати"

П Команды
П Команды
Диалоговое окно "Текущий стиль печати"
Понятия Процедуры Команды

Ввод команды: пстиль

Стиль печати по умолчанию для новых объектов.

Текущий стиль печати

Имя текущего стиля печати.

Список стилей печати

Список стилей печати, доступных для назначения объектам. Среди них стандартный стиль ОБЫЧНЫЙ. Стиль печати представляет собой совокупность переопределений для цвета, размывания, оттенков серого, присвоений перьев, интенсивности, типа и веса линий, торцов и соединений, способа заливки.

Активная таблица стилей печати

Таблица стилей печати, назначенная текущему листу. В таблице хранятся описания стилей печати.

Редактор

Отображает Редактор таблиц стилей печати, в котором можно изменять стили печати, входящие в таблицу стилей печати.

Назначение

Имя вкладки (модель или лист), которой назначена таблица стилей печати.


Диалоговое окно "Выбор стиля печати"

П Команды
П Команды
Диалоговое окно "Выбор стиля печати"
Понятия Процедуры Команды

Ввод команды: пстиль

Назначение стилей печати объектам.

Стили печати

Список доступных стилей печати, включая стандартный стиль - ОБЫЧНЫЙ. Стилем печати называется набор свойств объектов, назначаемых им при печати.

Исходный

Стиль печати, изначально назначенный объекту.

Новый

Новый стиль, назначаемый объекту.

Активная таблица стилей печати

Таблица стилей печати, назначенная текущему чертежу. Таблица содержит определения стилей печати.

Редактор

Открывается диалоговое окно Редактор таблиц стилей печати.

Назначение

Имя вкладки (модель или лист), которой назначена таблица стилей печати.


Командная строка ПСТИЛЬ

П Команды
П Команды
Командная строка ПСТИЛЬ
Понятия Процедуры Команды

Если по запросу "Команда:" ввести -пстиль, то команда ПСТИЛЬ отображает запрос в командной строке.

Ввод команды: -пстиль

Текущий стиль печати: "текущий "

Задать опцию [?/Текущий]:?

?—Список стилей печати

Список стилей печати в назначенной таблице стилей печати.

Текущий

Стиль печати, назначаемый новым объектам.


ПУБЛ Команда

П Команды
П Команды
ПУБЛ Команда
Понятия Процедуры Команды

Публикует чертежи в DWF-файлах или на плоттерах

Панель Стандартная

Меню "Файл": Публикация

Ввод команды: публ

Откроется диалоговое окно "Публикация". Для начала процесса публикации листов текущего чертежа с выводом в DWF-файл или на плоттер следует нажать кнопку «Опубликовать».

Для получения информации о публикуемых листах следует щелкнуть на значке сведений справа в строке состояния. При нажатии на данный значок открывается диалоговое окно "Подробности о печати/публикации", содержащее информацию о выполненных заданиях на печать и публикацию. Информация также сохраняется в специальном файле журнала печати и публикаций. Контекстное меню значка сведений позволяет открыть последний полученный файл Design Web Format™(DWF;™).

Если в ответ на подсказку "Команда:" ввести +публ, выводится стандартное диалоговое окно выбора файлов, в котором можно указать существующий файл описания набора чертежей (DSD). После этого в группе "Публикуемые листы" окна "Публикация" появляется список всех листов чертежей из DSD-файла.

Если при значении переменной FILEDIA, равном 0, по запросу "Команда:" вводится -публ, команда ПУБЛ отображает запросы в командной строке.

Темы:

  • Диалоговое окно "Публикация"
  • Диалоговое окно «Параметры публикации»
  • Диалоговое окно "Публикация шаблона блока" (Публикация)
  • Диалоговое окно "Параметры шаблона блока" (Публикация)
  • Диалоговое окно "Изменения в файле параметров принтера" (Публикация)
  • Диалоговое окно "Пароль для DWF-файла".
  • Диалоговое окно "Подтверждение пароля"
  • Диалоговое окно "Публикация Ход выполнения"
  • Командная строка ПУБЛ


Диалоговое окно "Публикация"

П Команды
П Команды
Диалоговое окно "Публикация"
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Файл": Публикация

Ввод команды: публ

Задание листов чертежа, которые можно компоновать, менять порядок следования, копировать, переименовывать и сохранять для публикации в многолистовом наборе чертежей. При публикации существует возможность вывести набор чертежей в DWF-файл, на плоттер или сохранить в файле печати. Этот набор можно сохранить как DSD-файл (формат описаний наборов чертежей). Сохраненные наборы чертежей можно затем добавлять к текущему списку либо заменять его.

Публикуемые листы

Список листов чертежа, которые предназначены для публикации. Для внесения изменений в параметры страницы следует нажать на них левую кнопку мыши. Используйте контекстное меню для добавления листов или внесите другие изменения в список.

Примечание Листы чертежей, включаемые в список публикуемых листов, определяются системной переменной PUBLISHALLSHEETS.

Имя листа

Комбинация имен чертежа и имен листов, разделенных дефисом (-). Вкладка "Модель" отображается только в том случае, если в контекстном меню активна опция "Включать вкладку модели". Для копирования листов предназначен пункт контекстного меню "Копировать выделенные листы". Имя можно изменить, выбрав в контекстном меню «Переименовать лист». DWF-файл не может содержать листы с одинаковыми именами. С помощью контекстного меню можно также удалить все листы из списка.

Параметры листа / 3D DWF

Именованный набор параметров листа. Чтобы изменить параметры листа, необходимо выбрать другой набор параметров в списке наборов параметров листа. Для листов на основе вкладки "Модель" можно применять только наборы параметров листа, созданные для этой вкладки, а для листов на основе вкладок "Лист" можно применять только наборы параметров листа, созданные для вкладок такого типа. Для импорта параметров листа из другого DWG файла необходимо выбрать из списка пункт "Импорт". Открывается диалоговое окно "Импорт наборов параметров листов для публикации" (стандартное окно выбора файлов).

Имеется опция задания формата 3D DWF в качестве параметров листа для листов пространства модели. Опция 3D DWF не доступна для записей листов в списке листов.

Статус

Отображает статус листа, загружаемого в список листов.

Просмотр

Вызов команды ПРЕДВАР для предварительного просмотра чертежа на экране в таком виде, в каком он появится на бумаге. Для выхода из режима предварительного просмотра и возврата в диалоговое окно "Публикация" нажать ESC или ENTER, либо нажать правую кнопку мыши и выбрать из контекстного меню пункт "Выход".

Примечание Кнопка "Образец" не действует, если в параметрах для листа задан формат 3D DWF.

Добавить листы

Отображает диалоговое окно "Выбор чертежей" (стандартное окно выбора файлов), в котором можно выбрать файл для добавления его листов в список. Из выбранных файлов чертежей извлекаются имена вкладок, и к списку листов для публикации добавляется по одному листу для каждой вкладки-листа и один лист для модели.

Имена листов для публикации составляются из имени исходного чертежа и имени вкладки-листа или слова "Модель", разделенных дефисом (-).

Исключить листы

Исключение выбранного листа из списка.

Сдвинуть лист вверх

Перемещение выбранного листа в списке на одну позицию вверх.

Сдвинуть лист вниз

Перемещение выбранного листа в списке на одну позицию вниз.

Загрузить список листов

Отображает диалоговое окно "Загрузка списка листов" (стандартное окно выбора файлов), в котором можно выбрать для загрузки DSD-файл или BP3-файл (список пакетной печати). Если в диалоговом окне "Публикация" уже присутствует список листов, появляется диалоговое окно "Замена или добавление". С помощью данного диалогового окна можно либо заменить имеющийся список листов, либо добавить новые листы в конец списка.

Сохранить список листов

Отображает диалоговое окно "Сохранение списка листов" (стандартное окно выбора файлов), в котором можно сохранить текущий список как DSD-файл. DSD-файлы используются для описания файлов чертежей, входящих в набор для публикации, а также выбранных вкладок этих чертежей.

Параметры штемпеля

Отображает диалоговое окно "Штемпель чертежа", в котором можно задать информацию, проставляемую на штемпеле, например, имя чертежа, дату и время, масштаб печати и т.д.

Добавить штемпель

Нанесение штемпеля в определенном углу каждого чертежа и запись соответствующей информации в файл журнала Информация, включаемая в штемпель, задается в диалоговом окне "Штемпель чертежа".

Для листов, настроенных на публикацию в формате 3D DWF, не добавляются штампы в файлы 3D DWF независимо от установки данного флажка.

Количество экземпляров

Определяет количество выводимых на печать экземпляров. При выборе опции "В DWF файл", параметр "Количество экземпляров" становится равным 1 и не может быть изменен. Если в параметрах листа задана его печать в файл, создается только один файл чертежа независимо от настройки данной опции.

Посылка листов на плоттер в обратном порядке

При выборе отправляет публикации в обратном порядке по умолчанию. Этот параметр доступен, только если выбран параметр "Плоттер, заданный в параметрах страницы".

Вывод при публикации

Направление вывода публикуемых листов. Листы могут публиковаться в многолистовом DWF-файле (электронном наборе чертежей) или выводиться на плоттер, заданный в параметрах листа (на бумагу или в файлы печати).

Плоттер, заданный на странице "Параметры листа"

Задается публикация с использованием устройства печати, указанного в параметрах листов для каждого чертежа. Если данный переключатель включен, публикуются все записи, не относящиеся к формату 3D DWF. Записи, для которых задан формат 3D DWF, помечаются предупредительным сообщением в столбце "Статус" списка публикуемых листов.

В DWF-файл

Список листов публикуется в DWF файл.

Добавление вкладок

Определяет, включаются ли вкладки модели и листов чертежа в список публикуемых листов. Хотя бы один флажок в этой группе должен быть активен.

Модель

Если эта опция активна, то при добавлении листов чертежа в список включается вкладка модели.

Листы

Если эта опция активна, то при добавлении листов чертежа в список включаются все вкладки листов.

Параметры публикации

Открывает диалоговое окно "Параметры публикации", в котором можно указать параметры для публикации.

С подробностями

Отображает и скрывает области "Сведения о выделенном листе" и "Сведения о выделенном наборе параметров".

Сведения о выделенном листе

Отображает следующие сведения о выделенном листе: исходный чертеж, расположение чертежа и имя листа.

Сведения о выделенном наборе параметров

Отображает следующие сведения о выделенном наборе параметров: устройство печати, размер чертежа на печати, масштаб печати и подробности.

Опубликовать

Запуск процесса публикации. При этом либо генерируется однолистовой или многолистовой DWF-файл, либо набор листов выводится на плоттер или в файл; все зависит от состояния переключателя "Вывод при публикации" и параметров, заданных в диалоговом окне "Параметры публикации".

Для получения информации о публикуемых листах (а также об ошибках и предупреждениях) служит значок на лотке справа в строке состояния. При нажатии на данный значок открывается диалоговое окно "Подробности о печати/публикации", содержащее информацию о выполненных заданиях на печать и публикацию. Информация также сохраняется в специальном файле журнала. Контекстное меню значка сведений позволяет открыть последний полученный DWF-файл.


Диалоговое окно «Параметры публикации»

П Команды
П Команды
Диалоговое окно «Параметры публикации»
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Файл": Публикация

Ввод команды: публ

Задание параметров процесса публикации.

Пользователь / Текущая подшивка

Имя текущего пользователя или текущей подшивки. Если отображается имя текущего пользователя, то изменения, вносимые в диалоговое окно, сохраняются в пользовательском профиле. Если отображается имя подшивки, то изменения, произведенные в диалоговом окне, сохраняются в ее настройках.

Папка для вывода (для DWF и печати в файл)

Указывает расположение папки для вывода, где файлы веб-формата проектирования (DWF) и файлы чертежей сохраняются при публикации листов чертежей.

Расположения

Указывает, где сохраняются файлы DWF и файлы чертежа при публикации чертежей.

Общие параметры DWF

Указывает параметры для создания однолистового файла DWF.

Тип DWF-файлов

Указывает, что однолистовой файл DWF или многолистовой файл DWF генерируется для всех листов, перечисленных в диалоговом окне "Публикация".

Защита паролем

Возможность защиты DWF-файла с помощью пароля.

Сигнал неактивен

Указывает, что пароль не требуется.

Запрос пароля

Отображает диалоговое окно "Пароль для DWF-файла" при выбранной опции "Публикация".

Пароль

Защита публикуемого DWF-файла с помощью пароля. Получатель DWF-файла должен знать назначенный файлу пароль, чтобы открыть этот файл.

Заданный здесь пароль

Указывает, что пароль для файла DWF задается в диалоговом окне "Пароль". При выборе этого параметра диалоговое окно "Пароль" становится доступным и необходимо ввести пароль.

Примечание Забытый или утерянный пароль не может быть восстановлен. Список паролей и имен соответствующих DWF-файлов рекомендуется хранить в надежном месте.

Параметры многолистовых файлов DWF

Указывает параметры для создания многолистового файла DWF.

Запрос имени

Имя папки и файла запрашивается каждый раз при публикации в многолистовой DWF-файл.

Заданное здесь имя

Указывает имя и местоположение публикуемых многолистовых файлов DWF.

Параметры данных DWF

Отображает дополнительные данные, доступные для включения в файл DWF.

Информация о слоях

Указывает, включаются ли сведения в публикуемом файле DWF.

Примечание Информация о слоях для записей 3D DWF не публикуется.

Сведения о блоке

Указывает, включаются ли сведения о свойстве и атрибуте блока в публикуемые файлы DWF.

Примечание Необходимо установить для сведения о блоке значение "Включить", чтобы сведения о файле шаблона блока были доступны.

Файл шаблона блока

Позволяет создавать новый файл шаблона блока (BLK), редактировать существующий файл шаблона блока или использовать параметры созданного ранее файла шаблона блока.

При использовании параметра создания открывается диалоговое окно "Публикация шаблона блока", в котором можно создать новый файл шаблона блока.

При использовании параметра редактирования открывается диалоговое окно "Выбор шаблона блока" (стандартное диалоговое окно выбора файлов), в котором можно выбрать для изменения существующий шаблон блока.

Примечание Если в очередь на публикацию включены только файлы 3D DWF, для файлов сведений о блоке и шаблона блока устанавливается значение "н/д", и их изменение становится невозможным.

Параметры 3D DWF

Отображает данные, доступные для выборочного включения для публикации в формате 3D DWF.

Группировать по иерархии вн-ссылок

Упорядочивает в отдельной программе просмотра объекты по иерархии внешних ссылок. Если выбрать значение "Нет", внешние ссылки перечисляются в программе просмотра наряду с другими объектами. Значение по умолчанию равно "Нет".

Публиковать с материалами

Большинство материалов, назначаемых пользовательской модели, публикуется в файле 3D DWF. Если пользовательский материал является текстурированным, в публикацию включается только текстура рассеяния с указанием ее масштаба и данными об ориентации. Значение по умолчанию = "Да".

Примечание Если в очередь на публикацию включены только файлы 2D DWF, для всех файлов 3D DWF устанавливается значение "н/д", и их изменение становится невозможным.


Диалоговое окно "Публикация шаблона блока" (Публикация)

П Команды
П Команды
Диалоговое окно "Публикация шаблона блока" (Публикация)
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Файл": Публикация

Ввод команды: публ

Указывает, какие блоки и их свойства и атрибуты необходимо включить в публикуемый файл DWF.

Текущий шаблон

Отображает имя текущего шаблона блока.

Исходные чертежи блока

Отображает все исходные чертежи блока, которые были загружены в диалоговое окно "Публикация шаблона блока".

Добавить

Добавляет чертежи в список исходных чертежей блока.

Удалить

Удаляет выбранные чертежи из списка исходных чертежей блока.

Поиск блоков

Выполняет поиск исходных чертежей для уникальных описаний блоков и их свойств и атрибутов.

Данные блока для публикации

Отображает данные блока для публикации.

Уникальные блоки в исходных чертежах

Отображает уникальные блоки, расположенные в исходных чертежах блока.

Проверить блоки для публикации

Отображает все отсканированные блоки, расположенные в исходных чертежах блока.

Исключать блоки без атрибутов

Исключает блоки без определенных атрибутов.

Свойства выбранных блоков

Отображает свойства выбранных блоков, расположенных в исходных чертежах блока.

Проверить свойства для публикации

Отображает набор свойств текущего выбора блоков.

Исключать общие свойства блоков

Исключает все общие свойства блока из списка.

Опции

Открывает диалоговое окно "Параметры шаблона блока", где можно указать дополнительные параметры.

Сохранить

Сохраняет файл шаблона блока.


Диалоговое окно "Параметры шаблона блока" (Публикация)

П Команды
П Команды
Диалоговое окно "Параметры шаблона блока" (Публикация)
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Файл": Публикация

Ввод команды: публ

Указывает дополнительные параметры для включения блоков в блоках и во внешних ссылках в публикуемый файл DWF.

Включая вложенные блоки

Включает блоки в блоках в публикуемый файл DWF.

Включать блоки во внешних ссылках

Включает блоки во внешних ссылках в публикуемый файл DWF.


Диалоговое окно "Изменения в файле параметров принтера" (Публикация)

П Команды
П Команды
Диалоговое окно "Изменения в файле параметров принтера" (Публикация)
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Файл": Публикация

Ввод команды: публ

Уведомление о том, что в PC3-файл параметров плоттера внесены изменения. Можно отказаться от изменений вообще, сохранить их только для текущей операции или записать в PC3-файл для формата вывода в DWF.

Применить изменения только к текущей публикации

Изменения, внесенные пользователем в файл PC3, используются в текущей операции публикации, но не сохраняются в файле PC3.

Сохранить изменения в PC3-файле для DWF

Изменения в настройках параметров печати сохраняются в PC3-файле для формата вывода в DWF.


Диалоговое окно "Пароль для DWF-файла".

П Команды
П Команды
Диалоговое окно "Пароль для DWF-файла".
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Файл": Публикация

Ввод команды: публ

Задание пароля для применения к DWF-файлу. Пароли вводятся с учетом регистра. Пароль может состоять из произвольных букв, цифр и знаков препинания и символов в кодах, отличных от ASCII.

Предупреждение Забытый или утерянный пароль не может быть восстановлен. Список паролей и имен соответствующих DWF-файлов рекомендуется хранить в надежном месте.

После ввода пароля и нажатия "ОК" появляется диалоговое окно "Подтверждение пароля".


Диалоговое окно "Подтверждение пароля"

П Команды
П Команды
Диалоговое окно "Подтверждение пароля"
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Файл": Публикация

Ввод команды: публ

Здесь нужно повторно ввести пароль, заданный в диалоговом окне "Пароль для DWF файла". Если пароли не совпадают, необходимо снова нажать кнопку "Опубликовать" и повторить задание пароля для файла.


Диалоговое окно "Публикация Ход выполнения"

П Команды
П Команды
Диалоговое окно "Публикация Ход выполнения"
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Файл": Публикация

Ввод команды: публ

Отображает информацию о статусе и ходе процесса печати, если фоновый вывод отключен в диалоговом окне "Настройка" (вкладка "Печать/Публикация").

Прервать вывод листа

Отмена публикации листа, выводимого в данный момент.

Отменить все

Отмена публикации всех чертежей.


Командная строка ПУБЛ

П Команды
П Команды
Командная строка ПУБЛ
Понятия Процедуры Команды

Ввод команды: -публ

Версия командной строки команды ПУБЛ предоставляет программируемый интерфейс для публикации листов чертежей. а также обеспечивает упрощенный способ регенерации DWF-файлов и вывода при печати из существующих DSD-файлов.

При значении системной переменной FILEDIA, равном 0 (или при запуске пакетного файла или другой программы на макроязыке) ввести по запросу "Команда" команду -публ или +публ. В командной строке появится следующий запрос:

Введите имя списка листов <путь имя файла.dsd>: Нажать ENTER для текущего чертежа или ввести имя списка листов

Примечание В угловых скобках <имя DSD-файла> содержится имя DSD-файла, использовавшегося при предыдущем вызове команды. Если имя DSD-файла ранее не использовалось, угловые скобки не содержат текста. Если вместо имени файла ввести тильду (~), выводится стандартное диалоговое окно выбора файлов независимо от значения системной переменной FILEDIA.

Имя файла подтверждается, и загружается список листов.

При использовании в пакетных файлах (SCR) команд -ПЕЧАТЬ, ПЕЧАТЬ, -ПУБЛ и ПУБЛ значение системной переменной BACKGROUNDPLOT игнорируется, а команды -ПЕЧАТЬ, ПЕЧАТЬ, -ПУБЛ и ПУБЛ обрабатываются в основном (не фоновом) режиме.

После начала процесса публикации в командной строке последовательно выводятся имена листов чертежа с соответствующими сообщениями. Для не найденных или не инициализированных листов выводятся сообщения об ошибках.

После того как публикация завершена, подробную информацию о ней можно получить в диалоговом окне "Подробности о печати/публикации".

В процессе публикации листов формируется специальный файл журнала. Файл журнала содержит имя листа чертежа, имя вкладки, полное имя и путь к файлу чертежа, а также статус публикации. Имя файла журнала состоит из имени файла списка листов плюс расширение CSV (вместо DSD).

Примечание Существующий файл журнала заменяется новым без вывода предупреждения.


ПУБЛ3DДВФ Команда

П Команды
П Команды
ПУБЛ3DДВФ Команда
Понятия Процедуры Команды

Устар.

Ввод команды: публ3dдвф

Выводится диалоговое окно "Экспорт 3D ДВФ" (диалоговое окно выбора стандартного файла).

См. команду 3DДВФ.


ПУЛЬТУПР Команда

П Команды
П Команды
ПУЛЬТУПР Команда
Понятия Процедуры Команды

Открывает окно "Пульт управления"

Меню "Инструменты": "Палитры" » подменю "Пульт управления"

Ввод команды: пультупр

Открывается окно "Пульт управления". Пульт управления имеет вид панелей управления, содержащих наборы соответствующих инструментов и органов управления. Количество панелей инструментов, отображаемых на пульте управления, определяется текущим рабочим пространством, при этом имеется возможность отображать или скрывать панели инструментов, используя для этого контекстные меню пульта управления.

Доступными панелями управления являются следующие:

  • 2D рисование (скрытая).См. также Построение геометрических объектов.
  • 3D построения.См. также Создание 3D моделей.
  • 3D переход.См. также Использование инструментов 3D просмотра.
  • Источники света.См. также Добавление освещения в модель.
  • Визуальные стили.См. также Диспетчер визуальных стилей.
  • Материалы.См. также Применение материалов и текстур к объектам.
  • Тонирование.См. также Пульт управления "Тонирование".

Примечание В исходном положении панель "2D рисование" является скрытой. Если необходимо отобразить эту панель, можно использовать любое контекстное меню пульта управления.

Нажав на расположенный на левом краю пульта управления ярлык какой-либо панели управления, можно вызвать выплывающую панель, которая содержит дополнительные инструменты этой панели управления. Каждый раз можно открыть только одну выплывающую панель.

Чтобы вызвать контекстное меню, можно нажать кнопку "Свойства" пульта управления или нажать правую кнопку мыши на строке заголовка, на какой-либо панели управления, выплывающей панели или на ярлыке панели управления. Состав пунктов контекстного меню зависит от выбранного объекта. Все опции, доступные из контекстных меню, и их описания приведены ниже.

Разрешить закрепление

Управляет возможностью закрепления пульта управления при перетаскивании его в пределах зоны закрепления у края чертежа. Чтобы снять закрепление пульта управления, следует отменить эту опцию.

Закрепить якорем слева

Позволяет закреплять и скрывать пульт управления на левой стороне окна приложения, в приоритетном положении по отношению к другим закрепленным окнам.

Закрепить якорем справа

Позволяет закреплять и скрывать пульт управления на правой стороне окна приложения, в приоритетном положении по отношению к другим закрепленным окнам.

Автоматически убирать с экрана

Позволяет управлять отображением пульта управления. Если эта опция выбрана, то при уходе курсора за пределы пульта управления на экране остается только его строка заголовка. При отмене этой опции пульт управления всегда отображается полностью.

Замкнуть

Закрытие окна "Пульт управления".

Панели управления

Вывод списка имен всех панелей управления, доступных для данного пульта управления в текущем рабочем пространстве. Выбором или отменой выбора имени определяется, будет соответствующая панель отображена или скрыта.

Справка

Вывод данной темы на экран в окне "Справка".

Скрыть

Скрытие панели управления на пульте управления.

Перенести

Курсор принимает форму четырех указывающих в разные направления стрелок.

Показать больше органов управления

Открывает выплывающую панель для соответствующей панели управления.

Показать меньше органов управления

Закрывает выплывающую панель соответствующей панели управления.

Размер

Курсор принимает форму четырех указывающих в разные направления стрелок. Чтобы изменить размер окна пульта управления, следует перетащить мышью ту его кромку, которая противоположна строке заголовка.

Группа инструментальных палитр

Отображение списка доступных групп инструментальных палитр. Чтобы связать какую-либо группу инструментальных палитр с данной панелью управления, нажать кнопку мыши на этой группе. Соответствующая группа инструментальных палитр будет отображаться при выборе панели управления.

Прозрачность

Отображает диалоговое окно "Прозрачность".


ПУЛЬТУПРЗАКР Команда

П Команды
П Команды
ПУЛЬТУПРЗАКР Команда
Понятия Процедуры Команды

Закрывает окно "Пульт управления"

Меню "Инструменты": "Палитры" » подменю "Пульт управления"

Ввод команды: ПУЛЬТУПРЗАКР

Закрывает окно "Пульт управления".


ПШОТКРЫТЬ Команда

П Команды
П Команды
ПШОТКРЫТЬ Команда
Понятия Процедуры Команды

Открывает выбранную подшивку

Меню "Файл": "Открыть подшивку"

Меню команд "Диспетчера подшивок": "Открыть"

Ввод команды: пшоткрыть

Откроется диалоговое окно "Открытие подшивки" (стандартное диалоговое окно выбора файлов).

В этом диалоговом окне можно выбрать файл подшивки (с расширением DST) для загрузки информации в "Диспетчер подшивок".


ПШСОЗДАТЬ Команда

П Команды
П Команды
ПШСОЗДАТЬ Команда
Понятия Процедуры Команды

Создание новой подшивки

Выбрать в меню "Файл": "Создать подшивку"

Меню "Сервис": "Мастера" » "Создать подшивку"

Меню команд диспетчера подшивок: "Создать подшивку"

Ввод команды: пшсоздать

Мастер создания подшивок проводит пользователя по всем этапам создания новой подшивки. Можно создать новую подшивку на основе ранее созданных чертежей, или использовать существующую подшивку как шаблон для новой.


Р Команды
  • РАБОЧЕЕПРОСТРАНСТВО
  • РАЗМЕР и РАЗМЕР1
  • РАЗМЕТИТЬ
  • РАЗОРВАТЬ
  • РАЗРЕЗ
  • РАССТОЯН
  • РАСТЯНУТЬ
  • РАСЧЛЕНИТЬ
  • РАСЧЛЕНИТЬ
  • РЕГЕН
  • РЕГЕНАВТО
  • РЕДСПЛАЙН
  • РЕДТЕЛ
  • РЕДШТРИХ
  • РЕЖИМРАСКР
  • РЕЖИМТОН
  • РЕЖИМТОНОТКЛ
  • РЕЖИМЧРТ
  • РЗМБАЗОВЫЙ
  • РЗМДИАМЕТР
  • РЗМДУГА
  • РЗМИЗЛОМ
  • РЗМЛИНЕЙНЫЙ
  • РЗМОРДИНАТА
  • РЗМОТКРЕПИТЬ
  • РЗМПАРАЛ
  • РЗМПОДАВИТЬ
  • РЗМПРИКРЕПИТЬ
  • РЗМПРОДОЛЖ
  • РЗМРАДИУС
  • РЗМРЕГЕН
  • РЗМРЕД
  • РЗМРЕДТЕКСТ
  • РЗМСТИЛЬ
  • РЗМУГЛОВОЙ
  • РЗМЦЕНТР
  • РЛИСТ
  • РОККОНВЕРТ
  • РПСОХРАНИТЬ


РАБОЧЕЕПРОСТРАНСТВО Команда

Р Команды
Р Команды
РАБОЧЕЕПРОСТРАНСТВО Команда
Понятия Процедуры Команды

Позволяет создать, изменить и сохранить рабочее пространство, а также сделать его текущим

Ввод команды: рабочеепространство

Введите опцию для команды "рабочеепространство" [Сделать текущим/соХранить/Изменить/Переименовать/Удалить/Настройка/?] <Сделать текущим>:

Сделать текущим

Установка заданного рабочего пространства текущим.

Введите имя рабочего пространства, которое необходимо сделать текущим [?] <текущее>: Ввести имя или ? для вывода списка доступных рабочих пространств.

Сохранить

Сохранение текущей конфигурации интерфейса в качестве рабочего пространства.

Сохранить рабочее пространство как <текущее>:

Изменить

Вызов вкладки "Настройка" диалогового окна "Настройка интерфейса пользователя", на которой можно изменить параметры рабочего пространства.

Переименовать

Изменение имени рабочего пространства.

Введите имя рабочего пространства, которое необходимо переименовать [?] <текущее>

Введите новое имя рабочего пространства <текущее>:

Рабочее пространство <имя> переименовано в <новое_имя>.

Удалить

Удаление рабочего пространства.

Введите имя рабочего пространства, которое необходимо удалить <текущее>: Ввести имя или ? для вывода списка доступных рабочих пространств.

Рабочее пространство <имя> удалено.

Настройка

Вызов диалогового окна "Параметры рабочего пространства", в котором определяются параметры отображения, сохранения и порядок следования меню рабочего пространства.

? Список рабочих пространств

Вывод списка всех рабочих пространств, определенных в основном и сетевом файле НПИ.


РАЗМЕР и РАЗМЕР1 Команда

Р Команды
Р Команды
РАЗМЕР и РАЗМЕР1 Команда
Понятия Процедуры Команды

Переход в режим нанесения размеров

Ввод команды: размер или размер1

Размер: Ввести размерную команду режима

Подсказка "Размер" указывает на то, что активен режим нанесения размеров, в котором можно использовать специальный набор команд, предназначенных для нанесения размеров. (Команды РАЗМЕР и РАЗМЕР1 поддерживаются только для совместимости с предыдущими версиями программы.)

Команда РАЗМЕР используется в тех случаях, когда после выполнения размерной команды необходимо остаться в режиме нанесения размеров. Команда РАЗМЕР1 используется для того, чтобы после выполнения размерной команды незамедлительно вернуться к обычной командной строке. Чтобы выйти из режима нанесения размеров, ввести вых или выход, или нажать клавишу ESC.

Команды в режиме нанесения размеров

Ниже перечислены команды, доступные в режиме нанесения размеров.

Команды, работающие в режиме нанесения размеров

Команда

Описание

ВЫХОД

Выход из режима нанесения размеров и возврат к подсказке "Команда:". Чтобы выйти из режима нанесения размеров, можно также нажать клавишу ESC.

ОСВЕЖИТЬ

Перерисовка текущего видового экрана

СТИЛЬ

Изменение текущего текстового стиля

ОТМЕНИТЬ или О

Стирание последнего из нанесенных размерных объектов; отмена последней установки размерной переменной. Команда ОТМЕНИТЬ, вызванная после выхода из режима образмеривания, полностью отменяет все выполненные операции по нанесению размеров.

В следующей таблице приведено соответствие размерных команд AutoCAD и вложенных команд режима образмеривания. Подробнее о командах режима см. описание соответствующей команды AutoCAD.

Эквиваленты команд, работающих в режиме нанесения размеров

Режим нанесения размеров

Команда

Эквивалентная

команда

ПАРАЛЛЕЛЬНЫЙ

РЗМПАРАЛ

УГЛОВОЙ

РЗМУГЛОВОЙ

БАЗОВЫЙ

РЗМБАЗОВЫЙ

ЦЕНТР

РЗМЦЕНТР

ПРОДОЛЖ

РЗМПРОДОЛЖ

ДИАМЕТР

РЗМДИАМЕТР

ВОСТЕКСТ

РЗМРЕД Вернуть

ГОРИЗОНТАЛ

РЗМЛИНЕЙНЫЙ Горизонтальный

ВЫНОСКА

ВЫНОСКА

НОВТЕКСТ

РЗМРЕД Создать

НАКЛОН

РЗМРЕД Наклонить

ОРДИНАТНЫЙ

РЗМОРДИНАТА

ПЕРЕОПРЕДЕЛИТЬ

РЗМПОДАВИТЬ

РАДИУС

РЗМРАДИУС

ВОССТАН

-РЗМСТИЛЬ Восстановить

ПОВЕРН

РЗМЛИНЕЙНЫЙ Повернутый

СОХРАН

-РЗМСТИЛЬ Сохранить

СТАТУС

-РЗМСТИЛЬ Положение

РЕДТЕКСТ

РЗМРЕДТЕКСТ

ПОВТЕКСТ

РЗМРЕД Повернуть

ОБНОВИТЬ

-РЗМСТИЛЬ Применить

ПЕРЕМЕННЫЕ

-РЗМСТИЛЬ Переменные

ВЕРТИКАЛ

РЗМЛИНЕЙНЫЙ Вертикальный


РАЗМЕТИТЬ Команда

Р Команды
Р Команды
РАЗМЕТИТЬ Команда
Понятия Процедуры Команды

Размещение на объекте точек или блоков с равными интервалами

Меню "Рисование": "Точка"» "Разметить"

Ввод команды: разметить

Выберите объект для разметки:

Длина сегмента или [Блок]: Задайте расстояние или введите б

Точки или блоки, расставленные командой РАЗМЕТИТЬ, помещаются в предыдущий набор объектов; выбор любого из них обеспечивается вводом т в ответ на очередной запрос "Выберите объекты". Для привязки к установленным точкам применяется режим объектной привязки "Узел". После этого можно удалить точки путем ввода команды "стереть предыдущий".

Маркеры размещаются в ПСК размечаемого объекта (за исключением 3D полилиний в текущей ПСК). Маркеры всегда ставятся непосредственно на объект, независимо от текущего уровня.

Если в качестве маркеров используются точеные объекты, их вид можно изменить с помощью системной переменной PDMODE.

Длина сегмента

Если задана длина, то вдоль объекта с заданным интервалом расставляются объекты-точки, начиная с конца, ближайшего к точке указания.

Разметка замкнутой полилинии начинается с ее начальной вершины (первой построенной вершины).

На окружностях первая точка ставится под центральным углом, равном текущему повороту сетки шаговой привязки. Если угол поворота сетки шаговой привязки равен 0, разметка круга начинается в точке, расположенной на окружности, справа от центра.

Следующий рисунок иллюстрирует расстановку точек командой РАЗМЕТИТЬ вдоль полилинии с интервалом 0,5 единицы; системной переменной PDMODE при этом присвоено значение 35.

Блок

Размещение блоков вдоль выбранного объекта с заданными интервалами.

Имя блока для вставки: Ввести имя существующего в чертеже блока

Выровнять блок с объектом? [Да/Нет] <Д>: Ввести д или н или нажать ENTER

Ответ д означает, что блок поворачивается относительно своей точки вставки таким образом, что его горизонтальные линии выравниваются по размечаемому объекту или совмещаются по расположению с касательными к объекту. Ответ н означает, что блок всегда вставляется с нулевым углом поворота.

Длина сегмента:

После задания длины сегмента блок вставляется с выбранным интервалом. Переменные атрибуты при вставке блока игнорируются.


РАЗОРВАТЬ Команда

Р Команды
Р Команды
РАЗОРВАТЬ Команда
Понятия Процедуры Команды

Разрыв выбранного объекта между двумя точками

Панель "Редактирование":

Меню "Редактировать": "Разорвать"

Ввод команды: разорвать

Выбрать объект: Выбрать объект любым способом, или указать первую точку разрыва (1) на объекте

Дальнейшие запросы зависят от того, как был выбран объект. При выборе объекта с помощью указывающего устройства программа выбирает точку, которая считается первой точкой разрыва. Отвечая на следующий запрос, пользователь может либо указать вторую точку, либо изменить первую.

Вторая точка разрыва или [Первая точка]: Указать вторую точку разрыва (2) или ввести п

Вторая точка разрыва

Указывает вторую точку, используемую для разрыва объекта.

Первая точка

Первая точка, определенная программой автоматически, заменяется на указанную пользователем в ответ на запрос.

Первая точка разрыва:

Вторая точка разрыва:

Стирает часть объекта, лежащую между указанными точками. Если вторая указанная точка не принадлежит объекту, выбирается ближайшая точка на объекте. Поэтому для разрыва одного из концов линии, дуги или полилинии необходимо указать вторую точку за удаляемым концом.

Чтобы разбить объект на две части, ничего не удаляя, нужно указать вторую точку, совпадающую с первой. Это можно сделать вводом @ в ответ на запрос второй точки.

Команда РАЗОРВАТЬ работает с отрезками, дугами, кругами, полилиниями, эллипсами, сплайнами, кольцами и некоторыми другими типами объектов.

Программа преобразует окружность в дугу, удаляя ее часть от первой до второй точки против часовой стрелки.


РАЗРЕЗ Команда

Р Команды
Р Команды
РАЗРЕЗ Команда
Понятия Процедуры Команды

Разрезание тел плоскостью или поверхностью

Меню "Редактирование": "3D операции" » "Разрез"

Ввод команды: разрез

Пульт управления: Панель создания 3D объектов (нажмите значок, чтобы развернуть), Разрез

Выберите объекты для разреза: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Примечание Включенные в набор объектов области игнорируются.

Укажите начальную точку режущей плоскости или [плоский Объект/Поверхность/Zось/Вид/XY/YZ/ZX/3точки] <3точки>: Указать точку, задать опцию или нажать ENTER для использования опции "3 точки"

Вторая точка на плоскости: Указать точку

Эти две точки определяют угол наклона режущей плоскости. Режущая плоскость перпендикулярна текущей ПСК.

Выберите тело для сохранения или [сохранить обе стороны] <Обе>: Выбрать одно из результирующих тел или ввести о

Плоский объект

Выравнивание секущей плоскости с сегментом круга, эллипса, круговой или эллиптической дуги, 2D сплайна или 2D полилинии.

Выберите круг, эллипс, дугу, 2D сплайн или 2D полилинию:

Можно оставить в чертеже либо обе полученные после разреза части, либо только одну. Части наследуют слой и цвет исходного тела. Однако результирующие тела не сохраняют истории исходных форм, которые использовались для их создания.

Укажите точку с нужной стороны или [выберите Обе стороны]: Указать точку или ввести о

Опции "Точка с нужной стороны от плоскости" и "Обе стороны" работают точно так же, как описано в разделе "3 точки".

Поверхность

Выравнивание секущей плоскости по поверхности.

Выберите поверхность:

Примечание Невозможно выбрать сети, созданные с помощью команд П-КРОМКА, П-ВРАЩ, П-СОЕД и П-СДВИГ.

Можно оставить в чертеже либо обе полученные после разреза части, либо только одну. Части наследуют слой и цвет исходного тела. Однако результирующие тела не сохраняют истории исходных форм, которые использовались для их создания.

Выберите тело для сохранения или [сохранить обе стороны] <Обе>: Выбрать одно из результирующих тел или ввести о

Ось Z

Определяет секущую плоскость путем задания точки начала на оси Z (нормали).

Точка на плоскости: Указать точку (1)

Точка на оси Z (нормали) плоскости: Указать точку (2)

Можно оставить в чертеже либо обе полученные после разреза части, либо только одну. Части наследуют слой и цвет исходного тела.

Укажите точку с нужной стороны или [выберите Обе стороны] <Обе>: Указать точку или ввести о

Опции "Точка с нужной стороны от плоскости" и "Обе стороны" работают точно так же, как описано в разделе "3 точки".

Вид

Проводит секущую плоскость параллельно плоскости вида на текущем видовом экране. Расположение секущей плоскости определяется указанной точкой.

Точка на плоскости текущего вида <0,0,0>: Указать точку (1) или нажать ENTER

Можно оставить в чертеже обе или только одну указанную половину разрезанного тела. Образованные после разреза тела наследуют слой и цвет исходного тела.

Укажите точку с нужной стороны или [выберите Обе стороны] <Обе>: Указать точку или ввести о

Опции "Точка с нужной стороны от плоскости" и "Обе стороны" работают точно так же, как описано в разделе "3 точки".

XY

Проводит секущую плоскость параллельно плоскости XY текущей ПСК. Расположение секущей плоскости определяется указанной точкой.

Точка на плоскости XY <0,0,0>: Указать точку (1) или нажать ENTER

Можно оставить в чертеже либо обе полученные после разреза части, либо только одну. Части наследуют слой и цвет исходного тела.

Укажите точку с нужной стороны или [выберите Обе стороны] <Обе>: Указать точку или ввести о

Опции "Точка с нужной стороны от плоскости" и "Обе стороны" работают точно так же, как описано в разделе "3 точки".

YZ

Выравнивание секущей плоскости параллельно плоскости YZ текущей ПСК. Расположение секущей плоскости определяется указанной точкой.

Точка на плоскости YZ <0,0,0>: Указать точку (1) или нажать ENTER

Можно оставить в чертеже либо обе полученные после разреза части, либо только одну. Части наследуют слой и цвет исходного тела.

Укажите точку с нужной стороны или [выберите Обе стороны] <Обе>: Указать точку или ввести о

Опции "Точка с нужной стороны от плоскости" и "Обе стороны" работают точно так же, как описано в разделе "3 точки".

ZX

Выравнивание секущей плоскости параллельно плоскости ZX текущей ПСК. Расположение секущей плоскости определяется указанной точкой.

Точка на плоскости ZX <0,0,0>: Указать точку (1) или нажать ENTER

Если одно тело разрезается больше, чем на два, то из частей, расположенных по одну сторону плоскости разреза, создается одно тело, а из частей, расположенных по другую сторону - второе.

Можно оставить в чертеже либо обе полученные после разреза части, либо только одну. Части наследуют слой и цвет исходного тела.

Укажите точку с нужной стороны или [выберите Обе стороны] <Обе>: Указать точку или ввести о

Опции "Точка с нужной стороны от плоскости" и "Обе стороны" работают точно так же, как описано в разделе "3 точки".

3 точки

Определяет секущую плоскость заданием трех точек.

Первая точка на плоскости: Указать точку (1)

Вторая точка на плоскости: Указать точку (2)

Третья точка на плоскости: Указать точку (3)

Можно оставить в чертеже либо обе полученные после разреза части, либо только одну. Части наследуют слой и цвет исходного тела.

Укажите точку с нужной стороны или [выберите Обе стороны] <Обе>: Указать точку или ввести о

Точка с нужной стороны

Определяет, какую часть разрезанного тела оставить в чертеже. Точка не должна лежать на секущей плоскости.

Обе стороны

Оставляет обе части разрезанного тела. Разрезание одного тела приводит к появлению в чертеже двух тел, лежащих по разные стороны режущей плоскости. Для каждого выбранного тела команда РАЗРЕЗ позволяет создать более двух новых тел.


РАССТОЯН Команда

Р Команды
Р Команды
РАССТОЯН Команда
Понятия Процедуры Команды

Измерение расстояний и углов между точками

Панель "Сведения":

Меню "Инструменты": "Сведения" » подменю "Расстояние"

Ввод команды: расстоян (или 'расстоян для прозрачного вызова)

Первая точка: Указать точку

Вторая точка: Указать точку

Расстояние = вычисленное расстояние, Угол в плоскости XY = угол,

Угол в плоскости XY = угол

Дельта X = разность X, Дельта Y = разность Y, Дельта Z = разность Z

Вычисляется расстояние между точками в трехмерном пространстве. Угол в плоскости XY отсчитывается от текущей оси X, а угол с плоскостью XY от текущей плоскости XY. Если координата Z первой или второй точки опущена, параметр РАССТОЯН подразумевает текущий уровень.

При выводе значения расстояния используется текущий формат единиц.

Примечание При работе в пространстве листа расстояния наносятся в единицах пространства листа. Но если команду РАССТОЯН использовать вместе с функцией объектной привязки на объектах пространства модели, которые отображаются в одном видовом экране, расстояния наносятся в единицах, принятых для пространства 2D-модели. При использовании команды ДИСТ для 3D расстояний рекомендуется переключиться в пространство модели.


РАСТЯНУТЬ Команда

Р Команды
Р Команды
РАСТЯНУТЬ Команда
Понятия Процедуры Команды

Перенос или растягивание объектов

Панель "Редактирование":

Меню "Редактирование": "Растянуть"

Ввод команды: растянуть

Выберите растягиваемые объекты секущей рамкой или секущим многоугольником...

Выберите объекты: Выбрать объекты секущей рамкой или секущим многоугольником и нажать ENTER . Отдельно выделенные объекты и объекты, которые полностью включены в секущую рамку, перемещаются, а не растягиваются.

С помощью команды РАСТЯНУТЬ перемещаются только вершины и конечные точки, находящиеся внутри секущей рамки; вершины и конечные точки за рамкой остаются неизменными. Команда РАСТЯНУТЬ не изменяет 3D тела, игнорирует информацию о ширине полилинии, направлениях касательных и сглаживании.

Базовая точка

Базовая точка или [Перемещение] <последнее перемещение>: Указать базовую точку или координаты точки перемещения

Вторая точка или <считать перемещением первую точку>: Указать точку или нажать ENTER для перемещения в точку с ранее указанными координатами

Перемещение

Укажите перемещение <последнее значение>: Ввести координаты X,Y точки перемещения (координату Z вводить необязательно)

Если ввести вторую точку, объекты растянутся на расстояние от базовой до второй точки. Если в ответ на запрос второй точки нажать ENTER , в качестве координат перемещения по осям X,Y,Z будут использованы координаты первой точки.


РАСЧЛЕНИТЬ Команда

Р Команды
Р Команды
РАСЧЛЕНИТЬ Команда
Понятия Процедуры Команды

Разбиение составного объекта на составляющие его объекты

Панель "Редактирование":

Меню "Изменить": "Расчленить"

Ввод команды: расчленить

Выбрать объекты: Выбрать объекты любым способом и нажать ENTER по завершении работы

После выполнения команды цвет, тип и вес линий расчлененного объекта может измениться. Другие результаты расчленения имеют отличия, определяемые типом расчленяемого составного объекта. Ниже приведены сведения о конкретных объектах и их расчленении.

Для расчленения объектов с одновременным изменением их свойств используют команду ВЗОРВАТЬ.

Примечание Если используется какой-либо пакет или функция ObjectARX®, то за один раз можно выполнить расчленение только одного объекта.

2D и компактные полилинии

Ширина полилинии и данные о касательных игнорируются. После расчленения широких полилиний полученные отрезки и дуги располагаются по осевой линии полилинии.

3D полилинии

Расчленяются на отрезки. Полученные отрезки наследуют исходный тип линий.

3D тела

Выполнение расчленения плоских граней на области. Неплоские грани расчленяются на поверхности.

Дуга

Дуги в неоднородно масштабированных блоках при расчленении преобразуются в эллиптические дуги.

Блок

Расчленение одного уровня вложенности блоков. Полилинии или вложенные блоки, содержащиеся в блоке, не расчленяются. Их расчленение необходимо выполнить отдельно.

Блоки с равными коэффициентами по осям X, Y и Z расчленяются на составляющие объекты. Если блок вставлен с различными масштабными коэффициентами по осям X, Y и Z, результат расчленения непредсказуем.

Если неоднородно масштабированные блоки содержат объекты, которые невозможно расчленить, они группируются в неименованный блок (обозначаемый префиксом “*E”) и снабжаются ссылкой как неоднородно масштабированные. Если не удалось расчленить ни один объект блока, то данное вхождение блока остается нерасчлененным. Так, тела, ACIS-тела и области из неоднородно масштабированного блока не расчленяются.

При расчленении блока с атрибутами значения атрибутов удаляются; остаются только их описания.

Не могут быть расчленены блоки, вставленные командой МВСТАВИТЬ, внешние ссылки и их зависимые блоки.

Тело ACIS

Расчленяются на ACIS-тела с единственной поверхностью (неплоские поверхности), области и кривые.

Круг

Круги в неоднородно масштабированных блоках при расчленении преобразуются в эллипсы.

Выноски

Расчленяются на отрезки, сплайны, фигуры (стрелки), блоки (стрелки, блоки пояснений), многострочный текст и рамки допусков (в зависимости от типа выноски).

Многострочные тексты

Расчленяются на отдельные текстовые объекты.

Мультилинии

Расчленяются на отрезки и дуги.

Многогранные сети

Сети с одной вершиной расчленяются на точки. Сети с двумя вершинами расчленяются на отрезки. Сети с тремя вершинами расчленяются на трехмерные грани.

Область

Расчленяются на отрезки, дуги и сплайны.


РАСЧЛЕНИТЬ Команда

Р Команды
Р Команды
РАСЧЛЕНИТЬ Команда
Понятия Процедуры Команды

Расчленение составного объекта на отдельные компоненты

Ввод команды: расчленить

Выберите объекты для расчленения на компоненты.

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Программа выдает сообщение о том, какое количество объектов выбрано и сколько из них невозможно расчленить. При выборе нескольких правильных объектов отобразится следующий запрос.

Задайте опцию [По отдельности/Все] <Все>: Ввести о, ввести в или нажать ENTER

По отдельности

Применение изменений к выбранным объектам по одному за раз. Для каждого объекта отображается следующий запрос.

Задайте опцию [Все/Цвет/Слой/вЕс линий/По объекту/Расчленить] <Расчленить>: Задать опцию или нажать ENTER

Все

Назначение цвета, типа и веса линий, а также слоя компонентам после расчленения объекта. Отобразятся подсказки, связанные с опциями "Цвет", "Тип линий", "Вес линий" и "Слой".

Цвет

Назначение цвета компонентам после расчленения объекта.

Новый цвет [изПалитры/Альбом]<ПОСЛОЮ>: Ввести имя цвета, номер от 1 до 255, ввести п или а, послою или поблоку либо нажать ENTER

Ввод послою означает, что компоненты наследуют цвет слоя расчленяемого объекта. Ввод поблоку означает, что компоненты наследуют цвет самого расчленяемого объекта.

Ввести п для выбора цвета объекта из всей палитры цветов (True color).

Компоненты R,G,B: Ввести три разделенных запятыми целых значения от 0 до 255

Ввести а для выбора цвета объекта из загруженного альбома цветов.

Имя альбома цветов: Ввести имя установленного альбома цветов, например PANTONE

После ввода имени альбома цветов отображается запрос на ввод имени цвета, содержащегося в этом альбоме.

Имя цвета: Ввести имя цвета из этого альбома, например PANTONE 573

Слой

Назначение слоя компонентам после расчленения объекта. При выборе слоя, предложенного по умолчанию, наследуется текущий слой (а не слой расчлененного объекта).

Введите новое имя слоя для расчлененных объектов <текущий>: Ввести имя существующего слоя или нажать ENTER

Тип линий

Назначение типа линий компонентам после расчленения объекта.

Введите новое имя типа линий для расчлененных объектов <ПОСЛОЮ>: Ввести имя типа линий или нажать ENTER

Допускается вводить имена типов линий, загруженных в чертеж. Ввод послою означает, что компоненты наследуют тип линий слоя расчленяемого объекта. Ввод поблоку означает, что компоненты наследуют тип линий самого расчленяемого объекта.

Вес линий

Назначение веса линий компонентам после расчленения объекта.

Введите новый вес линий для расчлененных объектов<ПОСЛОЮ>: Ввести в числовом виде расстояние, указать две точки или нажать клавишу ENTER

По объекту

Назначение цвета, типа и веса линий, а также слоя компонентам расчленяемого объекта, если последний находится на слое 0, а его цвет, вес линий и тип линий имеют значение ПОБЛОКУ.

Расчленить

Расчленение составного объекта на отдельные компоненты, аналогично тому, как это делает команда РАСЧЛЕНИТЬ.

Все

Применение изменений ко всем выбранным объектам.

Задайте опцию [Все/Цвет/Слой/вЕс линий/По объекту/Расчленить] <Расчленить>: Задать опцию или нажать ENTER

О назначении опций "Все", "Цвет", "Слой", "Тип линий", "По объекту" и "Расчленить" см. описание соответствующих опций, приведенных в разделе "По отдельности" данной команды.


РЕГЕН Команда

Р Команды
Р Команды
РЕГЕН Команда
Понятия Процедуры Команды

Регенерация чертежа и перерисовка содержимого текущего видового экрана

Меню "Вид": "Реген"

Ввод команды: реген

Команда РЕГЕН регенерирует весь чертеж и заново вычисляет экранные координаты всех объектов на текущем видовом экране. Она также выполняет индексирование базы данных чертежа для оптимального отображения на экране и выбора объектов.


РЕГЕНАВТО Команда

Р Команды
Р Команды
РЕГЕНАВТО Команда
Понятия Процедуры Команды

Управление автоматической регенерацией чертежа

Ввод команды: регенавто (или 'регенавто для прозрачного вызова)

Выберите режим [Вкл/Откл] <текущий>: Ввести вкл или откл или нажать ENTER

Вкл

Если при включении данного режима в очереди имеется невыполненная регенерация, то чертеж сразу регенерируется. В дальнейшем регенерация чертежа выполняется по мере выполнения команд, требующих этого.

Откл

Подавляет регенерацию чертежа до явного вызова команды РЕГЕН или ВСЕРЕГЕН или включения режима авторегенерации командой РЕГЕНАВТО.

Если выполняется операция, требующая регенерации чертежа, и эту операцию отменить нельзя (например, размораживание слоев), отображается следующее сообщение:

Регенерация отложена.

Если выполняется операция, требующая регенерации чертежа, и эту операцию можно отменить (например, размораживание слоев), отображается следующее сообщение:

О регенерации—продолжать?

При нажатии "OK" чертеж регенерируется. При нажатии "Отмена" последняя операция отменяется, и чертеж не регенерируется.


РЕДСПЛАЙН Команда

Р Команды
Р Команды
РЕДСПЛАЙН Команда
Понятия Процедуры Команды

Редактирование сплайнов или сглаженных сплайнами полилиний

Панель Редактирование-2:

Меню "Редактирование": "Объект" » " Сплайн"

Контекстное меню: Выбрать сплайн для редактирования, нажать правую кнопку мыши в области рисования и выбрать "Редактирование сплайна".

Ввод команды: редсплайн

Выберите сплайн:

Задайте опцию [Определяющие/Замкнуть/Перенести/Исправить/оБратить/Отменить]:

При выборе сплайна (сглаженной сплайном полилинии) его определяющие (управляющие) точки выделяются ручками.

Если выбранный сплайн замкнут, опция "Замкнуть" заменяется на "Разомкнуть". Если у сплайна нет определяющих данных, опция "Определяющие" становится недоступной. К определяющим данным относятся определяющие точки, допуск, связанные со сплайном касательные (все это задается в команде СПЛАЙН).

Сплайн теряет определяющие данные в случае:

  • использования опции "Очистить" в ходе редактирования данных
  • исправления сплайна с увеличением его порядка, добавления определяющих точек или изменения их весов
  • изменения допуска для сплайна
  • перемещения управляющих точек сплайна
  • подрезки, разрушения, растяжения или удлинения сплайна

Примечание Команда РЕДСПЛАЙН автоматически преобразует сглаженные сплайнами полилинии в настоящие сплайны. Преобразование имеет силу даже в случае прерывания команды сразу же после выбора полилинии.

Определяющие

Редактирует определяющие сплайн данные, используя следующие опции:

Задайте опцию

[Добавить/Замкнуть/Удалить/Перенести/Очистить/Касательные/ДОПуск/выХод] <выХод>: Задать опцию или нажать ENTER

Примечание Если выбранный сплайн замкнут, опция "Замкнуть" заменяется опцией "Разомкнуть".

Добавить

Добавляет в сплайн определяющие точки.

Управляющая точка <выход>: Указать управляющую точку или нажать ENTER

Новая точка <выход>: Указать точку или нажать ENTER

Новая точка <выход>: Указать точку или нажать ENTER

После выбора точки РЕДСПЛАЙН подсвечивает ее и следующую за ней; новая точка размещается между двумя этими точками. Для отмены последней добавленной точки можно использовать опцию "Отменить". Если выбрана последняя точка на разомкнутом сплайне, выделяется только указанная точка, и РЕДСПЛАЙН добавляет новую точку после последней точки. Если выбрать первую точку на разомкнутом сплайне, появится запрос, предлагающий поместить новую точку до или после первой точки.

Новая точка или [После/До] <выход>: Указать точку, задать опцию или нажать ENTER

Новая точка <выход>: Указать точку или нажать ENTER

Точка добавляется, и сплайн перестраивается с учетом нового набора точек.

Замкнуть/Разомкнуть

Если выбранный сплайн замкнут, опция "Замкнуть" заменяется опцией "Разомкнуть".

Замкнуть

Замыкает разомкнутый сплайн и сглаживает кривую в точке соединения. Если начальная и конечная точки сплайна совпадают, эта опция позволяет продолжить касательную к сплайну в обеих точках.

Разомкнуть

Размыкает замкнутый сплайн. Если начальная и конечная точки сплайна совпадали перед использованием опции "Замкнуть" для продолжения касательной к сплайну в обеих точках, опция "Разомкнуть" возвращает сплайн в исходное состояние. Начальная и конечная точки остаются на своих местах, но гладкость кривой в точке замыкания теряется.

Если перед применением опции "Замкнуть" начальная и конечная точка сплайна не совпадали, то опция "Разомкнуть" отменяет сглаживание сплайна и возвращает точки в исходное положение.

Удалить

Удаляет из сплайна определяющие точки и перестраивает сплайн с учетом оставшихся точек.

Управляющая точка <выход>: Указать управляющую точку или нажать ENTER

Перенести

Переносит определяющую точку в новое положение.

Новое положение или [След/Пред/Выбрать точку/выХод] <С>: Указать точку, задать опцию или нажать ENTER

Новое положение

Перенос выбранной точки в новое положение. Предыдущий запрос будет выведен повторно.

След

Выделение следующей точки.

Пред

Выделение предыдущей точки.

Выбрать точку

Позволяет выбрать управляющую точку.

Управляющая точка <выход>: Указать управляющую точку или нажать ENTER

Выход

Возврат к предыдущему запросу.

Очистить

Удаление определяющих данных сплайна из базы данных чертежа. После удаления определяющих данных сплайна основной запрос команды РЕДСПЛАЙН отображается без опции "Определяющие".

Касательные

Редактирует начальную и конечную касательные сплайна.

Касательная в начальной точке или [по Умолчанию]: Указать точку, задать опцию или нажать ENTER

Касательная в конечной точке или [по Умолчанию]: Указать точку, задать опцию или нажать ENTER

Если сплайн замкнут, запрос имеет вид "Направление касательной или [по Умолчанию]".

Опция "По умолчанию" устанавливает на концах касательные по умолчанию.

Следует указать точки для задания векторов касательных или использовать режимы привязки "Касательная" и "Нормаль" для выравнивания создаваемого сплайна по существующим объектам.

Допуск

Сплайн перестраивается с учетом нового значения допуска.

Допуск <текущий>: Ввести значение или нажать ENTER

Выход

Возврат к основному запросу команды РЕДСПЛАЙН.

Замкнуть/Разомкнуть

Если выбранный сплайн замкнут, опция "Замкнуть" заменяется на "Разомкнуть".

Замкнуть

Замыкает разомкнутый сплайн и сглаживает кривую в точке соединения. Если начальная и конечная точки сплайна совпадают, эта опция позволяет продолжить касательную к сплайну в обеих точках.

Разомкнуть

Размыкает замкнутый сплайн. Если начальная и конечная точки сплайна совпадали перед использованием опции "Замкнуть" для продолжения касательной к сплайну в обеих точках, опция "Разомкнуть" возвращает сплайн в исходное состояние. Начальная и конечная точки остаются на своих местах, но гладкость кривой в точке замыкания теряется.

Если перед применением опции "Замкнуть" начальная и конечная точка сплайна не совпадали, то опция "Разомкнуть" отменяет сглаживание сплайна и возвращает точки в исходное положение.

Перенести

Меняет положение управляющих вершин и удаляет определяющие точки.

Новое положение или [След/Пред/Выбрать точку/выХод] <С>: Указать точку, задать опцию или нажать ENTER

Новое положение

Перенос выбранной точки в новое положение.

После переноса выбранной точки в новое положение РЕДСПЛАЙН перестраивает сплайн с учетом нового положения точки.

След

Выделение следующей точки. При этом маркер не будет циклически переходить от конца к началу сплайна даже в том случае, когда последний замкнут.

Пред

Выделение предыдущей точки. При этом маркер не будет циклически переходить от начала к концу сплайна даже в том случае, когда последний замкнут.

Выбрать точку

Позволяет выбрать управляющую точку.

Определяющая точка <выход>: Указать точку или нажать ENTER

Выход

Возврат к основному запросу команды РЕДСПЛАЙН.

Исправить

Изменяет форму сплайна.

Задайте опцию [Добавить управляющую точку/Повысить порядок/Вес/выХод] <выХод>: Задать опцию или нажать ENTER

Добавить управляющую точку

Увеличивает число управляющих точек на участке сплайна.

Точка на сплайне <выход>: Указать точку или нажать ENTER

РЕДСПЛАЙН добавляет управляющую точку вблизи точки, выбранной на сплайне, между двумя другими управляющими точками, действующими на эту часть сплайна.

Повысить порядок

Увеличивает порядок сплайна.

Новое значение порядка <текущий>: Ввести целое число или нажать ENTER

Ввод большего (по сравнению с текущим) значения порядка ведет к увеличению числа управляющих точек. Максимальное значение порядка равно 26.

Вес

Изменяет весовые коэффициенты в различных управляющих точках сплайна. Чем больше весовой коэффициент, тем ближе сплайн к данной управляющей точке.

Новое значение веса (текущее = текущее ) или [След/Пред/Выбрать точку/выХод] <С>: Ввести значение, задать опцию или нажать ENTER

Новое значение веса

AutoCAD перестраивает сплайн с учетом новых весовых значений в выбранных управляющих точках. Чем больше вес (целое число), тем сплайн ближе к управляющей точке.

След

Выделение следующей точки. При этом маркер не будет циклически переходить от конца к началу сплайна даже в том случае, когда последний замкнут.

Пред

Выделение предыдущей точки. При этом маркер не будет циклически переходить от начала к концу сплайна даже в том случае, когда последний замкнут.

Выбрать точку

Позволяет выбрать управляющую точку.

Определяющая точка <выход>: Указать точку или нажать ENTER

Выход

Возврат к основной подсказке опции "Исправить".

Выход

Возврат к основному запросу команды РЕДСПЛАЙН.

Обратно

Обращение направления сплайна. Опция предназначена в первую очередь для использования в пользовательских приложениях.

Отменить

Отменяет последнюю операцию редактирования.


РЕДТЕЛ Команда

Р Команды
Р Команды
РЕДТЕЛ Команда
Понятия Процедуры Команды

Редактирование граней и ребер 3D тел

Меню "Редактирование": "Редактирование тела"

Ввод команды: редтел

Автоматическая проверка тел при редактировании: SOLIDCHECK=текущее

Задайте опцию редактирования тела

[Грань/Ребро/Тело ACIS/Отменить/выХод] <выХод>: З адать опцию или нажать ENTER

Грань

Редактирование граней твердотельных объектов путем их выдавливания, переноса, поворота, смещения, сведения на конус, удаления, копирования и изменения цвета.

Задайте опцию редактирования грани [Выдавить/пеРенести/Повернуть/Сместить/коНус/Удалить/Копировать/Цвет/Отменить/выХод] <выХод>: Задать опцию или нажать ENTER

Выдавить

Выдавливание выбранных плоских граней на заданную глубину или по заданной траектории. Допускается одновременный выбор нескольких граней.

Выберите грани или [Отменить/Исключить]: Выбрать одну или несколько граней или задать опцию

Выберите грани или [Отменить/Исключить/Все]: Выбрать одну или несколько граней или задать опцию

Отменить

Отменяет выбор граней, добавленных в набор последними, и вновь выводит запрос. Если все грани исключены, отобразится следующий запрос.

Выбор граней полностью отменен

Исключить

Исключение ранее выбранных граней из набора. Отображается следующий запрос:

Выберите грани для исключения или [Отменить/Добавить/Все]: Выбрать одну или несколько граней (1), задать опцию или нажать ENTER

Отменить

Отменяет выбор граней, удаленных из набора последними, и вновь выводит запрос. Если ни одна грань не выбрана, отобразится следующий запрос.

Выбор граней полностью отменен

Добавить

Добавление граней в набор.

Выберите грани или [Отменить/Исключить/Все]: Выбрать одну или несколько граней (1), или задать опцию

  • Отменить: Отменяет выбор граней, добавленных в набор последними, и вновь выводит запрос.
  • Исключить: Исключает ранее выбранные грани и вновь выводит запрос.
  • Все: Выбирает все грани и добавляет их в набор.

Все

Выбор всех граней и добавление их в набор.

Все

Выбор всех граней и добавление их в набор.

После выбора граней или опции отображается следующий запрос.

Выберите грани или [Отменить/Добавить/Все]: Выбрать одну или несколько граней (1), задать опцию или нажать ENTER

Глубина выдавливания или [Траектория]: Задать расстояние или ввести т

Глубина выдавливания

Задание направления и глубины выдавливания. Ввод положительного числа вызывает выдавливание в направлении нормали. Ввод отрицательного числа вызывает выдавливание в направлении, противоположном нормали.

Угол сужения для выдавливания <0>: Задать угол от -90 до +90 градусов или нажать ENTER

Положительное значение угла сужения соответствует уменьшению объема тела; отрицательное значение — увеличению объема. По умолчанию угол сужения равен 0, и грань выдавливается перпендикулярно своей плоскости без изменения размеров. Все грани, входящие в набор, сужаются на одинаковую величину. Задание слишком больших значений угла сужения или глубины выдавливания может привести к тому, что грань сузится до нуля, не достигнув заданной глубины.

Траектория

Установка режима выдавливания вдоль траектории (выбранной линии или кривой). Все контуры, связанные с выбранной гранью, выдавливаются согласно направлению и длине траектории.

Траектория выдавливания: Выбрать объекты любым способом

Траекториями могут служить отрезки, круги, дуги, эллипсы, эллиптические дуги, полилинии и сплайны. Траектория не должна лежать в одной плоскости с выдавливаемым объектом и не должна иметь участков с большой кривизной.

Выдавленная грань начинается в плоскости профиля и заканчивается в плоскости, перпендикулярной траектории в ее конечной точке. Одна из конечных точек траектории должна лежать на плоскости профиля; в противном случае траектория перемещается в центр профиля.

Если траектория представляет собой сплайн, он должен быть перпендикулярен плоскости выдавливаемой грани в одной из конечных точек. В противном случае профиль поворачивается до тех пор, пока он не будет перпендикулярен сплайновой траектории. Если одна из конечных точек сплайна лежит в плоскости грани, эта грань поворачивается вокруг этой точки; в противном случае сплайновая траектория перемещается в центр профиля, и профили поворачиваются вокруг ее центра.

Если в траектории имеется излом, программа выполняет выдавливание объекта в направлении каждого сегмента, а затем выполняет в месте соединения скос в плоскости, делящей пополам угол между сегментами. Если излом траектории находится в месте ее замыкания, контур должен лежать в плоскости скашивания. Только в этом случае начальное и конечное сечения тела будут совпадать. Если профиль не лежит в плоскости скашивания, он будет поворачиваться до тех пор, пока не окажется в плоскости скашивания.

Перенести

Перенос выбранных граней 3D тела на заданное расстояние. Допускается одновременный выбор нескольких граней.

Выберите грани или [Отменить/Исключить]: Выбрать одну или несколько граней или задать опцию

Описание опций "Отменить", "Исключить", "Добавить" и "Все" совпадают с описанием соответствующих опций в списке "Выдавить". После выбора граней или ввода опции отображается следующая подсказка.

Выберите грани или [Отменить/Добавить/Все]: Выбрать одну или несколько граней (1), задать опцию или нажать ENTER

Базовая точка или перемещение: Указать базовую точку (2)

Вторая точка перемещения: Указать точку (3) или нажать ENTER

Две указанные точки задают направляющий вектор, который определяет, на какое расстояние и в каком направлении должна быть смещена грань. РЕДТЕЛ использует первую точку в качестве базовой и размещает копию относительно нее. Если указана одна точка (обычно она задается координатами), а затем нажата клавиша ENTER, точка используется в качестве нового местоположения.

Поворот

Поворот одной или нескольких граней (или других элементов тела) вокруг заданной оси.

Выберите грани или [Отменить/Исключить]: Выбрать одну или несколько граней или задать опцию

Описание опций "Отменить", "Исключить", "Добавить" и "Все" совпадают с описанием соответствующих опций в списке "Выдавить". После выбора граней или ввода опции отображается следующая подсказка.

Выберите грани или [Отменить/Добавить/Все]: Выбрать одну или несколько граней (1), задать опцию или нажать ENTER

Точка на оси или [Объект/Вид/Xось/Yось/Zось] <2точки>: Задать опцию, указать точку или нажать ENTER

Точка на оси, 2 точки

Задание оси поворота путем указания двух точек. Если нажать ENTER в ответ на основной запрос опции, выдаются все приведенные ниже запросы. Если в ответ на главный запрос команды указать точку, первый запрос из приведенной ниже последовательности опускается.

Первая точка оси вращения: Указать точку (1)

Вторая точка оси вращения: Указать точку (2)

Угол поворота или [Базовая линия]: Задать угол или ввести б

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол (начальный) <0>: Задать начальный угол

Конечный угол: Задать конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.

Объект

Совмещение оси вращения с существующим объектом. Можно выбрать объект любого из следующих типов:

  • Отрезок: Совмещает ось с выбранным отрезком.
  • Круг: Совмещает ось с 3D осью круга (линией, перпендикулярной к плоскости круга и проходящей через центр круга).
  • Дуга: Совмещает ось с 3D осью дуги (линией, перпендикулярной к плоскости дуги и проходящей через центр дуги).
  • Эллипс: Совмещает ось с 3D осью эллипса (линией, перпендикулярной к плоскости эллипса и проходящей через центр эллипса).
  • 2D полилиния: Совмещает ось с 3D осью, образованной начальной и конечной точками полилинии.
  • 3D полилиния: Совмещает ось с 3D осью, образованной начальной и конечной точками полилинии.
  • Сплайн: Совмещает ось с 3D осью, образованной начальной и конечной точками сплайна.

Выберите объект, задающий ось: Выбрать объект любым способом

Угол поворота или [Базовая линия]: Задать угол или ввести б

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол (начальный) <0>: Задать начальный угол

Конечный угол: Задать конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.

Вид

Совмещение оси поворота с направлением взгляда на текущем видовом экране, проходящем через выбранную точку.

Начальная точка вращения <0, 0, 0>: Указать точку

Угол поворота или [Базовая линия]: Задать угол или ввести б

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол (начальный) <0>: Задать начальный угол

Конечный угол: Задать конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.

Ось X, ость Y, ось Z

Совмещение оси вращения с одной из стандартных осей (X, Y или Z), проходящей через выбранную точку.

Начальная точка вращения <0, 0, 0>: Указать точку

Угол поворота или [Базовая линия]: Задать угол или ввести б

Угол поворота

Определяет угол поворота объекта вокруг заданной оси.

Базовая линия

Задание опорного и нового углов.

Опорный угол (начальный) <0>: Задать начальный угол

Конечный угол: Задать конечный угол

Объект поворачивается на угол, равный разности конечного и начального углов.

Сместить

Равномерное смещение граней на заданное расстояние или так, чтобы они проходили через указанную точку. Положительное значение смещения соответствует увеличению объема тела, отрицательное уменьшению.

Выберите грани или [Отменить/Исключить]: Выбрать одну или несколько граней или задать опцию (1)

Описание опций "Отменить", "Исключить", "Добавить" и "Все" совпадают с описанием соответствующих опций в списке "Выдавить". После выбора граней или ввода опции отображается следующий запрос.

Выберите грани или [Отменить/Добавить/Все]: Выбрать одну или несколько граней (1), задать опцию или нажать ENTER

Расстояние смещения: Задать расстояние

Положительное значение смещения вызывает увеличение объема тела, отрицательное значение — уменьшение объема.

Примечание Если в смещении участвуют все грани тела, имеющего отверстия и вырезы, увеличение объема тела приводит к сужению отверстий.

Конус

Сведение граней на конус. Ось, относительно которой создается конусность, определяется последовательностью указания базовой и второй точек вектора.

Выберите грани или [Отменить/Исключить]: Выбрать одну или несколько граней или задать опцию

Описание опций "Отменить", "Исключить", "Добавить" и "Все" совпадают с описанием соответствующих опций в списке "Выдавить". После выбора граней или ввода опции отображается следующий запрос.

Выберите грани или [Отменить/Добавить/Все]: Выбрать одну или несколько граней (1), задать опцию или нажать ENTER

Базовая точка: Указать базовую точку (2)

Укажите другую точку на оси конуса: Указать точку (3)

Угол сужения: Задать угол от -90 до +90 градусов

Положительное значение угла сужения соответствует уменьшению объема тела; отрицательное значение — увеличению объема. По умолчанию угол сужения равен 0, и грань выдавливается перпендикулярно своей плоскости без изменения размеров. Все грани, входящие в набор, сужаются на одинаковую величину.

Удалить

Удаление граней (в том числе полученных в результате построения фасок и сопряжений).

Выберите грани или [Отменить/Исключить]: Выбрать одну или несколько граней

Описание опций "Отменить", "Исключить", "Добавить" и "Все" совпадают с описанием соответствующих опций в списке "Выдавить". После выбора граней или ввода опции отображается следующий запрос.

Выберите грани или [Отменить/Добавить/Все]: Выбрать одну или несколько граней (1), задать опцию или нажать ENTER

Выполняется проверка тела.

Проверка тела завершена.

Копировать

Копирование граней; результат может представлять собой области или тела ACIS. Если указаны две точки, РЕДТЕЛ использует первую точку в качестве базовой и размещает копию относительно нее. Если указать одну точку (обычно она задается координатами) и нажать клавишу ENTER, эта точка будет использована командой РЕДТЕЛ в качестве нового расположения.

Выберите грани или [Отменить/Исключить]: Выбрать одну или несколько граней

Описание опций "Отменить", "Исключить", "Добавить" и "Все" совпадают с описанием соответствующих опций в списке "Выдавить". После выбора граней или ввода опции отображается следующий запрос.

Выберите грани или [Отменить/Добавить/Все]: Выбрать одну или несколько граней (1), задать опцию или нажать ENTER

Базовая точка или перемещение: Указать базовую точку (2)

Вторая точка перемещения: Указать точку (3)

Цвет

Изменение цвета граней.

Выберите грани или [Отменить/Исключить]: Выбрать одну или несколько граней

Описание опций "Отменить", "Исключить", "Добавить" и "Все" совпадают с описанием соответствующих опций в списке "Выдавить". После выбора граней или ввода опции отображается следующий запрос.

Выберите грани или [Отменить/Исключить/Все]: Выбрать одну или несколько граней, задать опцию или нажать ENTER

Откроется диалоговое окно "Выбор цвета".

Отменить

Отмена последнего действия, выполненного командой РЕДТЕЛ. Последовательным вызовом нескольких опций отмены можно вернуть тело в состояние, которое оно имело в момент вызова команды.

Выход

Выход из режима редактирования тела как целого и возврат к запросу "Задайте опцию редактирования тела".

Ребро

Редактирование ребер твердотельных объектов путем изменения их цвета и копирования.

Задайте опцию редактирования ребра [Копировать/Цвет/Отменить/выХод] <выХод>: Задать опцию или нажать ENTER

Копировать

Копирование 3D ребер. Результирующими объектами при копировании являются отрезки, дуги, круги, эллипсы и сплайны.

Выберите ребра или [Отменить/Исключить]: Выбрать одно или несколько ребер, или задать опцию

После выбора ребер или ввода опции отображается следующая подсказка.

Выберите ребра или [Отменить/Исключить]: Выбрать одно или несколько ребер (1) или нажать ENTER

Базовая точка или перемещение: Указать базовую точку (2)

Вторая точка перемещения: Указать точку (3)

Отменить

Отмена выбора ребер, последними добавленных в набор. Отображается предыдущий запрос. Если все ребра удалены, отобразится следующая подсказка.

Выбор ребер полностью отменен

Удалить

Исключение ранее выбранных ребер из набора. Отображается предыдущий запрос.

Выберите ребра для исключения или [Отменить/Добавить]: Выбрать одно или несколько ребер, задать опцию или нажать ENTER

Отменить

Отмена выбора ребер, последними добавленных в набор. Отображается предыдущий запрос. Если ребра не выбраны, отобразится следующее сообщение.

Выбор ребер полностью отменен

Добавить

Добавление ребер в набор.

Выберите ребра или [Отменить/Исключить]: Выбрать одно или несколько ребер, или задать опцию

  • Отменить: Отменяет выбор ребер, последними добавленных в набор. Отображается предыдущий запрос.
  • Исключить: Исключает ранее выбранные ребра из набора. Отображается предыдущий запрос.
Цвет

Изменение цвета ребер.

Выберите ребра или [Отменить/Исключить]: Выбрать одно или несколько ребер, или задать опцию

Описание опций "Отменить", "Исключить", "Добавить" и "Все" совпадают с описанием соответствующих опций в списке "Копировать". После выбора ребер или ввода опции отобразится диалоговое окно "Выбор цвета".

Отменить

Отмена последнего действия, выполненного командой РЕДТЕЛ. Последовательным вызовом нескольких опций отмены можно вернуть тело в состояние, которое оно имело в момент вызова команды.

Выход

Выход из режима редактирования тела как целого и возврат к запросу "Задайте опцию редактирования тела".

Тело ACIS

Позволяет редактировать тело как целое путем клеймения его объектами, разделения на несколько тел, преобразования в оболочку, упрощения и проверки.

Задайте опцию редактирования тела [Клеймить/Разделить/оБолочка/Упростить/Проверить/Отменить/выХод] <выХод>: Задать опцию или нажать ENTER

Клеймить

Клеймение выбранного тела другим объектом. Для того, чтобы операция была успешной, необходимо наличие пересечения клеймящего объекта и грани (граней) выбранного тела. Клеймение может быть применено к следующим объектам: дуги, круги, отрезки, 2D и 3D полилинии, эллипсы, сплайны, области, тела и 3D тела.

Выберите 3D тело: Выбрать объект (1)

Выберите клеймящий объект: Выбрать объект (2)

Удалить исходный объект <Н>: Ввести д или нажать ENTER

Выберите объект для клеймения: Выбрать объект или нажать ENTER

Разделить

Разделение 3D тел, занимающих несколько замкнутых объемов в пространстве, на отдельные тела.

Выберите 3D тело: Выбрать объект

Примечание Функция разделения не действует на тела (полученные в результате логических операций), части которых обладают общим объемом.

Оболочка

Преобразование тел в тонкостенные оболочки заданной толщины. Толщина всех стенок одинакова. Имеется возможность исключения отдельных граней исходного тела из оболочки. Преобразовать тело в оболочку можно только один раз. Новые грани создаются с помощью смещения существующих граней наружу от их исходных позиций.

Выберите 3D тело: Выбрать объект

Выберите грани для исключения или [Отменить/Добавить/Все]: Выбрать одну или несколько граней, или задать опцию

Описание опций "Отменить", "Исключить", "Добавить" и "Все" совпадают с описанием соответствующих опций в списке "Выдавить". После выбора граней или ввода опции отображается следующий запрос.

Выберите грани для исключения или [Отменить/Добавить/Все]: Выбрать грань (1), задать опцию или нажать ENTER

Толщина стенок оболочки: Задать расстояние

При положительной толщине новые грани создаются внутри исходного тела, при отрицательной — снаружи.

Упростить

Слияние смежных ребер или вершин, лежащих на одной поверхности или кривой. Удаление всех избыточных ребер и вершин, а также неиспользуемой геометрии. Клейменные ребра не удаляются.

Выберите 3D тело: Выбрать объект (1)

Проверить

Проверка корректности тела (выполняется независимо от состояния системной переменной SOLIDCHECK).

Выберите 3D тело: Выбрать объект

Объект является корректным телом ShapeManager.

Отменить

Отмена операции редактирования.

Выход

Выход из режима редактирования тела как целого и возврат к запросу "Задайте опцию редактирования тела".

Отменить

Отмена операции редактирования.

Выход

Завершение команды РЕДТЕЛ.


РЕДШТРИХ Команда

Р Команды
Р Команды
РЕДШТРИХ Команда
Понятия Процедуры Команды

Изменяет существующую штриховку или заливку

Панель Редактирование-2:

Меню "Изменить": "Объект" » " Штриховка"

Контекстное меню: Выбрать штриховку для редактирования, нажать правую кнопку мыши в области рисования. Выбрать "Редактирование штриховки".

Ввод команды: редштрих

Выберите объект штриховки: Выбрать объект любым способом

Отобразится диалоговое окно "Редактирование штриховки".

Если в командной строке ввести -редштрих, будут выведены подсказки для команды РЕДШТРИХ.

Темы:

  • Диалоговое окно "Редактирование штриховки"
  • РЕДШТРИХ вариант для командной строки


Диалоговое окно "Редактирование штриховки"

Р Команды
Р Команды
Диалоговое окно "Редактирование штриховки"
Понятия Процедуры Команды

Панель Редактирование-2:

Меню "Изменить": "Объект" » " Штриховка"

Контекстное меню: Выбрать штриховку для редактирования, нажать правую кнопку мыши в области рисования и выбрать "Редактирование штриховки".

Ввод команды: редштрих

Изменяет характеристики имеющейся штриховки или заливки. В диалоговом окне "Редактирование штриховки" выводятся текущие свойства выбранного объекта-штриховки либо градиентной заливки. В диалоговом окне "Редактирование штриховки" можно изменять только доступные свойства.

Штриховка

Изменение свойств образца штриховки.

Для получения сведений об этих опциях см. вкладку "Штриховка" в диалоговом окне "Штриховка и градиент".

Градиент

Изменение свойств градиентной заливки. Для получения сведений об этих опциях см. вкладку "Градиент" в диалоговом окне "Штриховка и градиент".

Дополнительно

Изменяет наследуемые параметры в соответствии с наследуемыми свойствами. Все другие параметры недоступны.

Для получения дополнительной информации см. вкладку "Копировать свойства" диалогового окна "Штриховка и градиент".

Контуры

Изменяет контуры штриховки или заливки.

Для получения дополнительной информации см. диалоговое окно "Штриховка и градиент".

Параметры

Удаляет ассоциативность штриховки, разделяет объект штриховки, имеющий несколько контуров, на отдельные объекты и изменяет порядок прорисовки штриховки.

Для получения дополнительной информации см. диалоговое окно "Штриховка и градиент".

Копирование свойств

Назначает свойства штриховки или заливки другого объекта штриховки.

Для получения дополнительной информации см. диалоговое окно "Штриховка и градиент".

Образец

Временный выход из диалогового окна для просмотра изменений в выбранном объекте.


РЕДШТРИХ вариант для командной строки

Р Команды
Р Команды
РЕДШТРИХ вариант для командной строки
Понятия Процедуры Команды

Если в командной строке ввести -редштрих, будут выведены подсказки для команды РЕДШТРИХ.

Выберите объект штриховки:

Введите опцию штриховки [Неассоциативная/сТиль/Свойства/Порядок следования/Добавить контуры/Удалить контуры/Восстановить контур/свяЗать/Отдельные штриховки/Исходная точка] <Свойства>: Задайте опцию или нажмите ENTER

Неассоциативная

Отмена свойства ассоциативности штриховки.

сТиль

Изменение стиля штриховки. В командной строке выдаются следующие запросы:

Стиль штрихования [Игнорирующий/Внешний/Нормальный] <текущий>:

Пропустить

Штриховка или заливка наносится с игнорированием всех внутренних объектов (то есть поверх них). Установить стиль "Игнорирующий" можно также, добавив в системную переменную HPNAME после имени образца последовательность символов ,И.

Внешний

Штриховка или заливка наносятся вовнутрь, начиная от внешнего контура. Команда ШТРИХ отключает штриховку или заливку при обнаружении внутреннего островка. Эта опция позволяет штриховать или закрашивать только область между наружным и первым из внутренних контурами, а вся остальная часть остается незаполненной. Установить стиль "Внешний" можно также, добавив в системную переменную HPNAME после имени образца последовательность символов ,В.

Нормальный

Штриховка или заливка наносятся вовнутрь, начиная от внешнего контура. Если при выполнении команды ШТРИХ обнаруживается внутренний островок, штрихование или заливка прекращаются до обнаружения внутри него другого островка. Установить стиль "Нормальный" можно также, добавив в системную переменную HPNAME после имени образца последовательность символов ,Н.

Свойства

Задание новых характеристик для выбранной штриховки. Подробнее о задании свойств в командной строке см. описание команды ШТРИХ.

Порядок прорисовки

Задание порядка прорисовки штриховки. В командной строке выдаются следующие запросы:

Задайте порядок прорисовки [Не изменять/на Задний план/на Передний план/зА контуром/пЕред контуром] <Не изменять>: Задайте опцию

На задний план

Расположение штриховки позади всех других объектов

На передний план

Расположение штриховки перед всеми другими объектами

Поместить за контуром

Расположение штриховки позади контура штриховки

Поместить перед контуром

Расположение штриховки перед контуром штриховки

Добавить контуры

Изменяет контуры штриховки или заливки, добавляя новые контуры.

Для получения дополнительной информации см. Добавить: Точки выбора или Добавить: Выбрать объекты .

Удалить контуры

Изменяет контуры штриховки или заливки, удаляя существующие контуры.

Для получения дополнительной информации см. раздел Удалить контуры .

Восстановить контур

Создает полилинию или область вокруг указанной штриховки или заливки и, дополнительно, связывает с ней объект штриховки.

Для получения дополнительной информации см. раздел Восстановить контур .

Связать

Устанавливает связь выделенного образца штриховки с указанными контурами.

Укажите внутреннюю точку или [Выбор объектов]: Нажмите левую кнопку мыши в области контура, задайте опцию или нажмите ENTER, чтобы вернуться к предыдущей подсказке

Указать внутреннюю точку

Создает контур из существующих объектов, образующих замкнутую область вокруг указанной точки. Связывает выделенную штриховку с таким контуром.

Выбор объектов

Создает контур из выбранных объектов, образующих замкнутую область. Связывает выделенную штриховку с таким контуром.

Отдельные штриховки

Разделяет объект штриховки, имеющий несколько контуров, на отдельные объекты штриховки.

Исходная точка

Определяет начальную точку для создания штриховки. Некоторые образцы штриховки (например, штриховку в виде кирпичей) необходимо выровнять относительно определенной точки на контуре штриховки. По умолчанию, все исходные точки штриховки соответствуют текущей исходной точке ПСК.

[Использовать текущую исходную точку/Задать новую исходную точку/По умолчанию увеличить до контура] <текущий>: Задайте опцию или нажмите ENTER, чтобы принять предлагаемое по умолчанию значение и возвратиться к предыдущей подсказке

Использовать текущую исходную точку

Устанавливает значение системной переменной HPORIGINMODE. Пять последних опций, перечисленных ниже, соответствуют значениям от 1 до 5.

[Использовать текущую исходную точку/Задать новую исходную точку/Нижняя левая/Нижняя правая/Верхняя правая/Верхняя левая/Центр] <текущий>: Задайте опцию или нажмите ENTER, чтобы принять предлагаемое по умолчанию значение и возвратиться к предыдущей подсказке

Задать новую исходную точку

Непосредственно указывает новую исходную точку штриховки.

По умолчанию увеличить до контура

Вычисляет новую исходную точку с учетом прямоугольных границ штриховки. Следует указать все четыре угла прямоугольника и его центр. Также может хранить значение новой исходной точки штриховки в системной переменной HPORIGIN.


РЕЖИМРАСКР Команда

Р Команды
Р Команды
РЕЖИМРАСКР Команда
Понятия Процедуры Команды

Запускает команду ТЕКВИЗСТИЛЬ

Ввод команды: режимраскр

Вывод подсказок для команды ТЕКВИЗСТИЛЬ.

Если в командной строке ввести -режимраскр или запустить пакетный файл, содержащий команду РЕЖИМРАСКР, будет вызван вариант команды, использующий интерфейс командной строки.

Темы:

  • РЕЖИМРАСКР (вариант для командной строки)


РЕЖИМРАСКР (вариант для командной строки)

Р Команды
Р Команды
РЕЖИМРАСКР (вариант для командной строки)
Понятия Процедуры Команды

Если в командной строке ввести -режимраскр или запустить пакетный файл, содержащий команду РЕЖИМРАСКР, будет вызван вариант команды, использующий интерфейс командной строки.

Задайте опцию [2D каркас/3D каркас/Скрытие /Плоское/Гуро/пЛоское+кромки/ гУро+кромки] <текущее>:

2D каркас

Объекты представляются в виде отрезков и кривых (как кромки граней и тел). Видны растровые и OLE-объекты, учитываются типы и веса линий.

3D каркас

Объекты представляются в виде отрезков и кривых (как кромки граней и тел). Объекты показываются с учетом цветов присвоенных им материалов.

Скрытие

Объекты представляются в каркасном виде; линии, относящиеся к задним граням, не отображаются.

Плоское

Грани многоугольников раскрашиваются цветом. В отличие от раскрашивания по Гуро, эффектов плавного перехода здесь не создается. Объекты показываются с учетом цветов присвоенных им материалов.

По Гуро

Грани многоугольников на 3D виде раскрашиваются цветом; переходы граней сглаживаются с помощью цветовых оттенков. Плавность раскраски в этом случае более высокая. Объекты показываются с учетом цветов присвоенных им материалов.

Плоское с кромками

Комбинация опций "Плоское" и "Каркас". Грани подвергаются плоскому раскрашиванию, каркас просвечивает сквозь них.

Гуро с кромками

Комбинация опций "Гуро" и "Каркас". Грани подвергаются раскрашиванию по Гуро, каркас просвечивает сквозь них.


РЕЖИМТОН Команда

Р Команды
Р Команды
РЕЖИМТОН Команда
Понятия Процедуры Команды

Отображает палитру "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования

Панель "Тонирование":

Меню "Вид": "Тонирование" » "Дополнительные параметры тонирования"

Меню "Сервис": "Тонирование" » "Дополнительные параметры тонирования"

Ввод команды: режимтон

Пульт управления: Развернутая панель "Тонирование" » "Дополнительные параметры тонирования"

Открывается палитра "Дополнительные параметры тонирования".

Темы:

  • Палитра "Дополнительные параметры тонирования"
  • Диалоговое окно "Формат вывода"


Палитра "Дополнительные параметры тонирования"

Р Команды
Р Команды
Палитра "Дополнительные параметры тонирования"
Понятия Процедуры Команды

Панель "Тонирование":

Меню "Вид": "Тонирование" » "Дополнительные параметры тонирования"

Ввод команды: режимтон

Пульт управления: Развернутая панель "Тонирование" » "Дополнительные параметры тонирования"

Палитра "Дополнительные параметры тонирования" используется для настроек тонирования. Из палитры "Параметры тонирования" возможен также доступ к "Диспетчеру наборов стандартных параметров тонирования".

Список наборов параметров тонирования/Выбрать набор стандартных параметров тонирования

Содержит стандартные наборы параметров тонирования в порядке возрастания качества от наихудших к наилучшим, до четырех пользовательских наборов параметров тонирования; кроме того, обеспечивается доступ к Диспетчеру наборов стандартных параметров тонирования.

Тонировать

Выполняет непосредственное тонирование модели из палитры "Дополнительные параметры тонирования".

Контекстное меню тонирования

Содержит настройки, влияющие на метод тонирования изображения модели пользователем.

Сохранить файл

Определяет, требуется ли запись тонированного изображения в файл.

Процедура тонирования

Определяет содержимое модели, обрабатываемое во время тонирования. Для процедуры тонирования имеются три параметра: "Вид", "Обрезать" и "Выбранные".

  • Вид. Тонирование текущего видового экрана без вызова диалогового окна «Тонирование».
  • Обрезать. Предлагает задать область тонирования на экране Если кнопка "Тонирование" нажата при установленном флажке "Задать область тонирования", отобразится запрос на задание области на чертеже перед выполнением тонирования. Данный флажок доступен только в том случае, если в группе опций «Вывод» из списка выбран пункт «Видовой экран».
  • Выбранные. Предлагает выбрать объекты для тонирования.

Назначение

Определяется выходной адрес, используемый системой тонирования для вывода тонированных изображений.

  • Окно. Выполняет тонирование в Окно тонирования.
  • Видовой экран. Тонирование на видовой экран.

Имя выходного файла

Следует указать имя файла и адрес, по которому запоминается тонированное изображение. В списке "Тип файла" отображаются следующие форматы:

  • BMP (*.bmp). Файл растрового неподвижного изображения Windows (формат .bmp).
  • PCX (*.pcx). Простой формат с минимальным сжатием.
  • TGA (*.tga). Данный формат файла поддерживает 32-битовый истинный цвет (то есть, 24-битовый цвет и альфа-канал) и используется обычно в качестве формата истинного цвета True Color.
  • TIF (*.tif). Многоплатформенный формат растрового изображения.
  • JPEG (*.jpg). Формат, широко используемый для пересылки файлов изображений в Интернет благодаря минимальному размеру файлов и минимальной длительности загрузки.
  • PNG (*.png). Формат файла неподвижных изображений, разработанный для использования в сети Интернет.

Формат вывода

Отображается текущее значение разрешения на выходе для тонированного изображения. При открытии списка "Размер вывода" отображается следующее:

  • До четырех пользовательских параметров формата.

    • Примечание Пользовательские параметры формата не запоминаются с чертежом и не сохраняются в промежутках между сеансами.

  • Четыре из числа наиболее распространенных значений разрешения на выходе.
  • Доступ в диалоговое окно "Формат вывода".
Материалы

Содержит настройки, влияющие на способ обработки материалов системой тонирования.

С материалами

Применяет к поверхности материалы, которые пользователь определяет и применяет к объектам на чертеже. Если опция "С материалами" не выбрана, для всех объектов в чертеже предполагаются значения цвета, рассеяния, диффузии, отражения, шероховатости, прозрачности, преломления и текстуры выдавливания, определенные для ГЛОБАЛЬНОГО материала. Подробнее см. МАТЕРИАЛЫ.

Фильтр текстур

Указывает способ фильтрации образцов текстур.

Вынужденное 2-стороннее

Определяет, тонируются ли обе стороны грани.

Взятие образца

Определяет, как система тонирования выполняет взятие образца.

Мин. образцов

Задается минимальная частота взятия образцов. Значение отображает количество проб на пиксел. Значение, равное или большее единицы, указывает на вычисление одного и более образцов на пиксел. Дробная величина означает, что один образец вычисляется на каждые N пикселов (например, 1/4 указывает на вычисление не менее одного образца на каждые четыре пиксела). Значение по умолчанию = 1/4.

Макс. образцов

Задается максимальная частота взятия образцов. Если для соседних образцов обнаруживается разница контрастности, превышающая предел контрастности, то область с этой контрастностью подразделяется до глубины, определяемой параметром "Максимум". Значение по умолчанию=1.

Значения "Мин. образцов" и "Макс. образцов" связаны друг с другом так, что значение "Мин. образцов" не может превысить значения "Макс. образцов". Если значение "Мин. образцов" превышает значение "Макс. образцов", отображается диалоговое окно сообщения об ошибке.

Тип фильтра

Описывается способ комбинирования множества выборок в единое значение пиксела. Типы фильтров следующие:

  • Прямоугольник. Суммируются все образцы в области фильтрации, имеющие одинаковый вес. Это самый быстрый метод взятия образцов.
  • По Гауссу. Образцы взвешиваются с использованием гауссовой (колоколообразной) кривой, центрированной по пикселу.
  • Треугольник. Образцы взвешиваются с использованием пирамиды, центрированной по пикселу.
  • По Митчелу. Образцы взвешиваются с использованием кривой (большей крутизны по сравнению с гауссовой), центрированной по пикселу.
  • По Ланчосу. Образцы взвешиваются с использованием кривой (большей крутизны по сравнению с гауссовой), центрированной по пикселу, с уменьшением влияния проб на границе области фильтрации.

Ширина и высота фильтра

Указывается размер области фильтрации. Увеличение значений ширины фильтра и высоты фильтра может понизить контрастность изображения, но при этом увеличивается длительность тонирования.

Контрастность цвета

Нажатие кнопки [...] открывает диалоговое окно "Выбор цвета", в котором пользователь может интерактивно указать пороговые значения красного, зеленого и синего цветов.

Контрастность красного, зеленого и синего цветов

Задает пороговые значения для красной, зеленой и синей составляющей образцов. Эти значения нормализованы и находятся в области от 0,0 до 1,0, где 0,0 указывает на то, что цветовая составляющая совершенно не насыщена (черный цвет или 0 в восьмиразрядной кодировке) а 1,0 указывает на полную насыщенность цветовой составляющей (белый цвет или 255 в восьмиразрядной кодировке).

Коэффициент контрастности (Альфа)

Указывается пороговое значение составляющей альфа-канала для образцов. Данное значение нормализовано и находится в области от 0,0 (полностью прозрачный или 0 в восьмиразрядной кодировке) до 1,0 (совершенно непрозрачный или 255 в восьмиразрядной кодировке).

С тенями

Содержит настройки, влияющие на метод представления теней в тонированном изображении.

Включить

Указывает на то, вычисляются ли тени во время тонирования.

Режим

Возможными режимами теней являются "Простой", "Отсортировано" или "Сегмент".

  • Простой Располагает модули построения теней в случайном порядке.
  • Отсортировано. Последовательно формирует модули построения теней от объекта до источника освещения.
  • Сегмент. Последовательно формирует модули построения теней в порядке их расположения вдоль светового луча от модулей тонирования по объему к сегментам светового луча между объектом и источником света.

Текстура теней

Определяет, будет ли использовано наложение теней при их тонировании. Во включенном состоянии система тонирования выполняет раскрашивание с наложением теней. В отключенном состоянии все тени отслеживаются по лучам.

Отслеживание лучей

Содержит настройки, влияющие на метод представления теней в тонированном изображении.

Включить

Определяет, следует ли выполнять при раскрашивании отслеживание лучей.

Макс. глубина

Ограничивается комбинация отражений и преломлений. Трассировка луча прекращается при достижении суммой чисел отражения и преломления значения максимальной глубины. Например, если максимальная глубина равняется 3 и каждое из двух значений глубины отслеживания по умолчанию равно 2, возможно двукратное отражение и однократное преломление луча и наоборот, но четырехкратное отражение и преломление луча невозможно.

Максимум отражений

Задается число возможных отражений луча. При значении, равном 0, отражения отсутствуют. При значении, равном 1, допускается однократное отражение луча. При значении, равном 2, допускается двукратное отражение луча и т.д.

Максимум преломлений

Задается число возможных преломлений луча. При значении, равном 0, преломления отсутствуют. При значении, равном 1, допускается однократное преломление луча. При значении, равном 2, допускается двукратное преломление луча и т.д.

Общее освещение

Влияет на способ освещения сцены.

Включить

Определяет, требуется ли освещение сцены отраженным светом от источников.

Фотоны/образцы

Определяется количество фотонов, используемое для вычисления интенсивности общего освещения. При увеличении данного значения общее освещение становится менее ярким, но при этом более размытым. При уменьшении данного значения общее освещение становится более ярким, но при этом менее однородным. Чем выше значение "Образцы", тем больше длительность тонирования.

Использовать радиус

Определяет размер фотонов. Во включенном состоянии размер фотонов определяется значением наборного счетчика. В отключенном состоянии каждый фотон считается равным 1/10 радиуса полной сцены.

Радиус

Обозначается область, внутри которой используются фотоны при вычислении освещенности.

Макс. глубина

Ограничивается комбинация отражений и преломлений. Отражения и преломления фотона прекращаются, когда суммарное число отражений и преломлений достигает значения максимальной глубины. Например, если максимальная глубина равняется 3, и каждое из двух значений глубины отслеживания по умолчанию равно 2, возможно двукратное отражение и однократное преломление фотона и наоборот, но четырехкратное отражение и преломление фотона невозможно.

Максимум отражений

Задается число возможных отражений фотона. При значении, равном 0, отражения отсутствуют. При значении, равном 1, возможно только однократное отражение фотона. При значении, равном 2, возможно двукратное отражение фотона и т.д.

Максимум преломлений

Задается число возможных преломлений фотона. При значении, равном 0, преломления отсутствуют. При значении, равном 1, возможно только однократное преломление фотона. При значении, равном 2, возможно двукратное преломление фотона и т.д.

Чистовые пробы

Рассчитывает общее освещение.

Включить

Определяет, требуются ли чистовые пробы для расчета окончательного раскрашивания.

Лучи

Определяется количество лучей, используемое для вычисления отраженного освещения в чистовой пробе. При увеличении данного значения общее освещение становится менее ярким, но одновременно возрастает длительность тонирования.

Режим радиуса

Определяет режим радиуса для обработки чистовых проб Параметры: "Вкл", "Откл" или "Вид"

  • Вкл. Указывает на то, что значение максимального радиуса используется для обработки чистовых проб. Радиус указывается в единицах мировой системы и по умолчанию равняется 10 процентам максимальной длины окружности модели.
  • Откл. Максимальный радиус по умолчанию равняется 10 процентам максимального радиуса модели в единицах мировой системы.
  • Вид. Значение максимального радиуса указывается не в единицах мировой системы, а в пикселах и используется для обработки чистовых проб.

Максимальный радиус

Задается максимальный радиус, в пределах которого используются чистовые пробы. Уменьшая данное значение, можно повысить качество ценой увеличения длительности тонирования.

Использовать минимум

Определяет, будет ли использован параметр "Минимальный радиус" во время обработки чистовых проб. "Вкл" - Значение минимального радиуса используется для обработки чистовых проб. "Откл" - Значение минимального радиуса не используется для обработки окончательной сборки.

Минимальный радиус

Задается минимальный радиус, в пределах которого используются чистовые пробы. Увеличивая данное значение, можно повысить качество, но с увеличением длительности тонирования.

Свойства источника света

Влияют на режим расчета отраженного освещения. По умолчанию настройки энергии и фотонов применяются ко всем источникам света в сцене.

Фотоны/Источник света

Задается количество фотонов, испускаемых каждым источником света для использования в общем освещении. При увеличении данного значения повышается точность действия общего освещения, но одновременно увеличивается используемый объем памяти и возрастает длительность тонирования. Уменьшение данного значения приводит к сокращению объема используемой памяти и понижению длительности тонирования и может быть полезным при просмотре эффектов от общего освещения.

Энергетический множитель

Умножается на общее освещение, отраженное освещение и яркость тонированного изображения.

Визуальный

Помогает пользователю понять причину конкретного поведения системы тонирования.

Сетка

Тонируется изображение, представленное в координатном пространстве объектов, в координатах мировой системы или координатах камеры.

  • Объект. Отображение в локальных координатах (UVW). Каждый объект имеет свой собственное координатное пространство.
  • МСК. Отображение в координатах мировой системы (XYZ). Ко всем объектам применяется одна и та же система координат.
  • Камера. Отображение в координатах камеры, представляемых в виде прямоугольной сетки, накладываемой на вид.

Размер сетки

Указывается размер сетки.

Фотон

Создает эффект фотонной карты. Для этого требуется наличие фотонной схемы. Если фотонная схема отсутствует, то тонирование фотонов напоминает недиагностическое тонирование сцены: система тонирования вначале тонирует раскрашенную сцену, а затем заменяет ее псевдоцветным изображением.

  • Плотность. Тонирует фотонную карту так, как она проецируется на сцену. Высокая плотность отображается красным цветом, при понижении значений тонирование выполняется более холодными цветами.
  • Освещенность. Тонируется аналогично тонированию плотности, однако фотоны раскрашиваются согласно их освещенности. Максимальная освещенность тонируется красным цветом, при понижении значений тонирование выполняется более холодными цветами

БРП

Тонируется визуальное представление параметров, используемых иерархической структурой в методе ускорения отслеживания лучей с БРП. Если в сообщении от системы тонирования указаны слишком большие значения глубины или размера либо если скорость тонирования представляется недостаточной, это может помочь обнаружить проблему.

  • Глубина. Отображается глубина дерева с представлением верхних граней ярко-красным цветом и использованием все более холодных цветов по мере увеличения глубины расположения граней.
  • Формат. Отображается размер листьев дерева с обозначением листьев разного размера различающимися цветами.
Обработка

Размер фрагментов мозаики

Определяет размер фрагментов мозаики для тонирования. Для тонирования сцены изображение разделяют на мозаичные плитки. Чем меньше фрагмент, тем чаще обновляется изображение во время тонирования. При уменьшении размера мозаичной плитки увеличивается количество обновлений изображения, т.е. тонирование занимает больше времени. Если размер мозаичной плитки увеличивается, число обновлений изображения сокращается, и тонирование занимает меньше времени.

Порядок мозаики

Указывает используемый метод (порядок тонирования) обработки мозаичных плиток при тонировании изображения. Можно также выбрать метод в соответствии с тем, как должно выглядеть изображение при его тонировании в окне тонирования.

  • По Гильберту. Следующая тонируемая мозаичная плитка выбирается на основе стоимости переключения к следующей.
  • Спираль. Тонирование мозаичных плиток начинается в центре изображения и развивается по спирали наружу.
  • Слева направо. Мозаичные плитки тонируются столбцами снизу вверх, слева направо.
  • Справа налево. Мозаичные плитки тонируются столбцами снизу вверх, справа налево.
  • Сверху вниз. Мозаичные плитки тонируются рядами справа налево, сверху вниз.
  • Снизу вверх. Мозаичные плитки тонируются рядами справа налево, снизу вверх.

Ограничение по памяти

Определяет предел памяти для тонирования. Система тонирования ведет учет объема памяти, использованного во время тонирования. Если достигнут предел памяти, геометрия некоторых объектов не отображается, чтобы освободить память для других объектов.


Диалоговое окно "Формат вывода"

Р Команды
Р Команды
Диалоговое окно "Формат вывода"
Понятия Процедуры Команды

Меню "Вид": "Тонирование"; » "Дополнительные параметры тонирования"; » "Контекстное меню тонирования"; » "Формат вывода" » "Указать формат вывода"

Ввод команды: режимтон

Пульт управления: Панель "Тонирование" (развернуть нажатием левой кнопки на значке); "Формат вывода", "Указать формат вывода"

Диалоговое окно "Формат вывода" открывается при выборе "Указать формат вывода" из списка "Формат вывода". В диалоговом окне пользователь задает для тонированного изображения разрешение на выходе.

Если задается уникальный формат вывода, он добавляется в список "Формат вывода" палитры "Параметры тонирования". Возможно включение в список форматов вывода четырех уникальных значений формата вывода, но они не сохраняются с текущим чертежом и не переносятся из одного сеанса черчения в другой.

Ширина

Устанавливает разрешение по ширине для выходного изображения в пикселах.

Пользователь может ввести новое значение в поле ширины или использовать колесико вращения для увеличения или уменьшения значения. Можно задать значение ширины в интервале от 8 до 4096.

Высота

Устанавливает разрешение по высоте для выходного изображения в пикселах.

Пользователь может ввести новое значение в поле высоты или использовать колесико вращения для увеличения или уменьшения значения. Можно задать значение высоты в интервале от 8 до 4096.

Пропорции изображения

Устанавливает пропорцию тонируемого изображения как отношение ширины к высоте.

При изменении данного значения изменяется высота для поддержания правильных размеров для активного разрешения. Значение пропорций изображения всегда выражается в виде коэффициента.

Блокировать/разблокировать пропорции изображения

Блокирует пропорцию при задании пользовательского выходного разрешения.

В заблокированном состоянии наборные счетчики "Ширина" и "Высота" взаимно заблокированы; изменение значений одного счетчика приводит к изменению значений другого для поддержания значения пропорций изображения. В разблокированном состоянии изменения ширины или высоты влияют только на значение пропорций изображения.

Примечание В видовых экранах значение усечения камеры изменяется для отражения пропорций изображения, установленных в диалоговом окне "Разрешение на выходе". Данное изменение происходит при выходе из диалогового окна.

Кнопки "Разрешение набора параметров"

Устанавливает одно из четырех наиболее часто используемых выходных разрешений.


РЕЖИМТОНОТКЛ Команда

Р Команды
Р Команды
РЕЖИМТОНОТКЛ Команда
Понятия Процедуры Команды

Закрывается палитра "Параметры тонирования" (если открыта).

Ввод команды: режимтоноткл

Команда РЕЖИМТОНОТКЛ вызывает закрытие палитры "Параметры тонирования". Если палитра "Параметры тонирования" на данный момент отображается, находится в состоянии "Автоматически убирать с экрана" или в открытом состоянии, она закрывается.


РЕЖИМЧРТ Команда

Р Команды
Р Команды
РЕЖИМЧРТ Команда
Понятия Процедуры Команды

Установка сетки и привязки, полярного и объектного отслеживания, режимов объектной привязки и динамического ввода

Меню "Инструменты": "Режимы рисования"

Контекстное меню: На строке состояния нажать правую кнопку мыши на позициях "Шаг", "Сетка", "Отс-поляр", "Привязка", "Отс-объект" или "Дин". Выбрать "Установки".

Ввод команды: РЕЖИМЧРТ ( или 'режимрис для прозрачного вызова)

Откроется диалоговое окно "Режимы рисования".

Темы:

  • Диалоговое окно "Режимы рисования"
  • Диалоговое окно "Параметры ввода с помощью мыши"
  • Диалоговое окно "Параметры ввода размеров"
  • Диалоговое окно "Внешний вид подсказок"


Диалоговое окно "Режимы рисования"

Р Команды
Р Команды
Диалоговое окно "Режимы рисования"
Понятия Процедуры Команды

Меню "Инструменты": "Режимы рисования"

Контекстное меню: В строке состояния нажать правую кнопку мыши на позициях "Шаг", "Сетка", "Отс-поляр", "Привязка", "Отс-объект" или "Дин" и выбрать "Настройки".

Ввод команды: режимрис ( или 'режимрис для прозрачного вызова)

Настраиваемые режимы рисования разделены на четыре категории: Сетка и привязка, Полярное отслеживание, Объектная привязка и Динамический ввод.

Опции

Отображает диалоговое окно "Настройка". Переход из диалогового окна "Режимы рисования" в окно "Настройка" невозможен, если команда РЕЖИМЧРТ выполняется прозрачно.

Вкладка "Шаг и сетка" (диалоговое окно "Режимы рисования")

Здесь задаются параметры шаговой привязки и сетки.

Шаг вкл

Включает и отключает режим "Шаг". Режим шаговой привязки также можно включать и выключать путем нажатия кнопки "Шаг" в строке состояния, клавиши F9 или с помощью системной переменной SNAPMODE.

Шаг привязки

Управление невидимой сеткой, состоящей из прямоугольных ячеек шаговой привязки и ограничивающей возможность перемещения курсора заданным интервалом по оси X и Y.

Шаг привязки по X

Задает интервал шаговой привязки по X. Значение должно быть положительным вещественным числом. (Системная переменная SNAPUNIT)

Шаг привязки по Y

Задает интервал шаговой привязки по Y. Значение должно быть положительным вещественным числом. (Системная переменная SNAPUNIT)

Равный интервал по X и Y

Приводит величины интервалов шаговой привязки и шага сетки по осям X и Y к одному и тому же значению. Интервалы шаговой привязки могут отличаться от интервалов шага сетки.

Полярная привязка

Управление шаговым расстоянием полярной привязки™.

Шаг

Шаг привязки в случае, когда установлен ее полярный тип. Нулевое значение указывает, что шаг полярной привязки равен интервалу шаговой привязки по X. Значение шага полярной привязки работает совместно с функциями полярного и/или объектного отслеживания. Если ни то, ни другое не включено, полярная привязка не действует. (Системная переменная POLARDIST)

Тип привязки

Установка стиля и типа привязки.

Шаговая привязка

Установка шагового типа привязки. При задании точек перемещение курсора привязывается к горизонтальным и вертикальным точкам сетки. (Системная переменная SNAPTYPE)

Ортогональная: Установка обычного (ортогонального) стиля привязки. При шаговом типе и ортогональном стиле привязки курсор перемещается по узлам прямоугольной структуры. (Системная переменная SNAPSTYL)

Изометрическая: установка изометрического стиля привязки. При шаговом типе и изометрическом стиле привязки курсор перемещается по узлам изометрической структуры. (Системная переменная SNAPSTYL)

Полярная привязка

Установка полярного типа привязки. При полярном типе привязки и включенном полярном отслеживании движение курсора может происходить по воображаемым линиям, проведенным от базовой точки отслеживания под углами, заданными на вкладке "Отслеживание". (Системная переменная SNAPTYPE)

Сетка вкл

Включает и отключает сетку. Также можно включать и выключать режим сетки, нажав кнопку "Сетка" в строке состояния, клавишу F7 или с помощью системой переменной GRIDMODE.

Интервал сетки

Управляет отображением сетки, облегчающей визуальное восприятие расстояний.

Примечание Границы сетки определяются командой ЛИМИТЫ и системной переменной GRIDDISPLAY.

Шаг сетки по X

Задает величину шага сетки в направлении оси X. Нулевое значение указывает, что шаг сетки равен шагу привязки. (Системная переменная GRIDUNIT)

Шаг сетки по Y

Задает величину шага сетки в направлении оси Y. Нулевое значение указывает, что шаг сетки равен шагу привязки. (Системная переменная GRIDUNIT)

Частота главных линий

Определяет частоту показа главных линий сетки по сравнению с второстепенными. Предпочтителен вывод на экран линий сетки, а не точек, если переменная ТЕКВИЗСТИЛЬ установлена для всех стилей отображения, кроме стиля "2D каркас". (Системная переменная GRIDMAJOR)

Свойства сетки

Определяет вид линий сетки, которые отображаются, если переменная ТЕКВИЗСТИЛЬ установлена для всех стилей отображения, кроме стиля "2D каркас".

Адаптивная сетка

Ограничивает предельную плотность ячеек сетки при уменьшении масштаба. (Системная переменная GRIDDISPLAY)

Разрешить разбиение имеющегося интервала сетки:

При укрупнении масштаба формирует дополнительные линии сетки с уменьшенным интервалом расположения. Частоту отображения этих дополнительных линий определяет опция частоты показа главных линий сетки. (Системные переменные GRIDDISPLAY и GRIDMAJOR)

Показать сетку за границами

Показ сетки за пределами области, заданной с помощью команды ЛИМИТЫ. (Системная переменная GRIDDISPLAY)

В соответствии с динамической ПСК

Приводит плоскость сетки в соответствие с плоскостью XY динамической ПСК. (Системная переменная GRISDDISPLAY)

Вкладка "Слежение" (диалоговое окно "Режимы рисования")

Управление параметрами отслеживания.

Полярное отслеживание вкл

Включение и отключение режима полярного отслеживания. Включать и выключать полярное отслеживание можно также нажатием клавиши F10 или с помощью системной переменной AUTOSNAP.

Полярные углы

Задание углов выравнивания линий полярного отслеживания. (Системная переменная POLARANG)

Шаг углов

Задание шага (приращения) углов, используемых для генерации линий полярного отслеживания. Можно ввести любое значение угла или выбрать из списка значение угла 90, 45, 30, 22.5, 18, 15, 10 или 5 градусов. (Системная переменная POLARANG)

Дополнительные углы

Здесь можно задать отдельные значения углов полярного отслеживания, не подчиняющиеся правилу шага. Состояние флажка "Дополнительные углы" контролируется также с помощью системной переменной POLARMODE, а содержимое списка углов с помощью системной переменной POLARADDANG.

Примечание Дополнительные углы задаются абсолютным значением, а не как приращение.

Список значений углов

При выборе параметра "Дополнительные углы" выводится список доступных значений дополнительных углов. Для добавления новых значений углов выбрать "Новый". Для удаления существующих значений углов выбрать "Удалить". (Системная переменная POLARADDANG)

Новый

Добавление нового угла в список (всего до 10 значений).

Примечание Прежде чем добавить угол, значение которого имеет дробную часть, необходимо соответствующим образом установить системную переменную AUPREC. Например, если значением переменной AUPREC является 0 (значение по умолчанию), все дробные углы округляются до ближайшего целого числа.

Удалить

Удаление выбранных дополнительных углов.

Объектное отслеживание

Управление объектным отслеживанием.

Только ортогонально

В процессе объектной привязки линии отслеживания рисуются только в ортогональных направлениях (т.е. горизонтально и вертикально). (Системная переменная POLARMODE)

По всем полярным углам

Применение параметров полярного отслеживания к объектному отслеживанию. При использовании полярного отслеживания перемещение курсора происходит от точки объектной привязки под углами выравнивания. (Системная переменная POLARMODE)

Примечание Включение и отключение полярного и объектного отслеживания можно также выполнять с помощью кнопок "ОТС-ПОЛЯР" и "ОТС-ОБЪЕКТ" в строке состояния.

Отсчет полярных углов

Задание исходного направления, от которого отсчитываются углы линий отслеживания.

Абсолютно

От нулевого направления текущей ПСК.

От последнего сегмента

От направления, определяемого последним построенным сегментом.

Вкладка "Объектная привязка" (диалоговое окно "Режимы рисования")

Управление текущими режимами объектной привязки. При использовании режимов можно точно указывать положение точек на объектах. При выборе нескольких режимов привязки программа привязывается к точке, ближайшей к центру прицела. Нажатием клавиши TAB можно пролистать все опции.

Объектная привязка вкл

Включение и отключение текущих режимов объектной привязки. Режимы, заданные в основной группе данной вкладки, действуют, только если объектная привязка включена. (Системная переменная OSMODE)

Объектное отслеживание вкл

Включение и отключение объектного отслеживания. Используя его, можно указывать курсором точки, которые определенным образом расположены на линиях отслеживания, проведенных от характерных точек других объектов. Для объектного отслеживания необходимо, чтобы действовал хотя бы один режим объектной привязки. (Системная переменная AUTOSNAP)

Режимы объектной привязки

Вывод списка режимов объектных привязок, которые можно установить в качестве текущих.

Конточка

Привязка к ближайшей конечной точке дуги, эллиптической дуги, отрезка, мультилинии, сегмента полилинии, сплайна, области или луча или к ближайшему углу полосы, фигуры или 3D грани.

Середина

Привязка к середине дуги, эллипса, эллиптической дуги, отрезка, мультилинии, сегмента полилинии, области, фигуры, сплайна или прямой.

Центр

Привязка к центру дуги, эллиптической дуги, эллипса или круга.

Узел

Привязка к объекту-точке, определяющей точке размера или начальной точке размерного текста.

Квадрант

Привязка к точке квадранта дуги, эллиптической дуги, эллипса или круга.

Пересечение

Привязка к пересечению дуг, окружностей, эллипсов, эллиптических дуг, отрезков, мультилиний, полилиний, лучей, границ областей, сплайнов или прямых. "Расширенное пересечение" как отдельный режим установить нельзя.

В режимах "Пересечение" и "Расширенное пересечение" не осуществляется привязка к ребрам или углам 3D тел.

Примечание Одновременное включение режимов "Пересечение" и "Кажущееся пересечение" может привести к неоднозначным результатам.

Продолжение

Создание временной вспомогательной линии, являющейся продолжением объекта, над конечной точкой которого проходит курсор.

Примечание При работе в виде "Перспектива" нельзя провести курсор вдоль линии продолжения дуги или эллиптической дуги

Вставка

Привязка к точке вставки текста, блока, формы или атрибута.

Нормаль

Привязка к месту пересечения нормали с дугой, окружностью, эллипсом, эллиптической дугой, отрезком, мультилинией, полилинией, лучом, границей области, фигурой, сплайном или прямой. Если для создаваемого объекта требуется более одной точки привязки в режиме "Нормаль", автоматически включается режим привязки "Задержанная нормаль". В качестве второго объекта (от которого строится нормаль) можно использовать отрезок, дугу, окружность, полилинию, луч, прямую, мультилинию или ребро 3D тела. Режим "Задержанная нормаль" может применяться для построения линий, перпендикулярных одновременно любым двум из перечисленных выше объектов. При наведении прицела на точку возможной привязки в режиме "Задержанная нормаль" выводится маркер и подсказка для автопривязки.

Касательная

Привязка к месту пересечения касательной с дугой, эллиптической дугой, эллипсом, окружностью или сплайном. Если для создаваемого объекта требуется более одной точки привязки в режиме "Касательная", автоматически включается режим привязки "Задержанная касательная". Например, с помощью режима привязки "Задержанная касательная" можно построить отрезок, касательный одновременно к двум из следующих объектов: дуги, дуговые сегменты полилиний, окружности. При наведении прицела на точку возможной привязки в режиме "Задержанная нормаль" выводится маркер и подсказка для автопривязки.

Примечание При использовании режима "Смещение" в сочетании с режимом "Касательная" для построения объектов, отличных от отрезков между дугами и кругами, первая точка построения будет лежать на касательной к дуге или окружности, проведенной через точку, которая указана в области чертежа последней.

Ближайшая

Привязка к ближайшей точке дуги, окружности, эллипса, эллиптической дуги, отрезка, мультилинии, объекта-точки, полилинии, луча, сплайна или прямой.

Кажущееся пересечение

Привязка к кажущемуся пересечению двух объектов, которые не лежат в одной плоскости, но выглядят пересекающимися на текущем виде. "Кажущееся пересечение продолжений" как отдельный режим установить нельзя. В режимах "Кажущееся пересечение" и "Кажущееся пересечение продолжений" не осуществляется привязка к ребрам или углам 3D тел.

Примечание Одновременное включение режимов "Пересечение" и "Кажущееся пересечение" может привести к неоднозначным результатам.

Параллельно

При запросе на указание второй точки строится временная линия, параллельная другому объекту. После того как указана первая точка, если пользователь проводит курсор над каким-либо прямолинейным сегментом, направление этого сегмента запоминается и при создании объекта генерируется параллельная линия привязки. Таким образом, можно строить на чертеже параллельные объекты.

Выбрать все

Включает все режимы объектной привязки.

Очистить все

Отключает все режимы объектной привязки.

Вкладка "Динамический ввод" (диалоговое окно "Режимы рисования")

Управление вводом с помощью мыши, вводом размеров, динамическими подсказками и внешним видом всплывающих подсказок.

Включить ввод с помощью мыши

Включается ввода с помощью мыши. Если одновременно включены ввод с помощью мыши и динамический ввода, динамический ввод имеет более высокий приоритет. (Системная переменная DYNMODE)

Ввод с помощью мыши

Положение курсоров в форме перекрестия отображается в виде значений координат в подсказке возле курсора. В ответ на запросы ввода координат их значения можно вводить в окне подсказки, а не в командной строке.

Область предварительного просмотра

Пример ввода с помощью мыши.

Режимы

Отображает диалоговое окно "Параметры ввода с помощью мыши".

Включить ввод размеров

Включается динамический ввод. Динамический ввод не доступен для некоторых команд, запрашивающих вторую точку. (Системная переменная DYNMODE)

Ввод размеров

В ответ на запрос второй точки или расстояния в подсказке выводятся линейные и угловые значения. Значения в размерных подсказках изменяются по мере перемещения курсора. Значения можно вводить в окне подсказки, а не в командной строке.

Область просмотра

Пример ввода размеров.

Режимы

Отображает диалоговое окно "Параметры ввода размеров".

Динамические подсказки

Отображает подсказки, необходимые для завершения выполнения команды, в контекстном окне около курсора. Значения можно вводить в окне подсказки, а не в командной строке.

Область просмотра

Пример динамической подсказки.

"Показывать подсказку для ввода команды и вводимую команду рядом с перекрестьем"

Отображает подсказки динамического ввода. (Системная переменная DYNPROMPT)

Внешний вид подсказок на чертеже

Отображает диалоговое окно "Внешний вид подсказок".


Диалоговое окно "Параметры ввода с помощью мыши"

Р Команды
Р Команды
Диалоговое окно "Параметры ввода с помощью мыши"
Понятия Процедуры Команды

Меню "Инструменты": "Режимы рисования"

Контекстное меню: В строке состояния нажать правую кнопку мыши на позициях "Шаг", "Сетка", "Отс-поляр", "Привязка", "Отс-объект" или "Дин" и выбрать "Настройки".

Ввод команды: режимрис ( или 'режимрис для прозрачного вызова)

Формат

Управление форматом координат, отображаемых в подсказках, которые выводятся, когда включен ввод с помощью мыши.

Полярный формат

Отображает подсказку для второй или следующей точки в формате полярных координат. Чтобы перейти к декартовым координатам, необходимо ввести запятую (,). (Системная переменная DYNPIFORMAT)

Декартов формат

Отображает подсказку для второй или следующей точки в декартовом формате. Для перехода к полярным координатам, необходимо ввести символ (<). (Системная переменная DYNPIFORMAT)

Относительные координаты

Отображает подсказку для второй или следующей точки в формате относительных координат. Чтобы перейти к абсолютным координатам, необходимо ввести решетку (#). (Системная переменная DYNPICOORDS)

Абсолютные координаты

Отображает подсказку для второй или следующей точки в формате абсолютных координат. Чтобы перейти к относительным координатам, необходимо ввести знак "собачка" (@). При выборе этого параметра метод "направление-расстояние" будет недоступен. (Системная переменная DYNPICOORDS)

Видимость

Управление отображением ввода с помощью мыши. (Системная переменная DYNPIVIS)

Одновременно с вводом координатных данных

Когда ввод с помощью мыши включен, подсказки отображаются только в момент начала ввода координатных данных. (Системная переменная DYNPIVIS)

Когда команда содержит запрос для точки

Когда ввод с помощью мыши включен, подсказки отображаются, если команда запрашивает точку. (Системная переменная DYNPIVIS)

Всегда—Даже не в составе команды

Подсказки отображаются всегда, когда ввод с помощью мыши включен. (Системная переменная DYNPIVIS)


Диалоговое окно "Параметры ввода размеров"

Р Команды
Р Команды
Диалоговое окно "Параметры ввода размеров"
Понятия Процедуры Команды

Меню "Инструменты": "Режимы рисования"

Контекстное меню: В строке состояния нажать правую кнопку мыши на позициях "Шаг", "Сетка", "Отс-поляр", "Привязка", "Отс-объект" или "Дин" и выбрать "Настройки".

Ввод команды: режимрис ( или 'режимрис для прозрачного вызова)

Видимость

Выбор подсказок, отображаемых при растягивании ручек, когда ввод размеров включен. (Системная переменная DYNDIVIS)

Показывать одновременно только одно поле для ввода размеров

Когда для растягивания объекта используется редактирование с помощью ручек, отображается только подсказка ввода значений размеров для изменения длины. (Системная переменная DYNDIVIS)

Показывать одновременно два поля для ввода размеров

Когда для растягивания объекта используется редактирование с помощью ручек, отображается только подсказки ввода результирующих значений размеров и значений для изменения длины. (Системная переменная DYNDIVIS)

Показывать одновременно следующие поля для ввода размеров

Когда для растягивания объекта используется редактирование с помощью ручек, отображаются выбранные ниже подсказки ввода размеров. (Системные переменные DYNDIVIS и DYNDIGRIP)

Результирующий размер

Отображает подсказку, относящуюся к длине, которая обновляется при перемещении ручки.

Изменение длины

Отображает значение изменения длины при перемещении ручки.

Абсолютный угол

Отображает подсказку, относящуюся к углу, которая обновляется при перемещении ручки.

Изменение угла

Отображает значение изменения угла при перемещении ручки.

Радиус дуги

Отображает значение радиуса дуги, которое обновляется при перемещении ручки.


Диалоговое окно "Внешний вид подсказок"

Р Команды
Р Команды
Диалоговое окно "Внешний вид подсказок"
Понятия Процедуры Команды

Меню "Инструменты": "Режимы рисования"

Контекстное меню: В строке состояния нажать правую кнопку мыши на позициях "Шаг", "Сетка", "Отс-поляр", "Привязка", "Отс-объект" или "Дин" и выбрать "Настройки".

Ввод команды: режимрис ( или 'режимрис для прозрачного вызова)

Управление внешним видом всплывающих подсказок.

Примечание Системную переменную TOOLTIPMERGE используют для объединения всплывающих при выполнении построений подсказок в одну подсказку.

Предварительный просмотр

Пример текущих параметров внешнего вида подсказки.

Цвета

Выводит на экран диалоговое окно "Цвета окна чертежа", в котором пользователь имеет возможность задать цвет всплывающих при построениях подсказок и изменение цвета их фона в определенном контексте.

Размер

Задание размера подсказки. Значение по умолчанию - 0. Использовать указатель для увеличения или уменьшения подсказки.

Прозрачность

Управление прозрачностью подсказок. Чем меньше значение настройки, тем прозрачнее подсказка. При значении, равном 100 единицам, подсказка становится непрозрачной.

Применить

Указывает, применять параметры ко всем подсказкам на чертеже или только к подсказкам динамического ввода. (Системная переменная DYNTOOLTIPS)

Переопределение параметров ОС для всех подсказок на чертеже

Настройки применяются ко всем подсказкам; при этом настройки в операционной системе отменяются.

Замена параметров только для подсказок динамического ввода

Настройки применяются только к подсказкам на чертеже, используемым в динамическом вводе.


РЗМБАЗОВЫЙ Команда

Р Команды
Р Команды
РЗМБАЗОВЫЙ Команда
Понятия Процедуры Команды

Нанесение новых линейных, угловых или ординатных размеров от базовой линии предыдущего или выбранного размера

Панель "Размеры":

Меню "Размеры": Базовый

Ввод команды: рзмбазовый

Если в течение сеанса редактирования размер не нанесен, программой предлагается выбрать линейный, угловой или ординатный размер в качестве исходного.

Выбрать исходный размер: Выбрать линейный, ординатный или угловой размер

Если размеры уже нанесены, программа не выводит этот запрос и использует последний созданный в текущем сеансе объект для нанесения размера. Если выбран линейный или угловой размер, появляется следующий запрос:

Задать начало второй выносной линии или[Отменить/Выбрать] <Выбрать>: Указать точку, задать опцию или нажать клавишу ENTER для выбора базового размера

Если выбран ординатный размер, появляется следующий запрос:

Положение элемента или [Отменить/Выбрать] <Выбрать>:

Для завершения команды нужно дважды нажать клавишу ENTER или нажать ESC. Внешний вид размерного текста определяется текущим размерным стилем.

Начало второй выносной линии

По умолчанию начало первой выносной линии базового размера используется в качестве начала первой выносной линии размера, откладываемого от базовой линии. Пользователь может, однако, в ответ на запрос указания начала второй линии выбрать какой-либо из других существующих на чертеже размеров. Тогда базовый размер откладывается от той выносной линии выбранного размера, которая расположена ближе к точке указания. После указания второй точки наносится основной размер и вновь выводится запрос "Начало второй выносной линии". Для завершения команды нужно нажать клавишу ESC. Для выбора другого линейного, ординатного или углового размера в качестве основания для базового размера следует нажать клавишу ENTER.

Выбрать исходный размер: Выбрать линейный, ординатный или угловой размер

Выбрать базовый размер или нажать клавишу ESC для завершения команды.

Положение элемента

Конечная точка базового размера используется в качестве конечной точки размера, откладываемого от базовой линии. Появляется запрос для следующего положения элемента. При выборе положения элемента наносится основной размер и вновь выводится запрос "Положение элемента". Для завершения команды нужно нажать клавишу ESC. Для выбора другого линейного, ординатного или углового размера в качестве основания для базового размера следует нажать клавишу ENTER.

Выбрать исходный размер: Выбрать линейный, ординатный или угловой размер

Выбрать базовый размер или нажать клавишу ESC для завершения команды.

Отменить

Отмена нанесения последнего базового размера (в пределах одной команды).

Выбрать

Программа предлагает выбрать линейный, угловой или ординатный размер в качестве исходного. После выбора исходного размера вновь выводится запрос "Начало второй выносной линии" или "Положение элемента".


РЗМДИАМЕТР Команда

Р Команды
Р Команды
РЗМДИАМЕТР Команда
Понятия Процедуры Команды

Нанесение диаметров кругов и дуг

Панель "Размеры":

Меню "Размеры": "Диаметр"

Ввод команды: рзмдиаметр

Выбрать дугу или круг:

Команда РЗМДИАМЕТР используется для измерения диаметра выбранного круга или дуги и вывода на экран размерного текста, обозначенного символом диаметра.

Положение размерной линии или [МТекст/Текст/Угол]: Указать точку или задать опцию

Положение размерной линии

Определение угла размерной линии и положения размерного текста.

МТекст

Запуск редактора, используемого в месте редактирования, с помощью которого можно редактировать размерный текст. Если текст должен сопровождаться префиксом или суффиксом, их следует ввести соответственно перед полученным значением размера или после него. Для задания специальных символов можно использовать управляющие коды и Unicode-последовательности. См. раздел Управляющие коды и специальные символы.

Для того, чтобы изменить или удалить полученное значение размера, нужно удалить текст, ввести новый текст и нажать "OK". Если в размерном стиле отключены альтернативные единицы, можно задать режим их использования явным образом с помощью квадратных скобок ([ ]). Подробные сведения о форматировании размерного текста см. Методы редактирования в Руководстве пользователя.

Внешний вид размерного текста определяется текущим размерным стилем.

Текст

Предоставляет возможность отредактировать размерный текст в командной строке. Полученное значение размера отображается в угловых скобках.

Размерный текст <текущий>:

Ввести размерный текст или нажать клавишу ENTER для принятия полученного значения размера. Для того чтобы учесть полученное значение размера, необходимо записать его в угловых скобках (< >). Если в размерном стиле отключены альтернативные единицы, их можно отобразить, заключив в квадратные скобки ([ ]).

Свойства размерного текста задаются на вкладке "Текст" диалоговых окон создания, редактирования и переопределения размерных стилей.

Угол

Изменяет угол поворота размерного текста.

Угол поворота размерного текста:

Ввести угол. Например, для поворота текста на 45 градусов ввести 45.

После ввода значения угла вновь выводится запрос "Положение размерной линии".


РЗМДУГА Команда

Р Команды
Р Команды
РЗМДУГА Команда
Понятия Процедуры Команды

Создает размер длины дуги

Панель "Размеры":

Меню "Размеры": "Длина дуги"

Ввод команды: рзмдуга

Выбрать дугу или дуговой сегмент полилинии: Выбрать объект любым способом

Положение размера длины дуги или [МТекст/Текст/Угол/Частичный/Выноска]: Указать точку или задать опцию

Положение размера длины дуги

Указывается точка, через которую проводится размерная линия и которая задает направление выносных линий.

МТекст

Запуск редактора, используемого в месте редактирования, с помощью которого можно редактировать размерный текст. Если текст должен сопровождаться префиксом или суффиксом, их следует ввести соответственно перед полученным значением размера или после него. Для задания специальных символов можно использовать управляющие коды и Unicode-последовательности. См. раздел Управляющие коды и специальные символы.

Для того чтобы изменить или удалить полученное значение размера, нужно удалить текст, ввести новый текст и нажать "OK". Если в размерном стиле отключены альтернативные единицы, можно задать режим их использования явным образом с помощью квадратных скобок ([ ]). Подробные сведения о форматировании размерного текста см. Методы редактирования в Руководстве пользователя.

Внешний вид размерного текста определяется текущим размерным стилем.

Текст

Предоставляет возможность отредактировать размерный текст в командной строке. Полученное значение размера отображается в угловых скобках.

Размерный текст <текущий>:

Ввести размерный текст или нажать клавишу ENTER для принятия полученного значения размера. Для того, чтобы учесть полученное значение размера, необходимо записать его в угловых скобках (< >). Если в размерном стиле отключены альтернативные единицы, их можно отобразить, заключив в квадратные скобки ([ ]).

Свойства размерного текста задаются на вкладке "Текст" диалоговых окон создания, редактирования и переопределения размерных стилей.

Угол

Изменяет угол поворота размерного текста.

Угол поворота размерного текста:

Ввести угол. Например, для поворота текста на 45 градусов ввести 45.

Частичный

Уменьшение размера длины дуги.

Положение первой точки размера длины дуги:

Положение точки на дуге, от которой начинается отсчет размера длины дуги.

Положение второй точки размера длины дуги:

Определяет положение конечной точки на дуге для измерения её длины.

Выноска

Добавление объекта выноски. Эта опция доступна в том случае, если сегмент дуги больше 90 градусов. Выноска проводится радиально к центру дуги, длина которой измеряется.

Положение размера длины дуги или [Мтекст/Текст/Угол/Частичный/Без выноски]:

Указать точку или задать параметр. Выноска создается автоматически. Опция "Без выноски" отменяет действие опции "Выноска" до создания выносной линии. Чтобы удалить выноску, нужно удалить размер длины линии дуги и восстановить ее без опции выноски.


РЗМИЗЛОМ Команда

Р Команды
Р Команды
РЗМИЗЛОМ Команда
Понятия Процедуры Команды

Создание ломаных линий размеров радиуса

Панель "Размеры":

Меню "Размеры": "Ломаная линия"

Ввод команды: рзмизлом

Выбрать дугу или круг: Выбрать дугу, круг или дуговой сегмент полилинии.

Команда РЗМИЗЛОМ используется для измерения радиуса выбранного объекта и вывода на экран размерного текста, обозначенного символом радиуса. Исходную точку размера можно задать в любом удобном месте.

Примечание Ломаные линии размеров радиуса иначе называются "укороченные размеры радиуса".

Указать новое положение центра: Указать точку

Задание истинного центра дуги или окружности для ломаной линии размера радиуса.

Положение размерной дуги или [МТекст/Текст/Угол]: Указать точку или задать опцию

Положение размерной линии

Определение угла размерной линии и положения размерного текста.

МТекст

Запуск редактора, используемого в месте редактирования, с помощью которого можно редактировать размерный текст. Если текст должен сопровождаться префиксом или суффиксом, их следует ввести соответственно перед полученным значением размера или после него. Для задания специальных символов можно использовать управляющие коды и Unicode-последовательности. См. раздел Управляющие коды и специальные символы.

Для того, чтобы изменить или удалить полученное значение размера, нужно удалить текст, ввести новый текст и нажать "OK". Если в размерном стиле отключены альтернативные единицы, можно задать режим их использования явным образом с помощью квадратных скобок ([ ]). Подробные сведения о форматировании размерного текста см. Методы редактирования в Руководстве пользователя.

Внешний вид размерного текста определяется текущим размерным стилем.

Текст

Предоставляет возможность отредактировать размерный текст в командной строке. Полученное значение размера отображается в угловых скобках.

Размерный текст <текущий>: Ввести размерный текст или нажать ENTER для принятия измеренного значения

Для того чтобы учесть полученное значение размера, необходимо записать его в угловых скобках (< >). Если в размерном стиле отключены альтернативные единицы, их можно отобразить, заключив в квадратные скобки ([ ]).

Свойства размерного текста задаются на вкладке "Текст" диалоговых окон создания, редактирования и переопределения размерных стилей.

Угол

Изменяет угол поворота размерного текста.

Угол поворота размерного текста: Ввести значение угла

Например, для поворота текста на 45 градусов ввести 45.

Определение угла размерной линии и положения размерного текста.

Указать положение излома: Указать точку

Определение средней точки излома. Поперечный угол излома определяется диспетчером размерных стилей.


РЗМЛИНЕЙНЫЙ Команда

Р Команды
Р Команды
РЗМЛИНЕЙНЫЙ Команда
Понятия Процедуры Команды

Нанесение линейных размеров

Панель "Размеры":

Меню "Размеры": "Линейный"

Ввод команды: рзмлинейный

Задать начало первой выносной линии или <выбрать объект>: Указать точку или нажать клавишу ENTER для выбора объекта, подлежащего нанесению размеров

После указания начальных точек выносных линий или образмериваемых объектов появляется следующий запрос:

Положение размерной дуги или [МТекст/Текст/Угол/Горизонтальный/Вертикальный/Повернутый]: Указать точку или задать опцию

Начало первой выносной линии

Программа предлагает сначала задать положение начала первой выносной линии, а затем начало второй выносной линии.

Начало второй выносной линии: Указать точку (2)

Положение размерной линии

Через указанную точку проводится размерная линия, к которой строятся выносные линии. После определения положения наносится размер.

МТекст

Запуск редактора, используемого в месте редактирования, с помощью которого можно редактировать размерный текст. Если текст должен сопровождаться префиксом или суффиксом, их следует ввести соответственно перед полученным значением размера или после него. Для задания специальных символов можно использовать управляющие коды и Unicode-последовательности. См. раздел Управляющие коды и специальные символы.

Для того, чтобы изменить или удалить полученное значение размера, нужно удалить текст, ввести новый текст и нажать "OK". Если в размерном стиле отключены альтернативные единицы, можно задать режим их использования явным образом с помощью квадратных скобок ([ ]). Подробные сведения о форматировании размерного текста см. Методы редактирования в Руководстве пользователя.

Внешний вид размерного текста определяется текущим размерным стилем.

Текст

Предоставляет возможность отредактировать размерный текст в командной строке. Полученное значение размера отображается в угловых скобках.

Размерный текст <текущий>:

Ввести размерный текст или нажать клавишу ENTER для принятия полученного значения размера. Для того, чтобы учесть полученное значение размера, необходимо записать его в угловых скобках (< >). Если в размерном стиле отключены альтернативные единицы, их можно отобразить, заключив в квадратные скобки ([ ]).

Свойства размерного текста задаются на вкладке "Текст" диалоговых окон создания, редактирования и переопределения размерных стилей.

Угол

Изменяет угол поворота размерного текста.

Угол поворота размерного текста:

Ввести угол. Например, для поворота текста на 90 градусов ввести 90.

Горизонтальный

Нанесение горизонтального размера.

Положение размерной линии или [Мтекст/Текст/Угол]: Указать точку или задать опцию

Положение размерной линии

Размерная линия проводится через указанную точку. После определения положения наносится размер.

МТекст, Текст, Угол

Эти опции редактирования и форматирования размерного текста работают одинаково во всех размерных командах. Их описание приведено выше.

Вертикальный

Нанесение вертикального размера.

Положение размерной линии или [Мтекст/Текст/Угол]: Указать точку или задать опцию

Положение размерной линии

Размерная линия проводится через указанную точку. После определения положения наносится размер.

МТекст, Текст, Угол

Эти опции редактирования и форматирования размерного текста работают одинаково во всех размерных командах. Их описание приведено выше.

Повернутый

Нанесение линейного размера под некоторым углом.

Задать угол поворота размерной линии <текущий>: Задать угол или нажать клавишу ENTER

Выбрать объект

Автоматическое определение начальных точек первой и второй выносной линии после выбора объекта.

Выбрать объект для нанесения размера:

У полилиний (и подобных им объектов, которые можно расчленять) можно наносить лишь размеры отдельных сегментов. Не допускается выбор объектов, входящих в блок, вставленный с разными масштабными коэффициентами.

При выборе отрезка или дуги конечные точки объекта используются в качестве начальных точек выносных линий. Их отступ от объекта определяется значением параметра "Отступ от объекта" на вкладке "Линии и стрелки" диалоговых окон работы с размерными стилями. См. команда РЗМСТИЛЬ. Это значение хранится в системной переменной DIMEXO.

При выборе окружности начальными точками выносных линий являются концы его диаметра, проведенного через точку выбора. Если точка, используемая для выбора окружности, находится ближе к верхнему или нижнему квадранту, наносится горизонтальный размер. Если точка, используемая для выбора окружности, находится ближе к правому или левому квадранту, наносится вертикальный размер.


РЗМОРДИНАТА Команда

Р Команды
Р Команды
РЗМОРДИНАТА Команда
Понятия Процедуры Команды

Нанесение ординатных размеров

Панель "Размеры":

Меню "Размеры": "Ординатный"

Ввод команды: рзмордината

Указать положение элемента: Указать точку объекта (можно, с использованием объектной привязки)

Конечная точка выноски или [Xзначен/Yзначен/МТекст/Текст/Угол]: Указать точку или задать опцию

Конечная точка выноски

Если указана точка, программа выбирает ось, по которой наносится ординатный размер, на основании разности координат между образмериваемой точкой и концом выноски. Если разность координат Y больше, проставляется размер по оси X. В противном случае наносится размер по оси Y.

Xзначен

Измеряет расстояние по оси X и определяет ориентацию линии выноски и размерного текста. Выводится запрос "Конечная точка", с помощью которого можно задать конечную точку.

Yзначен

Измеряет расстояние по оси Y и определяет ориентацию линии выноски и размерного текста. Выводятся запросы "Конечная точка", с помощью которых можно задать конечную точку.

МТекст

Открывается Текстовый редактор, используемый в месте редактирования, с помощью которого пользователь может ввести или отредактировать размерный текст. Если текст должен сопровождаться префиксом или суффиксом, их следует ввести соответственно перед полученным значением размера или после него. Для задания специальных символов можно использовать управляющие коды и Unicode-последовательности. См. раздел Управляющие коды и специальные символы.

Для того чтобы изменить или удалить полученное значение размера, нужно удалить текст, ввести новый текст и нажать "OK". Если в размерном стиле отключены альтернативные единицы, можно задать режим их использования явным образом с помощью квадратных скобок ([ ]). Подробные сведения о форматировании размерного текста см. Методы редактирования в Руководстве пользователя.

Внешний вид размерного текста определяется текущим размерным стилем. После нажатия "OK" вновь выводится запрос "Конечная точка".

Текст

Предоставляет возможность отредактировать размерный текст в командной строке. Полученное значение размера отображается в угловых скобках.

Ввести размерный текст <текущий>: Ввести размерный текст или нажать клавишу ENTER для принятия полученного значения размера.

Для того, чтобы учесть полученное значение размера, необходимо записать его в угловых скобках (< >). Если в размерном стиле отключены альтернативные единицы, их можно отобразить, заключив в квадратные скобки ([ ]).

Свойства размерного текста задаются на вкладке "Текст" диалоговых окон создания, редактирования и переопределения размерных стилей. После нажатия клавиши ENTER вновь выводится запрос "Конточка".

Угол

Изменяет угол поворота размерного текста.

Угол поворота размерного текста:

Ввести угол. Например, для поворота текста на 45 градусов ввести 45.

После ввода значения угла вновь выводится запрос "Конечная точка".


РЗМОТКРЕПИТЬ Команда

Р Команды
Р Команды
РЗМОТКРЕПИТЬ Команда
Понятия Процедуры Команды

Отмена ассоциативности выбранных размеров

Ввод команды: рзмоткрепить

Выбрать открепляемые размеры: Выбрать один или несколько размеров и нажать клавишу ENTER

Команда РЗМОТКРЕПИТЬ фильтрует заданный список, оставляя в нем только ассоциативные размеры, которые не лежат на заблокированных слоях и находятся в текущем пространстве (например, при активном пространстве модели ассоциативные размеры пространства листа не входят в список). Затем команда РЗМОТКРЕПИТЬ открепляет эти размеры от геометрических объектов и выводит сообщение о количестве отфильтрованных и не вошедших в список размеров, и о количестве размеров, преобразованных в неассоциативные.


РЗМПАРАЛ Команда

Р Команды
Р Команды
РЗМПАРАЛ Команда
Понятия Процедуры Команды

Нанесение параллельных линейных размеров

Панель "Размеры":

Меню "Размеры": "Параллельный"

Ввод команды: рзмпарал

Задать начало первой выносной линии или <выбрать объект>: Указать точку для ручного задания выносных линий или нажать клавишу ENTER для автоматического нанесения выносных линий

После выбора режима нанесения выносных линий появляется запрос:

Положение размерной дуги или [МТекст/Текст/Угол]: Указать точку или задать опцию

Начало выносной линии

Первая точка задает положение начала первой выносной линии (1). Предлагается указать вторую точку.

Начало второй выносной линии: Указать точку (2)

Выбрать объект

Автоматическое определение начальных точек первой и второй выносной линии после выбора объекта.

Выбрать объект для нанесения размера:

У полилиний (и подобных им объектов, которые можно расчленять) можно наносить лишь размеры отдельных сегментов. Не допускается выбор объектов, входящих в блок, вставленный с разными масштабными коэффициентами.

При выборе отрезка или дуги начальными точками выносных линий являются конечные точки объекта. Выносные линии смещены от конечных точек на расстояние, определяемое значением параметра "Отступ от объекта" во вкладке "Линии и стрелки" диалоговых окон "Создание нового размерного стиля", "Изменение размерного стиля", "Переопределение размерного стиля" (см. команда РЗМСТИЛЬ). Это значение хранится в системной переменной DIMEXO.

При выборе круга начальными точками выносных линий являются концы его диаметра, проведенного через точку выбора. Точка указания берется за начало первой выносной линии.

Положение размерной линии

Указывается точка, через которую проводится размерная линия и которая задает направление выносных линий. После определения положения команда РЗМПАРАЛ завершается.

МТекст

Откроется Текстовый редактор, используемый в месте редактирования, с помощью которого можно вводить или редактировать размерный текст. Полученное значение размера отображается в угловых скобках (< >). Если текст должен сопровождаться префиксом или суффиксом, их следует ввести соответственно перед угловыми скобками или после них. Для задания специальных символов можно использовать управляющие коды и Unicode-последовательности. См. раздел Управляющие коды и специальные символы.

Для того, чтобы изменить или удалить полученное значение размера, нужно удалить угловые скобки, ввести новый размерный текст и нажать "OK". Если в размерном стиле отключены альтернативные единицы, можно задать режим их использования явным образом с помощью квадратных скобок ([ ]). Подробные сведения о форматировании размерного текста см. Методы редактирования в Руководстве пользователя.

Внешний вид размерного текста определяется текущим размерным стилем.

Текст

Предоставляет возможность отредактировать размерный текст в командной строке. Полученное значение размера отображается в угловых скобках.

Размерный текст <текущий>:

Ввести размерный текст или нажать клавишу ENTER для принятия полученного значения размера. Для того, чтобы учесть полученное значение размера, необходимо записать его в угловых скобках (< >). Если в размерном стиле отключены альтернативные единицы, их можно отобразить, заключив в квадратные скобки ([ ]).

Свойства размерного текста задаются на вкладке "Текст" диалоговых окон создания, редактирования и переопределения размерных стилей.

Угол

Изменяет угол поворота размерного текста.

Угол поворота размерного текста:

Ввести угол. Например, для поворота текста на 45 градусов ввести 45.

После ввода значения угла вновь выводится запрос "Положение размерной линии".


РЗМПОДАВИТЬ Команда

Р Команды
Р Команды
РЗМПОДАВИТЬ Команда
Понятия Процедуры Команды

Переопределение установок размерных переменных

Меню "Размеры": "Переопределение"

Ввод команды: рзмподавить

Действие какой размерной переменной переопределить или [Отменить переопределения]: Ввести имя размерной переменной или ввести c

Действие какой размерной переменной переопределить

Переопределение значения указанной размерной переменной.

Ввести новое значение для размерной переменной <текущее>: Ввести значение или нажать клавишу ENTER

После ввода нового значения вновь выводится запрос "Действие какой размерной переменной переопределить". При нажатии клавиши ENTER появляется запрос на выбор размеров.

Выбрать объекты: Выбрать размерные объекты любым способом

Применение переопределений к выбранным размерам.

Отменить переопределения

Отмена всех переопределений для выбранных размеров.

Выбрать объекты: Выбрать размерные объекты любым способом

Отмена переопределений и возвращение размерным объектам свойств, определенных размерным стилем.


РЗМПРИКРЕПИТЬ Команда

Р Команды
Р Команды
РЗМПРИКРЕПИТЬ Команда
Понятия Процедуры Команды

Ассоциирование выбранных размеров с геометрическими объектами

Меню "Размеры": "Прикрепить размеры"

Ввод команды: рзмприкрепить

Выбрать прикрепляемые размеры: Выбрать размерные объекты

Программа последовательно выделяет каждый выбранный размер и предлагает указать точки его прикрепления. При каждом запросе на экране появляется маркер. Если заданная точка текущего размера пока не связана с геометрическим объектом, маркер выглядит как знак Х, если связана — как знак Х внутри квадрата.

Примечание Маркер исчезает при панорамировании или зумировании с помощью мыши.

Для завершения команды с сохранением уже внесенных изменений нажать клавишу ESC. Для восстановления предыдущего состояния измененных размеров используется команда ОТМЕНИТЬ.

Запросы для разных типов размеров:

Линейный

Задать начало первой выносной линии или [Выбрать объект] <далее>: Указать положение с помощью объектной привязки, ввести s и выбрать геометрический объект или нажать клавишу ENTER для перехода к следующему запросу

Задать начало второй выносной линии <далее>: Указать положение с помощью объектной привязки или нажать клавишу ENTER для перехода к следующему размерному объекту, если он имеется

Параллельный

Задать начало первой выносной линии или [Выбрать объект] <далее>: Указать положение с помощью объектной привязки, ввести s и выбрать геометрический объект или нажать клавишу ENTER для перехода к следующему запросу

Задать начало второй выносной линии <далее>: Указать положение с помощью объектной привязки или нажать клавишу ENTER для перехода к следующему размерному объекту, если он имеется

Угловой (Три точки)

Задать вершину угла или [Выбрать дугу или круг] <далее>: Указать положение с помощью объектной привязки, ввести s и выбрать дугу или круг или нажать клавишу ENTER для перехода к следующему запросу

Задать первую конторку угла <далее>: Указать положение с помощью объектной привязки или нажать клавишу ENTER для перехода к следующему запросу

Задать вторую конторку угла <далее>: Указать положение с помощью объектной привязки или нажать клавишу ENTER для перехода к следующему размерному объекту, если он имеется

Угловой (Две линии)

Выбрать первый отрезок <далее>: Выбрать отрезок или нажать клавишу ENTER для перехода к следующему запросу

Выбрать второй отрезок <далее>: Выбрать другой отрезок или нажать клавишу ENTER для перехода к следующему размерному объекту, если он имеется

Диаметр

Выбрать дугу или круг <далее>: Выбрать дугу или круг или нажать клавишу ENTER для перехода к следующему размерному объекту, если он имеется

Выноска

Задать точку прикрепления выноски <далее>: Указать положение с помощью объектной привязки или нажать клавишу ENTER для перехода к следующему размерному объекту, если он имеется

Ординатный

Задать положение элемента <далее>: Указать положение с помощью объектной привязки или нажать клавишу ENTER для перехода к следующему размерному объекту, если он имеется

Радиус

Выбрать дугу или круг <далее>: Выбрать дугу или круг или нажать клавишу ENTER для перехода к следующему размерному объекту, если он имеется

Примечание Команда РЗМПРИКРЕПИТЬ не изменяет значение переменной DIMLFAC для размера. Сбросить линейные масштабные коэффициенты размеров можно с помощью команды РЗМПОДАВИТЬ.


РЗМПРОДОЛЖ Команда

Р Команды
Р Команды
РЗМПРОДОЛЖ Команда
Понятия Процедуры Команды

Нанесение цепи линейных, угловых или ординатных размеров от второй выносной линии предыдущего или выбранного размера

Панель "Размеры":

Меню "Размеры": "Продолжить"

Ввод команды: рзмпродолж

Если в течение сеанса редактирования размер не нанесен, программой предлагается выбрать линейный, угловой или ординатный размер в качестве размера цепи.

Выбрать исходный размер: Выбрать линейный, ординатный или угловой размер

Если размеры уже нанесены, программа не выводит этот запрос и использует последний созданный в текущем сеансе объект для нанесения размера. Если выбран линейный или угловой размер, появляется следующий запрос:

Задать начало второй выносной линии или [Отменить/Выбрать] <Выбрать>: Указать точку, задать опцию или нажать клавишу ENTER для выбора базового размера

Если выбран ординатный размер, появляется следующий запрос:

Положение элемента или [Отменить/Выбрать] <Выбрать>:

Для завершения команды дважды нажать клавишу ENTER или нажать ESC. Внешний вид размерного текста определяется текущим размерным стилем.

Начало второй выносной линии

Начало второй выносной линии указанного размера используется в качестве начала первой выносной линии следующего размера цепи. Внешний вид размерного текста определяется текущим размерным стилем.

После выбора исходного размера вновь выводится запрос "Начало второй выносной линии". Для завершения команды нужно нажать клавишу ESC. Для выбора другого линейного, ординатного или углового размера в качестве основания для продолженного размера следует нажать клавишу ENTER.

Выбрать исходный размер: Выбрать линейный, ординатный или угловой размер

Выбрать базовый размер или нажать клавишу ESC для завершения команды.

Положение элемента

Конечная точка базового размера используется в качестве конечной точки размерной цепи. Появляется запрос для следующего положения элемента. При выборе положения элемента наносится исходный размер и вновь выводится запрос "Положение элемента". Для завершения команды нужно нажать клавишу ESC. Для выбора другого линейного, ординатного или углового размера в качестве основания для продолженного размера следует нажать клавишу ENTER.

Выбрать исходный размер: Выбрать линейный, ординатный или угловой размер

Выбрать базовый размер или нажать клавишу ESC для завершения команды.

Отменить

Отмена нанесения последнего размера цепи (в пределах одной команды).

Выбрать

Программа предлагает выбрать линейный, угловой или ординатный размер в качестве исходного. После выбора исходного размера вновь выводится запрос "Начало второй выносной линии" или "Положение элемента". Для завершения команды нужно нажать клавишу ESC.


РЗМРАДИУС Команда

Р Команды
Р Команды
РЗМРАДИУС Команда
Понятия Процедуры Команды

Нанесение радиусов кругов и дуг

Панель "Размеры":

Меню "Размеры": "Радиус"

Ввод команды: рзмрадиус

Выбрать дугу или круг:

Команда РЗМРАДИУС используется для измерения радиуса выбранной дуги или круга и вывода на экран размерного текста, обозначенного символом радиуса.

Положение размерной линии или [Мтекст/Текст/Угол]: Указать точку или задать опцию

Положение размерной линии

Определение угла размерной линии и положения размерного текста.

Мтекст

Откроется Текстовый редактор, используемый в месте редактирования, с помощью которого пользователь может ввести или отредактировать размерный текст. Если текст должен сопровождаться префиксом или суффиксом, их следует ввести соответственно перед полученным значением размера или после него. Для задания специальных символов можно использовать управляющие коды и Unicode-последовательности. Края граней, расположенных под большим углом, не сглаживаются. См. раздел Управляющие коды и специальные символы.

Для того чтобы изменить или удалить полученное значение размера, нужно удалить текст, ввести новый текст и нажать "OK". Если в размерном стиле отключены альтернативные единицы, можно задать режим их использования явным образом с помощью квадратных скобок ([ ]). Подробные сведения о форматировании размерного текста см. Методы редактирования в Руководстве пользователя.

Внешний вид размерного текста определяется текущим размерным стилем.

Текст

Предоставляет возможность отредактировать размерный текст в командной строке. Полученное значение размера отображается в угловых скобках.

Размерный текст <текущий>: Ввести размерный текст или нажать ENTER для принятия измеренного значения

Для того, чтобы учесть полученное значение размера, необходимо записать его в угловых скобках (< >). Если в размерном стиле отключены альтернативные единицы, их можно отобразить, заключив в квадратные скобки ([ ]).

Свойства размерного текста задаются на вкладке "Текст" диалоговых окон создания, редактирования и переопределения размерных стилей.

Угол

Изменяет угол поворота размерного текста.

Угол поворота размерного текста: Ввести значение угла

Например, для поворота текста на 45 градусов ввести 45.


РЗМРЕГЕН Команда

Р Команды
Р Команды
РЗМРЕГЕН Команда
Понятия Процедуры Команды

Обновление расположения всех ассоциативных размеров

Ввод команды: рзмреген

Обновляется положение всех ассоциативных размеров текущего чертежа.

Обновление ассоциативных размеров вручную с помощью команды РЗМРЕГЕН бывает необходимо в трех случаях:

  • После панорамирования или изменения масштаба с помощью мыши на листе с активным пространством модели следует обновить ассоциативные размеры, созданные в пространстве листа.
  • Если измеряемые объекты были изменены при редактировании чертежа в предыдущей версии, необходимо обновить ассоциативные размеры.
  • После открытия чертежа, содержащего внешние ссылки, для которых были созданы размеры в текущем чертеже, необходимо обновить ассоциативные размеры, если геометрические объекты во внешних ссылках были изменены.


РЗМРЕД Команда

Р Команды
Р Команды
РЗМРЕД Команда
Понятия Процедуры Команды

Редактирование размерного текста и выносных линий на объектах для нанесения размеров

Панель "Размеры":

Ввод команды: рзмред

Ввести тип операции редактирования размеров [Вернуть/Новый /Повернуть/Наклонить] <Вернуть>: Задать опцию или нажать клавишу ENTER

Вернуть

Возврат размерного текста в положение по умолчанию.

Выбрать объекты: Выбрать размерные объекты любым способом

Размерный текст возвращается в позицию, предписанную размерным стилем.

Новый

Изменение размерного текста черезТекстовый редактор, используемый в месте редактирования .

Полученное значение размера отображается в угловых скобках (< >). Если текст должен сопровождаться префиксом или суффиксом, их следует ввести соответственно перед угловыми скобками или после них. Для задания специальных символов можно использовать управляющие коды и Unicode-последовательности. Края граней, расположенных под большим углом, не сглаживаются. См. раздел Управляющие коды и специальные символы.

Для того, чтобы изменить или удалить сгенерированное значение размера, нужно удалить угловые скобки, ввести новый размерный текст и нажать "OK". Если в размерном стиле отключены альтернативные единицы, можно задать режим их использования явным образом с помощью квадратных скобок ([ ]). Подробные сведения о форматировании размерного текста см. Методы редактирования в Руководстве пользователя.

Повернуть

Поворот размерного текста. Данная опция работает аналогично опции "Угол" команды РЗМРЕДТЕКСТ.

Угол поворота размерного текста:

Ввод 0 соответствует ориентации текста по умолчанию. См. команда РЗМСТИЛЬ. Кроме того, ориентацией можно управлять с помощью переменных DIMTIH и DIMTOH.

Выбрать объекты: Выбрать размерные объекты любым способом

Наклонить

Наклон выносных линий линейных размеров. Выносные линии строятся перпендикулярно размерной линии. Наклон бывает необходим, когда выносные линии перекрываются с другими объектами чертежа.

Выбрать объекты: Выбрать размерные объекты любым способом

Ввести величину угла наклона (нажать клавишу ENTER, если без наклона): Ввести величину угла или нажать ENTER


РЗМРЕДТЕКСТ Команда

Р Команды
Р Команды
РЗМРЕДТЕКСТ Команда
Понятия Процедуры Команды

Перемещение и поворот размерных текстов

Панель "Размеры":

Меню "Размеры": "Выравнивание текста"

Ввод команды: рзмредтекст

Выбрать размер: Выбрать размерный объект

Появляется запрос на определение нового положения размерного текста.

Новое положение размерного текста или [Влево/Вправо/Центр/Вернуть/Угол]: Указать точку или задать опцию

Положение размерного текста

Размер динамически обновляется по мере перемещения курсора. Для определения положения текста (над размерной линией, под ней или в ее разрыве) используется вкладка "Текст" диалоговых окон создания, редактирования и переопределения размерных стилей..

Влево

Выравнивает размерный текст влево вдоль размерной линии. Опция работает только с линейными размерами, радиусами и диаметрами.

Вправо

Выравнивает размерный текст вправо вдоль размерной линии. Опция работает только с линейными размерами, радиусами и диаметрами.

Центр

Центрирует размерный текст на размерной линии.

Вернуть

Возвращение размерного текста в положение по умолчанию.

Угол

Изменяет угол поворота размерного текста.

Угол поворота размерного текста:

Центральная точка текста не изменяется. При перемещении текста и регенерации размера заданный угол поворота поддерживается неизменным. Значение угла 0 градусов ориентирует текст по умолчанию.


РЗМСТИЛЬ Команда

Р Команды
Р Команды
РЗМСТИЛЬ Команда
Понятия Процедуры Команды

Создание и модификация размерных стилей

Панель "Стили":

Меню "Формат": "Размерные стили"

Меню "Размеры": "Стиль"

Ввод команды: рзмстиль

Открывается диалоговое окно "Диспетчер размерных стилей".

Если в ответ на подсказку "Команда" ввести -рзмстиль, параметры отобразятся в командной строке.

Темы:

  • Диспетчер размерных стилей
  • Диалоговое окно "Создание нового размерного стиля"
  • Диалоговые окна работы с размерными стилями
  • Диалоговое окно "Сравнение размерных стилей"
  • РЗМСТИЛЬ вариант для командной строки


Диспетчер размерных стилей

Р Команды
Р Команды
Диспетчер размерных стилей
Понятия Процедуры Команды

Панель "Стили":

Меню "Формат": "Размерные стили"

Меню "Размеры": "Стиль"

Ввод команды: рзмстиль

Здесь создаются новые стили, устанавливается текущий стиль, модифицируются имеющиеся стили, задаются переопределения текущих размерных стилей и выполняется сравнение стилей.

Текущий размерный стиль

Отображает имя текущего размерного стиля. По умолчанию применяется размерный стиль СТАНДАРТ. Текущий стиль применяется к наносимым размерам.

Стили

Вывод списка размерных стилей чертежа. Текущий стиль выделен. Нажатием правой кнопкой мыши в списке вызывается контекстное меню, с помощью которого можно устанавливать текущий стиль, переименовывать и удалять стили. Стиль, который является текущим или используется в текущем чертеже, невозможно удалить.

Имеющиеся в чертеже размерные стили определяют внешний вид размеров. Для установки стиля текущим выбрать его в списке и нажать кнопку "Установить".

Если не включена опция "Исключить стили внешних ссылок", размерные стили отображаются в чертежах, на которые есть внешние ссылки, в формате, используемом для всех именованных объектов, на которые имеются внешние ссылки. (См. Коротко о внешних ссылках в Руководстве пользователя.) Хотя такие стили нельзя изменять, переименовывать и делать текущими, на их основе можно создавать новые стили.

Вывести в список

Управление отображением стилей в списке "Стили". Если необходимо, чтобы на чертеже отображались все размерные стили, следует выбрать "Все стили". Если необходимо, чтобы на чертеже отображались размерные стили только нанесенных размеров, следует выбрать "Задействованные стили".

Исключить стили внешних ссылок

Если эта опция включена, в чертежах, на которые есть внешние ссылки, не используются стили из списка "Стили".

Образец

Графическое представление стиля, выбранного в списке "Стили".

Описание

Описание стиля, выбранного в списке "Стили", по отношению к текущему стилю. Если описание не помещается в окне, необходимо нажать на панели и с помощью клавиш со стрелкой прокрутить текст вниз.

Установить

Установка текущим размерного стиля, выделенного в списке "Стили". Текущий стиль применяется к наносимым размерам.

Создать

Отображает диалоговое окно "Создание нового размерного стиля", в котором можно задать параметры нового размерного стиля.

Изменить

Отображает диалоговое окно "Изменение размерного стиля", в котором производится модификация параметров стиля. Опции этого окна аналогичны опциям диалогового окна "Новый размерный стиль".

Переопределить

Отображает диалоговое окно "Переопределение текущего стиля", в котором можно временно переопределить параметры стиля. Опции этого окна аналогичны опциям диалогового окна "Новый размерный стиль". Переопределения отображаются в списке "Стили" как стили с несохраненными изменениями.

Сравнить

Отображает диалоговое окно "Сравнение размерных стилей", в котором можно сравнить два размерных стиля или вывести список всех свойств одного размерного стиля.


Диалоговое окно "Создание нового размерного стиля"

Р Команды
Р Команды
Диалоговое окно "Создание нового размерного стиля"
Понятия Процедуры Команды

Панель "Стили":

Меню "Формат": "Размерные стили"

Меню "Размеры": "Стиль"

Ввод команды: рзмстиль

Здесь указывается имя нового размерного стиля, базовый стиль для его создания и типы размеров, к которым он должен применяться.

Имя нового стиля

Присвоение размерному стилю нового имени.

На основе

Стиль, на основе которого создается новый стиль. Использование существующего стиля в качестве основы позволяет создать новый стиль с минимумом усилий, т.к. на практике большинство стилей отличается друг от друга всего лишь несколькими установками переменных.

Размеры

Создание размерного субстиля, применимого только к отдельным типам размеров. Например, можно создать модификацию размерного стиля СТАНДАРТ, используемую только для размеров диаметра.

Далее

Отображает диалоговое окно "Новый размерный стиль", в котором можно задать свойства нового размерного стиля.


Диалоговые окна работы с размерными стилями

Р Команды
Р Команды
Диалоговые окна работы с размерными стилями
Понятия Процедуры Команды

Панель "Стили":

Меню "Формат": "Размерные стили"

Меню "Размеры": "Стиль"

Ввод команды: рзмстиль

Здесь задаются свойства размерных стилей. После того, как пользователь нажал кнопку "Далее", в окне "Создание нового размерного стиля" открывается диалоговое окно "Новый размерный стиль". В нем полностью описывается создаваемый стиль. При открытии поля этого окна заполнены значениями, действующими для стиля, который был выбран в качестве основы.

При нажатии в диспетчере размерных стилей кнопок "Изменить" или "Переопределить" открывается соответственно диалоговое окно "Изменение размерного стиля" или "Переопределение текущего стиля". По содержанию они идентичны окну "Новый размерный стиль"; отличие заключается лишь в том, что здесь выполняется не создание нового стиля, а изменение существующих.

Изображение модели на каждой вкладке показывает результат применения опций.

Диалоговые окна работы с размерными стилями содержат следующие вкладки:

  • Линии
  • Символы и стрелки
  • Текст
  • Вписать
  • Основные единицы
  • Альтернативные единицы
  • Допуски

Вкладка "Линии"

На вкладке задаются формат и свойства размерных линий, выносных линий, стрелок и маркеров центра.

Размерные линии

Свойства размерных линий.

Цвет

Отображает и устанавливает цвет размерных линий. При выборе значения "Выбор цвета" (оно находится в конце списка) открывается диалоговое окно "Выбор цвета". Можно также ввести название цвета или его номер. (Системная переменная SNAPSTYL)

Цвет можно выбрать по его номеру из существующих 255 индексов цвета AutoCAD (ИЦА), из всей палитры цветов или с помощью альбомов цветов.

Тип линий

Установка типа размерных линий. (Системная переменная DIMLTYPE)

Вес линий

Установка веса для размерных линий. (Системная переменная DIMLWD)

Удлинение за выносные

Если в качестве размерных стрелок используются засечки, с помощью данной опции можно указать, на какое расстояние размерная линия должна продолжаться за пределами выносных линий. (Системная переменная DIMDLE)

Шаг в базовых размерах

Задает расстояние между размерными линиями в размерах от общей базы. Расстояние вводится в текстовом поле. Подробнее о базовых размерах см. описание команды РЗМБАЗОВЫЙ. (Системная переменная DIMDLI.)

Подавить

Подавляет вывод размерных линий, если они выходят за пределы выносных линий. Опция "Разм линия 1" действует на первую размерную линию; опция "Разм линия 2" - на вторую. (Системные переменные DIMSD1 и DIMSD2)

Выносные линии

Свойства выносных линий.

Цвет

Устанавливает цвет выносных линий. При выборе значения "Выбор цвета" (оно находится в конце списка) открывается диалоговое окно "Выбор цвета". Можно также ввести название цвета или его номер. (Системная переменная DIMCLRE.)

Цвет можно выбрать по его номеру из существующих 255 индексов цвета AutoCAD (ИЦА), из всей палитры цветов или с помощью альбомов цветов.

Тип выносной линии 1

Установка типа первой выносной линии. (Системная переменная DIMLTEX1)

Тип выносной линии 2

Установка типа второй выносной линии. (Системная переменная DIMLTEX2)

Вес линий

Установка веса для выносных линий. (Системная переменная DIMLWE)

Подавить

Подавляет вывод выносных линий. Опция "Вын линия 1" действует на первую выносную линию; опция "Вын линия 2" - на вторую. (Системные переменные DIMSE1 и DIMSE2)

Удлинение за размерные

Указывает расстояние, на которое выносные линии должны выступать за размерную. (Системная переменная DIMEXE)

Отступ от объекта

Указывает расстояние, на которое выносные линии отступают от точек объекта. (Системная переменная DIMEXO)

Выносные линии фиксированной длины

Активизирует функцию выносных линий фиксированной длины. (Системная переменная DIMFXLON)

Линейные

Установка полной длины выносных линий от размерной линии до исходной точки размера. (Системная переменная DIMFXL)

Образец

Отображает на экран образцы размерных изображений, отображающих результат изменения параметров размерного стиля.

Вкладка "Символы и стрелки"

На вкладке задаются формат и положение стрелок, меток центра, символов длины дуги и ломаных линий размера радиуса.

Стрелки

Управляет видом размерных стрелок.

Первая

Стрелка для первой размерной линии. При изменении типа первой стрелки автоматически изменяется и тип второй. (Системная переменная DIMBLK1)

Для задания пользовательской стрелки следует выбрать "Пользовательская". Открывается диалоговое окно "Выбор блока пользовательской стрелки". В нем выбирается один из имеющихся в чертеже блоков. Блок должен существовать в чертеже.

Вторая

Стрелка для второй размерной линии. (Системная переменная DIMBLK2)

Для задания пользовательской стрелки следует выбрать "Пользовательская". Открывается диалоговое окно "Выбор блока пользовательской стрелки". В нем выбирается один из имеющихся в чертеже блоков. Блок должен существовать в чертеже.

Выноска

Задание формата стрелки для выноски. (Системная переменная DIMLDRBLK)

Для задания пользовательской стрелки следует выбрать "Пользовательская". Открывается диалоговое окно "Выбор блока пользовательской стрелки". В нем выбирается один из имеющихся в чертеже блоков. Блок должен существовать в чертеже.

Величина

Отображает и задает размер стрелок. (Системная переменная DIMASZ)

Метки центра

Управляет простановкой маркеров центра и центровых линий при нанесении диаметров и радиусов. С маркерами центра и центровыми линиями работают команды РЗМЦЕНТР, РЗМДИАМЕТР и РЗМРАДИУС. В командах РЗМДИАМЕТР и РЗМРАДИУС можно нарисовать маркеры центра только в том случае, если размерная линия размещается за границами круга или дуги.

Нет

Не создает ни маркера центра, ни центровых линий. В системной переменной DIMCEN данное значение сохраняется равным 0.

Метка

Создает маркер центра. Величина маркера центра запоминается в переменной DIMCEN в виде положительного числа.

Линия

Создает центровые линии. Размер центровых линий запоминается в переменной DIMCEN в виде отрицательного числа.

Размер

Отображает и задает размер маркера центра или центровой линии. (Системная переменная DIMCEN)

Символ длины дуги

Управление отображением символа дуги в размере длины дуги. (Системная переменная DIMARCSYM)

Перед текстом размера

Вставка символов длины дуги перед текстом размера. (Системная переменная DIMARCSYM)

Над текстом размера

Вставка символов длины дуги над текстом размера. (Системная переменная DIMARCSYM)

Нет

Запрет отображения символов длины дуги. (Системная переменная DIMARCSYM)

Ломаная размера радиуса

Управление отображением ломаных линий (зигзагов) размеров радиуса. Ломаные линии размеров радиуса строятся в случаях, когда центр расположен за пределами страницы.

Угол излома

Определяет угол пересекающегося сегмента размерной линии, представляющей собой ломаную линию размера радиуса. (Системная переменная DIMJOGANG)

Образец

Отображает на экран образцы размерных изображений, отображающих результат изменения параметров размерного стиля.

Вкладка "Текст"

Здесь задают формат, размещение и выравнивание размерных текстов.

Свойства текста

Управление форматом и высотой размерных текстов.

Текстовый стиль

Отображает и устанавливает текущий стиль размерного текста. Стиль выбирается из списка "Стиль". Для создания и модификации текстовых стилей служит расположенная справа от списка кнопка с многоточием. (Системная переменная DIMTXSTY)

Текстовый стиль (кнопка)

Отображает диалоговое окно "Текстовые стили", в котором можно создать новый стиль или отредактировать существующий.

Цвет текста

Устанавливает цвет размерного текста. При выборе значения "Выбор цвета" (оно находится в конце списка) открывается диалоговое окно "Выбор цвета". Также можно ввести название цвета или его номер. (Системная переменная DIMCLRT)

Цвет можно выбрать по его номеру из существующих 255 индексов цвета AutoCAD (ИЦА), из всей палитры цветов или с помощью альбомов цветов.

Цвет фона

Задание цвета фона текста в размерах. При выборе значения "Выбор цвета" (оно находится в конце списка) открывается диалоговое окно "Выбор цвета". Также можно ввести название цвета или его номер. (Системные переменные DIMTFILL и DIMTFILLCLR)

Цвет можно выбрать по его номеру из существующих 255 индексов цвета AutoCAD (ИЦА), из всей палитры цветов или с помощью альбомов цветов.

Высота текста

Устанавливает текущую высоту размерного текста. Ввести значение в текстовом поле. Если в текстовом стиле задана фиксированная высота (т.е. значение высоты в стиле не равно 0), то введенная здесь высота игнорируется. Поэтому, чтобы пользователь имел возможность изменять высоту с помощью вкладки "Текст", высота в описании используемого текстового стиля должна быть равна 0. (Системная переменная DIMTXT)

Масштаб дробей

Задает масштаб дробных значений относительно остального текста. Эта опция доступна, только если для параметра "Формат единиц" вкладки "Основные единицы" задано значение "Дробные". Высота дробных текстов определяется путем умножения высоты обычного текста на данный коэффициент. (Системная переменная DIMTFAC)

Текст в рамке

Когда выбран этот параметр, размерный текст заключается в рамку. При включении данной опции знак переменной DIMGAP меняется на отрицательный.

Размещение текста

Задание размещения и выравнивания размерных текстов.

Вертикальный

Управляет положением размерного текста по вертикали относительно размерной линии. (Системная переменная DIMTAD)

Варианты выравнивания по вертикали:

  • По центру: Расположение размерного текста по центру между выносными линиями.
  • Над линией: Расположение размерного текста над размерной линией. Расстояние от размерной линии до базовой линии нижней границы текста равно текущему значению зазора текста. См. опцию "Отступ от размерной линии".
  • Снаружи: Расположение размерного текста рядом с размерной линией со стороны, наиболее удаленной от первой определяющей точки.
  • JIS: Размещение размерного текста согласно требованиям промышленных стандартов Японии JIS (Japanese Industrial Standards).

Горизонтальный

Управление положением размерного текста по горизонтали вдоль размерной линии относительно выносных линий. (Системная переменная DIMJUST)

Варианты выравнивания по горизонтали:

  • По центру: Расположение размерного текста по центру между выносными линиями вдоль размерной линии.
  • У первой выносной: Расположение текста слева у первой выносной линии. Расстояние от выносной линии до текста равно сумме удвоенной величины размерной стрелки и текстового зазора. См. разделы "Стрелки" и "Отступ от размерной линии".
  • У второй выносной: Расположение текста справа у второй выносной линии. Расстояние от выносной линии до текста равно сумме удвоенной величины размерной стрелки и текстового зазора. См. разделы "Стрелки" и "Отступ от размерной линии".

  • Над первой выносной: Расположение текста над или вдоль первой выносной линии.
  • Над второй выносной: Расположение текста над или вдоль второй выносной линии.

Отступ от размерной линии

Устанавливает текущий зазор текста ширину пустого пространства вокруг текста, расположенного в разрыве размерной линии.

Также это значение используется как минимальная длина фрагментов разорванной размерной линии.

Текст располагается между выносными линиями только при условии, что длины этих фрагментов не будут меньше величины зазора текста. Если текст расположен над размерной линией или под ней, он помещается между выносными линиями, только если там достаточно места для размерных стрелок и размерного текста, отстоящих друг от друга на величину зазора текста. (Системная переменная DIMGAP)

Ориентация текста

Управляет ориентацией размерного текста между размерными линиями и вне их. (Системные переменные DIMTIH и DIMTOH)

Горизонтальный

Размещает текст горизонтально.

Вдоль размерной линии

Текст размещается вдоль размерной линии.

Согласно ISO

Размерный текст располагается вдоль размерной линии, если находится внутри выносных линий, или горизонтально, если находится снаружи.

Образец

Отображает на экран образцы размерных изображений, отображающих результат изменения параметров размерного стиля.

Вкладка "Размещение"

Управление положением размерного текста, стрелок, выносок и размерной линии.

Опции размещения

Управляет размещением текста и размерных стрелок между выносными линиями или вне их, в зависимости от расстояния между выносными линиями.

Если места достаточно, текст и стрелки располагаются между выносными линиями. В противном случае подбирается оптимальный вариант размещения. (Системные переменные DIMATFIT, DIMTIX и DIMSOXD)

Либо текст, либо стрелки (оптимально)

Перемещает либо текст, либо стрелки за пределы выносных линий в зависимости от того, какое расположение наиболее оптимально (системная переменная DIMATFIT).

  • Если имеется достаточно места, то текст и стрелки размещаются между выносными линиями. В противном случае либо текст, либо стрелки перемещаются в зависимости от того, какое расположение наиболее оптимально.
  • Если места достаточно только для текста, то размерная надпись наносится между выносными линиями, а стрелки располагаются снаружи.
  • Если места достаточно только для стрелок, то между выносными линиями располагаются только стрелки, а текст выносится наружу.
  • Если ни для стрелок, ни для текста места недостаточно, то и текст, и стрелки размещаются вне выносных линий.

Стрелки

Сначала перемещает стрелки за пределы выносных линий, затем текст (системная переменная DIMATFIT).

  • Если имеется достаточно места, то текст и стрелки размещаются между выносными линиями.
  • Если места достаточно только для стрелок, то между выносными линиями располагаются только стрелки, а текст выносится наружу.
  • Если для стрелок места недостаточно, то и текст, и стрелки размещаются вне выносных линий.

Текст

Сначала перемещает текст за пределы выносных линий, затем стрелки (системная переменная DIMATFIT).

  • Если имеется достаточно места, текст и стрелки размещаются между выносными линиями.
  • Если места достаточно только для текста, то размерная надпись наносится между выносными линиями, а стрелки располагает снаружи.
  • Если для текста места недостаточно, то и текст, и стрелки размещаются вне выносных линий.

Текст и стрелки

Если для текста и стрелок места недостаточно, то и текст, и стрелки располагаются вне выносных линий (системная переменная DIMATFIT).

Текст всегда между выносными

Текст всегда размещается между выносными линиями. (Системная переменная DIMTIX)

Подавить стрелки, если они не умещаются между выносными линиями

Если для стрелок недостаточно места между выносными линиями, они подавляются. (Системная переменная DIMSOXD)

Размещение текста

Описывает поведение программы при перемещении размерного текста с позиции по умолчанию (заданной размерным стилем). (Системная переменная DIMTMOVE)

Перемещать размерную линию

Если выбрана эта опция, размерная линия перемещается при перемещении размерного текста. (Системная переменная DIMTMOVE)

Строить выноску

Если выбрана эта опция, размерные линии не перемещаются при перемещении размерного текста. Если текст удален от размерной линии, строится выноска, соединяющая их. Выноска не строится, если текст находится слишком близко к размерной линии. (Системная переменная DIMTMOVE)

Не строить выноску

Если выбрана эта опция, размерные линии не перемещаются при перемещении размерного текста. Никаких соединений текста и размерной линии не производится. (Системная переменная DIMTMOVE)

Масштаб размерных элементов

Задает глобальный масштабный коэффициент или масштабирование относительно пространства листа.

Глобальный масштаб

Коэффициент масштаба для всех параметров размерного стиля, задающих размеры, расстояния и отступы, включая высоту текста и величину стрелок. На измеренные значения размеров этот параметр не влияет. (Системная переменная DIMSCALE)

Масштаб размеров по листу

Задает масштабный коэффициент, основанный на отношении единиц измерения на текущем видовом экране пространства модели и в пространстве листа. (Системная переменная DIMSCALE)

При работе в пространстве листа, но вне видового экрана пространства модели или при значении переменной TILEMODE, равном 1, используется значение масштабного коэффициента, по умолчанию равное 1,0, или значение системной переменной DIMSCALE.

Подгонка элементов

Дополнительные опции для размещения размерного текста.

"Размещение текста вручную"

Если данная опция включена, игнорируются все режимы размещения по горизонтали и размер помещается в точку, указанную в ответ на запрос "Положение размерной линии". (Системная переменная DIMUPT)

Размерная линия между выносными

Размерная линия рисуется между образмеренными точками, даже если размерные стрелки размещаются вне этих точек. (Системная переменная DIMTOFL)

Образец

Отображает на экран образцы размерных изображений, отображающих результат изменения параметров размерного стиля.

Вкладка "Основные единицы"

Установка формата и точности основных единиц, а также префиксов и суффиксов размерного текста.

Линейные размеры

Формат и точность для линейных размеров.

Формат единиц

Устанавливает формат единиц для всех типов размеров, кроме угловых. (Системная переменная DIMLUNIT)

Относительные размеры чисел в дробных надписях основываются на значении переменной DIMTFAC (так же, как и для размерных допусков).

Точность

Отображает и определяет число десятичных знаков в размерном тексте. (Системная переменная DIMDEC)

Формат дробей

Задает формат для дробных текстов. (Системная переменная DIMFRAC)

Десятичный разделитель

Задает разделитель для размеров, выраженных в десятичных единицах. (Системная переменная DIMDSEP)

Округление

Устанавливает правила округления значений для всех типов размеров, кроме угловых. Если задать точность 0.25, все измеренные расстояния округляются до ближайшего значения, кратного 0.25. При вводе значения 1.0 все измеренные расстояния округляются до ближайшего целого значения. Число цифр в дробных частях расстояний зависит от точности, заданной в поле "Точность". (Системная переменная DIMRND)

Префикс

Определение префикса размерного текста. Для отображения специальных символов можно ввести их или использовать управляющие коды. Например, управляющий код %%c соответствует символу диаметра. Префикс, заданный явно, имеет приоритет перед префиксами по умолчанию, например, используемыми в диаметрах и радиусах. (Системная переменная DIMPOST)

При задании допусков префикс добавляется как к основному размеру, так и к допускам.

Для получения дополнительных сведений см. раздел Управляющие коды и специальные символы.

Суффикс

Определение префикса размерного текста. Для отображения специальных символов можно ввести их или использовать управляющие коды. Например, ввод суффикса мм приводит к результату, изображенному на чертеже. Введенный здесь суффикс имеет приоритет перед суффиксами по умолчанию. (Системная переменная DIMPOST)

При задании допусков суффикс добавляется как к основному размеру, так и к допускам.

Для получения дополнительных сведений см. раздел Управляющие коды и специальные символы.

Масштаб измерений

Задание линейных параметров масштаба. Применяется в первую очередь к чертежам, созданным в предыдущих версиях программы.

Масштаб: масштабный коэффициент для линейных размеров. Рекомендуется не изменять значение по умолчанию 1.00. Например, при вводе значения 2 для размера в 1 мм проставляется значение 2 мм. Коэффициент не оказывает влияния на угловые размеры, точность округления, положительный и отрицательный допуски. (Системная переменная DIMLFAC)

Только для размеров на листе: масштабный коэффициент единиц измерения применяется только к размерам, сформированным на видовых экранах листа. Данная установка должна оставаться неотмеченной, кроме случаев использования неассоциативных размеров. (Системная переменная DIMLFAC)

Подавление нулей

Управление подавлением ведущих и замыкающих нулей, а также нулевых значений футов и дюймов. (Системная переменная DIMZIN)

Режим подавления нулей влияет и на результаты преобразования вещественных чисел в строки, выполняемого функциями AutoLISP® rtos и angtos.

Ведущие: Подавление ведущих нулей во всех десятичных размерах. Например, 0,5000 записывается как ,5000.

Замыкающие: Подавление замыкающих нулей во всех десятичных размерах. Например, 12,5000 представляется как 12,5, а 30,0000 — как 30.

0 футов: подавление вывода значения футов в размере формата футы-дюймы, если расстояние меньше одного фута. Например, 0'-6 1/2" представляется как 6 1/2".

0 дюймов: подавление вывода значения дюймов в размере формата футы-дюймы, если расстояние равно целому числу футов. Например, 1'-0" представляется как 1'.

Угловые размеры

Отображает и устанавливает текущий формат углов для угловых размеров.

Формат единиц

Единицы измерения для угловых размеров. (Системная переменная DIMAUNIT)

Точность

Устанавливает число десятичных знаков в угловых размерах. DIMADEC - системная переменная

Подавление нулей

Управление подавлением ведущих и замыкающих нулей. (Системная переменная DIMAZIN)

Ведущие: подавление ведущих нулей во всех десятичных размерах. Например, 0,5000 записывается как ,5000.

Замыкающие: подавление замыкающих нулей во всех угловых десятичных размерах. Например, 12,5000 представляется как 12,5, а 30,0000 — как 30.

Образец

Отображает на экран образцы размерных изображений, отображающих результат изменения параметров размерного стиля.

Вкладка "Альтернативные единицы"

Задание формата и точности для альтернативных размерных единиц.

Разрешить альтернативные единицы

Разрешает использование альтернативных размерных единиц. Присвоение системной переменной DIMALT значения 1.

Альтернативные единицы

Отображает и определяет формат единиц для всех типов размеров, кроме угловых.

Формат единиц

Определение формата альтернативных единиц. (Системная переменная DIMALTU)

Относительные размеры чисел в двухэтажных надписях основываются на значении переменной DIMTFAC (так же, как и для размерных допусков).

Точность

Установка числа знаков после запятой для альтернативных единиц. (Системная переменная DIMALTD)

Коэффициент пересчета

Определение коэффициента пересчета из основных единиц в альтернативные. Например, для преобразования дюймов в миллиметры ввести 25,4. Значение не оказывает влияния на угловые размеры и не применяется для точности округления или положительных и отрицательных допусков. (Системная переменная DIMALTF)

Округление

Устанавливает правила округления значений для всех типов размеров, кроме угловых. Если задать точность 0,25, все измеренные расстояния округляются до ближайшего значения, кратного 0,25. При вводе значения 1,0 все измеренные расстояния округляются до ближайшего целого значения. Число цифр в дробных частях расстояний зависит от точности, заданной в поле "Точность". (Системная переменная DIMALTRND)

Префикс

Определение префикса альтернативного размерного текста. Для отображения специальных символов можно ввести их или использовать управляющие коды. Например, управляющий код %%c соответствует символу диаметра. (Системная переменная DIMAPOST)

Для получения дополнительных сведений см. раздел Управляющие коды и специальные символы.

Суффикс

Определение суффикса альтернативного размерного текста. Для отображения специальных символов можно ввести их или использовать управляющие коды. Например, ввод суффикса cm приводит к результату, изображенному на чертеже. Введенный здесь суффикс имеет приоритет перед суффиксами по умолчанию. (Системная переменная DIMAPOST)

Для получения дополнительной информации см. раздел Управляющие коды и специальные символы.

Подавление нулей

Управление подавлением ведущих и замыкающих нулей, а также нулевых значений футов и дюймов. (Системная переменная DIMALTZ)

Ведущие

Подавляет ведущие нули во всех десятичных размерах. Например, 0,5000 записывается как ,5000.

Замыкающие

Подавляет замыкающие нули во всех десятичных размерах. Например, 12,5000 представляется как 12,5, а 30,0000 — как 30.

0 футов

Подавляет вывод значения футов в размере формата футы-дюймы, если расстояние меньше 1 фута. Например, 0'-6 1/2" представляется как 6 1/2".

0 дюймов

Подавляет вывод значения дюймов в размере формата футы-дюймы, если расстояние равно целому числу футов. Например, 1'-0" представляется как 1'.

Размещение

Управление положением альтернативных единиц в размерном тексте. (Системная переменная DIMAPOST)

За основным значением

Значение в альтернативных единицах записывается в размерном тексте сразу же за значением в основных.

Под основным значением

Значение в альтернативных единицах записывается в размерном тексте под значением в основных.

Образец

Отображает на экран образцы размерных изображений, отображающих результат изменения параметров размерного стиля.

Вкладка "Допуски"

Управление отображением и форматом допусков в размерном тексте.

Формат допусков

Управление форматом допусков.

Метод

Способ определения допусков. (Системная переменная DIMTOL)

  • Нет: Отключение показа допусков. Переменной DIMTOL присваивается значение 0.
  • Симметрично: Наносятся два предельных отклонения, с помощью которых выводится размерный текст с одинаковыми верхним и нижним предельными отклонениями. Допуск отделяется от размера символом "±". Значение вводится в поле "Максимальное значение". Системной переменной DIMTOL присваивается значение 1. Системной переменной DIMLIM присваивается значение 0.

  • Отклонения: Нанесение двух предельных отклонений. Размерный текст выводится с разными верхним и нижним предельными отклонениями. Знак плюс (+) ставится перед значением допустимого отклонения, вводимым в поле "Максимальное значение", а знак минус (-) - перед значением допустимого отклонения, которое вводится в поле "Минимальное значение". Системной переменнойDIMTOL присваивается значение 1. Системной переменной DIMLIM присваивается значение 0.

  • Предельные размеры: Вывод размерного текста в виде предельных размеров. Максимальный предельный размер располагается над минимальным. Наибольший предельный размер получается прибавлением к номинальному размеру верхнего предельного отклонения; наименьший — вычитанием из номинального размера нижнего предельного отклонения. Переменной DIMTOL присваивается значение 0. Переменной DIMLIM присваивается значение 1.

  • Номинальный: вывод размерного текста в виде номинального размера, заключенного в рамку. Величина зазора между размерным текстом и рамкой хранится в переменной DIMGAP в виде отрицательного числа.

Точность

Устанавливает число десятичных знаков. (Системная переменная DIMTDEC)

Максимальное значение

Устанавливает значение верхнего предельного отклонения. При включении опции "Симметрично" обоим отклонениям присваивается это значение. (Системная переменная DIMTP)

Минимальное значение

Устанавливает значение нижнего предельного отклонения. (Системная переменная DIMTM)

Масштаб высоты

Устанавливает текущую высоту текста для отклонений. Вычисленное отношение высоты текста отклонения к высоте номинального размера сохраняется в переменной DIMTFAC.

Выравнивание

Управляет выравниванием текстов отклонений.

  • Вверх: выравнивание отклонения и номинального размера по верху. При выборе этой опции системной переменной DIMTOLJ присваивается значение 2.

  • Посередине: выравнивание отклонения и номинального размера по середине размерного текста. При выборе этой опции системной переменной DIMTOLJ присваивается значение 1.

  • Вниз: выравнивание отклонения и номинального размера по низу. При выборе этой опции системной переменной DIMTOLJ присваивается значение 0.

Подавление нулей

Управление подавлением ведущих и замыкающих нулей, а также нулевых значений футов и дюймов. (Системная переменная DIMTZIN)

Режим подавления нулей влияет и на результаты преобразования вещественных чисел в строки, выполняемого функциями AutoLISP®rtos и angtos.

Ведущие

Подавляет ведущие нули во всех десятичных размерах. Например, 0,5000 записывается как ,5000.

Замыкающие

Подавляет замыкающие нули во всех десятичных размерах. Например, 12,5000 представляется как 12,5, а 30,0000 — как 30.

0 футов

Подавляет вывод значения футов в размере формата футы-дюймы, если расстояние меньше 1 фута. Например, 0'-6 1/2" представляется как 6 1/2".

0 дюймов

Подавляет вывод значения дюймов в размере формата футы-дюймы, если расстояние равно целому числу футов. Например, 1'-0" представляется как 1'.

Допуски для альтернативных единиц

Форматирование допусков альтернативных единиц.

Точность

Отображает и определяет число десятичных знаков после запятой. (Системная переменная DIMALTTD)

Подавление нулей

Управление подавлением ведущих и замыкающих нулей, а также нулевых значений футов и дюймов. (Системная переменная DIMALTTZ)

Ведущие

Подавляет ведущие нули во всех десятичных размерах. Например, 0,5000 записывается как ,5000.

Замыкающие

Подавляет замыкающие нули во всех десятичных размерах. Например, 12,5000 представляется как 12,5, а 30,0000 — как 30.

0 футов

Подавляет вывод значения футов в размере формата футы-дюймы, если расстояние меньше 1 фута. Например, 0'-6 1/2" представляется как 6 1/2".

0 дюймов

Подавляет вывод значения дюймов в размере формата футы-дюймы, если расстояние равно целому числу футов. Например, 1'-0" представляется как 1'.

Образец

Отображает на экран образцы размерных изображений, отображающих результат изменения параметров размерного стиля.


Диалоговое окно "Сравнение размерных стилей"

Р Команды
Р Команды
Диалоговое окно "Сравнение размерных стилей"
Понятия Процедуры Команды

Панель "Стили":

Меню "Формат": "Размерные стили"

Меню "Размеры": "Стиль"

Ввод команды: рзмстиль

Окно используется для сравнения двух размерных стилей или просмотра перечня всех свойств стиля. Результаты сравнения можно скопировать в буфер обмена, а затем в любое другое приложение MicrosoftWindows.

Сравнить

Выбор первого размерного стиля для сравнения.

Со стилем

Выбор второго размерного стиля для сравнения. Если в качестве второго стиля выбрать <нет> или тот же стиль, что и первый, отобразятся все свойства этого размерного стиля.

После сравнения выводятся следующие данные о несовпадающих свойствах:

  • Описание свойства
  • Размерная переменная, задающая это свойство
  • Значения системных переменных для свойств, различающихся для сравниваемых размерных стилей

Результат

Отображает результат сравнения размерных стилей. При сравнении двух стилей отображаются различающиеся свойства. Если в качестве второго стиля выбрать <нет> или тот же стиль, что и первый, отобразятся все свойства этого размерного стиля.

Копировать в буфер (кнопка)

Копирование результатов сравнения в буфер обмена. Скопированные данные можно вставлять в другие приложения Windows, такие как текстовые редакторы и электронные таблицы.


РЗМСТИЛЬ вариант для командной строки

Р Команды
Р Команды
РЗМСТИЛЬ вариант для командной строки
Понятия Процедуры Команды

Если в ответ на подсказку "Команда" ввести -рзмстиль, будет вызван вариант команды РЗМСТИЛЬ, при котором в командной строке выводятся подсказки:

Текущий размерный стиль: <текущий>

Опция для размерного стиля

[Сохранить/Восстановить/СТатус/Переменные/Применить/?] <Восстановить>: Задать опцию или нажать клавишу ENTER

Сохранить

Сохраняет в размерном стиле текущие значения размерных переменных.

Имя нового размерного стиля или [?]: Ввести имя или ?

Имя

Сохраняет текущие значения размерных переменных в размерном стиле с заданным именем. Новый размерный стиль становится текущим.

Если ввести имя существующего размерного стиля, будут выданы следующие запросы:

Это имя уже используется; переопределить его? <N>: Ввести y или нажать клавишу ENTER

Если ввести y, ассоциативные размеры, нанесенные с применением данного стиля, регенерируются.

Если ввести ~имя_стиля, будут показаны результаты сравнения текущих размерных установок и стиля с заданным именем. Отображаются только различающиеся параметры. Значение текущего параметра выводится в первом столбце, значение сравниваемого параметра - во втором. После вывода списка различий выдается предыдущий запрос.

?—Вывод списка размерных стилей

Выводит список именованных размерных стилей текущего чертежа.

Ввести размерные стили, которые следует внести в список <*>: Ввести имя, часть имени с групповыми символами или нажать клавишу ENTER для вывода списка всех размерных стилей

После вывода списка имен размерных стилей выдается предыдущий запрос.

Восстановить

Устанавливает значения размерных переменных согласно указанному размерному стилю.

Ввести имя размерного стиля, [?] или <выбрать размер>:Ввести имя, ввести знак ? или нажать клавишу ENTER для выбора размера

Имя

Устанавливает указанный стиль текущим.

Если в ответ на подсказку ввести тильду (~) и указать после нее имя стиля, который необходимо сохранить, будут показаны результаты сравнения текущих размерных установок и стиля с заданным именем. Отображаются только различающиеся параметры. Значение текущего параметра выводится в первом столбце, значение сравниваемого параметра - во втором. После вывода списка различий выдается предыдущий запрос.

?—Вывод списка размерных стилей

Выводит список именованных размерных стилей текущего чертежа.

Ввести размерные стили, которые следует внести в список <*>: Ввести список имен или нажать клавишу ENTER

После вывода списка размерных стилей выдается предыдущий запрос.

Выбрать размер

Выбранным размерам назначается текущий размерный стиль.

Выбрать размер:

Статус

Выводит список текущих значений всех размерных переменных. После вывода списка переменных команда РЗМСТИЛЬ завершается.

Переменные

Выводит список значений размерных переменных указанного стиля, но не изменяет текущие установки.

Ввести имя размерного стиля, [?] или <выбрать размер>: Ввести имя, знак ? или нажать клавишу ENTER для выбора размеров

Имя

Вывод списка значений размерных переменных для указанного стиля. После вывода списка переменных команда РЗМСТИЛЬ завершается.

Если в ответ на подсказку ввести тильду (~) и указать после нее имя стиля, будут показаны результаты сравнения текущих размерных установок и стиля с заданным именем. Отображаются только различающиеся параметры. Значение текущего параметра выводится в первом столбце, значение сравниваемого параметра - во втором. После вывода списка различий выдается предыдущий запрос.

?—Вывод списка размерных стилей

Выводит список именованных размерных стилей текущего чертежа.

Ввести размерные стили, которые следует внести в список <*>: Ввести список имен или нажать клавишу ENTER

После вывода списка размерных стилей выдается предыдущий запрос.

Выбрать размер

Выводит имя размерного стиля и список всех переопределений размерных установок для выбранного размерного объекта.

Выбрать размер:

Применить

Обновляет выбранные размерные объекты в соответствии с текущим размерным стилем и действующими переопределениями.

Выбрать объекты: Выбрать размерные объекты любым способом

Интервал между размерными линиями существующих базовых размеров не обновляется (см. описание системной переменной DIMDLI); текст пояснений на выносках не обновляется.

?—Вывод списка размерных стилей

Выводит список именованных размерных стилей текущего чертежа.

Ввести размерные стили, которые следует внести в список <*>: Ввести имя, часть имени с групповыми символами или нажать клавишу ENTER


РЗМУГЛОВОЙ Команда

Р Команды
Р Команды
РЗМУГЛОВОЙ Команда
Понятия Процедуры Команды

Нанесение угловых размеров

Панель "Размеры":

Меню "Размеры": "Угловой"

Ввод команды: рзмугловой

Выбрать дугу, круг, отрезок или <задать вершину>: Выбрать дугу, круг или отрезок или нажать клавишу ENTER для создания углового размера путем определения трех точек

После задания угла для нанесения размера появляется следующий запрос:

Положение размерной дуги или [МТекст/Текст/Угол]:

Выбор дуги

Точки выбранной дуги берутся в качестве определяющих точек размера. Вершиной дуги считается ее центр. Точками начала выносных линий считаются ее конечные точки.

Размерная линия представляет собой дугу между выносными линиями. Выносные линии проводятся от указанных конечных точек до пересечения с размерной линией.

Выбор круга

Точка указания (1) берется за начало первой выносной линии. Вершиной угла считается центр круга.

Вторая конечная точка угла: Указать точку (2)

Указанная точка становится началом второй выносной линии. Она может и не лежать на окружности.

Выбор отрезка

Угол определяется по двум отрезкам.

Второй отрезок:

Программа определяет угол, используя выбранные отрезки как стороны угла, а точку их пересечения как его вершину. Размерная линия охватывает наименьший угол между отрезками. Если размерная дуга не пересекается с используемыми для нанесения размера отрезками, один или оба отрезка удлиняются с помощью выносных линий. Стягиваемый угол всегда меньше 180 градусов.

Нанесение по трем точкам

Размер строится по трем указанным точкам.

Вершина угла: Указать точку (1)

Первая конечная точка угла: Указать точку (2)

Вторая конечная точка угла: Указать точку (3)

Вершина угла может совпадать с одной из его конечных точек. Выносные линии (если они наносятся) проводятся от указанных конечных точек угла.

Размерная линия представляет собой дугу между выносными линиями. Выносные линии проводятся от указанных конечных точек до пересечения с размерной линией.

Положение размерной дуги

Указывается точка, через которую проводится размерная линия и которая задает направление выносных линий. После определения положения команда РЗМУГЛОВОЙ завершается.

МТекст

Запуск редактора, используемого в месте редактирования, с помощью которого можно редактировать размерный текст. Если текст должен сопровождаться префиксом или суффиксом, их следует ввести соответственно перед полученным значением размера или после него. Для задания специальных символов можно использовать управляющие коды и Unicode-последовательности. См. раздел Управляющие коды и специальные символы.

Для того, чтобы изменить или удалить полученное значение размера, нужно удалить текст, ввести новый текст и нажать "OK". Если в размерном стиле отключены альтернативные единицы, можно задать режим их использования явным образом с помощью квадратных скобок ([ ]). Подробные сведения о форматировании размерного текста см. Методы редактирования в Руководстве пользователя.

Внешний вид размерного текста определяется текущим размерным стилем.

Текст

Предоставляет возможность отредактировать размерный текст в командной строке. Полученное значение размера отображается в угловых скобках.

Размерный текст <текущий>:

Ввести размерный текст или нажать клавишу ENTER для принятия полученного значения размера. Для того, чтобы учесть полученное значение размера, необходимо записать его в угловых скобках (< >). Если в размерном стиле отключены альтернативные единицы, их можно отобразить, заключив в квадратные скобки ([ ]).

Свойства размерного текста задаются на вкладке "Текст" диалоговых окон создания, редактирования и переопределения размерных стилей.

Угол

Изменяет угол поворота размерного текста.

Угол поворота размерного текста:

Ввести угол. Например, для поворота текста на 45 градусов ввести 45.


РЗМЦЕНТР Команда

Р Команды
Р Команды
РЗМЦЕНТР Команда
Понятия Процедуры Команды

Нанесение маркеров центра или центровых линий для кругов и дуг

Панель "Размеры":

Меню "Размеры": "Маркер центра"

Ввод команды: рзмцентр

Выбрать дугу или круг: Выбрать объекты любым способом

Выбор типа наносимого объекта (маркер центра или осевые линии) и задание его величины производится в размерном стиле. См. РЗМСТИЛЬ. Кроме того, параметрами маркеров центра можно управлять с помощью переменной DIMCEN.


РЛИСТ Команда

Р Команды
Р Команды
РЛИСТ Команда
Понятия Процедуры Команды

Создание и изменение вкладок разметок листа в чертеже

Панель разметок листа:

Меню "Вставка": "Разметка листа"

Ввод команды: рлист

Задайте опцию для разметки листа [Копировать/Удалить/Новый/Шаблон/Переименовать/Сохранить как/усТановить/?] <установить>:

Примечание Большинство опций команды доступно при нажатии правой кнопки мыши на ярлыке вкладки разметки листа.

Копировать

Копирование разметок листов. Если имя не задано, то каждой новой копии присваивается имя исходной разметки листа с номером в круглых скобках, увеличивающимся при очередном копировании на единицу. Новая разметка листа вставляется непосредственно перед копируемой.

Какую разметку листа скопировать <текущий>:

Имя для копии разметки листа <по умолчанию>:

Удалить

Удаление разметок листов. По умолчанию предлагается разметка листа, которая была активной последней.

Какую разметку листа удалить <текущая>:

К вкладке «Модель» такая операция неприменима. Удаление объектов с вкладки «Модель» производится с помощью команды СТЕРЕТЬ.

Новый

Создание новых разметок листов. В одном чертеже можно создать до 255 разметок листов.

Имя новой разметки листа: <Рлист#>:

Имя разметки листа должно быть уникальным. Оно может быть длиной до 255 символов, регистр букв значения не имеет. На ярлыке вкладки отображаются только первые 31 символ имени.

Шаблон

Создание новой разметки листа на основе имеющегося шаблона (DWT), чертежа (DWG) или файла графического обмена (DXF). Если для системной переменной FILEDIA установлено значение 1, то отобразится стандартное диалоговое окно выбора файлов, в котором следует указать файл DWT, DWG или DXF. После того, как файл выбран, отобразится диалоговое окно "Вставка разметок лиса", где будут перечислены разметки, сохраненные в выбранном файле. После выбора разметки листа она (вместе со всеми графическими объектами) вставляется в текущий чертеж.

Переименовать

Переименование разметки листа. По умолчанию предлагается переименовать разметку листа, которая была активной последней.

Какую разметку листа переименовать <текущий>:

Новое имя разметки листа <текущее>:

Имя разметки листа должно быть уникальным. Оно может быть длиной до 255 символов, регистр букв значения не имеет. На ярлыке вкладки отображаются только первые 31 символ имени.

Сохранить

Сохраняет разметку листа как файл шаблона чертежа(DWT), не сохраняя при этом неиспользуемые данные таблицы символов и описаний блоков. Шаблоны позволяют создавать в чертеже новые разметки листа, не содержащие ненужной информации. См. раздел Повторное использование листов и их параметров в Руководстве пользователя.

Какую разметку листа сохранить в шаблоне <текущий>:

По умолчанию предлагается имя разметки листа, которая была активной последней. Если системная переменная FILEDIA установлена в 1, то выводится стандартное окно выбора файлов, в котором необходимо задать имя файла шаблона для сохранения разметки листа. Папка по умолчанию указывается в диалоговом окне "Настройка".

усТановить

Переход к разметке листа.

Какую разметку листа установить текущей <последняя>:

?—Вывести разметки

Вывод списка разметок листов, имеющихся в чертеже.


РОККОНВЕРТ Команда

Р Команды
Р Команды
РОККОНВЕРТ Команда
Понятия Процедуры Команды

Конвертирование моделей AME в твердотельные объекты AutoCAD

Ввод команды: рокконверт

Выбрать объекты: Выбрать объекты любым способом

Выбранные объекты должны быть областями или телами AME (расширения по объемному конструированию Advanced Modeling Extension) версий 2 или 2.1. Все остальные объекты игнорируются. Все другие объекты игнорируются.

Так как новые средства твердотельного моделирования отличаются повышенной точностью, модели AME после преобразования могут немного отличаться от своих оригиналов. Это происходит, если при обработке поверхностей двух различных форм средствами твердотельного моделирования предыдущей версии они расположены так близко, что считаются лежащими в одной плоскости. Поскольку в новых средствах моделирования предусмотрены более строгие допуски, после преобразования эти поверхности будут изображены с небольшим смещением. Особенно это заметно на сопряжениях, фасках и сквозных отверстиях.

Сквозные отверстия могут после конвертирования оказаться глухими из-за небольшой разницы в глубине детали и отверстия. Как правило, толщина оставшегося неударенным материала равна разнице между допусками старого и нового средств моделирования.

По этой же причине сопряжения и фаски могут оказаться чуть ниже поверхности детали, образуя в ней отверстия, а исходная форма остается без изменения. Сопряжения и фаски могут оказаться и чуть выше исходной поверхности, образуя неровный переход между телом и сопряжением или фаской.


РПСОХРАНИТЬ Команда

Р Команды
Р Команды
РПСОХРАНИТЬ Команда
Понятия Процедуры Команды

Сохранение рабочего пространства

Ввод команды: рпсохранить

Если в ответ на подсказку "Команда:" ввести -рпсохранить, вызывается вариант команды РПСОХРАНИТЬ, использующий интерфейс командной строки.

Откроется диалоговое окно "Сохранение рабочего пространства".

Темы:

  • Диалоговое окно "Сохранение рабочего пространства"


Диалоговое окно "Сохранение рабочего пространства"

Р Команды
Р Команды
Диалоговое окно "Сохранение рабочего пространства"
Понятия Процедуры Команды

Ввод команды: рпсохранить

Сохранение текущей схемы и параметров рабочего пространства.

Имя

Открытие текстового окна, в котором можно задать имя для вновь сохраняемого рабочего пространства и просмотреть список существующих рабочих пространств. Эти рабочие пространства могут быть заменены, если файл НПИ, в который они включены, доступен для записи. Файлы только для чтения, например файлы НПИ, используемые в сети (именуемые файлами НПИ предприятия), отображаются с атрибутом “Только для чтения“.


С Команды
  • СБРОСБЛОКА
  • СВЕТ
  • СВИД
  • СВОЙСТВА
  • СВОЙСТВАРИС
  • СВОЙСТВАСОЛНЦА
  • СВОЙСТВАСОЛНЦАЗАКР
  • СДВИГ
  • СЕКПЛОСКОСТЬ
  • СЕТКА
  • СЕЧЕНИЕ
  • СИММЕТРИЯ
  • СКРЫТЬ
  • СКРЫТЬВОССТАНЧЕРТЕЖА
  • СЛАЙД
  • СЛЕДИТЬ
  • СЛОЙ
  • СЛОЙБЛК
  • СЛОЙВКЛ
  • СЛОЙЗМР
  • СЛОЙИЗМНЕСК
  • СЛОЙОБЪЕД
  • СЛОЙОВЭ
  • СЛОЙОТД
  • СЛОЙОТДОТМ
  • СЛОЙОТКЛ
  • СЛОЙП
  • СЛОЙПРЕЖИМ
  • СЛОЙРАЗБЛ
  • СЛОЙРМР
  • СЛОЙТЕК
  • СЛОЙТРАНС
  • СЛОЙУДАЛ
  • СЛОЙУСТЕК
  • СМЕНАПРОСТР
  • СМЕЩЕНИЕ
  • СОЕДИНИТЬ
  • СОЗДАТЬ
  • СОПРЯЖЕНИЕ
  • СОХРАНИТЬ
  • СОХРАНИТЬКАК
  • СОХРИЗОБ
  • СПИРАЛЬ
  • СПИСМАСШТРЕД
  • СПИСОК
  • СПИСОКСВЕТ
  • СПИСОКСВЕТЗАКР
  • СПЛАЙН
  • СПРАВКА
  • СРЕДАТОН
  • ССВСТАВИТЬ
  • ССОТКРЫТЬ
  • ССПОДРЕЗАТЬ
  • ССЫЛЗАКР
  • ССЫЛКА
  • ССЫЛНАБ
  • ССЫЛРЕД
  • СТАНДАРТЫ
  • СТАТ
  • СТАТУС
  • СТЕРЕТЬ
  • СТИЛЬ


СБРОСБЛОКА Команда

С Команды
С Команды
СБРОСБЛОКА Команда
Понятия Процедуры Команды

Сбрасывает одно или несколько вхождений динамических блоков на значения описаний блоков по умолчанию.

Контекстное меню: Выберите вхождение динамического блока в чертеже. Щелкните в области рисования правой кнопкой мыши. Выберите "Сброс блока".

Ввод команды: сбросблока

Выберите объект: Выбрать одно или несколько вхождений динамических блоков и нажать ENTER


СВЕТ Команда

С Команды
С Команды
СВЕТ Команда
Понятия Процедуры Команды

Создает источник света

Ввод команды: свет

Введите тип источника света [Точечный/Прожектор/Удаленный] <Точечный>:

В зависимости от типа заданного пользователем источника света отображаемые приглашения идентичны приглашениям в командах ТОЧСВЕТ, ПРОЖЕКТОР или УДАЛСВЕТ.


СВИД Команда

С Команды
С Команды
СВИД Команда
Понятия Процедуры Команды

Создание видовых экранов на листах и управление ими

Меню "Вид": "Видовые экраны" » "1 ВЭкран", "2 ВЭкрана", "3 ВЭкрана", "4 ВЭкрана"

Ввод команды: свид

Угловая точка видового экрана или [Вкл/Откл/Вписать/Тонирование/Блокировать/Объект/Многоугольный/Восстановить/2/3/4] <Вписать>: Задать опцию или указать точку

На вкладке "Лист" можно создать неограниченное количество видовых экранов, но одновременно активными могут быть не более 64 из них (см. MAXACTVP). Объекты пространства модели видны только на активных видовых экранах. Неактивные видовые экраны пусты. Для управления видимостью видовых экранов служат опции "Вкл" и "Откл".

Угловая точка видового экрана

Задание первого угла прямоугольного видового экрана.

Противоположный угол:

Вкл

Включение (активизация) видового экрана. Объекты в пространстве модели становятся видимыми на включенном видовом экране. Системная переменная MAXACTVP определяет максимально возможное число одновременно включенных видовых экранов. Если видовых экранов в чертеже больше, чем указано в системной переменной MAXACTVP, то для просмотра одних видовых экранов придется отключать другие.

Выберите объекты: Выбрать один или несколько видовых экранов

Откл

Отключение (деактивизация) видового экрана. Объекты на отключенном видовом экране становятся невидимыми.

Выберите объекты: Выбрать один или несколько видовых экранов

Вписать

Создание одного видового экрана, который заполняет собой весь лист до самых границ формата. Если режим разметки формата отключен, видовой экран заполняет собой весь экран монитора.

Тонирование

Параметры печати видовых экранов.

Режим печати для тонированного ВЭ? [Обычный/все визуальные стили /все наборы параметров тонирования ]<Обычный>: Ввести опцию визуализации при печати

Обычный

Печать видового экрана в том же виде, в котором он отображается на экране.

Все визуальные стили

Печать изображение видового экрана с использованием заданного визуального стиля. Все визуальные стили, имеющиеся в чертеже, указываются в списке в виде опций независимо от их фактического использования.

Все наборы параметров тонирования

Печать изображение видового экрана с использованием заданного набора параметров тонирования. Все наборы параметров тонирования указываются в списке в виде опций.

Выберите объекты: Выбрать один или несколько видовых экранов

Блокировать

Запрещение изменений коэффициента экранного увеличения видовых экранов при работе в пространстве модели.

Блокировка вида на видовом экране [Вкл/Откл]: Введите вкл или откл

Выберите объекты: Выбрать один или несколько видовых экранов

Объект

Преобразование замкнутой полилинии, круга, эллипса, сплайна или области в новый видовой экран. Выбираемая полилиния должна быть замкнутой и содержать по крайней мере три вершины. Она может иметь самопересечения и состоять из линейных и дуговых сегментов.

Выберите объект для подрезки видового экрана: Выбрать объект

Многоугольный

Создание видового экрана, имеющего границу в виде многоугольника, по точкам. Подсказки, выдаваемые в командной строке, аналогичны запросам команды подрезки внешних ссылок, однако для задания границ многоугольных видовых экранов можно использовать дуги.

Начальная точка: Укажите точку

Следующая точка или [Дуга/Замкнуть/длИна/Отменить]: Указать точку или задать опцию

Дуга

Добавление дугового сегмента для многоугольного видового экрана.

[Угол/Центр/Замкнуть/Направление/Отрезок/Радиус/Вторая точка/Отменить/Конечная точка дуги] <Конечная точка>: Задать опцию или нажать ENTER

Подробнее об опциях для создания дуговых сегментов см. параметр "Дуга" в описании команды ПЛИНИЯ.

Замкнуть

Замыкание контура. Если нажать ENTER после задания не менее трех точек, контур замыкается автоматически.

Линейные

Построение линейного сегмента по заданной длине в том же направлении, что и предыдущий сегмент. Если предыдущим сегментом был дуговой сегмент, то новый линейный сегмент строится касательно к предыдущему.

Отменить

Удаление последнего дугового или линейного сегмента, построенного для границы многоугольного экрана.

Восстановить

Восстановление конфигураций видовых экранов, сохраненных командой ВЭКРАН.

Имя конфигурации видовых экранов или [?] <*АКТИВНЫЙ>: Ввести ?, указать имя или нажать ENTER

Первая угловая точка или [Вписать] <Вписать>: Указать точку или нажать ENTER

Первый угол

Задает положение и размер новых видовых экранов с помощью рамки выбора; видовые экраны располагаются внутри выбранной области.

Вписать

Масштабирование видовых экранов так, чтобы они заполняли всю область чертежа.

2

Заданная область разбивается по горизонтали или по вертикали на два равных по величине видовых экрана.

Расположение видовых экранов [Горизонтально/Вертикально] <Вертикально>: Ввести г или нажать ENTER

Первая угловая точка или [Вписать] <Вписать>: Указать точку или нажать ENTER

Первый угол

Задает положение и размер новых видовых экранов с помощью рамки выбора; видовые экраны располагаются внутри выбранной области.

Вписать

Масштабирование видовых экранов так, чтобы они заполняли всю область чертежа.

3

Заданная область разбивается на три видовых экрана.

Расположение видовых экранов

[Горизонтально/Вертикально/Выше/Ниже/Левее/<Правее>: Задать опцию или нажать ENTER

Опции "Горизонтально" и "Вертикально" делят указанную область на три равные части. Другие опции разделяют область на три видовых экрана: один видовой экран большего размера и два - меньшего. Название остальных опций ("Выше", "Ниже", "Левее", "Правее") указывает, где располагается больший видовой экран.

Первая угловая точка или [Вписать] <Вписать>: Указать точку или нажать ENTER

Первый угол

Задает положение и размер новых видовых экранов с помощью рамки выбора; видовые экраны располагаются внутри выбранной области.

Вписать

Масштабирование видовых экранов так, чтобы они заполняли всю область чертежа.

4

Заданная область разбивается по горизонтали и по вертикали на четыре равных по величине видовых экрана.

Первая угловая точка или [Вписать] <Вписать>: Указать точку или нажать ENTER

Первый угол

Задает положение и размер новых видовых экранов с помощью рамки выбора; видовые экраны располагаются внутри выбранной области.

Вписать

Масштабирование видовых экранов так, чтобы они заполняли всю область чертежа.


СВОЙСТВА Команда

С Команды
С Команды
СВОЙСТВА Команда
Понятия Процедуры Команды

Изменяет свойства объекта

Ввод команды: свойства

Выбрать объекты:

Ввести свойство, подлежащее изменению [Цвет/Слой/Тип линии/Лмасштаб/вЕс линии/Высота/Материал /стИль печати]:

Примечание Опция "Стиль печати" доступна только при использовании именованных стилей печати.

Если выбраны несколько объектов, имеющие различные значения изменяемого свойства, в качестве текущего значения отображается значение разные.

Цвет

Изменение цвета выбранных объектов.

Ввести новый цвет [изПалитры/Альбом]<текущий>: Ввести имя цвета или число от 1 до 255, ввести t, ввести co, ввести ПоСлою или ПоБлоку или нажать ENTER

Например, чтобы изменить цвет на красный, нужно ввести красный или 1. Чтобы установить цвет объекта равным цвету его слоя, следует ввести послою. Чтобы объект унаследовал цвет блока, в который он входит, следует ввести поблоку.

Из палитры

Выбор цвета для выбранного объекта из палитры всех цветов (true color).

Компоненты R,G,B: Ввести три разделенных запятыми значения от 0 до 255

Альбом

Выбор цвета для выбранного объекта из загруженного альбома цветов.

Имя альбома цветов: Ввести имя установленного альбома цветов, например PANTONE

При вводе имени альбома цветов отображается следующая подсказка.

Имя цвета: Ввести имя цвета из этого альбома, например PANTONE 573

Слой

Изменение слоя выбранных объектов.

Имя нового слоя <текущее>:

Тип линий

Изменение типа линии выбранных объектов.

Имя нового типа линии <текущее>:

Если указанный тип линии не загружен, программа пытается загрузить его из стандартного библиотечного файла типов линий acad.lin. Если попытка завершилась неудачно, следует загрузить этот тип линии вручную с помощью команды LINETYPE.

Лмасштаб

Изменение масштаба типа линии выбранных объектов.

Масштаб типа линии <текущий>:

Вес линий

Изменение веса линии выбранных объектов. Вес линий должен иметь значение из стандартного ряда. При вводе значения, отсутствующего в этом ряду, оно приводится к ближайшему стандартному.

Новый вес линии <текущий>:

Высота

Изменение высоты двумерного объекта по оси Z.

Новая высота <текущая>:

Попытка изменить высоту трехмерной полилинии, размера или видового экрана листа не дает никаких результатов.

Материал

Изменяет материал выбранных объектов, если он применяется.

Ввести имя нового материала < ПоСлою>:

Стиль печати

Изменение стиля печати выбранных объектов. Стиль печати — это набор свойств объектов, назначаемых им при печати и сохраняемых в таблицах стилей. Эта опция доступна только при использовании именованных стилей печати.

Стиль печати или [?] <текущий>: Ввести имя или ?

Стиль печати

Назначение стиля печати выбранным объектам. При выводе на печать объекты получают свойства, присущие назначенному стилю печати. Вновь назначенный объекту стиль печати заменяет имевшийся ранее.

?—Список стилей печати

Вывод списка стилей печати, имеющихся в чертеже.


СВОЙСТВАРИС Команда

С Команды
С Команды
СВОЙСТВАРИС Команда
Понятия Процедуры Команды

Задание и просмотр свойств текущего чертежа

Меню "Файл": "Свойства чертежа"

Ввод команды: свойстварис

Отображает диалоговое окно "Свойства чертежа".

Темы:

  • Диалоговое окно "Свойства чертежа"
  • Диалоговое окно "Новое дополнительное свойство"


Диалоговое окно "Свойства чертежа"

С Команды
С Команды
Диалоговое окно "Свойства чертежа"
Понятия Процедуры Команды

Меню "Файл": "Свойства чертежа"

Ввод команды: свойстварис

Здесь отображается общая информация о чертеже: имя, размер, даты создания и изменения, текстовые свойства, статистика и пользовательские свойства. Все это помогает распознать чертеж среди ему подобных.

Свойства документа отображаются в виде списка полей в диалоговом окне "Поле".

Вкладки диалогового окна "Свойства чертежа":

  • Общие
  • Сводка
  • Статистика
  • Прочее

Вкладка "Общие" (диалоговое окно "Свойства чертежа")

Здесь отображается нередактируемая информация о файле чертежа на диске. Данные извлекаются из операционной системы.

Имя файла

Ярлык файла и имя, под которым он хранится.

Тип, положение, размер

Информация о типе файла, положении в структуре папок и размере.

Имя MS-DOS, время создания, изменения, открытия

Информация об имени файла для системы MS-DOS, дате создания, последней модификации и последнего открытия файла.

Параметры

Атрибуты файлов, заданные на системном уровне. Для изменения атрибутов следует воспользоваться Проводником Windows.

Только чтение

Показывает, что файл не может быть перезаписан, что предохраняет от случайных изменений или удаления.

Архивация

Индикатор, обозначающий, что файл подлежит архивации. Этот параметр используется при выборе файлов для резервного копирования.

Скрытие

Файл с таким атрибутом не выводится в списках и может быть открыт только путем явного ввода имени.

Система

Файл является системным. У чертежа нет набора системных атрибутов.

Вкладка "Документ" (диалоговое окно "Свойства чертежа")

Содержит сведения об авторе, названии и теме чертежа. Например, пользователь может назначить всем файлам чертежа ключевые слова, по которым в дальнейшем через DesignCenter™ можно будет осуществлять поиск всех файлов чертежа, которым назначено определенное ключевое слово.

Заголовок

Название, которое должно использоваться при поиске чертежа. Оно может отличаться от имени файла чертежа.

Тема

Тема чертежа. Одну и ту же тему обычно назначают чертежам, объединенным в одном проекте или его составной части.

Автор

Автор чертежа. Имя автора вводит и изменяет сам пользователь. Для изменения имени автора необходимо удалить существующее имя и задать новое.

Ключевые слова

Ключевые слова, которые впоследствии могут использоваться для поиска чертежа.

Заметки

Место для сохранения замечаний и предложений по чертежу.

База гиперссылки

Базовый адрес, используемый для всех относительных гиперссылок в чертеже. Здесь можно задать Интернет-адрес (например, http://www.autodesk.com или путь к папке на сетевом диске.

Вкладка "Статистика" (диалоговое окно "Свойства чертежа")

Здесь выводятся данные о создании и изменении чертежа. Статистика отслеживается программой автоматически и бывает полезной при поиске чертежей, созданных или отредактированных в течение определенного промежутка времени.

Примечание Если программа обнаруживает, что последнее сохранение чертежа было выполнено с использованием не программы Autodesk®, а какого-то другого приложения, на экран выводится предупреждение. Выводом предупреждения на экран управляет системная переменная DWGCHECK.

Время создания

Дата и время создания чертежа. Это значение хранится в системной переменной TDCREATE.

Изменения

Дата и время последнего изменения чертежа. Это значение хранится в системной переменной TDUPDATE.

Автор изменений

Имя пользователя, который последним внес в файл изменения. Это имя запоминается в системной переменной LOGINNAME.

Редакция

Порядковый номер редакции чертежа.

Общее время редактирования

Суммарное количество времени, затраченное на редактирование чертежа. Эти сведения хранятся в системной переменной TDINDWG.

Вкладка "Прочее" (диалоговое окно "Свойства чертежа")

Здесь пользователь может задать для чертежа свойства по своему усмотрению. Например, можно создать свойство "Проект" и задать в качестве его значения имя проекта. Для назначения одного и того же свойства целой группе чертежей следует задать его в шаблоне.

Пользовательские свойства, заданные на вкладке "Прочее", отображаются в виде списка полей в диалоговом окне "Поле". Пользователь также может обратиться к информации о свойствах с помощью интерфейсов программирования, например AutoLISP®.

Прочие свойства

Список заданных пользователем имен и значений свойств текущего чертежа.

Добавить

Отображает диалоговое окно "Новое свойство", в котором можно задать имя и значение нового пользовательского свойства. Имя должно быть уникальным. Значение задавать не обязательно.

Удалить

Удаление выбранного в списке свойства.

Примечание Если удаленное пользовательское свойство используется в каком-либо из полей, то при следующем обновлении в этом поле будет отображаться строка ####.


Диалоговое окно "Новое дополнительное свойство"

С Команды
С Команды
Диалоговое окно "Новое дополнительное свойство"
Понятия Процедуры Команды

Меню "Файл": "Свойства чертежа"

Ввод команды: свойстварис

Добавление в файл чертежа нового свойства.

Имя нового свойства

Присвоение свойству уникального имени. Имя должно иметь длину не более 255 символов. Не допускается использование следующих символов: звездочки (*), знака равенства (=), знаков больше или меньше (< >), косой черты (/), обратной косой черты (\), кавычек ("), апострофа (`), вертикальной черты (|), двоеточия (:) и точки с запятой (;).

Значение

Значение свойства. Значение задавать не обязательно.


СВОЙСТВАСОЛНЦА Команда

С Команды
С Команды
СВОЙСТВАСОЛНЦА Команда
Понятия Процедуры Команды

Вызов окна "Свойства солнца" для определения свойств солнца

Меню "Вид": "Тонирование" » "Источник света" » "Свойства солнца"

Ввод команды: свойствасолнца

Пульт управления: Разверните управляющую панель "Свет" и нажмите "Изменить свойства солнца".

Откроется окно "Свойства солнца".

Темы:

  • Окно "Свойства солнца"


Окно "Свойства солнца"

С Команды
С Команды
Окно "Свойства солнца"
Понятия Процедуры Команды

Меню "Вид": "Тонирование" » "Свет" » "Изменить свойства солнца"

Ввод команды: свойствасолнца

Определение и изменение свойств солнца.

Общие

Определение основных свойств солнца.

Положение

Включение и отключение солнца. Если в чертеже не включено освещение, этот параметр является избыточным.

Коэффициент интенсивности

Установка интенсивности или яркости солнца. Диапазон - от 0 (без света) до максимума. Чем выше значение, тем ярче свет.

Цвет

Управление цветом источника света. Введите имя или номер цвета или нажмите "Выбор цвета" для вызова диалогового окна "Выбор цвета".

С тенями

Включение и отключение отображения и расчета теней от солнца. Отключение теней повышает производительность.

Положение солнца

Установка угла солнца.

Дата

Отображение текущего значения даты.

Время

Отображение текущего значения времени.

Летнее время

Отображение текущего значения для параметра летнего времени.

Азимут

Отображение азимута, угла солнца над горизонтом по часовой стрелке от направления на север. Этот параметр доступен только для чтения.

Широта

Широта, угол солнца по вертикали над горизонтом. Максимальное значение - 90 градусов или непосредственно заданное ограничение. Этот параметр доступен только для чтения.

Исходный вектор

Отображение координат исходного вектора направления солнца. Этот параметр доступен только для чтения.

Сведения о тонированном изображении с тенями

Задание свойств теней.

Тип

Параметр типа тени. При отключенном отображении теней этот параметр доступен только для чтения.

Размер текстуры

Размер текстуры тени. При отключенном отображении теней этот параметр доступен только для чтения.

Смягчение

Параметр отображения кромок теней. При отключенном отображении теней этот параметр доступен только для чтения.

Географическое положение

Отображение текущих параметров географического положения. Эта информация имеет отметку "только для чтения". Если при сохранении города не указана широта и долгота, название города не отображается в списке.

Кнопка "Редактировать географическое положение" служит для вызова диалогового окна "Географическое положение".


СВОЙСТВАСОЛНЦАЗАКР Команда

С Команды
С Команды
СВОЙСТВАСОЛНЦАЗАКР Команда
Понятия Процедуры Команды

Закрытие окна "Свойства Солнца"

Ввод команды: свойствасолнцазакр

Происходит закрытие окна "Свойства солнца".


СДВИГ Команда

С Команды
С Команды
СДВИГ Команда
Понятия Процедуры Команды

Создание 3D тела или поверхности посредством сдвига 2D кривой вдоль траектории

Панель "Моделирование":

Меню "Рисование": "Моделирование" » "Сдвиг"

Ввод команды: сдвиг

Пульт управления: Панель создания 3D объектов, Сдвиг

Команда СДВИГ используется для создания нового тела или поверхности посредством сдвига разомкнутой или замкнутой плоской кривой (профиля) вдоль разомкнутой или замкнутой 2D или 3D траектории. Команда СДВИГ вычерчивает тело или поверхность заданного профиля вдоль указанной траектории. Команду СДВИГ можно использовать сразу для нескольких объектов при условии, что все они находятся в одной плоскости.

При создании тела или поверхности с помощью команды СДВИГ можно использовать следующие объекты и траектории:

Объекты для сдвига | Объекты, используемые в качестве траектории сдвига
Отрезок | Отрезок
Дуга | Дуга
Эллиптическая дуга | Эллиптическая дуга
2D полилиния | 2D полилиния
2D сплайн | 2D сплайн
Круг | Круг
Эллипс | Эллипс
Плоская 3D грань | 3D сплайн
2D тело | 3D полилиния
Полоса | Спираль
Область | Кромки тела или поверхности
Плоская поверхность |
Плоские грани тела |

Примечание Для выбора граней и ребер на телах необходимо нажать и удерживать нажатой клавишу CTRL и далее выбирать эти подобъекты.

Системная переменная DELOBJ определяет способ удаления траекторий профилей и сдвига при создании тела или поверхности - автоматически или по запросу.

Объекты для сдвига можно выбрать перед запуском команды.

Текущая плотность каркаса: ISOLINES=4

Выберите объекты для сдвига: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Выберите траекторию сдвига или [Выравнивание/Базовая точка/Масштаб/Вращать]: Выбрать 2D или 3D траекторию сдвига или задать опцию

Выравнивание

Определяет, будет ли профиль выровнен по нормали к касательной траектории сдвига. По умолчанию профиль выровнен.

Перед сдвигом установить объект сдвига перпендикулярно траектории [Да/Нет] <Да>: Ввести нет, чтобы профиль не выравнивался, или нажать клавишу ENTER , чтобы выровнять профиль

Примечание Если кривая профиля не перпендикулярна (не располагается по нормали) к касательной начальной точки криволинейной траектории, то кривая профиля выравнивается автоматически. Введите "Нет" в ответ на запрос о выравнивании, чтобы предотвратить такое действие.

Базовая точка

Указание базовой точки для объектов, подлежащих сдвигу. Если указанная точка не лежит в плоскости выбранных объектов, она проецируется на эту плоскость.

Базовая точка: Указать базовую точку для набора объектов

Масштаб

Задание масштабного коэффициента для операции сдвига. Сдвигаемые из начальной в конечную точку траектории объекты масштабируются как единый объект.

Введите масштабный коэффициент или [Опорный отрезок] <1,0000>: Задать масштабный коэффициент, ввести о для опции "Опорный отрезок" или нажать клавишу ENTER, чтобы использовать значение по умолчанию

Опорный отрезок

Масштабы выбранных объектов основаны на длине опорного отрезка, который задается посредством указания точек или ввода значений.

Начальная длина опорного отрезка <1,0000>: Ввести начальное значение длины, начиная с которого изменяется масштаб выбранных объектов

Длина конечного опорного отрезка <1,0000>: Ввести конечное значение длины, до которого изменяется масштаб выбранных объектов

Вращать

Задание угла закручивания для объектов, подлежащих сдвигу. Угол закручивания определяет вращение вдоль всей длины траектории сдвига.

Введите угол закручивания или разрешите перекос неплоской траектории сдвига [Перекос]: <n>: Указать значение угла менее 360°, ввести п , чтобы включить перекос, или нажать клавишу ENTER, чтобы задать значение угла по умолчанию

Выберите траекторию сдвига или [Выравнивание/Базовая точка/Масштаб/Наклон]: Выбрать траекторию сдвига или задать опцию

Наклон позволяет включить/отключить естественный наклон (поворот) сдвигаемых кривых вдоль 3D траектории (3D полилинии, 3D сплайна или спирали).


СЕКПЛОСКОСТЬ Команда

С Команды
С Команды
СЕКПЛОСКОСТЬ Команда
Понятия Процедуры Команды

Создание объекта-сечения, который представляет собой секущую плоскость, проходящую через 3D объект

Меню "Рисование": "Моделирование" » "Объект - сечение"

Ввод команды: секплоскость

Пульт управления: Панель создания 3D объектов, Секущая плоскость

Построение объекта-сечения выполняется независимо от тела посредством выбора любой точки в области рисования, не лежащей на грани. Первая точка - эта точка поворота объекта-сечения. Вторая точка позволяет создать объект-сечение.

Выберите грань или любую точку для расположения линии сечения или [Построить сечение/Ортогональное]: Указать точку или задать опцию

Выравнивание объекта-сечения параллельно грани осуществляется посредством выбора грани на теле или в области.

Построение объекта-сечения выполняется посредством выбора любой точки в области рисования, не лежащей на грани. Первая точка - эта точка поворота объекта-сечения. Вторая точка позволяет создать объект-сечение.

Построить сечение

Определение объекта-сечения посредством указания множества точек для создания ломаной линии сечения.

Начальная точка: Указать точку (1)

Следующая точка: Указать точку (2)

Укажите следующую точку или нажмите ENTER для завершения: Указать точку (3) или нажать ENTER.

Укажите следующую точку в направлении вида сечения: Указать точку для обозначения направления секущей плоскости

Эта опция позволяет создать объект-сечение в состоянии контура сечения с отключенным режимом псевдоразреза.

Ортогонально

Выравнивание объекта-сечения ортогонально по отношению к ПСК.

Задайте ориентацию выравнивания сечения: [Спереди/Сзади/Сверху/Снизу/Слева/Справа]: Задать опцию

Объект-сечение создается с заданной ориентацией относительно ПСК (а не текущего вида) и содержит все 3D объекты. Эта опция позволяет создать объект-сечение в состоянии секущей плоскости с включенным режимом псевдоразреза.

Темы:

  • Диалоговое окно "Параметры сечения"
  • Диалоговое окно "Создание сечения/уровня"


Диалоговое окно "Параметры сечения"

С Команды
С Команды
Диалоговое окно "Параметры сечения"
Понятия Процедуры Команды

Контекстное меню: Нажмите правую кнопку мыши на линии сечения. Выберите "Параметры псевдоразреза".

В диалоговом окне "Параметры сечения" можно настроить параметры отображения для построения 2D и 3D сечений средствами диалогового окна "Создание сечения/уровня", а также для создания псевдоразрезов. Все параметры сохраняются в объекте-сечении.

Параметры создания блока 2D сечений/уровней

Задание способа отображения 2D сечения после его создания из 3D объекта.

Параметры создания блока 3D сечений/уровней

Задание способа отображения 3D объекта после его создания.

Параметры псевдоразреза

Задание способа отображения рассекаемых объектов чертежа при включенном режиме псевдоразреза.

Включить режим псевдоразреза

Включение режима псевдоразреза для выбранного объекта-сечения.

Контур пересечения

Задание внешнего вида линейных сегментов, очерчивающих поверхность пересечения плоскости объекта-сечения.

Заливка пересечения

Задание дополнительной заливки внутри области контура секущей поверхности, где объект-сечение пересекает 3D объект.

Линии заднего плана

Управление отображением линий заднего плана для 2D и 3D сечений. Кроме того, в случае 2D сечений данная опция позволяет управлять отображением линий заднего плана.

Линии переднего плана

Управление отображением линий переднего плана.

Касательные к кривой линии

Управление включением кривых линий, касательных к секущей плоскости. Применяется только к 2D сечениям.

Статическое изображение

Вывод описания выбранного элемента управления.

Применить параметры ко всем объектам-сечениям

При установке флажка параметры применяются ко всем объектам-сечениям чертежа. При снятии флажка параметры применяются только к текущему объекту-сечению.

Сброс

Восстановление значений по умолчанию для всех параметров диалогового окна.


Диалоговое окно "Создание сечения/уровня"

С Команды
С Команды
Диалоговое окно "Создание сечения/уровня"
Понятия Процедуры Команды

Контекстное меню: Нажмите правую кнопку мыши на линии сечения. Выберите "Создать 2D/3D сечение".

Создание 2D и 3D сечений.

2D/3D

2D сечение/уровень

Создание 2D сечения.

3D сечение

Создание 3D сечения.

Геометрия источника

Включить все объекты

Включение всех 3D объектов (3D тел, поверхностей и областей) в чертеж, в том числе объектов ссылок и блоков.

Выбрать объекты для включения

Позволяет вручную выбрать 3D объекты чертежа (3D тела, поверхности и области), из которых требуется создать сечение.

С выбором объектов

Временное закрытие диалогового окна с целью выбора объектов для создания сечения. Для возврата к диалоговому окну "Создание сечения/уровня" по завершении выбора объектов следует нажать ENTER.

Выбрано объектов

Вывод информации о количестве выбранных объектов.

Размещение

Вставить как новый блок

Вставка созданного сечения в текущий чертеж в качестве блока.

Заменить существующий блок

Замена существующего в чертеже блока на вновь созданное сечение.

Замена существующего в чертеже блока на вновь созданное сечение.

Выбор блока

Временное закрытие диалогового окна для выбора сечения в чертеже. Для возврата к диалоговому окну "Создание сечения/уровня" по завершении выбора объектов следует нажать ENTER.

Экспортировать в файл

Сохранение сечения во внешний файл.

Имя файла и путь

Задание полного пути к файлу, в котором требуется сохранить сечение.

Параметры сечения

Открытие Диалоговое окно "Параметры сечения".

Создать

Создание сечения.


СЕТКА Команда

С Команды
С Команды
СЕТКА Команда
Понятия Процедуры Команды

Отображение точечной сетки на текущем видовом экране, которая не выводится на печать

Строка состояния: Сетка

Ввод команды: сетка (или 'сетка для прозрачного вызова)

ЗадайтеШаг сетки (X) или [Вкл/Откл/Шаг/Частота основных линий сетки/Адаптивность/Limits Продолжение/Аспект] <текущий>: Введите значение или задайте опцию

Шаг сетки (X)

Задание интервала сетки. Если за значением указать символ x (латинская буква), интервал сетки будет равен интервалу шаговой привязки, умноженному на указанное значение.

Вкл

Включение сетки с текущим значением интервала.

Откл

Отключение сетки.

Шаг

Задает интервал сетки, равный интервалу шаговой привязки, который задается командой ШАГ.

Частота основных линий сетки

Задание частоты основных линий сетки относительно вспомогательных линий сетки. В любом визуальном стиле, кроме 2D Каркас, сетка отображается линиями, а не точками. (Системная переменная GRIDMAJOR)

Адаптивность

Определяет плотность линий сетки при увеличении или уменьшении масштаба.

Включить адаптивность [Да/Нет] <Да>: Введите Д или Н

Ограничение плотности линий или точек сетки при уменьшении масштаба. Этот параметр также определяется системной переменной GRIDDISPLAY.

Разрешить последующее дробление интервалов сетки [Да/Нет] <Да>

Если параметр включен, при увеличении масштаба формируются дополнительные линии или точки сетки с более мелким интервалом. Частота этих линий сетки определяется частотой основных линий сетки.

Лимиты

Отображение сетки за границами площади, заданной командой ЛИМИТЫ.

Продолжение

Изменение плоскости сетки для продолжения плоскости XY динамической ПСК. Этот параметр также определяется системной переменной GRIDMAJOR.

Аспект

Задание различных интервалов сетки по осям X и Y.

Задайте шаг по горизонтали (X) <текущий>: Введите значение или нажмите ENTER

Задайте шаг по вертикали (Y) <текущий>: Введите значение или нажмите ENTER

Если за каким-либо из значений ввести символ x (латинская буква), интервал сетки по данной оси будет равен интервалу шаговой привязки, умноженному на заданный коэффициент.

Если включен изометрический стиль шаговой привязки, параметр "Аспект" отсутствует.


СЕЧЕНИЕ Команда

С Команды
С Команды
СЕЧЕНИЕ Команда
Понятия Процедуры Команды

Создание области на основе пересечения плоскости и тел

Ввод команды: сечение

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Выбор нескольких тел ведет к созданию отдельных областей для каждого тела.

Первая точка на секущей плоскости [Объект/Zось/Вид/XY/YZ/ZX] <3точки>: Указать точку или задать опцию

Первая точка, 3 точки

Задание секущей плоскости по трем точкам. После указания первой точки выводятся следующие запросы:

Вторая точка на плоскости: Указать точку (2)

Третья точка на плоскости: Указать точку (3)

Объект

Выравнивание секущей плоскости с сегментом круга, эллипса, круговой или эллиптической дуги, 2D сплайна или 2D полилинии.

Выберите круг, эллипс, дугу, 2D сплайн или 2D полилинию:

Ось Z

Определение секущей плоскости посредством задания двух точек этой плоскости, одна из которых расположена на оси Z (нормали).

Точка на плоскости: Указать точку (1)

Точка на оси Z (нормали) плоскости: Указать точку (2)

Вид

Проводит секущую плоскость параллельно плоскости вида на текущем видовом экране. Расположение секущей плоскости определяется указанной точкой.

Точка на оси плоскости текущего вида <0,0,0>: Указать точку (1) или нажать ENTER

XY

Выравнивание секущей плоскости с плоскостью XY текущей ПСК. Расположение секущей плоскости определяется указанной точкой.

Точка на плоскости XY <0,0,0>: Указать точку (1) или нажать ENTER

YZ

Выравнивание секущей плоскости параллельно плоскости YZ текущей ПСК. Расположение секущей плоскости определяется указанной точкой.

Точка на оси плоскости YZ <0,0,0>: Указать точку или нажать ENTER

ZX

Выравнивание секущей плоскости параллельно плоскости ZX текущей ПСК. Расположение секущей плоскости определяется указанной точкой.

Точка на плоскости ZX <0,0,0>: Указать точку (1) или нажать ENTER


СИММЕТРИЯ Команда

С Команды
С Команды
СИММЕТРИЯ Команда
Понятия Процедуры Команды

Зеркальное копирование объектов

Панель "Редактирование":

Меню "Изменить": Симметрия

Ввод команды: симметрия

Выберите объекты: Выбрать объекты любым способом; по окончании выбора нажать ENTER

Первая точка оси отражения: Укажите точку

Вторая точка оси отражения: Указать точку

Две указанные точки становятся конечными точками линии, относительно которой объекты отражаются зеркально. Для выполнения зеркального отражения в трехмерном пространстве эта линия определяет плоскость отражения, перпендикулярную плоскости XY пользовательской системы координат (ПСК), содержащей ось отражения.

Удалить исходные объекты? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

Да

Помещает отраженное изображение в чертеж и стирает исходные объекты.

Нет

Помещает отраженное изображение в чертеж и сохраняет исходные объекты.

Примечание По умолчанию, при зеркальном отражении текстового объекта направление текста не изменяется. Чтобы изменить направление текста на обратное, следует установить значение 1 для системной переменной MIRRTEXT.


СКРЫТЬ Команда

С Команды
С Команды
СКРЫТЬ Команда
Понятия Процедуры Команды

Регенерирует трехмерную модель с подавлением линий заднего плана

Панель Тонирование:

Меню "Вид": "Скрыть"

Ввод команды: скрыть

При использовании команд ТЗРЕНИЯ, ДВИД или ВИД для создания 3D вида 2D чертежа каркас отображается в текущем видовом экране. Видимы все линии каркаса (даже заслоняемые другими объектами). Команда СКРЫТЬ подавляет отображение линий заднего плана.

В 3D чертеже команда СКРЫТЬ активизирует команду ТЕКВИЗСТИЛЬ и устанавливает в текущем видовом экране визуальный стиль "3D Скрытый". Установки стиля "3D Скрытый" можно просмотреть в разделе Диспетчер визуальных стилей.

Команда СКРЫТЬ рассматривает следующие элементы как непрозрачные поверхности, скрывающие объекты: круги, тела, полосы, текст, области, широкие сегменты полилиний, 3D грани, многоугольные сети и выдавленные с ненулевой глубиной кромки объектов.

Если объекты выдавленные, то круги, тела, полосы и широкие сегменты полилиний воспринимаются как твердотельные объекты с верхним и нижним основаниями. Команду СКРЫТЬ нельзя применять к объектам на замороженных слоях, но можно использовать для объектов на отключенных слоях.

Для того чтобы скрыть текст, созданный командами ДТЕКСТ, МТЕКСТ или ТЕКСТ нужно присвоить системной переменной HIDETEXT значение 1 или задать текстовому объекту значение высоты.

Если системная переменная INTERSECTIONDISPLAY включена, команда СКРЫТЬ отображает пересечения 3D поверхностей в виде полилиний.

В визуальном стиле "3D Скрытый" не учитывается установка системной переменной INTERSECTIONDISPLAY.

Если системная переменная DISPSILH включена, команда СКРЫТЬ отображает только контур 3D объектов. При этом внутренние ребра объектов, имеющих грани, не показываются.

При отключенной системной переменной HIDETEXT команда СКРЫТЬ игнорирует текстовые объекты. Текстовые объекты показываются независимо от того, заслоняются они другими объектами или нет; в свою очередь, объекты, заслоняемые текстовыми объектами, не визуализируются.


СКРЫТЬВОССТАНЧЕРТЕЖА Команда

С Команды
С Команды
СКРЫТЬВОССТАНЧЕРТЕЖА Команда
Понятия Процедуры Команды

Закрытие диспетчера восстановления чертежей

Ввод команды: скрытьвосстанчертежа

Закрытие диспетчера восстановления чертежей.


СЛАЙД Команда

С Команды
С Команды
СЛАЙД Команда
Понятия Процедуры Команды

Просмотр файла слайда на текущем видовом экране

Ввод команды: слайд

Откроется диалоговое окно "Выбор файла слайда" (стандартное окно выбора файлов). Ввести имя файла слайда (расширение .sld вводить не обязательно). При нажатии ENTER или выборе "Открыть" откроется файл слайда.

Для отображения слайда из библиотеки слайдов (с расширением .slb) установите для переменной FILEDIA значение 0, введите vslide, а затем укажите имя файла библиотеки слайдов, после которого в скобках указано имя файла слайда: библиотека слайдов(слайд).

Если слайд, который получен из изображения, раскрашенного с помощью команды -РАСКРАСИТЬ, просматривается в большем окне или с большим разрешением, чем то, которое использовалось при его создании, между линиями раскрашенной области изображения могут появляться черные линии. Чтобы этого избежать, при создании слайда следует использовать весь экран и максимальное разрешение.


СЛЕДИТЬ Команда

С Команды
С Команды
СЛЕДИТЬ Команда
Понятия Процедуры Команды

Управление отображением объектов при перетаскивании

Ввод команды: следить (или 'следить для прозрачного вызова)

Ввести новое значение [ВКЛ/ОТКЛ/Авто] <текущее>: Задать опцию или нажать клавишу ENTER

Вкл

Разрешает отображение объектов при условии ввода ключевого слова слежение в ходе выполнения команды рисования или редактирования.

Откл

Отключает отображение объектов при перетаскивании (даже при вызове из пунктов меню).

Авто

Включает отображение объектов при выполнении поддерживающих его команд. Слежение производится каждый раз, когда это возможно. При этом нет необходимости каждый раз вводить ключевое слово слежение.


СЛОЙ Команда

С Команды
С Команды
СЛОЙ Команда
Понятия Процедуры Команды

Управление слоями и их свойствами

Панель Слои:

Меню "Формат": "Слой"

Ввод команды: слой (или ’слой для прозрачного вызова)

Открывается диалоговое окно «Диспетчер свойств слоев».

Если в ответ на подсказку "Команда" ввести -слой, будет вызван вариант команды СЛОЙ, использующий интерфейс командной строки.

Темы:

  • Диспетчер свойств слоев
  • Диалоговое окно «Свойства фильтра слоев»
  • Примеры фильтров слоев
  • Диспетчер конфигураций слоев
  • Диалоговое окно «Сохранение новой конфигурации слоев»
  • Диалоговое окно «Выбор типа линий»
  • Диалоговое окно «Вес линий»
  • СЛОЙ вариант для командной строки


Диспетчер свойств слоев

С Команды
С Команды
Диспетчер свойств слоев
Понятия Процедуры Команды

Панель Слои:

Меню "Формат": "Слой"

Ввод команды: слой (или ’слой для прозрачного вызова)

Отображение списка слоев в чертеже и их свойств. Пользователь может добавлять, удалять и переименовывать слои, изменять их свойства и добавлять текстовые пояснения. Фильтры слоев определяют, какие слои будут отображены в списке; а также с их помощью можно осуществлять изменения сразу в группе слоев.

Новый фильтр по свойствам

Отображает диалоговое окно "Свойства фильтра слоев", в котором можно создать фильтр слоев на основе одного или более свойств слоев.

Новый групповой фильтр

Создание фильтра, содержащего слои, которые выбираются вручную пользователем.

Диспетчер конфигураций слоев

Отображает Диспетчер конфигураций слоевдиалоговое окно, в котором можно сохранить текущие настройки свойств слоев в именованной конфигурации, а позднее восстановить эти настройки.

Создать слой

Создание нового слоя. В списке отображается слой с именем СЛОЙ1. При этом происходит выделение имени, чтобы пользователь мог сразу же ввести новое имя слоя. Новый слой наследует свойства выделенного в списке при нажатии кнопки (цвет, состояние включенности и т.д.).

Удалить слой

Постановка выделенных слоев в очередь на удаление. Физически слои удаляются при нажатии кнопок «Применить» или «OK». Можно удалять только неиспользуемые слои. Невозможно удалить слои 0 и DEFPOINTS, слои с объектами (включая объекты в определениях блоков), текущий слой, а также слои, зависимые от внешних ссылок.

Слои в частично открытых чертежах также рассматриваются в качестве ссылочных и не могут быть удалены.

Примечание Следует с особой осторожностью удалять слои, совместно используемые несколькими пользователями, или применяемые в качестве стандартных.

Установить

Установка выбранного слоя текущим. Создаваемые пользователем объекты прорисовываются на текущем слое. (системная переменная CLAYER)

Текущий слой

Отображает имя текущего слоя.

Поиск слоя

Осуществление фильтрации списка по имени сразу же при вводе символов. Данный фильтр не сохраняется при закрытии Диспетчера свойств слоев.

Строка состояния

Показывает имя текущего фильтра, число отображаемых в списке слоев и число слоев в чертеже.

Инвертировать фильтр

Отображение всех слоев, не удовлетворяющих критериям выбранного фильтра свойств слоев.

Показать используемые слои

Отображает список значков, чтобы показать используются ли слои. Для чертежа со множеством слоев следует отключить этот параметр с целью повышения производительности. (системная переменная SHOWLAYERUSAGE)

Применить к панели слоев

Управление отображением слоев в списке слоев, находящемся в панели слоев, с помощью текущего фильтра слоев.

Применить

Применение изменений, сделанных в слоях и фильтрах, без закрытия диалогового окна.

Диспетчер свойств слоев имеет две рабочих области:

  • Область структуры
  • Список

Область структуры

Отображение иерархического списка слоев и фильтров чертежа. Самый верхний узел («Все») отображает все слои чертежа. Фильтры перечисляются в алфавитном порядке. Фильтр «Все используемые слои» не может быть изменен пользователем.

Для просмотра вложенных фильтров необходимо раскрыть узел. Двойной щелчок мыши на фильтре свойств открывает диалоговое окно "Свойства фильтра слоев"; здесь можно просмотреть определение фильтра.

Если к чертежу прикреплены внешние ссылки, то узел ВНЕШНИЕ ССЫЛКИ будет отображать имена всех внешних ссылок в чертеже и слоев в каждой внешней ссылке. Фильтры слоев, определенные в файлах внешних ссылок, не отображаются.

Контекстное меню области структуры

Предоставляет доступ к командам для элементов, выбранных в области структуры.

Видимость

Изменение состояния видимости всех слоев в выбранном фильтре (если выбраны опции «Все» или «Все используемые слои»).

  • Вкл: Отображение, чертеж на бумаге и регенерация объектов на слое; скрытие объектов, расположенных за объектами слоя с помощью команды СКРЫТЬ.
  • Откл: Объекты на слое не отображаются и не распечатываются, но при выполнении команды СКРЫТЬ скрывают другие объекты. При включении слоя чертеж не регенерируется.
  • Разморозить: Объекты на слое отображаются и распечатываются, при выполнении команды СКРЫТЬ скрывают другие объекты.
  • Заморозить: Объекты на слое не отображаются и не распечатываются, но при выполнении команды СКРЫТЬ скрывают другие объекты. При размораживании слоя чертеж регенерируется.

Блокировать

Разрешение или запрет модификации объектов на слоях в выбранном фильтре.

  • Блокировать: Ни один из объектов на слое не может быть модифицирован. На блокированных слоях по-прежнему имеется возможность использования режимов объектной привязки и выполнения других операций, не связанных с редактированием объектов.
  • Разблокировать: Объекты на слое могут быть модифицированы.

Видовой экран

Управление настройками замораживания слоев в выбранном фильтре слоев на текущем видовом экране листа. Эта опция недоступна для видовых экранов в пространстве модели.

  • Заморозить: Замораживание слоев в фильтре на текущем видовом экране. На текущем видовом экране объекты на слое не отображаются и не распечатываются, но при выполнении команды СКРЫТЬ скрывают другие объекты. При размораживании слоя чертеж регенерируется.
  • Разморозить: Размораживание слоев в фильтре на текущем видовом экране. На текущем видовом экране объекты на слое отображаются и распечатываются, при выполнении команды СКРЫТЬ скрывают другие объекты. Эта опция не размораживает слои, для которых включены опции «Откл» или «Заморозить» в чертеже.

Выделить группу

Отключение всех слоев, которые не находятся в выбранном фильтре. Видны только слои, находящиеся в фильтре.

  • Все ВЭкраны: Замораживание слоев, которые не находятся в выделенном фильтре, на всех текущих видовых экранах листа. Отключение всех слоев в пространстве модели, которые не находятся в выбранном фильтре.
  • Только активный ВЭкран: Замораживание слоев, которые не находятся в выделенном фильтре, на текущем видовом экране листа. Отключение всех слоев в пространстве модели, которые не находятся в выбранном фильтре.

Новый фильтр по свойствам

Отображает диалоговое окно "Свойства фильтра слоев", в котором можно создать новый фильтр слоев на основе имен и настроек слоев; например, по состоянию включенности, цвету или типу линий.

Новый групповой фильтр

Создание группового фильтра слоев с именем ГРУППОВОЙ ФИЛЬТР1 и добавление его в область структуры. Ввести новое имя. Выбрать опцию «Все» или любой другой фильтр слоев в области структуры для отображения слоев в списке, и затем перетащить слои из списка в фильтр новой группы слоев в области структуры.

Пользователь может использовать стандартные методы выбора. Для одновременного выбора нескольких имен слоев необходимо удерживать нажатой клавишу CTRL. Для выбора нескольких последовательных слоев необходимо, нажав клавишу SHIFT, выбрать первое имя, а затем последнее имя слоя.

Преобразовать в групповой фильтр

Преобразование выбранного фильтра по свойствам в групповой фильтр. Изменение свойств слоев в групповом фильтре слоев не влияет на фильтр.

Переименовать

Переименование выбранного фильтра. Ввести новое имя.

Удалить

Удаление выбранного фильтра слоев. Пользователь не может удалить фильтры «Все», «Все используемые фильтры» или «Внешние ссылки». Эта опция удаляет только фильтры слоев, но не сами слои в фильтре.

Свойства

Отображает диалоговое окно "Свойства фильтра слоев", в котором можно может изменить определение выбранного фильтра свойств слоев. Эта опция доступна, только если выбран фильтр свойств слоев.

Выбрать слои

Временно закрывает диалоговое окно «Диспетчер свойств слоев», чтобы можно было выбрать объекты в чертеже. Эта опция доступна, только если выбран групповой фильтр слоев.

  • Добавить: Добавляет слои выбранных объектов в групповой фильтр слоев, который выбран в области структуры.
  • Заменить: Заменяет слои выбранного группового фильтра слоев на слои объектов, которые выбраны в чертеже.

Список

Отображение слоев и фильтров слоев вместе с их свойствами и описаниями. Если в области структуры выбран фильтр слоев, то в списке будут отображены только слои, удовлетворяющие этому фильтру. Фильтр «Все» в области структуры отображает все слои и фильтры слоев чертежа. Если выбран фильтр свойств, но не существует слоев, которые соответствуют его определениям, то список будет пуст. Пользователь может использовать стандартные методы выбора с помощью клавиатуры. Чтобы модифицировать свойство выбранного слоя или всех слоев в выбранном фильтре, необходимо щелкнуть мышью на значке данного свойства. Если для фильтра слоев отображается смешанный значок или значок “Разные“, то данное свойство не является одинаковым для всех слоев в фильтре.

Статус

Указывает тип элемента: фильтр слоя, используемый слой, пустой слой или текущий слой.

Имя

Отображает имя слоя или фильтра. Нажмите F2 для ввода нового имени.

Вкл

Включение и отключение выбранных слоев. Включенные слои видны на экране и выводятся на печать. Отключенные слои не видны на экране и не выводятся на печать, даже если свойство «Печать» включено.

Заморозить

Замораживание выбранных слоев на всех видовых экранах. Это делается для ускорения работы команд ПОКАЗАТЬ, ПАН, и в некоторых других случаях для упрощения выбора объектов и уменьшения времени регенерации при построении сложных чертежей.

Объекты на замороженных слоях не отображаются, не печатаются, не тонируются, не регенерируются, а также не выполняется их скрытие.

Рекомендуется замораживать слои, объекты которых можно сделать невидимыми на долгое время. Если есть необходимость в частом переключении параметров видимости, то надо использовать параметр «Вкл/Откл», чтобы избегать регенераций чертежа. Слой можно замораживать на всех видовых экранах, на текущем видовом экране, а также сразу при создании новых видовых экранов.

Блокировать

Блокирование и разблокирование выделенных слоев. Объекты на блокированном слое не могут быть модифицированы.

Цвет

Изменение цвета, присвоенного выбранным слоям. Щелчок мышью на имени цвета открывает диалоговое окно "Выбор цвета".

Тип линий

Изменение типа линий, присвоенного выбранным слоям. Щелчок мышью на названии типа линий открывает диалоговое окно "Выбор типа линий".

Вес линий

Изменение веса линий, присвоенного выбранным слоям. Щелчок мышью на имени веса линий открывает диалоговое окно "Вес линий".

Стиль печати

Изменение стиля печати, присвоенного выбранным слоям. Стиль печати невозможно изменить при работе с цветозависимыми стилями печати (когда системная переменная PSTYLEPOLICY установлена в 1). Щелчок мышью на имени стиля печати открывает диалоговое окно "Выбор стиля печати".

пеЧать

Управление возможностью вывода выбранных слоев на печать. Запрещение печати слоя не влияет на видимость его на экране. Слои, которые выключены или заморожены, не выводятся на печать, независимо от настроек в столбце "Печать".

Замороженный на текущем ВЭ (доступно только на вкладках разметки листа)

Замораживание выбранных слоев на текущем видовом экране. Можно заморозить или разморозить слои на активном видовом экране, не меняя видимости слоев на других видовых экранах.

Опция «Замороженный на текущем ВЭ» переопределяет настройку размораживания слоев в чертеже. Пользователь может заморозить слой на текущем видовом экране, если он разморожен в чертеже, но он не может разморозить слой на текущем видовом экране, если он заморожен или отключен в чертеже. Если слой отключен или заморожен в чертеже, то он не виден.

Замороженный на новых ВЭ (доступно только на вкладках разметки листа)

Замораживание выбранных слоев на новых видовых экранах. Например, замораживание слоя DIMENSIONS на вновь созданных видовых экранах не позволяет видеть на них расположенные на этом слое размеры, но не влияет на их видимость на созданных ранее видовых экранах. Если же позднее на каком-либо из видовых экранов размеры должны присутствовать, для него можно переопределить состояние замороженности слоя.

Описание

Необязательное текстовое описание слоя или фильтра слоев.

Контекстное меню табличной области

Предоставляет возможность для модификации списка выбранных слоев и фильтров слоев.

Развернуть столбец

Изменение ширины столбца, с тем чтобы увеличить до максимума пространство для отображения содержимого столбца. Эта опция доступна в контекстном меню, которое возникает при нажатии правой кнопкой мыши на заголовке столбца.

Развернуть все столбцы

Изменение ширины всех столбцов, с тем чтобы увеличить до максимума пространство для отображения содержимого столбцов. Эта опция доступна в контекстном меню, которое возникает при нажатии правой кнопкой мыши на заголовке столбца.

Показать дерево фильтров

Отображение области структуры. Для скрытия области структуры необходимо отключить эту опцию.

Показать фильтры в списке

Отображение фильтров в верхней части списка. Фильтры отображаются в списке в алфавитном порядке. Для отображения в списке только слоев необходимо отключить эту опцию.

Установить

Установка выбранного слоя текущим. (системная переменная CLAYER)

Новый слой

Создание нового слоя. В списке отображается слой с именем СЛОЙ1. Сразу после создания имя нового слоя можно отредактировать. Новый слой наследует свойства выделенного в списке при нажатии кнопки (цвет, состояние включенности и т.д.).

Удалить слой

Удаление выбранных слоев из чертежа. Можно удалять только неиспользуемые слои. Невозможно удалить слои 0 и DEFPOINTS, слои с объектами (включая объекты в определениях блоков), текущий слой, а также слои, зависимые от внешних ссылок.

Примечание Следует с особой осторожностью удалять слои, совместно используемые несколькими пользователями, или применяемые в качестве стандартных.

Изменить пояснение

Добавление или изменение текста пояснения для выбранного слоя или фильтра. Если пояснение добавляется для фильтра, оно применяется ко всем слоям фильтра.

Удалить из группового фильтра

Удаление выделенных слоев из группового фильтра слоев, который выбран в области структуры.

Выбрать все

Выделение всех слоев, отображенных в списке.

Очистить все

Снимает выделение всех элементов в списке, за исключением самого последнего выделенного слоя или фильтра.

Выбрать все, кроме текущего

Выделение всех слоев, отображенных в списке, за исключением текущего слоя.

Инвертировать выбор

Выделение всего, что отображено в списке, за исключением выделенных в настоящий момент элементов.

Инвертировать фильтр

Отображение всех слоев, не удовлетворяющих критериям выбранного фильтра свойств слоев.

Фильтры слоев

Отображение списка фильтров слоев, включая фильтры «Все» и «Все используемые слои». Щелкнуть мышью на фильтре, чтобы применить его к списку.

Сохранить конфигурацию

Отображает диалоговое окно "Сохранение новой конфигурации слоев", используемое для сохранения конфигураций и свойств любых слоев чертежа.

Восстановить конфигурацию

Отображает диалоговое окно "Диспетчер конфигураций слоев", используемое для выбора именованной конфигурации слоев с целью восстановления настроек слоев чертежа. Восстанавливаются только те состояния и свойства, которые были выбраны при сохранении именованной конфигурации.


Диалоговое окно «Свойства фильтра слоев»

С Команды
С Команды
Диалоговое окно «Свойства фильтра слоев»
Понятия Процедуры Команды

Панель Слои:

Меню "Формат": "Слой"

Ввод команды: слой (или ’слой для прозрачного вызова)

Ограничение списка выводимых слоев на основании заданных пользователем критериев. Если в области структуры (Диспетчер свойств слоев) выбран какой-либо фильтр, то в списке будут отображены только слои, которые удовлетворяют критериям данного фильтра.

Имя фильтра

Место для ввода имени фильтра свойств слоя.

Показать примеры

Отображает примеры применения фильтров по свойствам из раздела Примеры фильтров слоев.

Описание фильтра

Отображение свойств слоев. Пользователь может использовать для определения фильтра одно или более свойств. Например, можно определить фильтр для отображения всех слоев, которые либо красные, либо голубые и при этом используются объектами. Для включения более чем одного цвета, типа линий или веса линий необходимо продублировать фильтр на следующей строке и выбрать другую настройку.

Статус

Выбрать «Используется» или «Не используется».

Имя

Для фильтрации имен слоев можно использовать символы-шаблоны. Например, для получения в список всех слоев, у которых в имени есть символы mech, необходимо ввести *mech*.

Перечень символов-шаблонов приведен в таблице в разделе Фильтрация и сортировка слоев в списке Руководства пользователя.

Вкл

Выбрать значок «Вкл» или «Откл».

Заморозить

Выбрать значок «Заморозить» или «Разморозить».

Блокировать

Выбрать значок «Блокировать» или «Разблокировать».

Цвет

Нажмите кнопку [...], чтобы открыть диалоговое окно "Выбор цвета".

Тип линий

Нажмите кнопку [...], чтобы открыть диалоговое окно "Выбор типа линий".

Вес линий

Нажмите кнопку [...], чтобы открыть диалоговое окно "Вес линий".

Стиль печати

Нажмите кнопку [...], чтобы открыть диалоговое окно "Выбор стиля печати".

пеЧать

Выбрать значок «Печать» или «Не печатать».

Образец фильтра

Отображение результата фильтрации при текущих параметрах фильтра. Образец показывает, какие слои будут отображаться в списке Диспетчера свойств слоев при выборе данного фильтра.

Темы:

  • Примеры фильтров слоев


Примеры фильтров слоев

С Команды
С Команды
Примеры фильтров слоев
Понятия Процедуры Команды

В примерах показаны определения фильтров слоев, которые устанавливаются в диалоговом окне «Свойства фильтра слоев».

Пример 1

Фильтр с именем “[ANNO]” отображает слои, удовлетворяющие всем следующим критериям:

  • Они используются объектами
  • Их имена содержат символы anno
  • Они находятся во включенном состоянии

Образец 2

Фильтр с именем “RYW” отображает слои, удовлетворяющие всем следующим критериям:

  • Они находятся во включенном состоянии
  • Заморожены
  • Они красные или желтые или белые


Диспетчер конфигураций слоев

С Команды
С Команды
Диспетчер конфигураций слоев
Понятия Процедуры Команды

Панель Слои:

Меню "Формат": "Слой"

Ввод команды: слой (или ’слой для прозрачного вызова)

Сохранение, восстановление и управление именованными конфигурациями слоев.

Конфигурации слоев

Список именованных конфигураций слоев, которые были сохранены в чертеже, пространство, где они были сохранены и необязательное описание.

Новый

Вывод диалогового окна «Сохранение новой конфигурации слоев», где пользователь может определить имя и описание для новой именованной конфигурации слоев.

Удалить

Удаление выделенной именованной конфигурации слоев.

Импорт

Вызов стандартного окна выбора файлов, предназначенного для указания ранее экспортированного LAS-файла конфигураций слоев, который загружается в текущий чертеж. Возможно, после этого в чертеже будут созданы новые слои.

Экспорт

Вызов стандартного окна выбора файлов, предназначенного для сохранения конфигурации слоев в LAS-файле.

Сохраняемые состояния слоев

Определение настроек свойств слоев, которые должны восстанавливаться при восстановлении выделенной именованной конфигурации слоев. При сохранении именованной конфигурации слоев на вкладке «Модель» опции «Зам/Разм на текущем ВЭкране» и «Зам/Разм на новых ВЭкранах» недоступны.

Выбрать все

Выделение всех настроек.

Очистить все

Снятие выделения со всех настроек.

Отключить слои, отсутствующие в конфигурации

При восстановлении именованной конфигурации слоев происходит отключение слоев, созданных после сохранения конфигурации. чертеж выглядит так же, как он выглядел при сохранении именованной конфигурации слоев.

Восстановить

Восстановление состояний и свойств слоев, ранее сохраненных в конфигурации. Восстанавливаются только те состояния и свойства, которые были выбраны при сохранении именованной конфигурации.

Замкнуть

Закрытие Диспетчера конфигураций слоев и сохранение изменений.


Диалоговое окно «Сохранение новой конфигурации слоев»

С Команды
С Команды
Диалоговое окно «Сохранение новой конфигурации слоев»
Понятия Процедуры Команды

Панель Слои:

Меню "Формат": "Слой"

Ввод команды: слой (или ’слой для прозрачного вызова)

Определение имени и пояснения к новой конфигурации слоев.

Имя новой конфигурации

Задание имени для новой сохраняемой конфигурации слоев.

Описание

Необязательное текстовое пояснение к конфигурации слоев, которое отображается в Диспетчере конфигураций слоев.


Диалоговое окно «Выбор типа линий»

С Команды
С Команды
Диалоговое окно «Выбор типа линий»
Понятия Процедуры Команды

Панель Слои:

Меню "Формат": "Слой"

Ввод команды: слой (или ’слой для прозрачного вызова)

Вывод списка загруженных в текущий чертеж типов линий.

Загруженные типы линий

Список типов линий, загруженных в текущий чертеж.

Загрузить

Отображает диалоговое окно "Загрузка/перезагрузка типов линий", с помощью которого производится добавление новых типов линий в список доступных.


Диалоговое окно «Вес линий»

С Команды
С Команды
Диалоговое окно «Вес линий»
Понятия Процедуры Команды

Панель Слои:

Меню "Формат": "Слой"

Ввод команды: слой (или ’слой для прозрачного вызова)

Отображает допустимые значения весов линий. С помощью Редактора таблиц стилей печати можно переназначить или изменить значения весов линий (т.е. толщину линий при печати), однако эти изменения действуют только при выводе чертежа на печать. См. раздел Задание веса и типа линий в Руководстве пользователя.

Веса линий

Отображает список имеющихся весов линий, которые могут быть применены для слоя. Здесь перечислены фиксированные значения весов линий, наиболее часто используемые в чертежах. Выбрать нужный вес линий для применения.

Исходный

Отображает предыдущий вес линий. При создании слою по умолчанию присваивается вес линий ОБЫЧНЫЙ (на печать выводится с шириной 0,01 дюйма, или 0,25 миллиметра). (системная переменная LWDEFAULT)

Новый

Новый вес линий, присвоенный слою.


СЛОЙ вариант для командной строки

С Команды
С Команды
СЛОЙ вариант для командной строки
Понятия Процедуры Команды

Если в ответ на подсказку "Команда" ввести -слой, будет вызван вариант команды СЛОЙ, использующий интерфейс командной строки.

Текущий слой: <"текущий ">

Задайте опцию [?/Создать/усТановить/Новый/ВКЛ/ВЫКЛ/Цвет/Тип линий/вЕс линий/МАТериал/пеЧать/Пстиль/Заморозить/Разморозить/Блок/рАзблок/Конфигурация]:

Примечание Опция «Пстиль» появляется только при работе с именованными стилями печати.

?—Список слоев

Вывод списка имеющихся слоев с их именами, состояниями, номерами цветов, типами и весами линий, информацией о зависимости от внешних ссылок.

Имена каких слоев вывести<*>: Ввести список имен или нажать ENTER для вывода списка всех слоев

Создать

Создание нового слоя и установка его текущим. Все новые объекты помещаются на текущий слой.

Введите имя нового слоя (этот слой станет текущим) <текущий>: Ввести имя или нажать клавишу ENTER

Если слоя с введенным именем не существует, будет создан новый слой с таким именем. Новый слой включен и по умолчанию имеет следующие свойства: цвет 7, тип линий CONTINUOUS, вес линий ОБЫЧНЫЙ.

Если слой существует, но отключен, он будет включен.

усТановить

Установка текущего слоя; однако, если слоя с заданным именем не существует, новый слой не создается. Если слой существует, но отключен, он будет включен и установлен текущим. Замороженный слой не может быть установлен текущим.

Введите имя слоя для установки его текущим или <выбрать объект>: Ввести имя или нажать ENTER и выбрать объект

Новый

Создание слоев. Можно создать несколько слоев сразу, если ввести несколько имен, разделенных запятыми.

Имя нового слоя(ев):

Вкл

Включение слоев. Выбранные слои становятся видимыми и могут быть выведены на печать.

Список имен слоев для включения:

Откл

Отключение слоев. Выбранные слои становятся невидимыми и не могут быть выведены на печать.

Список имен слоев для отключения или <выбрать объекты>: Ввести список имен или нажать ENTER и выбрать объекты

Цвет

Изменение цвета, присвоенного слою.

Введите имя цвета или номер (1-255)[Из палитры/Альбом]: Ввести номер цвета от 1 до 255, ввести п или ввести а

Из палитры

Выбор цвета для выбранного объекта из палитры всех цветов (true color).

Компоненты R,G,B: Ввести три разделенных запятыми значения от 0 до 255

Альбом

Выбор цвета для выбранного объекта из загруженного альбома цветов.

Имя альбома цветов: Ввести имя установленного альбома цветов, например PANTONE

При вводе имени альбома цветов отображается следующая подсказка:

Имя цвета: Ввести имя цвета из выбранного альбома, например PANTONE 573

Введите список имен слоев для текущего цвета <текущий>: Ввести имя или список имен, разделенных запятыми или нажать ENTER

Цвет назначается слоям; при этом слои переводятся во включенное состояние. Чтобы присвоить цвет, но отключить слой, перед именем цвета нужно поставить знак минус (-).

Тип линий

Задание типа линий для присвоения слою.

Введите имя загруженного типа линий или [?] <CONTINUOUS>: Ввести имя текущего типа линий или ? или нажать клавишу ENTER

Если введен тип линий или нажата клавиша ENTER, появляется следующая подсказка:

Список имен слоев для присвоения типа линий "текущий " <текущий>: Ввести шаблон имени, имя или список имен, разделенных запятыми, либо нажать ENTER

Если ввести ? на запрос об имени текущего типа линий появляется следующая подсказка:

Имена каких слоев вывести <*>: Ввести шаблон имени или нажать ENTER для вывода имен всех типов линий чертежа

Вес линий

Задание веса линий для присвоения слою.

Введите вес линий (0,0 мм - 2,11 мм):

Если введено корректное значение веса линий, то оно становится текущим значением. Если введено некорректное значение веса линий, то текущим значением становится ближайшее фиксированное значение. Для настройки вывода на печать объектов с нестандартными весами линий можно воспользоваться Редактором таблиц стилей печати.

Список имен слоев для присвоения веса линий текущее <текущее>: Ввести список имен или нажать клавишу ENTER

Вес линии назначается слою или слоям.

Материал

Назначение слою материала. Перед назначением слою материал должен быть доступен на чертеже.

Введите имя материала или [?] <ГЛОБАЛЬНЫЙ>: Ввести имя текущего доступного на чертеже материала, ввести ? или нажать ENTER

Если в ответ на запрос ввести ?, отобразится следующая подсказка:

Имя (имена) каких материалов вывести <*>: Нажать клавишу ENTER, чтобы указать в списке все материалы на чертеже

Материал назначается объектам, созданным на слое.

пеЧать

Управление возможностью вывода видимых слоев на печать. Замороженные и отключенные слои не выводятся на печать, даже если печать для них разрешена.

Задайте опцию печати [Печатать/Не печатать] <Печатать>: Задать опцию или нажать клавишу ENTER

Имена слоев для присвоения этой опции печати <текущие>: Ввести список имен или нажать клавишу ENTER

Настройки печати назначаются слою или слоям.

ПСтиль

Задание стиля печати для слоя. Эта опция недоступна в текущем чертеже при использовании цветозависимых стилей печати (когда системная переменная PSTYLEPOLICY установлена в 1). См. раздел Использование стилей печати в Руководстве пользователя.

Введите стиль печати или [?] <Обычный>: Ввести имя, ввести ? для вывода списка имеющихся стилей печати или нажать клавишу ENTER

Если выбран стиль печати, отличный от стиля «Обычный», то отображается следующий запрос:

Список имен слоев для присвоения этой опции печати текущий <текущий>: Ввести список имен слоев, использующих этот стиль печати, или нажать ENTER для применения этого стиля только к текущему слою

Заморозить

Опция замораживает слои, делая их невидимыми, исключая из процессов регенерации и печати.

Список имен слоев для замораживания, или <выбрать объекты>: Ввести список имен или нажать ENTER и выбрать объекты

Разморозить

Опция размораживает слои, делая их видимыми. Размороженные слои участвуют в регенерации и выводятся на печать.

Список имен слоев для размораживания:

Блокировать

Блокирование слоев т.е. запрещение редактирования находящихся на них объектов.

Список имен слоев для блокирования или <выбрать объекты>: Ввести список имен или нажать ENTER и выбрать объекты

рАзблок

Разблокирование слоев т.е. разрешение редактирования находящихся на них объектов.

Cписок имен слоев для разблокирования или <выбрать объекты>: Ввести список имен или нажать ENTER и выбрать объекты

Конфигурация

Сохранение и восстановление состояний и свойств слоев чертежа.

Задайте опцию [?/Сохранить/Восстановить/изМенить/Имя/Удалить/имПорт/Экспорт]:

?— Выводится список именованных конфигураций слоев

Список файлов именованных конфигураций слоев (LAS) в папке вспомогательных файлов для чертежа.

Сохранить

Сохранение под отдельным именем состояний и свойств слоев в чертеже. При сохранении конфигурации следует указать, какие параметры слоев должны быть заменены на записанные в конфигурации при ее восстановлении.

Имя новой конфигурации слоев: Введите имя и нажмите клавишу ENTER

Какие состояния изменить

[Вкл/Змр/Блк/Печать/змрНов/Цвет/Типлин/Веслин/Стильпеч]: Ввести настройки, которые требуется сохранить, а затем нажать клавишу ENTER

Восстановить

Восстановление состояний и свойств слоев в чертеже, ранее сохраненных в конфигурации. Восстанавливаются только те состояния и свойства, которые были выбраны при сохранении конфигурации.

Имя восстанавливаемой конфигурации слоев или [?]: Ввести имя конфигурации слоев или ? для просмотра списка сохраненных конфигураций

Изменить

Изменение параметров для выбранной конфигурации слоев. При восстановлении конфигурации будут использованы новые значения параметров.

Имя изменяемой конфигурации слоев или [?]: Ввести имя конфигурации слоев или ? для просмотра списка сохраненных конфигураций

Какие состояния изменить

[Вкл/Змр/Блк/Печать/змрНов/Цвет/Типлин/Веслин/Стильпеч]: Ввести настройки, которые требуется изменить, а затем нажать клавишу ENTER

Имя

Изменение имени сохраненной конфигурации слоев.

Имя переименовываемой конфигурации слоев или [?]: Ввести имя конфигурации слоев или ? для просмотра списка сохраненных конфигураций

Имя новой конфигурации слоев:

Удалить

Удаление сохраненной конфигурации слоев.

Имя удаляемой конфигурации слоев или [?]: Ввести имя конфигурации слоев или ? для просмотра списка сохраненных конфигураций

Импорт

Загрузка в текущий чертеж конфигурации слоев, сохраненной ранее в LAS-файле. Возможно, после этого в чертеже будут созданы новые слои.

Имя импортируемого файла <текущее>:

Экспорт

Сохранение выбранной именованной конфигурации слоев в LAS-файле.

Имя экспортируемой конфигурации слоев или [?]: Ввести имя конфигурации слоев или ? для просмотра списка сохраненных конфигураций

Имя файла для экспорта состояний:


СЛОЙБЛК Команда

С Команды
С Команды
СЛОЙБЛК Команда
Понятия Процедуры Команды

Блокирует слои выбранных объектов

Панель "Слои II":

Выберите в меню "Формат": "Инструменты слоя" » "Блокировать слой"

Ввод команды: слойблк

Выберите объект на блокируемом слое:


СЛОЙВКЛ Команда

С Команды
С Команды
СЛОЙВКЛ Команда
Понятия Процедуры Команды

Включает все слои

Выберите в меню "Формат": "Инструменты слоя" » "Включить все слои"

Ввод команды: слойвкл

Все слои в чертеже включаются.


СЛОЙЗМР Команда

С Команды
С Команды
СЛОЙЗМР Команда
Понятия Процедуры Команды

Замораживает слой выбранных объектов

Панель "Слои II":

Выберите в меню "Формат": "Инструменты слоя" » "Заморозить слой"

Ввод команды: слойзмр

Текущие параметры: Видовые экраны=Вэзаморозить, Уровень вложения блоков=Блок (значение параметров по умолчанию)

Выберите объект в слое, который требуется заморозить или [Параметры /Отменить]: Выбрать объект или ввести п или о

Слой <имя слоя> заморожен.

Выберите объект на слое, который требуется заморозить

Задает замораживаемый слой.

Слой <"имя слоя"> заморожен.

Параметры

Отображает параметры видовых экранов и определений блоков. Выбранные параметры сохраняются и для следующих сеансов работы.

Введите тип параметра для [Видовые экраны/Выбор блока]:

Видовые экраны

Отображает параметры видовых экранов.

Использовать видовой экран в пространстве листа [Заморозить/Вэзаморозить] <Вэзаморозить>: Ввести з, чтобы заморозить объекты во всех видовых экранах, или в, чтобы заморозить только объект в текущем видовом экране

Набор блоков

Отображает параметры для определений блоков.

Введите уровень вложения набора блока [Блок/Объект/Нет] <Блок>: Ввести б, о или н, чтобы задать значение по умолчанию

Блок

Если выбранный объект вложен в блок, слой этого блока замораживается. Если выбранный объект вложен во внешнюю ссылку, слой этого объекта замораживается.

Объект

Замораживает слои выбранных объектов, даже если они вложены во внешнюю ссылку или в блок.

Нет

Если выбран блок или внешняя ссылка, замораживается слой, содержащий этот блок или внешнюю ссылку.

Отменить

Отменяет выбор предыдущего слоя.


СЛОЙИЗМНЕСК Команда

С Команды
С Команды
СЛОЙИЗМНЕСК Команда
Понятия Процедуры Команды

Делает слой выбранных объектов соответствующим слою назначения.

Панель "Слои II":

Выберите в меню "Формат": "Инструменты слоя" » "Соответствие слоев"

Ввод команды: слойизмнеск

Выберите объекты, которые требуется отредактировать: Выбрать объект, чтобы изменить его слой

Выберите объект на слое назначения или [Имя]: Выбрать объект или ввести и, чтобы отобразить диалоговое окно "Перенос на слой"

Если в ответ на подсказку "Команда" ввести -слойизмнеск, будет вызван вариант команды СЛОЙИЗМНЕСК, использующий интерфейс командной строки.

Выбрать объект на слое назначения

Выбирается объект на слое назначения.

Имя

Выводится на экран диалоговое окно Изменить а слой.

Темы:

  • Диалоговое окно "Перенос на слой"
  • СЛОЙИЗМНЕСК вариант для командной строки


Диалоговое окно "Перенос на слой"

С Команды
С Команды
Диалоговое окно "Перенос на слой"
Понятия Процедуры Команды

Панель "Слои II":

Выберите в меню "Формат": "Инструменты слоя" » "Сменить на текущий слой"

Ввод команды: слойизмнеск

Отображение списка слоев, доступных для выбора в слое назначения. Кроме того, можно создать новый слой назначения.

Текущий слой

Отображает слой, выбранный в настоящий момент. Создает имя нового слоя путем ввода имени.

Список слоев назначения

Отображает список слоев, содержащихся в чертеже.


СЛОЙИЗМНЕСК вариант для командной строки

С Команды
С Команды
СЛОЙИЗМНЕСК вариант для командной строки
Понятия Процедуры Команды

Если в ответ на подсказку "Команда" ввести -слойобъед, будет вызван вариант команды СЛОЙОБЪЕД, использующий интерфейс командной строки.

Выберите объекты, которые требуется отредактировать: Выбрать объект, чтобы изменить его слой


СЛОЙОБЪЕД Команда

С Команды
С Команды
СЛОЙОБЪЕД Команда
Понятия Процедуры Команды

Объединение выбранных слоев в слое назначения

Выберите в меню "Формат": "Инструменты слоя" » "Объединить слой"

Ввод команды: слойобъед

Выберите объект на слое, который требуется объединить, или [Имя]: Выбрать объект или ввести и, чтобы отобразить диалоговое окно "Объединение слоев"

После объединения выбранного слоя (слоев) на экран выводится следующая подсказка:

Выберите объект на целевом слое или [Имя]: Выбрать объект или ввести и, чтобы отобразить диалоговое окно "Объединение слоев"

Слой, выбранный пользователем и объединяемый с целевом слоем, удаляется.

Если в ответ на подсказку "Команда" ввести -слойобъед, будет вызван вариант команды СЛОЙОБЪЕД, использующий интерфейс командной строки.

Выберите объект на слое, который требуется объединить

Выбирается объект на слое, который требуется объединить.

Выбранные слои: <имя слоя>

Выберите объект на слое, который требуется объединить, или [Имя/Отменить]: Выбрать объект, ввести и, чтобы отобразить диалоговое окно "Объединение слоев", или ввести о

Имя

Вызов диалогового окна "Объединение слоев".

Выбрать объект на целевом слое

Выбирается объект на слое назначения.

Выберите объект на целевом слое или [Имя]: Выбрать объект или ввести и, чтобы отобразить диалоговое окно "Объединение слоев"

Имя

Выводится на экран диалоговое окно Объединение слоев.

Темы:

  • Диалоговое окно "Объединение слоев"
  • Диалоговое окно "Объединение слоев"
  • СЛОЙОБЪЕД вариант для командной строки


Диалоговое окно "Объединение слоев"

С Команды
С Команды
Диалоговое окно "Объединение слоев"
Понятия Процедуры Команды

Выберите в меню "Формат": "Инструменты слоя" » "Объединить слой"

Ввод команды: слойобъед

Слои для объединения

Отображается список объединяемых слоев.


Диалоговое окно "Объединение слоев"

С Команды
С Команды
Диалоговое окно "Объединение слоев"
Понятия Процедуры Команды

Выберите в меню "Формат": "Инструменты слоя" » "Объединить слой"

Ввод команды: слойобъед

Отображается список слоев, с которыми могут быть объединены выбранные слои или объекты.

Целевой слой

Отображается первый слой в алфавитном порядке из списка слоев текущего чертежа.

Список целевых слоев

Отображается список слоев в алфавитном порядке, с которыми можно объединять выбранные слои или объекты.


СЛОЙОБЪЕД вариант для командной строки

С Команды
С Команды
СЛОЙОБЪЕД вариант для командной строки
Понятия Процедуры Команды

Если в ответ на подсказку "Команда" ввести -слойобъед, будет вызван вариант команды СЛОЙОБЪЕД, использующий интерфейс командной строки.

Выберите объект на слое, который требуется объединить, или [Имя]: Выбрать объект или ввести и, чтобы выбрать слой из списка слоев

После объединения выбранного слоя (слоев) на экран выводится следующая подсказка:

Выберите объект на целевом слое или [Имя]: Выбрать объект или ввести и, чтобы выбрать целевой слой из списка слоев

Слой, выбранный пользователем и объединяемый с целевом слоем, удаляется.

Выберите объект на объединяемом слое

Выбирается объект на слое назначения.

Выбранные слои: <имя слоя>

Выберите объект на слое, который требуется объединить, или [Имя]: Выбрать объект или ввести и

Имя

Отображается список слоев, в котором можно выбрать объединяемые слои.

Выбрать объединяемый слой.

Введите имя слоя или [?]: Ввести имя слоя или ?

Введите имя или имена слоев в список <*>: * Ввести имя слоя или нажать клавишу ENTER, чтобы вывести список всех слоев.

Выбрать объект на целевом слое

Выбирается объект на целевом слое.

Выбранные слои: <имя слоя>

Выберите объект на слое, который требуется объединить, или [Имя]: Выбрать объект, ввести и, чтобы отобразить список слоев

Имя

Отображается список слоев, с которыми можно объединять выбранный объект или слой.

Введите имя слоя или [?]: Ввести имя слоя или ?

Введите имя или имена слоев в список <*>: * Ввести имя слоя или нажать клавишу ENTER, чтобы вывести список всех слоев.


СЛОЙОВЭ Команда

С Команды
С Команды
СЛОЙОВЭ Команда
Понятия Процедуры Команды

Изолирует слой объекта в текущий видовой экран

Выберите в меню "Формат": "Инструменты слоя" » "Изолировать слой в текущий видовой экран"

Ввод команды: слойовэ

Изолирует слой выбранного объекта в текущий видовой экран, замораживая слой во всех видовых экранах, кроме текущего. Можно изолировать все разметки листа или только текущую.

Примечание Команда СЛОЙОВЭ работает только, когда параметр TILEMODE установлен в 0, и когда определены два или более видовых экрана в пространстве листа.

Действующие параметры : Разметки листа= , Уровень вложения блоков=

Выберите объекты на слое, который требуется выделить в видовом экране или [Параметры /Отменить]: выбрать объекты или ввести опцию

Выберите объекты на слое, который требуется выделить в видовом экране

Выбираются объекты, слой которых требуется изолировать в видовом экране.

Параметры

Отображает типы параметров "Видовые экраны" и "Набор блоков". Выбранные настройки сохраняются и для следующих сеансов работы.

Введите тип параметра Видовые экраны/Набор блоков]:

Разметки листа

Отображаются параметры разметок листа для изолируемых слоев.

Выделить слои во всех видовых экранах, кроме текущего, для [Все разметки листа/Текущая разметка листа] введите "Все разметки листа" или "Текущая разметка листа"

  • Все разметки листа: во всех разметках листов изолируются слои выбранных объектов во все видовые экраны, кроме текущего
  • Текущая разметка листа: в текущей разметке изолируются слои выбранных объектов во все видовые экраны, кроме текущего. Выбранная настройка сохраняется и для следующих сеансов работы.

Набор блоков

Отображает типы параметров "Набор блоков", в которых можно замораживать слои выбранных объектов.

Введите уровень вложения набора блоков [Блок/Объект/Нет] <Блок>: ввести б, о или н, чтобы задать значение по умолчанию

  • Блок: изолируются слои выбранных объектов. Если выбранный объект вложен в блок, слой, содержащий этот блок, изолируется. Если выбранный объект вложен во внешнюю ссылку, слой этого объекта изолируется.
  • Объект : изолируются слои выбранных объектов, даже если они вложены во внешнюю ссылку или в блок.
  • Нет: изолируются слои выбранных объектов. Если выбран блок или внешняя ссылка, изолируется слой, содержащий этот блок или внешнюю ссылку.

Отменить

Отменяет выбор предыдущего слоя.


СЛОЙОТД Команда

С Команды
С Команды
СЛОЙОТД Команда
Понятия Процедуры Команды

Изолирует слой выбранных объектов так, что все другие слои выключаются.

Панель "Слои II":

Выберите в меню "Формат": "Инструменты слоя" » "Изолировать слой"

Ввод команды: слойотд

Если в рабочем сеансе пользователь вносит изменения в слои и хочет восстановить состояние слоя, в котором он находился непосредственно до ввода команды СЛОЙОТД, необходимо использовать команду СЛОЙОТДОТМ.

Выберите объекты на слое (слоях), который (е) требуется выделить

Выбор объектов, слой которых требуется выделить.

Параметры

Задает настройку, которая определяет, будут ли заморожены слои в видовых экранах. Выбранные настройки сохраняются и для следующих сеансов работы.

Использовать видовой экран в пространстве листа [Вэзаморозить/Откл] <Вэзаморозить>:

Вэзаморозить

Выделяются слои на текущем видовом экране в пространстве листа. На выделенном слое отображаются объекты, все остальные слои текущего видового экрана заморожены. Другие видовые экраны на чертеже остаются без изменений.

Откл

Выделяются слои в видовых экранах, в пространстве модели и в пространстве листа. Отображаются объекты на выделенном слое. Все другие объекты в видовых экранах и в пространстве модели выключаются.


СЛОЙОТДОТМ Команда

С Команды
С Команды
СЛОЙОТДОТМ Команда
Понятия Процедуры Команды

Включает слои, которые были выключены последней командой СЛОЙОТД

Панель "Слои II":

Выберите в меню "Формат": "Инструменты слоя" » "Отключить изоляцию слоя"

Ввод команды: слойотдотм

СЛОЙОТДОТМ восстанавливает слои в том состоянии, которое они имели до выполнения команды СЛОЙОТД. Команда СЛОЙОТДОТМ восстанавливает параметры слоя, которые имели место до использования команды СЛОЙОТД. Если команда СЛОЙОТД не применялась, команда СЛОЙОТДОТМ не восстанавливает никакие слои.

Примечание Можно также восстановить предыдущее состояние слоев нажатием кнопки "Предыдущий слой", находящейся на инструментальной панели "Слои" (или вводом в командной строке команды СЛОЙП), пока не внесены никакие изменения в параметры слоя.


СЛОЙОТКЛ Команда

С Команды
С Команды
СЛОЙОТКЛ Команда
Понятия Процедуры Команды

Выключает слой выбранного объекта

Панель "Слои II":

Выберите в меню "Формат": "Инструменты слоя" » "Отключить слой"

Ввод команды: слойоткл

Текущие параметры : Видовые экраны= , Уровень вложения блоков=

Выберите объект на слое, который требуется отключить или [Параметры/Отменить]: Выбрать объект, ввести п или о

Выберите объект на слое, который требуется отключить

Выбирается один или более объектов, слои которых требуется отключить.

Параметры

Отображаются типы параметров "Видовые экраны" и "Набор блоков". Выбранные параметры сохраняются и для следующих сеансов работы.

Введите тип параметра для [Видовые экраны/Набор блоков]:

Видовые экраны

Отображаются типы параметров "Видовые экраны".

Выводится следующий запрос:

Использовать видовой экран в пространстве листа [Вэзаморозить/Откл] <Вэзаморозить>: Ввести в, чтобы заморозить выбранный слой в текущем видовом экране, или ввести о, чтобы отключить выбранные слои во всех видовых экранах

Вэзаморозить

В пространстве листа замораживаются слои, выбранные в текущем видовом экране.

Откл

В пространстве листа выключаются слои, выбранные во всех видовых экранах.

Набор блоков

Отображаются типы параметров "Набор блоков", в которых можно замораживать слои выбранных объектов.

Введите уровень вложения набора блоков [Блок/Объект/Нет] <Блок>: Ввести б, о или н, чтобы задать значение по умолчанию

  • Блок: Выключает слои выбранных объектов. Если выбранный объект вложен в блок, слой, содержащий этот блок, выключается. Если выбранный объект вложен во внешнюю ссылку, слой этого объекта выключается.
  • Объект: Выключает слои выбранных объектов, даже если они вложены во внешнюю ссылку или в блок.
  • Нет: Выключает слои выбранных объектов. Если выбран блок или внешняя ссылка, выключается слой, содержащий этот блок или внешнюю ссылку.

Отменить

Отменяется выбор предыдущего слоя.


СЛОЙП Команда

С Команды
С Команды
СЛОЙП Команда
Понятия Процедуры Команды

Отмена последних изменений состояний и свойств слоев

Панель Слои:

Ввод команды: слойп

Отмена последних изменений состояний и свойств слоев, таких как цвет или тип линий. После восстановления настроек появится сообщение: “Восстановлена предыдущая конфигурация слоев. ”

Команда СЛОЙП (Предыдущий слой) не поддерживает отмену следующих изменений:

  • Переименование слоев: Если переименовать слой и изменить его свойства, команда СЛОЙП восстанавливает исходные свойства, но не имя.
  • Удаление слоев: Нельзя восстановить слои, удаленные как с помощью Диспетчера свойств слоев, так и с помощью утилиты очистки чертежа.
  • Создание слоев: Если добавить в чертеж новый слой, его нельзя будет удалить с помощью команды СЛОЙП.


СЛОЙПРЕЖИМ Команда

С Команды
С Команды
СЛОЙПРЕЖИМ Команда
Понятия Процедуры Команды

Включение и отключение режима записи последовательности изменений свойств слоев.

Ввод команды: слойпрежим

Режим слежения для команды СЛОЙП [Вкл/ Откл] <Вкл>: Ввести вкл или выкл или нажать клавишу ENTER

После задания опции «Вкл» начинается запись последовательности всех действий по изменению слоев. После задания опции «Откл» запись прекращается.


СЛОЙРАЗБЛ Команда

С Команды
С Команды
СЛОЙРАЗБЛ Команда
Понятия Процедуры Команды

Разблокирует слой выбранного объекта

Панель "Слои II":

Выберите в меню "Формат": "Инструменты слоя" » "Разблокировать слой"

Ввод команды: слойразбл

При наведении курсора на объекты блокированных слоев отображается значок блокировки.

Выберите объект на слое для разблокирования:


СЛОЙРМР Команда

С Команды
С Команды
СЛОЙРМР Команда
Понятия Процедуры Команды

Размораживает все слои

Выберите в меню "Формат": "Инструменты слоя" > "Разморозить все слои"

Ввод команды: слойрмр

Размораживает все слои в чертеже.

Примечание СЛОЙРМР не размораживает слои на видовом экране. Чтобы разморозить слои видового экрана, используйте команду ВСЛОЙ.


СЛОЙТЕК Команда

С Команды
С Команды
СЛОЙТЕК Команда
Понятия Процедуры Команды

Делает слой выбранных объектов текущим

Панель "Слои II":

Выберите в меню "Формат": "Инструменты слоя" » "Сменить на текущий слой"

Ввод команды: слойтек

Выберите объекты, которые должны находиться в текущем слое: Использовать метод выбора объектов и по окончании выбора нажать клавишу ENTER

N объектов переведено в слой X (текущий слой).


СЛОЙТРАНС Команда

С Команды
С Команды
СЛОЙТРАНС Команда
Понятия Процедуры Команды

Изменение системы слоев чертежа в соответствии с установленными пользователем стандартами

Панель Стандарты оформления:

Меню "Сервис": "Стандарты оформления" » "Транслятор слоев"

Ввод команды: слойтранс

Открывается диалоговое окно «Транслятор слоев».

Темы:

  • Транслятор слоев
  • Диалоговое окно «Параметры»
  • Диалоговое окно «Редактирование слоя» / «Новый слой»


Транслятор слоев

С Команды
С Команды
Транслятор слоев
Понятия Процедуры Команды

Панель Стандарты оформления:

Меню "Сервис": "Стандарты оформления" » "Транслятор слоев"

Ввод команды: слойтранс

В Трансляторе слоев выбираются исходные слои и слои, в которые они должны быть преобразованы.

Исходные слои

Задание слоев текущего чертежа для преобразования. Выбрать слои для преобразования можно как непосредственно в списке «Исходные слои», так и с помощью фильтра.

Цвет значка рядом с именем слоя показывает, используется ли данный слой объектами чертежа. Темный цвет означает, что слой используется, светлый что слой не используется. Не используемые в чертеже слои могут быть удалены, если нажать правую кнопку мыши на списке «Исходные слои» и выбрать из контекстного меню пункт «Удалить неиспользуемые».

Фильтр

Использование фильтра для выбора слоев из списка исходных. В фильтре можно использовать символы-шаблоны. Список символов-шаблонов приведен в таблице раздела Фильтрация и сортировка слоев в списке Руководства пользователя. Слои, удовлетворяющие условиям фильтра, добавляются к списку выбранных явным указанием.

Выбрать

Выбор слоев из числа отфильтрованных.

Сопоставить

Сопоставление слоев из списка исходных и слоев назначения.

Одноименные

Сопоставление слоев из обоих списков, имеющих одинаковые имена.

Слои назначения

Список слоев, в которые можно преобразовать слои текущего чертежа.

Загрузить

Загрузка слоев в список слоев назначения из чертежа, шаблона или файла стандартов по выбору пользователя. Если в выбранном файле уже содержится таблица сопоставлений слоев, то эта информация отображается в окне Транслятора слоев.

В один чертеж можно загружать слои из нескольких файлов. Загрузка слоя не происходит, если его имя совпадает с именем уже загруженного слоя. Аналогично, отменяется загрузка элемента таблицы сопоставлений, если он совпадает с имеющимся в чертеже.

Новый

Добавление нового слоя в список слоев назначения. Если до нажатия кнопки "Новый" выбрать какой-либо слой в списке "Слои назначения", свойства этого слоя будут использованы по умолчанию для нового слоя. Запрещено использовать имя уже существующего слоя при создании нового слоя.

Таблица сопоставлений слоев

Вывод списка слоев, предназначенных для преобразования, и списка свойств, которые они при этом получат. У каждого слоя эти свойства можно отредактировать с помощью кнопки «Изменить».

Изменить

Открывает диалоговое окно "Редактирование слоя", где можно изменить выбранное соответствие слоев. Здесь можно изменить цвет, тип и вес линий слоя. Если во всех чертежах, участвующих в преобразовании слоев, используются именованные стили печати, стиль печати также можно изменять.

Удалить

Удаление выбранного сопоставления слоев из таблицы.

Сохранить

Сохранение текущей таблицы сопоставлений слоев в отдельном файле для использования в дальнейшем.

Сопоставления слоев сохраняются в файле формата DWG или DWS. При сохранении можно заместить уже существующий файл или создать новый. Транслятор слоев создает слои в файле и записывает в каждый из них информацию о сопоставлениях. Также в файл заносится информация об использованных типах линий.

Режимы

Открывает диалоговое окно "Параметры", где можно настроить преобразование слоев.

Преобразовать

Запуск процесса преобразования слоев на основе заданных сопоставлений.

При этом сначала появляется запрос на сохранение текущего сопоставления слоев, если оно не было сохранено.


Диалоговое окно «Параметры»

С Команды
С Команды
Диалоговое окно «Параметры»
Понятия Процедуры Команды

Панель Стандарты оформления:

Меню "Сервис": "Стандарты оформления" » "Транслятор слоев"

Ввод команды: слойтранс

Дополнительные опции управления процессом преобразования слоев.

Установить для объектов цвет ПоСлою

Поведение цветов объектов при преобразовании слоев остаются без изменений или принимают присвоенный этому слою цвет. Если опция включена, то объекты получают текущий для слоя назначения цвет. Если опция отключена, то объекты сохраняют свой оригинальный цвет.

Установить для объектов тип линий ПоСлою

Поведение типов линий объектов при преобразовании слоев: остаются без изменений или принимают присвоенный этому слою тип. Если опция включена, то объекты получают текущий для слоя назначения тип линий. Если опция отключена, то объекты сохраняют свой оригинальный тип линий.

Преобразовывать объекты в блоках

Установка режима преобразования объектов внутри блоков. Если опция включена, то объекты внутри блоков также преобразуются. Если опция отключена, то такие объекты остаются без изменений.

Вести журнал транзакций

Включение/отключение режима записи результатов процесса преобразования слоев в файл журнала. Если опция включена, то в папке, где находится исходный чертеж, создается файл журнала. Этот файл имеет одинаковое с чертежом имя, его расширение .log. Если опция отключена, файл журнала не создается.

Показывать содержимое выбранного слоя

Выбор слоев, отображаемых в области рисования. Если опция включена, то в области рисования отображаются только те слои, которые выбраны в диалоговом окне Транслятора слоев. Если опция отключена, отображаются все слои.


Диалоговое окно «Редактирование слоя» / «Новый слой»

С Команды
С Команды
Диалоговое окно «Редактирование слоя» / «Новый слой»
Понятия Процедуры Команды

Панель Стандарты оформления:

Меню "Сервис": "Стандарты оформления" » "Транслятор слоев"

Ввод команды: слойтранс

Установка и изменение свойств слоев.

Имя

Имя слоя.

Тип линий

Тип линий слоя.

Цвет

Цвет слоя.

Вес линий

Вес линий слоя.

Стиль печати

Стиль печати слоя. Изменение стиля печати возможно, только если во всех чертежах используются именованные стили печати.


СЛОЙУДАЛ Команда

С Команды
С Команды
СЛОЙУДАЛ Команда
Понятия Процедуры Команды

Удаляет слой выбранных объектов и все объекты на слое, удаляет слой с чертежа

Выберите в меню "Формат": "Инструменты слоя" » "Удалить слой"

Ввод команды: слойудал

Выберите объект на слое для удаления или [Имя]: Выбрать объект или ввести и, чтобы отобразить диалоговое окно "Удаление слоев"

Если в ответ на подсказку "Команда" ввести -слойудал, будет вызван вариант команды СЛОЙУДАЛ, использующий интерфейс командной строки.

Выберите удаляемый объект на слое

Выберите объект на слое, который требуется удалить.

Выберите на слое удаляемый объект или [Имя/Отмена]: Выбрать объект на втором слое или ввести о

Имя

Вызов диалогового окна "Удаление слоев".

Темы:

  • Диалоговое окно "Удаление слоев"
  • СЛОЙУДАЛ вариант для командной строки


Диалоговое окно "Удаление слоев"

С Команды
С Команды
Диалоговое окно "Удаление слоев"
Понятия Процедуры Команды

Выберите в меню "Формат": "Инструменты слоя" » "Удалить слой"

Ввод команды: слойудал

Отображает доступные для удаления слои.

Удаляемые слои

Отображает список слоев, подлежащих удалению. Нажмите клавишу SHIFT или CTRL, чтобы выбрать более одного слоя. Следующие слои удалить невозможно: текущий слой, слой 0, блокированные слои и слои с зависимостью от внешних ссылок.


СЛОЙУДАЛ вариант для командной строки

С Команды
С Команды
СЛОЙУДАЛ вариант для командной строки
Понятия Процедуры Команды

Если в ответ на подсказку "Команда" ввести -слойудал, будет вызван вариант команды СЛОЙУДАЛ, использующий интерфейс командной строки.

Выберите объект на слое для удаления или [Имя]: Выбрать объект или ввести и.

Выберите объект на слое для удаления или [Имя/Отмена]: Выбрать объект, ввести и или о

Выберите объект на слое для удаления

Выберите объект на слое, который требуется удалить.

Выберите объект на слое для удаления или [Отмена]: Выбрать удаляемый объект или ввести о

Имя

Выбирает удаляемый слой.

Введите имя слоя или [?]: Ввести имя слоя или ?

Введите имя или имена слоев в список <*>: * Ввести имя слоя или нажать клавишу ENTER, чтобы вывести список всех слоев.


СЛОЙУСТЕК Команда

С Команды
С Команды
СЛОЙУСТЕК Команда
Понятия Процедуры Команды

Делает слой выбранного объекта текущим

Панель Слои:

Выберите в меню "Формат": "Инструменты слоя" » "Сделать слой объекта текущим"

Ввод команды: слойустек

Выберите объект, слой которого должен стать текущим: Выбрать объект, чтобы сделать его слой текущим


СМЕНАПРОСТР Команда

С Команды
С Команды
СМЕНАПРОСТР Команда
Понятия Процедуры Команды

Переносит объекты из пространства модели в пространство листа и наоборот

Меню "Редактирование": "Изменить пространство"

Ввод команды: сменапростр

Выбрать объекты:

Установите активный видовой экран ИСТОЧНИК и для продолжения нажать ENTER

Выдает подсказки, аналогичные следующим:

N объекта(ов) сменили пространство МОДЕЛИ на пространство ЛИСТА

Объекты были масштабированы с коэффициентом n, чтобы обеспечить видимый формат.

Перенесенный объект соответствующим образом масштабирован в новом пространстве.


СМЕЩЕНИЕ Команда

С Команды
С Команды
СМЕЩЕНИЕ Команда
Понятия Процедуры Команды

Построение концентрических кругов, параллельных отрезков и кривых

Панель "Редактирование":

Меню "Редактирование": "Смещение"

Ввод команды: смещение

Текущие настройки: Удалить исходные = текущие Слой = текущий OFFSETGAPTYPE = текущее

Укажите расстояние смещения или [Через/Удалить/Слой] <текущий>: Указать расстояние, задать опцию или нажать ENTER

Для удобства вызов команды СМЕЩЕНИЕ повторяется. Для завершения команды следует нажать ENTER.

Расстояние смещения

Построение объекта, расположенного на заданном расстоянии от существующего объекта.

Выберите объект для смещения или [Выход/Отменить]<выход>: Выбрать один объект, задать опцию или нажать ENTER для завершения команды

Укажите точку, определяющую сторону смещения, или [Выход/Несколько/Отменить] <выход или следующий объект>: Указать точку (1) по нужную сторону от объекта или задать опцию

Выход

Завершение команды СМЕЩЕНИЕ.

Несколько

Включает режим многократного смещения, при котором смещение повторяется с учетом текущего расстояния смещения.

Отменить

Отменяет предыдущее смещение.

Через

Построение объекта, проходящего через заданную точку.

Выберите объект для смещения или <выход>: Выбрать один объект или нажать ENTER для завершения команды

Примечание Для наилучшего результата при смещении полилинии с углами точку, через которую должен проходить новый объект, следует указать рядом с серединой линейного сегмента, а не угла.

Укажите точку, через которую проходит объект или [Выход/Несколько/Отменить]<выход или следующий объект>: Указать точку (1), через которую должен проходить объект, или ввести расстояние

Выход

Завершение команды СМЕЩЕНИЕ.

Несколько

Включает режим многократного смещения, при котором смещение повторяется с учетом дополнительных точек, через которые должен проходить объект.

Отменить

Отменяет предыдущее смещение.

Удалить

Удаляет исходный объект после смещения.

Удалить исходный объект после смещения? [Да/Нет]<текущее>: Ввести д или н

Слой

Определяет положение смещенных объектов: на текущем слое или на слое исходного объекта.

Введите параметр слоя для смещаемых объектов [Текущий/Источник]<текущий>: Задать опцию


СОЕДИНИТЬ Команда

С Команды
С Команды
СОЕДИНИТЬ Команда
Понятия Процедуры Команды

Соединяет объекты для формирования одного целого объекта

Панель Редактирование:

Меню "Изменить": Соединить

Ввод команды: соединить

Выберите исходный объект: Выберите линию, полилинию, дугу, эллиптическую дугу, сплайн или спираль

В зависимости от того, какой выбран исходный объект, отобразится одна из следующих команд.

Линия

Выберите линии для соединения с исходным объектом: Выберите одну или несколько линий и нажмите ENTER

Объекты линии должны быть коллинеарны (т.е. лежать на одной бесконечной линии), но между ними должны быть зазоры.

Полилиния

Выберите объекты для соединения с исходным объектом: Выберите один или несколько объектов и нажмите ENTER

Объектами могут быть линии, полилинии или дуги. Между объектами не может быть зазоров, и они должны лежать в одной плоскости, параллельной плоскости XY ПСК.

Дуга

Выберите дуги, которые необходимо объединить с источником, или [Замкнуть]: Выберите одну или несколько дуг и нажмите ENTER или введите З

Дуги должны лежать на одной воображаемой окружности, но между ними должны быть зазоры. Опция "Замкнуть" преобразует исходную дугу в окружность.

Примечание При объединении двух или более дуг их объединение начинается с исходной дуги в направлении против часовой стрелки.

Эллиптическая дуга

Выберите эллиптические дуги, которые необходимо объединить с источником, или [Замкнуть]: Выберите одну или несколько эллиптических дуг, нажмите ENTER или введите З

Эллиптические дуги должны лежать на одном эллипсе, но между ними должны быть зазоры. Опция "Замкнуть" замыкает исходную эллиптическую дугу и преобразует ее в законченный эллипс.

Примечание При объединении двух или более эллиптических дуг их объединение начинается с исходной эллиптической дуги в направлении против часовой стрелки.

Сплайн

Выберите сплайны или спирали для соединения с исходным объектом: Выберите один или несколько сплайнов или спиралей и нажмите ENTER

Объекты типа "сплайн" и "спираль" должны быть непрерывными от начала до конца. Результирующим объектом является один сплайн.

Спираль

Выберите сплайны или спирали для соединения с исходным объектом: Выберите один или несколько сплайнов или спиралей и нажмите ENTER

Объекты типа "спираль" должны быть непрерывными от начала до конца. Результирующим объектом является один сплайн.


СОЗДАТЬ Команда

С Команды
С Команды
СОЗДАТЬ Команда
Понятия Процедуры Команды

Создание нового чертежа

Меню "Файл": "Создать"

Ввод команды: создать

Характер действий, выполняемых командой СОЗДАТЬ, зависит от значения параметра "При запуске" на вкладке "Система" диалогового окна "Настройка".

  • Диалоговое окно начала работы: Команда СОЗДАТЬ вызывает диалоговое окно "Создание нового чертежа.
  • Без окна начала работы: Команда СОЗДАТЬ вызывает окно "Выбор шаблона" (стандартное диалоговое окно выбора файлов).

Если значение системной переменной FILEDIA равно 0, а не 1, выводятся подсказки для этой команды. Если значение системной переменной FILEDIA равно 0, подсказка в командной строке отображается независимо от параметра "При запуске".

Темы:

  • Диалоговое окно "Создание нового чертежа"
  • Мастер быстрой подготовки
  • Мастер детальной подготовки
  • СОЗДАТЬ (вариант для командной строки)


Диалоговое окно "Создание нового чертежа"

С Команды
С Команды
Диалоговое окно "Создание нового чертежа"
Понятия Процедуры Команды

Меню "Файл": "Создать"

Ввод команды: создать

Задание параметров нового чертежа. С помощью параметра "С самого начала" можно создать новый чертеж с использованием британской или метрической системы единиц по умолчанию. С помощью параметра "По шаблону" можно создать новый чертеж с использованием настроек, заданных в выбранном шаблоне чертежа. С помощью параметра "Вызов Мастера" можно создать новый чертеж с использованием настроек, заданных в окне мастера быстрой подготовки или мастера детальной подготовки. (первый параметр - "Открытие чертежа" - недоступен при использовании команды СОЗДАТЬ. Для открытия чертежа служит команда ОТКРЫТЬ.)

С самого начала

Создание нового чертежа с использованием установленных по умолчанию единиц измерения (британских или метрических) [системная переменная MEASUREINIT]. Сменить систему измерений можно и позже, в процессе работы над чертежом, присвоив новое значение системной переменной MEASUREMENT. Файл Drawing1.dwg открывается при запуске программы и является чертежом на основе простейшего шаблона.

Британские

Создание нового чертежа, использующего британские систему единиц измерения. При этом размер области рисования (лимиты сетки) по умолчанию равен 12 на 9 дюймов.

Метрические

Создание нового чертежа, использующего метрическую систему единиц измерения. При этом размер области рисования (лимиты сетки) по умолчанию равен 429 на 297 дюймов.

Совет

Отображает описание используемых параметров единиц измерения.

По шаблону

Создание нового чертежа на основе шаблона. В шаблонах чертежей хранятся различные параметры чертежа, в том числе стандартные слои, размерные стили и виды. В отличие от других файлов чертежей, файлы шаблонов имеют расширение .dwt. Обычно шаблоны находятся в папке template.

Несколько стандартных шаблонов для чертежей поставляются вместе с программой. Можно создавать новые файлы шаблонов, сохраняя файлы чертежей с расширением .dwt. См. раздел Использование файла шаблона для создания чертежа в документе Руководство пользователя.

Выбрать шаблон

Вывод списка всех существующих DWT-файлов, находящихся в папке, которая задана в диалоговом окне "Настройка". Выбрать файл в качестве основы для создания нового чертежа.

Образец

Отображает образец для просмотра выбранного файла.

Обзор

Вызов диалогового окна "Выбор файла шаблона" (стандартное диалоговое окно выбора файлов), в котором можно указать шаблон, не попавший в список выбора шаблонов.

Описание шаблона

Отображает описание выбранного шаблона. При создании собственного шаблона можно использовать диалоговое окно "Описание шаблона" для ввода текста описания шаблона. См. команду СОХРАНИТЬКАК.

Вызов мастера

Пошаговые инструкции для задания параметров нового чертежа. Существует две разновидности мастеров: мастер быстрой подготовки и мастер детальной подготовки.

Мастер быстрой подготовки

Отображает диалоговое окно Мастер быстрой подготовки, в котором можно задать единицы и область для размещения нового чертежа. Мастер быстрой подготовки также устанавливает подходящие значения высоты текста, шага привязки и прочих параметров.

Детальная подготовка

Отображает диалоговое окно Мастер детальной подготовки, в котором можно задать линейные и угловые единицы, способ отсчета углов и область для размещения нового чертежа. Мастер детальной подготовки также устанавливает подходящие значения высоты текста, шага привязки и прочих параметров.

Описание мастера

Отображает описание выбранного мастера.


Мастер быстрой подготовки

С Команды
С Команды
Мастер быстрой подготовки
Понятия Процедуры Команды

Панель "Стандартная":

Меню "Файл": "Создать"

Ввод команды: создать

Задание единиц и области рисования.

Мастер быстрой подготовки состоит из двух страниц: "Единицы" и "Область рисования". Для перемещения по страницам мастера используются кнопки "Назад" и "Далее"; кнопка "Готово" завершает работу мастера и создает новый чертеж с указанными параметрами.

Единицы

Указывает формат, в котором измеренные значения и координаты вводятся пользователем и отображаются в программе. Программа поддерживает несколько форматов. Два из этих форматов, "Инженерные" и "Архитектурные", используют дюймы в качестве основных единиц измерения. Можно выбирать другие форматы в соответствии с используемыми единицами измерения.

Примечание Точность числовых данных задается в окне мастера детальной подготовки или с помощью команды ЕДИНИЦЫ. Точность, предлагаемая по умолчанию мастером быстрой подготовки, равна четырем знакам после запятой (0,0000).

Десятичные

Вывод измеренных значений в десятичной записи.

Конструкторский

Вывод измеренных значений в футах и десятичных дюймах.

Архитектурные

Вывод измеренных значений в футах, дюймах и долях дюймов.

С дробной частью

Вывод измеренных значений с дробными частями.

Научные

Вывод размеров в виде десятичного числа в интервале от 0 до 10, умноженного на 10 в заданной степени.

Площадь

Задание ширины и длины области рисования в полномасштабных единицах. При использовании этого параметра ограничивается область рисования, на которой отображаются точки сетки, если сетка включена. При включении режима контроля с помощью команды ЛИМИТЫ данный параметр также ограничивает значения координат, вводимых пользователем, пределами заданной прямоугольной площади. Команда ЛИМИТЫ позволяет изменять размеры области рисования, а также включать и отключать режим контроля.


Мастер детальной подготовки

С Команды
С Команды
Мастер детальной подготовки
Понятия Процедуры Команды

Панель "Стандартная":

Меню "Файл": "Создать"

Ввод команды: создать

Задание линейных и угловых единиц, способа отсчета углов и области рисования.

Мастер детальной подготовки состоит из пяти страниц: "Единицы", "Угол", "Нулевой угол", "Отсчет углов" и "Область рисования". Для перемещения по страницам мастера используются кнопки "Назад" и "Далее"; кнопка "Готово" завершает работу мастера и создает новый чертеж с указанными параметрами.

Впоследствии единицы чертежа, углы, нулевой угол и направление отсчета углов можно изменить с помощью команды ЕДИНИЦЫ, а область рисования с помощью команды ЛИМИТЫ.

Единицы

Задание формата и точности представления единиц. Формат единиц - это формат, в котором измеренные значения и координаты вводятся пользователем и отображаются в программе. Те же форматы единиц можно задать на странице "Единицы" мастера быстрой подготовки. Подробнее см. раздел Единицы.

Точность определяет число десятичных знаков или представление дробной части числа при выводе линейных размеров.

Угол

Указывает формат, в котором вводятся и отображаются значения угловых размеров.

Десятичные градусы

Измерение углов в градусах. Дробная часть представляется в десятичных градусах.

Град/Мин/Сек

Измерение углов в градусах. Дробная часть представляется в минутах и секундах.

Грады

Измерение углов в градах.

Радианы

Измерение углов в радианах.

Топографические

Измерение углов в топографических единицах.

Нулевой угол

Выбор направления нулевого угла. При вводе значение угла отсчитывается против или по часовой стрелке от начального направления, указанного на этой странице. Направление отсчета задается на странице "Отсчет углов".

Восток

Задание направления нулевого угла на восток.

Север

Задание направления нулевого угла на север.

Запад

Задание направления нулевого угла на запад.

Юг

Задание направления нулевого угла на юг.

Другое

Задание другого (не на восток, север, запад или юг) направления. Введите значение нулевого угла отсчета.

Отсчет углов

Указывает направление от нулевого угла, в котором вводится и отображается положительное значение угла: против часовой стрелки или по часовой стрелке.

Площадь

Задание ширины и длины области рисования в полномасштабных единицах. При использовании этого параметра ограничивается область рисования, на которой отображаются точки сетки, если сетка включена. При включении режима контроля с помощью команды ЛИМИТЫ данный параметр также ограничивает значения координат, вводимых пользователем, пределами заданной прямоугольной площади. Команда ЛИМИТЫ позволяет изменять размеры области рисования, а также включать и отключать режим контроля.


СОЗДАТЬ (вариант для командной строки)

С Команды
С Команды
СОЗДАТЬ (вариант для командной строки)
Понятия Процедуры Команды

Если установлен режим создания нового чертежа без использования диалогового окна "Создание нового чертежа", или значение системной переменной FILEDIA равно 0, команда СОЗДАТЬ выводит следующий запрос:

Введите имя файла шаблона или [. (если нет)] <текущее>: Ввести имя, точку (.), или нажать ENTER

При вводе символа тильда (~) в ответ на запрос шаблона открывается диалоговое окно "Выбор шаблона" (стандартное диалоговое окно выбора файлов).


СОПРЯЖЕНИЕ Команда

С Команды
С Команды
СОПРЯЖЕНИЕ Команда
Понятия Процедуры Команды

Скругление углов и сопряжение объектов

Панель Редактирование:

Меню "Изменить": Сопряжение

Ввод команды: сопряжение

Текущие настройки: Режим = текущий, Радиус сопряжения = текущий

Выберите первый объект или [Отменить/Полилиния/Радиус/С обрезкой/Несколько]: Выберите объект любым способом или задайте опцию

Первый объект

Выбор первого из двух сопрягаемых 2D объектов или кромки 3D тела для округления или сопряжения кромки.

Выберите второй объект или нажмите клавишу SHIFT при выборе, чтобы создать угол: Выбрать объекты любым способом или удерживать нажатой клавишу SHIFT, чтобы выбрать объект и создать острый угол

При выборе линий, дуг или полилиний их длины регулируются для соответствия длине сопрягающей дуги. Можно удерживать нажатой клавишу SHIFT при выборе объектов для замены значения текущего радиуса сопряжения на 0.

Сопрягаемые линейные сегменты двумерной полилинии не обязательно являются смежными — между ними могут находиться другие сегменты. В последнем случае команда СОПРЯЖЕНИЕ удаляет промежуточные сегменты, заменяя их сопрягающими линиями.

Сопряжение дуг и окружностей можно выполнить несколькими способами. Выберите объекты там, где необходимо расположить конечные точки сопряжения.

Сопряжение окружностей производится с помощью дуг соответствующего радиуса; сами окружности при этом не обрезаются.

В трехмерных объектах возможно сопряжение нескольких ребер; каждое из них следует выбирать отдельно.

Введите радиус сопряжения <текущий>: Укажите расстояние или нажмите ENTER

Выберите кромку или [Цепь/Радиус]: Выберите кромки, введите ц или ра

Кромка

Выбор отдельных кромок. Выбор завершается нажатием клавиши ENTER.

При выборе трех и более кромок, сходящихся в вершине параллелепипеда, в этой вершине с помощью команды СОПРЯЖЕНИЕ строится угловое сопряжение, которое при совпадении радиусов трех сопряжений представляет собой участок шара.

Цепь

Заменяет режим выбора одной кромки на режим выбора цепи из нескольких кромок, называемый выбор цепи.

Выберите цепь кромок или <Кромка/Радиус>: Выбрать цепь кромок, ввести к или ра

Цепь кромок

Выбор последовательности кромок, расположенных по касательной друг к другу. Например, при выборе одной кромки верхней грани твердотельного трехмерного параллелепипеда с помощью команды СОПРЯЖЕНИЕ выбираются также все расположенные по касательной к нему кромки этой грани.

Кромка

Устанавливает режим выбора отдельных кромок.

Радиус

Определяет радиус округленной кромки.

Радиус

Определяет радиус округленной кромки.

Введите радиус сопряжения <текущий>: Задайте расстояние или нажмите ENTER

Отобразится предыдущий запрос:

Выберите кромку или [Цепь/Радиус]: Выберите одну или несколько кромок или введите ц или ра

Отменить

Отменяет предыдущую операцию в команде.

Полилиния

AutoCAD строит дуги сопряжения во всех точках пересечения линейных сегментов двумерной полилинии.

Выберите 2D полилинию:

Если два линейных сегмента разделены дугой, при приближении к которой они сходятся, команда СОПРЯЖЕНИЕ заменяет эту дугу сопрягающей дугой.

Радиус

Задание радиуса сопрягающей дуги.

Радиус сопряжения <текущий>: Задайте расстояние или нажмите ENTER

Введенное значение определяет текущий радиус для последующих команд СОПРЯЖЕНИЕ. Изменение радиуса не влияет на сопряжения, выполненные ранее.

С обрезкой

Определяет, обрезает ли СОПРЯЖЕНИЕ выбранные кромки по конечным точкам дуги сопряжения.

Режим обрезки [С обрезкой/Без обрезки] <текущий>: Задайте опцию или нажмите ENTER

С обрезкой

Обрезка выбранных кромок по конечным точкам сопрягающей дуги.

Без обрезки

Сопряжение без обрезки выбранных кромок.

Несколько

Скругление углов у нескольких наборов объектов. Команда СОПРЯЖЕНИЕ будет отображать основную подсказку, а также подсказку "Выберите второй объект" до тех пор, пока не будет нажата клавиша ENTER для завершения команды.


СОХРАНИТЬ Команда

С Команды
С Команды
СОХРАНИТЬ Команда
Понятия Процедуры Команды

Сохранение чертежа под текущим или заданным именем

Ввод команды: сохранить

Откроется диалоговое окно "Сохранение чертежа" (стандартное диалоговое окно выбора файлов). Можно сохранить чертеж под текущим именем или задать другое имя файла и сохранить копию чертежа под этим именем.

Команда СОХРАНИТЬ доступна только из командной строки. Вызов команды БСОХРАНИТЬ производится выбором пункта "Сохранить" в меню "Файл" или на панели "Стандартная". Если чертежу уже присвоено имя, команда БСОХРАНИТЬ выполняет сохранение чертежа под этим именем, не открывая диалогового окна "Сохранение чертежа". Если имя чертежу не присвоено, откроется диалоговое окно "Сохранение чертежа". После ввода имени файла чертежа он сохраняется.


СОХРАНИТЬКАК Команда

С Команды
С Команды
СОХРАНИТЬКАК Команда
Понятия Процедуры Команды

Сохранение копии текущего чертежа под новым именем

Меню "Файл": "Сохранить как"

Ввод команды: сохранитькак

Откроется диалоговое окно "Сохранение чертежа" (стандартное диалоговое окно выбора файлов). В нем нужно выбрать тип файла и ввести имя. Сохранение чертежа в формате DXF™приводит к снижению производительности.

Примечание Формат файлов чертежей AutoCAD 2004 поддерживается версиями AutoCAD 2004, AutoCAD 2005 и AutoCAD 2006.

Подробнее об ограничениях, действующих при сохранении файлов в форматах прежних версий, см. раздел Сохранение чертежей в форматах прежних версий.

Если в диалоговом окне "Сохранение чертежа" выбрать "Сервис" » "Параметры", откроется диалоговое окно "Параметры сохранения", в котором можно настроить параметры сохранения DWG- и DXF-файлов.

Файл сохраняется под указанным именем. Если файлу уже присвоено имя, он сохраняется под новым именем. При сохранении чертежа в качестве шаблона открывается диалоговое окно "Описание шаблона", в котором можно ввести описание шаблона и установить единицы измерения.

Если системная переменная FILEDIA равна 0, вызывается вариант команды СОХРАНИТЬКАК, использующий интерфейс командной строки.

Темы:

  • Диалоговое окно "Описание шаблона"
  • Диалоговое окно "Параметры сохранения"
  • СОХРАНИТЬКАК (вариант для командной строки)


Диалоговое окно "Описание шаблона"

С Команды
С Команды
Диалоговое окно "Описание шаблона"
Понятия Процедуры Команды

Меню "Файл": "Сохранить как"

Ввод команды: сохранитькак

Установка параметров шаблона чертежа.

Описание

Позволяет ввести описание шаблона чертежа. Описание отображается при выборе шаблона в диалоговом окне "Начало работы" или в диалоговом окне "Создание нового чертежа".

Единицы

Задание британских или метрических единиц измерения для шаблона чертежа.


Диалоговое окно "Параметры сохранения"

С Команды
С Команды
Диалоговое окно "Параметры сохранения"
Понятия Процедуры Команды

Меню "Файл": "Сохранить как"

Ввод команды: сохранитькак

Установка параметров сохранения файлов чертежа (DWG) и файлов графического обмена (DXF).

Диалоговое окно "Параметры сохранения" имеет следующие вкладки:

  • Параметры DWG
  • Параметры DXF

Вкладка "Параметры DWG" (диалоговое окно "Параметры сохранения")

Управление индексами чертежей и отображением сторонних объектов, а также задание формата файлов по умолчанию для сохранения чертежей.

Сохранять объекты-заместители

При сохранении файла чертежа в формате прежних версий или чертежа, в котором содержатся сторонние объекты (объекты от других приложений), для записи в файл объектов-заместителей сторонних объектов следует установить флажок "Сохранять объекты-заместители". Если флажок не установлен, в файле чертежа сохраняются только контуры сторонних объектов. (системная переменная PROXYGRAPHICS)

Примечание Если пользователь сохраняет файл чертежа, содержащий ссылки DWF на чертежи в формате прежних версий, то этот переключатель не действует на подложки DWF, так как они не отображаются как объекты-заместители или в виде контура.

Тип индекса

Позволяет определить, следует ли создавать слоевые и пространственные индексы при сохранении чертежа. Индексы используются для повышения скорости работы в процессе подгрузки внешних ссылок. Применение индексов незначительно увеличивает время сохранения чертежа. При сохранении частично открытого чертежа, не имеющего пространственного и слоевого индексов, эта опция недоступна.

Нет

Ни слоевые, ни пространственные индексы не создаются.

Слоевой

Загружаются только объекты включенных и размороженных слоев.

Пространственный

Загружаются только объекты, находящиеся в пределах контура подрезки.

Оба

Загружаются только объекты, находящиеся на включенных и размороженных слоях и расположенные в пределах контура подрезки; это позволяет повысить скорость загрузки чертежа.

Сохранять все чертежи как

Задание формата файлов, используемого по умолчанию для сохранения чертежей. Измененный формат начинает действовать при всех последующих вызовах команд СОХРАНИТЬ и БСОХРАНИТЬ. Формат сохранения можно также задать на вкладке "Открытие/Сохранение" диалогового окна "Настройка" (см. команду НАСТРОЙКА). Для оптимизации производительности рекомендуется сохранять файлы в формате чертежей AutoCAD 2004.

Вкладка "Параметры DXF" (диалоговое окно "Параметры сохранения")

Установка параметров сохранения файлов графического обмена.

Формат

Задание формата создаваемого файла (ASCII или двоичный). DXF-файлы формата ASCII могут загружаться в текстовые редакторы; они совместимы с более широким спектром приложений. DXF-файлы двоичного формата содержат те же данные, что и файлы формата ASCII, но в более компактном виде. Скорость записи и чтения двоичных файлов выше.

Подробнее о DXF-файлах см. Рекомендации DXF в справочной системе.

С выбором объектов

Позволяет определить, какие объекты записываются в DXF-файл: только выбранные объекты или все объекты чертежа. Если флажок установлен, в выходной файл выводится информация только о выбранных объектах и частичных вхождениях включенных блоков. Таблицы описаний блоков не включаются в выходной файл.

С образцом для просмотра

Включение/отключение предварительного просмотра изображения чертежа в области просмотра диалогового окна "Выбор файла". Данная опция также контролируется системной переменной RASTERPREVIEW.

Число десятичных знаков

Сохранение файла с заданием количества двоичных разрядов точности. В большинстве случаев достаточно использовать значение по умолчанию; однако для некоторых чертежей и приложений требуется повышенная точность. Если при загрузке созданных DXF-файлов возникают неполадки, следует увеличить точность. Единственный недостаток использования повышенной точности - увеличение размера сохраняемых файлов. Низкую точность рекомендуется применять только в специальных случаях.


СОХРАНИТЬКАК (вариант для командной строки)

С Команды
С Команды
СОХРАНИТЬКАК (вариант для командной строки)
Понятия Процедуры Команды

Если значение системной переменной FILEDIA равно 0, при запуске команды СОХРАНИТЬКАК в командной строке отображается следующий запрос.

Текущий формат файла: текущий

Задайте формат файла [2000(LT2000)/2004/Стандарты/DXF/Шаблон] <2004>:

Задать опцию или нажать ENTER

Сохранить чертеж как <текущий>: Ввести имя или нажать ENTER


СОХРИЗОБ Команда

С Команды
С Команды
СОХРИЗОБ Команда
Понятия Процедуры Команды

Сохранение тонированных изображений в файлах

Меню "Сервис": "Изображение" » " Сохранить"

Ввод команды: сохризоб

Откроется диалоговое окно "Выходной файл тонирования".

Примечание Команда СОХРИЗОБ недоступна, если текущее устройство тонирования не поддерживает изображения, развернутые по строкам.


СПИРАЛЬ Команда

С Команды
С Команды
СПИРАЛЬ Команда
Понятия Процедуры Команды

Создание 2D или 3D винтовой линии

Панель "Моделирование":

Меню "Рисование": "Спираль"

Ввод команды: спираль

Пульт управления: Панель создания 3D объектов (нажмите левую кнопку мыши на значке, чтобы развернуть), "Спираль"

Число витков = 3 (по умолчанию)

Вращение = ПРЧС (по умолчанию)

Укажите центральную точку основания: Укажите точку

Задайте радиус основания или [Диаметр] <1.0000>: Задайте радиус основания, введите д, чтобы задать диаметр или нажмите ENTER, чтобы задать значение радиуса основания по умолчанию

Задайте верхний радиус или [Диаметр] <1.0000>: Задайте верхний радиус, введите д, чтобы задать диаметр или нажмите ENTER, чтобы задать значение верхнего радиуса по умолчанию

Задайте высоту спирали или выберите [Конечная точка оси/Витки/высота витка/вРащение] <1.0000>: Задайте высоту спирали или введите опцию

Первоначально значение радиуса основания по умолчанию установлено равным 1. В процессе работы над чертежом в качестве значения по умолчанию для радиуса основания всегда используется ранее введенное значение радиуса для любого элементарного тела или спирали.

Значение по умолчанию для верхнего радиуса всегда совпадает со значением радиуса основания.

Радиус основания и верхний радиус не могут быть одновременно равны 0.

Диаметр (основание)

Задание диаметра основания спирали.

Задайте диаметр <2.0000>: Задайте диаметр или нажмите ENTER для ввода значения по умолчанию

Первоначально значение диаметра основания по умолчанию установлено равным 2. В процессе работы над чертежом в качестве значения по умолчанию для диаметра основания всегда используется ранее введенное значение диаметра основания.

Диаметр (вершина)

Задание диаметра вершины спирали.

Задайте диаметр <2.0000>: Задайте диаметр или нажмите ENTER для ввода значения по умолчанию

Значение по умолчанию для верхнего диаметра всегда совпадает со значением диаметра основания.

Конечная точка оси

Задание расположения конечной точки для оси спирали. Конечная точка оси может быть расположена в любом месте 3D пространства. Конечная точка оси определяет длину и ориентацию спирали.

Укажите конечную точку оси: Укажите точку

Витки

Задание числа витков (вращений) спирали. Число витков спирали не может быть больше 500.

Изначально значение по умолчанию для числа витков равно 3. В процессе работы над чертежом в качестве значения по умолчанию для числа витков всегда используется ранее введенное число витков.

Введите число витков: Введите число

Высота витка

Задание высоты одного полного витка спирали.

Число витков спирали автоматически обновляется в соответствии с заданной высотой витка. Если число витков спирали уже определено, задать высоту витка невозможно.

Укажите расстояние между витками <по умолчанию>: Введите число, чтобы задать высоту каждого витка спирали

Вращать

Задание направления вычерчивания спирали – по часовой стрелке (ПОЧС) или против часовой стрелки (ПРЧС). По умолчанию вращение спирали осуществляется ПРЧС.

Введите направление вращения спирали [ПОЧС/ПРЧС] <ПРЧС>: Задайте направление вращения спирали


СПИСМАСШТРЕД Команда

С Команды
С Команды
СПИСМАСШТРЕД Команда
Понятия Процедуры Команды

Управление списком доступных значений масштаба для видовых экранов, листа и печати

Меню "Формат": "Список масштабов"

Ввод команды: списмасштред (или 'списмасштред для вызова в прозрачном режиме)

Откроется диалоговое окно "Изменение списка масштабов".

Если в ответ на приглашение "Команда" ввести -списмасштред, будет вызван вариант команды СПИСМАСШТРЕД, СПИСМАСШТРЕД (вариант для командной строки)использующий интерфейс командной строки.

Темы:

  • Диалоговое окно "Изменение списка масштабов"
  • Диалоговое окно "Добавить масштаб"
  • Диалоговое окно "Изменение масштаба"
  • СПИСМАСШТРЕД (вариант для командной строки)


Диалоговое окно "Изменение списка масштабов"

С Команды
С Команды
Диалоговое окно "Изменение списка масштабов"
Понятия Процедуры Команды

Меню "Формат": "Список масштабов"

Ввод команды: списмасштред (или 'списмасштред для вызова в прозрачном режиме)

Управление списком доступных значений масштаба для видовых экранов, листа и печати.

Список масштабов

Вывод списка определенных на данный момент масштабов.

Добавить

Вызов диалогового окна "Добавление масштаба".

Изменить

Вызов диалогового окна "Изменение масштаба".

Вверх

Перемещение выделенного значения масштаба на одну позицию вверх по списку.

Вниз

Перемещение выделенного значения масштаба на одну позицию вниз по списку.

Удалить

Удаление выделенного значения масштаба из списка.

Сброс

Удаление всех пользовательских значений масштаба и восстановление списка масштабов по умолчанию.


Диалоговое окно "Добавить масштаб"

С Команды
С Команды
Диалоговое окно "Добавить масштаб"
Понятия Процедуры Команды

Меню "Формат": "Список масштабов"

Ввод команды: списмасштред (или 'списмасштред для вызова в прозрачном режиме)

Добавление нового масштаба в список.

Имя масштаба

Присвоение масштабу имени, под которым он будет отображаться в списке.

Имя, отображаемое в списке масштабов

Ввести описательное или числовое имя. Например, для архитектурного чертежа, в котором используется стандартный масштаб в британских единицах, можно ввести "1”=4’" или "1:48".

Свойства масштаба

Задание отношения единиц листа к единицам чертежа.

Единицы листа

При одновременном использовании единиц листа с единицами чертежа - задание их отношения, определяющего масштаб при просмотре или печати.

Единицы чертежа

При одновременном использовании единиц чертежа с единицами листа - задание их отношения, определяющего масштаб при просмотре или печати.


Диалоговое окно "Изменение масштаба"

С Команды
С Команды
Диалоговое окно "Изменение масштаба"
Понятия Процедуры Команды

Меню "Формат": "Список масштабов"

Ввод команды: списмасштред (или 'списмасштред для вызова в прозрачном режиме)

Изменение значений масштаба, отображаемых в списке масштабов.

Имя масштаба

Вывод имени масштаба, выделенного в списке масштабов.

Имя, отображаемое в списке масштабов

Ввести описательное или числовое имя. Например, для архитектурного чертежа, в котором используется стандартный масштаб в британских единицах, можно ввести "1”=4’" или "1:48".

Свойства масштаба

Изменение отношения единиц листа к единицам чертежа.

Единицы листа

При одновременном использовании единиц листа с единицами чертежа - задание их отношения, определяющего масштаб при просмотре или печати.

Единицы чертежа

При одновременном использовании единиц чертежа с единицами листа - задание их отношения, определяющего масштаб при просмотре или печати.


СПИСМАСШТРЕД (вариант для командной строки)

С Команды
С Команды
СПИСМАСШТРЕД (вариант для командной строки)
Понятия Процедуры Команды

Если в ответ на приглашение "Команда" ввести -списмасштред, будет вызван вариант команды СПИСМАСШТРЕД, использующий интерфейс командной строки.

Введите опцию [?/Добавить/Удалить/Сброс/Выход] <Добавить>: Задать опцию или нажать ENTER

?

Вывод списка определенных масштабов.

Добавить

Добавление нового масштаба в список масштабов.

Введите имя для нового масштаба: Ввести описательное или числовое имя, например "1”=4’" или 1:48.

Введите коэффициент масштаба: Коэффициент вводится в формате n:m, где n - значение в единицах листа, а m - значение в единицах чертежа

Удалить

Удаление указанного масштаба.

Введите имя масштаба, который необходимо удалить: Ввести имя масштаба, который необходимо удалить

Сброс

Удаление всех пользовательских значений масштаба и восстановление списка масштабов по умолчанию.

Восстановить список масштабов по умолчанию? [Да/Нет]: Ввести д или н

Выход

Завершение команды.


СПИСОК Команда

С Команды
С Команды
СПИСОК Команда
Понятия Процедуры Команды

Получение информации о выбранных объектах из базы данных чертежа

Панель Сведения:

Меню "Сервис": "Сведения" » "Список"

Ввод команды: список

Выберите объекты: Выбрать объекты любым способом

В текстовом окне отображается тип объекта, слой объекта координаты X,Y,Z в текущей ПСК , а также пространство, в котором объект находится (модель или лист).

Цвет, тип и вес линий выводятся командой СПИСОК, если они заданы явно (не ПОСЛОЮ). Выводится также и трехмерная высота объекта, если она ненулевая. Координата Z определяет уровень объекта. Если направление выдавливания не совпадает с осью Z (0,0,1) в текущей ПСК, с помощью команды СПИСОК параметры направления выдавливания в ПСК включаются в данные об объекте.

Кроме того, в зависимости от конкретного выбранного объекта, команда СПИСОК может выводить и другие данные.


СПИСОКСВЕТ Команда

С Команды
С Команды
СПИСОКСВЕТ Команда
Понятия Процедуры Команды

Открывает источники света в окне "Модель", чтобы добавить и изменить источники света.

Панель "Тонирование" :

Меню "Вид": "Тонирование" » "Свет" » "Список источников света"

Ввод команды: списоксвет

Пульт управления: Панель "Источники света", "Список источников света"

Открывает источники света в окне "Модель", в котором содержится список источников света, заданных в чертеже.

Темы:

  • Источники света в окне "Модель"


Источники света в окне "Модель"

С Команды
С Команды
Источники света в окне "Модель"
Понятия Процедуры Команды

Панель "Тонирование" :

Меню "Вид": "Тонирование" » "Свет" » "Список источников света"

Ввод команды: списоксвет

Пульт управления: Панель "Источники света", "Список источников света"

Вывод списка источников света, заданных в чертеже. Значок в столбце "Тип" указывает тип источника света: точечный источник, прожектор или удаленный источник, а также включен он или выключен. Выберите источник света из списка, чтобы задать его на чертеже. Чтобы отсортировать список, нажмите на заголовок столбца "Тип" или "Имя".

"Удалить источник света" или "Удалить источники света"

Если выбран один или более источников света, нажмите правую кнопку мыши и выберите пункт "Удалить источник света" или "Удалить источники света", чтобы удалить источники света с чертежа. Можно также нажать кнопку УДАЛИТЬ.

Свойства

Если выбран один или более источников света, нажмите правую кнопку мыши и выберите пункт "Свойства", чтобы отобразить Палитру свойств, в которой можно изменить свойства источников света, а также включить или выключить их. После выбора свойств на панели внизу отображается описание свойства. Можно также дважды нажать кнопку мыши, чтобы отобразить палитру "Свойства".


СПИСОКСВЕТЗАКР Команда

С Команды
С Команды
СПИСОКСВЕТЗАКР Команда
Понятия Процедуры Команды

Закрывает источники света в окне "Модель"

Ввод команды: списоксветзакр

Пульт управления: Панель "Источники света", "Список источников света"

Закрывает источники света в окне "Модель".


СПЛАЙН Команда

С Команды
С Команды
СПЛАЙН Команда
Понятия Процедуры Команды

Создает гладкую кривую, проходящую вблизи (в пределах заданной погрешности) некоторого набора точек.

Панель "Рисование":

Меню "Рисование": "Сплайн"

Ввод команды: сплайн

Первая точка или [Объект]: Указать точку или ввести о

Первая точка

Создает сплайн по заданным точкам с использованием математики неоднородных рациональных B-сплайнов (NURBS).

Следующая точка: Указать точку

Задавать точки следует до тех пор, пока построение сплайновой кривой не будет завершено. После выбора двух точек отображается следующий запрос:

Следующая точка или [Замкнуть/Допуск] <Касательная в начале>: Указать точку, задать опцию или нажать ENTER

Следующая точка

Использование этой опции позволяет продолжать ввод точек, добавляя к сплайновой кривой новые сегменты, до тех пор пока не будет нажата клавиша ENTER. Для отмены последней введенной точки следует ввести отменить. После нажатия ENTER отобразится запрос на указание направления касательной в начале сплайновой кривой.

Замкнуть

Замыкает кривую сплайна, задавая конечную точку совпадающей с точкой начала и сглаживая кривую в точке соединения.

Направление касательной: Указать точку или нажать ENTER

Следует указать точку для задания вектора касательной или использовать режимы привязки "Касательная" и "Нормаль" для выравнивания создаваемого сплайна по существующим объектам.

Допуск

Изменяет значение допуска, используемое для построения сплайна. Кривая перестраивается в соответствии с измененным значением. В процессе построения сплайна значение допуска можно неоднократно изменять, однако величина отклонения кривой от каждой из определяющих точек всегда равна текущему значению допуска.

Допуск <текущий>: Ввести значение или нажать ENTER

Если задать нулевое значение допуска, сплайн будет проходить точно через определяющие точки. Придание допуску положительных значений позволяет кривой отклоняться от определяющих точек на заданную величину. Далее

СПЛАЙН возвращается к предыдущему запросу.

Касательная в начале

Задание направления касательной в начале (и, далее, в конце) сплайновой кривой.

Касательная в начальной точке: Указать точку или нажать ENTER

Указанное направление касательной определяет наклон сплайна в начальной точке.

Касательная в конечной точке: Указать точку или нажать ENTER

Указанное направление касательной определяет наклон сплайна в конечной точке.

При самостоятельном задании касательных можно использовать режимы привязки "Касательная" и "Нормаль" для выравнивания создаваемого сплайна по существующим объектам. Для расчета касательных по умолчанию следует нажать ENTER.

Объект

Преобразование сглаженных сплайнами 2D и 3D полилиний в эквивалентные им сплайны. В зависимости от установки системной переменной DELOBJ, исходные объекты могут быть удалены или оставлены в чертеже.

Выберите объекты для преобразования в сплайны...

Выберите объекты: Выбрать 2D или 3D полилинии, сглаженные сплайнами; по окончании выбора нажать ENTER


СПРАВКА Команда

С Команды
С Команды
СПРАВКА Команда
Понятия Процедуры Команды

Вызов справочной системы

Панель Стандартная

Меню "Справка": "Справка"

Ввод команды: справка или ? или нажмите F1 (или введите 'справка для прозрачного вызова)

Чтобы получить справку по конкретному меню, следует раскрыть его и нажать F1.

Для отображения справки по активной команде следует нажать F1 или ввести 'справка. Нажатие кнопки "Справка" в диалоговом окне выводит справочные сведения по данному окну.


СРЕДАТОН Команда

С Команды
С Команды
СРЕДАТОН Команда
Понятия Процедуры Команды

Управление туманом и затемнением объектов для визуального представления удаленных расстояний

Панель Тонирование:

Меню "Вид": "Тонирование" » "Тонировать среду"

Ввод команды: средатон

Пульт управления: Панель "Тонирование" (развернуть нажатием левой кнопки мыши на значок), "Тонировать среду"

Открывается диалоговое окно "Тонировать среду".

Темы:

  • Диалоговое окно "Тонировать среду"


Диалоговое окно "Тонировать среду"

С Команды
С Команды
Диалоговое окно "Тонировать среду"
Понятия Процедуры Команды

Панель Тонирование:

Меню "Вид": "Тонирование" » "Тонировать среду"

Ввод команды: средатон

Задание визуального представления расстояния между объектами и точкой наблюдения.

Туман/Затемнение

Туман и затемнение представляют собой два предельных случая одного и того же эффекта: туман имитируется белым цветом, а затемнение удаленных объектов черным. Можно, конечно, использовать и любой другой цвет.

Включить туман

Включение и отключение тумана без изменения других установок диалогового окна.

Цвет

Задается цвет тумана.

При нажатии на "Выбор цвета" открывается диалоговое окно "Выбор цвета". Цвет можно выбрать по его номеру из существующих 255 индексов цвета AutoCAD (ИЦА), из всей палитры цветов или воспользоваться альбомами цветов.

Туман на фоне

Применение тумана как к объектам, так и к фону.

Близкое расстояние

Указывается расстояние от камеры, на котором возникает туман.

Его указывают в виде десятичной доли расстояния до дальней секущей плоскости. Можно задавать значение либо путем ввода с клавиатуры в поле "Близкое расстояние", либо с помощью наборного счетчика. Значение в поле "Близкое расстояние" не должно превышать значение в поле "Далекое расстояние".

Далекое расстояние

Указывается расстояние от камеры, на которой заканчивается туман.

Его указывают в виде десятичной доли расстояния до дальней секущей плоскости. Можно задавать значение либо путем ввода с клавиатуры в поле "Близкое расстояние", либо с помощью наборного счетчика. Значение в поле "Далекое расстояние" не должно быть меньше значения в поле "Близкое расстояние".

Процент близкого тумана

Определяет непрозрачность тумана на близком расстоянии.

Процент далекого тумана

Определяет непрозрачность тумана на далеком расстоянии.


ССВСТАВИТЬ Команда

С Команды
С Команды
ССВСТАВИТЬ Команда
Понятия Процедуры Команды

Вставка внешних ссылок в текущий чертеж

Панель "Ссылки":

Меню "Вставка": "Внешние ссылки"

Ввод команды: ссвставить

Откроется диалоговое окно "Выбор файла внешней ссылки" (стандартное диалоговое окно выбора файлов). После выбора файла вызывается диалоговое окно "Внешняя ссылка".

Темы:

  • Диалоговое окно "Внешняя ссылка"


Диалоговое окно "Внешняя ссылка"

С Команды
С Команды
Диалоговое окно "Внешняя ссылка"
Понятия Процедуры Команды

Панель "Ссылки":

Меню "Вставка": "Внешние ссылки"

Ввод команды: ссвставить

Вставка чертежа в текущий чертеж в качестве внешней ссылки. При вставке чертежа, который сам содержит внешнюю ссылку, эта ссылка также отображается в текущем чертеже. По аналогии с блоками, вставляемые внешние ссылки могут быть вложенными. Если вставленный в качестве внешней ссылки чертеж в данный момент редактируется другим пользователем, его изображение в текущем чертеже соответствует моменту последнего сохранения чертежа, используемого в качестве внешней ссылки.

Имя

Отображение имени внешней ссылки в списке после ее вставки в чертеж. При выборе имени внешней ссылки в списке путь доступа к файлу соответствующего чертежа отображается в поле "Путь".

Обзор

Вызов диалогового окна "Выбор файла внешней ссылки" (стандартного диалогового окна выбора файлов), в котором выбираются новые внешние ссылки для текущего чертежа.

Найдена в

Отображение пути, по которому найдена внешняя ссылка.

Если для внешней ссылки не был сохранен путь или она не была найдена по указанному пути, поиск внешней ссылки будет осуществляться в следующем порядке:

  • Текущая папка главного чертежа
  • Пути поиска файлов проекта, заданные на вкладке "Файлы" диалогового окна "Настройка" и в системной переменной PROJECTNAME
  • Пути поиска вспомогательных файлов, заданные на вкладке "Файлы" диалогового окна "Настройка"
  • Рабочая папка, заданная в ярлыке приложения Microsoft® Windows®
Сохраненный путь

Отображение сохраненного пути доступа к внешней ссылке. Сохраненный путь может быть абсолютным (полностью заданным), относительным (частично заданным) или не заданным.

Тип ссылки

Задание типа внешней ссылки — вставленная или наложенная. Наложенная внешняя ссылка отличается от вставленной тем, что она игнорируется при вставке содержащего ее чертежа в другой чертеж в качестве внешней ссылки.

См. Вставка вхождений чертежей (внешних ссылок) и Вложенные и наложенные внешние чертежи. в Руководстве пользователя.

Задание пути

Выбор типа сохраненного пути доступа к внешней ссылке - "Полный путь", "Относительный путь" или "Путь не задан". Перед установкой значения "Относительный путь" необходимо сохранить текущий чертеж. Для вложенной внешней ссылки относительный путь всегда указывает на расположение ее главного чертежа, который не обязательно является текущим.

Опция "Относительный путь" не доступна, если чертеж, на который указывает внешняя ссылка, расположен на другом локальном компьютере или на сервере сети.

Точка вставки

Задание точки вставки для выбранной внешней ссылки.

Указать на экране

Отображение подсказок в командной строке и отключение опций "X", "Y" и "Z". Описания опций, выводимых в командной строке, совпадают с описаниями соответствующих опций в группе "Точка вставки" команды ВСТАВИТЬ.

X

Задание координаты X точки текущего чертежа, в которую требуется вставить вхождение внешней ссылки. Точка вставки, заданная командой БАЗА в файле внешней ссылки, совмещается с точкой вставки в текущем чертеже.

Y

Задание координаты Y точки текущего чертежа, в которую требуется вставить вхождение внешней ссылки. Точка вставки, заданная в системной переменной BASE в файле внешней ссылки, совмещается с точкой вставки в текущем чертеже.

Z

Задание координаты Z точки текущего чертежа, в которую требуется вставить вхождение внешней ссылки. Точка вставки, заданная в системной переменной BASE в файле внешней ссылки, совмещается с точкой вставки в текущем чертеже.

Масштаб

Задание масштаба для выбранной внешней ссылки.

Указать на экране

Отображение подсказок в командной строке и отключение опций "Масштаб по X", "Масштаб по Y" и "Масштаб по Z". Описания опций, выводимых в командной строке, совпадают с описаниями соответствующих опций в группе "Точка вставки" команды ВСТАВИТЬ.

Масштаб по X

Масштаб по оси X для вхождения внешней ссылки.

Масштаб по Y

Масштаб по оси Y для вхождения внешней ссылки.

Масштаб по Z

Масштаб по оси Z для вхождения внешней ссылки.

Равные масштабы

Обеспечивает задание масштабных коэффициентов по осям Y и Z, равных масштабному коэффициенту по оси X.

Поворот

Задание угла поворота для вхождения внешней ссылки.

Указать на экране

Отображение подсказок в командной строке и отключение опции "Угол". Появляется запрос угла поворота, аналогичный запросу для команды ВСТАВИТЬ.

Угол

Задание угла поворота, под которым вхождение внешней ссылки вставляется в текущий чертеж.

Единицы блока

Отображение информации о единицах блока.

Ед.изм.

Отображение значения системной переменной INSUNITS для вставленного блока.

Коэфф

Отображение масштабного коэффициента, который вычисляется на основе значения системной переменной INSUNITS блока и единиц чертежа.


ССОТКРЫТЬ Команда

С Команды
С Команды
ССОТКРЫТЬ Команда
Понятия Процедуры Команды

Открывает выбранную внешнюю ссылку на чертеж (xref) в новом окне

Ввод команды: ссоткрыть

Выберите внешнюю ссылку: Выбрать объект внешней ссылки

Внешняя ссылка на чертеж, в которую входит выбранный объект, открывается в отдельном окне. Если ссылка на чертеж содержит вложенные внешние ссылки, то открывается ссылка самого нижнего уровня вложенности выбранного объекта.


ССПОДРЕЗАТЬ Команда

С Команды
С Команды
ССПОДРЕЗАТЬ Команда
Понятия Процедуры Команды

Задание контура подрезки, а также передней и задней плоскости подрезки для внешней ссылки или блока

Панель "Ссылки":

Контекстное меню: Выберите внешнюю ссылку, нажмите правую кнопку мыши в области рисования, а затем выберите "Подрезать внешнюю ссылку".

Ввод команды: ссподрезать

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Задайте опцию подрезки [Вкл/Откл/Плоскости/Удалить/полиЛиния/Новый контур] <Новый>: Задать опцию или нажать ENTER

Вкл

Включение отображения в главном чертеже подрезанной части внешней ссылки или блока.

Откл

Отображение всего содержимого внешней ссылки или блока за исключением контура подрезки в главном чертеже.

Плоскости

Задание передней и задней плоскостей подрезки для внешней ссылки или блока. Объекты, выходящие за пределы ограниченного контуром и заданного плоскостями пространства, не отображаются на экране.

Укажите точку передней плоскости или [Расстояние/Удалить]:

Точка передней плоскости

Построение плоскости подрезки, проходящей через заданную точку перпендикулярно контуру подрезки.

Укажите точку задней плоскости или [Расстояние/Удалить]:

Расстояние

Построение плоскости подрезки, проходящей на заданном расстоянии параллельно контуру подрезки.

Расстояние от контура:

Отобразится предыдущий запрос.

Удалить

Удаление передней и задней плоскостей подрезки.

Удалить

Удаление контура подрезки для выбранной внешней ссылки или блока. Для временного отключения контура подрезки используется опция "Откл". Данная опция удаляет контур и плоскости подрезки. Команда СТЕРЕТЬ неприменима для удаления контуров подрезки.

полиЛиния

Автоматическое построение полилинии, вершины которой совпадают с вершинами контура подрезки. Новая полилиния размещается на текущем слое; ей присваиваются текущий цвет, а также тип и вес линий. Эта опция используется для изменения текущего контура подрезки с помощью команды ПОЛРЕД с последующим переопределением контура подрезки на основе новой полилинии. Для отображения ссылки целиком во время переопределения контура используется опция "Откл".

Новый контур

Создание нового прямоугольного или многоугольного контура подрезки или получение многоугольного контура подрезки из полилинии. Если контур уже существует, отобразится следующий запрос:

Удалить прежние контуры? [Да/Нет] <Да>:

Команда выполняется, только если все предыдущие контуры удалены.

Укажите контур(ы) подрезки:

[Выбрать полилинию/Многоугольный/Прямоугольный] <Прямоугольный>: Задать опцию контура подрезки или нажать ENTER

Выберите полилинию

Задание контура подрезки на основе выбранной полилинии. Эта полилиния может быть незамкнутой, но она должна состоять из прямолинейных сегментов и не иметь самопересечений. Контур подрезки, созданный таким способом, параллелен плоскости пользовательской системы координат (ПСК), в которой находится исходная полилиния.

Многоугольный

Задание многоугольного контура подрезки посредством указания вершин многоугольника. Вне зависимости от текущего вида, контур подрезки располагается в текущей ПСК.

Прямоугольный

Задание прямоугольного контура подрезки по двум точкам противоположных углов. Вне зависимости от текущего вида, контур подрезки располагается в текущей ПСК.


ССЫЛЗАКР Команда

С Команды
С Команды
ССЫЛЗАКР Команда
Понятия Процедуры Команды

Сохранение или отказ от изменений, произведенных в ходе редактирования вхождений блоков и ссылок

Меню "Сервис": » "Внешняя ссылка или блок для местного редактирования"; "Сохранить изменения вхождения" или » "Внешняя ссылка или блок для местного редактирования"; "Закрыть вхождение"

Контекстное меню: Убедиться, что в ходе редактирования вхождения нет выбранных объектов, щелкнуть правой кнопкой мыши в области чертежа и выбрать «Завершение сеанса ССЫЛРЕД».

Ввод команды: ссылзакр

Задайте опцию [Сохранить/Отменить изменения ссылки] <Сохранить>:

Сохранить

Сохранение в исходном чертеже внешней ссылки или в описании блока в текущем чертеже изменений, произведенных с объектами рабочего набора. Объекты, исключенные из рабочего набора, при сохранении изменений удаляются из вхождения и добавляются в основной чертеж. Изменения во вхождении автоматически сохраняются также при нажатии кнопки «Сохранить изменения» на панели инструментов «Редактирование вхождений».

Примечание Если формат файла исходного чертежа внешней ссылки создан в программе AutoCAD версии 14 или ниже, файл сохраняется в формате AutoCAD 2007. Формат файла AutoCAD 2000 и 2004 исходного чертежа внешней ссылки не меняется.

Отменить изменения ссылки

Завершение редактирования вхождения; при этом внешний чертеж или описание блока остаются без изменений. Изменения, произведенные с объектами текущего чертежа (не входящими во внешнюю ссылку или блок), остаются в чертеже. Удаленные объекты, не входящие в рабочий набор, не восстанавливаются даже после отказа от изменений. Изменения во вхождении автоматически отменяются также при нажатии кнопки "Отказаться от изменений" на панели инструментов "Редактирование вхождений" без использования ССЫЛЗАКР .

При сохранении изменений или отказе от них с помощью команды ССЫЛРЕД можно по-прежнему использовать команду ОТМЕНИТЬ для возврата в сеанс редактирования вхождения. Для отмены нежелательных изменений, уже сохраненных в файле внешней ссылки, можно воспользоваться командой ОТМЕНИТЬ, а затем вызвать команду ССЫЛЗАКР для сохранения изменений и восстановления файла внешних ссылок в его исходном состоянии.

Примечание После редактирования вхождения внешней ссылки в текущем чертеже изображение, использовавшееся для предварительного просмотра внешнего файла, становится недоступным и возобновляется только после открытия и сохранения файла внешней ссылки.


ССЫЛКА Команда

С Команды
С Команды
ССЫЛКА Команда
Понятия Процедуры Команды

Запуск команды ВНССЫЛКИ

Ввод команды: ссылка

Отобразится Палитра "Внешние ссылки".

Если в ответ на подсказку "Команда:" ввести -ссылка, будет вызван вариант команды ССЫЛКА, использующий интерфейс командной строки.

Темы:

  • Диалоговое окно "Внедрение ссылок"
  • ССЫЛКА (вариант для командной строки)


Диалоговое окно "Внедрение ссылок"

С Команды
С Команды
Диалоговое окно "Внедрение ссылок"
Понятия Процедуры Команды

Панель "Ссылки":

Меню "Вставка": "Внешние ссылки"

Контекстное меню: Выберите внешнюю ссылку на файл чертежа, нажмите правую кнопку мыши в области рисования и выберите "Внешние ссылки".

Ввод команды: внссылки

Преобразование внешних ссылок на файлы чертежа в стандартные описания локальных блоков. После внедрения внешней ссылки в текущий чертеж эта ссылка и все зависимые от нее именованные объекты становятся частью текущего чертежа. Для добавления в таблицу описаний текущего чертежа отдельных зависимых от внешней ссылки именованных объектов, таких как блоки, текстовые стили, размерные стили, слои или типы линий, служит команда ВНЕДРИТЬ. Существует два способа внедрения внешних ссылок в текущий чертеж — внедрение и вставка. При внедрении имена таблицы описаний внешней ссылки изменяются. При вставке имена таблицы описаний внешней ссылки не изменяются. Для внедрения вложенной внешней ссылки требуется также внедрить ее родительскую ссылку.

внеДрить

Опция внедряет элементы выбранной внешней ссылки в текущий чертеж. Имена символов внешней ссылки изменяются с имя_блока|имя_символа на имя_блока$n$имя_символа. Таким образом, для всех символов вставляемой внешней ссылки в символьной таблице текущего чертежа создаются уникальные имена.

Например, после внедрения внешней ссылки с именем ЭТАЖ1, содержащей слой СТЕНА, данный слой (ЭТАЖ1|СТЕНА) становится локально определенным слоем с именем ЭТАЖ1$0$СТЕНА. Номер в $n$ автоматически увеличивается, если в таблице описаний уже существует локальный именованный объект с таким именем. В данном примере, если имя слоя ЭТАЖ$0$СТЕНА уже имеется в текущем чертеже, то символ из внешней ссылки получит имя ЭТАЖ$1$СТЕНА.

Вставить

Внедрение внешней ссылки способом, который эквивалентен удалению внешней ссылки и последующей вставке чертежа внешней ссылки в текущий чертеж. Имена зависимых от внешней ссылки объектов не преобразуются в формат имя_блока$n$имя_символа. Как и при вставке чертежей, если имя внедряемого именованного объекта совпадает с именем уже существующим в текущем чертеже именем, переопределение имени существующего объекта не производится. Внедренный именованный объект, зависимый от внешней ссылки, наследует свойства существующего в текущем чертеже именованного объекта.

Например, после внедрения внешней ссылки с именем ЭТАЖ1, содержащей слой СТЕНА, с помощью опции "Вставить" данный слой (ЭТАЖ1|СТЕНА) становится локально определенным слоем СТЕНА.


ССЫЛКА (вариант для командной строки)

С Команды
С Команды
ССЫЛКА (вариант для командной строки)
Понятия Процедуры Команды

Если в ответ на подсказку «Команда:" ввести -cсылка, будет вызван вариант команды ССЫЛКА, использующий интерфейс командной строки.

Задайте опцию [?/внеДрить/Удалить/Путь/вЫгрузить/Обновить/Наложить/Вставить] <Вставить>: Задать опцию или нажать ENTER

?—Список внешних ссылок

Вывод имен, путей, типов и номеров ссылок на файл чертежа, вставленных в чертеж на данный момент. Отобразится следующий запрос:

Имена каких вн-ссылок вывести <*>: Ввести список имен или нажать ENTER для вывода имен всех внешних ссылок, вставленных в чертеж

внеДрить

Внедрение внешней ссылки на файл чертежа в качестве постоянной части текущего чертежа.

Какие элементы типа вн-ссылка внедрить: Ввести имя или список имен через запятую

В чертеж добавляются такие зависимые от предшествующей внешней ссылки объекты, как имена слоев. В каждом зависимом от внешней ссылки именованном объекте вертикальная черта (|) заменяется тремя новыми символами: число (обычно 0) между двумя знаками доллара ($). Если такое имя уже существует в текущем чертеже, номер увеличивается на единицу.

Удалить

Удаление одной или нескольких ссылок на файл чертежа из текущего чертежа, а также удаление всех вхождений этой ссылки и пометка ее описания "для удаления" в таблице описаний. Из текущего чертежа можно удалить только те внешние ссылки, которые вставлены/наложены в/на него непосредственно; вложенные ссылки удалять нельзя.

Какие вн-ссылки удалить:

Внешние ссылки, используемые другими внешними ссылками или блоками, не могут быть удалены.

Путь

Получение информации о пути доступа к файлу чертежа внешней ссылки с возможностью его изменения. Данная опция может оказаться полезной, если расположение или имя файла внешней ссылки изменилось.

Для какого элемента типа Вн-ссылка редактировать путь:

Отображается внешняя ссылка и ее старый путь, а затем появляется запрос на ввод нового пути:

имя внешней ссылки: “имя“

Старый путь: путь

Новый путь: Ввести новый путь доступа и имя файла чертежа внешней ссылки

Если введен неправильный путь или чертеж не может быть найден по указанному пути, отобразится повторный запрос.

вЫгрузить

Выгрузка выбранных ссылок на файл чертежа.

Какие вн-ссылки выгрузить:

Вместо выгруженной ссылки остается маркер, используя который в дальнейшем можно повторно загрузить ссылку.

Обновить

Обновление одной или нескольких ссылок на файл чертежа. Данная опция обеспечивает обновление и отображение самой последней версии чертежа внешней ссылки.

Какие элементы типа вн-ссылка обновить:

Если в процессе обновления внешних ссылок программа обнаружит ошибку, она завершит команду ССЫЛКА и отменит все действия по обновлению.

Наложить

Открытие диалогового окна "Файл для наложения" (стандартное диалоговое окно выбора файлов). В нем необходимо выбрать файл для наложения в качестве внешней ссылки. При наложении чертежа, который сам содержит наложенную внешнюю ссылку, эта вложенная ссылка не отображается в текущем чертеже.

В отличие от блоков и вставляемых внешних ссылок, наложенные ссылки не могут иметь вложенности. Если в данный момент файл, на который указывает внешняя ссылка, редактируется другим пользователем, выполняется наложение самой последней сохраненной версии этого файла.

Если выбранная ссылка еще не наложена, создается новая ссылка с именем связанного файла. Затем отобразится запрос точки вставки, масштаба и угла поворота, как это описано для команды ВСТАВИТЬ.

Если для системной переменной FILEDIA установлено значение 0, отобразится следующий запрос:

Файл для наложения:

Для выбора файла с помощью диалогового окна следует воспользоваться символом тильды (~).

Вставить

Вызов диалогового окна "Внешняя ссылка", если выбрана ссылка на файл чертежа, или диалогового окна "Выбор файла внешней ссылки", если ссылка не выбрана. См. команду ССВСТАВИТЬ.

При ссылке на чертеж, который сам содержит внешнюю ссылку, вложенная ссылка также отображается в текущем чертеже. Как и блоки, вставляемые внешние ссылки могут быть вложенными. При редактировании файла ссылки в этот момент другим пользователем, прикрепляется самая последняя сохраненная версия.

Если выбранная ссылка еще не наложена, создается новая ссылка с именем связанного файла. Отобразится запрос точки вставки, масштаба и угла поворота, как это описано для команды ВСТАВИТЬ.

При внедрении объектов из внешней ссылки в новый блок программа копирует только те объекты, которые были созданы в пространстве модели, но не в пространстве листа. Таким образом, видовые экраны и другие объекты пространства листа не становятся частью описания блока.

Слои 0 и DEFPOINTS, а также тип линий CONTINUOUS главного чертежа переопределяют одноименные элементы вставленных или наложенных внешних ссылок. При этом изменения объектов на этих слоях не происходит. Если слой DEFPOINTS существует в чертеже вставляемой внешней ссылки, но отсутствует в главном чертеже, он становится постоянной частью главного чертежа.

Если для системной переменной FILEDIA установлено значение 0, отобразится следующий запрос:

Файл для вставки ссылки:

Для выбора файла с помощью диалогового окна следует воспользоваться символом тильды (~).


ССЫЛНАБ Команда

С Команды
С Команды
ССЫЛНАБ Команда
Понятия Процедуры Команды

Добавление и исключение объектов из рабочего набора при редактировании вхождений блоков и ссылок

Меню "Сервис": » "Внешняя ссылка или блок для местного редактирования"; "Добавить в рабочий набор" или » "Внешняя ссылка или блок для местного редактирования"; "Исключить из рабочего набора"

Ввод команды: ссылнаб

Перемещение объектов из основного чертежа в рабочий набор для ССЫЛРЕД и обратно...

Задайте опцию [Добавить/Исключить] <Добавить>: Задать опцию или нажать ENTER

Объекты, входящие в рабочий набор, визуально выделяются среди других объектов чертежа. По сравнению с объектами, входящими в рабочий набор, все остальные объекты выглядят более бледно.

Добавить

Добавление объектов в рабочий набор.

Выберите объекты: Выбрать объекты для добавления

При сохранении изменений объекты, входившие в рабочий набор, удаляются из текущего чертежа и добавляются обратно во вхождение. Добавление объектов в рабочий набор возможно также нажатием кнопки "Добавить объекты в рабочий набор" на панели инструментов "Редактирование вхождений" без использования команды ССЫЛЗАКР.

Исключить

Исключение объектов из рабочего набора.

Выберите объекты: Выбрать объекты для исключения

Объект, исключенный из рабочего набора, удаляется из вхождения при сохранении изменений. Он также удаляется из текущего чертежа. Для исключения объектов из рабочего набора (не вызывая команду REFCLOSE) можно также на панели инструментов «Редактирование вхождений» нажать кнопку «Исключить объекты из рабочего набора».


ССЫЛРЕД Команда

С Команды
С Команды
ССЫЛРЕД Команда
Понятия Процедуры Команды

Выбирает внешнюю ссылку или вхождение блока для редактирования

Панель Редактирование вхождений:

Меню "Сервис": » "Внешняя ссылка или блок для местного редактирования"; "Редактирование вхождений"

Ввод команды: ссылред

Выберите вхождение: Выбрать вхождение блока или внешней ссылки в текущем чертеже

Отобразится диалоговое окно "Редактирование вхождений".

Если в ответ на запрос "Команда:" ввести -ссылред, вызывается вариант команды ССЫЛРЕД, использующий интерфейс командной строки.

Темы:

  • Диалоговое окно «Редактирование вхождений»
  • ССЫЛРЕД вариант для командной строки


Диалоговое окно «Редактирование вхождений»

С Команды
С Команды
Диалоговое окно «Редактирование вхождений»
Понятия Процедуры Команды

Панель Редактирование вхождений:

Меню "Сервис": » "Внешняя ссылка или блок для местного редактирования"; "Редактирование вхождений"

Ввод команды: ссылред

Выбор вхождения для редактирования. В выбранном вхождении необходимо указать объекты для редактирования. В диалоговом окне перечисляются все вложенные вхождения, которым принадлежит выбранный объект.

Диалоговое окно «Редактирование вхождений» имеет следующие вкладки:

  • Информация о ссылке
  • Настройки

Вкладка «Информация о ссылке» (диалоговое окно «Редактирование вхождений»)

Предоставляет наглядные средства для идентификации редактируемой ссылки и управляет выбором вложенных объектов.

Имя

Вхождение, выбранное для редактирования, и все его вложенные элементы (внешние ссылки и т.д.).

Здесь указываются только те вложенные вхождения, которым принадлежат выбранные объекты. Если в списке присутствует несколько вхождений, необходимо выбрать из них внешнюю ссылку или блок для редактирования. Допускается одновременное редактирование только одного вхождения. Вхождения блоков, занесенные в чертеж командой MINSERT, не могут участвовать в редактировании.

Динамические блоки в списке не отображаются и не могут редактироваться в этом диалоговом окне.

Образец

Здесь отображается образец для быстрого просмотра содержимого текущего выбранного вхождения.

Образ вхождения выглядит так, как оно последний раз было сохранено в чертеже. После сохранения изменений в отредактированном вхождении изменения образца для просмотра не происходит.

Траектория

Расположение файла, в котором хранится чертеж ссылки. Если выбрано вхождение блока, путь не отображается.

Выбирать вложенные объекты автоматически

Включение и отключение автоматического выбора вложенных объектов для редактирования.

Если отметить эту опцию, для редактирования будут доступны все объекты в выбранном вхождении.

Подтверждать выбор вложенных объектов

Включение и отключение выбора вложенных объектов для редактирования пользователем.

Если флажок для этого параметра установлен, после закрытия диалогового окна "Редактирование вхождений" и входа в режим редактирования вхождения будет предложено указать в выбранном вхождении объекты для редактирования.

Выберите вложенные объекты: Выбрать во вхождении объекты, которые необходимо отредактировать

Вкладка «Параметры» (диалоговое окно «Редактирование вхождений»)

Предоставляет опции редактирования вхождений.

Использовать уникальные имена слоев, стилей и блоков

Задает уникальность имен слоев и других именованных объектов, полученных из выбранного вхождения.

Если этот флажок установлен, программа модифицирует имена объектов во внешних ссылках, добавляя префикс «$#$» (так же, как при их внедрении из внешних ссылок). Если флажок снят, никаких изменений с именами не происходит. Если объектам не были присвоены уникальные имена, они получают свойства объектов текущего исходного чертежа с такими же именами.

Вывести описания атрибутов для редактирования

Управление извлечением и отображением описаний переменных атрибутов при редактировании вхождений блоков.

Если флажок «Вывести описания атрибутов для редактирования» установлен, атрибуты (кроме постоянных) делаются невидимыми; на экране появляются их описания, которые можно редактировать. При сохранении изменений в исходный чертеж описания блока атрибуты в имеющихся вхождениях остаются без изменений. Новые описания атрибутов вступают в силу только для последующих вхождений блока. Атрибуты имеющихся вхождений не изменяются. Опция не воздействует на внешние ссылки и блоки без атрибутов.

Блокировать объекты, не входящие в рабочий набор

Блокирование объектов, не входящих в рабочий набор. Данная опция служит для предотвращения случайного выбора и редактирования объектов исходного чертежа в режиме редактирования вхождения.

Блокированные объекты ведут себя так же, как и объекты на блокированных слоях. Заблокированные объекты при попытке их отредактировать в набор не включаются.


ССЫЛРЕД вариант для командной строки

С Команды
С Команды
ССЫЛРЕД вариант для командной строки
Понятия Процедуры Команды

Если в ответ на запрос "Команда:" ввести -ссылред, вызывается вариант команды ССЫЛРЕД, использующий интерфейс командной строки.

Выберите вхождение: Выбрать вхождение блока или внешней ссылки в текущем чертеже

Выберите уровень вложенности [OK/Далее] <Далее>: Задать опцию или нажать ENTER

OK

Редактирование текущего выбранного вхождения. Вхождения блоков, занесенные в чертеж командой MINSERT, не могут участвовать в редактировании.

Способ выбора объектов [Все/влоЖенные]<Все>: Ввести в, ввести ж или нажать ENTER.

Если ввести в, для редактирования будут доступны все объекты в выбранном вхождении. При вводе ж после закрытия диалогового окна "Редактирование вхождений" и входа в режим редактирования вхождения будет предложено указать в выбранном вхождении объекты для редактирования.

Выберите вложенные объекты: Выбрать во вхождении объекты, которые необходимо отредактировать

Показать описания атрибутов [Да/Нет] <Нет>: Ввести д или н, либо нажать ENTER при редактировании вхождения блока

Для завершения сеанса редактирования вхождения можно воспользоваться командой ССЫЛЗАКР или панелью инструментов «Редактирование вхождений».

Для вывода и редактирования атрибутов блока следует ввести д. При этом атрибуты становятся невидимыми, а описания атрибутов становятся доступными для редактирования вместе с графическими объектами выбранного вхождения. При сохранении изменений в исходный чертеж описания блока атрибуты в имеющихся вхождениях остаются без изменений. При сохранении изменений в исходный чертеж описания блока атрибуты в имеющихся вхождениях остаются без изменений. Новые описания атрибутов вступают в силу только для последующих вхождений блока. Атрибуты имеющихся вхождений не изменяются.

Далее

Циклическое перемещение по доступным для выбора вхождениям различного уровня вложенности. Текущее выбранное вхождение подсвечивается.

Из выбранных для редактирования объектов формируется рабочий набор. Изменения в объектах рабочего набора могут быть сохранены в исходном файле внешней ссылки или в описании блока. Эти изменения сохраняются во вхождении без фактического открытия внешнего чертежа или расчленения блока. Объекты рабочего набора визуально отличаются от остальных объектов текущего чертежа: по сравнению с объектами, входящими в рабочий набор, все остальные объекты чертежа выглядят более бледно. Интенсивностью отображения объектов в ходе редактирования вхождений управляет системная переменная XFADECTL.

Объекты во внешних ссылках можно выбрать для редактирования, даже если они в исходном файле находятся на блокированных слоях. Если объект вхождения является частью рабочего набора, можно разблокировать слой объектов и внести изменения в объект. При этом в исходный файл внешней ссылки записываются только изменения, выполненные для объекта; статус слоя не меняется (слой остается блокированным).

Примечание Если при изменении ссылки на месте установлен визуальный стиль, отличный от "2D каркас", объекты, не входящие в рабочий набор, не затеняются.


СТАНДАРТЫ Команда

С Команды
С Команды
СТАНДАРТЫ Команда
Понятия Процедуры Команды

Управляет подключением файлов стандартов к чертежам.

Панель "Стандарты оформления":

Меню "Сервис": "Стандарты оформления" » "Настроить"

Ввод команды: стандарты

Откроется диалоговое окно "Настройка стандартов".

Темы:

  • Диалоговое окно "Настройка стандартов"
  • Диалоговое окно "Параметры нормоконтроля"


Диалоговое окно "Настройка стандартов"

С Команды
С Команды
Диалоговое окно "Настройка стандартов"
Понятия Процедуры Команды

Панель "Стандарты оформления":

Меню "Сервис": "Стандарты оформления" » "Настроить"

Ввод команды: стандарты

Подключение к текущему чертежу AutoCAD файлов стандартов и вывод списка надстроек, использующихся для проверки на соответствие стандартам.

Нормоконтроль

Вызов диалогового окна "Нормоконтроль".

Режимы

Вызов диалогового окна "Параметры нормоконтроля", в котором задаются дополнительные параметры для диалоговых окон "Нормоконтроль" и "Настройка стандартов".

Диалоговое окно "Настройка стандартов" состоит из следующих вкладок:

  • Стандарты
  • Надстройки

Вкладка "Стандарты"

Отображает информацию о файлах стандартов, подключенных к текущему чертежу.

Файлы стандартов, подключенные к текущему чертежу

Список всех файлов стандартов (DWS-файлов), подключенных к текущему чертежу. Для подключения к чертежу дополнительного файла стандартов следует нажать кнопку "Добавить файл стандартов". Для отключения от чертежа выбранного в списке файла стандартов следует нажать кнопку "Отключить файл стандартов". При возникновении конфликтов между файлами стандартов (например если в двух стандартах задан слой с одним и тем же именем, но разными свойствами) приоритетом обладает файл стандартов, который расположен в списке ближе к началу. Для перемещения файла стандартов вверх или вниз по списку следует выбрать этот файл в списке и нажать кнопку "Вверх" или кнопку "Вниз".

С помощью контекстного меню файла стандартов можно перемещать файл вверх или вниз по списку, а также удалять файл из списка и заменять его другим файлом.

Добавить файл стандартов

Подключение к текущему чертежу AutoCAD дополнительного файла стандартов.

Отключить файл стандартов

Отключение выбранного в списке файла стандартов от чертежа. Отключение файла стандартов не влечет за собой удаление этого файла. При отключении производится разрыв связи текущего чертежа с файлом стандартов.

Вверх

Перемещение выбранного файла стандартов вверх по списку.

Вниз

Перемещение выбранного файла стандартов вниз по списку.

Описание

Краткая информация о выбранном в списке файле стандартов. Можно добавить комментарии и заголовок к описанию путем открытия файла DWS и использования команды СВОЙСТВАРИС. В диалоговом окне "Свойства чертежа" выберите вкладку "Документ".

Вкладка "Надстройки"

Список надстроек, установленных в системе. В настоящее время для каждого типа именованных объектов (размерных и текстовых стилей, слоев и типов линий) устанавливаются надстройки модуля нормоконтроля. Предполагается, что в дальнейшем будут устанавливаться надстройки приложений сторонних разработчиков.

Надстройки, обнаруженные на компьютере

Список надстроек, установленных в системе. Можно указать, какая надстройка будет использоваться для проверки чертежа, отметив ее в списке.

Пояснение

Краткая информация о выбранной в списке надстройке.


Диалоговое окно "Параметры нормоконтроля"

С Команды
С Команды
Диалоговое окно "Параметры нормоконтроля"
Понятия Процедуры Команды

Панель "Стандарты оформления":

Меню "Сервис": "Стандарты оформления" » "Настроить"

Ввод команды: стандарты или нормоконтроль

Задает дополнительные параметры для диалоговых окон Настройка стандартов и Нормоконтроль.

Параметры уведомлений

Здесь задаются параметры уведомлений о нарушениях стандартов.

Отменить уведомления о стандартах

Выбор этой опции отключает уведомления о нарушениях стандартов и об отсутствии файлов стандартов.

Предупреждать при нарушениях стандарта

Выбор этой опции включает уведомления о нарушениях стандартов в текущем чертеже. При нарушении стандарта отображается предупреждение, в котором сообщается, сколько нестандартных объектов было создано или отредактировано во время работы с чертежом. После вывода предупреждения можно исправить нарушение стандарта или проигнорировать его. Если в чертеже используются пакетные файлы или LISP-процедуры, предупреждение не выводится до тех пор, пока пакет или процедура не будут выполнены (системная переменная STANDARDSVIOLATION).

Отображать значок стандартов в строке состояния

Если выбрана эта опция, при открытии файла, связанного с файлом стандартов, а также при создании и редактировании нестандартных объектов в строке состояния отображается значок стандарта (системная переменная STANDARDSVIOLATION).

Параметры нормоконтроля

Здесь задаются параметры исправления нестандартных свойств или игнорирования нарушений.

Автоматически исправлять нестандартные свойства

Управляет режимом автоматического исправления не соответствующих стандартам объектов, если существует наиболее предпочтительная замена. Автоматическая замена происходит только в случаях, когда нестандартный объект имеет имя, совпадающее с именем обладающего другими свойствами стандартного объекта. В этом случае свойства стандартного объекта назначаются объекту, который не соответствовал стандартам. После проверки чертежа количество исправленных нарушений стандартов отображается в окне предупреждения.

Данная опция устанавливается для всех систем и применяется для всех проверяемых чертежей.

Показывать проигнорированные нарушения

Управление режимом отображения ошибок, помеченных как игнорируемые. Если эта опция активна, нарушения стандартов, помеченные как игнорируемые, все равно отображаются на экране при проверке текущего чертежа.

Предпочтительно использовать для замены

Перечень файлов стандартов, на основе которых по умолчанию выбирается рекомендуемое исправление в списке "Заменить на" диалогового окна "Нормоконтроль". Если имеется рекомендуемое исправление (помеченное "галочкой"), по умолчанию выбирается именно рекомендуемое исправление, независимо от выбранного в этом поле файла. Если рекомендуемое исправление не найдено, и выбран файл стандартов (DWS), выбирается первое исправление из выбранного файла стандартов. Если для данной опции выбрано значение "Нет" и рекомендуемое исправление отсутствует, для замены ничего не выбирается.


СТАТ Команда

С Команды
С Команды
СТАТ Команда
Понятия Процедуры Команды

Показ статистики о тонировании

Панель "Тонирование" :

Меню "Вид": "Тонирование" » "Статистика"

Ввод команды: стат

Отображается диалоговое окно "Статистика".

Темы:

  • Диалоговое окно "Статистика"


Диалоговое окно "Статистика"

С Команды
С Команды
Диалоговое окно "Статистика"
Понятия Процедуры Команды

Панель "Тонирование" :

Меню "Вид": "Тонирование" » "Статистика"

Ввод команды: стат

Здесь отображаются сведения о типе тонирования, имени сцены, времени тонирования и т.д. Значения не могут быть изменены, но их можно записать в файл. Список параметров, выводимых в окно, определяется текущими установками диалогового окна "Тонирование".

Тип тонирования

Показывает тип последнего тонирования.

Имя сцены

Вывод имени текущей сцены или "НЕТ", если сцены не существует.

Полное время

Показывает общее время, затраченное на инициализацию, тонирование, траверз, отображение, очистку.

Время инициализации

Показывает время инициализации буферов, источников света, материалов.

Время на траверз и тонирование

Показывает общее время, затраченное на обработку геометрических объектов и тонирование.

Время отображения

Показывает время, затраченное на вывод полученного изображения.

Время очистки

Показывает время очистки буферов, использовавшихся при тонировании.

Время тонирования

Показывает время, затраченное на последнее тонирование.

Всего граней

Показывает число граней, обработанных в ходе последнего тонирования.

Всего треугольников

Показывает число треугольников, обработанных в ходе последнего тонирования.

Сохранить статистику в файле

Сохранение статистики, представленной в окне "Статистика", в ASCII-файле. Необходимо ввести имя файла. Если файл с таким именем уже существует, информация будет добавлена в конец файла.


СТАТУС Команда

С Команды
С Команды
СТАТУС Команда
Понятия Процедуры Команды

Вывод на экран статистической информации о чертеже, режимах и границах

Меню "Сервис": "Сведения" » "Статус"

Ввод команды: статус (или 'статус для прозрачного вызова)

Все координаты и расстояния отображаются при выполнении команды СТАТУС в формате, установленном командой ЕДИНИЦЫ.

Команда СТАТУС выводит число объектов в текущем чертеже. В их число входят графические объекты (такие как дуги и полилинии), неграфические объекты (такие как слои, типы линий и описания блоков). Если ввести СТАТУС в ответ на приглашение команды РАЗМЕР, на экран будут выведены значения и описания всех системных переменных, хранящих информацию о размерах.

Кроме того, команда СТАТУС позволяет вывести на экран следующую информацию.

Пространство модели или листа: лимиты

Показывает лимиты сетки, которые определяются командой ЛИМИТЫ. В первой строке находятся координаты XY нижнего левого угла лимита, хранящиеся в системной переменной LIMMIN. Во второй строке находятся координаты XY верхнего правого угла лимита, хранящиеся в системной переменной LIMMAX. Замечание "Откл" справа от координаты Y говорит об отключенном контроле за лимитами чертежа.

Пространство модели или листа использует

Показывает границы чертежа, которые включают все объекты базы данных и могут выходить за лимиты сетки. В первой строке находятся XY-координаты нижнего левого угла. Во второй строке находятся XY-координаты верхнего правого угла. Замечание "Сверх" справа от координаты Y говорит о том, что чертеж выходит за заданные лимиты сетки.

Экран отображает

Выдает часть границ чертежа, видимую на текущем видовом экране. В первой строке находятся координаты XY нижнего левого угла экрана. Во второй строке находятся XY-координаты верхнего правого угла.

Точка вставки

Точка вставки чертежа, которая хранится в системной переменной INSBASE и выражается в координатах X,Y,Z.

Шаг

Интервалы шаговой привязки в направлениях X и Y, сохраняемые в системной переменной SNAPUNIT.

Интервал сетки

Интервалы шага сетки в направлениях X и Y, сохраняемые в системной переменной GRIDUNIT.

Текущее пространство

Показывает, какое из пространств (модели или листа) активно в данный момент.

Текущая вкладка

Отображает “Модель“ или имя текущего листа.

Текущий слой

Показывает текущий слой, задаваемый системной переменной CLAYER.

Текущий цвет

Показывает текущий цвет, задаваемый системной переменной CECOLOR.

Текущий тип линий

Показывает текущий тип линий, задаваемый системной переменной CELTYPE.

Текущий вес линий

Показывает текущий вес линий, задаваемый системной переменной CELWEIGHT.

Текущий стиль печати

Показывает текущий стиль печати, задаваемый системной переменной CPLOTSTYLE.

Текущий уровень

Показывает текущий уровень, задаваемый системной переменной ELEVATION.

Высота

Показывает текущую высоту, задаваемую системной переменной THICKNESS.

Закрашивание, Сетка, Орто, Ктекст, Шаг, Планшет

Указывает состояние (Вкл/Откл) для данных режимов.

Режимы объектной привязки

Перечисляет текущие режимы объектной привязки, задаваемые командой OSNAP.

Свободно на диске для чертежей

Показывает количество свободного места на диске, выделенном для чертежей.

Свободно на диске для временных файлов

Показывает количество свободного места на диске, выделенном для временных файлов.

Свободная физическая память

Показывает количество свободной оперативной памяти на компьютере.

Свободно в файле подкачки

Показывает количество свободного пространства в файле подкачки.


СТЕРЕТЬ Команда

С Команды
С Команды
СТЕРЕТЬ Команда
Понятия Процедуры Команды

Удаление объектов из чертежа

Панель "Редактирование":

Меню "Изменить": "Стереть"

Контекстное меню: Выбрать объекты для стирания, нажать правую кнопку мыши в области рисования и выбрать "Стереть".

Ввод команды: стереть

Выбрать объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Объекты удаляются из чертежа.


СТИЛЬ Команда

С Команды
С Команды
СТИЛЬ Команда
Понятия Процедуры Команды

Создание и изменение текстовых стилей, а также задание текущего текстового стиля

Панель "Текст:

Меню "Формат": "Текстовые стили"

Ввод команды: стиль (или 'стиль для прозрачного вызова)

Откроется диалоговое окно "Текстовые стили".

Если в ответ на подсказку "Команда:" ввести -стиль, будет вызван вариант команды СТИЛЬ, использующий интерфейс командной строки.

Темы:

  • Диалоговое окно "Текстовые стили"
  • СТИЛЬ (вариант для командной строки)


Диалоговое окно "Текстовые стили"

С Команды
С Команды
Диалоговое окно "Текстовые стили"
Понятия Процедуры Команды

Меню "Формат": "Текстовые стили"

Ввод команды: стиль (или 'стиль для прозрачного вызова)

Создание и изменение текстовых стилей, а также задание текущего текстового стиля.

Имя стиля

Список имен имеющихся текстовых стилей. Создание новых стилей, переименование и удаление имеющихся. Выделенный в списке стиль является текущим. Для изменения текущего стиля нужно либо выбрать другой стиль из списка, либо создать стиль с помощью кнопки "Новый".

Имя стиля может содержать до 255 символов. В именах можно использовать буквы и цифры, а также некоторые специальные знаки: знак доллара ($), подчеркивание (_) и дефис (-).

Новый

Вызов диалогового окна "Новый текстовый стиль" и автоматическое создание нового стиля с именем “стильn“ (где n - порядковый номер нового стиля). Можно либо принять это имя, либо ввести вместо него другое; затем необходимо нажать "OK".

Переименовать

Вызов диалогового окна "Переименование текстового стиля". Для переименования текстового стиля необходимо ввести новое имя и нажать "OK".

Для изменения имени имеющегося текстового стиля можно также использовать команду ПЕРЕИМЕНОВАТЬ. Если в чертеже имеются текстовые объекты, созданные с использованием переименованного стиля, они модифицируются в соответствии с заданным новым именем.

Удалить

Удаление текстового стиля. Перед нажатием кнопки "Удалить" необходимо сделать удаляемый стиль текущим в списке.

Шрифт

Изменение шрифта стиля.

Примечание Если пользователь изменил ориентацию или шрифт для существующего текстового стиля, все использующие его текстовые объекты изменяются при следующей регенерации чертежа.

Имя шрифта

Выводит список имен всех зарегистрированных шрифтов TrueType и SHX-шрифтов, находящихся в папке Fonts. При выборе имени из списка программа читает файл соответствующего шрифта. Загрузка описаний символов файла выполняется автоматически (если только этот файл не используется другим текстовым стилем). Один и тот же шрифт может использоваться различными текстовыми стилями. См. раздел Назначение шрифтов в Руководстве пользователя.

Начертание

Начертание символов шрифта (курсив, полужирный или обычный). Если установлен флажок "Использовать большой шрифт", данная опция заменяется опцией "Большой шрифт", которая используется для выбора имени файла большого шрифта.

Высота

Высота символов текста. Если ввести 0.0, программа запрашивает высоту при создании текстового объекта с использованием данного текстового стиля. Задание величины, большей чем 0.0, устанавливает фиксированную высоту. При одной и той же высоте символы шрифтов TrueType могут выглядеть несколько меньшими по сравнению с символами SHX-шрифтов. См. раздел Задание высоты символов в Руководстве пользователя.

Примечание Заданная высота текста может не совпадать с высотой заглавных букв шрифтов TrueType, поставляемых с программой.

Использовать большой шрифт

Использование файла большого шрифта (для азиатских языков). Опция доступна, только если основным является SHX-шрифт. Большие шрифты могут быть созданы только на базе файлов SHX-шрифтов.

Подробнее об использовании больших шрифтов для азиатских языков см. раздел Использование шрифтов текста для работ в рамках международного сотрудничества в Руководстве пользователя.

Эффекты

Задание параметров начертания шрифта: перевернутый, справа налево, вертикальный, степень растяжения, угол наклона.

Перевернутый

Отображение символов перевернутыми.

Справа налево

Отображение символов справа налево.

Вертикальный

Написание текста сверху вниз. Вертикальное направление может быть выбрано, только если оно поддерживается используемым шрифтом. Для шрифтов TrueType оно недопустимо.

Степень растяжения

Степень сжатия/растяжения символов. Задание значения, меньшего 1.0, вызывает сжатие. Задание значения, большего 1.0, вызывает растяжение.

Угол наклона

Угол наклона символов текста. Значение угла наклона текста может лежать в диапазоне от -85 до 85 градусов.

Примечание Шрифты TrueType, к которым применяются описанные в этом разделе эффекты, могут выглядеть на экране как полужирные. Это, однако, проявляется только на экране. При выводе на плоттер все стили в точности отражают заданное для них форматирование.

Образец

Образец текста, динамически изменяющийся при смене шрифтов и задании эффектов. Для изменения текста, показываемого в качестве образца, служит текстовое поле в нижней части группы.

Предварительный просмотр текста

Обеспечивает предварительный просмотр текста, выводимого на печать.

Показать

Обновление образца текста в области предварительного просмотра изображений символов с учетом всех изменений, внесенных в диалоговом окне.

Примечание Заданная в стиле высота игнорируется при создании образца для просмотра.

Применить

Применение текущих параметров, заданных в диалоговом окне, к текстовым объектам чертежа, выполненным с использованием текущего стиля.

Закрыть

Нажатие кнопки "Применить" позволяет принять текущие значения параметров. Если с помощью диалогового окна изменено состояние хотя бы одной опции, кнопка "Отмена" заменяется кнопкой "Закрыть". Изменение текущего стиля, переименование и удаление производятся немедленно и не могут быть проигнорированы путем выхода из окна кнопкой "Отмена".

Отмена

Если с помощью диалогового окна изменено состояние хотя бы одной опции, кнопка "Отмена" заменяется кнопкой "Закрыть".


СТИЛЬ (вариант для командной строки)

С Команды
С Команды
СТИЛЬ (вариант для командной строки)
Понятия Процедуры Команды

Если в ответ на подсказку "Команда:" ввести -стиль, будет вызван вариант команды СТИЛЬ, использующий интерфейс командной строки.

Имя текстового стиля или [?] <текущее>: Ввести имя стиля, ввести ? или нажать ENTER

Имя текстового стиля

Имя текстового стиля. Имя может содержать до 255 символов. В него могут входить буквы, цифры, пробелы и специальные символы, не используемые ОС Microsoft® Windows® и данной программой в других целях. В него могут входить буквы, цифры, пробелы и специальные символы, не используемые Microsoft Windows и AutoCAD в других целях. Если используется большой шрифт, то длинные имена файлов шрифтов не должны содержать запятых; этот символ считается разделителем имени SHX-файла и файла большого шрифта. После нажатия ENTER выдается следующий запрос (полные имена шрифтов отображаются, только если текущим установлен шрифт TrueType):

Существующий стиль. Полное имя шрифта = текущее :

Укажите полное имя шрифта или имя файла (TTF или SHX):

Необходимо указать имя семейства шрифтов TrueType или имя файла SHX-шрифта. Если расширение не задано, программа производит поиск SHX-шрифта с указанным именем. Если файл не найден, операционная система Windows подставляет первый из обнаруженных TrueType-шрифтов.

В ответ на запрос допускается ввод любых (в том числе длинных) имен файлов, кроме содержащих запятые. Запятая зарезервирована для присвоения имен файлам больших шрифтов: имя SHX-файла, запятая, затем имя файла большого шрифта. Пробелы здесь интерпретируются как часть имени шрифта; они не эквивалентны переводу каретки.

Если ввести тильду (~), на экран выводится диалоговое окно "Выбор файла шрифта".

Допустимые типы файлов для выбора — SHX и TTF. Загрузка описаний символов выбранного файла шрифта происходит автоматически при условии, что указанный шрифт не используется каким-либо другим стилем. Один и тот же шрифт может служить основой для нескольких текстовых стилей.

Высота текста <текущая>: Задать расстояние или нажать ENTER

Если ввести значение высоты 0.0, программа запросит высоту при создании текстового объекта с использованием данного текстового стиля. Задание величины, большей чем 0.0, устанавливает фиксированную высоту.

Степень сжатия-растяжения <текущая>: Задать расстояние или нажать ENTER

Задание значения, меньшего 1.0, вызывает сжатие. Задание значения, большего 1.0, вызывает растяжение.

Угол наклона <текущий>: Задать угол или нажать ENTER

Значение угла наклона может лежать в диапазоне от -85 до 85 градусов.

Писать текст справа налево? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

Создавать перевернутый текст? [Да/Нет] <Н>: Ввести д или н или нажать ENTER

Вертикальный? <Н>: Ввести д или н, либо нажать ENTER

Вертикальное направление может быть выбрано, только если оно поддерживается используемым шрифтом.

?—Список текстовых стилей

Получение списка имеющихся в текущем чертеже текстовых стилей.

Имена каких стилей вывести <*>: Ввести имя стиля или нажать ENTER

Если в ответ на запрос ввести имя стиля, выводятся его характеристики: имя стиля, имя файла шрифта, высота, степень сжатия-растяжения, угол наклона и ориентация, после чего команда завершается. При вводе звездочки (*) или нажатии ENTER отображаются параметры каждого текстового стиля: высота, коэффициент сжатия-растяжения, угол наклона и ориентация (справа налево, перевернутый, вертикальный или обычный); после этого команда завершается.


Т Команды
  • Т-ВИД
  • Т-ПРОФИЛЬ
  • Т-РИСОВАНИЕ
  • ТАБЛВСТБЛОК
  • ТАБЛИЦА
  • ТАБЛРЕД
  • ТАБЛСТИЛЬ
  • ТЕКВИЗСТИЛЬ
  • ТЕКСТ
  • ТЕКСТПЕРПЛАН
  • ТЕКСТЭКР
  • ТЗАГРТИП
  • ТЗРЕНИЯ
  • ТИПЛИН
  • ТОЛЩИНА
  • ТОНИРОВАТЬ
  • ТОНИРОКНО
  • ТОНИРПОДРЕЗ
  • ТОНЭКР
  • ТОР
  • ТОЧКА
  • ТОЧСВЕТ
  • ТУМАН


Т-ВИД Команда

Т Команды
Т Команды
Т-ВИД Команда
Понятия Процедуры Команды

Создает видовые экраны листов с использованием ортогональных проекций для компоновки чертежей 3D тел и объектов тел со множеством видов и в разрезе.

Меню "Рисование": "Моделирование" » "Подготовка" » "Вид"

Ввод команды: т-вид

Примечание Вызов команды Т-ВИД производится на вкладке "Лист". Если же активна вкладка "Модель", происходит переключение на последний использованный лист.

Задайте опцию [Пск/Орто/Дополнительный/Сечение]: Задать опцию или нажать ENTER для завершения команды

Команда Т-ВИД располагает объекты видового экрана на слое ВЭКРАН (если этот слой не существует, команда предварительно создает его). Информация, сохраняемая вместе с каждым созданным видовым экраном, используется командой Т-РИСОВАНИЕ для формирования вида законченного чертежа.

Команда Т-ВИД создает слои, которые используются командой Т-РИСОВАНИЕ для размещения видимых и скрытых линий для каждого вида (имя вида-VIS, имя вида-HID, имя вида-HAT) и слой для размещения размеров, видимых на отдельных видовых экранах (имя вида-DIM).

Предупреждение Информация, которая хранится на этих слоях, удаляется и обновляется в ходе выполнения команды РИСОВАНИЕ. На таких слоях не следует размещать постоянные данные чертежа.

Примечание Команда Т-ВИД определяется в приложении acsolids.arx и предназначена только для интерактивного использования.

ПСК

Создает вид относительно пользовательской системы координат. Если в чертеже еще нет видовых экранов, использование этой опции является хорошим способом создания исходного видового экрана, из которого затем можно создать остальные виды. Для всех остальных опций команды Т-ВИД требуется существование видового экрана.

Для задания плоскости вида используется либо текущая ПСК, либо предварительно сохраненная ПСК. Проекция на видовом экране создается параллельно плоскости XY ПСК с осью X, направленной вправо, и осью Y, направленной вверх.

Задайте опцию [Имя/Мск/?/Текущая] <текущая>: Задать опцию или нажать ENTER

Имя

Использует для создания вида профиля плоскость XY именованной ПСК.

Имя восстанавливаемой ПСК: Ввести имя имеющейся ПСК

Масштаб вида <1.0>: Ввести число или нажать ENTER

Нужно ввести имя требуемой ПСК и масштаб вида. Ввод масштаба аналогичен заданию коэффициента увеличения изображения на видовом экране относительно пространства листа. По умолчанию действует значение 1:1.

Центр вида: Указать точку и по окончании нажать ENTER

Вид создается в соответствии с текущими границами пространства модели. Можно последовательно выбрать несколько точек, пока не будет установлено подходящее расположение вида.

Затем появляется запрос о положении двух противоположных углов вида.

Первый угол видового экрана: Указать точку

Противоположный угол видового экрана: Указать точку

Имя вида: Задать имя вида

Т-ВИД возвращается к предыдущему запросу.

МСК

Использует для создания вида профиля плоскость XY МСК.

Масштаб вида <1.0>: Ввести число или нажать ENTER

Нужно ввести имя требуемой ПСК и масштаб вида. Ввод масштаба аналогичен заданию коэффициента увеличения изображения на видовом экране относительно пространства листа. По умолчанию действует значение 1:1.

Центр вида: Указать точку и по окончании нажать ENTER

Вид создается в соответствии с текущими границами пространства модели. Можно последовательно выбрать несколько точек, пока не будет установлено подходящее расположение вида.

Затем появляется запрос о положении двух противоположных углов вида.

Первый угол видового экрана:

Противоположный угол видового экрана:

Имя вида: Задать имя вида

Т-ВИД возвращается к предыдущему запросу.

?—Список именованных ПСК

Перечисляет имена существующих пользовательских систем координат. Список можно ограничить путем ввода комбинации глобальных символов (правила их задания аналогичны используемым в команде ПСК).

Имена ПСК для вывода <*>: Ввести имя или нажать ENTER для вывода списка всех именованных ПСК

После завершения вывода списка нажатие любой клавиши возвращает к начальному запросу.

Текущая

Использует для создания вида профиля плоскость XY текущей ПСК.

Масштаб вида <1.0>: Ввести число или нажать ENTER

Нужно ввести имя требуемой ПСК и масштаб вида. Ввод масштаба аналогичен заданию коэффициента увеличения изображения на видовом экране относительно пространства листа. По умолчанию действует значение 1:1.

Центр вида: Указать точку и по окончании нажать ENTER

Вид создается в соответствии с текущими границами пространства модели. Можно последовательно выбрать несколько точек, пока не будет установлено подходящее расположение вида.

Затем появляется запрос о положении двух противоположных углов вида.

Первый угол видового экрана:

Противоположный угол видового экрана:

Имя вида: Задать имя вида

Т-ВИД возвращается к предыдущему запросу.

Орто

Создает вид, ортогональный имеющемуся (вид сбоку или сверху).

Сначала следует запрос о стороне видового экрана, которая будет базовой для размещения нового вида; резиновая линия, перпендикулярная видовому экрану, помогает установить центр нового вида. Можно последовательно выбрать несколько точек, пока не будет установлено подходящее расположение вида.

Укажите сторону видового экрана для проекции: Указать сторону

Центр вида: Указать точку и нажать ENTER

Затем появляется запрос о положении двух противоположных углов вида.

Первый угол видового экрана:

Противоположный угол видового экрана:

Имя вида: Задать имя вида

Дополнительный

Создает дополнительный вид на базе имеющегося. Этот вид является проекцией на плоскость, ортогональную одному из основных видов и наклонную относительно смежного вида.

Сначала следует запрос о положении двух точек, определяющих наклонную плоскость для дополнительной проекции. Обе точки должны находиться на одном и том же видовом экране.

Первая точка наклонной плоскости:

Вторая точка наклонной плоскости:

Следующая точка определяет сторону, которая будет использоваться для проецирования нового вида.

Сторона просмотра: Указать точку

Резиновая линия, перпендикулярная наклонной плоскости, помогает установить центр нового вида. Можно последовательно выбрать несколько точек, пока не будет установлено подходящее расположение вида.

Центр вида: Указать точку и нажать ENTER

Затем появляется запрос о положении двух противоположных углов вида.

Первый угол видового экрана:

Противоположный угол видового экрана:

Имя вида: Задать имя вида

Сечение

Создает разрез тел и наносит на него штриховку. При использовании команды Т-РИСОВАНИЕ на виде, созданном при помощи этой опции, образуется временная копия тел и по заданной секущей плоскости выполняется команда РАЗРЕЗ. Далее команда Т-РИСОВАНИЕ создает профиль видимой половины тел и удаляет исходную копию. На конечном этапе выполнения команды Т-РИСОВАНИЕ производится разрез тел. Тела, не пересеченные секущей плоскостью, генерируются в виде обычных контуров. Так как обычно скрытые линии разреза не рисуются, команда Т-ВИД замораживает слой имя вида-HID.

На начальном видовом экране нужно указать две точки, определяющие секущую плоскость.

Первая точка секущей плоскости:

Вторая точка секущей плоскости:

Следующая точка определяет сторону секущей плоскости, которая будет использоваться для проецирования нового вида.

Сторона просмотра: Указать точку

Далее вводится масштаб нового вида. Ввод масштаба аналогичен заданию коэффициента увеличения изображения на видовом экране относительно пространства листа. По умолчанию действует значение 1:1, соответствующее коэффициенту 1.0XЛ.

Масштаб вида <текущий>: Ввести положительное значение

В командной строке появляется запрос о центральной точке. Если принят масштаб по умолчанию (нажатием ENTER), центр нового вида определяется с помощью резиновой линии, перпендикулярной секущей плоскости. В противном случае вид может быть помещен в любое место. Можно последовательно выбрать несколько точек, пока не будет установлено подходящее расположение вида.

Центр вида: Указать точку и нажать ENTER

Затем появляется запрос о положении двух противоположных углов вида.

Первый угол видового экрана:

Противоположный угол видового экрана:

Имя вида: Задать имя вида


Т-ПРОФИЛЬ Команда

Т Команды
Т Команды
Т-ПРОФИЛЬ Команда
Понятия Процедуры Команды

Создает профили трехмерных тел в пространстве листа

Меню "Рисование": "Моделирование" » "Подготовка" » "Контуры"

Ввод команды: т-профиль

Выберите объекты: Выбрать объекты любым способом

Изображать скрытые линии профиля на отдельном слое? [Да/Нет ] <Д>: Ввести д или н или нажать ENTER

Да

Генерируются только два блока: один для видимых линий, а другой для скрытых линий всего набора. При генерации скрытых линий тела могут частично или полностью закрываться другими телами. Блок видимых линий рисуется типом линий ПОСЛОЮ, а блок скрытых линий типом линий НЕВИДИМАЯ (если этот тип линий загружен). Блоки скрытых и видимых линий профиля помещаются на слои с уникальными именами в соответствии со следующим соглашением:

PV-метка видового экрана слой видимых линий

PH-метка видового экрана слой скрытых линий

Например, при создании профиля на видовом экране с номером 4B команда поместит блок с видимыми линиями профиля на слой с именем PV-4B, а блок со скрытыми линиями (если установлен режим его создания) — на слой с именем PH-4B. Если эти слои не существуют, команда создает их. Если эти слои существуют, блоки добавляются к имеющимся на них объектам.

Примечание Для того чтобы узнать метку видового экрана, следует перейти в пространство листа и ввести команду СПИСОК. Переключение из пространства модели в пространство листа производится выбором вкладки одного из листов.

Команда Т-ПРОФИЛЬ не изменяет видимость слоев; для просмотра только созданных линий профиля следует отключить слой с исходным телом (обычно это текущий слой).

Нет

Все линии профиля трактуются как видимые, и для каждого выбранного тела создается отдельный блок профильных линий. Для каждого тела в наборе создаются все линии профиля, даже если одно тело частично или полностью закрывается другим. Блок видимых линий рисуется тем же типом линий, что и первоначальный твердотельный объект, и размещается на слое с уникальным именем, присвоенным в соответствии с описанным выше для опции "Да".

Примечание При удалении скрытых линий наличие перекрывающихся тел (тел, имеющих общий объем) может привести к появлению висячих кромок. Это происходит из-за того, что кромки разрываются в точке соприкосновения с другим телом для их разделения на видимые и скрытые части. Для устранения висячих кромок следует перед созданием профиля объединить перекрывающиеся тела (при помощи команды ОБЪЕДИНЕНИЕ).

Затем появляется запрос о типе объектов (2D или 3D), представляющих видимые и скрытые линии профиля.

Проецировать линии профиля на плоскость? [Да/Нет] <Д>: Ввести д или н или нажать ENTER

Да

Линии профиля представляют собой 2D объекты. 3D профиль проецируется на плоскость, перпендикулярную направлению взгляда и проходящую через точку начала ПСК. Т-ПРОФИЛЬ выполняет очистку 2D профилей путем удаления линий, параллельных направлению взгляда, и преобразования кругов, видимых на ребре, в отрезки.

Нет

Линии профиля состоят из 3D объектов AutoCAD.

В следующей подсказке спрашивается, нужно ли удалять касательные кромки. Касательной кромкой называется линия перехода между двумя касательными гранями. Это — воображаемая линия соприкосновения двух граней. Например, при сопряжении кромки ящика в местах переходов от цилиндрической поверхности к планарным образуются касательные кромки. Обычно в чертежах касательные кромки не показываются.

Удалить касательные кромки? [Да/Нет] <Д>: Ввести д или н или нажать ENTER


Т-РИСОВАНИЕ Команда

Т Команды
Т Команды
Т-РИСОВАНИЕ Команда
Понятия Процедуры Команды

Построение профилей и сечений на видовых экранах, созданных командой Т-ВИД

Меню "Рисование": "Моделирование" » "Подготовка" » "Построение"

Ввод команды: т-рисование

Выберите видовые экраны для построений...

Выберите объекты: Выбрать видовые экраны

Команда Т-РИСОВАНИЕ применима только к видовым экранам, созданным с помощью команды Т-ВИД.

Сначала строятся видимые и скрытые линии силуэта и кромок твердотельных объектов на видовом экране, затем выполняется их проецирование на плоскость, перпендикулярную направлению взгляда. Силуэты и кромки генерируются для всех тел и частей тел, находящихся за плоскостью сечения. Сечения тел штрихуются; при этом используются текущие значения системных переменных HPNAME, HPSCALE и HPANG.

Все существующие профили и сечения на выбранном видовом экране удаляются, и вместо них создаются новые. Все слои, за исключением тех, которые нужны для отображения профиля или сечения, замораживаются.

Предупреждение Не следует размещать на слоях имя вида-VIS, имя вида-HID и имя вида-HAT никаких постоянных объектов чертежа. Информация, которая хранится на этих слоях, удаляется и обновляется в ходе выполнения команды Т-РИСОВАНИЕ.

Для отмены видового экрана, подготовленного командой Т-РИСОВАНИЕ следует использовать опцию "Обратно" команды ОТМЕНИТЬ.

Примечание Команда Т-РИСОВАНИЕ определяется в приложении acsolids.arx и предназначена только для интерактивного использования. Информацию об использовании этой команды в приложении см. в разделе “Команды, определяемые извне“ документа Справочное руководство AutoLISP.


ТАБЛВСТБЛОК Команда

Т Команды
Т Команды
ТАБЛВСТБЛОК Команда
Понятия Процедуры Команды

Вставка блока в ячейку таблицы

Контекстное меню: Выбрав ячейку таблицы, нажмите правую кнопку мыши и выберите в контекстном меню "Вставить блок".

Ввод команды: таблвстблок

Откроется диалоговое окно "Вставка блока в ячейку таблицы".

Темы:

  • Диалоговое окно "Вставка блока в ячейку таблицы"


Диалоговое окно "Вставка блока в ячейку таблицы"

Т Команды
Т Команды
Диалоговое окно "Вставка блока в ячейку таблицы"
Понятия Процедуры Команды

Контекстное меню: Выбрав ячейку таблицы, нажмите правую кнопку мыши и выберите в контекстном меню "Вставить блок".

Ввод команды: таблвстблок

Задание параметров вставки блока в ячейку таблицы.

Выравнивание в ячейке

Задание параметров выравнивания блока в ячейке таблицы. Относительно верхней и нижней границы ячейки блок можно выравнивать по середине, по верхнему краю или по нижнему краю. Относительно левой и правой границы ячейки блок можно выравнивать по центру, по левому краю или по правому краю.

Масштаб

Задание масштаба для вхождения блока. Для автоматического масштабирования блока по размеру ячейки следует ввести значение масштаба или выбрать "Вписать".

Угол поворота

Задание угла поворота блока.


ТАБЛИЦА Команда

Т Команды
Т Команды
ТАБЛИЦА Команда
Понятия Процедуры Команды

Создание пустой таблицы объектов в чертеже

Панель "Рисование":

Меню "Рисование": "Таблица"

Ввод команды: таблица

Откроется диалоговое окно "Вставка таблицы".

Если в ответ на подсказку "Команда:" ввести -таблица, будет вызван вариант команды ТАБЛИЦА, использующий интерфейс командной строки.

Темы:

  • Диалоговое окно "Вставка таблицы"
  • ТАБЛИЦА (вариант для командной строки)


Диалоговое окно "Вставка таблицы"

Т Команды
Т Команды
Диалоговое окно "Вставка таблицы"
Понятия Процедуры Команды

Панель "Рисование":

Меню "Рисование": "Таблица"

Ввод команды: таблица

Вставка пустой таблицы в чертеж.

Настройка стиля таблиц

Позволяет задать внешний вид таблиц.

Имя стиля

Задание имени стиля таблиц. По умолчанию используется стиль STANDARD.

Высота текста

Отображение высоты текста, заданной в текущем стиле таблиц для строк данных (только для чтения).

Образец

Отображение образца текущего стиля таблиц.

Способ вставки

Задание расположения таблицы.

Запрос точки вставки

Задание расположения левого верхнего угла таблицы. Расположение точек задается с помощью мыши или посредством ввода координат в командной строке. Если в стиле таблицы определено направление построения таблицы снизу вверх, точка вставки соответствует левому нижнему углу таблицы.

Запрос занимаемой области

Задание размера и расположения таблицы. Расположение точек задается с помощью мыши или посредством ввода координат в командной строке. При выборе этой опции число столбцов и строк, а также ширина столбцов и высота строк зависят от размера рамки и параметров столбцов и строк.

Строки и столбцы

Задание числа и размера столбцов и строк.

Значок столбца

Обозначение столбцов

Значок строки

Обозначение строк.

Количество столбцов

Задание количества столбцов. При выборе опции "Запрос занимаемой области" и задании ширины столбцов включается опция "Авто", и число столбцов вычисляется в соответствии с шириной таблицы.

Ширина столбцов

Задание ширины столбцов в таблице. При выборе опции "Запрос занимаемой области" и задании числа столбцов включается опция "Авто", и ширина столбцов вычисляется в соответствии с шириной таблицы. Минимальная ширина столбцов — один печатный символ.

Количество строк

Задание количества строк. При выборе опции "Запрос занимаемой области" и задании высоты строк включается опция "Авто", и число строк вычисляется в соответствии с высотой таблицы. Стиль таблиц со строкой названия и строкой заголовка определяет таблицу, содержащую как минимум три строки. Минимальная высота строк — одна строка текста.

Высота строки

Задание высоты строки в строках текста. Высота строки текста зависит от высоты текста и отступов от границ ячеек; эти параметры задаются в стиле таблиц. При выборе опции "Запрос занимаемой области" и задании числа строк включается опция "Авто", и высота строк вычисляется в соответствии с высотой таблицы.


ТАБЛИЦА (вариант для командной строки)

Т Команды
Т Команды
ТАБЛИЦА (вариант для командной строки)
Понятия Процедуры Команды

Если в ответ на подсказку «Команда:» ввести -таблица, будет вызван вариант команды ТАБЛИЦА, использующий интерфейс командной строки.

Текущий стиль таблиц: "Standard" Ширина ячейки: 2,5000 Высота ячейки: 1 строка

Количество столбцов или [Авто] <5>:

Количество столбцов

Задание количества столбцов.

Количество строк или [Aвто] <1>:

Количество строк

Задание количества строк.

Точка вставки или [Стиль/Ширина/Высота]:

Точка вставки

Задание расположения левого верхнего угла таблицы. Расположение точек задается с помощью мыши или посредством ввода координат в командной строке. Если в стиле таблицы определено направление построения таблицы снизу вверх, точка вставки соответствует левому нижнему углу таблицы.

Ширина

Задание ширины столбцов таблицы.

Ширина ячеек <2,50000>:

Точка вставки или [Стиль/Ширина/Высота]:

Высота

Задание высоты строк таблицы.

Минимальная высота ячеек <1 строка>:

Точка вставки или [Стиль/Ширина/Высота]:

Стиль

Задание стиля для таблицы.

Имя стиля таблиц <текущее>

Точка вставки или [Стиль/Ширина/Высота]:

Авто

Задание размера и расположения таблицы. Расположение точек задается с помощью мыши или посредством ввода координат в командной строке. Эта опция позволяет задать число или ширину столбцов, но не оба параметра одновременно. Число и высота строк зависят от указанного размера рамки.

Первый угол или [Высота]:

Первый угол

Задание расположения левого верхнего угла таблицы. Если в стиле таблицы определено направление построения таблицы снизу вверх, точка вставки соответствует левому нижнему углу таблицы.

Противоположный угол:

Высота

Задание высоты строк таблицы.

Минимальная высота ячеек <1 строка>:

Первый угол или [Высота]:

Авто

Задание размера и расположения таблицы. Расположение точек задается с помощью мыши или посредством ввода координат в командной строке. Эта опция позволяет задать число или ширину столбцов, но не оба параметра одновременно. Число и высота строк зависят от указанного размера рамки.

Число строк или [Aвто] <1>:

Число строк

Задание числа строк.

Первый угол или [Ширина]:

Противоположный угол:

Авто

Задание размера и расположения таблицы.

Первый угол или [Ширина]:

Противоположный угол:


ТАБЛРЕД Команда

Т Команды
Т Команды
ТАБЛРЕД Команда
Понятия Процедуры Команды

Редактирование текста в ячейках таблиц

Устройство указания: Дважды нажмите левой кнопкой мыши на ячейке таблицы.

Контекстное меню: Выбрав ячейку таблицы, нажмите правую кнопку мыши и в контекстном меню выберите "Изменить текст".

Ввод команды: таблред

Выберите ячейку таблицы: Нажать левую кнопку мыши внутри ячейки таблицы, ввести текст или внести изменения с помощью панели "Формат текста" или контекстного меню вкладки "Параметры"


ТАБЛСТИЛЬ Команда

Т Команды
Т Команды
ТАБЛСТИЛЬ Команда
Понятия Процедуры Команды

Создание нового стиля таблиц

Панель "Стили":

Меню "Формат": "Стили таблиц"

Ввод команды: таблстиль

Откроется диалоговое окно "Стили таблиц".

Темы:

  • Диалоговое окно "Стиль таблиц"
  • Диалоговое окно "Создание нового стиля таблиц"
  • Диалоговые окна "Новый стиль таблиц" и "Изменение стиля таблиц"
  • Диалоговое окно "Формат ячейки таблицы"
  • Диалоговое окно "Дополнительный формат"


Диалоговое окно "Стиль таблиц"

Т Команды
Т Команды
Диалоговое окно "Стиль таблиц"
Понятия Процедуры Команды

Панель "Стили":

Меню "Формат": "Стили таблиц"

Ввод команды: таблстиль

Задание текущего стиля таблиц, а также создание, изменение и удаление стилей таблиц.

Текущий стиль таблиц

Отображение имени стиля, который назначается создаваемым в чертежах таблицам. По умолчанию используется стиль STANDARD.

Стили

Отображение списка стилей таблиц. Текущий стиль подсвечивается.

Список

Управление элементами списка "Стили".

Все стили

Отображение всех стилей таблиц.

Задействованные стили

Отображение только стилей, на которые ссылаются таблицы текущего чертежа.

Образец

Предварительный просмотр стиля, выбранного в списке "Стили.

Установить

Установка текущим стиля, выбранного в списке "Стили". Все новые таблицы создаются на основе этого стиля.

Создать

Вызов диалогового окна "Создание нового стиля таблиц", в котором можно создавать новые стили таблиц.

Изменить

Вызов диалогового окна "Изменение стиля таблиц", в котором можно изменять стили таблиц.

Удалить

Удаление стиля таблиц из списка "Стили". Стили, используемые в чертеже, не могут быть удалены.


Диалоговое окно "Создание нового стиля таблиц"

Т Команды
Т Команды
Диалоговое окно "Создание нового стиля таблиц"
Понятия Процедуры Команды

Панель "Стили":

Меню "Формат": "Стили таблиц"

Ввод команды: таблстиль

Задание имени для нового стиля таблиц и выбор существующего стиля таблиц, на основе которого создается новый стиль.

Имя нового стиля

Задание имени нового стиля таблиц.

На основе

Задание существующего стиля таблиц, параметры которого наследует новый стиль таблиц.

Далее

Вызов диалогового окна "Новый стиль таблиц", в котором можно создать новый стиль таблиц.


Диалоговые окна "Новый стиль таблиц" и "Изменение стиля таблиц"

Т Команды
Т Команды
Диалоговые окна "Новый стиль таблиц" и "Изменение стиля таблиц"
Понятия Процедуры Команды

Панель "Стили":

Меню "Формат": "Стили таблиц"

Ввод команды: таблстиль

Задание нового или изменение существующего стиля таблиц. Диалоговое окно "Новый стиль таблиц" открывается при нажатии кнопки "Создать" в диалоговом окне "Стили таблиц" и задании имени в диалоговом окне "Создание нового стиля таблиц". Диалоговое окно "Изменение стиля таблиц" открывается при нажатии кнопки "Изменить" в диалоговом окне "Стили таблиц". Опции этих диалоговых окон одинаковы.

Каждое диалоговое окно содержит три вкладки: "Данные", "Заголовки столбцов" и "Заголовок таблицы". Опции этих вкладок позволяют задать внешний вид ячеек данных, заголовков столбцов и заголовка таблицы.

Свойства ячеек

Задание внешнего вида ячеек данных, заголовков столбцов и заголовка таблицы в зависимости от того, какая вкладка активна: "Данные", "Заголовки столбцов" или "Заголовок таблицы".

Для всех строк данных

Применение текущих настроек ко всем строкам данных (только для вкладки "Данные").

Заголовки столбцов/Заголовок таблицы

Добавление строки заголовка таблицы (только для вкладки "Заголовок таблицы") или строки заголовков столбцов (только для вкладки "Заголовки столбцов"). Если убрать этот флажок, параметры свойств ячеек становятся недоступны.

Текстовый стиль

Вывод списка всех текстовых стилей текущего чертежа. Кнопка "[...]" служит для вызова диалогового окна "Текстовые стили", в котором можно создать новый текстовый стиль.

Высота текста

Задание высоты текста. По умолчанию высота текста для данных и ячеек заголовков столбцов равна 0,1800. Высота текста по умолчанию для названия таблицы равна 0,25.

Цвет текста

Задание цвета текста.

При выборе параметра "Выбор цвета" открывается диалоговое окно "Выбор цвета".

Цвет фона

Задание цвета фона для ячеек. По умолчанию используется значение "Нет".

При выборе параметра "Выбор цвета" открывается диалоговое окно "Выбор цвета".

Выравнивание

Задание выравнивания текста в ячейках таблицы. Относительно верхней и нижней границы ячейки текст можно выравнивать по середине, по верхнему краю или по нижнему краю. Относительно правой и левой границы ячейки текст можно выравнивать по центру, по правому краю или по левому краю. Описание всех девяти видов выравнивания приведено в разделе Выравнивание многострочного текста Руководства пользователя.

Формат

Задание типа данных и формата следующих ячеек таблицы: "Данные", "Заголовок столбца" и "Заголовок таблицы".

Нажмите кнопку [...] справа от поля "Формат" для вызова диалогового окна "Формат ячейки таблицы", в котором задаются дополнительные опции форматирования.

Свойства границ

Задание внешнего вида границ ячеек. К свойствам границ относятся вес и цвет линий.

Все границы

Применение заданных свойств границ ко всем границам ячеек данных, ячеек заголовков столбцов или ячейки заголовка таблицы, в зависимости от того, какая вкладка выбрана.

Внешние границы

Применение заданных свойств границ к внешним границам ячеек данных, ячеек заголовков столбцов или ячейки заголовка таблицы, в зависимости от того, какая вкладка выбрана.

Внутренние границы

Применение заданных свойств границ к внутренним границам ячеек данных или ячеек заголовков столбцов, в зависимости от того, какая вкладка выбрана. Этот параметр не применим к ячейке заголовка таблицы.

Без границ

Скрытие границ ячеек данных, ячеек заголовков столбцов или ячейки заголовка таблицы, в зависимости от того, какая вкладка выбрана.

Нижние границы

Применение заданных свойств границ к нижним границам ячеек данных, ячеек заголовков столбцов или ячейки заголовка таблицы, в зависимости от того, какая вкладка выбрана.

Вес линий границ

Назначение веса линий границам, которые задаются с помощью кнопки "Граница". При использовании широких линий может потребоваться увеличить отступы от границ ячеек.

Цвет линий границ

Назначение цвета границам, которые задаются с помощью кнопки "Граница".

При выборе параметра "Выбор цвета" открывается диалоговое окно "Выбор цвета".

Образец

Отображение образца таблицы с настройками текущего стиля.

Общие

Изменение направления построения таблицы.

Направление построения

Задание направления построения таблицы.

  • Вниз: Создание таблицы, заполняемой сверху вниз. Строки названия и заголовков столбцов отображаются вверху таблицы. Если выбрать "Вставить строки" и нажать "Ниже", новая строка вставляется под текущей строкой.
  • Вверх: Создание таблицы, заполняемой снизу вверх. Строки названия и заголовков столбцов отображаются внизу таблицы. Если выбрать "Вставить строки" и нажать "Выше", новая строка вставляется над текущей строкой.
Отступ в ячейках

Задание расстояния между границами и содержимым ячеек. Параметры отступа от границ ячеек применяются ко всем ячейкам таблицы. Значение по умолчанию для отступа равно 0,06 (британская система) или 1,5 (метрическая система).

По горизонтали

Задание расстояния между текстом/блоком и левой и правой границами ячеек.

По вертикали

Задание расстояния между текстом/блоком и верхней и нижней границами ячеек.


Диалоговое окно "Формат ячейки таблицы"

Т Команды
Т Команды
Диалоговое окно "Формат ячейки таблицы"
Понятия Процедуры Команды

Меню "Формат": "Стили таблиц"

Ввод команды: таблстиль

Задание формата следующих ячеек таблицы: "Данные", "Заголовок столбца" и "Заголовок таблицы". Опции, отображаемые в этом диалоговом окне, изменяются в соответствии с выбранным типом данных и форматом.

Тип данных

Вывод списка типов данных ("Углы", "Дата", "Десятичное число" и пр.), которые можно назначить строкам таблицы.

Образец

Предварительный просмотр результата использования варианта, выбранного в списке "Формат".

Формат

Отображение списка подходящих форматов для выбранного типа данных. Например, если выбран тип данных "Углы", список форматов включает "Десятичные градусы", "Грады", "Радианы" и т. д.

Точность

Установка точности для форматов, соответствующих только следующим типам данных: "Углы", "Десятичное число" и "Точка". Например, если выбран тип данных "Углы" и формат "Радианы", допустимы следующие значения точности: "Текущая точность", 0,0x, 0,00x, 0,000x и т. д.

Разделитель списка

Отображение перечня символов (запятая, точка с запятой или двоеточие), которые можно использовать в качестве разделителей элементов списка [только для типа данных "Точка"].

Координаты X, Y и Z

Фильтрация координат X, Y или Z (только для типа данных "Точка").

Дополнительный формат

Вызов диалогового окна "Дополнительный формат", в котором можно задать дополнительные опции форматирования ячеек таблицы (только для типов данных "Угол", "Десятичное число" и "Целое число").

Примеры

Вывод списка вариантов отображения даты для выбранного формата (только для типа данных "Дата"). Для просмотра примера следует выбрать дату в поле "Формат".


Диалоговое окно "Дополнительный формат"

Т Команды
Т Команды
Диалоговое окно "Дополнительный формат"
Понятия Процедуры Команды

Меню "Формат": "Стили таблиц"

Контекстное меню: Нажать правую кнопку мыши во время выполнения любой из команд работы с текстом и выбрать "Вставить поле".

Меню "Формат": "Стили таблиц"

Обеспечивает дополнительные параметры форматирования полей и ячеек таблиц.

Текущее значение

Отображает значение в основных единицах измерения чертежа.

Образец

Отображает обновления в формате при изменении коэффициента преобразования и других настроек.

Коэффициент преобразования

Указывает коэффициент преобразования для использования в текущем значении. Для отмены преобразования используется значение по умолчанию, равное 1.

Дополнительный текст

Указывает префикс или суффикс значения.

Разделители чисел

Указывает десятичный разделитель и форматирование для чисел после 1000.

Десятичные

Указывает разделитель для десятичных значений. Выберите точку, запятую или пробел.

Тысячи

Добавляет разделитель для тысяч в значении поля.

Подавление нулей

Управляет подавлением начальных и конечных нулей, а также нулевых значений футов и дюймов.

Ведущие

Подавление начальных нулей во всех десятичных значениях. Например, 0,5000 записывается как ,5000.

Хвостовые

Подавление конечных нулей во всех десятичных значениях. Например, 12,5000 представляется как 12,5, а 30,0000 — как 30.

0 футов

Подавление вывода значения футов в поле формата футы-дюймы, если расстояние меньше одного фута. Например, 0'-6 1/2" представляется как 6 1/2".

0 дюймов

Подавление вывода значения дюймов в поле формата футы-дюймы, если расстояние равно целому числу футов. Например, 1'-0" представляется как 1'.


ТЕКВИЗСТИЛЬ Команда

Т Команды
Т Команды
ТЕКВИЗСТИЛЬ Команда
Понятия Процедуры Команды

Задается визуальный стиль в текущем видовом экране.

Ввод команды: теквизстиль

Ввести опцию [2dкаркас/3dкаркас/3dCкрытый/Реалистичный /Концептуальный/Другое] <текущий>:

Примечание Чтобы отобразить освещение от точечных источников, удаленных источников, прожекторов или солнца, установите визуальный стиль "Реалистичный", "Концептуальный" или используйте пользовательский визуальный стиль с тонированными объектами.

2D каркас

Объекты представляются в виде отрезков и кривых (как кромки граней и тел). Видны растровые и OLE-объекты, учитываются типы и веса линий. Даже если системная переменная COMPASS включена (равна 1), компас в режиме "2D каркас" не отображается.

3D каркас

Объекты представляются в виде отрезков и кривых (как кромки граней и тел). На экран выводится цветной объемный знак ПСК. Если системная переменная COMPASS активизирована (равна 1), на виде отображается компас.

3D скрытый

Объекты представляются в 3D каркасном виде; линии, относящиеся к задним граням, не отображаются.

Реалистичный

Грани многоугольников на 3D виде раскрашиваются цветом; переходы граней сглаживаются с помощью цветовых оттенков. Отображаются материалы объектов.

Концептуальный

Грани многоугольников на 3D виде раскрашиваются цветом; переходы граней сглаживаются с помощью цветовых оттенков. При раскрашивании используются переходы между холодными и теплыми цветами. Этот эффект менее реалистичен, но он лучше отображает подробности модели.

Другое

Отображается следующий запрос:

Имя визуального стиля [?]: Ввести имя визуального стиля в текущий чертеж или ввести ? для вывода списка имен и повтора запроса


ТЕКСТ Команда

Т Команды
Т Команды
ТЕКСТ Команда
Понятия Процедуры Команды

Создание однострочных текстовых объектов

Меню "Рисование": "Текст" » "Однострочный"

Ввод команды: текст

Текущий текстовый стиль: текущий Высота текста: текущая

Начальная точка текста или [Выравнивание/Стиль]: Указать точку или задать опцию

Команда ТЕКСТ создает однострочный текстовый объект. После вызова команды открывается упрощенный вариант Редактора вхождений текста, представляющего собой ограничивающую рамку по высоте текста, размер которой увеличивается в процессе ввода. Для доступа к пунктам контекстного меню следует нажать правую кнопку мыши.

Если последней введенной командой была команда ТЕКСТ, при нажатии клавиши ENTER в ответ на запрос "Начальная точка текста" высота и угол поворота не запрашиваются. Однострочный текст, введенный в редакторе вхождений, размещается непосредственно под предыдущей строкой. Точка, указанная в ответе на запрос, также сохраняется в качестве точки вставки текста.

Если значение системной переменнойDTEXTED равно 1, при создании текстового объекта с помощью команды ТЕКСТ или ДТЕКСТ открывается диалоговое окно "Редактирование текста".

Если значение переменной DTEXTED задано равным 2, вызывается текстовый редактор, используемый в месте редактирования. При создании текста можно указать любое место на чертеже для создания нового текстового блока. Можно также использовать клавиатуру для перемещения по текстовым блокам (например, для нового текста, созданного командой ТЕКСТ, можно осуществлять навигацию по группам текста нажатием клавиши TAB или Shift+TAB или редактировать группу строк текста нажатием клавиши ALT с нажатием кнопки мыши на каждом текстовом объекте.)

Примечание Неудобный для чтения текст (мелкий, очень крупный или повернутый) отображается горизонтально и масштабируется таким образом, чтобы его можно было легко прочесть и отредактировать.

Для ввода специальных символов и форматирования текста можно использовать последовательности Unicode и управляющие коды.

Команда -ТЕКСТ учитывает состояние системной переменной TEXTEVAL.

Команда ДТЕКСТ аналогична команде ТЕКСТ.

Начальная точка

Задание начальной точки для текстового объекта.

Высота <текущая>: Указать точку (1), ввести значение или нажать ENTER

Запрос высоты текста выводится только в случае, если в текущем текстовом стиле не задана фиксированная высота текста.

Угол поворота текста <текущий>: Задать угол или нажать ENTER

Введите однострочный текст в редакторе вхождений.

Выравнивание

Управление выравниванием текста.

Задайте опцию [впИсанный/Поширине/Центр/сЕредина/впРаво/ВЛ/ВЦ/ВП/СЛ/СЦ/СП/НЛ/НЦ/НП]:

Любую из опций выравнивания можно также ввести в ответе на запрос начальной точки текста.

Вписанный

Опция выравнивания, устанавливающая высоту и ориентацию текста по заданным конечным точкам базовой линии.

Первая конечная точка базовой линии текста: Указать точку (1)

Вторая конечная точка базовой линии текста: Указать точку (2)

Введите однострочный текст в редакторе вхождений.

Размер символов изменяется пропорционально их высоте. Чем длиннее текстовая строка, тем меньше ширина символов.

По ширине

Текст выравнивается по ширине занимаемой им области. Ориентация задается указанием двух точек и высоты. Опция доступна только для горизонтально расположенных текстовых объектов.

Первая конечная точка базовой линии текста: Указать точку (1)

Вторая конечная точка базовой линии текста: Указать точку (2)

Высота <текущая>:

Введите однострочный текст в редакторе вхождений.

Высота текста - это расстояние, измеряемое в единицах чертежа, на которое верхняя точка прописной буквы отстоит от базовой линии. При задании высоты с помощью мыши это расстояние отсчитывается от начальной до указанной точки. Чем длиннее текстовая строка, тем меньше ширина символов. Высота символов не зависит от их ширины.

По центру

Горизонтальное центрирование текста по базовой линии, которая задается точкой.

Центральная точка текста: Указать точку (1)

Высота <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

Угол поворота задает ориентацию базовой линии текста относительно центральной точки. Угол задается посредством указания точки. Базовая линия текста проходит от начальной к указанной точке. Если указать точку левее центральной, текст переворачивается.

Середина

Выравнивание текста по центру заданной горизонтальной базовой линии и высоты. Базовая линия при этом не соответствует нижнему краю текста.

Средняя точка текста: Указать точку (1)

Высота <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

Опция "Середина" отличается от опции "СЦ" тем, что при ее использовании в высоту символов включается высота подстрочных элементов букв (как, например, для букв: у, щ). В случае опции "СЦ" средняя точка рассчитывается по высоте прописных букв.

Справа

Выравнивание текста по правую сторону базовой линии, которая задается точкой.

Правая конечная точка базовой линии текста: Указать точку (1)

Высота <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

ВЛ (Сверху слева)

Выравнивание текста сверху и слева. Опция доступна только для горизонтально расположенных текстовых объектов.

Верхняя левая точка текста: Указать точку (1)

Высота <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

ВЦ (Сверху по центру)

Выравнивание текста сверху и по центру. Опция доступна только для горизонтально расположенных текстовых объектов.

Верхняя центральная точка текста: Указать точку (1)

Высота <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

ВП (Сверху справа)

Выравнивание текста надписи сверху и справа. Опция доступна только для горизонтально расположенных текстовых объектов.

Верхняя правая точка текста: Указать точку (1)

Высота <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

СЛ (Посередине слева)

Выравнивание текста надписи посередине слева. Опция доступна только для горизонтально расположенных текстовых объектов.

Средняя левая точка текста: Указать точку (1)

Высота <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

СЦ (Посередине по центру)

Центрирование текста по горизонтали и вертикали относительно средней точки текста. Опция доступна только для горизонтально расположенных текстовых объектов.

Средняя точка текста: Указать точку (1)

Высота текста <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

Опция "СЦ" отличается от опции "Середина" тем, что при ее использовании средняя точка рассчитывается по высоте прописных букв. В случае опции "Середина" средняя точка вычисляется с учетом полной высоты букв, включая подстрочные элементы.

СП (Посередине справа)

Выравнивание текста посередине справа по указанной средней точке. Опция доступна только для горизонтально расположенных текстовых объектов.

Средняя правая точка текста: Указать точку (1)

Высота <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

НЛ (Снизу слева)

Выравнивание текста слева по точке, задающей базовую линию. Опция доступна только для горизонтально расположенных текстовых объектов.

Нижняя левая точка текста: Указать точку (1)

Высота <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

НЦ (Снизу по центру)

Центрирование текста по точке, задающей базовую линию. Опция доступна только для горизонтально расположенных текстовых объектов.

Нижняя центральная точка текста: Указать точку (1)

Высота <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

НП (Снизу справа)

Выравнивание текста справа по точке, задающей базовую линию. Опция доступна только для горизонтально расположенных текстовых объектов.

Нижняя правая точка текста: Указать точку (1)

Высота <текущая>:

Угол поворота текста <текущий>:

Введите однострочный текст в редакторе вхождений.

Стиль

Задание текстового стиля, определяющего внешний вид текстовых символов. Пользовательские надписи отображаются в соответствии с текущим текстовым стилем.

Имя стиля или [?] <текущее>: Ввести имя текстового стиля или ? для вывода списка всех стилей

Если ввести ?, на экран выводится список текущих текстовых стилей, связанных с ними файлов шрифтов, значений высоты символов и других параметров.

Темы:

  • Контекстное меню текстовых объектов
  • Специальные символы в кодировке Unicode
  • Управляющие коды и специальные символы
  • Команда ТЕКСТ и системная переменная TEXTEVAL


Контекстное меню текстовых объектов

Т Команды
Т Команды
Контекстное меню текстовых объектов
Понятия Процедуры Команды

Отображение доступных функций для создания и редактирования однострочного текста.

Непрозрачный фон

Если установлен этот флажок, фон окна редактора становится непрозрачным. По умолчанию фон окна редактора прозрачный.

Вставить поле

Вызов диалогового окна "Поле", в котором можно выбрать поле для вставки в текст. После закрытия диалогового окна в тексте отображается текущее значение поля.

Поиск и замена

Вызов диалогового окна "Замена".

Выбрать все Выделить все

Выделение всего текста однострочного текстового объекта.

Изменить регистр

Изменение регистра выбранного текста. Возможны два варианта: "Верхний" и "Нижний".


Специальные символы в кодировке Unicode

Т Команды
Т Команды
Специальные символы в кодировке Unicode
Понятия Процедуры Команды

Для включения в текст специальных символов (градус, плюс-минус, диаметр) служат следующие последовательности Unicode:

\U+00B0

Символ градуса (°)

\U+00B1

±±Символ допуска (±)

\U+2205

Символ диаметра ( [image])

См. раздел Описания шрифтов Unicode Руководства по адаптации.


Управляющие коды и специальные символы

Т Команды
Т Команды
Управляющие коды и специальные символы
Понятия Процедуры Команды

Можно включать в текст специальные символы не только с помощью последовательностей Unicode, но и с помощью управляющих кодов. Последние могут также применяться для зачеркивания и подчеркивания текста. Управляющие последовательности начинаются с двух знаков процента.

Данный управляющий код можно использовать со стандартными текстовыми шрифтами AutoCAD и шрифтами Adobe PostScript:

%%nnn

Вставка символа с номером nnn.

Следующие управляющие коды можно использовать только со стандартными текстовыми шрифтами AutoCAD:

%%o

Включение/отключение зачеркивания.

%%u

Включение/отключение подчеркивания.

%%d

Вставка символа градуса (°)

%%p

Вставка символа допуска (±).

%%c

Вставка символа диаметра круга (ý).

%%%

Вставка одного символа процента (%).

Текст может быть одновременно зачеркнутым и подчеркнутым. По достижении конца строки оба режима автоматически отключаются.

Управляющую последовательность кодов %%nnn можно использовать для вставки специальных символов в шрифтах PostScript.

Образец чертежа (truetype.dwg) с таблицей символов для каждого из шрифтов находится в папке sample.

Символ евро

Символ евро можно использовать со шрифтами .shx и эквивалентными им шрифтами TrueType, поставляемыми вместе с AutoCAD 2000 и более поздними версиями продукта. Если на клавиатуре нет символа евро, его можно ввести следующим образом: удерживая клавишу ALT, набрать на числовой клавиатуре последовательность цифр 0128.


Команда ТЕКСТ и системная переменная TEXTEVAL

Т Команды
Т Команды
Команда ТЕКСТ и системная переменная TEXTEVAL
Понятия Процедуры Команды

Если в ответ на подсказку «Команда:» ввести -текст, последующие запросы командной строки будут такими же, как и у обычной команды ТЕКСТ. Однако в отличие от команды ТЕКСТ, команда -ТЕКСТ учитывает состояние системной переменной TEXTEVAL. Если для системной переменной TEXTEVAL установлено значение 2, значения выражений AutoLISP® вычисляются по завершении выполнения команды -ТЕКСТ. Выражения AutoLISP, вводимые таким способом, должны начинаться с восклицательного знака или открывающей скобки.

Команда ТЕКСТ учитывает состояние системной переменной TEXTEVAL только при использовании в командных файлах и AutoLISP-выражениях. В обоих случаях структура, в которую включена команда ТЕКСТ, должна содержать все запросы ее командной строки.


ТЕКСТПЕРПЛАН Команда

Т Команды
Т Команды
ТЕКСТПЕРПЛАН Команда
Понятия Процедуры Команды

Размещение текста и размеров поверх всех остальных объектов чертежа

Меню "Сервис": "Порядок прорисовки" » "Передний план для текста и размеров"

Ввод команды: текстперплан

На передний план: [Текст/Размеры/Оба]<Оба>: Задать опцию или нажать ENTER

Текст

Размещение всего текста поверх всех остальных объектов чертежа.

Размеры

Размещение всех размеров поверх всех остальных объектов чертежа.

Оба

Размещение всего текста и размеров поверх всех остальных объектов чертежа.


ТЕКСТЭКР Команда

Т Команды
Т Команды
ТЕКСТЭКР Команда
Понятия Процедуры Команды

Открытие текстового окна

Меню "Вид": "Отображение" » "Текстовое окно"

Ввод команды: текстэкр (или 'текстэкр для вызова в прозрачном режиме)

Команда ТЕКСТЭКР отображает командную строку в отдельном окне. Переключение между областью рисования и текстовым окном осуществляется с помощью клавиши F2. AutoCAD игнорирует эту команду, если к компьютеру подключены два монитора.

Если командная строка скрыта, ее можно восстановить, введя в текстовом окне комстр.


ТЗАГРТИП Команда

Т Команды
Т Команды
ТЗАГРТИП Команда
Понятия Процедуры Команды

Задание типа точки загрузки (i-drop) по умолчанию для текущего приложения Autodesk

Ввод команды: тзагртип

При вызове команды ТЗАГРТИП открывается диалоговое окно "Задание типа точек загрузки по умолчанию", в котором можно задать тип содержимого, вставляемого в текущее приложение Autodesk из точек загрузки. Этот параметр определяет тип содержимого, вставляемого в чертеж при перетаскивании изображения точки загрузки с веб-страницы в чертеж.

Темы:

  • Диалоговое окно "Задание типа точек загрузки по умолчанию"
  • Диалоговое окно "Параметры точки загрузки"


Диалоговое окно "Задание типа точек загрузки по умолчанию"

Т Команды
Т Команды
Диалоговое окно "Задание типа точек загрузки по умолчанию"
Понятия Процедуры Команды

Ввод команды: тзагртип

Задание типа содержимого точек загрузки по умолчанию, допустимого для текущего приложения Autodesk. Список содержит типы, доступные для установленных продуктов Autodesk, поддерживающих функцию точек загрузки.

Тип содержимого по умолчанию определяет тип содержимого, вставляемого в чертеж. Например, если в списке выбран блок, при перетаскивании с веб-страницы в чертеж изображения содержимого точки загрузки, оно вставляется в виде блока AutoCAD.


Диалоговое окно "Параметры точки загрузки"

Т Команды
Т Команды
Диалоговое окно "Параметры точки загрузки"
Понятия Процедуры Команды

Контекстное меню: Нажмите правую кнопку мыши на изображении содержимого точки загрузки и перетащите его с веб-страницы в текущий чертеж, а затем выберите "Блок".

Отображение URL-адреса исходного файла, имени файла журнала и имени файла содержимого точки загрузки, вставляемого в чертеж в текущий момент. Также позволяет выбрать связанные файлы данных для вставки и задать папку для них.

URL-адрес

Отображение URL-адреса исходного файла содержимого точки загрузки, вставляемого в чертеж в текущий момент.

Журнал

Отображение имени файла журнала для содержимого точки загрузки, вставляемого в чертеж в текущий момент.

Файл данных

Отображение имени файла содержимого точки загрузки, вставляемого в чертеж в текущий момент.

Выбор связанного файла

Выбор связанных файлов данных, вставляемых в чертеж вместе с содержимым точки загрузки в текущий момент.

Путь к папке назначения

Задание пути к папке назначения для всех связанных файлов данных, вставляемых в чертеж вместе с содержимым точки загрузки в текущий момент.

[...]

Вызов стандартного диалогового окна выбора файлов, в котором можно задать путь к папке назначения для всех связанных файлов данных, вставляемых в чертеж вместе с содержимым точки загрузки в текущий момент.


ТЗРЕНИЯ Команда

Т Команды
Т Команды
ТЗРЕНИЯ Команда
Понятия Процедуры Команды

Задание направления взгляда для трехмерных видов

Меню "Вид": » "3D виды"; "Точка зрения"

Ввод команды: тзрения

Текущее направление взгляда: VIEWDIR=текущее

Задайте точку зрения или [Повернуть] <компас и тройка осей>: Указать точку, ввести п или нажать ENTER для включения компаса и тройки осей

Точка зрения

Задание координат X,Y,Z точки зрения. Вектор направления взгляда проводится из заданной точки зрения к началу координат (0,0,0).

Повернуть

Задание нового направления взгляда при помощи двух углов.

Угол в плоскости XY относительно оси X <текущий>: Задать угол

Первый угол лежит в плоскости XY и отсчитывается от оси X.

Угол с плоскостью XY <текущий>: Задать угол

Второй угол лежит в плоскости, перпендикулярной плоскости XY.

Компас и тройка осей

Задание направления взгляда непосредственно на видовом экране с помощью компаса и тройки осей координат.

Компас в правой верхней части экрана — это двумерное представление глобуса. Центральная точка компаса совпадает с Северным полюсом (0,0,n), внутренняя окружность совпадает с экватором (n,n,0), а внешняя - с Южным полюсом (0,0-n).

На компасе имеется небольшое перекрестье. Им можно управлять с помощью устройства указания. При этом тройка осей координат вращается в соответствии с изменением точки зрения. Для выбора направления взгляда следует установить перекрестье в нужную часть глобуса и щелкнуть мышью.


ТИПЛИН Команда

Т Команды
Т Команды
ТИПЛИН Команда
Понятия Процедуры Команды

Загрузка, установка и изменение типов линий

Меню "Формат": "Тип линии"

Ввод команды: типлин (или 'типлин для прозрачного вызова)

Открывается диалоговое окно «Диспетчер типов линий».

Если в ответ на подсказку "Команда" ввести -типлин, будет вызван вариант команды ТИПЛИН, использующий интерфейс командной строки.

Темы:

  • Диспетчер типов линий
  • Диалоговое окно «Загрузка/перезагрузка типов линий»
  • ТИПЛИН вариант для командной строки


Диспетчер типов линий

Т Команды
Т Команды
Диспетчер типов линий
Понятия Процедуры Команды

Меню "Формат": "Тип линии"

Ввод команды: типлин (или 'типлин для прозрачного вызова)

Загрузка типов линий и установка текущего типа линий.

Фильтры типов линий

Определяет, какие типы линий выводятся в списке. Можно, например, отфильтровать типы линий, зависимые от ссылок, а также используемые в объектах или не используемые в них.

Инвертировать фильтр

Отбор типов линий, не удовлетворяющих условию установленного фильтра. Отобранные типы линий выводятся в списке.

Загрузить

Отображаетдиалоговое окно "Загрузка/перезагрузка типов линий", с помощью которого производится загрузка выбранных типов линий из файла acad.lin и добавление их в список доступных.

Текущий

Устанавливает выбранный тип линий текущим. Установка текущего типа линий ПОСЛОЮ означает, что создаваемые объекты принимают тот тип линий, который назначен их слою. Установка типа линий ПОБЛОКУ означает, что объекты принимают тип линий CONTINUOUS, пока не будут объединены в блок. При вставке блока все его объекты наследуют тип линий этого блока. Имя типа линий запоминается в системной переменной CELTYPE.

Удалить

Удаляет выбранные типы линий из чертежа. Можно удалить только неиспользуемые типы линий. Типы линий ПОСЛОЮ, ПОБЛОКУ и CONTINUOUS нельзя удалить.

Примечание Следует с осторожностью относиться к удалению типов линий в чертежах, совместно используемых несколькими пользователями. Описание удаленного типа линий хранится в файле acad.lin или acadiso.lin и может быть восстановлено.

Вкл подробности / Откл подробности

Управление выводом группы опций «Подробности» в Диспетчере типов линий.

Текущий тип линий

Отображает имя текущего типа линий.

Список типов линий

Вывод имен загруженных типов линий с учетом установленного фильтра. Для быстрого выделения сразу всех типов линий нажать правую кнопку мыши на списке и из контекстного меню выбрать «Выбрать все».

Тип линий

Вывод списка загруженных типов линий. Для переименования типа линий необходимо выбрать его из списка, щелкнуть на нем и ввести новое имя.. Типы линий ПОСЛОЮ, ПОБЛОКУ и CONTINUOUS, а также зависимые от внешних ссылок, переименовать нельзя. Имя типа линий может содержать не более 255 символов. Имя типа линии может состоять из букв, цифр, пробелов и специальных символов: знаков доллара ($), дефиса (-) и подчеркивания (_). В именах типов линий нельзя использовать следующие специальные символы: запятую (,), двоеточие (:), знак равенства (=), знак вопроса (?), звездочку (*), знаки меньше и больше (> <), обычную и обратную косую черту (/ \), вертикальную черту (|), кавычки (") и апостроф (`).

Формат

Просмотр образца выбранного типа линий.

Описание

Текстовое пояснение к типу линий, которое можно отредактировать в группе опций «Подробности».

Подробности

Предоставление альтернативного доступа к свойствам и дополнительным настройкам.

Имя

Отображает и позволяет редактировать имя выбранного типа линий. Имя типа линий может содержать не более 255 символов. Имя типа линии может состоять из букв, цифр, пробелов и специальных символов: знаков доллара ($), дефиса (-) и подчеркивания (_). В именах типов линий нельзя использовать следующие специальные символы: запятую (,), двоеточие (:), знак равенства (=), знак вопроса (?), звездочку (*), знаки меньше и больше (> <), обычную и обратную косую черту (/ \), вертикальную черту (|), кавычки (") и апостроф (`).

Описание

Отображает и позволяет редактировать текстовое пояснение для выбранного типа линий.

Масштаб в единицах пространства листа

Задание идентичного масштабирования типов линий в пространствах листа и модели. Опция полезна при одновременном использовании нескольких видовых экранов. (системная переменная PSLTSCALE)

Глобальный масштаб

Значение глобального масштабного коэффициента для всех типов линий. (системная переменная LTSCALE)

Текущий масштаб

Масштаб типа линий для вновь создаваемых объектов. Результирующий масштаб равен произведению значений глобального масштаба и текущего масштаба объекта. (системная переменная CELTSCALE)

Толщина пера по ISO

Присвоение масштабу типа линий одного из стандартных значений по ISO. Результирующий масштаб равен произведению значений глобального масштаба и текущего масштаба объекта.


Диалоговое окно «Загрузка/перезагрузка типов линий»

Т Команды
Т Команды
Диалоговое окно «Загрузка/перезагрузка типов линий»
Понятия Процедуры Команды

Меню "Формат": "Тип линии"

Ввод команды: типлин (или 'типлин для прозрачного вызова)

Загрузка типов линий Файл acad.lin содержит стандартные типы линий.

Кнопка "Файл"

Отображает диалоговое окно "Выбор файла типов линий", в котором можно выбрать различные файлы типов линий (LIN).

Имя файла

Отображает имя LIN-файла текущей библиотеки типов линий. Можно ввести имя другого файла LIN или нажать кнопку "Файл", чтобы выбрать файл в диалоговом окне "Выбор файла типов линий".

Доступные типы линий

Здесь перечисляются доступные для загрузки типы линий. Для выделения сразу всех имеющихся типов линий нажать правую кнопку мыши на списке и из контекстного меню выбрать «Выбрать все».


ТИПЛИН вариант для командной строки

Т Команды
Т Команды
ТИПЛИН вариант для командной строки
Понятия Процедуры Команды

Если в ответ на подсказку "Команда" ввести -типлин, будет вызван вариант команды ТИПЛИН, использующий интерфейс командной строки.

Задайте опцию [?/Создать/Загрузить/Установить]:

?—Вывести типы линий

Отображает диалоговое окно "Выбор файла типов линий" (стандартное окно выбора файлов). После того, как выбран файл LIN, будет выведен список доступных для загрузки типов линий.

Создать

Создание нового типа линий и запись его в LIN-файл.

Имя создаваемого типа линий:

Отобразится диалоговое окно "Создание или добавление файла типов линий" (стандартное окно выбора файлов). Здесь выбирается файл, в который будет добавлен новый тип линий.

Пояснение: Ввести необязательное пояснение

Длина пояснения не должна превышать 47 символов. Оно может представлять собой комментарий или набор точек, черточек и пробелов, иллюстрирующих образец типа линий.

Введите образец типа линий (на следующей строке):

A,

Описание образца представляет собой ряд чисел, разделенных запятыми. Положительными числами обозначаются длины штрихов, отрицательными — длины пробелов. Точки обозначаются нулями.

Символ “A“ в приглашении описания узора задает выравнивание узора вблизи концов отрезков, кругов и дуг. Поддерживается только тип "А". В соответствии с типом "A" линии и дуги начинаются и заканчиваются штрихом. Символ «A» добавляется в описание автоматически. Если создание типа линий производится во внешнем текстовом редакторе, пользователь должен сам добавлять a (латинское) в начало описания.

Перед использованием созданный тип линий необходимо загрузить.

Команда ТИПЛИН не позволяет создавать сложные типы линий. Дополнительную информацию см. в разделе Настройка типов линий Руководства по настройке.

Загрузить

Загрузка типа линий из файла. Файл acad.lin содержит стандартные типы линий.

Какие типы линий загрузить: Ввести имя или список имен через запятую.

Откроется диалоговое окно "Выбор файла типов линий" (Стандартные диалоговые окна выбора файловстандартное окно выбора файлов). В нем необходимо выбрать файл, в котором хранится тип линий.

Установить

Установка типа линий текущим для объектов, которые будут нарисованы в дальнейшем. Тип линий можно задать как явно для каждого объекта, так и по слою.

Имя типа линии или [?] <текущий>: Ввести имя типа линии, ? для вывода списка всех загруженных имен типов линий, послою или поблоку, либо нажать клавишу ENTER

Указанный тип линий становится текущим. Все новые объекты будут построены с использованием этого типа линий независимо от текущего слоя. Если запрашиваемый тип линий не загружен, программа ищет его описание в файле acad.lin. Если указанный тип линий не загружен и его нет в файле acad.lin, программа выводит соответствующее сообщение и повторяет подсказку команды.

Ввести ? для просмотра всех загруженных типов линий. Если ввести послою, то новые объекты наследуют тип линий, присвоенный тому слою, на который помещается объект. Если ввести поблоку, то новые объекты рисуются типом линий CONTINUOUS до тех пор, пока не будут объединены в блок. При вставке блока все его объекты наследуют тип линий этого блока.


ТОЛЩИНА Команда

Т Команды
Т Команды
ТОЛЩИНА Команда
Понятия Процедуры Команды

Создание 3D тела посредством утолщения поверхности

Меню "Редактирование": "3D операции" » "Придать толщину"

Ввод команды: толщина

Пульт управления: Панель создания 3D объектов (нажмите значок, чтобы развернуть), Толщина поверхности

Выберите поверхности для придания толщины: Выбрать одну или несколько поверхностей для создания тел посредством утолщения

Толщина <по умолчанию>: Задать толщину

Изначально толщина по умолчанию не определена. В процессе работы над чертежом в качестве значения по умолчанию для толщины всегда используется ранее введенное значение толщины.

Системная переменная DELOBJ определяет способ удаления выбранных объектов при создании поверхности - автоматически или по запросу.


ТОНИРОВАТЬ Команда

Т Команды
Т Команды
ТОНИРОВАТЬ Команда
Понятия Процедуры Команды

Создание реалистичного тонированного изображения трехмерной каркасной или твердотельной модели

Панель Тонирование:

Меню "Вид": » "Тонирование"; "Тонировать"

Ввод команды: тонировать

Пульт управления: Панель "Тонирование", "Тонировать"

Выполнение команды "Тонировать" вызывает процесс тонирования. Окно тонирования или видовой экран отображают тонированное изображение.

Темы:

  • Окно тонирования
  • Диалоговое окно "Отсутствующие текстуры"
  • Диалоговое окно "Выходной файл тонирования"
  • Диалоговое окно "Параметры изображения BMP"
  • Диалоговое окно "Параметры изображения PCX"
  • Диалоговое окно "Параметры изображения TGA"
  • Диалоговое окно "Параметры изображения TIFF"
  • Диалоговое окно "Параметры изображения JPEG"
  • Диалоговое окно "Параметры изображения PNG"


Окно тонирования

Т Команды
Т Команды
Окно тонирования
Понятия Процедуры Команды

Ввод команды: тонирокно

Пульт управления: Панель "Тонировать" (нажмите значок, чтобы раскрыть), "Показать окно тонирования"

В окне тонирования отображается результат тонирования текущей модели.

Окно тонирования разделено на три панели:

  • Панель "Изображение. Отображает тонированное изображение.
  • Панель "Статистика". Расположено с правой стороны. Отображает текущие настройки, используемые для тонирования.
  • Панель "Журнал". Расположено внизу. Отображает хронологию тонирования изображений из текущей модели и индикатор хода выполнения процесса тонирования.

Окна тонирования открываются по отдельности для каждого чертежа, из которого создаются тонированные изображения. Тонированное изображение из любого чертежа всегда появляется в соответствующем окне тонирования.

В окне тонирования можно

  • Сохранять изображение в файле.
  • Сохранять копию изображения в файле.
  • Просматривать настройки, используемые для текущего тонирования.
  • Отслеживать предысторию тонирования модели.
  • Очищать, удалять или очищать и удалять изображение из журнала тонирования.
  • Зумированием увеличивать видимые размеры сечения тонированного изображения с панорамированием изображения и последующим возвратом к исходным размерам.
Меню "Файл"

Сохраняются тонированные изображения.

Сохранить

Сохраняется изображение в файле растрового формата. Подробнее см. Сохранение и повторное воспроизведение изображений в Руководстве пользователя.

При тонировании в окне "Тонирование" нельзя пользоваться командой СОХРИЗОБ. Эта команда применяется только при тонировании на видовой экран.

Сохранить копию

Сохраняется копия изображения по новому адресу без изменения адреса, хранящегося в текущей записи.

Выход

Закрывается окно тонирования.

При новом открытии окна тонирования сохраняется журнал прошлых тонирований.

Меню "Вид"

Отображает разные элементы, из которых состоит окно "Тонирование"

Зона состояния

Отображает строку состояния под панелью "Журнал".

Панель "Статистика"

Отображает панель "Статистика" полностью.

Меню "Сервис"

Содержит команды зумирования для увеличения и уменьшения тонированного изображения.

Увеличить

Увеличивает масштаб тонированного изображения в панели "Изображение". При увеличении размеров можно панорамировать изображение.

Уменьшить

Уменьшает масштаб тонированного изображения в панели "Изображение".

При пользовании мышью с прокруточным колесиком можно зумировать или панорамировать изображение с помощью колесика.

Панель "Изображение"

В верхней левой части окна тонирования находится панель "Изображение". Она является основным объектом вывода целевого изображения для системы тонирования. При тонировании в панели "Изображение" последовательно отображаются тонированные фрагменты по мере их получения с помощью системы тонирования.

По окончании тонирования панель "Изображение" обеспечивает дополнительные функциональные возможности, например:

  • Полосы прокрутки. Если изображение не помещается в пространстве панели "Изображение", появляются горизонтальные и вертикальные полосы прокрутки на нижней и правой кромках. При нажатии средней кнопки или колесика мыши на панели "Изображение" появляется курсор в виде руки. Перемещая курсор, можно панорамировать изображение.
  • Коэффициент масштабирования. Первоначально выбирается небольшой коэффициент масштабирования, чтобы изображение могло поместиться на панели "Изображение". Коэффициент масштабирования принимает значения степеней "2" в интервале от 1:64 до 64:1. Коэффициент масштабирования можно изменить колесиком мыши. При прокрутке вперед коэффициент масштабирования увеличивается. Коэффициент масштабирования отображается в титульной надписи окна тонирования.
Индикатор хода выполнения / Строка состояния

До окончательного результата изображение проходит четыре фазы: трансляцию, излучение фотонов, чистовые пробы и тонирование. Между панелью "Изображение" и панелью "Журнал" имеется индикатор хода выполнения, указывающий степень выполнения каждой фазы, а также количество тонированной части общего изображения. Индикатор хода выполнения состоит из двух полос, отражающих данные двух разных видов.

  • Верхняя полоса отражает ход выполнения текущей фазы операции.
  • Нижняя полоса показывает ход выполнения всей процедуры тонирования.

Фазы трансляции и тонирования выполняются всегда. Фазы излучения фотонов и чистовые пробы выполняются только при выборе соответствующих опций. Время выполнения подсчитывается только для активных фаз операций.

Тонирование также можно отменить, для этого следует нажать на значок Х рядом с индикатором хода выполнения операции или просто нажать клавишу ESC.

В строке состояния, расположенной в нижнем левом углу окна "Тонирование", отображается копия верхнего сегмента индикатора хода выполнения операции.

Панель "Журнал"

Левая нижняя часть окна "Тонирование" предназначена для отображения панели "Журнал", с помощью которой можно просмотреть хронологию изображений, тонированных в текущей модели. Каждую запись, сохраненную на панели "Журнал", называют журнальной записью. В журнальные записи входят следующие данные

  • Имя файла тонирования и указатель типа тонирования.
  • Размер изображения.
  • Имя вида, для которого выполняется тонирование. Если именованные виды не используются, то вид запоминается в качестве текущего вида.
  • Длительность тонирования, измеряемая в часах : минутах : секундах.
  • Имя набора параметров тонирования, использованного для тонирования.

Сохраняется любая журнальная запись, в которой имеется имя файла.

Панель "Журнал" - контекстное меню

При нажатии правой кнопки мыши на любой журнальной записи открывается меню, содержащее указанные ниже опции:

Тонировать повторно

Повторно запускает систему тонирования для выбранной журнальной записи.

Сохранить

Открывается диалоговое окно "Выходной файл тонирования", в котором можно сохранить изображение на диске. Если выбрана временная запись, то при сохранении она преобразуется в обычную запись.

Сохранить копию

Сохраняется копия изображения по новому адресу без изменения адреса, хранящегося в текущей записи. Открывается диалоговое окно "Выходной файл тонирования".

Сделать параметры тонирования текущими

Загружает параметры тонирования, связанные с выбранной журнальной записью, если имеется несколько журнальных записей, которые используют разные параметры тонирования.

Удалить из списка

Запись удаляется из журнала с сохранением всех связанных с ней файлов изображений.

Удалить файл вывода

Тонированное изображение удаляется из панели "Изображение".

Панель "Статистика"

Занимает правую область окна "Тонирование". Здесь можно получить подробные сведения о тонировании и действующих параметрах тонирования, использованных при создании изображения.

Данная информация зависит от настроек, выполненных в диалоговом окне "Диспетчер наборов стандартных параметров тонирования", и от информации, созданной во время тонирования.


Диалоговое окно "Отсутствующие текстуры"

Т Команды
Т Команды
Диалоговое окно "Отсутствующие текстуры"
Понятия Процедуры Команды

Панель "Тонирование":

Меню "Вид": » "Тонирование"; "Тонировать"

Ввод команды: тонировать

Пульт управления: Панель "Тонирование", "Тонировать"

Данное диалоговое окно появляется при попытке тонировать сцену с использованием текстур, путь к которым не является более текущим. Это может происходить в случаях, когда текстуры перемещены или удалены либо модель помещена в систему с другими именами подключенных дисков, чем в системе, в которой создана модель.

AutoCAD осуществляет поиск текстур в папке, в которой хранится файл чертежа, или используя пути к текстурам в диалоговом окне "Параметры".

Список текстур

Отображается список текстур, для которых не может быть определено местоположение, с указанием имен их путей.

Больше не выводить это окно

При установке данного флажка запрещается вывод указанного выше сообщения в случае, когда текстуры не найдены.

Продолжить

Модель тонируется без загрузки недостающих текстур.


Диалоговое окно "Выходной файл тонирования"

Т Команды
Т Команды
Диалоговое окно "Выходной файл тонирования"
Понятия Процедуры Команды

Панель "Тонирование":

Меню "Вид": » "Тонирование"; » "Дополнительные параметры тонирования"; "Формат вывода"

Ввод команды: режимтон

Пульт управления: Панель "Тонирование" (развернуть нажатием левой кнопки на значке); "Формат вывода"

Диалоговое окно "Выходной файл тонирования" представляет собой обычное диалоговое окно выбора файла. Следует указать имя файла изображения, который требуется сохранить, и формат выходного файла. В этом диалоговом окне можно выбирать только форматы файлов вывода растровых изображений.

Форматы файлов для сохранения тонированных изображений следующие:

BMP (*.bmp)

Файлы BMP представляют собой растровые файлы неподвижного изображения в формате растровой карты (.bmp) Windows.

При нажатии на "Сохранить" после выбора данного формата отображается диалоговое окно "Параметры изображения BMP".

PCX (*.pcx)

Файлы PCX представляют собой относительно простые файлы, обеспечивающие минимально возможное сжатие с использованием кодирования длины серий (RLE).

При нажатии на "Сохранить" после выбора данного формата отображается диалоговое окно "Параметры изображения PCX".

TGA (*.tga)

Формат Targa (TGA) поддерживает 32-битовый истинный цвет. Этот формат обычно используют в качестве формата истинного цвета для тонирования неподвижных изображений.

При нажатии на "Сохранить" после выбора данного формата отображается диалоговое окно "Параметры изображения TGA".

TIF (*.tif)

Формат TIF (теговый формат файлов изображения) является многоплатформенным форматом растровых изображений. TIF обычно выбирается в случаях, когда планируется посылка выходных данных в сервисное бюро печати либо импорт изображения в программу компоновки страниц.

При нажатии на "Сохранить" после выбора данного формата отображается диалоговое окно "Параметры изображения TIFF".

JPEG (*.jpg)

Файлы JPEG (.jpeg или .jpg) подчиняются стандартам, созданным Объединенной Группой Экспертов по фотографии. В этих файлах используется метод переменного сжатия, именуемый сжатием с потерями по причине ухудшения качества изображения по мере увеличения сжатия. Однако схема сжатия JPEG действует очень хорошо и иногда позволяет сжимать файл до 200:1 без заметного ухудшения качества изображения. С учетом этого формат JPEG популярен при пересылке файлов изображений в Интернет благодаря минимальному размеру файлов и минимальной длительности загрузки.

При нажатии на "Сохранить" после выбора данного формата отображается диалоговое окно "Параметры изображения JPEG".

PNG (*.png)

PNG (Portable Network Graphics) является форматом файла неподвижных изображений, разработанным для использования в сети Интернет. PNG является форматом генерации сжатого изображения, не допускающим потерь качества, в отличие от формата JPEG.

При нажатии на "Сохранить" после выбора данного формата отображается диалоговое окно "Параметры изображения PNG".

Темы:

  • Диалоговое окно "Параметры изображения BMP"
  • Диалоговое окно "Параметры изображения PCX"
  • Диалоговое окно "Параметры изображения TGA"
  • Диалоговое окно "Параметры изображения TIFF"
  • Диалоговое окно "Параметры изображения JPEG"
  • Диалоговое окно "Параметры изображения PNG"


Диалоговое окно "Параметры изображения BMP"

Т Команды
Т Команды
Диалоговое окно "Параметры изображения BMP"
Понятия Процедуры Команды

Когда в качестве формата вывода выбирается BMP, открывается диалоговое окно "Параметры изображения BMP".

Цвет

Монохромный

Создает 2-битовое черно-белое изображение.

8 битов (256 оттенков серого)

Создается 8-разрядное полутоновое изображение с использованием 256 оттенков серого.

8 битов (256 цветов)

Выбирается тонирование небольшого по размеру 8-битового цветного изображения из палитры 256 цветов.

24 бита (16,7 миллионов цветов)

Создается большеобъемный файл с 24-битовым истинным цветом.


Диалоговое окно "Параметры изображения PCX"

Т Команды
Т Команды
Диалоговое окно "Параметры изображения PCX"
Понятия Процедуры Команды

Когда в качестве формата вывода выбирается PCX, открывается диалоговое окно "Параметры изображения PCX".

Цвет

Монохромный

Создает 2-битовое черно-белое изображение.

8 битов (256 оттенков серого)

Создается 8-разрядное полутоновое изображение с использованием 256 оттенков серого.

8 битов (256 цветов)

Выбирается тонирование небольшого по размеру 8-битового цветного изображения из палитры 256 цветов.


Диалоговое окно "Параметры изображения TGA"

Т Команды
Т Команды
Диалоговое окно "Параметры изображения TGA"
Понятия Процедуры Команды

Когда в качестве формата вывода выбирается TGA, открывается диалоговое окно "Параметры изображения TGA".

Цвет

8 битов (256 оттенков серого)

Создается 8-разрядное полутоновое изображение с использованием 256 оттенков серого.

8 битов (256 цветов)

Выбирается тонирование небольшого по размеру 8-битового цветного изображения из палитры 256 цветов.

24 бита (16,7 миллионов цветов)

Создается 24-разрядное цветное изображение с использованием палитры, содержащей 16,7 миллионов цветов.

32 бита (24 бита + альфа-канал)

Создается 24-битовое цветное изображение, в которое включается 8-разрядный альфа-канал. Альфа-канал - это тип данных, содержащийся в файлах 32-битовых изображений, который назначает прозрачность пикселам изображения.

Снизу вверх

Сохраняется изображение внизу вверх.


Диалоговое окно "Параметры изображения TIFF"

Т Команды
Т Команды
Диалоговое окно "Параметры изображения TIFF"
Понятия Процедуры Команды

Когда в качестве формата вывода выбирается TIF, открывается диалоговое окно "Параметры изображения TIFF".

Цвет

Монохромный

Создает 2-битовое черно-белое изображение.

8 битов (256 оттенков серого)

Создается 8-разрядное полутоновое изображение с использованием 256 оттенков серого.

8 битов (256 цветов)

Выбирается тонирование небольшого по размеру 8-битового цветного изображения из палитры 256 цветов.

24 бита (16,7 миллионов цветов)

Создается 24-разрядное цветное изображение с использованием палитры, содержащей 16,7 миллионов цветов.

32 бита (24 бита + альфа-канал)

Создается 24-битовое цветное изображение, в которое включается 8-разрядный альфа-канал. Альфа-канал - это тип данных, содержащийся в файлах 32-битовых изображений, который назначает прозрачность пикселам изображения.

Сжатый

Применяет к файлу сжатие без потери качества изображения.

Точек на дюйм

Задается количество точек на дюйм (dpi) для сохраняемого изображения. Данное значение не влияет на разрешение конечного изображения, но может повлиять на способ его распечатки в документах.


Диалоговое окно "Параметры изображения JPEG"

Т Команды
Т Команды
Диалоговое окно "Параметры изображения JPEG"
Понятия Процедуры Команды

Когда в качестве формата вывода выбирается JPG, открывается диалоговое окно "Параметры изображения JPEG".

Управление изображением

Качество

Задает уровень качества: чем выше качество, тем больше размер файла. Как правило, при установке регулятора в положение "Наилучшее", файлы сжимаются с коэффициентом от 5:1 до 15:1.

Размер файла

Задает требуемый размер файла: чем больше файл - тем выше качество.


Диалоговое окно "Параметры изображения PNG"

Т Команды
Т Команды
Диалоговое окно "Параметры изображения PNG"
Понятия Процедуры Команды

Когда в качестве формата вывода выбирается PNG, открывается диалоговое окно "Параметры изображения PNG".

Цвет

Монохромный

Создает 2-битовое черно-белое изображение.

8 битов (256 оттенков серого)

Создается 8-разрядное полутоновое изображение с использованием 256 оттенков серого.

8 битов (256 цветов)

Выбирается тонирование небольшого по размеру 8-битового цветного изображения из палитры 256 цветов.

16 битов (65 536 оттенков серого)

Создается 16-разрядное полутоновое изображение с использованием 65536 оттенков серого.

24 бита (16,7 миллионов цветов)

Создается большеобъемный файл с кодированием цвета в палитре True Color (24-разряда).

32 бита (24 бита + альфа-канал)

Создается 24-битовое цветное изображение, в которое включается 8-разрядный альфа-канал. Альфа-канал - это тип данных, содержащийся в файлах 32-битовых изображений, который назначает прозрачность пикселам изображения.

Прогрессивный

Обеспечивает более быстрый вывод изображения в веб-браузерах.

Точек на дюйм

Задается количество точек на дюйм (dpi) для сохраняемого изображения. Данное значение не влияет на разрешение конечного изображения, но может повлиять на способ его распечатки в документах.


ТОНИРОКНО Команда

Т Команды
Т Команды
ТОНИРОКНО Команда
Понятия Процедуры Команды

Отображается окно тонирования без вызова задачи тонирования.

Пульт управления: Панель "Тонирование" (нажмите значок, чтобы раскрыть), "Окно тонирования"

Ввод команды: тонирокно

Отображается Окно тонирования, но тонирование текущего чертежа не производится. Если чертеж содержит журнал тонирования, можно просматривать ранее тонированные изображения.

Если в текущем чертеже отсутствует журнал тонирования, пользователю сообщается об отсутствии журнала тонирования, и выполнение команды завершается.


ТОНИРПОДРЕЗ Команда

Т Команды
Т Команды
ТОНИРПОДРЕЗ Команда
Понятия Процедуры Команды

Задает конкретный участок (окно кадрирования) в изображении для тонирования

Ввод команды: тонирподрез

Пульт управления: Панель "Тонирование", "Тонировать обрезанную область"

Укажите область тонирования: Выбрать первый угол области, которую необходимо тонировать

Задайте вторую точку: Выбрать противоположный угол области, которую необходимо тонировать

Тонируется то, что расположено внутри указанной прямоугольной области в пределах видового экрана; остальная часть окна тонирования не изменяется. Данная команда используется при необходимости протестировать тонирование части модели.

Текущее назначение тонирования и процедура тонирования игнорируются. После выбора второго угла области тонирования начинается выполнение задачи тонирования и отображается видовой экран тонирования с обрезкой изображения.


ТОНЭКР Команда

Т Команды
Т Команды
ТОНЭКР Команда
Понятия Процедуры Команды

Устар.

Ввод команды: тонэкр

Открывается Окно тонирования. (команда ТОНИРОКНО)


ТОР Команда

Т Команды
Т Команды
ТОР Команда
Понятия Процедуры Команды

Создание 3D тела в форме тора

Панель "Моделирование":

Меню "Рисование": "Моделирование" » "Тор"

Ввод команды: тор

Пульт управления: Панель создания 3D объектов, Тор

Центр или [3Т/2Т/ККР]: Указать точку (1) или задать опцию

При задании центральной точки тор размещается так, чтобы его центральная ось была параллельна оси Z текущей ПСК. Плоскость XY текущей ПСК делит тор на две равные части в продольном сечении.

Радиус или [Диаметр] <по умолчанию>: Задать расстояние или ввести д

Изначально радиус по умолчанию не определен. В процессе работы над чертежом в качестве значения радиуса по умолчанию всегда используется ранее введенное значение радиуса любого элементарного тела.

3Т (Три точки)

Задание длины окружности тора по трем точкам. Три заданные точки также определяют плоскость окружности шара.

Первая точка: Указать точку (1)

Вторая точка: Указать точку (2)

Третья точка: Указать точку (3)

2Т (Две точки)

Задание длины окружности тора по двум точкам. Плоскость окружности шара определяется координатой Z первой точки.

Первая конечная точка диаметра: Указать точку (1)

Вторая конечная точка диаметра: Указать точку (2)

ККР (Касательная, Касательная, Радиус)

Построение тора по заданному радиусу, касающемуся двух объектов. Указанные точки касания проецируются на текущую ПСК.

Укажите на объекте точку для первой касательной: Выбрать точку на объекте

Укажите на объекте точку для второй касательной: Выбрать точку на объекте

Радиус круга <по умолчанию>: Задать радиус или нажать ENTER для использования значения радиуса по умолчанию

Изначально радиус по умолчанию не определен. В процессе работы над чертежом в качестве значения радиуса по умолчанию всегда используется ранее введенное значение радиуса любого элементарного тела.

Радиус

Задание радиуса тора: расстояние от центра тора до центра полости. Если радиус отрицателен, создается тело в форме мяча для регби.

Радиус полости или [Диаметр] <по умолчанию>: Задать расстояние или ввести д

Изначально радиус по умолчанию не определен. В процессе работы над чертежом в качестве значения радиуса по умолчанию всегда используется ранее введенное значение радиуса любого элементарного тела.

Радиус

Задание радиуса полости тора.

Диаметр

Задание диаметра полости тора.

Диаметр полости: Задать ненулевое расстояние

Диаметр

Задание диаметра полости тора.

Диаметр <по умолчанию>: Задать расстояние

Изначально диаметр по умолчанию не определен. В процессе работы над чертежом в качестве значения диаметра по умолчанию всегда используется ранее введенное значение диаметра любого элементарного тела.

Задайте радиус полости или [Диаметр] <по умолчанию>: Задать расстояние или ввести д

Радиус

Задание радиуса полости тора.

Диаметр

Задание диаметра полости тора.

Диаметр полости: Задать ненулевое расстояние


ТОЧКА Команда

Т Команды
Т Команды
ТОЧКА Команда
Понятия Процедуры Команды

Создание объектов-точек

Панель Рисование:

Меню "Рисование": Точка

Ввод команды: точка

Укажите точку:

Точки могут служить узлами для привязки с помощью режимов объектной привязки. При указании точки можно задать полный набор ее координат в трехмерном пространстве. Если координата Z опущена при задании точки, то используется текущее значение уровня.

Внешним видом объектов-точек управляют системные переменные PDMODE и PDSIZE. Значения PDMODE 0, 2, 3 и 4 задают форму изображения точки на экране. При значении 1 точка не видна.

Прибавление к вышеприведенному ряду значений чисел 32, 64 или 96 позволяет выбирать дополнительные формы для выделения точки на чертеже.

Переменная PDSIZE управляет размером отображающих точки элементов (если PDMODE не равна 0 или 1). Значение переменной, равное 0, задает величину точки в 5 процентов от высоты области рисования. Положительные значения PDSIZE задают абсолютную величину изображения точки. Отрицательные значения интерпретируются как число процентов от величины видового экрана. Размеры всех точек изменяются при регенерации чертежа.

После изменения значений переменных PDMODE и PDSIZE изменение внешнего вида точек происходит при следующей регенерации чертежа.


ТОЧСВЕТ Команда

Т Команды
Т Команды
ТОЧСВЕТ Команда
Понятия Процедуры Команды

Создается точечный источник света

Панель инструментов "Источники света"

Меню "Вид"; "Тонирование" » "Источник света" » "Новый точечный источник света"

Ввод команды: точсвет

Пульт управления: Панель "Источник света" (развернуть нажатием левой кнопки мыши), "Создать точечный источник света"

Задайте положение источника света <0,0,0>: Ввести значения координат или использовать указательное устройство

Задать опцию для изменения [Имя/Интенсивность/Состояние/раскрас/Затухание/Цвет/выХод] <выХод>:

Имя

Имя источника света. В имени можно использовать буквы верхнего и нижнего регистра, числа, пробелы, дефисы (-) и символы подчеркивания (_). Максимальная длина равна 256 символам.

Введите имя источника света:

Интенсивность

Установка интенсивности (или яркости) источника света. Область значений: от 0 до максимального значения, которое поддерживается в пользовательской системе.

Введите интенсивность (0,00 - макс. плавающее):

Статус

Включение и выключение источника света. Если освещение в чертеже не используется, данная установка не действует

Введите состояние (Вкл/ Откл):

Тень

Включение отбрасывания теней от источника света.

Введите параметры теней [Откл/Резкие/Мягкие]:

Откл

Отключается отображение и вычисление теней для источника света. При выключении теней повышается производительность.

Резкие

Отображаются тени с "резкими" кромками. Данная опция используется для повышения производительности.

Мягкие

Отображаются реалистичные тени с "нерезкими" кромками.

Затухание

Задать опцию для изменения [тип Затухания/Использовать пределы/Начальный предел затухания/Конечный предел затухания/выХод]<выХод>:

Тип затухания

Зависимость ослабления света от расстояния. Чем дальше от источника располагается объект, тем темнее он выглядит. Затухание иначе именуется спадом.

Задать тип затухания [Нет/Линейная инверсия/Квадратичная инверсия] <Линейная инверсия>:

  • Нет. Затухание отсутствует. И далекие, и близкие к источнику света объекты освещаются одинаково.
  • Линейная инверсия. Установка затухания обратно пропорционально расстоянию от источника света до объекта. Например, на расстоянии 2 единицы от источника освещенность равна 1/2 от освещенности на источнике, на расстоянии 4 единицы — 1/4. По умолчанию интенсивность при линейной инверсии равна половине максимальной интенсивности.
  • Квадратичная инверсия. Установка затухания обратно пропорционально квадрату расстояния от источника света до объекта. Например, на расстоянии 2 единицы от источника освещенность равна 1/4 от освещенности на источнике, на расстоянии 4 единицы — 1/16.

Начальный предел затухания

Указывается точка начала освещения в виде смещения от центра источника света. Значение по умолчанию равно 0.

Задайте смещение начального предела (0-??) или [Откл]:

Примечание Начальные и конечные ограничения затухания не поддерживаются драйвером OpenGLwopengl8.hdi. Для идентификации драйвера надо ввести командуграфнастр, затем нажать на "Просмотр протокола оптимизации". Просмотреть строку "Драйвер" в "Протоколе мастера оптимизации параметров".

Конечный предел затухания

Указывается точка конца освещения в виде смещения от центра источника света. Далее этой точки свет не распространяется. Задание конечного предела приводит к повышению производительности в случаях, когда эффект от освещения является столь незначительным, что время на вычисления тратится впустую.

Задайте смещение конечного предела или [Откл]:

Цвет

Цвет источника света.

Задайте цвет (R,G,B) или опцию [Номер цвета/Hsl/Альбом цветов]:

Из палитры

Указывается цвет из палитры. Задайте цвет в формате R,G,B (красный, зеленый, синий).

Номер

Указывается цвет ACI (цветовой индекс AutoCAD).

Имя цвета или его номер (1-255):

HSL

Указываются (оттенок, насыщенность, яркость) цвета.

Введите цвет HSL (О, Н, Я):

Альбом

Указывается цвет из альбома.

Задать имя альбома:

Выход

Завершение команды.


ТУМАН Команда

Т Команды
Т Команды
ТУМАН Команда
Понятия Процедуры Команды

Устар.

Ввод команды: туман

Откроется Диалоговое окно "Тонирование среды". (команда СРЕДАТОН)


У Команды
  • УВЕЛИЧИТЬ
  • УДАЛСВЕТ
  • УДЛИНИТЬ
  • УРЛРАЗОРВАТЬ
  • УРЛСВЯЗАТЬ
  • УРОВЕНЬ
  • УСТПЕРЕМ


УВЕЛИЧИТЬ Команда

У Команды
У Команды
УВЕЛИЧИТЬ Команда
Понятия Процедуры Команды

Изменение длин объектов и центральных углов дуг

Меню "Изменить": "Увеличить"

Ввод команды: увеличить

Выберите объект или [ДЕльта/проЦент/Всего/ДИнамика]: Выбрать один объект или задать опцию

Выбор объекта

Отображение длины и, где это имеет смысл, внутреннего угла выбранного объекта.

Действие команды УВЕЛИЧИТЬ не распространяется на замкнутые объекты. Направление выдавливания не обязательно должно быть параллельным оси Z текущей пользовательской системы координат (ПСК).

Текущая длина: <текущая>, внутренний угол: <текущий>:

Выберите объект или [ДЕльта/проЦент/Всего/ДИнамика]: Выбрать один объект, задать опцию или нажать ENTER для завершения команды

ДЕльта

Изменение длины объекта на заданную величину со стороны, ближней к точке указания. Опция «Дельта» также изменяет угол дуги на заданную величину со стороны выбранной конечной точки дуги. При задании положительного значения дуга удлиняется, а при задании отрицательного значения — укорачивается.

Приращение длины или [Угол] <текущее>: Указать расстояние, ввести у или нажать клавишу ENTER

Приращение длины

Изменение длины объекта на заданную величину

Выберите объект для изменения или [Отменить]: Выбрать один объект или ввести о

Запрос повторяется до тех пор, пока пользователь не нажмет клавишу ENTER для завершения команды.

Угол

Изменение центрального угла дуги на заданную величину.

Введите приращение угла <текущее>: Задать угол или нажать клавишу ENTER

Выберите объект для изменения или [Отменить]: Выбрать один объект или ввести о

Запрос повторяется до тех пор, пока пользователь не нажмет клавишу ENTER для завершения команды.

проЦент

Задание длины объекта в процентном отношении относительно исходной.

Процент длины <текущее>: Ввести ненулевое положительное значение или нажать клавишу ENTER

Выберите объект для изменения или [Отменить]: Выбрать один объект или ввести о

Запрос повторяется до тех пор, пока пользователь не нажмет клавишу ENTER для завершения команды.

Всего

Задание длины объекта или угла дуги равными абсолютной величине, отсчитываемой от фиксированного конца объекта. Параметр "Всего" также устанавливает для внутреннего угла выбранной дуги значение заданного полного угла.

Полная длина или [Угол] <текущая>: Указать расстояние, ввести ненулевое положительное значение, ввести у или нажать клавишу ENTER

Полная длина

Изменение длины объекта на заданную величину со стороны, ближней к точке указания.

Выберите объект для изменения или [Отменить]: Выбрать один объект или ввести о

Запрос повторяется до тех пор, пока пользователь не нажмет клавишу ENTER для завершения команды.

Угол

Задание угла выбранной дуги

Полный угол <текущий>: Задать угол или нажать клавишу ENTER

Выберите объект для изменения или [Отменить]: Выбрать один объект или ввести о

Запрос повторяется до тех пор, пока пользователь не нажмет клавишу ENTER для завершения команды.

ДИнамика

Включение режима динамического задания длины. Длина выбранного объекта изменяется путем динамического перемещения одной из его конечных точек. Другой конец объекта остается фиксированным.

Выберите объект для изменения или [Отменить]: Выбрать один объект или ввести о

Запрос повторяется до тех пор, пока пользователь не нажмет клавишу ENTER для завершения команды.


УДАЛСВЕТ Команда

У Команды
У Команды
УДАЛСВЕТ Команда
Понятия Процедуры Команды

Эта команда создает удаленный источник света

Панель "Источники света"

Меню "Вид": "Тонировать" » подменю "Свет" » подменю "Новый удаленный свет"

Ввод команды: удалсвет

Пульт управления: Панель "Источники света" (нажать, чтобы увеличить), "Создать удаленный свет"

Указать направление светового луча ОТ ТОЧКИ <0,0,0> или [Вектор]: Задать точку или ввести в

Задать направление светового луча К ТОЧКЕ <1,1,1> Задать точку

При вводе параметра "Вектор" отображается следующий запрос:

Задать направление вектора <0.0000,-0.0100,1.0000>: Ввести вектор

После задания направления светового луча на экран выводится следующий запрос:

Задать опцию, которая подлежит изменению [Имя/Интенсивность/Состояние/тень/Цвет/выход] <выход>:

Имя

Имя источника света. В тексте имени можно использовать буквы верхнего и нижнего регистра, цифры, пробелы, дефисы (-) и знаки подчеркивания. Максимальная длина имени равняется 256 символам.

Ввести имя источника света:

Интенсивность

Установка интенсивности (или яркости) источника света. Диапазон изменения от 0,00 до максимального значения, поддерживаемого системой.

Ввести значение интенсивности (0,00 - макс. возм. значение):

Статус

Включает и выключает источник света. Если в данном чертеже функция освещения не активизирована, то эта установка не работает.

Ввести значение статуса [Вкл/Выкл]:

Тень

Включение отбрасывания теней от удаленного источника света.

Задать параметры тени [Откл/Резкая/Нерезкая]:

Откл

Отключает отображение и расчет интенсивности теней для данного источника света. Отключение отображения теней повышает скорость обработки чертежа.

Резкая

Отображаемые тени имеют резкие очертания. Эту опцию используют для повышения скорости обработки чертежа.

Приглушенная

Отображение реалистичных теней с мягкими очертаниями.

Цвет

Цвет источника света.

Ввести цвет из палитры (красный, зеленый, синий) или [Цвет из индекса/Hsl/Альбом]:

Из палитры

Назначение цвета из палитры. Ввести в формате R,G,B (красный, зеленый, синий).

Индекс

Назначение цвета АСI (индекс цветов AutoCAD).

Имя цвета или его номер (1-255):

HSL

Назначение для цвета параметра HSL (оттенок, насыщенность, яркость).

Ввести цвет в формате HSL (H-оттенок, S-насыщенность, L-яркость):

Альбом

Назначение цвета из альбома.

Ввести имя альбома:

Выход

Завершение команды.


УДЛИНИТЬ Команда

У Команды
У Команды
УДЛИНИТЬ Команда
Понятия Процедуры Команды

Удлинение объектов до пересечения с другими объектами

Панель "Редактирование":

Меню "Изменить": "Удлинить"

Ввод команды: удлинить

Выбрать граничные кромки...

Выбрать объекты или <выбрать все>: Выбрать один или несколько объектов и нажать ENTER или нажать ENTER для выбора всех отображенных объектов

Выбрать удлиняемый (+Shift -- обрезаемый) объект Клавиша Shift для обрезки или [Линия/Секрамка/Проекция/Кромка/Отменить]: Выбрать удлиняемые объекты или, удерживая SHIFT , выбрать обрезаемый объект, или задать опцию

Выбор граничных кромок

Использование выбранных объектов для определения граничных кромок, до которых удлиняется объект.

Удлиняемые объекты

Указывает объекты для удлинения. Для завершения команды нажать клавишу ENTER.

Клавиша Shift для обрезки

Обрезка выбранных объектов до ближайшей кромки, а не удлинение. Это простой метод переключения между обрезкой и удлинением.

Линия

Выбор всех объектов, пересекающих линию выбора. Линия выбора - это последовательность временных сегментов линии, заданная с помощью двух или более точек линии выбора. Линия выбора не образует замкнутый контур.

Указать первую точку линии выбора: Указать начальную точку линии выбора

Указать следующую точку линии выбора или [Отменить]: Указать следующую точку линии выбора или ввести о

Указать следующую точку линии выбора или [Отменить]: Указать следующую точку линии выбора, ввести о или нажать ENTER

Секрамка

Выбор объектов, находящихся внутри прямоугольной области, определенной двумя точками, и пересекающих ее.

Первый угол: Указать точку

Противоположный угол: Точка на диагонали, которая выходит из первой точки

Примечание Некоторые рамки выбора объектов для расширения неоднозначны. Команда УДЛИНИТЬ разрешает выбор вдоль прямоугольной секущей рамки по часовой стрелке от первой точки до первого обнаруженного объекта.

Проекция

Задает режим проецирования, который используется при удлинении объектов.

Задать опцию проецирования [Нет/Пск/Вид] <текущая>: Задать опцию или нажать клавишу ENTER

Ничего

Без проецирования. Удлиняются только объекты, пересекающиеся в 3D пространстве с граничными кромками.

ПСК

Задание проецирования на плоскость XY текущей ПСК. Удлиняются объекты, не пересекающиеся в 3D пространстве с граничными кромками.

Вид

Проецирование вдоль текущего направления взгляда.

Кромка

Удлинение объекта до пересечения с воображаемой гранью другого объекта или только до объекта, действительно пересекающего этот объект в 3D-пространстве.

Задать режим продолжения кромки до воображаемого пересечения [Удлинить/Без удлинения] <текущий>: Задать опцию или нажать клавишу ENTER

С продолжением

Удлинение граничной кромки до пересечения с удлиняемым объектом или его продолжением в 3D пространстве.

Без продолжения

Режим удлинения объекта только до кромки, которую он реально пересекает в трехмерном пространстве.

Отменить

Отмена последних изменений, внесенных с помощью команды УДЛИНИТЬ.


УРЛРАЗОРВАТЬ Команда

У Команды
У Команды
УРЛРАЗОРВАТЬ Команда
Понятия Процедуры Команды

Удаление гиперссылок в чертеже

Ввод команды: урлразорвать

Выбрать объекты: Выбрать объекты любым способом, затем нажать ENTER для завершения операции

Удаление гиперссылок для выбранных графических объектов. Если выбрана зона, удаляется полилиния. Для удаления слоя URLLAYER можно использовать команду ОЧИСТИТЬ.


УРЛСВЯЗАТЬ Команда

У Команды
У Команды
УРЛСВЯЗАТЬ Команда
Понятия Процедуры Команды

Создает гиперссылки для объектов или областей чертежа

Ввод команды: урлсвязать

Задать опцию вставки гиперссылки [Площадь/Объект] <Объект>: Ввести а или нажать клавишу ENTER

Площадь

Команда создает слой URLLAYER, строит на этом слое полилинию и добавляет к ней URL.

Первый угол: Нажать кнопку мыши на чертеже, чтобы указать левый нижний угол зоны

Второй угол: Указать правый верхний угол области чертежа

Гиперссылка <текущий чертеж>: Ввести URL

Полилиния, которая ограничивает площадь, отображается в цвете, назначенном слою URLLAYER. По умолчанию используется красный цвет. При наведении курсора на границу области он меняет форму, указывая добавленный URL.

Объект

Добавление URL к выбранному объекту.

Выбрать объекты: Выбрать объекты любым способом, затем нажать ENTER

Гиперссылка <текущий чертеж>: Ввести URL

Если после добавления URL навести курсор на объект, то курсор меняет форму. Появляется значок гиперссылки и добавленный URL.


УРОВЕНЬ Команда

У Команды
У Команды
УРОВЕНЬ Команда
Понятия Процедуры Команды

Задание уровня и трехмерной высоты для вновь создаваемых объектов

Ввод команды: уровень (или 'уровень для прозрачного вызова)

Задать новый уровень по умолчанию <текущий>: Задать расстояние или нажать клавишу ENTER

Текущим уровнем по умолчанию для новых объектов является координата Z, если для 3D точки заданы только координаты X и Y.

Значение уровня будет одинаковым для всех видовых экранов независимо от пользовательских систем координат (ПСК). На заданной оси Z не созданы новые объекты относительно текущей ПСК на видовом экране.

Задать новое значение толщины по умолчанию <текущая>: Задать расстояние или нажать клавишу ENTER

Толщина определяет расстояние, на которое выдавливается 2D объект выше или ниже своего уровня. Положительное значение задает выдавливание в положительном направлении оси Z, а отрицательное в отрицательном направлении оси Z.

Команда УРОВЕНЬ управляет только вновь создаваемыми объектами, оставляя без изменений уже существующие. При изменении системы координат на мировую систему координат (МСК) уровень сбрасывается до значения 0.0.


УСТПЕРЕМ Команда

У Команды
У Команды
УСТПЕРЕМ Команда
Понятия Процедуры Команды

Вывод списка системных переменных, изменение их значений

Меню "Сервис": "Сведения" » "Переменные"

Ввод команды: устперем (или 'устперем для вызова в прозрачном режиме)

Имя переменной или [?] <текущее>: Ввести имя переменной, ввести ? или нажать ENTER

Имя переменной

Задание имени системной переменной, которой требуется присвоить значение.

Новое значение имя_переменной <текущее>: Ввести новое значение или нажать ENTER

Кроме этого, значения системных переменных можно изменять в командной строке (посредством ввода имени переменной и нового значения).

?—Список переменных

Вывод списка текущих значений всех системных переменных, используемых в чертеже.

Список переменных для вывода <*>: Ввести символ-шаблон или нажать ENTER


Ф Команды
  • ФАСКА
  • ФИГУРА
  • ФИЛЬТР
  • ФОН
  • ФОРМА
  • ФОРМАТЛ
  • ФОРМКОМПЛЕКТ


ФАСКА Команда

Ф Команды
Ф Команды
ФАСКА Команда
Понятия Процедуры Команды

Построение фасок в местах пересечения объектов

Панель "Редактирование":

Меню "Изменить": "Фаска"

Ввод команды: фаска

(Режим ОБРЕЗКА) Параметры фаски: Длина1 = текущая, Длина2 = текущая

Выбратьпервый отрезок или [Отменить/Полилиния/Длина/Угол/Обрезка/Метод/Несколько]: Выбрать объекты любым способом или задать опцию

Первый отрезок

Определяет первую из двух кромок для определения 2D фаски или снятия фаски кромки трехмерного твердотельного объекта.

Выбрать второй отрезок или нажать клавишу Shift при выборе, чтобы создать угол: Использовать любой способ выбора объекта или нажать и удерживать клавишу SHIFT и выбрать объект, чтобы создать острый угол

При выборе линий или полилиний их длины регулируются для соответствия длине линии фаски. Можно удерживать нажатой клавишу SHIFT при выборе объектов для замены значения текущих расстояний фаски на 0.

Если выбранные объекты являются линейными сегментами двумерной полилинии, они должны быть либо смежными, либо разделенными одним сегментом. Если они разделены другим сегментом полилинии, команда ФАСКА удалит сегмент, разделяющий их, и заменит его фаской.

Если для снятия фаски выбрано ребро трехмерного тела, необходимо указать, какая из двух смежных с ним граней является базовой поверхностью.

Выбирается базовая поверхность...

Ввести опцию выбора поверхности [Следующая/OK (текущая)] <OK>: Ввести n или o или нажать ENTER

Если ввести o или нажать ENTER, выбранная поверхность устанавливается как базовая поверхность. Если ввести с, выбранной становится вторая поверхность, смежная с указанным ребром.

Длина фаски для базовой поверхности <текущая>:

Длина фаски для другой поверхности <текущая>:

После выбора базовой поверхности нужно указать, какие из ее ребер участвуют в снятии фасок. Ребра можно выбирать по отдельности или все вместе.

Выбрать ребро или [Замкнутый контур] Выбрать ребро, ввести L или нажать ENTER

Ребро

Позволяет указывать ребра по отдельности.

Замкнутый контур

Переключение в режим выбора замкнутых контуров.

Выбрать замкнутый контур или [Ребро] Выбрать ребро, ввести e или нажать ENTER

Замкнутый контур грани

Выбор всех ребер базовой поверхности.

Ребро

Переключение в режим выбора отдельных ребер.

Отменить

Отменяет предыдущую операцию в команде.

Полилиния

Построение фасок вдоль всей полилинии.

Выбрать 2D полилинию:

Пересекающиеся сегменты полилинии соединяются фаской в каждой вершине полилинии. Линии фасок становятся новыми сегментами полилинии.

Если полилиния включает сегменты, которые намного короче длины фаски, у этих сегментов фаска не снимается.

Длина

Задание длин фасок (расстояний от выбранного пересечения до концов линии фаски).

Первая длина фаски <текущая>:

Вторая длина фаски <текущая>:

Если оба значения длины заданы равными нулю, команда ФАСКА удлиняет или обрезает две линии так, чтобы они заканчивались в одной точке.

Угол

Задание в качестве параметров фаски одной из ее длин и величины угла.

Первая длина фаски <текущая>:

Угол фаски с первым отрезком <текущий>:

Обрезка

Определяет, обрезает ли команда ФАСКА выбранные грани по конечным точкам фаски.

Режим обрезки [С обрезкой/Без обрезки] <текущий>:

Примечание Включение обрезки устанавливает системной переменной TRIMMODE значение 1; отключение обрезки присваивает системной переменной TRIMMODE значение 0.

Если системной переменной TRIMMODE установлено значение 1, команда ФАСКА обрезает пересекающиеся линии по конечным точкам линии фаски. Если выбранные линии не пересекаются, команда ФАСКА удлинит или обрежет их так, чтобы они пересеклись. Если переменной TRIMMODE установлено значение 0, фаска снимается без обрезки выбранных линий.

Метод

Определяет, использует ли команда ФАСКА для построения фаски значения двух длин или значение длины и величину угла.

Метод построения [Длина/Угол] <текущий>:

Несколько

Создает фаски для кромок нескольких наборов объектов. Команда ФАСКА будет отображать основную подсказку, а также подсказку "Выбрать второй объект" до тех пор, пока не будет нажата клавиша ENTER для завершения команды.


ФИГУРА Команда

Ф Команды
Ф Команды
ФИГУРА Команда
Понятия Процедуры Команды

Создание закрашенных многоугольников

Меню "Рисование": "Моделирование" » "Сети" » "2D фигура"

Ввод команды: фигура

Первая точка: Указать точку (1)

Вторая точка: Указать точку (2)

Первые две точки описывают одну сторону многоугольника.

Третья точка: Указать точку (3), диагонально противоположную второй

Четвертая точка <выход>: Указать точку (4) или нажать ENTER

Нажатие клавиши ENTER в ответ на запрос четвертой точки приводит к созданию треугольника с заливкой. Указание точки ведет к построению четырехугольника.

Две последние точки определяют первую сторону следующего многоугольника. Запросы "Третья точка" и "Четвертая точка" будут повторяться. После указания этих точек к исходной фигуре присоединяются дополнительные треугольные и четырехугольные фрагменты; в совокупности же образуется единый объект. Для завершения команды ФИГУРА следует нажать ENTER.

2D фигуры закрашиваются только в том случае, если системная переменная FILLMODE включена и направление взгляда ортогонально фигуре.


ФИЛЬТР Команда

Ф Команды
Ф Команды
ФИЛЬТР Команда
Понятия Процедуры Команды

Создает список свойств, которыми должен обладать объект, чтобы быть выбранным

Ввод команды: фильтр (или 'фильтр для прозрачного вызова)

Откроется диалоговое окно "Фильтры выбора объектов".

Темы:

  • Диалоговое окно "Фильтры выбора объектов"


Диалоговое окно "Фильтры выбора объектов"

Ф Команды
Ф Команды
Диалоговое окно "Фильтры выбора объектов"
Понятия Процедуры Команды

Ввод команды: фильтр (или 'фильтр для прозрачного вызова)

Назначение фильтров для выбора объектов, их редактирование, присвоение имен.

Список свойств фильтра

Список свойств текущего фильтра (выбранного в соответствующем списке группы опций "Именованные фильтры").

Выбор фильтра

Добавление в фильтр новых свойств (условий, по которым будут отбираться объекты).

Типы объектов и логические операторы

Перечень типов объектов, допускающих применение фильтров. Условия фильтрации могут быть сформулированы с помощью логических операторов: AND (И), OR (ИЛИ), XOR (Исключающее ИЛИ) и NOT (НЕ).

При использовании логических операторов необходимо следить за корректностью формулируемого логического выражения. Количество операндов определяется типом логической операции.

Логические операторы
Открывающий оператор | Количество операндов | Закрывающий оператор
Начало AND | Один или более | Конец AND
Начало OR | Один или более | Конец OR
Начало XOR | Два | Конец XOR
Начало NOT | Один | Конец NOT

Например, следующий фильтр выберет все окружности, за исключением тех, чей радиус больше или равен 1,0:

Объект=Круг

**Начало NOT

Радиус круга= 1,00

**Конец NOT

Параметры X, Y, Z

Определяют (в зависимости от объекта) дополнительные параметры фильтрации. Например, для выбора отрезка можно ввести координаты X, Y и Z его начальной точки.

Для значений параметров фильтрации можно указывать относительные операторы, такие как < (меньше) и > (больше). Например, следующий фильтр выберет все окружности, центры которых имеют координаты, большие или равные 1,1,0, а радиусы больше или равны 1:

Объект=Круг

Центр круга X >= 1,0000 Y >= 1,0000 Z >= 0,0000

Радиус круга>= 1,0000

Выбрать

Вызов диалогового окна со списком всех возможных значений для данного типа объектов. Предлагается выбрать значения для включения в фильтр. Например, при выборе типа объекта "Цвет" появляется список цветов.

Добавить

Добавление к списку свойств текущего фильтра нового параметра отбора. Свойства неименованных фильтров сохраняются до окончания текущего сеанса работы или до тех пор, пока они не будут удалены вручную.

Заменить

Замена текущего свойства фильтра (в списке свойств) на свойство, установленное в опции "Выбор фильтра".

Добавить объект

Добавление нового объекта в список фильтра.

Изменить

Указанное в списке свойство перемещается в опцию "Выбор фильтра". Для изменения свойства фильтра нужно выбрать его из списка и нажать кнопку "Изменить". По окончании редактирования нужно нажать кнопку "Заменить". Прежнее значение параметра будет заменено отредактированным.

Удалить

Удаление выбранного свойства из текущего фильтра.

Очистить

Удаление всех свойств из текущего фильтра.

Именованные фильтры

Просмотр, сохранение и удаление списков фильтров.

Текущий

Просмотр имеющихся списков фильтров. Для того чтобы сделать фильтр текущим, его следует выбрать из списка. Именованный фильтр и его список свойств загружаются из файла по умолчанию filter.nfl.

Сохранить как

Сохранение фильтра и списка его свойств. Фильтр сохраняется в файле filter.nfl. Имя файла может содержать не более 18 символов.

Удалить текущий список

Удаление фильтра и списка его свойств из файла, выбираемого по умолчанию.

Применить

Завершение работы в диалоговом окне и вывод подсказки "Выберите объекты" для создания набора. Текущий фильтр используется на выбранных объектах.


ФОН Команда

Ф Команды
Ф Команды
ФОН Команда
Понятия Процедуры Команды

Устар.

Ввод команды: фон

Чтобы добавить фон в чертеж, создайте именованный вид, назначьте виду фон, затем восстановите вид, чтобы фон стал видимым.

См. команду ВИД.


ФОРМА Команда

Ф Команды
Ф Команды
ФОРМА Команда
Понятия Процедуры Команды

Вставка формы из файла форм, загруженного с помощью команды ЗАГРУЗИТЬ

Ввод команды: форма

Имя формы или [?]: Ввести имя или ввести ?

Имя формы

Загрузка формы.

Точка вставки:

Высота <текущая>: Указать высоту или нажать ENTER

Угол поворота <0>: Задать угол или нажать ENTER

Если форма принадлежит вставленной в текущий чертеж внешней ссылке, файл формы помечается как внешне зависимый. Внешне зависимые формы не могут использоваться в текущем чертеже, пока не будут перезагружены.

?—Список форм

Получение списка загруженных форм и файлов, в которых они описаны. Если ввести знак вопроса (?), отображается следующий запрос:

Какие имена форм вывести <*>: Ввести список имен или нажать ENTER

Если ввести имя, программа выдаст имя файла, в котором содержится описание данной формы, и завершит команду ФОРМА. Если ввести звездочку (*), программа выдаст имена форм и завершит команду ФОРМА.


ФОРМАТЛ Команда

Ф Команды
Ф Команды
ФОРМАТЛ Команда
Понятия Процедуры Команды

Задание параметров чертежа

Ввод команды: форматл

Запросы, выдаваемые командой форматл, зависят от того, откуда она была вызвана: со вкладки "Модель" (пространство модели) или "Лист" (пространство листа).

На вкладке "Модель" с помощью команды ФОРМАТЛ из командной строки задаются тип единиц, коэффициент масштаба чертежа и размеры листа. Прямоугольная рамка строится на лимитах сетки на основании заданных настроек.

На вкладке-листе в чертеж можно вставить одну из стандартных основных надписей, а также определить набор видовых экранов листа. Можно задать глобальный масштаб в виде отношения между масштабом основной надписи в листе и масштабом чертежа во вкладке "Модель". Вкладку "Модель" полезно использовать при печати нескольких видов чертежа на одном листе.

Для того чтобы скомпоновать все листы и подготовить чертеж к печати, удобно также воспользоваться диалоговым окном "Параметры листа", которое автоматически открывается при переходе на лист в новом рабочем сеансе.

Темы:

  • Команда ФОРМАТЛ на вкладке "Модель"
  • Команда ФОРМАТЛ на вкладке "Лист"


Команда ФОРМАТЛ на вкладке "Модель"

Ф Команды
Ф Команды
Команда ФОРМАТЛ на вкладке "Модель"
Понятия Процедуры Команды

Если системная переменная TILEMODE включена (по умолчанию), отобразится следующий запрос:

Переключиться в пространство листа? [Нет/Да] <Д>: Ввести н или нажать ENTER

Если нажать ENTER, переменная TILEMODE отключается, и дальнейшая работа идет так, как описано в разделе Команда ФОРМАТЛ на вкладке "Лист"

Если ввести н, выдается следующий запрос:

Тип единиц [Научные/Десятичные/Технические/Архитектурные/Метрические]: Задать опцию

Отображается список доступных значений и запросов масштабного коэффициента и размера листа.

Введите масштаб: Ввести значение

Введите горизонтальный размер листа: Ввести значение

Введите вертикальный размер листа: Ввести значение

Рисуется ограничивающая рамка и команда завершается.


Команда ФОРМАТЛ на вкладке "Лист"

Ф Команды
Ф Команды
Команда ФОРМАТЛ на вкладке "Лист"
Понятия Процедуры Команды

Если системная переменная TILEMODE отключена, а в ответ на "Переключиться в пространство листа?" введено д или нажата клавиша ENTER, выводится следующий запрос:

Задайте опцию [Выравнивание/Создать/Масштаб/Опции/Штамп/Отменить]: Задать опцию или нажать ENTER для завершения команды

Выравнивание

Панорамирование вида на видовом экране с выравниванием его по базовой точке на другом видовом экране. Текущий видовой экран — это видовой экран, в который перемещается другая точка.

Задайте опцию [Угловое/Горизонтальное/Вертикальное выравнивание/Повернуть вид/Отменить]:Задать опцию

Угловое

Панорамирование вида на видовом экране в заданном направлении.

Базовая точка: Укажите точку

Укажите точку панорамирования на другом видовом экране: Указать точку на панорамируемом видовом экране

Следующие два запроса позволяют задать угол и расстояние до новой точки выравнивания.

Укажите расстояние и угол до новой точки выравнивания на том видовом экране, где была определена базовая точка.

Расстояние от базовой точки: Задать расстояние

Угол относительно базовой точки: Задать угол

Горизонтальный

Панорамирование вида на видовом экране так, чтобы он совместился по горизонтали с базовой точкой другого видового экрана. Данную опцию рекомендуется использовать, только если видовые экраны расположены горизонтально. В противном случае вид при панорамировании может выйти за границы видового экрана.

Базовая точка: Укажите точку

Укажите точку панорамирования на другом видовом экране: Указать точку на панорамируемом видовом экране

Вертикальное выравнивание

Панорамирование вида на видовом экране так, чтобы он совместился по вертикали с базовой точкой другого видового экрана. Данную опцию рекомендуется использовать, только если видовые экраны расположены вертикально. В противном случае вид при панорамировании может выйти за границы видового экрана.

Базовая точка: Укажите точку

Укажите точку панорамирования на другом видовом экране: Указать точку на панорамируемом видовом экране

Повернуть вид

Поворот вида на видовом экране относительно базовой точки.

Укажите базовую точку на видовом экране, содержащем поворачиваемый вид: Укажите точку

Угол относительно базовой точки: Задать угол

Отменить

Отмена операций, выполненных в текущем сеансе ФОРМАТЛ.

Создать

Создание новых видовых экранов.

Задайте опцию [Удалить/Создать видовые экраны/Отменить] <Создать>: Задать опцию или нажать ENTER

Удалить

Удаление имеющихся видовых экранов.

Выберите объекты для удаления...

Выберите объекты: Выбрать удаляемые видовые экраны и нажать ENTER

Создать видовые экраны

Отображение вариантов расположения создаваемых видовых экранов.

Возможные варианты компоновки видовых экранов:

0: Ничего

1: Один

2: Конструкторский

3: Массив видовых экранов

Введите номер варианта компоновки для загрузки или [Обновить]: Ввести номер параметра ( 0 - 3 ) или ввести с для повторного вывода списка параметров компоновки видового экрана

Номер варианта компоновки

Управление созданием видовых экранов.

Если ввести 0 или нажать ENTER, экран не создается.

Если ввести 1, создается один видовой экран, размер которого определяется пользователем при ответе на следующие запросы.

Первый угол границы области видового(ых) экрана(ов): Указать точку для первого угла

Противоположный угол: Указать точку для противоположного угла

Если ввести 2, создаются четыре видовых экрана, делящие выбранную область на квадранты. Отобразится запрос области, которую необходимо разделить, и расстояния между видовыми экранами.

Первый угол границы области видового(ых) экрана(ов): Указать точку для первого угла

Противоположный угол: Указать точку для противоположного угла

Расстояние между видовыми экранами по оси X <0,0>: Задать расстояние или нажать ENTER

Расстояние между видовыми экранами по оси Y <0,0>: Задать расстояние или нажать ENTER

Направления взгляда на каждом из квадрантов приведены в следующей таблице.

Виды в конструкторских видовых экранах

Квадрант

Вид

Верхний левый

Вид сверху (плоскость XY ПСК)

Верхний правый

Изометрический (ЮВ) вид

Нижний левый

Вид спереди (плоскость XZ ПСК)

Нижний правый

Вид справа (плоскость YZ ПСК)

Если ввести 3, создается матрица видовых экранов, располагаемая вдоль осей X и Y. При указании точек в ответ на следующие два запроса на чертеже задается прямоугольная область, в которой должны быть расположены создаваемые видовые экраны. Если в чертеж была вставлена стандартная основная надпись, то в запросе на ввод первой точки будет добавлена опция для выбора этой области (по умолчанию).

Первый угол границы области видового(ых) экрана(ов): Указать точку для первого угла

Противоположный угол: Указать точку для противоположного угла

Число видовых экранов по оси X <1>: Ввести число видовых экранов в направлении X

Число видовых экранов по оси Y <1>: Ввести число видовых экранов в направлении Y

Если в каждом направлении указано более одного видового экрана, отобразятся следующие запросы:

Расстояние между видовыми экранами по оси X <0,0>: Задать расстояние

Расстояние между видовыми экранами по оси Y <0,0>: Задать расстояние

Массив видовых экранов вставляется в заданную область.

Обновить

Повторный вывод списка вариантов размещения видовых экранов.

Отменить

Отмена операций, выполненных в текущем сеансе команды ФОРМАТЛ.

Масштаб видовых экранов

Настройка масштаба отображения объектов на видовых экранах. Масштаб отображения вычисляется как отношение масштаба рамки видового экрана в пространстве листа и масштаба выводимых на этом видовом экране объектов.

Выберите видовые экраны для задания масштаба…

Выберите объекты: Выбрать видовые экраны для масштабирования

Если выбран только один видовой экран, следующий запрос будет пропущен.

Задайте масштабный коэффициент для видовых экранов. Интерактивно/<Общий>: Ввести и или нажать ENTER

Число единиц пространства листа <1,0>: Ввести значение или нажать ENTER

Число единиц пространства модели <1,0>: Ввести значение или нажать ENTER

Интерактивно

Поочередное выделение видовых экранов и запрос масштаба для каждого из них:

Число единиц пространства листа <1,0>: Ввести значение или нажать ENTER

Число единиц пространства модели <1,0>: Ввести значение или нажать ENTER

Например, для назначения техническому чертежу масштаба 1:4 следует ввести 1 на запрос о числе единиц пространства листа, а затем 4 на запрос о числе единиц пространства модели.

Общий

Задание единого масштабного коэффициента для всех видовых экранов.

Число единиц пространства листа. <1,0>: Ввести значение или нажать ENTER

Число единиц пространства модели. <1,0>: Ввести значение или нажать ENTER

Опции

Задание предпочтительных параметров команды ФОРМАТЛ перед внесением изменений в чертеж.

Задайте опцию [Слой/Лимиты/Единицы/Вн-ссылка] <выход>: Задать опцию или нажать ENTER для возврата к предыдущему запросу

Слой

Задание слоя для вставки основной надписи.

Имя слоя для штампа или [. (для выбора текущего слоя)]: Ввести имя существующего или нового слоя, точку (.) для текущего слоя или нажать ENTER

Лимиты

Указывает, выполнять ли сброс лимитов сетки к границам чертежа после вставки основной надписи.

Установить лимиты чертежа? [Да/Нет] <Н>: Ввести д или нажать ENTER

Единицы

Определяет, пересчитываются ли значения размеров и расположения точек в единицы пространства листа (дюймы или миллиметры).

Единицы пространства листа [Футы/Дюймы/МЕтры/МИллиметры] <текущие>: Задать опцию или нажать ENTER

Вн-ссылка

Выбор способа вставки основной надписи: в виде блока или внешней ссылки.

Вставить штамп как [Ссылку/Блок] <текущий>: Ввести с, б или нажать ENTER

Штамп

Подготовка пространства листа, ориентация чертежа заданием его начала, построение рамки и основной надписи.

Задайте опцию для штампа [Удалить объекты/Начало/Отменить/Вставить] <Вставить>: Задать опцию или нажать ENTER

Удалить объекты

Удаление объектов в пространстве листа.

Выберите объекты для удаления. . .

Выберите объекты: Выбрать объекты любым способом

Начало

Изменение начальной точки листа.

Укажите новую точку начала отсчета для этого листа: Указать точку

Отменить

Отмена операций, выполненных в текущем сеансе ФОРМАТЛ.

Вставить

Отображение вариантов основных надписей.

Имеющиеся штампы:...

0: Ничего

1: Формат ISO A4 (мм)

2: Формат ISO A3 (мм)

3: Формат ISO A2 (мм)

4: Формат ISO A1 (мм)

5: Формат ISO A0 (мм)

6: Формат ANSI-V (дюйм)

7: Формат ANSI-A (дюйм)

8: Формат ANSI-B (дюйм)

9: Формат ANSI-C (дюйм)

10: Формат ANSI-D (дюйм)

11: Формат ANSI-E (дюйм)

12: Arch/Engineering (24 x 36 дюймов)

13: Обобщенный формат D (24 x 36 дюймов)

Введите порядковый номер штампа для загрузки или [Добавить/Удалить/Обновить]: Ввести номер параметра (от 0 до 13 ) или параметр

Штамп для загрузки

Вставка рамки и штампа с основной надписью. Если ввести 0 или нажать ENTER, рамка не создается. Если ввести номер от 1 до 13, создается стандартная рамка подходящего размера. В списке приведены рамки стандартов ANSI и DIN/ISO.

Добавить

Добавление основной надписи к чертежу. При выборе данной опции выдается запрос на ввод описания для новой основной надписи, а также имени чертежа для вставки.

Описание штампа: Ввести описание

Имя вставляемого чертежа (без расширения): Ввести имя файла

Задать используемую по умолчанию область? [Да/Нет] <Д>: Ввести н или нажать ENTER

Если нажать ENTER, программа выдает следующие запросы:

Левый нижний угол: Укажите точку

Правый верхний угол: Укажите точку

Строка, похожая на приведенный ниже пример, добавляется в конец файла mvsetup.dfs по умолчанию:

A/E (24 x 18дюймов),arch-b.dwg,(1,12 0,99 0,00),(18,63 17,02 0,00),д

Последнее поле строки указывает единицы измерения основной надписи (дюймы или миллиметры). Задание единиц позволяет изменять основные надписи, созданные в системах с разными единицами измерения, путем указания типа единицы с использованием опции "Настройки".

Допускается наличие в основной надписи переменных атрибутов.

Удалить

Удаление элементов из списка.

Номер пункта для удаления из списка: Ввести номер пункта для удаления

Обновить

Повторный вывод списка вариантов основных надписей.

Отменить

Отмена операций, выполненных в текущем сеансе ФОРМАТЛ.


ФОРМКОМПЛЕКТ Команда

Ф Команды
Ф Команды
ФОРМКОМПЛЕКТ Команда
Понятия Процедуры Команды

Формирование комплекта файлов для передачи другим пользователям через Интернет

Меню "Файл": eTransmit

Ввод команды: формкомплект

Открывается диалоговое окно "Формирование комплекта файлов".

Если в ответ на подсказку "Команда" ввести -формкомплект, будет вызван вариант команды ФОРМКОМПЛЕКТ, при котором в командной строке выводятся подсказки.

Темы:

  • Диалоговое окно "Формирование комплекта файлов"
  • Диалоговое окно "Наборы параметров комплектов"
  • Диалоговое окно "Импорт параметров комплекта"
  • Диалоговое окно "Изменение набора параметров комплекта"
  • Диалоговое окно "Комплект файлов задание пароля"
  • ФОРМКОМПЛЕКТ вариант для командной строки


Диалоговое окно "Формирование комплекта файлов"

Ф Команды
Ф Команды
Диалоговое окно "Формирование комплекта файлов"
Понятия Процедуры Команды

Меню "Файл": eTransmit

Ввод команды: формкомплект

Формирование комплекта файлов для передачи другим пользователям через Интернет.

Все файлы, включаемые в комплект, помечаются галочкой. При нажатии правой кнопки мыши в области файлов появляется контекстное меню.

Вкладка "Листы"

Перечисляет все листы, которые будут включены в комплект, в соответствии с иерархией. На этой вкладке можно создать комплект из подшивки, группы листов или одного листа. Для вызова функции необходимо открыть подшивку в Диспетчере подшивок, нажать правую кнопку мыши на подшивке, группе листов или одиночном листе и выбрать из контекстного меню пункт "Сформировать комплект".

Примечание Если какой-либо лист из списка недоступен, значит на него ссылается (как на внешнюю ссылку) некоторый другой файл из формируемого комплекта, и он автоматически будет включен в комплект.

Вкладка "Дерево файлов"

Перечисляет все файлы, которые будут включены в комплект, в виде иерархического дерева. По умолчанию сюда заносятся все файлы, на которые ссылается текущий чертеж (внешние ссылки, стили печати, шрифты и др.). Пользователь может добавлять и исключать файлы из комплекта. В комплект не включаются файлы, ссылки на которые установлены с помощью URL.

Чертежи для передачи перечислены в следующих категориях:

  • Чертежи с листами. Перечисление файлов чертежей, связанных с подшивкой.
  • Файлы подшивок. Перечисление вспомогательных файлов, связанных с подшивкой.
  • Текущий чертеж. Перечисление файлов чертежей, связанных с текущим чертежом.
  • Файлы, добавленные пользователем. Перечисляет файлы, добавленные вручную с помощью опции "Добавить файл".
Вкладка "Таблица файлов"

Отображает файлы для включения в комплект в табличном формате. По умолчанию сюда заносятся все файлы, на которые ссылается текущий чертеж (внешние ссылки, стили печати, шрифты и др.). Пользователь может добавлять и исключать файлы из комплекта. В комплект не включаются файлы, ссылки на которые установлены с помощью URL.

Добавить файл

Открывает стандартное диалоговое окно выбора файлов, в котором можно выбрать дополнительный файл для включения в комплект файлов. Эта опция доступна как на вкладке "Дерево файлов", так и на вкладке "Таблица файлов".

Примечания к комплекту файлов

Здесь можно ввести текстовые примечания к формируемому комплекту файлов. Примечания также включаются в отчет о работе процедуры. Для того, чтобы получить возможность использования шаблона примечаний, нужно создать текстовый файл etransmit.txt и занести в него стандартный текст примечания. Файл необходимо сохранить в одной из папок пути доступа к вспомогательным файлам, заданного на вкладке "Файлы" диалогового окна "Настройка".

Набор параметров комплекта

Список ранее сохраненных наборов параметров. Принятый по умолчанию набор параметров комплекта называется СТАНДАРТ. Для выбора другого параметра комплекта нужно нажать кнопку мыши. Для создания новых наборов параметров и изменения существующих служит кнопка "Наборы параметров". При нажатии правой кнопки появляется контекстное меню.

Параметры комплекта

Отображает диалоговое окно "Наборы параметров комплектов", в котором можно создавать, изменять и удалять наборы параметров комплектов файлов.

Просмотр отчета

Отображение отчетных сведений о комплекте файлов. К их числу относятся заданные примечания к комплекту и автоматически сгенерированные сопроводительные примечания, информирующие о том, как правильно использовать файлы комплекта. Например, если шрифты SHX обнаружены в одном из чертежей комплекта, указывается папка, в которую следует скопировать эти файлы, чтобы их можно было найти в системе, в которой установлен комплект файлов. В отчет также включается текст пользовательских примечаний к комплекту.

Сохранить как

Вызов диалогового окна сохранения файлов. Необходимо помнить, что отчет автоматически включается в формируемый комплект, а опция "Сохранить" предназначена для создания дополнительного экземпляра отчета (например, с целью создания архива).


Диалоговое окно "Наборы параметров комплектов"

Ф Команды
Ф Команды
Диалоговое окно "Наборы параметров комплектов"
Понятия Процедуры Команды

Меню "Файл": eTransmit

Ввод команды: формкомплект

Создание, изменение и удаление наборов параметров комплектов файлов.

Параметры комплекта

Список параметров комплекта файлов.

Создать

Создание нового набора параметров.

Имя нового набора параметров

Здесь вводится имя для нового набора параметров комплекта файлов.

На основе

Выбор существующего набора параметров комплекта файлов, на основе которого будет создан новый набор.

Переименовать

Переименование выделенного набора параметров комплекта файлов.

Изменить

Отображает диалоговое окно "Изменение набора параметров комплекта", в котором можно изменять настройки комплекта файлов.

Удалить

Удаление выделенного набора параметров комплекта файлов.

Импорт

Вызывает в контексте подшивки стандартное диалоговое окно выбора файлов, в котором можно перейти к файлу данных подшивки (DST). Затем отображает диалоговое окно "Импорт параметров комплекта", в котором можно указать параметры комплекта для импорта.


Диалоговое окно "Импорт параметров комплекта"

Ф Команды
Ф Команды
Диалоговое окно "Импорт параметров комплекта"
Понятия Процедуры Команды

Меню "Файл": eTransmit

Ввод команды: формкомплект

Импорт выбранных параметров комплекта из указанного файла данных подписки.

Список параметров комплекта

Список параметров комплекта. Выбрать параметры для импорта в текущую подшивку.

Описание

Отображение дополнительного описания, сохраненного вместе с выбранным параметром комплекта.

Место хранения текущей подшивки.

Отображение места хранения текущей подшивки.

Изменить на текущее место хранения

Если выбран этот параметр, места хранения импортируемых подшивок заменяются на места хранения текущих подшивок.

Импорт

Импорт параметров комплекта в список с пометками.


Диалоговое окно "Изменение набора параметров комплекта"

Ф Команды
Ф Команды
Диалоговое окно "Изменение набора параметров комплекта"
Понятия Процедуры Команды

Меню "Файл": eTransmit

Ввод команды: формкомплект

Тип комплекта

Тип формируемого комплекта файлов.

Папка с файлами

Комплект имеет вид набора неупакованных файлов, помещаемых во вновь создаваемую или существовавшую ранее папку.

Самораспаковывающийся EXE-файл

Комплект помещается в архивный самораспаковывающийся файл. Для распаковки этого файла и извлечения всех файлов комплекта достаточно запустить его подобно обычному приложению (например, двойным щелчком мыши).

Zip

Комплект помещается в архивный ZIP-файл. Для распаковки файла необходима программа-архиватор; например, PKZIP или WinZip.

Формат файлов

Указывает формат, в который преобразовываются все включаемые в комплект файлы. В раскрывающемся списке можно выбрать формат файла чертежа.

Папка с файлом комплекта

Задание расположения создаваемого комплекта файлов. В списке представлены последние девять использовавшихся для этого папок. Чтобы задать новую папку, следует нажать кнопку "Обзор" и разыскать папку в структуре диска.

Если оставить это поле пустым, то комплект файлов создается в папке, где хранится первый указанный файл чертежа. При формировании комплекта на основе подшивки комплект файлов создается в папке, где хранится файл данных (DST).

Обзор

Вызов стандартного диалогового окна выбора файлов. В нем следует перейти в папку, в которую должен быть записан формируемый комплект.

Имя файла комплекта

Выбор метода для задания имени комплекта файлов. Под этим полем отображается имя, присваиваемое комплекту по умолчанию. Опция недоступна, если комплект имеет тип "Папка с файлами".

Запрос имени файла

Пользователь вводит имя комплекта в стандартном диалоговом окне выбора файлов.

Имя с возрастанием номера, если необходимо

Используется логическое имя файла, установленное по умолчанию. Если файл с таким именем уже существует, то к концу имени добавляется номер. Этот номер возрастает каждый раз при сохранении нового комплекта.

Заменять, если необходимо

Используется логическое имя файла, установленное по умолчанию. Если файл с таким именем уже существует, то он автоматически перезаписывается.

Опции для комплекта

Настройки для организации файлов и папок, входящих в комплект.

Организованная структура папок

Дублирует структуру папок для файлов формируемого комплекта. Корневой папкой является папка верхнего уровня в иерархическом дереве папок.

При этом выполняются следующие условия:

  • Относительные пути не изменяются. Относительные пути, заданные вне исходной корневой папки, сохраняются вплоть до пути к папке первого уровня над ними и располагаются в корневой папке.
  • Абсолютные пути внутри дерева корневой папки преобразуются в относительные пути. Абсолютные пути сохраняются вплоть до пути к папке первого уровня над ними и располагаются в корневой папке.
  • Абсолютные пути вне дерева корневой папки преобразуются в пути к корневой папке или к папке внутри дерева корневой папки.
  • При необходимости создается папка Fonts.
  • При необходимости создается папка <f "italic">PlotCfgs</f>.
  • При необходимости создается папка SheetSets для хранения в ней всех вспомогательных файлов подшивок. Однако сам файл данных подшивки (DST) располагается в корневой папке.

Эта опция недоступна, если комплект сохраняется где-либо в Интернете.

Корневая папка

Определяет корневую папку для относительных путей зависимых от чертежей файлов, таких как внешние ссылки.

В корневую папку при формировании комплекта из подшивки также заносится файл данных подшивки (DST).

Обзор

Вызов стандартного диалогового окна выбора файлов, в котором пользователь может определить корневую папку.

Все файлы в одной папке

При создании комплекта все файлы собираются в одной папке.

Текущая структура файлов и папок

В комплекте сохраняется структура папок всех файлов. Это упрощает процесс их переноса на другие компьютеры. Эта опция недоступна, если комплект сохраняется где-либо в Интернете.

Включить шрифты

Включает в комплект файлов все ассоциированные файлы шрифтов (TTF и SHX).

Примечание Так как шрифты TrueType не являются общедоступными, важно убедиться, что получатель комплекта файлов имеет шрифты TrueType. Если это точно не известно, опцию следует отключить. Все отсутствующие на компьютере получателя шрифты TrueType будут подменены в соответствии со значением системной переменной FONTALT.

Включить текстуры из материалов

Позволяет отнести текстуры к материалам, присоединяемым к объектам или граням.

Отправить электронное уведомление

Запуск используемой по умолчанию программы работы с электронной почтой при создании комплекта файлов, чтобы отправить сообщение с комплектом файлов в качестве приложения.

"Без плоттера" по умолчанию

Замена настроенного принтера/плоттера для комплекта файлов на пустое устройство. Локальный принтер/плоттер, как правило, не совпадает с установленным у адресата.

Внедрить внешние ссылки

Внедрение всех внешних ссылок в файлы, в которые они вставлены.

Запрос пароля

Вызов диалогового окна "Комплект файлов задание пароля", предназначенного для защиты комплекта файлов с помощью пароля.

Включить данные и файлы подшивки

Включение в комплект файла данных подшивки (DST), файлов чертежей блоков марок и идентификаторов (DWG), а также файлов шаблонов чертежей (DWT).

Пояснение к набору параметров

Здесь вводится текст пояснения к набору. Пояснение к текущему набору отображается в окне "Формирование комплекта файлов" под списком наборов параметров. Для получения описания любого параметра комплекта можно выбрать этот параметр в списке.


Диалоговое окно "Комплект файлов задание пароля"

Ф Команды
Ф Команды
Диалоговое окно "Комплект файлов задание пароля"
Понятия Процедуры Команды

Меню "Файл": eTransmit

Ввод команды: формкомплект

Пароль на комплект файлов

Возможность (не обязательная) задания пароля для доступа к формируемому комплекту файлов. Если пароль установлен, пользователи, пытающиеся воспользоваться данным комплектом, должны будут ввести пароль. Защита паролем неприменима к типу комплекта "Папка с файлами".

Повторный пароль для подтверждения

Здесь нужно повторно ввести пароль, заданный в поле "Пароль на комплект файлов". Если два пароля не совпадают, программа требует ввести их заново.


ФОРМКОМПЛЕКТ вариант для командной строки

Ф Команды
Ф Команды
ФОРМКОМПЛЕКТ вариант для командной строки
Понятия Процедуры Команды

Если в ответ на подсказку "Команда" ввести -формкомплект, будет вызван вариант команды ФОРМКОМПЛЕКТ, при котором в командной строке выводятся подсказки.

Задать опцию [Создать комплект/Только отчет/Текущий набор параметров/Выбрать набор параметров/Подшивка> <Только отчет>: Задать опцию

Только отчет

Создание только файла отчета (TXT), без создания комплекта файлов. Файл отчета строится с учетом текущего набора параметров.

Текущий набор параметров

Отображение имени текущего набора параметров комплекта файлов.

Выбрать набор параметров

Выбор набора параметров для формируемого комплекта файлов.

Выбрать набор параметров комплекта или [?] <текущий>: Ввести стандартное имя параметра комплекта, ввести ? для вывода на экран списка имеющихся параметров комплекта, или нажать клавишу ENTER

Подшивка

Выбор подшивки и набора параметров для комплекта файлов. Опция доступна, только если открыта какая-либо подшивка.

Имя подшивки или [?] <текущее>: Ввести стандартное имя подшивки, ввести ? для вывода на экран списка имеющихся подшивок, или нажать клавишу ENTER

Выбрать набор параметров комплекта или [?] <текущий>: Ввести стандартное имя параметра комплекта, ввести ? для вывода на экран списка имеющихся параметров комплекта, или нажать клавишу ENTER


Ц Команды
  • Цвет
  • ЦИЛИНДР
  • ЦУВКЛ
  • ЦУОТКЛ
  • ЦУПЕРЕЙТИ


Цвет Команда

Ц Команды
Ц Команды
Цвет Команда
Понятия Процедуры Команды

Установка цвета для вновь создаваемых объектов

Меню "Формат": "Цвет"

Ввод команды: цвет (или 'цвет для прозрачного вызова)

Откроется диалоговое окно "Выбор цвета".

Если в ответ на подсказку "Команда" ввести -цвет, то команда ЦВЕТ будет выводить подсказки в командную строку.

Темы:

  • Диалоговое окно "Выбор цвета"
  • Вкладка "Номер цвета" (диалоговое окно "Выбор цвета")
  • True Color Tab (Select Color Dialog Box)
  • Вкладка "Альбомы цветов" (диалоговое окно "Выбор цвета")
  • ЦВЕТ- вариант для командной строки


Диалоговое окно "Выбор цвета"

Ц Команды
Ц Команды
Диалоговое окно "Выбор цвета"
Понятия Процедуры Команды

Меню "Формат": "Цвет"

Ввод команды: цвет (или 'цвет для прозрачного вызова)

Определяет цвет объектов. Можно выбрать цвет для элементов окна из числа 255 цветов, входящих в Индекс цветов AutoCAD (ИЦА), а также из всей палитры или из альбома цветов.

Диалоговое окно "Выбор цвета" имеет следующие вкладки:

  • Номер цвета
  • Вся палитра
  • Альбомы цветов

Темы:

  • Вкладка "Номер цвета" (диалоговое окно "Выбор цвета")
  • True Color Tab (Select Color Dialog Box)
  • Вкладка "Альбомы цветов" (диалоговое окно "Выбор цвета")


Вкладка "Номер цвета" (диалоговое окно "Выбор цвета")

Ц Команды
Ц Команды
Вкладка "Номер цвета" (диалоговое окно "Выбор цвета")
Понятия Процедуры Команды

Задание цвета из числа 255, входящих в Индекс цветов AutoCAD.

Палитры индекса цветов AutoCAD (ACI)

Задание цвета для с помощью Индекса цветов AutoCAD. При наведении курсора на цвет ниже палитры отображается его номер, а также значения красного, зеленого и голубого. Нажать кнопку мыши на цвете для его выбора или ввести в поле "Цвет" его имя или числовое значение.

В большую палитру входят цвета с номерами от 10 до 249.

Во вторую палитру входят цвета с номерами от 1 до 9. У этих цветов помимо номеров имеются также и имена.

В третью палитру входят цвета с номерами от 250 до 255; эти цвета представляют собой оттенки серого.

Номер цвета

Показывает номер цвета при наведении на него курсора.

Красный, зеленый, синий

Показывает значение цвета в системе RGB при наведении на него курсора.

ПоСлою

Указывает, что новым объектам присваивается цвет, назначенный слою, на котором они создаются. При выборе команды ПОСЛОЮ цвет текущего слоя отображается в образцах старого и нового цветов.

ПоБлоку

Указывает, что новые объекты имеют цвет по умолчанию (белый или черный, в зависимости от конфигурации) до тех пор, пока они не будут объединены в блок. При вставке блока в чертеж все его объекты принимают цвет блока.

Примечание Параметры ПОСЛОЮ и ПОБЛОКУ не применяются в команде СВЕТ.

Цвет

Задает имя цвета, цвет ПОСЛОЮ или ПОБЛОКУ или номер индекса цвета AutoCAD (ACI) от 1 до 255. Последний выбранный цвет отображается на образце нового цвета.

Образец старого цвета

Отображает последний выбранный цвет.

Образец нового цвета

Отображает цвет, выбранный в настоящий момент.


True Color Tab (Select Color Dialog Box)

Ц Команды
Ц Команды
True Color Tab (Select Color Dialog Box)
Понятия Процедуры Команды

Задание цвета из полной палитры цветов (True Color, 24-битные цвета). Цвет выбирается с помощью цветовой модели HSL (оттенок, насыщенность, яркость) или RGB (красный, зеленый, синий). Полная палитра содержит более 16 миллионов цветов. В зависимости от выбранной цветовой модели на вкладке "Вся палитра" доступны различные опции.

Цветовая модель HSL

Указывает цветовую модель HSL для выбора цветов.

Оттенок, насыщенность и яркость являются свойствами цветов. Изменяя значения этих свойств, можно задать огромное количество цветов.

Оттенок (H)

Значение оттенка цвета. Оттенок представляет собой определенную длину волны света внутри видимого спектра. Чтобы задать оттенок, используйте цветовой спектр или ввести значение в поле "Оттенок". Изменение этого значения влияет на значение цвета в модели RGB. Допустимые значения оттенка лежат в пределах от 0 до 360 градусов.

Насыщенность (S)

Значение чистоты цвета. При высокой насыщенности цвет выглядит более чистым, в то время как при низкой насыщенности цвет выглядит "полинявшим". Чтобы задать насыщенность цвета, используйте цветовой спектр или ввести значение в поле "Насыщенность". Изменение этого значения влияет на значение цвета в модели RGB. Допустимые значения насыщенности лежат в пределах от 0 до 100%.

Яркость (L)

Значение яркости цвета. Чтобы задать яркость цвета, используйте указатель или ввести значение в поле "Яркость". Допустимые значения яркости лежат в пределах от 0 до 100%. При значении яркости 0% цвет становится черным, 100% белым. Оптимальное значение яркости цвета 50%. Изменение этого значения также влияет на значение цвета в модели RGB.

Цветовой спектр

Указывает оттенок и чистоту цвета. Чтобы задать оттенок, переместите перекрестие из стороны в сторону над цветовым спектром. Чтобы задать насыщенность цвета, нужно переместить перекрестие сверху вниз над цветовым спектром.

Указатель шкалы цвета

Значение яркости цвета. Чтобы задать яркость цвета, нужно переместить указатель или ввести значение в соответствующее поле.

Цветовая модель RGB

Указывает цветовую модель RGB для выбора цветов. В зависимости от выбранной цветовой модели на вкладке "Вся палитра" доступны различные опции.

Любой цвет можно разбить на три составляющие: красный (R), зеленый (G) и синий (B). Значения этих составляющих представляют собой интенсивность красного, зеленого и синего компонентов цвета. Изменяя значения этих трех компонентов, можно задать огромное количество цветов.

Красный

Задание красной составляющей цвета. Значение задается перемещением ползунка или путем ввода числа от 1 до 255 в соответствующее поле. Изменение значения зеленой составляющей цвета отражается на значениях компонентов цветовой модели HSL.

Зеленый

Задание зеленой составляющей цвета. Значение задается перемещением ползунка или путем ввода числа от 1 до 255 в соответствующее поле. Изменение значения зеленой составляющей цвета отражается на значениях компонентов цветовой модели HSL.

Синий (B)

Задание синей составляющей цвета. Значение задается перемещением ползунка или путем ввода числа от 1 до 255 в соответствующее поле. Изменение значения зеленой составляющей цвета отражается на значениях компонентов цветовой модели HSL.

Цвет

Значение цвета в модели RGB. Данное значение обновляется при изменении значения любого компонента моделей HSL и RGB. Значение цвета в модели RGB можно редактировать напрямую, используя следующий формат: 000,000,000.

RGB-компоненты цвета из полной палитры

Значения всех трех составляющих модели RGB.

Образец старого цвета

Отображает последний выбранный цвет.

Образец нового цвета

Отображает цвет, выбранный в настоящий момент.


Вкладка "Альбомы цветов" (диалоговое окно "Выбор цвета")

Ц Команды
Ц Команды
Вкладка "Альбомы цветов" (диалоговое окно "Выбор цвета")
Понятия Процедуры Команды

Задает цвета, используя альбомы сторонних разработчиков (таких как PANTONE®) альбомы, заданные пользователем. Имя выбранного альбома цветов отображается на вкладке "Альбомы цветов".

Альбом

Выбор альбома цветов, который будет использоваться для задания цвета. В список включены все альбомы цветов, которые были найдены в папках для альбомов цветов, заданных в диалоговом окне "Параметры" вкладки "Файлы".

Отображает страницы выбранного альбома цветов, а также цвета и имена цветов на каждой странице. Поддерживаются альбомы цветов, содержащие до десяти цветов на страницу. Если страницы альбома цветов не пронумерованы, отображается по семь цветов на странице. Для просмотра содержимого альбома следует выбрать нужную цветовую область на шкале цветов или перемещаться по страницам альбома с помощью кнопок со стрелками.

RGB-эквивалент

Значения всех трех составляющих модели RGB.

Цвет

Имя выбранного в настоящий момент цвета из альбома. Можно выполнить поиск определенного цвета в альбоме цветов посредством ввода номера образца цвета и нажатия клавиши TAB. При этом значение в поле нового образца цветов меняется на указанное. Если указанный цвет не найден в альбоме цветов, отображается ближайший к нему по номеру.

Образец старого цвета

Отображает последний выбранный цвет.

Образец нового цвета

Отображает цвет, выбранный в настоящий момент.


ЦВЕТ- вариант для командной строки

Ц Команды
Ц Команды
ЦВЕТ- вариант для командной строки
Понятия Процедуры Команды

Если в ответ на подсказку "Команда:" ввести -цвет, команда ЦВЕТ будет выводить подсказки в командную строку.

Ввести цвет объекта по умолчанию [изПалитры/Альбом]<ПОСЛОЮ>: Ввести цвет, нажать t, ввести co или нажать ENTER

Пользователь может задать цвет по индексу цветов AutoCAD, цвет из палитры или альбома цветов.

Необходимо задать номер цвета (в диапазоне от 1 до 255) или стандартное название цвета (для первых семи цветов). Например, чтобы задать красный цвет, можно ввести либо 1 (его номер по ИЦА), либо имя красный.

Допустимыми именами цветов являются также послою и поблоку. При вводе поблоку все новые объекты рисуются цветом, установленном по умолчанию (белым или черным, в зависимости от цвета фона) до тех пор, пока они не будут объединены в блок. При вставке блока в чертеж все объекты блока принимают ЦВЕТ, соответствующий значению текущей установки .

Предупреждение Если объектам блока задать смешанные цвета, вставка этого блока или изменении цвета приведет к непредсказуемым результатам.

Ввод послою указывает, что новым объектам присваивается цвет, назначенный слою, на котором они создаются. О назначении цветов слоям см. команду СЛОЙ.

Из палитры

Выбор цвета для выбранного объекта из палитры всех цветов (true color).

Компоненты R,G,B: Ввести три разделенных запятыми значения от 0 до 255

Альбом

Выбор цвета для выбранного объекта из загруженного альбома цветов.

Имя альбома цветов: Ввести имя установленного альбома цветов, например, Pantone

Если пользователь ввел имя альбома цветов, ему будет предложено ввести имя цвета из этого альбома.

Имя цвета: Ввести имя цвета из этого альбома, например, Pantone 573


ЦИЛИНДР Команда

Ц Команды
Ц Команды
ЦИЛИНДР Команда
Понятия Процедуры Команды

Создает трехстороннее 3D тело с окружностью или эллипсом в основании и на верхней грани

Панель "Моделирование":

Меню "Рисование": подменю "Моделирование" » Цилиндр

Ввод команды: цилиндр

Пульт управления: Панель "3D Make", "Цилиндр"

Задать точку центра основания или [3Т/2Т/Ккр/Эллиптический]: Задать точку (1) или ввести опцию

Задать радиус основания или [Диаметр] <значение по умолчанию>: Задать радиус основания или ввести d, чтобы задать диаметр, или нажать ENTER, чтобы задать значение радиуса основания по умолчанию

Задать высоту или [2Точки/Конечная точка оси] <значение по умолчанию>: Задать высоту (2), ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение радиуса по умолчанию не установлено. В ходе сеанса построения значением радиуса основания по умолчанию всегда является предварительно введенное значение радиуса основания для любого элементарного тела.

3Т (Три точки)

Определяет длину окружности основания и базовую плоскость цилиндра с помощью задания трех точек.

Первая точка: Указать точку

Вторая точка: Указать точку

Задать третью точку: Указать точку

Задать высоту или [2Точки/Конечная точка оси] <значение по умолчанию>: Задать высоту, ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение высоты по умолчанию не установлено. В ходе сеанса построения значением высоты по умолчанию всегда является предварительно введенное значение высоты для любого элементарного тела.

2Точки

Указывает, что высотой цилиндра является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси цилиндра. Эта конечная точка является точкой центра верхней грани цилиндра. Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию цилиндра.

Задать конечную точку оси: Задать точку

2Т (Две точки)

Определяет диаметр основания цилиндра путем указания двух точек.

Указать первую конечную точку диаметра: Указать точку

Указать вторую конечную точку диаметра: Указать точку

Задать высоту или [2Point/Конечная точка оси] <значение по умолчанию>: Задать высоту, ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение высоты по умолчанию не установлено. В ходе сеанса построения значением высоты по умолчанию всегда является предварительно введенное значение высоты для любого элементарного тела.

2Точки

Указывает, что высотой цилиндра является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси цилиндра. Эта конечная точка является точкой центра верхней грани цилиндра. Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию цилиндра.

Задать конечную точку оси: Задать точку

ККР (Касательная, Касательная, Радиус)

Определяет основание цилиндра по задаваемым касательным к двум объектам.

Указать точку на объекте для первой касательной: Выбрать точку на объекте

Указать точку на объекте для второй касательной: Выбрать точку на объекте

Указать радиус основания <по умолчанию>: Задать значение радиуса основания или нажать ENTER, чтобы задать значение по умолчанию

В некоторых случаях заданным критериям соответствует несколько оснований. Программа вычерчивает основание заданного радиуса, точки касания которого расположены ближе всего к выбранным точкам.

Задать высоту или [2Точки/Конечная точка оси] <значение по умолчанию>: Задать высоту, ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение высоты по умолчанию не установлено. В ходе сеанса построения значением высоты по умолчанию всегда является предварительно введенное значение высоты для любого элементарного тела.

2Точки

Указывает, что высотой цилиндра является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси цилиндра. Эта конечная точка является точкой центра верхней грани цилиндра. Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию цилиндра.

Задать конечную точку оси: Задать точку

Эллиптический

Задает эллиптическое основание цилиндра.

Задает конечную точку первой оси или [Центр]: Задать точку (1)

Задать вторую конечную точку первой оси: Задать точку

Задать конечную точку второй оси: Задать точку

Задать высоту или [2Точки/Конечная точка оси] <значение по умолчанию>: Задать высоту, ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение высоты по умолчанию не установлено. В ходе сеанса построения значением высоты по умолчанию всегда является предварительно введенное значение высоты для любого элементарного тела.

Центр

Создает основание цилиндра по заданной точке центра.

Задать точку центра: Задать точку

Задать расстояние до первой оси <значение по умолчанию>: Задать расстояние или нажать ENTER, чтобы задать значение расстояния по умолчанию

Задать конечную точку второй оси: Задать точку

Задать высоту или [2Точки/Конечная точка оси] <значение по умолчанию>: Задать высоту, ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение высоты по умолчанию не установлено. В ходе сеанса построения значением высоты по умолчанию всегда является предварительно введенное значение высоты для любого элементарного тела.

2Точки

Указывает, что высотой цилиндра является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси цилиндра. Эта конечная точка является точкой центра верхней грани цилиндра. Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию цилиндра.

Задать конечную точку оси: Задать точку

Диаметр

Определяет диаметр основания цилиндра.

Задать диаметр <значение по умолчанию>: Задать диаметр или нажать ENTER, чтобы задать значение по умолчанию

Первоначально значение диаметра по умолчанию не установлено. В ходе сеанса построения значением диаметра по умолчанию всегда является предварительно введенное значение диаметра для любого элементарного тела.

Задать высоту или [2Точки/Конечная точка оси] <значение по умолчанию>: Задать высоту(2), ввести опцию или нажать ENTER, чтобы задать значение высоты по умолчанию

Первоначально значение высоты по умолчанию не установлено. В ходе сеанса построения значением высоты по умолчанию всегда является предварительно введенное значение высоты для любого элементарного тела.

2Точки

Указывает, что высотой цилиндра является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси цилиндра. Эта конечная точка является точкой центра верхней грани цилиндра. Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию цилиндра.

Задать конечную точку оси: Задать точку

2Точки

Указывает, что высотой цилиндра является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку

Конечная точка оси

Задает положение конечной точки для оси цилиндра. Эта конечная точка является точкой центра верхней грани цилиндра. Конечная точка оси может быть расположена в любой точке 3D пространства. Конечная точка оси определяет длину и ориентацию цилиндра.

Задать конечную точку оси: Задать точку


ЦУВКЛ Команда

Ц Команды
Ц Команды
ЦУВКЛ Команда
Понятия Процедуры Команды

Управление содержимым блоками, внешними ссылками и образцами штриховки

Панель Стандартная

Меню "Сервис": "Палитры" » "Центр управления"

Ввод команды: цувкл

Откроется DesignCenter.

Темы:

  • DesignCenter
  • Диалоговое окно "Поиск"


DesignCenter

Ц Команды
Ц Команды
DesignCenter
Понятия Процедуры Команды

Панель Стандартная

Меню "Сервис": "DesignCenter"

Ввод команды: цувкл

Осуществляет поиск и предварительный просмотр содержимого чертежей. Используется также для вставки элементов, в том числе внешних ссылок, в текущий чертеж.

Для доступа к различным функциям DesignCenter используются кнопки панели инструментов, расположенные в верхней части его окна.

При переходе на вкладку "Папки" или "Открытые чертежи" диалоговое окно Центра управления разделяется на две области.

  • Область содержимого (правая панель)
  • Область структуры (левая панель)

Палитра (DesignCenter)

Показывает содержимое текущего элемента зоны структуры. Этот элемент называется "контейнером". В качестве контейнера могут выступать домены и рабочие группы сети, компьютеры, жесткие диски компьютеров и папки на них, файлы или web-адреса (URL), содержащие информацию, доступную для DesignCenter. В зависимости от того, что используется в качестве контейнера, палитра может содержать следующее:

  • папки с чертежами и другими файлами
  • чертежи
  • именованные объекты в чертежах (именованные объекты включают в себя блоки, внешние ссылки, листы, слои, размерные и текстовые стили)
  • образцы блоков и штриховки
  • содержимое специализированных Web-сайтов
  • сторонние объекты, созданные другими приложениями

С помощью палитры можно вставлять блоки, образцы штриховок и внешние ссылки. Для этого нужно выбрать элемент палитры, нажать правую кнопку мыши и выбрать соответствующий элементу пункт контекстного меню. Можно просто перетащить любой элемент палитры в область чертежа. Таким образом, в чертеж можно добавить слои, размерные стили, листы. Пользователь может добавить блоки и образцы штриховок не только в чертеж, но и на инструментальные палитры. Для этого нужно перетащить эти элементы с помощью мыши.

Примечание Контекстные меню доступны как в палитре, так и в области структуры.

Загрузить

Отображает диалоговое окно "Выбор файла" (стандартное диалоговое окно выбора файлов). Окно позволяет выбрать файл на жестком диске компьютера или на компьютере, доступном через локальную сеть или Web. Выбранный файл загружается в палитру DesignCenter.

Назад

Возврат к предыдущему элементу (его выбор). Пользователь также может перейти к любому из элементов, занесенных в хронологический список.

Вперед

Переход к следующему элементу (его выбор). Пользователь также может перейти к любому из элементов, занесенных в хронологический список.

Вверх

Переход на один уровень вверх в зоне структуры.

Останов (вкладка "Интернет")

Остановка загрузки содержимого сайта.

Обновить (вкладка "Интернет")

Повторение загрузки текущей страницы.

Поиск

Отображает диалоговое окно "Поиск", в котором указываются критерии поиска чертежей, блоков и неграфических объектов внутри чертежей.

Допускается и поиск сторонних приложений.

Избранное

Заполнение палитры содержимым папки Избранное. Папка Избранное содержит ярлыки для доступа к часто используемым объектам. Элементы можно добавить в папку Избранное, нажав правую кнопку мыши в области содержимого или элемент в области структуры и выбрав в контекстном меню "Добавить в Избранное". Чтобы удалить элемент из папки Избранное, в контекстном меню для параметра "Упорядочить Избранное" нужно выбрать "Обновить".

Примечание Папка Центр управления добавляется в "Избранное" автоматически. Эта папка содержит чертежи, включающие в себя отраслевые блоки, которые пользователь может вставить в свои чертежи.

Домой

Вывод в палитру содержимого базовой папки. Эта функция аналогична возврату на домашнюю страницу в браузере. При установке для основной папки задается следующий путь ...\Sample\DesignCenter. Пользователь может изменить базовую папку с помощью контекстного меню зоны структуры.

Зона структуры

Отображение и скрытие зоны структуры. Если отказаться от показа зоны структуры, больше места окажется отведенным под палитру. При этом для навигации и загрузки содержимого можно пользоваться элементами управления палитры.

Кнопка "Зона структуры" недоступна при использовании вкладки "Журнал".

Предварительный просмотр

Отображение и скрытие области предварительного просмотра, расположенной в области палитры. Если у элемента нет образца для просмотра, зона просмотра остается пустой.

Описание

Отображение и скрытие области пояснений, расположенной в области палитры. Если область просмотра включена, пояснения располагаются под ней. Если у элемента нет пояснения, область пояснений остается пустой.

Виды

Выбор режимов просмотра элементов содержимого, загруженных в палитру. Нужный режим можно выбрать из выпадающего списка. Установленный по умолчанию режим просмотра зависит от того, что именно загружено в палитру.

Крупные значки

Показ крупных значков, соответствующих загруженным элементам палитры.

Мелкие значки

Показ мелких значков, соответствующих загруженным элементам палитры.

Список

Показ загруженных элементов палитры в виде списка.

Таблица

Показ дополнительных сведений о загруженных элементах палитры. Режим позволяет сортировать элементы по имени, размеру, типу и другим свойствам (в зависимости от типа содержимого, загруженного в палитру).

Обновить (только в контекстном меню)

Обновление палитры после внесения изменений. Следует нажать правую кнопку мыши на заднем фоне зоны содержимого и выбрать пункт "Обновить" из контекстного меню.

Зона структуры (DesignCenter)

В зоне структуры может отображаться дерево папок и файлов на локальном или сетевом диске, содержимое открытых чертежей, элементы сторонних приложений, и список элементов, которые выбирались хотя бы один раз. Выбор элемента в зоне структуры приводит к отображению его содержимого в палитре.

Примечание Папка sample\designcenter содержит чертежи с отраслевыми блоками, которые пользователь может вставлять в свои чертежи. Набор этих чертежей называется библиотекой компонентов.

Ниже панели управления находятся вкладки, с помощью которых можно управлять представлением зоны структуры на экране.

Папки

Отображение иерархии папок и файлов на локальном или сетевом диске (включая папки "Мой компьютер" и "Сетевое окружение").

Для перемещения в области структуры Центра управления к конкретному файлу, папке или сетевому ресурсу можно воспользоваться командой ЦУПЕРЕЙТИ. См. описание команды ЦУПЕРЕЙТИ.

Открытые чертежи

Отображает все чертежи, открытые в текущем сеансе, включая свернутые чертежи.

Журнал

Отображение списка файлов, открывавшихся в DesignCenter хотя бы один раз. С помощью контекстного меню пользователь может загрузить в палитру или удалить любой элемент журнала.

Интернет

Загрузка Интернет-модуля DesignCenter. После подключения к Интернету загружается начальная страница, содержащая две области. Левая область содержит библиотеки компонентов и ссылки на сайты производителей. При выборе любого элемента в левой области этот элемент отображается в правой области диалогового окна Центра управления. Пользователь может загрузить выбранный элемент и вставить его в чертеж.


Диалоговое окно "Поиск"

Ц Команды
Ц Команды
Диалоговое окно "Поиск"
Понятия Процедуры Команды

Панель "Стандартная"

Меню "Сервис": "DesignCenter"

Ввод команды: цувкл

Окно используется для поиска чертежей и их содержимого образцов штриховок, блоков и т.п.

Что искать

Тип содержимого для поиска. От типа содержимого, выбранного в списке "Что искать", зависит набор вкладок и полей поиска, отображаемых в диалоговом окне поиска. Вкладки "Дата изменения" и "Дополнительно" присутствуют в окне только в том случае, когда производится поиск файлов (чертежей, образцов штриховки и т.п.)

Путь поиска

Задает имя пути поиска. Можно задать несколько путей, разделяя их точками с запятой. Для выбора пути с помощью диалогового окна следует воспользоваться кнопкой "Обзор".

Обзор

Вызов диалогового окна "Обзор папок", в котором можно выбрать папку для поиска.

Просматривать вложенные папки

Поиск осуществляется также во вложенных в выбранную папку папках.

Искать

Начало выполнения поиска.

Остановить

Останов поиска. Элементы, найденные до останова, отображаются на панели результатов.

Новый поиск

Очистка поля "Искать слова" и установка курсора в это поле.

Таблица результатов поиска

Отображает результаты поиска в столбцах в нижней части окна, ширину которых можно изменять. Чтобы загрузить элемент в DesignCenter, следует дважды нажать на нем кнопку мыши.

Вкладки критериев поиска

Отображают поля задания критериев поиска, соответствующие типу содержимого, выбранному из списка "Что искать". Тип содержимого отображается в имени вкладки. При задании критериев поиска можно использовать глобальные символы.

Искать слова

Текстовая строка, поиск которой будет осуществлен. Чтобы расширить границы поиска, можно использовать символы-шаблоны - звездочку и знак вопроса.

  • * (Звездочка): соответствует любой последовательности символов. Может использоваться в любой позиции строки.
  • ? (Знак вопроса): соответствует любому одиночному символу; например, ?BC соответствует ABC, 3BC и т.п.

Опция доступна только на вкладках "Чертежи" и "Сторонние приложения".

В полях

Поля, в которых должен производиться поиск. Для чертежей все значения дополнительных полей (т.е. всех, кроме поля "Имя файла") извлекаются из свойств чертежа с помощью команды ОПЦИИМТФ.

Опция доступна только на вкладках "Чертежи" и "Сторонние приложения".

Примечание Не все сторонние приложения могут обеспечивать возможность поиска своих объектов по значениям текстовых полей.

Искать имя

Здесь задается имя чертежа, блока, слоя, внешней ссылки или другого элемента содержимого для поиска.

Опция доступна на всех вкладках, кроме вкладок "Чертежи" и "Сторонние приложения".

Вкладка "Дата изменения" (диалоговое окно "Поиск")

Поиск содержимого, которое было создано или изменено в течение заданного промежутка времени.

Все файлы

Поиск всех файлов, соответствующих заданным на других вкладках критериям (независимо от дат создания или изменения). Данная опция используется по умолчанию.

Все файлы, созданные или измененные

Поиск файлов, созданных или измененных в течение заданного промежутка времени. Данный критерий действует совместно с критериями, заданными на других вкладках.

Между

Поиск файлов, созданных или измененных в промежутке между двумя указанными датами.

За последние N месяцев

Поиск файлов, созданных или измененных за последние несколько месяцев (количество месяцев задается пользователем).

За последний день (дни)

Поиск файлов, созданных или измененных за последние несколько дней (количество дней задается пользователем).

Вкладка "Дополнительно" (диалоговое окно "Поиск")

Находит содержание внутри чертежей; эта вкладка будет доступна, только если выбрать "Чертежи" в списке "Что искать".

Содержащие

Тип содержимого чертежа, текст которого должен являться дополнительным критерием поиска. Например, можно осуществить поиск по значениям атрибутов блоков (кодам изготовителей и т.п.).

С текстом

Задание текстовой строки для поиска.

Размер

Минимальный или максимальный размер файла. Следует задать способ сравнения ("Не менее" или "Не более"), а затем ввести пороговое значение размера (в Кб).


ЦУОТКЛ Команда

Ц Команды
Ц Команды
ЦУОТКЛ Команда
Понятия Процедуры Команды

Закрывает DesignCenter (Центр управления)

Ввод команды: цуоткл

Команда закрывает диалоговое окно Центра управления (DesignCenter™).


ЦУПЕРЕЙТИ Команда

Ц Команды
Ц Команды
ЦУПЕРЕЙТИ Команда
Понятия Процедуры Команды

Загружает указанный файл чертежа, папку или сетевой путь DesignCenter

Ввод команды: цуперейти

Ввести путь <текущий>:

Заданный путь или чертеж становится текущим в списке папок зоны структуры DesignCenter.

В ответ на запрос можно ввести:

  • Путь к папке : c:\project files\electrical
  • Путь к папке и имя файла: c:\project files\electrical\circuit2.dwg
  • Сетевой путь в формате UNC (по соглашению об универсальном именовании): \\server1\campus_project

При этом отображается DesignCenter с активной вкладкой "Папки" и происходит переход к указанному файлу или папке.

ЦУПЕРЕЙТИ поддерживает доступ к удаленным доменам и рабочим группам. Для доступа необходимо, чтобы они были подключены к компьютеру как сетевые диски (с назначением букв).


Ч Команды
  • ЧИСТЭКРВКЛ
  • ЧИСТЭКРОТКЛ


ЧИСТЭКРВКЛ Команда

Ч Команды
Ч Команды
ЧИСТЭКРВКЛ Команда
Понятия Процедуры Команды

Убирает с экрана панели инструментов и закрепляемые окна (за исключением командной строки)

Меню "Вид": "Чистый экран"

Ввод команды: чистэкрвкл

На экране отображается только строка меню, вкладки "Модель" и "Лист" в нижней части чертежа, строка состояния и командная строка. Чтобы восстановить все элементы интерфейса, кроме строки меню, строки состояния и командной строки, следует воспользоваться командой ЧИСТЭКРОТКЛ. Одновременное нажатие клавиш CTRL и 0 (ноль) используется для переключения между командами ЧИСТЭКРВКЛ и ЧИСТЭКРОТКЛ. В правом нижнем углу окна приложения имеется кнопка очистки экрана.


ЧИСТЭКРОТКЛ Команда

Ч Команды
Ч Команды
ЧИСТЭКРОТКЛ Команда
Понятия Процедуры Команды

Восстанавливает отображение панели инструментов и закрепляемых окон (за исключением командной строки)

Меню "Вид": "Чистый экран"

Ввод команды: чистэкроткл

Восстановление состояния экрана после применения команды ЧИСТЭКРВКЛ. Команда ЧИСТЭКРВКЛ используется для очистки экрана от панелей инструментов и закрепляемых окон (за исключением командной строки) Одновременное нажатие клавиш CTRL и 0 (ноль) используется для переключения между командами ЧИСТЭКРВКЛ и ЧИСТЭКРОТКЛ. В правом нижнем углу окна приложения имеется кнопка очистки экрана.


Ш Команды
  • ШАГ
  • ШАР
  • ШТЕМПЕЛЬ
  • ШТРИХ


ШАГ Команда

Ш Команды
Ш Команды
ШАГ Команда
Понятия Процедуры Команды

Ограничение перемещения курсора определенными интервалами

Строка состояния: "Шаговая привязка"

Ввод команды: шаг (или 'шаг для вызова в прозрачном режиме)

Шаг привязкиШаг привязки или [Вкл/Выкл/Аспект/Rotate/Стиль/Тип] <текущий>: Указать расстояние, задать опцию или нажать ENTER

Шаг привязки

Включает режим "Шаг" и устанавливает заданное значение интервала.

Вкл

Включение режима привязки на основе параметров сетки привязки.

Откл

Отключает режим шаговой привязки; параметры привязки при этом сохраняются.

Аспект

Позволяет задавать различные интервалы шаговой привязки по X и по Y. Если включен изометрический стиль шаговой привязки, опция "Аспект" отсутствует.

Шаг по горизонтали <текущий>: Задать расстояние или нажать ENTER

Шаг по вертикали <текущий>: Задать расстояние или нажать ENTER

Поворот

Поворачивает сетку шаговой привязки относительно чертежа и экрана. Угол поворота измеряется в текущей ПСК. Угол поворота может быть задан в диапазоне от –90 до 90 градусов. Задание положительного угла означает поворот вокруг базовой точки против часовой стрелки. Задание отрицательного угла означает поворот по часовой стрелке.

Базовая точка <текущая>: Указать точку или нажать ENTER

Угол поворота <текущий>: Задать угол или нажать ENTER

Стиль

Позволяет задавать стандартный и изометрический стиль шаговой привязки.

Стиль шаговой привязки [Стандартный/Изометрический] <текущий>: Ввести с или и, либо нажать ENTER

Стандартный

Установка прямоугольной сетки шаговой привязки, параллельной плоскости XY текущей ПСК. Ячейка может иметь разные размеры по X и Y.

Шаг привязки или [Аспект] <текущий>: Указать расстояние, ввести а или нажать ENTER

Интервал

Значение шага привязки.

Аспект

Позволяет задать ширину ячейки сетки, отличную от ее высоты.

Шаг по горизонтали <текущий>: Задать расстояние или нажать ENTER

Шаг по вертикали <текущий>: Задать расстояние или нажать ENTER

Изометрический

Установка сетки изометрической привязки, в которой положения привязки изначально располагаются под углами 30 и 150 градусов. В случае изометрической привязки параметр "Аспект" не может принимать разные значения. Линейчатая сетка не совпадает с изометрической сеткой привязки.

Шаг по вертикали <текущий>: Задать расстояние или нажать ENTER

Команда ISOPLANE устанавливает, лежит ли перекрестье курсора в верхней (углы 30 и 150 градусов), левой (углы 90 и 150 градусов) или правой (углы 30 и 90 градусов) изометрической плоскости.

Тип

Задание типа привязки - полярная или прямоугольная. Этот параметр также контролируется системной переменной SNAPTYPE.

Полярная

Привязка в соответствии с углами полярного отслеживания, заданными в системной переменной POLARANG.

Сетка

Привязка к прямоугольной (или изометрической) сетке. При задании точек перемещение курсора привязывается к горизонтальным и вертикальным точкам сетки.


ШАР Команда

Ш Команды
Ш Команды
ШАР Команда
Понятия Процедуры Команды

Создание 3D тела - шара

Панель "Моделирование":

Меню "Рисование": "Моделирование" » "Шар"

Ввод команды: шар

Пульт управления: Панель создания 3D объектов, Шар

Центр или [3Т/2Т/ККР]: Указать точку или задать опцию

Центр

Задание центра шара.

При задании центральной точки шар размещается так, чтобы его центральная ось была параллельна оси Z текущей ПСК. Параллели шара оказываются параллельными плоскости XY.

Радиус или [Диаметр]: Задать расстояние или ввести д

Радиус

Задание радиуса шара.

Диаметр

Задание диаметра шара.

Диаметр: Задать расстояние

3Т (Три точки)

Определяет окружность сферы путем задания трех произвольных точек в 3D пространстве. Три заданные точки также определяют плоскость окружности шара.

Первая точка: Указать точку (1)

Вторая точка: Указать точку (2)

Третья точка: Указать точку (3)

2Т (Две точки)

Определяет окружность сферы путем задания двух произвольных точек в 3D пространстве. Плоскость окружности шара определяется координатой Z первой точки.

Первая конечная точка диаметра: Указать точку (1)

Вторая конечная точка диаметра: Указать точку (2)

ККР (Касательная, Касательная, Радиус)

Построение шара по заданному радиусу, касательному к двум объектам. Указанные точки касания проецируются на текущую ПСК.

Точка касания с первым объектом: Выбрать точку на объекте

Точка касания со вторым объектом: Выбрать точку на объекте

Радиус <по умолчанию>: Задать радиус или нажать ENTER для использования значения радиуса по умолчанию

Изначально радиус по умолчанию не определен. В процессе работы над чертежом в качестве значения радиуса по умолчанию всегда используется ранее введенное значение радиуса любого элементарного тела.


ШТЕМПЕЛЬ Команда

Ш Команды
Ш Команды
ШТЕМПЕЛЬ Команда
Понятия Процедуры Команды

Нанесение штемпеля в определенном углу каждого чертежа и запись соответствующей информации в файл журнала

Ввод команды: штемпель

Откроется диалоговое окно "Штемпель чертежа".

Примечание Штемпель всегда наносится пером номер 7 (или пером с наибольшим номером, если плоттер имеет менее семи перьев). Поэтому в это положение необходимо установить подходящее перо. При использовании неперьевого (растрового) устройства, штемпель всегда проставляется цветом 7.

Если по запросу "Команда:" ввести -штемпель, команда ШТЕМПЕЛЬ отображает запросы в командной строке.

Темы:

  • Диалоговое окно "Штемпель чертежа"
  • Диалоговое окно "Пользовательские поля"
  • Диалоговое окно "Дополнительные опции"
  • Командная строка ШТЕМПЕЛЬ


Диалоговое окно "Штемпель чертежа"

Ш Команды
Ш Команды
Диалоговое окно "Штемпель чертежа"
Понятия Процедуры Команды

Ввод команды: штемпель

Задание информации для штемпеля чертежа.

Поля штемпеля чертежа

Информация о чертеже, которая должна быть включена в штемпель. Поля штемпеля разделяются запятыми и пробелами.

Имя чертежа

Включение в штемпель информации об имени чертежа и пути к нему.

Имя листа

Включение имени листа в информацию о штемпеле чертежа

Дата и время

Включение в штемпель информации о дате и времени.

Примечание Формат даты и времени определяется региональными настройками, заданными на Панели управления Windows. Даты на штемпеле выводятся в кратком представлении.

Имя пользователя

Включение в информацию о штемпеле имени пользователя Windows.

Имя пользователя Windows содержится в системной переменной LOGINNAME.

Имя устройства

Включение в штемпель информации об имени текущего устройства печати.

Формат листа

Включение в штемпель информации о формате листа для текущего сконфигурированного устройства печати.

Масштаб печати

Включение в штемпель информации о масштабе выводимого чертежа.

Просмотр

Наглядное изображение расположения образца штемпеля на чертеже, исходя из значений расположения и поворота, заданных в диалоговом окне "Дополнительные опции". Никаким другим способом просмотреть штемпель перед печатью нельзя. Внутреннее содержимое штемпеля здесь не просматривается.

Дополнительная информация

Задание текста, который можно проставить на чертеже и/или занести в журнал при выводе чертежа на печать. Выводится значение, выбираемое в любом пользовательском списке. Например, в одном списке можно разместить типы носителей или цены, а в другом указать названия заданий. Если пользователем выбрано значение <нет>, то дополнительная информация не проставляется.

Добавить/Изменить

Отображает диалоговое окно "Пользовательские поля", в котором можно добавлять, редактировать и удалять задаваемые пользователем поля.

Файл параметров штемпеля чертежа

Сохранение параметров штемпеля в файле с расширением .pss. Обеспечивается доступ к одному и тому же файлу множеству пользователей с простановкой штемпелей на их распечатках по стандартам компании.

Поставляются два файла PSS, Mm.pss и Inches.pss, которые находятся в папке "Поддержка". Имя исходного файла параметров штемпеля, используемого по умолчанию, зависит от региональных установок операционной системы в момент установки программы.

Путь

Указывает местоположение файла параметра штемпеля.

Загрузить

Вызов диалогового окна "Имя файла параметров штемпеля" (стандартного окна выбора файлов), в котором можно указать местоположение файла параметров для использования.

Сохранить как

Сохранение текущих параметров штемпеля в новом файле параметров.

Дополнительные

Отображает диалоговое окно "Дополнительные опции", в котором можно задать расположение, свойства текста и единицы для штемпеля. Можно также создать файл журнала и указать его расположение.


Диалоговое окно "Пользовательские поля"

Ш Команды
Ш Команды
Диалоговое окно "Пользовательские поля"
Понятия Процедуры Команды

Ввод команды: штемпель

Пользовательские поля создаются и редактируются в диалоговом окне "Пользовательские поля", которое открывается при нажатии кнопки "Добавить/Изменить" в диалоговом окне "Штемпель чертежа".

Имя

Перечень имеющихся пользовательских полей.

Добавить

Добавление редактируемого пользовательского поля в конец списка.

Изменить

Редактирование выбранного пользовательского поля.

Удалить

Удаление выбранного пользовательского поля.


Диалоговое окно "Дополнительные опции"

Ш Команды
Ш Команды
Диалоговое окно "Дополнительные опции"
Понятия Процедуры Команды

Ввод команды: штемпель

Задание расположения, свойств текста и единиц для штемпеля. Можно также создать файл журнала и указать его расположение. Диалоговое окно вызывается нажатием кнопки "Дополнительно" в диалоговом окне "Штемпель чертежа".

Расположение и отступы

Задание расположения и ориентации штемпеля, а также применяемого смещения относительно границ области печати или границы листа.

Расположение

Задание области для расположения штемпеля. Возможны варианты "Вверху слева", "Внизу слева" (по умолчанию), "Внизу справа" и "Вверху справа". Расположение штемпеля определяется относительно расположения чертежа на странице.

Ориентации

Поворот штемпеля чертежа относительно указанной страницы. Возможны опции "Горизонтально" и "Вертикально" для каждого из вариантов расположения (например, вверху слева горизонтально или вверху слева вертикально).

Перевернутый штемпель

Штемпель чертежа переворачивается на 180 градусов по вертикали.

Отступ по X

Задание значения отступа по X от угла печатаемой области либо от угла листа, в зависимости от пользовательских настроек. При выборе опции "Отступ относительно границ листа" отступ вычисляется так, чтобы штемпель помещался на выбранном формате листа. Текст штемпеля, не умещающийся (по причине смещения) в рамках области печати, обрезается.

Отступ по Y

Задание значения отступа по Y от угла печатаемой области либо от угла листа, в зависимости от сделанного выбора. При выборе опции "Отступ относительно границ листа" отступ вычисляется так, чтобы штемпель помещался на выбранном формате листа. Текст штемпеля, не умещающийся (по причине смещения) в рамках области печати, обрезается.

Отступ относительно области печати

Вычисляются значения указываемого пользователем отступа от угла печатаемой области (а не от угла листа).

Отступ относительно границ листа

Вычисляются значения указываемого пользователем отступа от угла листа (а не от угла печатаемой области).

Свойства текста

Задание шрифта, высоты и количества строк, применяемых к тексту штемпеля.

Шрифт

Задание шрифта TrueType, применяемого к тексту информации в штемпеле.

Высота

Задание высоты шрифта, применяемой к информации в штемпеле.

Однострочный штемпель

Если выбрана данная опция, информация штемпеля располагается в одной строке текста. Информация штемпеля может содержать до двух строк текста, однако его расположение и значения отступов, задаваемые пользователем, должны обеспечивать перенос строк и требуемую высоту текста. Если штемпель содержит текст, длина которого не умещается в печатаемой зоне, текст штемпеля усекается. Если данный флажок сброшен, информация, расположенная после третьего поля, переносится во вторую строку.

Единицы для штемпеля

Задание единиц, используемых для измерения отступов по X и Y, а также высоты. В качестве единиц можно выбрать миллиметры, дюймы или пикселы.

В PSS-файле записываются два набора значений для штемпелей: и один для безразмерных файловых форматов, а другой - для размерных файловых форматов. Если в диалоговом окне выбраны размерные единицы, то выводятся и изменяются размерные значения. Для работы с безразмерными величинами следует выбирать в качестве единиц измерения пикселы. Независимо от единиц, выбранных в диалоговом окне, при распечатке применяется корректный набор значений. Иными словами, изменение единиц измерения не приводит к пересчету значений.

Предупреждение При штемпелевании в предыдущей версии(AcPltStamp.arx) изменение метрических единиц на британские приводило к тому, что штемпель становился в 25,4 раза больше, а при изменении на растровые единицы штемпель уменьшался до размеров точки. В данной версии при смене единиц измерения базовые величины остаются прежними; изменяются только способы отображения размера и координат местоположения.

Расположение файла журнала

Запись информации штемпеля в файл журнала вместо штемпелевания текущего чертежа или в дополнение к нему. Файл журнала может создаваться и при отключенной опции штемпелевания.

Создание файла журнала

Запись информации штемпеля в файл журнала. По умолчанию журнал ведется в файле plot.log, расположенном в основной папке приложения. Можно задать другое имя и путь для файла. После создания исходного файла plot.log информация штемпелей для каждого последующего печатаемого чертежа добавляется в этот файл. Информация штемпеля для каждого чертежа занимает в файле одну строку. Файл журнала штемпеля может быть размещен в сети и использоваться одновременно несколькими пользователями. Информация о штемпеле, проставляемом каждым из пользователей, добавляется в конец файла plot.log.

Имя файла журнала

Задание имени для создаваемого файла журнала. Если требуется имя файла, отличное от имени по умолчанию (plot.log), следует ввести новое имя..

Обзор

Здесь перечислены все сохраненные на текущий момент файлы журнала штемпеля. Текущую информацию штемпеля можно записать поверх информации в имеющемся файле журнала штемпеля и затем сохранить данный файл.


Командная строка ШТЕМПЕЛЬ

Ш Команды
Ш Команды
Командная строка ШТЕМПЕЛЬ
Понятия Процедуры Команды

Если по запросу "Команда:" ввести -штемпель, отображаются запросы в командной строке. По умолчанию для каждой подсказки выдаются настройки из PSS-файла.

Команду -ШТЕМПЕЛЬ можно использовать в составе пакета печатания для изменения информации штемпеля для чертежа.

Задайте опцию [Вкл/Откл/Поля/Пользовательские поля/Журнал/Расположение/Свойства текста/Единицы]:

Вкл

Включение режима нанесения штемпеля для текущего чертежа.

Откл

Отключение режима нанесения штемпеля для текущего чертежа.

Поля

Задание полей информации штемпеля, применяемых к текущему штемпелю.

Имя чертежа штемпеля? [Да/Нет] <Да>:

Имя листа штемпеля? [Да/Нет] <Да>:

Дата и время штемпеля? [Да/Нет] <Да>:

Имя пользователя штемпеля? [Да/Нет] <Да>:

Имя устройства печати для штемпеля? [Да/Нет] <Да>:

Формат листа штемпеля? [Да/Нет] <Да>:

Масштаб печати штемпеля? [Да/Нет] <Да>:

Пользовательские поля

Задание пользовательских полей, применяемых к текущему штемпелю.

Пользовательское поле 1 <>: Задать любое пользовательское поле

Пользовательское поле 2 <>: Задать любое пользовательское поле

Журнал

Задание записи информации текущего штемпеля в файл журнала вместо применения данной информации к текущему печатаемому чертежу. По умолчанию используется файл plot.log, но можно задать и другой файл.

Записать штемпель в файл журнала? [Да/Нет] <Да>:

Путь к файлу журнала <plot.log>:

Расположение

Задание расположения штемпеля на листе согласно отступам, ориентации и местоположению по отношению к области печати и границе листа.

Расположение определяется с включением печатаемой области или границы листа и соотносится с тем или другим в зависимости от того, что указано в запросе.

Расположение штемпеля [ВЛ/ВП/НЛ/НП] <НЛ>:

  • ВЛ: Слева вверху
  • ВП: Справа вверху
  • НЛ: Слева внизу
  • НП: Справа внизу

Ориентация текста задает угол поворота штемпеля на листе.

Ориентация штемпеля [Горизонтально/Вертикально] <Горизонтально>:

  • Горизонтально: Штемпель располагается на листе горизонтально.
  • Вертикально: Штемпель располагается на листе вертикально.

Перевернутый штемпель [Да/Нет] <Нет>:

Отступ штемпеля <0,1000;0,1000>:

При задании смещения штемпеля относительно границы листа значения отступов отсчитываются от угла листа. При задании смещения штемпеля относительно области печати значения отступов отсчитываются от угла области печати.

Задание отступа относительно [Границы листа/Область печати] <область печати>:

Свойства текста

Задание имени шрифта и высоты текста для текущего штемпеля. Можно также задать расположение текста в одну или две строки. Значения расположения и отступов должны задаваться с учетом количества строк штемпеля и высоты текста.

Имя шрифта <>: Ввести имя шрифта

Высота текста <0.1500>: Ввести значение

Расположить штемпель в одну строку? [Да/Нет] <Нет >:

Единицы

Задание единиц, используемых для измерения отступов по X и Y, а также высоты. В качестве единиц можно выбрать миллиметры, дюймы или пикселы.

Единицы измерения [Дюймы/Миллиметры/Пикселы] <дюймы>:


ШТРИХ Команда

Ш Команды
Ш Команды
ШТРИХ Команда
Понятия Процедуры Команды

Заполняет замкнутую область или выбранные объекты штриховкой, сплошной заливкой или градиентной заливкой

Панель Рисование:

Меню "Рисование": "Штриховка"

Ввод команды: штрих

Отобразится диалоговое окно "Штриховка и градиент".

Если в командной строке ввести -штрих, будут выведены подсказки для команды ШТРИХ.

Примечание По умолчанию программа не создает штриховок, содержащих более 10 000 сегментов. Этот предел определяется значением переменной реестра MaxHatch. Чтобы его изменить (например, присвоить переменной MaxHatch значение 50 000) нужно ввести в командной строке (setenv "MaxHatch" "50000"). Переменной реестра можно присвоить любое значение в диапазоне от 100 до 10 000 000.

Темы:

  • Диалоговое окно "Штриховка и градиент"
  • Вкладка "Штриховка" (диалоговое окно "Штриховка и градиент")
  • Вкладка "Градиент" (диалоговое окно "Штриховка и градиент")
  • Область "Дополнительно" (диалоговое окно "Штриховка и градиент")
  • Диалоговое окно "Палитра образцов штриховки"
  • ШТРИХ (вариант для командной строки)


Диалоговое окно "Штриховка и градиент"

Ш Команды
Ш Команды
Диалоговое окно "Штриховка и градиент"
Понятия Процедуры Команды

Панель Рисование:

Меню "Рисование": "Штриховка"

Ввод команды: штрих

Здесь задаются контур, тип и свойства образца и другие параметры штриховки и градиентной заливки.

Диалоговое окно "Штриховка и градиент" содержит следующие элементы.

  • Вкладка "Штриховка"
  • Вкладка "Градиент"
  • Раздел "Дополнительно"
  • Добавить: Точки выбора
  • Добавить: Выбрать объекты
  • Восстановить контур
  • Удалить контуры
  • Просмотр набора
  • Параметры
  • Копирование свойств
  • Образец

Добавить: Точки выбора

Создает контур из существующих объектов, образующих замкнутую область вокруг указанной точки. Диалоговое окно временно будет закрыто, и появится запрос для задания точки.

Выберите внутреннюю точку или [Выбрать объекты/удалить контуры]: Нажмите левую кнопку мыши внутри области, которую необходимо заштриховать или заполнить заливкой, задайте опцию, введите о или отменить для отмены предыдущего выбора или нажмите ENTER для возврата к диалоговому окну

При выборе внутренних точек нажатием правой кнопки мыши в области рисования можно вызвать контекстное меню, которое содержит несколько параметров.

Если включить режим обнаружения островков, то объекты, которые содержат области, находящиеся внутри самого внешнего контура расцениваются как островки. Процедура поиска контуров при выполнении команды ШТРИХ в этом режиме определяется тем, какой метод обнаружения островков выбран в области "Дополнительно" этого диалогового окна.

Добавить: Выбрать объекты

Создает контур из выбранных объектов, образующих замкнутую область. Диалоговое окно будет временно закрыто, и появится запрос для выбора объектов.

Выберите объекты или [Выбрать внутреннюю точку/удалить контуры]: Выберите объекты, определяющие область, которую необходимо заштриховать или заполнить заливкой, задайте опцию, введите о или отменить для отмены предыдущего выбора или нажмите ENTER для возврата к диалоговому окну

При использовании опции "Выбор объектов" команда ШТРИХ не производит поиск внутренних объектов автоматически. Чтобы выполнить штриховку или заливку объектов внутри выбранного контура, следует выбрать объекты в соответствии с текущим стилем обнаружения островков.

При каждом нажатии кнопки "Выбор объектов", команда ШТРИХ сбрасывает предыдущий набор объектов.

Нажатием правой кнопки мыши в области рисования в процессе выбора объектов можно вызвать контекстное меню. С его помощью можно отменить выбор последнего или всех объектов, изменить способ задания контуров и стиль обнаружения островков, а также предварительно просмотреть полученную штриховку или градиентную заливку.

Удалить контуры

Удаляет ранее добавленные внутрь контура объекты.

При нажатии кнопки "Выбрать все" диалоговое окно будет временно закрыто, а в командной строке отобразится запрос.

Выберите объекты или [Добавить контуры]: Выберите объекты для удаления из области, ограниченной контуром, задайте опцию или нажмите ENTERдля возврата к диалоговому окну

Выбор объектов

Удаляет временный контур для штриховки или заливки в соответствии с выбором пользователя.

Добавить контуры

Добавляет временный контур для штриховки или заливки в соответствии с выбором пользователя.

Восстановить контур

Создает полилинию или область вокруг указанной штриховки или заливки и, дополнительно, связывает с ней объект штриховки.

При нажатии кнопки "Восстановить контур" диалоговое окно будет временно закрыто, а в командной строке отобразится запрос.

Введите тип контура [Область/Полилиния] <текущий>: Введите о, чтобы создать область, или п, чтобы создать полилинию

Отменить связь штриховки с новым контуром? [Да/Нет]<текущее>: Ввести д или н

Просмотр набора

Временно закрывает диалоговое окно и отображает созданные контуры при текущих значениях параметров штриховки или заливки. Опция не доступна, если еще не указаны точки или не выбраны объекты.

Параметры

Управляет несколькими обычно используемыми параметрами штриховки или заливки.

Ассоциативная

Управляет ассоциативностью штриховки или заливки. Ассоциативная штриховка или заливка обновляется при изменении ее контуров. (системная переменная HPASSOC)

Создать отдельные штриховки

Определяет количество создаваемых заштрихованных объектов (один или несколько), если выделено несколько отдельных замкнутых контуров. (системная переменная HPSEPARATE)

Порядок прорисовки

Задает порядок прорисовки штриховки или заливки. Штриховку и заливку можно расположить за всеми объектами, перед всеми объектами, за контуром штриховки или перед контуром штриховки. (системная переменная HPDRAWORDER)

Копирование свойств

Выполняет штриховку или заливку указанных контуров с учетом свойств штриховки или заливки выделенного объекта штриховки. HPINHERIT определяет способ указания исходной точки полученной штриховки: с помощью системной переменной HPORIGIN или по исходному объекту. После выбора объекта штриховки, свойства которого будут наследоваться при штриховании, чтобы создать контуры, можно нажать правую кнопку мыши в области рисования и воспользоваться контекстным меню для переключения между параметрами "Выбрать объекты" и "Указать внутреннюю точку".

При нажатии кнопки "Копировать свойства" диалоговое окно будет временно закрыто, а в командной строке отобразится запрос.

Выберите объект штриховки: Нажмите левую кнопку мыши внутри заштрихованной или закрашенной области, чтобы выбрать образец штриховки, которую требуется применить к новому объекту штриховки

Образец

Выход из диалогового окна и показ контуров, которые будут участвовать в штриховании или закрашивании при текущих значениях параметров. Для возвращения в диалоговое окно следует нажать левую кнопку мыши на чертеже или нажать ESC. Чтобы принять полученную штриховку или заливку, следует нажать правую кнопку мыши или нажать ENTER. Опция не доступна, если еще не указаны точки или не выбраны объекты.

Дополнительно

Увеличивает размеры диалогового окна для отображения дополнительных параметров.

Темы:

  • Вкладка "Штриховка" (диалоговое окно "Штриховка и градиент")
  • Вкладка "Градиент" (диалоговое окно "Штриховка и градиент")
  • Область "Дополнительно" (диалоговое окно "Штриховка и градиент")


Вкладка "Штриховка" (диалоговое окно "Штриховка и градиент")

Ш Команды
Ш Команды
Вкладка "Штриховка" (диалоговое окно "Штриховка и градиент")
Понятия Процедуры Команды

Здесь задается внешний вид создаваемой штриховки.

Тип и массив

Определяет тип и образец штриховки.

Тип

Задает тип образца штриховки. Образцы, определяемые пользователем, строятся с учетом текущего типа линий чертежа. Образец пользователя - это образец, описанный в файле PAT, расположенном пользователем по стандартному пути поиска. Угол поворота и масштаб образца задаются пользователем.

Образцы штриховки по умолчанию хранятся в файле acad.pat или acadiso.pat, прилагаемом к программе.

Образец

Список имеющихся стандартных образцов. В верхней части списка перечислены шесть образцов штриховки, использованных последними. Команда ШТРИХ хранит выбранный образец в системной переменной HPNAME. Опция "Образец" доступна только для стандартного типа штриховки.

Кнопка "..."

Отображает диалоговое окно "Палитра образцов штриховки", в котором по наглядным изображениям можно выбрать один из стандартных образцов.

Структура

Слайд, на котором изображена графическая структура выбранного образца. Нажатие левой кнопки мыши на этом слайде открывает диалоговое окно "Палитра образцов штриховки". Если выбран образец СПЛОШНАЯ, нажатие кнопки со стрелкой позволяет отобразить список цветов или Диалоговое окно "Выбор цвета"диалоговое окно "Выбор цвета".

Образец пользователя

Список имеющихся пользовательских образцов. В верхней части списка перечислены шесть образцов штриховки, использованных последними. Имя выбранного образца хранится в системной переменной HPNAME. Опция "Образец пользователя" доступна только для пользовательского типа штриховки.

Кнопка "..."

Отображает диалоговое окно "Палитра образцов штриховки", в котором по наглядным изображениям можно выбрать один из стандартных образцов.

Угол и масштаб

Задает угол и масштаб для выбранного образца штриховки.

Угол

Угол поворота штриховки относительно оси X текущей ПСК. Команда ШТРИХ хранит значение угла штриховки в системной переменной HPANG.

Масштаб

Степень растяжения (сжатия) стандартного или пользовательского образца штриховки. Команда ШТРИХ хранит значение масштаба штриховки в системной переменной HPSCALE. Опция доступна только для стандартного и пользовательского типов штриховки.

Двусторонняя

Для образцов, определенных пользователем, наносит вторую штриховку, повернутую относительно первой на 90 градусов, создавая штриховку крест-накрест. Эта опция доступна, только если на вкладке "Штриховка" выбран тип "Пользовательская". (системная переменная HPDOUBLE)

Относительно пространства листа

Масштабирование образца штриховки относительно единиц пространства листа. Опция позволяет достичь приемлемого вида заштрихованных объектов на листах. Опция доступна только на вкладках "Лист".

Интервал

Расстояние между линиями в штриховках, созданных из линий. Команда ШТРИХ хранит значение интервала штриховки в системной переменной HPSPACE. Опция доступна только для штриховки, создаваемой из линий.

Толщина пера по ISO

Масштабирование стандартного образца ISO на основании выбранной толщины пера. Опция доступна, только если установлен стандартный тип штриховки, а в качестве образца выбран один из образцов ISO.

Исходная точка штриховки

Определяет начальную точку для создания штриховки. Некоторые образцы штриховки (например, штриховку в виде кирпичей) необходимо выровнять относительно определенной точки на контуре штриховки. По умолчанию, все исходные точки штриховки соответствуют текущей исходной точке ПСК.

Использовать текущую исходную точку

Использует настройку, хранящуюся в системной переменной HPORIGINMODE. По умолчанию исходная точка имеет координаты 0;0.

Указанная исходная точка

Указывает новою исходную точку штриховки. Нажмите левую кнопку мыши на этом параметре, чтобы сделать доступными следующие параметры.

Указать новую исходную точку с помощью мыши

Указание новой исходной точки штриховки непосредственно на чертеже.

По умолчанию увеличить до контура

Вычисление нового начала на основе прямоугольных границ контура для объекта штриховки. Следует указать все четыре угла прямоугольника и его центр. (системная переменная HPORIGINMODE)

Сохранить как исходную точку по умолчанию

Сохраняет значение новой исходной точки штриховки в системной переменной HPORIGIN.

Предварительный просмотр исходной точки

Показывает текущее положение исходной точки.


Вкладка "Градиент" (диалоговое окно "Штриховка и градиент")

Ш Команды
Ш Команды
Вкладка "Градиент" (диалоговое окно "Штриховка и градиент")
Понятия Процедуры Команды

Здесь задается внешний вид создаваемой градиентной заливки.

Цвет

Один цвет

Задает заливку, в которой используется плавный переход от более темных к более светлым оттенкам одного цвета. При выборе параметра "Один цвет" с помощью команды ШТРИХ можно отобразить образец цвета с кнопкой "Обзор" и указателем шкалы "Тень" и "Оттенок".

Два цвета

Задает заливку, в которой используется плавный переход от одного цвета к другому. При выборе параметра "Два цвета", с помощью команды ШТРИХ можно отобразить образец цвета с кнопкой "Обзор" отдельно для цвета 1 и цвета 2.

Образец цвета

Задает цвет для градиентной заливки. Нажмите кнопку "Обзор" [...], чтобы отобразить диалоговое окно "Выбор цвета", где можно выбрать цвет в соответствии с индексом цвета AutoCAD (ИЦА), из всей палитры или воспользовавшись альбомами цветов. По умолчанию отображается текущий цвет чертежа.

Бегунок "Тень … оттенок"

Задает оттенок (выбранный цвет смешивается с белым) или тень (выбранный цвет смешивается с черным) для градиентной заливки из одного цвета.

Образцы градиентной заливки

Девять стандартных образцов градиентной заливки. Имеются образцы линейной, сферической и параболической заливки.

Ориентации

Указывает угол градиента и определяет, является ли он симметричным.

По центру

Задает симметричный переход. Если параметр не выбран, градиентная заливка смещается вверх и влево, создавая таким образом иллюзию источника света, расположенного слева от объекта.

Угол

Угол градиентной заливки. Угол задается относительно текущей ПСК. Угол градиентной заливки задается независимо от угла поворота штриховки.


Область "Дополнительно" (диалоговое окно "Штриховка и градиент")

Ш Команды
Ш Команды
Область "Дополнительно" (диалоговое окно "Штриховка и градиент")
Понятия Процедуры Команды

Управляет работой с островками и контурами.

Островки

Указывает, нужно ли считать контурами замкнутые объекты, лежащие внутри внешнего контура штриховки/заливки. Если таких объектов нет, опция не влияет на процесс штрихования. Часто наилучшим оказывается стиль "Нормальный", т.к. в этом случае пользователь может задать точный набор контуров.

Островки

Определяет, выполняется ли поиск внутренних замкнутых контуров, называемых островками.

Нормальный

Штриховка или заливка наносятся вовнутрь, начиная от внешнего контура. Если при выполнении команды ШТРИХ обнаруживается внутренний островок, штрихование или заливка прекращаются до обнаружения внутри него другого островка. Установить стиль "Нормальный" можно также, добавив в системную переменную HPNAME после имени образца последовательность символов ,Н.

Внешний

Штриховка или заливка наносятся вовнутрь, начиная от внешнего контура. Команда ШТРИХ отключает штриховку или заливку при обнаружении внутреннего островка. Эта опция позволяет штриховать или закрашивать только область между наружным и первым из внутренних контурами, а вся остальная часть остается незаполненной. Установить стиль "Внешний" можно также, добавив в системную переменную HPNAME после имени образца последовательность символов ,В.

Пропустить

Штриховка или заливка наносится с игнорированием всех внутренних объектов (то есть поверх них). Кроме того, установить стиль "Игнорирующий" можно, добавив в системную переменную HPNAME последовательность символов, И.

Стили "Нормальный", "Внешний" и "Игнорирующий" доступны также в контекстном меню, которое вызывается нажатием правой кнопки мыши в области рисования в процессе выбора объектов или указания точек для контуров штриховки.

Сохранение контуров

Указывает, нужно ли сохранять контуры как объекты, и определяет присваиваемый им тип объектов.

Сохранение контуров

Создает объекты контура из временных контуров штриховки и добавляет их в чертеж.

Тип объекта

Определяет тип объекта для нового контура. Полученный объект контура может представлять собой область или полилинию. Эта опция доступна, если установлен флажок "Сохранение контуров".

Подробнее об областях см. раздел Построение и объединение областей в руководстве пользователя.

Набор контуров

Определяет набор объектов, анализируемых при создании контура от заданной точки. Заданный набор не оказывает никакого действия, если контур штриховки определяется путем указания объектов.

По умолчанию при использовании опции "Добавить: Точка выбора" для определения контура, команда ШТРИХ анализирует все объекты в текущих границах видового экрана. Переопределяя набор контуров, можно исключать некоторые объекты из рассмотрения, не скрывая и не удаляя их из чертежа. На больших чертежах при переопределении набора контуров контур может строиться быстрее, поскольку команда ШТРИХ анализирует меньше объектов.

Текущий ВЭкран

Создает набор контуров из всех объектов, находящихся в границах текущего видового экрана. При выборе этого параметра отменяется текущий набор контуров.

Имеющийся набор

Контуры создаются из объектов, указанных с помощью кнопки "Новый". Если кнопка "Новый" еще ни разу не использовалась, параметр "Имеющийся набор" не доступен.

Новый

Переход к выбору объектов, которые должны учитываться при создании набора контуров.

Допуск замкнутости

Задает максимально допустимую величину зазора между объектами, образующими контур штриховки. Установленное по умолчанию значение 0 означает, что между объектами, описывающими область, не должно быть зазора.

Можно задать максимально допустимую величину зазора между объектами, образующими контур штриховки. Его значение может быть в пределах от 0 до 5000, в единицах чертежа. Зазоры между объектами, величина которых не превышает заданного значения, игнорируются, а контур образованный такими объектами считается замкнутым. (системная переменная HPGAPTOL)

Наследовать параметры

При создании штриховки с помощью параметра "Копирование свойств" исходная точка штриховки определяется в соответствии с наследуемыми параметрами.

Использовать текущую исходную точку

Применяет текущую настройку исходной точки штриховки

Использовать исходную точку исходной штриховки

Применяет исходную точку штриховки исходной штриховки


Диалоговое окно "Палитра образцов штриховки"

Ш Команды
Ш Команды
Диалоговое окно "Палитра образцов штриховки"
Понятия Процедуры Команды

Панель Рисование:

Меню "Рисование": "Штриховка"

Ввод команды: штрих

Здесь представлены графические изображения стандартных и пользовательских образцов штриховки. Образцы распределены по четырем вкладкам; внутри вкладок они отсортированы по алфавиту. Для того чтобы выбрать образец, нужно выделить его изображение и нажать "OK".

ANSI

Отображает все образцы стандарта ANSI, поставляемые с продуктом.

ISO

Отображает все образцы стандарта ISO, поставляемые с продуктом.

Другие стандартные

Отображает образцы других стандартов (кроме ANSI и ISO), поставляемые с продуктом.

Пользовательский

Отображает список пользовательских файлов PAT, добавленных в путь поиска, который задается на вкладке "Файлы" диалогового окна "Настройка".

Образец

Отображает изображение для предварительного просмотра выбранного пользовательского образца.


ШТРИХ (вариант для командной строки)

Ш Команды
Ш Команды
ШТРИХ (вариант для командной строки)
Понятия Процедуры Команды

Если в командной строке ввести -штрих, будут выведены подсказки для команды ШТРИХ.

Укажите внутреннюю точку или [Свойства/Выбор объектов/Нарисовать контуры/Удалить контуры/Дополнительные/Порядок прорисовки/Начало]: Укажите точку или задайте опцию

Внутренняя точка

Создает контур из существующих объектов, образующих замкнутую область вокруг указанной точки. Если включить режим обнаружения островков, то объекты, которые содержат области, находящиеся внутри самого внешнего контура расцениваются как островки. Процедура поиска контуров при выполнении команды ШТРИХ в этом режиме определяется методом обнаружения островков.

Свойства

Задает новые характеристики наносимой штриховки.

Введите имя образца или выберите [?/Заливка/Пользовательская] <текущий>: Введите имя стандартного или пользовательского образца, введите с, введите п, введите ? или нажмите ENTER

Имя образца—Стандартное или пользовательское

Указывает стандартный образец в файле acad.pat или acadiso.pat или пользовательский образец в соответствующем файле PAT.

Введите имя образца и (дополнительно) код стиля штриховки. Для того чтобы штриховка представляла собой отдельные линии, а не объект, перед именем образца следует поставить звездочку (*).

Задайте масштаб штриховки <текущий>: Задайте масштаб или нажмите ENTER

Задайте наклон штриховки <текущий>: Задайте угол или нажмите ENTER

?—Список имен образцов

Выдает список имен и краткие описания образцов, определенных в файле acad.pat.

Какие имена образцов вывести <*>: Ввести список имен или нажать ENTER

Заливка

Устанавливает сплошной тип заливки и вновь отображает первую подсказку команды ШТРИХ, где можно перейти к заданию контура.

Из линий

Штриховка, генерируемая по заданным пользователем параметрам. Введите п и (дополнительно) код стиля штриховки. Для того чтобы штриховка представляла собой отдельные линии, а не блок, перед п следует поставить звездочку (*).

Задайте наклон перекрестной штриховки <текущий>: Задайте угол для образца или нажмите ENTER

Задайте шаг штриховки <текущий>: Задайте расстояние между линиями образца штриховки или нажмите ENTER

Штриховать крест-накрест? [Да/Нет] <текущий>: Введите д для нанесения дополнительных линий под углом 90 градусов к основным или нажмите ENTER

Выбор объектов

Создает контур из выбранных объектов, образующих замкнутую область. Добавляет объекты внутрь контура.

Выберите объекты: Выберите объекты любым способом

Нарисовать контур

Применяет заданные точки для определения контура штриховки или заливки.

Сохранить контур-полилинию? [Да/Нет] <текущий>: Введите д для сохранения контура-полилинии или н для его удаления после завершения штрихования области

Укажите начальную точку: Укажите начальную точку контура-полилинии

Укажите следующую точку или выберите [Дуга/Замкнуть/длИна/Отменить]: Укажите точку, задайте опцию или нажмите ENTER

Эти опции также доступны для команды ПЛИНИЯ. После завершения построения полилинии-контура следует нажать ENTER. Затем можно создать дополнительный контур-полилинию или дважды нажать ENTER, чтобы начать штрихование.

Укажите начальную точку для нового контура или <Принять>: Указать точку или дважды нажать ENTER , чтобы начать штрихование

Удалить контуры

Удаляет ранее добавленные внутрь контура объекты.

Выберите объекты или [Добавить контуры]: Выберите объекты для удаления из области, ограниченной контуром, задайте опцию или нажмите ENTERдля возврата к предыдущей подсказке

Выбор объектов

Удаляет ранее добавленные внутрь контура объекты.

Добавить контуры

Добавляет объекты внутрь контура.

Дополнительные

Устанавливает метод построения штриховки.

Задайте опцию [Контур/Сохранить/Островки/сТиль/Ассоциативность/Допуск замкнутости/отдельные Штриховки]: Задайте опцию или нажмите ENTER для возврата к предыдущей подсказке

Контур

Определяет набор объектов, анализируемых при создании контура от заданной внутренней точки.

Задайте набор кандидатов для контура [Новый/Все] <текущий>: Задайте опцию или нажмите ENTER

Новый

Создание набора контуров из определенного пользователем набора объектов.

Выберите объекты: Выберите объекты любым способом

Все

Создание набора контуров из всех объектов, видимых на текущем видовом экране. Если к моменту выбора данного параметра набор контуров был переопределен, переопределение отменяется.

Сохранить

Указывает, должны ли объекты, составляющие контур, сохраняться на чертеже после завершения штрихования.

Сохранить полученные контуры? [Да/Нет] <текуший>: Введите д или н или нажмите ENTER

Островки

Указывает, используются ли объекты, лежащие в пределах внешнего контура, в качестве контуров штриховки.

Вы хотите обнаруживать островки? [Да/Нет] <текуший>: Введите д или н или нажмите ENTER

Если обнаружение островков отключено, следует запрос метода отслеживания лучей.

Способ падения лучей [Ближайший/+X/-X/+Y/-Y/Угол] <текущий>: Задайте опцию или нажмите ENTER

Ближайшая

Луч падает от указанной точки к ближайшему объекту, затем производится трассировка контура против часовой стрелки.

+X

Луч падает от указанной точки до первого объекта в положительном направлении оси X, затем производится трассировка контура против часовой стрелки.

-X

Луч падает от указанной точки до первого объекта в отрицательном направлении оси X, затем производится трассировка контура против часовой стрелки.

+Y

Луч падает от указанной точки до первого объекта в положительном направлении оси Y, затем производится трассировка контура против часовой стрелки.

-Y

Луч падает от указанной точки до первого объекта в отрицательном направлении оси Y, затем производится трассировка контура против часовой стрелки.

Угол

Луч падает от указанной точки до первого объекта в направлении, заданном пользователем; затем производится трассировка контура против часовой стрелки.

Задайте угол падения лучей: Задайте угол

Стиль

Поведение по отношению к замкнутым объектам, лежащим внутри внешнего контура штриховки. Если таких объектов нет, установка опции не играет роли. Часто наилучшим оказывается стиль "Нормальный", т.к. в этом случае пользователь может задать точный набор контуров.

Задайте стиль штрихования [Игнорирующий/Внешний/Нормальный] <текущий>: Задайте опцию или нажмите ENTER

Пропустить

Игнорирует все внутренние объекты, а также штриховку и заливку внутри них. Установить стиль "Игнорирующий" можно также, добавив в системную переменную HPNAME после имени образца последовательность символов ,И.

Внешний

Штриховка или заливка наносятся вовнутрь, начиная от внешнего контура. Команда ШТРИХ отключает штриховку или заливку при обнаружении внутреннего островка. Эта опция позволяет штриховать или закрашивать только область между наружным и первым из внутренних контурами, а вся остальная часть остается незаполненной. Установить стиль "Внешний" можно также, добавив в системную переменную HPNAME после имени образца последовательность символов ,В.

Нормальный

Штриховка или заливка наносятся вовнутрь, начиная от внешнего контура. Если при выполнении команды ШТРИХ обнаруживается внутренний островок, штрихование или заливка прекращаются до обнаружения внутри него другого островка. Установить стиль "Нормальный" можно также, добавив в системную переменную HPNAME после имени образца последовательность символов ,Н.

Ассоциативность

Управление ассоциативностью штриховки.

Ассоциативность нового образца штриховки задается системной переменной HPASSOC. При изменении настройки для ассоциативности, изменяется также значение системной переменной HPASSOC.

Вам нужна ассоциативность? [Да/Нет] <текуший>: Введите д или н или нажмите ENTER

Допуск замкнутости

Задает максимально допустимую величину зазора между объектами, образующими контур штриховки. Установленное по умолчанию значение 0 означает, что между объектами, описывающими область, не должно быть зазора.

Максимальный зазор в контуре <0>: Ввести значение в единицах чертежа в промежутке от 0 до 5000

Зазоры между объектами, величина которых не превышает заданного допуска замкнутости, игнорируются, а контур образованный такими объектами считается замкнутым.

Отдельные штриховки

Определяет количество создаваемых заштрихованных объектов (один или несколько), если выделено несколько отдельных замкнутых контуров.

Создать отдельные штриховки? [Да/Нет] <текуший>: Введите д или н или нажмите ENTER

Порядок прорисовки

Задает порядок прорисовки штриховки или заливки. Штриховку и заливку можно расположить за всеми объектами, перед всеми объектами, за контуром штриховки или перед контуром штриховки. (системная переменная HPDRAWORDER)

Задайте порядок прорисовки [Не изменять/на Задний план/на Передний план/зА контуром/пЕред контуром] <зА контуром>: Задайте опцию или нажмите ENTER, чтобы принять предлагаемое по умолчанию значение и возвратиться к предыдущей подсказке

Начало

Определяет начальную точку для создания штриховки. Некоторые образцы штриховки (например, штриховку в виде кирпичей) необходимо выровнять относительно определенной точки на контуре штриховки. По умолчанию, все исходные точки штриховки соответствуют текущей исходной точке ПСК.

[Использовать текущую исходную точку/Задать новую исходную точку/По умолчанию увеличить до контура] <текущий>: Задайте опцию или нажмите ENTER, чтобы принять предлагаемое по умолчанию значение и возвратиться к предыдущей подсказке

Использовать текущую исходную точку

Устанавливает значение системной переменной HPORIGINMODE. Пять последних опций, перечисленных ниже, соответствуют значениям от 1 до 5.

[Использовать текущую исходную точку/Задать новую исходную точку/Нижняя левая/Нижняя правая/Верхняя правая/Верхняя левая/Центр] <текущий>: Задайте опцию или нажмите ENTER, чтобы принять предлагаемое по умолчанию значение и возвратиться к предыдущей подсказке

Задать новую исходную точку

Непосредственно указывает новую исходную точку штриховки.

По умолчанию увеличить до контура

Вычисляет новую исходную точку с учетом прямоугольных границ штриховки. Следует указать все четыре угла прямоугольника и его центр. Также может хранить значение новой исходной точки штриховки в системной переменной HPORIGIN.


Э Команды
  • ЭКСПОРТ
  • ЭКСПОРТ3ДС
  • ЭКСПОРТБМП
  • ЭКСПОРТДЖ
  • ЭКСПОРТМТФ
  • ЭКСПОРТПНГ
  • ЭКСПОРТСТЛ
  • ЭКСПОРТТАБЛ
  • ЭКСПОРТТЕЛ
  • ЭКСПОРТТИФ
  • ЭЛЛИПС
  • ЭСКИЗ


ЭКСПОРТ Команда

Э Команды
Э Команды
ЭКСПОРТ Команда
Понятия Процедуры Команды

Сохранение объектов в файлах различных форматов

Меню "Файл": "Экспорт"

Ввод команды: экспорт

Вызов диалогового окна "Экспорт данных" (стандартное диалоговое окно выбора файлов).

В списке "Тип файла" выбрать формат файла для экспорта объектов. Имя файла необходимо ввести в поле "Имя файла". Объекты экспортируются в файл заданного формата, имеющий указанное имя.

Примечание В диалоговом окне "Экспорт данных" записывается использовавшийся последним формат файла, который сохраняется для использования в рамках сеанса работы с текущим чертежом и между сеансами.

Поддерживаются следующие форматы файлов для экспорта:

  • 3D DWF (*.dwf): формат Design Web Format Autodesk (см. 3DДВФ)
  • Metafile (*.wmf): метафайл Microsoft Windows® (см. WMFOUT)
  • ACIS (*.sat): файл тел ACIS (см. ACISOUT)
  • Lithography (*.stl): Файл тел в стереолитографическом формате (см. STLOUT)
  • Encapsulated PS (*.eps): Файл Encapsulated PostScript
  • DXX Extract (*.dxx): файл извлечения атрибутов DXF™ (см. ATTEXT)
  • BMP: аппаратно-независимые растровые файлы (см. ЭКСПОРТБМП)
  • Block (*.dwg): файл чертежа (см. WBLOCK)

3D DWF - это принятый по умолчанию исходный тип файла. После выбора другого формата файла, этот формат сохраняется в диалоговом окне "Экспорт данных" до тех пор, пока пользователь не выберет новый формат файла для экспорта.


ЭКСПОРТ3ДС Команда

Э Команды
Э Команды
ЭКСПОРТ3ДС Команда
Понятия Процедуры Команды

Устар.

Ввод команды: экспорт3дс


ЭКСПОРТБМП Команда

Э Команды
Э Команды
ЭКСПОРТБМП Команда
Понятия Процедуры Команды

Сохранение выбранных объектов в файле аппаратно-независимого растрового формата (BMP)

Ввод команды: экспортбмп

Откроется диалоговое окно "Создание растрового файла" (стандартное окно выбора файлов). В нем следует ввести имя в поле "Имя файла".

Выбрать объекты или <все объекты и видовые экраны>: Нажать ENTER , чтобы выбрать все объекты и видовые экраны или использовать метод выбора объекта и нажать ENTER

Создается растровый файл, содержащий выбранные объекты. В файле содержится снимок экрана. Обозначения источников света, отображаемые в чертеже, появляются в новом файле, даже если атрибут источников света "Обозначение на печати" имеет значение "Нет".

Примечание Если для системной переменной FILEDIA установлено значение 0 (Откл), в командной строке отображаются подсказки.


ЭКСПОРТДЖ Команда

Э Команды
Э Команды
ЭКСПОРТДЖ Команда
Понятия Процедуры Команды

Сохраняет выбранные объекты в файл в формате JPEG

Ввод команды: экспортдж

Откроется диалоговое окно "Создание растрового файла" (стандартное окно выбора файлов). В нем следует ввести имя в поле "Имя файла".

Выберите объекты или <все объекты и видовые экраны>: Нажмите ENTER для выбора всех объектов и видовых экранов или выберите объекты любым способом и нажмите ENTER

Создается файл JPEG, который содержит выбранные объекты. Опции вывода для видовых экранов с раскрашиванием сохраняются в файле. Обозначения источников света, отображаемые в чертеже, появляются в новом файле, даже если атрибут источников света "Обозначение на печати" имеет значение "Нет".

Примечание Если системная переменная FILEDIA установлена в 0 (Откл), в командной строке выдаются подсказки.


ЭКСПОРТМТФ Команда

Э Команды
Э Команды
ЭКСПОРТМТФ Команда
Понятия Процедуры Команды

Сохранение объектов в метафайл Windows (WMF)

Ввод команды: экспортмтф

Откроется диалоговое окно "Создание WMF-файла", представляющее собой стандартное окно выбора файлов. Введите имя файла. A .К файлу будет добавлено расширение wmf.

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Выбранные объекты сохраняются в файле формата WMF.

Примечание Если в чертеж вставлено несколько растровых объектов и приложение по обработке растровых изображенийism.arx загружено, максимальное разрешение выходного метафайла составляет 2К на 2К. Приложение по обработке растровых изображений загружается при первом вызове команд ИЗОБ, ИЗОБРЕГУЛ, ИЗОБВСТАВИТЬ, ИЗОБРЕЗ, ИЗОБКОНТУР или ИЗОБКАЧЕСТВО.


ЭКСПОРТПНГ Команда

Э Команды
Э Команды
ЭКСПОРТПНГ Команда
Понятия Процедуры Команды

Сохраняет выбранные объекты в файл в формате Portable Network Graphics

Ввод команды: экспортпнг

Откроется диалоговое окно "Создание растрового файла" (стандартное окно выбора файлов). В нем следует ввести имя в поле "Имя файла".

Выберите объекты или <все объекты и видовые экраны>: Нажать ENTER для выбора всех объектов и видовых экранов или выбрать объекты любым способом и нажать ENTER

В PNG-файл записываются выбранные объекты. В файле содержится снимок экрана. Обозначения источников света, которые отображаются на чертеже, появляются в новом файле, даже если для параметра "Обозначение печати" источников света задано значение "Нет".

Примечание Когда для системной переменной FILEDIA установлено значение 0 (Откл), в командной строке выдаются подсказки.


ЭКСПОРТСТЛ Команда

Э Команды
Э Команды
ЭКСПОРТСТЛ Команда
Понятия Процедуры Команды

Сохранение тел в двоичном или ASCII-файле

Ввод команды: экспортстл

Выберите одно тело для вывода в STL-файл:

Выберите объекты: Выбрать объекты любым способом и нажать ENTER по завершении выбора объектов

Создать двоичный STL-файл? [Да/Нет] <Да>: Ввести д или нажать ENTER для создания двоичного файла, либо ввести н для создания ASCII-файла

Откроется диалоговое окно "Создание STL-файла" (стандартное диалоговое окно выбора файлов).

Создается файл с расширением .stl. STL-формат совместим с используемым в стереолитографических аппаратах (Stereo-Lithography Apparatus, SLA). Твердотельная модель переносится в SLA в виде граней. Грани включают наборы треугольников, аппроксимирующих грани модели AutoCAD. Рабочая станция SLA извлекает из информации о гранях наборы контуров, определяющих слои генерируемой детали.

Системная переменная FACETRES определяет то, как программа преобразует модель в треугольники. Установка больших значений переменной FACETRES приводит к созданию более гладкой сети и более точному представлению модели; однако при этом значительно увеличивается размер файла. Модель должна лежать в положительном XYZ-октанте МСК.


ЭКСПОРТТАБЛ Команда

Э Команды
Э Команды
ЭКСПОРТТАБЛ Команда
Понятия Процедуры Команды

Экспорт данных таблицы в файл формата CSV

Контекстное меню: Выбрав таблицу, нажмите правую кнопку мыши и в контекстном меню выберите "Экспорт".

Ввод команды: экспорттабл

Откроется стандартное диалоговое окно выбора файлов. Таблица данных экспортируется в файл формата CSV (с разделением запятыми). Форматирование таблицы и ее содержимого не сохраняется.


ЭКСПОРТТЕЛ Команда

Э Команды
Э Команды
ЭКСПОРТТЕЛ Команда
Понятия Процедуры Команды

Экспортирует в файл ACIS тела ACIS, 3D тела и области.

Ввод команды: экспорттел

Примечание При обмене файлами СБ с более ранними версиями AutoCAD необходимо присвоить для системной переменной ACISOUTVER значение, соответствующее используемой в них версии ACIS. Например, при экспорте СБ-файла для последующего использования в AutoCAD Release 14 переменная ACISOUTVER должна быть равна 16.

Выбрать объекты: Выбрать объекты любым способом

Выбранные объекты, кроме 3D тел и областей, игнорируются; откроется диалоговое окно "Создание файла ACIS". В нем следует ввести с клавиатуры имя создаваемого файла. Выбранные объекты экспортируются в файл ASCII.


ЭКСПОРТТИФ Команда

Э Команды
Э Команды
ЭКСПОРТТИФ Команда
Понятия Процедуры Команды

Сохранение выбранных объектов в файл формата TIFF

Ввод команды: экспорттиф

Откроется диалоговое окно "Создание растрового файла" (стандартное диалоговое окно выбора файлов). В нем следует ввести имя файла.

Выберите объекты или <все объекты и видовые экраны>: Нажмите ENTER для выбора всех объектов и видовых экранов или выберите объекты любым способом и нажмите ENTER

Выбранные объекты записываются в созданный файл TIFF. В файле содержится снимок экрана.

Примечание Если значение системной переменной FILEDIA равно 0 (Откл), запросы отображаются в командной строке.


ЭЛЛИПС Команда

Э Команды
Э Команды
ЭЛЛИПС Команда
Понятия Процедуры Команды

Построение эллипсов и эллиптических дуг

Панель "Рисование":

Меню "Рисование": "Эллипс"

Ввод команды: эллипс

Конечная точка оси эллипса или [Дуга/Центр/Изокруг]: Указать точку или задать опцию

Опция "Изокруг" доступна, только если для опции "Стиль" команды ШАГ установлено значение "Изометрический".

Конечная точка оси

Задание первой оси по двум точкам. Угол поворота первой оси задает поворот всего эллипса. Первой может строиться как большая, так и малая ось эллипса.

Вторая конечная точка оси: Указать точку (2)

Длина другой оси или [Поворот]: Задать значение расстояния, указать точку (3) или ввести р

Длина

Длина второй оси отсчитывается от середины первой оси до конечной точки (3) второй оси.

Поворот

Построение эллипса путем поворота круга относительно первой оси.

Поворот относительно главной оси: Указать точку (3) или ввести значение угла от 0 до 89,4

Перемещать перекрестье вокруг центра и нажать кнопку мыши для построения эллипса. Чем больше угол поворота, тем выше эксцентриситет эллипса. Если угол равен 0, строится круг.

Дуга

Построение эллиптической дуги. Угол поворота первой оси задает поворот всей эллиптической дуги. Первой может строиться как большая, так и малая ось эллиптической дуги.

Конечная точка оси эллиптической дуги или [Центр]: Указать точку или ввести c

Конечная точка оси

Задание начала первой оси.

Вторая конечная точка оси:

Длина другой оси или [Поворот]: Задать расстояние или ввести р

Описание опций "Длина" и "Поворот" аналогично соответствующим опциям при выборе "Центр".

Центр

Построение эллиптической дуги по указанной точке центра.

Центр эллиптической дуги:

Конечная точка оси:

Длина другой оси или [Поворот]: Задать расстояние или ввести р

Длина

Длина второй оси отсчитывается от середины первой оси до указанной точки.

Начальный угол или [Параметр]: Указать точку (1), задать значение или ввести т

Описание опций "Начальный угол" и "Параметр" аналогично соответствующим опциям при выборе "Поворот".

Поворот

Отношение длин осей эллипса задается путем поворота круга относительно первой оси. Чем больше угол поворота (он должен лежать в диапазоне от 0 до 89,4 градусов), тем больше отношение малой оси к большой. Если угол равен 0, строится круг.

Задать угол поворота относительно большой оси: Задать угол поворота

Начальный угол или [Параметр]: Задать угол или ввести p

Начальный угол

Задание первой конечной точки эллиптической дуги. Опция "Начальный угол" служит для переключения между режимами "Параметр" и "Угол". Режим контролирует вычисления эллипса.

Конечный угол или [Параметр/Внутренний угол]: Указать точку (2), ввести значение или задать опцию

Параметр

Требуется ввод таких же значений, как при выборе опции "Начальный угол", но эллиптическая дуга строится на основании следующего параметрического векторного уравнения:

p(u) = c + a* cos(u) + b* sin(u)

, где c является центром эллипса, а a и b - его большие и малые оси, соответственно.

Начальный параметр или [Угол]: Указать точку, задать значение или ввести т

Конечный параметр или [Угол/Внутренний угол]: Указать точку, ввести значение или задать опцию

  • Конечный параметр: задание конечного угла эллиптической дуги с использованием векторного параметрического уравнения. Опция "Начальный параметр" служит для переключения между режимами "Угол" и "Параметр". Режим контролирует вычисления эллипса.
  • Угол: задание конечного угла эллиптической дуги. Опция "Угол" служит для переключения между режимами "Параметр" и "Угол". Режим контролирует вычисления эллипса.
  • Внутренний угол: задание внутреннего угла эллиптической дуги; отмеряется относительно начального угла.

Центр

Построение эллипса по указанной точке центра.

Центр эллипса: Указать точку (1)

Конечная точка оси: Указать точку (2)

Длина другой оси или [Поворот]: Задать значение расстояния, указать точку (3) или ввести r

Длина

Длина второй оси отсчитывается от середины первой оси до указанной точки.

Поворот

Построение эллипса путем поворота круга относительно первой оси.

Поворот относительно главной оси: Указать точку или ввести значение угла от 0 до 89.4

Начальный угол или [Параметр]: Задать угол или ввести p

Перемещать перекрестье вокруг центра и нажать кнопку мыши для построения эллипса. Чем больше угол поворота, тем выше эксцентриситет эллипса. Если угол равен 0, строится круг.

Изокруг

Построение круга в текущей плоскости изометрии.

Примечание Опция "Изокруг" доступна, только если для опции "Стиль" команды ШАГ установлено значение "Изометрический".

Центр изокруга:

Радиус изокруга или [Диаметр]: Задать расстояние или ввести р

Радиус

Построение круга по указанному радиусу.

Диаметр

Построение круга по указанному диаметру.

Диаметр изокруга: Задать расстояние


ЭСКИЗ Команда

Э Команды
Э Команды
ЭСКИЗ Команда
Понятия Процедуры Команды

Рисование коротких смежных сегментов от руки

Ввод команды: эскиз

Приводимые ниже сведения излагаются в предположении, что режим "Планшет" включен.

Приращение <текущее>: Задать расстояние или нажать ENTER

Величина приращения определяет минимальную длину эскизных отрезков. Для того чтобы была создана эскизная линия, необходимо переместить курсор на расстояние, большее заданного приращения.

Эскизные линии генерируются в виде независимых отрезков. Если присвоить системной переменной SKPOLY ненулевое значение, то последовательности эскизных линий будут полилиниями, а не отрезками.

Эскиз. Перо выХод пОкинуть Записать Стереть пРодолжить . Задать опцию или нажать кнопку устройства указания

Перо (кнопка указания)

Поднимает и опускает перо для выполнения эскиза. Перед тем, как выбирать пункты меню устройством указания, перо должно быть поднято.

Выход—ENTER (кнопка 3)

Записывает эскиз в базу данных, выводит сообщение о числе созданных отрезков и завершает эскизное рисование.

Покинуть (кнопка 4)

Уничтожает все временные отрезки, введенные с момента начала работы команды ЭСКИЗ или последней опции «Записать», и завершает эскизное рисование.

Записать (кнопка 2)

Записывает существующий на текущий момент эскиз в базу данных чертежа, не изменяя состояние или положение пера. На экране отображается сообщение о числе отрезков, включенных в чертеж:

Записано: nnn отрезков.

Стереть (кнопка 5)

Стирает любую часть временных отрезков и поднимает перо (если оно было опущено).

Выберите конечную точку для стирания.

Продолжить (кнопка 6)

Опускает перо и продолжает эскиз от конечной точки последней эскизной линии или последнего стирания.

Продолжить: Укажите конечную точку отрезка.

. (Точка) (кнопка 1)

Опускает перо, строит отрезок, соединяющий конец последнего введенного отрезка с текущей позицией устройства указания, и возвращает перо в поднятое состояние.


Я Команды
  • ЯЩИК


ЯЩИК Команда

Я Команды
Я Команды
ЯЩИК Команда
Понятия Процедуры Команды

Создает 3D твердотельный параллелепипед (ящик)

Панель "Моделирование":

Меню "Рисование": подменю "Моделирование" » "Ящик"

Ввод команды: ящик

Пульт управления: Панель "3D Make", "Ящик"

Указать первый угол или [Центр]: Задать точку или ввести c для обозначения центра

Указать второй угол или [Куб/Длина]: Указать второй угол ящика или ввести опцию

Если значение Z для указанного второго угла ящика отличается от значения для указанного первого угла, подсказка высоты не выводится на экран.

Задать высоту или [2Точки] < значение по умолчанию>: Задать высоту или ввести 2P для опции моделирования по 2 точкам

При вводе положительного значения высоты цилиндр строится в положительном направлении оси Z текущей ПСК. Если значение высоты отрицательно, построение производится в отрицательном направлении оси Z текущей ПСК.

Центр

Построение ящика по указанной точке центра.

Задать центр: Указать точку (1)

Задать второй угол или [Куб/Длину]: Указать точку или ввести опцию

Задать высоту или опцию [2Точки] < по умолчанию>: Задать высоту или ввести 2Т для опции моделирования по 2 точкам

Куб

Построение ящика, стороны которого имеют равные длины.

Задать длину: Ввести значение или указать точку, чтобы задать длину и вращение ящика в плоскости XY

Линейные

Построение ящика с заданными значениями длины, ширины и высоты. Длина соответствует оси X, ширина оси Y, а высота оси Z.

Задать длину: Ввести значение или указать точку, чтобы задать длину и вращение ящика в плоскости XY

Ширина: Задать расстояние

Высота : Задать расстояние

Куб

Построение ящика, стороны которого имеют равные длины.

Задать длину: Ввести значение или указать точку, чтобы задать длину и вращение ящика в плоскости XY

Длина

Построение ящика с заданными значениями длины, ширины и высоты. При вводе значений длина соответствует оси X, ширина - оси Y, а высота - оси Z. Выбор точки для указания длины задает также вращение в плоскости XY.

Задать длину: Ввести значение, или указать точку, чтобы задать длину и вращение ящика в плоскости XY

Ширина: Задать расстояние

Высота : Задать расстояние

2Точки

Указывает, что высотой ящика является расстояние между двумя заданными точками.

Первая точка: Указать точку

Вторая точка: Указать точку


A Команды
  • ARX


ARX Команда

A Команды
A Команды
ARX Команда
Понятия Процедуры Команды

Загрузка, выгрузка и предоставление информации о приложениях ObjectARX

Ввод команды: arx

Задать опцию [?///Загрузить/Выгрузить]Команды:Опции

? - Список приложений

Отображает текущие приложения ObjectARX, которые могут быть как продуктами независимых разработчиков, так и внутренними компонентами (такими как модуль тонирования).

Загрузить

Отображает диалоговое окно "Выбор файла ARX/DBX" (стандартное диалоговое окно выбора файлов). Выбранное в нем приложение ObjectARX загружается в AutoCAD.

Выгрузить

Выгрузка указанного приложения ObjectARX.

Ввести имя ARX/DBX-файла для выгрузки:

Команды

Перечисляет список AcEd-зарегистрированных команд (эти команды описаны в руководстве для разработчиков ObjectARX).

Опции

Вывод сведений о режимах приложений ObjectARX. Эти режимы детально рассматриваются в руководстве для разработчиков ObjectARX.

Задать опцию [Группа/Классы/Службы]:Задать опцию или нажать клавишу ENTER

Группа

Указанная здесь группа команд получает приоритет, когда AutoCAD ищет процедуры, соответствующие именам его команд.

Классы

Отображение иерархии классов C++, унаследованной от зарегистрированных в системе объектов.

Службы

Получение списка всех зарегистрированных служб.


E Команды
  • EXPORTTOAUTOCAD


EXPORTTOAUTOCAD Команда

E Команды
E Команды
EXPORTTOAUTOCAD Команда
Понятия Процедуры Команды

Создание нового DWG-файла со всеми расчлененными AD-объектами

Ввод команды: -exporttoautocad или aectoacad

Export options [Format/Bind/bind Type/Maintain/Prefix/Suffix/?] <Enter for filename>: Ввести опцию или нажать ENTER , чтобы задать имя файла

Можно создать новую версию файла чертежа, в которой все AD-объекты будут расчленены и заменены базовыми объектами AutoCAD. В новой версии чертежа будет потеряна информация о пользовательских AD-объектах, однако в ней можно отобразить результирующие базовые объекты, а также получить к ним доступ из предыдущих версий AutoCAD, если активизаторы объектов для этих версий не доступны.

Примечание Любые последующие изменения, внесенные пользователем в этот новый файл чертежа, не влияют на исходный файл чертежа.

Enter for filename

Создание нового файла чертежа с заданным именем.

Примечание Чтобы создать уникальное имя файла для чертежа и избежать перезаписи существующего файла чертежа, можно использовать опцию префикса.

Export drawing name <current>: Ввести имя файла

Format

Определяет формат для результирующего файла чертежа.

Enter file format [r14/2000/2004/2007] <2007>: Указать формат файла чертежа

Bind

Определяет способ обработки внешних ссылок при создании нового чертежа.

Bind xrefs [Yes/No] <Yes>: Ввести y или n

Yes

Все внешние ссылки внедряются в чертеж. Слияние слоев и других именованных объектов, зависящих от внешних ссылок, с чертежом.

No

Внешние ссылки обслуживаются как указатели на другие чертежи

bind Type

Определяет способ обработки объектов, зависящих от внешних ссылок, при включенном параметре "Внедрить".

Bind type [Bind/Insert] <Insert>: Ввести параметр

Bind

Сохраняет имена слоев и других объектов, зависящих от внешних ссылок, при внедрении внешних ссылок.

Insert

Слияние имен объектов, зависящих от внешних ссылок, с новым чертежом без включения имени исходного файла.

Maintain

Определяет способ обработки блоков в пользовательских AD-объектах.

Maintain resolved properties [Yes/No] <Yes>: Ввести y или n

Yes

Расчленение всех вхождений блоков из пользовательских AD-объектов в базовые объекты AutoCAD. Результирующие базовые объекты вновь приобретают свои исходные свойства, а не свойства определений блока.

No

Отсутствие расчленения вхождений блоков в пользовательских AD-объектах. Свойства вхождений блоков определяются обычным способом, в зависимости от способа создания объектов в блоках и установок свойств слоев, в которые блоки вставлены.

Prefix

Префикс, добавляемый к текущему имени файла чертежа.

Filename prefix <>: Ввести символы, добавляемые к началу текущего имени файла

Suffix

Суффикс, добавляемый к текущему имени файла чертежа.

Filename suffix <>: Ввести символы, добавляемые к концу имени файла

? Список установок

Выводит список текущих установок команды.

File format: текущая установка

Bind xrefs: текущая установка

Bind type: текущая установка

Filename prefix: текущая установка

Filename suffix: текущая установка


G Команды
  • GOTOURL


GOTOURL Команда

G Команды
G Команды
GOTOURL Команда
Понятия Процедуры Команды

Открывает файл или web-страницу, ассоциированную с гиперссылкой, прикрепленной к объекту

Ввод команды: gotourl

Выбрать объект, содержащий гиперссылку, открывается ассоциированный с объектом файл или web-страница (URL).


N Команды
  • NETLOAD


NETLOAD Команда

N Команды
N Команды
NETLOAD Команда
Понятия Процедуры Команды

Загрузка приложения .NET

Ввод команды: netload

Отображается диалоговое окно "Выбор сборки .NET" (стандартное диалоговое окно выбора файлов).

Если значение системной переменной FILEDIA равно 0, команда NETLOAD выводит следующий запрос:

Имя файла сборки: Ввести имя файла и нажать ENTER.


O Команды
  • OLELINKS


OLELINKS Команда

O Команды
O Команды
OLELINKS Команда
Понятия Процедуры Команды

Обновление, изменение и разрыв имеющихся связей

Меню "Правка": "Связи"

Ввод команды: olelinks

Откроется диалоговое окно "Связи". Если чертеж не содержит OLE-связей, пункт "Связи" в меню "Правка" недоступен и диалоговое окно "Связи" не выводится. Чтобы задать другое исходное приложение для внедренного объекта, следует нажать правой кнопкой мыши на внедренном объекте и выбрать из контекстного меню "Преобразовать". При этом открывается диалоговое окно "Преобразование".

Темы:

  • Диалоговое окно "Связи"
  • Диалоговое окно "Преобразование"
  • Диалоговое окно "Смена значка"


Диалоговое окно "Связи"

O Команды
O Команды
Диалоговое окно "Связи"
Понятия Процедуры Команды

Меню "Правка": "Связи"

Ввод команды: olelinks

Вывод списка и обновление связанных файлов объектов.

Связи

Содержит информацию о связанных объектах. Вид информации зависит от типа связанного объекта. Для изменения информации о связанном объекте следует выбрать его в списке.

Источник данных

Отображает путь доступа к файлу, содержащему связанный объект, и тип данного объекта.

Тип

Отображает имя приложения, в котором создан связанный объект.

Обновление: Автоматическое

Включает автоматическое обновление связанного объекта в текущем чертеже при любых его изменениях в приложении-источнике.

Обновление: По запросу

Включает режим выдачи запроса на подтверждение необходимости обновить связи при открытии чертежа, содержащего связанные объекты.

Обновить

Выполняет обновление выбранных в списке связей.

Открыть источник

Открывает файл-источник и подсвечивает его часть, связанную с текущим чертежом AutoCAD.

Сменить источник

Вызов диалогового окна "Смена источника" (стандартного окна выбора файлов), с помощью которого можно задать другие исходные файлы. Если связанный объект является частью файла-источника (выбран не весь файл в целом), то в поле "Имя раздела" выводится строка, идентифицирующая выделенный элемент.

Разорвать связь

Разрыв связи между связанным объектом и его файлом-источником. Объект в чертеже преобразуется в формат WMF (формат метафайлов Windows), при этом дальнейшие изменения исходного файла не влияют на этот объект.


Диалоговое окно "Преобразование"

O Команды
O Команды
Диалоговое окно "Преобразование"
Понятия Процедуры Команды

Контекстное меню: Нажмите правой кнопкой мыши на внедренном объекте и выберите "OLE" » "Преобразовать".

Данное диалоговое окно позволяет сменить приложение-источник для выбранного внедренного объекта.

Текущий тип

Отображает тип преобразуемого или активизируемого объекта.

Тип объекта

Отображает список доступных типов объектов. Если предполагается преобразование OLE-объекта в объект AutoCAD , то текст преобразуется в многострочный текст (мтекст), файлы электронных таблиц в табличные объекты, а растровые файлы в объекты-изображения.

Преобразовать в

Задает режим преобразования типа внедренного объекта в тип, указанный в списке "Тип объекта".

Активизировать как

Объект активизируется как имеющий тип, указанный в списке "Тип объекта", но после редактирования возвращается к своему исходному типу.

В виде значка

Отображение значка приложения в чертеже. Внедренная (связанная) информация раскрывается после двойного щелчка мышью на значке.

Сменить значок

Вызов диалогового окна "Смена значка". Данная кнопка появляется только после включения опции "В виде значка".

Результат

Содержит описание результата применения выбранных в диалоговом окне "Преобразование" опций.


Диалоговое окно "Смена значка"

O Команды
O Команды
Диалоговое окно "Смена значка"
Понятия Процедуры Команды

Меню "Правка": "Связи"

Ввод команды: olelinks

Изменяет значок, представляющий внедренный или связанный объект в чертеже.

Значок

В данной группе пользователь может выбрать значок для представления внедренного или связанного объекта на чертеже.

Текущий

Задает использование текущего выбранного значка.

По умолчанию

Задает использование стандартного значка приложения-источника.

Из файла

Обеспечивает возможность выбора значка из файла (допустимые типы файлов: EXE, DLL и ICO).

Подпись

Позволяет ввести подпись к значку, представляющему связанный объект. Отобразится тип файла, если не указано иначе.

Обзор

Вызов диалогового окна "Обзор" (стандартного диалогового окна выбора файлов), в котором можно выбрать файл значка.


T Команды
  • TRAYSETTINGS


TRAYSETTINGS Команда

T Команды
T Команды
TRAYSETTINGS Команда
Понятия Процедуры Команды

Управление отображением значков и уведомлений на панели строки состояния

Контекстное меню: Нажмите правую кнопку мыши в строке состояния и выберите "Настройка области уведомлений".

Ввод команды: traysettings

Откроется диалоговое окно "Настройка области уведомлений".

Темы:

  • Диалоговое окно "Настройка области уведомлений"


Диалоговое окно "Настройка области уведомлений"

T Команды
T Команды
Диалоговое окно "Настройка области уведомлений"
Понятия Процедуры Команды

Контекстное меню: Нажмите правую кнопку мыши в строке состояния и выберите "Настройка области уведомлений".

Ввод команды: traysettings

Управление показом значков и уведомлений в области, расположенной в правой части строки состояния.

Показывать значки служб

Отображение области уведомлений со значками служб в правой части строки состояния. Если этот флажок снят, область уведомлений не отображается.

Показывать уведомления от служб

Отображение уведомлений от служб. Если снят флажок "Показывать значки служб", данный параметр не доступен.

Время отображения

Задание времени (в секундах), в течение которого отображаются уведомления.

До явного закрытия

Отображение уведомления до тех пор, пока не будет нажата кнопка "Закрыть".


V Команды
  • VBAIDE
  • VBALOAD
  • VBAMAN
  • VBARUN
  • VBASTMT
  • VBAUNLOAD
  • VLISP
  • VSSAVE


VBAIDE Команда

V Команды
V Команды
VBAIDE Команда
Понятия Процедуры Команды

Вызов редактора Visual Basic

Меню "Сервис": » "Макрос"; "Редактор Visual Basic"

Ввод команды: vbaide

Отобразится редактор Visual Basic.

Редактор Visual Basic позволяет редактировать проекты VBA (модули, формы, ссылки), хранящиеся в открытом чертеже или загруженные в AutoCAD. Кроме того, с помощью редактора Visual Basic можно запускать и отлаживать проекты VBA.


VBALOAD Команда

V Команды
V Команды
VBALOAD Команда
Понятия Процедуры Команды

Загружает глобальный проект в текущий сеанс работы

Меню "Сервис": » "Макрос"; "Загрузить проект"

Ввод команды: vbaload

Отобразится диалоговое окно "Открытие проекта VBA"(стандартное окно выбора файлов).

Число одновременно загруженных проектов Visual Basic for Applications (VBA) не ограничено. Если выбранный проект содержит вложенные проекты, то они также загружаются (если это возможно).

С помощью данного диалогового окна нельзя загружать встроенные проекты VBA (проекты, хранящиеся в файле чертежа). При открытии чертежа все содержащиеся в нем проекты загружаются, а при закрытии — выгружаются.

Если флажок "Открыть Редактор Visual Basic" установлен, после загрузки выбранного проекта откроется редактор Visual Basic. Информация о редакторе Visual Basic содержится в Руководстве разработчика ActiveX и VBA.

Если переменная FILEDIA равна 0 или по запросу "Команда" вводится -vbaload , то вызывается вариант команды VBALOAD, использующий интерфейс командной строки.

Открытие проекта VBA: Ввести имя файла проекта, который нужно открыть, и путь к нему

Если выбранный проект содержит макросы, отобразится диалоговое окно защиты от макровирусов AutoCAD.

Темы:

  • Диалоговое окно защиты от вирусов в макросах


Диалоговое окно защиты от вирусов в макросах

V Команды
V Команды
Диалоговое окно защиты от вирусов в макросах
Понятия Процедуры Команды

Меню "Сервис": » "Макрос"; "Загрузить проект"

Ввод команды: vbaload

Служит для защиты от вирусов, содержащихся в макросах. Макровирусы — это разновидность компьютерных вирусов, поражающая макросы проектов VBA. При открытии чертежа или проекта, содержащего макросы, существует опасность активизации макровирусов, которые в результате могут внедриться в другие файлы и привести к потере работоспособности компьютера. Так, любой чертеж или проект, сохраняемый в файле, может быть инфицирован макровирусом. Вместе с подготовленными на данном компьютере проектами вирус может распространиться дальше, к другим пользователям.

При открытии чертежа или проекта, содержащего макросы, AutoCAD выводит диалоговое окно, с помощью которого можно отключить макросы, если они не нужны. Макровирус опасен, только если ему позволено запуститься на выполнение. Открытие чертежей с отключением макросов не приводит к нежелательным последствиям.

В диалоговом окне присутствуют следующие опции:

Спрашивать при открытии каждого проекта с макросами

Если флажок сброшен, диалоговое окно защиты от макровирусов AutoCAD больше не выводится. Впоследствии защиту можно восстановить с помощью диалогового окна "Настройка", вызываемого в команде VBARUN.

Отключить макросы

Загрузка файла чертежа или проекта с отключением макросов. Опцию "Отключить макросы" следует использовать, если заведомо известно, что чертеж/проект не содержит полезных макросов или имеются сомнения в надежности источника.

В этом режиме макросы не выполняются. Однако их можно просматривать, редактировать и сохранять. Активизация макросов может быть произведена в каком-либо из последующих сеансов.

Включить макросы

Загрузка файла чертежа или проекта с включением макросов. Опцию «Включить макросы» следует использовать, если чертеж/проект содержит полезные макросы, или известно, что файлы получены из надежного источника.

Не загружать

Если загружается файл проекта, процесс прерывается и загрузки не происходит. Если открывается чертеж AutoCAD с внедренным проектом, макросы в чертеже отключены.


VBAMAN Команда

V Команды
V Команды
VBAMAN Команда
Понятия Процедуры Команды

Загрузка, выгрузка, сохранение, создание, вложение и извлечение проектов VBA

Меню "Сервис": » "Диспетчер VBA"

Ввод команды: vbaman

Открывается диалоговое окно «Диспетчер VBA».

Темы:

  • Диспетчер VBA


Диспетчер VBA

V Команды
V Команды
Диспетчер VBA
Понятия Процедуры Команды

Меню "Сервис": » "Макрос"; "Диспетчер VBA"

Ввод команды: vbaman

Служит для загрузки, выгрузки, сохранения, создания, встраивания и извлечения проектов Visual Basic for Applications (VBA):

чертеж

Задает активный чертеж. В списке представлены все чертежи, открытые в текущем сеансе работы.

Встроенный проект

Имя встроенного проекта для чертежа. Если в чертеже нет встроенного проекта, отображается “(нет)”.

Извлечь

Перемещение встроенного проекта из чертежа в глобальный файл проекта. Если проект не был сохранен ни разу, отобразится запрос на его сохранение.

При положительном ответе открывается диалоговое окно «Сохранение файла», где нужно задать имя и положение файла на диске.

При отрицательном ответе проект извлекается во временный файл.

Выбор опции «Отмена» прерывает извлечение и возвращает управление Диспетчеру VBA.

Проекты

Выдает список имен и расположений всех проектов, доступных в текущем сеансе работы.

Встроить

Встраивание выбранного проекта в указанный чертеж. В чертеже может присутствовать только один встроенный проект. Встраивание добавочных проектов не разрешено.

Новый

Создается новый проект с именем по умолчанию “Глобальныйn,”, где n является порядковым номером проекта в рамках сеанса.

Сохранить как

Сохранение глобального проекта. Данная опция доступна только при выборе несохраненного глобального проекта.

Загрузить

Отобразится диалоговое окно "Открытие проекта VBA" (см. VBALOAD), с помощью которого можно загрузить имеющийся проект в текущий сеанс работы.

Выгрузить

Выгрузка выбранного глобального проекта.

Макросы

Отображает диалоговое окно "Макросы", в котором можно выполнять, редактировать и удалять макросы VBA.

Редактор Visual Basic

Вызов Редактора Visual Basic, который позволяет редактировать проекты VBA (модули, формы, ссылки), хранящиеся в открытом чертеже или загруженные в AutoCAD. Кроме того, с помощью редактора Visual Basic можно запускать и отлаживать проекты VBA.


VBARUN Команда

V Команды
V Команды
VBARUN Команда
Понятия Процедуры Команды

Запуск VBA-макроса

Меню "Сервис": » "Макрос"; "Макросы"

Ввод команды: vbarun

Отобразится диалоговое окно "Макросы".

Если в ответ на запрос "Команда" ввести -vbarun, вызывается вариант команды VBARUN, использующий интерфейс командной строки.

Темы:

  • Диалоговое окно "Макросы"
  • Диалоговое окно «Выбор проекта»
  • Диалоговое окно «Параметры»
  • VBARUN вариант для командной строки


Диалоговое окно "Макросы"

V Команды
V Команды
Диалоговое окно "Макросы"
Понятия Процедуры Команды

Меню "Сервис": » "Макрос"; "Макросы"

Ввод команды: vbarun

Служит для выполнения, редактирования и удаления макросов VBA. С помощью данного окна можно также создавать новые макросы, настраивать опции VBA и вызывать Диспетчер VBA.

Имя

Имя макроса для выполнения, редактирования, удаления или создания. Его можно выбрать из списка или ввести самому.

Список макросов

Список всех макросов, которые найдены в источнике, заданном опцией «Макросы из». Для запуска макроса на выполнение можно дважды щелкнуть на его имени.

Макросы из

Задает проект или чертеж, макросы которого присутствуют в списке. Можно выбрать отображение списка макросов во всех чертежах и проектах, во всех чертежах, во всех проектах, в любом текущем загруженном чертеже или в любом текущем загруженном проекте. Если пользовательский проект или чертеж не указан в списке, следует нажать левой кнопкой мыши на "Диспетчер VBA" для загрузки проекта или чертежа.

Описание

Текстовое пояснение к выбранному макросу. Пользователь может изменять его по своему усмотрению. Пояснение сохраняется при переходе в другое поле диалогового окна.

Выполнить

Выполнение выбранного макроса.

Отладка

Открывает Редактор Visual Basic с загрузкой выбранного макроса. Процедура приостанавливается на первой исполняемой строке программного кода.

Изменить

Открывает Редактор Visual Basic с загрузкой выбранного макроса.

Создать

Создание макроса с именем, заданным в поле «Имя», и вызов Редактора Visual Basic с пустым телом для макроса.

Если для создаваемого макроса не указан файл проекта или чертеж, откроется диалоговое окно "Выбор проекта".

Если макрос с заданным именем уже существует, появляется сообщение, предлагающее перезаписать его.

При положительном ответе текст существующего макроса удаляется, и создается новый пустой макрос.

При отрицательном ответе программа возвращается в диалоговое окно «Макрос», где можно ввести другое имя.

Удалить

Удаление выбранного макроса.

Диспетчер VBA

Открывается диалоговое окно Диспетчер VBA.

Опции

Отображает диалоговое окно "Настройка".


Диалоговое окно «Выбор проекта»

V Команды
V Команды
Диалоговое окно «Выбор проекта»
Понятия Процедуры Команды

Меню "Сервис": » "Макрос"; "Макросы"

Ввод команды: vbarun

Приглашение к выбору проекта или чертежа для создания нового макроса. Необходимо выбрать проект или чертеж из списка и нажать «OK». Создается макрос, и открывается Редактор Visual Basic.


Диалоговое окно «Параметры»

V Команды
V Команды
Диалоговое окно «Параметры»
Понятия Процедуры Команды

Меню "Сервис": » "Макрос"; "Макросы"

Ввод команды: vbarun

Задает относящиеся к VBA параметры для текущего сеанса работы.

Включить автоматическое встраивание

Автоматическое создание встроенных проектов VBA для всех чертежей при их открытии.

Разрешить прерывания при ошибках

Позволяет VBA переходить в режим останова при обнаружении ошибок. Режим останова — это временное состояние программы, выполняемой в среде разработки. Находясь в этом режиме, можно проверять состояние переменных, отлаживать программу, выполнять повторный запуск, проходить в пошаговом режиме и запускать программу на выполнение.

Если опция «Разрешить прерывания при ошибках» активна, появление необрабатываемых ошибок ведет к приостанову выполнения макроса и вызову Редактора Visual Basic, установленного на точку входа в макрос.

Если опция «Разрешить прерывания при ошибках» сброшена, появление необрабатываемых ошибок ведет к показу сообщения и завершению макроса.

Включить защиту от вирусов

Включение механизма защиты от вирусов для макросов VBA. Этот механизм отвечает за выдачу предупреждения при открытии чертежей, которые потенциально могут содержать макровирусы.


VBARUN вариант для командной строки

V Команды
V Команды
VBARUN вариант для командной строки
Понятия Процедуры Команды

Если в ответ на запрос "Команда" ввести -vbarun, вызывается вариант команды VBARUN, использующий интерфейс командной строки.

Имя макроса: Ввести имя макроса для выполнения

Для встроенных или загруженных глобальных проектов здесь нужно ввести имя макроса, который требуется выполнить. Если имя не является уникальным в пределах загруженных проектов, следует ввести полное имя макроса, с указанием имени проекта и имени модуля. Например, для выполнения макроса «Test» из проекта «Project1» (модуль «Module1») нужно ввести:

Project1.Module1.Test

Для запуска макроса, хранящегося в пока не загруженном глобальном проекте, следует добавить к полному имени еще и имя DVB-файла. Например, если рассмотренный выше макрос «Test» находится в файле Acad_Projects.dvb и этот файл не загружен, для вызова макроса нужно ввести:

Acad_Projects.dvb!Project1.Module1.Test

Загрузится файл Acad_Projects.dvb, и будет выполнен макрос "Test". После завершения выполнения файл Acad_Projects.dvb остается загруженным.


VBASTMT Команда

V Команды
V Команды
VBASTMT Команда
Понятия Процедуры Команды

Выполнение выражения VBA в командной строке AutoCAD

Ввод команды: vbastmt

Выражение: Ввести выражение VBA для выполнения

Выражение Visual Basic — это законченная конструкция языка, которая может содержать ключевые слова, операторы, переменные и константы. Обычно каждое выражение занимает одну строку.) Для того, чтобы задать в одной строке несколько выражений, следует разделить их двоеточием (:).

Выражения VBA выполняются в командной строке в контексте текущего чертежа.


VBAUNLOAD Команда

V Команды
V Команды
VBAUNLOAD Команда
Понятия Процедуры Команды

Глобальная выгрузка проекта VBA

Ввод команды: vbaunload

Какой проект VBA выгрузить: Ввести имя проекта для выгрузки

Если имя проекта не задано, выгружается активный глобальный проект.


VLISP Команда

V Команды
V Команды
VLISP Команда
Понятия Процедуры Команды

Вызов интегрированной среды разработки приложений Visual LISP

Меню "Сервис": » AutoLISP; "Редактор Visual LISP"

Ввод команды: vlisp

Отобразится Visual LISP IDE. Visual LISP позволяет создавать, тестировать и отлаживать приложения AutoLISP.

Примечание VLIDE используется для передачи управления Visual LISP. Назначение этой команды аналогично назначению команды VLISP.


VSSAVE Команда

V Команды
V Команды
VSSAVE Команда
Понятия Процедуры Команды

Сохраняется визуальный стиль

Ввод команды: vssave

Сохранить текущий визуальный стиль как или [?]: Указать имя или ввести ? для вывода списка всех визуальных стилей в чертеже

Примечание Сохранение визуального стиля возможно только в пространстве модели. Если вводится имя, уже используемое в качестве имени визуального стиля, следует либо заменить имеющийся визуальный стиль, либо ввести другое имя.


Ключевые слова для команд

Использование ключевых слов помогает пользователю быстро выбирать объекты или указывать точки в процессе выполнения команды. Ключевые слова для координатных фильтров, указания точек методом "направление-расстояние", смещения, указания точки посредине между двумя точками и отслеживания можно использовать при любом запросе, в котором требуется указать точки. Ключевые слова режимов выбора используются при любом запросе, требующем выбрать объекты.


Ввод методом "направление-расстояние"
  • Ввод методом "направление-расстояние"
  • Ключевое слово СДТ
  • Ключевое слово СЛЕЖЕНИЕ
  • Ключевое слово СМЕЩЕНИЕ
  • Координатные фильтры
  • Режимы выбора объектов
  • Режимы объектной привязки


Ввод методом "направление-расстояние" Команда

Ввод методом "направление-расстояние"
Ввод методом "направление-расстояние"
Ввод методом "направление-расстояние" Команда
Понятия Процедуры Команды

Размещение следующей точки на определенном расстоянии от предыдущей в направлении, заданном с помощью курсора

Ввод команды: При появлении запроса на указание точки ввести число

С помощью метода "направление-расстояние" можно быстро указать точку относительно последней введенной точки. При появлении запроса на указание точки следует сначала переместить курсор, чтобы указать направление, а затем ввести числовое значение расстояния.

В следующем примере вторая точка отрезка располагается на расстоянии 5 единиц от первой точки в заданном курсором направлении. Расстояние отмеряется вдоль линии от последней введенной точки до текущего положения курсора. Этот метод указания точек обычно используется с включенными режимами "Орто" или "Шаг".

Команда: отрезок

Первая точка: Указать точку

Указать следующую точку: Переместить курсор в нужном направлении и ввести 5

Примечание Метод "направление-расстояние" недоступен, пока для режима "Орто", отслеживания объектной привязки или полярного отслеживания задействованы клавиши временной отмены.


Ключевое слово СДТ Команда

Ввод методом "направление-расстояние"
Ввод методом "направление-расстояние"
Ключевое слово СДТ Команда
Понятия Процедуры Команды

Указание расположения точки посредине между двумя другими точками

Ввод команды: При появлении запроса на указание точки ввести сдт

Ключевое слово указания точки посредине между двумя точками (СДТ) может быть применено при объектной привязке (команда ПРИВЯЗКА).

На любой запрос в командной строке о положении точки ввести сдт или с2т.

Первая точка середины: Указать точку

Вторая точка середины: Указать вторую точку


Ключевое слово СЛЕЖЕНИЕ Команда

Ввод методом "направление-расстояние"
Ввод методом "направление-расстояние"
Ключевое слово СЛЕЖЕНИЕ Команда
Понятия Процедуры Команды

Указание положения точки с помощью вспомогательных точек

Ввод команды: При появлении запроса на указание точки ввести слежение

Слежение включает режим "Орто" и может использоваться с режимом "Шаг".

При появлении запроса на указание точки ввести отслеживание, отс или сл.

Первая точка отслеживания: Указать положение или расстояние

Следующая точка (нажать ENTER для окончания отслеживания): Указать второе местоположение или расстояние

При слежении задается множество вспомогательных точек, каждая из них смещена относительно предыдущей. Так, путем задания множества временных направлений и расстояний можно определить положение новой точки. Для определения положения каждой временной точки можно воспользоваться методом направление-расстояние. В этом случае следует вначале переместить курсор в нужном направлении, а затем ввести численное значение расстояния.

Кроме того, средство отслеживания позволяет установить новую точку методом комбинирования значений X и Y двух заданных точек. Эти две точки можно указывать в любой последовательности, в зависимости от направления курсора после первой точки. Если используется метод "направление-расстояние", расстояние откладывается в направлении текущего положения курсора. Координатные фильтры комбинируют в одну точку значения X, Y и Z из разных точек. Ввод относительных координат задает положение точки относительно последней введенной точки.

Для получения доступа к средствам отслеживания, нажать клавишу SHIFT и, удерживая ее нажатой, нажать правую кнопку мыши для отображения контекстного меню привязки объекта.


Ключевое слово СМЕЩЕНИЕ Команда

Ввод методом "направление-расстояние"
Ввод методом "направление-расстояние"
Ключевое слово СМЕЩЕНИЕ Команда
Понятия Процедуры Команды

Привязка к точке, смещенной от указанной опорной точки на заданное расстояние

Панель инструментов "Объектная привязка":

Ввод команды: При появлении запроса на поиск точки ввести смещение

Базовая точка: Указать точку, которая будет использоваться в качестве базовой

от <смещения>: Ввести относительное смещение

При появлении запроса на указание точки ввести смещение, а затем указать временную опорную точку или базовую точку, относительно которой задается смещение для определения следующей точки. Указать местоположение смещения от этой базовой точки как относительную координату или воспользоваться методом направление-расстояние.

Примечание Этот метод указания точек невозможен при отслеживании в процессе выполнения таких команд, как ПЕРЕНЕСТИ и КОПИРОВАТЬ. Задание абсолютных координат с клавиатуры или с помощью указательного устройства отменяет ввод команды СМЕЩЕНИЕ.


Координатные фильтры Команда

Ввод методом "направление-расстояние"
Ввод методом "направление-расстояние"
Координатные фильтры Команда
Понятия Процедуры Команды

Задание координат точки путем комбинирования значений X, Y и Z других точек

Ввод команды: Ввести .x, .y, .xy, .xzили .yz

При появлении запроса на обнаружение точки можно ввести фильтры точек, чтобы указать одну координату путем извлечения значений координат X, Y и Z из нескольких точек. В следующем примере будет построена начальная точка отрезка, у которой координата X совпадает с координатой середины первого выбранного объекта, а координаты Y и Z с координатами середины второго выбранного объекта.

Команда: отрезок

Первая точка: .x

сер

Выбрать объект

(требуется YZ) сер

Выбрать другой объект

К точке: Указать точку


Режимы выбора объектов Команда

Ввод методом "направление-расстояние"
Ввод методом "направление-расстояние"
Режимы выбора объектов Команда
Понятия Процедуры Команды

Управление созданием наборов объектов

Ввод команды: При появлении запроса на выбор объектов следует ввести один из допустимых режимов выбора, описанных в команде ВЫБРАТЬ

Введенный режим выбора остается активным только для текущего запроса выбора объектов.


Режимы объектной привязки Команда

Ввод методом "направление-расстояние"
Ввод методом "направление-расстояние"
Режимы объектной привязки Команда
Понятия Процедуры Команды

Совмещение указываемой точки с характерной точкой на существующем объекте

Ввод команды: При появлении запроса на указание точки ввести один из допустимых режимов объектной привязки, описанных в команде -ПРИВЯЗКА, или выбрать режим на панели инструментов "Объектная привязка"

После активизации объектной привязки курсор принимает вид прицела объектной привязки. При выборе объекта курсор привязывается к соответствующей точке привязки, ближайшей к центру прицела.

Если режим объектной привязки выбран на панели или введен в командной строке, он действует только для указания одной точки. С помощью команды ПРИВЯЗКА устанавливаются постоянно действующие режимы объектной привязки. Для отключения разового и всех текущих режимов объектной привязки следует выбрать режим "Ничего".


Системные переменные

AutoCAD® хранит рабочие параметры операционной среды и некоторых команд в системных переменных. Для просмотра и изменения значения системной переменной можно непосредственно ввести ее имя в командной строке, либо воспользоваться командой УСТПЕРЕМ или функциями AutoLISP® getvar и setvar. Кроме того, значения многих системных переменных можно задать в диалоговых окнах команд

Для доступа к списку системных переменных следует перейти на вкладку "Содержимое" окна "Справка" и нажать значок "+", расположенный за полем "Системные переменные".


3D Системные переменные
  • 3DDWFPREC


3DDWFPREC Системная переменная

3D Системные переменные
3DDWFPREC Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 2

Управляет точностью публикации 3D ДВФ.

Эта системная переменная имеет диапазон от 1 до 6. Более высокая точность получается в результате более высокого значения параметра.

Значение DDWFPREC | Значение отклонения
1 | 1
2 | 0,5
3 | 0,2
4 | 0,1
5 | 0,01
6 | 0,001

Примечание При установке значения 3DDWFPREC равным 5 или 6 будут созданы очень большие 3D DWF-файлы или листы в многолистовых DWF-файлах.


A Системные переменные
  • ACADLSPASDOC
  • ACADPREFIX
  • ACADVER
  • ACISOUTVER
  • ADCSTATE
  • AFLAGS
  • ANGBASE
  • ANGDIR
  • APBOX
  • APERTURE
  • APSTATE
  • AREA
  • ASSISTSTATE
  • ATTDIA
  • ATTMODE
  • ATTREQ
  • AUDITCTL
  • AUNITS
  • AUPREC
  • AUTOSNAP


ACADLSPASDOC Системная переменная

A Системные переменные
ACADLSPASDOC Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управление режимом загрузки файла acad.lsp: либо в каждый чертеж, либо только при открытии первого чертежа в сеансе. .

0 | Загрузка файла acad.lsp только в первый чертеж, открытый в сеансе
1 | Загрузка файла acad.lsp в каждый открытый чертеж


ACADPREFIX Системная переменная

A Системные переменные
ACADPREFIX Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | путь

Сохранение пути (если имеется), заданного переменной среды ACAD, с добавлением разделителей пути (при необходимости). .


ACADVER Системная переменная

A Системные переменные
ACADVER Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен

Сохранение номера версии AutoCAD . Эта переменная отличается от переменной заголовка $ACADVER файла DXF, в которой содержится номер уровня базы данных чертежа.


ACISOUTVER Системная переменная

A Системные переменные
ACISOUTVER Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 70

Управление версией ACIS файлов SAT, созданных с помощью команды ACISOUT . ЭКСПОРТТЕЛ поддерживает значения от 15 до 18, 20, 21, 30, 40, 50, 60 и 70.


ADCSTATE Системная переменная

A Системные переменные
ADCSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | разные

Указывает на состояние DesignCenter™: активно или нет . Позволяет разработчикам определять статус с помощью AutoLISP.

0 | Не активна
1 | Активна


AFLAGS Системная переменная

A Системные переменные
AFLAGS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 16

Задание параметров для атрибутов . Значение является суммой следующих значений.

0 | Режим атрибута не выбран
1 | Скрытый
2 | Постоянный
4 | Контролируемый
8 | Установленный
16 | Зафиксировать положение в блоке


ANGBASE Системная переменная

A Системные переменные
ANGBASE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Задание для базового угла значения 0 в соответствии с текущей ПСК .


ANGDIR Системная переменная

A Системные переменные
ANGDIR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Задание направления для положительных углов. . Углы задаются относительно нулевого направления текущей ПСК.

0 | Против часовой стрелки
1 | По часовой стрелке


APBOX Системная переменная

A Системные переменные
APBOX Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Включает или отключает отображение прицела AutoSnap™ . Прицел выводится в центре перекрестья при привязке к точке объекта.

0 | Откл
1 | Вкл


APERTURE Системная переменная

A Системные переменные
APERTURE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 10

Установка размера прицела объектной привязки, в пикселах . Имя этой системной переменной совпадает с названием команды. Для доступа к системной переменной используется команда УСТПЕРЕМ.

Необходимо ввести значение (1-50). Чем выше число пикселов, тем больше прицел. Эту установку можно также изменить в диалоговом окне "Настройка" на вкладке "Построения"

Команда АПЕРТУРА изменяет размер прицела объектной привязки, а не прицела выбора объектов. Размер последнего задается системной переменной PICKBOX.


APSTATE Системная переменная

A Системные переменные
APSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Сохраняет значение, которое указывает, что открыто окно "Палитры вариаций блоков" в "Редакторе блоков".

0 | Замкнуто
1 | Открыть


AREA Системная переменная

A Системные переменные
AREA Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | Нет

Сохранение значения последней области, вычисленного с помощью команды ПЛОЩАДЬ . Имя этой системной переменной совпадает с названием команды. Для доступа к системной переменной используется команда УСТПЕРЕМ.


ASSISTSTATE Системная переменная

A Системные переменные
ASSISTSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | разные

Указывает состояние активности информационной палитры, отображающей краткую справку. .

0 | Не активна
1 | Активна


ATTDIA Системная переменная

A Системные переменные
ATTDIA Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Контроль команды ВСТАВИТЬ: используется ли диалоговое окно для указания значения атрибута. . Края граней, расположенных под большим углом, не сглаживаются. См. раздел ВСТАВИТЬ вариант для командной строки.

0 | Отображение подсказок в командной строке
1 | Использование диалогового окна


ATTMODE Системная переменная

A Системные переменные
ATTMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управление отображением атрибутов .

0 | Отключить: все атрибуты становятся невидимыми.
1 | Нормальное: сохраняется текущее состояние отображения каждого из атрибутов. Видимые атрибуты отображаются, скрытые - нет.
2 | Включить: все атрибуты видимы.


ATTREQ Системная переменная

A Системные переменные
ATTREQ Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Контроль использования командой ВСТАВИТЬ настроек по умолчанию для атрибутов в процессе вставки блоков.

0 | Для всех атрибутов принимаются значения по умолчанию.
1 | Отображение запросов или диалогового окна для значений атрибутов в соответствии с режимом, заданным ATTDIA


AUDITCTL Системная переменная

A Системные переменные
AUDITCTL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Контроль создания файла отчета проверки (ADT) с помощью команды ПРОВЕРИТЬ .

0 | Запрет записи файлов ADT
1 | Запись файлов ADT


AUNITS Системная переменная

A Системные переменные
AUNITS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Установка единиц измерения для углов .

0 | Десятичные градусы
1 | Градусы/минуты/секунды
2 | Грады
3 | Радианы
4 | Топографические единицы


AUPREC Системная переменная

A Системные переменные
AUPREC Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Установка количества десятичных знаков для всех значений углов со статусом "только для чтения", отображаемых в строке состояния, а также для всех редактируемых значений углов, точность которых меньше или равна текущему значению AUPREC . Предлагаемые для редактирования значения углов, точность которых равна или больше заданной в AUPREC, выводятся без усечения (т.е. с тем количеством десятичных знаков, которое имеется в действительности). AUPREC не влияет на точность отображения размерных текстов (см. РЗМСТИЛЬ).


AUTOSNAP Системная переменная

A Системные переменные
AUTOSNAP Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 63

Управление отображением маркера, всплывающей подсказки и магнита автопривязки . Включает также полярное и объектное отслеживания и управляет всплывающими на дисплей подсказками в этих режимах и режиме "Орто" Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Отключение маркера, подсказки и магнита автопривязки. Отключает также полярное и объектное отслеживания, а также подсказки этих средств и режима "Орто"
1 | Включение маркера автопривязки
2 | Включение подсказки автопривязки
4 | Включение магнита автопривязки
8 | Включение полярного отслеживания
16 | Включение отслеживания объектной привязки
32 | Включает отображение подсказки для полярного отслеживания, объектного отслеживания и режима "Орто"


B Системные переменные
  • BACKGROUNDPLOT
  • BACKZ
  • BACTIONCOLOR
  • BDEPENDENCYHIGHLIGHT
  • BGRIPOBJCOLOR
  • BGRIPOBJSIZE
  • BINDTYPE
  • BLIPMODE
  • BLOCKEDITLOCK
  • BLOCKEDITOR
  • BPARAMETERCOLOR
  • BPARAMETERFONT
  • BPARAMETERSIZE
  • BTMARKDISPLAY
  • BVMODE


BACKGROUNDPLOT Системная переменная

B Системные переменные
BACKGROUNDPLOT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Управление включением/отключением режима фонового вывода для операций печати и публикации . По умолчанию режим фонового вывода отключен в операциях печати и включен в операциях публикации.

Значение | ПЕЧАТЬ | ПУБЛ
0 | Передний план | Передний план
1 | Фон | Передний план
2 | Передний план | Фон
3 | Фон | Фон

При использовании в пакете (файл SCR) команд -ПЕЧАТЬ, ПЕЧАТЬ, -ПУБЛ и ПУБЛ значение системной переменной BACKGROUNDPLOT игнорируется, и команды -ПЕЧАТЬ, ПЕЧАТЬ, -ПУБЛ и ПУБЛ обрабатываются в стандартном (не фоновом) режиме.


BACKZ Системная переменная

B Системные переменные
BACKZ Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | Нет

Сохранение смещения задней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа). .

Имеет значение только, если секущая плоскость задана в командах КАМЕРА, ДВИД или 3DСЕКПЛ. При наличии нескольких камер значением является последняя задняя секущая плоскость, установленная как текущая. Для того, чтобы найти расстояние от камеры до задней секущей плоскости, нужно вычесть значение BACKZ из расстояния от камеры до цели.


BACTIONCOLOR Системная переменная

B Системные переменные
BACTIONCOLOR Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | 7

Установка цвета текста для операций, выполняемых в редакторе блоков . Значения выбираются из стандартного списка: BYLAYER, BYBLOCK и целые числа от 1 до 255.

Значения цветов полноцветного режима вводятся как уровни RGB-составляющих (целые числа от 1 до 255), разделенные запятыми. Значение цвета имеет следующий формат:

RGB:000,000,000


BDEPENDENCYHIGHLIGHT Системная переменная

B Системные переменные
BDEPENDENCYHIGHLIGHT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управление наличием выделенных взаимосвязей в зависимых объектах, когда параметр, действие или сетка выбраны в редакторе блоков .

0 | Указывает, что зависимые объекты не выделены
1 | Указывает, что зависимые объекты выделены

При выделении зависимостей объекты отображаются с эффектом ореола.


BGRIPOBJCOLOR Системная переменная

B Системные переменные
BGRIPOBJCOLOR Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | 141

Задает цвет ручек в редакторе блоков . Значения выбираются из стандартного списка: BYLAYER, BYBLOCK и целые числа от 1 до 255.

Значения цветов полноцветного режима вводятся как уровни RGB-составляющих (целые числа от 1 до 255), разделенные запятыми. Значение цвета имеет следующий формат:

RGB:000,000,000


BGRIPOBJSIZE Системная переменная

B Системные переменные
BGRIPOBJSIZE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 8

Установка отображаемого размера настраиваемых ручек в редакторе блоков относительно экранной системы . Допустимые значения содержат целые числа от 1 до 255.

С помощью команды РЕГЕН обновите отображаемый размер настраиваемых ручек в редакторе блоков.


BINDTYPE Системная переменная

B Системные переменные
BINDTYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Управление обработкой имен внешних ссылок при внедрении или редактировании внешних ссылок. .

0 | Традиционный способ внедрения ("xref1|one" преобразуется в "xref$0$one")
1 | Способ, аналогичный вставке блоков ("xref1|one" преобразуется в "one")


BLIPMODE Системная переменная

B Системные переменные
BLIPMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управление видимостью маркеров . Имя этой системной переменной совпадает с названием команды. Для доступа к системной переменной используется команда УСТПЕРЕМ.

0 | Отключение маркеров
1 | Включение маркеров


BLOCKEDITLOCK Системная переменная

B Системные переменные
BLOCKEDITLOCK Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Запрет открытия редактора блоков и редактирование определений динамических блоков . Если для BLOCKEDITLOCK установлено значение 1, то при двойном нажатии на динамический блок в чертеже откроется "Палитра свойств". Если динамический блок содержит атрибуты, то при двойном нажатии на вхождения блока откроется окно Редактор атрибутов блоков. Действия по двойному нажатию могут быть заданы пользователем с помощью редактора "Настройка интерфейса пользователя" (CUI).

0 | Указывает на то, что редактор блока можно открыть
1 | Указывает на то, что редактор блока нельзя открыть


BLOCKEDITOR Системная переменная

B Системные переменные
BLOCKEDITOR Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Отражает состояние редактора блока: открыт или не открыт .

0 | Означает, что редактор блока не открыт
1 | Означает, что редактор блока открыт


BPARAMETERCOLOR Системная переменная

B Системные переменные
BPARAMETERCOLOR Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | 7

Задает цвет параметров в редакторе блоков . Значения выбираются из стандартного списка: BYLAYER, BYBLOCKУ и целые числа от 1 до 255.

Значения цветов полноцветного режима вводятся как уровни RGB-составляющих (целые числа от 1 до 255), разделенные запятыми. Значение цвета имеет следующий формат:

RGB:000,000,000


BPARAMETERFONT Системная переменная

B Системные переменные
BPARAMETERFONT Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | Simplex.shx

Задает шрифт, используемый для параметров и операций в редакторе блоков .

Можно выбрать шрифт True Type или шрифт SHX (например, Verdana или Verdana.ttf). Для шрифта AutoCAD SHX необходимо добавить расширение .shx. При указании Asian Big Font используйте следующие правила именования: файл SHX, запятая (,), а затем имя файла Big Font (например, Simplex.shx,Bigfont.shx).


BPARAMETERSIZE Системная переменная

B Системные переменные
BPARAMETERSIZE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 12

Установка размера текста и функций параметра в редакторе блоков относительно экранной системы . Допустимые значения содержат целые числа от 1 до 255.


BTMARKDISPLAY Системная переменная

B Системные переменные
BTMARKDISPLAY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет отображением меток наборов значений для вхождений динамического блока .

0 | Указывает, что метки наборов значений не отображаются.
1 | Указывает, что метки наборов значений отображаются.


BVMODE Системная переменная

B Системные переменные
BVMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Управление способом отображения объектов, которые становятся невидимыми для текущего состояния видимости, в редакторе блока .

0 | Указывает, что скрытые объекты невидимы
1 | Указывает, что скрытые объекты видимы, но отображаются серым цветом


C Системные переменные
  • CALCINPUT
  • CAMERADISPLAY
  • CAMERAHEIGHT
  • CDATE
  • CECOLOR
  • CELTSCALE
  • CELTYPE
  • CELWEIGHT
  • CENTERMT
  • CHAMFERA
  • CHAMFERB
  • CHAMFERC
  • CHAMFERD
  • CHAMMODE
  • CIRCLERAD
  • CLAYER
  • CLEANSCREENSTATE
  • CLISTATE
  • CMATERIAL
  • CMDACTIVE
  • CMDDIA
  • CMDECHO
  • CMDINPUTHISTORYMAX
  • CMDNAMES
  • CMLJUST
  • CMLSCALE
  • CMLSTYLE
  • COMPASS
  • COORDS
  • CPLOTSTYLE
  • CPROFILE
  • CROSSINGAREACOLOR
  • CSHADOW
  • CTAB
  • CTABLESTYLE
  • CURSORSIZE
  • CVPORT


CALCINPUT Системная переменная

C Системные переменные
CALCINPUT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управление вычислением математических выражений и глобальных констант в полях для ввода текстовых или числовых данных .

0 | Выражения не вычисляются
1 | Выражения вычисляются после нажатия клавиш ALT+ENTER


CAMERADISPLAY Системная переменная

C Системные переменные
CAMERADISPLAY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Включает или выключает отображение объектов камеры. При использовании команды КАМЕРА значение изменяется на 1 (для отображения камер).

0 | Символьные обозначения камеры не выводятся на экран
1 | Символьные обозначения камеры выводятся на экран


CAMERAHEIGHT Системная переменная

C Системные переменные
CAMERAHEIGHT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Задает значение высоты по умолчанию для новых объектов камеры. Высота выражается в текущих единицах чертежа.


CDATE Системная переменная

C Системные переменные
CDATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | Не сохранен

Сохраняет текущие дату и время в десятичном формате.

Дата и время отображаются в десятичном формате, начиная с года. После десятичной точки команда CDATE отображает время в формате 24 часов. Например, 3 часа 05 минут после полудня в девятый день февраля 2006 года будет отображаться как 20060209.150500.


CECOLOR Системная переменная

C Системные переменные
CECOLOR Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | BYLAYER

Установка цвета для новых объектов. . Значения выбираются из стандартного списка: BYLAYER, BYBLOCK и целые числа от 1 до 255.

Значения цветов полноцветного режима вводятся после составляющей RGB как целые числа от 1 до 255, разделенные запятыми. Значение цвета имеет следующий формат.

RGB:000,000,000.


CELTSCALE Системная переменная

C Системные переменные
CELTSCALE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 1,0000

Установка текущего коэффициента масштабирования для типа линий объекта. . Установка значения масштабирования для новых объектов относительно установки команды ЛМАСШТАБ. Линия, созданная при CELTSCALE=2, выглядит в чертеже с базовым коэффициентом ЛМАСШТАБ=0.5 точно так же, как и линия с CELTSCALE=1 в чертеже с базовым коэффициентом ЛМАСШТАБ=1.


CELTYPE Системная переменная

C Системные переменные
CELTYPE Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | BYLAYER

Установка типа линии для новых объектов. .


CELWEIGHT Системная переменная

C Системные переменные
CELWEIGHT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | -1

Установка вес линий для новых объектов. .

-1 | Устанавливает значение BYLAYER для веса линий.
-2 | Устанавливает значение BYBLOCK для веса линий.
-3 | Устанавливает значение ПО УМОЛЧАНИЮ для веса линий. Значение веса ПО УМОЛЧАНИЮ контролируется системной переменной LWDEFAULT.

Другие допустимые значения 0, 5, 9, 13, 15, 18, 20, 25, 30, 35, 40, 50, 53, 60, 70, 80, 90, 100, 106, 120, 140, 158, 200 и 211.

Значения выражаются в сотых долях миллиметра. Для преобразования веса линий, выраженного в британской системе единиц, необходимо умножить его значение на коэффициент 2.54.


CENTERMT Системная переменная

C Системные переменные
CENTERMT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Пользовательские настройки
Начальное значение: | 0

Управление растягиванием центрированного по горизонтали многострочного текста с помощью ручек . Значение CENTERMT не применяется для растягивания многострочного текста с помощью линейки в текстовом редакторе, используемом в месте редактирования.

0 | При перемещении угловой ручки центрированного многострочного текста, центральная ручка перемещается в том же направлении, а ручка на противоположной стороне остается на месте
1 | При перемещении угловой ручки центрированного многострочного текста, центральная ручка остается на месте, и оба набора боковых ручек перемещаются в направлении растягивания


CHAMFERA Системная переменная

C Системные переменные
CHAMFERA Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Устанавливает первое расстояние фаски, когда значение CHAMMODE задано равным 0.


CHAMFERB Системная переменная

C Системные переменные
CHAMFERB Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Устанавливает второе расстояние фаски, когда значение CHAMMODE задано равным 0


CHAMFERC Системная переменная

C Системные переменные
CHAMFERC Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Устанавливает длину фаски, когда значение CHAMMODE задано равным 1.


CHAMFERD Системная переменная

C Системные переменные
CHAMFERD Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Устанавливает угол фаски, когда значение CHAMMODE задано равным 1.


CHAMMODE Системная переменная

C Системные переменные
CHAMMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Установка метода ввода для команды ФАСКА .

0 | Требуется ввод двух расстояний фаски
1 | Требуется ввод длины фаски и угла


CIRCLERAD Системная переменная

C Системные переменные
CIRCLERAD Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | 0,0000

Радиус круга по умолчанию. Нуль указывает на отсутствие значения по умолчанию .


CLAYER Системная переменная

C Системные переменные
CLAYER Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | 0

Установка имени текущего слоя .


CLEANSCREENSTATE Системная переменная

C Системные переменные
CLEANSCREENSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Сохраняет значение, которое указывает на включение состояния очистки экрана.

0 | Откл
1 | Вкл


CLISTATE Системная переменная

C Системные переменные
CLISTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 1

Сохранение значения, которое указывает состояние окна команды: скрыто или отображается .

0 | Скрытие
1 | Отображается


CMATERIAL Системная переменная

C Системные переменные
CMATERIAL Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | BYLAYER

Установка материала для новых объектов . Действительными значениями являются ПОСЛОЮ и имя материала в чертеже.


CMDACTIVE Системная переменная

C Системные переменные
CMDACTIVE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | Нет

Указывает на активность обычной команды, прозрачной команды, пакета команд или диалогового окна. . Параметр хранится в виде битового кода, использующего сумму следующих значений.

1 | Активна обычная команда
2 | Активны обычная команда и прозрачная команда
4 | Активен пакет команд
8 | Активно диалоговое окно
16 | Активно DDE
32 | Активно AutoLISP (отображается только для команды ObjectARX)
64 | Активна команда ObjectARX


CMDDIA Системная переменная

C Системные переменные
CMDDIA Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет отображением текстового редактора, используемого в месте редактирования, для команды БВЫНОСКА.

0 | Откл
1 | Вкл


CMDECHO Системная переменная

C Системные переменные
CMDECHO Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 1

Управление повтором подсказок и ввода при выполнении функции команды AutoLISP. .

0 | Выключение повтора
1 | Включение повтора


CMDINPUTHISTORYMAX Системная переменная

C Системные переменные
CMDINPUTHISTORYMAX Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 20

Установка максимального числа предыдущих значений ввода, которые хранятся в команде для запроса . Управление отображением последних введенных пользователем команд осуществляется системной переменной INPUTHISTORYMODE.


CMDNAMES Системная переменная

C Системные переменные
CMDNAMES Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | Нет

Отображает имена активной и прозрачной команд . Например, значение переменной LINE'ZOOM указывает на то, что команда МАСШТАБ используется в прозрачном режиме во время выполнения команды ОТРЕЗОК.

Переменная предназначена для использования в программном интерфейсе DIESEL.

Переменная предназначена для использования в программных интерфейсах, таких как AutoLISP, DIESEL и ActiveX Automation.

Приведенный ниже несложный пример демонстрирует, как с помощью DIESEL можно индицировать имена выполняемых команд в строке состояния.

Команда: modemacro

Новое значение MODEMACRO, или . если нет <"">: $(getvar, cmdnames)

Для получения дополнительной информации см. Введение в интерфейсы программирования в Руководстве по адаптации.


CMLJUST Системная переменная

C Системные переменные
CMLJUST Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Указывает выравнивание многострочного текста .

0 | Сверху
1 | Посередине
2 | Снизу


CMLSCALE Системная переменная

C Системные переменные
CMLSCALE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 1,0000 (британские единицы) или 20,0000 (метрические единицы)

Управление общей шириной многострочного текста . Например, при масштабе, равном 2.0, мультилиния оказывается вдвое шире, чем указано в описании. Если масштаб равен 0, мультилиния сжимается в одну линию. Отрицательное значение масштаба вызывает переворачивание мультилинии. Ширина в этом случае определяется абсолютной величиной масштаба.


CMLSTYLE Системная переменная

C Системные переменные
CMLSTYLE Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | СТАНДАРТ

Установка многострочного стиля, который управляет отображением многострочного текста .


COMPASS Системная переменная

C Системные переменные
COMPASS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Включение/отключение трехмерного компаса в текущем видовом экране .

0 | Отключение трехмерного компаса
1 | Включение трехмерного компаса


COORDS Системная переменная

C Системные переменные
COORDS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет форматом и частотой обновления координат на статусной строке.

0 | Абсолютные координаты устройства указания обновляются только, если заданы точки
1 | Абсолютные координаты устройства указания постоянно обновляются
2 | Абсолютные координаты устройства указания постоянно обновляются, кроме случаев запроса точки, расстояния или угла. В этом случае вместо Х и Y на экран выводятся относительные полярные координаты. Значения Z всегда выводятся как абсолютные координаты.


CPLOTSTYLE Системная переменная

C Системные переменные
CPLOTSTYLE Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | разные

Управление текущим стилем печати для новых объектов. . Если работа в текущем чертеже выполняется в цветозависимом режиме (для переменной PSTYLEPOLICY установлено значение 1), CPLOTSTYLE имеет статус "только чтение" и значение “ПоЦвету.” Если работа в текущем чертеже выполняется в режиме именованных стилей печати (для переменной PSTYLEPOLICY установлено значение 0), переменной CPLOTSTYLE можно установить следующие значения (значение “По Слою” является значением по умолчанию):

BYLAYER

BYBLOCK

"ОБЫЧНЫЙ"

"ПОЛЬЗОВАТЕЛЬСКИЙ"

Для изменения типа стилей печати, используемых в текущем чертеже, можно применить команду ПРЕОБРСПЕЧ.


CPROFILE Системная переменная

C Системные переменные
CPROFILE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | реестр
Начальное значение: | <<Unnamed Profile>>

Отображает имя текущего профиля . Для получения дополнительной информации о профилях см. команду НАСТРОЙКА.


CROSSINGAREACOLOR Системная переменная

C Системные переменные
CROSSINGAREACOLOR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 3 (зеленый)

Управление цветом области выбора в процессе выбора секущей рамки . Допустимый диапазон значений от 1 до 255. Системная переменная SELECTIONAREA должна быть активизирована.


CSHADOW Системная переменная

C Системные переменные
CSHADOW Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Задает свойство отображения теней для 3D объекта. Для обеспечения видимости следует включить отображение теней в стиле отображения, применяемом к видовому экрану.

0 | Отображает отбрасываемую и принимаемую тень
1 | Отображает отбрасываемую тень
2 | Отображает принимаемую тень
3 | Игнорирует тени

Примечание Для полного отображения теней требуется аппаратное ускорение. При отключенном параметре "Ускорение для геометрии" полное отображение теней невозможно. (Для доступа к эти установкам следует ввести графнастр в ответ на запрос команды. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" нажмите "Ручная настройка".)


CTAB Системная переменная

C Системные переменные
CTAB Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | разные

Отображение имени текущей вкладки (модель или лист) в чертеже. . Переменная может быть использована для определения активной вкладки из программных приложений.


CTABLESTYLE Системная переменная

C Системные переменные
CTABLESTYLE Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | СТАНДАРТ

Установка имени текущего стиля таблицы.


CURSORSIZE Системная переменная

C Системные переменные
CURSORSIZE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 5

Определение размера перекрестья в процентном отношении от размера экрана . Допустимые значения находятся в интервале от 1 до 100. При значении 100 перекрестье отображается на весь экран, и окончания образующих его линий не видны. При значении менее 100 окончания образующих перекрестье линий могут быть видимы при перемещении курсора.


CVPORT Системная переменная

C Системные переменные
CVPORT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 2

Отображает идентификационный номер текущего видового экрана . Пользователь может изменить это значение и, таким образом, сменить текущий видовой экран, если будут выполнены следующие условия:

  • Указанный номер принадлежит активному видовому экрану.
  • Движение курсора на этом видовом экране не заблокировано выполняемой командой.
  • Отключен режим планшета.


D Системные переменные
  • DASHBOARDSTATE
  • DATE
  • DBCSTATE
  • DBLCLKEDIT
  • DBMOD
  • DCTCUST
  • DCTMAIN
  • DEFAULTLIGHTING
  • DEFAULTLIGHTINGTYPE
  • DEFLPLSTYLE
  • DEFPLSTYLE
  • DELOBJ
  • DEMANDLOAD
  • DIASTAT
  • DIMADEC
  • DIMALT
  • DIMALTD
  • DIMALTF
  • DIMALTRND
  • DIMALTTD
  • DIMALTTZ
  • DIMALTU
  • DIMALTZ
  • DIMAPOST
  • DIMARCSYM
  • DIMASO
  • DIMASSOC
  • DIMASZ
  • DIMATFIT
  • DIMAUNIT
  • DIMAZIN
  • DIMBLK
  • DIMBLK1
  • DIMBLK2
  • DIMCEN
  • DIMCLRD
  • DIMCLRE
  • DIMCLRT
  • DIMDEC
  • DIMDLE
  • DIMDLI
  • DIMDSEP
  • DIMEXE
  • DIMEXO
  • DIMFIT
  • DIMFRAC
  • DIMFXL
  • DIMFXLON
  • DIMGAP
  • DIMJOGANG
  • DIMJUST
  • DIMLDRBLK
  • DIMLFAC
  • DIMLIM
  • DIMLTYPE
  • DIMLTEX1
  • DIMLTEX2
  • DIMLUNIT
  • DIMLWD
  • DIMLWE
  • DIMPOST
  • DIMRND
  • DIMSAH
  • DIMSCALE
  • DIMSD1
  • DIMSD2
  • DIMSE1
  • DIMSE2
  • DIMSHO
  • DIMSOXD
  • DIMSTYLE
  • DIMTAD
  • DIMTDEC
  • DIMTFAC
  • DIMTFILL
  • DIMTFILLCLR
  • DIMTIH
  • DIMTIX
  • DIMTM
  • DIMTMOVE
  • DIMTOFL
  • DIMTOH
  • DIMTOL
  • DIMTOLJ
  • DIMTP
  • DIMTSZ
  • DIMTVP
  • DIMTXSTY
  • DIMTXT
  • DIMTZIN
  • DIMUNIT
  • DIMUPT
  • DIMZIN
  • DISPSILH
  • DISTANCE
  • DONUTID
  • DONUTOD
  • DRAGMODE
  • DRAGP1
  • DRAGP2
  • DRAGVS
  • DRAWORDERCTL
  • DRSTATE
  • DTEXTED
  • DWFFRAME
  • DWFOSNAP
  • DWGCHECK
  • DWGCODEPAGE
  • DWGNAME
  • DWGPREFIX
  • DWGTITLED
  • DYNDIGRIP
  • DYNDIVIS
  • DYNMODE
  • DYNPICOORDS
  • DYNPIFORMAT
  • DYNPIVIS
  • DYNPROMPT
  • DYNTOOLTIPS


DASHBOARDSTATE Системная переменная

D Системные переменные
DASHBOARDSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | разные

Указывает состояние окна Пульта управления: активно или нет.

0 | Не активно
1 | Активно


DATE Системная переменная

D Системные переменные
DATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | разные

Сохраняет текущие дату и время в формате модифицированной даты по юлианскому календарю.. Значение представляется в виде модифицированной даты по юлианскому календарю (MJD), которая дополнена десятичной дробью, представляющей время суток:

<День по юлианскому календарю>.<Дробная часть дня>

Формат даты MJD (иначе называемый UT1) — это всемирный научный формат даты. Отсчет времени в этом формате начинается с полуночи 1 января 4713 года до нашей эры (B.C.E.). В этом формате момент времени 14 часов 29 минут 58 секунд 4 июля 1997 года представляется числом 2450634,60387736, а полдень 1 января 1998 представляется числом 2450815,50000000.

Для того, чтобы измерить временной промежуток, можно два раза прочитать значение переменной DATE и вычесть первое значение из второго. Для того, чтобы определить число секунд, истекших с полуночи до текущего момента, из значения переменной DATE, можно использовать процедуру на языке AutoLISP:

(setq s (getvar "DATE"))
(setq секунд (* 86400,0 (- s (fix s))))

Так как компьютерные часы отсчитывают дату и время, переменная DATE возвращает правильную дату по юлианскому календарю только в том случае, когда системные часы установлены на всемирное время (UTC). TDCREATE и TDUPDATE имеют тот же формат, что и переменная DATE, но их значения представляют время создания и время последней модификации текущего чертежа.


DBCSTATE Системная переменная

D Системные переменные
DBCSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Сохранение состояния Диспетчера подключения к БД: активен или неактивен .

0 | Не активен
1 | Активен


DBLCLKEDIT Системная переменная

D Системные переменные
DBLCLKEDIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Определяет действие по редактированию, выполняемое при двойном нажатии левой кнопки мыши в области чертежа . Пользователь может задавать действия, выполняемые по двойному нажатию левой кнопки мыши, с помощью редактора "Настройка интерфейса пользователя" (CUI). Системная переменная может принимать значения Вкл и Откл вместо 1 и 0.

0 | Сигнал неактивен
1 | Сигнал активен


DBMOD Системная переменная

D Системные переменные
DBMOD Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Определение состояния изменения в чертеже. . Параметр хранится в виде битового кода, использующего сумму следующих значений.

1 | База данных объекта изменена
4 | Переменная объекта изменена
8 | Окно изменено
16 | Вид изменен
32 | Поле изменено

При сохранении чертежа значение переменной DBMOD сбрасывается в 0.


DCTCUST Системная переменная

D Системные переменные
DCTCUST Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | путь

Отображает путь и имя файла текущего настраиваемого орфографического словаря. .


DCTMAIN Системная переменная

D Системные переменные
DCTMAIN Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | Зависит от страны/региона

Отображает имя файла текущего основного орфографического словаря. . Полный путь к данному файлу не отображается, так как предполагается, что этот файл должен находиться в папке "Support (Поддержка)".

Используемый по умолчанию основной орфографический словарь можно задать с помощью команды УСТПЕРЕМ В ответ на запрос о новом значении DCTMAIN разрешается вводить следующие значения: В зависимости от версии языка программы, возможно, не все словари будут доступны.

Ключевое слово | Имя языка
rus | Английский (США)
ena | Английский (Австралия)
ens | Английский (Великобритания, ise)
enz | Английский (Великобритания, ize)
ca | Каталонский
cs | Чешский
da | Датский
nl | Голландский (основной)
nls | Голландский (второй)
fi | Финский
fr | Французский (без диакритических знаков)
fra | Французский (с диакритическими знаками)
de | Немецкий (Scharfes s)
ded | Немецкий (Dopple s)
it | Итальянский
no | Норвежский (Bokmal)
non | Норвежский (Nynorsk)
pt | Португальский (иберский)
ptb | Португальский (бразильский)
ru | Русский (с использованием "ё")
rui | Русский (с использованием "е")
es | Испанский (без диакритических знаков)
esa | Испанский (с диакритическими знаками)
sv | Шведский


DEFAULTLIGHTING Системная переменная

D Системные переменные
DEFAULTLIGHTING Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет освещением по умолчанию в текущем видовом экране. Освещение по умолчанию обеспечивается набором удаленных источников света, которые светят в направлении вида. Если включено освещение по умолчанию, солнце и другие источники света не излучают свет, даже если они включены. Установка этой системной переменной зависит от видового экрана.

0 | Авто: освещение по умолчанию автоматически отключается, если включаются точечные источники света, прожекторы, удаленное освещение или солнечный свет.
1 | Вкл


DEFAULTLIGHTINGTYPE Системная переменная

D Системные переменные
DEFAULTLIGHTINGTYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Указывает тип освещения по умолчанию. В программе AutoCAD 2006 и более ранних версиях использовался один удаленный источник света в качестве освещения по умолчанию. В новом освещении по умолчанию используются два удаленных источника света, что позволяет обеспечить лучшее освещение модели, а также регулировать рассеянный свет. Установка этой системной переменной зависит от видового экрана.

0 | Старый тип освещения по умолчанию
1 | Новый тип освещения по умолчанию


DEFLPLSTYLE Системная переменная

D Системные переменные
DEFLPLSTYLE Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | разные

Указывает стиль печати по умолчанию для слоя 0. Если работа в текущем чертеже выполняется в цветозависимом режиме (для переменной PSTYLEPOLICY установлено значение 1), DEFLPLSTYLE имеет статус "только чтение" и значение “ПоЦвету.” Если работа в текущем чертеже выполняется в режиме именованных стилей печати (для переменной PSTYLEPOLICY установлено значение 0), переменная DEFLPLSTYLE является перезаписываемой и имеет значение по умолчанию “ОБЫЧНЫЙ.”

Для изменения типа стилей печати, используемых в текущем чертеже, можно применить команду ПРЕОБРСПЕЧ.


DEFPLSTYLE Системная переменная

D Системные переменные
DEFPLSTYLE Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр

Указывает стиль печати по умолчанию для новых объектов. . Если работа в текущем чертеже выполняется в цветозависимом режиме (для переменной PSTYLEPOLICY установлено значение 1), DEFPLSTYLE имеет статус "только чтение" и значение “ПоЦвету.” Если работа в текущем чертеже выполняется в режиме именованных стилей печати (для переменной PSTYLEPOLICY установлено значение 0), переменная DEFPLSTYLE является перезаписываемой и имеет значение по умолчанию “ПоСлою.”

Для изменения типа стилей печати, используемых в текущем чертеже, можно применить команду ПРЕОБРСПЕЧ.


DELOBJ Системная переменная

D Системные переменные
DELOBJ Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет сохранением или удалением геометрических объектов, использованных для создания 3D объектов..

0 | Сохраняется вся определяющая геометрия.
1 | Кривые профиля удаляются, в том числе те, которые были использованы с командами ВЫДАВИТЬ, СДВИГ, ВРАЩАТЬ и ПОСЕЧЕНИЯМ. Поперечные сечения, использованные с командой ПОСЕЧЕНИЯМ, также удаляются.
2 | Удаляется вся определяющая геометрия, в том числе траектории и направляющие кривые, использованные с командами СДВИГ и ПОСЕЧЕНИЯМ.
-1 | Запрос на удаление кривых профиля, в том числе тех, которые были использованы с командами ВЫДАВИТЬ, СДВИГ, ВРАЩАТЬ и ПОСЕЧЕНИЯМ. Поперечные сечения, использованные с командой ПОСЕЧЕНИЯМ, также удаляются.
-2 | Запрос на удаление всей определяющей геометрии, в том числе траекторий и направляющих кривых, использованных с командами СДВИГ и ПОСЕЧЕНИЯМ.


DEMANDLOAD Системная переменная

D Системные переменные
DEMANDLOAD Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | Начальное значение: 3

Определяет условие загрузки определенных приложений . Если установить эту системную переменную в 0, сторонние приложения и некоторые команды AutoCAD могут не работать.

0 | Отключение подгрузки.
1 | Режим подгрузки стороннего приложения при открытии чертежа, который содержит объекты, созданные в этом приложении. Это значение не вызывает подгрузку приложения при вызове одной из команд приложения.
2 | Требует подгрузки приложения-источника при вызове одной из команд приложения. Это значение не вызывает подгрузку приложения при открытии чертежа, в котором содержатся принадлежащие приложению объекты.
3 | Требует подгрузки приложения-источника при открытии чертежа, содержащего пользовательские объекты, или при вызове одной из команд приложения.


DIASTAT Системная переменная

D Системные переменные
DIASTAT Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | Нет

Поддержка метода выхода из последнего использованного диалогового окна. .

0 | Отмена
1 | OK

Примечание Системная переменная DIASTAT не применяется в диалоговых окнах стандартного выбора файлов, таких как диалоговые окна "Выбрать файл" и "Сохранить чертеж как".


DIMADEC Системная переменная

D Системные переменные
DIMADEC Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управление отображением числа точных знаков в угловых размерах. .

-1 | В угловых размерах отображается количество знаков после запятой, указанных с помощью переменной DIMDEC.
0-8 | Указывает количество знаков после запятой, отображаемых в угловых размерах (независимо от переменной DIMDEC)


DIMALT Системная переменная

D Системные переменные
DIMALT Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Управление альтернативными единицами в размерах. .

См. также DIMALTD, DIMALTF, DIMALTTD, DIMALTTZ, DIMALTZ и DIMAPOST.

Откл | Отключение альтернативных единиц
Вкл | Включение альтернативных единиц


DIMALTD Системная переменная

D Системные переменные
DIMALTD Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 2

Управление количеством десятичных знаков в альтернативных единицах. . Если системная переменная DIMALT включена, переменная DIMALTD задает количество знаков после запятой, отображаемых в альтернативных размерах.


DIMALTF Системная переменная

D Системные переменные
DIMALTF Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 25,4000

Управление множителем для альтернативных единиц. . Если переменная DIMALT включена, переменная DIMALTF умножает линейные размеры на коэффициент для создания значения в альтернативной системе измерений. Начальное значение переменной равно числу миллиметров в одном дюйме.


DIMALTRND Системная переменная

D Системные переменные
DIMALTRND Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,00

Округление альтернативных единиц измерения в размерах. .


DIMALTTD Системная переменная

D Системные переменные
DIMALTTD Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 2

Установка числа знаков после запятой в значениях допуска для альтернативных размерных единиц .


DIMALTTZ Системная переменная

D Системные переменные
DIMALTTZ Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управление подавлением нулей в значениях допуска. .

0 | Подавляет нулевые значения для футов и дюймов
1 | Записывает нулевые значения для футов и дюймов
2 | Записывает нулевые значения для футов и подавляет нулевые значения для дюймов
3 | Записывает нулевые значения для дюймов и подавляет нулевые значения для футов

Для подавления ведущих или замыкающих нулей к выбранному значению может быть добавлено:

4 | Подавление ведущих нулевых значений
8 | Подавление замыкающих нулевых значений.


DIMALTU Системная переменная

D Системные переменные
DIMALTU Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 2

Установка формата альтернативных единиц измерения для всех вторичных размерных стилей за исключением угловых. .

1 | Научные
2 | Десятичные
3 | Конструкторский
4 | Архитектурные (дробные)
5 | Дробные
6 | Архитектурные
7 | С дробной частью
8 | Установленные в Microsoft Windows (десятичный формат, в котором используются настройки панели управления для десятичного разделителя и группирования разрядов)


DIMALTZ Системная переменная

D Системные переменные
DIMALTZ Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управление подавлением нулей в альтернативных размерных единицах. . Значения переменной DIMALTZ от 0 до 3 относятся только к размерам, выраженным в футах и дюймах.

0 | Подавляет нулевые значения для футов и дюймов
1 | Записывает нулевые значения для футов и дюймов
2 | Записывает нулевые значения для футов и подавляет нулевые значения для дюймов
3 | Записывает нулевые значения для дюймов и подавляет нулевые значения для футов
4 | Подавляет ведущие нулевые значения в десятичных размерах (например, 0,5000 записывается как ,5000)
8 | Подавляет замыкающие нулевые значения в десятичных размерах (например, 12,5000 записывается как 12,5)
12 | Подавляет и ведущие, и замыкающие нулевые значения (например, 0,5000 записывается как ,5)


DIMAPOST Системная переменная

D Системные переменные
DIMAPOST Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | Нет

Указывает префикс или суффикс текста (или и то, и другое) для альтернативных размерных единиц для всех типов размеров, кроме угловых .

Например, если текущие единицы измерения являются архитектурными, переменная DIMALT включена, для переменной DIMALTF установлено значение 25,4 (значение миллиметров на дюйм), для переменной DIMALTD установлено значение 2, а для переменной DIMPOST установлено значение "мм", для расстояния для 10 единиц будет отображаться значение 10"[254,00 мм].

Для того чтобы отключить присоединение дополнительной строки, нужно присвоить переменной значение, состоящее только из одной точки (.).


DIMARCSYM Системная переменная

D Системные переменные
DIMARCSYM Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет отображением символа дуги в размере длины дуги.

0 | Помещает символы длины дуги перед текстом размера
1 | Помещает символы длины дуги над текстом размера
2 | Запрещает отображение символов длины дуги


DIMASO Системная переменная

D Системные переменные
DIMASO Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Вкл

Устар. . Сохранение в продукте для поддержания целостности сценариев. См. DIMASSOC.


DIMASSOC Системная переменная

D Системные переменные
DIMASSOC Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 2

Управляет ассоциативностью размерных объектов и расчленением размеров..

0 | Создание расчлененных размеров. Связь между элементами размера отсутствует. Составляющие размер отрезки, дуги, стрелки и текст строятся как отдельные объекты.
1 | Создание объектов неассоциативных размеров. Все составляющие размер элементы представляют собой единый объект. При перемещении определяющей точки размера его значение автоматически пересчитывается.
2 | Создание объектов ассоциативных размеров. Все составляющие размер элементы представляют собой единый объект. Кроме того, одна или несколько определяющих точек размера связаны с точками прикрепления на геометрических объектах. При перемещении ассоциативной точки на геометрическом объекте будут обновлены местоположение, ориентация и значение.

DIMASSOC не сохраняется в размерных стилях.

В чертеже, сохраненном в формате программы, которая предшествует версии AutoCAD 2002, сохраняются настройки системной переменной DIMASSOC. В случае открытия чертежа в программе AutoCAD 2002 или более поздней версии настройка ассоциативности размеров восстанавливается. Если открыть традиционный чертеж в программе AutoCAD 2002, системная переменная DIMASSOC примет значение системной переменной DIMASO традиционного чертежа.


DIMASZ Системная переменная

D Системные переменные
DIMASZ Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,1800

Управление величинами стрелок размерных линий и линий выноски , а также длинами полок выносок.

На основании величин стрелок AutoCAD принимает решение о том, где размещать размерные линии и текст — между выносными линиями или за их пределами. Переменная DIMASZ используется также для масштабирования блоков стрелок, если они заданы в переменной DIMBLK. Если значение переменной DIMASZ не равно нулю, переменная DIMTSZ не будет работать.


DIMATFIT Системная переменная

D Системные переменные
DIMATFIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 3

Определение размещения размерного текста и стрелок, если и для текста, и для стрелок недостаточно места в выносных линиях .

0 | Размещение текста и стрелок за пределами выносных линий
1 | Сначала перемещаются стрелки, затем текст
2 | Сначала перемещается текст, затем стрелки
3 | Перемещение текста или стрелок (выбирается оптимальное размещение).

Если для параметра DIMTMOVE установлено значение 1, выноска добавляется к перемещенному размерному тексту.


DIMAUNIT Системная переменная

D Системные переменные
DIMAUNIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Установка формата единиц измерения для угловых размеров. .

0 | Десятичные градусы
1 | Градусы/минуты/секунды
2 | Грады
3 | Радианы

Значение DIMAUNIT может изменяться как непосредственно из командной строки, так и на вкладке "Размещение" диалогового окна работы с размерными стилями.


DIMAZIN Системная переменная

D Системные переменные
DIMAZIN Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Подавление нулевых значений для всех угловых размеров. .

0 | Отображает все ведущие и замыкающие нули.
1 | Подавляет ведущие нулевые значения в десятичных размерах (например, 0,5000 записывается как ,5000)
2 | Подавляет замыкающие нулевые значения в десятичных размерах (например, 12,5000 записывается как 12,5)
3 | Подавление ведущих и замыкающих нулевых значений (например, 0,5000 записывается как ,5)


DIMBLK Системная переменная

D Системные переменные
DIMBLK Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | Нет

Установка блока стрелок, отображаемого на концах размерных линий или линий выноски. . Для того чтобы вернуться к стандартным заполненным замкнутым стрелкам, следует ввести точку (.). Ниже представлены элементы и имена блоков стрелок, используемых для выбора блоков в диалоговых окнах "Создание", "Изменение" и "Переопределение размерного стиля". Разрешается также использовать в качестве стрелок пользовательские блоки.

"" | заполненная замкнутая
"_DOT" | точка
"_DOTSMALL" | малая точка
"_DOTBLANK" | контурная точка
"_ORIGIN" | указатель исходной точки
"_ORIGIN2" | указатель исходной точки 2
"_OPEN" | разомкнутая
"_OPEN90" | прямой угол
"_OPEN30" | разомкнутая 30
"_CLOSED" | замкнутая
"_SMALL" | контурная малая точка
"_NONE" | отсутствует
"_OBLIQUE" | наклон
"_BOXFILLED" | заполненный прямоугольник
"_BOXBLANK" | прямоугольник
"_CLOSEDBLANK" | контурная замкнутая
"_DATUMFILLED" | заполненный треугольник
"_DATUMBLANK" | треугольник
"_INTEGRAL" | интеграл
"_ARCHTICK" | двойная засечка


DIMBLK1 Системная переменная

D Системные переменные
DIMBLK1 Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | Нет

Установка стрелки на первом конце размерной линии (при включенной переменной DIMSAH). . Для того чтобы вернуться к стандартным заполненным замкнутым стрелкам, следует ввести точку (.). Полный список стрелок приведен в описании переменной DIMBLK.


DIMBLK2 Системная переменная

D Системные переменные
DIMBLK2 Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | Нет

Установка стрелки на втором конце размерной линии (при включенной переменной DIMSAH). . Для того чтобы вернуться к стандартным заполненным замкнутым стрелкам, следует ввести точку (.). Полный список стрелок приведен в описании переменной DIMBLK.


DIMCEN Системная переменная

D Системные переменные
DIMCEN Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0900

Управление рисованием маркеров центра и центровых линий кругов и дуг с помощью команд РЗМЦЕНТР, РЗМДИАМЕТР и РЗМРАДИУС. . В командах РЗМДИАМЕТР и РЗМРАДИУС можно нарисовать маркеры центра только в том случае, если размерная линия размещается за границами круга или дуги.

0 | Не выполняется рисование ни маркера центра, ни центровых линий.
<0 | Выполняется рисование центровых линий
>0 | Выполняется рисование маркеров центра

Величина маркеров центра определяется абсолютным значением переменной.

Размер центровой линии равен длине сегмента центровой линии, выходящего за пределы круга или дуги. Это также и размер промежутка между маркером центра и началом центровой линии.

Размер маркера центра равен расстоянию от центра круга или дуги до конца маркера центра.


DIMCLRD Системная переменная

D Системные переменные
DIMCLRD Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Указание цветов для размерных линий, стрелок и размерных линий выноски. . Переменная также задает цвет линий выноски, создаваемых с помощью команды ВЫНОСКА. Номера цветов отображаются в диалоговом окне "Выбор цвета". Для BYBLOCK ввести 0. Для BYLAYER ввести 256.


DIMCLRE Системная переменная

D Системные переменные
DIMCLRE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Задает цвет для размерных выносных линий. . Номера цветов отображаются в диалоговом окне "Выбор цвета". Для BYBLOCK ввести 0. Для BYLAYER ввести 256.


DIMCLRT Системная переменная

D Системные переменные
DIMCLRT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Цвет, которым рисуется размерный текст. Для цвета можно выбрать любой допустимый номер цвета . См. DIMCLRD.


DIMDEC Системная переменная

D Системные переменные
DIMDEC Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 4

Установка числа десятичных знаков, отображаемых для основных единиц размера . Точность представления основывается на выбранном формате единиц.


DIMDLE Системная переменная

D Системные переменные
DIMDLE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Установка значения расстояния, на которое размерная линия выступает за выносную линию, когда наклонные засечки рисуются вместо стрелок .


DIMDLI Системная переменная

D Системные переменные
DIMDLI Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,3800

Управление расстоянием между размерными линиями в базовых размерах . Каждая новая размерная линия смещается относительно предыдущей на заданное здесь число единиц. На уже имеющиеся размеры изменение DIMDLI никакого влияния не оказывает.


DIMDSEP Системная переменная

D Системные переменные
DIMDSEP Системная переменная
Понятия Процедуры Команды

Тип: | Односимвольный
Сохранен в: | чертеж
Начальное значение: | символ точки

Задает символ десятичного разделителя, используемый при создании размеров с десятичным форматом единиц измерения. .

На запрос в командной строке нужно ввести требуемый символ. Если установлен десятичный формат единиц, то вместо используемой по умолчанию десятичной точки применяется символ, хранящийся в переменной DIMDSEP. Если для переменной DIMDSEP установлено значение NULL (значение по умолчанию, сбрасывается при вводе точки), символ точки используется в качестве десятичного разделителя.


DIMEXE Системная переменная

D Системные переменные
DIMEXE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,1800

Задает величину, на которую выносная линия должна выступать за размерную линию .


DIMEXO Системная переменная

D Системные переменные
DIMEXO Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0625

Задает величину смещения выносных линий относительно исходных точек . При использовании выносных линий фиксированной длины это значение определяет минимальную величину смещения.


DIMFIT Системная переменная

D Системные переменные
DIMFIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 3

Не употребляется, вместо нее использовать DIMATFIT и DIMTMOVE . Переменная DIMFIT заменена переменными DIMATFIT и DIMTMOVE. Однако, если переменной DIMFIT установлено значение 0 - 3, то DIMATFIT также устанавливается значение 0 - 3, а DIMTMOVE – значение 0. Если переменной DIMFIT установлено значение 4 или 5, то DIMATFIT устанавливается значение 3, а DIMTMOVE – соответственно 1 или 2.


DIMFRAC Системная переменная

D Системные переменные
DIMFRAC Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Установка формата дроби, если для переменной DIMLUNIT установлено значение 4 (архитектурные) или 5 (дробные).

0 | Горизонтальный
1 | Диагональ
2 | В одну строку (например, 1/2


DIMFXL Системная переменная

D Системные переменные
DIMFXL Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 1,0000

Устанавливает общую длину выносных линий от размерной линии до исходной точки размера . Длина устанавливается в единицах чертежа.


DIMFXLON Системная переменная

D Системные переменные
DIMFXLON Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Управляет установкой фиксированной длины выносных линий. Если значением DIMFXLON является вкл, то длина выносных линий устанавливается равной длине, заданной в DIMFXL.


DIMGAP Системная переменная

D Системные переменные
DIMGAP Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0900

Установка зазора вокруг размерного текста при разрыве размерной линии в соответствии с размерным текстом . Задает также зазор между пояснительным текстом и полкой выноски, созданной с помощью команды ВЫНОСКА. При задании отрицательного значения DIMGAP помещает размерный текст в рамку.

Переменная DIMGAP также используется в качестве минимальной длины отрезков размерной линии. При вычислении местоположения по умолчанию для размерного текста текст размещается внутри выносных линий только в том случае, если при этом размерные линии разбиваются на два сегмента, длина которых не меньше значения, заданного переменной DIMGAP. Текст, размещенный выше или ниже размерной линии, перемещается в размерную линию только в том случае, если имеется место для стрелок и размерного текста с интервалом между ними не меньше значения переменной DIMGAP: 2 * (DIMASZ + DIMGAP).


DIMJOGANG Системная переменная

D Системные переменные
DIMJOGANG Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 45 (90 в метрических размерах)

Определяет угол поперечного сегмента размерной линии в ломаной линии размера радиуса. Ломаные линии размеров радиуса строятся в случаях, когда центр расположен за пределами страницы.


DIMJUST Системная переменная

D Системные переменные
DIMJUST Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управление положением размерного текста по горизонтали .

0 | Размещение текста над размерной линией и центром (выравнивание между выносными линиями)
1 | Размещение текста рядом с первой выносной линией
2 | Размещение текста рядом со второй выносной линией
3 | Размещение текста над первой выносной линией и выравнивание с ней
4 | Размещение текста над второй выносной линией и выравнивание с ней


DIMLDRBLK Системная переменная

D Системные переменные
DIMLDRBLK Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | Нет

Задает тип стрелки для выносок . Для того чтобы вернуться к стандартным заполненным замкнутым стрелкам, следует ввести точку (.). Полный список стрелок приведен в описании переменной DIMBLK.


DIMLFAC Системная переменная

D Системные переменные
DIMLFAC Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 1,0000

Установка масштабного коэффициента для значений линейных размеров. . Все измеренные расстояния (в т.ч. радиусы, диаметры и координаты) перед генерацией размерных текстов умножаются на этот коэффициент. Положительные значения переменной DIMLFAC используются для размеров в пространстве модели и в пространстве листа; отрицательные значения используются только в пространстве листа.

DIMLFAC применяется, в основном, к неассоциативным размерам (значение DIMASSOC установлено равным 0 или 1). Для неассоциативных размеров в пространстве листа значение DIMLFAC должно быть установлено отдельно для каждого видового экрана листа, чтобы обеспечить масштабирование видового экрана.

Переменная DIMLFAC не влияет на угловые размеры и не применяется к числам, хранящимся в переменных DIMRND, DIMTM и DIMTP.


DIMLIM Системная переменная

D Системные переменные
DIMLIM Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Создание ограничений размеров в качестве текста по умолчанию . Включение DIMLIM приводит к автоматическому отключению переменной DIMTOL.

Откл | Пределы размеров не создаются как текст по умолчанию
Вкл | Пределы размеров создаются как текст по умолчанию


DIMLTYPE Системная переменная

D Системные переменные
DIMLTYPE Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | ""

Устанавливает тип размерной линии. Значением переменной могут быть BYLAYER, BYBLOCK или имя типа линии.


DIMLTEX1 Системная переменная

D Системные переменные
DIMLTEX1 Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | ""

Устанавливает тип первой выносной линии. Значением переменной могут быть BYLAYER, BYBLOCK или имя типа линии.


DIMLTEX2 Системная переменная

D Системные переменные
DIMLTEX2 Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | ""

Устанавливает тип второй выносной линии. Значением переменной могут быть BYLAYER, BYBLOCK или имя типа линии.


DIMLUNIT Системная переменная

D Системные переменные
DIMLUNIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 2

Установка единиц для всех типов размеров, кроме угловых. .

1 | Научные
2 | Десятичные
3 | Конструкторский
4 | Архитектурные (всегда отображается в дробном виде)
5 | Дробные (всегда отображается в дробном виде)
6 | Установленные в Microsoft Windows (десятичный формат, в котором используются настройки панели управления для десятичного разделителя и группирования разрядов)


DIMLWD Системная переменная

D Системные переменные
DIMLWD Системная переменная
Понятия Процедуры Команды

Тип: | значение из стандартного списка
Сохранен в: | чертеж
Начальное значение: | -2

Задание веса для размерных линий. . Значения выбираются из стандартного списка.

-3 | По умолчанию (значение переменной LWDEFAULT)
-2 | BYBLOCK
-1 | BYLAYER

Целое число представляет 1/100 мм.


DIMLWE Системная переменная

D Системные переменные
DIMLWE Системная переменная
Понятия Процедуры Команды

Тип: | значение из стандартного списка
Сохранен в: | чертеж
Начальное значение: | -2

Задание веса для выносных линий . Значения выбираются из стандартного списка.

-3 | По умолчанию (значение переменной LWDEFAULT)
-2 | BYBLOCK
-1 | BYLAYER

Целое число представляет 1/100 мм.


DIMPOST Системная переменная

D Системные переменные
DIMPOST Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | Нет

Указание префикса или суффикса текста (или и того, и другого) для размерных единиц . Чтобы задать размерный суффикс, обозначающий единицы измерения (миллиметры), следует присвоить DIMPOST значение "мм". Тогда, например, измеренное значение расстояния 19.2 единиц будет представлено на чертеже как "19.2 мм".

Если включены допуски, суффикс присоединяется как к основному размеру, так и к допускам.

Положение измеренного значения в размерном тексте задается пустыми угловыми скобками (<>). Например, введите <>мм, чтобы отобразить значение "5,0 мм" для радиуса в 5 миллиметров. При вводе мм <> отобразится размер "мм 5,0". Для угловых размеров, к которым не требуется ничего присоединять, можно присвоить переменной значение, состоящее только из пары угловых скобок.


DIMRND Системная переменная

D Системные переменные
DIMRND Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Округление всех размерных расстояний в соответствии с указанным значением . Например, если задать значение 0.25, все измеренные расстояния будут округлены до ближайшего кратного 0.25. Если же DIMRND равна 1.0, все измеренные расстояния будут округлены до ближайшего целого. Следует учитывать, что количество цифр, воспринимаемых после десятичной точки, зависит от значения переменной DIMDEC. На угловые размеры DIMRND не действует.


DIMSAH Системная переменная

D Системные переменные
DIMSAH Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Управление отображением блоков стрелок размерных линий. .

Откл | Использование блоков стрелок, установленных с помощью переменной DIMBLK
Вкл | Использование блоков стрелок, установленных с помощью переменных DIMBLK1 и DIMBLK2


DIMSCALE Системная переменная

D Системные переменные
DIMSCALE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 1,0000

Установка общего коэффициента масштабирования, применяемого для размерных переменных, задающих размеры, расстояния или смещения . Влияет также на масштаб выносных объектов, созданных с помощью команды ВЫНОСКА.

0,0 | Приемлемое значение по умолчанию вычисляется путем масштабирования между текущими видовыми экранами пространства модели и пространством листа. Если пространство листа не используется, коэффициент равен 1.0.
>0 | Вычисляется коэффициент масштабирования, который направляет размеры текста, размеры стрелок и другие масштабируемые величины на печать с их номинальными значениями.

DIMSCALE не влияет на измеренные расстояния, координаты и углы.


DIMSD1 Системная переменная

D Системные переменные
DIMSD1 Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Управление подавлением первой размерной линии .

Во включенном состоянии вызывает подавление нанесения той части размерной линии и размерной стрелки, которая находится между первой выносной линией и размерным текстом.


DIMSD2 Системная переменная

D Системные переменные
DIMSD2 Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Управление подавлением второй размерной линии .

Во включенном состоянии вызывает подавление нанесения той части размерной линии и размерной стрелки, которая находится между второй выносной линией и размерным текстом.


DIMSE1 Системная переменная

D Системные переменные
DIMSE1 Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Подавление отображения первой выносной линии .

Откл | Выносная линия не подавляется
Вкл | Выносная линия подавляется


DIMSE2 Системная переменная

D Системные переменные
DIMSE2 Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Подавление отображения второй выносной линии .

Откл | Выносная линия не подавляется
Вкл | Выносная линия подавляется


DIMSHO Системная переменная

D Системные переменные
DIMSHO Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Вкл

Устар. . Сохранена лишь для совместимости с пакетными файлами, написанными для прежних версий программы.


DIMSOXD Системная переменная

D Системные переменные
DIMSOXD Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Подавляет отображение стрелок при отсутствии достаточного пространства между выносными линиями.

Откл | Стрелки не подавляются
Вкл | Стрелки подавляются

Если достаточное пространство между выносными линиями отсутствует, и значение DIMTIX равно вкл, то при установке DIMSOXD равной вкл стрелки подавляются Если DIMTIX отключена, DIMSOXD не оказывает никакого влияния.


DIMSTYLE Системная переменная

D Системные переменные
DIMSTYLE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | СТАНДАРТ

Сохранение имени текущего размерного стиля . Имя этой системной переменной совпадает с названием команды. Для доступа к этой системной переменной используется команда УСТПЕРЕМ. Системная переменная DIMSTYLE имеет статус "только для чтения". Для изменения текущего размерного стиля используйте команду РЗМСТИЛЬ.


DIMTAD Системная переменная

D Системные переменные
DIMTAD Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управление расположением текста по вертикали относительно размерной линии .

0 | Расположение размерного текста по центру между выносными линиями.
1 | Размещает размерный текст над размерной линией (кроме случая, когда размерная линия не горизонтальна, а текст между выносными линиями принудительно сделан горизонтальным, т.е. когда DIMTIH = 1). Расстояние от размерной линии до базовой линии нижней границы текста равно текущему значению переменной DIMGAP.
2 | Размещает размерный текст рядом с размерной линией со стороны, наиболее удаленной от определяющих точек.
3 | Размещает размерный текст согласно требованиям промышленных стандартов Японии JIS (Japanese Industrial Standards).


DIMTDEC Системная переменная

D Системные переменные
DIMTDEC Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 4

Устанавливает количество десятичных знаков для значений допусков в основных единицах . Эта системная переменная не оказывает никакого действия, пока переменная DIMTOL не включена. Значение по умолчанию для переменной DIMTOL является Откл.


DIMTFAC Системная переменная

D Системные переменные
DIMTFAC Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 1,0000

Указывает масштабный коэффициент для высоты текста дробных частей размеров и допусков относительно высоты размерного текста, заданной в переменной DIMTXT . Например, если DIMTFAC = 1.0, дробные части размеров и допуски имеют ту же высоту, что и размерный текст. Если DIMTFAC = 0.7500, высота дробных частей размеров и допусков составляет три четверти высоты размерного текста.


DIMTFILL Системная переменная

D Системные переменные
DIMTFILL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет фоном размерного текста.

0 | Фон отсутствует
1 | Цвет фона чертежа
2 | Фон, заданный переменной DIMTFILLCLR


DIMTFILLCLR Системная переменная

D Системные переменные
DIMTFILLCLR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Устанавливает цвет фона текста в размерах. Номера цветов отображаются в диалоговом окне "Выбор цвета". Для BYBLOCK ввести 0. Для BYLAYER ввести 256.


DIMTIH Системная переменная

D Системные переменные
DIMTIH Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Вкл

Управляет ориентацией размерного текста для всех типов размеров, кроме ординатных, если текст вписывается между выносными линиями .

Откл | Размещает текст вдоль размерной линии
Вкл | Отображает текст по горизонтали


DIMTIX Системная переменная

D Системные переменные
DIMTIX Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Отображает текст между размерными линиями .

Откл | Поведение зависит от типа размера. Для линейных и угловых размеров текст помещается между выносными линиями, только если для них там достаточно места. DIMTIX не влияет на размерные тексты радиусов и диаметров, не вписывающиеся внутри круга или дуги, эти тексты всегда наносятся за пределами круга или дуги.
Вкл | Отображает размерный текст между выносными линиями, даже если обычно он размещается вне линий.


DIMTM Системная переменная

D Системные переменные
DIMTM Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Устанавливает минимальное (или нижнее) предельное отклонение для размерного текста при включенной переменной DIMTOL или DIMLIM . Переменная DIMTM допускает значения с любым знаком. Если DIMTOL включена, а DIMTP и DIMTM имеют одинаковые значения, отображается значение допуска.

Если значения DIMTM и DIMTP различны, верхнее отклонение рисуется над нижним. К значению DIMTP (если оно положительно) добавляется знак плюс.

Для DIMTM программа меняет знак переменной, которая вводится (если переменная положительна, в отклонении ее значение записывается со знаком минус, и наоборот).


DIMTMOVE Системная переменная

D Системные переменные
DIMTMOVE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Устанавливает правила перемещения размерного текста .

0 | Перемещает размерную линию с помощью размерного текста
1 | Добавляет выноску к перемещенному размерному тексту.
2 | Позволяет тексту свободно перемещаться без выноски.


DIMTOFL Системная переменная

D Системные переменные
DIMTOFL Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Управляет построением размерной линии между выносными линиями, даже если текст размещается вне линий . Для радиусов и диаметров (при отключеннойDIMTIX), размерная линия в таких случаях проводится внутри круга или дуги, а текст, стрелки и выноска размещаются снаружи.

Откл | Не отображает размерную линию между образмеренными точками, если размерные стрелки размещаются вне этих точек
Вкл | Отображает размерную линию между образмеренными точками, даже если размерные стрелки размещаются вне этих точек


DIMTOH Системная переменная

D Системные переменные
DIMTOH Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Вкл

Управляет ориентацией размерного текста за выносными линиями .

Откл | Размещает текст вдоль размерной линии
Вкл | Отображает текст по горизонтали


DIMTOL Системная переменная

D Системные переменные
DIMTOL Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Добавление предельных отклонений в конец размерного текста. Включение DIMTOL приводит к отключению переменной DIMLIM.


DIMTOLJ Системная переменная

D Системные переменные
DIMTOLJ Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Устанавливает выравнивание значений предельных отклонений относительно размерного текста номинала . Эта системная переменная не оказывает никакого действия, пока переменная DIMTOL не включена. Значение по умолчанию для переменной DIMTOL является Откл.

0 | Снизу
1 | Посередине
2 | Сверху


DIMTP Системная переменная

D Системные переменные
DIMTP Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Устанавливает максимальное (или верхнее) предельное отклонение для размерного текста при включенной переменной DIMTOL или DIMLIM. . Переменная DIMTOL допускает значения с любым знаком. Если переменная DIMTOL включена, а DIMTP и DIMTM имеют одинаковые значения, отображается значение допуска.

К значению DIMTP (если оно положительно) добавляется знак плюс.


DIMTSZ Системная переменная

D Системные переменные
DIMTSZ Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Указывает размер засечки, которая наносится вместо стрелки в линейных размерах, радиусах и диаметрах .

0 | Отображает стрелки.
>0 | Отображает засечки вместо стрелок. Величина засечки определяется значением, умноженным на значение переменной DIMSCALE


DIMTVP Системная переменная

D Системные переменные
DIMTVP Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Определяет вертикальное положение размерного текста над или под размерной линией . Значение переменной DIMTVP используется, когда переменная DIMTAD выключена. Значение смещения текста по вертикали вычисляется как произведение высоты текста и DIMTVP. Присвоение DIMTVP значения 1.0 эквивалентно включению DIMTAD. Размерная линия разрывается в соответствии с текстом, только если абсолютная величина DIMTVP меньше 0.7.


DIMTXSTY Системная переменная

D Системные переменные
DIMTXSTY Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | СТАНДАРТ

Указывает текстовый стиль для размера .


DIMTXT Системная переменная

D Системные переменные
DIMTXT Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,1800

Указывает высоту размерного текста, если в текстовом стиле не задана фиксированная высота .


DIMTZIN Системная переменная

D Системные переменные
DIMTZIN Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет подавлением нулей в допусках . Значение DIMTZIN может изменяться как непосредственно из командной строки, так и на вкладке "Допуски" диалогового окна работы с размерными стилями. Значения переменной DIMTZIN от 0 до 3 относятся только к размерам, выраженным в футах и дюймах.

0 | Подавляет нулевые значения для футов и дюймов
1 | Записывает нулевые значения для футов и дюймов
2 | Записывает нулевые значения для футов и подавляет нулевые значения для дюймов
3 | Записывает нулевые значения для дюймов и подавляет нулевые значения для футов
4 | Подавляет ведущие нулевые значения в десятичных размерах (например, 0,5000 записывается как ,5000)
8 | Подавляет замыкающие нулевые значения в десятичных размерах (например, 12,5000 записывается как 12,5)
12 | Подавляет и ведущие, и замыкающие нулевые значения (например, 0,5000 записывается как ,5)


DIMUNIT Системная переменная

D Системные переменные
DIMUNIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 2

Устар. . Сохранение в продукте для поддержания целостности сценариев. Переменная DIMUNIT заменена переменными DIMLUNIT и DIMFRAC.


DIMUPT Системная переменная

D Системные переменные
DIMUPT Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Управляет параметрами при пользовательском расположении текста .

Откл | Курсор задает только положение размерной линии
Вкл | Курсор задает и положение текста, и положение размерной линии


DIMZIN Системная переменная

D Системные переменные
DIMZIN Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет подавлением нулей в основных единицах измерения . Значение DIMZIN может изменяться как непосредственно из командной строки, так и на вкладке "Допуски" диалогового окна работы с размерными стилями. Значения переменной DIMZIN от 0 до 3 относятся только к размерам, выраженным в футах и дюймах.

0 | Подавляет нулевые значения для футов и дюймов
1 | Записывает нулевые значения для футов и дюймов
2 | Записывает нулевые значения для футов и подавляет нулевые значения для дюймов
3 | Записывает нулевые значения для дюймов и подавляет нулевые значения для футов
4 | Подавляет ведущие нулевые значения в десятичных размерах (например, 0,5000 записывается как ,5000)
8 | Подавляет замыкающие нулевые значения в десятичных размерах (например, 12,5000 записывается как 12,5)
12 | Подавляет и ведущие, и замыкающие нулевые значения (например, 0,5000 записывается как ,5)

DIMZIN влияет и на результаты преобразований вещественных чисел в строки, выполняемых функциями AutoLISP rtos и angtos.


DISPSILH Системная переменная

D Системные переменные
DISPSILH Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет отображением контуров силуэта твердотельных объектов в каркасном режиме .

0 | Откл
1 | Вкл


DISTANCE Системная переменная

D Системные переменные
DISTANCE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | Нет

Сохраняет значение расстояния, вычисленное с помощью команды DIST .


DONUTID Системная переменная

D Системные переменные
DONUTID Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | 0,5000

Устанавливает внутренний диаметр кольца по умолчанию .


DONUTOD Системная переменная

D Системные переменные
DONUTOD Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | 1,0000

Устанавливает внешний диаметр кольца по умолчанию . Значение должно быть ненулевым. Если оказывается, что DONUTID больше, чем DONUTOD, два значения меняются при вызове следующей команды.


DRAGMODE Системная переменная

D Системные переменные
DRAGMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Управляет отображением объектов при перетаскивании . Имя этой системной переменной совпадает с названием команды. Для доступа к этой системной переменной используется команда УСТПЕРЕМ.

Если режим перетаскивания включен, изображение объекта отображается при перетаскивании его в другое положение. На некоторых компьютерах такая прорисовка может занимать значительное время. Для подавления прорисовки объектов используется системная переменная DRAGMODE.

0 | Не отображает объект при его перетаскивании.
1 | Отображает контур объекта при перетаскивании, только если ввести в командной строке перетаскивать, после выбора объекта для перетаскивания.
2 | Авто; всегда отображает контур перетаскиваемого объекта


DRAGP1 Системная переменная

D Системные переменные
DRAGP1 Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 10

Устанавливает частоту регенерации объекта при перемещении .


DRAGP2 Системная переменная

D Системные переменные
DRAGP2 Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 25

Устанавливает частоту регенерации объекта при быстром перемещении .


DRAGVS Системная переменная

D Системные переменные
DRAGVS Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | Текущий стиль отображения

Устанавливает визуальный стиль при создании 3D твердотельных примитивов и выдавленных тел и поверхностей.. Можно ввести точку (.), чтобы задать текущий стиль отображения. DRAGVS можно задать только для стиля отображения, сохраненного в чертеже.

DRAGVS не действует, если значение стиля отображения текущего видового экрана установлено равным "2D каркас".

Стиль отображения, заданный для переменной DRAGVS, не может быть удален командой ОЧИСТИТЬ.


DRAWORDERCTL Системная переменная

D Системные переменные
DRAWORDERCTL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 3

Управляет порядком отображения перекрывающихся объектов . Использовать данный параметр для повышения скорости операций редактирования в больших чертежах. Наследование влияет на команды РАЗОРВАТЬ, СОПРЯЖЕНИЕ, ШТРИХОВКА, РЕД ШТР, РАСЧЛЕНИТЬ, ОБРЕЗАТЬ, СОЕДИНИТЬ, ПОЛРЕД и СМЕЩЕНИЕ.

0 | Отключает порядок прорисовки перекрывающихся объектов по умолчанию: после редактирования объектов они видимы всегда, независимо от их порядка следования, до завершения регенерации чертежа (команда REGEN) или до повторного открытия чертежа. С помощью этого параметра можно также отключить наследование порядка прорисовки: новым объектам, созданным из другого объекта с помощью команд, перечисленных выше, не назначается порядок прорисовки первоначально выбранного объекта.
1 | Включает порядок прорисовки объектов по умолчанию: после редактирования объектов они отображаются автоматически в соответствии с правильным порядком прорисовки.
2 | Включает наследование порядка прорисовки: новым объектам, созданным из другого объекта с помощью команд, перечисленных выше, назначается порядок прорисовки первоначально выбранного объекта.
3 | Обеспечивает полное отображение порядка прорисовки. Включает правильный порядок прорисовки объектов и наследование порядка рисования.

Примечание Отображение полного порядка прорисовки может замедлить выполнение некоторых операций редактирования.


DRSTATE Системная переменная

D Системные переменные
DRSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | разные

Определяет, активно ли окно "Восстановление чертежа" .

0 | Окно "Восстановление чертежа" не активно
1 | Окно "Восстановление чертежа" активно


DTEXTED Системная переменная

D Системные переменные
DTEXTED Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Задает интерфейс пользователя, выводимый на экран для редактирования однострочного текста. .

0 | Выводит на экран Текстовый редактор, используемый в месте редактирования.
1 | Выводит на экран текстовую подсказку создания текста и позволяет указать любое место на чертеже для создания нового текстового блока; выводит на экран диалоговое окно правки текста для его изменения.
2 | Выводит на экран Текстовый редактор, используемый в месте редактирования, для создания и изменения текста. При создании текста можно указать любое место на чертеже для создания нового текстового блока. Для перемещения между текстовыми блоками можно также использовать клавиатуру (например, в новом тексте, создаваемом с помощью команды ТЕКСТ, можно перемещаться между текстовыми группами нажатием клавиши TAB или клавиш SHIFT+TAB, или редактировать группу строк текста нажатием клавиши ALT и выбором каждого текстового объекта.)


DWFFRAME Системная переменная

D Системные переменные
DWFFRAME Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 2

Определяет видимость контура подложки DWF.

0 | Контур подложки DWF не видим и не печатается
1 | Контур подложки DWF отображается и может быть напечатан
2 | Контур подложки DWF отображается, но не печатается


DWFOSNAP Системная переменная

D Системные переменные
DWFOSNAP Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Определяет активность привязки объекта для геометрии в подложках DWF, прикрепленных к чертежу.

0 | Привязка объекта запрещена для геометрии во всех вложениях подложки DWF чертежа
1 | Привязка объекта разрешена для геометрии во всех вложениях подложки DWF чертежа


DWGCHECK Системная переменная

D Системные переменные
DWGCHECK Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет проверкой чертежей на потенциальные ошибки при их открытии .

0 | Если в чертеже, который предстоит открыть, содержатся ошибки, перед открытием выводится предупреждение об этом.
1 | Если в чертеже, который предстоит открыть, содержатся ошибки, или он был сохранен в другом приложении (не в AutoCAD или AutoCAD LT), перед открытием выводится предупреждение об этом.
2 | Если в чертеже, который предстоит открыть, содержатся ошибки, выводится предупреждение об этом в командной строке.
3 | Если в чертеже, который предстоит открыть, содержатся ошибки, выводится предупреждение об этом в командной строке. Если в открываемом чертеже содержатся ошибки или он был сохранен в приложении, отличном от AutoCAD или AutoCAD LT, выводится предупреждение.


DWGCODEPAGE Системная переменная

D Системные переменные
DWGCODEPAGE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | чертеж

Сохраняет то же значение, что и переменная SYSCODEPAGE (для целей совместимости).


DWGNAME Системная переменная

D Системные переменные
DWGNAME Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | Drawing.dwg

Сохраняет имя чертежа, введенное пользователем . Если чертежу еще не присвоено имя, DWGNAME по умолчанию равна “Чертеж.dwg. ” Если задан префикс диска/каталога, то префикс сохраняется в DWGPREFIX.


DWGPREFIX Системная переменная

D Системные переменные
DWGPREFIX Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен

Сохраняет путь к чертежу (диск и папка) .


DWGTITLED Системная переменная

D Системные переменные
DWGTITLED Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Указывает, присвоено ли текущему чертежу имя .

0 | Имя чертежу не присвоено
1 | Имя чертежу присвоено


DYNDIGRIP Системная переменная

D Системные переменные
DYNDIGRIP Системная переменная
Понятия Процедуры Команды

Тип: | битовый код
Сохранен в: | реестр
Начальное значение: | 31

Управляет отображением динамических размеров во время растягивания ручками . Системной переменной DYNDIVIS необходимо присвоить значение 2, которое отображает все динамические размеры.

0 | Нет
1 | Результирующий размер
2 | Размер изменения длины
4 | Размер абсолютного угла
8 | Размер изменения угла
16 | Размер радиуса дуги

С помощью системной переменной DYNMODE можно включить и отключить функции динамического ввода.


DYNDIVIS Системная переменная

D Системные переменные
DYNDIVIS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Пользовательские настройки
Начальное значение: | 1

Управляет отображением количества динамических размеров во время растягивания ручками . DYNDIGRIP управляет отображением динамических размеров во время растягивания ручками.

0 | Только первый динамический размер в циклической последовательности
1 | Только первые два размера в циклической последовательности
2 | Все динамические размеры, определяемые системной переменной DYNDIGRIP

С помощью системной переменной DYNMODE можно включить и отключить функции динамического ввода.


DYNMODE Системная переменная

D Системные переменные
DYNMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Пользовательские настройки
Начальное значение: | 3

Включает и отключает функции динамического ввода . Когда все функции включены, контекст управляет отображением.

Если переменной DYNMODE задано отрицательное значение, функции динамического ввода не включаются, однако параметр сохраняется. Нажмите кнопку Dyn в строке состояния, чтобы установить для переменной DYNMODE соответствующее положительное значение.

0 | Все функции динамического ввода, в том числе динамические подсказки, отключены
1 | Ввод указателя включен
2 | Размерный ввод включен
3 | Ввод указателя и размерный ввод включены

Если включены динамические подсказки (значение DYNPROMPT равно 1), они будут выводиться на экран, если DYNMODE установлено равным 1, 2 или 3.

Если включен размерный ввод (DYNMODE = 2 или 3), программа переключается в режим ввода указателя при вводе запятой или угловой скобки (<), или при выборе нескольких точек расположения ручки.

Если значение переменной DYNMODE установлено равным 1, 2 или 3, можно временно отключить все функции, удерживая нажатой клавишу временного переопределения F12.

Параметры включены на вкладке "Динамический ввод" в диалоговом окне "Режимы черчения".


DYNPICOORDS Системная переменная

D Системные переменные
DYNPICOORDS Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | Пользовательские настройки
Начальное значение: | 0

Контролирует, используются ли для ввода с помощью мыши абсолютные или относительные координаты .

0 | Относительная
1 | Абсолютно

С помощью системной переменной DYNMODE можно включить или отключить функции динамического ввода.


DYNPIFORMAT Системная переменная

D Системные переменные
DYNPIFORMAT Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | Пользовательские настройки
Начальное значение: | 0

Контролирует, используется ли для ввода с помощью мыши формат полярных или декартовых координат . Этот параметр применяется только для второй или следующей точки.

0 | Полярные
1 | Декартовы

С помощью системной переменной DYNMODE можно включить или отключить функции динамического ввода.


DYNPIVIS Системная переменная

D Системные переменные
DYNPIVIS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Пользовательские настройки
Начальное значение: | 1

Управляет отображением ввода с помощью мыши .

0 | Только при вводе в запросе точки
1 | Автоматически в запросе точки
2 | Всегда

С помощью системной переменной DYNMODE можно включить или отключить функции динамического ввода.


DYNPROMPT Системная переменная

D Системные переменные
DYNPROMPT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Пользовательские настройки
Начальное значение: | 1

Управляет отображением подсказок динамического ввода .

0 | Откл
1 | Вкл

С помощью системной переменной DYNMODE можно включить или отключить функции динамического ввода. Если значение DYNMODE установлено равным 0 (откл), подсказки не выводятся на экран независимо от параметра DYNPROMPT.


DYNTOOLTIPS Системная переменная

D Системные переменные
DYNTOOLTIPS Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | Пользовательские настройки
Начальное значение: | 1

Управляет выбором подсказок, на которые влияют параметры внешнего вида подсказок .

0 | Только поля значений динамического ввода
1 | Все подсказки на чертеже


E Системные переменные
  • EDGEMODE
  • ELEVATION
  • ENTERPRISEMENU
  • ERRNO
  • ERSTATE
  • EXPERT
  • EXPLMODE
  • EXTMAX
  • EXTMIN
  • EXTNAMES


EDGEMODE Системная переменная

E Системные переменные
EDGEMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет режимом определения режущих и граничных кромок для команд ОБРЕЗАТЬ и УДЛИНИТЬ. .

0 | Использует выбранную кромку в своих текущих границах
1 | Удлиняет или обрезает выбранный объект до точки пересечения с воображаемым продолжением режущего или граничного объекта

Отрезки, дуги (в том числе эллиптические), лучи и полилинии обладают так называемыми натуральными продолжениями. Для отрезка и луча это — прямая линия, для дуги — круг, а для эллиптической дуги — эллипс. Полилиния разбивается на линейные и дуговые сегменты, после чего для них генерируются натуральные продолжения.


ELEVATION Системная переменная

E Системные переменные
ELEVATION Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0.0000

Сохраняет текущий уровень новых объектов относительно текущей ПСК .


ENTERPRISEMENU Системная переменная

E Системные переменные
ENTERPRISEMENU Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | реестр
Начальное значение: | "."

Сохраняет имя файла НПИ (если определено), включая путь. .


ERRNO Системная переменная

E Системные переменные
ERRNO Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Отображает номер соответствующего кода ошибки, когда вызов функции AutoLISP приводит к ошибки, определенной AutoCAD . Приложения AutoLISP могут определить текущее значение переменной ERRNO через функцию (getvar"errno").

Системная переменная ERRNO не всегда сбрасывается в нуль. Кроме случаев, когда переменная проверяется сразу после сигнала об ошибке из функции AutoLISP, ошибка, о которой свидетельствует значение переменной, может быть неверной. Перед созданием или открытием чертежа данная переменная всегда очищается.

Более подробную информацию см. в Руководстве разработчика AutoLISP.


ERSTATE Системная переменная

E Системные переменные
ERSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | разные

Определяет активность палитры внешних ссылок .

0 | Не активна
1 | Активна


EXPERT Системная переменная

E Системные переменные
EXPERT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Управляет отображением определенных подсказок .

0 | Отображает все подсказки обычным образом.
1 | Подавляет вывод подсказки “Будет выполнена регенерация, продолжить?” и “Действительно хотите отключить текущий слой?” (-СЛОЙ)
2 | Подавляет перечисленные выше подсказки, а также “Блок уже определен. Переопределить?” (БЛОК) и “Чертеж с этим именем уже существует. Заменить?” (СОХРАНИТЬ или WBLOCK).
3 | Подавляет перечисленные выше подсказки, а также выданные командой ТИПЛИН в командной строке (-ТИПЛИН) при попытке загрузки уже загруженного типа линии или создания нового типа линии в файле, в котором этот тип линии уже определен.
4 | Подавляет перечисленные выше запросы, а также запросы команд ПСК (параметр "Сохранить") и ВЭКРАН (параметр "Сохранить"), если имя, вводимое пользователем, уже существует.
5 | Подавляет вывод подсказки “Это имя уже используется, переопределить?”, выданной командой -РЗМСТИЛЬ Сохраните параметр при задании имени существующего размерного стиля.

При подавлении запроса с помощью переменной EXPERT подразумевается, что пользователь дает утвердительный ответ д . Установки EXPERT оказывают воздействие на пакеты, макросы меню, функции AutoLISP и команды.


EXPLMODE Системная переменная

E Системные переменные
EXPLMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 1

Управляет обработкой блоков с разными масштабами вставки в команде РАСЧЛЕНИТЬ .

0 | Блоки не расчленяются
1 | Блоки расчленяются


EXTMAX Системная переменная

E Системные переменные
EXTMAX Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | 3D-point
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет верхнюю правую точку границ чертежа . Расширяется при добавлении к чертежу новых объектов; сжимаетПОКАЗАТЬ только при выполнении команды ПОКАЗАТЬ с опциями "Все" или "Границы". Результат выдается в мировых координатах для текущего пространства.


EXTMIN Системная переменная

E Системные переменные
EXTMIN Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | 3D-point
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет левую нижнюю точку границ чертежа . Расширяется при добавлении к чертежу новых объектов; сжимаетПОКАЗАТЬ только при выполнении команды ПОКАЗАТЬ с опциями "Все" или "Границы". Результат выдается в мировых координатах для текущего пространства.


EXTNAMES Системная переменная

E Системные переменные
EXTNAMES Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Устанавливает параметры для имен именованных объектов (например, типов линий и слоев), которые хранятся в таблицах описаний .

0 | Использует параметры AutoCAD Release 14, которые ограничивают длину имен до 31 символа. Имена могут включать буквы от A до Z, цифры от 0 до 9 и специальные символы - знак доллара ($), подчеркивание (_) и дефис (-).
1 | Использует параметры Uses AutoCAD 2000 (и более поздних версий). Имена могут иметь длину до 255 символов и содержать буквы от A до Z, цифры от 0 до 9, пробелы и любые специальные символы, не используемые Microsoft® Windows® и AutoCAD в других целях.


F Системные переменные
  • FACETRATIO
  • FACETRES
  • FIELDDISPLAY
  • FIELDEVAL
  • FILEDIA
  • FILLETRAD
  • FILLMODE
  • FONTALT
  • FONTMAP
  • FRONTZ
  • FULLOPEN
  • FULLPLOTPATH


FACETRATIO Системная переменная

F Системные переменные
FACETRATIO Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Управляет плотностью сетевого представления цилиндрических и конических тел. Значение 1 увеличивает плотность сетки и улучшает качество тонирования.

0 | Создает сетку размером N на 1 для цилиндрических и конических тел
1 | Создает сетку размером N на M для цилиндрических и конических тел


FACETRES Системная переменная

F Системные переменные
FACETRES Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,5

Регулирует гладкость раскрашенных и тонированных объектов, а также объектов с подавленными скрытыми линиями . Допустимые значения находятся в интервале от 0,01 до 10,0.

Примечание 3DDWFPREC заменяет FACETRES при управлении точностью опубликованных 3D файлов DWF.


FIELDDISPLAY Системная переменная

F Системные переменные
FIELDDISPLAY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет отображением полей на сером фоне . На печать фон не выводится.

0 | Поля отображаются без фона
1 | Поля отображаются на сером фоне


FIELDEVAL Системная переменная

F Системные переменные
FIELDEVAL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 31

Управляет обновлением полей . Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Не обновляется
1 | Обновляются при открытии
2 | Обновляются при сохранении
4 | Обновляются при печати
8 | Обновляются при вызове команды ФОРМКОМПЛЕКТ
16 | Обновляются при регенерации

Примечание Поле данных обновляется командой UPDATEFIELD, но не обновляется автоматически по значению системной переменной FIELDEVAL.


FILEDIA Системная переменная

F Системные переменные
FILEDIA Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Подавляет отображение диалоговых окон навигации к файлу .

0 | Диалоговые окна не отображаются. Тем не менее, возможность принудительного вызова диалогового окна файла сохраняется; для этого нужно ввести тильду (~) в ответ на подсказку команды. То же справедливо для функций AutoLISP и ADS.
1 | Отображает диалоговые окна. Однако, если пакетный файл или программа AutoLISP/ObjectARX™ активны, на экран выводится обычная подсказка.


FILLETRAD Системная переменная

F Системные переменные
FILLETRAD Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Сохраняет значение текущего радиуса сопряжения .


FILLMODE Системная переменная

F Системные переменные
FILLMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Указывает, заполнены ли штриховки и заливки, двумерные объекты и широкие полилинии. .

0 | Объекты не заполнены
1 | Объекты заполнены


FONTALT Системная переменная

F Системные переменные
FONTALT Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | simplex.shx

Указывает альтернативный шрифт, используемый в случае, если не найден указанный шрифт . Если открыт файл чертежа с определенным стилем текста и не указан альтернативный шрифт, отобразится диалоговое окно "Альтернативный шрифт".


FONTMAP Системная переменная

F Системные переменные
FONTMAP Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | acad.fmp

Указывает файл, описывающий подстановку шрифтов . В каждой строке файла подстановки записываются исходный и подставляемый вместо него шрифты, разделенные точкой с запятой (;). Например, для замены шрифта Roman на TrueType-шрифт Times в файле подстановки должна присутствовать следующая строка:

romanc.shx;times.ttf

Если FONTMAP не указывает на файл описания подстановки, не найден файл FMP или не найден шрифт, заданный в файле FMP, используется шрифт из описания текстового стиля. Если шрифт в стиле не обнаружен, шрифт заменяется по внутренним правилам.


FRONTZ Системная переменная

F Системные переменные
FRONTZ Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | Нет

Сохраняет смещение передней секущей плоскости от плоскости цели для текущего видового экрана (в единицах чертежа) . Имеет смысл, только если в переменной VIEWMODE включена передняя плоскость, и она не совмещена с точкой наблюдения. Значением FRONTZ является последнее значение передней секущей плоскости, установленное как текущее с помощью команды КАМЕРА, ДВИД или 3DСЕКПЛ. Для того чтобы найти расстояние от камеры до передней секущей плоскости, нужно вычесть значение FRONTZ из расстояния от камеры до цели.


FULLOPEN Системная переменная

F Системные переменные
FULLOPEN Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен

Указывает, частично ли открыт текущий чертеж .

0 | Указывает на частичное открытие текущего чертежа
1 | Указывает на полное открытие чертежа


FULLPLOTPATH Системная переменная

F Системные переменные
FULLPLOTPATH Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Определяет, отправлен ли весь файл чертежа в буфер печати .

0 | Отправляет только имя файла чертежа
1 | Отправляет весь файл чертежа


G Системные переменные
  • GRIDDISPLAY
  • GRIDMAJOR
  • GRIDMODE
  • GRIDUNIT
  • GRIPBLOCK
  • GRIPCOLOR
  • GRIPDYNCOLOR
  • GRIPHOT
  • GRIPHOVER
  • GRIPOBJLIMIT
  • GRIPS
  • GRIPSIZE
  • GRIPTIPS
  • GTAUTO
  • GTDEFAULT
  • GTLOCATION


GRIDDISPLAY Системная переменная

G Системные переменные
GRIDDISPLAY Системная переменная
Понятия Процедуры Команды

Тип: | битовый код
Сохранен в: | чертеж
Начальное значение: | 3

Управляет режимом работы дисплея и лимитами отображения сетки.

Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Ограничивает отображение сетки зоной, заданной командой ЛИМИТЫ
1 | Не ограничивает отображение сетки зоной, заданной командой ЛИМИТЫ
2 | Включает отображение адаптивной сетки, которая ограничивает плотность сетки при уменьшении масштаба изображения
4 | Если задано отображение адаптивной сетки, то при увеличении масштаба изображения генерируются дополнительные более плотно расположенные линии сетки пропорционально интервалам основных линий сетки.
8 | Изменяет плоскость сетки в соответствии с плоскостью XY динамической ПСК.

Примечание Параметр 4 игнорируется, если не задан параметр 2.


GRIDMAJOR Системная переменная

G Системные переменные
GRIDMAJOR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 5

Управляет частотой основных линий сетки по сравнению с второстепенными линиями сетки. Допустимый диапазон значений от 1 до 100.

Линии сетки отображаются в любом визуальном стиле, кроме 2D Каркаса.


GRIDMODE Системная переменная

G Системные переменные
GRIDMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Указывает, включена или отключена сетка .

0 | Отключает сетку
1 | Включает сетку


GRIDUNIT Системная переменная

G Системные переменные
GRIDUNIT Системная переменная
Понятия Процедуры Команды

Тип: | 2D-point
Сохранен в: | чертеж
Начальное значение: | 0,5000, 0,5000 (британские единицы) или 10,10 (метрические единицы)

Указывает размер ячейки сетки на текущем видовом экране по X и Y .


GRIPBLOCK Системная переменная

G Системные переменные
GRIPBLOCK Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет ручками внутри блоков .

0 | Устанавливает ручку только в точке вставки блока
1 | Устанавливает ручку на всех объектах в блоке


GRIPCOLOR Системная переменная

G Системные переменные
GRIPCOLOR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 160

Управляет цветом невыбранных ручек . Допустимый диапазон значений от 1 до 255.


GRIPDYNCOLOR Системная переменная

G Системные переменные
GRIPDYNCOLOR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 140

Управляет цветом специальных ручек для динамических блоков . Допустимый диапазон значений от 1 до 255.


GRIPHOT Системная переменная

G Системные переменные
GRIPHOT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет цветом выбранных ручек . Допустимый диапазон значений от 1 до 255.


GRIPHOVER Системная переменная

G Системные переменные
GRIPHOVER Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 3

Управляет цветом заполнения невыбранной ручки, когда курсор останавливается над ней . Допустимый диапазон значений от 1 до 255.


GRIPOBJLIMIT Системная переменная

G Системные переменные
GRIPOBJLIMIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 100

Подавляет ручки, если исходный набор содержит больше объектов, чем задано . Допустимый диапазон значений от 0 до 32767. Если переменная равна 1, ручки подавляются при выборе более одного объекта. Если установлено значение 0, отображение ручек не подавляется.


GRIPS Системная переменная

G Системные переменные
GRIPS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет использованием набора ручек при растягивании, перемещении, повороте, масштабировании и зеркальном отображении объектов .

0 | Отключает ручки
1 | Включает ручки

Для установки величины ручек и эффективной области выбора в момент привязки к ручке служит переменная GRIPSIZE.


GRIPSIZE Системная переменная

G Системные переменные
GRIPSIZE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 5

Устанавливает размер квадрата, изображающего ручку (в пикселах) . Допустимый диапазон значений от 1 до 255.


GRIPTIPS Системная переменная

G Системные переменные
GRIPTIPS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет подсказками для ручки при наведении курсора на ручку пользовательского объекта, поддерживающего подсказки к ручкам .

0 | Отключает отображение подсказок для ручки
1 | Включает отображение подсказки для ручки


GTAUTO Системная переменная

G Системные переменные
GTAUTO Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет автоматическим отображением инструментов ручки при выборе объектов перед запуском команды в видовом экране, которому задан 3D стиль отображения.

0 | Инструменты ручки не отображаются автоматически при выборе объектов перед выполнением команды.
1 | Инструменты ручки отображаются автоматически после создания набора объектов перед выполнением команды.


GTDEFAULT Системная переменная

G Системные переменные
GTDEFAULT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет автоматическим выполнением команд 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ при выполнении команд ПЕРЕНЕСТИ и ПОВЕРНУТЬ (соответственно) в 3D виде.

0 | 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ (команды) не выполняются автоматически при выполнении команд ПЕРЕНЕСТИ и ПОВЕРНУТЬ (соответственно) в 3D виде.
1 | 3DПЕРЕНЕСТИ и 3DПОВЕРНУТЬ (команды) выполняются автоматически при выполнении команд ПЕРЕНЕСТИ и ПОВЕРНУТЬ (соответственно) в 3D виде.


GTLOCATION Системная переменная

G Системные переменные
GTLOCATION Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет первоначальным расположением инструментов ручки, если выбор объектов производится до выполнения команд 3DПЕРЕНЕСТИ или 3DПОВЕРНУТЬ.

0 | Помещает ручку на ту же вкладку, что и знак ПСК. Выравнивает также ручку по значку ПСК.
1 | Помещает ручку на последний выбранный объект или подобъект и выравнивает по нему.


H Системные переменные
  • HALOGAP
  • HANDLES
  • HIDEPRECISION
  • HIDETEXT
  • HIGHLIGHT
  • HPANG
  • HPASSOC
  • HPBOUND
  • HPDOUBLE
  • HPDRAWORDER
  • HPGAPTOL
  • HPINHERIT
  • HPNAME
  • HPOBJWARNING
  • HPORIGIN
  • HPORIGINMODE
  • HPSCALE
  • HPSEPARATE
  • HPSPACE
  • HYPERLINKBASE


HALOGAP Системная переменная

H Системные переменные
HALOGAP Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Указывает отображение зазора в области покрытия одного объекта другим . Значение задается в процентах от одной единицы и не зависит от экранного увеличения.

HALOGAP доступна только в 2D видах. В 3D видах используется системная переменная VSHALOGAP.


HANDLES Системная переменная

H Системные переменные
HANDLES Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | чертеж
Начальное значение: | Вкл

Сообщает, могут ли приложения получить доступ к меткам объектов . Так как функция отключения не доступна в данной версии программы, переменная служит только для совместимости с пакетными файлами, написанными для прежних версий программы.


HIDEPRECISION Системная переменная

H Системные переменные
HIDEPRECISION Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Управляет точностью скрытия невидимых линий и раскрашивания . Скрытие линий может выполняться с одинарной или с двойной точностью. Присвоение HIDEPRECISION значения 1 повышает качество выполнения операции, но требует большего объема памяти и может ухудшить общую производительность (особенно при обработке тел).

0 | Обычная точность; использует меньший объем памяти
1 | Двойная точность; использует больший объем памяти


HIDETEXT Системная переменная

H Системные переменные
HIDETEXT Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Вкл

Указывает, обработаны ли текстовые объекты, созданные с помощью команды ТЕКСТ, МТЕКСТ или ДТЕКСТ, в команде СКРЫТЬ .

Откл | Текст не скрыт и не скрывает другие объекты
Вкл | Текст скрыт, но не скрывает другие объекты


HIGHLIGHT Системная переменная

H Системные переменные
HIGHLIGHT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 1

Управляет подсветкой объектов; не влияет на объекты, имеющие ручки .

0 | Отключает подсветку выбора объектов
1 | Включает подсветку выбора объектов


HPANG Системная переменная

H Системные переменные
HPANG Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | 0

Указывает угол поворота образца штриховки .


HPASSOC Системная переменная

H Системные переменные
HPASSOC Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет ассоциативностью образцов штриховки и градиентных заливок .

0 | Образцы штриховки и градиентные заливки не связаны с контурами
1 | Образцы штриховки и градиентные заливки связаны с контурами и обновляются при изменении контуров


HPBOUND Системная переменная

H Системные переменные
HPBOUND Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 1

Управляет типом объекта, созданного с помощью команд КШТРИХ и КОНТУР .

0 | Создает область
1 | Создает полилинию


HPDOUBLE Системная переменная

H Системные переменные
HPDOUBLE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Указывает режим штрихования крест-накрест для созданных пользователем штриховок . Штрихование крест-накрест подразумевает нанесение второй штриховки, повернутой относительно первой на 90 градусов.

0 | Отключает штрихование крест-накрест
1 | Включает штрихование крест-накрест


HPDRAWORDER Системная переменная

H Системные переменные
HPDRAWORDER Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 3

Управляет порядком прорисовки штриховки или заливки . Сохраняет параметр "Порядок прорисовки" из диалогового окна "Штриховка/заливка по контуру".

0 | Нет. Для порядка прорисовки не назначается штриховка или заливка.
1 | На задний план. Штриховка или заливка помещается на задний план всех остальных объектов.
2 | На передний план. Штриховка или заливка помещается на передний план всех остальных объектов.
3 | За контуром. Штриховка или заливка помещается за контуром.
4 | Перед контуром. Штриховка или заливка помещается перед контуром


HPGAPTOL Системная переменная

H Системные переменные
HPGAPTOL Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | реестр
Начальное значение: | 0

Рассматривает набор объектов, окружающих почти замкнутую область, как замкнутый контур штриховки . Установленное по умолчанию значение 0 означает, что между объектами, описывающими область, не должно быть зазора. Можно задать максимально допустимую величину зазора между объектами, образующими контур штриховки. Его значение может быть от в пределах от 0 до 5000, в единицах чертежа.


HPINHERIT Системная переменная

H Системные переменные
HPINHERIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Определяет исходную точку полученной штриховки с помощью параметра "Копирование свойств" команд ШТРИХОВКА и РЕДШТРИХ .

0 | Исходная точка штриховки заимствована из переменной HPORIGIN
1 | Исходная точка штриховки заимствована из объекта исходной штриховки


HPNAME Системная переменная

H Системные переменные
HPNAME Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ANSI31

Устанавливает имя образца штриховки по умолчанию длиной до 34 символов (без пробелов) . Если образца по умолчанию нет, возвращает пустую строку (""). Чтобы восстановить начальное значение, следует ввести точку (.) .


HPOBJWARNING Системная переменная

H Системные переменные
HPOBJWARNING Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 10000

Устанавливает количество объектов контура штриховки, которые можно выбрать до отображения предупреждения . Максимальное значение может изменяться, но оно значительно больше 100000000 (ста миллионов).


HPORIGIN Системная переменная

H Системные переменные
HPORIGIN Системная переменная
Понятия Процедуры Команды

Тип: | 2D-point
Сохранен в: | чертеж
Начальное значение: | 0,0

Устанавливает исходную точку штриховки для новых объектов штриховки относительно текущей системы координат пользователя .


HPORIGINMODE Системная переменная

H Системные переменные
HPORIGINMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Определяет исходную точку штриховки с помощью команды ШТРИХОВКА .

0 | Исходные точки штриховки установлены с помощью переменной HPORIGIN
1 | Исходные точки установлены с помощью левого нижнего угла прямоугольных границ контура штриховки
2 | Исходные точки установлены с помощью правого нижнего угла прямоугольных границ контура штриховки
3 | Исходные точки установлены с помощью правого верхнего угла прямоугольных границ контура штриховки
4 | Исходные точки установлены с помощью левого верхнего угла прямоугольных границ контура штриховки
5 | Исходные точки установлены с помощью центра прямоугольных границ контура штриховки


HPSCALE Системная переменная

H Системные переменные
HPSCALE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | 1,0000

Указывает масштабный коэффициент образца штриховки, который должен быть ненулевым .


HPSEPARATE Системная переменная

H Системные переменные
HPSEPARATE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Определяет количество создаваемых заштрихованных объектов (один или несколько) с помощью команды ШТРИХОВКА, если выделено несколько замкнутых контуров .

0 | Создан один заштрихованный объект
1 | Создано несколько заштрихованных объектов


HPSPACE Системная переменная

H Системные переменные
HPSPACE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | 1,0000

Указывает расстояние между линиями образца штриховки для созданных пользователем штриховок, которое должно быть ненулевым .


HYPERLINKBASE Системная переменная

H Системные переменные
HYPERLINKBASE Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | ""

Указывает путь, используемый для всех относительных гиперссылок в чертеже . Если значение не задано, используется тот же путь, что и у чертежа.


I Системные переменные
  • IMAGEHLT
  • IMPLIEDFACE
  • INDEXCTL
  • INETLOCATION
  • INPUTHISTORYMODE
  • INSBASE
  • INSNAME
  • INSUNITS
  • INSUNITSDEFSOURCE
  • INSUNITSDEFTARGET
  • INTELLIGENTUPDATE
  • INTERFERECOLOR
  • INTERFEREOBJVS
  • INTERFEREVPVS
  • INTERSECTIONCOLOR
  • INTERSECTIONDISPLAY
  • ISAVEBAK
  • ISAVEPERCENT
  • ISOLINES


IMAGEHLT Системная переменная

I Системные переменные
IMAGEHLT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет режимом подсветки растровых изображений при выборе .

0 | Подсвечивает только границы растрового изображения
1 | Подсвечивает все растровое изображение


IMPLIEDFACE Системная переменная

I Системные переменные
IMPLIEDFACE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет обнаружением предполагаемых граней. Значение этой переменной должно быть установлено равным 1, если необходимо выбирать и изменять предполагаемые грани.

0 | Предполагаемые грани не обнаруживаются.
1 | Предполагаемые грани обнаруживаются.


INDEXCTL Системная переменная

I Системные переменные
INDEXCTL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет созданием слоевых и пространственных индексов и сохранением их в файле чертежа .

0 | Индексы не создаются
1 | Создан слоевой индекс
2 | Создан пространственный индекс
3 | Созданы слоевые и пространственные индексы


INETLOCATION Системная переменная

I Системные переменные
INETLOCATION Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | http://www.autodesk.com

Сохраняет адрес Интернета, используемый в команде БРАУЗЕР и в диалоговом окне "Просмотр Web" .


INPUTHISTORYMODE Системная переменная

I Системные переменные
INPUTHISTORYMODE Системная переменная
Понятия Процедуры Команды

Тип: | битовый код
Сохранен в: | реестр
Начальное значение: | 15

Управляет содержанием и положением отображения последних введенных пользователем команд .

Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Последние введенные команды не отображаются
1 | Последние введенные команды отображаются в командной строке или в динамической подсказке, доступ к которой можно получить с помощью клавиш "Стрелка вверх" и "Стрелка вниз"
2 | Последняя введенная текущая команда отображается в контекстном меню
4 | Все последние введенные команды в текущем сеансе отображаются в контекстном меню
8 | Маркеры для последнего ввода местоположений точки отображаются в чертеже


INSBASE Системная переменная

I Системные переменные
INSBASE Системная переменная
Понятия Процедуры Команды

Тип: | 3D-point
Сохранен в: | чертеж
Начальное значение: | 0,0000, 0,0000, 0,0000

Сохраняет базовую точку вставки, установленную с помощью команды БАЗА, в текущей ПСК текущего пространства .


INSNAME Системная переменная

I Системные переменные
INSNAME Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ""

Устанавливает имя блока по умолчанию для команды ВСТАВИТЬ . Имя должно удовлетворять требованиям к элементам символьных таблиц. Если блока по умолчанию нет, возвращает пустую строку (""). Чтобы восстановить начальное значение, следует ввести точку (.) , чтобы отменить значение по умолчанию.


INSUNITS Системная переменная

I Системные переменные
INSUNITS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Указывает значение в единицах чертежа для автоматического масштабирования блоков, изображений или вставленных или прикрепленных к чертежу внешних ссылок .

0 | Не заданы
1 | Дюймы
2 | Футы
3 | Мили
4 | Миллиметры
5 | Сантиметры
6 | Метры
7 | Километры
8 | Микродюймы
9 | Милы
10 | Ярды
11 | Ангстремы
12 | Нанометры
13 | Микроны
14 | Дециметры
15 | Декаметры
16 | Гектометры
17 | Гигаметры
18 | Астрономические единицы
19 | Световые годы
20 | Парсеки


INSUNITSDEFSOURCE Системная переменная

I Системные переменные
INSUNITSDEFSOURCE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Устанавливает единицы измерения исходного содержимого, когда переменная INSUNITS имеет значение, равное 0. Допустимый диапазон значений — от 0 до 20.

0 | Не заданы
1 | Дюймы
2 | Футы
3 | Мили
4 | Миллиметры
5 | Сантиметры
6 | Метры
7 | Километры
8 | Микродюймы
9 | Милы
10 | Ярды
11 | Ангстремы
12 | Нанометры
13 | Микроны
14 | Дециметры
15 | Декаметры
16 | Гектометры
17 | Гигаметры
18 | Астрономические единицы
19 | Световые годы
20 | Парсеки


INSUNITSDEFTARGET Системная переменная

I Системные переменные
INSUNITSDEFTARGET Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Устанавливает единицы измерения в целевом чертеже, когда переменная INSUNITS имеет значение, равное 0. Допустимый диапазон значений — от 0 до 20.

0 | Не заданы
1 | Дюймы
2 | Футы
3 | Мили
4 | Миллиметры
5 | Сантиметры
6 | Метры
7 | Километры
8 | Микродюймы
9 | Милы
10 | Ярды
11 | Ангстремы
12 | Нанометры
13 | Микроны
14 | Дециметры
15 | Декаметры
16 | Гектометры
17 | Гигаметры
18 | Астрономические единицы
19 | Световые годы
20 | Парсеки


INTELLIGENTUPDATE Системная переменная

I Системные переменные
INTELLIGENTUPDATE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 20

Управляет скоростью обновления графики . Значение по умолчанию равно 20 кадров в секунду. При возникновении проблем, связанных с генерацией графики или регулировкой времени, отключите переменную, установив для нее значение 0. Системная переменная INTELLIGENTUPDATE работает с помощью подавления обновления графики, пока не исчезнет счетчик времени. Последующие обновления сбрасывают счетчик времени.

Увеличение производительности значительно влияет на обновления сценариев и графики AutoLISP. При использовании обычных команд AutoCAD различия в производительности не будут заметны.


INTERFERECOLOR Системная переменная

I Системные переменные
INTERFERECOLOR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Устанавливает цвет объектов взаимодействия . Действительными значениями являются ПОСЛОЮ и целые числа от 0 до 255.

Значения цветов полноцветного режима вводятся как уровни RGB-составляющих (целые числа от 1 до 255), разделенные запятыми. Значение цвета имеет следующий формат:

RGB:000,000,000

Если установлен альбом цветов, можно задать любые цвета, определенные в альбоме.


INTERFEREOBJVS Системная переменная

I Системные переменные
INTERFEREOBJVS Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | Реалистичные

Устанавливает стиль отображения объектов взаимодействия. Для INTERFEREOBJVS может быть задан только стиль отображения, сохраненный чертеже.

Стиль отображения, заданный для INTERFEREOBJVS, не может быть удален командой ОЧИСТИТЬ.


INTERFEREVPVS Системная переменная

I Системные переменные
INTERFEREVPVS Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | Каркас

Задает стиль отображения видового экрана во время проверки пространственных взаимодействий. Для INTERFEREVPVS может быть задан только стиля отображения, сохраненный в чертеже.

Стиль отображения, заданный для INTERFEREVPVS, не может быть удален командойОЧИСТИТЬ


INTERSECTIONCOLOR Системная переменная

I Системные переменные
INTERSECTIONCOLOR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 257

Управляет цветом полилиний на пересечении 3D поверхностей, если визуальному стилю установлено значение 2D Каркас..

Значение 0 задает значение цвета ПОБЛОКУ, значение 256 – ПОСЛОЮ, а значение 257 – ПООБЪЕКТУ. Значения от 1 до 255 задают цвета в соответствии с индексом цветов AutoCAD. Доступны также цвета полноцветного режима и цветового альбома.

Значение переменной INTERSECTIONCOLOR можно видеть, только если переменной INTERSECTIONDISPLAY установлено значение Вкл.


INTERSECTIONDISPLAY Системная переменная

I Системные переменные
INTERSECTIONDISPLAY Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | Откл

Управляет отображением полилиний на пересечении 3D поверхностей, если визуальному стилю установлено значение 2D Каркас. .

Откл | Отключает отображение полилиний пересечения.
Вкл | Включает отображение полилиний пересечения


ISAVEBAK Системная переменная

I Системные переменные
ISAVEBAK Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Повышает скорость последовательных сохранений, особенно для больших чертежей . Переменная ISAVEBAK управляет созданием файла резервной копии (.bak). В операционной системе копирование данных для создания BAK-файла может занять при сохранении основную долю времени.

0 | BAK-файл не создается (даже при полном сохранении)
1 | BAK-файл создается

Предупреждение В некоторых случаях (например, при сбое электропитания во время сохранения) данные чертежа могут быть потеряны.


ISAVEPERCENT Системная переменная

I Системные переменные
ISAVEPERCENT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 50

Определяет количество неиспользуемого дискового пространства, допустимого в файле чертежа . Переменная принимает значения в диапазоне от 0 до 100. Значение 50 (по умолчанию) означает, что неиспользуемое пространство внутри файла не должно превышать 50% от размера всего файла. Неиспользуемое пространство периодически сокращается при полных сохранениях. Как только программа обнаруживает, что оно превысило 50%, следующее сохранение делается полным, а счетчик неиспользуемого пространства сбрасывается в 0. Если ISAVEPERCENT установлена в 0, производятся только полные сохранения чертежа.


ISOLINES Системная переменная

I Системные переменные
ISOLINES Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 4

Указывает количество линий контура для изображения поверхностей объектов . Допустимые значения — целые числа от 0 до 2047.


L Системные переменные
  • LASTANGLE
  • LASTPOINT
  • LASTPROMPT
  • LATITUDE
  • LAYERFILTERALERT
  • LAYOUTREGENCTL
  • LEGACYCTRLPICK
  • LENSLENGTH
  • LIGHTGLYPHDISPLAY
  • LIGHTLISTSTATE
  • LIMCHECK
  • LIMMAX
  • LIMMIN
  • LISPINIT
  • LOCALE
  • LOCALROOTPREFIX
  • LOCKUI
  • LOFTANG1
  • LOFTANG2
  • LOFTMAG1
  • LOFTMAG2
  • LOFTNORMALS
  • LOFTPARAM
  • LOGFILEMODE
  • LOGFILENAME
  • LOGFILEPATH
  • LOGINNAME
  • LONGITUDE
  • LTSCALE
  • LUNITS
  • LUPREC
  • LWDEFAULT
  • LWDISPLAY
  • LWUNITS


LASTANGLE Системная переменная

L Системные переменные
LASTANGLE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | 0

Сохраняет конечный угол последней введенной дуги в плоскости XY текущей ПСК в текущем пространстве .


LASTPOINT Системная переменная

L Системные переменные
LASTPOINT Системная переменная
Понятия Процедуры Команды

Тип: | 3D-point
Сохранен в: | Не сохранен
Начальное значение: | 0,0000, 0,0000, 0,0000

Сохраняет последнюю введенную точку, выраженную в координатах ПСК в текущем пространстве. Для того чтобы координаты отсчитывались от нее, необходимо начать ввод с клавиатуры с символа @ .


LASTPROMPT Системная переменная

L Системные переменные
LASTPROMPT Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ""

Сохраняет последний текст, выведенный в командной строке . Эта строка абсолютно идентична последней командной строке и включает любой введенный пользователем текст.


LATITUDE Системная переменная

L Системные переменные
LATITUDE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | разные

Задает широту модели чертежа в формате десятичных чисел. Значением по умолчанию является широта Сан-Франциско, Калифорния. Диапазон допустимых значений от -90 до +90. Положительные значения представляют северные широты. На значение не влияют установки системных переменных AUNITS и AUPREC.


LAYERFILTERALERT Системная переменная

L Системные переменные
LAYERFILTERALERT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Удаляет избыточные фильтры слоев для повышения производительности . Если чертеж имеет более 100 фильтров слоев, а количество фильтров слоев превышает количество слоев, переменная LAYERFILTERALERT обеспечивает способ удаления фильтров слоев для повышения производительности.

0 | Откл
1 | Когда диспетчер свойств открыт, можно удалить все фильтры слоев; сообщение не отобразится
2 | Если открыт диспетчер слоев, выводится сообщение, в котором будет указана ошибка, рекомендовано удалить все фильтры и предложено: “Хотите удалить все фильтры слоев сейчас?”
3 | Когда открыт чертеж, отобразится сообщение об ошибке, и будет предложено открыть диалоговое окно, в котором можно выбрать фильтры для удаления


LAYOUTREGENCTL Системная переменная

L Системные переменные
LAYOUTREGENCTL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Указывает режим обновления списка отображения на вкладке "Модель" и вкладках "Лист" . При переходе с одной вкладки на другую это обновление может осуществляться либо путем регенерации чертежа, либо путем сохранения списка отображения в памяти и последующей регенерации только измененных объектов. Изменяя переменную LAYOUTREGENCTL, можно управлять производительностью работы с чертежами.

0 | Чертеж регенерируется при каждом переходе с одной вкладки на другую.
1 | Для вкладки "Модель" и последнего активного листа список отображения сохраняется в памяти. При переключении между этими двумя вкладками регенерации не происходит. При переходе на какой-либо другой лист его содержимое регенерируется.
2 | Чертеж регенерируется только при первом заходе на каждую из вкладок. Поскольку списки отображения сохраняются в памяти на протяжении всего рабочего сеанса, последующих регенераций при переходе между вкладками уже не требуется.

Выигрыш в производительности, обеспечиваемый надлежащей установкой LAYOUTREGENCTL, зависит от различных факторов — размера и типа чертежа, находящихся в нем объектов, объема доступной памяти и наличия параллельно открытых чертежей и приложений. Если LAYOUTREGENCTL равна 1 или 2, объем используемой дополнительной памяти равен произведению размера списка экранов вкладки "Модель" на количество видовых экранов в каждом листе, для которого сохранен список экранов.

Если LAYOUTREGENCTL равна 1 или 2, а программа работает медленно или переключается между вкладками с большой задержкой, следует, изменяя значение соответственно на 0 или 1, подобрать оптимальный баланс для конкретной рабочей среды. Подробнее о настройках производительности см. вкладку "Система" в диалоговом окне "Настройки".

Независимо от значения LAYOUTREGENCTL, чертеж регенерируется при первом переходе на вкладку, содержащую сохраненные видовые экраны, если были выполнены переопределение блока или отмена перехода на другую вкладку.


LEGACYCTRLPICK Системная переменная

L Системные переменные
LEGACYCTRLPICK Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Задает клавиши циклического повторения выбора и определяет действия при нажатии клавиши CTRL и левой кнопки мыши.

0 | Нажатие клавиши CTRL и левой кнопки мыши используется для выбора подобъектов (граней, контуров и вершин) на 3D твердотельных объектах.
1 | Нажатие клавиши CTRL и левой кнопки мыши используется для циклического просмотра перекрывающихся объектов. Запрещает использование нажатия клавиши CTRL и левой кнопки мыши для выбора подобъектов на 3D твердотельных объектах.


LENSLENGTH Системная переменная

L Системные переменные
LENSLENGTH Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 50,0000

Сохраняет фокусное расстояние объектива (в мм), используемого при построении вида в перспективе.


LIGHTGLYPHDISPLAY Системная переменная

L Системные переменные
LIGHTGLYPHDISPLAY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет отображением обозначений источников света. Если эта системная переменная отключена, обозначения источников света на чертеже не отображаются.

0 | Откл
1 | Вкл


LIGHTLISTSTATE Системная переменная

L Системные переменные
LIGHTLISTSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Указывает, открыто ли окно источников света в модели.

0 | Закрыто
1 | Открыть


LIMCHECK Системная переменная

L Системные переменные
LIMCHECK Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет созданием объектов за пределами лимитов чертежа .

0 | Объекты можно создавать за пределами лимитов
1 | Объекты нельзя создавать за пределами лимитов


LIMMAX Системная переменная

L Системные переменные
LIMMAX Системная переменная
Понятия Процедуры Команды

Тип: | 2D-point
Сохранен в: | чертеж
Начальное значение: | 12,0000, 9,0000

Правая верхняя точка лимитов чертежа, выраженная в мировых координатах. При активном пространстве листа с показом подложенного формата или границ печати LIMMAX становится доступной только для чтения.


LIMMIN Системная переменная

L Системные переменные
LIMMIN Системная переменная
Понятия Процедуры Команды

Тип: | 2D-point
Сохранен в: | чертеж
Начальное значение: | 0,0000, 0,0000

Сохраняет левую нижнюю точку лимитов чертежа, выраженную в мировых координатах . При активном пространстве листа с показом подложенного формата или границ печати LIMMIN становится доступной только для чтения.


LISPINIT Системная переменная

L Системные переменные
LISPINIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Указывает, сохраняются ли функции и переменные AutoLISP при открытом чертеже в однодокументном интерфейсе .

0 | Функции и переменные AutoLISP сохраняются при переходе к следующему чертежу
1 | Функции и переменные AutoLISP допустимы только в текущем чертеже

Если для системной переменной SDI установлено значение 0, результат действия AutoLISP аналогичен результату, получаемому, если для системной переменной LISPINIT установлено значение 1. Информацию о работе функций, определенных в программе AutoLISP, и о переменных в многодокументном интерфейсе см. в Руководстве разработчика AutoLISP.


LOCALE Системная переменная

L Системные переменные
LOCALE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ""

Отображает код, указывающий текущее место . Этот код отображается в виде трехбуквенной аббревиатуры, возвращаемой функцией Windows GetLocaleInfo с помощью константы LOCALE_SABBREVLANGNAME.


LOCALROOTPREFIX Системная переменная

L Системные переменные
LOCALROOTPREFIX Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | реестр
Начальное значение: | "путь"

Сохраняет полный путь к корневой папке, в которую были установлены локальные адаптируемые файлы . Такие файлы хранятся в папках, вложенных в системную папку Local Settings; например, "C:\ Documents and Settings\имя_пользователя\ Local Settings\ Application Data\имя_продукта\версия\язык".

Папки Template и Textures находятся здесь же, и в них можно добавить любой адаптируемый файл, не нуждающийся в сетевом роуминге. Подробнее об этом см. ROAMABLEROOTPREFIX.


LOCKUI Системная переменная

L Системные переменные
LOCKUI Системная переменная
Понятия Процедуры Команды

Тип: | битовый код
Сохранен в: | реестр
Начальное значение: | 0

Блокирует положение и размер панелей инструментов и плавающих окон, таких как "DesignCenter" и "Палитра свойств" . Закрепленные панели инструментов и окна могут открываться и закрываться, а элементы могут быть добавлены или удалены. Чтобы временно их разблокировать, удерживайте нажатой клавишу CTRL.

Значок блокировки в строке состояния указывает, заблокированы ли панели инструментов и окна. Для отображения заблокированных параметров следует нажать правую кнопку мыши на значке блокировки.

Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Панели инструменты и окна не заблокированы
1 | Закрепленные панели инструментов заблокированы
2 | Заблокированы закрепленные или имеющие якорь окна
4 | Плавающие панели инструментов заблокированы
8 | Плавающие окна заблокированы


LOFTANG1 Системная переменная

L Системные переменные
LOFTANG1 Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 90

Устанавливает черновой угол сквозь первое поперечное сечение в операции сечения. Нулевое направление измеряется наружу от кривой на плоскости кривой. Положительное направление измеряется в сторону следующего поперечного сечения. Действительными являются значения большие или равные 0, но меньшие 360.


LOFTANG2 Системная переменная

L Системные переменные
LOFTANG2 Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 90

Устанавливает черновой угол сквозь последнее поперечное сечение в операции сечения. Нулевое направление измеряется наружу от кривой на плоскости кривой. Положительное направление измеряется в сторону предыдущего поперечного сечения. Действительными являются значения большие или равные 0, но меньшие 360.


LOFTMAG1 Системная переменная

L Системные переменные
LOFTMAG1 Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Устанавливает величину чернового угла сквозь первое поперечное сечение в операции сечения. Контролирует, насколько быстро поверхность начинает изгибаться в направлении следующего поперечного сечения. Действительными являются целые значения от 1 до 10.


LOFTMAG2 Системная переменная

L Системные переменные
LOFTMAG2 Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Устанавливает величину чернового угла сквозь последнее поперечное сечение в операции сечения. Контролирует, насколько быстро поверхность начинает изгибаться в направлении следующего поперечного сечения. Действительными являются целые значения от 1 до 10.


LOFTNORMALS Системная переменная

L Системные переменные
LOFTNORMALS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет нормалями развернутого объекта в точках их прохода сквозь поперечные сечения. Этот параметр игнорируется при задании траектории или направляющих.

Эти параметры также можно задать в диалоговом окне "Настройки сечений".

0 | Линейчатый
1 | Сглаженный
2 | Первая нормаль
3 | Последняя нормаль
4 | Конечная нормаль
5 | Все нормали
6 | Использовать черновой угол и величину


LOFTPARAM Системная переменная

L Системные переменные
LOFTPARAM Системная переменная
Понятия Процедуры Команды

Тип: | битовый код
Сохранен в: | чертеж
Начальное значение: | 7

Управляет очертанием развернутых тел и поверхностей.

1 | Без поворота (минимизирует поворот между поперечными сечениями)
2 | Спрямить направление (спрямляет направление от начала до конца каждой кривой поперечного сечения)
4 | Упростить (генерирует простые сплошные тела и поверхности, такие как цилиндр или плоскость, вместо сплайновых тел и поверхностей)
8 | Закрыть (закрывает поверхность или тело между первым и последним поперечными сечениями)


LOGFILEMODE Системная переменная

L Системные переменные
LOGFILEMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Указывает, производится ли запись содержимого текстового окна в файл журнала. .

0 | Журнал не ведется
1 | Журнал ведется


LOGFILENAME Системная переменная

L Системные переменные
LOGFILENAME Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | разные

Задает путь и имя файла журнала текстового окна для текущего чертежа . Начальное значение зависит от имени текущего чертежа и папки установки.


LOGFILEPATH Системная переменная

L Системные переменные
LOGFILEPATH Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | "c:\Documents and Settings\имя_пользователя\Local Settings\Application Data\Autodesk\имя_продукта\версия\локальный_код"

Задает путь к файлам журналов текстового окна для всех чертежей в сеансе. Можно также задать путь с помощью команды НАСТРОЙКА. Начальное значение зависит от папки установки.


LOGINNAME Системная переменная

L Системные переменные
LOGINNAME Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ""

Отображает имя пользователя, обновленное или введенное при запуске программы . Максимальная длина имени — 30 символов.


LONGITUDE Системная переменная

L Системные переменные
LONGITUDE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | разные

Задает долготу модели чертежа в формате десятичных чисел . Значением по умолчанию является долгота Сан-Франциско, Калифорния. Диапазон допустимых значений от -180 до +180. Положительные значения представляют западную долготу. На значение не влияют установки системных переменных AUNITS и AUPREC.


LTSCALE Системная переменная

L Системные переменные
LTSCALE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 1,0000

Глобальный масштаб типов линий. Он должен быть ненулевым. Имя этой системной переменной совпадает с названием команды. Для доступа к этой системной переменной используется команда УСТПЕРЕМ.


LUNITS Системная переменная

L Системные переменные
LUNITS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 2

Устанавливает линейные единицы .

1 | Научные
2 | Десятичные
3 | Конструкторские
4 | Архитектурные
5 | С дробной частью


LUPREC Системная переменная

L Системные переменные
LUPREC Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 4

Определяет количество десятичных знаков, отображаемых для нередактируемых линейных единиц и для всех редактируемых линейных единиц, исходная точность которых меньше или равна значению текущей системной переменной LUPREC. . Предлагаемые для редактирования значения расстояний, точность которых равна или больше заданной в LUPREC, выводятся без усечения (т.е. с тем количеством десятичных знаков, которое имеется в действительности). LUPREC не влияет на точность представления размерных текстов (см. РЗМСТИЛЬ).


LWDEFAULT Системная переменная

L Системные переменные
LWDEFAULT Системная переменная
Понятия Процедуры Команды

Тип: | значение из стандартного списка
Сохранен в: | реестр
Начальное значение: | 25

Устанавливает значение для веса линии по умолчанию . Значение веса линии по умолчанию выражается в сотых долях миллиметра и может быть любым из следующего ряда: 0, 5, 9, 13, 15, 18, 20, 25, 30, 35, 40, 50, 53, 60, 70, 80, 90, 100, 106, 120, 140, 158, 200 и 211.

Значения выражаются в сотых долях миллиметра. Для преобразования веса линий, выраженного в британской системе единиц, необходимо умножить его значение на коэффициент 2.54.


LWDISPLAY Системная переменная

L Системные переменные
LWDISPLAY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | ОТКЛ (0)

Управляет отображением веса линий . Для каждой вкладки чертежа сохраняется отдельное значение переменной.

ОТКЛ или 0 | Вес линий не отображается
ВКЛ или 1 | Вес линий отображается


LWUNITS Системная переменная

L Системные переменные
LWUNITS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Определяет единицы измерения для весов линий (дюймы или миллиметры) .

0 | Дюймы
1 | Миллиметры


M Системные переменные
  • MATSTATE
  • MAXACTVP
  • MAXSORT
  • MBUTTONPAN
  • MEASUREINIT
  • MEASUREMENT
  • MENUCTL
  • MENUECHO
  • MENUNAME
  • MIRRTEXT
  • MODEMACRO
  • MSMSTATE
  • MSOLESCALE
  • MTEXTED
  • MTEXTFIXED
  • MTJIGSTRING
  • MYDOCUMENTSPREFIX


MATSTATE Системная переменная

M Системные переменные
MATSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Указывает состояние окна "Материалы": открыто или нет.

0 | Закрыт
1 | Открыто


MAXACTVP Системная переменная

M Системные переменные
MAXACTVP Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 64

Устанавливает максимальное количество видовых экранов, которые могут быть активны одновременно . Переменная MAXACTVP не оказывает влияния на число видовых экранов, выводимых на печать.


MAXSORT Системная переменная

M Системные переменные
MAXSORT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1000

Устанавливает максимальное количество имен символов или имен файлов, которое можно отсортировать с помощью команд вывода списков . Если количество элементов списка превышает это значение, список не сортируется.


MBUTTONPAN Системная переменная

M Системные переменные
MBUTTONPAN Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет действиями третьей кнопки или колесика на устройстве указания. .

0 | Поддерживает операцию, определенную в файле адаптации (НПИ)
1 | Выполняет панорамирование путем нажатия третьей кнопки (колесика) и последующего перемещения мыши


MEASUREINIT Системная переменная

M Системные переменные
MEASUREINIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | Зависит от страны/региона

Определяет, какая система единиц по умолчанию (британская или метрическая) используется в чертеже, созданном на основе простейшего шаблона . В частности, системная переменная MEASUREINIT определяет, какой файл образца штриховки и типа линии используется. Файл Drawing1.dwg, открывающийся при запуске программы, является чертежом, созданным с помощью простейшего шаблона.

0 | Британские единицы; использует файлы образцов штриховки и типов линий, заданные в элементах реестра ANSIHatch и ANSILinetype
1 | Метрические единицы; использует файлы образцов штриховки и типов линий, заданные в элементах реестра ISOHatch и ISOLinetype


MEASUREMENT Системная переменная

M Системные переменные
MEASUREMENT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Определяет, какие единицы используются в файлах образцов штриховки или типов линий текущего чертежа .

0 | Британские единицы; использует файлы образцов штриховки и типов линий, заданные в элементах реестра ANSIHatch и ANSILinetype
1 | Метрические единицы; использует файлы образцов штриховки и типов линий, заданные в элементах реестра ISOHatch и ISOLinetype


MENUCTL Системная переменная

M Системные переменные
MENUCTL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет переключением страниц экранного меню .

0 | Страницы экранного меню не переключаются при вводе команд с клавиатуры
1 | Страницы экранного меню переключаются при вводе команд с клавиатуры


MENUECHO Системная переменная

M Системные переменные
MENUECHO Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Устанавливает битовый код управления эхо-выводом и запросами меню . Код является суммой следующих значений:

1 | Подавляет эхо-вывод пунктов меню (переключатель в меню ^P)
2 | Подавляет системные запросы во время выполнения команд из меню
4 | Подавляет переключателя ^P эхо-вывода пунктов меню
8 | Отображает все выводимые и вводимые строки (режим отладки для макросов DIESEL)


MENUNAME Системная переменная

M Системные переменные
MENUNAME Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | реестр
Начальное значение: | "имя_файла_адаптации"

Хранит имя файла адаптации, включая путь .


MIRRTEXT Системная переменная

M Системные переменные
MIRRTEXT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет отображением текста с помощью команды ЗЕРКАЛО .

0 | Сохраняет направление текста
1 | Зеркально отображает текст


MODEMACRO Системная переменная

M Системные переменные
MODEMACRO Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ""

Отображает текстовую последовательность в статусной строке; например, имя текущего чертежа, время и дата или специальные режимы. .

Для отображения текстовой строки используйте системную переменную MODEMACRO, или специальные текстовые строки, написанные на макроязыке DIESEL, для периодического их обновления макросом с учетом условий, определенных пользователем.


MSMSTATE Системная переменная

M Системные переменные
MSMSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Сохраняет значение, указывающее состояние Диспетчера наборов пометок: открыт или нет.

0 | Закрыт
1 | Открыт


MSOLESCALE Системная переменная

M Системные переменные
MSOLESCALE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 1,000

Управляет размером объектов OLE, в которых текст вставлен в пространство модели . MSOLESCALE управляет только исходным размером. Если значение масштабного коэффициента изменяется, это не влияет на имеющиеся в чертеже OLE-объекты.

Положительное число масштабируется по значению. Центр (0) масштабируется по значению DIMSCALE.


MTEXTED Системная переменная

M Системные переменные
MTEXTED Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | "Встроенный"

Определяет приложение для редактирования многострочных текстовых объектов. Для команды МТЕКСТ можно задать другой текстовый редактор. Если переменной MTEXTED установить значение "встроенный" или "нуль" (.), на экран будет выведен Текстовый редактор, используемый в месте редактирования. Если переменной MTEXTED установить значение "OldEditor", на экран будет выведен Многострочный текстовый редактор. Если задано имя и путь к исполняемому файлу другого текстового редактора, вместо этого отобразится имя и путь к файлу.

Если длина многострочного текста не превышает 80 символов, можно ввести :lisped, чтобы воспользоваться редактором LISP.

В текстовых редакторах, отличных от встроенного, отображаются символы форматирования.


MTEXTFIXED Системная переменная

M Системные переменные
MTEXTFIXED Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Устанавливает размер экрана и положение многострочного текста.

Если переменной MTEXTED установлено значение "Встроенный", то многострочный текст будет выведен в текстовый редактор, используемый в месте редактирования. Если переменной MTEXTED установлено значение "OldEditor", то многострочный текст будет выведен в "Редактор многострочного текста".

Если переменной MTEXTED установлено значение "Встроенный":

0 или 1

Выводит текстовый редактор, используемый в месте редактирования, и текст, расположенный в нем, в соответствии с размером, положением и направлением поворота многострочного текстового объекта на чертеже.

2

Выводит текстовый редактор, используемый в месте редактирования, и текст, расположенный в нем, в соответствии с размером, положением и направлением поворота многострочного текстового объекта на чертеже.

Неудобочитаемый текст (слишком мелкий, слишком крупный или повернутый) отображается разборчиво и в горизонтальном направлении, чтобы его можно было легко прочитать и отредактировать.

Если переменной MTEXTED установлено значение "OldEditor":

0 | Отображает редактор многострочного текста и текст, расположенный внутри него, в соответствии с размером и расположением многострочного текстового объекта внутри чертежа. Слишком большой или маленький текст отображается, соответственно, с максимальным или минимальным размером окна. Повернутый текст отображается горизонтально.
1 или 2 | Отображает редактор многострочного текста в фиксированном положении и заданного размера, с учетом настройки при последнем использовании, а текст внутри него - в соответствии с заданной высотой. Повернутый текст отображается горизонтально.


MTJIGSTRING Системная переменная

M Системные переменные
MTJIGSTRING Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | "abc"

Определяет содержимое образца текста, отображаемого в месте курсора при запуске команды МТЕКСТ . Строка отображается с использованием текущих шрифта и размера. Допустимая длина строки — до десяти символов (цифр и букв). Если строка-образец не нужна, следует ввести точку (.).


MYDOCUMENTSPREFIX Системная переменная

M Системные переменные
MYDOCUMENTSPREFIX Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | реестр
Начальное значение: | "путь"

Хранит полный путь к папке "Мои документы" текущего пользователя . Такие файлы хранятся в папках, вложенных в системную папку Local Settings; например, "c:\ Documents and Settings\имя_пользователя\ Мои документы".


N Системные переменные
  • NOMUTT
  • NORTHDIRECTION


NOMUTT Системная переменная

N Системные переменные
NOMUTT Системная переменная
Понятия Процедуры Команды

Тип: | короткий целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Подавляет вывод сообщения на экран (подсказка), которое в нормальном режиме не подавляется. В нормальном режиме работы команды сопровождаются соответствующими подсказками в командной строке, которые подавляются при выполнении сценариев, функций AutoLISP и т.д.

0 | Нормальный режим подсказок
1 | Полностью подавляет подсказки


NORTHDIRECTION Системная переменная

N Системные переменные
NORTHDIRECTION Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | разные

Задает угол смещения Вс от севера . Установки системных переменных AUNITS и AUPREC влияют на это значение.

Примечание Угол интерпретируется в контексте мировой системы координат (МСК). Это значение полностью отделено от топографических угловых единиц, которые всегда устанавливаются относительно текущей ПСК.


O Системные переменные
  • OBSCUREDCOLOR
  • OBSCUREDLTYPE
  • OFFSETDIST
  • OFFSETGAPTYPE
  • OLEFRAME
  • OLEHIDE
  • OLEQUALITY
  • OLESTARTUP
  • OPMSTATE
  • ORTHOMODE
  • OSMODE
  • OSNAPCOORD
  • OSNAPHATCH
  • OSNAPZ
  • OSOPTIONS


OBSCUREDCOLOR Системная переменная

O Системные переменные
OBSCUREDCOLOR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 257

Задает цвет линий заднего плана . Значения 0, 256 и 257 задают логические цвета ПоБлоку, ПоСлою и ПоОбъекту, соответственно. Значения от 1 до 255 задают цвета в соответствии с индексом цветов AutoCAD.

Линией заднего плана является скрытая линия, которую можно сделать видимой, изменив ее цвет и тип. Переменная OBSCUREDCOLOR доступна только в 2D видах. В 3D видах используется системная переменная VSOBSCUREDCOLOR.

Настройка переменной OBSCUREDCOLOR проявляется только тогда, когда системной переменной OBSCUREDLTYPE присвоено отличное от нуля значение.


OBSCUREDLTYPE Системная переменная

O Системные переменные
OBSCUREDLTYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Указывает тип линий заднего плана . В отличие от обычных типов линий, тип линий заднего плана не зависит от экранного увеличения. Переменная может принимать следующие значения:

0 | Откл
1 | Заливка
2 | Штриховая
3 | Пунктирная
4 | Штриховая (кор. штрих)
5 | Штриховая (ср. штрих)
6 | Штриховая (дл. штрих)
7 | Двойная (кор. штрих)
8 | Двойная (ср. штрих)
9 | Двойная (дл. штрих)
10 | Штриховая (увел. штрих)
11 | Редкопунктирная

Линией заднего плана является скрытая линия, которую можно сделать видимой, изменив ее цвет и тип. Переменная OBSCUREDLTYPE доступна только в 2D видах. В 3D видах используется системная переменная VSOBSCUREDLTYPE.


OFFSETDIST Системная переменная

O Системные переменные
OFFSETDIST Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | -1,0000

Устанавливает расстояние смещения по умолчанию .

<0 | Смещает объект по указанной точке
≥0 | Устанавливает расстояние смещения по умолчанию


OFFSETGAPTYPE Системная переменная

O Системные переменные
OFFSETGAPTYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет зазорами между сегментами, возникающими при смещении замкнутых полилиний .

0 | Зазоры заполняются путем растягивания сегментов полилиний.
1 | Зазоры заполняются сопрягающими дуговыми сегментами (радиусом, равным расстоянию смещения).
2 | Зазоры заполняются соединяющими линейными сегментами (перпендикуляр к каждой из фасок равен расстоянию смещения).


OLEFRAME Системная переменная

O Системные переменные
OLEFRAME Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 2

Управляет отображением и печатью рамок для всех объектов OLE чертежа . Рамка на OLE-объекте должна отображаться для того, чтобы были видны ручки.

0 | Рамка не отображается и не выводится на печать
1 | Рамка отображается и выводится на печать
2 | Рамка отображается, но не выводится на печать


OLEHIDE Системная переменная

O Системные переменные
OLEHIDE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет отображением и выводом на печать объектов OLE .

0 | Все объекты OLE видимы и доступны для печати
1 | Объекты OLE видимы и доступны для печати только в пространстве листа
2 | Объекты OLE видимы и доступны для печати только в пространстве модели
3 | Объекты OLE невидимы и недоступны для печати


OLEQUALITY Системная переменная

O Системные переменные
OLEQUALITY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 3

Устанавливает качества печати объектов OLE по умолчанию . Когда для OLEQUALITY задано значение 3, уровень качества вывода назначается автоматически на основе типа объектов. Например, для таблиц задается значение 0, для цветного текста и диаграмм значение 1, а для фотографий значение 2.

0 | Монохромный
1 | Простая графика
2 | Сложная графика
3 | Автоматический выбор


OLESTARTUP Системная переменная

O Системные переменные
OLESTARTUP Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет загрузкой исходного приложения, в котором был создан внедренный OLE объект, при печати . Загрузка приложения может улучшить качество вывода.

0 | Исходное приложение не загружается
1 | Исходное приложение загружается при печати


OPMSTATE Системная переменная

O Системные переменные
OPMSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Сохраняет значение, которое указывает состояние Палитры свойств: открыта или нет.

0 | Закрыта
1 | Открыта
2 | Авто-скрытие: Открыта, однако, если курсор выходит за пределы палитры, отображается только строка заголовка.


ORTHOMODE Системная переменная

O Системные переменные
ORTHOMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет перемещением курсора в перпендикулярном направлении . Если ORTHOMODE включена, курсор может двигаться только горизонтально и вертикально относительно текущей ПСК (с учетом угла поворота шаговой привязки).

0 | Отключает режим "Орто"
1 | Включает режим "Орто"


OSMODE Системная переменная

O Системные переменные
OSMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 4133

Определяет выполнение объектных привязок . Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | НИЧего
1 | КОНточка
2 | СЕРедина
4 | ЦЕНтр
8 | УЗЕл
16 | КВАдрант
32 | ПЕРесечение
64 | ТВСтавки
128 | НОРмаль
256 | КАСательная
512 | БЛИжайшая
1024 | Отменяет все объектные привязки
2048 | КАЖущееся пересечение
4096 | ПРОдолжение
8192 | ПАРаллельно

Если одновременно должно быть активно несколько режимов, следует ввести сумму соответствующих чисел. Так, например, значение 3 означает комбинацию режимов "Конточка" (код 1) и "Середина" (код 2). Значение 16383 активизирует все режимы.

Когда все режимы объектной привязки отключены с помощью кнопки "ПРИВЯЗКА" в строке состояния, возвращается значение 16384 (0x4000). Это дополнительное значение позволяет разработчикам отличать данный режим от режимов объектной привязки, которые были отключены в диалоговом окне "Режимы рисования". Установка дополнительного бита в 1 позволяет отключить привязку. Присвоение переменной OSMODE значения, в котором данный бит установлен в 0, включает объектную привязку.


OSNAPCOORD Системная переменная

O Системные переменные
OSNAPCOORD Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Управляет приоритетом ввода координат с клавиатуры над текущими режимами привязки .

0 | Текущие режимы объектной привязки подавляют ввод координат с клавиатуры
1 | Вводимые с клавиатуры координаты подавляют текущие режимы объектной привязки
2 | Вводимые с клавиатуры координаты подавляют режимы привязки (за исключением использованных в сценариях)


OSNAPHATCH Системная переменная

O Системные переменные
OSNAPHATCH Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Устар. . Системная переменная OSOPTIONS используется для управления объектной привязкой: игнорировать объекты штриховки или нет. При использовании значения по умолчанию, равного 0, повышается производительность.

0 | Объекты штриховки игнорируются при объектной привязке
1 | При объектной привязке объекты штриховки воспринимаются как другие объекты


OSNAPZ Системная переменная

O Системные переменные
OSNAPZ Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Управляет автоматической проекцией объектной привязки на плоскость, параллельную плоскости XY текущей ПСК, на текущем уровне .

0 | При привязке используется значение координаты Z указанной точки
1 | При привязке значение координаты Z указанной точки заменяется значением уровня (ELEV), установленным для текущей ПСК


OSOPTIONS Системная переменная

O Системные переменные
OSOPTIONS Системная переменная
Понятия Процедуры Команды

Тип: | битовый код
Сохранен в: | реестр
Начальное значение: | 3

Автоматически подавляет объектную привязку на объектах штриховки и геометрию с отрицательными значениями Z при использовании динамической ПСК.

Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Объектная привязка работает на объектах штриховки и в геометрии с отрицательными значениями Z при использовании динамической ПСК
1 | Объекты штриховки игнорируются при объектной привязке
2 | Объектная привязка игнорирует геометрию с отрицательными значениями Z при использовании динамической ПСК


P Системные переменные
  • PALETTEOPAQUE
  • PAPERUPDATE
  • PDMODE
  • PDSIZE
  • PEDITACCEPT
  • PELLIPSE
  • PERIMETER
  • PERSPECTIVE
  • PFACEVMAX
  • PICKADD
  • PICKAUTO
  • PICKBOX
  • PICKDRAG
  • PICKFIRST
  • PICKSTYLE
  • PLATFORM
  • PLINEGEN
  • PLINETYPE
  • PLINEWID
  • PLOTOFFSET
  • PLOTROTMODE
  • PLQUIET
  • POLARADDANG
  • POLARANG
  • POLARDIST
  • POLARMODE
  • POLYSIDES
  • POPUPS
  • PREVIEWEFFECT
  • PREVIEWFILTER
  • PRODUCT
  • PROGRAM
  • PROJECTNAME
  • PROJMODE
  • PROXYGRAPHICS
  • PROXYNOTICE
  • PROXYSHOW
  • PROXYWEBSEARCH
  • PSLTSCALE
  • PSOLHEIGHT
  • PSOLWIDTH
  • PSTYLEMODE
  • PSTYLEPOLICY
  • PSVPSCALE
  • PUBLISHALLSHEETS
  • PUCSBASE


PALETTEOPAQUE Системная переменная

P Системные переменные
PALETTEOPAQUE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет прозрачностью окон . Если режим прозрачности отключен или не имеет смысла, палитры не могут быть прозрачными. Прозрачность недоступна в случаях, когда палитры или окна закреплены, режим прозрачности не поддерживается операционной системой, а также при использовании аппаратного ускорения.

При доступном и включенном режиме прозрачности степень прозрачности палитр настраивается через опцию "Прозрачность" в контекстном меню.

0 | Режим прозрачности включен пользователем
1 | Режим прозрачности отключен пользователем
2 | Режим прозрачности недоступен, хотя и включен пользователем
3 | Режим прозрачности недоступен и отключен пользователем


PAPERUPDATE Системная переменная

P Системные переменные
PAPERUPDATE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управление выводом диалогового окна предупреждения при попытке вывести на печать лист, формат которого не совпадает с форматом, заданным по умолчанию в файле параметров плоттера .

0 | Отображает диалоговое окно предупреждения, если плоттер не поддерживает данный формат листа
1 | Листу назначается формат, заданный в файле параметров плоттера


PDMODE Системная переменная

P Системные переменные
PDMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет отображением точечных объектов . Список возможных значений см. в описании команды ТОЧКА.


PDSIZE Системная переменная

P Системные переменные
PDSIZE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Устанавливает размер отображения точечных объектов .

0 | Создает точку, величина которой составляет 5% высоты области чертежа
>0 | Задает абсолютный размер
<0 | Указывает размер в процентах от размера видового экрана


PEDITACCEPT Системная переменная

P Системные переменные
PEDITACCEPT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Подавляет отображение подсказки "Выбранный объект не является полилинией" команды ПОЛРЕД . После подсказки выводится “Хотите преобразовать в полилинию?” Введитед, чтобы преобразовать выбранный объект в полилинию. При подавлении запроса выбранный объект преобразуется в полилинию автоматически.

0 | Подсказка отображается
1 | Подсказка не отображается


PELLIPSE Системная переменная

P Системные переменные
PELLIPSE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Определяет тип эллипса, созданного с помощью команды ЭЛЛИПС .

0 | Создает реальные эллипсы.
1 | Создает представление эллипса в виде полилинии


PERIMETER Системная переменная

P Системные переменные
PERIMETER Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | 0,0000

Хранит последнее значение периметра, вычисленное с помощью команды ПЛОЩАДЬ или СПИСОК .

Также хранит значения периметров, вычисленных с помощью команды БДСПИСОК.


PERSPECTIVE Системная переменная

P Системные переменные
PERSPECTIVE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | разные

Указывает, отображает текущий видовой экран рабочий вид в перспективе или нет. Значение переменной PERSPECTIVE сбрасывается в 0, если файл чертежа или DXF-файл сохраняется в формате, предшествующем формату AutoCAD 2007. Эта системная переменная действительна только в пространстве модели.

0 | Вид в перспективе отключен
1 | Вид в перспективе включен

Примечание Вид в перспективе не доступен в режиме отображения 2D Каркас. При открытии файла, созданного в более ранней версии с сохранением вида в перспективе в режиме 2D Каркас, он будет отображен в параллельной проекции.


PFACEVMAX Системная переменная

P Системные переменные
PFACEVMAX Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 4

Устанавливает максимальное число вершин на одну грань .


PICKADD Системная переменная

P Системные переменные
PICKADD Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет дополнительным выбором объектов (заменяет или дополняет текущий набор выбранных объектов) .

0 | Отключает системную переменную PICKADD. Последние выбранные объекты и подобъекты становятся набором объектов. Ранее выбранные объекты и подобъекты удаляются из набора объектов. Добавить объекты и подобъекты в набор можно, выбирая их при нажатой клавише SHIFT.
1 | Включает системную переменную PICKADD. Каждый объект или подобъект, выбранный отдельно или с помощью рамки, добавляется в текущий набор объектов. Чтобы удалить объекты или подобъекты из набора, необходимо при выборе нажать клавишу SHIFT.


PICKAUTO Системная переменная

P Системные переменные
PICKAUTO Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет автоматическим созданием рамки выбора объектов в ответ на запрос "Выберите объекты". .

0 | Отключает системную переменную PICKAUTO.
1 | Выполняет построение рамки выбора (в том числе и секущей) в ответ на запрос "Выберите объекты".


PICKBOX Системная переменная

P Системные переменные
PICKBOX Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 3

Устанавливает размер прицела выбора объектов (в пикселах) .

Примечание Если для системной переменной PICKBOX установлено значение 0, просмотр выбранных объектов недоступен.


PICKDRAG Системная переменная

P Системные переменные
PICKDRAG Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет методом создания рамки выбора .

0 | Выполняет построение рамки выбора по двум точкам. При этом нет необходимости удерживать в нажатом состоянии кнопку выбора устройства указания.
1 | Выполняет построение рамки выбора путем перемещения мыши. Точка, где была нажата кнопка, становится одним углом рамки; точка, где она была отпущена — вторым.


PICKFIRST Системная переменная

P Системные переменные
PICKFIRST Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Определяет момент выбора объектов: до вызова команды (предварительный выбор) или после .

0 | Отключает PICKFIRST; объекты выбираются после вызова команды
1 | Включает PICKFIRST; объекты выбираются до вызова команды


PICKSTYLE Системная переменная

P Системные переменные
PICKSTYLE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет выбором групп и ассоциативной штриховки .

0 | Нет выбора групп или ассоциативной штриховки
1 | Выбор группы
2 | Выбор ассоциативной штриховки
3 | Выбор групп и ассоциативной штриховки


PLATFORM Системная переменная

P Системные переменные
PLATFORM Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | разные

Указывает имя используемой платформы .


PLINEGEN Системная переменная

P Системные переменные
PLINEGEN Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет созданием типа линии вокруг вершин двухмерных полилиний . Не действует для полилиний с сегментами переменной ширины.

0 | Создает полилинии, начинающиеся и заканчивающиеся со штриха в каждой вершине
1 | Создает линии заданного типа, не прерывающиеся в вершинах полилинии


PLINETYPE Системная переменная

P Системные переменные
PLINETYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Указывает, используется ли оптимизированные двухмерные полилинии . PLINETYPE управляет созданием новых полилиний с помощью команды ПЛИНИЯ, а также преобразованием существующих полилиний в чертежах старых форматов.

0 | Полилинии в старых чертежах не преобразуются при открытии; команда ПЛИНИЯ создает полилинии в старом формате
1 | Полилинии в старых чертежах не преобразуются при открытии; команда ПЛИНИЯ создает оптимизированные полилинии
2 | Полилинии в чертежах AutoCAD Release 14 или чертежах, созданных в более ранних версиях, преобразуются при открытии; команда ПЛИНИЯ создает оптимизированные полилинии

Дополнительную информацию о форматах см. в описании команды ПРЕОБРАЗОВАТЬ.

PLINETYPE управляет также типом полилиний, создаваемых в командах: КОНТУР (если типом объекта является полилиния), КОЛЬЦО, ПОЛРЕД (при выборе отрезка или дуги), МН-УГОЛ и ЭСКИЗ (если переменная SKPOLY равна 1).


PLINEWID Системная переменная

P Системные переменные
PLINEWID Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Хранит значение ширины полилинии по умолчанию .


PLOTOFFSET Системная переменная

P Системные переменные
PLOTOFFSET Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет способом отсчета смещения чертежа относительно печатаемой области или кромок листа бумаги .

0 | Устанавливает отсчет смещения чертежа относительно печатаемой области.
1 | Устанавливает отсчет смещения чертежа относительно кромок листа бумаги


PLOTROTMODE Системная переменная

P Системные переменные
PLOTROTMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Управляет ориентацией чертежа .

0 | Выполняет поворот печатаемой области так, что метка, обозначающая левый нижний угол чертежа (при просмотре контура), совпадает с нижним левым (0), верхним левым (90), верхним правым (180) или нижним правым (270) углом листа. X и Y смещения начала чертежа отсчитываются от левого нижнего угла бумаги.
1 | Нижний левый угол печатаемой области совмещается с нижним левым углом листа.
2 | Действие аналогично действию при нулевом значении, но смещение начала чертежа по оси X и Y отсчитывается относительно повернутой исходной точки.


PLQUIET Системная переменная

P Системные переменные
PLQUIET Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет выводом дополнительных диалоговых окон и сообщений о незначительных ошибках при пакетной печати и выполнении командных файлов. .

0 | Отображает диалоговые окна печати и сообщения о незначительных ошибках
1 | Регистрирует в журнале незначительные ошибки и не отображает связанные с печатью диалоговые окна


POLARADDANG Системная переменная

P Системные переменные
POLARADDANG Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | ""

Содержит полярные углы, определенные пользователем . Имеется возможность занести в переменную до 10 значений углов. Каждая запись об угле может состоять из не более чем 25 символов. Записи разделяются точками с запятой (;). Системная переменная AUNITS задает формат для отображения углов.

В отличие от переменной POLARANG, значения углов, заданные в переменной POLARADDANG, могут и не быть кратными.

При использовании дробных значений углов переменной AUPREC (точность углов) следует задавать большее значение. В противном случае, значения углов, заданные в переменной POLARADDANG округляются.


POLARANG Системная переменная

P Системные переменные
POLARANG Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | реестр
Начальное значение: | 90

Задает шаг для полярных углов . Допустимые значения — 90, 45, 30, 22.5, 18, 15,10 и 5.


POLARDIST Системная переменная

P Системные переменные
POLARDIST Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | реестр
Начальное значение: | 0,0000

Задает шаг привязки в случае, если для системной переменной SNAPTYPE установлено значение 1 (полярная привязка).


POLARMODE Системная переменная

P Системные переменные
POLARMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет полярным и объектным отслеживанием . Параметр хранится в виде битового кода, использующего сумму следующих значений.

Отсчет полярных углов

0 | Отсчет полярных углов от текущей ПСК (абсолютный)
1 | Отсчет полярных углов от выбранных объектов (относительный)

Объектное отслеживание

0 | Только ортогонально
2 | Использовать в отслеживании объектной привязки параметры полярного отслеживания

Использование дополнительных углов полярного отслеживания

0 | Нет
4 | Да

Получение точек объектного отслеживания

0 | Захватывать автоматически
8 | По нажатию SHIFT

Примечание В 3D виде также отображается вектор отслеживания, параллельный оси Z ПСК, а в подсказке для угла будет выведено +Z и -Z, в зависимости от направления вдоль оси Z.


POLYSIDES Системная переменная

P Системные переменные
POLYSIDES Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 4

Задает число сторон по умолчанию для команды МН-УГОЛ . Допустимый диапазон значений от 3 до 1024.


POPUPS Системная переменная

P Системные переменные
POPUPS Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 1

Отображает состояние настроенного в настоящий момент драйвера дисплея .

0 | Не поддерживает диалоговые окна, строку меню и графические меню
1 | Поддерживает эти функции


PREVIEWEFFECT Системная переменная

P Системные переменные
PREVIEWEFFECT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Указывает визуальный эффект, используемый для предварительного просмотра набора объектов .

0 | Пунктирные линии (отображение по умолчанию для выбранных объектов)
1 | Утолщенные линии
2 | Пунктирные и утолщенные линии


PREVIEWFILTER Системная переменная

P Системные переменные
PREVIEWFILTER Системная переменная
Понятия Процедуры Команды

Тип: | битовый код
Сохранен в: | реестр
Начальное значение: | 7

Исключает указанные типы объектов из области предварительного выбора . Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Не исключает никакие объекты
1 | Исключает объекты на заблокированных слоях
2 | Исключает объекты внешних ссылок
4 | Исключает таблицы
8 | Исключает объекты многострочного текста
16 | Исключает заштрихованные объекты
32 | Исключает объекты в группах


PRODUCT Системная переменная

P Системные переменные
PRODUCT Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | "AutoCAD"

Возвращает название программного продукта .


PROGRAM Системная переменная

P Системные переменные
PROGRAM Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | "acad"

Возвращает имя программы .


PROJECTNAME Системная переменная

P Системные переменные
PROJECTNAME Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | ""

Присваивает имя проекта текущему чертежу . Используется, если файл внешней ссылки, изображения или подложки DWF не будет найдет по исходному указанному пути. Имя проекта указывает на отдельный раздел системного реестра, в который записываются один или несколько путей поиска относящихся к проекту файлов. Имена проектов и пути их поиска задаются на вкладке "Файлы" диалогового окна "Настройка".

Имена проектов упрощают управление внешними ссылками, изображениями и подложкой DWF, если пользователи обмениваются чертежами или используют различные преобразования устройства в одно и то же местоположение на сервере.

Если внешняя ссылка, изображение или файл подложки DWF не найдены по их исходному пути, будет произведен поиск по путям проекта, связанным с именем проекта. Если внешняя ссылка, изображение или файл подложки DWF снова не будут найдены, будет произведен поиск по пути поиска программы AutoCAD.


PROJMODE Системная переменная

P Системные переменные
PROJMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Устанавливает текущий режим проецирования для операций обрезки и удлинения .

0 | Реальный 3D режим (без проецирования)
1 | Проекция на плоскость XY текущей ПСК
2 | Проекция на плоскость текущего вида


PROXYGRAPHICS Системная переменная

P Системные переменные
PROXYGRAPHICS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет сохранением объектов-заместителей в чертеже .

0 | Изображение не сохраняется вместе с чертежом; вместо него отображается ограничивающая рамка
1 | Сохраняет изображение вместе с чертежом


PROXYNOTICE Системная переменная

P Системные переменные
PROXYNOTICE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Отображает сообщение при создании объекта-заместителя . Заместитель создается при открытии чертежа, содержащего сторонние объекты, которые были созданы приложением, отсутствующим в данный момент. Заместитель также образуется при вызове команды, выгружающей родительское приложение пользовательского объекта.

0 | Предупреждение о создании заместителей не отображается
1 | Отображается предупреждение о создании заместителей


PROXYSHOW Системная переменная

P Системные переменные
PROXYSHOW Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет отображением объектов-заместителей на чертеже .

0 | Объекты-заместители не отображаются
1 | Для всех объектов-заместителей отображаются графические изображения
2 | Для всех объектов-заместителей отображаются только ограничивающая рамка


PROXYWEBSEARCH Системная переменная

P Системные переменные
PROXYWEBSEARCH Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Устанавливает в программе режим поиска адаптеров объектов .

Адаптеры объектов позволяют видеть в чертежах сторонние объекты и работать с ними, даже когда породившее их ObjectARX-приложение недоступно. Значение PROXYWEBSEARCH также можно задать на вкладке "Система" диалогового окна "Настройки".

0 | Не проверяет наличие новых адаптеров объектов
1 | Проверяет наличие адаптеров объектов только при установленном подключении к Интернету


PSLTSCALE Системная переменная

P Системные переменные
PSLTSCALE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет масштабированием типов линий в пространстве листа .

0 | Специальное масштабирование типа линий не выполняется. Длина штрихов базируется на единицах чертежа в том пространстве (модели или листа), где был создан объект, Задает масштаб по глобальному коэффициенту LTSCALE.
1 | Масштаб типа линий зависит от масштаба видового экрана. Если для TILEMODE установлено значение 0, длина пунктира базируется на единицах чертежа в пространстве листа, даже если объекты находятся в пространстве модели. На видовых экранах в этом режиме можно как угодно изменять увеличение, сохраняя при этом одинаковые типы линий. Длины штрихов на видовых экранах в этом случае всегда совпадают с длинами штрихов, принадлежащих тому же типу линий и расположенных в пространстве листа. Управлять длиной пунктира можно при помощи команды ЛМАСШТАБ

При изменении значения PSLTSCALE или использовании команды МАСШТАБ (при PSLTSCALE, равной 1) автоматическая регенерация объектов на видовых экранах не происходит. Для обновления масштабов типов линий на каждом видовом экране используйте команду РЕГЕН или ВСЕРЕГЕН.


PSOLHEIGHT Системная переменная

P Системные переменные
PSOLHEIGHT Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 4 (британские единицы); 80 (метрические)

Управляет значением высоты по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО. Значение содержит последнее значение высоты, введенное с помощью команды ПОЛИТЕЛО. Запрещается вводить 0 в качестве значения.


PSOLWIDTH Системная переменная

P Системные переменные
PSOLWIDTH Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,25 (британские единицы); 5 (метрические)

Управляет значением ширины по умолчанию для развернутого твердотельного объекта, созданного командой ПОЛИТЕЛО . Значение содержит последнее значение ширины, введенное с помощью команды ПОЛИТЕЛО. Запрещается вводить 0 в качестве значения.


PSTYLEMODE Системная переменная

P Системные переменные
PSTYLEMODE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Указывает режим стиля печати текущего чертежа - цветозависимый или именованный .

0 | Использует таблицы именованных стилей печати в текущем чертеже
1 | Использует таблицы цветозависимых стилей печати в текущем чертеже


PSTYLEPOLICY Системная переменная

P Системные переменные
PSTYLEPOLICY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет ассоциативностью свойства цвета объекта с его стилем печати. Изменение значения воздействует только на новые чертежи, а также на чертежи, созданные в версиях до AutoCAD 2000.

0 | Ассоциативность между цветом и стилем печати не создается. Для вновь создаваемых объектов назначается стиль печати по умолчанию, заданный в переменной DEFPLSTYLE. Для вновь создаваемых слоев назначается стиль печати по умолчанию, заданный в переменной DEFPLSTYLE.
1 | Стиль печати объекта ассоциируется с его цветом.


PSVPSCALE Системная переменная

P Системные переменные
PSVPSCALE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0

Устанавливает масштабный коэффициент вида для вновь создаваемых видовых экранов . Масштаб определяется как отношение единицы пространства листа к единице вновь создаваемого видового экрана пространства модели. Заданный масштабный коэффициент используется в команде ВЭКРАН. Значение 0 соответствует вписыванию вида. Масштаб не может быть отрицательным.


PUBLISHALLSHEETS Системная переменная

P Системные переменные
PUBLISHALLSHEETS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет заполнением списка диалогового окна публикации при выдаче команды ПУБЛ.

0 | В список публикации автоматически загружается только содержимое текущих документов (пространства листа и/или модели)
1 | Содержимое (пространство листа и/или модели) всех открытых документов AutoCAD автоматически загружается в список публикации.


PUCSBASE Системная переменная

P Системные переменные
PUCSBASE Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | ""

Сохраняет имя ПСК, которая определяет параметры исходной точки и ориентации ортогональной ПСК (только для пространства листа) .


Q Системные переменные
  • QCSTATE
  • QTEXTMODE


QCSTATE Системная переменная

Q Системные переменные
QCSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | разные

Определяет, активен ли калькулятор QuickCalc .

0 | Не активна
1 | Активный


QTEXTMODE Системная переменная

Q Системные переменные
QTEXTMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет отображением текста .

0 | Отключает режим "Контурный текст"; отображает символы
1 | Включает режим "Контурный текст"; отображает рамку вместо текста


R Системные переменные
  • RASTERDPI
  • RASTERPREVIEW
  • RECOVERYMODE
  • REFEDITNAME
  • REGENMODE
  • RE-INIT
  • REMEMBERFOLDERS
  • RENDERPREFSSTATE
  • REPORTERROR
  • ROAMABLEROOTPREFIX
  • RTDISPLAY


RASTERDPI Системная переменная

R Системные переменные
RASTERDPI Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 300

Управляет размером листа и масштабом печати при переключении с устройств вывода размерных файловых форматов на устройства вывода безразмерных файловых форматов и наоборот . Преобразование миллиметров или дюймов в пикселы и наоборот. Принимает целые значения от 100 до 32,767.


RASTERPREVIEW Системная переменная

R Системные переменные
RASTERPREVIEW Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет сохранением вместе с чертежом образцов для просмотра в формате BMP .

0 | Образец для просмотра не создается
1 | Образец для просмотра создается


RECOVERYMODE Системная переменная

Р Системные переменные
RECOVERYMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Управляет записью информации о восстановлении чертежа после системного сбоя .

0 | Информация о восстановлении не записывается, окно "Восстановление чертежа" не открывается автоматически после системного сбоя, а любая информация о восстановлении удаляется из системного реестра
1 | Информация о восстановлении записывается, но окно "Восстановление чертежа" не открывается автоматически после системного сбоя
2 | Информация о восстановлении записывается, окно "Восстановление чертежа" открывается автоматически при начале следующего сеанса работы после системного сбоя


REFEDITNAME Системная переменная

R Системные переменные
REFEDITNAME Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ""

Отображает имя редактируемого вхождения .


REGENMODE Системная переменная

R Системные переменные
REGENMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет автоматической регенерацией чертежа .

0 | Отключает команду РЕГЕНАВТО
1 | Включает команду РЕГЕНАВТО


RE-INIT Системная переменная

R Системные переменные
RE-INIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Выполняет повторную инициализацию дигитайзера, его порта и файла acad.pgp . Параметр хранится в виде битового кода, использующего сумму следующих значений.

1 | Повторная инициализация порта ввода/вывода дигитайзера
4 | Повторная инициализация дигитайзера
16 | Повторная инициализация (перезагрузка) файла PGP

Для задания нескольких переинициализаций следует ввести сумму значений кодов. Например, значение 5 задает повторную инициализацию порта (1) и дигитайзера (4).


REMEMBERFOLDERS Системная переменная

R Системные переменные
REMEMBERFOLDERS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет путем по умолчанию, который отображается в стандартных диалоговых окнах выбора файлов .

0 | Поддерживает совместимость с AutoCAD 2000 и более ранними версиями. При запуске программы двойным щелчком значка путь, указанный в поле "Рабочий каталог" в свойствах ярлыка, по умолчанию используется в стандартных диалоговых окнах выбора файлов.
1 | Использует соответствие стандартам Microsoft. При первом запуске программы после установки путем по умолчанию во всех стандартных диалоговых окнах выбора файлов является папка Мои документы. При открытии или сохранении файла в другую папку она запоминается для последующих операций выбора файлов. Рабочая папка, указанная для ярлыка не используется)


RENDERPREFSSTATE Системная переменная

R Системные переменные
RENDERPREFSSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Сохраняет значение, указывающее открыта палитра параметров тонирования или нет.

0 | Закрыта
1 | Открыта


REPORTERROR Системная переменная

R Системные переменные
REPORTERROR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет возможностью отправки отчета об ошибке в компанию Autodesk при неожиданном закрытии программы .

Сообщения об ошибках помогают компании Autodesk устранить скрытые неполадки в программе.

0 | Сообщение "Отчет об ошибке" не отображается, сведения не пересылаются в Autodesk.
1 | Сообщение "Отчет об ошибке" отображается, сведения могут быть отправлены в Autodesk

Если на компьютере установлена Windows XP, отчет об ошибке можно отправить в Microsoft, если для системной переменной REPORTERROR установлено значение 0 и в Windows включена соответствующая функция.


ROAMABLEROOTPREFIX Системная переменная

R Системные переменные
ROAMABLEROOTPREFIX Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | реестр
Начальное значение: | "путь"

Сохраняет полный путь к корневой папке, в которую были установлены перемещаемые адаптируемые файлы . При работе в сети, поддерживающей перемещаемые профили, файлы, адаптированные в профиле пользователя, становятся доступны ему с любого компьютера.

Эти файлы хранятся в папке, вложенной в папку Application Data; например, "c:\ Documents and Settings\имя_пользователя\ Application Data\имя_продукта\версия\язык".


RTDISPLAY Системная переменная

R Системные переменные
RTDISPLAY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет отображением растровых изображений и объектов OLE при выполнении команды МАСШТАБ или ПАН в режиме реального времени .

0 | Отображает содержимое растровых изображений и объектов OLE.
1 | Отображает только контур

RTDISPLAY сохраняется в текущем профиле.


S Системные переменные
  • SAVEFILE
  • SAVEFILEPATH
  • SAVENAME
  • SAVETIME
  • SCREENBOXES
  • SCREENMODE
  • SCREENSIZE
  • SDI
  • SELECTIONAREA
  • SELECTIONAREAOPACITY
  • SELECTIONPREVIEW
  • SHADEDGE
  • SHADEDIF
  • SHADOWPLANELOCATION
  • SHORTCUTMENU
  • SHOWHIST
  • SHOWLAYERUSAGE
  • SHPNAME
  • SIGWARN
  • SKETCHINC
  • SKPOLY
  • SNAPANG
  • SNAPBASE
  • SNAPISOPAIR
  • SNAPMODE
  • SNAPSTYL
  • SNAPTYPE
  • SNAPUNIT
  • SOLIDCHECK
  • SOLIDHIST
  • SPLFRAME
  • SPLINESEGS
  • SPLINETYPE
  • SSFOUND
  • SSLOCATE
  • SSMAUTOOPEN
  • SSMPOLLTIME
  • SSMSHEETSTATUS
  • SSMSTATE
  • STANDARDSVIOLATION
  • STARTUP
  • STEPSIZE
  • STEPSPERSEC
  • SUNPROPERTIESSTATE
  • SUNSTATUS
  • SURFTAB1
  • SURFTAB2
  • SURFU
  • SURFTYPE
  • SURFV
  • SYSCODEPAGE


SAVEFILE Системная переменная

S Системные переменные
SAVEFILE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | реестр
Начальное значение: | "c:\Documents and Settings\имя_пользователя\Local Settings\TEMP\Drawing1.dwg"

Сохраняет имя текущего файла автоматического сохранения .


SAVEFILEPATH Системная переменная

S Системные переменные
SAVEFILEPATH Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | "c:\Documents and Settings\имя_пользователя\Local Settings\TEMP\"

Указывает путь к папке всех файлов автоматического сохранения для текущего сеанса . Этот путь можно также задать на вкладке "Файлы" диалогового окна "Настройка".


SAVENAME Системная переменная

S Системные переменные
SAVENAME Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ""

Сохраняет имя файла и путь к папке самого последнего сохраненного чертежа .


SAVETIME Системная переменная

S Системные переменные
SAVETIME Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 10

Задает интервал автоматического сохранения (в минутах) .

0 | Отключает функцию автосохранения.
>0 | Автоматически сохраняет чертеж через заданный (ненулевой) интервал

Таймер переменной SAVETIME запускается после внесения первого изменения в чертеж. Его сброс и повторный запуск осуществляется вручную командами БСОХРАНИТЬ, СОХРАНИТЬ и СОХРАНИТЬКАК. Текущий чертеж сохраняется в папке, которая задана в системной переменной SAVEFILEPATH. Имя файла сохраняется в системной переменной SAVEFILE.


SCREENBOXES Системная переменная

S Системные переменные
SCREENBOXES Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Сохраняет количество окон экранного меню области рисования . Если экранное меню отключено при настройке, SCREENBOXES равна нулю. В системах, позволяющих изменять размер графического окна AutoCAD или перенастраивать экранное меню в ходе сеанса редактирования, значение этой переменной может изменяться в течение сеанса.


SCREENMODE Системная переменная

S Системные переменные
SCREENMODE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 3

Указывает состояние экрана . Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Отображается текстовое окно
1 | Отображается область рисования
2 | Двухэкранная конфигурация


SCREENSIZE Системная переменная

S Системные переменные
SCREENSIZE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | 2D-point
Сохранен в: | Не сохранен
Начальное значение: | разные

Сохраняет размер текущего видового экрана в пикселах (по X и Y).


SDI Системная переменная

S Системные переменные
SDI Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет режимом работы программы (одно- или многодокументный интерфейс) .

0 | Включает многодокументный интерфейс.
1 | Отключает многодокументный интерфейс.
2 | (только чтение) Многодокументный интерфейс недоступен, т.к. загружено приложение, не поддерживающее такой интерфейс. Значение 2 не сохраняется.
3 | (только чтение) Многодокументный интерфейс недоступен, т.к. пользователь присвоил для SDI значение 1, и было загружено приложение, не поддерживающее такой интерфейс. (Для переменной SDI было установлено значение 1 до загрузки приложения.) Значение 3 не сохраняется.

Если переменной SDI установлено значение 3, оно сбрасывается на 1 при выгрузке приложения, не поддерживающего работу с несколькими чертежами.

Примечание В следующих версиях программы AutoCAD системная переменная SDI будет удалена. В настоящее время переменная SDI доступна, но не поддерживается.

Некоторые команды и функции недоступны при работе в режиме интерфейса одного документа.

Команда | Как влияет?
ВНССЫЛКИ | Палитра внешних ссылок отключена, пока SDI не будет вновь установлена в значение 0 (ноль).


SELECTIONAREA Системная переменная

S Системные переменные
SELECTIONAREA Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет отображением эффектов для областей выбора . Области выбора создаются с помощью параметров "Рамка", "Секрамка", "РМн-угол" и "СМн-угол" команды ВЫБРАТЬ.

0 | Откл
1 | Вкл


SELECTIONAREAOPACITY Системная переменная

S Системные переменные
SELECTIONAREAOPACITY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 25

Управляет прозрачностью области выбора в процессе выбора рамки и секущей рамки . Допустимый диапазон значений от 0 до 100. Чем меньше значение настройки, тем прозрачнее область. При значении, равном 100 единицам, область становится yепрозрачной. Системная переменная SELECTIONAREA должна быть активизирована.


SELECTIONPREVIEW Системная переменная

S Системные переменные
SELECTIONPREVIEW Системная переменная
Понятия Процедуры Команды

Тип: | битовый код
Сохранен в: | реестр
Начальное значение: | 3

Управляет отображением предварительного просмотра выбора . Объекты выделяются при наведении на них прицела. В этом случае предварительный выбор означает, что объект был бы выбран при щелчке на нем. Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Откл
1 | Включено, если ни одна команда не активна
2 | Включено в ответ на запрос выбора объекта


SHADEDGE Системная переменная

S Системные переменные
SHADEDGE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 3

Управляет раскрашиванием кромок при тонировании .

0 | Грани раскрашиваются, кромки не выделяются
1 | Грани раскрашиваются, кромки рисуются фоновым цветом
2 | Грани не заполняются, кромки рисуются цветом объекта
3 | Грани рисуются цветом объекта, а кромки - цветом фона


SHADEDIF Системная переменная

S Системные переменные
SHADEDIF Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 70

Задает соотношение диффузного отражения к рассеянной освещенности . Коэффициент представляет собой процентное содержание диффузного отраженного света, если SHADEDGE установлено равным 0 или 1.


SHADOWPLANELOCATION Системная переменная

S Системные переменные
SHADOWPLANELOCATION Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет расположением скрытой опущенной нулевой плоскости, используемой для отображения теней. Значение представляет собой положение на текущей оси Z. Опущенная нулевая плоскость является скрытой, однако она отбрасывает и принимает тени. На объекты, расположенные ниже опущенной нулевой плоскости, падает тень от этой плоскости. Опущенная нулевая плоскость используется, если системной переменной VSSHADOWS установлено значение отображения полных теней или теней на земле.


SHORTCUTMENU Системная переменная

S Системные переменные
SHORTCUTMENU Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 11

Управляет доступностью контекстных меню (стандартного, режимов редактирования и команд) в области рисования . Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Отключает все контекстные меню (стандартное, режимов редактирования и команд), обеспечивая совместимость AutoCAD Release 14.
1 | Включает контекстные меню стандартного режима.
2 | Включает контекстные меню режима редактирования.
4 | Включает контекстные меню режима команды, когда команда активна.
8 | Включает контекстные меню режима команды, только если в настоящий момент в командной строке доступны параметры.
16 | Включает отображение контекстного меню, если правая кнопка указывающего устройства удерживается нажатой в течение некоторого времени.


SHOWHIST Системная переменная

S Системные переменные
SHOWHIST Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет свойством "Показать журнал" для тел на чертеже.

0 | Устанавливает свойству "Показать журнал" значение "Нет"(только чтение) для всех тел. Переопределяет отдельные установки свойства "Показать журнал" для тел. Невозможно просмотреть исходные объекты, которые были использованы для создания твердотельного объекта.
1 | Не переопределяет отдельные установки свойства "Показать журнал" для тел.
2 | Отображает журнал для всех тел, переопределяя отдельные установки свойства "Показать журнал" для тел. Можно просмотреть исходные объекты, которые были использованы для создания твердотельного объекта.


SHOWLAYERUSAGE Системная переменная

S Системные переменные
SHOWLAYERUSAGE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Отображает значки в Диспетчере свойств слоев, чтобы показать, используются ли слои . Отключение этой системной переменной повышает производительность Диспетчера свойств слоев.

0 | Откл
1 | Вкл


SHPNAME Системная переменная

S Системные переменные
SHPNAME Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ""

Задает имя формы по умолчанию. Оно должно соответствовать принятому соглашению по именованию символов. . Если формы по умолчанию нет, возвращает пустую строку (""). Чтобы восстановить начальное значение, следует ввести точку (.) , чтобы отменить значение по умолчанию.


SIGWARN Системная переменная

S Системные переменные
SIGWARN Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет отображением предупреждения при открытии файла с присоединенной цифровой подписью . Если переменная включена, открытие файла с действительной подписью вызывает отображение информации о цифровой подписи. Открытие файла при отключенной системной переменной вызывает отображение информации о цифровой подписи только в случае, если подпись недействительна. Данную переменную можно установить через опцию "Отображать информацию о цифровой подписи" на вкладке "Открытие/Сохранение" диалогового окна "Настройка".

0 | Предупреждение не отображается, если подпись в файле действительна
1 | Отображается предупреждение


SKETCHINC Системная переменная

S Системные переменные
SKETCHINC Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,1000

Устанавливает приращение для команды ЭСКИЗ .


SKPOLY Системная переменная

S Системные переменные
SKPOLY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Задает тип объектов (линии или полилинии), генерируемых командой ЭСКИЗ .

0 | Генерирует линии
1 | Генерирует полилинии


SNAPANG Системная переменная

S Системные переменные
SNAPANG Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0

Задает угол поворота сетки и шаговой привязки для текущего видового экрана. Отсчитывается относительно текущей ПСК.

Если переменной SNAPANG задано значение, отличное от 0, линованная сетка не будет отображаться.


SNAPBASE Системная переменная

S Системные переменные
SNAPBASE Системная переменная
Понятия Процедуры Команды

Тип: | 2D-point
Сохранен в: | чертеж
Начальное значение: | 0,0000, 0,0000

Задает начальную точку сетки и шаговой привязки для текущего видового экрана относительно текущей ПСК.


SNAPISOPAIR Системная переменная

S Системные переменные
SNAPISOPAIR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет плоскостью изометрии для текущего видового экрана .

0 | Слева
1 | Сверху
2 | Вправо


SNAPMODE Системная переменная

S Системные переменные
SNAPMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Включает и отключает режим привязки .

0 | Режим привязки отключен
1 | Режим привязки включен для текущего видового экрана


SNAPSTYL Системная переменная

S Системные переменные
SNAPSTYL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Задает стиль шаговой привязки для текущего видового экрана .

0 | Стандартная (прямоугольная привязка)
1 | Изометрическая


SNAPTYPE Системная переменная

S Системные переменные
SNAPTYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Задает тип привязки для текущего видового экрана .

0 | "Сетка", или стандартная привязка.
1 | Полярная привязка. Курсор перемещается по дискретным значениям углов. Используется в сочетании с объектным и полярным отслеживанием.


SNAPUNIT Системная переменная

S Системные переменные
SNAPUNIT Системная переменная
Понятия Процедуры Команды

Тип: | 2D-point
Сохранен в: | чертеж
Начальное значение: | 0,5000, 0,5000

Задает интервал привязки для текущего видового экрана . Если для SNAPSTYL установлено значение 1, значение X системной переменной SNAPUNIT подстраивается автоматически для обеспечения изометрической привязки.

Изменение переменной вступает в силу только после перерисовки экрана.


SOLIDCHECK Системная переменная

S Системные переменные
SOLIDCHECK Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 1

Включает и отключает проверку тела для текущего сеанса .

0 | Откл
1 | Вкл


SOLIDHIST Системная переменная

S Системные переменные
SOLIDHIST Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет установкой значения по умолчанию для свойства Журнала для новых и существующих объектов. Если установлено значение 1, для составных тел сохраняется "журнал" исходных объектов, входящих в состав составного тела.

0 | Устанавливает значение свойства "Журнал" равным "Нет" для всех тел. Журнал не сохраняется.
1 | Устанавливает значение свойства "Журнал" равным "Запись для всех тел". Все тела сохраняют журнал своих исходных объектов.


SPLFRAME Системная переменная

S Системные переменные
SPLFRAME Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет отображением сплайнов и сглаженных сплайнами полилиний .

0 | Не отображает управляющую ломаную для сплайнов и сглаженных сплайнами полилиний. Выдается только поверхность сглаживания (без определяющей сети). Не отображает невидимые кромки 3D граней или многогранных сетей.
1 | Отображает управляющую ломаную для сплайнов и сглаженных сплайнами полилиний.


SPLINESEGS Системная переменная

S Системные переменные
SPLINESEGS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 8

Задает количество сегментов линии, генерируемых для каждой сглаженной сплайном полилинии, созданной с помощью параметра "Сплайн" команды ПОЛРЕД .

Диапазон допустимых значений от -32768 до 32767. Если задать для SPLINESEGS отрицательное значение, будет создано количество сегментов, равное абсолютной величине этой переменной, а затем к этим сегментам будет применено дуговое сглаживание. При таком способе дуги используются в качестве аппроксимирующих сегментов. Это позволяет производить более плавное сглаживание при малом числе заданных сегментов, но за большее время.


SPLINETYPE Системная переменная

S Системные переменные
SPLINETYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 6

Задает тип кривой, создаваемой с помощью параметра "Сплайн" команды ПОЛРЕД .

5 | Квадратичный B-сплайн
6 | Кубический B-сплайн


SSFOUND Системная переменная

S Системные переменные
SSFOUND Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ""

Отображает имя файла и путь, полученные при успешном поиске подшивки .


SSLOCATE Системная переменная

S Системные переменные
SSLOCATE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Пользовательские настройки
Начальное значение: | 1

Управляет местоположением и открытием подшивки, связанной с чертежом, при открытии чертежа..

0 | Не открывает подшивку вместе с чертежом
1 | Открывает подшивку вместе с чертежом

SSMAUTOOPEN и SSLOCATE необходимо установить в значение 1, чтобы подшивка открывалась автоматически в Диспетчере подшивок.


SSMAUTOOPEN Системная переменная

S Системные переменные
SSMAUTOOPEN Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Пользовательские настройки
Начальное значение: | 1

Управляет режимом отображения Диспетчера подшивок при открытии чертежа, связанного с подшивкой..

0 | Не открывает Диспетчер подшивок автоматически
1 | Открывает Диспетчер подшивок автоматически

Для системных переменных SSMAUTOOPEN и SSLOCATEнеобходимо установить значение 1, чтобы подшивка открывалась автоматически в Диспетчере подшивок.


SSMPOLLTIME Системная переменная

S Системные переменные
SSMPOLLTIME Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 60

Управляет временным интервалом автоматического обновления данных о состоянии в подшивке .

Таймер SSMPOLLTIME задает временной интервал (в секундах) автоматического обновления данных о состоянии листов в подшивке. Допустимый диапазон значений от 20 до 600. Для системной переменной SSMSHEETSTATUS необходимо установить значение 2, чтобы таймер начал работать.


SSMSHEETSTATUS Системная переменная

S Системные переменные
SSMSHEETSTATUS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Управляет способом обновления данных о состоянии в подшивке .

Данные о состоянии листов в подшивке включают сведения о блокировке и отсутствии листа (или нахождении в неизвестном месте). Эти данные о состоянии можно обновлять автоматически для всех листов.

Чтобы обновить подшивку вручную, нажмите кнопку "Обновить состояние листа", расположенную на вкладке "Список листов" Диспетчера подшивок.

0 | Не обновлять данные о состоянии в подшивке автоматически
1 | Обновлять данные о состоянии при загрузке или выгрузке подшивки
2 | Обновлять данные о состоянии при загрузке или обновлении подшивки, или регулярно через интервал времени, установленный переменной SSMPOLLTIME


SSMSTATE Системная переменная

S Системные переменные
SSMSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | разные

Определяет активность окна Диспетчера подшивок .

0 | Не активна
1 | Активна


STANDARDSVIOLATION Системная переменная

S Системные переменные
STANDARDSVIOLATION Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Указывает режим оповещения пользователя о нарушениях стандартов в текущем чертеже при создании или изменении нестандартного объекта .

Изменение значения этой системной переменной вступает в силу только если в диалоговом окне "Настройка лотка" установлен флажок "Показывать значки служб". Диалоговое окно "Настройка лотка" вызывается щелчком на кнопке со стрелкой в правом углу лотка в строке состояния и выбором пункта "Настройка лотка" в контекстном меню.

0 | Уведомление отключено
1 | При нарушении стандартов в чертеже отображается предупреждение
2 | При открытии файла, связанного с файлом стандартов, а также при создании и редактировании нестандартных объектов в строке состояния отображается значок


STARTUP Системная переменная

S Системные переменные
STARTUP Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет отображением диалогового окна "Создание нового чертежа" при создании нового чертежа с помощью команды НОВЫЙ или БСОЗДАТЬ . а также выводом диалогового окна при запуске приложения.

Если для системной переменной FILEDIA установлено значение 0, диалоговые окна не отображаются (кроме диалогового окна "Настройка интерфейса пользователя").

0 | Отображает диалоговое окно "Выбор шаблона" или использует файл шаблона чертежа по умолчанию, заданный на вкладке "Файлы" диалогового окна "Настройки".
1 | Отображает диалоговые окна "Начало работы" и "Создание нового чертежа"


STEPSIZE Системная переменная

S Системные переменные
STEPSIZE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 6,0000

Задает размер каждого шага в единицах чертежа при работе в режиме обхода или облета. Можно ввести любое вещественное число от 1E-6 до 1E+6.


STEPSPERSEC Системная переменная

S Системные переменные
STEPSPERSEC Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 2

Задает число шагов, выполняемых в секунду, при работе в режиме обхода или облета. Можно ввести любое вещественное число от 1 до 30.


SUNPROPERTIESSTATE Системная переменная

S Системные переменные
SUNPROPERTIESSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Указывает, открыто окно Свойств солнца или нет..

0 | Закрыто
1 | Открыто


SUNSTATUS Системная переменная

S Системные переменные
SUNSTATUS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет излучением солнечного света на текущем видовом экране.

0 | Откл
1 | Вкл


SURFTAB1 Системная переменная

S Системные переменные
SURFTAB1 Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 6

Задает число интервалов, генерируемых командами П-СОЕД и П-СДВИГ . Задает также плотность сети в направлении M для команд П-ВРАЩ и П-КРОМКА.


SURFTAB2 Системная переменная

S Системные переменные
SURFTAB2 Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 6

Задает плотность сети в направлении N для команд П-ВРАЩ и П-КРОМКА .


SURFU Системная переменная

S Системные переменные
SURFU Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 6

Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении М и плотность изолиний U на объектах поверхности. Допустимые значения от 0 до 200. Сети всегда создаются с плотностью поверхности не меньше 2.


SURFTYPE Системная переменная

S Системные переменные
SURFTYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 6

Управляет типом поверхности сглаживания, которая используется командой ПОЛРЕД (параметр "Сплайн") .

5 | Квадратичная В-сплайновая поверхность
6 | Кубическая В-сплайновая поверхность
8 | Поверхность Безье


SURFV Системная переменная

S Системные переменные
SURFV Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 6

Задает плотность поверхности для параметра "Сглаживание" команды ПОЛРЕД в направлении N и плотность изолиний V на объектах поверхности. . Допустимые значения от 0 до 200. Сети всегда создаются с плотностью поверхности не меньше 2.


SYSCODEPAGE Системная переменная

S Системные переменные
SYSCODEPAGE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ""

Указывает системную кодовую страницу, которая определяется операционной системой . Способы изменения кодовой страницы описаны в документации по операционной системе.


T Системные переменные
  • TABLEINDICATOR
  • TABMODE
  • TARGET
  • TBCUSTOMIZE
  • TDCREATE
  • TDINDWG
  • TDUCREATE
  • TDUPDATE
  • TDUSRTIMER
  • TDUUPDATE
  • TEMPOVERRIDES
  • TEMPPREFIX
  • TEXTEVAL
  • TEXTFILL
  • TEXTQLTY
  • TEXTSIZE
  • TEXTSTYLE
  • THICKNESS
  • TILEMODE
  • TIMEZONE
  • TOOLTIPMERGE
  • TOOLTIPS
  • TPSTATE
  • TRACEWID
  • TRACKPATH
  • TRAYICONS
  • TRAYNOTIFY
  • TRAYTIMEOUT
  • TREEDEPTH
  • TREEMAX
  • TRIMMODE
  • TSPACEFAC
  • TSPACETYPE
  • TSTACKALIGN
  • TSTACKSIZE


TABLEINDICATOR Системная переменная

T Системные переменные
TABLEINDICATOR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Пользовательские настройки
Начальное значение: | 1

Управляет отображением номеров рядов и букв столбцов при открытии текстового редактора, используемого в месте редактирования, для изменения ячейки таблицы .

0 | Откл
1 | Вкл


TABMODE Системная переменная

T Системные переменные
TABMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Управляет использованием режима "Планшет" . Для получения дополнительной информации об использовании и настройке планшета см. описание команды ПЛАНШЕТ.

0 | Откл
1 | Вкл


TARGET Системная переменная

T Системные переменные
TARGET Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | 3D-point
Сохранен в: | чертеж
Начальное значение: | 0,0000, 0,0000, 0,0000

Сохраняет положение точки цели (в координатах ПСК) на текущем видовом экране .


TBCUSTOMIZE Системная переменная

T Системные переменные
TBCUSTOMIZE Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | реестр
Начальное значение: | 1

Управляет возможностью настройки групп инструментальных палитр .

Управляет разрешением или запретом использования команды АДАПТАЦИЯ для настройки группы инструментальных палитр, а также отображением опции "Настройка" в контекстном меню панели инструментов.

0 | Запрещает доступ к настройке
1 | Разрешает доступ к настройке


TDCREATE Системная переменная

T Системные переменные
TDCREATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет дату и время (местное) создания чертежа .


TDINDWG Системная переменная

T Системные переменные
TDINDWG Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет общее время редактирования (т.е. общее количество времени, прошедшего между сохранениями текущего чертежа) . Для этого используется формат:

<количество дней>.<дробная часть дня>

Для вычисления количества секунд значение переменной TDINDWG следует умножить на 86400.


TDUCREATE Системная переменная

T Системные переменные
TDUCREATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет дату и время (всемирное) создания чертежа .


TDUPDATE Системная переменная

T Системные переменные
TDUPDATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет дату и время (местное) последнего сохранения/обновления .


TDUSRTIMER Системная переменная

T Системные переменные
TDUSRTIMER Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет счетчик времени работы пользователя .


TDUUPDATE Системная переменная

T Системные переменные
TDUUPDATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет дату и время (всемирное) последнего сохранения/обновления .


TEMPOVERRIDES Системная переменная

T Системные переменные
TEMPOVERRIDES Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Включает и отключает клавиши временной отмены . Удерживая нажатой клавишу временной отмены, можно временно включить или отключить режимы рисования, установленные в диалоговом окне "Режимы рисования"; например, режим "Орто", объектные привязки или полярный режим.

0 | Откл
1 | Вкл


TEMPPREFIX Системная переменная

T Системные переменные
TEMPPREFIX Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | "c:\Documents and Settings\имя_пользователя\Local Settings\Temp\"

Содержит имя папки (если таковое имеется), используемой для хранения временных файлов, с добавленными при необходимости разделителями пути .


TEXTEVAL Системная переменная

T Системные переменные
TEXTEVAL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Управляет методом обработки текстовых строк, вводимых с помощью команды ТЕКСТ (с использованием AutoLISP) или -ТЕКСТ .

0 | Ответы на запросы ввода текстовых строк и значений атрибутов воспринимаются буквально.
1 | Весь текст, начинающийся с открывающей скобки [(] или знака восклицания [!] считается выражением языка AutoLISP, как при вводе нетекстовой информации.

Команда ТЕКСТ воспринимает весь ввод буквально независимо от значения TEXTEVAL (кроме случаев, когда она выполняется в сценарии или внутри выражения AutoLISP). Команда –ТЕКСТ учитывает состояние TEXTEVAL.


TEXTFILL Системная переменная

T Системные переменные
TEXTFILL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет заливкой шрифтов TrueType во время печати или тонирования .

0 | Отображает текст в виде контуров
1 | Отображает текст в виде закрашенных изображений


TEXTQLTY Системная переменная

T Системные переменные
TEXTQLTY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 50

Качество начертания шрифтов TrueType при выводе текстов на печать и тонировании. Значение 0 полностью отключает улучшение качества шрифтов; значение 100 соответствует максимальному улучшению качества. Меньшие значения уменьшают разрешение, но увеличивают скорость вывода текста. Большие значения увеличивают разрешение, уменьшая скорость вывода текста.

Качество начертания шрифтов TrueType при выводе текстов на печать. Переменная может принимать целые значения в интервале от 0 до 100. Меньшие значения уменьшают разрешение, но увеличивают скорость вывода текста. Большие значения увеличивают разрешение, уменьшая скорость вывода текста.


TEXTSIZE Системная переменная

T Системные переменные
TEXTSIZE Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,2000 (британские единицы); 2,500 (метрические)

Устанавливает высоту по умолчанию для новых текстовых объектов, созданных при помощи текущего стиля . Системная переменная TEXTSIZE не действует, если высота в текущем текстовом стиле фиксирована.


TEXTSTYLE Системная переменная

T Системные переменные
TEXTSTYLE Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | СТАНДАРТ

Задает имя текущего текстового стиля .


THICKNESS Системная переменная

T Системные переменные
THICKNESS Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Задает текущую трехмерную высоту .


TILEMODE Системная переменная

T Системные переменные
TILEMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Устанавливает вкладку "Модель" или последнюю вкладку листа текущей .

0 | Делает вкладку листа (пространство листа), с которым в последний раз производилась работа, активной
1 | Делает вкладку "Модель" активной


TIMEZONE Системная переменная

T Системные переменные
TIMEZONE Системная переменная
Понятия Процедуры Команды

Тип: | значение из стандартного списка
Сохранен в: | чертеж
Начальное значение: | -8000

Устанавливает часовой пояс для вс в чертеже. Значения в таблице выражены в часах и минутах от всемирного времени. Заданное географическое положение также устанавливает часовой пояс. Если часовой пояс задан неправильно, можно исправить его в диалоговом окне Географическое положение или задать системную переменную TIMEZONE.

-12000 | Международная западная линия даты
-11000 | о-в Мидуэй, Самоа
-10000 | Гаваи
-9000 | Аляска
-8000 | Тихоокеанское поясное время (США и Канада), Тихуана
-7000 | Аризона
-7000 | Чихуахуа, Ла-Пас, Мацатлан
-7000 | Горный часовой пояс (США и Канада)
-6000 | Центральная Америка
-6000 | Центральноамериканское время (США и Канада)
-6000 | Гвадалахара, Мехико, Монтеррей
-6000 | Саскачеван
-5000 | Богота, Лима, Киото
-5000 | Восточное поясное время (США и Канада)
-5000 | Индиана (восток)
-4000 | Атлантическое время (Канада)
-4000 | Каракас, Ла-Пас
-4000 | Сантьяго
-3000 | Ньюфаундленд
-3000 | Бразилия
-3000 | Буэнос-Айрес, Джорджтаун
-3000 | Гренландия
-2000 | Центрально-атлантическое время
-1000 | Азорские острова
-1000 | Острова Зеленого Мыса
0000 | Касабланка, Монровия
-0000 | Дублин, Эдинбург, Лиссабон
+1000 | Амстердам, Берлин, Берн, Рим, Стокгольм
+1000 | Белград, Братислава, Будапешт, Любляна
+1000 | Брюссель, Мадрид, Копенгаген, Париж
+1000 | Сараево, Скопье, Варшава, Загреб
+1000 | Западная Центральная Африка
+2000 | Афины, Бейрут, Стамбул, Минск
+2000 | Бухарест
+2000 | Каир
+2000 | Хараре, Претория
+2000 | Хельсинки, Киев, София, Таллинн, Вильнюс
+2000 | Иерусалим
+3000 | Багдад
+3000 | Кувейт, Эр-Рияд
+3000 | Москва, Санкт-Петербург, Волгоград
+3000 | Найроби
+3300 | Тегеран
+4000 | Абу Даби, Мускат
+4000 | Баку, Тбилиси, Ереван
+4300 | Кабул
+5000 | Екатеринбург
+5000 | Исламабад, Карачи, Ташкент
+5300 | Сенай, Калькутта, Мумбаи, Нью-Дели
+5450 | Катманду
+6000 | Алматы, Новосибирск
+6000 | Астана, Дака
+6000 | Шри Джаяварденепура
+6300 | Рангун
+7000 | Бангкок, Ханой, Джакарта
+7000 | Красноярск
+8000 | Пекин, Чонвинг, Гонконг, Урумчи
+8000 | Иркутск, Улан-Батор
+8000 | Куала-Лампур, Сингапур
+8000 | Перт
+8000 | Тайпей
+9000 | Осака, Саппоро, Токио
+9000 | Сеул
+9000 | Якутск
+9300 | Аделаида
+9300 | Дарвин
+10000 | Брисбен
+10000 | Канберра, Мельбурн, Сидней
+10000 | о-в Гуам, Порт-Морсби
+10000 | Хобарт
+10000 | Владивосток
+11000 | Магадан, Соломоновы Острова, Новая Каледония
+12000 | Окленд, Веллингтон
+12000 | Фиджи, Камчатка, Маршалловы острова
+13000 | Нукуалофа


TOOLTIPMERGE Системная переменная

T Системные переменные
TOOLTIPMERGE Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | Пользовательские настройки
Начальное значение: | 0

Объединяет подсказки на чертеже в одну подсказку . Внешний вид объединенной подсказки определяется настройками в диалоговом окне "Внешний вид подсказок".

0 | Откл
1 | Вкл


TOOLTIPS Системная переменная

T Системные переменные
TOOLTIPS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет отображением подсказок .

0 | Отключает отображение подсказок
1 | Включает отображение подсказок


TPSTATE Системная переменная

T Системные переменные
TPSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | разные

Определяет активность окна инструментальных палитр .

0 | Не активна
1 | Активна


TRACEWID Системная переменная

T Системные переменные
TRACEWID Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0500

Задает ширину полосы по умолчанию .


TRACKPATH Системная переменная

T Системные переменные
TRACKPATH Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет отображением линий выравнивания для полярного отслеживания и отслеживания объектной привязки .

0 | Отображает линии полярного отслеживания и отслеживания объектной привязки во весь экран
1 | Отображает линию полярного отслеживания во весь экран; отображает линию отслеживания объектной привязки только от точки выравнивания до курсора
2 | Отображает линию отслеживания объектной привязки во весь экран; не отображает линию полярного отслеживания
3 | Не отображает линию полярного отслеживания; отображает линию отслеживания объектной привязки только от точки выравнивания до курсора


TRAYICONS Системная переменная

T Системные переменные
TRAYICONS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет отображением панели в строке состояния .

0 | Не отображает панель
1 | Отображает панель


TRAYNOTIFY Системная переменная

T Системные переменные
TRAYNOTIFY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет отображением уведомлений служб в панели строки состояния .

0 | Не отображает уведомления
1 | Отображает уведомления


TRAYTIMEOUT Системная переменная

T Системные переменные
TRAYTIMEOUT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет временем (в секундах), в течение которого отображаются уведомления служб . Допустимые значения от 0 до 10.


TREEDEPTH Системная переменная

T Системные переменные
TREEDEPTH Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 3020

Указывает максимальное количество ветвлений древовидного пространственного индекса .

0 | Запрещает использование пространственного индекса. Понижение производительности компенсируется возможностью работать с большими чертежами. Порядок обработки объектов в этом случае неизменен и обуславливается лишь тем положением, которое они занимают в базе данных чертежа.
>0 | Включает пространственный индекс. Допустимыми являются целые числа длиной до пяти цифр. Первые три цифры кода обозначают глубину узлов в пространстве модели, а оставшиеся две цифры — в пространстве листа.
<0 | Объекты пространства модели рассматриваются как двумерные (координата Z игнорируется), как это происходит с объектами пространства листа. Эта установка предназначена для 2D чертежей, она обеспечивает эффективное использование памяти без потери производительности

Переменная TREEDEPTH не может вызываться прозрачно.


TREEMAX Системная переменная

T Системные переменные
TREEMAX Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 10000000

Снижает использование памяти при регенерации чертежа путем ограничения числа узлов в пространственном индексе (дерево октантов).

Этим достигается возможность загрузки чертежей, созданных в системах с большим объемом памяти, при большем значении TREEDEPTH, чем может обработать имеющийся компьютер (т.е. чертежи с деревом октантов, требующим больше памяти, чем имеется). Такие чертежи имеют достаточно большое дерево октантов и иногда могут требовать больше памяти, чем имеется на компьютере. Кроме того, переменная TREEMAX защищает загруженный чертеж от экспериментирования с недопустимо завышенными значениями переменной TREEDEPTH.

Исходное значение по умолчанию для TREEMAX равно 10000000 (десять миллионов); этого вполне достаточно для отключения контроля над системной переменной TREEDEPTH. Значение, которое следует установить для переменной TREEMAX, зависит от объема доступной системе памяти ОЗУ. На каждый мегабайт ОЗУ приходится примерно 15000 узлов дерева октантов.

Если необходимо отвести под дерево октантов 2 мегабайта ОЗУ, следует установить TREEMAX равным 30000 (2 x 15000). Если программе не хватает памяти при распределении узлов дерева октантов, перезапустите программу, установите для системной переменной TREEMAX меньшее значение и загрузите чертеж еще раз.

Программа может случайно достичь предела, установленного при помощи переменной TREEMAX. В этом случае нужно следовать инструкциям, появляющимся в строке подсказок. Возможность увеличения значения переменной TREEMAX зависит от доступного объема памяти на компьютере.


TRIMMODE Системная переменная

T Системные переменные
TRIMMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет обрезкой выбранных кромок для фасок и сопряжений .

0 | Оставляет выбранные кромки нетронутыми
1 | Обрезает выбранные кромки до конечных точек фасок/сопряжений


TSPACEFAC Системная переменная

T Системные переменные
TSPACEFAC Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | Не сохранен
Начальное значение: | 1,0

Управляет отношением межстрочного интервала к высоте многострочного текста . Допустимые значения — от 0,25 до 4,0.


TSPACETYPE Системная переменная

T Системные переменные
TSPACETYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Стиль межстрочного интервала в многострочном тексте. Стиль "Минимум" настраивает межстрочный интервал на основе самых высоких символов строки. Стиль "Точно" использует заданное значение интервала, несмотря на различие высот отдельных символов.

1 | Минимум
2 | Точно


TSTACKALIGN Системная переменная

T Системные переменные
TSTACKALIGN Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет выравниванием дробного текста по вертикали .

0 | Выравнивание по нижнему краю
1 | Выравнивание по центру
2 | Выравнивание по верхнему краю


TSTACKSIZE Системная переменная

T Системные переменные
TSTACKSIZE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 70

Управляет процентом дробной высоты многострочного текста относительно текущей высоты выбранного текста . Допустимые значения от 25 до 125.


U Системные переменные
  • UCSAXISANG
  • UCSBASE
  • UCSDETECT
  • UCSFOLLOW
  • UCSICON
  • UCSNAME
  • UCSORG
  • UCSORTHO
  • UCSVIEW
  • UCSVP
  • UCSXDIR
  • UCSYDIR
  • UNDOCTL
  • UNDOMARKS
  • UNITMODE
  • UPDATETHUMBNAIL
  • USERI1-5
  • USERR1-5
  • USERS1-5


UCSAXISANG Системная переменная

U Системные переменные
UCSAXISANG Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 90

Сохраняет значение угла по умолчанию при повороте ПСК вокруг одной из ее осей с помощью параметров "X", "Y" или "Z" команды "ПСК" . Угол выражается в градусах. Допустимые значения: 5, 10, 15, 18, 22.5, 30, 45, 90, 180.


UCSBASE Системная переменная

U Системные переменные
UCSBASE Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | МСК

Сохраняет имя ПСК, которая определяет исходную точку и ориентацию ортогональной ПСК . Это может быть любая именованная система координат.


UCSDETECT Системная переменная

U Системные переменные
UCSDETECT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет активность сбора данных динамической ПСК.

0 | Не активна
1 | Активна


UCSFOLLOW Системная переменная

U Системные переменные
UCSFOLLOW Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Устанавливает вид в плане при переходе от одной ПСК к другой . Значение системной переменной UCSFOLLOW сохраняется отдельно для каждого видового экрана. Если системная переменная UCSFOLLOW включена для определенного видового экрана, вид в плане устанавливается на этом видовом экране при каждой смене системы координат.

Для дальнейшего изменения вида можно воспользоваться командами ДВИД, ПЛАН, ВИД и ТЗРЕНИЯ. Но как только система координат опять изменится, снова будет установлен вид в ее плане.

0 | ПСК не влияет на вид
1 | Смена ПСК вызывает установку вида в плане на текущем видовом экране

К переменной UCSFOLLOW можно обращаться как из пространства листа, так и из пространства модели (и она может иметь в них разные значения). Однако в пространстве листа ее установка игнорируется, и AutoCAD ведет себя так, как если бы она равнялась 0. Хотя в пространстве листа можно создавать любые ПСК, в нем всегда поддерживается вид в плане Мировой системы координат.


UCSICON Системная переменная

U Системные переменные
UCSICON Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 3

Отображает знак ПСК для текущего видового экрана или лист . Имя этой системной переменной совпадает с названием команды. Для доступа к этой системной переменной используется команда УСТПЕРЕМ.

Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Значок не отображается
1 | Включено; значок отображается в левом нижнем углу текущего видового экрана или листа
2 | Исходная точка; если значок включен, он отображается в исходной точке ПСК (если это возможно)

Значение этой системной переменной зависит от видового экрана и листа.


UCSNAME Системная переменная

U Системные переменные
UCSNAME Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | строковый
Сохранен в: | чертеж

Сохраняет имя текущей системы координат для текущего видового экрана в текущем пространстве . Если текущая ПСК не имеет имени, возвращается пустая строка.


UCSORG Системная переменная

U Системные переменные
UCSORG Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | 3D-point
Сохранен в: | чертеж

Сохраняет исходную точку текущей системы координат для текущего видового экрана в текущем пространстве . Значение всегда возвращается в мировых координатах.


UCSORTHO Системная переменная

U Системные переменные
UCSORTHO Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Определяет режим восстановления ортогональной ПСК в момент установки соответствующего ортогонального вида .

0 | Указывает, что настройка ПСК не изменяется при восстановлении ортогонального вида
1 | Указывает, что при установке ортогонального вида восстанавливается соответствующая ортогональная ПСК


UCSVIEW Системная переменная

U Системные переменные
UCSVIEW Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Определяет режим сохранения текущей ПСК вместе с именованным видом .

0 | Не сохраняет текущую ПСК вместе с именованным видом
1 | Сохраняет текущую ПСК при создании именованного вида


UCSVP Системная переменная

U Системные переменные
UCSVP Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Определяет, фиксируется ли ПСК в видовых экранах или изменяется в соответствии с ПСК текущего видового экрана . Значение этой системной переменной зависит от видового экрана.

0 | Разблокировано; ПСК совпадает с системой координат текущего видового экрана
1 | Заблокировано; ПСК сохраняется в видовом экране и не зависит от системы координат текущего видового экрана


UCSXDIR Системная переменная

U Системные переменные
UCSXDIR Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | 3D-point
Сохранен в: | чертеж
Начальное значение: | 1,0000, 0,0000, 0,0000

Сохраняет направление X текущей ПСК на текущем видовом экране в текущем пространстве .

Значение этой системной переменной зависит от видового экрана.


UCSYDIR Системная переменная

U Системные переменные
UCSYDIR Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | 3D-point
Сохранен в: | чертеж
Начальное значение: | 0,0000, 1,0000, 0,0000

Сохраняет направление Y текущей ПСК на текущем видовом экране в текущем пространстве .

Значение этой системной переменной зависит от видового экрана.


UNDOCTL Системная переменная

U Системные переменные
UNDOCTL Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 21

Указывает состояние параметров "Авто", "Управление" и "Группа" команды ОТМЕНИТЬ . Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Команда ОТМЕНИТЬ отключена
1 | Команда ОТМЕНИТЬ включена
2 | Можно отменить только одну команду
4 | Включен параметр "Авто"
8 | Группа в настоящий момент активна
16 | Операции масштабирования и панорамирования группируются в одно действие


UNDOMARKS Системная переменная

U Системные переменные
UNDOMARKS Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Сохраняет количество меток, заданных в команде ОТМЕНИТЬ (параметр "Метка") для управления отменой . Опции "Метка" и "Обратно" отключены, если выполняется группа команд.


UNITMODE Системная переменная

U Системные переменные
UNITMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет отображением формата единиц . По умолчанию формат отображения измеренных значений немного отличается от формата, используемого при их вводе. (При вводе измеренных значений нельзя использовать пробелы).

0 | Дробные числа, измерения, выполненные в футах или дюймах, а также топографические углы отображаются в формате отчета с использованием пробелов в качестве разделителей.
1 | Дробные числа, измерения, выполненные в футах или дюймах, а также топографические углы отображаются в формате ввода без использования пробелов, в некоторых случаях вместо пробелов используются тире.


UPDATETHUMBNAIL Системная переменная

U Системные переменные
UPDATETHUMBNAIL Системная переменная
Понятия Процедуры Команды

Тип: | битовый код
Сохранен в: | чертеж
Начальное значение: | 15

Управляет обновлением образцов для просмотра в Диспетчере подшивок . Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Не обновляет образцы для просмотра листов, видов листов и видов пространства модели
1 | Обновляет образцы для просмотра видов пространства модели
2 | Обновляет образы для просмотра видов листов
4 | Обновляет образы для просмотра листов
8 | Обновляет образцы для просмотра при создании, изменении или восстановлении листов или видов
16 | Обновляет образцы для просмотра при сохранении чертежа


USERI1-5 Системная переменная

U Системные переменные
USERI1-5 Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Обеспечивает хранение и получение целых значений . Существует пять системных переменных: USERI1, USERI2, USERI3, USERI4 и USERI5.


USERR1-5 Системная переменная

U Системные переменные
USERR1-5 Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0,0000

Обеспечивает хранение и получение вещественных чисел . Существует пять системных переменных: USERR1, USERR2, USERR3, USERR4 и USERR5.


USERS1-5 Системная переменная

U Системные переменные
USERS1-5 Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | ""

Обеспечивает хранение и получение данных текстовой строки . Существует пять системных переменных: USERS1, USERS2, USERS3, USERS4 и USERS5.


V Системные переменные
  • VIEWCTR
  • VIEWDIR
  • VIEWMODE
  • VIEWSIZE
  • VIEWTWIST
  • VISRETAIN
  • VPMAXIMIZEDSTATE
  • VSBACKGROUNDS
  • VSEDGECOLOR
  • VSEDGEJITTER
  • VSEDGEOVERHANG
  • VSEDGES
  • VSEDGESMOOTH
  • VSFACECOLORMODE
  • VSFACEHIGHLIGHT
  • VSFACEOPACITY
  • VSFACESTYLE
  • VSHALOGAP
  • VSHIDEPRECISION
  • VSINTERSECTIONCOLOR
  • VSINTERSECTIONEDGES
  • VSINTERSECTIONLTYPE
  • VSISOONTOP
  • VSLIGHTINGQUALITY
  • VSMATERIALMODE
  • VSMAX
  • VSMIN
  • VSMONOCOLOR
  • VSOBSCUREDCOLOR
  • VSOBSCUREDEDGES
  • VSOBSCUREDLTYPE
  • VSSHADOWS
  • VSSILHEDGES
  • VSSILHWIDTH
  • VSSTATE
  • VTDURATION
  • VTENABLE
  • VTFPS


VIEWCTR Системная переменная

V Системные переменные
VIEWCTR Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | 3D-point
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет центр вида на текущем видовом экране . (в координатах ПСК).


VIEWDIR Системная переменная

V Системные переменные
VIEWDIR Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | 3D-vector
Сохранен в: | чертеж
Начальное значение: | Нет

Сохраняет направление взгляда в текущем видовом экране, выраженное в координатах ПСК. Аналогично по сути 3D вектору смещения камеры относительно точки цели.


VIEWMODE Системная переменная

V Системные переменные
VIEWMODE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Сохраняет режим "Вид" для текущего видового экрана . Параметр хранится в виде битового кода, использующего сумму следующих значений.

0 | Отключено.
1 | Вид в перспективе включен.
2 | Включена передняя секущая
4 | Включена задняя секущая.
8 | Включен режим установки вида в плане при смене ПСК.
16 | Передняя секущая плоскость не совмещена с точкой наблюдения. Если этот бит установлен, положение передней секущей плоскости определяется переменной FRONTZ. Если бит сброшен, FRONTZ игнорируется, и передняя плоскость считается проходящей через точку наблюдения (векторы за камерой не видны). Бит игнорируется, если передняя секущая плоскость отключена (т.е. сброшен бит со значением 2).


VIEWSIZE Системная переменная

V Системные переменные
VIEWSIZE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет высоту вида на текущем видовом экране, выраженную в единицах чертежа .


VIEWTWIST Системная переменная

V Системные переменные
VIEWTWIST Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | 0

Сохраняет угол поворота вида на текущем видовом экране .


VISRETAIN Системная переменная

V Системные переменные
VISRETAIN Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет свойствами зависимых от внешних ссылок слоев. Управляет видимостью, цветом, типом линий, толщиной линий и стилями печати (если для PSTYLEPOLICY установлено значение 0).

0 | Приоритет имеет таблица слоев, сохраненная в чертеже внешней ссылки. Изменения зависимых от внешней ссылки слоев, сделанные в текущем чертеже, действуют только в пределах сеанса и не сохраняются. При следующем открытии текущего чертежа таблица слоев загружается из чертежа внешней ссылки. При этом затрагиваются следующие установки для слоев: вкл/откл, замороженный/размороженный, цвет, тип линии, вес линии и стиль печати (если PSTYLEPOLICY равна 0).
1 | Приоритет имеют изменения зависимых от внешней ссылки слоев, выполненные в текущем чертеже. Установки слоя сохраняются в таблице слоев текущего чертежа и используются в следующих сеансах.


VPMAXIMIZEDSTATE Системная переменная

V Системные переменные
VPMAXIMIZEDSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Сохраняет значение, которое указывает, что видовой экран развернут . Видовой экран сворачивается при выполнении команды ПЕЧАТЬ.

0 | Не развернут
1 | Развернут


VSBACKGROUNDS Системная переменная

V Системные переменные
VSBACKGROUNDS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет отображением фонов в стиле отображения, применяемом к текущему видовому экрану.

0 | Откл
1 | Вкл


VSEDGECOLOR Системная переменная

V Системные переменные
VSEDGECOLOR Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | 7

Устанавливает цвет граней в стиле отображения текущего видового экрана. Начальное значение равно 7 (ACI черный).


VSEDGEJITTER Системная переменная

V Системные переменные
VSEDGEJITTER Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | -2

Управляет степенью проявления линий сквозь карандашную зарисовку. Если установке предшествует знак минус, эффект мерцания отключается.

1 | Низкий
2 | Средний
3 | Высокий

Примечание Стили печати не доступны для объектов, к которым был применен атрибут мерцания граней.


VSEDGEOVERHANG Системная переменная

V Системные переменные
VSEDGEOVERHANG Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | -6

Отрезки продлеваются за их пересечения для создания эффекта рисования от руки . Диапазон значений от 1 до 100 пикселов. Если значению предшествует знак минус, эффект продления отрезков отключается.


VSEDGES Системная переменная

V Системные переменные
VSEDGES Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет типом граней, отображаемых в видовом экране.

0 | Грани не отображаются
1 | Изолинии отображаются
2 | Ребра граней отображаются


VSEDGESMOOTH Системная переменная

V Системные переменные
VSEDGESMOOTH Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Задает угол, под которым отображаются загнутые грани. Диапазон значений от 0 до 180.


VSFACECOLORMODE Системная переменная

V Системные переменные
VSFACECOLORMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет вычислением цвета граней.

0 | Нормальный: атрибут цвета грани не применяется
1 | Монохромный: отображает все грани цветом, заданным системной переменной VSMONOCOLOR.
2 | Тонированный: Использует для оттенения всех граней цвет, заданный системной переменной VSMONOCOLOR, изменяя значения оттенка и насыщенности цвета.
3 | Разбавить: смягчает цвет, уменьшая компонент насыщенности на 30 процентов


VSFACEHIGHLIGHT Системная переменная

V Системные переменные
VSFACEHIGHLIGHT Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | -30

Управляет отображением бликующей подсветки на гранях, не заполненных материалом, в текущем видовом экране . Диапазон значений от -100 до 100. Чем больше число, тем больше подсветка. Объекты с прикрепленными материалами игнорируют установку переменной VSFACEHIGHLIGHT, если включена переменная VSMATERIALMODE.


VSFACEOPACITY Системная переменная

V Системные переменные
VSFACEOPACITY Системная переменная
Понятия Процедуры Команды

Тип: | вещественный
Сохранен в: | чертеж
Начальное значение: | -60

Управляет прозрачностью граней в текущем видовом экране. Диапазон значений от -100 до 100. Если значение равно 100, грань полностью непрозрачная. Если значение равно 0, грань полностью прозрачная. При отрицательных значениях уровень прозрачности устанавливается, но отключается влияние этого значения на изображение на чертеже.


VSFACESTYLE Системная переменная

V Системные переменные
VSFACESTYLE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет отображением граней в текущем видовом экране.

0 | Стиль не применяется
1 | "Реалистичное": максимально возможное приближение отображения к тому, как грань выглядит на самом деле
2 | "Гуч": используется гамма холодных и теплых цветов вместо темных и светлых для улучшения отображения граней, которые могли бы быть затенены и плохо видны в реалистичном представлении


VSHALOGAP Системная переменная

V Системные переменные
VSHALOGAP Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Устанавливает коэффициент недовода в стиле отображения, применяемом к текущему видовому экрану . Диапазон значений от 0 до 100.


VSHIDEPRECISION Системная переменная

V Системные переменные
VSHIDEPRECISION Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Управляет точностью отображения скрытых и раскрашенных объектов в стиле отображения, применяемом к текущему видовому экрану.


VSINTERSECTIONCOLOR Системная переменная

V Системные переменные
VSINTERSECTIONCOLOR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 7

Указывает цвет полилиний пересечения в стиле отображения, применяемом к текущему видовому экрану. Исходным значением является 7, специальное значение, при котором цвет (белый или черный) меняется на обратный на основе цвета фона.

Значение 0 задает значение цвета ПОБЛОКУ, значение 256 – ПОСЛОЮ, а значение 257 – ПООБЪЕКТУ. Значения от 1 до 255 задают цвета в соответствии с индексом цветов AutoCAD. Доступны также цвета полноцветного режима и цветового альбома.

Примечание Переменная INTERSECTIONCOLOR управляет цветом полилиний пересечения, если для визуального стиля установлено значение 2D Каркас.


VSINTERSECTIONEDGES Системная переменная

V Системные переменные
VSINTERSECTIONEDGES Системная переменная
Понятия Процедуры Команды

Тип: | переключатель
Сохранен в: | чертеж
Начальное значение: | 0

Управляет отображением ребер пересечения в стиле отображения, применяемом к текущему видовому экрану.

Примечание Переменная INTERSECTIONDISPLAY управляет цветом полилиний пересечения, если для визуального стиля установлено значение 2D Каркас.

0 | Откл
1 | Вкл


VSINTERSECTIONLTYPE Системная переменная

V Системные переменные
VSINTERSECTIONLTYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Устанавливает тип линии для линий пересечения в визуальном стиле, применяемом в текущем видовом экране. Диапазон значений от 1 до 11.

0 | Откл
1 | Заливка
2 | Штриховая
3 | Пунктирная
4 | Штриховая (кор. штрих)
5 | Штриховая (ср. штрих)
6 | Штриховая (дл. штрих)
7 | Двойная (кор. штрих)
8 | Двойная (ср. штрих)
9 | Двойная (дл. штрих)
10 | Штриховая (увел. штрих)
11 | Редкопунктирная


VSISOONTOP Системная переменная

V Системные переменные
VSISOONTOP Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Отображает изолинии сверху раскрашенных объектов в стиле отображения, применяемом к текущему видовому экрану.

0 | Откл
1 | Вкл


VSLIGHTINGQUALITY Системная переменная

V Системные переменные
VSLIGHTINGQUALITY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Устанавливает качество освещения в текущем видовом экране.

0 | Отображаются грани
1 | Отображается сглаженным


VSMATERIALMODE Системная переменная

V Системные переменные
VSMATERIALMODE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет отображением материалов в текущем видовом экране.

0 | Материалы не отображаются
1 | Материалы отображаются, текстуры не отображаются
2 | Отображаются материалы и текстуры


VSMAX Системная переменная

V Системные переменные
VSMAX Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | 3D-point
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет правый верхний угол виртуального экрана текущего видового экрана . (в координатах ПСК).


VSMIN Системная переменная

V Системные переменные
VSMIN Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | 3D-point
Сохранен в: | чертеж
Начальное значение: | разные

Сохраняет левый нижний угол виртуального экрана текущего видового экрана . (в координатах ПСК).


VSMONOCOLOR Системная переменная

V Системные переменные
VSMONOCOLOR Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | 255,255,255

Устанавливает цвет монохромного и тонированного отображения граней в стиле отображения, применяемом в текущем видовом экране. Начальным значением является белый.


VSOBSCUREDCOLOR Системная переменная

V Системные переменные
VSOBSCUREDCOLOR Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | чертеж
Начальное значение: | ПООБЪЕКТУ

Задает цвет линий заднего плана в стиле отображения, применяемом в текущем видовом экране. Начальным значением является ПООБЪЕКТУ.


VSOBSCUREDEDGES Системная переменная

V Системные переменные
VSOBSCUREDEDGES Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет отображением граней заднего плана (скрытых).

0 | Откл
1 | Вкл


VSOBSCUREDLTYPE Системная переменная

V Системные переменные
VSOBSCUREDLTYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Задает тип линии для линий заднего плана в стиле отображения, применяемом в текущем видовом экране. Диапазон значений от 1 до 11.

0 | Откл
1 | Заливка
2 | Штриховая
3 | Пунктирная
4 | Штриховая (кор. штрих)
5 | Штриховая (ср. штрих)
6 | Штриховая (дл. штрих)
7 | Двойная (кор. штрих)
8 | Двойная (ср. штрих)
9 | Двойная (дл. штрих)
10 | Штриховая (увел. штрих)
11 | Редкопунктирная


VSSHADOWS Системная переменная

V Системные переменные
VSSHADOWS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет отображением теней в стиле отображения.

0 | Тени не отображаются
1 | Отображаются только тени на земле
2 | Отображаются все тени

Примечание Для полного отображения теней требуется аппаратное ускорение. При отключенном параметре "Ускорение для геометрии" полное отображение теней невозможно. (Для доступа к эти установкам следует ввести графнастр в ответ на запрос команды. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" нажмите "Ручная настройка".)


VSSILHEDGES Системная переменная

V Системные переменные
VSSILHEDGES Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет отображением контуров силуэта твердотельных объектов в визуальном стиле, применяемом в текущем видовом экране .

0 | Откл
1 | Вкл


VSSILHWIDTH Системная переменная

V Системные переменные
VSSILHWIDTH Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 5

Управляет шириной контуров силуэта в текущем видовом экране. Диапазон значений от 1 до 25.


VSSTATE Системная переменная

V Системные переменные
VSSTATE Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 0

Сохраняет значение, которое указывает, открыто окно визуальных стилей или нет .


VTDURATION Системная переменная

V Системные переменные
VTDURATION Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 750

Задает длительность плавного перехода видов в миллисекундах . Допустимый диапазон значений от 0 до 5000.


VTENABLE Системная переменная

V Системные переменные
VTENABLE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 3

Управляет использованием плавной смены вида. Плавную смену вида можно включить или отключить для панорамирования, масштабирования, изменений угла вида или для сценариев. Допустимый диапазон значений от 0 до 7.

Параметр | Для панорамирования/масштабирования | Для поворота | Для сценариев
0 | Откл | Откл | Откл
1 | Вкл | Откл | Откл
2 | Откл | Вкл | Откл
3 | Вкл | Вкл | Откл
4 | Откл | Откл | Вкл
5 | Вкл | Откл | Вкл
6 | Откл | Вкл | Вкл
7 | Вкл | Вкл | Вкл


VTFPS Системная переменная

V Системные переменные
VTFPS Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 7

Задает минимальную скорость плавного перехода видов в кадрах в секунду . Если отображение плавных переходов не поддерживает эту скорость, используется мгновенный переход. Диапазон допустимых значений от 1 до 30.


W Системные переменные
  • WHIPARC
  • WHIPTHREAD
  • WINDOWAREACOLOR
  • WMFBKGND
  • WMFFOREGND
  • WORLDUCS
  • WORLDVIEW
  • WRITESTAT
  • WSCURRENT


WHIPARC Системная переменная

W Системные переменные
WHIPARC Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет сглаживанием кругов и дуг на экране .

0 | Окружности и дуги не сглаживаются и отображаются в виде нескольких векторов.
1 | Окружности и дуги сглаживаются и отображаются в виде правильных кругов и дуг


WHIPTHREAD Системная переменная

W Системные переменные
WHIPTHREAD Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 1

Управляет использованием дополнительного процессора для повышения скорости операций (например ПОКАЗАТЬ), выполняющих перерисовку или регенерацию чертежа . На однопроцессорных компьютерах WHIPTHREAD не оказывает никакого влияния.

0 | Без многопоточной обработки. Ограничивает выполнение регенерации и перерисовки одним процессором. Это параметр совместим с AutoCAD 2000 и более ранними версиями.
1 | Многопоточная обработка только при регенерации. На многопроцессорных компьютерах обработка регенерации распределяется между двумя процессорами.
2 | Многопоточная обработка только при перерисовке. На многопроцессорных компьютерах обработка перерисовки распределяется между двумя процессорами.
3 | Многопоточная обработка при регенерации и перерисовке. На многопроцессорных компьютерах обработка регенерации и перерисовки распределяется между двумя процессорами.

При многопоточной обработке данных для перерисовки (значения 2 и 3) сохранение порядка вывода объектов на экран, заданного командой ПОРЯДОК, не гарантируется. Но при выводе объектов на печать соблюдается правильный порядок.


WINDOWAREACOLOR Системная переменная

W Системные переменные
WINDOWAREACOLOR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 5 (синий)

Управляет цветом прозрачной области выбора в процессе выбора рамки . Допустимый диапазон значений от 1 до 255. SELECTIONAREA должна быть активизирована.


WMFBKGND Системная переменная

W Системные переменные
WMFBKGND Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | Откл

Управляет отображением фона при вставке объектов в формат метафайлов Windows (WMF) . Объекты можно вставить одним из следующих способов.

  • Вывод в метафайл Windows командой ЭКСПОРТМТФ
  • Копирование в буфер обмена и последующая вставка как метафайла Windows
  • Перетаскивание как метафайла Windows
Откл | Прозрачный цвет фона. Цвет переднего плана зависит от настройки системной переменной WMFFOREGND.
Вкл | Цвет фона совпадает с текущим цветом фона в чертеже (как в пространстве модели, так и на листе). Цвет линий не меняется.


WMFFOREGND Системная переменная

W Системные переменные
WMFFOREGND Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | Откл

Управляет назначением цвета переднего плана при вставке объектов в формат метафайла Windows (WMF) . Объекты можно вставить одним из следующих способов.

  • Вывод в метафайл Windows командой ЭКСПОРТМТФ
  • Копирование в буфер обмена и последующая вставка как метафайла Windows
  • Перетаскивание как метафайла Windows

WMFFOREGND работает, только если переменная WMFBKGND отключена.

Откл | Замена цветов переднего плана и фона осуществляется, если необходимо убедиться в том, что цвет переднего плана темнее цвета фона
Вкл | Замена цветов переднего плана и фона осуществляется, если необходимо убедиться в том, что цвет переднего плана светлее цвета фона


WORLDUCS Системная переменная

W Системные переменные
WORLDUCS Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 1

Указывает, что ПСК совпадает с мировой системой координат .

0 | ПСК не совпадает с МСК
1 | ПСК совпадает с МСК


WORLDVIEW Системная переменная

W Системные переменные
WORLDVIEW Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет интерпретацией координат, вводимых в командах ДВИД и ТЗРЕНИЯ, относительно МСК (по умолчанию) или текущей ПСК .

0 | ПСК не изменяется
1 | На время действия команды ПСК изменяется на МСК; ввод команды интерпретируется относительно текущей ПСК


WRITESTAT Системная переменная

W Системные переменные
WRITESTAT Системная переменная
Понятия Процедуры Команды

(Только чтение)
Тип: | целый
Сохранен в: | Не сохранен
Начальное значение: | 1

Указывает, является ли файл чертежа доступным только для чтения или перезаписи . Позволяет разработчикам приложений определять статус доступа к файлу чертежа с помощью функций AutoLISP.

0 | Запись в чертеж запрещена
1 | Запись в чертеж разрешена


WSCURRENT Системная переменная

W Системные переменные
WSCURRENT Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | Не сохранен
Начальное значение: | Имя рабочего пространства по умолчанию

Возвращает имя текущего рабочего пространства в интерфейс командной строки и устанавливает это пространство текущим .


X Системные переменные
  • XCLIPFRAME
  • XEDIT
  • XFADECTL
  • XLOADCTL
  • XLOADPATH
  • XREFCTL
  • XREFNOTIFY
  • XREFTYPE


XCLIPFRAME Системная переменная

X Системные переменные
XCLIPFRAME Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 0

Управляет видимостью контуров подрезки внешних ссылок .

0 | Невидимые
1 | Видимые


XEDIT Системная переменная

X Системные переменные
XEDIT Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | чертеж
Начальное значение: | 1

Управляет возможностью редактирования текущего чертежа на месте при использовании его в качестве внешней ссылки .

0 | Редактирование вхождений запрещено
1 | Редактирование вхождений разрешено


XFADECTL Системная переменная

X Системные переменные
XFADECTL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 50

Управляет процентом интенсивности затенения для редактируемых ссылок . Допустимые значения находятся в интервале от 0 до 90.


XLOADCTL Системная переменная

X Системные переменные
XLOADCTL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Включает и отключает режим подгрузки внешних ссылок, а также управляет открытием чертежа внешней ссылки или его копии .

0 | Отключает режим подгрузки; открывается весь чертеж.
1 | Включает режим подгрузки. Открывается файл ссылки.
2 | Включает режим подгрузки. Открываются и блокируются копии чертежей внешних ссылок; чертежи внешних ссылок не блокируются

Если для XLOADCTL установлено значение 2, копия файла чертежа внешней ссылки записывается в папку, заданную системной переменной XLOADPATH, или папку для временных файлов (заданную в диалоговом окне "Настройка"). Внешние ссылки загружаются быстрее при работе в сети: повышение производительности особенно ощутимо при открытии чертежей с большим числом ссылок.


XLOADPATH Системная переменная

X Системные переменные
XLOADPATH Системная переменная
Понятия Процедуры Команды

Тип: | строковый
Сохранен в: | реестр
Начальное значение: | "путь"

Создает путь для хранения временных копий файлов подгруженных внешних ссылок . Для получения дополнительной информации см. описание системной переменной XLOADCTL.


XREFCTL Системная переменная

X Системные переменные
XREFCTL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет созданием файлов журналов внешних ссылок (XLG) .

0 | Файлы журналов не создаются
1 | Файлы журналов создаются


XREFNOTIFY Системная переменная

X Системные переменные
XREFNOTIFY Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 2

Управляет уведомлением для обновленных или отсутствующих внешних ссылок .

0 | Отключает уведомление для внешней ссылки
1 | Включает уведомление для внешней ссылки. О том, что в текущем чертеже имеются внешние ссылки, свидетельствует значок в правом нижнем углу окна приложения (на лотке в строке состояния). Предупреждение о потерянных внешних ссылках выводится в виде значка внешней ссылки с желтым восклицательным знаком (!).
2 | Включает уведомление для внешней ссылки и всплывающие уведомления. Отображение значка внешних ссылок, как и для значения 1. При изменении файла внешней ссылки из лотка всплывает уведомление. Периодичность проверки наличия обновлений во внешних ссылках управляется системной переменной XNOTIFYTIME.


XREFTYPE Системная переменная

X Системные переменные
XREFTYPE Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Управляет типом ссылки по умолчанию при вставке или наложении внешней ссылки .

0 | Параметр "Вставленная" используется по умолчанию
1 | Параметр "Наложенная" используется по умолчанию


Z Системные переменные
  • ZOOMFACTOR
  • ZOOMWHEEL


ZOOMFACTOR Системная переменная

Z Системные переменные
ZOOMFACTOR Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 60

Управляет степенью увеличения при прокрутке колесика мыши . Принимает целые значения от 3 до 100. Чем больше значение, тем выше степень увеличения.


ZOOMWHEEL Системная переменная

Z Системные переменные
ZOOMWHEEL Системная переменная
Понятия Процедуры Команды

Тип: | целый
Сохранен в: | реестр
Начальное значение: | 0

Переключает направление операций прозрачного масштабирования при прокрутке колесика мыши.

0 | При движении колесика вперед масштаб увеличивается, при движении колесика назад - уменьшается.
1 | При движении колесика вперед масштаб уменьшается, при движении колесика назад - увеличивается.


Утилиты

В данном разделе рассматриваются утилиты AutoCAD®. Эти утилиты можно запускать независимо от AutoCAD.


СЛАЙДОТЕКА - утилита создания библиотек слайдов
  • СЛАЙДОТЕКА - утилита создания библиотек слайдов
  • Утилита пакетного нормоконтроля
  • Утилита цифровой подписи


СЛАЙДОТЕКА - утилита создания библиотек слайдов Команда

СЛАЙДОТЕКА - утилита создания библиотек слайдов
СЛАЙДОТЕКА - утилита создания библиотек слайдов
СЛАЙДОТЕКА - утилита создания библиотек слайдов Команда
Понятия Процедуры Команды

Используется для компиляции файлов слайдов, перечисленных в файле ASCII, в библиотеку

С помощью утилиты СЛАЙДОТЕКА, находящейся в папке основной программы, можно конструировать файлы библиотеки слайдов (SLB) из отдельных файлов слайдов (SLD). Синтаксис командной строки операционной системы для вызова утилиты выглядит так:

слайдотека [ <список_слайдов ]

, где

библиотека как аргумент задает имя файла библиотеки (с расширением .slb), в который добавляются файлы слайдов (с расширением .sld), а аргумент список_слайдов указывает на текстовый файл списка файлов слайдов. Если нужно задать в нем расширение файла, им должно быть sld.

СЛАЙДОТЕКА считывает список имен файлов слайдов. Это производится путем перенаправления списка файлов на стандартный ввод (каждому имени слайда соответствует одна строка другого файла, который можно создать в любом текстовом редакторе или пользовательской утилите).

Указанные ниже команды операционной системы создадут файл списка_слайдов, который можно использовать с утилитой СЛАЙДОТЕКА Все файлы слайдов, предназначенные для создания библиотеки, должны быть помещены в одну папку. В ответ на приглашение DOS (версии 5.0 или более поздней) нужно ввести:

dir *.sld /b > mylist

При этом будет создан файл mylist, который можно передать в утилиту СЛАЙДОТЕКА. Файл mylist можно также создать с помощью текстового редактора, внеся в него список имен файлов слайдов (и путей, если потребуется), например, lobby, d:\slides\office и \aec\slides\stairs. В файле библиотеки сохраняется имя слайда, но не информация о его местонахождении. Поскольку в библиотеку включается только имя файла, в ней могут храниться слайды с одинаковыми именами из разных папок. При этом доступ может осуществляться только к одному слайду.

Для создания библиотеки слайдов mlib из mylist требуется ввести строку:

slidelib mlib < mylist

В результате получится файл mlib.slb, содержащий имена и описания слайдов, перечисленных в mylist.

Предупреждение Не следует удалять оригиналы слайдов. Программа СЛАЙДОТЕКА не предназначена для обновления библиотек слайдов после их создания. При необходимости добавления или удаления слайда, нужно обновить файл список_слайдов и создать библиотеку заново с помощью утилиты СЛАЙДОТЕКА. Чтобы сделать это, требуется наличие всех оригиналов слайдов.


Утилита пакетного нормоконтроля Команда

СЛАЙДОТЕКА - утилита создания библиотек слайдов
СЛАЙДОТЕКА - утилита создания библиотек слайдов
Утилита пакетного нормоконтроля Команда
Понятия Процедуры Команды

Проверка набора чертежей на соблюдение стандартов оформления

Меню "Пуск" (Windows): "Программы" » подменю Autodesk » подменю AutoCAD » "Утилита пакетного нормоконтроля"

Открывается диалоговое окно "Окно утилиты пакетного нормоконтроля".

Темы:

  • Окно утилиты пакетного нормоконтроля


Окно утилиты пакетного нормоконтроля

СЛАЙДОТЕКА - утилита создания библиотек слайдов
СЛАЙДОТЕКА - утилита создания библиотек слайдов
Окно утилиты пакетного нормоконтроля
Понятия Процедуры Команды

Проверка набора чертежей на соблюдение стандартов оформления с созданием XML-отчета, в котором подробно описываются все нарушения. Для использования утилиты необходимо создать файл нормоконтроля, в котором определяются проверяемые чертежи и используемые для этого файлы стандартов.

Утилита пакетного нормоконтроля содержит следующие вкладки:

  • Чертежи
  • Стандарты
  • Надстройки
  • Примечания
  • Ход процесса

Панель утилиты пакетного нормоконтроля содержит ряд дополнительных опций.

Вкладка "Чертежи" (утилита пакетного нормоконтроля)

Позволяет создать список чертежей для проверки на соблюдение стандартов.

Чертежи для проверки

Список чертежей для проверки на соблюдение стандартов оформления. Для добавления чертежа в список нужно воспользоваться кнопкой "Добавить чертеж". Для удаления чертежа из списка — кнопкой "Исключить чертеж". Чертежи, которые утилита пакетного нормоконтроля не может обнаружить, помечены восклицательным знаком. Чертежи проверяются согласно последовательности, заданной в списке. Для изменения последовательности чертежей служат кнопки "Вверх" и "Вниз".

Добавить файл стандартов

Вызов стандартного диалогового окна выбора файлов, где можно выбрать чертеж для проверки.

Исключить чертеж

Исключение чертежа из списка "Чертежи для проверки".

Вверх

Перемещение выделенного чертежа на одну позицию выше в списке чертежей для проверки.

Вниз

Перемещение файла стандартов на позицию ниже в списке, отображаемом в "Стандартах для проверки всех чертежей".

Описание

Краткая информация о чертеже, выделенном в списке "Чертежи для проверки".

Проверять внешние ссылки в выбранных чертежах

Проверка внешних ссылок, вставленных в чертежи из списка "чертежи для проверки". Если выбрана эта опция, то после запуска пакетного нормоконтроля внешние ссылки добавляются в список обрабатываемых файлов.

Вкладка "Стандарты" (утилита пакетного нормоконтроля)

Задание файлов стандартов, используемых для проверки именованных объектов при пакетном нормоконтроле.

Использовать для проверки каждого чертежа свои файлы стандартов

Задание проверки чертежа с использованием файлов стандартов, связанных с данным чертежом. Если эта опция задана, остальные опции вкладки становятся недоступными.

Использовать для проверки всех чертежей следующие файлы стандартов

Использование для нормоконтроля файлов стандартов, занесенных в список "Стандарты для проверки всех чертежей".

Стандарты для проверки всех чертежей

Показывает все файлы стандартов, используемые для проверки чертежей. Для подключения к чертежу дополнительного файла стандартов следует нажать кнопку "Добавить файл стандартов". Для отключения файла стандартов следует нажать кнопку "Отключить файл стандартов". При возникновении конфликтов между файлами стандартов (например, если в двух стандартах задан слой с одним и тем же именем, но разными свойствами) приоритетом обладает файл стандартов, который расположен в списке ближе к началу. Для перемещения файла стандартов вверх или вниз по списку следует выбрать этот файл в списке и нажать кнопку "Вверх" или кнопку "Вниз".

Добавить файл стандартов

Добавление файла в список "Стандарты для проверки всех чертежей".

Отключить файл стандартов

Исключение файла стандартов из списка "Стандарты для проверки всех чертежей".

Вверх

Перемещение файла стандартов на позицию выше в списке, отображаемом в "Стандартах для проверки всех чертежей".

Вниз

Перемещение файла стандартов на позицию ниже в списке, отображаемом в "Стандартах для проверки всех чертежей".

Описание

Краткая информация о выбранном из списка файле стандартов.

Вкладка "Надстройки" (утилита пакетного нормоконтроля)

Здесь выводится список надстроек для контроля стандартов, которые установлены в данной системе. В настоящий момент для каждого типа именованных объектов (размерных и текстовых стилей, слоев и типов линий) устанавливаются надстройки модуля нормоконтроля. Предполагается, что в дальнейшем будут устанавливаться надстройки приложений сторонних разработчиков.

Надстройки для контроля стандартов

Список надстроек для контроля стандартов, которые установлены в данной системе. Необходимо отметить в списке по крайней мере одну надстройку, которая будет использоваться для проверки чертежа. Выбранные надстройки используются при проверке на соответствие стандартам для всех чертежей.

Описание

Краткая информация о надстройке, выбранной из списка.

Вкладка "Замечания" (утилита пакетного нормоконтроля)

Позволяет добавлять замечания в XML-отчет.

Замечания для включения в отчет

Позволяет ввести дополнительные замечания в отчет.

Вкладка "Ход выполнения" (утилита пакетного нормоконтроля)

Краткая информация о статусе текущей пакетной проверки.

Панель инструментов "Утилита пакетного нормоконтроля"

Новый | Создание нового файла нормоконтроля с расширениемchx. В файлы нормоконтроля записывается, какие чертежи и файлы стандартов должны использоваться при пакетном нормоконтроле.
Открыть | Вызов стандартного диалогового окна выбора файлов, где выбирается файл нормоконтроля.
Сохранить | Сохранение текущего файла нормоконтроля.
Сохранить как | Вызов стандартного диалогового окна сохранения файлов, где указываются имя и папка для сохранения файла нормоконтроля.
Начать проверку | Запуск пакетной проверки с использованием текущего загруженного файла нормоконтроля. Опция доступна только после добавления чертежей, подключения файла стандартов и выбора по крайней мере одной надстройки для проверки чертежа на соответствие стандартам.
Остановить проверку | Останов пакетной проверки файлов. Опция доступна только во время выполнения пакетной проверки.
Просмотр отчета | Вывод на экран HTML-отчета, подводящего итог результатов пакетного нормоконтроля. Кнопка доступна, когда готов отчет пакетной проверки файлов. Содержимое отчета записывается также в файл нормоконтроля.
Экспорт отчета | Экспорт HTML-отчета для передачи его другим пользователям. Кнопка доступна, когда пакетная проверка файлов завершена и отчет готов к экспорту. Кнопка позволяет оптимизировать существующие XML-отчеты, созданные в предыдущих версиях модуля поддержки стандартов, для повышения качества их печати.


Утилита цифровой подписи Команда

СЛАЙДОТЕКА - утилита создания библиотек слайдов
СЛАЙДОТЕКА - утилита создания библиотек слайдов
Утилита цифровой подписи Команда
Понятия Процедуры Команды

Используется для добавления цифровой подписи к файлам

Меню "Пуск" (Windows): "Программы" » подменю Autodesk » подменю AutoCAD » подменю "Добавление цифровых подписей"

Ввод команды: (DOS) AcSignApply.exe

Откроется диалоговое окно "Добавление цифровых подписей".

Темы:

  • Диалоговое окно "Добавление цифровых подписей"
  • Диалоговое окно "Поиск в папках"


Диалоговое окно "Добавление цифровых подписей"

СЛАЙДОТЕКА - утилита создания библиотек слайдов
СЛАЙДОТЕКА - утилита создания библиотек слайдов
Диалоговое окно "Добавление цифровых подписей"
Понятия Процедуры Команды

Здесь выбираются файлы для добавления цифровых подписей.

Список файлов для добавления подписи

Показывает список имен файлов для добавления цифровой подписи, название папки, в которой хранится каждый файл, а также текущий статус файла.

Добавление файлов

Открывает диалоговое окно "Выбор файла", в котором выбираются файлы для добавления цифровой подписи.

Поиск в папках

Открывает диалоговое окно "Поиск в папках", в котором можно произвести поиск файлов в заданной папке.

Удалить

Удаляет выбранные файлы из списка файлов для добавления подписи.

Очистить

Удаляет все файлы из списка файлов для добавления подписи.

Число файлов для добавления цифровой подписи

Число файлов, которое утилита цифровой подписи попытается подписать.

Выберите сертификат

Список сертификатов, которые можно использовать для подписания файлов. В список включена информация об организации или частном лице, получившем цифровую подпись, организации, выдавшей подпись, и о сроке действия подписи.

Сведения о цифровой подписи

Предоставляет список служб определения времени, которые можно использовать для добавления отметки времени к цифровой подписи; содержит поля для отображения состояния связи с сервером времени и для комментариев (для информации, относящейся к цифровой подписи или к файлам, которые нужно подписать).

Источник для отметки времени

Список серверов времени, которые можно использовать для добавления отметки времени к цифровой подписи, а также информация о состоянии связи с сервером времени.

Состояние связи с сервером времени

Отображает состояние связи с сервером времени ("Связь с сервером времени успешно установлена" или "Невозможно установить связь с сервером времени").

Комментарий

Место для комментариев к цифровой подписи или подписываемым файлам.

Добавить подпись

Добавление цифровых подписей к каждому файлу в списке диалогового окна.


Диалоговое окно "Поиск в папках"

СЛАЙДОТЕКА - утилита создания библиотек слайдов
СЛАЙДОТЕКА - утилита создания библиотек слайдов
Диалоговое окно "Поиск в папках"
Понятия Процедуры Команды

Поиск папок с файлами для добавления подписи.

Начать поиск в папке

Поле для имени папки, в которой требуется начать поиск файлов для добавления подписи.

Включая вложенные папки

Поиск во вложенных папках заданной в поле папки.

Обзор

Открытие диалогового окна "Обзор папок", где выбирается папка, в которой будет производиться поиск.

Искать файлы с именами

Поиск файлов заданного типа.

Допустимы следующие типы файлов: DWG, DWS и DWT-файлы, а также EXE и ZIP-файлы (порожденные функцией формирования комплектов).


Комментарии пользователя

Данная форма предназначена для ввода замечаний и предложений, которые будут отправлены в группу технической документации компании Autodesk.

Заголовок и расположение раздела (не изменять):
Имя и фамилия (не обязательно):
         E-mail (не обязательно):
Текст комментария:

Замечание: Форма не может служить средством получения советов или технической поддержки. Информация из нее будет использована для улучшения документации по продукту. Благодарим Вас!


Р Системные переменные
Ваш комментарий об этой странице